EDKB12WS Reference

EDKB12WS Reference | This is the first topic | Next topic
EDKB12WS Reference | This is the first topic | Next topic

Namespaces

 | Name | Description
Supported by the .NET Compact Framework. | EDKB12WS |
Supported by the .NET Compact Framework. | EDKB12WS.My |
Supported by the .NET Compact Framework. | EDKB12WS.My.Resources |
Supported by the .NET Compact Framework. | EDKB12WS.edokaDB |
Supported by the .NET Compact Framework. | EDKB12WS.edokadb |

Top


EDKB12WS Namespace

EDKB12WS Namespace

EDKB12WS Namespace | Previous topic | Next topic
EDKB12WS Namespace | Previous topic | Next topic

Assembly: EDKB12WS (in EDKB12WS.exe)

Classes

 | Name | Description
Supported by the .NET Compact Framework. | Action |
Supported by the .NET Compact Framework. | ActionException |
Supported by the .NET Compact Framework. | AvaloqDokumentWert |
Supported by the .NET Compact Framework. | AvaloqDokumentWerte |
Supported by the .NET Compact Framework. | Parameters |
Supported by the .NET Compact Framework. | ProjectInstaller |
Supported by the .NET Compact Framework. | Service1 |
Supported by the .NET Compact Framework. | clsDivFnkt |
Internal (Friend) class Supported by the .NET Compact Framework. | Globals |
Internal (Friend) class Supported by the .NET Compact Framework. | ModMain |

Top

Structures

 | Name | Description
Supported by the .NET Compact Framework. | Parameter | Struct für einzelne Parameter

Top

Enumerations

 | Name | Description
Supported by the .NET Compact Framework. | ActionType |

Top

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0


Action Class

Action Class

Action Class | Previous topic | Next topic
Action Class | Previous topic | Next topic

Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Class Action

C#

public class Action

C++

public ref class Action

JScript

public class Action

Inheritance Hierarchy

System.Object

EDKB12WS.Action

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

Action Members


Action Members

Action Members

Action Members | Previous topic | Next topic
Action Members | Previous topic | Next topic

The following tables list the members exposed by the Action type.

Public Properties

 | Name | Description
Supported by the .NET Compact Framework. | Action |
Supported by the .NET Compact Framework. | ActionType |
Supported by the .NET Compact Framework. | CreatorTgNr |
Supported by the .NET Compact Framework. | Parameters |
Supported by the .NET Compact Framework. | SourceApplication |
Supported by the .NET Compact Framework. | valtionOK |

Top

Public Methods

 | Name | Description
Supported by the .NET Compact Framework. | Destroy | Zerstört die statische Instanz
Public method | Equals | (Overloaded) (inherited from Object).
Public method | GetHashCode | (inherited from Object).
Supported by the .NET Compact Framework. | GetParameterByName | Returns a parameter identified by his name
Public method | GetType | (Overloaded) (inherited from Object).
Supported by the .NET Compact Framework. | Load | Lädt externes Xml file für automatisierte Aktionen
 | ReferenceEquals | (inherited from Object).
Public method | ToString | (inherited from Object).

Top

Protected Methods

 | Name | Description
Protected method | Finalize | (inherited from Object).
Protected method | MemberwiseClone | (Overloaded) (inherited from Object).

Top

Private, internal (Friend) and internal protected (Protected Friend) Methods

 | Name | Description
Supported by the .NET Compact Framework. | IsValid | Überprüft ob das Xml file dem angegebenen Schema entspricht
Supported by the .NET Compact Framework. | ValidationCallback |

Top

Fields

 | Name | Description
Supported by the .NET Compact Framework. | _actionSingleton |
Supported by the .NET Compact Framework. | _actionType |
Supported by the .NET Compact Framework. | _creatorTgNr |
Supported by the .NET Compact Framework. | _parameters |
Supported by the .NET Compact Framework. | _sourceApplication |
Supported by the .NET Compact Framework. | _validationSuccess |

Top

See Also

Reference

Action Class


Action Properties

Action Properties

Action Properties | Previous topic | Next topic
Action Properties | Previous topic | Next topic

Public Properties

 | Name | Description
Supported by the .NET Compact Framework. | Action |
Supported by the .NET Compact Framework. | ActionType |
Supported by the .NET Compact Framework. | CreatorTgNr |
Supported by the .NET Compact Framework. | Parameters |
Supported by the .NET Compact Framework. | SourceApplication |
Supported by the .NET Compact Framework. | valtionOK |

Top

See Also

Reference

Action Class


Action.Action Property

Action.Action Property

Action.Action Property | Previous topic | Next topic
Action.Action Property | Previous topic | Next topic

Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public ReadOnly Shared Property Action() As Action

C#

public static Action Action {get;}

C++

public:
static property Action^ Action {
Action^ get( );
}

JScript

public static function get Action() : Action;

Source code

Visual Basic

Copy Code Copy Code

Public Shared ReadOnly Property Action() As Action
Get
If IsNothing(_actionSingleton) Then
_actionSingleton = New Action()
End If

Return _actionSingleton
End Get
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

Action Class
Action Action Members


Action.ActionType Property

Action.ActionType Property

Action.ActionType Property | Previous topic | Next topic
Action.ActionType Property | Previous topic | Next topic

Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public ReadOnly Property ActionType() As ActionType

C#

public ActionType ActionType {get;}

C++

public:
property ActionType ActionType {
ActionType get( );
}

JScript

public function get ActionType() : ActionType;

Source code

Visual Basic

Copy Code Copy Code

Public ReadOnly Property ActionType() As ActionType
Get
Return _actionType
End Get
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

Action Class
Action Action Members


Action.CreatorTgNr Property

Action.CreatorTgNr Property

Action.CreatorTgNr Property | Previous topic | Next topic
Action.CreatorTgNr Property | Previous topic | Next topic

Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public ReadOnly Property CreatorTgNr() As String

C#

public string CreatorTgNr {get;}

C++

public:
property String^ CreatorTgNr {
String^ get( );
}

JScript

public function get CreatorTgNr() : String;

Source code

Visual Basic

Copy Code Copy Code

Public ReadOnly Property CreatorTgNr() As String
Get
Return _creatorTgNr
End Get
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

Action Class
Action Action Members


Action.Parameters Property

Action.Parameters Property

Action.Parameters Property | Previous topic | Next topic
Action.Parameters Property | Previous topic | Next topic

Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public ReadOnly Property Parameters() As Parameter()

C#

public Parameter[] Parameters {get;}

C++

public:
property array< Parameter >^ Parameters {
array< Parameter >^ get( );
}

JScript

public function get Parameters() : Parameter[];

Source code

Visual Basic

Copy Code Copy Code

Public ReadOnly Property Parameters() As Parameter()
Get
Return _parameters
End Get
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

Action Class
Action Action Members


Action.SourceApplication Property

Action.SourceApplication Property

Action.SourceApplication Property | Previous topic | Next topic
Action.SourceApplication Property | Previous topic | Next topic

Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public ReadOnly Property SourceApplication() As String

C#

public string SourceApplication {get;}

C++

public:
property String^ SourceApplication {
String^ get( );
}

JScript

public function get SourceApplication() : String;

Source code

Visual Basic

Copy Code Copy Code

Public ReadOnly Property SourceApplication() As String
Get
Return _sourceApplication
End Get
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

Action Class
Action Action Members


Action.valtionOK Property

Action.valtionOK Property

Action.valtionOK Property | Previous topic | Next topic
Action.valtionOK Property | Previous topic | Next topic

Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public ReadOnly Property valtionOK() As Boolean

C#

public bool valtionOK {get;}

C++

public:
property bool valtionOK {
bool get( );
}

JScript

public function get valtionOK() : boolean;

Source code

Visual Basic

Copy Code Copy Code

Public ReadOnly Property valtionOK() As Boolean
Get
Return _validationSuccess
End Get
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

Action Class
Action Action Members


Action Methods

Action Methods

Action Methods | Previous topic | Next topic
Action Methods | Previous topic | Next topic

Public Methods

 | Name | Description
Supported by the .NET Compact Framework. | Destroy | Zerstört die statische Instanz
Public method | Equals | (Overloaded) (inherited from Object).
Public method | GetHashCode | (inherited from Object).
Supported by the .NET Compact Framework. | GetParameterByName | Returns a parameter identified by his name
Public method | GetType | (Overloaded) (inherited from Object).
Supported by the .NET Compact Framework. | Load | Lädt externes Xml file für automatisierte Aktionen
 | ReferenceEquals | (inherited from Object).
Public method | ToString | (inherited from Object).

Top

Protected Methods

 | Name | Description
Protected method | Finalize | (inherited from Object).
Protected method | MemberwiseClone | (Overloaded) (inherited from Object).

Top

Private, internal (Friend) and internal protected (Protected Friend) Methods

 | Name | Description
Supported by the .NET Compact Framework. | IsValid | Überprüft ob das Xml file dem angegebenen Schema entspricht
Supported by the .NET Compact Framework. | ValidationCallback |

Top

See Also

Reference

Action Class


Action.Destroy Method

Action.Destroy Method

Action.Destroy Method | Previous topic | Next topic
Action.Destroy Method | Previous topic | Next topic

Zerstört die statische Instanz

Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Sub Destroy()

C#

public System.Void Destroy()

C++

public:
System::Void Destroy()

JScript

public function Destroy();

Source code

Visual Basic

Copy Code Copy Code

Public Sub Destroy()
Try
_actionSingleton = Nothing
Catch ex As Exception
Throw ex
End Try
End Sub

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

Action Class
Action Action Members


Action.GetParameterByName Method

Action.GetParameterByName Method

Action.GetParameterByName Method | Previous topic | Next topic
Action.GetParameterByName Method | Previous topic | Next topic

Returns a parameter identified by his name

Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Function GetParameterByName( _
ByVal paramName As String _
) As Parameter

C#

public Parameter GetParameterByName(
stringparamName
)

C++

public:
Parameter GetParameterByName(
String^ paramName
)

JScript

public function GetParameterByName(
paramName : String
) : Parameter;

Parameters

paramName

Source code

Visual Basic

Copy Code Copy Code

Public Function GetParameterByName(ByVal paramName As String) As Parameter
Try
Dim param As Parameter
For Each param In _parameters
If param.Name = paramName Then
Return param
End If
Next
Catch ex As Exception
Throw ex
End Try
End Function

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

Action Class
Action Action Members


Action.IsValid Method

Action.IsValid Method

Action.IsValid Method | Previous topic | Next topic
Action.IsValid Method | Previous topic | Next topic

Überprüft ob das Xml file dem angegebenen Schema entspricht

Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private Function IsValid( _
ByVal xmlImportFile As FileInfo _
) As Boolean

C#

private bool IsValid(
FileInfoxmlImportFile
)

C++

private:
bool IsValid(
FileInfo^ xmlImportFile
)

JScript

private function IsValid(
xmlImportFile : FileInfo
) : boolean;

Parameters

xmlImportFile

Source code

Visual Basic

Copy Code Copy Code

Private Function IsValid(ByVal xmlImportFile As FileInfo) As Boolean
Dim reader As New XmlTextReader(xmlImportFile.FullName)
'We pass the xmltextreader into the xmlvalidatingreader
'This will validate the xml doc with the schema file
'NOTE the xml file it self points to the schema file

Dim validator As New XmlValidatingReader(reader)
Try
'First we create the xmltextreader

' Set the validation event handler
'AddHandler validator.ValidationEventHandler, _
'AddressOf ValidationCallback
_validationSuccess = True 'make sure to reset the success var

' Read XML data
While (validator.Read)
End While
'Close the reader.
validator.Close()

reader.Close()

'The validationeventhandler is the only thing that would
'set m_Success to false
Return _validationSuccess
Catch ex As Exception
validator.Close()
reader.Close()

_validationSuccess = False
_validationSuccess = False
Return _validationSuccess
Throw ex
End Try
End Function

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

Action Class
Action Action Members


Action.Load Method

Action.Load Method

Action.Load Method | Previous topic | Next topic
Action.Load Method | Previous topic | Next topic

Lädt externes Xml file für automatisierte Aktionen

Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Function Load( _
ByVal xmlImportFile As FileInfo _
) As Boolean

C#

public bool Load(
FileInfoxmlImportFile
)

C++

public:
bool Load(
FileInfo^ xmlImportFile
)

JScript

public function Load(
xmlImportFile : FileInfo
) : boolean;

Parameters

xmlImportFile

Das Xml File mit den entsprechenden Parametern

Source code

Visual Basic

Copy Code Copy Code

Public Function Load(ByVal xmlImportFile As FileInfo) As Boolean
If Param.DebugMode Then
DivFnkt.InsertJournale("EDKB12: Start Load XML-File", clsDivFnkt.Enum_InfoTyp.Information)
End If

Try
'Validate source
If Not IsValid(xmlImportFile) Then
'xml file is invalid
DivFnkt.InsertJournale("EDKB12::Fehler:: Load XML-File::File invalid", clsDivFnkt.Enum_InfoTyp.Fehler)
If Param.DebugMode Then
DivFnkt.InsertJournale("EDKB12::Fehler:: XML-File::File invalid", clsDivFnkt.Enum_InfoTyp.Information)
End If
Return False
End If

Dim doc As New XmlDocument()
doc.Load(xmlImportFile.FullName)

'read header elements
_actionType = CType(doc.SelectSingleNode("action/actionId").InnerText, ActionType)
_creatorTgNr = doc.SelectSingleNode("action/creatorTg").InnerText
_sourceApplication = doc.SelectSingleNode("action/sourceApplication").InnerText

Dim RootNode As XmlElement = doc.DocumentElement
Dim nodeList As XmlNodeList = RootNode.ChildNodes
If nodeList.Count > 0 Then
'set correct array size
ReDim _parameters(nodeList.Count - 1)

Dim value As String
Dim name As String
Dim parameterCounter As Integer = 0

Dim i As Integer

For i = 0 To nodeList.Count - 1
value = nodeList.Item(i).InnerText
name = nodeList.Item(i).LocalName
'append new parameter
_parameters(parameterCounter) = New Parameter(name, value)

parameterCounter = parameterCounter + 1
Next
End If
If Param.DebugMode Then
DivFnkt.InsertJournale("EDKB12: Ende Load XML-File (True)", clsDivFnkt.Enum_InfoTyp.Information)
End If

Return True
Catch ex As Exception
DivFnkt.InsertJournale("EDKB12::Fehler:: Load XML-File::File invalid::" & ex.Message, clsDivFnkt.Enum_InfoTyp.Fehler)
If Param.DebugMode Then
DivFnkt.InsertJournale("EDKB12: Load XML-File::File invalid(False)", clsDivFnkt.Enum_InfoTyp.Information)
End If
Return False
End Try
End Function

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

Action Class
Action Action Members


Action.ValidationCallback Method

Action.ValidationCallback Method

Action.ValidationCallback Method | Previous topic | Next topic
Action.ValidationCallback Method | Previous topic | Next topic

Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private Sub ValidationCallback( _
ByVal sender As Object, _
ByVal args As ValidationEventArgs _
)

C#

private System.Void ValidationCallback(
objectsender,
ValidationEventArgsargs
)

C++

private:
System::Void ValidationCallback(
object^ sender,
ValidationEventArgs^ args
)

JScript

private function ValidationCallback(
sender : object,
args : ValidationEventArgs
);

Parameters

sender

args

Source code

Visual Basic

Copy Code Copy Code

Private Sub ValidationCallback(ByVal sender As Object, ByVal args As ValidationEventArgs)
Try
'Display the validation error. This is only called on error
_validationSuccess = False 'Validation failed
Debug.Write("Validation error: " + args.Message + Environment.NewLine)
Throw New ActionException(1, "Fehler bei der Validierung")
Catch ex As Exception
Throw ex
End Try
End Sub

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

Action Class
Action Action Members


Action Fields

Action Fields

Action Fields | Previous topic | Next topic
Action Fields | Previous topic | Next topic

Fields

 | Name | Description
Supported by the .NET Compact Framework. | _actionSingleton |
Supported by the .NET Compact Framework. | _actionType |
Supported by the .NET Compact Framework. | _creatorTgNr |
Supported by the .NET Compact Framework. | _parameters |
Supported by the .NET Compact Framework. | _sourceApplication |
Supported by the .NET Compact Framework. | _validationSuccess |

Top

See Also

Reference

Action Class


_actionSingleton Field

_actionSingleton Field

_actionSingleton Field | Previous topic | Next topic
_actionSingleton Field | Previous topic | Next topic

Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private Shared _actionSingleton As Action

C#

private static Action _actionSingleton

C++

private:
static Action^ _actionSingleton;

JScript

private static _actionSingleton : Action

Source code

Visual Basic

Copy Code Copy Code

Private Shared _actionSingleton As Action

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

Action Class
Action Action Members


_actionType Field

_actionType Field

_actionType Field | Previous topic | Next topic
_actionType Field | Previous topic | Next topic

Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private _actionType As ActionType

C#

private ActionType _actionType

C++

private:
ActionType _actionType;

JScript

private _actionType : ActionType

Source code

Visual Basic

Copy Code Copy Code

Private _actionType As ActionType

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

Action Class
Action Action Members


_creatorTgNr Field

_creatorTgNr Field

_creatorTgNr Field | Previous topic | Next topic
_creatorTgNr Field | Previous topic | Next topic

Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private _creatorTgNr As String

C#

private string _creatorTgNr

C++

private:
String^ _creatorTgNr;

JScript

private _creatorTgNr : String

Source code

Visual Basic

Copy Code Copy Code

Private _creatorTgNr As String

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

Action Class
Action Action Members


_parameters Field

_parameters Field

_parameters Field | Previous topic | Next topic
_parameters Field | Previous topic | Next topic

Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private _parameters As Parameter()

C#

private Parameter[] _parameters

C++

private:
array< Parameter >^ _parameters;

JScript

private _parameters : Parameter[]

Source code

Visual Basic

Copy Code Copy Code

Private _parameters As Parameter()

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

Action Class
Action Action Members


_sourceApplication Field

_sourceApplication Field

_sourceApplication Field | Previous topic | Next topic
_sourceApplication Field | Previous topic | Next topic

Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private _sourceApplication As String

C#

private string _sourceApplication

C++

private:
String^ _sourceApplication;

JScript

private _sourceApplication : String

Source code

Visual Basic

Copy Code Copy Code

Private _sourceApplication As String

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

Action Class
Action Action Members


_validationSuccess Field

_validationSuccess Field

_validationSuccess Field | Previous topic | Next topic
_validationSuccess Field | Previous topic | Next topic

Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private _validationSuccess As Boolean

C#

private bool _validationSuccess

C++

private:
bool _validationSuccess;

JScript

private _validationSuccess : boolean

Source code

Visual Basic

Copy Code Copy Code

Private _validationSuccess As Boolean

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

Action Class
Action Action Members


ActionException Class

ActionException Class

ActionException Class | Previous topic | Next topic
ActionException Class | Previous topic | Next topic

Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Class ActionException
Inherits Exception

C#

public class ActionException : Exception

C++

public ref class ActionException : public Exception^

JScript

public class ActionException
extends Exception

Inheritance Hierarchy

System.Object

System.Exception

EDKB12WS.ActionException

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

ActionException Members


ActionException Members

ActionException Members

ActionException Members | Previous topic | Next topic
ActionException Members | Previous topic | Next topic

The following tables list the members exposed by the ActionException type.

Public Constructors

 | Name | Description
Supported by the .NET Compact Framework. | ActionException Constructor |

Top

Public Properties

 | Name | Description
Public property | Data | (inherited from Exception).
Public property | HResult | (inherited from Exception).
Public property | HelpLink | (inherited from Exception).
Public property | InnerException | (inherited from Exception).
Supported by the .NET Compact Framework. | Message |
Supported by the .NET Compact Framework. | Number |
Public property | Source | (inherited from Exception).
Public property | StackTrace | (inherited from Exception).
Public property | TargetSite | (inherited from Exception).

Top

Public Methods

 | Name | Description
Public method | Equals | (Overloaded) (inherited from Object).
Public method | GetBaseException | (inherited from Exception).
Public method | GetHashCode | (inherited from Object).
Public method | GetObjectData | (inherited from Exception).
Public method | GetType | (Overloaded) (inherited from Exception).
 | ReferenceEquals | (inherited from Object).
Public method | ToString | (inherited from Exception).

Top

Protected Methods

 | Name | Description
Protected method | Finalize | (inherited from Object).
Protected method | MemberwiseClone | (Overloaded) (inherited from Object).

Top

Protected Events

 | Name | Description
Protected event | SerializeObjectState | (inherited from Exception).

Top

Fields

 | Name | Description
Supported by the .NET Compact Framework. | _description |
Supported by the .NET Compact Framework. | _number |

Top

See Also

Reference

ActionException Class


ActionException Constructor

ActionException Constructor

ActionException Constructor | Previous topic | Next topic
ActionException Constructor | Previous topic | Next topic

Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Sub New( _
ByVal number As Integer, _
ByVal description As String _
)

C#

public ActionException(
intnumber,
stringdescription
)

C++

public:
ActionException(
intnumber,
String^ description
)

JScript

public function ActionException(
number : int,
description : String
);

Parameters

number

description

Source code

Visual Basic

Copy Code Copy Code

Public Sub New(ByVal number As Integer, ByVal description As String)
_number = number
_description = description
End Sub

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

ActionException Class
ActionException ActionException Members


ActionException Properties

ActionException Properties

ActionException Properties | Previous topic | Next topic
ActionException Properties | Previous topic | Next topic

Public Properties

 | Name | Description
Public property | Data | (inherited from Exception).
Public property | HResult | (inherited from Exception).
Public property | HelpLink | (inherited from Exception).
Public property | InnerException | (inherited from Exception).
Supported by the .NET Compact Framework. | Message |
Supported by the .NET Compact Framework. | Number |
Public property | Source | (inherited from Exception).
Public property | StackTrace | (inherited from Exception).
Public property | TargetSite | (inherited from Exception).

Top

See Also

Reference

ActionException Class


ActionException.Message Property

ActionException.Message Property

ActionException.Message Property | Previous topic | Next topic
ActionException.Message Property | Previous topic | Next topic

Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public ReadOnly Overrides Property Message() As String

C#

public override string Message {get;}

C++

public:
property String^ Message {
String^ get( );
}

JScript

public function get Message() : String;

Source code

Visual Basic

Copy Code Copy Code

Public Overrides ReadOnly Property Message() As String
Get
Return _description
End Get
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

ActionException Class
ActionException ActionException Members


ActionException.Number Property

ActionException.Number Property

ActionException.Number Property | Previous topic | Next topic
ActionException.Number Property | Previous topic | Next topic

Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public ReadOnly Property Number() As Integer

C#

public int Number {get;}

C++

public:
property int Number {
int get( );
}

JScript

public function get Number() : int;

Source code

Visual Basic

Copy Code Copy Code

Public ReadOnly Property Number() As Integer
Get
Return _number
End Get
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

ActionException Class
ActionException ActionException Members


ActionException Methods

ActionException Methods

ActionException Methods | Previous topic | Next topic
ActionException Methods | Previous topic | Next topic

Public Methods

 | Name | Description
Public method | Equals | (Overloaded) (inherited from Object).
Public method | GetBaseException | (inherited from Exception).
Public method | GetHashCode | (inherited from Object).
Public method | GetObjectData | (inherited from Exception).
Public method | GetType | (Overloaded) (inherited from Exception).
 | ReferenceEquals | (inherited from Object).
Public method | ToString | (inherited from Exception).

Top

Protected Methods

 | Name | Description
Protected method | Finalize | (inherited from Object).
Protected method | MemberwiseClone | (Overloaded) (inherited from Object).

Top

See Also

Reference

ActionException Class


ActionException Events

ActionException Events

ActionException Events | Previous topic | Next topic
ActionException Events | Previous topic | Next topic

Protected Events

 | Name | Description
Protected event | SerializeObjectState | (inherited from Exception).

Top

See Also

Reference

ActionException Class


ActionException Fields

ActionException Fields

ActionException Fields | Previous topic | Next topic
ActionException Fields | Previous topic | Next topic

Fields

 | Name | Description
Supported by the .NET Compact Framework. | _description |
Supported by the .NET Compact Framework. | _number |

Top

See Also

Reference

ActionException Class


_description Field

_description Field

_description Field | Previous topic | Next topic
_description Field | Previous topic | Next topic

Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private _description As String

C#

private string _description

C++

private:
String^ _description;

JScript

private _description : String

Source code

Visual Basic

Copy Code Copy Code

Private _description As String

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

ActionException Class
ActionException ActionException Members


_number Field

_number Field

_number Field | Previous topic | Next topic
_number Field | Previous topic | Next topic

Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private _number As Integer

C#

private int _number

C++

private:
int _number;

JScript

private _number : int

Source code

Visual Basic

Copy Code Copy Code

Private _number As Integer

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

ActionException Class
ActionException ActionException Members


AvaloqDokumentWert Class

AvaloqDokumentWert Class

AvaloqDokumentWert Class | Previous topic | Next topic
AvaloqDokumentWert Class | Previous topic | Next topic

Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Class AvaloqDokumentWert

C#

public class AvaloqDokumentWert

C++

public ref class AvaloqDokumentWert

JScript

public class AvaloqDokumentWert

Inheritance Hierarchy

System.Object

EDKB12WS.AvaloqDokumentWert

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

AvaloqDokumentWert Members


AvaloqDokumentWert Members

AvaloqDokumentWert Members

AvaloqDokumentWert Members | Previous topic | Next topic
AvaloqDokumentWert Members | Previous topic | Next topic

The following tables list the members exposed by the AvaloqDokumentWert type.

Public Constructors

 | Name | Description
Supported by the .NET Compact Framework. | AvaloqDokumentWert Constructor |

Top

Public Properties

 | Name | Description
Supported by the .NET Compact Framework. | name |
Supported by the .NET Compact Framework. | value |

Top

Public Methods

 | Name | Description
Public method | Equals | (Overloaded) (inherited from Object).
Public method | GetHashCode | (inherited from Object).
Public method | GetType | (Overloaded) (inherited from Object).
 | ReferenceEquals | (inherited from Object).
Public method | ToString | (inherited from Object).

Top

Protected Methods

 | Name | Description
Protected method | Finalize | (inherited from Object).
Protected method | MemberwiseClone | (Overloaded) (inherited from Object).

Top

Fields

 | Name | Description
Supported by the .NET Compact Framework. | strName |
Supported by the .NET Compact Framework. | strValue |

Top

See Also

Reference

AvaloqDokumentWert Class


AvaloqDokumentWert Constructor

AvaloqDokumentWert Constructor

AvaloqDokumentWert Constructor | Previous topic | Next topic
AvaloqDokumentWert Constructor | Previous topic | Next topic

Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Sub New( _
ByVal name As String, _
ByVal value As String _
)

C#

public AvaloqDokumentWert(
stringname,
stringvalue
)

C++

public:
AvaloqDokumentWert(
String^ name,
String^ value
)

JScript

public function AvaloqDokumentWert(
name : String,
value : String
);

Parameters

name

value

Source code

Visual Basic

Copy Code Copy Code

Public Sub New(ByVal name As String, ByVal value As String)
Me.name = name
Me.value = value

End Sub

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

AvaloqDokumentWert Class
AvaloqDokumentWert AvaloqDokumentWert Members


AvaloqDokumentWert Properties

AvaloqDokumentWert Properties

AvaloqDokumentWert Properties | Previous topic | Next topic
AvaloqDokumentWert Properties | Previous topic | Next topic

Public Properties

 | Name | Description
Supported by the .NET Compact Framework. | name |
Supported by the .NET Compact Framework. | value |

Top

See Also

Reference

AvaloqDokumentWert Class


AvaloqDokumentWert.name Property

AvaloqDokumentWert.name Property

AvaloqDokumentWert.name Property | Previous topic | Next topic
AvaloqDokumentWert.name Property | Previous topic | Next topic

Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property name() As String

C#

public string name {get; set;}

C++

public:
property String^ name {
String^ get( );
void set(
String^ value
);
}

JScript

public function get name() : String;
public function set name(value : String);

Source code

Visual Basic

Copy Code Copy Code

Public Property name() As String
Get
Return strName
End Get
Set(ByVal Value As String)
strName = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

AvaloqDokumentWert Class
AvaloqDokumentWert AvaloqDokumentWert Members


AvaloqDokumentWert.value Property

AvaloqDokumentWert.value Property

AvaloqDokumentWert.value Property | Previous topic | Next topic
AvaloqDokumentWert.value Property | Previous topic | Next topic

Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property value() As String

C#

public string value {get; set;}

C++

public:
property String^ value {
String^ get( );
void set(
String^ value
);
}

JScript

public function get value() : String;
public function set value(value : String);

Source code

Visual Basic

Copy Code Copy Code

Public Property value() As String
Get
Return strValue
End Get
Set(ByVal Value As String)
strValue = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

AvaloqDokumentWert Class
AvaloqDokumentWert AvaloqDokumentWert Members


AvaloqDokumentWert Methods

AvaloqDokumentWert Methods

AvaloqDokumentWert Methods | Previous topic | Next topic
AvaloqDokumentWert Methods | Previous topic | Next topic

Public Methods

 | Name | Description
Public method | Equals | (Overloaded) (inherited from Object).
Public method | GetHashCode | (inherited from Object).
Public method | GetType | (Overloaded) (inherited from Object).
 | ReferenceEquals | (inherited from Object).
Public method | ToString | (inherited from Object).

Top

Protected Methods

 | Name | Description
Protected method | Finalize | (inherited from Object).
Protected method | MemberwiseClone | (Overloaded) (inherited from Object).

Top

See Also

Reference

AvaloqDokumentWert Class


AvaloqDokumentWert Fields

AvaloqDokumentWert Fields

AvaloqDokumentWert Fields | Previous topic | Next topic
AvaloqDokumentWert Fields | Previous topic | Next topic

Fields

 | Name | Description
Supported by the .NET Compact Framework. | strName |
Supported by the .NET Compact Framework. | strValue |

Top

See Also

Reference

AvaloqDokumentWert Class


strName Field

strName Field

strName Field | Previous topic | Next topic
strName Field | Previous topic | Next topic

Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private strName As String

C#

private string strName

C++

private:
String^ strName;

JScript

private strName : String

Source code

Visual Basic

Copy Code Copy Code

Private strName As String

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

AvaloqDokumentWert Class
AvaloqDokumentWert AvaloqDokumentWert Members


strValue Field

strValue Field

strValue Field | Previous topic | Next topic
strValue Field | Previous topic | Next topic

Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private strValue As String

C#

private string strValue

C++

private:
String^ strValue;

JScript

private strValue : String

Source code

Visual Basic

Copy Code Copy Code

Private strValue As String

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

AvaloqDokumentWert Class
AvaloqDokumentWert AvaloqDokumentWert Members


AvaloqDokumentWerte Class

AvaloqDokumentWerte Class

AvaloqDokumentWerte Class | Previous topic | Next topic
AvaloqDokumentWerte Class | Previous topic | Next topic

Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Class AvaloqDokumentWerte

C#

public class AvaloqDokumentWerte

C++

public ref class AvaloqDokumentWerte

JScript

public class AvaloqDokumentWerte

Inheritance Hierarchy

System.Object

EDKB12WS.AvaloqDokumentWerte

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

AvaloqDokumentWerte Members


AvaloqDokumentWerte Members

AvaloqDokumentWerte Members

AvaloqDokumentWerte Members | Previous topic | Next topic
AvaloqDokumentWerte Members | Previous topic | Next topic

The following tables list the members exposed by the AvaloqDokumentWerte type.

Public Methods

 | Name | Description
Public method | Equals | (Overloaded) (inherited from Object).
Public method | GetHashCode | (inherited from Object).
Public method | GetType | (Overloaded) (inherited from Object).
 | ReferenceEquals | (inherited from Object).
Public method | ToString | (inherited from Object).
Supported by the .NET Compact Framework. | clearAvaloqDokumentWerte |
Supported by the .NET Compact Framework. | getAvaloqDokumentWertByName |
Supported by the .NET Compact Framework. | init | Lädt externes Xml file für automatisierte Aktionen

Top

Protected Methods

 | Name | Description
Protected method | Finalize | (inherited from Object).
Protected method | MemberwiseClone | (Overloaded) (inherited from Object).

Top

Fields

 | Name | Description
Supported by the .NET Compact Framework. | arrDoukmentWerte |
Supported by the .NET Compact Framework. | objDokumentWert |

Top

See Also

Reference

AvaloqDokumentWerte Class


AvaloqDokumentWerte Methods

AvaloqDokumentWerte Methods

AvaloqDokumentWerte Methods | Previous topic | Next topic
AvaloqDokumentWerte Methods | Previous topic | Next topic

Public Methods

 | Name | Description
Public method | Equals | (Overloaded) (inherited from Object).
Public method | GetHashCode | (inherited from Object).
Public method | GetType | (Overloaded) (inherited from Object).
 | ReferenceEquals | (inherited from Object).
Public method | ToString | (inherited from Object).
Supported by the .NET Compact Framework. | clearAvaloqDokumentWerte |
Supported by the .NET Compact Framework. | getAvaloqDokumentWertByName |
Supported by the .NET Compact Framework. | init | Lädt externes Xml file für automatisierte Aktionen

Top

Protected Methods

 | Name | Description
Protected method | Finalize | (inherited from Object).
Protected method | MemberwiseClone | (Overloaded) (inherited from Object).

Top

See Also

Reference

AvaloqDokumentWerte Class


AvaloqDokumentWerte.clearAvaloqDokumentWerte Method

AvaloqDokumentWerte.clearAvaloqDokumentWerte Method

AvaloqDokumentWerte.clearAvaloqDokumentWerte Method | Previous topic | Next topic
AvaloqDokumentWerte.clearAvaloqDokumentWerte Method | Previous topic | Next topic

Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Sub clearAvaloqDokumentWerte()

C#

public System.Void clearAvaloqDokumentWerte()

C++

public:
System::Void clearAvaloqDokumentWerte()

JScript

public function clearAvaloqDokumentWerte();

Source code

Visual Basic

Copy Code Copy Code

Public Sub clearAvaloqDokumentWerte()
arrDoukmentWerte.Clear()
End Sub

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

AvaloqDokumentWerte Class
AvaloqDokumentWerte AvaloqDokumentWerte Members


AvaloqDokumentWerte.getAvaloqDokumentWertByName Method

AvaloqDokumentWerte.getAvaloqDokumentWertByName Method

AvaloqDokumentWerte.getAvaloqDokumentWertByName Method | Previous topic | Next topic
AvaloqDokumentWerte.getAvaloqDokumentWertByName Method | Previous topic | Next topic

Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Function getAvaloqDokumentWertByName( _
ByVal name As String _
) As AvaloqDokumentWert

C#

public AvaloqDokumentWert getAvaloqDokumentWertByName(
stringname
)

C++

public:
AvaloqDokumentWert^ getAvaloqDokumentWertByName(
String^ name
)

JScript

public function getAvaloqDokumentWertByName(
name : String
) : AvaloqDokumentWert;

Parameters

name

Source code

Visual Basic

Copy Code Copy Code

Public Function getAvaloqDokumentWertByName(ByVal name As String) As AvaloqDokumentWert
Dim objRet As AvaloqDokumentWert = Nothing
Dim i As Integer

For i = 0 To arrDoukmentWerte.Count - 1
If arrDoukmentWerte(i).name = name Then
objRet = arrDoukmentWerte(i)
End If
Next
Return objRet
End Function

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

AvaloqDokumentWerte Class
AvaloqDokumentWerte AvaloqDokumentWerte Members


AvaloqDokumentWerte.init Method

AvaloqDokumentWerte.init Method

AvaloqDokumentWerte.init Method | Previous topic | Next topic
AvaloqDokumentWerte.init Method | Previous topic | Next topic

Lädt externes Xml file für automatisierte Aktionen

Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Function init( _
ByVal xmlImportFile As FileInfo _
) As Object

C#

public object init(
FileInfoxmlImportFile
)

C++

public:
object^ init(
FileInfo^ xmlImportFile
)

JScript

public function init(
xmlImportFile : FileInfo
) : object;

Parameters

xmlImportFile

Das Xml File mit den entsprechenden Parametern

Source code

Visual Basic

Copy Code Copy Code

Public Function init(ByVal xmlImportFile As FileInfo)
Try

Dim doc As New XmlDocument()

doc.Load(xmlImportFile.FullName)

'read all parameter nodes
Dim parameterNodes As XmlNodeList
parameterNodes = doc.SelectNodes("action/dokwerte/parameter")

If parameterNodes.Count > 0 Then
Dim node As XmlNode
Dim name, value, dataType As String

Dim parameterCounter As Integer = 0

For Each node In parameterNodes
'Read all Document specified Values
'20080401 RGL zusätzliches TRY wenn node <parameter> leer geliefert wird kein Absturz
Try
name = node.SelectSingleNode("name").InnerText
value = node.SelectSingleNode("value").InnerText
objDokumentWert = New AvaloqDokumentWert(name, value)
arrDoukmentWerte.Add(objDokumentWert)
Catch ex As Exception
'xxx
'TKBLib.Errorhandling.TraceHelper.Msg("EdokaLib.Common.Action.Load", ex.Message & ex.StackTrace, TraceLevel.Error)
End Try
parameterCounter = parameterCounter + 1

Next
End If

Catch ex As Exception
'xxx
' TKBLib.Errorhandling.TraceHelper.Msg("EdokaLib.Common.Action.Load", ex.Message & ex.StackTrace, TraceLevel.Error)
Throw ex
End Try
End Function

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

AvaloqDokumentWerte Class
AvaloqDokumentWerte AvaloqDokumentWerte Members


AvaloqDokumentWerte Fields

AvaloqDokumentWerte Fields

AvaloqDokumentWerte Fields | Previous topic | Next topic
AvaloqDokumentWerte Fields | Previous topic | Next topic

Fields

 | Name | Description
Supported by the .NET Compact Framework. | arrDoukmentWerte |
Supported by the .NET Compact Framework. | objDokumentWert |

Top

See Also

Reference

AvaloqDokumentWerte Class


arrDoukmentWerte Field

arrDoukmentWerte Field

arrDoukmentWerte Field | Previous topic | Next topic
arrDoukmentWerte Field | Previous topic | Next topic

Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private arrDoukmentWerte As ArrayList

C#

private ArrayList arrDoukmentWerte

C++

private:
ArrayList^ arrDoukmentWerte;

JScript

private arrDoukmentWerte : ArrayList

Source code

Visual Basic

Copy Code Copy Code

Private arrDoukmentWerte As New ArrayList()

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

AvaloqDokumentWerte Class
AvaloqDokumentWerte AvaloqDokumentWerte Members


objDokumentWert Field

objDokumentWert Field

objDokumentWert Field | Previous topic | Next topic
objDokumentWert Field | Previous topic | Next topic

Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private objDokumentWert As AvaloqDokumentWert

C#

private AvaloqDokumentWert objDokumentWert

C++

private:
AvaloqDokumentWert^ objDokumentWert;

JScript

private objDokumentWert : AvaloqDokumentWert

Source code

Visual Basic

Copy Code Copy Code

Private objDokumentWert As AvaloqDokumentWert

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

AvaloqDokumentWerte Class
AvaloqDokumentWerte AvaloqDokumentWerte Members


Parameters Class

Parameters Class

Parameters Class | Previous topic | Next topic
Parameters Class | Previous topic | Next topic

Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Class Parameters

C#

public class Parameters

C++

public ref class Parameters

JScript

public class Parameters

Inheritance Hierarchy

System.Object

EDKB12WS.Parameters

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

Parameters Members


Parameters Members

Parameters Members

Parameters Members | Previous topic | Next topic
Parameters Members | Previous topic | Next topic

The following tables list the members exposed by the Parameters type.

Public Constructors

 | Name | Description
Supported by the .NET Compact Framework. | Parameters Constructor |

Top

Public Properties

 | Name | Description
Supported by the .NET Compact Framework. | CheckOffice2010_Vorlage |
Supported by the .NET Compact Framework. | DebugMode |
Supported by the .NET Compact Framework. | FehlerMeldungMeldung |
Supported by the .NET Compact Framework. | FehlermeldungBetreff |
Supported by the .NET Compact Framework. | MaNrFehlermeldung |
Supported by the .NET Compact Framework. | NOKMeldung |
Supported by the .NET Compact Framework. | NOKMeldungBetreff |
Supported by the .NET Compact Framework. | OKMeldung |
Supported by the .NET Compact Framework. | OKMeldungBetreff |
Supported by the .NET Compact Framework. | TimerInterval |
Supported by the .NET Compact Framework. | WorkDir |
Supported by the .NET Compact Framework. | connectionstring |
Supported by the .NET Compact Framework. | connectionstring_Journale |

Top

Public Methods

 | Name | Description
Supported by the .NET Compact Framework. | ApplicationPath |
Public method | Equals | (Overloaded) (inherited from Object).
Public method | GetHashCode | (inherited from Object).
Public method | GetType | (Overloaded) (inherited from Object).
 | ReferenceEquals | (inherited from Object).
Public method | ToString | (inherited from Object).

Top

Protected Methods

 | Name | Description
Protected method | Finalize | (inherited from Object).
Protected method | MemberwiseClone | (Overloaded) (inherited from Object).

Top

Fields

 | Name | Description
Supported by the .NET Compact Framework. | bCheckOffice2010_Vorlage |
Supported by the .NET Compact Framework. | bDebugmode |
Supported by the .NET Compact Framework. | iInterval |
Supported by the .NET Compact Framework. | iMaNrFehlerMeldung |
Supported by the .NET Compact Framework. | sFehlerMeldungMeldung |
Supported by the .NET Compact Framework. | sFehlermeldungBetreff |
Supported by the .NET Compact Framework. | sNOKMeldung |
Supported by the .NET Compact Framework. | sNOKMeldungBetreff |
Supported by the .NET Compact Framework. | sOKMeldung |
Supported by the .NET Compact Framework. | sOKMeldungBetreff |
Supported by the .NET Compact Framework. | sconnectionstring |
Supported by the .NET Compact Framework. | sconnectionstring_Journale |
Supported by the .NET Compact Framework. | sworkdir |
Supported by the .NET Compact Framework. | xmldoc |

Top

See Also

Reference

Parameters Class


Parameters Constructor

Parameters Constructor

Parameters Constructor | Previous topic | Next topic
Parameters Constructor | Previous topic | Next topic

Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Sub New()

C#

public Parameters()

C++

public:
Parameters()

JScript

public function Parameters();

Source code

Visual Basic

Copy Code Copy Code

Public Sub New()
xmldoc.Load(Me.ApplicationPath + "Parameters.xml")
Me.connectionstring = xmldoc.SelectSingleNode("/Configuration/SQLConnectionString").InnerText
Me.connectionstring_Journale = xmldoc.SelectSingleNode("/Configuration/SQLConnectionStringJournale").InnerText
Me.WorkDir = xmldoc.SelectSingleNode("/Configuration/WorkDir").InnerText
Me.DebugMode = UCase(xmldoc.SelectSingleNode("/Configuration/DebugMode").InnerText) = "TRUE"
Me.OKMeldungBetreff = xmldoc.SelectSingleNode("/Configuration/OKMeldungBetreff").InnerText
Me.OKMeldung = xmldoc.SelectSingleNode("/Configuration/OKMeldung").InnerText
Me.NOKMeldungBetreff = xmldoc.SelectSingleNode("/Configuration/NOKMeldungBetreff").InnerText
Me.NOKMeldung = xmldoc.SelectSingleNode("/Configuration/NOKMeldung").InnerText
Me.TimerInterval = xmldoc.SelectSingleNode("/Configuration/TimerInterval").InnerText
Me.MaNrFehlermeldung = xmldoc.SelectSingleNode("/Configuration/MaNrFehlerMeldung").InnerText
Me.FehlermeldungBetreff = xmldoc.SelectSingleNode("/Configuration/FehlerMeldungBetreff").InnerText
Me.FehlerMeldungMeldung = xmldoc.SelectSingleNode("/Configuration/FehlerMeldungMeldung").InnerText
Me.MaNrFehlermeldung = xmldoc.SelectSingleNode("/Configuration/MaNrFehlerMeldung").InnerText
Me.CheckOffice2010_Vorlage = UCase(xmldoc.SelectSingleNode("/Configuration/CheckOffice2010_Vorlage").InnerText) = "TRUE"
Globals.conn.sConnectionString = Me.connectionstring
Globals.connJournale.sConnectionString = Me.connectionstring_Journale
Globals.PrintLog("EDKB12 gestartet", EventLogEntryType.Information)
Globals.PrintLog("Connectionstring EDOKA:" & Me.connectionstring, EventLogEntryType.Information)
Globals.PrintLog("Connectionstring Journale:" & Me.connectionstring_Journale, EventLogEntryType.Information)
Globals.PrintLog("WorkDir:" & Me.WorkDir, EventLogEntryType.Information)
Globals.PrintLog("DebugMode:" & Me.DebugMode, EventLogEntryType.Information)
Globals.PrintLog("TimerInterval:" & Me.TimerInterval, EventLogEntryType.Information)
Globals.PrintLog("Ma-Nr Fehlermeldung:" & Me.MaNrFehlermeldung, EventLogEntryType.Information)
End Sub

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

Parameters Class
Parameters Parameters Members


Parameters Properties

Parameters Properties

Parameters Properties | Previous topic | Next topic
Parameters Properties | Previous topic | Next topic

Public Properties

 | Name | Description
Supported by the .NET Compact Framework. | CheckOffice2010_Vorlage |
Supported by the .NET Compact Framework. | DebugMode |
Supported by the .NET Compact Framework. | FehlerMeldungMeldung |
Supported by the .NET Compact Framework. | FehlermeldungBetreff |
Supported by the .NET Compact Framework. | MaNrFehlermeldung |
Supported by the .NET Compact Framework. | NOKMeldung |
Supported by the .NET Compact Framework. | NOKMeldungBetreff |
Supported by the .NET Compact Framework. | OKMeldung |
Supported by the .NET Compact Framework. | OKMeldungBetreff |
Supported by the .NET Compact Framework. | TimerInterval |
Supported by the .NET Compact Framework. | WorkDir |
Supported by the .NET Compact Framework. | connectionstring |
Supported by the .NET Compact Framework. | connectionstring_Journale |

Top

See Also

Reference

Parameters Class


Parameters.CheckOffice2010_Vorlage Property

Parameters.CheckOffice2010_Vorlage Property

Parameters.CheckOffice2010_Vorlage Property | Previous topic | Next topic
Parameters.CheckOffice2010_Vorlage Property | Previous topic | Next topic

Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property CheckOffice2010_Vorlage() As Boolean

C#

public bool CheckOffice2010_Vorlage {get; set;}

C++

public:
property bool CheckOffice2010_Vorlage {
bool get( );
void set(
bool value
);
}

JScript

public function get CheckOffice2010_Vorlage() : boolean;
public function set CheckOffice2010_Vorlage(value : boolean);

Source code

Visual Basic

Copy Code Copy Code

Property CheckOffice2010_Vorlage() As Boolean
Get
Return bCheckOffice2010_Vorlage
End Get
Set(ByVal value As Boolean)
bCheckOffice2010_Vorlage = value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

Parameters Class
Parameters Parameters Members


Parameters.DebugMode Property

Parameters.DebugMode Property

Parameters.DebugMode Property | Previous topic | Next topic
Parameters.DebugMode Property | Previous topic | Next topic

Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property DebugMode() As Boolean

C#

public bool DebugMode {get; set;}

C++

public:
property bool DebugMode {
bool get( );
void set(
bool value
);
}

JScript

public function get DebugMode() : boolean;
public function set DebugMode(value : boolean);

Source code

Visual Basic

Copy Code Copy Code

Property DebugMode() As Boolean
Get
Return bDebugmode
End Get
Set(ByVal value As Boolean)
bDebugmode = value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

Parameters Class
Parameters Parameters Members


Parameters.FehlerMeldungMeldung Property

Parameters.FehlerMeldungMeldung Property

Parameters.FehlerMeldungMeldung Property | Previous topic | Next topic
Parameters.FehlerMeldungMeldung Property | Previous topic | Next topic

Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property FehlerMeldungMeldung() As String

C#

public string FehlerMeldungMeldung {get; set;}

C++

public:
property String^ FehlerMeldungMeldung {
String^ get( );
void set(
String^ value
);
}

JScript

public function get FehlerMeldungMeldung() : String;
public function set FehlerMeldungMeldung(value : String);

Source code

Visual Basic

Copy Code Copy Code

Property FehlerMeldungMeldung() As String
Get
Return sFehlerMeldungMeldung
End Get
Set(ByVal value As String)
sFehlerMeldungMeldung = value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

Parameters Class
Parameters Parameters Members


Parameters.FehlermeldungBetreff Property

Parameters.FehlermeldungBetreff Property

Parameters.FehlermeldungBetreff Property | Previous topic | Next topic
Parameters.FehlermeldungBetreff Property | Previous topic | Next topic

Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property FehlermeldungBetreff() As String

C#

public string FehlermeldungBetreff {get; set;}

C++

public:
property String^ FehlermeldungBetreff {
String^ get( );
void set(
String^ value
);
}

JScript

public function get FehlermeldungBetreff() : String;
public function set FehlermeldungBetreff(value : String);

Source code

Visual Basic

Copy Code Copy Code

Property FehlermeldungBetreff() As String
Get
Return sFehlermeldungBetreff
End Get
Set(ByVal value As String)
sFehlermeldungBetreff = value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

Parameters Class
Parameters Parameters Members


Parameters.MaNrFehlermeldung Property

Parameters.MaNrFehlermeldung Property

Parameters.MaNrFehlermeldung Property | Previous topic | Next topic
Parameters.MaNrFehlermeldung Property | Previous topic | Next topic

Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property MaNrFehlermeldung() As Integer

C#

public int MaNrFehlermeldung {get; set;}

C++

public:
property int MaNrFehlermeldung {
int get( );
void set(
int value
);
}

JScript

public function get MaNrFehlermeldung() : int;
public function set MaNrFehlermeldung(value : int);

Source code

Visual Basic

Copy Code Copy Code

Property MaNrFehlermeldung() As Integer
Get
Return iMaNrFehlerMeldung
End Get
Set(ByVal value As Integer)
iMaNrFehlerMeldung = value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

Parameters Class
Parameters Parameters Members


Parameters.NOKMeldung Property

Parameters.NOKMeldung Property

Parameters.NOKMeldung Property | Previous topic | Next topic
Parameters.NOKMeldung Property | Previous topic | Next topic

Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property NOKMeldung() As String

C#

public string NOKMeldung {get; set;}

C++

public:
property String^ NOKMeldung {
String^ get( );
void set(
String^ value
);
}

JScript

public function get NOKMeldung() : String;
public function set NOKMeldung(value : String);

Source code

Visual Basic

Copy Code Copy Code

Property NOKMeldung() As String
Get
Return sNOKMeldung
End Get
Set(ByVal value As String)
sNOKMeldung = value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

Parameters Class
Parameters Parameters Members


Parameters.NOKMeldungBetreff Property

Parameters.NOKMeldungBetreff Property

Parameters.NOKMeldungBetreff Property | Previous topic | Next topic
Parameters.NOKMeldungBetreff Property | Previous topic | Next topic

Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property NOKMeldungBetreff() As String

C#

public string NOKMeldungBetreff {get; set;}

C++

public:
property String^ NOKMeldungBetreff {
String^ get( );
void set(
String^ value
);
}

JScript

public function get NOKMeldungBetreff() : String;
public function set NOKMeldungBetreff(value : String);

Source code

Visual Basic

Copy Code Copy Code

Property NOKMeldungBetreff() As String
Get
Return sNOKMeldungBetreff
End Get
Set(ByVal value As String)
sNOKMeldungBetreff = value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

Parameters Class
Parameters Parameters Members


Parameters.OKMeldung Property

Parameters.OKMeldung Property

Parameters.OKMeldung Property | Previous topic | Next topic
Parameters.OKMeldung Property | Previous topic | Next topic

Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property OKMeldung() As String

C#

public string OKMeldung {get; set;}

C++

public:
property String^ OKMeldung {
String^ get( );
void set(
String^ value
);
}

JScript

public function get OKMeldung() : String;
public function set OKMeldung(value : String);

Source code

Visual Basic

Copy Code Copy Code

Property OKMeldung() As String
Get
Return sOKMeldung
End Get
Set(ByVal value As String)
sOKMeldung = value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

Parameters Class
Parameters Parameters Members


Parameters.OKMeldungBetreff Property

Parameters.OKMeldungBetreff Property

Parameters.OKMeldungBetreff Property | Previous topic | Next topic
Parameters.OKMeldungBetreff Property | Previous topic | Next topic

Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property OKMeldungBetreff() As String

C#

public string OKMeldungBetreff {get; set;}

C++

public:
property String^ OKMeldungBetreff {
String^ get( );
void set(
String^ value
);
}

JScript

public function get OKMeldungBetreff() : String;
public function set OKMeldungBetreff(value : String);

Source code

Visual Basic

Copy Code Copy Code

Property OKMeldungBetreff() As String
Get
Return sOKMeldungBetreff
End Get
Set(ByVal value As String)
sOKMeldungBetreff = value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

Parameters Class
Parameters Parameters Members


Parameters.TimerInterval Property

Parameters.TimerInterval Property

Parameters.TimerInterval Property | Previous topic | Next topic
Parameters.TimerInterval Property | Previous topic | Next topic

Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property TimerInterval() As Integer

C#

public int TimerInterval {get; set;}

C++

public:
property int TimerInterval {
int get( );
void set(
int value
);
}

JScript

public function get TimerInterval() : int;
public function set TimerInterval(value : int);

Source code

Visual Basic

Copy Code Copy Code

Property TimerInterval() As Integer
Get
Return iInterval
End Get
Set(ByVal value As Integer)
iInterval = value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

Parameters Class
Parameters Parameters Members


Parameters.WorkDir Property

Parameters.WorkDir Property

Parameters.WorkDir Property | Previous topic | Next topic
Parameters.WorkDir Property | Previous topic | Next topic

Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property WorkDir() As String

C#

public string WorkDir {get; set;}

C++

public:
property String^ WorkDir {
String^ get( );
void set(
String^ value
);
}

JScript

public function get WorkDir() : String;
public function set WorkDir(value : String);

Source code

Visual Basic

Copy Code Copy Code

Property WorkDir() As String
Get
Return sworkdir
End Get
Set(ByVal value As String)
sworkdir = value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

Parameters Class
Parameters Parameters Members


Parameters.connectionstring Property

Parameters.connectionstring Property

Parameters.connectionstring Property | Previous topic | Next topic
Parameters.connectionstring Property | Previous topic | Next topic

Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property connectionstring() As String

C#

public string connectionstring {get; set;}

C++

public:
property String^ connectionstring {
String^ get( );
void set(
String^ value
);
}

JScript

public function get connectionstring() : String;
public function set connectionstring(value : String);

Source code

Visual Basic

Copy Code Copy Code

Property connectionstring() As String
Get
Return sconnectionstring
End Get
Set(ByVal value As String)
sconnectionstring = value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

Parameters Class
Parameters Parameters Members


Parameters.connectionstring_Journale Property

Parameters.connectionstring_Journale Property

Parameters.connectionstring_Journale Property | Previous topic | Next topic
Parameters.connectionstring_Journale Property | Previous topic | Next topic

Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property connectionstring_Journale() As String

C#

public string connectionstring_Journale {get; set;}

C++

public:
property String^ connectionstring_Journale {
String^ get( );
void set(
String^ value
);
}

JScript

public function get connectionstring_Journale() : String;
public function set connectionstring_Journale(value : String);

Source code

Visual Basic

Copy Code Copy Code

Property connectionstring_Journale() As String
Get
Return sconnectionstring_Journale
End Get
Set(ByVal value As String)
sconnectionstring_Journale = value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

Parameters Class
Parameters Parameters Members


Parameters Methods

Parameters Methods

Parameters Methods | Previous topic | Next topic
Parameters Methods | Previous topic | Next topic

Public Methods

 | Name | Description
Supported by the .NET Compact Framework. | ApplicationPath |
Public method | Equals | (Overloaded) (inherited from Object).
Public method | GetHashCode | (inherited from Object).
Public method | GetType | (Overloaded) (inherited from Object).
 | ReferenceEquals | (inherited from Object).
Public method | ToString | (inherited from Object).

Top

Protected Methods

 | Name | Description
Protected method | Finalize | (inherited from Object).
Protected method | MemberwiseClone | (Overloaded) (inherited from Object).

Top

See Also

Reference

Parameters Class


Parameters.ApplicationPath Method

Parameters.ApplicationPath Method

Parameters.ApplicationPath Method | Previous topic | Next topic
Parameters.ApplicationPath Method | Previous topic | Next topic

Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Function ApplicationPath() As String

C#

public string ApplicationPath()

C++

public:
String^ ApplicationPath()

JScript

public function ApplicationPath() : String;

Source code

Visual Basic

Copy Code Copy Code

Public Function ApplicationPath() As String
Return Path.GetDirectoryName([Assembly].GetEntryAssembly().Location) + "\"
End Function

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

Parameters Class
Parameters Parameters Members


Parameters Fields

Parameters Fields

Parameters Fields | Previous topic | Next topic
Parameters Fields | Previous topic | Next topic

Fields

 | Name | Description
Supported by the .NET Compact Framework. | bCheckOffice2010_Vorlage |
Supported by the .NET Compact Framework. | bDebugmode |
Supported by the .NET Compact Framework. | iInterval |
Supported by the .NET Compact Framework. | iMaNrFehlerMeldung |
Supported by the .NET Compact Framework. | sFehlerMeldungMeldung |
Supported by the .NET Compact Framework. | sFehlermeldungBetreff |
Supported by the .NET Compact Framework. | sNOKMeldung |
Supported by the .NET Compact Framework. | sNOKMeldungBetreff |
Supported by the .NET Compact Framework. | sOKMeldung |
Supported by the .NET Compact Framework. | sOKMeldungBetreff |
Supported by the .NET Compact Framework. | sconnectionstring |
Supported by the .NET Compact Framework. | sconnectionstring_Journale |
Supported by the .NET Compact Framework. | sworkdir |
Supported by the .NET Compact Framework. | xmldoc |

Top

See Also

Reference

Parameters Class


bCheckOffice2010_Vorlage Field

bCheckOffice2010_Vorlage Field

bCheckOffice2010_Vorlage Field | Previous topic | Next topic
bCheckOffice2010_Vorlage Field | Previous topic | Next topic

Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private bCheckOffice2010_Vorlage As Boolean

C#

private bool bCheckOffice2010_Vorlage

C++

private:
bool bCheckOffice2010_Vorlage;

JScript

private bCheckOffice2010_Vorlage : boolean

Source code

Visual Basic

Copy Code Copy Code

Dim bCheckOffice2010_Vorlage As Boolean

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

Parameters Class
Parameters Parameters Members


bDebugmode Field

bDebugmode Field

bDebugmode Field | Previous topic | Next topic
bDebugmode Field | Previous topic | Next topic

Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private bDebugmode As Boolean

C#

private bool bDebugmode

C++

private:
bool bDebugmode;

JScript

private bDebugmode : boolean

Source code

Visual Basic

Copy Code Copy Code

Dim bDebugmode As Boolean

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

Parameters Class
Parameters Parameters Members


iInterval Field

iInterval Field

iInterval Field | Previous topic | Next topic
iInterval Field | Previous topic | Next topic

Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private iInterval As Integer

C#

private int iInterval

C++

private:
int iInterval;

JScript

private iInterval : int

Source code

Visual Basic

Copy Code Copy Code

Dim iInterval As Integer

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

Parameters Class
Parameters Parameters Members


iMaNrFehlerMeldung Field

iMaNrFehlerMeldung Field

iMaNrFehlerMeldung Field | Previous topic | Next topic
iMaNrFehlerMeldung Field | Previous topic | Next topic

Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private iMaNrFehlerMeldung As Integer

C#

private int iMaNrFehlerMeldung

C++

private:
int iMaNrFehlerMeldung;

JScript

private iMaNrFehlerMeldung : int

Source code

Visual Basic

Copy Code Copy Code

Dim iMaNrFehlerMeldung As Integer

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

Parameters Class
Parameters Parameters Members


sFehlerMeldungMeldung Field

sFehlerMeldungMeldung Field

sFehlerMeldungMeldung Field | Previous topic | Next topic
sFehlerMeldungMeldung Field | Previous topic | Next topic

Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private sFehlerMeldungMeldung As String

C#

private string sFehlerMeldungMeldung

C++

private:
String^ sFehlerMeldungMeldung;

JScript

private sFehlerMeldungMeldung : String

Source code

Visual Basic

Copy Code Copy Code

Dim sFehlerMeldungMeldung As String

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

Parameters Class
Parameters Parameters Members


sFehlermeldungBetreff Field

sFehlermeldungBetreff Field

sFehlermeldungBetreff Field | Previous topic | Next topic
sFehlermeldungBetreff Field | Previous topic | Next topic

Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private sFehlermeldungBetreff As String

C#

private string sFehlermeldungBetreff

C++

private:
String^ sFehlermeldungBetreff;

JScript

private sFehlermeldungBetreff : String

Source code

Visual Basic

Copy Code Copy Code

Dim sFehlermeldungBetreff As String

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

Parameters Class
Parameters Parameters Members


sNOKMeldung Field

sNOKMeldung Field

sNOKMeldung Field | Previous topic | Next topic
sNOKMeldung Field | Previous topic | Next topic

Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private sNOKMeldung As String

C#

private string sNOKMeldung

C++

private:
String^ sNOKMeldung;

JScript

private sNOKMeldung : String

Source code

Visual Basic

Copy Code Copy Code

Dim sNOKMeldung As String

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

Parameters Class
Parameters Parameters Members


sNOKMeldungBetreff Field

sNOKMeldungBetreff Field

sNOKMeldungBetreff Field | Previous topic | Next topic
sNOKMeldungBetreff Field | Previous topic | Next topic

Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private sNOKMeldungBetreff As String

C#

private string sNOKMeldungBetreff

C++

private:
String^ sNOKMeldungBetreff;

JScript

private sNOKMeldungBetreff : String

Source code

Visual Basic

Copy Code Copy Code

Dim sNOKMeldungBetreff As String

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

Parameters Class
Parameters Parameters Members


sOKMeldung Field

sOKMeldung Field

sOKMeldung Field | Previous topic | Next topic
sOKMeldung Field | Previous topic | Next topic

Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private sOKMeldung As String

C#

private string sOKMeldung

C++

private:
String^ sOKMeldung;

JScript

private sOKMeldung : String

Source code

Visual Basic

Copy Code Copy Code

Dim sOKMeldung As String

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

Parameters Class
Parameters Parameters Members


sOKMeldungBetreff Field

sOKMeldungBetreff Field

sOKMeldungBetreff Field | Previous topic | Next topic
sOKMeldungBetreff Field | Previous topic | Next topic

Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private sOKMeldungBetreff As String

C#

private string sOKMeldungBetreff

C++

private:
String^ sOKMeldungBetreff;

JScript

private sOKMeldungBetreff : String

Source code

Visual Basic

Copy Code Copy Code

Dim sOKMeldungBetreff As String

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

Parameters Class
Parameters Parameters Members


sconnectionstring Field

sconnectionstring Field

sconnectionstring Field | Previous topic | Next topic
sconnectionstring Field | Previous topic | Next topic

Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private sconnectionstring As String

C#

private string sconnectionstring

C++

private:
String^ sconnectionstring;

JScript

private sconnectionstring : String

Source code

Visual Basic

Copy Code Copy Code

Dim sconnectionstring As String

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

Parameters Class
Parameters Parameters Members


sconnectionstring_Journale Field

sconnectionstring_Journale Field

sconnectionstring_Journale Field | Previous topic | Next topic
sconnectionstring_Journale Field | Previous topic | Next topic

Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private sconnectionstring_Journale As String

C#

private string sconnectionstring_Journale

C++

private:
String^ sconnectionstring_Journale;

JScript

private sconnectionstring_Journale : String

Source code

Visual Basic

Copy Code Copy Code

Dim sconnectionstring_Journale As String

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

Parameters Class
Parameters Parameters Members


sworkdir Field

sworkdir Field

sworkdir Field | Previous topic | Next topic
sworkdir Field | Previous topic | Next topic

Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private sworkdir As String

C#

private string sworkdir

C++

private:
String^ sworkdir;

JScript

private sworkdir : String

Source code

Visual Basic

Copy Code Copy Code

Dim sworkdir As String

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

Parameters Class
Parameters Parameters Members


xmldoc Field

xmldoc Field

xmldoc Field | Previous topic | Next topic
xmldoc Field | Previous topic | Next topic

Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private xmldoc As XmlDocument

C#

private XmlDocument xmldoc

C++

private:
XmlDocument^ xmldoc;

JScript

private xmldoc : XmlDocument

Source code

Visual Basic

Copy Code Copy Code

Dim xmldoc As New XmlDocument

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

Parameters Class
Parameters Parameters Members


ProjectInstaller Class

ProjectInstaller Class

ProjectInstaller Class | Previous topic | Next topic
ProjectInstaller Class | Previous topic | Next topic

Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Class ProjectInstaller
Inherits Installer

C#

public class ProjectInstaller : Installer

C++

public ref class ProjectInstaller : public Installer^

JScript

public class ProjectInstaller
extends Installer

Inheritance Hierarchy

System.Object

System.MarshalByRefObject

System.ComponentModel.Component

System.Configuration.Install.Installer

EDKB12WS.ProjectInstaller

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

ProjectInstaller Members


ProjectInstaller Members

ProjectInstaller Members

ProjectInstaller Members | Previous topic | Next topic
ProjectInstaller Members | Previous topic | Next topic

The following tables list the members exposed by the ProjectInstaller type.

Public Constructors

 | Name | Description
Supported by the .NET Compact Framework. | ProjectInstaller Constructor |

Top

Public Properties

 | Name | Description
Public property | Container | (inherited from Component).
Public property | Context | (inherited from Installer).
Public property | HelpText | (inherited from Installer).
Public property | Installers | (inherited from Installer).
Public property | Parent | (inherited from Installer).
Public property | Site | (inherited from Component).

Top

Public Methods

 | Name | Description
Public method | Commit | (inherited from Installer).
Public method | CreateObjRef | (inherited from MarshalByRefObject).
Public method | Equals | (Overloaded) (inherited from Object).
Public method | GetHashCode | (inherited from Object).
Public method | GetLifetimeService | (inherited from MarshalByRefObject).
Public method | GetType | (Overloaded) (inherited from Object).
Public method | InitializeLifetimeService | (inherited from MarshalByRefObject).
Public method | Install | (inherited from Installer).
 | ReferenceEquals | (inherited from Object).
Public method | Rollback | (inherited from Installer).
Public method | ToString | (inherited from Component).
Public method | Uninstall | (inherited from Installer).

Top

Protected Methods

 | Name | Description
Supported by the .NET Compact Framework. | Dispose | (Overloaded)
Protected method | Finalize | (inherited from Component).
Protected method | GetService | (inherited from Component).
Protected method | MemberwiseClone | (Overloaded) (inherited from MarshalByRefObject).
Protected method | OnAfterInstall | (inherited from Installer).
Protected method | OnAfterRollback | (inherited from Installer).
Protected method | OnAfterUninstall | (inherited from Installer).
Protected method | OnBeforeInstall | (inherited from Installer).
Protected method | OnBeforeRollback | (inherited from Installer).
Protected method | OnBeforeUninstall | (inherited from Installer).
Protected method | OnCommitted | (inherited from Installer).
Protected method | OnCommitting | (inherited from Installer).

Top

Private, internal (Friend) and internal protected (Protected Friend) Methods

 | Name | Description
Supported by the .NET Compact Framework. | InitializeComponent |

Top

Public Events

 | Name | Description
Public event | AfterInstall | (inherited from Installer).
Public event | AfterRollback | (inherited from Installer).
Public event | AfterUninstall | (inherited from Installer).
Public event | BeforeInstall | (inherited from Installer).
Public event | BeforeRollback | (inherited from Installer).
Public event | BeforeUninstall | (inherited from Installer).
Public event | Committed | (inherited from Installer).
Public event | Committing | (inherited from Installer).
Public event | Disposed | (inherited from Component).

Top

Fields

 | Name | Description
Supported by the .NET Compact Framework. | components |

Top

See Also

Reference

ProjectInstaller Class


ProjectInstaller Constructor

ProjectInstaller Constructor

ProjectInstaller Constructor | Previous topic | Next topic
ProjectInstaller Constructor | Previous topic | Next topic

Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Sub New()

C#

public ProjectInstaller()

C++

public:
ProjectInstaller()

JScript

public function ProjectInstaller();

Source code

Visual Basic

Copy Code Copy Code

Public Sub New()
MyBase.New()

'Dieser Aufruf ist für den Komponenten-Designer erforderlich.
InitializeComponent()

'Initialisierungscode nach dem Aufruf von InitializeComponent hinzufügen

End Sub

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

ProjectInstaller Class
ProjectInstaller ProjectInstaller Members


ProjectInstaller Properties

ProjectInstaller Properties

ProjectInstaller Properties | Previous topic | Next topic
ProjectInstaller Properties | Previous topic | Next topic

Public Properties

 | Name | Description
Public property | Container | (inherited from Component).
Public property | Context | (inherited from Installer).
Public property | HelpText | (inherited from Installer).
Public property | Installers | (inherited from Installer).
Public property | Parent | (inherited from Installer).
Public property | Site | (inherited from Component).

Top

See Also

Reference

ProjectInstaller Class


ProjectInstaller Methods

ProjectInstaller Methods

ProjectInstaller Methods | Previous topic | Next topic
ProjectInstaller Methods | Previous topic | Next topic

Public Methods

 | Name | Description
Public method | Commit | (inherited from Installer).
Public method | CreateObjRef | (inherited from MarshalByRefObject).
Public method | Equals | (Overloaded) (inherited from Object).
Public method | GetHashCode | (inherited from Object).
Public method | GetLifetimeService | (inherited from MarshalByRefObject).
Public method | GetType | (Overloaded) (inherited from Object).
Public method | InitializeLifetimeService | (inherited from MarshalByRefObject).
Public method | Install | (inherited from Installer).
 | ReferenceEquals | (inherited from Object).
Public method | Rollback | (inherited from Installer).
Public method | ToString | (inherited from Component).
Public method | Uninstall | (inherited from Installer).

Top

Protected Methods

 | Name | Description
Supported by the .NET Compact Framework. | Dispose | (Overloaded)
Protected method | Finalize | (inherited from Component).
Protected method | GetService | (inherited from Component).
Protected method | MemberwiseClone | (Overloaded) (inherited from MarshalByRefObject).
Protected method | OnAfterInstall | (inherited from Installer).
Protected method | OnAfterRollback | (inherited from Installer).
Protected method | OnAfterUninstall | (inherited from Installer).
Protected method | OnBeforeInstall | (inherited from Installer).
Protected method | OnBeforeRollback | (inherited from Installer).
Protected method | OnBeforeUninstall | (inherited from Installer).
Protected method | OnCommitted | (inherited from Installer).
Protected method | OnCommitting | (inherited from Installer).

Top

Private, internal (Friend) and internal protected (Protected Friend) Methods

 | Name | Description
Supported by the .NET Compact Framework. | InitializeComponent |

Top

See Also

Reference

ProjectInstaller Class


ProjectInstaller.Dispose Method

ProjectInstaller.Dispose Method

ProjectInstaller.Dispose Method | Previous topic | Next topic
ProjectInstaller.Dispose Method | Previous topic | Next topic

Overload List

Name | Description
Dispose(bool) |
Dispose | (System.ComponentModel.Component).

See Also

Reference

ProjectInstaller Class
ProjectInstaller ProjectInstaller Members


ProjectInstaller.InitializeComponent Method

ProjectInstaller.InitializeComponent Method

ProjectInstaller.InitializeComponent Method | Previous topic | Next topic
ProjectInstaller.InitializeComponent Method | Previous topic | Next topic

Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

<System.Diagnostics.DebuggerStepThrough()> _
Private Sub InitializeComponent()

C#

[System.Diagnostics.DebuggerStepThrough()]
private System.Void InitializeComponent()

C++

[System.Diagnostics.DebuggerStepThrough()]
private:
System::Void InitializeComponent()

JScript

private
System.Diagnostics.DebuggerStepThrough()
function InitializeComponent();

Source code

Visual Basic

Copy Code Copy Code

Private Sub InitializeComponent()
Me.ServiceProcessInstaller1 = New System.ServiceProcess.ServiceProcessInstaller
Me.ServiceInstaller1 = New System.ServiceProcess.ServiceInstaller
'
'ServiceProcessInstaller1
'
Me.ServiceProcessInstaller1.Account = System.ServiceProcess.ServiceAccount.LocalSystem
Me.ServiceProcessInstaller1.Password = Nothing
Me.ServiceProcessInstaller1.Username = Nothing
'
'ServiceInstaller1
'
Me.ServiceInstaller1.DisplayName = "EDKB12WS"
Me.ServiceInstaller1.ServiceName = "EDKB12WS"
'
'ProjectInstaller
'
Me.Installers.AddRange(New System.Configuration.Install.Installer() {Me.ServiceProcessInstaller1, Me.ServiceInstaller1})

End Sub

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

ProjectInstaller Class
ProjectInstaller ProjectInstaller Members


ProjectInstaller Events

ProjectInstaller Events

ProjectInstaller Events | Previous topic | Next topic
ProjectInstaller Events | Previous topic | Next topic

Public Events

 | Name | Description
Public event | AfterInstall | (inherited from Installer).
Public event | AfterRollback | (inherited from Installer).
Public event | AfterUninstall | (inherited from Installer).
Public event | BeforeInstall | (inherited from Installer).
Public event | BeforeRollback | (inherited from Installer).
Public event | BeforeUninstall | (inherited from Installer).
Public event | Committed | (inherited from Installer).
Public event | Committing | (inherited from Installer).
Public event | Disposed | (inherited from Component).

Top

See Also

Reference

ProjectInstaller Class


ProjectInstaller Fields

ProjectInstaller Fields

ProjectInstaller Fields | Previous topic | Next topic
ProjectInstaller Fields | Previous topic | Next topic

Fields

 | Name | Description
Supported by the .NET Compact Framework. | components |

Top

See Also

Reference

ProjectInstaller Class


components Field

components Field

components Field | Previous topic | Next topic
components Field | Previous topic | Next topic

Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private components As IContainer

C#

private IContainer components

C++

private:
IContainer^ components;

JScript

private components : IContainer

Source code

Visual Basic

Copy Code Copy Code

Private components As System.ComponentModel.IContainer

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

ProjectInstaller Class
ProjectInstaller ProjectInstaller Members


Service1 Class

Service1 Class

Service1 Class | Previous topic | Next topic
Service1 Class | Previous topic | Next topic

Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Class Service1
Inherits ServiceBase

C#

public class Service1 : ServiceBase

C++

public ref class Service1 : public ServiceBase^

JScript

public class Service1
extends ServiceBase

Inheritance Hierarchy

System.Object

System.MarshalByRefObject

System.ComponentModel.Component

System.ServiceProcess.ServiceBase

EDKB12WS.Service1

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

Service1 Members


Service1 Members

Service1 Members

Service1 Members | Previous topic | Next topic
Service1 Members | Previous topic | Next topic

The following tables list the members exposed by the Service1 type.

Public Properties

 | Name | Description
Public property | AutoLog | (inherited from ServiceBase).
Public property | CanHandlePowerEvent | (inherited from ServiceBase).
Public property | CanHandleSessionChangeEvent | (inherited from ServiceBase).
Public property | CanPauseAndContinue | (inherited from ServiceBase).
Public property | CanShutdown | (inherited from ServiceBase).
Public property | CanStop | (inherited from ServiceBase).
Public property | Container | (inherited from Component).
Public property | EventLog | (inherited from ServiceBase).
Public property | ExitCode | (inherited from ServiceBase).
Public property | ServiceName | (inherited from ServiceBase).
Public property | Site | (inherited from Component).

Top

Public Methods

 | Name | Description
Supported by the .NET Compact Framework. | CheckTimer_Elapsed |
Public method | CreateObjRef | (inherited from MarshalByRefObject).
Public method | Equals | (Overloaded) (inherited from Object).
Public method | GetHashCode | (inherited from Object).
Public method | GetLifetimeService | (inherited from MarshalByRefObject).
Public method | GetType | (Overloaded) (inherited from Object).
Public method | InitializeLifetimeService | (inherited from MarshalByRefObject).
Supported by the .NET Compact Framework. | Main |
 | ReferenceEquals | (inherited from Object).
Public method | RequestAdditionalTime | (inherited from ServiceBase).
 | Run | (Overloaded) (inherited from ServiceBase).
Public method | ServiceMainCallback | (inherited from ServiceBase).
Public method | Stop | (inherited from ServiceBase).
Public method | ToString | (inherited from Component).

Top

Protected Methods

 | Name | Description
Supported by the .NET Compact Framework. | Dispose | (Overloaded)
Protected method | Finalize | (inherited from Component).
Protected method | GetService | (inherited from Component).
Protected method | MemberwiseClone | (Overloaded) (inherited from MarshalByRefObject).
Protected method | OnContinue | (inherited from ServiceBase).
Protected method | OnCustomCommand | (inherited from ServiceBase).
Protected method | OnPause | (inherited from ServiceBase).
Protected method | OnPowerEvent | (inherited from ServiceBase).
Protected method | OnSessionChange | (inherited from ServiceBase).
Protected method | OnShutdown | (inherited from ServiceBase).
Supported by the .NET Compact Framework. | OnStart | (Overloaded)
Supported by the .NET Compact Framework. | OnStop |

Top

Private, internal (Friend) and internal protected (Protected Friend) Methods

 | Name | Description
Supported by the .NET Compact Framework. | InitializeComponent |

Top

Public Events

 | Name | Description
Public event | Disposed | (inherited from Component).

Top

Fields

 | Name | Description
Supported by the .NET Compact Framework. | RowId |
Supported by the .NET Compact Framework. | Working |
Supported by the .NET Compact Framework. | components |

Top

See Also

Reference

Service1 Class


Service1 Properties

Service1 Properties

Service1 Properties | Previous topic | Next topic
Service1 Properties | Previous topic | Next topic

Public Properties

 | Name | Description
Public property | AutoLog | (inherited from ServiceBase).
Public property | CanHandlePowerEvent | (inherited from ServiceBase).
Public property | CanHandleSessionChangeEvent | (inherited from ServiceBase).
Public property | CanPauseAndContinue | (inherited from ServiceBase).
Public property | CanShutdown | (inherited from ServiceBase).
Public property | CanStop | (inherited from ServiceBase).
Public property | Container | (inherited from Component).
Public property | EventLog | (inherited from ServiceBase).
Public property | ExitCode | (inherited from ServiceBase).
Public property | ServiceName | (inherited from ServiceBase).
Public property | Site | (inherited from Component).

Top

See Also

Reference

Service1 Class


Service1 Methods

Service1 Methods

Service1 Methods | Previous topic | Next topic
Service1 Methods | Previous topic | Next topic

Public Methods

 | Name | Description
Supported by the .NET Compact Framework. | CheckTimer_Elapsed |
Public method | CreateObjRef | (inherited from MarshalByRefObject).
Public method | Equals | (Overloaded) (inherited from Object).
Public method | GetHashCode | (inherited from Object).
Public method | GetLifetimeService | (inherited from MarshalByRefObject).
Public method | GetType | (Overloaded) (inherited from Object).
Public method | InitializeLifetimeService | (inherited from MarshalByRefObject).
Supported by the .NET Compact Framework. | Main |
 | ReferenceEquals | (inherited from Object).
Public method | RequestAdditionalTime | (inherited from ServiceBase).
 | Run | (Overloaded) (inherited from ServiceBase).
Public method | ServiceMainCallback | (inherited from ServiceBase).
Public method | Stop | (inherited from ServiceBase).
Public method | ToString | (inherited from Component).

Top

Protected Methods

 | Name | Description
Supported by the .NET Compact Framework. | Dispose | (Overloaded)
Protected method | Finalize | (inherited from Component).
Protected method | GetService | (inherited from Component).
Protected method | MemberwiseClone | (Overloaded) (inherited from MarshalByRefObject).
Protected method | OnContinue | (inherited from ServiceBase).
Protected method | OnCustomCommand | (inherited from ServiceBase).
Protected method | OnPause | (inherited from ServiceBase).
Protected method | OnPowerEvent | (inherited from ServiceBase).
Protected method | OnSessionChange | (inherited from ServiceBase).
Protected method | OnShutdown | (inherited from ServiceBase).
Supported by the .NET Compact Framework. | OnStart | (Overloaded)
Supported by the .NET Compact Framework. | OnStop |

Top

Private, internal (Friend) and internal protected (Protected Friend) Methods

 | Name | Description
Supported by the .NET Compact Framework. | InitializeComponent |

Top

See Also

Reference

Service1 Class


Service1.CheckTimer_Elapsed Method

Service1.CheckTimer_Elapsed Method

Service1.CheckTimer_Elapsed Method | Previous topic | Next topic
Service1.CheckTimer_Elapsed Method | Previous topic | Next topic

Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Sub CheckTimer_Elapsed( _
ByVal sender As Object, _
ByVal e As ElapsedEventArgs _
) Handles _
CheckTimer.Elapsed

C#

public System.Void CheckTimer_Elapsed(
objectsender,
ElapsedEventArgse
)

C++

public:
System::Void CheckTimer_Elapsed(
object^ sender,
ElapsedEventArgs^ e
)

JScript

public function CheckTimer_Elapsed(
sender : object,
e : ElapsedEventArgs
);

Parameters

sender

e

Source code

Visual Basic

Copy Code Copy Code

Public Sub CheckTimer_Elapsed(ByVal sender As Object, ByVal e As System.Timers.ElapsedEventArgs) Handles CheckTimer.Elapsed
CheckTimer.Enabled = False
rowid = ModMain.Check_pendente_Dokumente()
While RowId > 0
If RowId > 0 Then
ModMain.Generate_Dokument(RowId)
RowId = ModMain.Check_pendente_Dokumente()
End If
End While
CheckTimer.Enabled = True
End Sub

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

Service1 Class
Service1 Service1 Members


Service1.Dispose Method

Service1.Dispose Method

Service1.Dispose Method | Previous topic | Next topic
Service1.Dispose Method | Previous topic | Next topic

Overload List

Name | Description
Dispose(bool) |
Dispose | (System.ComponentModel.Component).

See Also

Reference

Service1 Class
Service1 Service1 Members


Service1.InitializeComponent Method

Service1.InitializeComponent Method

Service1.InitializeComponent Method | Previous topic | Next topic
Service1.InitializeComponent Method | Previous topic | Next topic

Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

<System.Diagnostics.DebuggerStepThrough()> _
Private Sub InitializeComponent()

C#

[System.Diagnostics.DebuggerStepThrough()]
private System.Void InitializeComponent()

C++

[System.Diagnostics.DebuggerStepThrough()]
private:
System::Void InitializeComponent()

JScript

private
System.Diagnostics.DebuggerStepThrough()
function InitializeComponent();

Source code

Visual Basic

Copy Code Copy Code

Private Sub InitializeComponent()
Me.components = New System.ComponentModel.Container
Me.Timer1 = New System.Windows.Forms.Timer(Me.components)
'
'Service1
'
Me.ServiceName = "Service1"

End Sub

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

Service1 Class
Service1 Service1 Members


Service1.Main Method

Service1.Main Method

Service1.Main Method | Previous topic | Next topic
Service1.Main Method | Previous topic | Next topic

Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

<MTAThread()> _
<System.Diagnostics.DebuggerNonUserCode()> _
Public Shared Sub Main()

C#

[MTAThread()]
[System.Diagnostics.DebuggerNonUserCode()]
public static System.Void Main()

C++

[MTAThread()]
[System.Diagnostics.DebuggerNonUserCode()]
public:
static System::Void Main()

JScript

public
MTAThread()
System.Diagnostics.DebuggerNonUserCode()
static function Main();

Source code

Visual Basic

Copy Code Copy Code

Shared Sub Main()
Dim ServicesToRun() As System.ServiceProcess.ServiceBase

' Innerhalb eines Prozesses können mehrere NT-Dienste ausgeführt werden. Um einen
' weiteren Dienst zu diesem Prozess hinzuzufügen, ändern Sie die folgende Zeile,
' um ein zweites Dienstobjekt zu erstellen. Zum Beispiel
'
' ServicesToRun = New System.ServiceProcess.ServiceBase () {New Service1, New MySecondUserService}
'
ServicesToRun = New System.ServiceProcess.ServiceBase() {New Service1}

System.ServiceProcess.ServiceBase.Run(ServicesToRun)
End Sub

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

Service1 Class
Service1 Service1 Members


Service1.OnStart Method

Service1.OnStart Method

Service1.OnStart Method | Previous topic | Next topic
Service1.OnStart Method | Previous topic | Next topic

Overload List

Name | Description
OnStart(String[]) | (System.ServiceProcess.ServiceBase).
OnStart(string[]) |

See Also

Reference

Service1 Class
Service1 Service1 Members


Service1.OnStop Method

Service1.OnStop Method

Service1.OnStop Method | Previous topic | Next topic
Service1.OnStop Method | Previous topic | Next topic

Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Protected Overrides Sub OnStop()

C#

protected override System.Void OnStop()

C++

protected:
System::Void OnStop()

JScript

protected function OnStop();

Source code

Visual Basic

Copy Code Copy Code

Protected Overrides Sub OnStop()
CheckTimer.Stop()
End Sub

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

Service1 Class
Service1 Service1 Members


Service1 Events

Service1 Events

Service1 Events | Previous topic | Next topic
Service1 Events | Previous topic | Next topic

Public Events

 | Name | Description
Public event | Disposed | (inherited from Component).

Top

See Also

Reference

Service1 Class


Service1 Fields

Service1 Fields

Service1 Fields | Previous topic | Next topic
Service1 Fields | Previous topic | Next topic

Fields

 | Name | Description
Supported by the .NET Compact Framework. | RowId |
Supported by the .NET Compact Framework. | Working |
Supported by the .NET Compact Framework. | components |

Top

See Also

Reference

Service1 Class


RowId Field

RowId Field

RowId Field | Previous topic | Next topic
RowId Field | Previous topic | Next topic

Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private RowId As Integer

C#

private int RowId

C++

private:
int RowId;

JScript

private RowId : int

Source code

Visual Basic

Copy Code Copy Code

Dim RowId As Integer

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

Service1 Class
Service1 Service1 Members


Working Field

Working Field

Working Field | Previous topic | Next topic
Working Field | Previous topic | Next topic

Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private Working As Boolean

C#

private bool Working

C++

private:
bool Working;

JScript

private Working : boolean

Source code

Visual Basic

Copy Code Copy Code

Dim Working As Boolean = False

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

Service1 Class
Service1 Service1 Members


components Field

components Field

components Field | Previous topic | Next topic
components Field | Previous topic | Next topic

Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private components As IContainer

C#

private IContainer components

C++

private:
IContainer^ components;

JScript

private components : IContainer

Source code

Visual Basic

Copy Code Copy Code

Private components As System.ComponentModel.IContainer

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

Service1 Class
Service1 Service1 Members


clsDivFnkt Class

clsDivFnkt Class

clsDivFnkt Class | Previous topic | Next topic
clsDivFnkt Class | Previous topic | Next topic

Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Class clsDivFnkt

C#

public class clsDivFnkt

C++

public ref class clsDivFnkt

JScript

public class clsDivFnkt

Inheritance Hierarchy

System.Object

EDKB12WS.clsDivFnkt

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsDivFnkt Members


clsDivFnkt Members

clsDivFnkt Members

clsDivFnkt Members | Previous topic | Next topic
clsDivFnkt Members | Previous topic | Next topic

The following tables list the members exposed by the clsDivFnkt type.

Public Methods

 | Name | Description
Public method | Equals | (Overloaded) (inherited from Object).
Supported by the .NET Compact Framework. | Generate_Key |
Public method | GetHashCode | (inherited from Object).
Public method | GetType | (Overloaded) (inherited from Object).
Supported by the .NET Compact Framework. | InsertJournale |
Supported by the .NET Compact Framework. | Pruefziffer | Berechnung der Prüfziffer nach Modulo9/Rekursiv
 | ReferenceEquals | (inherited from Object).
Public method | ToString | (inherited from Object).

Top

Protected Methods

 | Name | Description
Protected method | Finalize | (inherited from Object).
Protected method | MemberwiseClone | (Overloaded) (inherited from Object).

Top

Private, internal (Friend) and internal protected (Protected Friend) Methods

 | Name | Description
Supported by the .NET Compact Framework. | Send_Message |

Top

Enumerations

 | Name | Description
Supported by the .NET Compact Framework. | Enum_InfoTyp |

Top

Fields

 | Name | Description
Supported by the .NET Compact Framework. | clsjournaleintrag |

Top

See Also

Reference

clsDivFnkt Class


Enum_InfoTyp Enumeration

Enum_InfoTyp Enumeration

Enum_InfoTyp Enumeration | Previous topic | Next topic
Enum_InfoTyp Enumeration | Previous topic | Next topic

Assembly: EDKB12WS (in EDKB12WS.exe)

Members

Member name | Description
Fehler |
Information |
Keine |
Warnung |

Source code

Visual Basic

Copy Code Copy Code

Public Enum Enum_InfoTyp
Keine = 0
Information = 1
Warnung = 2
Fehler = 3
End Enum

See Also

Reference

clsDivFnkt Class
clsDivFnkt clsDivFnkt Members


clsDivFnkt Methods

clsDivFnkt Methods

clsDivFnkt Methods | Previous topic | Next topic
clsDivFnkt Methods | Previous topic | Next topic

Public Methods

 | Name | Description
Public method | Equals | (Overloaded) (inherited from Object).
Supported by the .NET Compact Framework. | Generate_Key |
Public method | GetHashCode | (inherited from Object).
Public method | GetType | (Overloaded) (inherited from Object).
Supported by the .NET Compact Framework. | InsertJournale |
Supported by the .NET Compact Framework. | Pruefziffer | Berechnung der Prüfziffer nach Modulo9/Rekursiv
 | ReferenceEquals | (inherited from Object).
Public method | ToString | (inherited from Object).

Top

Protected Methods

 | Name | Description
Protected method | Finalize | (inherited from Object).
Protected method | MemberwiseClone | (Overloaded) (inherited from Object).

Top

Private, internal (Friend) and internal protected (Protected Friend) Methods

 | Name | Description
Supported by the .NET Compact Framework. | Send_Message |

Top

See Also

Reference

clsDivFnkt Class


clsDivFnkt.Generate_Key Method

clsDivFnkt.Generate_Key Method

clsDivFnkt.Generate_Key Method | Previous topic | Next topic
clsDivFnkt.Generate_Key Method | Previous topic | Next topic

Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Function Generate_Key() As String

C#

public string Generate_Key()

C++

public:
String^ Generate_Key()

JScript

public function Generate_Key() : String;

Source code

Visual Basic

Copy Code Copy Code

Public Function Generate_Key() As String
Dim dbkey As New edokadb.clsMyKey_Tabelle()
Dim key As Long
Dim skey As String
Dim s As String

dbkey.cpMainConnectionProvider = Globals.conn
conn.OpenConnection()
key = dbkey.get_dbkey("dokument")
conn.CloseConnection(True)
skey = "OFFEDK000"

s = Str(Year(Now))
While Microsoft.VisualBasic.Left(s, 1) = " "
s = Microsoft.VisualBasic.Right(s, Len(s) - 1)
End While
skey = skey + s

s = Str(key)
While Microsoft.VisualBasic.Left(s, 1) = " "
s = Microsoft.VisualBasic.Right(s, Len(s) - 1)
End While

While Len(s) < 8
s = "0" + s
End While
skey = skey + s

s = Pruefziffer(Microsoft.VisualBasic.Right(skey, 15))
While Microsoft.VisualBasic.Left(s, 1) = " "
s = Microsoft.VisualBasic.Right(s, Len(s) - 1)
End While
skey = skey + s
Generate_Key = skey
End Function

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsDivFnkt Class
clsDivFnkt clsDivFnkt Members


clsDivFnkt.InsertJournale Method

clsDivFnkt.InsertJournale Method

clsDivFnkt.InsertJournale Method | Previous topic | Next topic
clsDivFnkt.InsertJournale Method | Previous topic | Next topic

Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Sub InsertJournale( _
ByVal Message As String, _
ByVal sTyp As Enum_InfoTyp _
)

C#

public System.Void InsertJournale(
stringMessage,
Enum_InfoTypsTyp
)

C++

public:
System::Void InsertJournale(
String^ Message,
Enum_InfoTypsTyp
)

JScript

public function InsertJournale(
Message : String,
sTyp : Enum_InfoTyp
);

Parameters

Message

sTyp

Source code

Visual Basic

Copy Code Copy Code

Public Sub InsertJournale(ByVal Message As String, ByVal sTyp As Enum_InfoTyp)
If sTyp <> Enum_InfoTyp.Keine Then
End If
clsjournaleintrag.iJournalnr = New SqlInt32(CType(-2, Int32))
clsjournaleintrag.daDatumzeit = New SqlDateTime(CType(Now, DateTime))
clsjournaleintrag.sEintrag = New SqlString(CType(Message, String))
clsjournaleintrag.cpMainConnectionProvider = Globals.connJournale
Console.WriteLine(Message)
Globals.connJournale.OpenConnection()
clsjournaleintrag.Insert()
Globals.connJournale.CloseConnection(True)
If sTyp = Enum_InfoTyp.Fehler Then
Send_Message(Message)
End If
End Sub

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsDivFnkt Class
clsDivFnkt clsDivFnkt Members


clsDivFnkt.Pruefziffer Method

clsDivFnkt.Pruefziffer Method

clsDivFnkt.Pruefziffer Method | Previous topic | Next topic
clsDivFnkt.Pruefziffer Method | Previous topic | Next topic

Berechnung der Prüfziffer nach Modulo9/Rekursiv

Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Function Pruefziffer( _
ByVal zahl As String _
) As String

C#

public string Pruefziffer(
stringzahl
)

C++

public:
String^ Pruefziffer(
String^ zahl
)

JScript

public function Pruefziffer(
zahl : String
) : String;

Parameters

zahl

Dokumentid ohne Präfix

Return Value

DokumentID ohne Präfix (OFFEDK) inkl. Prüfziffer

Source code

Visual Basic

Copy Code Copy Code

Public Function Pruefziffer(ByVal zahl As String) As String
Dim ptab(9, 9) As Integer
Dim pz(9) As Integer
Dim s1, s2, s3 As String

Dim i1, i2 As Long

s1 = "0,9,4,6,8,2,7,1,3,5"
s2 = s1
For i1 = 0 To 9
For i2 = 0 To 9
ptab(i1, i2) = Mid(s2, (i2 * 2) + 1, 1)
Next
s3 = Microsoft.VisualBasic.Left(s1, 1)
s1 = Microsoft.VisualBasic.Right(s1, Len(s1) - 2)
s1 = s1 + "," + s3
s2 = s1
Next
pz(0) = 0
pz(1) = 9
pz(2) = 8
pz(3) = 7
pz(4) = 6
pz(5) = 5
pz(6) = 4
pz(7) = 3
pz(8) = 2
pz(9) = 1

Dim i, x, y As Integer
y = 0
For i = 1 To Len(zahl)
x = Val(Mid(zahl, i, 1))
y = ptab(x, y)
Next
Pruefziffer = Str(pz(y))
End Function

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsDivFnkt Class
clsDivFnkt clsDivFnkt Members
EDKB12.clsDivFnkt


clsDivFnkt.Send_Message Method

clsDivFnkt.Send_Message Method

clsDivFnkt.Send_Message Method | Previous topic | Next topic
clsDivFnkt.Send_Message Method | Previous topic | Next topic

Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private Sub Send_Message( _
ByVal message As String _
)

C#

private System.Void Send_Message(
stringmessage
)

C++

private:
System::Void Send_Message(
String^ message
)

JScript

private function Send_Message(
message : String
);

Parameters

message

Source code

Visual Basic

Copy Code Copy Code

Private Sub Send_Message(ByVal message As String)
Dim betreff As String
Dim meldung As String
betreff = Param.FehlermeldungBetreff
meldung = Param.FehlerMeldungMeldung
meldung = meldung.Replace("#Message#", message)

Dim scmCmdToExecute As SqlCommand = New SqlCommand()
scmCmdToExecute.CommandText = "sp_edkb12_meldung"
scmCmdToExecute.CommandType = CommandType.StoredProcedure
Dim dtToReturn As DataTable = New DataTable()
Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
Try
scmCmdToExecute.Connection = Globals.conn.scoDBConnection
scmCmdToExecute.Parameters.Add(New SqlParameter("@status", SqlDbType.Int, 225, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, -1))
scmCmdToExecute.Parameters.Add(New SqlParameter("@mitarbeiter", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Param.MaNrFehlermeldung))
scmCmdToExecute.Parameters.Add(New SqlParameter("@betreff", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, betreff))
scmCmdToExecute.Parameters.Add(New SqlParameter("@meldung", SqlDbType.VarChar, 1024, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, meldung))
scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, ""))
sdaAdapter.Fill(dtToReturn)
Return
Catch ex As Exception
DivFnkt.InsertJournale("EDKB12::Fehler:: Send_Message::" & ex.Message, clsDivFnkt.Enum_InfoTyp.Fehler)
If Param.DebugMode Then
DivFnkt.InsertJournale("EDKB12: Ende Send_Message (False)::" & ex.Message, clsDivFnkt.Enum_InfoTyp.Information)
End If
Finally
scmCmdToExecute.Dispose()
sdaAdapter.Dispose()
End Try

End Sub

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsDivFnkt Class
clsDivFnkt clsDivFnkt Members


clsDivFnkt Fields

clsDivFnkt Fields

clsDivFnkt Fields | Previous topic | Next topic
clsDivFnkt Fields | Previous topic | Next topic

Fields

 | Name | Description
Supported by the .NET Compact Framework. | clsjournaleintrag |

Top

See Also

Reference

clsDivFnkt Class


clsjournaleintrag Field

clsjournaleintrag Field

clsjournaleintrag Field | Previous topic | Next topic
clsjournaleintrag Field | Previous topic | Next topic

Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private clsjournaleintrag As clsJournaleintrag

C#

private clsJournaleintrag clsjournaleintrag

C++

private:
clsJournaleintrag^ clsjournaleintrag;

JScript

private clsjournaleintrag : clsJournaleintrag

Source code

Visual Basic

Copy Code Copy Code

Dim clsjournaleintrag As New edokaDB.clsJournaleintrag

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsDivFnkt Class
clsDivFnkt clsDivFnkt Members


Globals Class

Globals Class

Globals Class | Previous topic | Next topic
Globals Class | Previous topic | Next topic

Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Friend Module Globals

C#

internal sealed class Globals

C++

private ref class sealed Globals

JScript

internal final class Globals

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

Globals Members


Globals Members

Globals Members

Globals Members | Previous topic | Next topic
Globals Members | Previous topic | Next topic

The following tables list the members exposed by the Globals type.

Public Methods

 | Name | Description
Public method | Equals | (Overloaded) (inherited from Object).
Public method | GetHashCode | (inherited from Object).
Public method | GetType | (Overloaded) (inherited from Object).
Supported by the .NET Compact Framework. | PrintLog |
 | ReferenceEquals | (inherited from Object).
Public method | ToString | (inherited from Object).

Top

Protected Methods

 | Name | Description
Protected method | Finalize | (inherited from Object).
Protected method | MemberwiseClone | (Overloaded) (inherited from Object).

Top

Fields

 | Name | Description
Supported by the .NET Compact Framework. | AppldataRow |
Supported by the .NET Compact Framework. | Applikationsdaten |
Supported by the .NET Compact Framework. | CurrentMitarbeiterdata |
Supported by the .NET Compact Framework. | DivFnkt |
Supported by the .NET Compact Framework. | EVLog |
Supported by the .NET Compact Framework. | Mitarbeiter |
Supported by the .NET Compact Framework. | Param |
Supported by the .NET Compact Framework. | PrintLogType |
Supported by the .NET Compact Framework. | TGNummer |
Supported by the .NET Compact Framework. | conn |
Supported by the .NET Compact Framework. | connJournale |
Supported by the .NET Compact Framework. | objAvaloqDokumentWerte |
Supported by the .NET Compact Framework. | profilnr |
Supported by the .NET Compact Framework. | sConnectionString |

Top

See Also

Reference

Globals Class


Globals Methods

Globals Methods

Globals Methods | Previous topic | Next topic
Globals Methods | Previous topic | Next topic

Public Methods

 | Name | Description
Public method | Equals | (Overloaded) (inherited from Object).
Public method | GetHashCode | (inherited from Object).
Public method | GetType | (Overloaded) (inherited from Object).
Supported by the .NET Compact Framework. | PrintLog |
 | ReferenceEquals | (inherited from Object).
Public method | ToString | (inherited from Object).

Top

Protected Methods

 | Name | Description
Protected method | Finalize | (inherited from Object).
Protected method | MemberwiseClone | (Overloaded) (inherited from Object).

Top

See Also

Reference

Globals Class


Globals.PrintLog Method

Globals.PrintLog Method

Globals.PrintLog Method | Previous topic | Next topic
Globals.PrintLog Method | Previous topic | Next topic

Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Shared Sub PrintLog( _
ByVal message As String, _
Optional ByVal eventmessage As EventLogEntryType = EventLogEntryType.Information _
)

C#

public static System.Void PrintLog(
stringmessage,
EventLogEntryTypeeventmessage = EventLogEntryType.Information
)

C++

public:
static System::Void PrintLog(
String^ message,
EventLogEntryTypeeventmessage
)

JScript

public static function PrintLog(
message : String,
eventmessage : EventLogEntryType
);

Parameters

message

eventmessage

Source code

Visual Basic

Copy Code Copy Code

Public Sub PrintLog(ByVal message As String, Optional ByVal eventmessage As EventLogEntryType = EventLogEntryType.Information)
If Not EventLog.SourceExists("EDKB12") Then
EventLog.CreateEventSource("EDKB12", "EDKB12 Log")
End If
EVLog.Source = "EDKB12 Log"
EventLog.WriteEntry(EVLog.Source, message, eventmessage)
End Sub

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

Globals Class
Globals Globals Members


Globals Fields

Globals Fields

Globals Fields | Previous topic | Next topic
Globals Fields | Previous topic | Next topic

Fields

 | Name | Description
Supported by the .NET Compact Framework. | AppldataRow |
Supported by the .NET Compact Framework. | Applikationsdaten |
Supported by the .NET Compact Framework. | CurrentMitarbeiterdata |
Supported by the .NET Compact Framework. | DivFnkt |
Supported by the .NET Compact Framework. | EVLog |
Supported by the .NET Compact Framework. | Mitarbeiter |
Supported by the .NET Compact Framework. | Param |
Supported by the .NET Compact Framework. | PrintLogType |
Supported by the .NET Compact Framework. | TGNummer |
Supported by the .NET Compact Framework. | conn |
Supported by the .NET Compact Framework. | connJournale |
Supported by the .NET Compact Framework. | objAvaloqDokumentWerte |
Supported by the .NET Compact Framework. | profilnr |
Supported by the .NET Compact Framework. | sConnectionString |

Top

See Also

Reference

Globals Class


AppldataRow Field

AppldataRow Field

AppldataRow Field | Previous topic | Next topic
AppldataRow Field | Previous topic | Next topic

Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Shared AppldataRow As Integer

C#

public static int AppldataRow

C++

public:
static int AppldataRow;

JScript

public static AppldataRow : int

Source code

Visual Basic

Copy Code Copy Code

Public AppldataRow As Integer

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

Globals Class
Globals Globals Members


Applikationsdaten Field

Applikationsdaten Field

Applikationsdaten Field | Previous topic | Next topic
Applikationsdaten Field | Previous topic | Next topic

Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Shared Applikationsdaten As DataTable

C#

public static DataTable Applikationsdaten

C++

public:
static DataTable^ Applikationsdaten;

JScript

public static Applikationsdaten : DataTable

Source code

Visual Basic

Copy Code Copy Code

Public Applikationsdaten As DataTable

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

Globals Class
Globals Globals Members


CurrentMitarbeiterdata Field

CurrentMitarbeiterdata Field

CurrentMitarbeiterdata Field | Previous topic | Next topic
CurrentMitarbeiterdata Field | Previous topic | Next topic

Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Shared CurrentMitarbeiterdata As DataTable

C#

public static DataTable CurrentMitarbeiterdata

C++

public:
static DataTable^ CurrentMitarbeiterdata;

JScript

public static CurrentMitarbeiterdata : DataTable

Source code

Visual Basic

Copy Code Copy Code

Public CurrentMitarbeiterdata As New DataTable()

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

Globals Class
Globals Globals Members


DivFnkt Field

DivFnkt Field

DivFnkt Field | Previous topic | Next topic
DivFnkt Field | Previous topic | Next topic

Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Shared DivFnkt As clsDivFnkt

C#

public static clsDivFnkt DivFnkt

C++

public:
static clsDivFnkt^ DivFnkt;

JScript

public static DivFnkt : clsDivFnkt

Source code

Visual Basic

Copy Code Copy Code

Public DivFnkt As New clsDivFnkt

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

Globals Class
Globals Globals Members


EVLog Field

EVLog Field

EVLog Field | Previous topic | Next topic
EVLog Field | Previous topic | Next topic

Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private Shared EVLog As EventLog

C#

private static EventLog EVLog

C++

private:
static EventLog^ EVLog;

JScript

private static EVLog : EventLog

Source code

Visual Basic

Copy Code Copy Code

Dim EVLog As New EventLog("Log_EDKB07")

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

Globals Class
Globals Globals Members


Mitarbeiter Field

Mitarbeiter Field

Mitarbeiter Field | Previous topic | Next topic
Mitarbeiter Field | Previous topic | Next topic

Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Shared Mitarbeiter As clsMyMitarbeiter

C#

public static clsMyMitarbeiter Mitarbeiter

C++

public:
static clsMyMitarbeiter^ Mitarbeiter;

JScript

public static Mitarbeiter : clsMyMitarbeiter

Source code

Visual Basic

Copy Code Copy Code

Public Mitarbeiter As New edokadb.clsMyMitarbeiter()

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

Globals Class
Globals Globals Members


Param Field

Param Field

Param Field | Previous topic | Next topic
Param Field | Previous topic | Next topic

Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Shared Param As Parameters

C#

public static Parameters Param

C++

public:
static Parameters^ Param;

JScript

public static Param : Parameters

Source code

Visual Basic

Copy Code Copy Code

Public Param As Parameters

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

Globals Class
Globals Globals Members


PrintLogType Field

PrintLogType Field

PrintLogType Field | Previous topic | Next topic
PrintLogType Field | Previous topic | Next topic

Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Shared PrintLogType As EventLogEntryType

C#

public static EventLogEntryType PrintLogType

C++

public:
static EventLogEntryType PrintLogType;

JScript

public static PrintLogType : EventLogEntryType

Source code

Visual Basic

Copy Code Copy Code

Public PrintLogType As EventLogEntryType

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

Globals Class
Globals Globals Members


TGNummer Field

TGNummer Field

TGNummer Field | Previous topic | Next topic
TGNummer Field | Previous topic | Next topic

Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Shared TGNummer As String

C#

public static string TGNummer

C++

public:
static String^ TGNummer;

JScript

public static TGNummer : String

Source code

Visual Basic

Copy Code Copy Code

Public TGNummer As String

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

Globals Class
Globals Globals Members


conn Field

conn Field

conn Field | Previous topic | Next topic
conn Field | Previous topic | Next topic

Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Shared conn As clsConnectionProvider

C#

public static clsConnectionProvider conn

C++

public:
static clsConnectionProvider^ conn;

JScript

public static conn : clsConnectionProvider

Source code

Visual Basic

Copy Code Copy Code

Public conn As New edokadb.clsConnectionProvider()

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

Globals Class
Globals Globals Members


connJournale Field

connJournale Field

connJournale Field | Previous topic | Next topic
connJournale Field | Previous topic | Next topic

Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Shared connJournale As clsConnectionProvider

C#

public static clsConnectionProvider connJournale

C++

public:
static clsConnectionProvider^ connJournale;

JScript

public static connJournale : clsConnectionProvider

Source code

Visual Basic

Copy Code Copy Code

Public connJournale As New edokadb.clsConnectionProvider

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

Globals Class
Globals Globals Members


objAvaloqDokumentWerte Field

objAvaloqDokumentWerte Field

objAvaloqDokumentWerte Field | Previous topic | Next topic
objAvaloqDokumentWerte Field | Previous topic | Next topic

Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Shared objAvaloqDokumentWerte As AvaloqDokumentWerte

C#

public static AvaloqDokumentWerte objAvaloqDokumentWerte

C++

public:
static AvaloqDokumentWerte^ objAvaloqDokumentWerte;

JScript

public static objAvaloqDokumentWerte : AvaloqDokumentWerte

Source code

Visual Basic

Copy Code Copy Code

Public objAvaloqDokumentWerte As New AvaloqDokumentWerte()

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

Globals Class
Globals Globals Members


profilnr Field

profilnr Field

profilnr Field | Previous topic | Next topic
profilnr Field | Previous topic | Next topic

Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Shared profilnr As Integer

C#

public static int profilnr

C++

public:
static int profilnr;

JScript

public static profilnr : int

Source code

Visual Basic

Copy Code Copy Code

Public profilnr As Integer

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

Globals Class
Globals Globals Members


sConnectionString Field

sConnectionString Field

sConnectionString Field | Previous topic | Next topic
sConnectionString Field | Previous topic | Next topic

Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Shared sConnectionString As String

C#

public static string sConnectionString

C++

public:
static String^ sConnectionString;

JScript

public static sConnectionString : String

Source code

Visual Basic

Copy Code Copy Code

Public sConnectionString As String

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

Globals Class
Globals Globals Members


ModMain Class

ModMain Class

ModMain Class | Previous topic | Next topic
ModMain Class | Previous topic | Next topic

Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Friend Module ModMain

C#

internal sealed class ModMain

C++

private ref class sealed ModMain

JScript

internal final class ModMain

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

ModMain Members


ModMain Members

ModMain Members

ModMain Members | Previous topic | Next topic
ModMain Members | Previous topic | Next topic

The following tables list the members exposed by the ModMain type.

Public Methods

 | Name | Description
Supported by the .NET Compact Framework. | Bar25I |
Supported by the .NET Compact Framework. | Bar25Ics |
Supported by the .NET Compact Framework. | COLD_Index_Sichern |
Supported by the .NET Compact Framework. | Check_pendente_Dokumente |
Supported by the .NET Compact Framework. | Dokument_Vervollstaendigen |
Supported by the .NET Compact Framework. | Dokumentwert_Sichern |
Supported by the .NET Compact Framework. | Dokumentwerte_Sichern |
Public method | Equals | (Overloaded) (inherited from Object).
Supported by the .NET Compact Framework. | Generate_Dokument |
Public method | GetHashCode | (inherited from Object).
Public method | GetType | (Overloaded) (inherited from Object).
Supported by the .NET Compact Framework. | Get_Applikationnr |
Supported by the .NET Compact Framework. | IDV_makros_bearbeiten |
Supported by the .NET Compact Framework. | Office_Vorlage_Get_From_DB |
 | ReferenceEquals | (inherited from Object).
Supported by the .NET Compact Framework. | Save_Doc |
Supported by the .NET Compact Framework. | Save_To_DB |
Public method | ToString | (inherited from Object).
Supported by the .NET Compact Framework. | Update_DokumentColdIndexwert |
Supported by the .NET Compact Framework. | Word_Werte_Auslesen |
Supported by the .NET Compact Framework. | convert |
Supported by the .NET Compact Framework. | convert_wordfelder |
Supported by the .NET Compact Framework. | insert_history_status |

Top

Protected Methods

 | Name | Description
Protected method | Finalize | (inherited from Object).
Protected method | MemberwiseClone | (Overloaded) (inherited from Object).

Top

Private, internal (Friend) and internal protected (Protected Friend) Methods

 | Name | Description
Supported by the .NET Compact Framework. | Check_EDK_Data |
Supported by the .NET Compact Framework. | Check_Umfeld |
Supported by the .NET Compact Framework. | Cold_Werte |
Supported by the .NET Compact Framework. | Create_Dokumentstatus |
Supported by the .NET Compact Framework. | Dokument_Erstellen |
Supported by the .NET Compact Framework. | Dokumentdaten_Zusammenstellen |
Supported by the .NET Compact Framework. | Dokumentstatus_erstellen_und_Status_Setzen |
Supported by the .NET Compact Framework. | DokumentwertListe_laden |
Supported by the .NET Compact Framework. | Dokumentwerte |
Supported by the .NET Compact Framework. | Dokumentwerte_Uebertragen |
Supported by the .NET Compact Framework. | FeldMakros |
Supported by the .NET Compact Framework. | Fill_Dokument |
Supported by the .NET Compact Framework. | Generate_Barcodes |
Supported by the .NET Compact Framework. | Generate_Word |
Supported by the .NET Compact Framework. | Get_Dokumentstatus |
Supported by the .NET Compact Framework. | Get_EDK_Data |
Supported by the .NET Compact Framework. | Get_Pendente_EDK_Dokumente |
Supported by the .NET Compact Framework. | Get_Profil |
Supported by the .NET Compact Framework. | Get_Team |
Supported by the .NET Compact Framework. | HeaderFooterAnzeigen |
Supported by the .NET Compact Framework. | Insert_Kopfzeile |
Supported by the .NET Compact Framework. | Insert_TextFelder |
Supported by the .NET Compact Framework. | Send_Message |
Supported by the .NET Compact Framework. | Set_EDK_Status |
Supported by the .NET Compact Framework. | StartWord |
Supported by the .NET Compact Framework. | Update_FANummer |
Supported by the .NET Compact Framework. | delete_Textfelder |
Supported by the .NET Compact Framework. | ins_Barcode |
Supported by the .NET Compact Framework. | insert_Barcode |
Supported by the .NET Compact Framework. | insert_Textfield |
Supported by the .NET Compact Framework. | set_headerbookmark |

Top

Fields

 | Name | Description
Supported by the .NET Compact Framework. | BarTextIn |
Supported by the .NET Compact Framework. | BarTextOut |
Supported by the .NET Compact Framework. | CharValue |
Supported by the .NET Compact Framework. | CheckSum |
Supported by the .NET Compact Framework. | DoCheckSum |
Supported by the .NET Compact Framework. | Dok |
Supported by the .NET Compact Framework. | DokType |
Supported by the .NET Compact Framework. | DokumentFilename |
Supported by the .NET Compact Framework. | Dokumentdaten |
Supported by the .NET Compact Framework. | Dokumentid |
Supported by the .NET Compact Framework. | EDK_Data |
Supported by the .NET Compact Framework. | EDK_Daten |
Supported by the .NET Compact Framework. | FileExtension |
Supported by the .NET Compact Framework. | Filename |
Supported by the .NET Compact Framework. | II |
Supported by the .NET Compact Framework. | IsProtected |
Supported by the .NET Compact Framework. | Mitarbeiter |
Supported by the .NET Compact Framework. | Mitarbeiterdata |
Supported by the .NET Compact Framework. | OfficeVorlage |
Supported by the .NET Compact Framework. | OfficeVorlageDatei |
Supported by the .NET Compact Framework. | Partner |
Supported by the .NET Compact Framework. | Profile |
Supported by the .NET Compact Framework. | Profilnr |
Supported by the .NET Compact Framework. | RowId |
Supported by the .NET Compact Framework. | Sum |
Supported by the .NET Compact Framework. | Teamnr |
Supported by the .NET Compact Framework. | Teams |
Supported by the .NET Compact Framework. | TempString |
Supported by the .NET Compact Framework. | Textboxes |
Supported by the .NET Compact Framework. | Textboxesi |
Supported by the .NET Compact Framework. | Unterschriftlinks |
Supported by the .NET Compact Framework. | Unterschriftrechts |
Supported by the .NET Compact Framework. | args |
Supported by the .NET Compact Framework. | barcodeout |
Supported by the .NET Compact Framework. | tmpAction |
Supported by the .NET Compact Framework. | xMitarbeiter |
Supported by the .NET Compact Framework. | xdata |

Top

See Also

Reference

ModMain Class


ModMain Methods

ModMain Methods

ModMain Methods | Previous topic | Next topic
ModMain Methods | Previous topic | Next topic

Public Methods

 | Name | Description
Supported by the .NET Compact Framework. | Bar25I |
Supported by the .NET Compact Framework. | Bar25Ics |
Supported by the .NET Compact Framework. | COLD_Index_Sichern |
Supported by the .NET Compact Framework. | Check_pendente_Dokumente |
Supported by the .NET Compact Framework. | Dokument_Vervollstaendigen |
Supported by the .NET Compact Framework. | Dokumentwert_Sichern |
Supported by the .NET Compact Framework. | Dokumentwerte_Sichern |
Public method | Equals | (Overloaded) (inherited from Object).
Supported by the .NET Compact Framework. | Generate_Dokument |
Public method | GetHashCode | (inherited from Object).
Public method | GetType | (Overloaded) (inherited from Object).
Supported by the .NET Compact Framework. | Get_Applikationnr |
Supported by the .NET Compact Framework. | IDV_makros_bearbeiten |
Supported by the .NET Compact Framework. | Office_Vorlage_Get_From_DB |
 | ReferenceEquals | (inherited from Object).
Supported by the .NET Compact Framework. | Save_Doc |
Supported by the .NET Compact Framework. | Save_To_DB |
Public method | ToString | (inherited from Object).
Supported by the .NET Compact Framework. | Update_DokumentColdIndexwert |
Supported by the .NET Compact Framework. | Word_Werte_Auslesen |
Supported by the .NET Compact Framework. | convert |
Supported by the .NET Compact Framework. | convert_wordfelder |
Supported by the .NET Compact Framework. | insert_history_status |

Top

Protected Methods

 | Name | Description
Protected method | Finalize | (inherited from Object).
Protected method | MemberwiseClone | (Overloaded) (inherited from Object).

Top

Private, internal (Friend) and internal protected (Protected Friend) Methods

 | Name | Description
Supported by the .NET Compact Framework. | Check_EDK_Data |
Supported by the .NET Compact Framework. | Check_Umfeld |
Supported by the .NET Compact Framework. | Cold_Werte |
Supported by the .NET Compact Framework. | Create_Dokumentstatus |
Supported by the .NET Compact Framework. | Dokument_Erstellen |
Supported by the .NET Compact Framework. | Dokumentdaten_Zusammenstellen |
Supported by the .NET Compact Framework. | Dokumentstatus_erstellen_und_Status_Setzen |
Supported by the .NET Compact Framework. | DokumentwertListe_laden |
Supported by the .NET Compact Framework. | Dokumentwerte |
Supported by the .NET Compact Framework. | Dokumentwerte_Uebertragen |
Supported by the .NET Compact Framework. | FeldMakros |
Supported by the .NET Compact Framework. | Fill_Dokument |
Supported by the .NET Compact Framework. | Generate_Barcodes |
Supported by the .NET Compact Framework. | Generate_Word |
Supported by the .NET Compact Framework. | Get_Dokumentstatus |
Supported by the .NET Compact Framework. | Get_EDK_Data |
Supported by the .NET Compact Framework. | Get_Pendente_EDK_Dokumente |
Supported by the .NET Compact Framework. | Get_Profil |
Supported by the .NET Compact Framework. | Get_Team |
Supported by the .NET Compact Framework. | HeaderFooterAnzeigen |
Supported by the .NET Compact Framework. | Insert_Kopfzeile |
Supported by the .NET Compact Framework. | Insert_TextFelder |
Supported by the .NET Compact Framework. | Send_Message |
Supported by the .NET Compact Framework. | Set_EDK_Status |
Supported by the .NET Compact Framework. | StartWord |
Supported by the .NET Compact Framework. | Update_FANummer |
Supported by the .NET Compact Framework. | delete_Textfelder |
Supported by the .NET Compact Framework. | ins_Barcode |
Supported by the .NET Compact Framework. | insert_Barcode |
Supported by the .NET Compact Framework. | insert_Textfield |
Supported by the .NET Compact Framework. | set_headerbookmark |

Top

See Also

Reference

ModMain Class


ModMain.Bar25I Method

ModMain.Bar25I Method

ModMain.Bar25I Method | Previous topic | Next topic
ModMain.Bar25I Method | Previous topic | Next topic

Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Shared Function Bar25I( _
ByVal BarTextIn As String _
) As String

C#

public static string Bar25I(
stringBarTextIn
)

C++

public:
static String^ Bar25I(
String^ BarTextIn
)

JScript

public static function Bar25I(
BarTextIn : String
) : String;

Parameters

BarTextIn

Source code

Visual Basic

Copy Code Copy Code

Public Function Bar25I(ByVal BarTextIn As String) As String

' Initialize input and output strings
BarTextOut = ""
BarTextIn = RTrim(LTrim(BarTextIn))

' Throw away non-numeric data
TempString = ""
For II = 1 To Len(BarTextIn)
If IsNumeric(Mid(BarTextIn, II, 1)) Then
TempString = TempString & Mid(BarTextIn, II, 1)
End If
Next II

' If not an even number of digits, add a leading 0
If (Len(TempString) Mod 2) = 1 Then
TempString = "0" & TempString
End If

' Break digit pairs up and convert to characters- build output string
For II = 1 To Len(TempString) Step 2
'Break string into pairs of digits and get value
CharValue = Mid(TempString, II, 2)
'translate value to ASCII and save in BarTextOut
If CharValue < 90 Then
BarTextOut = BarTextOut & Chr(CharValue + 33)
Else
BarTextOut = BarTextOut & Chr(CharValue + 71)
End If
Next II

'Build ouput string, trailing space for Windows rasterization bug
barcodeout = "{" & BarTextOut & "} "

'Return the string
Bar25I = barcodeout

End Function

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

ModMain Class
ModMain ModMain Members


ModMain.Bar25Ics Method

ModMain.Bar25Ics Method

ModMain.Bar25Ics Method | Previous topic | Next topic
ModMain.Bar25Ics Method | Previous topic | Next topic

Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Shared Function Bar25Ics( _
ByVal BarTextIn As String _
) As String

C#

public static string Bar25Ics(
stringBarTextIn
)

C++

public:
static String^ Bar25Ics(
String^ BarTextIn
)

JScript

public static function Bar25Ics(
BarTextIn : String
) : String;

Parameters

BarTextIn

Source code

Visual Basic

Copy Code Copy Code

Public Function Bar25Ics(ByVal BarTextIn As String) As String

' Initialize input and output strings
BarTextOut = ""
BarTextIn = RTrim(LTrim(BarTextIn))

' Throw away non-numeric data
TempString = ""
For II = 1 To Len(BarTextIn)
If IsNumeric(Mid(BarTextIn, II, 1)) Then
TempString = TempString & Mid(BarTextIn, II, 1)
End If
Next II

' If not an odd number of digits, add a leading 0
If (Len(TempString) Mod 2) = 0 Then
TempString = "0" & TempString
End If

' Figure out the checksum digit
Sum = 0
For II = 1 To Len(TempString)
CharValue = Mid(TempString, II, 1)
If (II Mod 2) = 1 Then
Sum = Sum + (3 * CharValue)
Else
Sum = Sum + CharValue
End If
Next II

' Figure checksum, add it as last digit
CheckSum = 10 - (Sum Mod 10)
If CheckSum = 10 Then CheckSum = 0
TempString = TempString & Chr(48 + CheckSum)

' Break digit pairs up and convert to characters- build output string
For II = 1 To Len(TempString) Step 2
'Break string into pairs of digits and get value
CharValue = Mid(TempString, II, 2)
'translate value to ASCII and save in BarTextOut
If CharValue < 90 Then
BarTextOut = BarTextOut & Chr(CharValue + 33)
Else
BarTextOut = BarTextOut & Chr(CharValue + 71)
End If
Next II

'Build ouput string, trailing space for Windows rasterization bug
barcodeout = "{" & BarTextOut & "} "

'Return the string
Bar25Ics = barcodeout

End Function

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

ModMain Class
ModMain ModMain Members


ModMain.COLD_Index_Sichern Method

ModMain.COLD_Index_Sichern Method

ModMain.COLD_Index_Sichern Method | Previous topic | Next topic
ModMain.COLD_Index_Sichern Method | Previous topic | Next topic

Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Shared Function COLD_Index_Sichern( _
ByVal indextyp As Integer, _
ByVal dokumentid As String _
) As DataTable

C#

public static DataTable COLD_Index_Sichern(
intindextyp,
stringdokumentid
)

C++

public:
static DataTable^ COLD_Index_Sichern(
intindextyp,
String^ dokumentid
)

JScript

public static function COLD_Index_Sichern(
indextyp : int,
dokumentid : String
) : DataTable;

Parameters

indextyp

dokumentid

Source code

Visual Basic

Copy Code Copy Code

Public Function COLD_Index_Sichern(ByVal indextyp As Integer, ByVal dokumentid As String) As System.Data.DataTable
If Param.DebugMode Then
DivFnkt.InsertJournale("EDKB12: Start COLD_Index_Sichern", clsDivFnkt.Enum_InfoTyp.Information)
End If
Dim scmCmdToExecute As SqlCommand = New SqlCommand()
scmCmdToExecute.CommandText = "dbo.SP_Dokument_Cold_Index"
scmCmdToExecute.CommandType = CommandType.StoredProcedure
Dim dtToReturn As System.Data.DataTable = New System.Data.DataTable()
Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
scmCmdToExecute.Connection = Globals.conn.scoDBConnection
Try
scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, dokumentid))
scmCmdToExecute.Parameters.Add(New SqlParameter("@indextyp", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, indextyp))
sdaAdapter.Fill(dtToReturn)

If Param.DebugMode Then
DivFnkt.InsertJournale("EDKB12: Ende COLD_Index_Sichern (True)", clsDivFnkt.Enum_InfoTyp.Information)
End If

Return dtToReturn
Catch ex As Exception
DivFnkt.InsertJournale("EDKB12::Fehler:: COLD_Index_Sichern::" & ex.Message, clsDivFnkt.Enum_InfoTyp.Fehler)
If Param.DebugMode Then
DivFnkt.InsertJournale("EDKB12: Ende COLD_Index_Sichern (False)::" & ex.Message, clsDivFnkt.Enum_InfoTyp.Information)
End If
Finally
scmCmdToExecute.Dispose()
sdaAdapter.Dispose()
End Try
End Function

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

ModMain Class
ModMain ModMain Members


ModMain.Check_EDK_Data Method

ModMain.Check_EDK_Data Method

ModMain.Check_EDK_Data Method | Previous topic | Next topic
ModMain.Check_EDK_Data Method | Previous topic | Next topic

Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private Shared Function Check_EDK_Data() As Boolean

C#

private static bool Check_EDK_Data()

C++

private:
static bool Check_EDK_Data()

JScript

private static function Check_EDK_Data() : boolean;

Source code

Visual Basic

Copy Code Copy Code

Private Function Check_EDK_Data() As Boolean
If Param.DebugMode Then
DivFnkt.InsertJournale("EDKB12: Start Check_EDK_Data", clsDivFnkt.Enum_InfoTyp.Information)
End If
Try
'File Checken
Dim file As New IO.FileInfo(Filename)
tmpAction = New Action
If Not tmpAction.Load(file) Then
Return False
End If
objAvaloqDokumentWerte.init(file)

If Param.DebugMode Then
DivFnkt.InsertJournale("EDKB12: Ende Check_EDK_Data (True)", clsDivFnkt.Enum_InfoTyp.Information)
End If

Return True
Catch ex As Exception
DivFnkt.InsertJournale("EDKB12::Fehler:: Check_EDK_Data::" & ex.Message, clsDivFnkt.Enum_InfoTyp.Fehler)
If Param.DebugMode Then
DivFnkt.InsertJournale("EDKB12: Ende Check_EDK_Data (False)::" & ex.Message, clsDivFnkt.Enum_InfoTyp.Information)
End If
Return False
End Try

End Function

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

ModMain Class
ModMain ModMain Members


ModMain.Check_Umfeld Method

ModMain.Check_Umfeld Method

ModMain.Check_Umfeld Method | Previous topic | Next topic
ModMain.Check_Umfeld Method | Previous topic | Next topic

Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private Shared Function Check_Umfeld() As Boolean

C#

private static bool Check_Umfeld()

C++

private:
static bool Check_Umfeld()

JScript

private static function Check_Umfeld() : boolean;

Source code

Visual Basic

Copy Code Copy Code

Private Function Check_Umfeld() As Boolean
If Param.DebugMode Then
DivFnkt.InsertJournale("EDKB12: Start Check_Umfeld", clsDivFnkt.Enum_InfoTyp.Information)
End If

Try
If Param.DebugMode Then
DivFnkt.InsertJournale("EDKB12: Start Check_Umfeld::Mitarbeiter", clsDivFnkt.Enum_InfoTyp.Information)
End If

xMitarbeiter.xtgnummer = tmpAction.GetParameterByName("creatorTg").Value
Mitarbeiter.cpMainConnectionProvider = Globals.conn
conn.OpenConnection()
xMitarbeiter.cpMainConnectionProvider = Globals.conn
Mitarbeiterdata = xMitarbeiter.SelectWithTGNummer()
conn.CloseConnection(True)

Mitarbeiter.cpMainConnectionProvider = Globals.conn
conn.OpenConnection()
Mitarbeiter.iMitarbeiternr = New SqlInt32(Mitarbeiterdata.Rows(0).Item("Mitarbeiternr"))
Mitarbeiter.SelectOne()
conn.CloseConnection(True)

If Param.DebugMode Then
DivFnkt.InsertJournale("EDKB12: Start Check_Umfeld::Dokumenttyp", clsDivFnkt.Enum_InfoTyp.Information)
End If
DokType.cpMainConnectionProvider = Globals.conn
conn.OpenConnection()
DokType.iDokumenttypnr = New SqlInt32(tmpAction.GetParameterByName("DokumentTypNr").Value - 900000000)
DokType.SelectOne()
conn.CloseConnection(True)

If Param.DebugMode Then
DivFnkt.InsertJournale("EDKB12: Start Check_Umfeld::Partner", clsDivFnkt.Enum_InfoTyp.Information)
End If

Partner.cpMainConnectionProvider = Globals.conn
conn.OpenConnection()
Partner.iNRPAR00 = New SqlInt32(tmpAction.GetParameterByName("PartnerNr").Value)
Partner.SelectOne()
conn.CloseConnection(True)

If Param.DebugMode Then
DivFnkt.InsertJournale("EDKB12: Start Check_Umfeld::Office-Vorlage", clsDivFnkt.Enum_InfoTyp.Information)
End If
OfficeVorlage.cpMainConnectionProvider = Globals.conn
conn.OpenConnection()
OfficeVorlage.iOffice_vorlagenr = New SqlInt32(DokType.iOffice_vorlagenr.Value)
OfficeVorlage.SelectOne()
conn.CloseConnection(True)

If Param.DebugMode Then
DivFnkt.InsertJournale("EDKB12: Start Check_Umfeld::Auslesen Office-Vorlage", clsDivFnkt.Enum_InfoTyp.Information)
End If

'Office 2010
If Param.DebugMode Then
DivFnkt.InsertJournale("EDKB12: Start Check_Umfeld::Param.CheckOffice2010_Vorlage:" + Param.CheckOffice2010_Vorlage.ToString, clsDivFnkt.Enum_InfoTyp.Information)
End If
If Param.CheckOffice2010_Vorlage = True Then
Dim applnr As Integer = Get_Applikationnr(OfficeVorlage.iOffice_vorlagenr.Value)
DivFnkt.InsertJournale("EDKB12: Start Check_Umfeld::Appl-Nr:" + applnr.ToString, clsDivFnkt.Enum_InfoTyp.Information)
Select Case applnr
Case 0
FileExtension = ".doc"
Case 1
FileExtension = ".doc"
Case 2
FileExtension = ".xls"
Case 3
FileExtension = ".pdf"
Case 4
FileExtension = ".docx"
Case 5
FileExtension = ".docm"
Case 6
FileExtension = ".dotx"
Case 7
FileExtension = ".dotm"
Case 8
FileExtension = ".xlsx"
Case 9
FileExtension = ".xlsm"
Case 10
FileExtension = ".xltx"
Case 11
FileExtension = ".xltm"
End Select
Else

Select Case OfficeVorlage.iAnwendungnr.Value
Case 0
FileExtension = ".doc"
Case 1
FileExtension = ".doc"
Case 2
FileExtension = ".xls"
Case 3
FileExtension = ".pdf"
Case 4
FileExtension = ".docx"
Case 5
FileExtension = ".docm"
Case 6
FileExtension = ".dotx"
Case 7
FileExtension = ".dotm"
Case 8
FileExtension = ".xlsx"
Case 9
FileExtension = ".xlsm"
Case 10
FileExtension = ".xltx"
Case 11
FileExtension = ".xltm"
End Select

End If

If Param.DebugMode Then
DivFnkt.InsertJournale("EDKB12: Start Check_Umfeld:: Office_Voralge: " + OfficeVorlage.iOffice_vorlagenr.Value.ToString, clsDivFnkt.Enum_InfoTyp.Information)
DivFnkt.InsertJournale("EDKB12: Start Check_Umfeld:: Dokumenttyp: " + FileExtension, clsDivFnkt.Enum_InfoTyp.Information)
End If

If Office_Vorlage_Get_From_DB(OfficeVorlage.iOffice_vorlagenr.Value, Filename + FileExtension) = "" Then
Return False
End If
DokumentFilename = Filename + FileExtension

If Param.DebugMode Then
DivFnkt.InsertJournale("EDKB12: Start Check_Umfeld::Profil", clsDivFnkt.Enum_InfoTyp.Information)
End If

Profile = Get_Profil(Mitarbeiter.iMitarbeiternr.Value)
If Profile.Rows.Count < 1 Then
Profilnr = 0
Unterschriftlinks = 0
Unterschriftrechts = 0
Else
Profilnr = Profile.Rows(0).Item("Profilnr")
Unterschriftlinks = Profile.Rows(0).Item("Unterschriftlinks")
Unterschriftrechts = Profile.Rows(0).Item("Unterschriftrechts")
End If
Profile.Dispose()

If Param.DebugMode Then
DivFnkt.InsertJournale("EDKB12: Start Check_Umfeld::Teams", clsDivFnkt.Enum_InfoTyp.Information)
End If

Teams = Get_Team(Profilnr)
If Teams.Rows.Count = 0 Then
teamnr = 0
Else
teamnr = Teams.Rows(0).Item("Teamnr")
End If
Teams.Dispose()

If Param.DebugMode Then
DivFnkt.InsertJournale("EDKB12: Ende Check_Umfeld (True)", clsDivFnkt.Enum_InfoTyp.Information)
End If
Return True
Catch ex As Exception
DivFnkt.InsertJournale("EDKB12::Fehler:: Check_Umfeld::" & ex.Message, clsDivFnkt.Enum_InfoTyp.Fehler)
If Param.DebugMode Then
DivFnkt.InsertJournale("EDKB12: Ende Check_Umfeld (False)::" & ex.Message, clsDivFnkt.Enum_InfoTyp.Information)
End If

Return False
End Try
End Function

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

ModMain Class
ModMain ModMain Members


ModMain.Check_pendente_Dokumente Method

ModMain.Check_pendente_Dokumente Method

ModMain.Check_pendente_Dokumente Method | Previous topic | Next topic
ModMain.Check_pendente_Dokumente Method | Previous topic | Next topic

Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Shared Function Check_pendente_Dokumente() As Integer

C#

public static int Check_pendente_Dokumente()

C++

public:
static int Check_pendente_Dokumente()

JScript

public static function Check_pendente_Dokumente() : int;

Source code

Visual Basic

Copy Code Copy Code

Public Function Check_pendente_Dokumente() As Integer
'20080918 Version 12 SHU
'Im Fehlerfall mit -99 aus der Routine aussteigen
Try
EDK_Daten = Get_Pendente_EDK_Dokumente()
If EDK_Daten.Rows.Count < 1 Then
Return 0
End If
Dim rid As Integer = EDK_Daten.Rows(0).Item("RowId")
EDK_Daten.Dispose()
Return rid
Catch ex As Exception
Return -99
End Try

End Function

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

ModMain Class
ModMain ModMain Members


ModMain.Cold_Werte Method

ModMain.Cold_Werte Method

ModMain.Cold_Werte Method | Previous topic | Next topic
ModMain.Cold_Werte Method | Previous topic | Next topic

Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private Shared Function Cold_Werte( _
ByVal dokumenttypnr As Integer _
) As DataTable

C#

private static DataTable Cold_Werte(
intdokumenttypnr
)

C++

private:
static DataTable^ Cold_Werte(
intdokumenttypnr
)

JScript

private static function Cold_Werte(
dokumenttypnr : int
) : DataTable;

Parameters

dokumenttypnr

Source code

Visual Basic

Copy Code Copy Code

Private Function Cold_Werte(ByVal dokumenttypnr As Integer) As System.Data.DataTable
If Param.DebugMode Then
DivFnkt.InsertJournale("EDKB12: Start Cold_Werte", clsDivFnkt.Enum_InfoTyp.Information)
End If

Dim scmCmdToExecute As SqlCommand = New SqlCommand()
scmCmdToExecute.CommandText = "sp_archiv_getschema_doc"
scmCmdToExecute.CommandType = CommandType.StoredProcedure
Dim dtToReturn As System.Data.DataTable = New System.Data.DataTable()
Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
Try
scmCmdToExecute.Connection = Globals.conn.scoDBConnection
scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumenttypnr", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, dokumenttypnr))
sdaAdapter.Fill(dtToReturn)
If Param.DebugMode Then
DivFnkt.InsertJournale("EDKB12: Ende Cold_Werte(True)", clsDivFnkt.Enum_InfoTyp.Information)
End If

Return dtToReturn
Catch ex As Exception
DivFnkt.InsertJournale("EDKB12::Fehler:: Cold_Werte::" & ex.Message, clsDivFnkt.Enum_InfoTyp.Fehler)
If Param.DebugMode Then
DivFnkt.InsertJournale("EDKB12: Ende Cold_Werte (False)::" & ex.Message, clsDivFnkt.Enum_InfoTyp.Information)
End If
Finally
scmCmdToExecute.Dispose()
sdaAdapter.Dispose()
End Try
End Function

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

ModMain Class
ModMain ModMain Members


ModMain.Create_Dokumentstatus Method

ModMain.Create_Dokumentstatus Method

ModMain.Create_Dokumentstatus Method | Previous topic | Next topic
ModMain.Create_Dokumentstatus Method | Previous topic | Next topic

Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private Shared Function Create_Dokumentstatus( _
Optional ByVal blkunde As Integer = 0 _
) As DataTable

C#

private static DataTable Create_Dokumentstatus(
intblkunde = 0
)

C++

private:
static DataTable^ Create_Dokumentstatus(
intblkunde
)

JScript

private static function Create_Dokumentstatus(
blkunde : int
) : DataTable;

Parameters

blkunde

Source code

Visual Basic

Copy Code Copy Code

Private Function Create_Dokumentstatus(Optional ByVal blkunde As Integer = 0) As System.Data.DataTable
If Param.DebugMode Then
DivFnkt.InsertJournale("EDKB12: Start Create_Dokumentstatus", clsDivFnkt.Enum_InfoTyp.Information)
End If
Dim scmCmdToExecute As SqlCommand = New SqlCommand()
Dim dtToReturn As System.Data.DataTable = New System.Data.DataTable()
Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
scmCmdToExecute.CommandText = "dbo.sp_dokumentberabeigung_status_erstellen"
scmCmdToExecute.CommandType = CommandType.StoredProcedure
scmCmdToExecute.Connection = Globals.conn.scoDBConnection
Try
scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Dokumentid))
scmCmdToExecute.Parameters.Add(New SqlParameter("@bck", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, 0))
If blkunde = 0 Then
scmCmdToExecute.Parameters.Add(New SqlParameter("@blsequenz", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, 0))
Else
scmCmdToExecute.Parameters.Add(New SqlParameter("@blsequenz", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, 1))
End If
sdaAdapter.Fill(dtToReturn)
If Param.DebugMode Then
DivFnkt.InsertJournale("EDKB12: Ende Create_Dokumentstatus (True)", clsDivFnkt.Enum_InfoTyp.Information)
End If

Return dtToReturn
Catch ex As Exception
DivFnkt.InsertJournale("EDKB12::Fehler:: Create_Dokumentstatus::" & ex.Message, clsDivFnkt.Enum_InfoTyp.Fehler)
If Param.DebugMode Then
DivFnkt.InsertJournale("EDKB12: Ende Create_Dokumentstatus (False)::" & ex.Message, clsDivFnkt.Enum_InfoTyp.Information)
End If
Finally
Globals.conn.CloseConnection(True)
scmCmdToExecute.Dispose()
sdaAdapter.Dispose()
End Try
End Function

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

ModMain Class
ModMain ModMain Members


ModMain.Dokument_Erstellen Method

ModMain.Dokument_Erstellen Method

ModMain.Dokument_Erstellen Method | Previous topic | Next topic
ModMain.Dokument_Erstellen Method | Previous topic | Next topic

Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private Shared Function Dokument_Erstellen() As Object

C#

private static object Dokument_Erstellen()

C++

private:
static object^ Dokument_Erstellen()

JScript

private static function Dokument_Erstellen() : object;

Source code

Visual Basic

Copy Code Copy Code

Private Function Dokument_Erstellen()
If Param.DebugMode Then
DivFnkt.InsertJournale("EDKB12: Start Dokument_Erstellen", clsDivFnkt.Enum_InfoTyp.Information)
End If
Try
Dok.cpMainConnectionProvider = Globals.conn
Dokumentid = Globals.DivFnkt.Generate_Key
Dok.sDokumentid = New SqlString(CType(Dokumentid, String))

'***************************************************************************************************************3
'Defaultwerte für das Dokument
'***************************************************************************************************************3
Dok.bAktiv = New SqlBoolean(True)
Dok.bAmsdokument = New SqlBoolean(CType(False, Boolean))
Dok.bAuserstuebernahme = New SqlBoolean(CType(False, Boolean))
Dok.bAusgangsarchiviert = New SqlBoolean(CType(False, Boolean))
Dok.iStatus_edoka_batch_ausgang = Nothing
Dok.daTermin = New SqlDateTime(CType("01.01.1900", DateTime))
Dok.bBereit_zur_archivierung = New SqlBoolean(CType(True, Boolean))
Dok.bEingangsarchiviert = New SqlBoolean(CType(False, Boolean))
Dok.bGesperrt = New SqlBoolean(CType(False, Boolean))
Dok.bUnvollstaendig = New SqlBoolean(CType(False, Boolean))
Dok.iBck = New SqlInt32(CType(1, Int32))
Dok.iColdstatus = New SqlInt32(CType(0, Int32))
Dok.iUnterschriftlinks = New SqlInt32(CType(Unterschriftlinks, Int32))
Dok.iUnterschriftrechts = New SqlInt32(CType(Unterschriftrechts, Int32))
Dok.iVerantwortlich = New SqlInt32(CType(Mitarbeiter.iMitarbeiternr.Value, Int32))
Dok.bVertraulich = New SqlBoolean(CType(False, Boolean))
Dok.sZustelladresse = New SqlString(CType("", String))
Dok.sAnredezustelladresse = New SqlString(CType("", String))
Dok.iZustaendiger = New SqlInt32(CType(Mitarbeiter.iMitarbeiternr.Value, Int32))
Dok.iPostzustellung = New SqlInt32(CType(0, Int32))
Dok.bZustaendig_kube = New SqlBoolean(CType(0, Boolean))
Dok.iMa_ausgangsarchivierung = New SqlInt32(CType(0, Int32))
Dok.iMa_eingangsarchivierung = New SqlInt32(CType(0, Int32))
Dok.sBemerkung = New SqlString(CType("", String))
Dok.sColddokumentid = New SqlString(CType("", String))
Dok.iDokdurchkubeweitergegeben = New SqlInt32(CType(0, Int32))
Dok.sBedRDokumentid = New SqlString(CType("", String))
Dok.bBldossier = New SqlBoolean(CType(False, Boolean))

'***************************************************************************************************************3
'Werte aus Dokumenttyp
'***************************************************************************************************************3
Dok.iDokumenttypnr = New SqlInt32(CType(DokType.iDokumenttypnr.Value, Int32))
Dok.bZu_retournieren = New SqlBoolean(CType(DokType.bZu_retournieren.Value, Boolean))
Dok.iAufbewahrung_elektronisch = New SqlInt32(CType(DokType.iAufbewahrungsfrist_elektronisch.Value, Int32))
Dok.iAufbewahrung_phaysisch = New SqlInt32(CType(DokType.iAufbewahrungsfrist_physisch.Value, Int32))
Dok.iBearbeitung_nach_abschluss = New SqlInt32(CType(DokType.iTage_mutation.Value, Int32))
Dok.iBearbeitungszeit_in_minuten = New SqlInt32(CType(DokType.iDbearbeitungszeit.Value, Int32))
Dok.iMonierung_in_tagen = New SqlInt32(CType(DokType.iAnzahl_tage.Value, Int32))
Dok.sBezeichnung = New SqlString(CType(DokType.sBezeichnung.Value, String))

'***************************************************************************************************************3
'Werte aus der Schnittstelle bzw. Defaultwerte
'***************************************************************************************************************3
Dok.iNrpar00 = New SqlInt32(CType(Partner.iNRPAR00.Value, Int32))
Dok.daArchivierungsdatum = New SqlDateTime(CType(Now, DateTime))

'Ersteller und Mutierer
Dok.iErsteller = New SqlInt32(CType(Mitarbeiter.iMitarbeiternr.Value, Int32))
Dok.iMutierer = Dok.iErsteller
Dok.iMitarbeiternr = Dok.iErsteller

'Erstellungs- und Mutationsdatum
Dok.daMutiertam = New SqlDateTime(CType(Now, DateTime))
Dok.daErstelltam = New SqlDateTime(CType(Now, DateTime))

Dok.iMutierertieam = New SqlInt32(CType(Teamnr, Int32))
Dok.iErstellerteam = New SqlInt32(CType(Teamnr, Int32))
Dok.daErstellungsdatum = New SqlDateTime(CType(Dok.daArchivierungsdatum.Value, DateTime))
Dok.sDokumentname = New SqlString(CType(OfficeVorlage.sPrefix_dokumentname.Value + Dokumentid + FileExtension, String))
Dok.iAnzeigeStatus = New SqlInt32(CType(0, Int32))
conn.OpenConnection()
Dok.Insert()
conn.CloseConnection(True)

Dim t As System.Data.DataTable
Try
t = Cold_Werte(Dok.iDokumenttypnr.Value)
Dok.sColdfolder = New SqlString(CType(t.Rows(0).Item(0), String))
Dok.sColdschema = New SqlString(CType(t.Rows(0).Item(1), String))
Globals.conn.OpenConnection()
Dok.Update()
Globals.conn.CloseConnection(True)
Catch
End Try

'FANummerin im EDOKA-Dokumentaktualisieren
Update_FANummer(tmpAction.GetParameterByName("fanummer3").Value)
Dok.SelectOne()

'Cold_index erstellen
COLD_Index_Sichern(1, Dokumentid)
If Dok.bZu_retournieren.Value = True Then
COLD_Index_Sichern(2, Dokumentid)
End If

'VVNummer im COLDIndex aktualisieren, sofern als Indexwert übergeben

Dok.iStatusnr = New SqlInt32(CType(Dokumentstatus_erstellen_und_Status_Setzen(Dokumentid, True, 0), Int32))
'Dokumentstatus erstelln und Statushistory_eintragen
'dok.iStatusnr = New SqlInt32(CType(Dokumentstatus_erstellen_und_Status_Setzen(datarow, True), Int32))

'Dokument auf der Datenbank speichern
'Abhängig vom entsprechenden Status, wird das Flag, bereit zur Ausgangsarchivierung wieder entfernt

Globals.conn.OpenConnection()
Dok.Update()
Globals.conn.CloseConnection(True)

If Param.DebugMode Then
DivFnkt.InsertJournale("EDKB12: Ende Dokument_Erstellen (True)", clsDivFnkt.Enum_InfoTyp.Information)
End If

Return True
Catch ex As Exception
DivFnkt.InsertJournale("EDKB12::Fehler:: Dokument_Erstellen::" & ex.Message, clsDivFnkt.Enum_InfoTyp.Fehler)
If Param.DebugMode Then
DivFnkt.InsertJournale("EDKB12: Ende Dokument_Erstellen (False)::" & ex.Message, clsDivFnkt.Enum_InfoTyp.Information)
End If
Return False
End Try
End Function

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

ModMain Class
ModMain ModMain Members


ModMain.Dokument_Vervollstaendigen Method

ModMain.Dokument_Vervollstaendigen Method

ModMain.Dokument_Vervollstaendigen Method | Previous topic | Next topic
ModMain.Dokument_Vervollstaendigen Method | Previous topic | Next topic

Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Shared Function Dokument_Vervollstaendigen( _
ByVal xdata As DataTable _
) As Boolean

C#

public static bool Dokument_Vervollstaendigen(
DataTablexdata
)

C++

public:
static bool Dokument_Vervollstaendigen(
DataTable^ xdata
)

JScript

public static function Dokument_Vervollstaendigen(
xdata : DataTable
) : boolean;

Parameters

xdata

Source code

Visual Basic

Copy Code Copy Code

Public Function Dokument_Vervollstaendigen(ByVal xdata As System.Data.DataTable) As Boolean
If Param.DebugMode Then
DivFnkt.InsertJournale("EDKB12: Start Dokument_Vervollstaendigen", clsDivFnkt.Enum_InfoTyp.Information)
End If

Try

If docword.ProtectionType <> WdProtectionType.wdNoProtection Then
docword.Unprotect(Password:=Globals.Applikationsdaten.Rows(Globals.AppldataRow).Item("passwort_wordvorlagen"))
IsProtected = True
End If

Fill_Dokument()

If DokType.bZu_retournieren.Value = True Or DokType.iDoktypbedingteretournierung.Value > 0 Then
Generate_Barcodes()
Else
Try
objword.ActiveWindow.ActivePane.View.SeekView = WdSeekView.wdSeekMainDocument
Catch
End Try
End If
If IsProtected Then
Try
docword.Protect(Type:=WdProtectionType.wdAllowOnlyFormFields, NoReset:=True, Password:=Globals.Applikationsdaten.Rows(Globals.AppldataRow).Item("passwort_wordvorlagen"))
Catch
End Try
End If
FeldMakros()

If objword.ActiveWindow.View.SplitSpecial = WdSpecialPane.wdPaneNone Then
objword.ActiveWindow.ActivePane.View.Type = WdViewType.wdPrintView
Else
objword.ActiveWindow.View.Type = WdViewType.wdPrintView
End If

IDV_makros_bearbeiten()
'Rel 3.5 / BUD / 13.01.2005 (IF / END IF)

'Dim dn As String = objword.ActiveDocument.FullName
'docword.Save()
'docword.Close()
'objword.Documents.Open(dn)
'objword.NormalTemplate.Saved = True
'docword = objword.ActiveDocument
'docword.Saved = False

'If objword.ActiveWindow.View.SplitSpecial = WdSpecialPane.wdPaneNone Then
' objword.ActiveWindow.ActivePane.View.Type = WdViewType.wdPrintView
' Else
' objword.ActiveWindow.View.Type = WdViewType.wdPrintView
' End If
If Param.DebugMode Then
DivFnkt.InsertJournale("EDKB12: Ende Dokument_Vervollstaendigen (True)", clsDivFnkt.Enum_InfoTyp.Information)
End If
Return True
Catch ex As Exception
DivFnkt.InsertJournale("EDKB12::Fehler:: Dokument_Vervollstaendigen::" & ex.Message, clsDivFnkt.Enum_InfoTyp.Fehler)
If Param.DebugMode Then
DivFnkt.InsertJournale("EDKB12: Ende Dokument_Vervollstaendigen (False)::" & ex.Message, clsDivFnkt.Enum_InfoTyp.Information)
End If
Return False
End Try

End Function

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

ModMain Class
ModMain ModMain Members


ModMain.Dokumentdaten_Zusammenstellen Method

ModMain.Dokumentdaten_Zusammenstellen Method

ModMain.Dokumentdaten_Zusammenstellen Method | Previous topic | Next topic
ModMain.Dokumentdaten_Zusammenstellen Method | Previous topic | Next topic

Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private Shared Function Dokumentdaten_Zusammenstellen() As Boolean

C#

private static bool Dokumentdaten_Zusammenstellen()

C++

private:
static bool Dokumentdaten_Zusammenstellen()

JScript

private static function Dokumentdaten_Zusammenstellen() : boolean;

Source code

Visual Basic

Copy Code Copy Code

Private Function Dokumentdaten_Zusammenstellen() As Boolean
If Param.DebugMode Then
DivFnkt.InsertJournale("EDKB12: Start Dokumentdaten_Zusammenstellen", clsDivFnkt.Enum_InfoTyp.Information)
End If

Try
xdata = DokumentwertListe_laden(Dokumentid)
Dokumentwerte_Sichern()
xdata = Nothing
xdata = Dokumentwerte(Dokumentid)
Dokumentdaten = Dokumentwerte(Dokumentid)

If Param.DebugMode Then
DivFnkt.InsertJournale("EDKB12: Ende Dokumentdaten_Zusammenstellen (True)", clsDivFnkt.Enum_InfoTyp.Information)
End If

Return True
Catch ex As Exception
DivFnkt.InsertJournale("EDKB12::Fehler:: Dokumentdaten_Zusammenstellen::" & ex.Message, clsDivFnkt.Enum_InfoTyp.Fehler)
If Param.DebugMode Then
DivFnkt.InsertJournale("EDKB12: Ende Dokumentdaten_Zusammenstellen (False)::" & ex.Message, clsDivFnkt.Enum_InfoTyp.Information)
End If

Return False
End Try
End Function

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

ModMain Class
ModMain ModMain Members


ModMain.Dokumentstatus_erstellen_und_Status_Setzen Method

ModMain.Dokumentstatus_erstellen_und_Status_Setzen Method

ModMain.Dokumentstatus_erstellen_und_Status_Setzen Method | Previous topic | Next topic
ModMain.Dokumentstatus_erstellen_und_Status_Setzen Method | Previous topic | Next topic

Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private Shared Function Dokumentstatus_erstellen_und_Status_Setzen( _
ByVal dokumentid As String, _
ByVal erstellen As Boolean, _
Optional ByVal BLKunde As Integer = 0 _
) As Integer

C#

private static int Dokumentstatus_erstellen_und_Status_Setzen(
stringdokumentid,
boolerstellen,
intBLKunde = 0
)

C++

private:
static int Dokumentstatus_erstellen_und_Status_Setzen(
String^ dokumentid,
boolerstellen,
intBLKunde
)

JScript

private static function Dokumentstatus_erstellen_und_Status_Setzen(
dokumentid : String,
erstellen : boolean,
BLKunde : int
) : int;

Parameters

dokumentid

erstellen

BLKunde

Source code

Visual Basic

Copy Code Copy Code

Private Function Dokumentstatus_erstellen_und_Status_Setzen(ByVal dokumentid As String, ByVal erstellen As Boolean, Optional ByVal BLKunde As Integer = 0) As Integer
If Param.DebugMode Then
DivFnkt.InsertJournale("EDKB12: Start Dokumentstatus_erstellen_und_Status_Setzen", clsDivFnkt.Enum_InfoTyp.Information)
End If
Try

Dim st As New System.Data.DataTable()
Dim i As Integer
Dim dt As DateTime = DateAdd(DateInterval.Second, -5, Now)
Dim MitArchivfunktion As Boolean = False

If erstellen = True Then
Create_Dokumentstatus(BLKunde)
End If
st = Get_Dokumentstatus()
For i = 0 To st.Rows.Count - 1
Select Case Integer.Parse(st.Rows(i).Item(2).ToString)
Case 3
MitArchivfunktion = True
Case 11
MitArchivfunktion = True
End Select
Next

If MitArchivfunktion Then
For i = 0 To st.Rows.Count - 1
insert_history_status(st.Rows(i).Item(0), dokumentid, Mitarbeiter.iMitarbeiternr.Value, dt)
dt = DateAdd(DateInterval.Second, 1, dt)
If st.Rows(i).Item(2) = 3 Or st.Rows(i).Item(2) = 11 Then
Return st.Rows(i).Item(0)
Exit Function
End If
Next
Else
'Dokumentstatusreihenfolge ohne Ausgangsarchivierung
End If
If Param.DebugMode Then
DivFnkt.InsertJournale("EDKB12: Ende Dokumentstatus_erstellen_und_Status_Setzen (True)", clsDivFnkt.Enum_InfoTyp.Information)
End If

Catch ex As Exception

End Try
DivFnkt.InsertJournale("EDKB12::Fehler:: Dokumentstatus_erstellen_und_Status_Setzen::", clsDivFnkt.Enum_InfoTyp.Fehler)
If Param.DebugMode Then
DivFnkt.InsertJournale("EDKB12: Ende Dokumentstatus_erstellen_und_Status_Setzen (False)", clsDivFnkt.Enum_InfoTyp.Information)
End If

End Function

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

ModMain Class
ModMain ModMain Members


ModMain.DokumentwertListe_laden Method

ModMain.DokumentwertListe_laden Method

ModMain.DokumentwertListe_laden Method | Previous topic | Next topic
ModMain.DokumentwertListe_laden Method | Previous topic | Next topic

Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private Shared Function DokumentwertListe_laden( _
ByVal dokumentid As String _
) As DataTable

C#

private static DataTable DokumentwertListe_laden(
stringdokumentid
)

C++

private:
static DataTable^ DokumentwertListe_laden(
String^ dokumentid
)

JScript

private static function DokumentwertListe_laden(
dokumentid : String
) : DataTable;

Parameters

dokumentid

Source code

Visual Basic

Copy Code Copy Code

Private Function DokumentwertListe_laden(ByVal dokumentid As String) As System.Data.DataTable
If Param.DebugMode Then
DivFnkt.InsertJournale("EDKB12: Start DokumentwertListe_laden", clsDivFnkt.Enum_InfoTyp.Information)
End If

Dim i As Integer
Dim scmCmdToExecute As SqlCommand = New SqlCommand()
Dim dtToReturn As System.Data.DataTable = New System.Data.DataTable()
Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
scmCmdToExecute.CommandText = "dbo.SP_Dokumentbearbeitung_Dokumentwerte"
scmCmdToExecute.CommandType = CommandType.StoredProcedure
scmCmdToExecute.Connection = conn.scoDBConnection
Try
scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, dokumentid))
scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumenttypnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, DokType.iDokumenttypnr.Value))
scmCmdToExecute.Parameters.Add(New SqlParameter("@CreateNew", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, 1))
sdaAdapter.Fill(dtToReturn)
For i = 0 To dtToReturn.Rows.Count - 1
Dim objDokumentWert As AvaloqDokumentWert
If Not dtToReturn.Rows(i).Item(0) Is System.DBNull.Value Then
objDokumentWert = objAvaloqDokumentWerte.getAvaloqDokumentWertByName(dtToReturn.Rows(i).Item(0))
End If
If objDokumentWert Is Nothing = False Then
dtToReturn.Rows(i).Item(2) = objDokumentWert.value
End If
objDokumentWert = Nothing
Next
If Param.DebugMode Then
DivFnkt.InsertJournale("EDKB12: Ende DokumentwertListe_laden (True)", clsDivFnkt.Enum_InfoTyp.Information)
End If

Return dtToReturn
Catch ex As Exception
DivFnkt.InsertJournale("EDKB12::Fehler:: DokumentwertListe_laden::" & ex.Message, clsDivFnkt.Enum_InfoTyp.Fehler)
If Param.DebugMode Then
DivFnkt.InsertJournale("EDKB12: Ende DokumentwertListe_laden (False)::" & ex.Message, clsDivFnkt.Enum_InfoTyp.Information)
End If
Finally
scmCmdToExecute.Dispose()
sdaAdapter.Dispose()
End Try

End Function

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

ModMain Class
ModMain ModMain Members


ModMain.Dokumentwert_Sichern Method

ModMain.Dokumentwert_Sichern Method

ModMain.Dokumentwert_Sichern Method | Previous topic | Next topic
ModMain.Dokumentwert_Sichern Method | Previous topic | Next topic

Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Shared Sub Dokumentwert_Sichern( _
ByVal wert As String, _
ByVal feldnr As Integer _
)

C#

public static System.Void Dokumentwert_Sichern(
stringwert,
intfeldnr
)

C++

public:
static System::Void Dokumentwert_Sichern(
String^ wert,
intfeldnr
)

JScript

public static function Dokumentwert_Sichern(
wert : String,
feldnr : int
);

Parameters

wert

feldnr

Source code

Visual Basic

Copy Code Copy Code

Public Sub Dokumentwert_Sichern(ByVal wert As String, ByVal feldnr As Integer)
If Param.DebugMode Then
DivFnkt.InsertJournale("EDKB12: Start Dokumentwert_Sichern", clsDivFnkt.Enum_InfoTyp.Information)
End If
Dim scmCmdToExecute As SqlCommand = New SqlCommand()
scmCmdToExecute.CommandText = "dbo.SP_Dokument_Information_Wert"
scmCmdToExecute.CommandType = CommandType.StoredProcedure
scmCmdToExecute.Connection = Globals.conn.scoDBConnection
scmCmdToExecute.Connection.Open()
Try
scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Dokumentid))
scmCmdToExecute.Parameters.Add(New SqlParameter("@vorlagenfeldnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, feldnr))
scmCmdToExecute.Parameters.Add(New SqlParameter("@value", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, wert))
scmCmdToExecute.ExecuteNonQuery()
If Param.DebugMode Then
DivFnkt.InsertJournale("EDKB12: Ende Dokumentwert_Sichern (True)", clsDivFnkt.Enum_InfoTyp.Information)
End If

Catch ex As Exception
DivFnkt.InsertJournale("EDKB12::Fehler:: Dokumentwert_Sichern::" & ex.Message, clsDivFnkt.Enum_InfoTyp.Fehler)
If Param.DebugMode Then
DivFnkt.InsertJournale("EDKB12: Ende Dokumentwert_Sichern (False)::" & ex.Message, clsDivFnkt.Enum_InfoTyp.Information)
End If
Finally
scmCmdToExecute.Connection.Close()
scmCmdToExecute.Dispose()
End Try
End Sub

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

ModMain Class
ModMain ModMain Members


ModMain.Dokumentwerte Method

ModMain.Dokumentwerte Method

ModMain.Dokumentwerte Method | Previous topic | Next topic
ModMain.Dokumentwerte Method | Previous topic | Next topic

Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private Shared Function Dokumentwerte( _
ByVal dokumentid As String _
) As DataTable

C#

private static DataTable Dokumentwerte(
stringdokumentid
)

C++

private:
static DataTable^ Dokumentwerte(
String^ dokumentid
)

JScript

private static function Dokumentwerte(
dokumentid : String
) : DataTable;

Parameters

dokumentid

Source code

Visual Basic

Copy Code Copy Code

Private Function Dokumentwerte(ByVal dokumentid As String) As System.Data.DataTable
If Param.DebugMode Then
DivFnkt.InsertJournale("EDKB12: Start Dokumentwerte", clsDivFnkt.Enum_InfoTyp.Information)
End If
Dim scmCmdToExecute As SqlCommand = New SqlCommand()
scmCmdToExecute.CommandText = "dbo.SP_Dokumentwerte"
scmCmdToExecute.CommandType = CommandType.StoredProcedure
Dim dtToReturn As System.Data.DataTable = New System.Data.DataTable()
Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
scmCmdToExecute.Connection = conn.scoDBConnection
scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, dokumentid))
scmCmdToExecute.Parameters.Add(New SqlParameter("@ierrorcode", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, 0))
Try
sdaAdapter.Fill(dtToReturn)
Return dtToReturn
If Param.DebugMode Then
DivFnkt.InsertJournale("EDKB12: Ende Dokumentwerte (True)", clsDivFnkt.Enum_InfoTyp.Information)
End If
Catch ex As Exception
DivFnkt.InsertJournale("EDKB12::Fehler:: Dokumentwerte::" & ex.Message, clsDivFnkt.Enum_InfoTyp.Fehler)
If Param.DebugMode Then
DivFnkt.InsertJournale("EDKB12: Ende Dokumentwerte (False)::" & ex.Message, clsDivFnkt.Enum_InfoTyp.Information)
End If
Finally
scmCmdToExecute.Dispose()
sdaAdapter.Dispose()
End Try
End Function

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

ModMain Class
ModMain ModMain Members


ModMain.Dokumentwerte_Sichern Method

ModMain.Dokumentwerte_Sichern Method

ModMain.Dokumentwerte_Sichern Method | Previous topic | Next topic
ModMain.Dokumentwerte_Sichern Method | Previous topic | Next topic

Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Shared Sub Dokumentwerte_Sichern()

C#

public static System.Void Dokumentwerte_Sichern()

C++

public:
static System::Void Dokumentwerte_Sichern()

JScript

public static function Dokumentwerte_Sichern();

Source code

Visual Basic

Copy Code Copy Code

Public Sub Dokumentwerte_Sichern()
If Param.DebugMode Then
DivFnkt.InsertJournale("EDKB12: Start Dokumentwerte_Sichern", clsDivFnkt.Enum_InfoTyp.Information)
End If
Dim i As Integer
For i = 0 To xdata.Rows.Count - 1
If xdata.Rows(i).Item("cold_indexfeld") Is System.DBNull.Value Then xdata.Rows(i).Item("cold_indexfeld") = 0
If xdata.Rows(i).Item("cold_indexfeld") = 0 Then
Dim scmCmdToExecute As SqlCommand = New SqlCommand()
scmCmdToExecute.CommandText = "dbo.SP_Dokument_Information_Wert"
scmCmdToExecute.CommandType = CommandType.StoredProcedure
scmCmdToExecute.Connection = conn.scoDBConnection
scmCmdToExecute.Connection.Open()
Try
scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Dokumentid))
scmCmdToExecute.Parameters.Add(New SqlParameter("@vorlagenfeldnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, xdata.Rows(i).Item("vorlagenfeldnr")))
scmCmdToExecute.Parameters.Add(New SqlParameter("@value", SqlDbType.VarChar, 8000, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, xdata.Rows(i).Item("feldwert")))
scmCmdToExecute.ExecuteNonQuery()
Catch ex As Exception
DivFnkt.InsertJournale("EDKB12::Fehler:: Dokumentwerte_Sichern::" & ex.Message, clsDivFnkt.Enum_InfoTyp.Fehler)
If Param.DebugMode Then
DivFnkt.InsertJournale("EDKB12: Ende Dokumentwerte_Sichern (False)::" & ex.Message, clsDivFnkt.Enum_InfoTyp.Information)
End If
Finally
scmCmdToExecute.Connection.Close()
scmCmdToExecute.Dispose()
End Try
End If
Next
xdata.Dispose()
If Param.DebugMode Then
DivFnkt.InsertJournale("EDKB12: Ende Dokumentwerte_Sichern (True)", clsDivFnkt.Enum_InfoTyp.Information)
End If
End Sub

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

ModMain Class
ModMain ModMain Members


ModMain.Dokumentwerte_Uebertragen Method

ModMain.Dokumentwerte_Uebertragen Method

ModMain.Dokumentwerte_Uebertragen Method | Previous topic | Next topic
ModMain.Dokumentwerte_Uebertragen Method | Previous topic | Next topic

Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private Shared Function Dokumentwerte_Uebertragen() As Boolean

C#

private static bool Dokumentwerte_Uebertragen()

C++

private:
static bool Dokumentwerte_Uebertragen()

JScript

private static function Dokumentwerte_Uebertragen() : boolean;

Source code

Visual Basic

Copy Code Copy Code

Private Function Dokumentwerte_Uebertragen() As Boolean
Dim i As Long
Dim pos As Long
Dim pos2 As Long
Dim Fieldlen As Long
Dim temp1 As String
Dim temp2 As String
If Param.DebugMode Then
DivFnkt.InsertJournale("EDKB12: Start Dokumentwerte_Uebertragen", clsDivFnkt.Enum_InfoTyp.Information)
End If

For i = 0 To Dokumentdaten.Rows.Count - 1
If Param.DebugMode Then
Try
temp1 = Dokumentdaten.Rows(i).Item("beginntextmarke")

Catch ex As Exception
temp1 = ""
End Try
Try
temp2 = Dokumentdaten.Rows(i).Item("feldname")

Catch ex As Exception
temp2 = ""
End Try
DivFnkt.InsertJournale("EDKB12: Dokumentwerte_Uebertragen:" & temp1 & ":" & temp2, clsDivFnkt.Enum_InfoTyp.Information)
End If

'Beginn-Textmarke
If Dokumentdaten.Rows(i).Item("aktiv") = True Then
If Dokumentdaten.Rows(i).Item("beginntextmarke") Is System.DBNull.Value Then
Dokumentdaten.Rows(i).Item("beginntextmarke") = ""
End If
If Dokumentdaten.Rows(i).Item("endetextmarke") Is System.DBNull.Value Then
Dokumentdaten.Rows(i).Item("endetextmarke") = ""
End If
If Dokumentdaten.Rows(i).Item("feldname") Is System.DBNull.Value Then
Dokumentdaten.Rows(i).Item("feldname") = ""
End If

If Dokumentdaten.Rows(i).Item("beginntextmarke") = "TGEDKCursor" Or _
Dokumentdaten.Rows(i).Item("beginntextmarke") = "TGEDKCursorB" Or _
Dokumentdaten.Rows(i).Item("feldname") = "TGEDKCursorB" Or _
Dokumentdaten.Rows(i).Item("feldname") = "TGEDKCursor" Then
Else

If Dokumentdaten.Rows(i).Item("beginntextmarke") <> "" And _
Dokumentdaten.Rows(i).Item("endetextmarke") = "" Then
Try
docword.Bookmarks.Item(Dokumentdaten.Rows(i).Item("beginntextmarke")).Select()
pos = docword.Bookmarks.Item(Dokumentdaten.Rows(i).Item("beginntextmarke")).Start
If Dokumentdaten.Rows(i).Item("used") = 1 Then
objword.Selection.Text = Dokumentdaten.Rows(i).Item("xvalue")
End If
pos2 = objword.Selection.End
If Microsoft.VisualBasic.Left(Dokumentdaten.Rows(i).Item("beginntextmarke"), 19) = "XTGEDKDirektTelefonB" Or _
Microsoft.VisualBasic.Left(Dokumentdaten.Rows(i).Item("beginntextmarke"), 23) = "XTGEDKVornameNameBetreue" Or _
Microsoft.VisualBasic.Left(Dokumentdaten.Rows(i).Item("beginntextmarke"), 19) = "XTGEDKDirektTelefonZ" Then
objword.Selection.MoveLeft(Unit:=WdUnits.wdCharacter, Count:=1)
'hutter
objword.Selection.TypeText(Text:=" ")
objword.Selection.SetRange(Start:=pos + 1, End:=pos2 + 1)
With docword.Bookmarks
.Add(Range:=objword.Selection.Range, Name:=Dokumentdaten.Rows(i).Item("beginntextmarke"))
.DefaultSorting = WdBookmarkSortBy.wdSortByName
.ShowHidden = False
End With
Else
If Microsoft.VisualBasic.Left(Dokumentdaten.Rows(i).Item("beginntextmarke"), 22) = "XTGEDKDirektTelefonDokZ" Or _
Microsoft.VisualBasic.Left(Dokumentdaten.Rows(i).Item("beginntextmarke"), 20) = "XTGEDKVornameNameDokZ" Then
objword.Selection.Text = Dokumentdaten.Rows(i).Item("xvalue")
objword.Selection.MoveLeft(Unit:=WdUnits.wdCharacter, Count:=1)
objword.Selection.TypeText(Text:=" ")
objword.Selection.SetRange(Start:=pos + 1, End:=pos2 + 1)
With docword.Bookmarks
.Add(Range:=objword.Selection.Range, Name:=Dokumentdaten.Rows(i).Item("beginntextmarke"))
.DefaultSorting = WdBookmarkSortBy.wdSortByName
.ShowHidden = False
End With
Else
objword.Visible = True
objword.Selection.SetRange(Start:=pos, End:=pos2)
With docword.Bookmarks
.Add(Range:=objword.Selection.Range, Name:=Dokumentdaten.Rows(i).Item("beginntextmarke"))
.DefaultSorting = WdBookmarkSortBy.wdSortByName
.ShowHidden = False
End With
End If
End If
objword.Selection.MoveLeft(Unit:=WdUnits.wdCharacter, Count:=1)
objword.Selection.MoveLeft(Unit:=WdUnits.wdCharacter, Count:=2, Extend:=WdMovementType.wdExtend)
If objword.Selection.Text = " " Then
objword.Selection.MoveRight(Unit:=WdUnits.wdCharacter, Count:=1)
objword.Selection.MoveLeft(Unit:=WdUnits.wdCharacter, Count:=1, Extend:=WdMovementType.wdExtend)
objword.Selection.Delete(Unit:=WdUnits.wdCharacter, Count:=1)
End If

Catch
End Try
End If

'Beginn- und Ende-Textmarke
If Dokumentdaten.Rows(i).Item("beginntextmarke") <> "" And _
Dokumentdaten.Rows(i).Item("endetextmarke") <> "" Then
Try
docword.Bookmarks.Item(Dokumentdaten.Rows(i).Item("beginntextmarke")).Select()
pos = docword.Bookmarks.Item(Dokumentdaten.Rows(i).Item("beginntextmarke")).Start
docword.Bookmarks.Item(Dokumentdaten.Rows(i).Item("endetextmarke")).Select()
pos2 = docword.Bookmarks.Item(Dokumentdaten.Rows(i).Item("endetextmarke")).Start
objword.Selection.SetRange(Start:=pos, End:=pos2)
If Dokumentdaten.Rows(i).Item("used") = 1 Then
objword.Selection.TypeText(Text:=Dokumentdaten.Rows(i).Item("xvalue"))
End If
With docword.Bookmarks
.Add(Range:=objword.Selection.Range, Name:=Dokumentdaten.Rows(i).Item("beginntextmarke"))
.DefaultSorting = WdBookmarkSortBy.wdSortByName
.ShowHidden = False
End With
Catch
End Try
End If
'Felder
If Dokumentdaten.Rows(i).Item("feldname") <> "" Then
Try
If docword.FormFields.Item(Dokumentdaten.Rows(i).Item("feldname")).TextInput.Width <> 0 Then
Fieldlen = docword.FormFields.Item(Dokumentdaten.Rows(i).Item("feldname")).TextInput.Width
docword.FormFields.Item(Dokumentdaten.Rows(i).Item("feldname")).TextInput.Width = Fieldlen + 5
End If
If Dokumentdaten.Rows(i).Item("used") = 1 Then
docword.FormFields.Item(Dokumentdaten.Rows(i).Item("feldname")).Result = convert_wordfelder(Dokumentdaten.Rows(i).Item("xvalue"))
End If
Catch
End Try
End If
End If
End If
Next
If Param.DebugMode Then
DivFnkt.InsertJournale("EDKB12: Start Ende Dokumentwerte_Uebertragen", clsDivFnkt.Enum_InfoTyp.Information)
End If

Return True

End Function

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

ModMain Class
ModMain ModMain Members


ModMain.FeldMakros Method

ModMain.FeldMakros Method

ModMain.FeldMakros Method | Previous topic | Next topic
ModMain.FeldMakros Method | Previous topic | Next topic

Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private Shared Sub FeldMakros()

C#

private static System.Void FeldMakros()

C++

private:
static System::Void FeldMakros()

JScript

private static function FeldMakros();

Source code

Visual Basic

Copy Code Copy Code

Private Sub FeldMakros()
Dim i As Integer
For i = 0 To Dokumentdaten.Rows.Count - 1
If Dokumentdaten.Rows(i).Item("feldname") <> "" Then
If Dokumentdaten.Rows(i).Item("einstiegsmakro") = True Then
objWord.Run(docWord.FormFields.Item(Dokumentdaten.Rows(i).Item("feldname")).EntryMacro)
End If
If Dokumentdaten.Rows(i).Item("ausstiegsmakro") = True Then
objWord.Run(docWord.FormFields.Item(Dokumentdaten.Rows(i).Item("feldname")).ExitMacro)
End If
End If
Next
End Sub

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

ModMain Class
ModMain ModMain Members


ModMain.Fill_Dokument Method

ModMain.Fill_Dokument Method

ModMain.Fill_Dokument Method | Previous topic | Next topic
ModMain.Fill_Dokument Method | Previous topic | Next topic

Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private Shared Function Fill_Dokument() As Boolean

C#

private static bool Fill_Dokument()

C++

private:
static bool Fill_Dokument()

JScript

private static function Fill_Dokument() : boolean;

Source code

Visual Basic

Copy Code Copy Code

Private Function Fill_Dokument() As Boolean
If Param.DebugMode Then
DivFnkt.InsertJournale("EDKB12: Start Fill_Dokument", clsDivFnkt.Enum_InfoTyp.Information)
End If

Try
If OfficeVorlage.bKopfzeile_generieren.Value = True Then
If Param.DebugMode Then
DivFnkt.InsertJournale("EDKB12: Vor Insert Kopfzeile", clsDivFnkt.Enum_InfoTyp.Information)
End If
Insert_Kopfzeile()
If Param.DebugMode Then
DivFnkt.InsertJournale("EDKB12: Nach Insert Kopfzeile", clsDivFnkt.Enum_InfoTyp.Information)
End If
End If

Dokumentwerte_Uebertragen()

If Param.DebugMode Then
DivFnkt.InsertJournale("EDKB12: Ende Fill_Dokument (True)", clsDivFnkt.Enum_InfoTyp.Information)
End If
Return True
Catch ex As Exception
DivFnkt.InsertJournale("EDKB12::Fehler:: Fill_Dokument::" & ex.Message, clsDivFnkt.Enum_InfoTyp.Fehler)
If Param.DebugMode Then
DivFnkt.InsertJournale("EDKB12: Ende Fill_Dokument (False)::" & ex.Message, clsDivFnkt.Enum_InfoTyp.Information)
End If
Return False
End Try

End Function

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

ModMain Class
ModMain ModMain Members


ModMain.Generate_Barcodes Method

ModMain.Generate_Barcodes Method

ModMain.Generate_Barcodes Method | Previous topic | Next topic
ModMain.Generate_Barcodes Method | Previous topic | Next topic

Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private Shared Sub Generate_Barcodes()

C#

private static System.Void Generate_Barcodes()

C++

private:
static System::Void Generate_Barcodes()

JScript

private static function Generate_Barcodes();

Source code

Visual Basic

Copy Code Copy Code

Private Sub Generate_Barcodes()
delete_Textfelder()
Insert_TextFelder()
ins_Barcode()
End Sub

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

ModMain Class
ModMain ModMain Members


ModMain.Generate_Dokument Method

ModMain.Generate_Dokument Method

ModMain.Generate_Dokument Method | Previous topic | Next topic
ModMain.Generate_Dokument Method | Previous topic | Next topic

Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Shared Sub Generate_Dokument( _
ByVal row As Integer _
)

C#

public static System.Void Generate_Dokument(
introw
)

C++

public:
static System::Void Generate_Dokument(
introw
)

JScript

public static function Generate_Dokument(
row : int
);

Parameters

row

Source code

Visual Basic

Copy Code Copy Code

Public Sub Generate_Dokument(ByVal row As Integer)
Try

RowId = row

Set_EDK_Status(RowId, 1)

Filename = Param.WorkDir + "\" + Trim(Str(RowId)) & "_EDK_" & Format(Now, "dd_MM_yyyy hh_mm_ss") & "_" & ".edk"

DivFnkt.InsertJournale("EDKB12: Start " + Filename, clsDivFnkt.Enum_InfoTyp.Information)

' Applikationsdaten lasen
Dim Applikation As New edokadb.clsApplikation()
Applikation.cpMainConnectionProvider = Globals.conn
Applikation.iApplikationsnr = New SqlInt32(CType(1, Int32))
Globals.Applikationsdaten = Applikation.SelectOne

'Initialisierung vor Dokument_Bearbeitung / 20110208 SHU
EDK_Daten.Dispose()
EDK_Daten = Nothing
EDK_Daten = New System.Data.DataTable

EDK_Data.Dispose()
EDK_Data = Nothing
EDK_Data = New DataSet

xdata.Dispose()
xdata = Nothing
xdata = New System.Data.DataTable

Dokumentdaten.Dispose()
Dokumentdaten = Nothing
Dokumentdaten = New System.Data.DataTable

Profile.Dispose()
Profile = Nothing
Profile = New System.Data.DataTable

Teams.Dispose()
Teams = Nothing
Teams = New System.Data.DataTable

Mitarbeiterdata.Dispose()
Mitarbeiterdata = Nothing
Mitarbeiterdata = New System.Data.DataTable

DokType.Dispose()
OfficeVorlage.Dispose()
OfficeVorlageDatei.Dispose()
Partner.Dispose()
xMitarbeiter.Dispose()
Mitarbeiter.Dispose()
Mitarbeiterdata.Dispose()
objAvaloqDokumentWerte.clearAvaloqDokumentWerte()

If Not Get_EDK_Data() Then
Set_EDK_Status(RowId, 2)
Exit Sub
End If

If Not Check_EDK_Data() Then
Set_EDK_Status(RowId, 2)
Exit Sub
End If

If Not Check_Umfeld() Then
Set_EDK_Status(RowId, 2)
Exit Sub
End If

If Not Dokument_Erstellen() Then
Set_EDK_Status(RowId, 2)
Exit Sub
End If

If Not Dokumentdaten_Zusammenstellen() Then
Set_EDK_Status(RowId, 2)
Exit Sub
End If

If Not Generate_Word() Then
Set_EDK_Status(RowId, 2)
Exit Sub
End If
Try
EDK_Data.Tables.Clear()
EDK_Daten.Rows.Clear()

xdata.Rows.Clear()
Dokumentdaten.Rows.Clear()
Profile.Rows.Clear()
Teams.Rows.Clear()
Mitarbeiterdata.Rows.Clear()
EDK_Data.Dispose()
EDK_Daten.Dispose()

DokType.Dispose()
DokType.Dispose()
OfficeVorlage.Dispose()
OfficeVorlageDatei.Dispose()
Partner.Dispose()
xMitarbeiter.Dispose()
Mitarbeiter.Dispose()
Mitarbeiterdata.Dispose()
xdata.Dispose()
Dokumentdaten.Dispose()
Profile.Dispose()
Teams.Dispose()
tmpAction.Destroy()
objAvaloqDokumentWerte.clearAvaloqDokumentWerte()

File.Delete(Filename)
File.Delete(Filename + FileExtension)
Catch
End Try
Set_EDK_Status(RowId, 3)
DivFnkt.InsertJournale("EDKB12: Ende " + Filename, clsDivFnkt.Enum_InfoTyp.Information)
Catch ex As Exception
DivFnkt.InsertJournale("EDKB12: Fehler:: " + ex.Message, clsDivFnkt.Enum_InfoTyp.Information)
End Try

End Sub

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

ModMain Class
ModMain ModMain Members


ModMain.Generate_Word Method

ModMain.Generate_Word Method

ModMain.Generate_Word Method | Previous topic | Next topic
ModMain.Generate_Word Method | Previous topic | Next topic

Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private Shared Function Generate_Word() As Boolean

C#

private static bool Generate_Word()

C++

private:
static bool Generate_Word()

JScript

private static function Generate_Word() : boolean;

Source code

Visual Basic

Copy Code Copy Code

Private Function Generate_Word() As Boolean
If Param.DebugMode Then
DivFnkt.InsertJournale("EDKB12: Start Generate_Word", clsDivFnkt.Enum_InfoTyp.Information)
End If

Try
If Not StartWord() Then
Return True
Exit Function
End If
objword.Documents.Open(DokumentFilename)
docword = objword.ActiveDocument
objword.NormalTemplate.Saved = True
objword.Visible = True
If Not Word_Werte_Auslesen(xdata) Then
DivFnkt.InsertJournale("EDKB12::Fehler:: Generate_Word: Word_Werte_auslesen", clsDivFnkt.Enum_InfoTyp.Fehler)
If Param.DebugMode Then
DivFnkt.InsertJournale("EDKB12::Fehler:: Generate_Word: Word_Werte_auslesen", clsDivFnkt.Enum_InfoTyp.Information)
End If
End If
If Not Dokument_Vervollstaendigen(xdata) Then
DivFnkt.InsertJournale("EDKB12::Fehler:: Generate_Word: Dokument_Vervollstaendigen", clsDivFnkt.Enum_InfoTyp.Fehler)
If Param.DebugMode Then
DivFnkt.InsertJournale("EDKB12::Fehler:: Generate_Word: Dokument_Vervollstaendigen", clsDivFnkt.Enum_InfoTyp.Information)
End If
End If

docword = objword.ActiveDocument
docword.Save()
docword.Close()
docword = Nothing
objword.Quit(False)
objword = Nothing

If Save_Doc() = True Then
If Param.DebugMode Then
DivFnkt.InsertJournale("EDKB12: Ende Generate_Word (True)", clsDivFnkt.Enum_InfoTyp.Information)
End If
Return True
Else
DivFnkt.InsertJournale("EDKB12::Fehler:: Generate_Word: Save_Doc", clsDivFnkt.Enum_InfoTyp.Fehler)
If Param.DebugMode Then
DivFnkt.InsertJournale("EDKB12::Fehler:: Generate_Word: Save_Doc", clsDivFnkt.Enum_InfoTyp.Information)
End If
Return False
End If

Catch ex As Exception
DivFnkt.InsertJournale("EDKB12::Fehler:: Generate_Word::" & ex.Message, clsDivFnkt.Enum_InfoTyp.Fehler)
If Param.DebugMode Then
DivFnkt.InsertJournale("EDKB12: Ende Generate_Word (False)::" & ex.Message, clsDivFnkt.Enum_InfoTyp.Information)
End If
Return False
End Try

End Function

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

ModMain Class
ModMain ModMain Members


ModMain.Get_Applikationnr Method

ModMain.Get_Applikationnr Method

ModMain.Get_Applikationnr Method | Previous topic | Next topic
ModMain.Get_Applikationnr Method | Previous topic | Next topic

Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Shared Function Get_Applikationnr( _
ByVal Dateinr As Integer _
) As Integer

C#

public static int Get_Applikationnr(
intDateinr
)

C++

public:
static int Get_Applikationnr(
intDateinr
)

JScript

public static function Get_Applikationnr(
Dateinr : int
) : int;

Parameters

Dateinr

Source code

Visual Basic

Copy Code Copy Code

Public Function Get_Applikationnr(ByVal Dateinr As Integer) As Integer
Try
Dim connection As New SqlConnection()
Dim da As New SqlDataAdapter("Select * From Office2010_Vorlage_datei where Office_Vorlage_Dateinr=" + Dateinr.ToString, connection)
Dim CB As SqlCommandBuilder = New SqlCommandBuilder(da)
Dim ds As New DataSet()

Try
connection.ConnectionString = Param.connectionstring
connection.Open()
da.Fill(ds, "docs")
If ds.Tables(0).Rows.Count > 0 Then
Return ds.Tables(0).Rows(0).Item(3)
Else
Return 0
End If
Catch ex As Exception
MsgBox(ex.Message)
End Try
CB = Nothing
ds = Nothing
da = Nothing
connection.Close()
connection = Nothing
CB = Nothing
ds = Nothing
da = Nothing
connection.Close()
connection = Nothing
Catch ex As Exception
Return 0
End Try
End Function

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

ModMain Class
ModMain ModMain Members


ModMain.Get_Dokumentstatus Method

ModMain.Get_Dokumentstatus Method

ModMain.Get_Dokumentstatus Method | Previous topic | Next topic
ModMain.Get_Dokumentstatus Method | Previous topic | Next topic

Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private Shared Function Get_Dokumentstatus() As DataTable

C#

private static DataTable Get_Dokumentstatus()

C++

private:
static DataTable^ Get_Dokumentstatus()

JScript

private static function Get_Dokumentstatus() : DataTable;

Source code

Visual Basic

Copy Code Copy Code

Private Function Get_Dokumentstatus() As System.Data.DataTable
If Param.DebugMode Then
DivFnkt.InsertJournale("EDKB12: Start Get_Dokumentstatus", clsDivFnkt.Enum_InfoTyp.Information)
End If
Dim scmCmdToExecute As SqlCommand = New SqlCommand()
Dim dtToReturn As System.Data.DataTable = New System.Data.DataTable()
Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
scmCmdToExecute.CommandText = "dbo.sp_edoka_import_get_dokumentstatus"
scmCmdToExecute.CommandType = CommandType.StoredProcedure
scmCmdToExecute.Connection = Globals.conn.scoDBConnection
Try
scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Dokumentid))
sdaAdapter.Fill(dtToReturn)
If Param.DebugMode Then
DivFnkt.InsertJournale("EDKB12: Ende Get_Dokumentstatus (True)", clsDivFnkt.Enum_InfoTyp.Information)
End If

Return dtToReturn
Catch ex As Exception
DivFnkt.InsertJournale("EDKB12::Fehler:: Get_Dokumentstatus::" & ex.Message, clsDivFnkt.Enum_InfoTyp.Fehler)
If Param.DebugMode Then
DivFnkt.InsertJournale("EDKB12: Ende Get_Dokumentstatus (False)::" & ex.Message, clsDivFnkt.Enum_InfoTyp.Information)
End If
Finally
Globals.conn.CloseConnection(True)
scmCmdToExecute.Dispose()
sdaAdapter.Dispose()
End Try
End Function

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

ModMain Class
ModMain ModMain Members


ModMain.Get_EDK_Data Method

ModMain.Get_EDK_Data Method

ModMain.Get_EDK_Data Method | Previous topic | Next topic
ModMain.Get_EDK_Data Method | Previous topic | Next topic

Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private Shared Function Get_EDK_Data() As Object

C#

private static object Get_EDK_Data()

C++

private:
static object^ Get_EDK_Data()

JScript

private static function Get_EDK_Data() : object;

Source code

Visual Basic

Copy Code Copy Code

Private Function Get_EDK_Data()
If Param.DebugMode Then
DivFnkt.InsertJournale("EDKB12: Start Get_EDK_Data", clsDivFnkt.Enum_InfoTyp.Information)
End If
Try
Dim Connection As New SqlConnection()
Dim DA As New SqlDataAdapter("select * from edk_data where rowid = " & Str(RowId), Connection)
Dim cb As SqlCommandBuilder = New SqlCommandBuilder(DA)
Connection.ConnectionString = Globals.Param.connectionstring
Connection.Open()
EDK_Data.Tables.Clear()
DA.Fill(EDK_Data, "EDK_Data")

Dim myRow As DataRow
myRow = EDK_Data.Tables(0).Rows(0)
Dim MyData() As Byte
MyData = myRow.Item(5)
Dim K As Long
K = UBound(MyData)
Dim fs As New FileStream(Filename, FileMode.OpenOrCreate, FileAccess.Write)
fs.Write(MyData, 0, K)
fs.Close()
fs = Nothing
DA = Nothing
cb = Nothing
Connection = Nothing

If Param.DebugMode Then
DivFnkt.InsertJournale("EDKB12: Ende Get_EDK_Data (True)", clsDivFnkt.Enum_InfoTyp.Information)
End If
Return True
Catch ex As Exception
DivFnkt.InsertJournale("EDKB12::Fehler:: Get_EDK_Data::" & ex.Message, clsDivFnkt.Enum_InfoTyp.Fehler)
If Param.DebugMode Then
DivFnkt.InsertJournale("EDKB12: Ende Get_EDK_Data (False)::" & ex.Message, clsDivFnkt.Enum_InfoTyp.Information)
End If
Return False
End Try
End Function

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

ModMain Class
ModMain ModMain Members


ModMain.Get_Pendente_EDK_Dokumente Method

ModMain.Get_Pendente_EDK_Dokumente Method

ModMain.Get_Pendente_EDK_Dokumente Method | Previous topic | Next topic
ModMain.Get_Pendente_EDK_Dokumente Method | Previous topic | Next topic

Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private Shared Function Get_Pendente_EDK_Dokumente() As DataTable

C#

private static DataTable Get_Pendente_EDK_Dokumente()

C++

private:
static DataTable^ Get_Pendente_EDK_Dokumente()

JScript

private static function Get_Pendente_EDK_Dokumente() : DataTable;

Source code

Visual Basic

Copy Code Copy Code

Private Function Get_Pendente_EDK_Dokumente() As System.Data.DataTable
If Param.DebugMode Then
DivFnkt.InsertJournale("EDKB12: Start Get_Pendente_EDK_Dokumente", clsDivFnkt.Enum_InfoTyp.Information)
End If

Dim scmCmdToExecute As SqlCommand = New SqlCommand()
scmCmdToExecute.CommandText = "sp_edkb12"
scmCmdToExecute.CommandType = CommandType.StoredProcedure
Dim dtToReturn As System.Data.DataTable = New System.Data.DataTable()
Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
Try
scmCmdToExecute.Connection = Globals.conn.scoDBConnection
scmCmdToExecute.Parameters.Add(New SqlParameter("@fnkt", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, 1))
scmCmdToExecute.Parameters.Add(New SqlParameter("@rowid", SqlDbType.Int, 225, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, 0))
scmCmdToExecute.Parameters.Add(New SqlParameter("@status", SqlDbType.Int, 225, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, 0))
sdaAdapter.Fill(dtToReturn)
Return dtToReturn
Catch ex As Exception
'20080918 Version 12 SHU
'Im Feherfall nichts auf DB schreiben. Passiert nachdem ein SQL-Verbindungsunterbruch stattgefunden hat.
Try

DivFnkt.InsertJournale("EDKB12::Fehler:: Get_Pendente_EDK_Dokumente::" & ex.Message, clsDivFnkt.Enum_InfoTyp.Fehler)
If Param.DebugMode Then
DivFnkt.InsertJournale("EDKB12: Ende Get_Pendente_EDK_Dokumente (False)::" & ex.Message, clsDivFnkt.Enum_InfoTyp.Information)
End If
Catch
End Try
Finally
scmCmdToExecute.Dispose()
sdaAdapter.Dispose()
End Try
End Function

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

ModMain Class
ModMain ModMain Members


ModMain.Get_Profil Method

ModMain.Get_Profil Method

ModMain.Get_Profil Method | Previous topic | Next topic
ModMain.Get_Profil Method | Previous topic | Next topic

Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private Shared Function Get_Profil( _
ByVal Mitarbeiternr As Integer _
) As DataTable

C#

private static DataTable Get_Profil(
intMitarbeiternr
)

C++

private:
static DataTable^ Get_Profil(
intMitarbeiternr
)

JScript

private static function Get_Profil(
Mitarbeiternr : int
) : DataTable;

Parameters

Mitarbeiternr

Source code

Visual Basic

Copy Code Copy Code

Private Function Get_Profil(ByVal Mitarbeiternr As Integer) As System.Data.DataTable
If Param.DebugMode Then
DivFnkt.InsertJournale("EDKB12: Get_ProfilGet_Team", clsDivFnkt.Enum_InfoTyp.Information)
End If
Dim scmCmdToExecute As SqlCommand = New SqlCommand()
Dim dtToReturn As System.Data.DataTable = New System.Data.DataTable()
Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
scmCmdToExecute.CommandText = "dbo.sp_edkb12_profil"
scmCmdToExecute.CommandType = CommandType.StoredProcedure
scmCmdToExecute.Connection = Globals.conn.scoDBConnection
Try
scmCmdToExecute.Parameters.Add(New SqlParameter("@mitarbeiternr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Mitarbeiternr))
sdaAdapter.Fill(dtToReturn)
If Param.DebugMode Then
DivFnkt.InsertJournale("EDKB12: Ende Get_Profil (True)", clsDivFnkt.Enum_InfoTyp.Information)
End If

Return dtToReturn
Catch ex As Exception
DivFnkt.InsertJournale("EDKB12::Fehler:: Get_Profil::" & ex.Message, clsDivFnkt.Enum_InfoTyp.Fehler)
If Param.DebugMode Then
DivFnkt.InsertJournale("EDKB12: Ende Get_Profil (False)::" & ex.Message, clsDivFnkt.Enum_InfoTyp.Information)
End If
Finally
Globals.conn.CloseConnection(True)
scmCmdToExecute.Dispose()
sdaAdapter.Dispose()
End Try
End Function

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

ModMain Class
ModMain ModMain Members


ModMain.Get_Team Method

ModMain.Get_Team Method

ModMain.Get_Team Method | Previous topic | Next topic
ModMain.Get_Team Method | Previous topic | Next topic

Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private Shared Function Get_Team( _
ByVal profilnr As Integer _
) As DataTable

C#

private static DataTable Get_Team(
intprofilnr
)

C++

private:
static DataTable^ Get_Team(
intprofilnr
)

JScript

private static function Get_Team(
profilnr : int
) : DataTable;

Parameters

profilnr

Source code

Visual Basic

Copy Code Copy Code

Private Function Get_Team(ByVal profilnr As Integer) As System.Data.DataTable
If Param.DebugMode Then
DivFnkt.InsertJournale("EDKB12: Start Get_Team", clsDivFnkt.Enum_InfoTyp.Information)
End If
Dim scmCmdToExecute As SqlCommand = New SqlCommand()
Dim dtToReturn As System.Data.DataTable = New System.Data.DataTable()
Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
scmCmdToExecute.CommandText = "dbo.sp_dokumentbearbeitung_team"
scmCmdToExecute.CommandType = CommandType.StoredProcedure
scmCmdToExecute.Connection = Globals.conn.scoDBConnection
Try
scmCmdToExecute.Parameters.Add(New SqlParameter("@profilnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, profilnr))
scmCmdToExecute.Parameters.Add(New SqlParameter("@mitarbeiternr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, 0))
sdaAdapter.Fill(dtToReturn)
If Param.DebugMode Then
DivFnkt.InsertJournale("EDKB12: Ende Get_Team (True)", clsDivFnkt.Enum_InfoTyp.Information)
End If

Return dtToReturn
Catch ex As Exception
DivFnkt.InsertJournale("EDKB12::Fehler:: Get_Team::" & ex.Message, clsDivFnkt.Enum_InfoTyp.Fehler)
If Param.DebugMode Then
DivFnkt.InsertJournale("EDKB12: Ende Get_Team (False)::" & ex.Message, clsDivFnkt.Enum_InfoTyp.Information)
End If
Finally
Globals.conn.CloseConnection(True)
scmCmdToExecute.Dispose()
sdaAdapter.Dispose()
End Try
End Function

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

ModMain Class
ModMain ModMain Members


ModMain.HeaderFooterAnzeigen Method

ModMain.HeaderFooterAnzeigen Method

ModMain.HeaderFooterAnzeigen Method | Previous topic | Next topic
ModMain.HeaderFooterAnzeigen Method | Previous topic | Next topic

Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private Shared Sub HeaderFooterAnzeigen()

C#

private static System.Void HeaderFooterAnzeigen()

C++

private:
static System::Void HeaderFooterAnzeigen()

JScript

private static function HeaderFooterAnzeigen();

Source code

Visual Basic

Copy Code Copy Code

Private Sub HeaderFooterAnzeigen()
If objword.ActiveWindow.View.SplitSpecial <> WdSpecialPane.wdPaneNone Then
objword.ActiveWindow.Panes.Item(2).Close()
End If
If objWord.ActiveWindow.ActivePane.View.Type = WdViewType.wdNormalView Or objWord.ActiveWindow.ActivePane.View.Type = WdViewType.wdOutlineView Then
objWord.ActiveWindow.ActivePane.View.Type = WdViewType.wdPrintView
End If
objWord.ActiveWindow.ActivePane.View.SeekView = WdSeekView.wdSeekCurrentPageHeader
If objWord.Selection.HeaderFooter.IsHeader = True Then
objWord.ActiveWindow.ActivePane.View.SeekView = WdSeekView.wdSeekCurrentPageFooter
Else
objWord.ActiveWindow.ActivePane.View.SeekView = WdSeekView.wdSeekCurrentPageHeader
End If
End Sub

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

ModMain Class
ModMain ModMain Members


ModMain.IDV_makros_bearbeiten Method

ModMain.IDV_makros_bearbeiten Method

ModMain.IDV_makros_bearbeiten Method | Previous topic | Next topic
ModMain.IDV_makros_bearbeiten Method | Previous topic | Next topic

Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Shared Function IDV_makros_bearbeiten() As Boolean

C#

public static bool IDV_makros_bearbeiten()

C++

public:
static bool IDV_makros_bearbeiten()

JScript

public static function IDV_makros_bearbeiten() : boolean;

Source code

Visual Basic

Copy Code Copy Code

Public Function IDV_makros_bearbeiten() As Boolean
If Param.DebugMode Then
DivFnkt.InsertJournale("EDKB12: Start IDV_makros_bearbeiten", clsDivFnkt.Enum_InfoTyp.Information)
End If

Try
Dim idvmakros As New edokadb.clsMyDokumentDaten()
Dim makros As System.Data.DataTable
Dim i As Long

idvmakros.cpMainConnectionProvider = conn
makros = idvmakros.Select_IDVMakros(DokType.iDokumenttypnr.Value)

For i = 0 To makros.Rows.Count - 1
Try
If makros.Rows(i).Item("ist_in_dll") = True Then
'SetForegroundWindow(...)
Try
objword.Activate()
Catch
Thread.Sleep(100)
objword.Activate()
End Try
'System.Windows.Forms.Application.DoEvents()
' idvdll = CreateObject("IDVMakros.Application")
' Call idvdll.CallSub(objword, makros.Rows(i).Item("makro"))
'System.Windows.Forms.Application.DoEvents()
objword.Visible = True
Try
' objWord.Activate()
Catch
' Thread.Sleep(100)
' objWord.Activate()
End Try
Else
'System.Windows.Forms.Application.DoEvents()
If Param.DebugMode Then
DivFnkt.InsertJournale("EDKB12: Start IDV_makros_bearbeiten:Makro: " & makros.Rows(i).Item("makro"), clsDivFnkt.Enum_InfoTyp.Information)
End If

objword.Run(makros.Rows(i).Item("makro"))
'System.Windows.Forms.Application.DoEvents()
End If
Catch ex As Exception
If Param.DebugMode Then
DivFnkt.InsertJournale("EDKB12: IDV_makros_bearbeiten:: Fehler beim Makro-Aufruf::" & makros.Rows(i).Item("makro") & "::" & ex.Message, clsDivFnkt.Enum_InfoTyp.Information)
End If
End Try
Next i
If Param.DebugMode Then
DivFnkt.InsertJournale("EDKB12: Ende IDV_makros_bearbeiten (True)", clsDivFnkt.Enum_InfoTyp.Information)
End If
Return True
Catch ex As Exception
DivFnkt.InsertJournale("EDKB12::Fehler:: IDV_makros_bearbeiten::" & ex.Message, clsDivFnkt.Enum_InfoTyp.Fehler)
If Param.DebugMode Then
DivFnkt.InsertJournale("EDKB12: Ende IDV_makros_bearbeiten (False)::" & ex.Message, clsDivFnkt.Enum_InfoTyp.Information)
End If
Return False
End Try
End Function

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

ModMain Class
ModMain ModMain Members


ModMain.Insert_Kopfzeile Method

ModMain.Insert_Kopfzeile Method

ModMain.Insert_Kopfzeile Method | Previous topic | Next topic
ModMain.Insert_Kopfzeile Method | Previous topic | Next topic

Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private Shared Sub Insert_Kopfzeile()

C#

private static System.Void Insert_Kopfzeile()

C++

private:
static System::Void Insert_Kopfzeile()

JScript

private static function Insert_Kopfzeile();

Source code

Visual Basic

Copy Code Copy Code

Private Sub Insert_Kopfzeile()
On Error Resume Next
objword.Selection.HomeKey(Unit:=WdUnits.wdStory)
If objWord.ActiveWindow.View.SplitSpecial <> WdSpecialPane.wdPaneNone Then
objWord.ActiveWindow.Panes.Item(2).Close()
End If
If objword.ActiveWindow.ActivePane.View.Type = WdViewType.wdNormalView Or objword.ActiveWindow.ActivePane.View.Type = WdViewType.wdOutlineView Then
objword.ActiveWindow.ActivePane.View.Type = WdViewType.wdPrintView
End If
objword.ActiveWindow.ActivePane.View.SeekView = WdSeekView.wdSeekCurrentPageHeader
set_headerbookmark()
objWord.ActiveWindow.ActivePane.View.SeekView = WdSeekView.wdSeekMainDocument
End Sub

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

ModMain Class
ModMain ModMain Members


ModMain.Insert_TextFelder Method

ModMain.Insert_TextFelder Method

ModMain.Insert_TextFelder Method | Previous topic | Next topic
ModMain.Insert_TextFelder Method | Previous topic | Next topic

Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private Shared Sub Insert_TextFelder()

C#

private static System.Void Insert_TextFelder()

C++

private:
static System::Void Insert_TextFelder()

JScript

private static function Insert_TextFelder();

Source code

Visual Basic

Copy Code Copy Code

Private Sub Insert_TextFelder()
Dim xname As String
Dim i As Integer
Dim pages As Long
Dim prop As Object
For Each prop In objWord.ActiveDocument.BuiltInDocumentProperties
If UCase(prop.Name) = "NUMBER OF PAGES" Then
pages = prop.value
End If
Next
Textboxesi = 1
objword.Selection.HomeKey(Unit:=WdUnits.wdStory)
For i = 1 To pages
xname = Str(i)
If Left(xname, 1) = " " Then xname = Right(xname, Len(xname) - 1)
objword.Selection.GoTo(What:=WdGoToItem.wdGoToPage, Name:=xname)
insert_Textfield()
objWord.ActiveWindow.ActivePane.View.SeekView = WdSeekView.wdSeekMainDocument
Next i
End Sub

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

ModMain Class
ModMain ModMain Members


ModMain.Office_Vorlage_Get_From_DB Method

ModMain.Office_Vorlage_Get_From_DB Method

ModMain.Office_Vorlage_Get_From_DB Method | Previous topic | Next topic
ModMain.Office_Vorlage_Get_From_DB Method | Previous topic | Next topic

Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Shared Function Office_Vorlage_Get_From_DB( _
ByVal office_vorlagenr As Integer, _
ByVal Filename As String _
) As String

C#

public static string Office_Vorlage_Get_From_DB(
intoffice_vorlagenr,
stringFilename
)

C++

public:
static String^ Office_Vorlage_Get_From_DB(
intoffice_vorlagenr,
String^ Filename
)

JScript

public static function Office_Vorlage_Get_From_DB(
office_vorlagenr : int,
Filename : String
) : String;

Parameters

office_vorlagenr

Filename

Source code

Visual Basic

Copy Code Copy Code

Public Function Office_Vorlage_Get_From_DB(ByVal office_vorlagenr As Integer, ByVal Filename As String) As String
If Param.DebugMode Then
DivFnkt.InsertJournale("EDKB12: Start Office_Vorlage_Get_From_DB", clsDivFnkt.Enum_InfoTyp.Information)
End If
Dim s As String = "Select * From office_vorlage_datei where office_vorlage_Dateinr=" + Trim(Str(office_vorlagenr))
If Param.CheckOffice2010_Vorlage = True Then
s = "Select * from Office2010_Vorlage_datei where office_vorlage_dateinr=" + Trim(Str(office_vorlagenr))
End If
Dim connection As New SqlConnection()
Dim da As New SqlDataAdapter(s, connection)
Dim CB As SqlCommandBuilder = New SqlCommandBuilder(da)
Dim ds As New DataSet()
Try
connection.ConnectionString = Param.connectionstring
connection.Open()
da.Fill(ds, "docs")
Dim myRow As DataRow
myRow = ds.Tables(0).Rows(0)
Dim MyData() As Byte
MyData = myRow.Item(2)
Dim K As Long
K = UBound(MyData)
Dim fs As New FileStream(Filename, FileMode.OpenOrCreate, FileAccess.Write)
fs.Write(MyData, 0, K)
fs.Close()
fs = Nothing
If Param.DebugMode Then
DivFnkt.InsertJournale("EDKB12: Ende GOffice_Vorlage_Get_From_DB (True)", clsDivFnkt.Enum_InfoTyp.Information)
End If
Return Filename
Catch ex As Exception
DivFnkt.InsertJournale("EDKB12::Fehler:: Office_Vorlage_Get_From_DB::" & ex.Message, clsDivFnkt.Enum_InfoTyp.Fehler)
If Param.DebugMode Then
DivFnkt.InsertJournale("EDKB12: Ende GOffice_Vorlage_Get_From_DB (False)::" & ex.Message, clsDivFnkt.Enum_InfoTyp.Information)
End If
Return ""
End Try
CB = Nothing
ds = Nothing
da = Nothing
connection.Close()
connection = Nothing
End Function

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

ModMain Class
ModMain ModMain Members


ModMain.Save_Doc Method

ModMain.Save_Doc Method

ModMain.Save_Doc Method | Previous topic | Next topic
ModMain.Save_Doc Method | Previous topic | Next topic

Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Shared Function Save_Doc() As Boolean

C#

public static bool Save_Doc()

C++

public:
static bool Save_Doc()

JScript

public static function Save_Doc() : boolean;

Source code

Visual Basic

Copy Code Copy Code

Public Function Save_Doc() As Boolean
If Param.DebugMode Then
DivFnkt.InsertJournale("EDKB12: Start Save_Doc", clsDivFnkt.Enum_InfoTyp.Information)
End If

If Save_To_DB(Dokumentid, DokumentFilename) = True Then
If Param.DebugMode Then
DivFnkt.InsertJournale("EDKB12: Ende Save_Doc (True)", clsDivFnkt.Enum_InfoTyp.Information)
End If
Return True
Else
DivFnkt.InsertJournale("EDKB12::Fehler:: Save_Doc::", clsDivFnkt.Enum_InfoTyp.Fehler)
If Param.DebugMode Then
DivFnkt.InsertJournale("EDKB12: Ende Save_Doc (False)::", clsDivFnkt.Enum_InfoTyp.Information)
End If
Return False
End If
End Function

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

ModMain Class
ModMain ModMain Members


ModMain.Save_To_DB Method

ModMain.Save_To_DB Method

ModMain.Save_To_DB Method | Previous topic | Next topic
ModMain.Save_To_DB Method | Previous topic | Next topic

Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Shared Function Save_To_DB( _
ByVal sDokumentID As String, _
ByVal sDokumentName As String _
) As Boolean

C#

public static bool Save_To_DB(
stringsDokumentID,
stringsDokumentName
)

C++

public:
static bool Save_To_DB(
String^ sDokumentID,
String^ sDokumentName
)

JScript

public static function Save_To_DB(
sDokumentID : String,
sDokumentName : String
) : boolean;

Parameters

sDokumentID

sDokumentName

Source code

Visual Basic

Copy Code Copy Code

Public Function Save_To_DB(ByVal sDokumentID As String, ByVal sDokumentName As String) As Boolean
If Param.DebugMode Then
DivFnkt.InsertJournale("EDKB12: Start Save_To_DB", clsDivFnkt.Enum_InfoTyp.Information)
End If

Try

Dim Connection As New SqlConnection()
Dim DA As New SqlDataAdapter("select * from doks where dokumentid='" + Dokumentid + "'", Connection)
Dim cb As SqlCommandBuilder = New SqlCommandBuilder(DA)
Dim ds As New DataSet()
Dim fs As New FileStream(DokumentFilename, FileMode.Open, FileAccess.Read)
Dim mydata(fs.Length) As Byte
Try
fs.Read(mydata, 0, fs.Length)
fs.Close()
Connection.ConnectionString = Param.connectionstring
Connection.Open()
DA.Fill(ds, "docs")
Dim myRow As DataRow
If ds.Tables(0).Rows.Count = 0 Then
' Neues Dokument speichern
myRow = ds.Tables(0).NewRow
myRow.Item(0) = Dokumentid
myRow.Item(1) = mydata
ds.Tables(0).Rows.Add(myRow)
DA.Update(ds, "docs")
Else
'Bestehendes Dokument sichenr
myRow = ds.Tables(0).Rows(0)
myRow.Item(1) = mydata
DA.Update(ds, "docs")
End If
Catch ex As Exception
Return False
End Try
fs = Nothing
cb = Nothing
ds = Nothing
DA = Nothing

Connection.Close()
Connection = Nothing
If Param.DebugMode Then
DivFnkt.InsertJournale("EDKB12: Ende Save_To_DB (True)", clsDivFnkt.Enum_InfoTyp.Information)
End If

Return True
Catch EX As Exception
DivFnkt.InsertJournale("EDKB12::Fehler:: Save_To_DB::" & EX.Message, clsDivFnkt.Enum_InfoTyp.Fehler)
If Param.DebugMode Then
DivFnkt.InsertJournale("EDKB12: Ende Save_To_DB (False)::" & EX.Message, clsDivFnkt.Enum_InfoTyp.Information)
End If
Return False
End Try
End Function

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

ModMain Class
ModMain ModMain Members


ModMain.Send_Message Method

ModMain.Send_Message Method

ModMain.Send_Message Method | Previous topic | Next topic
ModMain.Send_Message Method | Previous topic | Next topic

Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private Shared Sub Send_Message( _
ByVal ok As Boolean, _
ByVal status As Integer _
)

C#

private static System.Void Send_Message(
boolok,
intstatus
)

C++

private:
static System::Void Send_Message(
boolok,
intstatus
)

JScript

private static function Send_Message(
ok : boolean,
status : int
);

Parameters

ok

status

Source code

Visual Basic

Copy Code Copy Code

Private Sub Send_Message(ByVal ok As Boolean, ByVal status As Integer)
Dim betreff As String
Dim meldung As String

If ok Then
betreff = Param.OKMeldungBetreff
meldung = Param.OKMeldung
Else
betreff = Param.NOKMeldungBetreff
meldung = Param.NOKMeldung
End If
betreff = betreff.Replace("#Partnernr#", Trim(Str(Partner.iNRPAR00.Value)))
meldung = meldung.Replace("#Dokumenttyp#", Trim(DokType.sBezeichnung.Value))
meldung = meldung.Replace("#Partnernr#", Trim(Str(Partner.iNRPAR00.Value)))

Dim scmCmdToExecute As SqlCommand = New SqlCommand()
scmCmdToExecute.CommandText = "sp_edkb12_meldung"
scmCmdToExecute.CommandType = CommandType.StoredProcedure
Dim dtToReturn As System.Data.DataTable = New System.Data.DataTable()
Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
Try
scmCmdToExecute.Connection = Globals.conn.scoDBConnection
scmCmdToExecute.Parameters.Add(New SqlParameter("@status", SqlDbType.Int, 225, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, status))
scmCmdToExecute.Parameters.Add(New SqlParameter("@mitarbeiter", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Mitarbeiter.iMitarbeiternr.Value))
scmCmdToExecute.Parameters.Add(New SqlParameter("@betreff", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, betreff))
scmCmdToExecute.Parameters.Add(New SqlParameter("@meldung", SqlDbType.VarChar, 1024, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, meldung))
scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Dokumentid))
sdaAdapter.Fill(dtToReturn)
Return
Catch ex As Exception
DivFnkt.InsertJournale("EDKB12::Fehler:: Send_Message::" & ex.Message, clsDivFnkt.Enum_InfoTyp.Fehler)
If Param.DebugMode Then
DivFnkt.InsertJournale("EDKB12: Ende Send_Message (False)::" & ex.Message, clsDivFnkt.Enum_InfoTyp.Information)
End If
Finally
scmCmdToExecute.Dispose()
sdaAdapter.Dispose()
End Try

End Sub

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

ModMain Class
ModMain ModMain Members


ModMain.Set_EDK_Status Method

ModMain.Set_EDK_Status Method

ModMain.Set_EDK_Status Method | Previous topic | Next topic
ModMain.Set_EDK_Status Method | Previous topic | Next topic

Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private Shared Function Set_EDK_Status( _
ByVal rowid As Integer, _
ByVal status As Integer _
) As DataTable

C#

private static DataTable Set_EDK_Status(
introwid,
intstatus
)

C++

private:
static DataTable^ Set_EDK_Status(
introwid,
intstatus
)

JScript

private static function Set_EDK_Status(
rowid : int,
status : int
) : DataTable;

Parameters

rowid

status

Source code

Visual Basic

Copy Code Copy Code

Private Function Set_EDK_Status(ByVal rowid As Integer, ByVal status As Integer) As System.Data.DataTable
If Param.DebugMode Then
DivFnkt.InsertJournale("EDKB12: Start Set_EDK_Status", clsDivFnkt.Enum_InfoTyp.Information)
End If

Dim scmCmdToExecute As SqlCommand = New SqlCommand()
scmCmdToExecute.CommandText = "sp_edkb12"
scmCmdToExecute.CommandType = CommandType.StoredProcedure
Dim dtToReturn As System.Data.DataTable = New System.Data.DataTable()
Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
Try
scmCmdToExecute.Connection = Globals.conn.scoDBConnection
scmCmdToExecute.Parameters.Add(New SqlParameter("@fnkt", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, 2))
scmCmdToExecute.Parameters.Add(New SqlParameter("@rowid", SqlDbType.Int, 225, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, rowid))
scmCmdToExecute.Parameters.Add(New SqlParameter("@status", SqlDbType.Int, 225, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, status))
sdaAdapter.Fill(dtToReturn)
Return dtToReturn
Catch ex As Exception
DivFnkt.InsertJournale("EDKB12::Fehler:: Set_EDK_Status::" & ex.Message, clsDivFnkt.Enum_InfoTyp.Fehler)
If Param.DebugMode Then
DivFnkt.InsertJournale("EDKB12: Ende Set_EDK_Status (False)::" & ex.Message, clsDivFnkt.Enum_InfoTyp.Information)
End If
Finally
scmCmdToExecute.Dispose()
sdaAdapter.Dispose()
If status = 2 Then Send_Message(False, 2)
If status = 3 Then Send_Message(True, 3)
End Try
End Function

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

ModMain Class
ModMain ModMain Members


ModMain.StartWord Method

ModMain.StartWord Method

ModMain.StartWord Method | Previous topic | Next topic
ModMain.StartWord Method | Previous topic | Next topic

Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private Shared Function StartWord() As Boolean

C#

private static bool StartWord()

C++

private:
static bool StartWord()

JScript

private static function StartWord() : boolean;

Source code

Visual Basic

Copy Code Copy Code

Private Function StartWord() As Boolean
If Param.DebugMode Then
DivFnkt.InsertJournale("EDKB12: Start StartWord", clsDivFnkt.Enum_InfoTyp.Information)
End If
Try
objword = CreateObject("Word.application")
objword.Application.Options.SaveInterval = 0
If Param.DebugMode Then
DivFnkt.InsertJournale("EDKB12: Ende StartWord (True)", clsDivFnkt.Enum_InfoTyp.Information)
End If
Catch ex As Exception
DivFnkt.InsertJournale("EDKB12::Fehler:: StartWord::" & ex.Message, clsDivFnkt.Enum_InfoTyp.Fehler)
If Param.DebugMode Then
DivFnkt.InsertJournale("EDKB12: Ende StartWord (False)::" & ex.Message, clsDivFnkt.Enum_InfoTyp.Information)
End If
Return False
Finally
objword.Visible = False
End Try
Try
'objword.Run("Autoexec")
Catch
End Try
Return True
End Function

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

ModMain Class
ModMain ModMain Members


ModMain.Update_DokumentColdIndexwert Method

ModMain.Update_DokumentColdIndexwert Method

ModMain.Update_DokumentColdIndexwert Method | Previous topic | Next topic
ModMain.Update_DokumentColdIndexwert Method | Previous topic | Next topic

Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Shared Function Update_DokumentColdIndexwert( _
ByVal dokumentid As String, _
ByVal Indextyp As Integer, _
ByVal indexfeld As Integer, _
ByVal wert As String _
) As DataTable

C#

public static DataTable Update_DokumentColdIndexwert(
stringdokumentid,
intIndextyp,
intindexfeld,
stringwert
)

C++

public:
static DataTable^ Update_DokumentColdIndexwert(
String^ dokumentid,
intIndextyp,
intindexfeld,
String^ wert
)

JScript

public static function Update_DokumentColdIndexwert(
dokumentid : String,
Indextyp : int,
indexfeld : int,
wert : String
) : DataTable;

Parameters

dokumentid

Indextyp

indexfeld

wert

Source code

Visual Basic

Copy Code Copy Code

Public Function Update_DokumentColdIndexwert(ByVal dokumentid As String, ByVal Indextyp As Integer, ByVal indexfeld As Integer, ByVal wert As String) As System.Data.DataTable
If Param.DebugMode Then
DivFnkt.InsertJournale("EDKB12: Start Update_DokumentColdIndexwert", clsDivFnkt.Enum_InfoTyp.Information)
End If

Dim scmCmdToExecute As SqlCommand = New SqlCommand()
scmCmdToExecute.CommandText = "dbo.SP_Archiv_Update_DokumentColdIndexwert"
scmCmdToExecute.CommandType = CommandType.StoredProcedure
Dim dtToReturn As System.Data.DataTable = New System.Data.DataTable()
Globals.conn.OpenConnection()
Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentid", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, dokumentid))
scmCmdToExecute.Parameters.Add(New SqlParameter("@indextyp", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Indextyp))
scmCmdToExecute.Parameters.Add(New SqlParameter("@indexfeld", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, indexfeld))
scmCmdToExecute.Parameters.Add(New SqlParameter("@wert", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, wert))
scmCmdToExecute.Connection = Globals.conn.scoDBConnection
Try
sdaAdapter.Fill(dtToReturn)

If Param.DebugMode Then
DivFnkt.InsertJournale("EDKB12: Ende Update_DokumentColdIndexwert (True)", clsDivFnkt.Enum_InfoTyp.Information)
End If

Return dtToReturn
Catch ex As Exception
DivFnkt.InsertJournale("EDKB12::Fehler:: Update_DokumentColdIndexwert::" & ex.Message, clsDivFnkt.Enum_InfoTyp.Fehler)
If Param.DebugMode Then
DivFnkt.InsertJournale("EDKB12: Ende Update_DokumentColdIndexwert (False)::" & ex.Message, clsDivFnkt.Enum_InfoTyp.Information)
End If
Finally
scmCmdToExecute.Dispose()
sdaAdapter.Dispose()
Globals.conn.CloseConnection(True)
End Try
End Function

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

ModMain Class
ModMain ModMain Members


ModMain.Update_FANummer Method

ModMain.Update_FANummer Method

ModMain.Update_FANummer Method | Previous topic | Next topic
ModMain.Update_FANummer Method | Previous topic | Next topic

Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private Shared Function Update_FANummer( _
ByVal fanummer3 As String _
) As DataTable

C#

private static DataTable Update_FANummer(
stringfanummer3
)

C++

private:
static DataTable^ Update_FANummer(
String^ fanummer3
)

JScript

private static function Update_FANummer(
fanummer3 : String
) : DataTable;

Parameters

fanummer3

Source code

Visual Basic

Copy Code Copy Code

Private Function Update_FANummer(ByVal fanummer3 As String) As System.Data.DataTable
If Param.DebugMode Then
DivFnkt.InsertJournale("EDKB12: Start Get_EDK_Data", clsDivFnkt.Enum_InfoTyp.Information)
End If

Dim scmCmdToExecute As SqlCommand = New SqlCommand()
scmCmdToExecute.CommandText = "sp_edoka_import_update_fanummer"
scmCmdToExecute.CommandType = CommandType.StoredProcedure
Dim dtToReturn As System.Data.DataTable = New System.Data.DataTable()
Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)
Try
scmCmdToExecute.Connection = Globals.conn.scoDBConnection
scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumentid", SqlDbType.VarChar, 225, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, Dokumentid))
scmCmdToExecute.Parameters.Add(New SqlParameter("@fanummer2", SqlDbType.VarChar, 225, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, ""))
If fanummer3 <> "" Then
scmCmdToExecute.Parameters.Add(New SqlParameter("@fanummer1", SqlDbType.VarChar, 225, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, "Ordernr: " & fanummer3))
scmCmdToExecute.Parameters.Add(New SqlParameter("@fanummer3", SqlDbType.VarChar, 225, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, "Avalog: " & fanummer3))
Else
scmCmdToExecute.Parameters.Add(New SqlParameter("@fanummer1", SqlDbType.VarChar, 225, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, ""))
scmCmdToExecute.Parameters.Add(New SqlParameter("@fanummer3", SqlDbType.VarChar, 225, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, ""))
End If
sdaAdapter.Fill(dtToReturn)
Return dtToReturn
Catch ex As Exception
DivFnkt.InsertJournale("EDKB12::Fehler:: Get_EDK_Data::" & ex.Message, clsDivFnkt.Enum_InfoTyp.Fehler)
If Param.DebugMode Then
DivFnkt.InsertJournale("EDKB12: Ende Get_EDK_Data (False)::" & ex.Message, clsDivFnkt.Enum_InfoTyp.Information)
End If
Finally
scmCmdToExecute.Dispose()
sdaAdapter.Dispose()
End Try
End Function

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

ModMain Class
ModMain ModMain Members


ModMain.Word_Werte_Auslesen Method

ModMain.Word_Werte_Auslesen Method

ModMain.Word_Werte_Auslesen Method | Previous topic | Next topic
ModMain.Word_Werte_Auslesen Method | Previous topic | Next topic

Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Shared Function Word_Werte_Auslesen( _
ByVal xdata As DataTable _
) As Boolean

C#

public static bool Word_Werte_Auslesen(
DataTablexdata
)

C++

public:
static bool Word_Werte_Auslesen(
DataTable^ xdata
)

JScript

public static function Word_Werte_Auslesen(
xdata : DataTable
) : boolean;

Parameters

xdata

Source code

Visual Basic

Copy Code Copy Code

Public Function Word_Werte_Auslesen(ByVal xdata As System.Data.DataTable) As Boolean
Try
Dim i As Integer
Dim pos, pos2 As Integer
For i = 0 To xdata.Rows.Count - 1
xdata.Rows(i).Item("used") = 0
If xdata.Rows(i).Item("beginntextmarke") <> "" And xdata.Rows(i).Item("endetextmarke") = "" Then
Try
docword.Bookmarks.Item(xdata.Rows(i).Item("beginntextmarke")).Select()
xdata.Rows(i).Item("oldvalue") = convert(objword.Selection.Text)
xdata.Rows(i).Item("used") = 1
Catch
End Try
If xdata.Rows(i).Item("beginntextmarke") = "TGEDKCompanyBBEB99" Then xdata.Rows(i).Item("used") = 1
End If
If xdata.Rows(i).Item("beginntextmarke") <> "" And xdata.Rows(i).Item("endetextmarke") <> "" Then
Try
docword.Bookmarks.Item(xdata.Rows(i).Item("beginntextmarke")).Select()
pos = objword.Selection.Start
docword.Bookmarks.Item(xdata.Rows(i).Item("endetextmarke")).Select()
pos2 = objword.Selection.Start
objword.Selection.SetRange(Start:=pos, End:=pos2)
xdata.Rows(i).Item("oldvalue") = convert(objword.Selection.Text)
xdata.Rows(i).Item("used") = 1
Catch
End Try
End If
Try
If xdata.Rows(i).Item("feldname") <> "" Then
Try
xdata.Rows(i).Item("oldvalue") = convert(docword.FormFields.Item(xdata.Rows(i).Item("feldname")).Result)
xdata.Rows(i).Item("used") = 1
Catch
End Try
End If
Catch
End Try
Next
Return True
Catch ex As Exception
Return False
End Try

End Function

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

ModMain Class
ModMain ModMain Members


ModMain.convert Method

ModMain.convert Method

ModMain.convert Method | Previous topic | Next topic
ModMain.convert Method | Previous topic | Next topic

Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Shared Function convert( _
ByVal x As String _
) As String

C#

public static string convert(
stringx
)

C++

public:
static String^ convert(
String^ x
)

JScript

public static function convert(
x : String
) : String;

Parameters

x

Source code

Visual Basic

Copy Code Copy Code

Function convert(ByVal x As String) As String
Dim s As String
Dim s1 As String
Dim i As Integer
s = x
i = InStr(s, Chr(13))
While i > 0
s = Left(s, i - 1) & "#" & Right(s, Len(s) - (i))
If Mid(s, i + 1, 1) = Chr(10) Then
s = Left(s, i) & Right(s, Len(s) - (i + 1))
End If
i = InStr(s, Chr(13))
End While
i = InStr(s, "#")
While i > 0
s = Left(s, i - 1) & vbCrLf & Right(s, Len(s) - (i))
i = InStr(s, "#")
End While
convert = s
End Function

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

ModMain Class
ModMain ModMain Members


ModMain.convert_wordfelder Method

ModMain.convert_wordfelder Method

ModMain.convert_wordfelder Method | Previous topic | Next topic
ModMain.convert_wordfelder Method | Previous topic | Next topic

Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Shared Function convert_wordfelder( _
ByVal x As String _
) As String

C#

public static string convert_wordfelder(
stringx
)

C++

public:
static String^ convert_wordfelder(
String^ x
)

JScript

public static function convert_wordfelder(
x : String
) : String;

Parameters

x

Source code

Visual Basic

Copy Code Copy Code

Function convert_wordfelder(ByVal x As String) As String
Dim s As String
Dim s1 As String
Dim i As Integer
s = x
i = InStr(s, Chr(13))
While i > 0
s = Left(s, i - 1) & "#" & Right(s, Len(s) - (i))
If Mid(s, i + 1, 1) = Chr(10) Then
s = Left(s, i) & Right(s, Len(s) - (i + 1))
End If
i = InStr(s, Chr(13))
End While
i = InStr(s, "#")
While i > 0
s = Left(s, i - 1) & Chr(11) & Right(s, Len(s) - (i))
i = InStr(s, "#")
End While
convert_wordfelder = s
End Function

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

ModMain Class
ModMain ModMain Members


ModMain.delete_Textfelder Method

ModMain.delete_Textfelder Method

ModMain.delete_Textfelder Method | Previous topic | Next topic
ModMain.delete_Textfelder Method | Previous topic | Next topic

Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private Shared Sub delete_Textfelder()

C#

private static System.Void delete_Textfelder()

C++

private:
static System::Void delete_Textfelder()

JScript

private static function delete_Textfelder();

Source code

Visual Basic

Copy Code Copy Code

Private Sub delete_Textfelder()
Dim xname As String
Dim i As Integer
Dim i1 As Integer
Dim pages As Long
Dim Prop As Object
objword.Selection.HomeKey(Unit:=WdUnits.wdStory)

For Each Prop In objWord.ActiveDocument.BuiltInDocumentProperties
If UCase(Prop.Name) = "NUMBER OF PAGES" Then
pages = Prop.value
End If
Next
For i = 1 To pages
xname = Str(i)
If Left(xname, 1) = " " Then xname = Right(xname, Len(xname) - 1)
objword.Selection.GoTo(What:=WdGoToItem.wdGoToPage, Name:=xname)
HeaderFooterAnzeigen()
While objWord.Selection.HeaderFooter.Shapes.Count > 0
objWord.Selection.HeaderFooter.Shapes.Item(1).Delete()
End While
objword.ActiveWindow.ActivePane.View.SeekView = WdSeekView.wdSeekMainDocument
Next i
Exit Sub
eh:
Resume Next
End Sub

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

ModMain Class
ModMain ModMain Members


ModMain.ins_Barcode Method

ModMain.ins_Barcode Method

ModMain.ins_Barcode Method | Previous topic | Next topic
ModMain.ins_Barcode Method | Previous topic | Next topic

Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private Shared Sub ins_Barcode()

C#

private static System.Void ins_Barcode()

C++

private:
static System::Void ins_Barcode()

JScript

private static function ins_Barcode();

Source code

Visual Basic

Copy Code Copy Code

Private Sub ins_Barcode()
Dim xname As String
Dim i As Integer
Dim pages As Long
Dim prop As Object
For Each prop In objWord.ActiveDocument.BuiltInDocumentProperties
If UCase(prop.Name) = "NUMBER OF PAGES" Then
pages = prop.value
End If
Next

objword.Selection.HomeKey(Unit:=WdUnits.wdStory)
Textboxesi = 1
For i = 1 To pages
xname = Str(i)
If Left(xname, 1) = " " Then xname = Right(xname, Len(xname) - 1)
objword.Selection.GoTo(What:=WdGoToItem.wdGoToPage, Name:=xname)
HeaderFooterAnzeigen()
insert_Barcode(i)
Textboxesi = Textboxesi + 1
objWord.ActiveWindow.ActivePane.View.SeekView = WdSeekView.wdSeekMainDocument
Next i
End Sub

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

ModMain Class
ModMain ModMain Members


ModMain.insert_Barcode Method

ModMain.insert_Barcode Method

ModMain.insert_Barcode Method | Previous topic | Next topic
ModMain.insert_Barcode Method | Previous topic | Next topic

Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private Shared Sub insert_Barcode( _
ByVal x As Integer _
)

C#

private static System.Void insert_Barcode(
intx
)

C++

private:
static System::Void insert_Barcode(
intx
)

JScript

private static function insert_Barcode(
x : int
);

Parameters

x

Source code

Visual Basic

Copy Code Copy Code

Private Sub insert_Barcode(ByVal x As Integer)

Dim Form
Dim strsel As String
Dim strresult
Dim s As String
' Selection.ShapeRange.Select
If DokType.bZu_retournieren.Value = True Then
Try
Form = objword.Selection.HeaderFooter.Shapes.Item(Textboxes(Textboxesi))
Form.Select()
Form = objword.Selection.HeaderFooter.Shapes.Item(Textboxes(Textboxesi))
Form.Select()
If OfficeVorlage.bBchorizontal.Value = False Then
objword.ActiveDocument.Tables.Add(Range:=objword.Selection.Range, NumRows:=1, NumColumns:=1)
With objword.Selection.Tables.Item(1)
.Borders.Item(WdBorderType.wdBorderLeft).LineStyle = WdLineStyle.wdLineStyleNone
.Borders.Item(WdBorderType.wdBorderRight).LineStyle = WdLineStyle.wdLineStyleNone
.Borders.Item(WdBorderType.wdBorderTop).LineStyle = WdLineStyle.wdLineStyleNone
.Borders.Item(WdBorderType.wdBorderBottom).LineStyle = WdLineStyle.wdLineStyleNone
.Borders.Item(WdBorderType.wdBorderDiagonalDown).LineStyle = WdLineStyle.wdLineStyleNone
.Borders.Item(WdBorderType.wdBorderDiagonalUp).LineStyle = WdLineStyle.wdLineStyleNone
.Borders.Shadow = False
End With
objword.Selection.Orientation = WdTextOrientation.wdTextOrientationUpward
objword.Selection.Tables.Item(1).Rows.HeightRule = WdRowHeightRule.wdRowHeightAtLeast
objword.Selection.Tables.Item(1).Rows.Height = Form.height
End If
'gaga'
Dim id As String
id = Dokumentid
s = Bar25I(Microsoft.VisualBasic.Right(Right(id, Len(id) - 6), 16))
objword.Selection.TypeText(Text:=s)
objword.Selection.HomeKey(Unit:=WdUnits.wdLine, Extend:=WdMovementType.wdExtend)
objword.Selection.Font.Name = Globals.Applikationsdaten.Rows(Globals.AppldataRow).Item("barcode_font")
objword.Selection.Font.Size = Globals.Applikationsdaten.Rows(Globals.AppldataRow).Item("bcfont_groesse")
objword.Selection.ParagraphFormat.Alignment = WdParagraphAlignment.wdAlignParagraphRight
objword.Selection.EndKey(Unit:=WdUnits.wdLine)
objword.Selection.Font.Name = "Arial"
objword.Selection.Font.Size = 8

Dim Zeichen As String
Select Case DokType.iPhysisches_archiv.Value
Case 0
Case 1
Zeichen = " U"
Case 2
Zeichen = " F"
End Select
objword.Selection.TypeText(Zeichen)
Form = Nothing
Catch ex As Exception
End Try
End If
End Sub

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

ModMain Class
ModMain ModMain Members


ModMain.insert_Textfield Method

ModMain.insert_Textfield Method

ModMain.insert_Textfield Method | Previous topic | Next topic
ModMain.insert_Textfield Method | Previous topic | Next topic

Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private Shared Sub insert_Textfield()

C#

private static System.Void insert_Textfield()

C++

private:
static System::Void insert_Textfield()

JScript

private static function insert_Textfield();

Source code

Visual Basic

Copy Code Copy Code

Private Sub insert_Textfield()
Dim Public_barcodeleft
Dim Public_barcodetop
Dim Public_barcodewidth#
Dim Public_barcodeheight
Try
Public_barcodeleft = OfficeVorlage.iBcpl.Value
Public_barcodetop = OfficeVorlage.iBcpt.Value
Public_barcodewidth = OfficeVorlage.iBcw.Value
Public_barcodeheight = OfficeVorlage.iBch.Value

HeaderFooterAnzeigen()
objWord.Selection.HeaderFooter.Shapes.AddTextbox(1, Public_barcodeleft, Public_barcodetop, _
Public_barcodewidth#, Public_barcodeheight).Select()
' objWord.Selection.ShapeRange.TextFrame.TextRange.Select
objword.Selection.ShapeRange.Line.Visible = Microsoft.Office.Core.MsoTriState.msoFalse
'objWord.Selection.ShapeRange.Line.Visible = Microsoft.Office.Core.MsoTriState.msoFalse 'RS:2006-08-22
objWord.Selection.ShapeRange.TextFrame.MarginLeft = 0.0#
objWord.Selection.ShapeRange.TextFrame.MarginRight = 0.0#
objWord.Selection.ShapeRange.TextFrame.MarginTop = 0.0#
objWord.Selection.ShapeRange.TextFrame.MarginBottom = 0.0#
objWord.Selection.Collapse()
Textboxes(Textboxesi) = objWord.Selection.HeaderFooter.Shapes.Item(Textboxesi).Name
Textboxesi = Textboxesi + 1
'System.Windows.Forms.Application.DoEvents()
Exit Sub

Catch ex As Exception
'MsgBox(ex.Message)
End Try

End Sub

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

ModMain Class
ModMain ModMain Members


ModMain.insert_history_status Method

ModMain.insert_history_status Method

ModMain.insert_history_status Method | Previous topic | Next topic
ModMain.insert_history_status Method | Previous topic | Next topic

Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Shared Sub insert_history_status( _
ByVal statusnr As Integer, _
ByVal dokumentid As String, _
ByVal Verantwortlicher As Integer, _
ByVal datumzeit As Date _
)

C#

public static System.Void insert_history_status(
intstatusnr,
stringdokumentid,
intVerantwortlicher,
DateTimedatumzeit
)

C++

public:
static System::Void insert_history_status(
intstatusnr,
String^ dokumentid,
intVerantwortlicher,
DateTimedatumzeit
)

JScript

public static function insert_history_status(
statusnr : int,
dokumentid : String,
Verantwortlicher : int,
datumzeit : DateTime
);

Parameters

statusnr

dokumentid

Verantwortlicher

datumzeit

Source code

Visual Basic

Copy Code Copy Code

Public Sub insert_history_status(ByVal statusnr As Integer, ByVal dokumentid As String, ByVal Verantwortlicher As Integer, ByVal datumzeit As DateTime)
If Param.DebugMode Then
DivFnkt.InsertJournale("EDKB12: Start insert_history_status", clsDivFnkt.Enum_InfoTyp.Information)
End If
Try
Dim sh As New edokadb.clsStatushistory()
Dim dbkey As New edokadb.clsMyKey_Tabelle()
Dim key As Long
dbkey.cpMainConnectionProvider = Globals.conn
key = dbkey.get_dbkey("statushistory")
sh.cpMainConnectionProvider = Globals.conn
sh.iStatushistorynr = New SqlInt32(CType(key, Int32))
sh.iStatus = New SqlInt32(CType(statusnr, Int32))
sh.iMandantnr = New SqlInt32(CType(1, Int32))
sh.iMutierer = New SqlInt32(CType(Mitarbeiter.iMitarbeiternr.Value, Int32))
sh.bAktiv = New SqlBoolean(True)
sh.daErstellt_am = New SqlDateTime(CType(datumzeit, DateTime))
sh.daMutiert_am = New SqlDateTime(CType(datumzeit, DateTime))
sh.sDokumentid = New SqlString(CType(dokumentid, String))
sh.iVerantwortlich = New SqlInt32(CType(Verantwortlicher, Int32))
Try
Globals.conn.OpenConnection()
Catch
End Try
sh.Insert()
Try
Globals.conn.CloseConnection(True)
Catch
End Try
dbkey.Dispose()
sh.Dispose()
If Param.DebugMode Then
DivFnkt.InsertJournale("EDKB12: Ende insert_history_status (True)", clsDivFnkt.Enum_InfoTyp.Information)
End If
Catch ex As Exception
DivFnkt.InsertJournale("EDKB12::Fehler:: insert_history_status::" & ex.Message, clsDivFnkt.Enum_InfoTyp.Fehler)
If Param.DebugMode Then
DivFnkt.InsertJournale("EDKB12: Ende insert_history_status (False)::" & ex.Message, clsDivFnkt.Enum_InfoTyp.Information)
End If
End Try

End Sub

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

ModMain Class
ModMain ModMain Members


ModMain.set_headerbookmark Method

ModMain.set_headerbookmark Method

ModMain.set_headerbookmark Method | Previous topic | Next topic
ModMain.set_headerbookmark Method | Previous topic | Next topic

Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private Shared Sub set_headerbookmark()

C#

private static System.Void set_headerbookmark()

C++

private:
static System::Void set_headerbookmark()

JScript

private static function set_headerbookmark();

Source code

Visual Basic

Copy Code Copy Code

Private Sub set_headerbookmark()
Try
docword.Bookmarks.Item("TGEDKCompanyBBEB99").Select()
Catch
objword.Selection.MoveDown(Unit:=WdUnits.wdLine, Count:=1)
With objword.ActiveDocument.Bookmarks
.Add(Range:=objword.Selection.Range, Name:="TGEDKCompanyBBEB99")
.DefaultSorting = WdBookmarkSortBy.wdSortByName
.ShowHidden = False
End With
End Try
End Sub

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

ModMain Class
ModMain ModMain Members


ModMain Fields

ModMain Fields

ModMain Fields | Previous topic | Next topic
ModMain Fields | Previous topic | Next topic

Fields

 | Name | Description
Supported by the .NET Compact Framework. | BarTextIn |
Supported by the .NET Compact Framework. | BarTextOut |
Supported by the .NET Compact Framework. | CharValue |
Supported by the .NET Compact Framework. | CheckSum |
Supported by the .NET Compact Framework. | DoCheckSum |
Supported by the .NET Compact Framework. | Dok |
Supported by the .NET Compact Framework. | DokType |
Supported by the .NET Compact Framework. | DokumentFilename |
Supported by the .NET Compact Framework. | Dokumentdaten |
Supported by the .NET Compact Framework. | Dokumentid |
Supported by the .NET Compact Framework. | EDK_Data |
Supported by the .NET Compact Framework. | EDK_Daten |
Supported by the .NET Compact Framework. | FileExtension |
Supported by the .NET Compact Framework. | Filename |
Supported by the .NET Compact Framework. | II |
Supported by the .NET Compact Framework. | IsProtected |
Supported by the .NET Compact Framework. | Mitarbeiter |
Supported by the .NET Compact Framework. | Mitarbeiterdata |
Supported by the .NET Compact Framework. | OfficeVorlage |
Supported by the .NET Compact Framework. | OfficeVorlageDatei |
Supported by the .NET Compact Framework. | Partner |
Supported by the .NET Compact Framework. | Profile |
Supported by the .NET Compact Framework. | Profilnr |
Supported by the .NET Compact Framework. | RowId |
Supported by the .NET Compact Framework. | Sum |
Supported by the .NET Compact Framework. | Teamnr |
Supported by the .NET Compact Framework. | Teams |
Supported by the .NET Compact Framework. | TempString |
Supported by the .NET Compact Framework. | Textboxes |
Supported by the .NET Compact Framework. | Textboxesi |
Supported by the .NET Compact Framework. | Unterschriftlinks |
Supported by the .NET Compact Framework. | Unterschriftrechts |
Supported by the .NET Compact Framework. | args |
Supported by the .NET Compact Framework. | barcodeout |
Supported by the .NET Compact Framework. | tmpAction |
Supported by the .NET Compact Framework. | xMitarbeiter |
Supported by the .NET Compact Framework. | xdata |

Top

See Also

Reference

ModMain Class


BarTextIn Field

BarTextIn Field

BarTextIn Field | Previous topic | Next topic
BarTextIn Field | Previous topic | Next topic

Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private Shared BarTextIn As String

C#

private static string BarTextIn

C++

private:
static String^ BarTextIn;

JScript

private static BarTextIn : String

Source code

Visual Basic

Copy Code Copy Code

Private BarTextIn As String

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

ModMain Class
ModMain ModMain Members


BarTextOut Field

BarTextOut Field

BarTextOut Field | Previous topic | Next topic
BarTextOut Field | Previous topic | Next topic

Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private Shared BarTextOut As String

C#

private static string BarTextOut

C++

private:
static String^ BarTextOut;

JScript

private static BarTextOut : String

Source code

Visual Basic

Copy Code Copy Code

Private BarTextOut As String

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

ModMain Class
ModMain ModMain Members


CharValue Field

CharValue Field

CharValue Field | Previous topic | Next topic
CharValue Field | Previous topic | Next topic

Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private Shared CharValue As Long

C#

private static long CharValue

C++

private:
static long CharValue;

JScript

private static CharValue : long

Source code

Visual Basic

Copy Code Copy Code

Private CharValue As Long

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

ModMain Class
ModMain ModMain Members


CheckSum Field

CheckSum Field

CheckSum Field | Previous topic | Next topic
CheckSum Field | Previous topic | Next topic

Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private Shared CheckSum As Integer

C#

private static int CheckSum

C++

private:
static int CheckSum;

JScript

private static CheckSum : int

Source code

Visual Basic

Copy Code Copy Code

Private CheckSum As Integer

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

ModMain Class
ModMain ModMain Members


DoCheckSum Field

DoCheckSum Field

DoCheckSum Field | Previous topic | Next topic
DoCheckSum Field | Previous topic | Next topic

Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private Shared DoCheckSum As Integer

C#

private static int DoCheckSum

C++

private:
static int DoCheckSum;

JScript

private static DoCheckSum : int

Source code

Visual Basic

Copy Code Copy Code

Private DoCheckSum As Integer

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

ModMain Class
ModMain ModMain Members


Dok Field

Dok Field

Dok Field | Previous topic | Next topic
Dok Field | Previous topic | Next topic

Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private Shared Dok As clsDokument

C#

private static clsDokument Dok

C++

private:
static clsDokument^ Dok;

JScript

private static Dok : clsDokument

Source code

Visual Basic

Copy Code Copy Code

Dim Dok As New edokadb.clsDokument

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

ModMain Class
ModMain ModMain Members


DokType Field

DokType Field

DokType Field | Previous topic | Next topic
DokType Field | Previous topic | Next topic

Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private Shared DokType As clsDokumenttyp

C#

private static clsDokumenttyp DokType

C++

private:
static clsDokumenttyp^ DokType;

JScript

private static DokType : clsDokumenttyp

Source code

Visual Basic

Copy Code Copy Code

Dim DokType As New edokadb.clsDokumenttyp

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

ModMain Class
ModMain ModMain Members


DokumentFilename Field

DokumentFilename Field

DokumentFilename Field | Previous topic | Next topic
DokumentFilename Field | Previous topic | Next topic

Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private Shared DokumentFilename As String

C#

private static string DokumentFilename

C++

private:
static String^ DokumentFilename;

JScript

private static DokumentFilename : String

Source code

Visual Basic

Copy Code Copy Code

Dim DokumentFilename As String

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

ModMain Class
ModMain ModMain Members


Dokumentdaten Field

Dokumentdaten Field

Dokumentdaten Field | Previous topic | Next topic
Dokumentdaten Field | Previous topic | Next topic

Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private Shared Dokumentdaten As DataTable

C#

private static DataTable Dokumentdaten

C++

private:
static DataTable^ Dokumentdaten;

JScript

private static Dokumentdaten : DataTable

Source code

Visual Basic

Copy Code Copy Code

Dim Dokumentdaten As New System.Data.DataTable

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

ModMain Class
ModMain ModMain Members


Dokumentid Field

Dokumentid Field

Dokumentid Field | Previous topic | Next topic
Dokumentid Field | Previous topic | Next topic

Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private Shared Dokumentid As String

C#

private static string Dokumentid

C++

private:
static String^ Dokumentid;

JScript

private static Dokumentid : String

Source code

Visual Basic

Copy Code Copy Code

Dim Dokumentid As String

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

ModMain Class
ModMain ModMain Members


EDK_Data Field

EDK_Data Field

EDK_Data Field | Previous topic | Next topic
EDK_Data Field | Previous topic | Next topic

Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private Shared EDK_Data As DataSet

C#

private static DataSet EDK_Data

C++

private:
static DataSet^ EDK_Data;

JScript

private static EDK_Data : DataSet

Source code

Visual Basic

Copy Code Copy Code

Dim EDK_Data As New DataSet

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

ModMain Class
ModMain ModMain Members


EDK_Daten Field

EDK_Daten Field

EDK_Daten Field | Previous topic | Next topic
EDK_Daten Field | Previous topic | Next topic

Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private Shared EDK_Daten As DataTable

C#

private static DataTable EDK_Daten

C++

private:
static DataTable^ EDK_Daten;

JScript

private static EDK_Daten : DataTable

Source code

Visual Basic

Copy Code Copy Code

Dim EDK_Daten As New System.Data.DataTable

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

ModMain Class
ModMain ModMain Members


FileExtension Field

FileExtension Field

FileExtension Field | Previous topic | Next topic
FileExtension Field | Previous topic | Next topic

Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private Shared FileExtension As String

C#

private static string FileExtension

C++

private:
static String^ FileExtension;

JScript

private static FileExtension : String

Source code

Visual Basic

Copy Code Copy Code

Dim FileExtension As String = ""

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

ModMain Class
ModMain ModMain Members


Filename Field

Filename Field

Filename Field | Previous topic | Next topic
Filename Field | Previous topic | Next topic

Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private Shared Filename As String

C#

private static string Filename

C++

private:
static String^ Filename;

JScript

private static Filename : String

Source code

Visual Basic

Copy Code Copy Code

Dim Filename As String

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

ModMain Class
ModMain ModMain Members


II Field

II Field

II Field | Previous topic | Next topic
II Field | Previous topic | Next topic

Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private Shared II As Integer

C#

private static int II

C++

private:
static int II;

JScript

private static II : int

Source code

Visual Basic

Copy Code Copy Code

Private II As Integer

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

ModMain Class
ModMain ModMain Members


IsProtected Field

IsProtected Field

IsProtected Field | Previous topic | Next topic
IsProtected Field | Previous topic | Next topic

Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private Shared IsProtected As Boolean

C#

private static bool IsProtected

C++

private:
static bool IsProtected;

JScript

private static IsProtected : boolean

Source code

Visual Basic

Copy Code Copy Code

Dim IsProtected As Boolean = False

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

ModMain Class
ModMain ModMain Members


Mitarbeiter Field

Mitarbeiter Field

Mitarbeiter Field | Previous topic | Next topic
Mitarbeiter Field | Previous topic | Next topic

Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private Shared Mitarbeiter As clsMitarbeiter

C#

private static clsMitarbeiter Mitarbeiter

C++

private:
static clsMitarbeiter^ Mitarbeiter;

JScript

private static Mitarbeiter : clsMitarbeiter

Source code

Visual Basic

Copy Code Copy Code

Dim Mitarbeiter As New edokadb.clsMitarbeiter

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

ModMain Class
ModMain ModMain Members


Mitarbeiterdata Field

Mitarbeiterdata Field

Mitarbeiterdata Field | Previous topic | Next topic
Mitarbeiterdata Field | Previous topic | Next topic

Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private Shared Mitarbeiterdata As DataTable

C#

private static DataTable Mitarbeiterdata

C++

private:
static DataTable^ Mitarbeiterdata;

JScript

private static Mitarbeiterdata : DataTable

Source code

Visual Basic

Copy Code Copy Code

Dim Mitarbeiterdata As New System.Data.DataTable

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

ModMain Class
ModMain ModMain Members


OfficeVorlage Field

OfficeVorlage Field

OfficeVorlage Field | Previous topic | Next topic
OfficeVorlage Field | Previous topic | Next topic

Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private Shared OfficeVorlage As clsOffice_vorlage

C#

private static clsOffice_vorlage OfficeVorlage

C++

private:
static clsOffice_vorlage^ OfficeVorlage;

JScript

private static OfficeVorlage : clsOffice_vorlage

Source code

Visual Basic

Copy Code Copy Code

Dim OfficeVorlage As New edokadb.clsOffice_vorlage

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

ModMain Class
ModMain ModMain Members


OfficeVorlageDatei Field

OfficeVorlageDatei Field

OfficeVorlageDatei Field | Previous topic | Next topic
OfficeVorlageDatei Field | Previous topic | Next topic

Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private Shared OfficeVorlageDatei As clsOffice_Vorlage_Datei

C#

private static clsOffice_Vorlage_Datei OfficeVorlageDatei

C++

private:
static clsOffice_Vorlage_Datei^ OfficeVorlageDatei;

JScript

private static OfficeVorlageDatei : clsOffice_Vorlage_Datei

Source code

Visual Basic

Copy Code Copy Code

Dim OfficeVorlageDatei As New edokadb.clsOffice_Vorlage_Datei

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

ModMain Class
ModMain ModMain Members


Partner Field

Partner Field

Partner Field | Previous topic | Next topic
Partner Field | Previous topic | Next topic

Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private Shared Partner As clsPartner

C#

private static clsPartner Partner

C++

private:
static clsPartner^ Partner;

JScript

private static Partner : clsPartner

Source code

Visual Basic

Copy Code Copy Code

Dim Partner As New edokadb.clsPartner

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

ModMain Class
ModMain ModMain Members


Profile Field

Profile Field

Profile Field | Previous topic | Next topic
Profile Field | Previous topic | Next topic

Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private Shared Profile As DataTable

C#

private static DataTable Profile

C++

private:
static DataTable^ Profile;

JScript

private static Profile : DataTable

Source code

Visual Basic

Copy Code Copy Code

Dim Profile As New System.Data.DataTable

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

ModMain Class
ModMain ModMain Members


Profilnr Field

Profilnr Field

Profilnr Field | Previous topic | Next topic
Profilnr Field | Previous topic | Next topic

Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private Shared Profilnr As Integer

C#

private static int Profilnr

C++

private:
static int Profilnr;

JScript

private static Profilnr : int

Source code

Visual Basic

Copy Code Copy Code

Dim Profilnr As Integer

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

ModMain Class
ModMain ModMain Members


RowId Field

RowId Field

RowId Field | Previous topic | Next topic
RowId Field | Previous topic | Next topic

Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private Shared RowId As Integer

C#

private static int RowId

C++

private:
static int RowId;

JScript

private static RowId : int

Source code

Visual Basic

Copy Code Copy Code

Dim RowId As Integer

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

ModMain Class
ModMain ModMain Members


Sum Field

Sum Field

Sum Field | Previous topic | Next topic
Sum Field | Previous topic | Next topic

Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private Shared Sum As Long

C#

private static long Sum

C++

private:
static long Sum;

JScript

private static Sum : long

Source code

Visual Basic

Copy Code Copy Code

Private Sum As Long

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

ModMain Class
ModMain ModMain Members


Teamnr Field

Teamnr Field

Teamnr Field | Previous topic | Next topic
Teamnr Field | Previous topic | Next topic

Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private Shared Teamnr As Integer

C#

private static int Teamnr

C++

private:
static int Teamnr;

JScript

private static Teamnr : int

Source code

Visual Basic

Copy Code Copy Code

Dim Teamnr As Integer

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

ModMain Class
ModMain ModMain Members


Teams Field

Teams Field

Teams Field | Previous topic | Next topic
Teams Field | Previous topic | Next topic

Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private Shared Teams As DataTable

C#

private static DataTable Teams

C++

private:
static DataTable^ Teams;

JScript

private static Teams : DataTable

Source code

Visual Basic

Copy Code Copy Code

Dim Teams As New System.Data.DataTable

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

ModMain Class
ModMain ModMain Members


TempString Field

TempString Field

TempString Field | Previous topic | Next topic
TempString Field | Previous topic | Next topic

Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private Shared TempString As String

C#

private static string TempString

C++

private:
static String^ TempString;

JScript

private static TempString : String

Source code

Visual Basic

Copy Code Copy Code

Private TempString As String

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

ModMain Class
ModMain ModMain Members


Textboxes Field

Textboxes Field

Textboxes Field | Previous topic | Next topic
Textboxes Field | Previous topic | Next topic

Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private Shared Textboxes As String()

C#

private static string[] Textboxes

C++

private:
static array< String^ >^ Textboxes;

JScript

private static Textboxes : String[]

Source code

Visual Basic

Copy Code Copy Code

Dim Textboxes(100) As String

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

ModMain Class
ModMain ModMain Members


Textboxesi Field

Textboxesi Field

Textboxesi Field | Previous topic | Next topic
Textboxesi Field | Previous topic | Next topic

Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private Shared Textboxesi As Integer

C#

private static int Textboxesi

C++

private:
static int Textboxesi;

JScript

private static Textboxesi : int

Source code

Visual Basic

Copy Code Copy Code

Dim Textboxesi As Integer

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

ModMain Class
ModMain ModMain Members


Unterschriftlinks Field

Unterschriftlinks Field

Unterschriftlinks Field | Previous topic | Next topic
Unterschriftlinks Field | Previous topic | Next topic

Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private Shared Unterschriftlinks As Integer

C#

private static int Unterschriftlinks

C++

private:
static int Unterschriftlinks;

JScript

private static Unterschriftlinks : int

Source code

Visual Basic

Copy Code Copy Code

Dim Unterschriftlinks As Integer

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

ModMain Class
ModMain ModMain Members


Unterschriftrechts Field

Unterschriftrechts Field

Unterschriftrechts Field | Previous topic | Next topic
Unterschriftrechts Field | Previous topic | Next topic

Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private Shared Unterschriftrechts As Integer

C#

private static int Unterschriftrechts

C++

private:
static int Unterschriftrechts;

JScript

private static Unterschriftrechts : int

Source code

Visual Basic

Copy Code Copy Code

Dim Unterschriftrechts As Integer

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

ModMain Class
ModMain ModMain Members


args Field

args Field

args Field | Previous topic | Next topic
args Field | Previous topic | Next topic

Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private Shared args As String()

C#

private static string[] args

C++

private:
static array< String^ >^ args;

JScript

private static args : String[]

Source code

Visual Basic

Copy Code Copy Code

Dim args As String() = Environment.GetCommandLineArgs()

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

ModMain Class
ModMain ModMain Members


barcodeout Field

barcodeout Field

barcodeout Field | Previous topic | Next topic
barcodeout Field | Previous topic | Next topic

Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private Shared barcodeout As Object

C#

private static object barcodeout

C++

private:
static object^ barcodeout;

JScript

private static barcodeout : object

Source code

Visual Basic

Copy Code Copy Code

Private barcodeout

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

ModMain Class
ModMain ModMain Members


tmpAction Field

tmpAction Field

tmpAction Field | Previous topic | Next topic
tmpAction Field | Previous topic | Next topic

Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private Shared tmpAction As Action

C#

private static Action tmpAction

C++

private:
static Action^ tmpAction;

JScript

private static tmpAction : Action

Source code

Visual Basic

Copy Code Copy Code

Dim tmpAction As Action

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

ModMain Class
ModMain ModMain Members


xMitarbeiter Field

xMitarbeiter Field

xMitarbeiter Field | Previous topic | Next topic
xMitarbeiter Field | Previous topic | Next topic

Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private Shared xMitarbeiter As clsMyMitarbeiter

C#

private static clsMyMitarbeiter xMitarbeiter

C++

private:
static clsMyMitarbeiter^ xMitarbeiter;

JScript

private static xMitarbeiter : clsMyMitarbeiter

Source code

Visual Basic

Copy Code Copy Code

Dim xMitarbeiter As New edokadb.clsMyMitarbeiter

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

ModMain Class
ModMain ModMain Members


xdata Field

xdata Field

xdata Field | Previous topic | Next topic
xdata Field | Previous topic | Next topic

Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private Shared xdata As DataTable

C#

private static DataTable xdata

C++

private:
static DataTable^ xdata;

JScript

private static xdata : DataTable

Source code

Visual Basic

Copy Code Copy Code

Dim xdata As New System.Data.DataTable

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

ModMain Class
ModMain ModMain Members


Parameter Structure

Parameter Structure

Parameter Structure | Previous topic | Next topic
Parameter Structure | Previous topic | Next topic

Struct für einzelne Parameter

Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Structure Parameter

C#

public struct Parameter

C++

public value struct Parameter

JScript

JScript suports the use of structures, but not the declaration of new ones.

Source code

Visual Basic

Copy Code Copy Code

Public Structure Parameter

Private _value As String
Private _name As String

Public Sub New(ByVal name As String, ByVal value As String)
Try
_value = value
_name = name

Catch ex As Exception
'TKBLib.Errorhandling.TraceHelper.Msg("EdokaLib.Common.Parameter.New", ex.Message & ex.StackTrace, TraceLevel.Error)
Throw ex
End Try
End Sub

Public ReadOnly Property Value() As String
Get
Return _value
End Get
End Property
Public ReadOnly Property Name() As String
Get
Return _name
End Get
End Property

End Structure

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

Parameter Members


Parameter Members

Parameter Members

Parameter Members | Previous topic | Next topic
Parameter Members | Previous topic | Next topic

Struct für einzelne Parameter

The following tables list the members exposed by the Parameter type.

Public Constructors

 | Name | Description
Supported by the .NET Compact Framework. | Parameter Constructor |

Top

Public Properties

 | Name | Description
Supported by the .NET Compact Framework. | Name |
Supported by the .NET Compact Framework. | Value |

Top

Fields

 | Name | Description
Supported by the .NET Compact Framework. | _name |
Supported by the .NET Compact Framework. | _value |

Top

See Also

Reference

Parameter Structure


Parameter Constructor

Parameter Constructor

Parameter Constructor | Previous topic | Next topic
Parameter Constructor | Previous topic | Next topic

Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Sub New( _
ByVal name As String, _
ByVal value As String _
)

C#

public Parameter(
stringname,
stringvalue
)

C++

public:
Parameter(
String^ name,
String^ value
)

JScript

public function Parameter(
name : String,
value : String
);

Parameters

name

value

Source code

Visual Basic

Copy Code Copy Code

Public Sub New(ByVal name As String, ByVal value As String)
Try
_value = value
_name = name

Catch ex As Exception
'TKBLib.Errorhandling.TraceHelper.Msg("EdokaLib.Common.Parameter.New", ex.Message & ex.StackTrace, TraceLevel.Error)
Throw ex
End Try
End Sub

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

Parameter Structure
Parameter Parameter Members


Parameter Properties

Parameter Properties

Parameter Properties | Previous topic | Next topic
Parameter Properties | Previous topic | Next topic

Public Properties

 | Name | Description
Supported by the .NET Compact Framework. | Name |
Supported by the .NET Compact Framework. | Value |

Top

See Also

Reference

Parameter Structure


Parameter.Name Property

Parameter.Name Property

Parameter.Name Property | Previous topic | Next topic
Parameter.Name Property | Previous topic | Next topic

Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public ReadOnly Property Name() As String

C#

public string Name {get;}

C++

public:
property String^ Name {
String^ get( );
}

JScript

public function get Name() : String;

Source code

Visual Basic

Copy Code Copy Code

Public ReadOnly Property Name() As String
Get
Return _name
End Get
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

Parameter Structure
Parameter Parameter Members


Parameter.Value Property

Parameter.Value Property

Parameter.Value Property | Previous topic | Next topic
Parameter.Value Property | Previous topic | Next topic

Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public ReadOnly Property Value() As String

C#

public string Value {get;}

C++

public:
property String^ Value {
String^ get( );
}

JScript

public function get Value() : String;

Source code

Visual Basic

Copy Code Copy Code

Public ReadOnly Property Value() As String
Get
Return _value
End Get
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

Parameter Structure
Parameter Parameter Members


Parameter Fields

Parameter Fields

Parameter Fields | Previous topic | Next topic
Parameter Fields | Previous topic | Next topic

Fields

 | Name | Description
Supported by the .NET Compact Framework. | _name |
Supported by the .NET Compact Framework. | _value |

Top

See Also

Reference

Parameter Structure


_name Field

_name Field

_name Field | Previous topic | Next topic
_name Field | Previous topic | Next topic

Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private _name As String

C#

private string _name

C++

private:
String^ _name;

JScript

private _name : String

Source code

Visual Basic

Copy Code Copy Code

Private _name As String

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

Parameter Structure
Parameter Parameter Members


_value Field

_value Field

_value Field | Previous topic | Next topic
_value Field | Previous topic | Next topic

Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private _value As String

C#

private string _value

C++

private:
String^ _value;

JScript

private _value : String

Source code

Visual Basic

Copy Code Copy Code

Private _value As String

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

Parameter Structure
Parameter Parameter Members


ActionType Enumeration

ActionType Enumeration

ActionType Enumeration | Previous topic | Next topic
ActionType Enumeration | Previous topic | Next topic

Assembly: EDKB12WS (in EDKB12WS.exe)

Members

Member name | Description
AnzeigePartnerdossier |
DokumentAnzeige |
DokumentBearbeitung |
DokumentErstellung |
HostDokumentAnzeige |
Statusmutation |

Source code

Visual Basic

Copy Code Copy Code

Public Enum ActionType
AnzeigePartnerdossier = 1
DokumentAnzeige = 2
DokumentErstellung = 3
DokumentBearbeitung = 4
Statusmutation = 5
HostDokumentAnzeige = 6
End Enum

See Also

Reference


EDKB12WS.My Namespace

EDKB12WS.My Namespace

EDKB12WS.My Namespace | Previous topic | Next topic
EDKB12WS.My Namespace | Previous topic | Next topic

Assembly: EDKB12WS (in EDKB12WS.exe)

Classes

 | Name | Description
Internal (Friend) class Supported by the .NET Compact Framework. | MySettings |
Internal (Friend) class Supported by the .NET Compact Framework. | MySettingsProperty |

Top

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0


MySettings Class

MySettings Class

MySettings Class | Previous topic | Next topic
MySettings Class | Previous topic | Next topic

Namespace: EDKB12WS.My
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

<Global.System.Runtime.CompilerServices.CompilerGenerated()> _
<Global.System.CodeDom.Compiler.GeneratedCode("Microsoft.VisualStudio.Editors.SettingsDesigner.SettingsSingleFileGenerator", "12.0.0.0")> _
<Global.System.ComponentModel.EditorBrowsable(Global.System.ComponentModel.EditorBrowsableState.Advanced)> _
Friend NotInheritable Class MySettings
Inherits ApplicationSettingsBase

C#

[Global.System.Runtime.CompilerServices.CompilerGenerated()]
[Global.System.CodeDom.Compiler.GeneratedCode("Microsoft.VisualStudio.Editors.SettingsDesigner.SettingsSingleFileGenerator", "12.0.0.0")]
[Global.System.ComponentModel.EditorBrowsable(Global.System.ComponentModel.EditorBrowsableState.Advanced)]
internal sealed class MySettings : ApplicationSettingsBase

C++

[Global.System.Runtime.CompilerServices.CompilerGenerated()]
[Global.System.CodeDom.Compiler.GeneratedCode("Microsoft.VisualStudio.Editors.SettingsDesigner.SettingsSingleFileGenerator", "12.0.0.0")]
[Global.System.ComponentModel.EditorBrowsable(Global.System.ComponentModel.EditorBrowsableState.Advanced)]
private ref class MySettings sealed : public ApplicationSettingsBase^

JScript

internal
Global.System.Runtime.CompilerServices.CompilerGenerated()
Global.System.CodeDom.Compiler.GeneratedCode("Microsoft.VisualStudio.Editors.SettingsDesigner.SettingsSingleFileGenerator", "12.0.0.0")
Global.System.ComponentModel.EditorBrowsable(Global.System.ComponentModel.EditorBrowsableState.Advanced)
final class MySettings
extends ApplicationSettingsBase

Inheritance Hierarchy

System.Object

System.Configuration.SettingsBase

System.Configuration.ApplicationSettingsBase

EDKB12WS.My.MySettings

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

MySettings Members
EDKB12WS.My Namespace


MySettings Members

MySettings Members

MySettings Members | Previous topic | Next topic
MySettings Members | Previous topic | Next topic

The following tables list the members exposed by the MySettings type.

Public Properties

 | Name | Description
Public property | Context | (inherited from ApplicationSettingsBase).
Supported by the .NET Compact Framework. | Default |
Public property | IsSynchronized | (inherited from SettingsBase).
Public property | Item | (inherited from ApplicationSettingsBase).
Public property | Properties | (inherited from ApplicationSettingsBase).
Public property | PropertyValues | (inherited from ApplicationSettingsBase).
Public property | Providers | (inherited from ApplicationSettingsBase).
Public property | SettingsKey | (inherited from ApplicationSettingsBase).

Top

Public Methods

 | Name | Description
Public method | Equals | (Overloaded) (inherited from Object).
Public method | GetHashCode | (inherited from Object).
Public method | GetPreviousVersion | (inherited from ApplicationSettingsBase).
Public method | GetType | (Overloaded) (inherited from Object).
Public method | Initialize | (inherited from SettingsBase).
 | ReferenceEquals | (inherited from Object).
Public method | Reload | (inherited from ApplicationSettingsBase).
Public method | Reset | (inherited from ApplicationSettingsBase).
Public method | Save | (inherited from ApplicationSettingsBase).
 | Synchronized | (inherited from SettingsBase).
Public method | ToString | (inherited from Object).
Public method | Upgrade | (inherited from ApplicationSettingsBase).

Top

Protected Methods

 | Name | Description
Protected method | Finalize | (inherited from Object).
Protected method | MemberwiseClone | (Overloaded) (inherited from Object).
Protected method | OnPropertyChanged | (inherited from ApplicationSettingsBase).
Protected method | OnSettingChanging | (inherited from ApplicationSettingsBase).
Protected method | OnSettingsLoaded | (inherited from ApplicationSettingsBase).
Protected method | OnSettingsSaving | (inherited from ApplicationSettingsBase).

Top

Public Events

 | Name | Description
Public event | PropertyChanged | (inherited from ApplicationSettingsBase).
Public event | SettingChanging | (inherited from ApplicationSettingsBase).
Public event | SettingsLoaded | (inherited from ApplicationSettingsBase).
Public event | SettingsSaving | (inherited from ApplicationSettingsBase).

Top

Fields

 | Name | Description
Supported by the .NET Compact Framework. | defaultInstance |

Top

See Also

Reference

MySettings Class
EDKB12WS.My Namespace


MySettings Properties

MySettings Properties

MySettings Properties | Previous topic | Next topic
MySettings Properties | Previous topic | Next topic

Public Properties

 | Name | Description
Public property | Context | (inherited from ApplicationSettingsBase).
Supported by the .NET Compact Framework. | Default |
Public property | IsSynchronized | (inherited from SettingsBase).
Public property | Item | (inherited from ApplicationSettingsBase).
Public property | Properties | (inherited from ApplicationSettingsBase).
Public property | PropertyValues | (inherited from ApplicationSettingsBase).
Public property | Providers | (inherited from ApplicationSettingsBase).
Public property | SettingsKey | (inherited from ApplicationSettingsBase).

Top

See Also

Reference

MySettings Class
EDKB12WS.My Namespace


MySettings.Default Property

MySettings.Default Property

MySettings.Default Property | Previous topic | Next topic
MySettings.Default Property | Previous topic | Next topic

Namespace: EDKB12WS.My
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public ReadOnly Shared Property Default() As MySettings

C#

public static MySettings Default {get;}

C++

public:
static property MySettings^ Default {
MySettings^ get( );
}

JScript

public static function get Default() : MySettings;

Source code

Visual Basic

Copy Code Copy Code

Public Shared ReadOnly Property [Default]() As MySettings
Get

#If _MyType = "WindowsForms" Then
If Not addedHandler Then
SyncLock addedHandlerLockObject
If Not addedHandler Then
AddHandler My.Application.Shutdown, AddressOf AutoSaveSettings
addedHandler = True
End If
End SyncLock
End If
#End If
Return defaultInstance
End Get
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

MySettings Class
MySettings MySettings Members
EDKB12WS.My Namespace


MySettings Methods

MySettings Methods

MySettings Methods | Previous topic | Next topic
MySettings Methods | Previous topic | Next topic

Public Methods

 | Name | Description
Public method | Equals | (Overloaded) (inherited from Object).
Public method | GetHashCode | (inherited from Object).
Public method | GetPreviousVersion | (inherited from ApplicationSettingsBase).
Public method | GetType | (Overloaded) (inherited from Object).
Public method | Initialize | (inherited from SettingsBase).
 | ReferenceEquals | (inherited from Object).
Public method | Reload | (inherited from ApplicationSettingsBase).
Public method | Reset | (inherited from ApplicationSettingsBase).
Public method | Save | (inherited from ApplicationSettingsBase).
 | Synchronized | (inherited from SettingsBase).
Public method | ToString | (inherited from Object).
Public method | Upgrade | (inherited from ApplicationSettingsBase).

Top

Protected Methods

 | Name | Description
Protected method | Finalize | (inherited from Object).
Protected method | MemberwiseClone | (Overloaded) (inherited from Object).
Protected method | OnPropertyChanged | (inherited from ApplicationSettingsBase).
Protected method | OnSettingChanging | (inherited from ApplicationSettingsBase).
Protected method | OnSettingsLoaded | (inherited from ApplicationSettingsBase).
Protected method | OnSettingsSaving | (inherited from ApplicationSettingsBase).

Top

See Also

Reference

MySettings Class
EDKB12WS.My Namespace


MySettings Events

MySettings Events

MySettings Events | Previous topic | Next topic
MySettings Events | Previous topic | Next topic

Public Events

 | Name | Description
Public event | PropertyChanged | (inherited from ApplicationSettingsBase).
Public event | SettingChanging | (inherited from ApplicationSettingsBase).
Public event | SettingsLoaded | (inherited from ApplicationSettingsBase).
Public event | SettingsSaving | (inherited from ApplicationSettingsBase).

Top

See Also

Reference

MySettings Class
EDKB12WS.My Namespace


MySettings Fields

MySettings Fields

MySettings Fields | Previous topic | Next topic
MySettings Fields | Previous topic | Next topic

Fields

 | Name | Description
Supported by the .NET Compact Framework. | defaultInstance |

Top

See Also

Reference

MySettings Class
EDKB12WS.My Namespace


defaultInstance Field

defaultInstance Field

defaultInstance Field | Previous topic | Next topic
defaultInstance Field | Previous topic | Next topic

Namespace: EDKB12WS.My
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private Shared defaultInstance As MySettings

C#

private static MySettings defaultInstance

C++

private:
static MySettings^ defaultInstance;

JScript

private static defaultInstance : MySettings

Source code

Visual Basic

Copy Code Copy Code

Private Shared defaultInstance As MySettings = CType(Global.System.Configuration.ApplicationSettingsBase.Synchronized(New MySettings()),MySettings)

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

MySettings Class
MySettings MySettings Members
EDKB12WS.My Namespace


MySettingsProperty Class

MySettingsProperty Class

MySettingsProperty Class | Previous topic | Next topic
MySettingsProperty Class | Previous topic | Next topic

Namespace: EDKB12WS.My
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

<Global.Microsoft.VisualBasic.HideModuleName()> _
<Global.System.Diagnostics.DebuggerNonUserCode()> _
<Global.System.Runtime.CompilerServices.CompilerGenerated()> _
Friend Module MySettingsProperty

C#

[Global.Microsoft.VisualBasic.HideModuleName()]
[Global.System.Diagnostics.DebuggerNonUserCode()]
[Global.System.Runtime.CompilerServices.CompilerGenerated()]
internal sealed class MySettingsProperty

C++

[Global.Microsoft.VisualBasic.HideModuleName()]
[Global.System.Diagnostics.DebuggerNonUserCode()]
[Global.System.Runtime.CompilerServices.CompilerGenerated()]
private ref class sealed MySettingsProperty

JScript

internal
Global.Microsoft.VisualBasic.HideModuleName()
Global.System.Diagnostics.DebuggerNonUserCode()
Global.System.Runtime.CompilerServices.CompilerGenerated()
final class MySettingsProperty

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

MySettingsProperty Members
EDKB12WS.My Namespace


MySettingsProperty Members

MySettingsProperty Members

MySettingsProperty Members | Previous topic | Next topic
MySettingsProperty Members | Previous topic | Next topic

The following tables list the members exposed by the MySettingsProperty type.

Private, internal (Friend) and internal protected (Protected Friend) Properties

 | Name | Description
Internal (Friend) property Supported by the .NET Compact Framework. | Settings |

Top

Public Methods

 | Name | Description
Public method | Equals | (Overloaded) (inherited from Object).
Public method | GetHashCode | (inherited from Object).
Public method | GetType | (Overloaded) (inherited from Object).
 | ReferenceEquals | (inherited from Object).
Public method | ToString | (inherited from Object).

Top

Protected Methods

 | Name | Description
Protected method | Finalize | (inherited from Object).
Protected method | MemberwiseClone | (Overloaded) (inherited from Object).

Top

See Also

Reference

MySettingsProperty Class
EDKB12WS.My Namespace


MySettingsProperty Properties

MySettingsProperty Properties

MySettingsProperty Properties | Previous topic | Next topic
MySettingsProperty Properties | Previous topic | Next topic

Private, internal (Friend) and internal protected (Protected Friend) Properties

 | Name | Description
Internal (Friend) property Supported by the .NET Compact Framework. | Settings |

Top

See Also

Reference

MySettingsProperty Class
EDKB12WS.My Namespace


MySettingsProperty.Settings Property

MySettingsProperty.Settings Property

MySettingsProperty.Settings Property | Previous topic | Next topic
MySettingsProperty.Settings Property | Previous topic | Next topic

Namespace: EDKB12WS.My
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

<Global.System.ComponentModel.Design.HelpKeyword("My.Settings")> _
Friend ReadOnly Shared Property Settings() As MySettings

C#

[Global.System.ComponentModel.Design.HelpKeyword("My.Settings")]
internal static MySettings Settings {get;}

C++

[Global.System.ComponentModel.Design.HelpKeyword("My.Settings")]
public private:
static property MySettings^ Settings {
MySettings^ get( );
}

JScript

internal
Global.System.ComponentModel.Design.HelpKeyword("My.Settings")
static function get Settings() : MySettings;

Source code

Visual Basic

Copy Code Copy Code

Friend ReadOnly Property Settings() As Global.EDKB12WS.My.MySettings
Get
Return Global.EDKB12WS.My.MySettings.Default
End Get
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

MySettingsProperty Class
MySettingsProperty MySettingsProperty Members
EDKB12WS.My Namespace


MySettingsProperty Methods

MySettingsProperty Methods

MySettingsProperty Methods | Previous topic | Next topic
MySettingsProperty Methods | Previous topic | Next topic

Public Methods

 | Name | Description
Public method | Equals | (Overloaded) (inherited from Object).
Public method | GetHashCode | (inherited from Object).
Public method | GetType | (Overloaded) (inherited from Object).
 | ReferenceEquals | (inherited from Object).
Public method | ToString | (inherited from Object).

Top

Protected Methods

 | Name | Description
Protected method | Finalize | (inherited from Object).
Protected method | MemberwiseClone | (Overloaded) (inherited from Object).

Top

See Also

Reference

MySettingsProperty Class
EDKB12WS.My Namespace


EDKB12WS.My.Resources Namespace

EDKB12WS.My.Resources Namespace

EDKB12WS.My.Resources Namespace | Previous topic | Next topic
EDKB12WS.My.Resources Namespace | Previous topic | Next topic

Assembly: EDKB12WS (in EDKB12WS.exe)

Classes

 | Name | Description
Internal (Friend) class Supported by the .NET Compact Framework. | Resources | Eine stark typisierte Ressourcenklasse zum Suchen von lokalisierten Zeichenfolgen usw.

Top

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0


Resources Class

Resources Class

Resources Class | Previous topic | Next topic
Resources Class | Previous topic | Next topic

Eine stark typisierte Ressourcenklasse zum Suchen von lokalisierten Zeichenfolgen usw.

Namespace: EDKB12WS.My.Resources
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

<Global.System.CodeDom.Compiler.GeneratedCode("System.Resources.Tools.StronglyTypedResourceBuilder", "4.0.0.0")> _
<Global.System.Diagnostics.DebuggerNonUserCode()> _
<Global.System.Runtime.CompilerServices.CompilerGenerated()> _
<Global.Microsoft.VisualBasic.HideModuleName()> _
Friend Module Resources

C#

[Global.System.CodeDom.Compiler.GeneratedCode("System.Resources.Tools.StronglyTypedResourceBuilder", "4.0.0.0")]
[Global.System.Diagnostics.DebuggerNonUserCode()]
[Global.System.Runtime.CompilerServices.CompilerGenerated()]
[Global.Microsoft.VisualBasic.HideModuleName()]
internal sealed class Resources

C++

[Global.System.CodeDom.Compiler.GeneratedCode("System.Resources.Tools.StronglyTypedResourceBuilder", "4.0.0.0")]
[Global.System.Diagnostics.DebuggerNonUserCode()]
[Global.System.Runtime.CompilerServices.CompilerGenerated()]
[Global.Microsoft.VisualBasic.HideModuleName()]
private ref class sealed Resources

JScript

internal
Global.System.CodeDom.Compiler.GeneratedCode("System.Resources.Tools.StronglyTypedResourceBuilder", "4.0.0.0")
Global.System.Diagnostics.DebuggerNonUserCode()
Global.System.Runtime.CompilerServices.CompilerGenerated()
Global.Microsoft.VisualBasic.HideModuleName()
final class Resources

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

Resources Members
EDKB12WS.My.Resources Namespace


Resources Members

Resources Members

Resources Members | Previous topic | Next topic
Resources Members | Previous topic | Next topic

Eine stark typisierte Ressourcenklasse zum Suchen von lokalisierten Zeichenfolgen usw.

The following tables list the members exposed by the Resources type.

Private, internal (Friend) and internal protected (Protected Friend) Properties

 | Name | Description
Internal (Friend) property Supported by the .NET Compact Framework. | Culture | Überschreibt die CurrentUICulture-Eigenschaft des aktuellen Threads für alle Ressourcenzuordnungen, die diese stark typisierte Ressourcenklasse verwenden.
Internal (Friend) property Supported by the .NET Compact Framework. | ResourceManager | Gibt die zwischengespeicherte ResourceManager-Instanz zurück, die von dieser Klasse verwendet wird.

Top

Public Methods

 | Name | Description
Public method | Equals | (Overloaded) (inherited from Object).
Public method | GetHashCode | (inherited from Object).
Public method | GetType | (Overloaded) (inherited from Object).
 | ReferenceEquals | (inherited from Object).
Public method | ToString | (inherited from Object).

Top

Protected Methods

 | Name | Description
Protected method | Finalize | (inherited from Object).
Protected method | MemberwiseClone | (Overloaded) (inherited from Object).

Top

Fields

 | Name | Description
Supported by the .NET Compact Framework. | resourceCulture |
Supported by the .NET Compact Framework. | resourceMan |

Top

See Also

Reference

Resources Class
EDKB12WS.My.Resources Namespace


Resources Properties

Resources Properties

Resources Properties | Previous topic | Next topic
Resources Properties | Previous topic | Next topic

Private, internal (Friend) and internal protected (Protected Friend) Properties

 | Name | Description
Internal (Friend) property Supported by the .NET Compact Framework. | Culture | Überschreibt die CurrentUICulture-Eigenschaft des aktuellen Threads für alle Ressourcenzuordnungen, die diese stark typisierte Ressourcenklasse verwenden.
Internal (Friend) property Supported by the .NET Compact Framework. | ResourceManager | Gibt die zwischengespeicherte ResourceManager-Instanz zurück, die von dieser Klasse verwendet wird.

Top

See Also

Reference

Resources Class
EDKB12WS.My.Resources Namespace


Resources.Culture Property

Resources.Culture Property

Resources.Culture Property | Previous topic | Next topic
Resources.Culture Property | Previous topic | Next topic

Überschreibt die CurrentUICulture-Eigenschaft des aktuellen Threads für alle Ressourcenzuordnungen, die diese stark typisierte Ressourcenklasse verwenden.

Namespace: EDKB12WS.My.Resources
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

<Global.System.ComponentModel.EditorBrowsable(Global.System.ComponentModel.EditorBrowsableState.Advanced)> _
Friend Shared Property Culture() As CultureInfo

C#

[Global.System.ComponentModel.EditorBrowsable(Global.System.ComponentModel.EditorBrowsableState.Advanced)]
internal static CultureInfo Culture {get; set;}

C++

[Global.System.ComponentModel.EditorBrowsable(Global.System.ComponentModel.EditorBrowsableState.Advanced)]
public private:
static property CultureInfo^ Culture {
CultureInfo^ get( );
void set(
CultureInfo^ value
);
}

JScript

internal
Global.System.ComponentModel.EditorBrowsable(Global.System.ComponentModel.EditorBrowsableState.Advanced)
static function get Culture() : CultureInfo;
internal
Global.System.ComponentModel.EditorBrowsable(Global.System.ComponentModel.EditorBrowsableState.Advanced)
static function set Culture(value : CultureInfo);

Source code

Visual Basic

Copy Code Copy Code

Friend Property Culture() As Global.System.Globalization.CultureInfo
Get
Return resourceCulture
End Get
Set
resourceCulture = value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

Resources Class
Resources Resources Members
EDKB12WS.My.Resources Namespace


Resources.ResourceManager Property

Resources.ResourceManager Property

Resources.ResourceManager Property | Previous topic | Next topic
Resources.ResourceManager Property | Previous topic | Next topic

Gibt die zwischengespeicherte ResourceManager-Instanz zurück, die von dieser Klasse verwendet wird.

Namespace: EDKB12WS.My.Resources
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

<Global.System.ComponentModel.EditorBrowsable(Global.System.ComponentModel.EditorBrowsableState.Advanced)> _
Friend ReadOnly Shared Property ResourceManager() As ResourceManager

C#

[Global.System.ComponentModel.EditorBrowsable(Global.System.ComponentModel.EditorBrowsableState.Advanced)]
internal static ResourceManager ResourceManager {get;}

C++

[Global.System.ComponentModel.EditorBrowsable(Global.System.ComponentModel.EditorBrowsableState.Advanced)]
public private:
static property ResourceManager^ ResourceManager {
ResourceManager^ get( );
}

JScript

internal
Global.System.ComponentModel.EditorBrowsable(Global.System.ComponentModel.EditorBrowsableState.Advanced)
static function get ResourceManager() : ResourceManager;

Source code

Visual Basic

Copy Code Copy Code

Friend ReadOnly Property ResourceManager() As Global.System.Resources.ResourceManager
Get
If Object.ReferenceEquals(resourceMan, Nothing) Then
Dim temp As Global.System.Resources.ResourceManager = New Global.System.Resources.ResourceManager("EDKB12WS.Resources", GetType(Resources).Assembly)
resourceMan = temp
End If
Return resourceMan
End Get
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

Resources Class
Resources Resources Members
EDKB12WS.My.Resources Namespace


Resources Methods

Resources Methods

Resources Methods | Previous topic | Next topic
Resources Methods | Previous topic | Next topic

Public Methods

 | Name | Description
Public method | Equals | (Overloaded) (inherited from Object).
Public method | GetHashCode | (inherited from Object).
Public method | GetType | (Overloaded) (inherited from Object).
 | ReferenceEquals | (inherited from Object).
Public method | ToString | (inherited from Object).

Top

Protected Methods

 | Name | Description
Protected method | Finalize | (inherited from Object).
Protected method | MemberwiseClone | (Overloaded) (inherited from Object).

Top

See Also

Reference

Resources Class
EDKB12WS.My.Resources Namespace


Resources Fields

Resources Fields

Resources Fields | Previous topic | Next topic
Resources Fields | Previous topic | Next topic

Fields

 | Name | Description
Supported by the .NET Compact Framework. | resourceCulture |
Supported by the .NET Compact Framework. | resourceMan |

Top

See Also

Reference

Resources Class
EDKB12WS.My.Resources Namespace


resourceCulture Field

resourceCulture Field

resourceCulture Field | Previous topic | Next topic
resourceCulture Field | Previous topic | Next topic

Namespace: EDKB12WS.My.Resources
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private Shared resourceCulture As CultureInfo

C#

private static CultureInfo resourceCulture

C++

private:
static CultureInfo^ resourceCulture;

JScript

private static resourceCulture : CultureInfo

Source code

Visual Basic

Copy Code Copy Code

Private resourceCulture As Global.System.Globalization.CultureInfo

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

Resources Class
Resources Resources Members
EDKB12WS.My.Resources Namespace


resourceMan Field

resourceMan Field

resourceMan Field | Previous topic | Next topic
resourceMan Field | Previous topic | Next topic

Namespace: EDKB12WS.My.Resources
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private Shared resourceMan As ResourceManager

C#

private static ResourceManager resourceMan

C++

private:
static ResourceManager^ resourceMan;

JScript

private static resourceMan : ResourceManager

Source code

Visual Basic

Copy Code Copy Code

Private resourceMan As Global.System.Resources.ResourceManager

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

Resources Class
Resources Resources Members
EDKB12WS.My.Resources Namespace


EDKB12WS.edokaDB Namespace

EDKB12WS.edokaDB Namespace

EDKB12WS.edokaDB Namespace | Previous topic | Next topic
EDKB12WS.edokaDB Namespace | Previous topic | Next topic

Assembly: EDKB12WS (in EDKB12WS.exe)

Classes

 | Name | Description
Supported by the .NET Compact Framework. | clsMyMitarbeiter |
Supported by the .NET Compact Framework. | clsOffice_Vorlage_Datei |

Top

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0


clsMyMitarbeiter Class

clsMyMitarbeiter Class

clsMyMitarbeiter Class | Previous topic | Next topic
clsMyMitarbeiter Class | Previous topic | Next topic

Namespace: EDKB12WS.edokaDB
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Class clsMyMitarbeiter
Inherits clsMitarbeiter

C#

public class clsMyMitarbeiter : clsMitarbeiter

C++

public ref class clsMyMitarbeiter : public clsMitarbeiter^

JScript

public class clsMyMitarbeiter
extends clsMitarbeiter

Inheritance Hierarchy

System.Object

EDKB12WS.edokadb.clsDBInteractionBase

EDKB12WS.edokadb.clsMitarbeiter

EDKB12WS.edokaDB.clsMyMitarbeiter

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsMyMitarbeiter Members
EDKB12WS.edokaDB Namespace


clsMyMitarbeiter Members

clsMyMitarbeiter Members

clsMyMitarbeiter Members | Previous topic | Next topic
clsMyMitarbeiter Members | Previous topic | Next topic

The following tables list the members exposed by the clsMyMitarbeiter type.

Public Constructors

 | Name | Description
Supported by the .NET Compact Framework. | clsMyMitarbeiter Constructor | (inherited from clsMitarbeiter ).

Top

Public Properties

 | Name | Description
Supported by the .NET Compact Framework. | bAktiv | (inherited from clsMitarbeiter ).
Supported by the .NET Compact Framework. | bEdokaMesasge | (inherited from clsMitarbeiter ).
Supported by the .NET Compact Framework. | bEdoka_mail | (inherited from clsMitarbeiter ).
Supported by the .NET Compact Framework. | bJournalisierung | (inherited from clsMitarbeiter ).
Supported by the .NET Compact Framework. | bMailDirektVersenden | (inherited from clsMitarbeiter ).
Supported by the .NET Compact Framework. | bMailDokumentrueckgang | (inherited from clsMitarbeiter ).
Supported by the .NET Compact Framework. | bMailempfang | (inherited from clsMitarbeiter ).
Supported by the .NET Compact Framework. | bShowtip | (inherited from clsMitarbeiter ).
Supported by the .NET Compact Framework. | cpMainConnectionProvider | (inherited from clsDBInteractionBase ).
Supported by the .NET Compact Framework. | daErstellt_am | (inherited from clsMitarbeiter ).
Supported by the .NET Compact Framework. | daMutiert_am | (inherited from clsMitarbeiter ).
Supported by the .NET Compact Framework. | iErrorCode | (inherited from clsDBInteractionBase ).
Supported by the .NET Compact Framework. | iFuermandant | (inherited from clsMitarbeiter ).
Supported by the .NET Compact Framework. | iFunktionnr | (inherited from clsMitarbeiter ).
Supported by the .NET Compact Framework. | iKlassifizierung | (inherited from clsMitarbeiter ).
Supported by the .NET Compact Framework. | iMandantnr | (inherited from clsMitarbeiter ).
Supported by the .NET Compact Framework. | iMitarbeiternr | (inherited from clsMitarbeiter ).
Supported by the .NET Compact Framework. | iMutierer | (inherited from clsMitarbeiter ).
Supported by the .NET Compact Framework. | iPartnernr | (inherited from clsMitarbeiter ).
Supported by the .NET Compact Framework. | iSprache | (inherited from clsMitarbeiter ).
Supported by the .NET Compact Framework. | sAnrede | (inherited from clsMitarbeiter ).
Supported by the .NET Compact Framework. | sConnectionString | (inherited from clsDBInteractionBase ).
Supported by the .NET Compact Framework. | sEmail | (inherited from clsMitarbeiter ).
Supported by the .NET Compact Framework. | sFax | (inherited from clsMitarbeiter ).
Supported by the .NET Compact Framework. | sFunktion | (inherited from clsMitarbeiter ).
Supported by the .NET Compact Framework. | sKurzzeichen | (inherited from clsMitarbeiter ).
Supported by the .NET Compact Framework. | sName | (inherited from clsMitarbeiter ).
Supported by the .NET Compact Framework. | sRang | (inherited from clsMitarbeiter ).
Supported by the .NET Compact Framework. | sTelefon | (inherited from clsMitarbeiter ).
Supported by the .NET Compact Framework. | sTgnummer | (inherited from clsMitarbeiter ).
Supported by the .NET Compact Framework. | sUnterschrift_text | (inherited from clsMitarbeiter ).
Supported by the .NET Compact Framework. | sVorname | (inherited from clsMitarbeiter ).
Supported by the .NET Compact Framework. | xtgnummer |

Top

Public Methods

 | Name | Description
Supported by the .NET Compact Framework. | Delete | (inherited from clsMitarbeiter ).
Supported by the .NET Compact Framework. | Dispose | (Overloaded) (inherited from clsDBInteractionBase ).
Public method | Equals | (Overloaded) (inherited from Object).
Public method | GetHashCode | (inherited from Object).
Public method | GetType | (Overloaded) (inherited from Object).
Supported by the .NET Compact Framework. | Insert | (inherited from clsMitarbeiter ).
 | ReferenceEquals | (inherited from Object).
Supported by the .NET Compact Framework. | SelectAll | (inherited from clsMitarbeiter ).
Supported by the .NET Compact Framework. | SelectOne | (inherited from clsMitarbeiter ).
Supported by the .NET Compact Framework. | SelectWithTGNummer |
Public method | ToString | (inherited from Object).
Supported by the .NET Compact Framework. | Update | (inherited from clsMitarbeiter ).

Top

Protected Methods

 | Name | Description
Protected method | Finalize | (inherited from Object).
Protected method | MemberwiseClone | (Overloaded) (inherited from Object).

Top

Fields

 | Name | Description
Supported by the .NET Compact Framework. | m_bMainConnectionIsCreatedLocal | (inherited from clsDBInteractionBase ).
Supported by the .NET Compact Framework. | m_cpMainConnectionProvider | (inherited from clsDBInteractionBase ).
Supported by the .NET Compact Framework. | m_iErrorCode | (inherited from clsDBInteractionBase ).
Supported by the .NET Compact Framework. | m_scoMainConnection | (inherited from clsDBInteractionBase ).
Supported by the .NET Compact Framework. | m_xtgnummer |

Top

See Also

Reference

clsMyMitarbeiter Class


clsMitarbeiter Constructor

clsMitarbeiter Constructor

clsMitarbeiter Constructor | Previous topic | Next topic
clsMitarbeiter Constructor | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Sub New()

C#

public clsMitarbeiter()

C++

public:
clsMitarbeiter()

JScript

public function clsMitarbeiter();

Source code

Visual Basic

Copy Code Copy Code

Public Sub New()
' // Nothing for now.
End Sub

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsMitarbeiter Class
clsMitarbeiter clsMitarbeiter Members


clsMyMitarbeiter Properties

clsMyMitarbeiter Properties

clsMyMitarbeiter Properties | Previous topic | Next topic
clsMyMitarbeiter Properties | Previous topic | Next topic

Public Properties

 | Name | Description
Supported by the .NET Compact Framework. | bAktiv | (inherited from clsMitarbeiter ).
Supported by the .NET Compact Framework. | bEdokaMesasge | (inherited from clsMitarbeiter ).
Supported by the .NET Compact Framework. | bEdoka_mail | (inherited from clsMitarbeiter ).
Supported by the .NET Compact Framework. | bJournalisierung | (inherited from clsMitarbeiter ).
Supported by the .NET Compact Framework. | bMailDirektVersenden | (inherited from clsMitarbeiter ).
Supported by the .NET Compact Framework. | bMailDokumentrueckgang | (inherited from clsMitarbeiter ).
Supported by the .NET Compact Framework. | bMailempfang | (inherited from clsMitarbeiter ).
Supported by the .NET Compact Framework. | bShowtip | (inherited from clsMitarbeiter ).
Supported by the .NET Compact Framework. | cpMainConnectionProvider | (inherited from clsDBInteractionBase ).
Supported by the .NET Compact Framework. | daErstellt_am | (inherited from clsMitarbeiter ).
Supported by the .NET Compact Framework. | daMutiert_am | (inherited from clsMitarbeiter ).
Supported by the .NET Compact Framework. | iErrorCode | (inherited from clsDBInteractionBase ).
Supported by the .NET Compact Framework. | iFuermandant | (inherited from clsMitarbeiter ).
Supported by the .NET Compact Framework. | iFunktionnr | (inherited from clsMitarbeiter ).
Supported by the .NET Compact Framework. | iKlassifizierung | (inherited from clsMitarbeiter ).
Supported by the .NET Compact Framework. | iMandantnr | (inherited from clsMitarbeiter ).
Supported by the .NET Compact Framework. | iMitarbeiternr | (inherited from clsMitarbeiter ).
Supported by the .NET Compact Framework. | iMutierer | (inherited from clsMitarbeiter ).
Supported by the .NET Compact Framework. | iPartnernr | (inherited from clsMitarbeiter ).
Supported by the .NET Compact Framework. | iSprache | (inherited from clsMitarbeiter ).
Supported by the .NET Compact Framework. | sAnrede | (inherited from clsMitarbeiter ).
Supported by the .NET Compact Framework. | sConnectionString | (inherited from clsDBInteractionBase ).
Supported by the .NET Compact Framework. | sEmail | (inherited from clsMitarbeiter ).
Supported by the .NET Compact Framework. | sFax | (inherited from clsMitarbeiter ).
Supported by the .NET Compact Framework. | sFunktion | (inherited from clsMitarbeiter ).
Supported by the .NET Compact Framework. | sKurzzeichen | (inherited from clsMitarbeiter ).
Supported by the .NET Compact Framework. | sName | (inherited from clsMitarbeiter ).
Supported by the .NET Compact Framework. | sRang | (inherited from clsMitarbeiter ).
Supported by the .NET Compact Framework. | sTelefon | (inherited from clsMitarbeiter ).
Supported by the .NET Compact Framework. | sTgnummer | (inherited from clsMitarbeiter ).
Supported by the .NET Compact Framework. | sUnterschrift_text | (inherited from clsMitarbeiter ).
Supported by the .NET Compact Framework. | sVorname | (inherited from clsMitarbeiter ).
Supported by the .NET Compact Framework. | xtgnummer |

Top

See Also

Reference

clsMyMitarbeiter Class


clsMitarbeiter.bAktiv Property

clsMitarbeiter.bAktiv Property

clsMitarbeiter.bAktiv Property | Previous topic | Next topic
clsMitarbeiter.bAktiv Property | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property bAktiv() As SqlBoolean

C#

public SqlBoolean bAktiv {get; set;}

C++

public:
property SqlBoolean bAktiv {
SqlBoolean get( );
void set(
SqlBoolean value
);
}

JScript

public function get bAktiv() : SqlBoolean;
public function set bAktiv(value : SqlBoolean);

Source code

Visual Basic

Copy Code Copy Code

Public Property [bAktiv]() As SqlBoolean
Get
Return m_bAktiv
End Get
Set(ByVal Value As SqlBoolean)
m_bAktiv = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsMitarbeiter Class
clsMitarbeiter clsMitarbeiter Members


clsMitarbeiter.bEdokaMesasge Property

clsMitarbeiter.bEdokaMesasge Property

clsMitarbeiter.bEdokaMesasge Property | Previous topic | Next topic
clsMitarbeiter.bEdokaMesasge Property | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property bEdokaMesasge() As SqlBoolean

C#

public SqlBoolean bEdokaMesasge {get; set;}

C++

public:
property SqlBoolean bEdokaMesasge {
SqlBoolean get( );
void set(
SqlBoolean value
);
}

JScript

public function get bEdokaMesasge() : SqlBoolean;
public function set bEdokaMesasge(value : SqlBoolean);

Source code

Visual Basic

Copy Code Copy Code

Public Property [bEdokaMesasge]() As SqlBoolean
Get
Return m_bEdokaMesasge
End Get
Set(ByVal Value As SqlBoolean)
m_bEdokaMesasge = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsMitarbeiter Class
clsMitarbeiter clsMitarbeiter Members


clsMitarbeiter.bEdoka_mail Property

clsMitarbeiter.bEdoka_mail Property

clsMitarbeiter.bEdoka_mail Property | Previous topic | Next topic
clsMitarbeiter.bEdoka_mail Property | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property bEdoka_mail() As SqlBoolean

C#

public SqlBoolean bEdoka_mail {get; set;}

C++

public:
property SqlBoolean bEdoka_mail {
SqlBoolean get( );
void set(
SqlBoolean value
);
}

JScript

public function get bEdoka_mail() : SqlBoolean;
public function set bEdoka_mail(value : SqlBoolean);

Source code

Visual Basic

Copy Code Copy Code

Public Property [bEdoka_mail]() As SqlBoolean
Get
Return m_bEdoka_mail
End Get
Set(ByVal Value As SqlBoolean)
m_bEdoka_mail = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsMitarbeiter Class
clsMitarbeiter clsMitarbeiter Members


clsMitarbeiter.bJournalisierung Property

clsMitarbeiter.bJournalisierung Property

clsMitarbeiter.bJournalisierung Property | Previous topic | Next topic
clsMitarbeiter.bJournalisierung Property | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property bJournalisierung() As SqlBoolean

C#

public SqlBoolean bJournalisierung {get; set;}

C++

public:
property SqlBoolean bJournalisierung {
SqlBoolean get( );
void set(
SqlBoolean value
);
}

JScript

public function get bJournalisierung() : SqlBoolean;
public function set bJournalisierung(value : SqlBoolean);

Source code

Visual Basic

Copy Code Copy Code

Public Property [bJournalisierung]() As SqlBoolean
Get
Return m_bJournalisierung
End Get
Set(ByVal Value As SqlBoolean)
m_bJournalisierung = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsMitarbeiter Class
clsMitarbeiter clsMitarbeiter Members


clsMitarbeiter.bMailDirektVersenden Property

clsMitarbeiter.bMailDirektVersenden Property

clsMitarbeiter.bMailDirektVersenden Property | Previous topic | Next topic
clsMitarbeiter.bMailDirektVersenden Property | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property bMailDirektVersenden() As SqlBoolean

C#

public SqlBoolean bMailDirektVersenden {get; set;}

C++

public:
property SqlBoolean bMailDirektVersenden {
SqlBoolean get( );
void set(
SqlBoolean value
);
}

JScript

public function get bMailDirektVersenden() : SqlBoolean;
public function set bMailDirektVersenden(value : SqlBoolean);

Source code

Visual Basic

Copy Code Copy Code

Public Property [bMailDirektVersenden]() As SqlBoolean
Get
Return m_bMailDirektVersenden
End Get
Set(ByVal Value As SqlBoolean)
m_bMailDirektVersenden = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsMitarbeiter Class
clsMitarbeiter clsMitarbeiter Members


clsMitarbeiter.bMailDokumentrueckgang Property

clsMitarbeiter.bMailDokumentrueckgang Property

clsMitarbeiter.bMailDokumentrueckgang Property | Previous topic | Next topic
clsMitarbeiter.bMailDokumentrueckgang Property | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property bMailDokumentrueckgang() As SqlBoolean

C#

public SqlBoolean bMailDokumentrueckgang {get; set;}

C++

public:
property SqlBoolean bMailDokumentrueckgang {
SqlBoolean get( );
void set(
SqlBoolean value
);
}

JScript

public function get bMailDokumentrueckgang() : SqlBoolean;
public function set bMailDokumentrueckgang(value : SqlBoolean);

Source code

Visual Basic

Copy Code Copy Code

Public Property [bMailDokumentrueckgang]() As SqlBoolean
Get
Return m_bMailDokumentrueckgang
End Get
Set(ByVal Value As SqlBoolean)
m_bMailDokumentrueckgang = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsMitarbeiter Class
clsMitarbeiter clsMitarbeiter Members


clsMitarbeiter.bMailempfang Property

clsMitarbeiter.bMailempfang Property

clsMitarbeiter.bMailempfang Property | Previous topic | Next topic
clsMitarbeiter.bMailempfang Property | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property bMailempfang() As SqlBoolean

C#

public SqlBoolean bMailempfang {get; set;}

C++

public:
property SqlBoolean bMailempfang {
SqlBoolean get( );
void set(
SqlBoolean value
);
}

JScript

public function get bMailempfang() : SqlBoolean;
public function set bMailempfang(value : SqlBoolean);

Source code

Visual Basic

Copy Code Copy Code

Public Property [bMailempfang]() As SqlBoolean
Get
Return m_bMailempfang
End Get
Set(ByVal Value As SqlBoolean)
m_bMailempfang = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsMitarbeiter Class
clsMitarbeiter clsMitarbeiter Members


clsMitarbeiter.bShowtip Property

clsMitarbeiter.bShowtip Property

clsMitarbeiter.bShowtip Property | Previous topic | Next topic
clsMitarbeiter.bShowtip Property | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property bShowtip() As SqlBoolean

C#

public SqlBoolean bShowtip {get; set;}

C++

public:
property SqlBoolean bShowtip {
SqlBoolean get( );
void set(
SqlBoolean value
);
}

JScript

public function get bShowtip() : SqlBoolean;
public function set bShowtip(value : SqlBoolean);

Source code

Visual Basic

Copy Code Copy Code

Public Property [bShowtip]() As SqlBoolean
Get
Return m_bShowtip
End Get
Set(ByVal Value As SqlBoolean)
Dim bShowtipTmp As SqlBoolean = Value
If bShowtipTmp.IsNull Then
Throw New ArgumentOutOfRangeException("bShowtip", "bShowtip can't be NULL")
End If
m_bShowtip = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsMitarbeiter Class
clsMitarbeiter clsMitarbeiter Members


clsDBInteractionBase.cpMainConnectionProvider Property

clsDBInteractionBase.cpMainConnectionProvider Property

clsDBInteractionBase.cpMainConnectionProvider Property | Previous topic | Next topic
clsDBInteractionBase.cpMainConnectionProvider Property | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public WriteOnly Property cpMainConnectionProvider() As clsConnectionProvider

C#

public clsConnectionProvider cpMainConnectionProvider {set;}

C++

public:
property clsConnectionProvider^ cpMainConnectionProvider {
void set(
clsConnectionProvider^ value
);
}

JScript

public function set cpMainConnectionProvider(value : clsConnectionProvider);

Source code

Visual Basic

Copy Code Copy Code

Public WriteOnly Property cpMainConnectionProvider() As clsConnectionProvider
Set(ByVal Value As clsConnectionProvider)
If Value Is Nothing Then
' // Invalid value
Throw New ArgumentNullException("cpMainConnectionProvider", "Nothing passed as value to this property which is not allowed.")
End If

' // A connection provider object is passed to this class.
' // Retrieve the SqlConnection object, if present and create a
' // reference to it. If there is already a MainConnection object
' // referenced by the membervar, destroy that one or simply
' // remove the reference, based on the flag.
If Not (m_scoMainConnection Is Nothing) Then
' // First get rid of current connection object. Caller is responsible
If m_bMainConnectionIsCreatedLocal Then
' // Is local created object, close it and dispose it.
m_scoMainConnection.Close()
m_scoMainConnection.Dispose()
End If
' // Remove reference.
m_scoMainConnection = Nothing
End If
m_cpMainConnectionProvider = CType(Value, clsConnectionProvider)
m_scoMainConnection = m_cpMainConnectionProvider.scoDBConnection
m_bMainConnectionIsCreatedLocal = False
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsDBInteractionBase Class
clsDBInteractionBase clsDBInteractionBase Members


clsMitarbeiter.daErstellt_am Property

clsMitarbeiter.daErstellt_am Property

clsMitarbeiter.daErstellt_am Property | Previous topic | Next topic
clsMitarbeiter.daErstellt_am Property | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property daErstellt_am() As SqlDateTime

C#

public SqlDateTime daErstellt_am {get; set;}

C++

public:
property SqlDateTime daErstellt_am {
SqlDateTime get( );
void set(
SqlDateTime value
);
}

JScript

public function get daErstellt_am() : SqlDateTime;
public function set daErstellt_am(value : SqlDateTime);

Source code

Visual Basic

Copy Code Copy Code

Public Property [daErstellt_am]() As SqlDateTime
Get
Return m_daErstellt_am
End Get
Set(ByVal Value As SqlDateTime)
m_daErstellt_am = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsMitarbeiter Class
clsMitarbeiter clsMitarbeiter Members


clsMitarbeiter.daMutiert_am Property

clsMitarbeiter.daMutiert_am Property

clsMitarbeiter.daMutiert_am Property | Previous topic | Next topic
clsMitarbeiter.daMutiert_am Property | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property daMutiert_am() As SqlDateTime

C#

public SqlDateTime daMutiert_am {get; set;}

C++

public:
property SqlDateTime daMutiert_am {
SqlDateTime get( );
void set(
SqlDateTime value
);
}

JScript

public function get daMutiert_am() : SqlDateTime;
public function set daMutiert_am(value : SqlDateTime);

Source code

Visual Basic

Copy Code Copy Code

Public Property [daMutiert_am]() As SqlDateTime
Get
Return m_daMutiert_am
End Get
Set(ByVal Value As SqlDateTime)
m_daMutiert_am = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsMitarbeiter Class
clsMitarbeiter clsMitarbeiter Members


clsDBInteractionBase.iErrorCode Property

clsDBInteractionBase.iErrorCode Property

clsDBInteractionBase.iErrorCode Property | Previous topic | Next topic
clsDBInteractionBase.iErrorCode Property | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public ReadOnly Property iErrorCode() As SqlInt32

C#

public SqlInt32 iErrorCode {get;}

C++

public:
property SqlInt32 iErrorCode {
SqlInt32 get( );
}

JScript

public function get iErrorCode() : SqlInt32;

Source code

Visual Basic

Copy Code Copy Code

Public ReadOnly Property iErrorCode() As SqlInt32
Get
Return m_iErrorCode
End Get
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsDBInteractionBase Class
clsDBInteractionBase clsDBInteractionBase Members


clsMitarbeiter.iFuermandant Property

clsMitarbeiter.iFuermandant Property

clsMitarbeiter.iFuermandant Property | Previous topic | Next topic
clsMitarbeiter.iFuermandant Property | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property iFuermandant() As SqlInt32

C#

public SqlInt32 iFuermandant {get; set;}

C++

public:
property SqlInt32 iFuermandant {
SqlInt32 get( );
void set(
SqlInt32 value
);
}

JScript

public function get iFuermandant() : SqlInt32;
public function set iFuermandant(value : SqlInt32);

Source code

Visual Basic

Copy Code Copy Code

Public Property [iFuermandant]() As SqlInt32
Get
Return m_iFuermandant
End Get
Set(ByVal Value As SqlInt32)
Dim iFuermandantTmp As SqlInt32 = Value
If iFuermandantTmp.IsNull Then
Throw New ArgumentOutOfRangeException("iFuermandant", "iFuermandant can't be NULL")
End If
m_iFuermandant = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsMitarbeiter Class
clsMitarbeiter clsMitarbeiter Members


clsMitarbeiter.iFunktionnr Property

clsMitarbeiter.iFunktionnr Property

clsMitarbeiter.iFunktionnr Property | Previous topic | Next topic
clsMitarbeiter.iFunktionnr Property | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property iFunktionnr() As SqlInt32

C#

public SqlInt32 iFunktionnr {get; set;}

C++

public:
property SqlInt32 iFunktionnr {
SqlInt32 get( );
void set(
SqlInt32 value
);
}

JScript

public function get iFunktionnr() : SqlInt32;
public function set iFunktionnr(value : SqlInt32);

Source code

Visual Basic

Copy Code Copy Code

Public Property [iFunktionnr]() As SqlInt32
Get
Return m_iFunktionnr
End Get
Set(ByVal Value As SqlInt32)
m_iFunktionnr = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsMitarbeiter Class
clsMitarbeiter clsMitarbeiter Members


clsMitarbeiter.iKlassifizierung Property

clsMitarbeiter.iKlassifizierung Property

clsMitarbeiter.iKlassifizierung Property | Previous topic | Next topic
clsMitarbeiter.iKlassifizierung Property | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property iKlassifizierung() As SqlInt32

C#

public SqlInt32 iKlassifizierung {get; set;}

C++

public:
property SqlInt32 iKlassifizierung {
SqlInt32 get( );
void set(
SqlInt32 value
);
}

JScript

public function get iKlassifizierung() : SqlInt32;
public function set iKlassifizierung(value : SqlInt32);

Source code

Visual Basic

Copy Code Copy Code

Public Property [iKlassifizierung]() As SqlInt32
Get
Return m_iKlassifizierung
End Get
Set(ByVal Value As SqlInt32)
m_iKlassifizierung = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsMitarbeiter Class
clsMitarbeiter clsMitarbeiter Members


clsMitarbeiter.iMandantnr Property

clsMitarbeiter.iMandantnr Property

clsMitarbeiter.iMandantnr Property | Previous topic | Next topic
clsMitarbeiter.iMandantnr Property | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property iMandantnr() As SqlInt32

C#

public SqlInt32 iMandantnr {get; set;}

C++

public:
property SqlInt32 iMandantnr {
SqlInt32 get( );
void set(
SqlInt32 value
);
}

JScript

public function get iMandantnr() : SqlInt32;
public function set iMandantnr(value : SqlInt32);

Source code

Visual Basic

Copy Code Copy Code

Public Property [iMandantnr]() As SqlInt32
Get
Return m_iMandantnr
End Get
Set(ByVal Value As SqlInt32)
m_iMandantnr = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsMitarbeiter Class
clsMitarbeiter clsMitarbeiter Members


clsMitarbeiter.iMitarbeiternr Property

clsMitarbeiter.iMitarbeiternr Property

clsMitarbeiter.iMitarbeiternr Property | Previous topic | Next topic
clsMitarbeiter.iMitarbeiternr Property | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property iMitarbeiternr() As SqlInt32

C#

public SqlInt32 iMitarbeiternr {get; set;}

C++

public:
property SqlInt32 iMitarbeiternr {
SqlInt32 get( );
void set(
SqlInt32 value
);
}

JScript

public function get iMitarbeiternr() : SqlInt32;
public function set iMitarbeiternr(value : SqlInt32);

Source code

Visual Basic

Copy Code Copy Code

Public Property [iMitarbeiternr]() As SqlInt32
Get
Return m_iMitarbeiternr
End Get
Set(ByVal Value As SqlInt32)
Dim iMitarbeiternrTmp As SqlInt32 = Value
If iMitarbeiternrTmp.IsNull Then
Throw New ArgumentOutOfRangeException("iMitarbeiternr", "iMitarbeiternr can't be NULL")
End If
m_iMitarbeiternr = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsMitarbeiter Class
clsMitarbeiter clsMitarbeiter Members


clsMitarbeiter.iMutierer Property

clsMitarbeiter.iMutierer Property

clsMitarbeiter.iMutierer Property | Previous topic | Next topic
clsMitarbeiter.iMutierer Property | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property iMutierer() As SqlInt32

C#

public SqlInt32 iMutierer {get; set;}

C++

public:
property SqlInt32 iMutierer {
SqlInt32 get( );
void set(
SqlInt32 value
);
}

JScript

public function get iMutierer() : SqlInt32;
public function set iMutierer(value : SqlInt32);

Source code

Visual Basic

Copy Code Copy Code

Public Property [iMutierer]() As SqlInt32
Get
Return m_iMutierer
End Get
Set(ByVal Value As SqlInt32)
m_iMutierer = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsMitarbeiter Class
clsMitarbeiter clsMitarbeiter Members


clsMitarbeiter.iPartnernr Property

clsMitarbeiter.iPartnernr Property

clsMitarbeiter.iPartnernr Property | Previous topic | Next topic
clsMitarbeiter.iPartnernr Property | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property iPartnernr() As SqlInt32

C#

public SqlInt32 iPartnernr {get; set;}

C++

public:
property SqlInt32 iPartnernr {
SqlInt32 get( );
void set(
SqlInt32 value
);
}

JScript

public function get iPartnernr() : SqlInt32;
public function set iPartnernr(value : SqlInt32);

Source code

Visual Basic

Copy Code Copy Code

Public Property [iPartnernr]() As SqlInt32
Get
Return m_iPartnernr
End Get
Set(ByVal Value As SqlInt32)
Dim iPartnernrTmp As SqlInt32 = Value
If iPartnernrTmp.IsNull Then
Throw New ArgumentOutOfRangeException("iPartnernr", "iPartnernr can't be NULL")
End If
m_iPartnernr = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsMitarbeiter Class
clsMitarbeiter clsMitarbeiter Members


clsMitarbeiter.iSprache Property

clsMitarbeiter.iSprache Property

clsMitarbeiter.iSprache Property | Previous topic | Next topic
clsMitarbeiter.iSprache Property | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property iSprache() As SqlInt32

C#

public SqlInt32 iSprache {get; set;}

C++

public:
property SqlInt32 iSprache {
SqlInt32 get( );
void set(
SqlInt32 value
);
}

JScript

public function get iSprache() : SqlInt32;
public function set iSprache(value : SqlInt32);

Source code

Visual Basic

Copy Code Copy Code

Public Property [iSprache]() As SqlInt32
Get
Return m_iSprache
End Get
Set(ByVal Value As SqlInt32)
m_iSprache = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsMitarbeiter Class
clsMitarbeiter clsMitarbeiter Members


clsMitarbeiter.sAnrede Property

clsMitarbeiter.sAnrede Property

clsMitarbeiter.sAnrede Property | Previous topic | Next topic
clsMitarbeiter.sAnrede Property | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property sAnrede() As SqlString

C#

public SqlString sAnrede {get; set;}

C++

public:
property SqlString sAnrede {
SqlString get( );
void set(
SqlString value
);
}

JScript

public function get sAnrede() : SqlString;
public function set sAnrede(value : SqlString);

Source code

Visual Basic

Copy Code Copy Code

Public Property [sAnrede]() As SqlString
Get
Return m_sAnrede
End Get
Set(ByVal Value As SqlString)
m_sAnrede = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsMitarbeiter Class
clsMitarbeiter clsMitarbeiter Members


clsDBInteractionBase.sConnectionString Property

clsDBInteractionBase.sConnectionString Property

clsDBInteractionBase.sConnectionString Property | Previous topic | Next topic
clsDBInteractionBase.sConnectionString Property | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property sConnectionString() As String

C#

public string sConnectionString {get; set;}

C++

public:
property String^ sConnectionString {
String^ get( );
void set(
String^ value
);
}

JScript

public function get sConnectionString() : String;
public function set sConnectionString(value : String);

Source code

Visual Basic

Copy Code Copy Code

Public Property sConnectionString() As String
Get
Return m_sConnectionString
End Get
Set (ByVal Value As String)
m_sConnectionString = Value
m_scoMainConnection.ConnectionString = m_sConnectionString
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsDBInteractionBase Class
clsDBInteractionBase clsDBInteractionBase Members


clsMitarbeiter.sEmail Property

clsMitarbeiter.sEmail Property

clsMitarbeiter.sEmail Property | Previous topic | Next topic
clsMitarbeiter.sEmail Property | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property sEmail() As SqlString

C#

public SqlString sEmail {get; set;}

C++

public:
property SqlString sEmail {
SqlString get( );
void set(
SqlString value
);
}

JScript

public function get sEmail() : SqlString;
public function set sEmail(value : SqlString);

Source code

Visual Basic

Copy Code Copy Code

Public Property [sEmail]() As SqlString
Get
Return m_sEmail
End Get
Set(ByVal Value As SqlString)
m_sEmail = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsMitarbeiter Class
clsMitarbeiter clsMitarbeiter Members


clsMitarbeiter.sFax Property

clsMitarbeiter.sFax Property

clsMitarbeiter.sFax Property | Previous topic | Next topic
clsMitarbeiter.sFax Property | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property sFax() As SqlString

C#

public SqlString sFax {get; set;}

C++

public:
property SqlString sFax {
SqlString get( );
void set(
SqlString value
);
}

JScript

public function get sFax() : SqlString;
public function set sFax(value : SqlString);

Source code

Visual Basic

Copy Code Copy Code

Public Property [sFax]() As SqlString
Get
Return m_sFax
End Get
Set(ByVal Value As SqlString)
m_sFax = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsMitarbeiter Class
clsMitarbeiter clsMitarbeiter Members


clsMitarbeiter.sFunktion Property

clsMitarbeiter.sFunktion Property

clsMitarbeiter.sFunktion Property | Previous topic | Next topic
clsMitarbeiter.sFunktion Property | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property sFunktion() As SqlString

C#

public SqlString sFunktion {get; set;}

C++

public:
property SqlString sFunktion {
SqlString get( );
void set(
SqlString value
);
}

JScript

public function get sFunktion() : SqlString;
public function set sFunktion(value : SqlString);

Source code

Visual Basic

Copy Code Copy Code

Public Property [sFunktion]() As SqlString
Get
Return m_sFunktion
End Get
Set(ByVal Value As SqlString)
m_sFunktion = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsMitarbeiter Class
clsMitarbeiter clsMitarbeiter Members


clsMitarbeiter.sKurzzeichen Property

clsMitarbeiter.sKurzzeichen Property

clsMitarbeiter.sKurzzeichen Property | Previous topic | Next topic
clsMitarbeiter.sKurzzeichen Property | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property sKurzzeichen() As SqlString

C#

public SqlString sKurzzeichen {get; set;}

C++

public:
property SqlString sKurzzeichen {
SqlString get( );
void set(
SqlString value
);
}

JScript

public function get sKurzzeichen() : SqlString;
public function set sKurzzeichen(value : SqlString);

Source code

Visual Basic

Copy Code Copy Code

Public Property [sKurzzeichen]() As SqlString
Get
Return m_sKurzzeichen
End Get
Set(ByVal Value As SqlString)
m_sKurzzeichen = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsMitarbeiter Class
clsMitarbeiter clsMitarbeiter Members


clsMitarbeiter.sName Property

clsMitarbeiter.sName Property

clsMitarbeiter.sName Property | Previous topic | Next topic
clsMitarbeiter.sName Property | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property sName() As SqlString

C#

public SqlString sName {get; set;}

C++

public:
property SqlString sName {
SqlString get( );
void set(
SqlString value
);
}

JScript

public function get sName() : SqlString;
public function set sName(value : SqlString);

Source code

Visual Basic

Copy Code Copy Code

Public Property [sName]() As SqlString
Get
Return m_sName
End Get
Set(ByVal Value As SqlString)
m_sName = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsMitarbeiter Class
clsMitarbeiter clsMitarbeiter Members


clsMitarbeiter.sRang Property

clsMitarbeiter.sRang Property

clsMitarbeiter.sRang Property | Previous topic | Next topic
clsMitarbeiter.sRang Property | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property sRang() As SqlString

C#

public SqlString sRang {get; set;}

C++

public:
property SqlString sRang {
SqlString get( );
void set(
SqlString value
);
}

JScript

public function get sRang() : SqlString;
public function set sRang(value : SqlString);

Source code

Visual Basic

Copy Code Copy Code

Public Property [sRang]() As SqlString
Get
Return m_sRang
End Get
Set(ByVal Value As SqlString)
m_sRang = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsMitarbeiter Class
clsMitarbeiter clsMitarbeiter Members


clsMitarbeiter.sTelefon Property

clsMitarbeiter.sTelefon Property

clsMitarbeiter.sTelefon Property | Previous topic | Next topic
clsMitarbeiter.sTelefon Property | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property sTelefon() As SqlString

C#

public SqlString sTelefon {get; set;}

C++

public:
property SqlString sTelefon {
SqlString get( );
void set(
SqlString value
);
}

JScript

public function get sTelefon() : SqlString;
public function set sTelefon(value : SqlString);

Source code

Visual Basic

Copy Code Copy Code

Public Property [sTelefon]() As SqlString
Get
Return m_sTelefon
End Get
Set(ByVal Value As SqlString)
m_sTelefon = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsMitarbeiter Class
clsMitarbeiter clsMitarbeiter Members


clsMitarbeiter.sTgnummer Property

clsMitarbeiter.sTgnummer Property

clsMitarbeiter.sTgnummer Property | Previous topic | Next topic
clsMitarbeiter.sTgnummer Property | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property sTgnummer() As SqlString

C#

public SqlString sTgnummer {get; set;}

C++

public:
property SqlString sTgnummer {
SqlString get( );
void set(
SqlString value
);
}

JScript

public function get sTgnummer() : SqlString;
public function set sTgnummer(value : SqlString);

Source code

Visual Basic

Copy Code Copy Code

Public Property [sTgnummer]() As SqlString
Get
Return m_sTgnummer
End Get
Set(ByVal Value As SqlString)
m_sTgnummer = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsMitarbeiter Class
clsMitarbeiter clsMitarbeiter Members


clsMitarbeiter.sUnterschrift_text Property

clsMitarbeiter.sUnterschrift_text Property

clsMitarbeiter.sUnterschrift_text Property | Previous topic | Next topic
clsMitarbeiter.sUnterschrift_text Property | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property sUnterschrift_text() As SqlString

C#

public SqlString sUnterschrift_text {get; set;}

C++

public:
property SqlString sUnterschrift_text {
SqlString get( );
void set(
SqlString value
);
}

JScript

public function get sUnterschrift_text() : SqlString;
public function set sUnterschrift_text(value : SqlString);

Source code

Visual Basic

Copy Code Copy Code

Public Property [sUnterschrift_text]() As SqlString
Get
Return m_sUnterschrift_text
End Get
Set(ByVal Value As SqlString)
m_sUnterschrift_text = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsMitarbeiter Class
clsMitarbeiter clsMitarbeiter Members


clsMitarbeiter.sVorname Property

clsMitarbeiter.sVorname Property

clsMitarbeiter.sVorname Property | Previous topic | Next topic
clsMitarbeiter.sVorname Property | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property sVorname() As SqlString

C#

public SqlString sVorname {get; set;}

C++

public:
property SqlString sVorname {
SqlString get( );
void set(
SqlString value
);
}

JScript

public function get sVorname() : SqlString;
public function set sVorname(value : SqlString);

Source code

Visual Basic

Copy Code Copy Code

Public Property [sVorname]() As SqlString
Get
Return m_sVorname
End Get
Set(ByVal Value As SqlString)
m_sVorname = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsMitarbeiter Class
clsMitarbeiter clsMitarbeiter Members


clsMyMitarbeiter.xtgnummer Property

clsMyMitarbeiter.xtgnummer Property

clsMyMitarbeiter.xtgnummer Property | Previous topic | Next topic
clsMyMitarbeiter.xtgnummer Property | Previous topic | Next topic

Namespace: EDKB12WS.edokaDB
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property xtgnummer() As String

C#

public string xtgnummer {get; set;}

C++

public:
property String^ xtgnummer {
String^ get( );
void set(
String^ value
);
}

JScript

public function get xtgnummer() : String;
public function set xtgnummer(value : String);

Source code

Visual Basic

Copy Code Copy Code

Property xtgnummer() As String
Get
Return m_xtgnummer
End Get
Set(ByVal Value As String)
m_xtgnummer = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsMyMitarbeiter Class
clsMyMitarbeiter clsMyMitarbeiter Members


clsMyMitarbeiter Methods

clsMyMitarbeiter Methods

clsMyMitarbeiter Methods | Previous topic | Next topic
clsMyMitarbeiter Methods | Previous topic | Next topic

Public Methods

 | Name | Description
Supported by the .NET Compact Framework. | Delete | (inherited from clsMitarbeiter ).
Supported by the .NET Compact Framework. | Dispose | (Overloaded) (inherited from clsDBInteractionBase ).
Public method | Equals | (Overloaded) (inherited from Object).
Public method | GetHashCode | (inherited from Object).
Public method | GetType | (Overloaded) (inherited from Object).
Supported by the .NET Compact Framework. | Insert | (inherited from clsMitarbeiter ).
 | ReferenceEquals | (inherited from Object).
Supported by the .NET Compact Framework. | SelectAll | (inherited from clsMitarbeiter ).
Supported by the .NET Compact Framework. | SelectOne | (inherited from clsMitarbeiter ).
Supported by the .NET Compact Framework. | SelectWithTGNummer |
Public method | ToString | (inherited from Object).
Supported by the .NET Compact Framework. | Update | (inherited from clsMitarbeiter ).

Top

Protected Methods

 | Name | Description
Protected method | Finalize | (inherited from Object).
Protected method | MemberwiseClone | (Overloaded) (inherited from Object).

Top

See Also

Reference

clsMyMitarbeiter Class


clsMitarbeiter.Delete Method

clsMitarbeiter.Delete Method

clsMitarbeiter.Delete Method | Previous topic | Next topic
clsMitarbeiter.Delete Method | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Overrides Function Delete() As Boolean

C#

public override bool Delete()

C++

public:
bool Delete()

JScript

public function Delete() : boolean;

Source code

Visual Basic

Copy Code Copy Code

Public Overrides Function Delete() As Boolean
Dim scmCmdToExecute As SqlCommand = New SqlCommand()
scmCmdToExecute.CommandText = "dbo.[pr_mitarbeiter_Delete]"
scmCmdToExecute.CommandType = CommandType.StoredProcedure

' // Use base class' connection object
scmCmdToExecute.Connection = m_scoMainConnection

Try
scmCmdToExecute.Parameters.Add(New SqlParameter("@imitarbeiternr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iMitarbeiternr))
scmCmdToExecute.Parameters.Add(New SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

If m_bMainConnectionIsCreatedLocal Then
' // Open connection.
m_scoMainConnection.Open()
Else
If m_cpMainConnectionProvider.bIsTransactionPending Then
scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
End If
End If

' // Execute query.
scmCmdToExecute.ExecuteNonQuery()
m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
' // Throw error.
Throw New Exception("Stored Procedure 'pr_mitarbeiter_Delete' reported the ErrorCode: " & m_iErrorCode.ToString())
End If

Return True
Catch ex As Exception
' // some error occured. Bubble it to caller and encapsulate Exception object
Throw New Exception("clsMitarbeiter::Delete::Error occured.", ex)
Finally
If m_bMainConnectionIsCreatedLocal Then
' // Close connection.
m_scoMainConnection.Close()
End If
scmCmdToExecute.Dispose()
End Try
End Function

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsMitarbeiter Class
clsMitarbeiter clsMitarbeiter Members


clsDBInteractionBase.Dispose Method

clsDBInteractionBase.Dispose Method

clsDBInteractionBase.Dispose Method | Previous topic | Next topic
clsDBInteractionBase.Dispose Method | Previous topic | Next topic

Overload List

Name | Description
Dispose() |
Dispose(bool) |

See Also

Reference

clsDBInteractionBase Class
clsDBInteractionBase clsDBInteractionBase Members


clsMitarbeiter.Insert Method

clsMitarbeiter.Insert Method

clsMitarbeiter.Insert Method | Previous topic | Next topic
clsMitarbeiter.Insert Method | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Overrides Function Insert() As Boolean

C#

public override bool Insert()

C++

public:
bool Insert()

JScript

public function Insert() : boolean;

Source code

Visual Basic

Copy Code Copy Code

Overrides Public Function Insert() As Boolean
Dim scmCmdToExecute As SqlCommand = New SqlCommand()
scmCmdToExecute.CommandText = "dbo.[pr_mitarbeiter_Insert]"
scmCmdToExecute.CommandType = CommandType.StoredProcedure

' // Use base class' connection object
scmCmdToExecute.Connection = m_scoMainConnection

Try
scmCmdToExecute.Parameters.Add(New SqlParameter("@imitarbeiternr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iMitarbeiternr))
scmCmdToExecute.Parameters.Add(New SqlParameter("@svorname", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sVorname))
scmCmdToExecute.Parameters.Add(New SqlParameter("@sname", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sName))
scmCmdToExecute.Parameters.Add(New SqlParameter("@skurzzeichen", SqlDbType.VarChar, 10, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sKurzzeichen))
scmCmdToExecute.Parameters.Add(New SqlParameter("@sanrede", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sAnrede))
scmCmdToExecute.Parameters.Add(New SqlParameter("@stgnummer", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sTgnummer))
scmCmdToExecute.Parameters.Add(New SqlParameter("@semail", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sEmail))
scmCmdToExecute.Parameters.Add(New SqlParameter("@sfax", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sFax))
scmCmdToExecute.Parameters.Add(New SqlParameter("@stelefon", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sTelefon))
scmCmdToExecute.Parameters.Add(New SqlParameter("@sunterschrift_text", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sUnterschrift_text))
scmCmdToExecute.Parameters.Add(New SqlParameter("@ifunktionnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iFunktionnr))
scmCmdToExecute.Parameters.Add(New SqlParameter("@isprache", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iSprache))
scmCmdToExecute.Parameters.Add(New SqlParameter("@ifuermandant", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iFuermandant))
scmCmdToExecute.Parameters.Add(New SqlParameter("@bshowtip", SqlDbType.Bit, 1, ParameterDirection.Input, False, 1, 0, "", DataRowVersion.Proposed, m_bShowtip))
scmCmdToExecute.Parameters.Add(New SqlParameter("@ipartnernr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iPartnernr))
scmCmdToExecute.Parameters.Add(New SqlParameter("@imandantnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMandantnr))
scmCmdToExecute.Parameters.Add(New SqlParameter("@baktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bAktiv))
scmCmdToExecute.Parameters.Add(New SqlParameter("@daerstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daErstellt_am))
scmCmdToExecute.Parameters.Add(New SqlParameter("@damutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daMutiert_am))
scmCmdToExecute.Parameters.Add(New SqlParameter("@imutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
scmCmdToExecute.Parameters.Add(New SqlParameter("@bMailempfang", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bMailempfang))
scmCmdToExecute.Parameters.Add(New SqlParameter("@bEdokaMesasge", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bEdokaMesasge))
scmCmdToExecute.Parameters.Add(New SqlParameter("@sfunktion", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sFunktion))
scmCmdToExecute.Parameters.Add(New SqlParameter("@bMailDirektVersenden", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bMailDirektVersenden))
scmCmdToExecute.Parameters.Add(New SqlParameter("@sRang", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sRang))
scmCmdToExecute.Parameters.Add(New SqlParameter("@bMailDokumentrueckgang", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bMailDokumentrueckgang))
scmCmdToExecute.Parameters.Add(New SqlParameter("@iklassifizierung", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iKlassifizierung))
scmCmdToExecute.Parameters.Add(New SqlParameter("@bedoka_mail", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bEdoka_mail))
scmCmdToExecute.Parameters.Add(New SqlParameter("@bjournalisierung", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bJournalisierung))
scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

If m_bMainConnectionIsCreatedLocal Then
' // Open connection.
m_scoMainConnection.Open()
Else
If m_cpMainConnectionProvider.bIsTransactionPending Then
scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
End If
End If

' // Execute query.
scmCmdToExecute.ExecuteNonQuery()
m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
' // Throw error.
Throw New Exception("Stored Procedure 'pr_mitarbeiter_Insert' reported the ErrorCode: " & m_iErrorCode.ToString())
End If

Return True
Catch ex As Exception
' // some error occured. Bubble it to caller and encapsulate Exception object
Throw New Exception("clsMitarbeiter::Insert::Error occured.", ex)
Finally
If m_bMainConnectionIsCreatedLocal Then
' // Close connection.
m_scoMainConnection.Close()
End If
scmCmdToExecute.Dispose()
End Try
End Function

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsMitarbeiter Class
clsMitarbeiter clsMitarbeiter Members


clsMitarbeiter.SelectAll Method

clsMitarbeiter.SelectAll Method

clsMitarbeiter.SelectAll Method | Previous topic | Next topic
clsMitarbeiter.SelectAll Method | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Overrides Function SelectAll() As DataTable

C#

public override DataTable SelectAll()

C++

public:
DataTable^ SelectAll()

JScript

public function SelectAll() : DataTable;

Source code

Visual Basic

Copy Code Copy Code

Public Overrides Function SelectAll() As DataTable
Dim scmCmdToExecute As SqlCommand = New SqlCommand()
scmCmdToExecute.CommandText = "dbo.[pr_mitarbeiter_SelectAll]"
scmCmdToExecute.CommandType = CommandType.StoredProcedure
Dim dtToReturn As DataTable = New DataTable("mitarbeiter")
Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)

' // Use base class' connection object
scmCmdToExecute.Connection = m_scoMainConnection

Try
scmCmdToExecute.Parameters.Add(New SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

If m_bMainConnectionIsCreatedLocal Then
' // Open connection.
m_scoMainConnection.Open()
Else
If m_cpMainConnectionProvider.bIsTransactionPending Then
scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
End If
End If

' // Execute query.
sdaAdapter.Fill(dtToReturn)
m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
' // Throw error.
Throw New Exception("Stored Procedure 'pr_mitarbeiter_SelectAll' reported the ErrorCode: " & m_iErrorCode.ToString())
End If

Return dtToReturn
Catch ex As Exception
' // some error occured. Bubble it to caller and encapsulate Exception object
Throw New Exception("clsMitarbeiter::SelectAll::Error occured.", ex)
Finally
If m_bMainConnectionIsCreatedLocal Then
' // Close connection.
m_scoMainConnection.Close()
End If
scmCmdToExecute.Dispose()
sdaAdapter.Dispose()
End Try
End Function

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsMitarbeiter Class
clsMitarbeiter clsMitarbeiter Members


clsMitarbeiter.SelectOne Method

clsMitarbeiter.SelectOne Method

clsMitarbeiter.SelectOne Method | Previous topic | Next topic
clsMitarbeiter.SelectOne Method | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Overrides Function SelectOne() As DataTable

C#

public override DataTable SelectOne()

C++

public:
DataTable^ SelectOne()

JScript

public function SelectOne() : DataTable;

Source code

Visual Basic

Copy Code Copy Code

Overrides Public Function SelectOne() As DataTable
Dim scmCmdToExecute As SqlCommand = New SqlCommand()
scmCmdToExecute.CommandText = "dbo.[pr_mitarbeiter_SelectOne]"
scmCmdToExecute.CommandType = CommandType.StoredProcedure
Dim dtToReturn As DataTable = new DataTable("mitarbeiter")
Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

' // Use base class' connection object
scmCmdToExecute.Connection = m_scoMainConnection

Try
scmCmdToExecute.Parameters.Add(new SqlParameter("@imitarbeiternr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iMitarbeiternr))
scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

If m_bMainConnectionIsCreatedLocal Then
' // Open connection.
m_scoMainConnection.Open()
Else
If m_cpMainConnectionProvider.bIsTransactionPending Then
scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
End If
End If

' // Execute query.
sdaAdapter.Fill(dtToReturn)
m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
' // Throw error.
Throw New Exception("Stored Procedure 'pr_mitarbeiter_SelectOne' reported the ErrorCode: " & m_iErrorCode.ToString())
End If

If dtToReturn.Rows.Count > 0 Then
m_iMitarbeiternr = New SqlInt32(CType(dtToReturn.Rows(0)("mitarbeiternr"), Integer))
If dtToReturn.Rows(0)("vorname") Is System.DBNull.Value Then
m_sVorname = SqlString.Null
Else
m_sVorname = New SqlString(CType(dtToReturn.Rows(0)("vorname"), String))
End If
If dtToReturn.Rows(0)("name") Is System.DBNull.Value Then
m_sName = SqlString.Null
Else
m_sName = New SqlString(CType(dtToReturn.Rows(0)("name"), String))
End If
If dtToReturn.Rows(0)("kurzzeichen") Is System.DBNull.Value Then
m_sKurzzeichen = SqlString.Null
Else
m_sKurzzeichen = New SqlString(CType(dtToReturn.Rows(0)("kurzzeichen"), String))
End If
If dtToReturn.Rows(0)("anrede") Is System.DBNull.Value Then
m_sAnrede = SqlString.Null
Else
m_sAnrede = New SqlString(CType(dtToReturn.Rows(0)("anrede"), String))
End If
If dtToReturn.Rows(0)("tgnummer") Is System.DBNull.Value Then
m_sTgnummer = SqlString.Null
Else
m_sTgnummer = New SqlString(CType(dtToReturn.Rows(0)("tgnummer"), String))
End If
If dtToReturn.Rows(0)("email") Is System.DBNull.Value Then
m_sEmail = SqlString.Null
Else
m_sEmail = New SqlString(CType(dtToReturn.Rows(0)("email"), String))
End If
If dtToReturn.Rows(0)("fax") Is System.DBNull.Value Then
m_sFax = SqlString.Null
Else
m_sFax = New SqlString(CType(dtToReturn.Rows(0)("fax"), String))
End If
If dtToReturn.Rows(0)("telefon") Is System.DBNull.Value Then
m_sTelefon = SqlString.Null
Else
m_sTelefon = New SqlString(CType(dtToReturn.Rows(0)("telefon"), String))
End If
If dtToReturn.Rows(0)("unterschrift_text") Is System.DBNull.Value Then
m_sUnterschrift_text = SqlString.Null
Else
m_sUnterschrift_text = New SqlString(CType(dtToReturn.Rows(0)("unterschrift_text"), String))
End If
If dtToReturn.Rows(0)("funktionnr") Is System.DBNull.Value Then
m_iFunktionnr = SqlInt32.Null
Else
m_iFunktionnr = New SqlInt32(CType(dtToReturn.Rows(0)("funktionnr"), Integer))
End If
If dtToReturn.Rows(0)("sprache") Is System.DBNull.Value Then
m_iSprache = SqlInt32.Null
Else
m_iSprache = New SqlInt32(CType(dtToReturn.Rows(0)("sprache"), Integer))
End If
m_iFuermandant = New SqlInt32(CType(dtToReturn.Rows(0)("fuermandant"), Integer))
m_bShowtip = New SqlBoolean(CType(dtToReturn.Rows(0)("showtip"), Boolean))
m_iPartnernr = New SqlInt32(CType(dtToReturn.Rows(0)("partnernr"), Integer))
If dtToReturn.Rows(0)("mandantnr") Is System.DBNull.Value Then
m_iMandantnr = SqlInt32.Null
Else
m_iMandantnr = New SqlInt32(CType(dtToReturn.Rows(0)("mandantnr"), Integer))
End If
If dtToReturn.Rows(0)("aktiv") Is System.DBNull.Value Then
m_bAktiv = SqlBoolean.Null
Else
m_bAktiv = New SqlBoolean(CType(dtToReturn.Rows(0)("aktiv"), Boolean))
End If
If dtToReturn.Rows(0)("erstellt_am") Is System.DBNull.Value Then
m_daErstellt_am = SqlDateTime.Null
Else
m_daErstellt_am = New SqlDateTime(CType(dtToReturn.Rows(0)("erstellt_am"), Date))
End If
If dtToReturn.Rows(0)("mutiert_am") Is System.DBNull.Value Then
m_daMutiert_am = SqlDateTime.Null
Else
m_daMutiert_am = New SqlDateTime(CType(dtToReturn.Rows(0)("mutiert_am"), Date))
End If
If dtToReturn.Rows(0)("mutierer") Is System.DBNull.Value Then
m_iMutierer = SqlInt32.Null
Else
m_iMutierer = New SqlInt32(CType(dtToReturn.Rows(0)("mutierer"), Integer))
End If
If dtToReturn.Rows(0)("Mailempfang") Is System.DBNull.Value Then
m_bMailempfang = SqlBoolean.Null
Else
m_bMailempfang = New SqlBoolean(CType(dtToReturn.Rows(0)("Mailempfang"), Boolean))
End If
If dtToReturn.Rows(0)("EdokaMesasge") Is System.DBNull.Value Then
m_bEdokaMesasge = SqlBoolean.Null
Else
m_bEdokaMesasge = New SqlBoolean(CType(dtToReturn.Rows(0)("EdokaMesasge"), Boolean))
End If
If dtToReturn.Rows(0)("funktion") Is System.DBNull.Value Then
m_sFunktion = SqlString.Null
Else
m_sFunktion = New SqlString(CType(dtToReturn.Rows(0)("funktion"), String))
End If
If dtToReturn.Rows(0)("MailDirektVersenden") Is System.DBNull.Value Then
m_bMailDirektVersenden = SqlBoolean.Null
Else
m_bMailDirektVersenden = New SqlBoolean(CType(dtToReturn.Rows(0)("MailDirektVersenden"), Boolean))
End If
If dtToReturn.Rows(0)("Rang") Is System.DBNull.Value Then
m_sRang = SqlString.Null
Else
m_sRang = New SqlString(CType(dtToReturn.Rows(0)("Rang"), String))
End If
If dtToReturn.Rows(0)("MailDokumentrueckgang") Is System.DBNull.Value Then
m_bMailDokumentrueckgang = SqlBoolean.Null
Else
m_bMailDokumentrueckgang = New SqlBoolean(CType(dtToReturn.Rows(0)("MailDokumentrueckgang"), Boolean))
End If
If dtToReturn.Rows(0)("klassifizierung") Is System.DBNull.Value Then
m_iKlassifizierung = SqlInt32.Null
Else
m_iKlassifizierung = New SqlInt32(CType(dtToReturn.Rows(0)("klassifizierung"), Integer))
End If
If dtToReturn.Rows(0)("edoka_mail") Is System.DBNull.Value Then
m_bEdoka_mail = SqlBoolean.Null
Else
m_bEdoka_mail = New SqlBoolean(CType(dtToReturn.Rows(0)("edoka_mail"), Boolean))
End If
If dtToReturn.Rows(0)("journalisierung") Is System.DBNull.Value Then
m_bJournalisierung = SqlBoolean.Null
Else
m_bJournalisierung = New SqlBoolean(CType(dtToReturn.Rows(0)("journalisierung"), Boolean))
End If
End If
Return dtToReturn
Catch ex As Exception
' // some error occured. Bubble it to caller and encapsulate Exception object
Throw New Exception("clsMitarbeiter::SelectOne::Error occured.", ex)
Finally
If m_bMainConnectionIsCreatedLocal Then
' // Close connection.
m_scoMainConnection.Close()
End If
scmCmdToExecute.Dispose()
sdaAdapter.Dispose()
End Try
End Function

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsMitarbeiter Class
clsMitarbeiter clsMitarbeiter Members


clsMyMitarbeiter.SelectWithTGNummer Method

clsMyMitarbeiter.SelectWithTGNummer Method

clsMyMitarbeiter.SelectWithTGNummer Method | Previous topic | Next topic
clsMyMitarbeiter.SelectWithTGNummer Method | Previous topic | Next topic

Namespace: EDKB12WS.edokaDB
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Function SelectWithTGNummer() As DataTable

C#

public DataTable SelectWithTGNummer()

C++

public:
DataTable^ SelectWithTGNummer()

JScript

public function SelectWithTGNummer() : DataTable;

Source code

Visual Basic

Copy Code Copy Code

Public Function SelectWithTGNummer() As DataTable
Dim scmCmdToExecute As SqlCommand = New SqlCommand()
scmCmdToExecute.CommandText = "dbo.[sp_mitarbeiter_SelectWithTGNummer]"
scmCmdToExecute.CommandType = CommandType.StoredProcedure
Dim dtToReturn As DataTable = New DataTable("mitarbeiter")
Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)

' // Use base class' connection object
scmCmdToExecute.Connection = m_scoMainConnection
Try

scmCmdToExecute.Parameters.Add(New SqlParameter("@stgnummer", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_xtgnummer))

scmCmdToExecute.Parameters.Add(New SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

If m_bMainConnectionIsCreatedLocal Then
' // Open connection.
m_scoMainConnection.Open()
Else
If m_cpMainConnectionProvider.bIsTransactionPending Then
scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
End If
End If

' // Execute query.
sdaAdapter.Fill(dtToReturn)
m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
' // Throw error.
Throw New Exception("Stored Procedure 'pr_mitarbeiter_SelectAllWithTGNummer' reported the ErrorCode: " & m_iErrorCode.ToString())
End If
Globals.CurrentMitarbeiterdata = dtToReturn
Return dtToReturn
Catch ex As Exception
MsgBox(ex.Message)
' // some error occured. Bubble it to caller and encapsulate Exception object
Throw New Exception("clsMitarbeiter::SelectWithTGNummer::Error occured." + ex.Message, ex)
Finally
If m_bMainConnectionIsCreatedLocal Then
' // Close connection.
m_scoMainConnection.Close()
End If
scmCmdToExecute.Dispose()
sdaAdapter.Dispose()
End Try
End Function

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsMyMitarbeiter Class
clsMyMitarbeiter clsMyMitarbeiter Members


clsMitarbeiter.Update Method

clsMitarbeiter.Update Method

clsMitarbeiter.Update Method | Previous topic | Next topic
clsMitarbeiter.Update Method | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Overrides Function Update() As Boolean

C#

public override bool Update()

C++

public:
bool Update()

JScript

public function Update() : boolean;

Source code

Visual Basic

Copy Code Copy Code

Overrides Public Function Update() As Boolean
Dim scmCmdToExecute As SqlCommand = New SqlCommand()
scmCmdToExecute.CommandText = "dbo.[pr_mitarbeiter_Update]"
scmCmdToExecute.CommandType = CommandType.StoredProcedure

' // Use base class' connection object
scmCmdToExecute.Connection = m_scoMainConnection

Try
scmCmdToExecute.Parameters.Add(New SqlParameter("@imitarbeiternr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iMitarbeiternr))
scmCmdToExecute.Parameters.Add(New SqlParameter("@svorname", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sVorname))
scmCmdToExecute.Parameters.Add(New SqlParameter("@sname", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sName))
scmCmdToExecute.Parameters.Add(New SqlParameter("@skurzzeichen", SqlDbType.VarChar, 10, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sKurzzeichen))
scmCmdToExecute.Parameters.Add(New SqlParameter("@sanrede", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sAnrede))
scmCmdToExecute.Parameters.Add(New SqlParameter("@stgnummer", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sTgnummer))
scmCmdToExecute.Parameters.Add(New SqlParameter("@semail", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sEmail))
scmCmdToExecute.Parameters.Add(New SqlParameter("@sfax", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sFax))
scmCmdToExecute.Parameters.Add(New SqlParameter("@stelefon", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sTelefon))
scmCmdToExecute.Parameters.Add(New SqlParameter("@sunterschrift_text", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sUnterschrift_text))
scmCmdToExecute.Parameters.Add(New SqlParameter("@ifunktionnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iFunktionnr))
scmCmdToExecute.Parameters.Add(New SqlParameter("@isprache", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iSprache))
scmCmdToExecute.Parameters.Add(New SqlParameter("@ifuermandant", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iFuermandant))
scmCmdToExecute.Parameters.Add(New SqlParameter("@bshowtip", SqlDbType.Bit, 1, ParameterDirection.Input, False, 1, 0, "", DataRowVersion.Proposed, m_bShowtip))
scmCmdToExecute.Parameters.Add(New SqlParameter("@ipartnernr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iPartnernr))
scmCmdToExecute.Parameters.Add(New SqlParameter("@imandantnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMandantnr))
scmCmdToExecute.Parameters.Add(New SqlParameter("@baktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bAktiv))
scmCmdToExecute.Parameters.Add(New SqlParameter("@daerstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daErstellt_am))
scmCmdToExecute.Parameters.Add(New SqlParameter("@damutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daMutiert_am))
scmCmdToExecute.Parameters.Add(New SqlParameter("@imutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
scmCmdToExecute.Parameters.Add(New SqlParameter("@bMailempfang", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bMailempfang))
scmCmdToExecute.Parameters.Add(New SqlParameter("@bEdokaMesasge", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bEdokaMesasge))
scmCmdToExecute.Parameters.Add(New SqlParameter("@sfunktion", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sFunktion))
scmCmdToExecute.Parameters.Add(New SqlParameter("@bMailDirektVersenden", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bMailDirektVersenden))
scmCmdToExecute.Parameters.Add(New SqlParameter("@sRang", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sRang))
scmCmdToExecute.Parameters.Add(New SqlParameter("@bMailDokumentrueckgang", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bMailDokumentrueckgang))
scmCmdToExecute.Parameters.Add(New SqlParameter("@iklassifizierung", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iKlassifizierung))
scmCmdToExecute.Parameters.Add(New SqlParameter("@bedoka_mail", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bEdoka_mail))
scmCmdToExecute.Parameters.Add(New SqlParameter("@bjournalisierung", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bJournalisierung))
scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

If m_bMainConnectionIsCreatedLocal Then
' // Open connection.
m_scoMainConnection.Open()
Else
If m_cpMainConnectionProvider.bIsTransactionPending Then
scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
End If
End If

' // Execute query.
scmCmdToExecute.ExecuteNonQuery()
m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
' // Throw error.
Throw New Exception("Stored Procedure 'pr_mitarbeiter_Update' reported the ErrorCode: " & m_iErrorCode.ToString())
End If

Return True
Catch ex As Exception
' // some error occured. Bubble it to caller and encapsulate Exception object
Throw New Exception("clsMitarbeiter::Update::Error occured.", ex)
Finally
If m_bMainConnectionIsCreatedLocal Then
' // Close connection.
m_scoMainConnection.Close()
End If
scmCmdToExecute.Dispose()
End Try
End Function

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsMitarbeiter Class
clsMitarbeiter clsMitarbeiter Members


clsMyMitarbeiter Fields

clsMyMitarbeiter Fields

clsMyMitarbeiter Fields | Previous topic | Next topic
clsMyMitarbeiter Fields | Previous topic | Next topic

Fields

 | Name | Description
Supported by the .NET Compact Framework. | m_bMainConnectionIsCreatedLocal | (inherited from clsDBInteractionBase ).
Supported by the .NET Compact Framework. | m_cpMainConnectionProvider | (inherited from clsDBInteractionBase ).
Supported by the .NET Compact Framework. | m_iErrorCode | (inherited from clsDBInteractionBase ).
Supported by the .NET Compact Framework. | m_scoMainConnection | (inherited from clsDBInteractionBase ).
Supported by the .NET Compact Framework. | m_xtgnummer |

Top

See Also

Reference

clsMyMitarbeiter Class


m_bMainConnectionIsCreatedLocal Field

m_bMainConnectionIsCreatedLocal Field

m_bMainConnectionIsCreatedLocal Field | Previous topic | Next topic
m_bMainConnectionIsCreatedLocal Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Protected m_bMainConnectionIsCreatedLocal As Boolean

C#

protected bool m_bMainConnectionIsCreatedLocal

C++

protected:
bool m_bMainConnectionIsCreatedLocal;

JScript

protected m_bMainConnectionIsCreatedLocal : boolean

Source code

Visual Basic

Copy Code Copy Code

Protected m_bMainConnectionIsCreatedLocal As Boolean

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsDBInteractionBase Class
clsDBInteractionBase clsDBInteractionBase Members


m_cpMainConnectionProvider Field

m_cpMainConnectionProvider Field

m_cpMainConnectionProvider Field | Previous topic | Next topic
m_cpMainConnectionProvider Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Protected m_cpMainConnectionProvider As clsConnectionProvider

C#

protected clsConnectionProvider m_cpMainConnectionProvider

C++

protected:
clsConnectionProvider^ m_cpMainConnectionProvider;

JScript

protected m_cpMainConnectionProvider : clsConnectionProvider

Source code

Visual Basic

Copy Code Copy Code

Protected m_cpMainConnectionProvider As clsConnectionProvider

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsDBInteractionBase Class
clsDBInteractionBase clsDBInteractionBase Members


m_iErrorCode Field

m_iErrorCode Field

m_iErrorCode Field | Previous topic | Next topic
m_iErrorCode Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Protected m_iErrorCode As SqlInt32

C#

protected SqlInt32 m_iErrorCode

C++

protected:
SqlInt32 m_iErrorCode;

JScript

protected m_iErrorCode : SqlInt32

Source code

Visual Basic

Copy Code Copy Code

Protected m_iErrorCode As SqlInt32

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsDBInteractionBase Class
clsDBInteractionBase clsDBInteractionBase Members


m_scoMainConnection Field

m_scoMainConnection Field

m_scoMainConnection Field | Previous topic | Next topic
m_scoMainConnection Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Protected m_scoMainConnection As SqlConnection

C#

protected SqlConnection m_scoMainConnection

C++

protected:
SqlConnection^ m_scoMainConnection;

JScript

protected m_scoMainConnection : SqlConnection

Source code

Visual Basic

Copy Code Copy Code

Protected m_scoMainConnection As SqlConnection

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsDBInteractionBase Class
clsDBInteractionBase clsDBInteractionBase Members


m_xtgnummer Field

m_xtgnummer Field

m_xtgnummer Field | Previous topic | Next topic
m_xtgnummer Field | Previous topic | Next topic

Namespace: EDKB12WS.edokaDB
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_xtgnummer As String

C#

private string m_xtgnummer

C++

private:
String^ m_xtgnummer;

JScript

private m_xtgnummer : String

Source code

Visual Basic

Copy Code Copy Code

Private m_xtgnummer As String

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsMyMitarbeiter Class
clsMyMitarbeiter clsMyMitarbeiter Members


clsOffice_Vorlage_Datei Class

clsOffice_Vorlage_Datei Class

clsOffice_Vorlage_Datei Class | Previous topic | Next topic
clsOffice_Vorlage_Datei Class | Previous topic | Next topic

Namespace: EDKB12WS.edokaDB
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Class clsOffice_Vorlage_Datei
Inherits clsDBInteractionBase

C#

public class clsOffice_Vorlage_Datei : clsDBInteractionBase

C++

public ref class clsOffice_Vorlage_Datei : public clsDBInteractionBase^

JScript

public class clsOffice_Vorlage_Datei
extends clsDBInteractionBase

Inheritance Hierarchy

System.Object

EDKB12WS.edokadb.clsDBInteractionBase

EDKB12WS.edokaDB.clsOffice_Vorlage_Datei

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsOffice_Vorlage_Datei Members


clsOffice_Vorlage_Datei Members

clsOffice_Vorlage_Datei Members

clsOffice_Vorlage_Datei Members | Previous topic | Next topic
clsOffice_Vorlage_Datei Members | Previous topic | Next topic

The following tables list the members exposed by the clsOffice_Vorlage_Datei type.

Public Constructors

 | Name | Description
Supported by the .NET Compact Framework. | clsOffice_Vorlage_Datei Constructor |

Top

Public Properties

 | Name | Description
Supported by the .NET Compact Framework. | bAktiv |
Supported by the .NET Compact Framework. | bFreigegeben |
Supported by the .NET Compact Framework. | blobVorlage |
Supported by the .NET Compact Framework. | cpMainConnectionProvider | (inherited from clsDBInteractionBase ).
Supported by the .NET Compact Framework. | daFragabe_am |
Supported by the .NET Compact Framework. | daMutiert_am |
Supported by the .NET Compact Framework. | daUebernahme_produktion |
Supported by the .NET Compact Framework. | iErrorCode | (inherited from clsDBInteractionBase ).
Supported by the .NET Compact Framework. | iFreigabe_durch |
Supported by the .NET Compact Framework. | iMutierer |
Supported by the .NET Compact Framework. | iOffice_vorlage_dateinr |
Supported by the .NET Compact Framework. | iOffice_vorlagenr |
Supported by the .NET Compact Framework. | sConnectionString | (inherited from clsDBInteractionBase ).
Supported by the .NET Compact Framework. | sDateiname |

Top

Public Methods

 | Name | Description
Supported by the .NET Compact Framework. | Delete |
Supported by the .NET Compact Framework. | Dispose | (Overloaded) (inherited from clsDBInteractionBase ).
Public method | Equals | (Overloaded) (inherited from Object).
Public method | GetHashCode | (inherited from Object).
Public method | GetType | (Overloaded) (inherited from Object).
Supported by the .NET Compact Framework. | Insert |
 | ReferenceEquals | (inherited from Object).
Supported by the .NET Compact Framework. | SelectAll |
Supported by the .NET Compact Framework. | SelectOne |
Public method | ToString | (inherited from Object).
Supported by the .NET Compact Framework. | Update |

Top

Protected Methods

 | Name | Description
Protected method | Finalize | (inherited from Object).
Protected method | MemberwiseClone | (Overloaded) (inherited from Object).

Top

Fields

 | Name | Description
Supported by the .NET Compact Framework. | m_bAktiv |
Supported by the .NET Compact Framework. | m_bFreigegeben |
Supported by the .NET Compact Framework. | m_bMainConnectionIsCreatedLocal | (inherited from clsDBInteractionBase ).
Supported by the .NET Compact Framework. | m_blobVorlage |
Supported by the .NET Compact Framework. | m_cpMainConnectionProvider | (inherited from clsDBInteractionBase ).
Supported by the .NET Compact Framework. | m_daFragabe_am |
Supported by the .NET Compact Framework. | m_daMutiert_am |
Supported by the .NET Compact Framework. | m_daUebernahme_produktion |
Supported by the .NET Compact Framework. | m_iErrorCode | (inherited from clsDBInteractionBase ).
Supported by the .NET Compact Framework. | m_iFreigabe_durch |
Supported by the .NET Compact Framework. | m_iMutierer |
Supported by the .NET Compact Framework. | m_iOffice_vorlage_dateinr |
Supported by the .NET Compact Framework. | m_iOffice_vorlagenr |
Supported by the .NET Compact Framework. | m_sDateiname |
Supported by the .NET Compact Framework. | m_scoMainConnection | (inherited from clsDBInteractionBase ).

Top

See Also

Reference

clsOffice_Vorlage_Datei Class


clsOffice_Vorlage_Datei Constructor

clsOffice_Vorlage_Datei Constructor

clsOffice_Vorlage_Datei Constructor | Previous topic | Next topic
clsOffice_Vorlage_Datei Constructor | Previous topic | Next topic

Namespace: EDKB12WS.edokaDB
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Sub New()

C#

public clsOffice_Vorlage_Datei()

C++

public:
clsOffice_Vorlage_Datei()

JScript

public function clsOffice_Vorlage_Datei();

Source code

Visual Basic

Copy Code Copy Code

Public Sub New()
' // Nothing for now.
End Sub

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsOffice_Vorlage_Datei Class
clsOffice_Vorlage_Datei clsOffice_Vorlage_Datei Members


clsOffice_Vorlage_Datei Properties

clsOffice_Vorlage_Datei Properties

clsOffice_Vorlage_Datei Properties | Previous topic | Next topic
clsOffice_Vorlage_Datei Properties | Previous topic | Next topic

Public Properties

 | Name | Description
Supported by the .NET Compact Framework. | bAktiv |
Supported by the .NET Compact Framework. | bFreigegeben |
Supported by the .NET Compact Framework. | blobVorlage |
Supported by the .NET Compact Framework. | cpMainConnectionProvider | (inherited from clsDBInteractionBase ).
Supported by the .NET Compact Framework. | daFragabe_am |
Supported by the .NET Compact Framework. | daMutiert_am |
Supported by the .NET Compact Framework. | daUebernahme_produktion |
Supported by the .NET Compact Framework. | iErrorCode | (inherited from clsDBInteractionBase ).
Supported by the .NET Compact Framework. | iFreigabe_durch |
Supported by the .NET Compact Framework. | iMutierer |
Supported by the .NET Compact Framework. | iOffice_vorlage_dateinr |
Supported by the .NET Compact Framework. | iOffice_vorlagenr |
Supported by the .NET Compact Framework. | sConnectionString | (inherited from clsDBInteractionBase ).
Supported by the .NET Compact Framework. | sDateiname |

Top

See Also

Reference

clsOffice_Vorlage_Datei Class


clsOffice_Vorlage_Datei.bAktiv Property

clsOffice_Vorlage_Datei.bAktiv Property

clsOffice_Vorlage_Datei.bAktiv Property | Previous topic | Next topic
clsOffice_Vorlage_Datei.bAktiv Property | Previous topic | Next topic

Namespace: EDKB12WS.edokaDB
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property bAktiv() As SqlBoolean

C#

public SqlBoolean bAktiv {get; set;}

C++

public:
property SqlBoolean bAktiv {
SqlBoolean get( );
void set(
SqlBoolean value
);
}

JScript

public function get bAktiv() : SqlBoolean;
public function set bAktiv(value : SqlBoolean);

Source code

Visual Basic

Copy Code Copy Code

Public Property [bAktiv]() As SqlBoolean
Get
Return m_bAktiv
End Get
Set(ByVal Value As SqlBoolean)
m_bAktiv = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsOffice_Vorlage_Datei Class
clsOffice_Vorlage_Datei clsOffice_Vorlage_Datei Members


clsOffice_Vorlage_Datei.bFreigegeben Property

clsOffice_Vorlage_Datei.bFreigegeben Property

clsOffice_Vorlage_Datei.bFreigegeben Property | Previous topic | Next topic
clsOffice_Vorlage_Datei.bFreigegeben Property | Previous topic | Next topic

Namespace: EDKB12WS.edokaDB
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property bFreigegeben() As SqlBoolean

C#

public SqlBoolean bFreigegeben {get; set;}

C++

public:
property SqlBoolean bFreigegeben {
SqlBoolean get( );
void set(
SqlBoolean value
);
}

JScript

public function get bFreigegeben() : SqlBoolean;
public function set bFreigegeben(value : SqlBoolean);

Source code

Visual Basic

Copy Code Copy Code

Public Property [bFreigegeben]() As SqlBoolean
Get
Return m_bFreigegeben
End Get
Set(ByVal Value As SqlBoolean)
m_bFreigegeben = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsOffice_Vorlage_Datei Class
clsOffice_Vorlage_Datei clsOffice_Vorlage_Datei Members


clsOffice_Vorlage_Datei.blobVorlage Property

clsOffice_Vorlage_Datei.blobVorlage Property

clsOffice_Vorlage_Datei.blobVorlage Property | Previous topic | Next topic
clsOffice_Vorlage_Datei.blobVorlage Property | Previous topic | Next topic

Namespace: EDKB12WS.edokaDB
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property blobVorlage() As SqlBinary

C#

public SqlBinary blobVorlage {get; set;}

C++

public:
property SqlBinary blobVorlage {
SqlBinary get( );
void set(
SqlBinary value
);
}

JScript

public function get blobVorlage() : SqlBinary;
public function set blobVorlage(value : SqlBinary);

Source code

Visual Basic

Copy Code Copy Code

Public Property [blobVorlage]() As SqlBinary
Get
Return m_blobVorlage
End Get
Set(ByVal Value As SqlBinary)
m_blobVorlage = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsOffice_Vorlage_Datei Class
clsOffice_Vorlage_Datei clsOffice_Vorlage_Datei Members


clsOffice_Vorlage_Datei.daFragabe_am Property

clsOffice_Vorlage_Datei.daFragabe_am Property

clsOffice_Vorlage_Datei.daFragabe_am Property | Previous topic | Next topic
clsOffice_Vorlage_Datei.daFragabe_am Property | Previous topic | Next topic

Namespace: EDKB12WS.edokaDB
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property daFragabe_am() As SqlDateTime

C#

public SqlDateTime daFragabe_am {get; set;}

C++

public:
property SqlDateTime daFragabe_am {
SqlDateTime get( );
void set(
SqlDateTime value
);
}

JScript

public function get daFragabe_am() : SqlDateTime;
public function set daFragabe_am(value : SqlDateTime);

Source code

Visual Basic

Copy Code Copy Code

Public Property [daFragabe_am]() As SqlDateTime
Get
Return m_daFragabe_am
End Get
Set(ByVal Value As SqlDateTime)
m_daFragabe_am = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsOffice_Vorlage_Datei Class
clsOffice_Vorlage_Datei clsOffice_Vorlage_Datei Members


clsOffice_Vorlage_Datei.daMutiert_am Property

clsOffice_Vorlage_Datei.daMutiert_am Property

clsOffice_Vorlage_Datei.daMutiert_am Property | Previous topic | Next topic
clsOffice_Vorlage_Datei.daMutiert_am Property | Previous topic | Next topic

Namespace: EDKB12WS.edokaDB
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property daMutiert_am() As SqlDateTime

C#

public SqlDateTime daMutiert_am {get; set;}

C++

public:
property SqlDateTime daMutiert_am {
SqlDateTime get( );
void set(
SqlDateTime value
);
}

JScript

public function get daMutiert_am() : SqlDateTime;
public function set daMutiert_am(value : SqlDateTime);

Source code

Visual Basic

Copy Code Copy Code

Public Property [daMutiert_am]() As SqlDateTime
Get
Return m_daMutiert_am
End Get
Set(ByVal Value As SqlDateTime)
m_daMutiert_am = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsOffice_Vorlage_Datei Class
clsOffice_Vorlage_Datei clsOffice_Vorlage_Datei Members


clsOffice_Vorlage_Datei.daUebernahme_produktion Property

clsOffice_Vorlage_Datei.daUebernahme_produktion Property

clsOffice_Vorlage_Datei.daUebernahme_produktion Property | Previous topic | Next topic
clsOffice_Vorlage_Datei.daUebernahme_produktion Property | Previous topic | Next topic

Namespace: EDKB12WS.edokaDB
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property daUebernahme_produktion() As SqlDateTime

C#

public SqlDateTime daUebernahme_produktion {get; set;}

C++

public:
property SqlDateTime daUebernahme_produktion {
SqlDateTime get( );
void set(
SqlDateTime value
);
}

JScript

public function get daUebernahme_produktion() : SqlDateTime;
public function set daUebernahme_produktion(value : SqlDateTime);

Source code

Visual Basic

Copy Code Copy Code

Public Property [daUebernahme_produktion]() As SqlDateTime
Get
Return m_daUebernahme_produktion
End Get
Set(ByVal Value As SqlDateTime)
m_daUebernahme_produktion = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsOffice_Vorlage_Datei Class
clsOffice_Vorlage_Datei clsOffice_Vorlage_Datei Members


clsOffice_Vorlage_Datei.iFreigabe_durch Property

clsOffice_Vorlage_Datei.iFreigabe_durch Property

clsOffice_Vorlage_Datei.iFreigabe_durch Property | Previous topic | Next topic
clsOffice_Vorlage_Datei.iFreigabe_durch Property | Previous topic | Next topic

Namespace: EDKB12WS.edokaDB
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property iFreigabe_durch() As SqlInt32

C#

public SqlInt32 iFreigabe_durch {get; set;}

C++

public:
property SqlInt32 iFreigabe_durch {
SqlInt32 get( );
void set(
SqlInt32 value
);
}

JScript

public function get iFreigabe_durch() : SqlInt32;
public function set iFreigabe_durch(value : SqlInt32);

Source code

Visual Basic

Copy Code Copy Code

Public Property [iFreigabe_durch]() As SqlInt32
Get
Return m_iFreigabe_durch
End Get
Set(ByVal Value As SqlInt32)
m_iFreigabe_durch = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsOffice_Vorlage_Datei Class
clsOffice_Vorlage_Datei clsOffice_Vorlage_Datei Members


clsOffice_Vorlage_Datei.iMutierer Property

clsOffice_Vorlage_Datei.iMutierer Property

clsOffice_Vorlage_Datei.iMutierer Property | Previous topic | Next topic
clsOffice_Vorlage_Datei.iMutierer Property | Previous topic | Next topic

Namespace: EDKB12WS.edokaDB
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property iMutierer() As SqlInt32

C#

public SqlInt32 iMutierer {get; set;}

C++

public:
property SqlInt32 iMutierer {
SqlInt32 get( );
void set(
SqlInt32 value
);
}

JScript

public function get iMutierer() : SqlInt32;
public function set iMutierer(value : SqlInt32);

Source code

Visual Basic

Copy Code Copy Code

Public Property [iMutierer]() As SqlInt32
Get
Return m_iMutierer
End Get
Set(ByVal Value As SqlInt32)
m_iMutierer = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsOffice_Vorlage_Datei Class
clsOffice_Vorlage_Datei clsOffice_Vorlage_Datei Members


clsOffice_Vorlage_Datei.iOffice_vorlage_dateinr Property

clsOffice_Vorlage_Datei.iOffice_vorlage_dateinr Property

clsOffice_Vorlage_Datei.iOffice_vorlage_dateinr Property | Previous topic | Next topic
clsOffice_Vorlage_Datei.iOffice_vorlage_dateinr Property | Previous topic | Next topic

Namespace: EDKB12WS.edokaDB
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property iOffice_vorlage_dateinr() As SqlInt32

C#

public SqlInt32 iOffice_vorlage_dateinr {get; set;}

C++

public:
property SqlInt32 iOffice_vorlage_dateinr {
SqlInt32 get( );
void set(
SqlInt32 value
);
}

JScript

public function get iOffice_vorlage_dateinr() : SqlInt32;
public function set iOffice_vorlage_dateinr(value : SqlInt32);

Source code

Visual Basic

Copy Code Copy Code

Public Property [iOffice_vorlage_dateinr]() As SqlInt32
Get
Return m_iOffice_vorlage_dateinr
End Get
Set(ByVal Value As SqlInt32)
Dim iOffice_vorlage_dateinrTmp As SqlInt32 = Value
If iOffice_vorlage_dateinrTmp.IsNull Then
Throw New ArgumentOutOfRangeException("iOffice_vorlage_dateinr", "iOffice_vorlage_dateinr can't be NULL")
End If
m_iOffice_vorlage_dateinr = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsOffice_Vorlage_Datei Class
clsOffice_Vorlage_Datei clsOffice_Vorlage_Datei Members


clsOffice_Vorlage_Datei.iOffice_vorlagenr Property

clsOffice_Vorlage_Datei.iOffice_vorlagenr Property

clsOffice_Vorlage_Datei.iOffice_vorlagenr Property | Previous topic | Next topic
clsOffice_Vorlage_Datei.iOffice_vorlagenr Property | Previous topic | Next topic

Namespace: EDKB12WS.edokaDB
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property iOffice_vorlagenr() As SqlInt32

C#

public SqlInt32 iOffice_vorlagenr {get; set;}

C++

public:
property SqlInt32 iOffice_vorlagenr {
SqlInt32 get( );
void set(
SqlInt32 value
);
}

JScript

public function get iOffice_vorlagenr() : SqlInt32;
public function set iOffice_vorlagenr(value : SqlInt32);

Source code

Visual Basic

Copy Code Copy Code

Public Property [iOffice_vorlagenr]() As SqlInt32
Get
Return m_iOffice_vorlagenr
End Get
Set(ByVal Value As SqlInt32)
m_iOffice_vorlagenr = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsOffice_Vorlage_Datei Class
clsOffice_Vorlage_Datei clsOffice_Vorlage_Datei Members


clsOffice_Vorlage_Datei.sDateiname Property

clsOffice_Vorlage_Datei.sDateiname Property

clsOffice_Vorlage_Datei.sDateiname Property | Previous topic | Next topic
clsOffice_Vorlage_Datei.sDateiname Property | Previous topic | Next topic

Namespace: EDKB12WS.edokaDB
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property sDateiname() As SqlString

C#

public SqlString sDateiname {get; set;}

C++

public:
property SqlString sDateiname {
SqlString get( );
void set(
SqlString value
);
}

JScript

public function get sDateiname() : SqlString;
public function set sDateiname(value : SqlString);

Source code

Visual Basic

Copy Code Copy Code

Public Property [sDateiname]() As SqlString
Get
Return m_sDateiname
End Get
Set(ByVal Value As SqlString)
m_sDateiname = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsOffice_Vorlage_Datei Class
clsOffice_Vorlage_Datei clsOffice_Vorlage_Datei Members


clsOffice_Vorlage_Datei Methods

clsOffice_Vorlage_Datei Methods

clsOffice_Vorlage_Datei Methods | Previous topic | Next topic
clsOffice_Vorlage_Datei Methods | Previous topic | Next topic

Public Methods

 | Name | Description
Supported by the .NET Compact Framework. | Delete |
Supported by the .NET Compact Framework. | Dispose | (Overloaded) (inherited from clsDBInteractionBase ).
Public method | Equals | (Overloaded) (inherited from Object).
Public method | GetHashCode | (inherited from Object).
Public method | GetType | (Overloaded) (inherited from Object).
Supported by the .NET Compact Framework. | Insert |
 | ReferenceEquals | (inherited from Object).
Supported by the .NET Compact Framework. | SelectAll |
Supported by the .NET Compact Framework. | SelectOne |
Public method | ToString | (inherited from Object).
Supported by the .NET Compact Framework. | Update |

Top

Protected Methods

 | Name | Description
Protected method | Finalize | (inherited from Object).
Protected method | MemberwiseClone | (Overloaded) (inherited from Object).

Top

See Also

Reference

clsOffice_Vorlage_Datei Class


clsOffice_Vorlage_Datei.Delete Method

clsOffice_Vorlage_Datei.Delete Method

clsOffice_Vorlage_Datei.Delete Method | Previous topic | Next topic
clsOffice_Vorlage_Datei.Delete Method | Previous topic | Next topic

Namespace: EDKB12WS.edokaDB
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Overrides Function Delete() As Boolean

C#

public override bool Delete()

C++

public:
bool Delete()

JScript

public function Delete() : boolean;

Source code

Visual Basic

Copy Code Copy Code

Public Overrides Function Delete() As Boolean
Dim scmCmdToExecute As SqlCommand = New SqlCommand()
scmCmdToExecute.CommandText = "dbo.[pr_Office_Vorlage_Datei_Delete]"
scmCmdToExecute.CommandType = CommandType.StoredProcedure

' // Use base class' connection object
scmCmdToExecute.Connection = m_scoMainConnection

Try
scmCmdToExecute.Parameters.Add(New SqlParameter("@ioffice_vorlage_dateinr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iOffice_vorlage_dateinr))
scmCmdToExecute.Parameters.Add(New SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

If m_bMainConnectionIsCreatedLocal Then
' // Open connection.
m_scoMainConnection.Open()
Else
If m_cpMainConnectionProvider.bIsTransactionPending Then
scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
End If
End If

' // Execute query.
scmCmdToExecute.ExecuteNonQuery()
m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
' // Throw error.
Throw New Exception("Stored Procedure 'pr_Office_Vorlage_Datei_Delete' reported the ErrorCode: " & m_iErrorCode.ToString())
End If

Return True
Catch ex As Exception
' // some error occured. Bubble it to caller and encapsulate Exception object
Throw New Exception("clsOffice_Vorlage_Datei::Delete::Error occured.", ex)
Finally
If m_bMainConnectionIsCreatedLocal Then
' // Close connection.
m_scoMainConnection.Close()
End If
scmCmdToExecute.Dispose()
End Try
End Function

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsOffice_Vorlage_Datei Class
clsOffice_Vorlage_Datei clsOffice_Vorlage_Datei Members


clsOffice_Vorlage_Datei.Insert Method

clsOffice_Vorlage_Datei.Insert Method

clsOffice_Vorlage_Datei.Insert Method | Previous topic | Next topic
clsOffice_Vorlage_Datei.Insert Method | Previous topic | Next topic

Namespace: EDKB12WS.edokaDB
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Overrides Function Insert() As Boolean

C#

public override bool Insert()

C++

public:
bool Insert()

JScript

public function Insert() : boolean;

Source code

Visual Basic

Copy Code Copy Code

Overrides Public Function Insert() As Boolean
Dim scmCmdToExecute As SqlCommand = New SqlCommand()
scmCmdToExecute.CommandText = "dbo.[pr_Office_Vorlage_Datei_Insert]"
scmCmdToExecute.CommandType = CommandType.StoredProcedure

' // Use base class' connection object
scmCmdToExecute.Connection = m_scoMainConnection

Try
scmCmdToExecute.Parameters.Add(New SqlParameter("@ioffice_vorlage_dateinr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iOffice_vorlage_dateinr))
scmCmdToExecute.Parameters.Add(New SqlParameter("@ioffice_vorlagenr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iOffice_vorlagenr))
Dim iLength As Integer = 0
If Not m_blobVorlage.IsNull Then
iLength = m_blobVorlage.Length
End If
scmCmdToExecute.Parameters.Add(New SqlParameter("@blobvorlage", SqlDbType.Image, iLength, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_blobVorlage))
scmCmdToExecute.Parameters.Add(New SqlParameter("@baktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bAktiv))
scmCmdToExecute.Parameters.Add(New SqlParameter("@damutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daMutiert_am))
scmCmdToExecute.Parameters.Add(New SqlParameter("@imutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
scmCmdToExecute.Parameters.Add(New SqlParameter("@bfreigegeben", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bFreigegeben))
scmCmdToExecute.Parameters.Add(New SqlParameter("@dafragabe_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daFragabe_am))
scmCmdToExecute.Parameters.Add(New SqlParameter("@ifreigabe_durch", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iFreigabe_durch))
scmCmdToExecute.Parameters.Add(New SqlParameter("@dauebernahme_produktion", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daUebernahme_produktion))
scmCmdToExecute.Parameters.Add(New SqlParameter("@sdateiname", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sDateiname))
scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

If m_bMainConnectionIsCreatedLocal Then
' // Open connection.
m_scoMainConnection.Open()
Else
If m_cpMainConnectionProvider.bIsTransactionPending Then
scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
End If
End If

' // Execute query.
scmCmdToExecute.ExecuteNonQuery()
m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
' // Throw error.
Throw New Exception("Stored Procedure 'pr_Office_Vorlage_Datei_Insert' reported the ErrorCode: " & m_iErrorCode.ToString())
End If

Return True
Catch ex As Exception
' // some error occured. Bubble it to caller and encapsulate Exception object
Throw New Exception("clsOffice_Vorlage_Datei::Insert::Error occured.", ex)
Finally
If m_bMainConnectionIsCreatedLocal Then
' // Close connection.
m_scoMainConnection.Close()
End If
scmCmdToExecute.Dispose()
End Try
End Function

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsOffice_Vorlage_Datei Class
clsOffice_Vorlage_Datei clsOffice_Vorlage_Datei Members


clsOffice_Vorlage_Datei.SelectAll Method

clsOffice_Vorlage_Datei.SelectAll Method

clsOffice_Vorlage_Datei.SelectAll Method | Previous topic | Next topic
clsOffice_Vorlage_Datei.SelectAll Method | Previous topic | Next topic

Namespace: EDKB12WS.edokaDB
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Overrides Function SelectAll() As DataTable

C#

public override DataTable SelectAll()

C++

public:
DataTable^ SelectAll()

JScript

public function SelectAll() : DataTable;

Source code

Visual Basic

Copy Code Copy Code

Public Overrides Function SelectAll() As DataTable
Dim scmCmdToExecute As SqlCommand = New SqlCommand()
scmCmdToExecute.CommandText = "dbo.[pr_Office_Vorlage_Datei_SelectAll]"
scmCmdToExecute.CommandType = CommandType.StoredProcedure
Dim dtToReturn As DataTable = New DataTable("Office_Vorlage_Datei")
Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)

' // Use base class' connection object
scmCmdToExecute.Connection = m_scoMainConnection

Try
scmCmdToExecute.Parameters.Add(New SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

If m_bMainConnectionIsCreatedLocal Then
' // Open connection.
m_scoMainConnection.Open()
Else
If m_cpMainConnectionProvider.bIsTransactionPending Then
scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
End If
End If

' // Execute query.
sdaAdapter.Fill(dtToReturn)
m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
' // Throw error.
Throw New Exception("Stored Procedure 'pr_Office_Vorlage_Datei_SelectAll' reported the ErrorCode: " & m_iErrorCode.ToString())
End If

Return dtToReturn
Catch ex As Exception
' // some error occured. Bubble it to caller and encapsulate Exception object
Throw New Exception("clsOffice_Vorlage_Datei::SelectAll::Error occured.", ex)
Finally
If m_bMainConnectionIsCreatedLocal Then
' // Close connection.
m_scoMainConnection.Close()
End If
scmCmdToExecute.Dispose()
sdaAdapter.Dispose()
End Try
End Function

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsOffice_Vorlage_Datei Class
clsOffice_Vorlage_Datei clsOffice_Vorlage_Datei Members


clsOffice_Vorlage_Datei.SelectOne Method

clsOffice_Vorlage_Datei.SelectOne Method

clsOffice_Vorlage_Datei.SelectOne Method | Previous topic | Next topic
clsOffice_Vorlage_Datei.SelectOne Method | Previous topic | Next topic

Namespace: EDKB12WS.edokaDB
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Overrides Function SelectOne() As DataTable

C#

public override DataTable SelectOne()

C++

public:
DataTable^ SelectOne()

JScript

public function SelectOne() : DataTable;

Source code

Visual Basic

Copy Code Copy Code

Overrides Public Function SelectOne() As DataTable
Dim scmCmdToExecute As SqlCommand = New SqlCommand()
scmCmdToExecute.CommandText = "dbo.[pr_Office_Vorlage_Datei_SelectOne]"
scmCmdToExecute.CommandType = CommandType.StoredProcedure
Dim dtToReturn As DataTable = new DataTable("Office_Vorlage_Datei")
Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

' // Use base class' connection object
scmCmdToExecute.Connection = m_scoMainConnection

Try
scmCmdToExecute.Parameters.Add(new SqlParameter("@ioffice_vorlage_dateinr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iOffice_vorlage_dateinr))
scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

If m_bMainConnectionIsCreatedLocal Then
' // Open connection.
m_scoMainConnection.Open()
Else
If m_cpMainConnectionProvider.bIsTransactionPending Then
scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
End If
End If

' // Execute query.
sdaAdapter.Fill(dtToReturn)
m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
' // Throw error.
Throw New Exception("Stored Procedure 'pr_Office_Vorlage_Datei_SelectOne' reported the ErrorCode: " & m_iErrorCode.ToString())
End If

If dtToReturn.Rows.Count > 0 Then
m_iOffice_vorlage_dateinr = New SqlInt32(CType(dtToReturn.Rows(0)("office_vorlage_dateinr"), Integer))
If dtToReturn.Rows(0)("office_vorlagenr") Is System.DBNull.Value Then
m_iOffice_vorlagenr = SqlInt32.Null
Else
m_iOffice_vorlagenr = New SqlInt32(CType(dtToReturn.Rows(0)("office_vorlagenr"), Integer))
End If
If dtToReturn.Rows(0)("vorlage") Is System.DBNull.Value Then
m_blobVorlage = SqlBinary.Null
Else
m_blobVorlage = New SqlBinary(CType(dtToReturn.Rows(0)("vorlage"), Byte()))
End If
If dtToReturn.Rows(0)("aktiv") Is System.DBNull.Value Then
m_bAktiv = SqlBoolean.Null
Else
m_bAktiv = New SqlBoolean(CType(dtToReturn.Rows(0)("aktiv"), Boolean))
End If
If dtToReturn.Rows(0)("mutiert_am") Is System.DBNull.Value Then
m_daMutiert_am = SqlDateTime.Null
Else
m_daMutiert_am = New SqlDateTime(CType(dtToReturn.Rows(0)("mutiert_am"), Date))
End If
If dtToReturn.Rows(0)("mutierer") Is System.DBNull.Value Then
m_iMutierer = SqlInt32.Null
Else
m_iMutierer = New SqlInt32(CType(dtToReturn.Rows(0)("mutierer"), Integer))
End If
If dtToReturn.Rows(0)("freigegeben") Is System.DBNull.Value Then
m_bFreigegeben = SqlBoolean.Null
Else
m_bFreigegeben = New SqlBoolean(CType(dtToReturn.Rows(0)("freigegeben"), Boolean))
End If
If dtToReturn.Rows(0)("fragabe_am") Is System.DBNull.Value Then
m_daFragabe_am = SqlDateTime.Null
Else
m_daFragabe_am = New SqlDateTime(CType(dtToReturn.Rows(0)("fragabe_am"), Date))
End If
If dtToReturn.Rows(0)("freigabe_durch") Is System.DBNull.Value Then
m_iFreigabe_durch = SqlInt32.Null
Else
m_iFreigabe_durch = New SqlInt32(CType(dtToReturn.Rows(0)("freigabe_durch"), Integer))
End If
If dtToReturn.Rows(0)("uebernahme_produktion") Is System.DBNull.Value Then
m_daUebernahme_produktion = SqlDateTime.Null
Else
m_daUebernahme_produktion = New SqlDateTime(CType(dtToReturn.Rows(0)("uebernahme_produktion"), Date))
End If
If dtToReturn.Rows(0)("dateiname") Is System.DBNull.Value Then
m_sDateiname = SqlString.Null
Else
m_sDateiname = New SqlString(CType(dtToReturn.Rows(0)("dateiname"), String))
End If
End If
Return dtToReturn
Catch ex As Exception
' // some error occured. Bubble it to caller and encapsulate Exception object
Throw New Exception("clsOffice_Vorlage_Datei::SelectOne::Error occured.", ex)
Finally
If m_bMainConnectionIsCreatedLocal Then
' // Close connection.
m_scoMainConnection.Close()
End If
scmCmdToExecute.Dispose()
sdaAdapter.Dispose()
End Try
End Function

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsOffice_Vorlage_Datei Class
clsOffice_Vorlage_Datei clsOffice_Vorlage_Datei Members


clsOffice_Vorlage_Datei.Update Method

clsOffice_Vorlage_Datei.Update Method

clsOffice_Vorlage_Datei.Update Method | Previous topic | Next topic
clsOffice_Vorlage_Datei.Update Method | Previous topic | Next topic

Namespace: EDKB12WS.edokaDB
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Overrides Function Update() As Boolean

C#

public override bool Update()

C++

public:
bool Update()

JScript

public function Update() : boolean;

Source code

Visual Basic

Copy Code Copy Code

Overrides Public Function Update() As Boolean
Dim scmCmdToExecute As SqlCommand = New SqlCommand()
scmCmdToExecute.CommandText = "dbo.[pr_Office_Vorlage_Datei_Update]"
scmCmdToExecute.CommandType = CommandType.StoredProcedure

' // Use base class' connection object
scmCmdToExecute.Connection = m_scoMainConnection

Try
scmCmdToExecute.Parameters.Add(New SqlParameter("@ioffice_vorlage_dateinr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iOffice_vorlage_dateinr))
scmCmdToExecute.Parameters.Add(New SqlParameter("@ioffice_vorlagenr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iOffice_vorlagenr))
Dim iLength As Integer = 0
If Not m_blobVorlage.IsNull Then
iLength = m_blobVorlage.Length
End If
scmCmdToExecute.Parameters.Add(New SqlParameter("@blobvorlage", SqlDbType.Image, iLength, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_blobVorlage))
scmCmdToExecute.Parameters.Add(New SqlParameter("@baktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bAktiv))
scmCmdToExecute.Parameters.Add(New SqlParameter("@damutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daMutiert_am))
scmCmdToExecute.Parameters.Add(New SqlParameter("@imutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
scmCmdToExecute.Parameters.Add(New SqlParameter("@bfreigegeben", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bFreigegeben))
scmCmdToExecute.Parameters.Add(New SqlParameter("@dafragabe_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daFragabe_am))
scmCmdToExecute.Parameters.Add(New SqlParameter("@ifreigabe_durch", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iFreigabe_durch))
scmCmdToExecute.Parameters.Add(New SqlParameter("@dauebernahme_produktion", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daUebernahme_produktion))
scmCmdToExecute.Parameters.Add(New SqlParameter("@sdateiname", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sDateiname))
scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

If m_bMainConnectionIsCreatedLocal Then
' // Open connection.
m_scoMainConnection.Open()
Else
If m_cpMainConnectionProvider.bIsTransactionPending Then
scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
End If
End If

' // Execute query.
scmCmdToExecute.ExecuteNonQuery()
m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
' // Throw error.
Throw New Exception("Stored Procedure 'pr_Office_Vorlage_Datei_Update' reported the ErrorCode: " & m_iErrorCode.ToString())
End If

Return True
Catch ex As Exception
' // some error occured. Bubble it to caller and encapsulate Exception object
Throw New Exception("clsOffice_Vorlage_Datei::Update::Error occured.", ex)
Finally
If m_bMainConnectionIsCreatedLocal Then
' // Close connection.
m_scoMainConnection.Close()
End If
scmCmdToExecute.Dispose()
End Try
End Function

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsOffice_Vorlage_Datei Class
clsOffice_Vorlage_Datei clsOffice_Vorlage_Datei Members


clsOffice_Vorlage_Datei Fields

clsOffice_Vorlage_Datei Fields

clsOffice_Vorlage_Datei Fields | Previous topic | Next topic
clsOffice_Vorlage_Datei Fields | Previous topic | Next topic

Fields

 | Name | Description
Supported by the .NET Compact Framework. | m_bAktiv |
Supported by the .NET Compact Framework. | m_bFreigegeben |
Supported by the .NET Compact Framework. | m_bMainConnectionIsCreatedLocal | (inherited from clsDBInteractionBase ).
Supported by the .NET Compact Framework. | m_blobVorlage |
Supported by the .NET Compact Framework. | m_cpMainConnectionProvider | (inherited from clsDBInteractionBase ).
Supported by the .NET Compact Framework. | m_daFragabe_am |
Supported by the .NET Compact Framework. | m_daMutiert_am |
Supported by the .NET Compact Framework. | m_daUebernahme_produktion |
Supported by the .NET Compact Framework. | m_iErrorCode | (inherited from clsDBInteractionBase ).
Supported by the .NET Compact Framework. | m_iFreigabe_durch |
Supported by the .NET Compact Framework. | m_iMutierer |
Supported by the .NET Compact Framework. | m_iOffice_vorlage_dateinr |
Supported by the .NET Compact Framework. | m_iOffice_vorlagenr |
Supported by the .NET Compact Framework. | m_sDateiname |
Supported by the .NET Compact Framework. | m_scoMainConnection | (inherited from clsDBInteractionBase ).

Top

See Also

Reference

clsOffice_Vorlage_Datei Class


m_bAktiv Field

m_bAktiv Field

m_bAktiv Field | Previous topic | Next topic
m_bAktiv Field | Previous topic | Next topic

Namespace: EDKB12WS.edokaDB
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_bAktiv As SqlBoolean

C#

private SqlBoolean m_bAktiv

C++

private:
SqlBoolean m_bAktiv;

JScript

private m_bAktiv : SqlBoolean

Source code

Visual Basic

Copy Code Copy Code

Private m_bAktiv, m_bFreigegeben As SqlBoolean

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsOffice_Vorlage_Datei Class
clsOffice_Vorlage_Datei clsOffice_Vorlage_Datei Members


m_bFreigegeben Field

m_bFreigegeben Field

m_bFreigegeben Field | Previous topic | Next topic
m_bFreigegeben Field | Previous topic | Next topic

Namespace: EDKB12WS.edokaDB
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_bFreigegeben As SqlBoolean

C#

private SqlBoolean m_bFreigegeben

C++

private:
SqlBoolean m_bFreigegeben;

JScript

private m_bFreigegeben : SqlBoolean

Source code

Visual Basic

Copy Code Copy Code

Private m_bAktiv, m_bFreigegeben As SqlBoolean

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsOffice_Vorlage_Datei Class
clsOffice_Vorlage_Datei clsOffice_Vorlage_Datei Members


m_blobVorlage Field

m_blobVorlage Field

m_blobVorlage Field | Previous topic | Next topic
m_blobVorlage Field | Previous topic | Next topic

Namespace: EDKB12WS.edokaDB
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_blobVorlage As SqlBinary

C#

private SqlBinary m_blobVorlage

C++

private:
SqlBinary m_blobVorlage;

JScript

private m_blobVorlage : SqlBinary

Source code

Visual Basic

Copy Code Copy Code

Private m_blobVorlage As SqlBinary

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsOffice_Vorlage_Datei Class
clsOffice_Vorlage_Datei clsOffice_Vorlage_Datei Members


m_daFragabe_am Field

m_daFragabe_am Field

m_daFragabe_am Field | Previous topic | Next topic
m_daFragabe_am Field | Previous topic | Next topic

Namespace: EDKB12WS.edokaDB
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_daFragabe_am As SqlDateTime

C#

private SqlDateTime m_daFragabe_am

C++

private:
SqlDateTime m_daFragabe_am;

JScript

private m_daFragabe_am : SqlDateTime

Source code

Visual Basic

Copy Code Copy Code

Private m_daFragabe_am, m_daUebernahme_produktion, m_daMutiert_am As SqlDateTime

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsOffice_Vorlage_Datei Class
clsOffice_Vorlage_Datei clsOffice_Vorlage_Datei Members


m_daMutiert_am Field

m_daMutiert_am Field

m_daMutiert_am Field | Previous topic | Next topic
m_daMutiert_am Field | Previous topic | Next topic

Namespace: EDKB12WS.edokaDB
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_daMutiert_am As SqlDateTime

C#

private SqlDateTime m_daMutiert_am

C++

private:
SqlDateTime m_daMutiert_am;

JScript

private m_daMutiert_am : SqlDateTime

Source code

Visual Basic

Copy Code Copy Code

Private m_daFragabe_am, m_daUebernahme_produktion, m_daMutiert_am As SqlDateTime

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsOffice_Vorlage_Datei Class
clsOffice_Vorlage_Datei clsOffice_Vorlage_Datei Members


m_daUebernahme_produktion Field

m_daUebernahme_produktion Field

m_daUebernahme_produktion Field | Previous topic | Next topic
m_daUebernahme_produktion Field | Previous topic | Next topic

Namespace: EDKB12WS.edokaDB
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_daUebernahme_produktion As SqlDateTime

C#

private SqlDateTime m_daUebernahme_produktion

C++

private:
SqlDateTime m_daUebernahme_produktion;

JScript

private m_daUebernahme_produktion : SqlDateTime

Source code

Visual Basic

Copy Code Copy Code

Private m_daFragabe_am, m_daUebernahme_produktion, m_daMutiert_am As SqlDateTime

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsOffice_Vorlage_Datei Class
clsOffice_Vorlage_Datei clsOffice_Vorlage_Datei Members


m_iFreigabe_durch Field

m_iFreigabe_durch Field

m_iFreigabe_durch Field | Previous topic | Next topic
m_iFreigabe_durch Field | Previous topic | Next topic

Namespace: EDKB12WS.edokaDB
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_iFreigabe_durch As SqlInt32

C#

private SqlInt32 m_iFreigabe_durch

C++

private:
SqlInt32 m_iFreigabe_durch;

JScript

private m_iFreigabe_durch : SqlInt32

Source code

Visual Basic

Copy Code Copy Code

Private m_iFreigabe_durch, m_iOffice_vorlage_dateinr, m_iOffice_vorlagenr, m_iMutierer As SqlInt32

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsOffice_Vorlage_Datei Class
clsOffice_Vorlage_Datei clsOffice_Vorlage_Datei Members


m_iMutierer Field

m_iMutierer Field

m_iMutierer Field | Previous topic | Next topic
m_iMutierer Field | Previous topic | Next topic

Namespace: EDKB12WS.edokaDB
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_iMutierer As SqlInt32

C#

private SqlInt32 m_iMutierer

C++

private:
SqlInt32 m_iMutierer;

JScript

private m_iMutierer : SqlInt32

Source code

Visual Basic

Copy Code Copy Code

Private m_iFreigabe_durch, m_iOffice_vorlage_dateinr, m_iOffice_vorlagenr, m_iMutierer As SqlInt32

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsOffice_Vorlage_Datei Class
clsOffice_Vorlage_Datei clsOffice_Vorlage_Datei Members


m_iOffice_vorlage_dateinr Field

m_iOffice_vorlage_dateinr Field

m_iOffice_vorlage_dateinr Field | Previous topic | Next topic
m_iOffice_vorlage_dateinr Field | Previous topic | Next topic

Namespace: EDKB12WS.edokaDB
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_iOffice_vorlage_dateinr As SqlInt32

C#

private SqlInt32 m_iOffice_vorlage_dateinr

C++

private:
SqlInt32 m_iOffice_vorlage_dateinr;

JScript

private m_iOffice_vorlage_dateinr : SqlInt32

Source code

Visual Basic

Copy Code Copy Code

Private m_iFreigabe_durch, m_iOffice_vorlage_dateinr, m_iOffice_vorlagenr, m_iMutierer As SqlInt32

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsOffice_Vorlage_Datei Class
clsOffice_Vorlage_Datei clsOffice_Vorlage_Datei Members


m_iOffice_vorlagenr Field

m_iOffice_vorlagenr Field

m_iOffice_vorlagenr Field | Previous topic | Next topic
m_iOffice_vorlagenr Field | Previous topic | Next topic

Namespace: EDKB12WS.edokaDB
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_iOffice_vorlagenr As SqlInt32

C#

private SqlInt32 m_iOffice_vorlagenr

C++

private:
SqlInt32 m_iOffice_vorlagenr;

JScript

private m_iOffice_vorlagenr : SqlInt32

Source code

Visual Basic

Copy Code Copy Code

Private m_iFreigabe_durch, m_iOffice_vorlage_dateinr, m_iOffice_vorlagenr, m_iMutierer As SqlInt32

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsOffice_Vorlage_Datei Class
clsOffice_Vorlage_Datei clsOffice_Vorlage_Datei Members


m_sDateiname Field

m_sDateiname Field

m_sDateiname Field | Previous topic | Next topic
m_sDateiname Field | Previous topic | Next topic

Namespace: EDKB12WS.edokaDB
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_sDateiname As SqlString

C#

private SqlString m_sDateiname

C++

private:
SqlString m_sDateiname;

JScript

private m_sDateiname : SqlString

Source code

Visual Basic

Copy Code Copy Code

Private m_sDateiname As SqlString

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsOffice_Vorlage_Datei Class
clsOffice_Vorlage_Datei clsOffice_Vorlage_Datei Members


EDKB12WS.edokadb Namespace

EDKB12WS.edokadb Namespace

EDKB12WS.edokadb Namespace | Previous topic | Next topic
EDKB12WS.edokadb Namespace | Previous topic | Next topic

Assembly: EDKB12WS (in EDKB12WS.exe)

Classes

 | Name | Description
Supported by the .NET Compact Framework. | clsApplikation |
Supported by the .NET Compact Framework. | clsConnectionProvider |
Supported by the .NET Compact Framework. | clsDBInteractionBase |
Supported by the .NET Compact Framework. | clsDokument |
Supported by the .NET Compact Framework. | clsDokumenttyp |
Supported by the .NET Compact Framework. | clsIdvmakro_office_vorlage |
Supported by the .NET Compact Framework. | clsJournaleintrag |
Supported by the .NET Compact Framework. | clsKey_tabelle |
Supported by the .NET Compact Framework. | clsMitarbeiter |
Supported by the .NET Compact Framework. | clsMyDokumentDaten |
Supported by the .NET Compact Framework. | clsMyKey_Tabelle |
Supported by the .NET Compact Framework. | clsMyPartner |
Supported by the .NET Compact Framework. | clsOffice_vorlage |
Supported by the .NET Compact Framework. | clsPartner |
Supported by the .NET Compact Framework. | clsStatushistory |
Supported by the .NET Compact Framework. | clsVorlagenfeld |

Top

Interfaces

 | Name | Description
Supported by the .NET Compact Framework. | ICommonDBAccess |

Top

Enumerations

 | Name | Description
Supported by the .NET Compact Framework. | LLBLError |

Top

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0


clsApplikation Class

clsApplikation Class

clsApplikation Class | Previous topic | Next topic
clsApplikation Class | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Class clsApplikation
Inherits clsDBInteractionBase

C#

public class clsApplikation : clsDBInteractionBase

C++

public ref class clsApplikation : public clsDBInteractionBase^

JScript

public class clsApplikation
extends clsDBInteractionBase

Inheritance Hierarchy

System.Object

EDKB12WS.edokadb.clsDBInteractionBase

EDKB12WS.edokadb.clsApplikation

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsApplikation Members


clsApplikation Members

clsApplikation Members

clsApplikation Members | Previous topic | Next topic
clsApplikation Members | Previous topic | Next topic

The following tables list the members exposed by the clsApplikation type.

Public Constructors

 | Name | Description
Supported by the .NET Compact Framework. | clsApplikation Constructor |

Top

Public Properties

 | Name | Description
Supported by the .NET Compact Framework. | bAktiv |
Supported by the .NET Compact Framework. | bNet_use |
Supported by the .NET Compact Framework. | bShowlogin |
Supported by the .NET Compact Framework. | cpMainConnectionProvider | (inherited from clsDBInteractionBase ).
Supported by the .NET Compact Framework. | daErstellt_am |
Supported by the .NET Compact Framework. | daLetzer_ams_run |
Supported by the .NET Compact Framework. | daLetzter_cold_run |
Supported by the .NET Compact Framework. | daLetzter_host_run |
Supported by the .NET Compact Framework. | daLetzter_rdm_run |
Supported by the .NET Compact Framework. | daMutiert_am |
Supported by the .NET Compact Framework. | iAmsstunden |
Supported by the .NET Compact Framework. | iAnzahl_Cold_Viewer |
Supported by the .NET Compact Framework. | iApplikationsnr |
Supported by the .NET Compact Framework. | iBcfont_groesse |
Supported by the .NET Compact Framework. | iColdstunden |
Supported by the .NET Compact Framework. | iErrorCode | (inherited from clsDBInteractionBase ).
Supported by the .NET Compact Framework. | iHoststunden |
Supported by the .NET Compact Framework. | iMandantnr |
Supported by the .NET Compact Framework. | iMutierer |
Supported by the .NET Compact Framework. | iRdmstunden |
Supported by the .NET Compact Framework. | iZeitintervall_in_Minuten |
Supported by the .NET Compact Framework. | sBarcode_font |
Supported by the .NET Compact Framework. | sColdgui |
Supported by the .NET Compact Framework. | sColdpassword |
Supported by the .NET Compact Framework. | sColdstart |
Supported by the .NET Compact Framework. | sColdsystem |
Supported by the .NET Compact Framework. | sColduser |
Supported by the .NET Compact Framework. | sConnectionString | (inherited from clsDBInteractionBase ).
Supported by the .NET Compact Framework. | sDokument_server |
Supported by the .NET Compact Framework. | sLogisches_laufwerk |
Supported by the .NET Compact Framework. | sMailadresse |
Supported by the .NET Compact Framework. | sPasswort_excelvorlagen |
Supported by the .NET Compact Framework. | sPasswort_fileserver |
Supported by the .NET Compact Framework. | sPasswort_report |
Supported by the .NET Compact Framework. | sPasswort_vorlagenverwaltung |
Supported by the .NET Compact Framework. | sPasswort_wordvorlagen |
Supported by the .NET Compact Framework. | sPfad_dokumente |
Supported by the .NET Compact Framework. | sPfad_excel_vorlagen |
Supported by the .NET Compact Framework. | sPfad_reportdateien |
Supported by the .NET Compact Framework. | sPfad_temporaer_dokumente |
Supported by the .NET Compact Framework. | sPfad_word_vorlagen |
Supported by the .NET Compact Framework. | sReport_db |
Supported by the .NET Compact Framework. | sReport_server |
Supported by the .NET Compact Framework. | sUser_fileserver |
Supported by the .NET Compact Framework. | sUser_report |
Supported by the .NET Compact Framework. | sVersion |
Supported by the .NET Compact Framework. | sVideomenu |

Top

Public Methods

 | Name | Description
Supported by the .NET Compact Framework. | Delete |
Supported by the .NET Compact Framework. | Dispose | (Overloaded) (inherited from clsDBInteractionBase ).
Public method | Equals | (Overloaded) (inherited from Object).
Public method | GetHashCode | (inherited from Object).
Public method | GetType | (Overloaded) (inherited from Object).
Supported by the .NET Compact Framework. | Insert |
 | ReferenceEquals | (inherited from Object).
Supported by the .NET Compact Framework. | SelectAll |
Supported by the .NET Compact Framework. | SelectOne |
Public method | ToString | (inherited from Object).
Supported by the .NET Compact Framework. | Update |

Top

Protected Methods

 | Name | Description
Protected method | Finalize | (inherited from Object).
Protected method | MemberwiseClone | (Overloaded) (inherited from Object).

Top

Fields

 | Name | Description
Supported by the .NET Compact Framework. | m_bAktiv |
Supported by the .NET Compact Framework. | m_bMainConnectionIsCreatedLocal | (inherited from clsDBInteractionBase ).
Supported by the .NET Compact Framework. | m_bNet_use |
Supported by the .NET Compact Framework. | m_bShowlogin |
Supported by the .NET Compact Framework. | m_cpMainConnectionProvider | (inherited from clsDBInteractionBase ).
Supported by the .NET Compact Framework. | m_cutoverdate |
Supported by the .NET Compact Framework. | m_daErstellt_am |
Supported by the .NET Compact Framework. | m_daLetzer_ams_run |
Supported by the .NET Compact Framework. | m_daLetzter_cold_run |
Supported by the .NET Compact Framework. | m_daLetzter_host_run |
Supported by the .NET Compact Framework. | m_daLetzter_rdm_run |
Supported by the .NET Compact Framework. | m_daMutiert_am |
Supported by the .NET Compact Framework. | m_iAmsstunden |
Supported by the .NET Compact Framework. | m_iAnzahl_Cold_Viewer |
Supported by the .NET Compact Framework. | m_iApplikationsnr |
Supported by the .NET Compact Framework. | m_iBcfont_groesse |
Supported by the .NET Compact Framework. | m_iColdstunden |
Supported by the .NET Compact Framework. | m_iErrorCode | (inherited from clsDBInteractionBase ).
Supported by the .NET Compact Framework. | m_iHoststunden |
Supported by the .NET Compact Framework. | m_iMandantnr |
Supported by the .NET Compact Framework. | m_iMutierer |
Supported by the .NET Compact Framework. | m_iRdmstunden |
Supported by the .NET Compact Framework. | m_iZeitintervall_in_Minuten |
Supported by the .NET Compact Framework. | m_sBarcode_font |
Supported by the .NET Compact Framework. | m_sColdgui |
Supported by the .NET Compact Framework. | m_sColdpassword |
Supported by the .NET Compact Framework. | m_sColdstart |
Supported by the .NET Compact Framework. | m_sColdsystem |
Supported by the .NET Compact Framework. | m_sColduser |
Supported by the .NET Compact Framework. | m_sDokument_server |
Supported by the .NET Compact Framework. | m_sLogisches_laufwerk |
Supported by the .NET Compact Framework. | m_sMailadresse |
Supported by the .NET Compact Framework. | m_sPasswort_excelvorlagen |
Supported by the .NET Compact Framework. | m_sPasswort_fileserver |
Supported by the .NET Compact Framework. | m_sPasswort_report |
Supported by the .NET Compact Framework. | m_sPasswort_vorlagenverwaltung |
Supported by the .NET Compact Framework. | m_sPasswort_wordvorlagen |
Supported by the .NET Compact Framework. | m_sPfad_dokumente |
Supported by the .NET Compact Framework. | m_sPfad_excel_vorlagen |
Supported by the .NET Compact Framework. | m_sPfad_reportdateien |
Supported by the .NET Compact Framework. | m_sPfad_temporaer_dokumente |
Supported by the .NET Compact Framework. | m_sPfad_word_vorlagen |
Supported by the .NET Compact Framework. | m_sReport_db |
Supported by the .NET Compact Framework. | m_sReport_server |
Supported by the .NET Compact Framework. | m_sUser_fileserver |
Supported by the .NET Compact Framework. | m_sUser_report |
Supported by the .NET Compact Framework. | m_sVersion |
Supported by the .NET Compact Framework. | m_sVideomenu |
Supported by the .NET Compact Framework. | m_scoMainConnection | (inherited from clsDBInteractionBase ).

Top

See Also

Reference

clsApplikation Class


clsApplikation Constructor

clsApplikation Constructor

clsApplikation Constructor | Previous topic | Next topic
clsApplikation Constructor | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Sub New()

C#

public clsApplikation()

C++

public:
clsApplikation()

JScript

public function clsApplikation();

Source code

Visual Basic

Copy Code Copy Code

Public Sub New()
' // Nothing for now.
End Sub

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsApplikation Class
clsApplikation clsApplikation Members


clsApplikation Properties

clsApplikation Properties

clsApplikation Properties | Previous topic | Next topic
clsApplikation Properties | Previous topic | Next topic

Public Properties

 | Name | Description
Supported by the .NET Compact Framework. | bAktiv |
Supported by the .NET Compact Framework. | bNet_use |
Supported by the .NET Compact Framework. | bShowlogin |
Supported by the .NET Compact Framework. | cpMainConnectionProvider | (inherited from clsDBInteractionBase ).
Supported by the .NET Compact Framework. | daErstellt_am |
Supported by the .NET Compact Framework. | daLetzer_ams_run |
Supported by the .NET Compact Framework. | daLetzter_cold_run |
Supported by the .NET Compact Framework. | daLetzter_host_run |
Supported by the .NET Compact Framework. | daLetzter_rdm_run |
Supported by the .NET Compact Framework. | daMutiert_am |
Supported by the .NET Compact Framework. | iAmsstunden |
Supported by the .NET Compact Framework. | iAnzahl_Cold_Viewer |
Supported by the .NET Compact Framework. | iApplikationsnr |
Supported by the .NET Compact Framework. | iBcfont_groesse |
Supported by the .NET Compact Framework. | iColdstunden |
Supported by the .NET Compact Framework. | iErrorCode | (inherited from clsDBInteractionBase ).
Supported by the .NET Compact Framework. | iHoststunden |
Supported by the .NET Compact Framework. | iMandantnr |
Supported by the .NET Compact Framework. | iMutierer |
Supported by the .NET Compact Framework. | iRdmstunden |
Supported by the .NET Compact Framework. | iZeitintervall_in_Minuten |
Supported by the .NET Compact Framework. | sBarcode_font |
Supported by the .NET Compact Framework. | sColdgui |
Supported by the .NET Compact Framework. | sColdpassword |
Supported by the .NET Compact Framework. | sColdstart |
Supported by the .NET Compact Framework. | sColdsystem |
Supported by the .NET Compact Framework. | sColduser |
Supported by the .NET Compact Framework. | sConnectionString | (inherited from clsDBInteractionBase ).
Supported by the .NET Compact Framework. | sDokument_server |
Supported by the .NET Compact Framework. | sLogisches_laufwerk |
Supported by the .NET Compact Framework. | sMailadresse |
Supported by the .NET Compact Framework. | sPasswort_excelvorlagen |
Supported by the .NET Compact Framework. | sPasswort_fileserver |
Supported by the .NET Compact Framework. | sPasswort_report |
Supported by the .NET Compact Framework. | sPasswort_vorlagenverwaltung |
Supported by the .NET Compact Framework. | sPasswort_wordvorlagen |
Supported by the .NET Compact Framework. | sPfad_dokumente |
Supported by the .NET Compact Framework. | sPfad_excel_vorlagen |
Supported by the .NET Compact Framework. | sPfad_reportdateien |
Supported by the .NET Compact Framework. | sPfad_temporaer_dokumente |
Supported by the .NET Compact Framework. | sPfad_word_vorlagen |
Supported by the .NET Compact Framework. | sReport_db |
Supported by the .NET Compact Framework. | sReport_server |
Supported by the .NET Compact Framework. | sUser_fileserver |
Supported by the .NET Compact Framework. | sUser_report |
Supported by the .NET Compact Framework. | sVersion |
Supported by the .NET Compact Framework. | sVideomenu |

Top

See Also

Reference

clsApplikation Class


clsApplikation.bAktiv Property

clsApplikation.bAktiv Property

clsApplikation.bAktiv Property | Previous topic | Next topic
clsApplikation.bAktiv Property | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property bAktiv() As SqlBoolean

C#

public SqlBoolean bAktiv {get; set;}

C++

public:
property SqlBoolean bAktiv {
SqlBoolean get( );
void set(
SqlBoolean value
);
}

JScript

public function get bAktiv() : SqlBoolean;
public function set bAktiv(value : SqlBoolean);

Source code

Visual Basic

Copy Code Copy Code

Public Property [bAktiv]() As SqlBoolean
Get
Return m_bAktiv
End Get
Set(ByVal Value As SqlBoolean)
m_bAktiv = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsApplikation Class
clsApplikation clsApplikation Members


clsApplikation.bNet_use Property

clsApplikation.bNet_use Property

clsApplikation.bNet_use Property | Previous topic | Next topic
clsApplikation.bNet_use Property | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property bNet_use() As SqlBoolean

C#

public SqlBoolean bNet_use {get; set;}

C++

public:
property SqlBoolean bNet_use {
SqlBoolean get( );
void set(
SqlBoolean value
);
}

JScript

public function get bNet_use() : SqlBoolean;
public function set bNet_use(value : SqlBoolean);

Source code

Visual Basic

Copy Code Copy Code

Public Property [bNet_use]() As SqlBoolean
Get
Return m_bNet_use
End Get
Set(ByVal Value As SqlBoolean)
m_bNet_use = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsApplikation Class
clsApplikation clsApplikation Members


clsApplikation.bShowlogin Property

clsApplikation.bShowlogin Property

clsApplikation.bShowlogin Property | Previous topic | Next topic
clsApplikation.bShowlogin Property | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property bShowlogin() As SqlBoolean

C#

public SqlBoolean bShowlogin {get; set;}

C++

public:
property SqlBoolean bShowlogin {
SqlBoolean get( );
void set(
SqlBoolean value
);
}

JScript

public function get bShowlogin() : SqlBoolean;
public function set bShowlogin(value : SqlBoolean);

Source code

Visual Basic

Copy Code Copy Code

Public Property [bShowlogin]() As SqlBoolean
Get
Return m_bShowlogin
End Get
Set(ByVal Value As SqlBoolean)
m_bShowlogin = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsApplikation Class
clsApplikation clsApplikation Members


clsApplikation.daErstellt_am Property

clsApplikation.daErstellt_am Property

clsApplikation.daErstellt_am Property | Previous topic | Next topic
clsApplikation.daErstellt_am Property | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property daErstellt_am() As SqlDateTime

C#

public SqlDateTime daErstellt_am {get; set;}

C++

public:
property SqlDateTime daErstellt_am {
SqlDateTime get( );
void set(
SqlDateTime value
);
}

JScript

public function get daErstellt_am() : SqlDateTime;
public function set daErstellt_am(value : SqlDateTime);

Source code

Visual Basic

Copy Code Copy Code

Public Property [daErstellt_am]() As SqlDateTime
Get
Return m_daErstellt_am
End Get
Set(ByVal Value As SqlDateTime)
m_daErstellt_am = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsApplikation Class
clsApplikation clsApplikation Members


clsApplikation.daLetzer_ams_run Property

clsApplikation.daLetzer_ams_run Property

clsApplikation.daLetzer_ams_run Property | Previous topic | Next topic
clsApplikation.daLetzer_ams_run Property | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property daLetzer_ams_run() As SqlDateTime

C#

public SqlDateTime daLetzer_ams_run {get; set;}

C++

public:
property SqlDateTime daLetzer_ams_run {
SqlDateTime get( );
void set(
SqlDateTime value
);
}

JScript

public function get daLetzer_ams_run() : SqlDateTime;
public function set daLetzer_ams_run(value : SqlDateTime);

Source code

Visual Basic

Copy Code Copy Code

Public Property [daLetzer_ams_run]() As SqlDateTime
Get
Return m_daLetzer_ams_run
End Get
Set(ByVal Value As SqlDateTime)
m_daLetzer_ams_run = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsApplikation Class
clsApplikation clsApplikation Members


clsApplikation.daLetzter_cold_run Property

clsApplikation.daLetzter_cold_run Property

clsApplikation.daLetzter_cold_run Property | Previous topic | Next topic
clsApplikation.daLetzter_cold_run Property | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property daLetzter_cold_run() As SqlDateTime

C#

public SqlDateTime daLetzter_cold_run {get; set;}

C++

public:
property SqlDateTime daLetzter_cold_run {
SqlDateTime get( );
void set(
SqlDateTime value
);
}

JScript

public function get daLetzter_cold_run() : SqlDateTime;
public function set daLetzter_cold_run(value : SqlDateTime);

Source code

Visual Basic

Copy Code Copy Code

Public Property [daLetzter_cold_run]() As SqlDateTime
Get
Return m_daLetzter_cold_run
End Get
Set(ByVal Value As SqlDateTime)
m_daLetzter_cold_run = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsApplikation Class
clsApplikation clsApplikation Members


clsApplikation.daLetzter_host_run Property

clsApplikation.daLetzter_host_run Property

clsApplikation.daLetzter_host_run Property | Previous topic | Next topic
clsApplikation.daLetzter_host_run Property | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property daLetzter_host_run() As SqlDateTime

C#

public SqlDateTime daLetzter_host_run {get; set;}

C++

public:
property SqlDateTime daLetzter_host_run {
SqlDateTime get( );
void set(
SqlDateTime value
);
}

JScript

public function get daLetzter_host_run() : SqlDateTime;
public function set daLetzter_host_run(value : SqlDateTime);

Source code

Visual Basic

Copy Code Copy Code

Public Property [daLetzter_host_run]() As SqlDateTime
Get
Return m_daLetzter_host_run
End Get
Set(ByVal Value As SqlDateTime)
m_daLetzter_host_run = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsApplikation Class
clsApplikation clsApplikation Members


clsApplikation.daLetzter_rdm_run Property

clsApplikation.daLetzter_rdm_run Property

clsApplikation.daLetzter_rdm_run Property | Previous topic | Next topic
clsApplikation.daLetzter_rdm_run Property | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property daLetzter_rdm_run() As SqlDateTime

C#

public SqlDateTime daLetzter_rdm_run {get; set;}

C++

public:
property SqlDateTime daLetzter_rdm_run {
SqlDateTime get( );
void set(
SqlDateTime value
);
}

JScript

public function get daLetzter_rdm_run() : SqlDateTime;
public function set daLetzter_rdm_run(value : SqlDateTime);

Source code

Visual Basic

Copy Code Copy Code

Public Property [daLetzter_rdm_run]() As SqlDateTime
Get
Return m_daLetzter_rdm_run
End Get
Set(ByVal Value As SqlDateTime)
m_daLetzter_rdm_run = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsApplikation Class
clsApplikation clsApplikation Members


clsApplikation.daMutiert_am Property

clsApplikation.daMutiert_am Property

clsApplikation.daMutiert_am Property | Previous topic | Next topic
clsApplikation.daMutiert_am Property | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property daMutiert_am() As SqlDateTime

C#

public SqlDateTime daMutiert_am {get; set;}

C++

public:
property SqlDateTime daMutiert_am {
SqlDateTime get( );
void set(
SqlDateTime value
);
}

JScript

public function get daMutiert_am() : SqlDateTime;
public function set daMutiert_am(value : SqlDateTime);

Source code

Visual Basic

Copy Code Copy Code

Public Property [daMutiert_am]() As SqlDateTime
Get
Return m_daMutiert_am
End Get
Set(ByVal Value As SqlDateTime)
m_daMutiert_am = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsApplikation Class
clsApplikation clsApplikation Members


clsApplikation.iAmsstunden Property

clsApplikation.iAmsstunden Property

clsApplikation.iAmsstunden Property | Previous topic | Next topic
clsApplikation.iAmsstunden Property | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property iAmsstunden() As SqlInt32

C#

public SqlInt32 iAmsstunden {get; set;}

C++

public:
property SqlInt32 iAmsstunden {
SqlInt32 get( );
void set(
SqlInt32 value
);
}

JScript

public function get iAmsstunden() : SqlInt32;
public function set iAmsstunden(value : SqlInt32);

Source code

Visual Basic

Copy Code Copy Code

Public Property [iAmsstunden]() As SqlInt32
Get
Return m_iAmsstunden
End Get
Set(ByVal Value As SqlInt32)
m_iAmsstunden = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsApplikation Class
clsApplikation clsApplikation Members


clsApplikation.iAnzahl_Cold_Viewer Property

clsApplikation.iAnzahl_Cold_Viewer Property

clsApplikation.iAnzahl_Cold_Viewer Property | Previous topic | Next topic
clsApplikation.iAnzahl_Cold_Viewer Property | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property iAnzahl_Cold_Viewer() As SqlInt32

C#

public SqlInt32 iAnzahl_Cold_Viewer {get; set;}

C++

public:
property SqlInt32 iAnzahl_Cold_Viewer {
SqlInt32 get( );
void set(
SqlInt32 value
);
}

JScript

public function get iAnzahl_Cold_Viewer() : SqlInt32;
public function set iAnzahl_Cold_Viewer(value : SqlInt32);

Source code

Visual Basic

Copy Code Copy Code

Public Property [iAnzahl_Cold_Viewer]() As SqlInt32
Get
Return m_iAnzahl_Cold_Viewer
End Get
Set(ByVal Value As SqlInt32)
m_iAnzahl_Cold_Viewer = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsApplikation Class
clsApplikation clsApplikation Members


clsApplikation.iApplikationsnr Property

clsApplikation.iApplikationsnr Property

clsApplikation.iApplikationsnr Property | Previous topic | Next topic
clsApplikation.iApplikationsnr Property | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property iApplikationsnr() As SqlInt32

C#

public SqlInt32 iApplikationsnr {get; set;}

C++

public:
property SqlInt32 iApplikationsnr {
SqlInt32 get( );
void set(
SqlInt32 value
);
}

JScript

public function get iApplikationsnr() : SqlInt32;
public function set iApplikationsnr(value : SqlInt32);

Source code

Visual Basic

Copy Code Copy Code

Public Property [iApplikationsnr]() As SqlInt32
Get
Return m_iApplikationsnr
End Get
Set(ByVal Value As SqlInt32)
Dim iApplikationsnrTmp As SqlInt32 = Value
If iApplikationsnrTmp.IsNull Then
Throw New ArgumentOutOfRangeException("iApplikationsnr", "iApplikationsnr can't be NULL")
End If
m_iApplikationsnr = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsApplikation Class
clsApplikation clsApplikation Members


clsApplikation.iBcfont_groesse Property

clsApplikation.iBcfont_groesse Property

clsApplikation.iBcfont_groesse Property | Previous topic | Next topic
clsApplikation.iBcfont_groesse Property | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property iBcfont_groesse() As SqlInt32

C#

public SqlInt32 iBcfont_groesse {get; set;}

C++

public:
property SqlInt32 iBcfont_groesse {
SqlInt32 get( );
void set(
SqlInt32 value
);
}

JScript

public function get iBcfont_groesse() : SqlInt32;
public function set iBcfont_groesse(value : SqlInt32);

Source code

Visual Basic

Copy Code Copy Code

Public Property [iBcfont_groesse]() As SqlInt32
Get
Return m_iBcfont_groesse
End Get
Set(ByVal Value As SqlInt32)
m_iBcfont_groesse = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsApplikation Class
clsApplikation clsApplikation Members


clsApplikation.iColdstunden Property

clsApplikation.iColdstunden Property

clsApplikation.iColdstunden Property | Previous topic | Next topic
clsApplikation.iColdstunden Property | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property iColdstunden() As SqlInt32

C#

public SqlInt32 iColdstunden {get; set;}

C++

public:
property SqlInt32 iColdstunden {
SqlInt32 get( );
void set(
SqlInt32 value
);
}

JScript

public function get iColdstunden() : SqlInt32;
public function set iColdstunden(value : SqlInt32);

Source code

Visual Basic

Copy Code Copy Code

Public Property [iColdstunden]() As SqlInt32
Get
Return m_iColdstunden
End Get
Set(ByVal Value As SqlInt32)
m_iColdstunden = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsApplikation Class
clsApplikation clsApplikation Members


clsApplikation.iHoststunden Property

clsApplikation.iHoststunden Property

clsApplikation.iHoststunden Property | Previous topic | Next topic
clsApplikation.iHoststunden Property | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property iHoststunden() As SqlInt32

C#

public SqlInt32 iHoststunden {get; set;}

C++

public:
property SqlInt32 iHoststunden {
SqlInt32 get( );
void set(
SqlInt32 value
);
}

JScript

public function get iHoststunden() : SqlInt32;
public function set iHoststunden(value : SqlInt32);

Source code

Visual Basic

Copy Code Copy Code

Public Property [iHoststunden]() As SqlInt32
Get
Return m_iHoststunden
End Get
Set(ByVal Value As SqlInt32)
m_iHoststunden = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsApplikation Class
clsApplikation clsApplikation Members


clsApplikation.iMandantnr Property

clsApplikation.iMandantnr Property

clsApplikation.iMandantnr Property | Previous topic | Next topic
clsApplikation.iMandantnr Property | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property iMandantnr() As SqlInt32

C#

public SqlInt32 iMandantnr {get; set;}

C++

public:
property SqlInt32 iMandantnr {
SqlInt32 get( );
void set(
SqlInt32 value
);
}

JScript

public function get iMandantnr() : SqlInt32;
public function set iMandantnr(value : SqlInt32);

Source code

Visual Basic

Copy Code Copy Code

Public Property [iMandantnr]() As SqlInt32
Get
Return m_iMandantnr
End Get
Set(ByVal Value As SqlInt32)
m_iMandantnr = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsApplikation Class
clsApplikation clsApplikation Members


clsApplikation.iMutierer Property

clsApplikation.iMutierer Property

clsApplikation.iMutierer Property | Previous topic | Next topic
clsApplikation.iMutierer Property | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property iMutierer() As SqlInt32

C#

public SqlInt32 iMutierer {get; set;}

C++

public:
property SqlInt32 iMutierer {
SqlInt32 get( );
void set(
SqlInt32 value
);
}

JScript

public function get iMutierer() : SqlInt32;
public function set iMutierer(value : SqlInt32);

Source code

Visual Basic

Copy Code Copy Code

Public Property [iMutierer]() As SqlInt32
Get
Return m_iMutierer
End Get
Set(ByVal Value As SqlInt32)
m_iMutierer = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsApplikation Class
clsApplikation clsApplikation Members


clsApplikation.iRdmstunden Property

clsApplikation.iRdmstunden Property

clsApplikation.iRdmstunden Property | Previous topic | Next topic
clsApplikation.iRdmstunden Property | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property iRdmstunden() As SqlInt32

C#

public SqlInt32 iRdmstunden {get; set;}

C++

public:
property SqlInt32 iRdmstunden {
SqlInt32 get( );
void set(
SqlInt32 value
);
}

JScript

public function get iRdmstunden() : SqlInt32;
public function set iRdmstunden(value : SqlInt32);

Source code

Visual Basic

Copy Code Copy Code

Public Property [iRdmstunden]() As SqlInt32
Get
Return m_iRdmstunden
End Get
Set(ByVal Value As SqlInt32)
m_iRdmstunden = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsApplikation Class
clsApplikation clsApplikation Members


clsApplikation.iZeitintervall_in_Minuten Property

clsApplikation.iZeitintervall_in_Minuten Property

clsApplikation.iZeitintervall_in_Minuten Property | Previous topic | Next topic
clsApplikation.iZeitintervall_in_Minuten Property | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property iZeitintervall_in_Minuten() As SqlInt32

C#

public SqlInt32 iZeitintervall_in_Minuten {get; set;}

C++

public:
property SqlInt32 iZeitintervall_in_Minuten {
SqlInt32 get( );
void set(
SqlInt32 value
);
}

JScript

public function get iZeitintervall_in_Minuten() : SqlInt32;
public function set iZeitintervall_in_Minuten(value : SqlInt32);

Source code

Visual Basic

Copy Code Copy Code

Public Property [iZeitintervall_in_Minuten]() As SqlInt32
Get
Return m_iZeitintervall_in_Minuten
End Get
Set(ByVal Value As SqlInt32)
m_iZeitintervall_in_Minuten = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsApplikation Class
clsApplikation clsApplikation Members


clsApplikation.sBarcode_font Property

clsApplikation.sBarcode_font Property

clsApplikation.sBarcode_font Property | Previous topic | Next topic
clsApplikation.sBarcode_font Property | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property sBarcode_font() As SqlString

C#

public SqlString sBarcode_font {get; set;}

C++

public:
property SqlString sBarcode_font {
SqlString get( );
void set(
SqlString value
);
}

JScript

public function get sBarcode_font() : SqlString;
public function set sBarcode_font(value : SqlString);

Source code

Visual Basic

Copy Code Copy Code

Public Property [sBarcode_font]() As SqlString
Get
Return m_sBarcode_font
End Get
Set(ByVal Value As SqlString)
m_sBarcode_font = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsApplikation Class
clsApplikation clsApplikation Members


clsApplikation.sColdgui Property

clsApplikation.sColdgui Property

clsApplikation.sColdgui Property | Previous topic | Next topic
clsApplikation.sColdgui Property | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property sColdgui() As SqlString

C#

public SqlString sColdgui {get; set;}

C++

public:
property SqlString sColdgui {
SqlString get( );
void set(
SqlString value
);
}

JScript

public function get sColdgui() : SqlString;
public function set sColdgui(value : SqlString);

Source code

Visual Basic

Copy Code Copy Code

Public Property [sColdgui]() As SqlString
Get
Return m_sColdgui
End Get
Set(ByVal Value As SqlString)
m_sColdgui = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsApplikation Class
clsApplikation clsApplikation Members


clsApplikation.sColdpassword Property

clsApplikation.sColdpassword Property

clsApplikation.sColdpassword Property | Previous topic | Next topic
clsApplikation.sColdpassword Property | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property sColdpassword() As SqlString

C#

public SqlString sColdpassword {get; set;}

C++

public:
property SqlString sColdpassword {
SqlString get( );
void set(
SqlString value
);
}

JScript

public function get sColdpassword() : SqlString;
public function set sColdpassword(value : SqlString);

Source code

Visual Basic

Copy Code Copy Code

Public Property [sColdpassword]() As SqlString
Get
Return m_sColdpassword
End Get
Set(ByVal Value As SqlString)
m_sColdpassword = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsApplikation Class
clsApplikation clsApplikation Members


clsApplikation.sColdstart Property

clsApplikation.sColdstart Property

clsApplikation.sColdstart Property | Previous topic | Next topic
clsApplikation.sColdstart Property | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property sColdstart() As SqlString

C#

public SqlString sColdstart {get; set;}

C++

public:
property SqlString sColdstart {
SqlString get( );
void set(
SqlString value
);
}

JScript

public function get sColdstart() : SqlString;
public function set sColdstart(value : SqlString);

Source code

Visual Basic

Copy Code Copy Code

Public Property [sColdstart]() As SqlString
Get
Return m_sColdstart
End Get
Set(ByVal Value As SqlString)
m_sColdstart = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsApplikation Class
clsApplikation clsApplikation Members


clsApplikation.sColdsystem Property

clsApplikation.sColdsystem Property

clsApplikation.sColdsystem Property | Previous topic | Next topic
clsApplikation.sColdsystem Property | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property sColdsystem() As SqlString

C#

public SqlString sColdsystem {get; set;}

C++

public:
property SqlString sColdsystem {
SqlString get( );
void set(
SqlString value
);
}

JScript

public function get sColdsystem() : SqlString;
public function set sColdsystem(value : SqlString);

Source code

Visual Basic

Copy Code Copy Code

Public Property [sColdsystem]() As SqlString
Get
Return m_sColdsystem
End Get
Set(ByVal Value As SqlString)
m_sColdsystem = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsApplikation Class
clsApplikation clsApplikation Members


clsApplikation.sColduser Property

clsApplikation.sColduser Property

clsApplikation.sColduser Property | Previous topic | Next topic
clsApplikation.sColduser Property | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property sColduser() As SqlString

C#

public SqlString sColduser {get; set;}

C++

public:
property SqlString sColduser {
SqlString get( );
void set(
SqlString value
);
}

JScript

public function get sColduser() : SqlString;
public function set sColduser(value : SqlString);

Source code

Visual Basic

Copy Code Copy Code

Public Property [sColduser]() As SqlString
Get
Return m_sColduser
End Get
Set(ByVal Value As SqlString)
m_sColduser = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsApplikation Class
clsApplikation clsApplikation Members


clsApplikation.sDokument_server Property

clsApplikation.sDokument_server Property

clsApplikation.sDokument_server Property | Previous topic | Next topic
clsApplikation.sDokument_server Property | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property sDokument_server() As SqlString

C#

public SqlString sDokument_server {get; set;}

C++

public:
property SqlString sDokument_server {
SqlString get( );
void set(
SqlString value
);
}

JScript

public function get sDokument_server() : SqlString;
public function set sDokument_server(value : SqlString);

Source code

Visual Basic

Copy Code Copy Code

Public Property [sDokument_server]() As SqlString
Get
Return m_sDokument_server
End Get
Set(ByVal Value As SqlString)
m_sDokument_server = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsApplikation Class
clsApplikation clsApplikation Members


clsApplikation.sLogisches_laufwerk Property

clsApplikation.sLogisches_laufwerk Property

clsApplikation.sLogisches_laufwerk Property | Previous topic | Next topic
clsApplikation.sLogisches_laufwerk Property | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property sLogisches_laufwerk() As SqlString

C#

public SqlString sLogisches_laufwerk {get; set;}

C++

public:
property SqlString sLogisches_laufwerk {
SqlString get( );
void set(
SqlString value
);
}

JScript

public function get sLogisches_laufwerk() : SqlString;
public function set sLogisches_laufwerk(value : SqlString);

Source code

Visual Basic

Copy Code Copy Code

Public Property [sLogisches_laufwerk]() As SqlString
Get
Return m_sLogisches_laufwerk
End Get
Set(ByVal Value As SqlString)
m_sLogisches_laufwerk = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsApplikation Class
clsApplikation clsApplikation Members


clsApplikation.sMailadresse Property

clsApplikation.sMailadresse Property

clsApplikation.sMailadresse Property | Previous topic | Next topic
clsApplikation.sMailadresse Property | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property sMailadresse() As SqlString

C#

public SqlString sMailadresse {get; set;}

C++

public:
property SqlString sMailadresse {
SqlString get( );
void set(
SqlString value
);
}

JScript

public function get sMailadresse() : SqlString;
public function set sMailadresse(value : SqlString);

Source code

Visual Basic

Copy Code Copy Code

Public Property [sMailadresse]() As SqlString
Get
Return m_sMailadresse
End Get
Set(ByVal Value As SqlString)
m_sMailadresse = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsApplikation Class
clsApplikation clsApplikation Members


clsApplikation.sPasswort_excelvorlagen Property

clsApplikation.sPasswort_excelvorlagen Property

clsApplikation.sPasswort_excelvorlagen Property | Previous topic | Next topic
clsApplikation.sPasswort_excelvorlagen Property | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property sPasswort_excelvorlagen() As SqlString

C#

public SqlString sPasswort_excelvorlagen {get; set;}

C++

public:
property SqlString sPasswort_excelvorlagen {
SqlString get( );
void set(
SqlString value
);
}

JScript

public function get sPasswort_excelvorlagen() : SqlString;
public function set sPasswort_excelvorlagen(value : SqlString);

Source code

Visual Basic

Copy Code Copy Code

Public Property [sPasswort_excelvorlagen]() As SqlString
Get
Return m_sPasswort_excelvorlagen
End Get
Set(ByVal Value As SqlString)
m_sPasswort_excelvorlagen = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsApplikation Class
clsApplikation clsApplikation Members


clsApplikation.sPasswort_fileserver Property

clsApplikation.sPasswort_fileserver Property

clsApplikation.sPasswort_fileserver Property | Previous topic | Next topic
clsApplikation.sPasswort_fileserver Property | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property sPasswort_fileserver() As SqlString

C#

public SqlString sPasswort_fileserver {get; set;}

C++

public:
property SqlString sPasswort_fileserver {
SqlString get( );
void set(
SqlString value
);
}

JScript

public function get sPasswort_fileserver() : SqlString;
public function set sPasswort_fileserver(value : SqlString);

Source code

Visual Basic

Copy Code Copy Code

Public Property [sPasswort_fileserver]() As SqlString
Get
Return m_sPasswort_fileserver
End Get
Set(ByVal Value As SqlString)
m_sPasswort_fileserver = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsApplikation Class
clsApplikation clsApplikation Members


clsApplikation.sPasswort_report Property

clsApplikation.sPasswort_report Property

clsApplikation.sPasswort_report Property | Previous topic | Next topic
clsApplikation.sPasswort_report Property | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property sPasswort_report() As SqlString

C#

public SqlString sPasswort_report {get; set;}

C++

public:
property SqlString sPasswort_report {
SqlString get( );
void set(
SqlString value
);
}

JScript

public function get sPasswort_report() : SqlString;
public function set sPasswort_report(value : SqlString);

Source code

Visual Basic

Copy Code Copy Code

Public Property [sPasswort_report]() As SqlString
Get
Return m_sPasswort_report
End Get
Set(ByVal Value As SqlString)
m_sPasswort_report = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsApplikation Class
clsApplikation clsApplikation Members


clsApplikation.sPasswort_vorlagenverwaltung Property

clsApplikation.sPasswort_vorlagenverwaltung Property

clsApplikation.sPasswort_vorlagenverwaltung Property | Previous topic | Next topic
clsApplikation.sPasswort_vorlagenverwaltung Property | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property sPasswort_vorlagenverwaltung() As SqlString

C#

public SqlString sPasswort_vorlagenverwaltung {get; set;}

C++

public:
property SqlString sPasswort_vorlagenverwaltung {
SqlString get( );
void set(
SqlString value
);
}

JScript

public function get sPasswort_vorlagenverwaltung() : SqlString;
public function set sPasswort_vorlagenverwaltung(value : SqlString);

Source code

Visual Basic

Copy Code Copy Code

Public Property [sPasswort_vorlagenverwaltung]() As SqlString
Get
Return m_sPasswort_vorlagenverwaltung
End Get
Set(ByVal Value As SqlString)
m_sPasswort_vorlagenverwaltung = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsApplikation Class
clsApplikation clsApplikation Members


clsApplikation.sPasswort_wordvorlagen Property

clsApplikation.sPasswort_wordvorlagen Property

clsApplikation.sPasswort_wordvorlagen Property | Previous topic | Next topic
clsApplikation.sPasswort_wordvorlagen Property | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property sPasswort_wordvorlagen() As SqlString

C#

public SqlString sPasswort_wordvorlagen {get; set;}

C++

public:
property SqlString sPasswort_wordvorlagen {
SqlString get( );
void set(
SqlString value
);
}

JScript

public function get sPasswort_wordvorlagen() : SqlString;
public function set sPasswort_wordvorlagen(value : SqlString);

Source code

Visual Basic

Copy Code Copy Code

Public Property [sPasswort_wordvorlagen]() As SqlString
Get
Return m_sPasswort_wordvorlagen
End Get
Set(ByVal Value As SqlString)
m_sPasswort_wordvorlagen = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsApplikation Class
clsApplikation clsApplikation Members


clsApplikation.sPfad_dokumente Property

clsApplikation.sPfad_dokumente Property

clsApplikation.sPfad_dokumente Property | Previous topic | Next topic
clsApplikation.sPfad_dokumente Property | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property sPfad_dokumente() As SqlString

C#

public SqlString sPfad_dokumente {get; set;}

C++

public:
property SqlString sPfad_dokumente {
SqlString get( );
void set(
SqlString value
);
}

JScript

public function get sPfad_dokumente() : SqlString;
public function set sPfad_dokumente(value : SqlString);

Source code

Visual Basic

Copy Code Copy Code

Public Property [sPfad_dokumente]() As SqlString
Get
Return m_sPfad_dokumente
End Get
Set(ByVal Value As SqlString)
m_sPfad_dokumente = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsApplikation Class
clsApplikation clsApplikation Members


clsApplikation.sPfad_excel_vorlagen Property

clsApplikation.sPfad_excel_vorlagen Property

clsApplikation.sPfad_excel_vorlagen Property | Previous topic | Next topic
clsApplikation.sPfad_excel_vorlagen Property | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property sPfad_excel_vorlagen() As SqlString

C#

public SqlString sPfad_excel_vorlagen {get; set;}

C++

public:
property SqlString sPfad_excel_vorlagen {
SqlString get( );
void set(
SqlString value
);
}

JScript

public function get sPfad_excel_vorlagen() : SqlString;
public function set sPfad_excel_vorlagen(value : SqlString);

Source code

Visual Basic

Copy Code Copy Code

Public Property [sPfad_excel_vorlagen]() As SqlString
Get
Return m_sPfad_excel_vorlagen
End Get
Set(ByVal Value As SqlString)
m_sPfad_excel_vorlagen = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsApplikation Class
clsApplikation clsApplikation Members


clsApplikation.sPfad_reportdateien Property

clsApplikation.sPfad_reportdateien Property

clsApplikation.sPfad_reportdateien Property | Previous topic | Next topic
clsApplikation.sPfad_reportdateien Property | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property sPfad_reportdateien() As SqlString

C#

public SqlString sPfad_reportdateien {get; set;}

C++

public:
property SqlString sPfad_reportdateien {
SqlString get( );
void set(
SqlString value
);
}

JScript

public function get sPfad_reportdateien() : SqlString;
public function set sPfad_reportdateien(value : SqlString);

Source code

Visual Basic

Copy Code Copy Code

Public Property [sPfad_reportdateien]() As SqlString
Get
Return m_sPfad_reportdateien
End Get
Set(ByVal Value As SqlString)
m_sPfad_reportdateien = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsApplikation Class
clsApplikation clsApplikation Members


clsApplikation.sPfad_temporaer_dokumente Property

clsApplikation.sPfad_temporaer_dokumente Property

clsApplikation.sPfad_temporaer_dokumente Property | Previous topic | Next topic
clsApplikation.sPfad_temporaer_dokumente Property | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property sPfad_temporaer_dokumente() As SqlString

C#

public SqlString sPfad_temporaer_dokumente {get; set;}

C++

public:
property SqlString sPfad_temporaer_dokumente {
SqlString get( );
void set(
SqlString value
);
}

JScript

public function get sPfad_temporaer_dokumente() : SqlString;
public function set sPfad_temporaer_dokumente(value : SqlString);

Source code

Visual Basic

Copy Code Copy Code

Public Property [sPfad_temporaer_dokumente]() As SqlString
Get
Return m_sPfad_temporaer_dokumente
End Get
Set(ByVal Value As SqlString)
m_sPfad_temporaer_dokumente = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsApplikation Class
clsApplikation clsApplikation Members


clsApplikation.sPfad_word_vorlagen Property

clsApplikation.sPfad_word_vorlagen Property

clsApplikation.sPfad_word_vorlagen Property | Previous topic | Next topic
clsApplikation.sPfad_word_vorlagen Property | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property sPfad_word_vorlagen() As SqlString

C#

public SqlString sPfad_word_vorlagen {get; set;}

C++

public:
property SqlString sPfad_word_vorlagen {
SqlString get( );
void set(
SqlString value
);
}

JScript

public function get sPfad_word_vorlagen() : SqlString;
public function set sPfad_word_vorlagen(value : SqlString);

Source code

Visual Basic

Copy Code Copy Code

Public Property [sPfad_word_vorlagen]() As SqlString
Get
Return m_sPfad_word_vorlagen
End Get
Set(ByVal Value As SqlString)
m_sPfad_word_vorlagen = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsApplikation Class
clsApplikation clsApplikation Members


clsApplikation.sReport_db Property

clsApplikation.sReport_db Property

clsApplikation.sReport_db Property | Previous topic | Next topic
clsApplikation.sReport_db Property | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property sReport_db() As SqlString

C#

public SqlString sReport_db {get; set;}

C++

public:
property SqlString sReport_db {
SqlString get( );
void set(
SqlString value
);
}

JScript

public function get sReport_db() : SqlString;
public function set sReport_db(value : SqlString);

Source code

Visual Basic

Copy Code Copy Code

Public Property [sReport_db]() As SqlString
Get
Return m_sReport_db
End Get
Set(ByVal Value As SqlString)
m_sReport_db = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsApplikation Class
clsApplikation clsApplikation Members


clsApplikation.sReport_server Property

clsApplikation.sReport_server Property

clsApplikation.sReport_server Property | Previous topic | Next topic
clsApplikation.sReport_server Property | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property sReport_server() As SqlString

C#

public SqlString sReport_server {get; set;}

C++

public:
property SqlString sReport_server {
SqlString get( );
void set(
SqlString value
);
}

JScript

public function get sReport_server() : SqlString;
public function set sReport_server(value : SqlString);

Source code

Visual Basic

Copy Code Copy Code

Public Property [sReport_server]() As SqlString
Get
Return m_sReport_server
End Get
Set(ByVal Value As SqlString)
m_sReport_server = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsApplikation Class
clsApplikation clsApplikation Members


clsApplikation.sUser_fileserver Property

clsApplikation.sUser_fileserver Property

clsApplikation.sUser_fileserver Property | Previous topic | Next topic
clsApplikation.sUser_fileserver Property | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property sUser_fileserver() As SqlString

C#

public SqlString sUser_fileserver {get; set;}

C++

public:
property SqlString sUser_fileserver {
SqlString get( );
void set(
SqlString value
);
}

JScript

public function get sUser_fileserver() : SqlString;
public function set sUser_fileserver(value : SqlString);

Source code

Visual Basic

Copy Code Copy Code

Public Property [sUser_fileserver]() As SqlString
Get
Return m_sUser_fileserver
End Get
Set(ByVal Value As SqlString)
m_sUser_fileserver = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsApplikation Class
clsApplikation clsApplikation Members


clsApplikation.sUser_report Property

clsApplikation.sUser_report Property

clsApplikation.sUser_report Property | Previous topic | Next topic
clsApplikation.sUser_report Property | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property sUser_report() As SqlString

C#

public SqlString sUser_report {get; set;}

C++

public:
property SqlString sUser_report {
SqlString get( );
void set(
SqlString value
);
}

JScript

public function get sUser_report() : SqlString;
public function set sUser_report(value : SqlString);

Source code

Visual Basic

Copy Code Copy Code

Public Property [sUser_report]() As SqlString
Get
Return m_sUser_report
End Get
Set(ByVal Value As SqlString)
m_sUser_report = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsApplikation Class
clsApplikation clsApplikation Members


clsApplikation.sVersion Property

clsApplikation.sVersion Property

clsApplikation.sVersion Property | Previous topic | Next topic
clsApplikation.sVersion Property | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property sVersion() As SqlString

C#

public SqlString sVersion {get; set;}

C++

public:
property SqlString sVersion {
SqlString get( );
void set(
SqlString value
);
}

JScript

public function get sVersion() : SqlString;
public function set sVersion(value : SqlString);

Source code

Visual Basic

Copy Code Copy Code

Public Property [sVersion]() As SqlString
Get
Return m_sVersion
End Get
Set(ByVal Value As SqlString)
m_sVersion = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsApplikation Class
clsApplikation clsApplikation Members


clsApplikation.sVideomenu Property

clsApplikation.sVideomenu Property

clsApplikation.sVideomenu Property | Previous topic | Next topic
clsApplikation.sVideomenu Property | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property sVideomenu() As SqlString

C#

public SqlString sVideomenu {get; set;}

C++

public:
property SqlString sVideomenu {
SqlString get( );
void set(
SqlString value
);
}

JScript

public function get sVideomenu() : SqlString;
public function set sVideomenu(value : SqlString);

Source code

Visual Basic

Copy Code Copy Code

Public Property [sVideomenu]() As SqlString
Get
Return m_sVideomenu
End Get
Set(ByVal Value As SqlString)
m_sVideomenu = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsApplikation Class
clsApplikation clsApplikation Members


clsApplikation Methods

clsApplikation Methods

clsApplikation Methods | Previous topic | Next topic
clsApplikation Methods | Previous topic | Next topic

Public Methods

 | Name | Description
Supported by the .NET Compact Framework. | Delete |
Supported by the .NET Compact Framework. | Dispose | (Overloaded) (inherited from clsDBInteractionBase ).
Public method | Equals | (Overloaded) (inherited from Object).
Public method | GetHashCode | (inherited from Object).
Public method | GetType | (Overloaded) (inherited from Object).
Supported by the .NET Compact Framework. | Insert |
 | ReferenceEquals | (inherited from Object).
Supported by the .NET Compact Framework. | SelectAll |
Supported by the .NET Compact Framework. | SelectOne |
Public method | ToString | (inherited from Object).
Supported by the .NET Compact Framework. | Update |

Top

Protected Methods

 | Name | Description
Protected method | Finalize | (inherited from Object).
Protected method | MemberwiseClone | (Overloaded) (inherited from Object).

Top

See Also

Reference

clsApplikation Class


clsApplikation.Delete Method

clsApplikation.Delete Method

clsApplikation.Delete Method | Previous topic | Next topic
clsApplikation.Delete Method | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Overrides Function Delete() As Boolean

C#

public override bool Delete()

C++

public:
bool Delete()

JScript

public function Delete() : boolean;

Source code

Visual Basic

Copy Code Copy Code

Public Overrides Function Delete() As Boolean
Dim scmCmdToExecute As SqlCommand = New SqlCommand()
scmCmdToExecute.CommandText = "dbo.[pr_applikation_Delete]"
scmCmdToExecute.CommandType = CommandType.StoredProcedure

' // Use base class' connection object
scmCmdToExecute.Connection = m_scoMainConnection

Try
scmCmdToExecute.Parameters.Add(New SqlParameter("@iapplikationsnr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iApplikationsnr))
scmCmdToExecute.Parameters.Add(New SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

If m_bMainConnectionIsCreatedLocal Then
' // Open connection.
m_scoMainConnection.Open()
Else
If m_cpMainConnectionProvider.bIsTransactionPending Then
scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
End If
End If

' // Execute query.
scmCmdToExecute.ExecuteNonQuery()
m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
' // Throw error.
Throw New Exception("Stored Procedure 'pr_applikation_Delete' reported the ErrorCode: " & m_iErrorCode.ToString())
End If

Return True
Catch ex As Exception
' // some error occured. Bubble it to caller and encapsulate Exception object
Throw New Exception("clsApplikation::Delete::Error occured.", ex)
Finally
If m_bMainConnectionIsCreatedLocal Then
' // Close connection.
m_scoMainConnection.Close()
End If
scmCmdToExecute.Dispose()
End Try
End Function

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsApplikation Class
clsApplikation clsApplikation Members


clsApplikation.Insert Method

clsApplikation.Insert Method

clsApplikation.Insert Method | Previous topic | Next topic
clsApplikation.Insert Method | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Overrides Function Insert() As Boolean

C#

public override bool Insert()

C++

public:
bool Insert()

JScript

public function Insert() : boolean;

Source code

Visual Basic

Copy Code Copy Code

Overrides Public Function Insert() As Boolean
Dim scmCmdToExecute As SqlCommand = New SqlCommand()
scmCmdToExecute.CommandText = "dbo.[pr_applikation_Insert]"
scmCmdToExecute.CommandType = CommandType.StoredProcedure

' // Use base class' connection object
scmCmdToExecute.Connection = m_scoMainConnection

Try
scmCmdToExecute.Parameters.Add(New SqlParameter("@iapplikationsnr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iApplikationsnr))
scmCmdToExecute.Parameters.Add(New SqlParameter("@sversion", SqlDbType.VarChar, 4, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sVersion))
scmCmdToExecute.Parameters.Add(New SqlParameter("@sdokument_server", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sDokument_server))
scmCmdToExecute.Parameters.Add(New SqlParameter("@bnet_use", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bNet_use))
scmCmdToExecute.Parameters.Add(New SqlParameter("@slogisches_laufwerk", SqlDbType.VarChar, 10, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sLogisches_laufwerk))
scmCmdToExecute.Parameters.Add(New SqlParameter("@spfad_dokumente", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sPfad_dokumente))
scmCmdToExecute.Parameters.Add(New SqlParameter("@spfad_word_vorlagen", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sPfad_word_vorlagen))
scmCmdToExecute.Parameters.Add(New SqlParameter("@spfad_excel_vorlagen", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sPfad_excel_vorlagen))
scmCmdToExecute.Parameters.Add(New SqlParameter("@spfad_temporaer_dokumente", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sPfad_temporaer_dokumente))
scmCmdToExecute.Parameters.Add(New SqlParameter("@suser_fileserver", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sUser_fileserver))
scmCmdToExecute.Parameters.Add(New SqlParameter("@spasswort_fileserver", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sPasswort_fileserver))
scmCmdToExecute.Parameters.Add(New SqlParameter("@spasswort_wordvorlagen", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sPasswort_wordvorlagen))
scmCmdToExecute.Parameters.Add(New SqlParameter("@spasswort_excelvorlagen", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sPasswort_excelvorlagen))
scmCmdToExecute.Parameters.Add(New SqlParameter("@sreport_db", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sReport_db))
scmCmdToExecute.Parameters.Add(New SqlParameter("@sreport_server", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sReport_server))
scmCmdToExecute.Parameters.Add(New SqlParameter("@spfad_reportdateien", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sPfad_reportdateien))
scmCmdToExecute.Parameters.Add(New SqlParameter("@suser_report", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sUser_report))
scmCmdToExecute.Parameters.Add(New SqlParameter("@spasswort_report", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sPasswort_report))
scmCmdToExecute.Parameters.Add(New SqlParameter("@sbarcode_font", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBarcode_font))
scmCmdToExecute.Parameters.Add(New SqlParameter("@ibcfont_groesse", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iBcfont_groesse))
scmCmdToExecute.Parameters.Add(New SqlParameter("@smailadresse", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sMailadresse))
scmCmdToExecute.Parameters.Add(New SqlParameter("@bshowlogin", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bShowlogin))
scmCmdToExecute.Parameters.Add(New SqlParameter("@imandantnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMandantnr))
scmCmdToExecute.Parameters.Add(New SqlParameter("@baktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bAktiv))
scmCmdToExecute.Parameters.Add(New SqlParameter("@daerstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daErstellt_am))
scmCmdToExecute.Parameters.Add(New SqlParameter("@damutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daMutiert_am))
scmCmdToExecute.Parameters.Add(New SqlParameter("@imutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
scmCmdToExecute.Parameters.Add(New SqlParameter("@daletzter_cold_run", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daLetzter_cold_run))
scmCmdToExecute.Parameters.Add(New SqlParameter("@daletzer_ams_run", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daLetzer_ams_run))
scmCmdToExecute.Parameters.Add(New SqlParameter("@daletzter_rdm_run", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daLetzter_rdm_run))
scmCmdToExecute.Parameters.Add(New SqlParameter("@daletzter_host_run", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daLetzter_host_run))
scmCmdToExecute.Parameters.Add(New SqlParameter("@irdmstunden", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iRdmstunden))
scmCmdToExecute.Parameters.Add(New SqlParameter("@icoldstunden", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iColdstunden))
scmCmdToExecute.Parameters.Add(New SqlParameter("@iamsstunden", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iAmsstunden))
scmCmdToExecute.Parameters.Add(New SqlParameter("@ihoststunden", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iHoststunden))
scmCmdToExecute.Parameters.Add(New SqlParameter("@scoldsystem", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sColdsystem))
scmCmdToExecute.Parameters.Add(New SqlParameter("@scolduser", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sColduser))
scmCmdToExecute.Parameters.Add(New SqlParameter("@scoldpassword", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sColdpassword))
scmCmdToExecute.Parameters.Add(New SqlParameter("@scoldgui", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sColdgui))
scmCmdToExecute.Parameters.Add(New SqlParameter("@sPasswort_vorlagenverwaltung", SqlDbType.VarChar, 25, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sPasswort_vorlagenverwaltung))
scmCmdToExecute.Parameters.Add(New SqlParameter("@iAnzahl_Cold_Viewer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iAnzahl_Cold_Viewer))
scmCmdToExecute.Parameters.Add(New SqlParameter("@iZeitintervall_in_Minuten", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iZeitintervall_in_Minuten))
scmCmdToExecute.Parameters.Add(New SqlParameter("@scoldstart", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sColdstart))
scmCmdToExecute.Parameters.Add(New SqlParameter("@svideomenu", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sVideomenu))
scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

If m_bMainConnectionIsCreatedLocal Then
' // Open connection.
m_scoMainConnection.Open()
Else
If m_cpMainConnectionProvider.bIsTransactionPending Then
scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
End If
End If

' // Execute query.
scmCmdToExecute.ExecuteNonQuery()
m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
' // Throw error.
Throw New Exception("Stored Procedure 'pr_applikation_Insert' reported the ErrorCode: " & m_iErrorCode.ToString())
End If

Return True
Catch ex As Exception
MsgBox(ex.Message)
' // some error occured. Bubble it to caller and encapsulate Exception object
Throw New Exception("clsApplikation::Insert::Error occured.", ex)
Finally
If m_bMainConnectionIsCreatedLocal Then
' // Close connection.
m_scoMainConnection.Close()
End If
scmCmdToExecute.Dispose()
End Try
End Function

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsApplikation Class
clsApplikation clsApplikation Members


clsApplikation.SelectAll Method

clsApplikation.SelectAll Method

clsApplikation.SelectAll Method | Previous topic | Next topic
clsApplikation.SelectAll Method | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Overrides Function SelectAll() As DataTable

C#

public override DataTable SelectAll()

C++

public:
DataTable^ SelectAll()

JScript

public function SelectAll() : DataTable;

Source code

Visual Basic

Copy Code Copy Code

Public Overrides Function SelectAll() As DataTable
Dim scmCmdToExecute As SqlCommand = New SqlCommand()
scmCmdToExecute.CommandText = "dbo.[pr_applikation_SelectAll]"
scmCmdToExecute.CommandType = CommandType.StoredProcedure
Dim dtToReturn As DataTable = New DataTable("applikation")
Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)

' // Use base class' connection object
scmCmdToExecute.Connection = m_scoMainConnection

Try
scmCmdToExecute.Parameters.Add(New SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

If m_bMainConnectionIsCreatedLocal Then
' // Open connection.
m_scoMainConnection.Open()
Else
If m_cpMainConnectionProvider.bIsTransactionPending Then
scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
End If
End If

' // Execute query.
sdaAdapter.Fill(dtToReturn)
m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
' // Throw error.
Throw New Exception("Stored Procedure 'pr_applikation_SelectAll' reported the ErrorCode: " & m_iErrorCode.ToString())
End If

Return dtToReturn
Catch ex As Exception
' // some error occured. Bubble it to caller and encapsulate Exception object
Throw New Exception("clsApplikation::SelectAll::Error occured.", ex)
Finally
If m_bMainConnectionIsCreatedLocal Then
' // Close connection.
m_scoMainConnection.Close()
End If
scmCmdToExecute.Dispose()
sdaAdapter.Dispose()
End Try
End Function

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsApplikation Class
clsApplikation clsApplikation Members


clsApplikation.SelectOne Method

clsApplikation.SelectOne Method

clsApplikation.SelectOne Method | Previous topic | Next topic
clsApplikation.SelectOne Method | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Overrides Function SelectOne() As DataTable

C#

public override DataTable SelectOne()

C++

public:
DataTable^ SelectOne()

JScript

public function SelectOne() : DataTable;

Source code

Visual Basic

Copy Code Copy Code

Overrides Public Function SelectOne() As DataTable
Dim scmCmdToExecute As SqlCommand = New SqlCommand()
scmCmdToExecute.CommandText = "dbo.[pr_applikation_SelectOne]"
scmCmdToExecute.CommandType = CommandType.StoredProcedure
Dim dtToReturn As DataTable = new DataTable("applikation")
Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

' // Use base class' connection object
scmCmdToExecute.Connection = m_scoMainConnection

Try
scmCmdToExecute.Parameters.Add(new SqlParameter("@iapplikationsnr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iApplikationsnr))
scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

If m_bMainConnectionIsCreatedLocal Then
' // Open connection.
m_scoMainConnection.Open()
Else
If m_cpMainConnectionProvider.bIsTransactionPending Then
scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
End If
End If

' // Execute query.
sdaAdapter.Fill(dtToReturn)
m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
' // Throw error.
Throw New Exception("Stored Procedure 'pr_applikation_SelectOne' reported the ErrorCode: " & m_iErrorCode.ToString())
End If

If dtToReturn.Rows.Count > 0 Then
m_iApplikationsnr = New SqlInt32(CType(dtToReturn.Rows(0)("applikationsnr"), Integer))
If dtToReturn.Rows(0)("version") Is System.DBNull.Value Then
m_sVersion = SqlString.Null
Else
m_sVersion = New SqlString(CType(dtToReturn.Rows(0)("version"), String))
End If
If dtToReturn.Rows(0)("dokument_server") Is System.DBNull.Value Then
m_sDokument_server = SqlString.Null
Else
m_sDokument_server = New SqlString(CType(dtToReturn.Rows(0)("dokument_server"), String))
End If
If dtToReturn.Rows(0)("net_use") Is System.DBNull.Value Then
m_bNet_use = SqlBoolean.Null
Else
m_bNet_use = New SqlBoolean(CType(dtToReturn.Rows(0)("net_use"), Boolean))
End If
If dtToReturn.Rows(0)("logisches_laufwerk") Is System.DBNull.Value Then
m_sLogisches_laufwerk = SqlString.Null
Else
m_sLogisches_laufwerk = New SqlString(CType(dtToReturn.Rows(0)("logisches_laufwerk"), String))
End If
If dtToReturn.Rows(0)("pfad_dokumente") Is System.DBNull.Value Then
m_sPfad_dokumente = SqlString.Null
Else
m_sPfad_dokumente = New SqlString(CType(dtToReturn.Rows(0)("pfad_dokumente"), String))
End If
If dtToReturn.Rows(0)("pfad_word_vorlagen") Is System.DBNull.Value Then
m_sPfad_word_vorlagen = SqlString.Null
Else
m_sPfad_word_vorlagen = New SqlString(CType(dtToReturn.Rows(0)("pfad_word_vorlagen"), String))
End If
If dtToReturn.Rows(0)("pfad_excel_vorlagen") Is System.DBNull.Value Then
m_sPfad_excel_vorlagen = SqlString.Null
Else
m_sPfad_excel_vorlagen = New SqlString(CType(dtToReturn.Rows(0)("pfad_excel_vorlagen"), String))
End If
If dtToReturn.Rows(0)("pfad_temporaer_dokumente") Is System.DBNull.Value Then
m_sPfad_temporaer_dokumente = SqlString.Null
Else
m_sPfad_temporaer_dokumente = New SqlString(CType(dtToReturn.Rows(0)("pfad_temporaer_dokumente"), String))
End If
If dtToReturn.Rows(0)("user_fileserver") Is System.DBNull.Value Then
m_sUser_fileserver = SqlString.Null
Else
m_sUser_fileserver = New SqlString(CType(dtToReturn.Rows(0)("user_fileserver"), String))
End If
If dtToReturn.Rows(0)("passwort_fileserver") Is System.DBNull.Value Then
m_sPasswort_fileserver = SqlString.Null
Else
m_sPasswort_fileserver = New SqlString(CType(dtToReturn.Rows(0)("passwort_fileserver"), String))
End If
If dtToReturn.Rows(0)("passwort_wordvorlagen") Is System.DBNull.Value Then
m_sPasswort_wordvorlagen = SqlString.Null
Else
m_sPasswort_wordvorlagen = New SqlString(CType(dtToReturn.Rows(0)("passwort_wordvorlagen"), String))
End If
If dtToReturn.Rows(0)("passwort_excelvorlagen") Is System.DBNull.Value Then
m_sPasswort_excelvorlagen = SqlString.Null
Else
m_sPasswort_excelvorlagen = New SqlString(CType(dtToReturn.Rows(0)("passwort_excelvorlagen"), String))
End If
If dtToReturn.Rows(0)("report_db") Is System.DBNull.Value Then
m_sReport_db = SqlString.Null
Else
m_sReport_db = New SqlString(CType(dtToReturn.Rows(0)("report_db"), String))
End If
If dtToReturn.Rows(0)("report_server") Is System.DBNull.Value Then
m_sReport_server = SqlString.Null
Else
m_sReport_server = New SqlString(CType(dtToReturn.Rows(0)("report_server"), String))
End If
If dtToReturn.Rows(0)("pfad_reportdateien") Is System.DBNull.Value Then
m_sPfad_reportdateien = SqlString.Null
Else
m_sPfad_reportdateien = New SqlString(CType(dtToReturn.Rows(0)("pfad_reportdateien"), String))
End If
If dtToReturn.Rows(0)("user_report") Is System.DBNull.Value Then
m_sUser_report = SqlString.Null
Else
m_sUser_report = New SqlString(CType(dtToReturn.Rows(0)("user_report"), String))
End If
If dtToReturn.Rows(0)("passwort_report") Is System.DBNull.Value Then
m_sPasswort_report = SqlString.Null
Else
m_sPasswort_report = New SqlString(CType(dtToReturn.Rows(0)("passwort_report"), String))
End If
If dtToReturn.Rows(0)("barcode_font") Is System.DBNull.Value Then
m_sBarcode_font = SqlString.Null
Else
m_sBarcode_font = New SqlString(CType(dtToReturn.Rows(0)("barcode_font"), String))
End If
If dtToReturn.Rows(0)("bcfont_groesse") Is System.DBNull.Value Then
m_iBcfont_groesse = SqlInt32.Null
Else
m_iBcfont_groesse = New SqlInt32(CType(dtToReturn.Rows(0)("bcfont_groesse"), Integer))
End If
If dtToReturn.Rows(0)("mailadresse") Is System.DBNull.Value Then
m_sMailadresse = SqlString.Null
Else
m_sMailadresse = New SqlString(CType(dtToReturn.Rows(0)("mailadresse"), String))
End If
If dtToReturn.Rows(0)("showlogin") Is System.DBNull.Value Then
m_bShowlogin = SqlBoolean.Null
Else
m_bShowlogin = New SqlBoolean(CType(dtToReturn.Rows(0)("showlogin"), Boolean))
End If
If dtToReturn.Rows(0)("mandantnr") Is System.DBNull.Value Then
m_iMandantnr = SqlInt32.Null
Else
m_iMandantnr = New SqlInt32(CType(dtToReturn.Rows(0)("mandantnr"), Integer))
End If
If dtToReturn.Rows(0)("aktiv") Is System.DBNull.Value Then
m_bAktiv = SqlBoolean.Null
Else
m_bAktiv = New SqlBoolean(CType(dtToReturn.Rows(0)("aktiv"), Boolean))
End If
If dtToReturn.Rows(0)("erstellt_am") Is System.DBNull.Value Then
m_daErstellt_am = SqlDateTime.Null
Else
m_daErstellt_am = New SqlDateTime(CType(dtToReturn.Rows(0)("erstellt_am"), Date))
End If
If dtToReturn.Rows(0)("mutiert_am") Is System.DBNull.Value Then
m_daMutiert_am = SqlDateTime.Null
Else
m_daMutiert_am = New SqlDateTime(CType(dtToReturn.Rows(0)("mutiert_am"), Date))
End If
If dtToReturn.Rows(0)("mutierer") Is System.DBNull.Value Then
m_iMutierer = SqlInt32.Null
Else
m_iMutierer = New SqlInt32(CType(dtToReturn.Rows(0)("mutierer"), Integer))
End If
If dtToReturn.Rows(0)("letzter_cold_run") Is System.DBNull.Value Then
m_daLetzter_cold_run = SqlDateTime.Null
Else
m_daLetzter_cold_run = New SqlDateTime(CType(dtToReturn.Rows(0)("letzter_cold_run"), Date))
End If
If dtToReturn.Rows(0)("letzer_ams_run") Is System.DBNull.Value Then
m_daLetzer_ams_run = SqlDateTime.Null
Else
m_daLetzer_ams_run = New SqlDateTime(CType(dtToReturn.Rows(0)("letzer_ams_run"), Date))
End If
If dtToReturn.Rows(0)("letzter_rdm_run") Is System.DBNull.Value Then
m_daLetzter_rdm_run = SqlDateTime.Null
Else
m_daLetzter_rdm_run = New SqlDateTime(CType(dtToReturn.Rows(0)("letzter_rdm_run"), Date))
End If
If dtToReturn.Rows(0)("letzter_host_run") Is System.DBNull.Value Then
m_daLetzter_host_run = SqlDateTime.Null
Else
m_daLetzter_host_run = New SqlDateTime(CType(dtToReturn.Rows(0)("letzter_host_run"), Date))
End If
If dtToReturn.Rows(0)("rdmstunden") Is System.DBNull.Value Then
m_iRdmstunden = SqlInt32.Null
Else
m_iRdmstunden = New SqlInt32(CType(dtToReturn.Rows(0)("rdmstunden"), Integer))
End If
If dtToReturn.Rows(0)("coldstunden") Is System.DBNull.Value Then
m_iColdstunden = SqlInt32.Null
Else
m_iColdstunden = New SqlInt32(CType(dtToReturn.Rows(0)("coldstunden"), Integer))
End If
If dtToReturn.Rows(0)("amsstunden") Is System.DBNull.Value Then
m_iAmsstunden = SqlInt32.Null
Else
m_iAmsstunden = New SqlInt32(CType(dtToReturn.Rows(0)("amsstunden"), Integer))
End If
If dtToReturn.Rows(0)("hoststunden") Is System.DBNull.Value Then
m_iHoststunden = SqlInt32.Null
Else
m_iHoststunden = New SqlInt32(CType(dtToReturn.Rows(0)("hoststunden"), Integer))
End If
If dtToReturn.Rows(0)("coldsystem") Is System.DBNull.Value Then
m_sColdsystem = SqlString.Null
Else
m_sColdsystem = New SqlString(CType(dtToReturn.Rows(0)("coldsystem"), String))
End If
If dtToReturn.Rows(0)("colduser") Is System.DBNull.Value Then
m_sColduser = SqlString.Null
Else
m_sColduser = New SqlString(CType(dtToReturn.Rows(0)("colduser"), String))
End If
If dtToReturn.Rows(0)("coldpassword") Is System.DBNull.Value Then
m_sColdpassword = SqlString.Null
Else
m_sColdpassword = New SqlString(CType(dtToReturn.Rows(0)("coldpassword"), String))
End If
If dtToReturn.Rows(0)("coldgui") Is System.DBNull.Value Then
m_sColdgui = SqlString.Null
Else
m_sColdgui = New SqlString(CType(dtToReturn.Rows(0)("coldgui"), String))
End If
If dtToReturn.Rows(0)("Passwort_vorlagenverwaltung") Is System.DBNull.Value Then
m_sPasswort_vorlagenverwaltung = SqlString.Null
Else
m_sPasswort_vorlagenverwaltung = New SqlString(CType(dtToReturn.Rows(0)("Passwort_vorlagenverwaltung"), String))
End If
If dtToReturn.Rows(0)("Anzahl_Cold_Viewer") Is System.DBNull.Value Then
m_iAnzahl_Cold_Viewer = SqlInt32.Null
Else
m_iAnzahl_Cold_Viewer = New SqlInt32(CType(dtToReturn.Rows(0)("Anzahl_Cold_Viewer"), Integer))
End If
If dtToReturn.Rows(0)("Zeitintervall_in_Minuten") Is System.DBNull.Value Then
m_iZeitintervall_in_Minuten = SqlInt32.Null
Else
m_iZeitintervall_in_Minuten = New SqlInt32(CType(dtToReturn.Rows(0)("Zeitintervall_in_Minuten"), Integer))
End If
If dtToReturn.Rows(0)("coldstart") Is System.DBNull.Value Then
m_sColdstart = SqlString.Null
Else
m_sColdstart = New SqlString(CType(dtToReturn.Rows(0)("coldstart"), String))
End If
If dtToReturn.Rows(0)("videomenu") Is System.DBNull.Value Then
m_sVideomenu = SqlString.Null
Else
m_sVideomenu = New SqlString(CType(dtToReturn.Rows(0)("videomenu"), String))
End If
'20071120 RGL Cutover Avaloq Anbindung
If dtToReturn.Rows(0)("Cutoverdate") Is System.DBNull.Value Then
m_cutoverdate = SqlDateTime.Null
Else
m_cutoverdate = New SqlDateTime(CType(dtToReturn.Rows(0)("Cutoverdate"), Date))
End If
End If
Return dtToReturn
Catch ex As Exception
MsgBox(ex.Message)
' // some error occured. Bubble it to caller and encapsulate Exception object
Throw New Exception("clsApplikation::SelectOne::Error occured.", ex)
Finally
If m_bMainConnectionIsCreatedLocal Then
' // Close connection.
m_scoMainConnection.Close()
End If
scmCmdToExecute.Dispose()
sdaAdapter.Dispose()
End Try
End Function

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsApplikation Class
clsApplikation clsApplikation Members


clsApplikation.Update Method

clsApplikation.Update Method

clsApplikation.Update Method | Previous topic | Next topic
clsApplikation.Update Method | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Overrides Function Update() As Boolean

C#

public override bool Update()

C++

public:
bool Update()

JScript

public function Update() : boolean;

Source code

Visual Basic

Copy Code Copy Code

Overrides Public Function Update() As Boolean
Dim scmCmdToExecute As SqlCommand = New SqlCommand()
scmCmdToExecute.CommandText = "dbo.[pr_applikation_Update]"
scmCmdToExecute.CommandType = CommandType.StoredProcedure

' // Use base class' connection object
scmCmdToExecute.Connection = m_scoMainConnection

Try
scmCmdToExecute.Parameters.Add(New SqlParameter("@iapplikationsnr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iApplikationsnr))
scmCmdToExecute.Parameters.Add(New SqlParameter("@sversion", SqlDbType.VarChar, 4, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sVersion))
scmCmdToExecute.Parameters.Add(New SqlParameter("@sdokument_server", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sDokument_server))
scmCmdToExecute.Parameters.Add(New SqlParameter("@bnet_use", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bNet_use))
scmCmdToExecute.Parameters.Add(New SqlParameter("@slogisches_laufwerk", SqlDbType.VarChar, 10, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sLogisches_laufwerk))
scmCmdToExecute.Parameters.Add(New SqlParameter("@spfad_dokumente", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sPfad_dokumente))
scmCmdToExecute.Parameters.Add(New SqlParameter("@spfad_word_vorlagen", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sPfad_word_vorlagen))
scmCmdToExecute.Parameters.Add(New SqlParameter("@spfad_excel_vorlagen", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sPfad_excel_vorlagen))
scmCmdToExecute.Parameters.Add(New SqlParameter("@spfad_temporaer_dokumente", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sPfad_temporaer_dokumente))
scmCmdToExecute.Parameters.Add(New SqlParameter("@suser_fileserver", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sUser_fileserver))
scmCmdToExecute.Parameters.Add(New SqlParameter("@spasswort_fileserver", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sPasswort_fileserver))
scmCmdToExecute.Parameters.Add(New SqlParameter("@spasswort_wordvorlagen", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sPasswort_wordvorlagen))
scmCmdToExecute.Parameters.Add(New SqlParameter("@spasswort_excelvorlagen", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sPasswort_excelvorlagen))
scmCmdToExecute.Parameters.Add(New SqlParameter("@sreport_db", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sReport_db))
scmCmdToExecute.Parameters.Add(New SqlParameter("@sreport_server", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sReport_server))
scmCmdToExecute.Parameters.Add(New SqlParameter("@spfad_reportdateien", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sPfad_reportdateien))
scmCmdToExecute.Parameters.Add(New SqlParameter("@suser_report", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sUser_report))
scmCmdToExecute.Parameters.Add(New SqlParameter("@spasswort_report", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sPasswort_report))
scmCmdToExecute.Parameters.Add(New SqlParameter("@sbarcode_font", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBarcode_font))
scmCmdToExecute.Parameters.Add(New SqlParameter("@ibcfont_groesse", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iBcfont_groesse))
scmCmdToExecute.Parameters.Add(New SqlParameter("@smailadresse", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sMailadresse))
scmCmdToExecute.Parameters.Add(New SqlParameter("@bshowlogin", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bShowlogin))
scmCmdToExecute.Parameters.Add(New SqlParameter("@imandantnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMandantnr))
scmCmdToExecute.Parameters.Add(New SqlParameter("@baktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bAktiv))
scmCmdToExecute.Parameters.Add(New SqlParameter("@daerstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daErstellt_am))
scmCmdToExecute.Parameters.Add(New SqlParameter("@damutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daMutiert_am))
scmCmdToExecute.Parameters.Add(New SqlParameter("@imutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
scmCmdToExecute.Parameters.Add(New SqlParameter("@daletzter_cold_run", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daLetzter_cold_run))
scmCmdToExecute.Parameters.Add(New SqlParameter("@daletzer_ams_run", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daLetzer_ams_run))
scmCmdToExecute.Parameters.Add(New SqlParameter("@daletzter_rdm_run", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daLetzter_rdm_run))
scmCmdToExecute.Parameters.Add(New SqlParameter("@daletzter_host_run", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daLetzter_host_run))
scmCmdToExecute.Parameters.Add(New SqlParameter("@irdmstunden", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iRdmstunden))
scmCmdToExecute.Parameters.Add(New SqlParameter("@icoldstunden", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iColdstunden))
scmCmdToExecute.Parameters.Add(New SqlParameter("@iamsstunden", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iAmsstunden))
scmCmdToExecute.Parameters.Add(New SqlParameter("@ihoststunden", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iHoststunden))
scmCmdToExecute.Parameters.Add(New SqlParameter("@scoldsystem", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sColdsystem))
scmCmdToExecute.Parameters.Add(New SqlParameter("@scolduser", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sColduser))
scmCmdToExecute.Parameters.Add(New SqlParameter("@scoldpassword", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sColdpassword))
scmCmdToExecute.Parameters.Add(New SqlParameter("@scoldgui", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sColdgui))
scmCmdToExecute.Parameters.Add(New SqlParameter("@sPasswort_vorlagenverwaltung", SqlDbType.VarChar, 25, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sPasswort_vorlagenverwaltung))
scmCmdToExecute.Parameters.Add(New SqlParameter("@iAnzahl_Cold_Viewer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iAnzahl_Cold_Viewer))
scmCmdToExecute.Parameters.Add(New SqlParameter("@iZeitintervall_in_Minuten", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iZeitintervall_in_Minuten))
scmCmdToExecute.Parameters.Add(New SqlParameter("@scoldstart", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sColdstart))
scmCmdToExecute.Parameters.Add(New SqlParameter("@svideomenu", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sVideomenu))
scmCmdToExecute.Parameters.Add(New SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

Try
m_scoMainConnection.Open()
Catch
End Try

If m_bMainConnectionIsCreatedLocal Then
' // Open connection.
m_scoMainConnection.Open()
Else
If m_cpMainConnectionProvider.bIsTransactionPending Then
scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
End If
End If

' // Execute query.
scmCmdToExecute.ExecuteNonQuery()
m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
' // Throw error.
Throw New Exception("Stored Procedure 'pr_applikation_Update' reported the ErrorCode: " & m_iErrorCode.ToString())
End If

Return True
Catch ex As Exception
' // some error occured. Bubble it to caller and encapsulate Exception object
Throw New Exception("clsApplikation::Update::Error occured.", ex)
Finally
If m_bMainConnectionIsCreatedLocal Then
' // Close connection.
m_scoMainConnection.Close()
End If
Try
m_scoMainConnection.Close()
Catch

End Try
scmCmdToExecute.Dispose()
End Try
End Function

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsApplikation Class
clsApplikation clsApplikation Members


clsApplikation Fields

clsApplikation Fields

clsApplikation Fields | Previous topic | Next topic
clsApplikation Fields | Previous topic | Next topic

Fields

 | Name | Description
Supported by the .NET Compact Framework. | m_bAktiv |
Supported by the .NET Compact Framework. | m_bMainConnectionIsCreatedLocal | (inherited from clsDBInteractionBase ).
Supported by the .NET Compact Framework. | m_bNet_use |
Supported by the .NET Compact Framework. | m_bShowlogin |
Supported by the .NET Compact Framework. | m_cpMainConnectionProvider | (inherited from clsDBInteractionBase ).
Supported by the .NET Compact Framework. | m_cutoverdate |
Supported by the .NET Compact Framework. | m_daErstellt_am |
Supported by the .NET Compact Framework. | m_daLetzer_ams_run |
Supported by the .NET Compact Framework. | m_daLetzter_cold_run |
Supported by the .NET Compact Framework. | m_daLetzter_host_run |
Supported by the .NET Compact Framework. | m_daLetzter_rdm_run |
Supported by the .NET Compact Framework. | m_daMutiert_am |
Supported by the .NET Compact Framework. | m_iAmsstunden |
Supported by the .NET Compact Framework. | m_iAnzahl_Cold_Viewer |
Supported by the .NET Compact Framework. | m_iApplikationsnr |
Supported by the .NET Compact Framework. | m_iBcfont_groesse |
Supported by the .NET Compact Framework. | m_iColdstunden |
Supported by the .NET Compact Framework. | m_iErrorCode | (inherited from clsDBInteractionBase ).
Supported by the .NET Compact Framework. | m_iHoststunden |
Supported by the .NET Compact Framework. | m_iMandantnr |
Supported by the .NET Compact Framework. | m_iMutierer |
Supported by the .NET Compact Framework. | m_iRdmstunden |
Supported by the .NET Compact Framework. | m_iZeitintervall_in_Minuten |
Supported by the .NET Compact Framework. | m_sBarcode_font |
Supported by the .NET Compact Framework. | m_sColdgui |
Supported by the .NET Compact Framework. | m_sColdpassword |
Supported by the .NET Compact Framework. | m_sColdstart |
Supported by the .NET Compact Framework. | m_sColdsystem |
Supported by the .NET Compact Framework. | m_sColduser |
Supported by the .NET Compact Framework. | m_sDokument_server |
Supported by the .NET Compact Framework. | m_sLogisches_laufwerk |
Supported by the .NET Compact Framework. | m_sMailadresse |
Supported by the .NET Compact Framework. | m_sPasswort_excelvorlagen |
Supported by the .NET Compact Framework. | m_sPasswort_fileserver |
Supported by the .NET Compact Framework. | m_sPasswort_report |
Supported by the .NET Compact Framework. | m_sPasswort_vorlagenverwaltung |
Supported by the .NET Compact Framework. | m_sPasswort_wordvorlagen |
Supported by the .NET Compact Framework. | m_sPfad_dokumente |
Supported by the .NET Compact Framework. | m_sPfad_excel_vorlagen |
Supported by the .NET Compact Framework. | m_sPfad_reportdateien |
Supported by the .NET Compact Framework. | m_sPfad_temporaer_dokumente |
Supported by the .NET Compact Framework. | m_sPfad_word_vorlagen |
Supported by the .NET Compact Framework. | m_sReport_db |
Supported by the .NET Compact Framework. | m_sReport_server |
Supported by the .NET Compact Framework. | m_sUser_fileserver |
Supported by the .NET Compact Framework. | m_sUser_report |
Supported by the .NET Compact Framework. | m_sVersion |
Supported by the .NET Compact Framework. | m_sVideomenu |
Supported by the .NET Compact Framework. | m_scoMainConnection | (inherited from clsDBInteractionBase ).

Top

See Also

Reference

clsApplikation Class


m_bAktiv Field

m_bAktiv Field

m_bAktiv Field | Previous topic | Next topic
m_bAktiv Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_bAktiv As SqlBoolean

C#

private SqlBoolean m_bAktiv

C++

private:
SqlBoolean m_bAktiv;

JScript

private m_bAktiv : SqlBoolean

Source code

Visual Basic

Copy Code Copy Code

Private m_bNet_use, m_bShowlogin, m_bAktiv As SqlBoolean

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsApplikation Class
clsApplikation clsApplikation Members


m_bNet_use Field

m_bNet_use Field

m_bNet_use Field | Previous topic | Next topic
m_bNet_use Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_bNet_use As SqlBoolean

C#

private SqlBoolean m_bNet_use

C++

private:
SqlBoolean m_bNet_use;

JScript

private m_bNet_use : SqlBoolean

Source code

Visual Basic

Copy Code Copy Code

Private m_bNet_use, m_bShowlogin, m_bAktiv As SqlBoolean

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsApplikation Class
clsApplikation clsApplikation Members


m_bShowlogin Field

m_bShowlogin Field

m_bShowlogin Field | Previous topic | Next topic
m_bShowlogin Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_bShowlogin As SqlBoolean

C#

private SqlBoolean m_bShowlogin

C++

private:
SqlBoolean m_bShowlogin;

JScript

private m_bShowlogin : SqlBoolean

Source code

Visual Basic

Copy Code Copy Code

Private m_bNet_use, m_bShowlogin, m_bAktiv As SqlBoolean

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsApplikation Class
clsApplikation clsApplikation Members


m_cutoverdate Field

m_cutoverdate Field

m_cutoverdate Field | Previous topic | Next topic
m_cutoverdate Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_cutoverdate As SqlString

C#

private SqlString m_cutoverdate

C++

private:
SqlString m_cutoverdate;

JScript

private m_cutoverdate : SqlString

Source code

Visual Basic

Copy Code Copy Code

Private m_sColdsystem, m_sColduser, m_sColdpassword, m_sPfad_excel_vorlagen, m_sPfad_word_vorlagen, m_sPfad_dokumente, m_sDokument_server, m_sColdstart, m_sVideomenu, m_sColdgui, m_sPasswort_vorlagenverwaltung, m_sLogisches_laufwerk, m_sPfad_temporaer_dokumente, m_sPasswort_report, m_sUser_report, m_sPfad_reportdateien, m_sBarcode_font, m_sMailadresse, m_sVersion, m_sPasswort_wordvorlagen, m_sPasswort_fileserver, m_sUser_fileserver, m_sReport_server, m_sReport_db, m_sPasswort_excelvorlagen, m_cutoverdate As SqlString

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsApplikation Class
clsApplikation clsApplikation Members


m_daErstellt_am Field

m_daErstellt_am Field

m_daErstellt_am Field | Previous topic | Next topic
m_daErstellt_am Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_daErstellt_am As SqlDateTime

C#

private SqlDateTime m_daErstellt_am

C++

private:
SqlDateTime m_daErstellt_am;

JScript

private m_daErstellt_am : SqlDateTime

Source code

Visual Basic

Copy Code Copy Code

Private m_daLetzer_ams_run, m_daLetzter_rdm_run, m_daLetzter_host_run, m_daErstellt_am, m_daMutiert_am, m_daLetzter_cold_run As SqlDateTime

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsApplikation Class
clsApplikation clsApplikation Members


m_daLetzer_ams_run Field

m_daLetzer_ams_run Field

m_daLetzer_ams_run Field | Previous topic | Next topic
m_daLetzer_ams_run Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_daLetzer_ams_run As SqlDateTime

C#

private SqlDateTime m_daLetzer_ams_run

C++

private:
SqlDateTime m_daLetzer_ams_run;

JScript

private m_daLetzer_ams_run : SqlDateTime

Source code

Visual Basic

Copy Code Copy Code

Private m_daLetzer_ams_run, m_daLetzter_rdm_run, m_daLetzter_host_run, m_daErstellt_am, m_daMutiert_am, m_daLetzter_cold_run As SqlDateTime

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsApplikation Class
clsApplikation clsApplikation Members


m_daLetzter_cold_run Field

m_daLetzter_cold_run Field

m_daLetzter_cold_run Field | Previous topic | Next topic
m_daLetzter_cold_run Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_daLetzter_cold_run As SqlDateTime

C#

private SqlDateTime m_daLetzter_cold_run

C++

private:
SqlDateTime m_daLetzter_cold_run;

JScript

private m_daLetzter_cold_run : SqlDateTime

Source code

Visual Basic

Copy Code Copy Code

Private m_daLetzer_ams_run, m_daLetzter_rdm_run, m_daLetzter_host_run, m_daErstellt_am, m_daMutiert_am, m_daLetzter_cold_run As SqlDateTime

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsApplikation Class
clsApplikation clsApplikation Members


m_daLetzter_host_run Field

m_daLetzter_host_run Field

m_daLetzter_host_run Field | Previous topic | Next topic
m_daLetzter_host_run Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_daLetzter_host_run As SqlDateTime

C#

private SqlDateTime m_daLetzter_host_run

C++

private:
SqlDateTime m_daLetzter_host_run;

JScript

private m_daLetzter_host_run : SqlDateTime

Source code

Visual Basic

Copy Code Copy Code

Private m_daLetzer_ams_run, m_daLetzter_rdm_run, m_daLetzter_host_run, m_daErstellt_am, m_daMutiert_am, m_daLetzter_cold_run As SqlDateTime

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsApplikation Class
clsApplikation clsApplikation Members


m_daLetzter_rdm_run Field

m_daLetzter_rdm_run Field

m_daLetzter_rdm_run Field | Previous topic | Next topic
m_daLetzter_rdm_run Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_daLetzter_rdm_run As SqlDateTime

C#

private SqlDateTime m_daLetzter_rdm_run

C++

private:
SqlDateTime m_daLetzter_rdm_run;

JScript

private m_daLetzter_rdm_run : SqlDateTime

Source code

Visual Basic

Copy Code Copy Code

Private m_daLetzer_ams_run, m_daLetzter_rdm_run, m_daLetzter_host_run, m_daErstellt_am, m_daMutiert_am, m_daLetzter_cold_run As SqlDateTime

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsApplikation Class
clsApplikation clsApplikation Members


m_daMutiert_am Field

m_daMutiert_am Field

m_daMutiert_am Field | Previous topic | Next topic
m_daMutiert_am Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_daMutiert_am As SqlDateTime

C#

private SqlDateTime m_daMutiert_am

C++

private:
SqlDateTime m_daMutiert_am;

JScript

private m_daMutiert_am : SqlDateTime

Source code

Visual Basic

Copy Code Copy Code

Private m_daLetzer_ams_run, m_daLetzter_rdm_run, m_daLetzter_host_run, m_daErstellt_am, m_daMutiert_am, m_daLetzter_cold_run As SqlDateTime

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsApplikation Class
clsApplikation clsApplikation Members


m_iAmsstunden Field

m_iAmsstunden Field

m_iAmsstunden Field | Previous topic | Next topic
m_iAmsstunden Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_iAmsstunden As SqlInt32

C#

private SqlInt32 m_iAmsstunden

C++

private:
SqlInt32 m_iAmsstunden;

JScript

private m_iAmsstunden : SqlInt32

Source code

Visual Basic

Copy Code Copy Code

Private m_iZeitintervall_in_Minuten, m_iAnzahl_Cold_Viewer, m_iApplikationsnr, m_iBcfont_groesse, m_iMandantnr, m_iColdstunden, m_iRdmstunden, m_iAmsstunden, m_iMutierer, m_iHoststunden As SqlInt32

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsApplikation Class
clsApplikation clsApplikation Members


m_iAnzahl_Cold_Viewer Field

m_iAnzahl_Cold_Viewer Field

m_iAnzahl_Cold_Viewer Field | Previous topic | Next topic
m_iAnzahl_Cold_Viewer Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_iAnzahl_Cold_Viewer As SqlInt32

C#

private SqlInt32 m_iAnzahl_Cold_Viewer

C++

private:
SqlInt32 m_iAnzahl_Cold_Viewer;

JScript

private m_iAnzahl_Cold_Viewer : SqlInt32

Source code

Visual Basic

Copy Code Copy Code

Private m_iZeitintervall_in_Minuten, m_iAnzahl_Cold_Viewer, m_iApplikationsnr, m_iBcfont_groesse, m_iMandantnr, m_iColdstunden, m_iRdmstunden, m_iAmsstunden, m_iMutierer, m_iHoststunden As SqlInt32

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsApplikation Class
clsApplikation clsApplikation Members


m_iApplikationsnr Field

m_iApplikationsnr Field

m_iApplikationsnr Field | Previous topic | Next topic
m_iApplikationsnr Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_iApplikationsnr As SqlInt32

C#

private SqlInt32 m_iApplikationsnr

C++

private:
SqlInt32 m_iApplikationsnr;

JScript

private m_iApplikationsnr : SqlInt32

Source code

Visual Basic

Copy Code Copy Code

Private m_iZeitintervall_in_Minuten, m_iAnzahl_Cold_Viewer, m_iApplikationsnr, m_iBcfont_groesse, m_iMandantnr, m_iColdstunden, m_iRdmstunden, m_iAmsstunden, m_iMutierer, m_iHoststunden As SqlInt32

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsApplikation Class
clsApplikation clsApplikation Members


m_iBcfont_groesse Field

m_iBcfont_groesse Field

m_iBcfont_groesse Field | Previous topic | Next topic
m_iBcfont_groesse Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_iBcfont_groesse As SqlInt32

C#

private SqlInt32 m_iBcfont_groesse

C++

private:
SqlInt32 m_iBcfont_groesse;

JScript

private m_iBcfont_groesse : SqlInt32

Source code

Visual Basic

Copy Code Copy Code

Private m_iZeitintervall_in_Minuten, m_iAnzahl_Cold_Viewer, m_iApplikationsnr, m_iBcfont_groesse, m_iMandantnr, m_iColdstunden, m_iRdmstunden, m_iAmsstunden, m_iMutierer, m_iHoststunden As SqlInt32

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsApplikation Class
clsApplikation clsApplikation Members


m_iColdstunden Field

m_iColdstunden Field

m_iColdstunden Field | Previous topic | Next topic
m_iColdstunden Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_iColdstunden As SqlInt32

C#

private SqlInt32 m_iColdstunden

C++

private:
SqlInt32 m_iColdstunden;

JScript

private m_iColdstunden : SqlInt32

Source code

Visual Basic

Copy Code Copy Code

Private m_iZeitintervall_in_Minuten, m_iAnzahl_Cold_Viewer, m_iApplikationsnr, m_iBcfont_groesse, m_iMandantnr, m_iColdstunden, m_iRdmstunden, m_iAmsstunden, m_iMutierer, m_iHoststunden As SqlInt32

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsApplikation Class
clsApplikation clsApplikation Members


m_iHoststunden Field

m_iHoststunden Field

m_iHoststunden Field | Previous topic | Next topic
m_iHoststunden Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_iHoststunden As SqlInt32

C#

private SqlInt32 m_iHoststunden

C++

private:
SqlInt32 m_iHoststunden;

JScript

private m_iHoststunden : SqlInt32

Source code

Visual Basic

Copy Code Copy Code

Private m_iZeitintervall_in_Minuten, m_iAnzahl_Cold_Viewer, m_iApplikationsnr, m_iBcfont_groesse, m_iMandantnr, m_iColdstunden, m_iRdmstunden, m_iAmsstunden, m_iMutierer, m_iHoststunden As SqlInt32

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsApplikation Class
clsApplikation clsApplikation Members


m_iMandantnr Field

m_iMandantnr Field

m_iMandantnr Field | Previous topic | Next topic
m_iMandantnr Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_iMandantnr As SqlInt32

C#

private SqlInt32 m_iMandantnr

C++

private:
SqlInt32 m_iMandantnr;

JScript

private m_iMandantnr : SqlInt32

Source code

Visual Basic

Copy Code Copy Code

Private m_iZeitintervall_in_Minuten, m_iAnzahl_Cold_Viewer, m_iApplikationsnr, m_iBcfont_groesse, m_iMandantnr, m_iColdstunden, m_iRdmstunden, m_iAmsstunden, m_iMutierer, m_iHoststunden As SqlInt32

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsApplikation Class
clsApplikation clsApplikation Members


m_iMutierer Field

m_iMutierer Field

m_iMutierer Field | Previous topic | Next topic
m_iMutierer Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_iMutierer As SqlInt32

C#

private SqlInt32 m_iMutierer

C++

private:
SqlInt32 m_iMutierer;

JScript

private m_iMutierer : SqlInt32

Source code

Visual Basic

Copy Code Copy Code

Private m_iZeitintervall_in_Minuten, m_iAnzahl_Cold_Viewer, m_iApplikationsnr, m_iBcfont_groesse, m_iMandantnr, m_iColdstunden, m_iRdmstunden, m_iAmsstunden, m_iMutierer, m_iHoststunden As SqlInt32

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsApplikation Class
clsApplikation clsApplikation Members


m_iRdmstunden Field

m_iRdmstunden Field

m_iRdmstunden Field | Previous topic | Next topic
m_iRdmstunden Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_iRdmstunden As SqlInt32

C#

private SqlInt32 m_iRdmstunden

C++

private:
SqlInt32 m_iRdmstunden;

JScript

private m_iRdmstunden : SqlInt32

Source code

Visual Basic

Copy Code Copy Code

Private m_iZeitintervall_in_Minuten, m_iAnzahl_Cold_Viewer, m_iApplikationsnr, m_iBcfont_groesse, m_iMandantnr, m_iColdstunden, m_iRdmstunden, m_iAmsstunden, m_iMutierer, m_iHoststunden As SqlInt32

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsApplikation Class
clsApplikation clsApplikation Members


m_iZeitintervall_in_Minuten Field

m_iZeitintervall_in_Minuten Field

m_iZeitintervall_in_Minuten Field | Previous topic | Next topic
m_iZeitintervall_in_Minuten Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_iZeitintervall_in_Minuten As SqlInt32

C#

private SqlInt32 m_iZeitintervall_in_Minuten

C++

private:
SqlInt32 m_iZeitintervall_in_Minuten;

JScript

private m_iZeitintervall_in_Minuten : SqlInt32

Source code

Visual Basic

Copy Code Copy Code

Private m_iZeitintervall_in_Minuten, m_iAnzahl_Cold_Viewer, m_iApplikationsnr, m_iBcfont_groesse, m_iMandantnr, m_iColdstunden, m_iRdmstunden, m_iAmsstunden, m_iMutierer, m_iHoststunden As SqlInt32

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsApplikation Class
clsApplikation clsApplikation Members


m_sBarcode_font Field

m_sBarcode_font Field

m_sBarcode_font Field | Previous topic | Next topic
m_sBarcode_font Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_sBarcode_font As SqlString

C#

private SqlString m_sBarcode_font

C++

private:
SqlString m_sBarcode_font;

JScript

private m_sBarcode_font : SqlString

Source code

Visual Basic

Copy Code Copy Code

Private m_sColdsystem, m_sColduser, m_sColdpassword, m_sPfad_excel_vorlagen, m_sPfad_word_vorlagen, m_sPfad_dokumente, m_sDokument_server, m_sColdstart, m_sVideomenu, m_sColdgui, m_sPasswort_vorlagenverwaltung, m_sLogisches_laufwerk, m_sPfad_temporaer_dokumente, m_sPasswort_report, m_sUser_report, m_sPfad_reportdateien, m_sBarcode_font, m_sMailadresse, m_sVersion, m_sPasswort_wordvorlagen, m_sPasswort_fileserver, m_sUser_fileserver, m_sReport_server, m_sReport_db, m_sPasswort_excelvorlagen, m_cutoverdate As SqlString

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsApplikation Class
clsApplikation clsApplikation Members


m_sColdgui Field

m_sColdgui Field

m_sColdgui Field | Previous topic | Next topic
m_sColdgui Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_sColdgui As SqlString

C#

private SqlString m_sColdgui

C++

private:
SqlString m_sColdgui;

JScript

private m_sColdgui : SqlString

Source code

Visual Basic

Copy Code Copy Code

Private m_sColdsystem, m_sColduser, m_sColdpassword, m_sPfad_excel_vorlagen, m_sPfad_word_vorlagen, m_sPfad_dokumente, m_sDokument_server, m_sColdstart, m_sVideomenu, m_sColdgui, m_sPasswort_vorlagenverwaltung, m_sLogisches_laufwerk, m_sPfad_temporaer_dokumente, m_sPasswort_report, m_sUser_report, m_sPfad_reportdateien, m_sBarcode_font, m_sMailadresse, m_sVersion, m_sPasswort_wordvorlagen, m_sPasswort_fileserver, m_sUser_fileserver, m_sReport_server, m_sReport_db, m_sPasswort_excelvorlagen, m_cutoverdate As SqlString

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsApplikation Class
clsApplikation clsApplikation Members


m_sColdpassword Field

m_sColdpassword Field

m_sColdpassword Field | Previous topic | Next topic
m_sColdpassword Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_sColdpassword As SqlString

C#

private SqlString m_sColdpassword

C++

private:
SqlString m_sColdpassword;

JScript

private m_sColdpassword : SqlString

Source code

Visual Basic

Copy Code Copy Code

Private m_sColdsystem, m_sColduser, m_sColdpassword, m_sPfad_excel_vorlagen, m_sPfad_word_vorlagen, m_sPfad_dokumente, m_sDokument_server, m_sColdstart, m_sVideomenu, m_sColdgui, m_sPasswort_vorlagenverwaltung, m_sLogisches_laufwerk, m_sPfad_temporaer_dokumente, m_sPasswort_report, m_sUser_report, m_sPfad_reportdateien, m_sBarcode_font, m_sMailadresse, m_sVersion, m_sPasswort_wordvorlagen, m_sPasswort_fileserver, m_sUser_fileserver, m_sReport_server, m_sReport_db, m_sPasswort_excelvorlagen, m_cutoverdate As SqlString

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsApplikation Class
clsApplikation clsApplikation Members


m_sColdstart Field

m_sColdstart Field

m_sColdstart Field | Previous topic | Next topic
m_sColdstart Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_sColdstart As SqlString

C#

private SqlString m_sColdstart

C++

private:
SqlString m_sColdstart;

JScript

private m_sColdstart : SqlString

Source code

Visual Basic

Copy Code Copy Code

Private m_sColdsystem, m_sColduser, m_sColdpassword, m_sPfad_excel_vorlagen, m_sPfad_word_vorlagen, m_sPfad_dokumente, m_sDokument_server, m_sColdstart, m_sVideomenu, m_sColdgui, m_sPasswort_vorlagenverwaltung, m_sLogisches_laufwerk, m_sPfad_temporaer_dokumente, m_sPasswort_report, m_sUser_report, m_sPfad_reportdateien, m_sBarcode_font, m_sMailadresse, m_sVersion, m_sPasswort_wordvorlagen, m_sPasswort_fileserver, m_sUser_fileserver, m_sReport_server, m_sReport_db, m_sPasswort_excelvorlagen, m_cutoverdate As SqlString

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsApplikation Class
clsApplikation clsApplikation Members


m_sColdsystem Field

m_sColdsystem Field

m_sColdsystem Field | Previous topic | Next topic
m_sColdsystem Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_sColdsystem As SqlString

C#

private SqlString m_sColdsystem

C++

private:
SqlString m_sColdsystem;

JScript

private m_sColdsystem : SqlString

Source code

Visual Basic

Copy Code Copy Code

Private m_sColdsystem, m_sColduser, m_sColdpassword, m_sPfad_excel_vorlagen, m_sPfad_word_vorlagen, m_sPfad_dokumente, m_sDokument_server, m_sColdstart, m_sVideomenu, m_sColdgui, m_sPasswort_vorlagenverwaltung, m_sLogisches_laufwerk, m_sPfad_temporaer_dokumente, m_sPasswort_report, m_sUser_report, m_sPfad_reportdateien, m_sBarcode_font, m_sMailadresse, m_sVersion, m_sPasswort_wordvorlagen, m_sPasswort_fileserver, m_sUser_fileserver, m_sReport_server, m_sReport_db, m_sPasswort_excelvorlagen, m_cutoverdate As SqlString

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsApplikation Class
clsApplikation clsApplikation Members


m_sColduser Field

m_sColduser Field

m_sColduser Field | Previous topic | Next topic
m_sColduser Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_sColduser As SqlString

C#

private SqlString m_sColduser

C++

private:
SqlString m_sColduser;

JScript

private m_sColduser : SqlString

Source code

Visual Basic

Copy Code Copy Code

Private m_sColdsystem, m_sColduser, m_sColdpassword, m_sPfad_excel_vorlagen, m_sPfad_word_vorlagen, m_sPfad_dokumente, m_sDokument_server, m_sColdstart, m_sVideomenu, m_sColdgui, m_sPasswort_vorlagenverwaltung, m_sLogisches_laufwerk, m_sPfad_temporaer_dokumente, m_sPasswort_report, m_sUser_report, m_sPfad_reportdateien, m_sBarcode_font, m_sMailadresse, m_sVersion, m_sPasswort_wordvorlagen, m_sPasswort_fileserver, m_sUser_fileserver, m_sReport_server, m_sReport_db, m_sPasswort_excelvorlagen, m_cutoverdate As SqlString

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsApplikation Class
clsApplikation clsApplikation Members


m_sDokument_server Field

m_sDokument_server Field

m_sDokument_server Field | Previous topic | Next topic
m_sDokument_server Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_sDokument_server As SqlString

C#

private SqlString m_sDokument_server

C++

private:
SqlString m_sDokument_server;

JScript

private m_sDokument_server : SqlString

Source code

Visual Basic

Copy Code Copy Code

Private m_sColdsystem, m_sColduser, m_sColdpassword, m_sPfad_excel_vorlagen, m_sPfad_word_vorlagen, m_sPfad_dokumente, m_sDokument_server, m_sColdstart, m_sVideomenu, m_sColdgui, m_sPasswort_vorlagenverwaltung, m_sLogisches_laufwerk, m_sPfad_temporaer_dokumente, m_sPasswort_report, m_sUser_report, m_sPfad_reportdateien, m_sBarcode_font, m_sMailadresse, m_sVersion, m_sPasswort_wordvorlagen, m_sPasswort_fileserver, m_sUser_fileserver, m_sReport_server, m_sReport_db, m_sPasswort_excelvorlagen, m_cutoverdate As SqlString

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsApplikation Class
clsApplikation clsApplikation Members


m_sLogisches_laufwerk Field

m_sLogisches_laufwerk Field

m_sLogisches_laufwerk Field | Previous topic | Next topic
m_sLogisches_laufwerk Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_sLogisches_laufwerk As SqlString

C#

private SqlString m_sLogisches_laufwerk

C++

private:
SqlString m_sLogisches_laufwerk;

JScript

private m_sLogisches_laufwerk : SqlString

Source code

Visual Basic

Copy Code Copy Code

Private m_sColdsystem, m_sColduser, m_sColdpassword, m_sPfad_excel_vorlagen, m_sPfad_word_vorlagen, m_sPfad_dokumente, m_sDokument_server, m_sColdstart, m_sVideomenu, m_sColdgui, m_sPasswort_vorlagenverwaltung, m_sLogisches_laufwerk, m_sPfad_temporaer_dokumente, m_sPasswort_report, m_sUser_report, m_sPfad_reportdateien, m_sBarcode_font, m_sMailadresse, m_sVersion, m_sPasswort_wordvorlagen, m_sPasswort_fileserver, m_sUser_fileserver, m_sReport_server, m_sReport_db, m_sPasswort_excelvorlagen, m_cutoverdate As SqlString

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsApplikation Class
clsApplikation clsApplikation Members


m_sMailadresse Field

m_sMailadresse Field

m_sMailadresse Field | Previous topic | Next topic
m_sMailadresse Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_sMailadresse As SqlString

C#

private SqlString m_sMailadresse

C++

private:
SqlString m_sMailadresse;

JScript

private m_sMailadresse : SqlString

Source code

Visual Basic

Copy Code Copy Code

Private m_sColdsystem, m_sColduser, m_sColdpassword, m_sPfad_excel_vorlagen, m_sPfad_word_vorlagen, m_sPfad_dokumente, m_sDokument_server, m_sColdstart, m_sVideomenu, m_sColdgui, m_sPasswort_vorlagenverwaltung, m_sLogisches_laufwerk, m_sPfad_temporaer_dokumente, m_sPasswort_report, m_sUser_report, m_sPfad_reportdateien, m_sBarcode_font, m_sMailadresse, m_sVersion, m_sPasswort_wordvorlagen, m_sPasswort_fileserver, m_sUser_fileserver, m_sReport_server, m_sReport_db, m_sPasswort_excelvorlagen, m_cutoverdate As SqlString

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsApplikation Class
clsApplikation clsApplikation Members


m_sPasswort_excelvorlagen Field

m_sPasswort_excelvorlagen Field

m_sPasswort_excelvorlagen Field | Previous topic | Next topic
m_sPasswort_excelvorlagen Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_sPasswort_excelvorlagen As SqlString

C#

private SqlString m_sPasswort_excelvorlagen

C++

private:
SqlString m_sPasswort_excelvorlagen;

JScript

private m_sPasswort_excelvorlagen : SqlString

Source code

Visual Basic

Copy Code Copy Code

Private m_sColdsystem, m_sColduser, m_sColdpassword, m_sPfad_excel_vorlagen, m_sPfad_word_vorlagen, m_sPfad_dokumente, m_sDokument_server, m_sColdstart, m_sVideomenu, m_sColdgui, m_sPasswort_vorlagenverwaltung, m_sLogisches_laufwerk, m_sPfad_temporaer_dokumente, m_sPasswort_report, m_sUser_report, m_sPfad_reportdateien, m_sBarcode_font, m_sMailadresse, m_sVersion, m_sPasswort_wordvorlagen, m_sPasswort_fileserver, m_sUser_fileserver, m_sReport_server, m_sReport_db, m_sPasswort_excelvorlagen, m_cutoverdate As SqlString

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsApplikation Class
clsApplikation clsApplikation Members


m_sPasswort_fileserver Field

m_sPasswort_fileserver Field

m_sPasswort_fileserver Field | Previous topic | Next topic
m_sPasswort_fileserver Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_sPasswort_fileserver As SqlString

C#

private SqlString m_sPasswort_fileserver

C++

private:
SqlString m_sPasswort_fileserver;

JScript

private m_sPasswort_fileserver : SqlString

Source code

Visual Basic

Copy Code Copy Code

Private m_sColdsystem, m_sColduser, m_sColdpassword, m_sPfad_excel_vorlagen, m_sPfad_word_vorlagen, m_sPfad_dokumente, m_sDokument_server, m_sColdstart, m_sVideomenu, m_sColdgui, m_sPasswort_vorlagenverwaltung, m_sLogisches_laufwerk, m_sPfad_temporaer_dokumente, m_sPasswort_report, m_sUser_report, m_sPfad_reportdateien, m_sBarcode_font, m_sMailadresse, m_sVersion, m_sPasswort_wordvorlagen, m_sPasswort_fileserver, m_sUser_fileserver, m_sReport_server, m_sReport_db, m_sPasswort_excelvorlagen, m_cutoverdate As SqlString

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsApplikation Class
clsApplikation clsApplikation Members


m_sPasswort_report Field

m_sPasswort_report Field

m_sPasswort_report Field | Previous topic | Next topic
m_sPasswort_report Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_sPasswort_report As SqlString

C#

private SqlString m_sPasswort_report

C++

private:
SqlString m_sPasswort_report;

JScript

private m_sPasswort_report : SqlString

Source code

Visual Basic

Copy Code Copy Code

Private m_sColdsystem, m_sColduser, m_sColdpassword, m_sPfad_excel_vorlagen, m_sPfad_word_vorlagen, m_sPfad_dokumente, m_sDokument_server, m_sColdstart, m_sVideomenu, m_sColdgui, m_sPasswort_vorlagenverwaltung, m_sLogisches_laufwerk, m_sPfad_temporaer_dokumente, m_sPasswort_report, m_sUser_report, m_sPfad_reportdateien, m_sBarcode_font, m_sMailadresse, m_sVersion, m_sPasswort_wordvorlagen, m_sPasswort_fileserver, m_sUser_fileserver, m_sReport_server, m_sReport_db, m_sPasswort_excelvorlagen, m_cutoverdate As SqlString

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsApplikation Class
clsApplikation clsApplikation Members


m_sPasswort_vorlagenverwaltung Field

m_sPasswort_vorlagenverwaltung Field

m_sPasswort_vorlagenverwaltung Field | Previous topic | Next topic
m_sPasswort_vorlagenverwaltung Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_sPasswort_vorlagenverwaltung As SqlString

C#

private SqlString m_sPasswort_vorlagenverwaltung

C++

private:
SqlString m_sPasswort_vorlagenverwaltung;

JScript

private m_sPasswort_vorlagenverwaltung : SqlString

Source code

Visual Basic

Copy Code Copy Code

Private m_sColdsystem, m_sColduser, m_sColdpassword, m_sPfad_excel_vorlagen, m_sPfad_word_vorlagen, m_sPfad_dokumente, m_sDokument_server, m_sColdstart, m_sVideomenu, m_sColdgui, m_sPasswort_vorlagenverwaltung, m_sLogisches_laufwerk, m_sPfad_temporaer_dokumente, m_sPasswort_report, m_sUser_report, m_sPfad_reportdateien, m_sBarcode_font, m_sMailadresse, m_sVersion, m_sPasswort_wordvorlagen, m_sPasswort_fileserver, m_sUser_fileserver, m_sReport_server, m_sReport_db, m_sPasswort_excelvorlagen, m_cutoverdate As SqlString

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsApplikation Class
clsApplikation clsApplikation Members


m_sPasswort_wordvorlagen Field

m_sPasswort_wordvorlagen Field

m_sPasswort_wordvorlagen Field | Previous topic | Next topic
m_sPasswort_wordvorlagen Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_sPasswort_wordvorlagen As SqlString

C#

private SqlString m_sPasswort_wordvorlagen

C++

private:
SqlString m_sPasswort_wordvorlagen;

JScript

private m_sPasswort_wordvorlagen : SqlString

Source code

Visual Basic

Copy Code Copy Code

Private m_sColdsystem, m_sColduser, m_sColdpassword, m_sPfad_excel_vorlagen, m_sPfad_word_vorlagen, m_sPfad_dokumente, m_sDokument_server, m_sColdstart, m_sVideomenu, m_sColdgui, m_sPasswort_vorlagenverwaltung, m_sLogisches_laufwerk, m_sPfad_temporaer_dokumente, m_sPasswort_report, m_sUser_report, m_sPfad_reportdateien, m_sBarcode_font, m_sMailadresse, m_sVersion, m_sPasswort_wordvorlagen, m_sPasswort_fileserver, m_sUser_fileserver, m_sReport_server, m_sReport_db, m_sPasswort_excelvorlagen, m_cutoverdate As SqlString

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsApplikation Class
clsApplikation clsApplikation Members


m_sPfad_dokumente Field

m_sPfad_dokumente Field

m_sPfad_dokumente Field | Previous topic | Next topic
m_sPfad_dokumente Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_sPfad_dokumente As SqlString

C#

private SqlString m_sPfad_dokumente

C++

private:
SqlString m_sPfad_dokumente;

JScript

private m_sPfad_dokumente : SqlString

Source code

Visual Basic

Copy Code Copy Code

Private m_sColdsystem, m_sColduser, m_sColdpassword, m_sPfad_excel_vorlagen, m_sPfad_word_vorlagen, m_sPfad_dokumente, m_sDokument_server, m_sColdstart, m_sVideomenu, m_sColdgui, m_sPasswort_vorlagenverwaltung, m_sLogisches_laufwerk, m_sPfad_temporaer_dokumente, m_sPasswort_report, m_sUser_report, m_sPfad_reportdateien, m_sBarcode_font, m_sMailadresse, m_sVersion, m_sPasswort_wordvorlagen, m_sPasswort_fileserver, m_sUser_fileserver, m_sReport_server, m_sReport_db, m_sPasswort_excelvorlagen, m_cutoverdate As SqlString

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsApplikation Class
clsApplikation clsApplikation Members


m_sPfad_excel_vorlagen Field

m_sPfad_excel_vorlagen Field

m_sPfad_excel_vorlagen Field | Previous topic | Next topic
m_sPfad_excel_vorlagen Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_sPfad_excel_vorlagen As SqlString

C#

private SqlString m_sPfad_excel_vorlagen

C++

private:
SqlString m_sPfad_excel_vorlagen;

JScript

private m_sPfad_excel_vorlagen : SqlString

Source code

Visual Basic

Copy Code Copy Code

Private m_sColdsystem, m_sColduser, m_sColdpassword, m_sPfad_excel_vorlagen, m_sPfad_word_vorlagen, m_sPfad_dokumente, m_sDokument_server, m_sColdstart, m_sVideomenu, m_sColdgui, m_sPasswort_vorlagenverwaltung, m_sLogisches_laufwerk, m_sPfad_temporaer_dokumente, m_sPasswort_report, m_sUser_report, m_sPfad_reportdateien, m_sBarcode_font, m_sMailadresse, m_sVersion, m_sPasswort_wordvorlagen, m_sPasswort_fileserver, m_sUser_fileserver, m_sReport_server, m_sReport_db, m_sPasswort_excelvorlagen, m_cutoverdate As SqlString

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsApplikation Class
clsApplikation clsApplikation Members


m_sPfad_reportdateien Field

m_sPfad_reportdateien Field

m_sPfad_reportdateien Field | Previous topic | Next topic
m_sPfad_reportdateien Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_sPfad_reportdateien As SqlString

C#

private SqlString m_sPfad_reportdateien

C++

private:
SqlString m_sPfad_reportdateien;

JScript

private m_sPfad_reportdateien : SqlString

Source code

Visual Basic

Copy Code Copy Code

Private m_sColdsystem, m_sColduser, m_sColdpassword, m_sPfad_excel_vorlagen, m_sPfad_word_vorlagen, m_sPfad_dokumente, m_sDokument_server, m_sColdstart, m_sVideomenu, m_sColdgui, m_sPasswort_vorlagenverwaltung, m_sLogisches_laufwerk, m_sPfad_temporaer_dokumente, m_sPasswort_report, m_sUser_report, m_sPfad_reportdateien, m_sBarcode_font, m_sMailadresse, m_sVersion, m_sPasswort_wordvorlagen, m_sPasswort_fileserver, m_sUser_fileserver, m_sReport_server, m_sReport_db, m_sPasswort_excelvorlagen, m_cutoverdate As SqlString

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsApplikation Class
clsApplikation clsApplikation Members


m_sPfad_temporaer_dokumente Field

m_sPfad_temporaer_dokumente Field

m_sPfad_temporaer_dokumente Field | Previous topic | Next topic
m_sPfad_temporaer_dokumente Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_sPfad_temporaer_dokumente As SqlString

C#

private SqlString m_sPfad_temporaer_dokumente

C++

private:
SqlString m_sPfad_temporaer_dokumente;

JScript

private m_sPfad_temporaer_dokumente : SqlString

Source code

Visual Basic

Copy Code Copy Code

Private m_sColdsystem, m_sColduser, m_sColdpassword, m_sPfad_excel_vorlagen, m_sPfad_word_vorlagen, m_sPfad_dokumente, m_sDokument_server, m_sColdstart, m_sVideomenu, m_sColdgui, m_sPasswort_vorlagenverwaltung, m_sLogisches_laufwerk, m_sPfad_temporaer_dokumente, m_sPasswort_report, m_sUser_report, m_sPfad_reportdateien, m_sBarcode_font, m_sMailadresse, m_sVersion, m_sPasswort_wordvorlagen, m_sPasswort_fileserver, m_sUser_fileserver, m_sReport_server, m_sReport_db, m_sPasswort_excelvorlagen, m_cutoverdate As SqlString

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsApplikation Class
clsApplikation clsApplikation Members


m_sPfad_word_vorlagen Field

m_sPfad_word_vorlagen Field

m_sPfad_word_vorlagen Field | Previous topic | Next topic
m_sPfad_word_vorlagen Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_sPfad_word_vorlagen As SqlString

C#

private SqlString m_sPfad_word_vorlagen

C++

private:
SqlString m_sPfad_word_vorlagen;

JScript

private m_sPfad_word_vorlagen : SqlString

Source code

Visual Basic

Copy Code Copy Code

Private m_sColdsystem, m_sColduser, m_sColdpassword, m_sPfad_excel_vorlagen, m_sPfad_word_vorlagen, m_sPfad_dokumente, m_sDokument_server, m_sColdstart, m_sVideomenu, m_sColdgui, m_sPasswort_vorlagenverwaltung, m_sLogisches_laufwerk, m_sPfad_temporaer_dokumente, m_sPasswort_report, m_sUser_report, m_sPfad_reportdateien, m_sBarcode_font, m_sMailadresse, m_sVersion, m_sPasswort_wordvorlagen, m_sPasswort_fileserver, m_sUser_fileserver, m_sReport_server, m_sReport_db, m_sPasswort_excelvorlagen, m_cutoverdate As SqlString

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsApplikation Class
clsApplikation clsApplikation Members


m_sReport_db Field

m_sReport_db Field

m_sReport_db Field | Previous topic | Next topic
m_sReport_db Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_sReport_db As SqlString

C#

private SqlString m_sReport_db

C++

private:
SqlString m_sReport_db;

JScript

private m_sReport_db : SqlString

Source code

Visual Basic

Copy Code Copy Code

Private m_sColdsystem, m_sColduser, m_sColdpassword, m_sPfad_excel_vorlagen, m_sPfad_word_vorlagen, m_sPfad_dokumente, m_sDokument_server, m_sColdstart, m_sVideomenu, m_sColdgui, m_sPasswort_vorlagenverwaltung, m_sLogisches_laufwerk, m_sPfad_temporaer_dokumente, m_sPasswort_report, m_sUser_report, m_sPfad_reportdateien, m_sBarcode_font, m_sMailadresse, m_sVersion, m_sPasswort_wordvorlagen, m_sPasswort_fileserver, m_sUser_fileserver, m_sReport_server, m_sReport_db, m_sPasswort_excelvorlagen, m_cutoverdate As SqlString

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsApplikation Class
clsApplikation clsApplikation Members


m_sReport_server Field

m_sReport_server Field

m_sReport_server Field | Previous topic | Next topic
m_sReport_server Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_sReport_server As SqlString

C#

private SqlString m_sReport_server

C++

private:
SqlString m_sReport_server;

JScript

private m_sReport_server : SqlString

Source code

Visual Basic

Copy Code Copy Code

Private m_sColdsystem, m_sColduser, m_sColdpassword, m_sPfad_excel_vorlagen, m_sPfad_word_vorlagen, m_sPfad_dokumente, m_sDokument_server, m_sColdstart, m_sVideomenu, m_sColdgui, m_sPasswort_vorlagenverwaltung, m_sLogisches_laufwerk, m_sPfad_temporaer_dokumente, m_sPasswort_report, m_sUser_report, m_sPfad_reportdateien, m_sBarcode_font, m_sMailadresse, m_sVersion, m_sPasswort_wordvorlagen, m_sPasswort_fileserver, m_sUser_fileserver, m_sReport_server, m_sReport_db, m_sPasswort_excelvorlagen, m_cutoverdate As SqlString

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsApplikation Class
clsApplikation clsApplikation Members


m_sUser_fileserver Field

m_sUser_fileserver Field

m_sUser_fileserver Field | Previous topic | Next topic
m_sUser_fileserver Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_sUser_fileserver As SqlString

C#

private SqlString m_sUser_fileserver

C++

private:
SqlString m_sUser_fileserver;

JScript

private m_sUser_fileserver : SqlString

Source code

Visual Basic

Copy Code Copy Code

Private m_sColdsystem, m_sColduser, m_sColdpassword, m_sPfad_excel_vorlagen, m_sPfad_word_vorlagen, m_sPfad_dokumente, m_sDokument_server, m_sColdstart, m_sVideomenu, m_sColdgui, m_sPasswort_vorlagenverwaltung, m_sLogisches_laufwerk, m_sPfad_temporaer_dokumente, m_sPasswort_report, m_sUser_report, m_sPfad_reportdateien, m_sBarcode_font, m_sMailadresse, m_sVersion, m_sPasswort_wordvorlagen, m_sPasswort_fileserver, m_sUser_fileserver, m_sReport_server, m_sReport_db, m_sPasswort_excelvorlagen, m_cutoverdate As SqlString

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsApplikation Class
clsApplikation clsApplikation Members


m_sUser_report Field

m_sUser_report Field

m_sUser_report Field | Previous topic | Next topic
m_sUser_report Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_sUser_report As SqlString

C#

private SqlString m_sUser_report

C++

private:
SqlString m_sUser_report;

JScript

private m_sUser_report : SqlString

Source code

Visual Basic

Copy Code Copy Code

Private m_sColdsystem, m_sColduser, m_sColdpassword, m_sPfad_excel_vorlagen, m_sPfad_word_vorlagen, m_sPfad_dokumente, m_sDokument_server, m_sColdstart, m_sVideomenu, m_sColdgui, m_sPasswort_vorlagenverwaltung, m_sLogisches_laufwerk, m_sPfad_temporaer_dokumente, m_sPasswort_report, m_sUser_report, m_sPfad_reportdateien, m_sBarcode_font, m_sMailadresse, m_sVersion, m_sPasswort_wordvorlagen, m_sPasswort_fileserver, m_sUser_fileserver, m_sReport_server, m_sReport_db, m_sPasswort_excelvorlagen, m_cutoverdate As SqlString

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsApplikation Class
clsApplikation clsApplikation Members


m_sVersion Field

m_sVersion Field

m_sVersion Field | Previous topic | Next topic
m_sVersion Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_sVersion As SqlString

C#

private SqlString m_sVersion

C++

private:
SqlString m_sVersion;

JScript

private m_sVersion : SqlString

Source code

Visual Basic

Copy Code Copy Code

Private m_sColdsystem, m_sColduser, m_sColdpassword, m_sPfad_excel_vorlagen, m_sPfad_word_vorlagen, m_sPfad_dokumente, m_sDokument_server, m_sColdstart, m_sVideomenu, m_sColdgui, m_sPasswort_vorlagenverwaltung, m_sLogisches_laufwerk, m_sPfad_temporaer_dokumente, m_sPasswort_report, m_sUser_report, m_sPfad_reportdateien, m_sBarcode_font, m_sMailadresse, m_sVersion, m_sPasswort_wordvorlagen, m_sPasswort_fileserver, m_sUser_fileserver, m_sReport_server, m_sReport_db, m_sPasswort_excelvorlagen, m_cutoverdate As SqlString

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsApplikation Class
clsApplikation clsApplikation Members


m_sVideomenu Field

m_sVideomenu Field

m_sVideomenu Field | Previous topic | Next topic
m_sVideomenu Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_sVideomenu As SqlString

C#

private SqlString m_sVideomenu

C++

private:
SqlString m_sVideomenu;

JScript

private m_sVideomenu : SqlString

Source code

Visual Basic

Copy Code Copy Code

Private m_sColdsystem, m_sColduser, m_sColdpassword, m_sPfad_excel_vorlagen, m_sPfad_word_vorlagen, m_sPfad_dokumente, m_sDokument_server, m_sColdstart, m_sVideomenu, m_sColdgui, m_sPasswort_vorlagenverwaltung, m_sLogisches_laufwerk, m_sPfad_temporaer_dokumente, m_sPasswort_report, m_sUser_report, m_sPfad_reportdateien, m_sBarcode_font, m_sMailadresse, m_sVersion, m_sPasswort_wordvorlagen, m_sPasswort_fileserver, m_sUser_fileserver, m_sReport_server, m_sReport_db, m_sPasswort_excelvorlagen, m_cutoverdate As SqlString

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsApplikation Class
clsApplikation clsApplikation Members


clsConnectionProvider Class

clsConnectionProvider Class

clsConnectionProvider Class | Previous topic | Next topic
clsConnectionProvider Class | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Class clsConnectionProvider
Implements IDisposable

C#

public class clsConnectionProvider : IDisposable

C++

public ref class clsConnectionProvider : public IDisposable^

JScript

public class clsConnectionProvider
implements IDisposable

Inheritance Hierarchy

System.Object

EDKB12WS.edokadb.clsConnectionProvider

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsConnectionProvider Members


clsConnectionProvider Members

clsConnectionProvider Members

clsConnectionProvider Members | Previous topic | Next topic
clsConnectionProvider Members | Previous topic | Next topic

The following tables list the members exposed by the clsConnectionProvider type.

Public Constructors

 | Name | Description
Supported by the .NET Compact Framework. | clsConnectionProvider Constructor |

Top

Public Properties

 | Name | Description
Supported by the .NET Compact Framework. | bIsTransactionPending |
Supported by the .NET Compact Framework. | sConnectionString |
Supported by the .NET Compact Framework. | scoDBConnection |
Supported by the .NET Compact Framework. | stCurrentTransaction |

Top

Public Methods

 | Name | Description
Supported by the .NET Compact Framework. | BeginTransaction |
Supported by the .NET Compact Framework. | CloseConnection |
Supported by the .NET Compact Framework. | CommitTransaction |
Supported by the .NET Compact Framework. | Dispose | (Overloaded)
Public method | Equals | (Overloaded) (inherited from Object).
Public method | GetHashCode | (inherited from Object).
Public method | GetType | (Overloaded) (inherited from Object).
Supported by the .NET Compact Framework. | OpenConnection |
 | ReferenceEquals | (inherited from Object).
Supported by the .NET Compact Framework. | RollbackTransaction |
Supported by the .NET Compact Framework. | SaveTransaction |
Public method | ToString | (inherited from Object).

Top

Protected Methods

 | Name | Description
Protected method | Finalize | (inherited from Object).
Protected method | MemberwiseClone | (Overloaded) (inherited from Object).

Top

Private, internal (Friend) and internal protected (Protected Friend) Methods

 | Name | Description
Supported by the .NET Compact Framework. | InitClass |

Top

Fields

 | Name | Description
Supported by the .NET Compact Framework. | m_alSavePoints |
Supported by the .NET Compact Framework. | m_bIsDisposed |
Supported by the .NET Compact Framework. | m_bIsTransactionPending |
Supported by the .NET Compact Framework. | m_scoDBConnection |
Supported by the .NET Compact Framework. | m_stCurrentTransaction |

Top

See Also

Reference

clsConnectionProvider Class


clsConnectionProvider Constructor

clsConnectionProvider Constructor

clsConnectionProvider Constructor | Previous topic | Next topic
clsConnectionProvider Constructor | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Sub New()

C#

public clsConnectionProvider()

C++

public:
clsConnectionProvider()

JScript

public function clsConnectionProvider();

Source code

Visual Basic

Copy Code Copy Code

Public Sub New()
' // Init the class
InitClass()
End Sub

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsConnectionProvider Class
clsConnectionProvider clsConnectionProvider Members


clsConnectionProvider Properties

clsConnectionProvider Properties

clsConnectionProvider Properties | Previous topic | Next topic
clsConnectionProvider Properties | Previous topic | Next topic

Public Properties

 | Name | Description
Supported by the .NET Compact Framework. | bIsTransactionPending |
Supported by the .NET Compact Framework. | sConnectionString |
Supported by the .NET Compact Framework. | scoDBConnection |
Supported by the .NET Compact Framework. | stCurrentTransaction |

Top

See Also

Reference

clsConnectionProvider Class


clsConnectionProvider.bIsTransactionPending Property

clsConnectionProvider.bIsTransactionPending Property

clsConnectionProvider.bIsTransactionPending Property | Previous topic | Next topic
clsConnectionProvider.bIsTransactionPending Property | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public ReadOnly Property bIsTransactionPending() As Boolean

C#

public bool bIsTransactionPending {get;}

C++

public:
property bool bIsTransactionPending {
bool get( );
}

JScript

public function get bIsTransactionPending() : boolean;

Source code

Visual Basic

Copy Code Copy Code

Public ReadOnly Property bIsTransactionPending() As Boolean
Get
Return m_bIsTransactionPending
End Get
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsConnectionProvider Class
clsConnectionProvider clsConnectionProvider Members


clsConnectionProvider.sConnectionString Property

clsConnectionProvider.sConnectionString Property

clsConnectionProvider.sConnectionString Property | Previous topic | Next topic
clsConnectionProvider.sConnectionString Property | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public WriteOnly Property sConnectionString() As String

C#

public string sConnectionString {set;}

C++

public:
property String^ sConnectionString {
void set(
String^ value
);
}

JScript

public function set sConnectionString(value : String);

Source code

Visual Basic

Copy Code Copy Code

Public WriteOnly Property sConnectionString() As String
Set (ByVal Value As String)
m_scoDBConnection.ConnectionString = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsConnectionProvider Class
clsConnectionProvider clsConnectionProvider Members


clsConnectionProvider.scoDBConnection Property

clsConnectionProvider.scoDBConnection Property

clsConnectionProvider.scoDBConnection Property | Previous topic | Next topic
clsConnectionProvider.scoDBConnection Property | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public ReadOnly Property scoDBConnection() As SqlConnection

C#

public SqlConnection scoDBConnection {get;}

C++

public:
property SqlConnection^ scoDBConnection {
SqlConnection^ get( );
}

JScript

public function get scoDBConnection() : SqlConnection;

Source code

Visual Basic

Copy Code Copy Code

Public ReadOnly Property scoDBConnection() As SqlConnection
Get
Return m_scoDBConnection
End Get
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsConnectionProvider Class
clsConnectionProvider clsConnectionProvider Members


clsConnectionProvider.stCurrentTransaction Property

clsConnectionProvider.stCurrentTransaction Property

clsConnectionProvider.stCurrentTransaction Property | Previous topic | Next topic
clsConnectionProvider.stCurrentTransaction Property | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public ReadOnly Property stCurrentTransaction() As SqlTransaction

C#

public SqlTransaction stCurrentTransaction {get;}

C++

public:
property SqlTransaction^ stCurrentTransaction {
SqlTransaction^ get( );
}

JScript

public function get stCurrentTransaction() : SqlTransaction;

Source code

Visual Basic

Copy Code Copy Code

Public ReadOnly Property stCurrentTransaction() As SqlTransaction
Get
Return m_stCurrentTransaction
End Get
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsConnectionProvider Class
clsConnectionProvider clsConnectionProvider Members


clsConnectionProvider Methods

clsConnectionProvider Methods

clsConnectionProvider Methods | Previous topic | Next topic
clsConnectionProvider Methods | Previous topic | Next topic

Public Methods

 | Name | Description
Supported by the .NET Compact Framework. | BeginTransaction |
Supported by the .NET Compact Framework. | CloseConnection |
Supported by the .NET Compact Framework. | CommitTransaction |
Supported by the .NET Compact Framework. | Dispose | (Overloaded)
Public method | Equals | (Overloaded) (inherited from Object).
Public method | GetHashCode | (inherited from Object).
Public method | GetType | (Overloaded) (inherited from Object).
Supported by the .NET Compact Framework. | OpenConnection |
 | ReferenceEquals | (inherited from Object).
Supported by the .NET Compact Framework. | RollbackTransaction |
Supported by the .NET Compact Framework. | SaveTransaction |
Public method | ToString | (inherited from Object).

Top

Protected Methods

 | Name | Description
Protected method | Finalize | (inherited from Object).
Protected method | MemberwiseClone | (Overloaded) (inherited from Object).

Top

Private, internal (Friend) and internal protected (Protected Friend) Methods

 | Name | Description
Supported by the .NET Compact Framework. | InitClass |

Top

See Also

Reference

clsConnectionProvider Class


clsConnectionProvider.BeginTransaction Method

clsConnectionProvider.BeginTransaction Method

clsConnectionProvider.BeginTransaction Method | Previous topic | Next topic
clsConnectionProvider.BeginTransaction Method | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Function BeginTransaction( _
ByVal sTransactionName As String _
) As Boolean

C#

public bool BeginTransaction(
stringsTransactionName
)

C++

public:
bool BeginTransaction(
String^ sTransactionName
)

JScript

public function BeginTransaction(
sTransactionName : String
) : boolean;

Parameters

sTransactionName

Source code

Visual Basic

Copy Code Copy Code

Public Function BeginTransaction(sTransactionName As String) As Boolean
Try
If m_bIsTransactionPending Then
' // no nested transactions allowed.
Throw New Exception("BeginTransaction::Already transaction pending. Nesting not allowed")
End If
If (m_scoDBConnection.State And ConnectionState.Open) = 0 Then
' // no open connection
Throw New Exception("BeginTransaction::Connection is not open.")
End If
' // begin the transaction and store the transaction object.
m_stCurrentTransaction = m_scoDBConnection.BeginTransaction(IsolationLevel.ReadCommitted, sTransactionName)
m_bIsTransactionPending = True
Return True
Catch ex As Exception
' // bubble exception
Throw ex
End Try
End Function

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsConnectionProvider Class
clsConnectionProvider clsConnectionProvider Members


clsConnectionProvider.CloseConnection Method

clsConnectionProvider.CloseConnection Method

clsConnectionProvider.CloseConnection Method | Previous topic | Next topic
clsConnectionProvider.CloseConnection Method | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Function CloseConnection( _
ByVal bCommitPendingTransaction As Boolean _
) As Boolean

C#

public bool CloseConnection(
boolbCommitPendingTransaction
)

C++

public:
bool CloseConnection(
boolbCommitPendingTransaction
)

JScript

public function CloseConnection(
bCommitPendingTransaction : boolean
) : boolean;

Parameters

bCommitPendingTransaction

Source code

Visual Basic

Copy Code Copy Code

Public Function CloseConnection(bCommitPendingTransaction As Boolean) As Boolean
Try
If (m_scoDBConnection.State And ConnectionState.Open) = 0 Then
' // No open connection
Return False
End If
If m_bIsTransactionPending Then
If bCommitPendingTransaction Then
' // Commit the pending transaction
m_stCurrentTransaction.Commit()
Else
' // Rollback the pending transaction
m_stCurrentTransaction.Rollback()
End If
m_bIsTransactionPending = False
m_stCurrentTransaction.Dispose()
m_stCurrentTransaction = Nothing
m_alSavePoints.Clear()
End If
' // close the connection
m_scoDBConnection.Close()
Return True
Catch ex As Exception
' // bubble exception
Throw ex
End Try
End Function

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsConnectionProvider Class
clsConnectionProvider clsConnectionProvider Members


clsConnectionProvider.CommitTransaction Method

clsConnectionProvider.CommitTransaction Method

clsConnectionProvider.CommitTransaction Method | Previous topic | Next topic
clsConnectionProvider.CommitTransaction Method | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Function CommitTransaction() As Boolean

C#

public bool CommitTransaction()

C++

public:
bool CommitTransaction()

JScript

public function CommitTransaction() : boolean;

Source code

Visual Basic

Copy Code Copy Code

Public Function CommitTransaction() As Boolean
Try
If Not m_bIsTransactionPending Then
' // no transaction pending
Throw New Exception("CommitTransaction::No transaction pending.")
End If
If (m_scoDBConnection.State And ConnectionState.Open) = 0 Then
' // no open connection
Throw New Exception("CommitTransaction::Connection is not open.")
End if
' // commit the transaction
m_stCurrentTransaction.Commit()
m_bIsTransactionPending = False
m_stCurrentTransaction.Dispose()
m_stCurrentTransaction = Nothing
m_alSavePoints.Clear()
Return True
Catch ex As Exception
' // bubble exception
Throw ex
End Try
End Function

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsConnectionProvider Class
clsConnectionProvider clsConnectionProvider Members


clsConnectionProvider.Dispose Method

clsConnectionProvider.Dispose Method

clsConnectionProvider.Dispose Method | Previous topic | Next topic
clsConnectionProvider.Dispose Method | Previous topic | Next topic

Overload List

Name | Description
Dispose() |
Dispose(bool) |

See Also

Reference

clsConnectionProvider Class
clsConnectionProvider clsConnectionProvider Members


clsConnectionProvider.InitClass Method

clsConnectionProvider.InitClass Method

clsConnectionProvider.InitClass Method | Previous topic | Next topic
clsConnectionProvider.InitClass Method | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private Sub InitClass()

C#

private System.Void InitClass()

C++

private:
System::Void InitClass()

JScript

private function InitClass();

Source code

Visual Basic

Copy Code Copy Code

Private Sub InitClass()
' // Create all the objects and initialize other members.
m_scoDBConnection = new SqlConnection()
m_bIsDisposed = False
m_stCurrentTransaction = Nothing
m_bIsTransactionPending = False
m_alSavePoints = new ArrayList()
End Sub

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsConnectionProvider Class
clsConnectionProvider clsConnectionProvider Members


clsConnectionProvider.OpenConnection Method

clsConnectionProvider.OpenConnection Method

clsConnectionProvider.OpenConnection Method | Previous topic | Next topic
clsConnectionProvider.OpenConnection Method | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Function OpenConnection() As Boolean

C#

public bool OpenConnection()

C++

public:
bool OpenConnection()

JScript

public function OpenConnection() : boolean;

Source code

Visual Basic

Copy Code Copy Code

Public Function OpenConnection() As Boolean
Try
If (m_scoDBConnection.State And ConnectionState.Open) > 0 Then
' // It's already open.
Throw New Exception("OpenConnection::Connection is already open.")
End If
m_scoDBConnection.Open()
m_bIsTransactionPending = False
m_alSavePoints.Clear()
Return True
Catch ex As Exception
' // bubble exception
Throw ex
End Try
End Function

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsConnectionProvider Class
clsConnectionProvider clsConnectionProvider Members


clsConnectionProvider.RollbackTransaction Method

clsConnectionProvider.RollbackTransaction Method

clsConnectionProvider.RollbackTransaction Method | Previous topic | Next topic
clsConnectionProvider.RollbackTransaction Method | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Function RollbackTransaction( _
ByVal sTransactionToRollback As String _
) As Boolean

C#

public bool RollbackTransaction(
stringsTransactionToRollback
)

C++

public:
bool RollbackTransaction(
String^ sTransactionToRollback
)

JScript

public function RollbackTransaction(
sTransactionToRollback : String
) : boolean;

Parameters

sTransactionToRollback

Source code

Visual Basic

Copy Code Copy Code

Public Function RollbackTransaction(sTransactionToRollback As String) As Boolean
Try
If Not m_bIsTransactionPending Then
' // no transaction pending
Throw New Exception("RollbackTransaction::No transaction pending.")
End If
If (m_scoDBConnection.State And ConnectionState.Open) = 0 Then
' // no open connection
Throw New Exception("RollbackTransaction::Connection is not open.")
End If
' // rollback the transaction
m_stCurrentTransaction.Rollback(sTransactionToRollback)
' // if this wasn't a savepoint, we've rolled back the complete transaction, so we
' // can clean it up.
If Not m_alSavePoints.Contains(sTransactionToRollback) Then
' // it's not a savepoint
m_bIsTransactionPending = False
m_stCurrentTransaction.Dispose()
m_stCurrentTransaction = Nothing
m_alSavePoints.Clear()
End If
Return True
Catch ex As Exception
' // bubble exception
Throw ex
End Try
End Function

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsConnectionProvider Class
clsConnectionProvider clsConnectionProvider Members


clsConnectionProvider.SaveTransaction Method

clsConnectionProvider.SaveTransaction Method

clsConnectionProvider.SaveTransaction Method | Previous topic | Next topic
clsConnectionProvider.SaveTransaction Method | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Function SaveTransaction( _
ByVal sSavePointName As String _
) As Boolean

C#

public bool SaveTransaction(
stringsSavePointName
)

C++

public:
bool SaveTransaction(
String^ sSavePointName
)

JScript

public function SaveTransaction(
sSavePointName : String
) : boolean;

Parameters

sSavePointName

Source code

Visual Basic

Copy Code Copy Code

Public Function SaveTransaction(sSavePointName As String) As Boolean
Try
If Not m_bIsTransactionPending Then
' // no transaction pending
Throw New Exception("SaveTransaction::No transaction pending.")
End If
If (m_scoDBConnection.State And ConnectionState.Open) = 0 Then
' // no open connection
Throw New Exception("SaveTransaction::Connection is not open.")
End If
' // save the transaction
m_stCurrentTransaction.Save(sSavePointName)
' // Store the savepoint in the list.
m_alSavePoints.Add(sSavePointName)
Return True
Catch ex As Exception
' // bubble exception
Throw ex
End Try
End Function

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsConnectionProvider Class
clsConnectionProvider clsConnectionProvider Members


clsConnectionProvider Fields

clsConnectionProvider Fields

clsConnectionProvider Fields | Previous topic | Next topic
clsConnectionProvider Fields | Previous topic | Next topic

Fields

 | Name | Description
Supported by the .NET Compact Framework. | m_alSavePoints |
Supported by the .NET Compact Framework. | m_bIsDisposed |
Supported by the .NET Compact Framework. | m_bIsTransactionPending |
Supported by the .NET Compact Framework. | m_scoDBConnection |
Supported by the .NET Compact Framework. | m_stCurrentTransaction |

Top

See Also

Reference

clsConnectionProvider Class


m_alSavePoints Field

m_alSavePoints Field

m_alSavePoints Field | Previous topic | Next topic
m_alSavePoints Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_alSavePoints As ArrayList

C#

private ArrayList m_alSavePoints

C++

private:
ArrayList^ m_alSavePoints;

JScript

private m_alSavePoints : ArrayList

Source code

Visual Basic

Copy Code Copy Code

Private m_alSavePoints As ArrayList

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsConnectionProvider Class
clsConnectionProvider clsConnectionProvider Members


m_bIsDisposed Field

m_bIsDisposed Field

m_bIsDisposed Field | Previous topic | Next topic
m_bIsDisposed Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_bIsDisposed As Boolean

C#

private bool m_bIsDisposed

C++

private:
bool m_bIsDisposed;

JScript

private m_bIsDisposed : boolean

Source code

Visual Basic

Copy Code Copy Code

Private m_bIsTransactionPending, m_bIsDisposed As Boolean

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsConnectionProvider Class
clsConnectionProvider clsConnectionProvider Members


m_bIsTransactionPending Field

m_bIsTransactionPending Field

m_bIsTransactionPending Field | Previous topic | Next topic
m_bIsTransactionPending Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_bIsTransactionPending As Boolean

C#

private bool m_bIsTransactionPending

C++

private:
bool m_bIsTransactionPending;

JScript

private m_bIsTransactionPending : boolean

Source code

Visual Basic

Copy Code Copy Code

Private m_bIsTransactionPending, m_bIsDisposed As Boolean

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsConnectionProvider Class
clsConnectionProvider clsConnectionProvider Members


m_scoDBConnection Field

m_scoDBConnection Field

m_scoDBConnection Field | Previous topic | Next topic
m_scoDBConnection Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_scoDBConnection As SqlConnection

C#

private SqlConnection m_scoDBConnection

C++

private:
SqlConnection^ m_scoDBConnection;

JScript

private m_scoDBConnection : SqlConnection

Source code

Visual Basic

Copy Code Copy Code

Private m_scoDBConnection As SqlConnection

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsConnectionProvider Class
clsConnectionProvider clsConnectionProvider Members


m_stCurrentTransaction Field

m_stCurrentTransaction Field

m_stCurrentTransaction Field | Previous topic | Next topic
m_stCurrentTransaction Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_stCurrentTransaction As SqlTransaction

C#

private SqlTransaction m_stCurrentTransaction

C++

private:
SqlTransaction^ m_stCurrentTransaction;

JScript

private m_stCurrentTransaction : SqlTransaction

Source code

Visual Basic

Copy Code Copy Code

Private m_stCurrentTransaction As SqlTransaction

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsConnectionProvider Class
clsConnectionProvider clsConnectionProvider Members


clsDBInteractionBase Class

clsDBInteractionBase Class

clsDBInteractionBase Class | Previous topic | Next topic
clsDBInteractionBase Class | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public MustInherit Class clsDBInteractionBase
Implements IDisposable, _
ICommonDBAccess

C#

public abstract class clsDBInteractionBase : IDisposable,
ICommonDBAccess

C++

public ref class clsDBInteractionBase abstract : public IDisposable^,
public ICommonDBAccess^

JScript

public abstract class clsDBInteractionBase
implements IDisposable,
ICommonDBAccess

Inheritance Hierarchy

System.Object

EDKB12WS.edokadb.clsDBInteractionBase

EDKB12WS.edokaDB.clsOffice_Vorlage_Datei

EDKB12WS.edokadb.clsApplikation

EDKB12WS.edokadb.clsDokument

EDKB12WS.edokadb.clsDokumenttyp

EDKB12WS.edokadb.clsIdvmakro_office_vorlage

EDKB12WS.edokadb.clsJournaleintrag

EDKB12WS.edokadb.clsKey_tabelle

EDKB12WS.edokadb.clsMitarbeiter

EDKB12WS.edokadb.clsOffice_vorlage

EDKB12WS.edokadb.clsPartner

EDKB12WS.edokadb.clsStatushistory

EDKB12WS.edokadb.clsVorlagenfeld

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsDBInteractionBase Members


clsDBInteractionBase Members

clsDBInteractionBase Members

clsDBInteractionBase Members | Previous topic | Next topic
clsDBInteractionBase Members | Previous topic | Next topic

The following tables list the members exposed by the clsDBInteractionBase type.

Public Constructors

 | Name | Description
Supported by the .NET Compact Framework. | clsDBInteractionBase Constructor |

Top

Public Properties

 | Name | Description
Supported by the .NET Compact Framework. | cpMainConnectionProvider |
Supported by the .NET Compact Framework. | iErrorCode |
Supported by the .NET Compact Framework. | sConnectionString |

Top

Public Methods

 | Name | Description
Supported by the .NET Compact Framework. | Delete |
Supported by the .NET Compact Framework. | Dispose | (Overloaded)
Public method | Equals | (Overloaded) (inherited from Object).
Public method | GetHashCode | (inherited from Object).
Public method | GetType | (Overloaded) (inherited from Object).
Supported by the .NET Compact Framework. | Insert |
 | ReferenceEquals | (inherited from Object).
Supported by the .NET Compact Framework. | SelectAll |
Supported by the .NET Compact Framework. | SelectOne |
Public method | ToString | (inherited from Object).
Supported by the .NET Compact Framework. | Update |

Top

Protected Methods

 | Name | Description
Protected method | Finalize | (inherited from Object).
Protected method | MemberwiseClone | (Overloaded) (inherited from Object).

Top

Private, internal (Friend) and internal protected (Protected Friend) Methods

 | Name | Description
Supported by the .NET Compact Framework. | InitClass |

Top

Fields

 | Name | Description
Supported by the .NET Compact Framework. | m_bIsDisposed |
Supported by the .NET Compact Framework. | m_bMainConnectionIsCreatedLocal |
Supported by the .NET Compact Framework. | m_cpMainConnectionProvider |
Supported by the .NET Compact Framework. | m_iErrorCode |
Supported by the .NET Compact Framework. | m_sConnectionString |
Supported by the .NET Compact Framework. | m_scoMainConnection |

Top

See Also

Reference

clsDBInteractionBase Class


clsDBInteractionBase Constructor

clsDBInteractionBase Constructor

clsDBInteractionBase Constructor | Previous topic | Next topic
clsDBInteractionBase Constructor | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Sub New()

C#

public clsDBInteractionBase()

C++

public:
clsDBInteractionBase()

JScript

public function clsDBInteractionBase();

Source code

Visual Basic

Copy Code Copy Code

Public Sub New()
' // Initialize the class' members.
InitClass()
End Sub

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsDBInteractionBase Class
clsDBInteractionBase clsDBInteractionBase Members


clsDBInteractionBase Properties

clsDBInteractionBase Properties

clsDBInteractionBase Properties | Previous topic | Next topic
clsDBInteractionBase Properties | Previous topic | Next topic

Public Properties

 | Name | Description
Supported by the .NET Compact Framework. | cpMainConnectionProvider |
Supported by the .NET Compact Framework. | iErrorCode |
Supported by the .NET Compact Framework. | sConnectionString |

Top

See Also

Reference

clsDBInteractionBase Class


clsDBInteractionBase Methods

clsDBInteractionBase Methods

clsDBInteractionBase Methods | Previous topic | Next topic
clsDBInteractionBase Methods | Previous topic | Next topic

Public Methods

 | Name | Description
Supported by the .NET Compact Framework. | Delete |
Supported by the .NET Compact Framework. | Dispose | (Overloaded)
Public method | Equals | (Overloaded) (inherited from Object).
Public method | GetHashCode | (inherited from Object).
Public method | GetType | (Overloaded) (inherited from Object).
Supported by the .NET Compact Framework. | Insert |
 | ReferenceEquals | (inherited from Object).
Supported by the .NET Compact Framework. | SelectAll |
Supported by the .NET Compact Framework. | SelectOne |
Public method | ToString | (inherited from Object).
Supported by the .NET Compact Framework. | Update |

Top

Protected Methods

 | Name | Description
Protected method | Finalize | (inherited from Object).
Protected method | MemberwiseClone | (Overloaded) (inherited from Object).

Top

Private, internal (Friend) and internal protected (Protected Friend) Methods

 | Name | Description
Supported by the .NET Compact Framework. | InitClass |

Top

See Also

Reference

clsDBInteractionBase Class


clsDBInteractionBase.Delete Method

clsDBInteractionBase.Delete Method

clsDBInteractionBase.Delete Method | Previous topic | Next topic
clsDBInteractionBase.Delete Method | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Overridable Function Delete() As Boolean Implements _
ICommonDBAccess.Delete

C#

public virtual bool Delete()

C++

public:
virtual bool Delete()

JScript

public function Delete() : boolean;

Implements

ICommonDBAccess.Delete

Source code

Visual Basic

Copy Code Copy Code

Public Overridable Function Delete() As Boolean Implements ICommonDBAccess.Delete
' // No implementation, throw exception
Throw New NotImplementedException()
End Function

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsDBInteractionBase Class
clsDBInteractionBase clsDBInteractionBase Members


clsDBInteractionBase.InitClass Method

clsDBInteractionBase.InitClass Method

clsDBInteractionBase.InitClass Method | Previous topic | Next topic
clsDBInteractionBase.InitClass Method | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private Sub InitClass()

C#

private System.Void InitClass()

C++

private:
System::Void InitClass()

JScript

private function InitClass();

Source code

Visual Basic

Copy Code Copy Code

Private Sub InitClass()
' // create all the objects and initialize other members.
m_scoMainConnection = new SqlConnection()
m_bMainConnectionIsCreatedLocal = True
m_cpMainConnectionProvider = Nothing
m_iErrorCode = New SqlInt32(LLBLError.AllOk)
m_bIsDisposed = False
End Sub

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsDBInteractionBase Class
clsDBInteractionBase clsDBInteractionBase Members


clsDBInteractionBase.Insert Method

clsDBInteractionBase.Insert Method

clsDBInteractionBase.Insert Method | Previous topic | Next topic
clsDBInteractionBase.Insert Method | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Overridable Function Insert() As Boolean Implements _
ICommonDBAccess.Insert

C#

public virtual bool Insert()

C++

public:
virtual bool Insert()

JScript

public function Insert() : boolean;

Implements

ICommonDBAccess.Insert

Source code

Visual Basic

Copy Code Copy Code

Public Overridable Function Insert() As Boolean Implements ICommonDBAccess.Insert
' // No implementation, throw exception
Throw New NotImplementedException()
End Function

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsDBInteractionBase Class
clsDBInteractionBase clsDBInteractionBase Members


clsDBInteractionBase.SelectAll Method

clsDBInteractionBase.SelectAll Method

clsDBInteractionBase.SelectAll Method | Previous topic | Next topic
clsDBInteractionBase.SelectAll Method | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Overridable Function SelectAll() As DataTable Implements _
ICommonDBAccess.SelectAll

C#

public virtual DataTable SelectAll()

C++

public:
virtual DataTable^ SelectAll()

JScript

public function SelectAll() : DataTable;

Implements

ICommonDBAccess.SelectAll

Source code

Visual Basic

Copy Code Copy Code

Public Overridable Function SelectAll() As DataTable Implements ICommonDBAccess.SelectAll
' // No implementation, throw exception
Throw New NotImplementedException()
End Function

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsDBInteractionBase Class
clsDBInteractionBase clsDBInteractionBase Members


clsDBInteractionBase.SelectOne Method

clsDBInteractionBase.SelectOne Method

clsDBInteractionBase.SelectOne Method | Previous topic | Next topic
clsDBInteractionBase.SelectOne Method | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Overridable Function SelectOne() As DataTable Implements _
ICommonDBAccess.SelectOne

C#

public virtual DataTable SelectOne()

C++

public:
virtual DataTable^ SelectOne()

JScript

public function SelectOne() : DataTable;

Implements

ICommonDBAccess.SelectOne

Source code

Visual Basic

Copy Code Copy Code

Public Overridable Function SelectOne() As DataTable Implements ICommonDBAccess.SelectOne
' // No implementation, throw exception
Throw New NotImplementedException()
End Function

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsDBInteractionBase Class
clsDBInteractionBase clsDBInteractionBase Members


clsDBInteractionBase.Update Method

clsDBInteractionBase.Update Method

clsDBInteractionBase.Update Method | Previous topic | Next topic
clsDBInteractionBase.Update Method | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Overridable Function Update() As Boolean Implements _
ICommonDBAccess.Update

C#

public virtual bool Update()

C++

public:
virtual bool Update()

JScript

public function Update() : boolean;

Implements

ICommonDBAccess.Update

Source code

Visual Basic

Copy Code Copy Code

Public Overridable Function Update() As Boolean Implements ICommonDBAccess.Update
' // No implementation, throw exception
Throw New NotImplementedException()
End Function

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsDBInteractionBase Class
clsDBInteractionBase clsDBInteractionBase Members


clsDBInteractionBase Fields

clsDBInteractionBase Fields

clsDBInteractionBase Fields | Previous topic | Next topic
clsDBInteractionBase Fields | Previous topic | Next topic

Fields

 | Name | Description
Supported by the .NET Compact Framework. | m_bIsDisposed |
Supported by the .NET Compact Framework. | m_bMainConnectionIsCreatedLocal |
Supported by the .NET Compact Framework. | m_cpMainConnectionProvider |
Supported by the .NET Compact Framework. | m_iErrorCode |
Supported by the .NET Compact Framework. | m_sConnectionString |
Supported by the .NET Compact Framework. | m_scoMainConnection |

Top

See Also

Reference

clsDBInteractionBase Class


m_bIsDisposed Field

m_bIsDisposed Field

m_bIsDisposed Field | Previous topic | Next topic
m_bIsDisposed Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_bIsDisposed As Boolean

C#

private bool m_bIsDisposed

C++

private:
bool m_bIsDisposed;

JScript

private m_bIsDisposed : boolean

Source code

Visual Basic

Copy Code Copy Code

Private m_bIsDisposed As Boolean

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsDBInteractionBase Class
clsDBInteractionBase clsDBInteractionBase Members


m_sConnectionString Field

m_sConnectionString Field

m_sConnectionString Field | Previous topic | Next topic
m_sConnectionString Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_sConnectionString As String

C#

private string m_sConnectionString

C++

private:
String^ m_sConnectionString;

JScript

private m_sConnectionString : String

Source code

Visual Basic

Copy Code Copy Code

Private m_sConnectionString As String

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsDBInteractionBase Class
clsDBInteractionBase clsDBInteractionBase Members


clsDokument Class

clsDokument Class

clsDokument Class | Previous topic | Next topic
clsDokument Class | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Class clsDokument
Inherits clsDBInteractionBase

C#

public class clsDokument : clsDBInteractionBase

C++

public ref class clsDokument : public clsDBInteractionBase^

JScript

public class clsDokument
extends clsDBInteractionBase

Inheritance Hierarchy

System.Object

EDKB12WS.edokadb.clsDBInteractionBase

EDKB12WS.edokadb.clsDokument

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsDokument Members


clsDokument Members

clsDokument Members

clsDokument Members | Previous topic | Next topic
clsDokument Members | Previous topic | Next topic

The following tables list the members exposed by the clsDokument type.

Public Constructors

 | Name | Description
Supported by the .NET Compact Framework. | clsDokument Constructor |

Top

Public Properties

 | Name | Description
Supported by the .NET Compact Framework. | bAktiv |
Supported by the .NET Compact Framework. | bAmsdokument |
Supported by the .NET Compact Framework. | bAuserstuebernahme |
Supported by the .NET Compact Framework. | bAusgangsarchiviert |
Supported by the .NET Compact Framework. | bBedRRetourniert |
Supported by the .NET Compact Framework. | bBereit_zur_archivierung |
Supported by the .NET Compact Framework. | bBl_scan |
Supported by the .NET Compact Framework. | bBldossier |
Supported by the .NET Compact Framework. | bEingangsarchiviert |
Supported by the .NET Compact Framework. | bFAStatuswechsel |
Supported by the .NET Compact Framework. | bFAVerantwortlicherwechsel |
Supported by the .NET Compact Framework. | bFapartnerwechsel |
Supported by the .NET Compact Framework. | bGesperrt |
Supported by the .NET Compact Framework. | bOfficedokumentgeloescht |
Supported by the .NET Compact Framework. | bUnvollstaendig |
Supported by the .NET Compact Framework. | bVertraulich |
Supported by the .NET Compact Framework. | bZu_retournieren |
Supported by the .NET Compact Framework. | bZustaendig_kube |
Supported by the .NET Compact Framework. | cpMainConnectionProvider | (inherited from clsDBInteractionBase ).
Supported by the .NET Compact Framework. | daArchivierungsdatum |
Supported by the .NET Compact Framework. | daDatum_ausgangsarchivierung |
Supported by the .NET Compact Framework. | daDatum_eingangsarchivierung |
Supported by the .NET Compact Framework. | daErinnerungam |
Supported by the .NET Compact Framework. | daErstelltam |
Supported by the .NET Compact Framework. | daErstellungsdatum |
Supported by the .NET Compact Framework. | daGesperrtam |
Supported by the .NET Compact Framework. | daMutiertam |
Supported by the .NET Compact Framework. | daTermin |
Supported by the .NET Compact Framework. | iAnzeigeStatus |
Supported by the .NET Compact Framework. | iAufbewahrung_elektronisch |
Supported by the .NET Compact Framework. | iAufbewahrung_phaysisch |
Supported by the .NET Compact Framework. | iBRVernichtungnachTagen |
Supported by the .NET Compact Framework. | iBarcodenr |
Supported by the .NET Compact Framework. | iBck |
Supported by the .NET Compact Framework. | iBearbeitung_nach_abschluss |
Supported by the .NET Compact Framework. | iBearbeitungszeit_in_minuten |
Supported by the .NET Compact Framework. | iColdstatus |
Supported by the .NET Compact Framework. | iDokdurchkubeweitergegeben |
Supported by the .NET Compact Framework. | iDokumenttypnr |
Supported by the .NET Compact Framework. | iErrorCode | (inherited from clsDBInteractionBase ).
Supported by the .NET Compact Framework. | iErsteller |
Supported by the .NET Compact Framework. | iErstellerteam |
Supported by the .NET Compact Framework. | iGesperrt_durch |
Supported by the .NET Compact Framework. | iIn_edoka_datenbank |
Supported by the .NET Compact Framework. | iMa_ausgangsarchivierung |
Supported by the .NET Compact Framework. | iMa_eingangsarchivierung |
Supported by the .NET Compact Framework. | iMitarbeiternr |
Supported by the .NET Compact Framework. | iMitarbeiternr1 |
Supported by the .NET Compact Framework. | iMonierung_in_tagen |
Supported by the .NET Compact Framework. | iMutierer |
Supported by the .NET Compact Framework. | iMutiererteam |
Supported by the .NET Compact Framework. | iMutierertieam |
Supported by the .NET Compact Framework. | iNrpar00 |
Supported by the .NET Compact Framework. | iPostzustellung |
Supported by the .NET Compact Framework. | iStatus_edoka_batch_ausgang |
Supported by the .NET Compact Framework. | iStatus_edoka_batch_eingang |
Supported by the .NET Compact Framework. | iStatusnr |
Supported by the .NET Compact Framework. | iUnterschriftlinks |
Supported by the .NET Compact Framework. | iUnterschriftrechts |
Supported by the .NET Compact Framework. | iVerantwortlich |
Supported by the .NET Compact Framework. | iZustaendiger |
Supported by the .NET Compact Framework. | sAnredezustelladresse |
Supported by the .NET Compact Framework. | sBedRDokumentid |
Supported by the .NET Compact Framework. | sBemerkung |
Supported by the .NET Compact Framework. | sBemerkunguvm |
Supported by the .NET Compact Framework. | sBezeichnung |
Supported by the .NET Compact Framework. | sColddokumentid |
Supported by the .NET Compact Framework. | sColdfolder |
Supported by the .NET Compact Framework. | sColdschema |
Supported by the .NET Compact Framework. | sConnectionString | (inherited from clsDBInteractionBase ).
Supported by the .NET Compact Framework. | sDokumentid |
Supported by the .NET Compact Framework. | sDokumentidn |
Supported by the .NET Compact Framework. | sDokumentname |
Supported by the .NET Compact Framework. | sFANummer1 |
Supported by the .NET Compact Framework. | sFANummer2 |
Supported by the .NET Compact Framework. | sFanummer3 |
Supported by the .NET Compact Framework. | sLoeschgrund |
Supported by the .NET Compact Framework. | sSpeicherort |
Supported by the .NET Compact Framework. | sVersandadresse |
Supported by the .NET Compact Framework. | sVvnr |
Supported by the .NET Compact Framework. | sZustelladresse |

Top

Public Methods

 | Name | Description
Supported by the .NET Compact Framework. | Delete |
Supported by the .NET Compact Framework. | Dispose | (Overloaded) (inherited from clsDBInteractionBase ).
Public method | Equals | (Overloaded) (inherited from Object).
Public method | GetHashCode | (inherited from Object).
Public method | GetType | (Overloaded) (inherited from Object).
Supported by the .NET Compact Framework. | Insert |
 | ReferenceEquals | (inherited from Object).
Supported by the .NET Compact Framework. | SelectAll |
Supported by the .NET Compact Framework. | SelectOne |
Public method | ToString | (inherited from Object).
Supported by the .NET Compact Framework. | Update |

Top

Protected Methods

 | Name | Description
Protected method | Finalize | (inherited from Object).
Protected method | MemberwiseClone | (Overloaded) (inherited from Object).

Top

Fields

 | Name | Description
Supported by the .NET Compact Framework. | m_bAktiv |
Supported by the .NET Compact Framework. | m_bAmsdokument |
Supported by the .NET Compact Framework. | m_bAuserstuebernahme |
Supported by the .NET Compact Framework. | m_bAusgangsarchiviert |
Supported by the .NET Compact Framework. | m_bBedRRetourniert |
Supported by the .NET Compact Framework. | m_bBereit_zur_archivierung |
Supported by the .NET Compact Framework. | m_bBl_scan |
Supported by the .NET Compact Framework. | m_bBldossier |
Supported by the .NET Compact Framework. | m_bEingangsarchiviert |
Supported by the .NET Compact Framework. | m_bFAStatuswechsel |
Supported by the .NET Compact Framework. | m_bFAVerantwortlicherwechsel |
Supported by the .NET Compact Framework. | m_bFapartnerwechsel |
Supported by the .NET Compact Framework. | m_bGesperrt |
Supported by the .NET Compact Framework. | m_bMainConnectionIsCreatedLocal | (inherited from clsDBInteractionBase ).
Supported by the .NET Compact Framework. | m_bOfficedokumentgeloescht |
Supported by the .NET Compact Framework. | m_bUnvollstaendig |
Supported by the .NET Compact Framework. | m_bVertraulich |
Supported by the .NET Compact Framework. | m_bZu_retournieren |
Supported by the .NET Compact Framework. | m_bZustaendig_kube |
Supported by the .NET Compact Framework. | m_cpMainConnectionProvider | (inherited from clsDBInteractionBase ).
Supported by the .NET Compact Framework. | m_daArchivierungsdatum |
Supported by the .NET Compact Framework. | m_daDatum_ausgangsarchivierung |
Supported by the .NET Compact Framework. | m_daDatum_eingangsarchivierung |
Supported by the .NET Compact Framework. | m_daErinnerungam |
Supported by the .NET Compact Framework. | m_daErstelltam |
Supported by the .NET Compact Framework. | m_daErstellungsdatum |
Supported by the .NET Compact Framework. | m_daGesperrtam |
Supported by the .NET Compact Framework. | m_daMutiertam |
Supported by the .NET Compact Framework. | m_daTermin |
Supported by the .NET Compact Framework. | m_iAnzeigeStatus |
Supported by the .NET Compact Framework. | m_iAufbewahrung_elektronisch |
Supported by the .NET Compact Framework. | m_iAufbewahrung_phaysisch |
Supported by the .NET Compact Framework. | m_iBRVernichtungnachTagen |
Supported by the .NET Compact Framework. | m_iBarcodenr |
Supported by the .NET Compact Framework. | m_iBck |
Supported by the .NET Compact Framework. | m_iBearbeitung_nach_abschluss |
Supported by the .NET Compact Framework. | m_iBearbeitungszeit_in_minuten |
Supported by the .NET Compact Framework. | m_iColdstatus |
Supported by the .NET Compact Framework. | m_iDokdurchkubeweitergegeben |
Supported by the .NET Compact Framework. | m_iDokumenttypnr |
Supported by the .NET Compact Framework. | m_iErrorCode | (inherited from clsDBInteractionBase ).
Supported by the .NET Compact Framework. | m_iErsteller |
Supported by the .NET Compact Framework. | m_iErstellerteam |
Supported by the .NET Compact Framework. | m_iGesperrt_durch |
Supported by the .NET Compact Framework. | m_iIn_edoka_datenbank |
Supported by the .NET Compact Framework. | m_iMa_ausgangsarchivierung |
Supported by the .NET Compact Framework. | m_iMa_eingangsarchivierung |
Supported by the .NET Compact Framework. | m_iMitarbeiternr |
Supported by the .NET Compact Framework. | m_iMitarbeiternr1 |
Supported by the .NET Compact Framework. | m_iMonierung_in_tagen |
Supported by the .NET Compact Framework. | m_iMutierer |
Supported by the .NET Compact Framework. | m_iMutiererteam |
Supported by the .NET Compact Framework. | m_iMutierertieam |
Supported by the .NET Compact Framework. | m_iNrpar00 |
Supported by the .NET Compact Framework. | m_iPostzustellung |
Supported by the .NET Compact Framework. | m_iStatus_edoka_batch_ausgang |
Supported by the .NET Compact Framework. | m_iStatus_edoka_batch_eingang |
Supported by the .NET Compact Framework. | m_iStatusnr |
Supported by the .NET Compact Framework. | m_iUnterschriftlinks |
Supported by the .NET Compact Framework. | m_iUnterschriftrechts |
Supported by the .NET Compact Framework. | m_iVerantwortlich |
Supported by the .NET Compact Framework. | m_iZustaendiger |
Supported by the .NET Compact Framework. | m_sAnredezustelladresse |
Supported by the .NET Compact Framework. | m_sBedRDokumentid |
Supported by the .NET Compact Framework. | m_sBemerkung |
Supported by the .NET Compact Framework. | m_sBemerkunguvm |
Supported by the .NET Compact Framework. | m_sBezeichnung |
Supported by the .NET Compact Framework. | m_sColddokumentid |
Supported by the .NET Compact Framework. | m_sColdfolder |
Supported by the .NET Compact Framework. | m_sColdschema |
Supported by the .NET Compact Framework. | m_sDokumentid |
Supported by the .NET Compact Framework. | m_sDokumentidn |
Supported by the .NET Compact Framework. | m_sDokumentname |
Supported by the .NET Compact Framework. | m_sFANummer1 |
Supported by the .NET Compact Framework. | m_sFANummer2 |
Supported by the .NET Compact Framework. | m_sFanummer3 |
Supported by the .NET Compact Framework. | m_sLoeschgrund |
Supported by the .NET Compact Framework. | m_sSpeicherort |
Supported by the .NET Compact Framework. | m_sVersandadresse |
Supported by the .NET Compact Framework. | m_sVvnr |
Supported by the .NET Compact Framework. | m_sZustelladresse |
Supported by the .NET Compact Framework. | m_scoMainConnection | (inherited from clsDBInteractionBase ).

Top

See Also

Reference

clsDokument Class


clsDokument Constructor

clsDokument Constructor

clsDokument Constructor | Previous topic | Next topic
clsDokument Constructor | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Sub New()

C#

public clsDokument()

C++

public:
clsDokument()

JScript

public function clsDokument();

Source code

Visual Basic

Copy Code Copy Code

Public Sub New()
' // Nothing for now.
End Sub

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsDokument Class
clsDokument clsDokument Members


clsDokument Properties

clsDokument Properties

clsDokument Properties | Previous topic | Next topic
clsDokument Properties | Previous topic | Next topic

Public Properties

 | Name | Description
Supported by the .NET Compact Framework. | bAktiv |
Supported by the .NET Compact Framework. | bAmsdokument |
Supported by the .NET Compact Framework. | bAuserstuebernahme |
Supported by the .NET Compact Framework. | bAusgangsarchiviert |
Supported by the .NET Compact Framework. | bBedRRetourniert |
Supported by the .NET Compact Framework. | bBereit_zur_archivierung |
Supported by the .NET Compact Framework. | bBl_scan |
Supported by the .NET Compact Framework. | bBldossier |
Supported by the .NET Compact Framework. | bEingangsarchiviert |
Supported by the .NET Compact Framework. | bFAStatuswechsel |
Supported by the .NET Compact Framework. | bFAVerantwortlicherwechsel |
Supported by the .NET Compact Framework. | bFapartnerwechsel |
Supported by the .NET Compact Framework. | bGesperrt |
Supported by the .NET Compact Framework. | bOfficedokumentgeloescht |
Supported by the .NET Compact Framework. | bUnvollstaendig |
Supported by the .NET Compact Framework. | bVertraulich |
Supported by the .NET Compact Framework. | bZu_retournieren |
Supported by the .NET Compact Framework. | bZustaendig_kube |
Supported by the .NET Compact Framework. | cpMainConnectionProvider | (inherited from clsDBInteractionBase ).
Supported by the .NET Compact Framework. | daArchivierungsdatum |
Supported by the .NET Compact Framework. | daDatum_ausgangsarchivierung |
Supported by the .NET Compact Framework. | daDatum_eingangsarchivierung |
Supported by the .NET Compact Framework. | daErinnerungam |
Supported by the .NET Compact Framework. | daErstelltam |
Supported by the .NET Compact Framework. | daErstellungsdatum |
Supported by the .NET Compact Framework. | daGesperrtam |
Supported by the .NET Compact Framework. | daMutiertam |
Supported by the .NET Compact Framework. | daTermin |
Supported by the .NET Compact Framework. | iAnzeigeStatus |
Supported by the .NET Compact Framework. | iAufbewahrung_elektronisch |
Supported by the .NET Compact Framework. | iAufbewahrung_phaysisch |
Supported by the .NET Compact Framework. | iBRVernichtungnachTagen |
Supported by the .NET Compact Framework. | iBarcodenr |
Supported by the .NET Compact Framework. | iBck |
Supported by the .NET Compact Framework. | iBearbeitung_nach_abschluss |
Supported by the .NET Compact Framework. | iBearbeitungszeit_in_minuten |
Supported by the .NET Compact Framework. | iColdstatus |
Supported by the .NET Compact Framework. | iDokdurchkubeweitergegeben |
Supported by the .NET Compact Framework. | iDokumenttypnr |
Supported by the .NET Compact Framework. | iErrorCode | (inherited from clsDBInteractionBase ).
Supported by the .NET Compact Framework. | iErsteller |
Supported by the .NET Compact Framework. | iErstellerteam |
Supported by the .NET Compact Framework. | iGesperrt_durch |
Supported by the .NET Compact Framework. | iIn_edoka_datenbank |
Supported by the .NET Compact Framework. | iMa_ausgangsarchivierung |
Supported by the .NET Compact Framework. | iMa_eingangsarchivierung |
Supported by the .NET Compact Framework. | iMitarbeiternr |
Supported by the .NET Compact Framework. | iMitarbeiternr1 |
Supported by the .NET Compact Framework. | iMonierung_in_tagen |
Supported by the .NET Compact Framework. | iMutierer |
Supported by the .NET Compact Framework. | iMutiererteam |
Supported by the .NET Compact Framework. | iMutierertieam |
Supported by the .NET Compact Framework. | iNrpar00 |
Supported by the .NET Compact Framework. | iPostzustellung |
Supported by the .NET Compact Framework. | iStatus_edoka_batch_ausgang |
Supported by the .NET Compact Framework. | iStatus_edoka_batch_eingang |
Supported by the .NET Compact Framework. | iStatusnr |
Supported by the .NET Compact Framework. | iUnterschriftlinks |
Supported by the .NET Compact Framework. | iUnterschriftrechts |
Supported by the .NET Compact Framework. | iVerantwortlich |
Supported by the .NET Compact Framework. | iZustaendiger |
Supported by the .NET Compact Framework. | sAnredezustelladresse |
Supported by the .NET Compact Framework. | sBedRDokumentid |
Supported by the .NET Compact Framework. | sBemerkung |
Supported by the .NET Compact Framework. | sBemerkunguvm |
Supported by the .NET Compact Framework. | sBezeichnung |
Supported by the .NET Compact Framework. | sColddokumentid |
Supported by the .NET Compact Framework. | sColdfolder |
Supported by the .NET Compact Framework. | sColdschema |
Supported by the .NET Compact Framework. | sConnectionString | (inherited from clsDBInteractionBase ).
Supported by the .NET Compact Framework. | sDokumentid |
Supported by the .NET Compact Framework. | sDokumentidn |
Supported by the .NET Compact Framework. | sDokumentname |
Supported by the .NET Compact Framework. | sFANummer1 |
Supported by the .NET Compact Framework. | sFANummer2 |
Supported by the .NET Compact Framework. | sFanummer3 |
Supported by the .NET Compact Framework. | sLoeschgrund |
Supported by the .NET Compact Framework. | sSpeicherort |
Supported by the .NET Compact Framework. | sVersandadresse |
Supported by the .NET Compact Framework. | sVvnr |
Supported by the .NET Compact Framework. | sZustelladresse |

Top

See Also

Reference

clsDokument Class


clsDokument.bAktiv Property

clsDokument.bAktiv Property

clsDokument.bAktiv Property | Previous topic | Next topic
clsDokument.bAktiv Property | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property bAktiv() As SqlBoolean

C#

public SqlBoolean bAktiv {get; set;}

C++

public:
property SqlBoolean bAktiv {
SqlBoolean get( );
void set(
SqlBoolean value
);
}

JScript

public function get bAktiv() : SqlBoolean;
public function set bAktiv(value : SqlBoolean);

Source code

Visual Basic

Copy Code Copy Code

Public Property [bAktiv]() As SqlBoolean
Get
Return m_bAktiv
End Get
Set(ByVal Value As SqlBoolean)
m_bAktiv = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsDokument Class
clsDokument clsDokument Members


clsDokument.bAmsdokument Property

clsDokument.bAmsdokument Property

clsDokument.bAmsdokument Property | Previous topic | Next topic
clsDokument.bAmsdokument Property | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property bAmsdokument() As SqlBoolean

C#

public SqlBoolean bAmsdokument {get; set;}

C++

public:
property SqlBoolean bAmsdokument {
SqlBoolean get( );
void set(
SqlBoolean value
);
}

JScript

public function get bAmsdokument() : SqlBoolean;
public function set bAmsdokument(value : SqlBoolean);

Source code

Visual Basic

Copy Code Copy Code

Public Property [bAmsdokument]() As SqlBoolean
Get
Return m_bAmsdokument
End Get
Set(ByVal Value As SqlBoolean)
m_bAmsdokument = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsDokument Class
clsDokument clsDokument Members


clsDokument.bAuserstuebernahme Property

clsDokument.bAuserstuebernahme Property

clsDokument.bAuserstuebernahme Property | Previous topic | Next topic
clsDokument.bAuserstuebernahme Property | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property bAuserstuebernahme() As SqlBoolean

C#

public SqlBoolean bAuserstuebernahme {get; set;}

C++

public:
property SqlBoolean bAuserstuebernahme {
SqlBoolean get( );
void set(
SqlBoolean value
);
}

JScript

public function get bAuserstuebernahme() : SqlBoolean;
public function set bAuserstuebernahme(value : SqlBoolean);

Source code

Visual Basic

Copy Code Copy Code

Public Property [bAuserstuebernahme]() As SqlBoolean
Get
Return m_bAuserstuebernahme
End Get
Set(ByVal Value As SqlBoolean)
m_bAuserstuebernahme = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsDokument Class
clsDokument clsDokument Members


clsDokument.bAusgangsarchiviert Property

clsDokument.bAusgangsarchiviert Property

clsDokument.bAusgangsarchiviert Property | Previous topic | Next topic
clsDokument.bAusgangsarchiviert Property | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property bAusgangsarchiviert() As SqlBoolean

C#

public SqlBoolean bAusgangsarchiviert {get; set;}

C++

public:
property SqlBoolean bAusgangsarchiviert {
SqlBoolean get( );
void set(
SqlBoolean value
);
}

JScript

public function get bAusgangsarchiviert() : SqlBoolean;
public function set bAusgangsarchiviert(value : SqlBoolean);

Source code

Visual Basic

Copy Code Copy Code

Public Property [bAusgangsarchiviert]() As SqlBoolean
Get
Return m_bAusgangsarchiviert
End Get
Set(ByVal Value As SqlBoolean)
m_bAusgangsarchiviert = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsDokument Class
clsDokument clsDokument Members


clsDokument.bBedRRetourniert Property

clsDokument.bBedRRetourniert Property

clsDokument.bBedRRetourniert Property | Previous topic | Next topic
clsDokument.bBedRRetourniert Property | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property bBedRRetourniert() As SqlBoolean

C#

public SqlBoolean bBedRRetourniert {get; set;}

C++

public:
property SqlBoolean bBedRRetourniert {
SqlBoolean get( );
void set(
SqlBoolean value
);
}

JScript

public function get bBedRRetourniert() : SqlBoolean;
public function set bBedRRetourniert(value : SqlBoolean);

Source code

Visual Basic

Copy Code Copy Code

Public Property [bBedRRetourniert]() As SqlBoolean
Get
Return m_bBedRRetourniert
End Get
Set(ByVal Value As SqlBoolean)
m_bBedRRetourniert = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsDokument Class
clsDokument clsDokument Members


clsDokument.bBereit_zur_archivierung Property

clsDokument.bBereit_zur_archivierung Property

clsDokument.bBereit_zur_archivierung Property | Previous topic | Next topic
clsDokument.bBereit_zur_archivierung Property | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property bBereit_zur_archivierung() As SqlBoolean

C#

public SqlBoolean bBereit_zur_archivierung {get; set;}

C++

public:
property SqlBoolean bBereit_zur_archivierung {
SqlBoolean get( );
void set(
SqlBoolean value
);
}

JScript

public function get bBereit_zur_archivierung() : SqlBoolean;
public function set bBereit_zur_archivierung(value : SqlBoolean);

Source code

Visual Basic

Copy Code Copy Code

Public Property [bBereit_zur_archivierung]() As SqlBoolean
Get
Return m_bBereit_zur_archivierung
End Get
Set(ByVal Value As SqlBoolean)
m_bBereit_zur_archivierung = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsDokument Class
clsDokument clsDokument Members


clsDokument.bBl_scan Property

clsDokument.bBl_scan Property

clsDokument.bBl_scan Property | Previous topic | Next topic
clsDokument.bBl_scan Property | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property bBl_scan() As SqlBoolean

C#

public SqlBoolean bBl_scan {get; set;}

C++

public:
property SqlBoolean bBl_scan {
SqlBoolean get( );
void set(
SqlBoolean value
);
}

JScript

public function get bBl_scan() : SqlBoolean;
public function set bBl_scan(value : SqlBoolean);

Source code

Visual Basic

Copy Code Copy Code

Public Property [bBl_scan]() As SqlBoolean
Get
Return m_bBl_scan
End Get
Set(ByVal Value As SqlBoolean)
m_bBl_scan = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsDokument Class
clsDokument clsDokument Members


clsDokument.bBldossier Property

clsDokument.bBldossier Property

clsDokument.bBldossier Property | Previous topic | Next topic
clsDokument.bBldossier Property | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property bBldossier() As SqlBoolean

C#

public SqlBoolean bBldossier {get; set;}

C++

public:
property SqlBoolean bBldossier {
SqlBoolean get( );
void set(
SqlBoolean value
);
}

JScript

public function get bBldossier() : SqlBoolean;
public function set bBldossier(value : SqlBoolean);

Source code

Visual Basic

Copy Code Copy Code

Public Property [bBldossier]() As SqlBoolean
Get
Return m_bBldossier
End Get
Set(ByVal Value As SqlBoolean)
m_bBldossier = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsDokument Class
clsDokument clsDokument Members


clsDokument.bEingangsarchiviert Property

clsDokument.bEingangsarchiviert Property

clsDokument.bEingangsarchiviert Property | Previous topic | Next topic
clsDokument.bEingangsarchiviert Property | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property bEingangsarchiviert() As SqlBoolean

C#

public SqlBoolean bEingangsarchiviert {get; set;}

C++

public:
property SqlBoolean bEingangsarchiviert {
SqlBoolean get( );
void set(
SqlBoolean value
);
}

JScript

public function get bEingangsarchiviert() : SqlBoolean;
public function set bEingangsarchiviert(value : SqlBoolean);

Source code

Visual Basic

Copy Code Copy Code

Public Property [bEingangsarchiviert]() As SqlBoolean
Get
Return m_bEingangsarchiviert
End Get
Set(ByVal Value As SqlBoolean)
m_bEingangsarchiviert = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsDokument Class
clsDokument clsDokument Members


clsDokument.bFAStatuswechsel Property

clsDokument.bFAStatuswechsel Property

clsDokument.bFAStatuswechsel Property | Previous topic | Next topic
clsDokument.bFAStatuswechsel Property | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property bFAStatuswechsel() As SqlBoolean

C#

public SqlBoolean bFAStatuswechsel {get; set;}

C++

public:
property SqlBoolean bFAStatuswechsel {
SqlBoolean get( );
void set(
SqlBoolean value
);
}

JScript

public function get bFAStatuswechsel() : SqlBoolean;
public function set bFAStatuswechsel(value : SqlBoolean);

Source code

Visual Basic

Copy Code Copy Code

Public Property [bFAStatuswechsel]() As SqlBoolean
Get
Return m_bFAStatuswechsel
End Get
Set(ByVal Value As SqlBoolean)
m_bFAStatuswechsel = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsDokument Class
clsDokument clsDokument Members


clsDokument.bFAVerantwortlicherwechsel Property

clsDokument.bFAVerantwortlicherwechsel Property

clsDokument.bFAVerantwortlicherwechsel Property | Previous topic | Next topic
clsDokument.bFAVerantwortlicherwechsel Property | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property bFAVerantwortlicherwechsel() As SqlBoolean

C#

public SqlBoolean bFAVerantwortlicherwechsel {get; set;}

C++

public:
property SqlBoolean bFAVerantwortlicherwechsel {
SqlBoolean get( );
void set(
SqlBoolean value
);
}

JScript

public function get bFAVerantwortlicherwechsel() : SqlBoolean;
public function set bFAVerantwortlicherwechsel(value : SqlBoolean);

Source code

Visual Basic

Copy Code Copy Code

Public Property [bFAVerantwortlicherwechsel]() As SqlBoolean
Get
Return m_bFAVerantwortlicherwechsel
End Get
Set(ByVal Value As SqlBoolean)
m_bFAVerantwortlicherwechsel = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsDokument Class
clsDokument clsDokument Members


clsDokument.bFapartnerwechsel Property

clsDokument.bFapartnerwechsel Property

clsDokument.bFapartnerwechsel Property | Previous topic | Next topic
clsDokument.bFapartnerwechsel Property | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property bFapartnerwechsel() As SqlBoolean

C#

public SqlBoolean bFapartnerwechsel {get; set;}

C++

public:
property SqlBoolean bFapartnerwechsel {
SqlBoolean get( );
void set(
SqlBoolean value
);
}

JScript

public function get bFapartnerwechsel() : SqlBoolean;
public function set bFapartnerwechsel(value : SqlBoolean);

Source code

Visual Basic

Copy Code Copy Code

Public Property [bFapartnerwechsel]() As SqlBoolean
Get
Return m_bFapartnerwechsel
End Get
Set(ByVal Value As SqlBoolean)
m_bFapartnerwechsel = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsDokument Class
clsDokument clsDokument Members


clsDokument.bGesperrt Property

clsDokument.bGesperrt Property

clsDokument.bGesperrt Property | Previous topic | Next topic
clsDokument.bGesperrt Property | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property bGesperrt() As SqlBoolean

C#

public SqlBoolean bGesperrt {get; set;}

C++

public:
property SqlBoolean bGesperrt {
SqlBoolean get( );
void set(
SqlBoolean value
);
}

JScript

public function get bGesperrt() : SqlBoolean;
public function set bGesperrt(value : SqlBoolean);

Source code

Visual Basic

Copy Code Copy Code

Public Property [bGesperrt]() As SqlBoolean
Get
Return m_bGesperrt
End Get
Set(ByVal Value As SqlBoolean)
m_bGesperrt = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsDokument Class
clsDokument clsDokument Members


clsDokument.bOfficedokumentgeloescht Property

clsDokument.bOfficedokumentgeloescht Property

clsDokument.bOfficedokumentgeloescht Property | Previous topic | Next topic
clsDokument.bOfficedokumentgeloescht Property | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property bOfficedokumentgeloescht() As SqlBoolean

C#

public SqlBoolean bOfficedokumentgeloescht {get; set;}

C++

public:
property SqlBoolean bOfficedokumentgeloescht {
SqlBoolean get( );
void set(
SqlBoolean value
);
}

JScript

public function get bOfficedokumentgeloescht() : SqlBoolean;
public function set bOfficedokumentgeloescht(value : SqlBoolean);

Source code

Visual Basic

Copy Code Copy Code

Public Property [bOfficedokumentgeloescht]() As SqlBoolean
Get
Return m_bOfficedokumentgeloescht
End Get
Set(ByVal Value As SqlBoolean)
m_bOfficedokumentgeloescht = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsDokument Class
clsDokument clsDokument Members


clsDokument.bUnvollstaendig Property

clsDokument.bUnvollstaendig Property

clsDokument.bUnvollstaendig Property | Previous topic | Next topic
clsDokument.bUnvollstaendig Property | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property bUnvollstaendig() As SqlBoolean

C#

public SqlBoolean bUnvollstaendig {get; set;}

C++

public:
property SqlBoolean bUnvollstaendig {
SqlBoolean get( );
void set(
SqlBoolean value
);
}

JScript

public function get bUnvollstaendig() : SqlBoolean;
public function set bUnvollstaendig(value : SqlBoolean);

Source code

Visual Basic

Copy Code Copy Code

Public Property [bUnvollstaendig]() As SqlBoolean
Get
Return m_bUnvollstaendig
End Get
Set(ByVal Value As SqlBoolean)
m_bUnvollstaendig = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsDokument Class
clsDokument clsDokument Members


clsDokument.bVertraulich Property

clsDokument.bVertraulich Property

clsDokument.bVertraulich Property | Previous topic | Next topic
clsDokument.bVertraulich Property | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property bVertraulich() As SqlBoolean

C#

public SqlBoolean bVertraulich {get; set;}

C++

public:
property SqlBoolean bVertraulich {
SqlBoolean get( );
void set(
SqlBoolean value
);
}

JScript

public function get bVertraulich() : SqlBoolean;
public function set bVertraulich(value : SqlBoolean);

Source code

Visual Basic

Copy Code Copy Code

Public Property [bVertraulich]() As SqlBoolean
Get
Return m_bVertraulich
End Get
Set(ByVal Value As SqlBoolean)
m_bVertraulich = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsDokument Class
clsDokument clsDokument Members


clsDokument.bZu_retournieren Property

clsDokument.bZu_retournieren Property

clsDokument.bZu_retournieren Property | Previous topic | Next topic
clsDokument.bZu_retournieren Property | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property bZu_retournieren() As SqlBoolean

C#

public SqlBoolean bZu_retournieren {get; set;}

C++

public:
property SqlBoolean bZu_retournieren {
SqlBoolean get( );
void set(
SqlBoolean value
);
}

JScript

public function get bZu_retournieren() : SqlBoolean;
public function set bZu_retournieren(value : SqlBoolean);

Source code

Visual Basic

Copy Code Copy Code

Public Property [bZu_retournieren]() As SqlBoolean
Get
Return m_bZu_retournieren
End Get
Set(ByVal Value As SqlBoolean)
m_bZu_retournieren = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsDokument Class
clsDokument clsDokument Members


clsDokument.bZustaendig_kube Property

clsDokument.bZustaendig_kube Property

clsDokument.bZustaendig_kube Property | Previous topic | Next topic
clsDokument.bZustaendig_kube Property | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property bZustaendig_kube() As SqlBoolean

C#

public SqlBoolean bZustaendig_kube {get; set;}

C++

public:
property SqlBoolean bZustaendig_kube {
SqlBoolean get( );
void set(
SqlBoolean value
);
}

JScript

public function get bZustaendig_kube() : SqlBoolean;
public function set bZustaendig_kube(value : SqlBoolean);

Source code

Visual Basic

Copy Code Copy Code

Public Property [bZustaendig_kube]() As SqlBoolean
Get
Return m_bZustaendig_kube
End Get
Set(ByVal Value As SqlBoolean)
m_bZustaendig_kube = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsDokument Class
clsDokument clsDokument Members


clsDokument.daArchivierungsdatum Property

clsDokument.daArchivierungsdatum Property

clsDokument.daArchivierungsdatum Property | Previous topic | Next topic
clsDokument.daArchivierungsdatum Property | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property daArchivierungsdatum() As SqlDateTime

C#

public SqlDateTime daArchivierungsdatum {get; set;}

C++

public:
property SqlDateTime daArchivierungsdatum {
SqlDateTime get( );
void set(
SqlDateTime value
);
}

JScript

public function get daArchivierungsdatum() : SqlDateTime;
public function set daArchivierungsdatum(value : SqlDateTime);

Source code

Visual Basic

Copy Code Copy Code

Public Property [daArchivierungsdatum]() As SqlDateTime
Get
Return m_daArchivierungsdatum
End Get
Set(ByVal Value As SqlDateTime)
m_daArchivierungsdatum = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsDokument Class
clsDokument clsDokument Members


clsDokument.daDatum_ausgangsarchivierung Property

clsDokument.daDatum_ausgangsarchivierung Property

clsDokument.daDatum_ausgangsarchivierung Property | Previous topic | Next topic
clsDokument.daDatum_ausgangsarchivierung Property | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property daDatum_ausgangsarchivierung() As SqlDateTime

C#

public SqlDateTime daDatum_ausgangsarchivierung {get; set;}

C++

public:
property SqlDateTime daDatum_ausgangsarchivierung {
SqlDateTime get( );
void set(
SqlDateTime value
);
}

JScript

public function get daDatum_ausgangsarchivierung() : SqlDateTime;
public function set daDatum_ausgangsarchivierung(value : SqlDateTime);

Source code

Visual Basic

Copy Code Copy Code

Public Property [daDatum_ausgangsarchivierung]() As SqlDateTime
Get
Return m_daDatum_ausgangsarchivierung
End Get
Set(ByVal Value As SqlDateTime)
m_daDatum_ausgangsarchivierung = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsDokument Class
clsDokument clsDokument Members


clsDokument.daDatum_eingangsarchivierung Property

clsDokument.daDatum_eingangsarchivierung Property

clsDokument.daDatum_eingangsarchivierung Property | Previous topic | Next topic
clsDokument.daDatum_eingangsarchivierung Property | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property daDatum_eingangsarchivierung() As SqlDateTime

C#

public SqlDateTime daDatum_eingangsarchivierung {get; set;}

C++

public:
property SqlDateTime daDatum_eingangsarchivierung {
SqlDateTime get( );
void set(
SqlDateTime value
);
}

JScript

public function get daDatum_eingangsarchivierung() : SqlDateTime;
public function set daDatum_eingangsarchivierung(value : SqlDateTime);

Source code

Visual Basic

Copy Code Copy Code

Public Property [daDatum_eingangsarchivierung]() As SqlDateTime
Get
Return m_daDatum_eingangsarchivierung
End Get
Set(ByVal Value As SqlDateTime)
m_daDatum_eingangsarchivierung = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsDokument Class
clsDokument clsDokument Members


clsDokument.daErinnerungam Property

clsDokument.daErinnerungam Property

clsDokument.daErinnerungam Property | Previous topic | Next topic
clsDokument.daErinnerungam Property | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property daErinnerungam() As SqlDateTime

C#

public SqlDateTime daErinnerungam {get; set;}

C++

public:
property SqlDateTime daErinnerungam {
SqlDateTime get( );
void set(
SqlDateTime value
);
}

JScript

public function get daErinnerungam() : SqlDateTime;
public function set daErinnerungam(value : SqlDateTime);

Source code

Visual Basic

Copy Code Copy Code

Public Property [daErinnerungam]() As SqlDateTime
Get
Return m_daErinnerungam
End Get
Set(ByVal Value As SqlDateTime)
m_daErinnerungam = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsDokument Class
clsDokument clsDokument Members


clsDokument.daErstelltam Property

clsDokument.daErstelltam Property

clsDokument.daErstelltam Property | Previous topic | Next topic
clsDokument.daErstelltam Property | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property daErstelltam() As SqlDateTime

C#

public SqlDateTime daErstelltam {get; set;}

C++

public:
property SqlDateTime daErstelltam {
SqlDateTime get( );
void set(
SqlDateTime value
);
}

JScript

public function get daErstelltam() : SqlDateTime;
public function set daErstelltam(value : SqlDateTime);

Source code

Visual Basic

Copy Code Copy Code

Public Property [daErstelltam]() As SqlDateTime
Get
Return m_daErstelltam
End Get
Set(ByVal Value As SqlDateTime)
m_daErstelltam = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsDokument Class
clsDokument clsDokument Members


clsDokument.daErstellungsdatum Property

clsDokument.daErstellungsdatum Property

clsDokument.daErstellungsdatum Property | Previous topic | Next topic
clsDokument.daErstellungsdatum Property | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property daErstellungsdatum() As SqlDateTime

C#

public SqlDateTime daErstellungsdatum {get; set;}

C++

public:
property SqlDateTime daErstellungsdatum {
SqlDateTime get( );
void set(
SqlDateTime value
);
}

JScript

public function get daErstellungsdatum() : SqlDateTime;
public function set daErstellungsdatum(value : SqlDateTime);

Source code

Visual Basic

Copy Code Copy Code

Public Property [daErstellungsdatum]() As SqlDateTime
Get
Return m_daErstellungsdatum
End Get
Set(ByVal Value As SqlDateTime)
m_daErstellungsdatum = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsDokument Class
clsDokument clsDokument Members


clsDokument.daGesperrtam Property

clsDokument.daGesperrtam Property

clsDokument.daGesperrtam Property | Previous topic | Next topic
clsDokument.daGesperrtam Property | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property daGesperrtam() As SqlDateTime

C#

public SqlDateTime daGesperrtam {get; set;}

C++

public:
property SqlDateTime daGesperrtam {
SqlDateTime get( );
void set(
SqlDateTime value
);
}

JScript

public function get daGesperrtam() : SqlDateTime;
public function set daGesperrtam(value : SqlDateTime);

Source code

Visual Basic

Copy Code Copy Code

Public Property [daGesperrtam]() As SqlDateTime
Get
Return m_daGesperrtam
End Get
Set(ByVal Value As SqlDateTime)
m_daGesperrtam = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsDokument Class
clsDokument clsDokument Members


clsDokument.daMutiertam Property

clsDokument.daMutiertam Property

clsDokument.daMutiertam Property | Previous topic | Next topic
clsDokument.daMutiertam Property | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property daMutiertam() As SqlDateTime

C#

public SqlDateTime daMutiertam {get; set;}

C++

public:
property SqlDateTime daMutiertam {
SqlDateTime get( );
void set(
SqlDateTime value
);
}

JScript

public function get daMutiertam() : SqlDateTime;
public function set daMutiertam(value : SqlDateTime);

Source code

Visual Basic

Copy Code Copy Code

Public Property [daMutiertam]() As SqlDateTime
Get
Return m_daMutiertam
End Get
Set(ByVal Value As SqlDateTime)
m_daMutiertam = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsDokument Class
clsDokument clsDokument Members


clsDokument.daTermin Property

clsDokument.daTermin Property

clsDokument.daTermin Property | Previous topic | Next topic
clsDokument.daTermin Property | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property daTermin() As SqlDateTime

C#

public SqlDateTime daTermin {get; set;}

C++

public:
property SqlDateTime daTermin {
SqlDateTime get( );
void set(
SqlDateTime value
);
}

JScript

public function get daTermin() : SqlDateTime;
public function set daTermin(value : SqlDateTime);

Source code

Visual Basic

Copy Code Copy Code

Public Property [daTermin]() As SqlDateTime
Get
Return m_daTermin
End Get
Set(ByVal Value As SqlDateTime)
m_daTermin = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsDokument Class
clsDokument clsDokument Members


clsDokument.iAnzeigeStatus Property

clsDokument.iAnzeigeStatus Property

clsDokument.iAnzeigeStatus Property | Previous topic | Next topic
clsDokument.iAnzeigeStatus Property | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property iAnzeigeStatus() As SqlInt32

C#

public SqlInt32 iAnzeigeStatus {get; set;}

C++

public:
property SqlInt32 iAnzeigeStatus {
SqlInt32 get( );
void set(
SqlInt32 value
);
}

JScript

public function get iAnzeigeStatus() : SqlInt32;
public function set iAnzeigeStatus(value : SqlInt32);

Source code

Visual Basic

Copy Code Copy Code

Public Property [iAnzeigeStatus]() As SqlInt32
Get
Return m_iAnzeigeStatus
End Get
Set(ByVal Value As SqlInt32)
m_iAnzeigeStatus = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsDokument Class
clsDokument clsDokument Members


clsDokument.iAufbewahrung_elektronisch Property

clsDokument.iAufbewahrung_elektronisch Property

clsDokument.iAufbewahrung_elektronisch Property | Previous topic | Next topic
clsDokument.iAufbewahrung_elektronisch Property | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property iAufbewahrung_elektronisch() As SqlInt32

C#

public SqlInt32 iAufbewahrung_elektronisch {get; set;}

C++

public:
property SqlInt32 iAufbewahrung_elektronisch {
SqlInt32 get( );
void set(
SqlInt32 value
);
}

JScript

public function get iAufbewahrung_elektronisch() : SqlInt32;
public function set iAufbewahrung_elektronisch(value : SqlInt32);

Source code

Visual Basic

Copy Code Copy Code

Public Property [iAufbewahrung_elektronisch]() As SqlInt32
Get
Return m_iAufbewahrung_elektronisch
End Get
Set(ByVal Value As SqlInt32)
m_iAufbewahrung_elektronisch = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsDokument Class
clsDokument clsDokument Members


clsDokument.iAufbewahrung_phaysisch Property

clsDokument.iAufbewahrung_phaysisch Property

clsDokument.iAufbewahrung_phaysisch Property | Previous topic | Next topic
clsDokument.iAufbewahrung_phaysisch Property | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property iAufbewahrung_phaysisch() As SqlInt32

C#

public SqlInt32 iAufbewahrung_phaysisch {get; set;}

C++

public:
property SqlInt32 iAufbewahrung_phaysisch {
SqlInt32 get( );
void set(
SqlInt32 value
);
}

JScript

public function get iAufbewahrung_phaysisch() : SqlInt32;
public function set iAufbewahrung_phaysisch(value : SqlInt32);

Source code

Visual Basic

Copy Code Copy Code

Public Property [iAufbewahrung_phaysisch]() As SqlInt32
Get
Return m_iAufbewahrung_phaysisch
End Get
Set(ByVal Value As SqlInt32)
m_iAufbewahrung_phaysisch = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsDokument Class
clsDokument clsDokument Members


clsDokument.iBRVernichtungnachTagen Property

clsDokument.iBRVernichtungnachTagen Property

clsDokument.iBRVernichtungnachTagen Property | Previous topic | Next topic
clsDokument.iBRVernichtungnachTagen Property | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property iBRVernichtungnachTagen() As SqlInt32

C#

public SqlInt32 iBRVernichtungnachTagen {get; set;}

C++

public:
property SqlInt32 iBRVernichtungnachTagen {
SqlInt32 get( );
void set(
SqlInt32 value
);
}

JScript

public function get iBRVernichtungnachTagen() : SqlInt32;
public function set iBRVernichtungnachTagen(value : SqlInt32);

Source code

Visual Basic

Copy Code Copy Code

Public Property [iBRVernichtungnachTagen]() As SqlInt32
Get
Return m_iBRVernichtungnachTagen
End Get
Set(ByVal Value As SqlInt32)
m_iBRVernichtungnachTagen = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsDokument Class
clsDokument clsDokument Members


clsDokument.iBarcodenr Property

clsDokument.iBarcodenr Property

clsDokument.iBarcodenr Property | Previous topic | Next topic
clsDokument.iBarcodenr Property | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property iBarcodenr() As SqlInt32

C#

public SqlInt32 iBarcodenr {get; set;}

C++

public:
property SqlInt32 iBarcodenr {
SqlInt32 get( );
void set(
SqlInt32 value
);
}

JScript

public function get iBarcodenr() : SqlInt32;
public function set iBarcodenr(value : SqlInt32);

Source code

Visual Basic

Copy Code Copy Code

Public Property [iBarcodenr]() As SqlInt32
Get
Return m_iBarcodenr
End Get
Set(ByVal Value As SqlInt32)
m_iBarcodenr = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsDokument Class
clsDokument clsDokument Members


clsDokument.iBck Property

clsDokument.iBck Property

clsDokument.iBck Property | Previous topic | Next topic
clsDokument.iBck Property | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property iBck() As SqlInt32

C#

public SqlInt32 iBck {get; set;}

C++

public:
property SqlInt32 iBck {
SqlInt32 get( );
void set(
SqlInt32 value
);
}

JScript

public function get iBck() : SqlInt32;
public function set iBck(value : SqlInt32);

Source code

Visual Basic

Copy Code Copy Code

Public Property [iBck]() As SqlInt32
Get
Return m_iBck
End Get
Set(ByVal Value As SqlInt32)
m_iBck = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsDokument Class
clsDokument clsDokument Members


clsDokument.iBearbeitung_nach_abschluss Property

clsDokument.iBearbeitung_nach_abschluss Property

clsDokument.iBearbeitung_nach_abschluss Property | Previous topic | Next topic
clsDokument.iBearbeitung_nach_abschluss Property | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property iBearbeitung_nach_abschluss() As SqlInt32

C#

public SqlInt32 iBearbeitung_nach_abschluss {get; set;}

C++

public:
property SqlInt32 iBearbeitung_nach_abschluss {
SqlInt32 get( );
void set(
SqlInt32 value
);
}

JScript

public function get iBearbeitung_nach_abschluss() : SqlInt32;
public function set iBearbeitung_nach_abschluss(value : SqlInt32);

Source code

Visual Basic

Copy Code Copy Code

Public Property [iBearbeitung_nach_abschluss]() As SqlInt32
Get
Return m_iBearbeitung_nach_abschluss
End Get
Set(ByVal Value As SqlInt32)
m_iBearbeitung_nach_abschluss = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsDokument Class
clsDokument clsDokument Members


clsDokument.iBearbeitungszeit_in_minuten Property

clsDokument.iBearbeitungszeit_in_minuten Property

clsDokument.iBearbeitungszeit_in_minuten Property | Previous topic | Next topic
clsDokument.iBearbeitungszeit_in_minuten Property | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property iBearbeitungszeit_in_minuten() As SqlInt32

C#

public SqlInt32 iBearbeitungszeit_in_minuten {get; set;}

C++

public:
property SqlInt32 iBearbeitungszeit_in_minuten {
SqlInt32 get( );
void set(
SqlInt32 value
);
}

JScript

public function get iBearbeitungszeit_in_minuten() : SqlInt32;
public function set iBearbeitungszeit_in_minuten(value : SqlInt32);

Source code

Visual Basic

Copy Code Copy Code

Public Property [iBearbeitungszeit_in_minuten]() As SqlInt32
Get
Return m_iBearbeitungszeit_in_minuten
End Get
Set(ByVal Value As SqlInt32)
m_iBearbeitungszeit_in_minuten = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsDokument Class
clsDokument clsDokument Members


clsDokument.iColdstatus Property

clsDokument.iColdstatus Property

clsDokument.iColdstatus Property | Previous topic | Next topic
clsDokument.iColdstatus Property | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property iColdstatus() As SqlInt32

C#

public SqlInt32 iColdstatus {get; set;}

C++

public:
property SqlInt32 iColdstatus {
SqlInt32 get( );
void set(
SqlInt32 value
);
}

JScript

public function get iColdstatus() : SqlInt32;
public function set iColdstatus(value : SqlInt32);

Source code

Visual Basic

Copy Code Copy Code

Public Property [iColdstatus]() As SqlInt32
Get
Return m_iColdstatus
End Get
Set(ByVal Value As SqlInt32)
m_iColdstatus = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsDokument Class
clsDokument clsDokument Members


clsDokument.iDokdurchkubeweitergegeben Property

clsDokument.iDokdurchkubeweitergegeben Property

clsDokument.iDokdurchkubeweitergegeben Property | Previous topic | Next topic
clsDokument.iDokdurchkubeweitergegeben Property | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property iDokdurchkubeweitergegeben() As SqlInt32

C#

public SqlInt32 iDokdurchkubeweitergegeben {get; set;}

C++

public:
property SqlInt32 iDokdurchkubeweitergegeben {
SqlInt32 get( );
void set(
SqlInt32 value
);
}

JScript

public function get iDokdurchkubeweitergegeben() : SqlInt32;
public function set iDokdurchkubeweitergegeben(value : SqlInt32);

Source code

Visual Basic

Copy Code Copy Code

Public Property [iDokdurchkubeweitergegeben]() As SqlInt32
Get
Return m_iDokdurchkubeweitergegeben
End Get
Set(ByVal Value As SqlInt32)
m_iDokdurchkubeweitergegeben = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsDokument Class
clsDokument clsDokument Members


clsDokument.iDokumenttypnr Property

clsDokument.iDokumenttypnr Property

clsDokument.iDokumenttypnr Property | Previous topic | Next topic
clsDokument.iDokumenttypnr Property | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property iDokumenttypnr() As SqlInt32

C#

public SqlInt32 iDokumenttypnr {get; set;}

C++

public:
property SqlInt32 iDokumenttypnr {
SqlInt32 get( );
void set(
SqlInt32 value
);
}

JScript

public function get iDokumenttypnr() : SqlInt32;
public function set iDokumenttypnr(value : SqlInt32);

Source code

Visual Basic

Copy Code Copy Code

Public Property [iDokumenttypnr]() As SqlInt32
Get
Return m_iDokumenttypnr
End Get
Set(ByVal Value As SqlInt32)
m_iDokumenttypnr = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsDokument Class
clsDokument clsDokument Members


clsDokument.iErsteller Property

clsDokument.iErsteller Property

clsDokument.iErsteller Property | Previous topic | Next topic
clsDokument.iErsteller Property | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property iErsteller() As SqlInt32

C#

public SqlInt32 iErsteller {get; set;}

C++

public:
property SqlInt32 iErsteller {
SqlInt32 get( );
void set(
SqlInt32 value
);
}

JScript

public function get iErsteller() : SqlInt32;
public function set iErsteller(value : SqlInt32);

Source code

Visual Basic

Copy Code Copy Code

Public Property [iErsteller]() As SqlInt32
Get
Return m_iErsteller
End Get
Set(ByVal Value As SqlInt32)
m_iErsteller = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsDokument Class
clsDokument clsDokument Members


clsDokument.iErstellerteam Property

clsDokument.iErstellerteam Property

clsDokument.iErstellerteam Property | Previous topic | Next topic
clsDokument.iErstellerteam Property | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property iErstellerteam() As SqlInt32

C#

public SqlInt32 iErstellerteam {get; set;}

C++

public:
property SqlInt32 iErstellerteam {
SqlInt32 get( );
void set(
SqlInt32 value
);
}

JScript

public function get iErstellerteam() : SqlInt32;
public function set iErstellerteam(value : SqlInt32);

Source code

Visual Basic

Copy Code Copy Code

Public Property [iErstellerteam]() As SqlInt32
Get
Return m_iErstellerteam
End Get
Set(ByVal Value As SqlInt32)
m_iErstellerteam = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsDokument Class
clsDokument clsDokument Members


clsDokument.iGesperrt_durch Property

clsDokument.iGesperrt_durch Property

clsDokument.iGesperrt_durch Property | Previous topic | Next topic
clsDokument.iGesperrt_durch Property | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property iGesperrt_durch() As SqlInt32

C#

public SqlInt32 iGesperrt_durch {get; set;}

C++

public:
property SqlInt32 iGesperrt_durch {
SqlInt32 get( );
void set(
SqlInt32 value
);
}

JScript

public function get iGesperrt_durch() : SqlInt32;
public function set iGesperrt_durch(value : SqlInt32);

Source code

Visual Basic

Copy Code Copy Code

Public Property [iGesperrt_durch]() As SqlInt32
Get
Return m_iGesperrt_durch
End Get
Set(ByVal Value As SqlInt32)
m_iGesperrt_durch = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsDokument Class
clsDokument clsDokument Members


clsDokument.iIn_edoka_datenbank Property

clsDokument.iIn_edoka_datenbank Property

clsDokument.iIn_edoka_datenbank Property | Previous topic | Next topic
clsDokument.iIn_edoka_datenbank Property | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property iIn_edoka_datenbank() As SqlInt32

C#

public SqlInt32 iIn_edoka_datenbank {get; set;}

C++

public:
property SqlInt32 iIn_edoka_datenbank {
SqlInt32 get( );
void set(
SqlInt32 value
);
}

JScript

public function get iIn_edoka_datenbank() : SqlInt32;
public function set iIn_edoka_datenbank(value : SqlInt32);

Source code

Visual Basic

Copy Code Copy Code

Public Property [iIn_edoka_datenbank]() As SqlInt32
Get
Return m_iIn_edoka_datenbank
End Get
Set(ByVal Value As SqlInt32)
m_iIn_edoka_datenbank = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsDokument Class
clsDokument clsDokument Members


clsDokument.iMa_ausgangsarchivierung Property

clsDokument.iMa_ausgangsarchivierung Property

clsDokument.iMa_ausgangsarchivierung Property | Previous topic | Next topic
clsDokument.iMa_ausgangsarchivierung Property | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property iMa_ausgangsarchivierung() As SqlInt32

C#

public SqlInt32 iMa_ausgangsarchivierung {get; set;}

C++

public:
property SqlInt32 iMa_ausgangsarchivierung {
SqlInt32 get( );
void set(
SqlInt32 value
);
}

JScript

public function get iMa_ausgangsarchivierung() : SqlInt32;
public function set iMa_ausgangsarchivierung(value : SqlInt32);

Source code

Visual Basic

Copy Code Copy Code

Public Property [iMa_ausgangsarchivierung]() As SqlInt32
Get
Return m_iMa_ausgangsarchivierung
End Get
Set(ByVal Value As SqlInt32)
m_iMa_ausgangsarchivierung = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsDokument Class
clsDokument clsDokument Members


clsDokument.iMa_eingangsarchivierung Property

clsDokument.iMa_eingangsarchivierung Property

clsDokument.iMa_eingangsarchivierung Property | Previous topic | Next topic
clsDokument.iMa_eingangsarchivierung Property | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property iMa_eingangsarchivierung() As SqlInt32

C#

public SqlInt32 iMa_eingangsarchivierung {get; set;}

C++

public:
property SqlInt32 iMa_eingangsarchivierung {
SqlInt32 get( );
void set(
SqlInt32 value
);
}

JScript

public function get iMa_eingangsarchivierung() : SqlInt32;
public function set iMa_eingangsarchivierung(value : SqlInt32);

Source code

Visual Basic

Copy Code Copy Code

Public Property [iMa_eingangsarchivierung]() As SqlInt32
Get
Return m_iMa_eingangsarchivierung
End Get
Set(ByVal Value As SqlInt32)
m_iMa_eingangsarchivierung = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsDokument Class
clsDokument clsDokument Members


clsDokument.iMitarbeiternr Property

clsDokument.iMitarbeiternr Property

clsDokument.iMitarbeiternr Property | Previous topic | Next topic
clsDokument.iMitarbeiternr Property | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property iMitarbeiternr() As SqlInt32

C#

public SqlInt32 iMitarbeiternr {get; set;}

C++

public:
property SqlInt32 iMitarbeiternr {
SqlInt32 get( );
void set(
SqlInt32 value
);
}

JScript

public function get iMitarbeiternr() : SqlInt32;
public function set iMitarbeiternr(value : SqlInt32);

Source code

Visual Basic

Copy Code Copy Code

Public Property [iMitarbeiternr]() As SqlInt32
Get
Return m_iMitarbeiternr
End Get
Set(ByVal Value As SqlInt32)
m_iMitarbeiternr = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsDokument Class
clsDokument clsDokument Members


clsDokument.iMitarbeiternr1 Property

clsDokument.iMitarbeiternr1 Property

clsDokument.iMitarbeiternr1 Property | Previous topic | Next topic
clsDokument.iMitarbeiternr1 Property | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property iMitarbeiternr1() As SqlInt32

C#

public SqlInt32 iMitarbeiternr1 {get; set;}

C++

public:
property SqlInt32 iMitarbeiternr1 {
SqlInt32 get( );
void set(
SqlInt32 value
);
}

JScript

public function get iMitarbeiternr1() : SqlInt32;
public function set iMitarbeiternr1(value : SqlInt32);

Source code

Visual Basic

Copy Code Copy Code

Public Property [iMitarbeiternr1]() As SqlInt32
Get
Return m_iMitarbeiternr1
End Get
Set(ByVal Value As SqlInt32)
m_iMitarbeiternr1 = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsDokument Class
clsDokument clsDokument Members


clsDokument.iMonierung_in_tagen Property

clsDokument.iMonierung_in_tagen Property

clsDokument.iMonierung_in_tagen Property | Previous topic | Next topic
clsDokument.iMonierung_in_tagen Property | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property iMonierung_in_tagen() As SqlInt32

C#

public SqlInt32 iMonierung_in_tagen {get; set;}

C++

public:
property SqlInt32 iMonierung_in_tagen {
SqlInt32 get( );
void set(
SqlInt32 value
);
}

JScript

public function get iMonierung_in_tagen() : SqlInt32;
public function set iMonierung_in_tagen(value : SqlInt32);

Source code

Visual Basic

Copy Code Copy Code

Public Property [iMonierung_in_tagen]() As SqlInt32
Get
Return m_iMonierung_in_tagen
End Get
Set(ByVal Value As SqlInt32)
m_iMonierung_in_tagen = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsDokument Class
clsDokument clsDokument Members


clsDokument.iMutierer Property

clsDokument.iMutierer Property

clsDokument.iMutierer Property | Previous topic | Next topic
clsDokument.iMutierer Property | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property iMutierer() As SqlInt32

C#

public SqlInt32 iMutierer {get; set;}

C++

public:
property SqlInt32 iMutierer {
SqlInt32 get( );
void set(
SqlInt32 value
);
}

JScript

public function get iMutierer() : SqlInt32;
public function set iMutierer(value : SqlInt32);

Source code

Visual Basic

Copy Code Copy Code

Public Property [iMutierer]() As SqlInt32
Get
Return m_iMutierer
End Get
Set(ByVal Value As SqlInt32)
m_iMutierer = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsDokument Class
clsDokument clsDokument Members


clsDokument.iMutiererteam Property

clsDokument.iMutiererteam Property

clsDokument.iMutiererteam Property | Previous topic | Next topic
clsDokument.iMutiererteam Property | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property iMutiererteam() As SqlInt32

C#

public SqlInt32 iMutiererteam {get; set;}

C++

public:
property SqlInt32 iMutiererteam {
SqlInt32 get( );
void set(
SqlInt32 value
);
}

JScript

public function get iMutiererteam() : SqlInt32;
public function set iMutiererteam(value : SqlInt32);

Source code

Visual Basic

Copy Code Copy Code

Public Property [iMutiererteam]() As SqlInt32
Get
Return m_iMutiererteam
End Get
Set(ByVal Value As SqlInt32)
m_iMutiererteam = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsDokument Class
clsDokument clsDokument Members


clsDokument.iMutierertieam Property

clsDokument.iMutierertieam Property

clsDokument.iMutierertieam Property | Previous topic | Next topic
clsDokument.iMutierertieam Property | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property iMutierertieam() As SqlInt32

C#

public SqlInt32 iMutierertieam {get; set;}

C++

public:
property SqlInt32 iMutierertieam {
SqlInt32 get( );
void set(
SqlInt32 value
);
}

JScript

public function get iMutierertieam() : SqlInt32;
public function set iMutierertieam(value : SqlInt32);

Source code

Visual Basic

Copy Code Copy Code

Public Property [iMutierertieam]() As SqlInt32
Get
Return m_iMutierertieam
End Get
Set(ByVal Value As SqlInt32)
m_iMutierertieam = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsDokument Class
clsDokument clsDokument Members


clsDokument.iNrpar00 Property

clsDokument.iNrpar00 Property

clsDokument.iNrpar00 Property | Previous topic | Next topic
clsDokument.iNrpar00 Property | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property iNrpar00() As SqlInt32

C#

public SqlInt32 iNrpar00 {get; set;}

C++

public:
property SqlInt32 iNrpar00 {
SqlInt32 get( );
void set(
SqlInt32 value
);
}

JScript

public function get iNrpar00() : SqlInt32;
public function set iNrpar00(value : SqlInt32);

Source code

Visual Basic

Copy Code Copy Code

Public Property [iNrpar00]() As SqlInt32
Get
Return m_iNrpar00
End Get
Set(ByVal Value As SqlInt32)
m_iNrpar00 = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsDokument Class
clsDokument clsDokument Members


clsDokument.iPostzustellung Property

clsDokument.iPostzustellung Property

clsDokument.iPostzustellung Property | Previous topic | Next topic
clsDokument.iPostzustellung Property | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property iPostzustellung() As SqlInt32

C#

public SqlInt32 iPostzustellung {get; set;}

C++

public:
property SqlInt32 iPostzustellung {
SqlInt32 get( );
void set(
SqlInt32 value
);
}

JScript

public function get iPostzustellung() : SqlInt32;
public function set iPostzustellung(value : SqlInt32);

Source code

Visual Basic

Copy Code Copy Code

Public Property [iPostzustellung]() As SqlInt32
Get
Return m_iPostzustellung
End Get
Set(ByVal Value As SqlInt32)
m_iPostzustellung = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsDokument Class
clsDokument clsDokument Members


clsDokument.iStatus_edoka_batch_ausgang Property

clsDokument.iStatus_edoka_batch_ausgang Property

clsDokument.iStatus_edoka_batch_ausgang Property | Previous topic | Next topic
clsDokument.iStatus_edoka_batch_ausgang Property | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property iStatus_edoka_batch_ausgang() As SqlInt32

C#

public SqlInt32 iStatus_edoka_batch_ausgang {get; set;}

C++

public:
property SqlInt32 iStatus_edoka_batch_ausgang {
SqlInt32 get( );
void set(
SqlInt32 value
);
}

JScript

public function get iStatus_edoka_batch_ausgang() : SqlInt32;
public function set iStatus_edoka_batch_ausgang(value : SqlInt32);

Source code

Visual Basic

Copy Code Copy Code

Public Property [iStatus_edoka_batch_ausgang]() As SqlInt32
Get
Return m_iStatus_edoka_batch_ausgang
End Get
Set(ByVal Value As SqlInt32)
m_iStatus_edoka_batch_ausgang = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsDokument Class
clsDokument clsDokument Members


clsDokument.iStatus_edoka_batch_eingang Property

clsDokument.iStatus_edoka_batch_eingang Property

clsDokument.iStatus_edoka_batch_eingang Property | Previous topic | Next topic
clsDokument.iStatus_edoka_batch_eingang Property | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property iStatus_edoka_batch_eingang() As SqlInt32

C#

public SqlInt32 iStatus_edoka_batch_eingang {get; set;}

C++

public:
property SqlInt32 iStatus_edoka_batch_eingang {
SqlInt32 get( );
void set(
SqlInt32 value
);
}

JScript

public function get iStatus_edoka_batch_eingang() : SqlInt32;
public function set iStatus_edoka_batch_eingang(value : SqlInt32);

Source code

Visual Basic

Copy Code Copy Code

Public Property [iStatus_edoka_batch_eingang]() As SqlInt32
Get
Return m_iStatus_edoka_batch_eingang
End Get
Set(ByVal Value As SqlInt32)
m_iStatus_edoka_batch_eingang = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsDokument Class
clsDokument clsDokument Members


clsDokument.iStatusnr Property

clsDokument.iStatusnr Property

clsDokument.iStatusnr Property | Previous topic | Next topic
clsDokument.iStatusnr Property | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property iStatusnr() As SqlInt32

C#

public SqlInt32 iStatusnr {get; set;}

C++

public:
property SqlInt32 iStatusnr {
SqlInt32 get( );
void set(
SqlInt32 value
);
}

JScript

public function get iStatusnr() : SqlInt32;
public function set iStatusnr(value : SqlInt32);

Source code

Visual Basic

Copy Code Copy Code

Public Property [iStatusnr]() As SqlInt32
Get
Return m_iStatusnr
End Get
Set(ByVal Value As SqlInt32)
m_iStatusnr = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsDokument Class
clsDokument clsDokument Members


clsDokument.iUnterschriftlinks Property

clsDokument.iUnterschriftlinks Property

clsDokument.iUnterschriftlinks Property | Previous topic | Next topic
clsDokument.iUnterschriftlinks Property | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property iUnterschriftlinks() As SqlInt32

C#

public SqlInt32 iUnterschriftlinks {get; set;}

C++

public:
property SqlInt32 iUnterschriftlinks {
SqlInt32 get( );
void set(
SqlInt32 value
);
}

JScript

public function get iUnterschriftlinks() : SqlInt32;
public function set iUnterschriftlinks(value : SqlInt32);

Source code

Visual Basic

Copy Code Copy Code

Public Property [iUnterschriftlinks]() As SqlInt32
Get
Return m_iUnterschriftlinks
End Get
Set(ByVal Value As SqlInt32)
m_iUnterschriftlinks = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsDokument Class
clsDokument clsDokument Members


clsDokument.iUnterschriftrechts Property

clsDokument.iUnterschriftrechts Property

clsDokument.iUnterschriftrechts Property | Previous topic | Next topic
clsDokument.iUnterschriftrechts Property | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property iUnterschriftrechts() As SqlInt32

C#

public SqlInt32 iUnterschriftrechts {get; set;}

C++

public:
property SqlInt32 iUnterschriftrechts {
SqlInt32 get( );
void set(
SqlInt32 value
);
}

JScript

public function get iUnterschriftrechts() : SqlInt32;
public function set iUnterschriftrechts(value : SqlInt32);

Source code

Visual Basic

Copy Code Copy Code

Public Property [iUnterschriftrechts]() As SqlInt32
Get
Return m_iUnterschriftrechts
End Get
Set(ByVal Value As SqlInt32)
m_iUnterschriftrechts = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsDokument Class
clsDokument clsDokument Members


clsDokument.iVerantwortlich Property

clsDokument.iVerantwortlich Property

clsDokument.iVerantwortlich Property | Previous topic | Next topic
clsDokument.iVerantwortlich Property | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property iVerantwortlich() As SqlInt32

C#

public SqlInt32 iVerantwortlich {get; set;}

C++

public:
property SqlInt32 iVerantwortlich {
SqlInt32 get( );
void set(
SqlInt32 value
);
}

JScript

public function get iVerantwortlich() : SqlInt32;
public function set iVerantwortlich(value : SqlInt32);

Source code

Visual Basic

Copy Code Copy Code

Public Property [iVerantwortlich]() As SqlInt32
Get
Return m_iVerantwortlich
End Get
Set(ByVal Value As SqlInt32)
m_iVerantwortlich = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsDokument Class
clsDokument clsDokument Members


clsDokument.iZustaendiger Property

clsDokument.iZustaendiger Property

clsDokument.iZustaendiger Property | Previous topic | Next topic
clsDokument.iZustaendiger Property | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property iZustaendiger() As SqlInt32

C#

public SqlInt32 iZustaendiger {get; set;}

C++

public:
property SqlInt32 iZustaendiger {
SqlInt32 get( );
void set(
SqlInt32 value
);
}

JScript

public function get iZustaendiger() : SqlInt32;
public function set iZustaendiger(value : SqlInt32);

Source code

Visual Basic

Copy Code Copy Code

Public Property [iZustaendiger]() As SqlInt32
Get
Return m_iZustaendiger
End Get
Set(ByVal Value As SqlInt32)
m_iZustaendiger = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsDokument Class
clsDokument clsDokument Members


clsDokument.sAnredezustelladresse Property

clsDokument.sAnredezustelladresse Property

clsDokument.sAnredezustelladresse Property | Previous topic | Next topic
clsDokument.sAnredezustelladresse Property | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property sAnredezustelladresse() As SqlString

C#

public SqlString sAnredezustelladresse {get; set;}

C++

public:
property SqlString sAnredezustelladresse {
SqlString get( );
void set(
SqlString value
);
}

JScript

public function get sAnredezustelladresse() : SqlString;
public function set sAnredezustelladresse(value : SqlString);

Source code

Visual Basic

Copy Code Copy Code

Public Property [sAnredezustelladresse]() As SqlString
Get
Return m_sAnredezustelladresse
End Get
Set(ByVal Value As SqlString)
m_sAnredezustelladresse = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsDokument Class
clsDokument clsDokument Members


clsDokument.sBedRDokumentid Property

clsDokument.sBedRDokumentid Property

clsDokument.sBedRDokumentid Property | Previous topic | Next topic
clsDokument.sBedRDokumentid Property | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property sBedRDokumentid() As SqlString

C#

public SqlString sBedRDokumentid {get; set;}

C++

public:
property SqlString sBedRDokumentid {
SqlString get( );
void set(
SqlString value
);
}

JScript

public function get sBedRDokumentid() : SqlString;
public function set sBedRDokumentid(value : SqlString);

Source code

Visual Basic

Copy Code Copy Code

Public Property [sBedRDokumentid]() As SqlString
Get
Return m_sBedRDokumentid
End Get
Set(ByVal Value As SqlString)
m_sBedRDokumentid = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsDokument Class
clsDokument clsDokument Members


clsDokument.sBemerkung Property

clsDokument.sBemerkung Property

clsDokument.sBemerkung Property | Previous topic | Next topic
clsDokument.sBemerkung Property | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property sBemerkung() As SqlString

C#

public SqlString sBemerkung {get; set;}

C++

public:
property SqlString sBemerkung {
SqlString get( );
void set(
SqlString value
);
}

JScript

public function get sBemerkung() : SqlString;
public function set sBemerkung(value : SqlString);

Source code

Visual Basic

Copy Code Copy Code

Public Property [sBemerkung]() As SqlString
Get
Return m_sBemerkung
End Get
Set(ByVal Value As SqlString)
m_sBemerkung = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsDokument Class
clsDokument clsDokument Members


clsDokument.sBemerkunguvm Property

clsDokument.sBemerkunguvm Property

clsDokument.sBemerkunguvm Property | Previous topic | Next topic
clsDokument.sBemerkunguvm Property | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property sBemerkunguvm() As SqlString

C#

public SqlString sBemerkunguvm {get; set;}

C++

public:
property SqlString sBemerkunguvm {
SqlString get( );
void set(
SqlString value
);
}

JScript

public function get sBemerkunguvm() : SqlString;
public function set sBemerkunguvm(value : SqlString);

Source code

Visual Basic

Copy Code Copy Code

Public Property [sBemerkunguvm]() As SqlString
Get
Return m_sBemerkunguvm
End Get
Set(ByVal Value As SqlString)
m_sBemerkunguvm = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsDokument Class
clsDokument clsDokument Members


clsDokument.sBezeichnung Property

clsDokument.sBezeichnung Property

clsDokument.sBezeichnung Property | Previous topic | Next topic
clsDokument.sBezeichnung Property | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property sBezeichnung() As SqlString

C#

public SqlString sBezeichnung {get; set;}

C++

public:
property SqlString sBezeichnung {
SqlString get( );
void set(
SqlString value
);
}

JScript

public function get sBezeichnung() : SqlString;
public function set sBezeichnung(value : SqlString);

Source code

Visual Basic

Copy Code Copy Code

Public Property [sBezeichnung]() As SqlString
Get
Return m_sBezeichnung
End Get
Set(ByVal Value As SqlString)
m_sBezeichnung = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsDokument Class
clsDokument clsDokument Members


clsDokument.sColddokumentid Property

clsDokument.sColddokumentid Property

clsDokument.sColddokumentid Property | Previous topic | Next topic
clsDokument.sColddokumentid Property | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property sColddokumentid() As SqlString

C#

public SqlString sColddokumentid {get; set;}

C++

public:
property SqlString sColddokumentid {
SqlString get( );
void set(
SqlString value
);
}

JScript

public function get sColddokumentid() : SqlString;
public function set sColddokumentid(value : SqlString);

Source code

Visual Basic

Copy Code Copy Code

Public Property [sColddokumentid]() As SqlString
Get
Return m_sColddokumentid
End Get
Set(ByVal Value As SqlString)
m_sColddokumentid = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsDokument Class
clsDokument clsDokument Members


clsDokument.sColdfolder Property

clsDokument.sColdfolder Property

clsDokument.sColdfolder Property | Previous topic | Next topic
clsDokument.sColdfolder Property | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property sColdfolder() As SqlString

C#

public SqlString sColdfolder {get; set;}

C++

public:
property SqlString sColdfolder {
SqlString get( );
void set(
SqlString value
);
}

JScript

public function get sColdfolder() : SqlString;
public function set sColdfolder(value : SqlString);

Source code

Visual Basic

Copy Code Copy Code

Public Property [sColdfolder]() As SqlString
Get
Return m_sColdfolder
End Get
Set(ByVal Value As SqlString)
m_sColdfolder = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsDokument Class
clsDokument clsDokument Members


clsDokument.sColdschema Property

clsDokument.sColdschema Property

clsDokument.sColdschema Property | Previous topic | Next topic
clsDokument.sColdschema Property | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property sColdschema() As SqlString

C#

public SqlString sColdschema {get; set;}

C++

public:
property SqlString sColdschema {
SqlString get( );
void set(
SqlString value
);
}

JScript

public function get sColdschema() : SqlString;
public function set sColdschema(value : SqlString);

Source code

Visual Basic

Copy Code Copy Code

Public Property [sColdschema]() As SqlString
Get
Return m_sColdschema
End Get
Set(ByVal Value As SqlString)
m_sColdschema = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsDokument Class
clsDokument clsDokument Members


clsDokument.sDokumentid Property

clsDokument.sDokumentid Property

clsDokument.sDokumentid Property | Previous topic | Next topic
clsDokument.sDokumentid Property | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property sDokumentid() As SqlString

C#

public SqlString sDokumentid {get; set;}

C++

public:
property SqlString sDokumentid {
SqlString get( );
void set(
SqlString value
);
}

JScript

public function get sDokumentid() : SqlString;
public function set sDokumentid(value : SqlString);

Source code

Visual Basic

Copy Code Copy Code

Public Property [sDokumentid]() As SqlString
Get
Return m_sDokumentid
End Get
Set(ByVal Value As SqlString)
Dim sDokumentidTmp As SqlString = Value
If sDokumentidTmp.IsNull Then
Throw New ArgumentOutOfRangeException("sDokumentid", "sDokumentid can't be NULL")
End If
m_sDokumentid = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsDokument Class
clsDokument clsDokument Members


clsDokument.sDokumentidn Property

clsDokument.sDokumentidn Property

clsDokument.sDokumentidn Property | Previous topic | Next topic
clsDokument.sDokumentidn Property | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property sDokumentidn() As SqlString

C#

public SqlString sDokumentidn {get; set;}

C++

public:
property SqlString sDokumentidn {
SqlString get( );
void set(
SqlString value
);
}

JScript

public function get sDokumentidn() : SqlString;
public function set sDokumentidn(value : SqlString);

Source code

Visual Basic

Copy Code Copy Code

Public Property [sDokumentidn]() As SqlString
Get
Return m_sDokumentidn
End Get
Set(ByVal Value As SqlString)
m_sDokumentidn = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsDokument Class
clsDokument clsDokument Members


clsDokument.sDokumentname Property

clsDokument.sDokumentname Property

clsDokument.sDokumentname Property | Previous topic | Next topic
clsDokument.sDokumentname Property | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property sDokumentname() As SqlString

C#

public SqlString sDokumentname {get; set;}

C++

public:
property SqlString sDokumentname {
SqlString get( );
void set(
SqlString value
);
}

JScript

public function get sDokumentname() : SqlString;
public function set sDokumentname(value : SqlString);

Source code

Visual Basic

Copy Code Copy Code

Public Property [sDokumentname]() As SqlString
Get
Return m_sDokumentname
End Get
Set(ByVal Value As SqlString)
m_sDokumentname = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsDokument Class
clsDokument clsDokument Members


clsDokument.sFANummer1 Property

clsDokument.sFANummer1 Property

clsDokument.sFANummer1 Property | Previous topic | Next topic
clsDokument.sFANummer1 Property | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property sFANummer1() As SqlString

C#

public SqlString sFANummer1 {get; set;}

C++

public:
property SqlString sFANummer1 {
SqlString get( );
void set(
SqlString value
);
}

JScript

public function get sFANummer1() : SqlString;
public function set sFANummer1(value : SqlString);

Source code

Visual Basic

Copy Code Copy Code

Public Property [sFANummer1]() As SqlString
Get
Return m_sFANummer1
End Get
Set(ByVal Value As SqlString)
m_sFANummer1 = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsDokument Class
clsDokument clsDokument Members


clsDokument.sFANummer2 Property

clsDokument.sFANummer2 Property

clsDokument.sFANummer2 Property | Previous topic | Next topic
clsDokument.sFANummer2 Property | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property sFANummer2() As SqlString

C#

public SqlString sFANummer2 {get; set;}

C++

public:
property SqlString sFANummer2 {
SqlString get( );
void set(
SqlString value
);
}

JScript

public function get sFANummer2() : SqlString;
public function set sFANummer2(value : SqlString);

Source code

Visual Basic

Copy Code Copy Code

Public Property [sFANummer2]() As SqlString
Get
Return m_sFANummer2
End Get
Set(ByVal Value As SqlString)
m_sFANummer2 = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsDokument Class
clsDokument clsDokument Members


clsDokument.sFanummer3 Property

clsDokument.sFanummer3 Property

clsDokument.sFanummer3 Property | Previous topic | Next topic
clsDokument.sFanummer3 Property | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property sFanummer3() As SqlString

C#

public SqlString sFanummer3 {get; set;}

C++

public:
property SqlString sFanummer3 {
SqlString get( );
void set(
SqlString value
);
}

JScript

public function get sFanummer3() : SqlString;
public function set sFanummer3(value : SqlString);

Source code

Visual Basic

Copy Code Copy Code

Public Property [sFanummer3]() As SqlString
Get
Return m_sFanummer3
End Get
Set(ByVal Value As SqlString)
m_sFanummer3 = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsDokument Class
clsDokument clsDokument Members


clsDokument.sLoeschgrund Property

clsDokument.sLoeschgrund Property

clsDokument.sLoeschgrund Property | Previous topic | Next topic
clsDokument.sLoeschgrund Property | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property sLoeschgrund() As SqlString

C#

public SqlString sLoeschgrund {get; set;}

C++

public:
property SqlString sLoeschgrund {
SqlString get( );
void set(
SqlString value
);
}

JScript

public function get sLoeschgrund() : SqlString;
public function set sLoeschgrund(value : SqlString);

Source code

Visual Basic

Copy Code Copy Code

Public Property [sLoeschgrund]() As SqlString
Get
Return m_sLoeschgrund
End Get
Set(ByVal Value As SqlString)
m_sLoeschgrund = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsDokument Class
clsDokument clsDokument Members


clsDokument.sSpeicherort Property

clsDokument.sSpeicherort Property

clsDokument.sSpeicherort Property | Previous topic | Next topic
clsDokument.sSpeicherort Property | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property sSpeicherort() As SqlString

C#

public SqlString sSpeicherort {get; set;}

C++

public:
property SqlString sSpeicherort {
SqlString get( );
void set(
SqlString value
);
}

JScript

public function get sSpeicherort() : SqlString;
public function set sSpeicherort(value : SqlString);

Source code

Visual Basic

Copy Code Copy Code

Public Property [sSpeicherort]() As SqlString
Get
Return m_sSpeicherort
End Get
Set(ByVal Value As SqlString)
m_sSpeicherort = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsDokument Class
clsDokument clsDokument Members


clsDokument.sVersandadresse Property

clsDokument.sVersandadresse Property

clsDokument.sVersandadresse Property | Previous topic | Next topic
clsDokument.sVersandadresse Property | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property sVersandadresse() As SqlString

C#

public SqlString sVersandadresse {get; set;}

C++

public:
property SqlString sVersandadresse {
SqlString get( );
void set(
SqlString value
);
}

JScript

public function get sVersandadresse() : SqlString;
public function set sVersandadresse(value : SqlString);

Source code

Visual Basic

Copy Code Copy Code

Public Property [sVersandadresse]() As SqlString
Get
Return m_sVersandadresse
End Get
Set(ByVal Value As SqlString)
m_sVersandadresse = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsDokument Class
clsDokument clsDokument Members


clsDokument.sVvnr Property

clsDokument.sVvnr Property

clsDokument.sVvnr Property | Previous topic | Next topic
clsDokument.sVvnr Property | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property sVvnr() As SqlString

C#

public SqlString sVvnr {get; set;}

C++

public:
property SqlString sVvnr {
SqlString get( );
void set(
SqlString value
);
}

JScript

public function get sVvnr() : SqlString;
public function set sVvnr(value : SqlString);

Source code

Visual Basic

Copy Code Copy Code

Public Property [sVvnr]() As SqlString
Get
Return m_sVvnr
End Get
Set(ByVal Value As SqlString)
m_sVvnr = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsDokument Class
clsDokument clsDokument Members


clsDokument.sZustelladresse Property

clsDokument.sZustelladresse Property

clsDokument.sZustelladresse Property | Previous topic | Next topic
clsDokument.sZustelladresse Property | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property sZustelladresse() As SqlString

C#

public SqlString sZustelladresse {get; set;}

C++

public:
property SqlString sZustelladresse {
SqlString get( );
void set(
SqlString value
);
}

JScript

public function get sZustelladresse() : SqlString;
public function set sZustelladresse(value : SqlString);

Source code

Visual Basic

Copy Code Copy Code

Public Property [sZustelladresse]() As SqlString
Get
Return m_sZustelladresse
End Get
Set(ByVal Value As SqlString)
m_sZustelladresse = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsDokument Class
clsDokument clsDokument Members


clsDokument Methods

clsDokument Methods

clsDokument Methods | Previous topic | Next topic
clsDokument Methods | Previous topic | Next topic

Public Methods

 | Name | Description
Supported by the .NET Compact Framework. | Delete |
Supported by the .NET Compact Framework. | Dispose | (Overloaded) (inherited from clsDBInteractionBase ).
Public method | Equals | (Overloaded) (inherited from Object).
Public method | GetHashCode | (inherited from Object).
Public method | GetType | (Overloaded) (inherited from Object).
Supported by the .NET Compact Framework. | Insert |
 | ReferenceEquals | (inherited from Object).
Supported by the .NET Compact Framework. | SelectAll |
Supported by the .NET Compact Framework. | SelectOne |
Public method | ToString | (inherited from Object).
Supported by the .NET Compact Framework. | Update |

Top

Protected Methods

 | Name | Description
Protected method | Finalize | (inherited from Object).
Protected method | MemberwiseClone | (Overloaded) (inherited from Object).

Top

See Also

Reference

clsDokument Class


clsDokument.Delete Method

clsDokument.Delete Method

clsDokument.Delete Method | Previous topic | Next topic
clsDokument.Delete Method | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Overrides Function Delete() As Boolean

C#

public override bool Delete()

C++

public:
bool Delete()

JScript

public function Delete() : boolean;

Source code

Visual Basic

Copy Code Copy Code

Public Overrides Function Delete() As Boolean
Dim scmCmdToExecute As SqlCommand = New SqlCommand()
scmCmdToExecute.CommandText = "dbo.[pr_dokument_Delete]"
scmCmdToExecute.CommandType = CommandType.StoredProcedure

' // Use base class' connection object
scmCmdToExecute.Connection = m_scoMainConnection

Try
scmCmdToExecute.Parameters.Add(New SqlParameter("@sdokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, False, 0, 0, "", DataRowVersion.Proposed, m_sDokumentid))
scmCmdToExecute.Parameters.Add(New SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

If m_bMainConnectionIsCreatedLocal Then
' // Open connection.
m_scoMainConnection.Open()
Else
If m_cpMainConnectionProvider.bIsTransactionPending Then
scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
End If
End If

' // Execute query.
scmCmdToExecute.ExecuteNonQuery()
m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
' // Throw error.
Throw New Exception("Stored Procedure 'pr_dokument_Delete' reported the ErrorCode: " & m_iErrorCode.ToString())
End If

Return True
Catch ex As Exception
' // some error occured. Bubble it to caller and encapsulate Exception object
Throw New Exception("clsDokument::Delete::Error occured.", ex)
Finally
If m_bMainConnectionIsCreatedLocal Then
' // Close connection.
m_scoMainConnection.Close()
End If
scmCmdToExecute.Dispose()
End Try
End Function

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsDokument Class
clsDokument clsDokument Members


clsDokument.Insert Method

clsDokument.Insert Method

clsDokument.Insert Method | Previous topic | Next topic
clsDokument.Insert Method | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Overrides Function Insert() As Boolean

C#

public override bool Insert()

C++

public:
bool Insert()

JScript

public function Insert() : boolean;

Source code

Visual Basic

Copy Code Copy Code

Overrides Public Function Insert() As Boolean
Dim scmCmdToExecute As SqlCommand = New SqlCommand()
scmCmdToExecute.CommandText = "dbo.[pr_dokument_Insert]"
scmCmdToExecute.CommandType = CommandType.StoredProcedure

' // Use base class' connection object
scmCmdToExecute.Connection = m_scoMainConnection

Try
scmCmdToExecute.Parameters.Add(New SqlParameter("@sdokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, False, 0, 0, "", DataRowVersion.Proposed, m_sDokumentid))
scmCmdToExecute.Parameters.Add(New SqlParameter("@imitarbeiternr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMitarbeiternr))
scmCmdToExecute.Parameters.Add(New SqlParameter("@imitarbeiternr1", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMitarbeiternr1))
scmCmdToExecute.Parameters.Add(New SqlParameter("@inrpar00", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iNrpar00))
scmCmdToExecute.Parameters.Add(New SqlParameter("@sdokumentidn", SqlDbType.VarChar, 20, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sDokumentidn))
scmCmdToExecute.Parameters.Add(New SqlParameter("@sdokumentname", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sDokumentname))
scmCmdToExecute.Parameters.Add(New SqlParameter("@iersteller", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iErsteller))
scmCmdToExecute.Parameters.Add(New SqlParameter("@ierstellerteam", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iErstellerteam))
scmCmdToExecute.Parameters.Add(New SqlParameter("@daerstelltam", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daErstelltam))
scmCmdToExecute.Parameters.Add(New SqlParameter("@imutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
scmCmdToExecute.Parameters.Add(New SqlParameter("@imutierertieam", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierertieam))
scmCmdToExecute.Parameters.Add(New SqlParameter("@damutiertam", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daMutiertam))
scmCmdToExecute.Parameters.Add(New SqlParameter("@sspeicherort", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sSpeicherort))
scmCmdToExecute.Parameters.Add(New SqlParameter("@bgesperrt", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bGesperrt))
scmCmdToExecute.Parameters.Add(New SqlParameter("@igesperrt_durch", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iGesperrt_durch))
scmCmdToExecute.Parameters.Add(New SqlParameter("@dagesperrtam", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daGesperrtam))
scmCmdToExecute.Parameters.Add(New SqlParameter("@sbezeichnung", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBezeichnung))
scmCmdToExecute.Parameters.Add(New SqlParameter("@sbemerkung", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBemerkung))
scmCmdToExecute.Parameters.Add(New SqlParameter("@bauserstuebernahme", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bAuserstuebernahme))
scmCmdToExecute.Parameters.Add(New SqlParameter("@idokumenttypnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iDokumenttypnr))
scmCmdToExecute.Parameters.Add(New SqlParameter("@bunvollstaendig", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bUnvollstaendig))
scmCmdToExecute.Parameters.Add(New SqlParameter("@sbemerkunguvm", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBemerkunguvm))
scmCmdToExecute.Parameters.Add(New SqlParameter("@bbereit_zur_archivierung", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bBereit_zur_archivierung))
scmCmdToExecute.Parameters.Add(New SqlParameter("@bausgangsarchiviert", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bAusgangsarchiviert))
scmCmdToExecute.Parameters.Add(New SqlParameter("@dadatum_ausgangsarchivierung", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daDatum_ausgangsarchivierung))
scmCmdToExecute.Parameters.Add(New SqlParameter("@ima_ausgangsarchivierung", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMa_ausgangsarchivierung))
scmCmdToExecute.Parameters.Add(New SqlParameter("@bzu_retournieren", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bZu_retournieren))
scmCmdToExecute.Parameters.Add(New SqlParameter("@beingangsarchiviert", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bEingangsarchiviert))
scmCmdToExecute.Parameters.Add(New SqlParameter("@dadatum_eingangsarchivierung", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daDatum_eingangsarchivierung))
scmCmdToExecute.Parameters.Add(New SqlParameter("@ima_eingangsarchivierung", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMa_eingangsarchivierung))
scmCmdToExecute.Parameters.Add(New SqlParameter("@istatus_edoka_batch_ausgang", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iStatus_edoka_batch_ausgang))
scmCmdToExecute.Parameters.Add(New SqlParameter("@istatus_edoka_batch_eingang", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iStatus_edoka_batch_eingang))
scmCmdToExecute.Parameters.Add(New SqlParameter("@sloeschgrund", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sLoeschgrund))
scmCmdToExecute.Parameters.Add(New SqlParameter("@icoldstatus", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iColdstatus))
scmCmdToExecute.Parameters.Add(New SqlParameter("@sversandadresse", SqlDbType.VarChar, 1024, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sVersandadresse))
scmCmdToExecute.Parameters.Add(New SqlParameter("@ibarcodenr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iBarcodenr))
scmCmdToExecute.Parameters.Add(New SqlParameter("@scolddokumentid", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sColddokumentid))
scmCmdToExecute.Parameters.Add(New SqlParameter("@bamsdokument", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bAmsdokument))
scmCmdToExecute.Parameters.Add(New SqlParameter("@iverantwortlich", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iVerantwortlich))
scmCmdToExecute.Parameters.Add(New SqlParameter("@izustaendiger", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iZustaendiger))
scmCmdToExecute.Parameters.Add(New SqlParameter("@iunterschriftlinks", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iUnterschriftlinks))
scmCmdToExecute.Parameters.Add(New SqlParameter("@iunterschriftrechts", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iUnterschriftrechts))
scmCmdToExecute.Parameters.Add(New SqlParameter("@ipostzustellung", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iPostzustellung))
scmCmdToExecute.Parameters.Add(New SqlParameter("@baktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bAktiv))
scmCmdToExecute.Parameters.Add(New SqlParameter("@istatusnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iStatusnr))
scmCmdToExecute.Parameters.Add(New SqlParameter("@bzustaendig_kube", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bZustaendig_kube))
scmCmdToExecute.Parameters.Add(New SqlParameter("@szustelladresse", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sZustelladresse))
scmCmdToExecute.Parameters.Add(New SqlParameter("@bvertraulich", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bVertraulich))
scmCmdToExecute.Parameters.Add(New SqlParameter("@daerstellungsdatum", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daErstellungsdatum))
scmCmdToExecute.Parameters.Add(New SqlParameter("@daarchivierungsdatum", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daArchivierungsdatum))
scmCmdToExecute.Parameters.Add(New SqlParameter("@datermin", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daTermin))
scmCmdToExecute.Parameters.Add(New SqlParameter("@imutiererteam", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutiererteam))
scmCmdToExecute.Parameters.Add(New SqlParameter("@sanredezustelladresse", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sAnredezustelladresse))
scmCmdToExecute.Parameters.Add(New SqlParameter("@idokdurchkubeweitergegeben", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iDokdurchkubeweitergegeben))
scmCmdToExecute.Parameters.Add(New SqlParameter("@ibck", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iBck))
scmCmdToExecute.Parameters.Add(New SqlParameter("@ibearbeitungszeit_in_minuten", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iBearbeitungszeit_in_minuten))
scmCmdToExecute.Parameters.Add(New SqlParameter("@imonierung_in_tagen", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMonierung_in_tagen))
scmCmdToExecute.Parameters.Add(New SqlParameter("@iaufbewahrung_elektronisch", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iAufbewahrung_elektronisch))
scmCmdToExecute.Parameters.Add(New SqlParameter("@iaufbewahrung_phaysisch", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iAufbewahrung_phaysisch))
scmCmdToExecute.Parameters.Add(New SqlParameter("@iin_edoka_datenbank", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iIn_edoka_datenbank))
scmCmdToExecute.Parameters.Add(New SqlParameter("@ibearbeitung_nach_abschluss", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iBearbeitung_nach_abschluss))
scmCmdToExecute.Parameters.Add(New SqlParameter("@scoldfolder", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sColdfolder))
scmCmdToExecute.Parameters.Add(New SqlParameter("@scoldschema", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sColdschema))
scmCmdToExecute.Parameters.Add(New SqlParameter("@daerinnerungam", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daErinnerungam))
scmCmdToExecute.Parameters.Add(New SqlParameter("@sFANummer1", SqlDbType.VarChar, 128, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sFANummer1))
scmCmdToExecute.Parameters.Add(New SqlParameter("@sFANummer2", SqlDbType.VarChar, 128, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sFANummer2))
scmCmdToExecute.Parameters.Add(New SqlParameter("@bfapartnerwechsel", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bFapartnerwechsel))
scmCmdToExecute.Parameters.Add(New SqlParameter("@bFAStatuswechsel", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bFAStatuswechsel))
scmCmdToExecute.Parameters.Add(New SqlParameter("@bFAVerantwortlicherwechsel", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bFAVerantwortlicherwechsel))
scmCmdToExecute.Parameters.Add(New SqlParameter("@sBedRDokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBedRDokumentid))
scmCmdToExecute.Parameters.Add(New SqlParameter("@bBedRRetourniert", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bBedRRetourniert))
scmCmdToExecute.Parameters.Add(New SqlParameter("@iBRVernichtungnachTagen", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iBRVernichtungnachTagen))
scmCmdToExecute.Parameters.Add(New SqlParameter("@bofficedokumentgeloescht", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bOfficedokumentgeloescht))
scmCmdToExecute.Parameters.Add(New SqlParameter("@sfanummer3", SqlDbType.VarChar, 128, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sFanummer3))
scmCmdToExecute.Parameters.Add(New SqlParameter("@svvnr", SqlDbType.VarChar, 25, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sVvnr))
scmCmdToExecute.Parameters.Add(New SqlParameter("@iAnzeigeStatus", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iAnzeigeStatus))
scmCmdToExecute.Parameters.Add(New SqlParameter("@bbl_scan", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bBl_scan))
scmCmdToExecute.Parameters.Add(New SqlParameter("@bbldossier", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bBldossier))
scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

If m_bMainConnectionIsCreatedLocal Then
' // Open connection.
m_scoMainConnection.Open()
Else
If m_cpMainConnectionProvider.bIsTransactionPending Then
scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
End If
End If

' // Execute query.
scmCmdToExecute.ExecuteNonQuery()
m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
' // Throw error.
Throw New Exception("Stored Procedure 'pr_dokument_Insert' reported the ErrorCode: " & m_iErrorCode.ToString())
End If

Return True
Catch ex As Exception
' // some error occured. Bubble it to caller and encapsulate Exception object
Throw New Exception("clsDokument::Insert::Error occured.", ex)
Finally
If m_bMainConnectionIsCreatedLocal Then
' // Close connection.
m_scoMainConnection.Close()
End If
scmCmdToExecute.Dispose()
End Try
End Function

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsDokument Class
clsDokument clsDokument Members


clsDokument.SelectAll Method

clsDokument.SelectAll Method

clsDokument.SelectAll Method | Previous topic | Next topic
clsDokument.SelectAll Method | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Overrides Function SelectAll() As DataTable

C#

public override DataTable SelectAll()

C++

public:
DataTable^ SelectAll()

JScript

public function SelectAll() : DataTable;

Source code

Visual Basic

Copy Code Copy Code

Public Overrides Function SelectAll() As DataTable
Dim scmCmdToExecute As SqlCommand = New SqlCommand()
scmCmdToExecute.CommandText = "dbo.[pr_dokument_SelectAll]"
scmCmdToExecute.CommandType = CommandType.StoredProcedure
Dim dtToReturn As DataTable = New DataTable("dokument")
Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)

' // Use base class' connection object
scmCmdToExecute.Connection = m_scoMainConnection

Try
scmCmdToExecute.Parameters.Add(New SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

If m_bMainConnectionIsCreatedLocal Then
' // Open connection.
m_scoMainConnection.Open()
Else
If m_cpMainConnectionProvider.bIsTransactionPending Then
scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
End If
End If

' // Execute query.
sdaAdapter.Fill(dtToReturn)
m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
' // Throw error.
Throw New Exception("Stored Procedure 'pr_dokument_SelectAll' reported the ErrorCode: " & m_iErrorCode.ToString())
End If

Return dtToReturn
Catch ex As Exception
' // some error occured. Bubble it to caller and encapsulate Exception object
Throw New Exception("clsDokument::SelectAll::Error occured.", ex)
Finally
If m_bMainConnectionIsCreatedLocal Then
' // Close connection.
m_scoMainConnection.Close()
End If
scmCmdToExecute.Dispose()
sdaAdapter.Dispose()
End Try
End Function

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsDokument Class
clsDokument clsDokument Members


clsDokument.SelectOne Method

clsDokument.SelectOne Method

clsDokument.SelectOne Method | Previous topic | Next topic
clsDokument.SelectOne Method | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Overrides Function SelectOne() As DataTable

C#

public override DataTable SelectOne()

C++

public:
DataTable^ SelectOne()

JScript

public function SelectOne() : DataTable;

Source code

Visual Basic

Copy Code Copy Code

Overrides Public Function SelectOne() As DataTable
Dim scmCmdToExecute As SqlCommand = New SqlCommand()
scmCmdToExecute.CommandText = "dbo.[pr_dokument_SelectOne]"
scmCmdToExecute.CommandType = CommandType.StoredProcedure
Dim dtToReturn As DataTable = new DataTable("dokument")
Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

' // Use base class' connection object
scmCmdToExecute.Connection = m_scoMainConnection

Try
scmCmdToExecute.Parameters.Add(new SqlParameter("@sdokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, False, 0, 0, "", DataRowVersion.Proposed, m_sDokumentid))
scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

If m_bMainConnectionIsCreatedLocal Then
' // Open connection.
m_scoMainConnection.Open()
Else
If m_cpMainConnectionProvider.bIsTransactionPending Then
scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
End If
End If

' // Execute query.
sdaAdapter.Fill(dtToReturn)
m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
' // Throw error.
Throw New Exception("Stored Procedure 'pr_dokument_SelectOne' reported the ErrorCode: " & m_iErrorCode.ToString())
End If

If dtToReturn.Rows.Count > 0 Then
m_sDokumentid = New SqlString(CType(dtToReturn.Rows(0)("dokumentid"), String))
If dtToReturn.Rows(0)("mitarbeiternr") Is System.DBNull.Value Then
m_iMitarbeiternr = SqlInt32.Null
Else
m_iMitarbeiternr = New SqlInt32(CType(dtToReturn.Rows(0)("mitarbeiternr"), Integer))
End If
If dtToReturn.Rows(0)("mitarbeiternr1") Is System.DBNull.Value Then
m_iMitarbeiternr1 = SqlInt32.Null
Else
m_iMitarbeiternr1 = New SqlInt32(CType(dtToReturn.Rows(0)("mitarbeiternr1"), Integer))
End If
If dtToReturn.Rows(0)("nrpar00") Is System.DBNull.Value Then
m_iNrpar00 = SqlInt32.Null
Else
m_iNrpar00 = New SqlInt32(CType(dtToReturn.Rows(0)("nrpar00"), Integer))
End If
If dtToReturn.Rows(0)("dokumentidn") Is System.DBNull.Value Then
m_sDokumentidn = SqlString.Null
Else
m_sDokumentidn = New SqlString(CType(dtToReturn.Rows(0)("dokumentidn"), String))
End If
If dtToReturn.Rows(0)("dokumentname") Is System.DBNull.Value Then
m_sDokumentname = SqlString.Null
Else
m_sDokumentname = New SqlString(CType(dtToReturn.Rows(0)("dokumentname"), String))
End If
If dtToReturn.Rows(0)("ersteller") Is System.DBNull.Value Then
m_iErsteller = SqlInt32.Null
Else
m_iErsteller = New SqlInt32(CType(dtToReturn.Rows(0)("ersteller"), Integer))
End If
If dtToReturn.Rows(0)("erstellerteam") Is System.DBNull.Value Then
m_iErstellerteam = SqlInt32.Null
Else
m_iErstellerteam = New SqlInt32(CType(dtToReturn.Rows(0)("erstellerteam"), Integer))
End If
If dtToReturn.Rows(0)("erstelltam") Is System.DBNull.Value Then
m_daErstelltam = SqlDateTime.Null
Else
m_daErstelltam = New SqlDateTime(CType(dtToReturn.Rows(0)("erstelltam"), Date))
End If
If dtToReturn.Rows(0)("mutierer") Is System.DBNull.Value Then
m_iMutierer = SqlInt32.Null
Else
m_iMutierer = New SqlInt32(CType(dtToReturn.Rows(0)("mutierer"), Integer))
End If
If dtToReturn.Rows(0)("mutierertieam") Is System.DBNull.Value Then
m_iMutierertieam = SqlInt32.Null
Else
m_iMutierertieam = New SqlInt32(CType(dtToReturn.Rows(0)("mutierertieam"), Integer))
End If
If dtToReturn.Rows(0)("mutiertam") Is System.DBNull.Value Then
m_daMutiertam = SqlDateTime.Null
Else
m_daMutiertam = New SqlDateTime(CType(dtToReturn.Rows(0)("mutiertam"), Date))
End If
If dtToReturn.Rows(0)("speicherort") Is System.DBNull.Value Then
m_sSpeicherort = SqlString.Null
Else
m_sSpeicherort = New SqlString(CType(dtToReturn.Rows(0)("speicherort"), String))
End If
If dtToReturn.Rows(0)("gesperrt") Is System.DBNull.Value Then
m_bGesperrt = SqlBoolean.Null
Else
m_bGesperrt = New SqlBoolean(CType(dtToReturn.Rows(0)("gesperrt"), Boolean))
End If
If dtToReturn.Rows(0)("gesperrt_durch") Is System.DBNull.Value Then
m_iGesperrt_durch = SqlInt32.Null
Else
m_iGesperrt_durch = New SqlInt32(CType(dtToReturn.Rows(0)("gesperrt_durch"), Integer))
End If
If dtToReturn.Rows(0)("gesperrtam") Is System.DBNull.Value Then
m_daGesperrtam = SqlDateTime.Null
Else
m_daGesperrtam = New SqlDateTime(CType(dtToReturn.Rows(0)("gesperrtam"), Date))
End If
If dtToReturn.Rows(0)("bezeichnung") Is System.DBNull.Value Then
m_sBezeichnung = SqlString.Null
Else
m_sBezeichnung = New SqlString(CType(dtToReturn.Rows(0)("bezeichnung"), String))
End If
If dtToReturn.Rows(0)("bemerkung") Is System.DBNull.Value Then
m_sBemerkung = SqlString.Null
Else
m_sBemerkung = New SqlString(CType(dtToReturn.Rows(0)("bemerkung"), String))
End If
If dtToReturn.Rows(0)("auserstuebernahme") Is System.DBNull.Value Then
m_bAuserstuebernahme = SqlBoolean.Null
Else
m_bAuserstuebernahme = New SqlBoolean(CType(dtToReturn.Rows(0)("auserstuebernahme"), Boolean))
End If
If dtToReturn.Rows(0)("dokumenttypnr") Is System.DBNull.Value Then
m_iDokumenttypnr = SqlInt32.Null
Else
m_iDokumenttypnr = New SqlInt32(CType(dtToReturn.Rows(0)("dokumenttypnr"), Integer))
End If
If dtToReturn.Rows(0)("unvollstaendig") Is System.DBNull.Value Then
m_bUnvollstaendig = SqlBoolean.Null
Else
m_bUnvollstaendig = New SqlBoolean(CType(dtToReturn.Rows(0)("unvollstaendig"), Boolean))
End If
If dtToReturn.Rows(0)("bemerkunguvm") Is System.DBNull.Value Then
m_sBemerkunguvm = SqlString.Null
Else
m_sBemerkunguvm = New SqlString(CType(dtToReturn.Rows(0)("bemerkunguvm"), String))
End If
If dtToReturn.Rows(0)("bereit_zur_archivierung") Is System.DBNull.Value Then
m_bBereit_zur_archivierung = SqlBoolean.Null
Else
m_bBereit_zur_archivierung = New SqlBoolean(CType(dtToReturn.Rows(0)("bereit_zur_archivierung"), Boolean))
End If
If dtToReturn.Rows(0)("ausgangsarchiviert") Is System.DBNull.Value Then
m_bAusgangsarchiviert = SqlBoolean.Null
Else
m_bAusgangsarchiviert = New SqlBoolean(CType(dtToReturn.Rows(0)("ausgangsarchiviert"), Boolean))
End If
If dtToReturn.Rows(0)("datum_ausgangsarchivierung") Is System.DBNull.Value Then
m_daDatum_ausgangsarchivierung = SqlDateTime.Null
Else
m_daDatum_ausgangsarchivierung = New SqlDateTime(CType(dtToReturn.Rows(0)("datum_ausgangsarchivierung"), Date))
End If
If dtToReturn.Rows(0)("ma_ausgangsarchivierung") Is System.DBNull.Value Then
m_iMa_ausgangsarchivierung = SqlInt32.Null
Else
m_iMa_ausgangsarchivierung = New SqlInt32(CType(dtToReturn.Rows(0)("ma_ausgangsarchivierung"), Integer))
End If
If dtToReturn.Rows(0)("zu_retournieren") Is System.DBNull.Value Then
m_bZu_retournieren = SqlBoolean.Null
Else
m_bZu_retournieren = New SqlBoolean(CType(dtToReturn.Rows(0)("zu_retournieren"), Boolean))
End If
If dtToReturn.Rows(0)("eingangsarchiviert") Is System.DBNull.Value Then
m_bEingangsarchiviert = SqlBoolean.Null
Else
m_bEingangsarchiviert = New SqlBoolean(CType(dtToReturn.Rows(0)("eingangsarchiviert"), Boolean))
End If
If dtToReturn.Rows(0)("datum_eingangsarchivierung") Is System.DBNull.Value Then
m_daDatum_eingangsarchivierung = SqlDateTime.Null
Else
m_daDatum_eingangsarchivierung = New SqlDateTime(CType(dtToReturn.Rows(0)("datum_eingangsarchivierung"), Date))
End If
If dtToReturn.Rows(0)("ma_eingangsarchivierung") Is System.DBNull.Value Then
m_iMa_eingangsarchivierung = SqlInt32.Null
Else
m_iMa_eingangsarchivierung = New SqlInt32(CType(dtToReturn.Rows(0)("ma_eingangsarchivierung"), Integer))
End If
If dtToReturn.Rows(0)("status_edoka_batch_ausgang") Is System.DBNull.Value Then
m_iStatus_edoka_batch_ausgang = SqlInt32.Null
Else
m_iStatus_edoka_batch_ausgang = New SqlInt32(CType(dtToReturn.Rows(0)("status_edoka_batch_ausgang"), Integer))
End If
If dtToReturn.Rows(0)("status_edoka_batch_eingang") Is System.DBNull.Value Then
m_iStatus_edoka_batch_eingang = SqlInt32.Null
Else
m_iStatus_edoka_batch_eingang = New SqlInt32(CType(dtToReturn.Rows(0)("status_edoka_batch_eingang"), Integer))
End If
If dtToReturn.Rows(0)("loeschgrund") Is System.DBNull.Value Then
m_sLoeschgrund = SqlString.Null
Else
m_sLoeschgrund = New SqlString(CType(dtToReturn.Rows(0)("loeschgrund"), String))
End If
If dtToReturn.Rows(0)("coldstatus") Is System.DBNull.Value Then
m_iColdstatus = SqlInt32.Null
Else
m_iColdstatus = New SqlInt32(CType(dtToReturn.Rows(0)("coldstatus"), Integer))
End If
If dtToReturn.Rows(0)("versandadresse") Is System.DBNull.Value Then
m_sVersandadresse = SqlString.Null
Else
m_sVersandadresse = New SqlString(CType(dtToReturn.Rows(0)("versandadresse"), String))
End If
If dtToReturn.Rows(0)("barcodenr") Is System.DBNull.Value Then
m_iBarcodenr = SqlInt32.Null
Else
m_iBarcodenr = New SqlInt32(CType(dtToReturn.Rows(0)("barcodenr"), Integer))
End If
If dtToReturn.Rows(0)("colddokumentid") Is System.DBNull.Value Then
m_sColddokumentid = SqlString.Null
Else
m_sColddokumentid = New SqlString(CType(dtToReturn.Rows(0)("colddokumentid"), String))
End If
If dtToReturn.Rows(0)("amsdokument") Is System.DBNull.Value Then
m_bAmsdokument = SqlBoolean.Null
Else
m_bAmsdokument = New SqlBoolean(CType(dtToReturn.Rows(0)("amsdokument"), Boolean))
End If
If dtToReturn.Rows(0)("verantwortlich") Is System.DBNull.Value Then
m_iVerantwortlich = SqlInt32.Null
Else
m_iVerantwortlich = New SqlInt32(CType(dtToReturn.Rows(0)("verantwortlich"), Integer))
End If
If dtToReturn.Rows(0)("zustaendiger") Is System.DBNull.Value Then
m_iZustaendiger = SqlInt32.Null
Else
m_iZustaendiger = New SqlInt32(CType(dtToReturn.Rows(0)("zustaendiger"), Integer))
End If
If dtToReturn.Rows(0)("unterschriftlinks") Is System.DBNull.Value Then
m_iUnterschriftlinks = SqlInt32.Null
Else
m_iUnterschriftlinks = New SqlInt32(CType(dtToReturn.Rows(0)("unterschriftlinks"), Integer))
End If
If dtToReturn.Rows(0)("unterschriftrechts") Is System.DBNull.Value Then
m_iUnterschriftrechts = SqlInt32.Null
Else
m_iUnterschriftrechts = New SqlInt32(CType(dtToReturn.Rows(0)("unterschriftrechts"), Integer))
End If
If dtToReturn.Rows(0)("postzustellung") Is System.DBNull.Value Then
m_iPostzustellung = SqlInt32.Null
Else
m_iPostzustellung = New SqlInt32(CType(dtToReturn.Rows(0)("postzustellung"), Integer))
End If
If dtToReturn.Rows(0)("aktiv") Is System.DBNull.Value Then
m_bAktiv = SqlBoolean.Null
Else
m_bAktiv = New SqlBoolean(CType(dtToReturn.Rows(0)("aktiv"), Boolean))
End If
If dtToReturn.Rows(0)("statusnr") Is System.DBNull.Value Then
m_iStatusnr = SqlInt32.Null
Else
m_iStatusnr = New SqlInt32(CType(dtToReturn.Rows(0)("statusnr"), Integer))
End If
If dtToReturn.Rows(0)("zustaendig_kube") Is System.DBNull.Value Then
m_bZustaendig_kube = SqlBoolean.Null
Else
m_bZustaendig_kube = New SqlBoolean(CType(dtToReturn.Rows(0)("zustaendig_kube"), Boolean))
End If
If dtToReturn.Rows(0)("zustelladresse") Is System.DBNull.Value Then
m_sZustelladresse = SqlString.Null
Else
m_sZustelladresse = New SqlString(CType(dtToReturn.Rows(0)("zustelladresse"), String))
End If
If dtToReturn.Rows(0)("vertraulich") Is System.DBNull.Value Then
m_bVertraulich = SqlBoolean.Null
Else
m_bVertraulich = New SqlBoolean(CType(dtToReturn.Rows(0)("vertraulich"), Boolean))
End If
If dtToReturn.Rows(0)("erstellungsdatum") Is System.DBNull.Value Then
m_daErstellungsdatum = SqlDateTime.Null
Else
m_daErstellungsdatum = New SqlDateTime(CType(dtToReturn.Rows(0)("erstellungsdatum"), Date))
End If
If dtToReturn.Rows(0)("archivierungsdatum") Is System.DBNull.Value Then
m_daArchivierungsdatum = SqlDateTime.Null
Else
m_daArchivierungsdatum = New SqlDateTime(CType(dtToReturn.Rows(0)("archivierungsdatum"), Date))
End If
If dtToReturn.Rows(0)("termin") Is System.DBNull.Value Then
m_daTermin = SqlDateTime.Null
Else
m_daTermin = New SqlDateTime(CType(dtToReturn.Rows(0)("termin"), Date))
End If
If dtToReturn.Rows(0)("mutiererteam") Is System.DBNull.Value Then
m_iMutiererteam = SqlInt32.Null
Else
m_iMutiererteam = New SqlInt32(CType(dtToReturn.Rows(0)("mutiererteam"), Integer))
End If
If dtToReturn.Rows(0)("anredezustelladresse") Is System.DBNull.Value Then
m_sAnredezustelladresse = SqlString.Null
Else
m_sAnredezustelladresse = New SqlString(CType(dtToReturn.Rows(0)("anredezustelladresse"), String))
End If
If dtToReturn.Rows(0)("dokdurchkubeweitergegeben") Is System.DBNull.Value Then
m_iDokdurchkubeweitergegeben = SqlInt32.Null
Else
m_iDokdurchkubeweitergegeben = New SqlInt32(CType(dtToReturn.Rows(0)("dokdurchkubeweitergegeben"), Integer))
End If
If dtToReturn.Rows(0)("bck") Is System.DBNull.Value Then
m_iBck = SqlInt32.Null
Else
m_iBck = New SqlInt32(CType(dtToReturn.Rows(0)("bck"), Integer))
End If
If dtToReturn.Rows(0)("bearbeitungszeit_in_minuten") Is System.DBNull.Value Then
m_iBearbeitungszeit_in_minuten = SqlInt32.Null
Else
m_iBearbeitungszeit_in_minuten = New SqlInt32(CType(dtToReturn.Rows(0)("bearbeitungszeit_in_minuten"), Integer))
End If
If dtToReturn.Rows(0)("monierung_in_tagen") Is System.DBNull.Value Then
m_iMonierung_in_tagen = SqlInt32.Null
Else
m_iMonierung_in_tagen = New SqlInt32(CType(dtToReturn.Rows(0)("monierung_in_tagen"), Integer))
End If
If dtToReturn.Rows(0)("aufbewahrung_elektronisch") Is System.DBNull.Value Then
m_iAufbewahrung_elektronisch = SqlInt32.Null
Else
m_iAufbewahrung_elektronisch = New SqlInt32(CType(dtToReturn.Rows(0)("aufbewahrung_elektronisch"), Integer))
End If
If dtToReturn.Rows(0)("aufbewahrung_phaysisch") Is System.DBNull.Value Then
m_iAufbewahrung_phaysisch = SqlInt32.Null
Else
m_iAufbewahrung_phaysisch = New SqlInt32(CType(dtToReturn.Rows(0)("aufbewahrung_phaysisch"), Integer))
End If
If dtToReturn.Rows(0)("in_edoka_datenbank") Is System.DBNull.Value Then
m_iIn_edoka_datenbank = SqlInt32.Null
Else
m_iIn_edoka_datenbank = New SqlInt32(CType(dtToReturn.Rows(0)("in_edoka_datenbank"), Integer))
End If
If dtToReturn.Rows(0)("bearbeitung_nach_abschluss") Is System.DBNull.Value Then
m_iBearbeitung_nach_abschluss = SqlInt32.Null
Else
m_iBearbeitung_nach_abschluss = New SqlInt32(CType(dtToReturn.Rows(0)("bearbeitung_nach_abschluss"), Integer))
End If
If dtToReturn.Rows(0)("coldfolder") Is System.DBNull.Value Then
m_sColdfolder = SqlString.Null
Else
m_sColdfolder = New SqlString(CType(dtToReturn.Rows(0)("coldfolder"), String))
End If
If dtToReturn.Rows(0)("coldschema") Is System.DBNull.Value Then
m_sColdschema = SqlString.Null
Else
m_sColdschema = New SqlString(CType(dtToReturn.Rows(0)("coldschema"), String))
End If
If dtToReturn.Rows(0)("erinnerungam") Is System.DBNull.Value Then
m_daErinnerungam = SqlDateTime.Null
Else
m_daErinnerungam = New SqlDateTime(CType(dtToReturn.Rows(0)("erinnerungam"), Date))
End If
If dtToReturn.Rows(0)("FANummer1") Is System.DBNull.Value Then
m_sFANummer1 = SqlString.Null
Else
m_sFANummer1 = New SqlString(CType(dtToReturn.Rows(0)("FANummer1"), String))
End If
If dtToReturn.Rows(0)("FANummer2") Is System.DBNull.Value Then
m_sFANummer2 = SqlString.Null
Else
m_sFANummer2 = New SqlString(CType(dtToReturn.Rows(0)("FANummer2"), String))
End If
If dtToReturn.Rows(0)("fapartnerwechsel") Is System.DBNull.Value Then
m_bFapartnerwechsel = SqlBoolean.Null
Else
m_bFapartnerwechsel = New SqlBoolean(CType(dtToReturn.Rows(0)("fapartnerwechsel"), Boolean))
End If
If dtToReturn.Rows(0)("FAStatuswechsel") Is System.DBNull.Value Then
m_bFAStatuswechsel = SqlBoolean.Null
Else
m_bFAStatuswechsel = New SqlBoolean(CType(dtToReturn.Rows(0)("FAStatuswechsel"), Boolean))
End If
If dtToReturn.Rows(0)("FAVerantwortlicherwechsel") Is System.DBNull.Value Then
m_bFAVerantwortlicherwechsel = SqlBoolean.Null
Else
m_bFAVerantwortlicherwechsel = New SqlBoolean(CType(dtToReturn.Rows(0)("FAVerantwortlicherwechsel"), Boolean))
End If
If dtToReturn.Rows(0)("BedRDokumentid") Is System.DBNull.Value Then
m_sBedRDokumentid = SqlString.Null
Else
m_sBedRDokumentid = New SqlString(CType(dtToReturn.Rows(0)("BedRDokumentid"), String))
End If
If dtToReturn.Rows(0)("BedRRetourniert") Is System.DBNull.Value Then
m_bBedRRetourniert = SqlBoolean.Null
Else
m_bBedRRetourniert = New SqlBoolean(CType(dtToReturn.Rows(0)("BedRRetourniert"), Boolean))
End If
If dtToReturn.Rows(0)("BRVernichtungnachTagen") Is System.DBNull.Value Then
m_iBRVernichtungnachTagen = SqlInt32.Null
Else
m_iBRVernichtungnachTagen = New SqlInt32(CType(dtToReturn.Rows(0)("BRVernichtungnachTagen"), Integer))
End If
If dtToReturn.Rows(0)("officedokumentgeloescht") Is System.DBNull.Value Then
m_bOfficedokumentgeloescht = SqlBoolean.Null
Else
m_bOfficedokumentgeloescht = New SqlBoolean(CType(dtToReturn.Rows(0)("officedokumentgeloescht"), Boolean))
End If
If dtToReturn.Rows(0)("fanummer3") Is System.DBNull.Value Then
m_sFanummer3 = SqlString.Null
Else
m_sFanummer3 = New SqlString(CType(dtToReturn.Rows(0)("fanummer3"), String))
End If
If dtToReturn.Rows(0)("vvnr") Is System.DBNull.Value Then
m_sVvnr = SqlString.Null
Else
m_sVvnr = New SqlString(CType(dtToReturn.Rows(0)("vvnr"), String))
End If
If dtToReturn.Rows(0)("AnzeigeStatus") Is System.DBNull.Value Then
m_iAnzeigeStatus = SqlInt32.Null
Else
m_iAnzeigeStatus = New SqlInt32(CType(dtToReturn.Rows(0)("AnzeigeStatus"), Integer))
End If
If dtToReturn.Rows(0)("bl_scan") Is System.DBNull.Value Then
m_bBl_scan = SqlBoolean.Null
Else
m_bBl_scan = New SqlBoolean(CType(dtToReturn.Rows(0)("bl_scan"), Boolean))
End If
If dtToReturn.Rows(0)("bldossier") Is System.DBNull.Value Then
m_bBldossier = SqlBoolean.Null
Else
m_bBldossier = New SqlBoolean(CType(dtToReturn.Rows(0)("bldossier"), Boolean))
End If
End If
Return dtToReturn
Catch ex As Exception
' // some error occured. Bubble it to caller and encapsulate Exception object
Throw New Exception("clsDokument::SelectOne::Error occured.", ex)
Finally
If m_bMainConnectionIsCreatedLocal Then
' // Close connection.
m_scoMainConnection.Close()
End If
scmCmdToExecute.Dispose()
sdaAdapter.Dispose()
End Try
End Function

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsDokument Class
clsDokument clsDokument Members


clsDokument.Update Method

clsDokument.Update Method

clsDokument.Update Method | Previous topic | Next topic
clsDokument.Update Method | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Overrides Function Update() As Boolean

C#

public override bool Update()

C++

public:
bool Update()

JScript

public function Update() : boolean;

Source code

Visual Basic

Copy Code Copy Code

Overrides Public Function Update() As Boolean
Dim scmCmdToExecute As SqlCommand = New SqlCommand()
scmCmdToExecute.CommandText = "dbo.[pr_dokument_Update]"
scmCmdToExecute.CommandType = CommandType.StoredProcedure

' // Use base class' connection object
scmCmdToExecute.Connection = m_scoMainConnection

Try
scmCmdToExecute.Parameters.Add(New SqlParameter("@sdokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, False, 0, 0, "", DataRowVersion.Proposed, m_sDokumentid))
scmCmdToExecute.Parameters.Add(New SqlParameter("@imitarbeiternr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMitarbeiternr))
scmCmdToExecute.Parameters.Add(New SqlParameter("@imitarbeiternr1", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMitarbeiternr1))
scmCmdToExecute.Parameters.Add(New SqlParameter("@inrpar00", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iNrpar00))
scmCmdToExecute.Parameters.Add(New SqlParameter("@sdokumentidn", SqlDbType.VarChar, 20, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sDokumentidn))
scmCmdToExecute.Parameters.Add(New SqlParameter("@sdokumentname", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sDokumentname))
scmCmdToExecute.Parameters.Add(New SqlParameter("@iersteller", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iErsteller))
scmCmdToExecute.Parameters.Add(New SqlParameter("@ierstellerteam", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iErstellerteam))
scmCmdToExecute.Parameters.Add(New SqlParameter("@daerstelltam", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daErstelltam))
scmCmdToExecute.Parameters.Add(New SqlParameter("@imutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
scmCmdToExecute.Parameters.Add(New SqlParameter("@imutierertieam", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierertieam))
scmCmdToExecute.Parameters.Add(New SqlParameter("@damutiertam", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daMutiertam))
scmCmdToExecute.Parameters.Add(New SqlParameter("@sspeicherort", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sSpeicherort))
scmCmdToExecute.Parameters.Add(New SqlParameter("@bgesperrt", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bGesperrt))
scmCmdToExecute.Parameters.Add(New SqlParameter("@igesperrt_durch", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iGesperrt_durch))
scmCmdToExecute.Parameters.Add(New SqlParameter("@dagesperrtam", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daGesperrtam))
scmCmdToExecute.Parameters.Add(New SqlParameter("@sbezeichnung", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBezeichnung))
scmCmdToExecute.Parameters.Add(New SqlParameter("@sbemerkung", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBemerkung))
scmCmdToExecute.Parameters.Add(New SqlParameter("@bauserstuebernahme", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bAuserstuebernahme))
scmCmdToExecute.Parameters.Add(New SqlParameter("@idokumenttypnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iDokumenttypnr))
scmCmdToExecute.Parameters.Add(New SqlParameter("@bunvollstaendig", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bUnvollstaendig))
scmCmdToExecute.Parameters.Add(New SqlParameter("@sbemerkunguvm", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBemerkunguvm))
scmCmdToExecute.Parameters.Add(New SqlParameter("@bbereit_zur_archivierung", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bBereit_zur_archivierung))
scmCmdToExecute.Parameters.Add(New SqlParameter("@bausgangsarchiviert", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bAusgangsarchiviert))
scmCmdToExecute.Parameters.Add(New SqlParameter("@dadatum_ausgangsarchivierung", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daDatum_ausgangsarchivierung))
scmCmdToExecute.Parameters.Add(New SqlParameter("@ima_ausgangsarchivierung", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMa_ausgangsarchivierung))
scmCmdToExecute.Parameters.Add(New SqlParameter("@bzu_retournieren", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bZu_retournieren))
scmCmdToExecute.Parameters.Add(New SqlParameter("@beingangsarchiviert", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bEingangsarchiviert))
scmCmdToExecute.Parameters.Add(New SqlParameter("@dadatum_eingangsarchivierung", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daDatum_eingangsarchivierung))
scmCmdToExecute.Parameters.Add(New SqlParameter("@ima_eingangsarchivierung", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMa_eingangsarchivierung))
scmCmdToExecute.Parameters.Add(New SqlParameter("@istatus_edoka_batch_ausgang", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iStatus_edoka_batch_ausgang))
scmCmdToExecute.Parameters.Add(New SqlParameter("@istatus_edoka_batch_eingang", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iStatus_edoka_batch_eingang))
scmCmdToExecute.Parameters.Add(New SqlParameter("@sloeschgrund", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sLoeschgrund))
scmCmdToExecute.Parameters.Add(New SqlParameter("@icoldstatus", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iColdstatus))
scmCmdToExecute.Parameters.Add(New SqlParameter("@sversandadresse", SqlDbType.VarChar, 1024, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sVersandadresse))
scmCmdToExecute.Parameters.Add(New SqlParameter("@ibarcodenr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iBarcodenr))
scmCmdToExecute.Parameters.Add(New SqlParameter("@scolddokumentid", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sColddokumentid))
scmCmdToExecute.Parameters.Add(New SqlParameter("@bamsdokument", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bAmsdokument))
scmCmdToExecute.Parameters.Add(New SqlParameter("@iverantwortlich", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iVerantwortlich))
scmCmdToExecute.Parameters.Add(New SqlParameter("@izustaendiger", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iZustaendiger))
scmCmdToExecute.Parameters.Add(New SqlParameter("@iunterschriftlinks", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iUnterschriftlinks))
scmCmdToExecute.Parameters.Add(New SqlParameter("@iunterschriftrechts", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iUnterschriftrechts))
scmCmdToExecute.Parameters.Add(New SqlParameter("@ipostzustellung", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iPostzustellung))
scmCmdToExecute.Parameters.Add(New SqlParameter("@baktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bAktiv))
scmCmdToExecute.Parameters.Add(New SqlParameter("@istatusnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iStatusnr))
scmCmdToExecute.Parameters.Add(New SqlParameter("@bzustaendig_kube", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bZustaendig_kube))
scmCmdToExecute.Parameters.Add(New SqlParameter("@szustelladresse", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sZustelladresse))
scmCmdToExecute.Parameters.Add(New SqlParameter("@bvertraulich", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bVertraulich))
scmCmdToExecute.Parameters.Add(New SqlParameter("@daerstellungsdatum", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daErstellungsdatum))
scmCmdToExecute.Parameters.Add(New SqlParameter("@daarchivierungsdatum", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daArchivierungsdatum))
scmCmdToExecute.Parameters.Add(New SqlParameter("@datermin", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daTermin))
scmCmdToExecute.Parameters.Add(New SqlParameter("@imutiererteam", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutiererteam))
scmCmdToExecute.Parameters.Add(New SqlParameter("@sanredezustelladresse", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sAnredezustelladresse))
scmCmdToExecute.Parameters.Add(New SqlParameter("@idokdurchkubeweitergegeben", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iDokdurchkubeweitergegeben))
scmCmdToExecute.Parameters.Add(New SqlParameter("@ibck", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iBck))
scmCmdToExecute.Parameters.Add(New SqlParameter("@ibearbeitungszeit_in_minuten", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iBearbeitungszeit_in_minuten))
scmCmdToExecute.Parameters.Add(New SqlParameter("@imonierung_in_tagen", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMonierung_in_tagen))
scmCmdToExecute.Parameters.Add(New SqlParameter("@iaufbewahrung_elektronisch", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iAufbewahrung_elektronisch))
scmCmdToExecute.Parameters.Add(New SqlParameter("@iaufbewahrung_phaysisch", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iAufbewahrung_phaysisch))
scmCmdToExecute.Parameters.Add(New SqlParameter("@iin_edoka_datenbank", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iIn_edoka_datenbank))
scmCmdToExecute.Parameters.Add(New SqlParameter("@ibearbeitung_nach_abschluss", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iBearbeitung_nach_abschluss))
scmCmdToExecute.Parameters.Add(New SqlParameter("@scoldfolder", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sColdfolder))
scmCmdToExecute.Parameters.Add(New SqlParameter("@scoldschema", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sColdschema))
scmCmdToExecute.Parameters.Add(New SqlParameter("@daerinnerungam", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daErinnerungam))
scmCmdToExecute.Parameters.Add(New SqlParameter("@sFANummer1", SqlDbType.VarChar, 128, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sFANummer1))
scmCmdToExecute.Parameters.Add(New SqlParameter("@sFANummer2", SqlDbType.VarChar, 128, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sFANummer2))
scmCmdToExecute.Parameters.Add(New SqlParameter("@bfapartnerwechsel", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bFapartnerwechsel))
scmCmdToExecute.Parameters.Add(New SqlParameter("@bFAStatuswechsel", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bFAStatuswechsel))
scmCmdToExecute.Parameters.Add(New SqlParameter("@bFAVerantwortlicherwechsel", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bFAVerantwortlicherwechsel))
scmCmdToExecute.Parameters.Add(New SqlParameter("@sBedRDokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBedRDokumentid))
scmCmdToExecute.Parameters.Add(New SqlParameter("@bBedRRetourniert", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bBedRRetourniert))
scmCmdToExecute.Parameters.Add(New SqlParameter("@iBRVernichtungnachTagen", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iBRVernichtungnachTagen))
scmCmdToExecute.Parameters.Add(New SqlParameter("@bofficedokumentgeloescht", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bOfficedokumentgeloescht))
scmCmdToExecute.Parameters.Add(New SqlParameter("@sfanummer3", SqlDbType.VarChar, 128, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sFanummer3))
scmCmdToExecute.Parameters.Add(New SqlParameter("@svvnr", SqlDbType.VarChar, 25, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sVvnr))
scmCmdToExecute.Parameters.Add(New SqlParameter("@iAnzeigeStatus", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iAnzeigeStatus))
scmCmdToExecute.Parameters.Add(New SqlParameter("@bbl_scan", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bBl_scan))
scmCmdToExecute.Parameters.Add(New SqlParameter("@bbldossier", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bBldossier))
scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

If m_bMainConnectionIsCreatedLocal Then
' // Open connection.
m_scoMainConnection.Open()
Else
If m_cpMainConnectionProvider.bIsTransactionPending Then
scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
End If
End If

' // Execute query.
scmCmdToExecute.ExecuteNonQuery()
m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
' // Throw error.
Throw New Exception("Stored Procedure 'pr_dokument_Update' reported the ErrorCode: " & m_iErrorCode.ToString())
End If

Return True
Catch ex As Exception
' // some error occured. Bubble it to caller and encapsulate Exception object
Throw New Exception("clsDokument::Update::Error occured.", ex)
Finally
If m_bMainConnectionIsCreatedLocal Then
' // Close connection.
m_scoMainConnection.Close()
End If
scmCmdToExecute.Dispose()
End Try
End Function

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsDokument Class
clsDokument clsDokument Members


clsDokument Fields

clsDokument Fields

clsDokument Fields | Previous topic | Next topic
clsDokument Fields | Previous topic | Next topic

Fields

 | Name | Description
Supported by the .NET Compact Framework. | m_bAktiv |
Supported by the .NET Compact Framework. | m_bAmsdokument |
Supported by the .NET Compact Framework. | m_bAuserstuebernahme |
Supported by the .NET Compact Framework. | m_bAusgangsarchiviert |
Supported by the .NET Compact Framework. | m_bBedRRetourniert |
Supported by the .NET Compact Framework. | m_bBereit_zur_archivierung |
Supported by the .NET Compact Framework. | m_bBl_scan |
Supported by the .NET Compact Framework. | m_bBldossier |
Supported by the .NET Compact Framework. | m_bEingangsarchiviert |
Supported by the .NET Compact Framework. | m_bFAStatuswechsel |
Supported by the .NET Compact Framework. | m_bFAVerantwortlicherwechsel |
Supported by the .NET Compact Framework. | m_bFapartnerwechsel |
Supported by the .NET Compact Framework. | m_bGesperrt |
Supported by the .NET Compact Framework. | m_bMainConnectionIsCreatedLocal | (inherited from clsDBInteractionBase ).
Supported by the .NET Compact Framework. | m_bOfficedokumentgeloescht |
Supported by the .NET Compact Framework. | m_bUnvollstaendig |
Supported by the .NET Compact Framework. | m_bVertraulich |
Supported by the .NET Compact Framework. | m_bZu_retournieren |
Supported by the .NET Compact Framework. | m_bZustaendig_kube |
Supported by the .NET Compact Framework. | m_cpMainConnectionProvider | (inherited from clsDBInteractionBase ).
Supported by the .NET Compact Framework. | m_daArchivierungsdatum |
Supported by the .NET Compact Framework. | m_daDatum_ausgangsarchivierung |
Supported by the .NET Compact Framework. | m_daDatum_eingangsarchivierung |
Supported by the .NET Compact Framework. | m_daErinnerungam |
Supported by the .NET Compact Framework. | m_daErstelltam |
Supported by the .NET Compact Framework. | m_daErstellungsdatum |
Supported by the .NET Compact Framework. | m_daGesperrtam |
Supported by the .NET Compact Framework. | m_daMutiertam |
Supported by the .NET Compact Framework. | m_daTermin |
Supported by the .NET Compact Framework. | m_iAnzeigeStatus |
Supported by the .NET Compact Framework. | m_iAufbewahrung_elektronisch |
Supported by the .NET Compact Framework. | m_iAufbewahrung_phaysisch |
Supported by the .NET Compact Framework. | m_iBRVernichtungnachTagen |
Supported by the .NET Compact Framework. | m_iBarcodenr |
Supported by the .NET Compact Framework. | m_iBck |
Supported by the .NET Compact Framework. | m_iBearbeitung_nach_abschluss |
Supported by the .NET Compact Framework. | m_iBearbeitungszeit_in_minuten |
Supported by the .NET Compact Framework. | m_iColdstatus |
Supported by the .NET Compact Framework. | m_iDokdurchkubeweitergegeben |
Supported by the .NET Compact Framework. | m_iDokumenttypnr |
Supported by the .NET Compact Framework. | m_iErrorCode | (inherited from clsDBInteractionBase ).
Supported by the .NET Compact Framework. | m_iErsteller |
Supported by the .NET Compact Framework. | m_iErstellerteam |
Supported by the .NET Compact Framework. | m_iGesperrt_durch |
Supported by the .NET Compact Framework. | m_iIn_edoka_datenbank |
Supported by the .NET Compact Framework. | m_iMa_ausgangsarchivierung |
Supported by the .NET Compact Framework. | m_iMa_eingangsarchivierung |
Supported by the .NET Compact Framework. | m_iMitarbeiternr |
Supported by the .NET Compact Framework. | m_iMitarbeiternr1 |
Supported by the .NET Compact Framework. | m_iMonierung_in_tagen |
Supported by the .NET Compact Framework. | m_iMutierer |
Supported by the .NET Compact Framework. | m_iMutiererteam |
Supported by the .NET Compact Framework. | m_iMutierertieam |
Supported by the .NET Compact Framework. | m_iNrpar00 |
Supported by the .NET Compact Framework. | m_iPostzustellung |
Supported by the .NET Compact Framework. | m_iStatus_edoka_batch_ausgang |
Supported by the .NET Compact Framework. | m_iStatus_edoka_batch_eingang |
Supported by the .NET Compact Framework. | m_iStatusnr |
Supported by the .NET Compact Framework. | m_iUnterschriftlinks |
Supported by the .NET Compact Framework. | m_iUnterschriftrechts |
Supported by the .NET Compact Framework. | m_iVerantwortlich |
Supported by the .NET Compact Framework. | m_iZustaendiger |
Supported by the .NET Compact Framework. | m_sAnredezustelladresse |
Supported by the .NET Compact Framework. | m_sBedRDokumentid |
Supported by the .NET Compact Framework. | m_sBemerkung |
Supported by the .NET Compact Framework. | m_sBemerkunguvm |
Supported by the .NET Compact Framework. | m_sBezeichnung |
Supported by the .NET Compact Framework. | m_sColddokumentid |
Supported by the .NET Compact Framework. | m_sColdfolder |
Supported by the .NET Compact Framework. | m_sColdschema |
Supported by the .NET Compact Framework. | m_sDokumentid |
Supported by the .NET Compact Framework. | m_sDokumentidn |
Supported by the .NET Compact Framework. | m_sDokumentname |
Supported by the .NET Compact Framework. | m_sFANummer1 |
Supported by the .NET Compact Framework. | m_sFANummer2 |
Supported by the .NET Compact Framework. | m_sFanummer3 |
Supported by the .NET Compact Framework. | m_sLoeschgrund |
Supported by the .NET Compact Framework. | m_sSpeicherort |
Supported by the .NET Compact Framework. | m_sVersandadresse |
Supported by the .NET Compact Framework. | m_sVvnr |
Supported by the .NET Compact Framework. | m_sZustelladresse |
Supported by the .NET Compact Framework. | m_scoMainConnection | (inherited from clsDBInteractionBase ).

Top

See Also

Reference

clsDokument Class


m_bAktiv Field

m_bAktiv Field

m_bAktiv Field | Previous topic | Next topic
m_bAktiv Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_bAktiv As SqlBoolean

C#

private SqlBoolean m_bAktiv

C++

private:
SqlBoolean m_bAktiv;

JScript

private m_bAktiv : SqlBoolean

Source code

Visual Basic

Copy Code Copy Code

Private m_bBereit_zur_archivierung, m_bAusgangsarchiviert, m_bUnvollstaendig, m_bGesperrt, m_bAuserstuebernahme, m_bZu_retournieren, m_bAmsdokument, m_bAktiv, m_bZustaendig_kube, m_bEingangsarchiviert, m_bVertraulich, m_bFapartnerwechsel, m_bBl_scan, m_bOfficedokumentgeloescht, m_bFAStatuswechsel, m_bFAVerantwortlicherwechsel, m_bBldossier, m_bBedRRetourniert As SqlBoolean

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsDokument Class
clsDokument clsDokument Members


m_bAmsdokument Field

m_bAmsdokument Field

m_bAmsdokument Field | Previous topic | Next topic
m_bAmsdokument Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_bAmsdokument As SqlBoolean

C#

private SqlBoolean m_bAmsdokument

C++

private:
SqlBoolean m_bAmsdokument;

JScript

private m_bAmsdokument : SqlBoolean

Source code

Visual Basic

Copy Code Copy Code

Private m_bBereit_zur_archivierung, m_bAusgangsarchiviert, m_bUnvollstaendig, m_bGesperrt, m_bAuserstuebernahme, m_bZu_retournieren, m_bAmsdokument, m_bAktiv, m_bZustaendig_kube, m_bEingangsarchiviert, m_bVertraulich, m_bFapartnerwechsel, m_bBl_scan, m_bOfficedokumentgeloescht, m_bFAStatuswechsel, m_bFAVerantwortlicherwechsel, m_bBldossier, m_bBedRRetourniert As SqlBoolean

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsDokument Class
clsDokument clsDokument Members


m_bAuserstuebernahme Field

m_bAuserstuebernahme Field

m_bAuserstuebernahme Field | Previous topic | Next topic
m_bAuserstuebernahme Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_bAuserstuebernahme As SqlBoolean

C#

private SqlBoolean m_bAuserstuebernahme

C++

private:
SqlBoolean m_bAuserstuebernahme;

JScript

private m_bAuserstuebernahme : SqlBoolean

Source code

Visual Basic

Copy Code Copy Code

Private m_bBereit_zur_archivierung, m_bAusgangsarchiviert, m_bUnvollstaendig, m_bGesperrt, m_bAuserstuebernahme, m_bZu_retournieren, m_bAmsdokument, m_bAktiv, m_bZustaendig_kube, m_bEingangsarchiviert, m_bVertraulich, m_bFapartnerwechsel, m_bBl_scan, m_bOfficedokumentgeloescht, m_bFAStatuswechsel, m_bFAVerantwortlicherwechsel, m_bBldossier, m_bBedRRetourniert As SqlBoolean

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsDokument Class
clsDokument clsDokument Members


m_bAusgangsarchiviert Field

m_bAusgangsarchiviert Field

m_bAusgangsarchiviert Field | Previous topic | Next topic
m_bAusgangsarchiviert Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_bAusgangsarchiviert As SqlBoolean

C#

private SqlBoolean m_bAusgangsarchiviert

C++

private:
SqlBoolean m_bAusgangsarchiviert;

JScript

private m_bAusgangsarchiviert : SqlBoolean

Source code

Visual Basic

Copy Code Copy Code

Private m_bBereit_zur_archivierung, m_bAusgangsarchiviert, m_bUnvollstaendig, m_bGesperrt, m_bAuserstuebernahme, m_bZu_retournieren, m_bAmsdokument, m_bAktiv, m_bZustaendig_kube, m_bEingangsarchiviert, m_bVertraulich, m_bFapartnerwechsel, m_bBl_scan, m_bOfficedokumentgeloescht, m_bFAStatuswechsel, m_bFAVerantwortlicherwechsel, m_bBldossier, m_bBedRRetourniert As SqlBoolean

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsDokument Class
clsDokument clsDokument Members


m_bBedRRetourniert Field

m_bBedRRetourniert Field

m_bBedRRetourniert Field | Previous topic | Next topic
m_bBedRRetourniert Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_bBedRRetourniert As SqlBoolean

C#

private SqlBoolean m_bBedRRetourniert

C++

private:
SqlBoolean m_bBedRRetourniert;

JScript

private m_bBedRRetourniert : SqlBoolean

Source code

Visual Basic

Copy Code Copy Code

Private m_bBereit_zur_archivierung, m_bAusgangsarchiviert, m_bUnvollstaendig, m_bGesperrt, m_bAuserstuebernahme, m_bZu_retournieren, m_bAmsdokument, m_bAktiv, m_bZustaendig_kube, m_bEingangsarchiviert, m_bVertraulich, m_bFapartnerwechsel, m_bBl_scan, m_bOfficedokumentgeloescht, m_bFAStatuswechsel, m_bFAVerantwortlicherwechsel, m_bBldossier, m_bBedRRetourniert As SqlBoolean

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsDokument Class
clsDokument clsDokument Members


m_bBereit_zur_archivierung Field

m_bBereit_zur_archivierung Field

m_bBereit_zur_archivierung Field | Previous topic | Next topic
m_bBereit_zur_archivierung Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_bBereit_zur_archivierung As SqlBoolean

C#

private SqlBoolean m_bBereit_zur_archivierung

C++

private:
SqlBoolean m_bBereit_zur_archivierung;

JScript

private m_bBereit_zur_archivierung : SqlBoolean

Source code

Visual Basic

Copy Code Copy Code

Private m_bBereit_zur_archivierung, m_bAusgangsarchiviert, m_bUnvollstaendig, m_bGesperrt, m_bAuserstuebernahme, m_bZu_retournieren, m_bAmsdokument, m_bAktiv, m_bZustaendig_kube, m_bEingangsarchiviert, m_bVertraulich, m_bFapartnerwechsel, m_bBl_scan, m_bOfficedokumentgeloescht, m_bFAStatuswechsel, m_bFAVerantwortlicherwechsel, m_bBldossier, m_bBedRRetourniert As SqlBoolean

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsDokument Class
clsDokument clsDokument Members


m_bBl_scan Field

m_bBl_scan Field

m_bBl_scan Field | Previous topic | Next topic
m_bBl_scan Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_bBl_scan As SqlBoolean

C#

private SqlBoolean m_bBl_scan

C++

private:
SqlBoolean m_bBl_scan;

JScript

private m_bBl_scan : SqlBoolean

Source code

Visual Basic

Copy Code Copy Code

Private m_bBereit_zur_archivierung, m_bAusgangsarchiviert, m_bUnvollstaendig, m_bGesperrt, m_bAuserstuebernahme, m_bZu_retournieren, m_bAmsdokument, m_bAktiv, m_bZustaendig_kube, m_bEingangsarchiviert, m_bVertraulich, m_bFapartnerwechsel, m_bBl_scan, m_bOfficedokumentgeloescht, m_bFAStatuswechsel, m_bFAVerantwortlicherwechsel, m_bBldossier, m_bBedRRetourniert As SqlBoolean

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsDokument Class
clsDokument clsDokument Members


m_bBldossier Field

m_bBldossier Field

m_bBldossier Field | Previous topic | Next topic
m_bBldossier Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_bBldossier As SqlBoolean

C#

private SqlBoolean m_bBldossier

C++

private:
SqlBoolean m_bBldossier;

JScript

private m_bBldossier : SqlBoolean

Source code

Visual Basic

Copy Code Copy Code

Private m_bBereit_zur_archivierung, m_bAusgangsarchiviert, m_bUnvollstaendig, m_bGesperrt, m_bAuserstuebernahme, m_bZu_retournieren, m_bAmsdokument, m_bAktiv, m_bZustaendig_kube, m_bEingangsarchiviert, m_bVertraulich, m_bFapartnerwechsel, m_bBl_scan, m_bOfficedokumentgeloescht, m_bFAStatuswechsel, m_bFAVerantwortlicherwechsel, m_bBldossier, m_bBedRRetourniert As SqlBoolean

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsDokument Class
clsDokument clsDokument Members


m_bEingangsarchiviert Field

m_bEingangsarchiviert Field

m_bEingangsarchiviert Field | Previous topic | Next topic
m_bEingangsarchiviert Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_bEingangsarchiviert As SqlBoolean

C#

private SqlBoolean m_bEingangsarchiviert

C++

private:
SqlBoolean m_bEingangsarchiviert;

JScript

private m_bEingangsarchiviert : SqlBoolean

Source code

Visual Basic

Copy Code Copy Code

Private m_bBereit_zur_archivierung, m_bAusgangsarchiviert, m_bUnvollstaendig, m_bGesperrt, m_bAuserstuebernahme, m_bZu_retournieren, m_bAmsdokument, m_bAktiv, m_bZustaendig_kube, m_bEingangsarchiviert, m_bVertraulich, m_bFapartnerwechsel, m_bBl_scan, m_bOfficedokumentgeloescht, m_bFAStatuswechsel, m_bFAVerantwortlicherwechsel, m_bBldossier, m_bBedRRetourniert As SqlBoolean

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsDokument Class
clsDokument clsDokument Members


m_bFAStatuswechsel Field

m_bFAStatuswechsel Field

m_bFAStatuswechsel Field | Previous topic | Next topic
m_bFAStatuswechsel Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_bFAStatuswechsel As SqlBoolean

C#

private SqlBoolean m_bFAStatuswechsel

C++

private:
SqlBoolean m_bFAStatuswechsel;

JScript

private m_bFAStatuswechsel : SqlBoolean

Source code

Visual Basic

Copy Code Copy Code

Private m_bBereit_zur_archivierung, m_bAusgangsarchiviert, m_bUnvollstaendig, m_bGesperrt, m_bAuserstuebernahme, m_bZu_retournieren, m_bAmsdokument, m_bAktiv, m_bZustaendig_kube, m_bEingangsarchiviert, m_bVertraulich, m_bFapartnerwechsel, m_bBl_scan, m_bOfficedokumentgeloescht, m_bFAStatuswechsel, m_bFAVerantwortlicherwechsel, m_bBldossier, m_bBedRRetourniert As SqlBoolean

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsDokument Class
clsDokument clsDokument Members


m_bFAVerantwortlicherwechsel Field

m_bFAVerantwortlicherwechsel Field

m_bFAVerantwortlicherwechsel Field | Previous topic | Next topic
m_bFAVerantwortlicherwechsel Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_bFAVerantwortlicherwechsel As SqlBoolean

C#

private SqlBoolean m_bFAVerantwortlicherwechsel

C++

private:
SqlBoolean m_bFAVerantwortlicherwechsel;

JScript

private m_bFAVerantwortlicherwechsel : SqlBoolean

Source code

Visual Basic

Copy Code Copy Code

Private m_bBereit_zur_archivierung, m_bAusgangsarchiviert, m_bUnvollstaendig, m_bGesperrt, m_bAuserstuebernahme, m_bZu_retournieren, m_bAmsdokument, m_bAktiv, m_bZustaendig_kube, m_bEingangsarchiviert, m_bVertraulich, m_bFapartnerwechsel, m_bBl_scan, m_bOfficedokumentgeloescht, m_bFAStatuswechsel, m_bFAVerantwortlicherwechsel, m_bBldossier, m_bBedRRetourniert As SqlBoolean

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsDokument Class
clsDokument clsDokument Members


m_bFapartnerwechsel Field

m_bFapartnerwechsel Field

m_bFapartnerwechsel Field | Previous topic | Next topic
m_bFapartnerwechsel Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_bFapartnerwechsel As SqlBoolean

C#

private SqlBoolean m_bFapartnerwechsel

C++

private:
SqlBoolean m_bFapartnerwechsel;

JScript

private m_bFapartnerwechsel : SqlBoolean

Source code

Visual Basic

Copy Code Copy Code

Private m_bBereit_zur_archivierung, m_bAusgangsarchiviert, m_bUnvollstaendig, m_bGesperrt, m_bAuserstuebernahme, m_bZu_retournieren, m_bAmsdokument, m_bAktiv, m_bZustaendig_kube, m_bEingangsarchiviert, m_bVertraulich, m_bFapartnerwechsel, m_bBl_scan, m_bOfficedokumentgeloescht, m_bFAStatuswechsel, m_bFAVerantwortlicherwechsel, m_bBldossier, m_bBedRRetourniert As SqlBoolean

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsDokument Class
clsDokument clsDokument Members


m_bGesperrt Field

m_bGesperrt Field

m_bGesperrt Field | Previous topic | Next topic
m_bGesperrt Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_bGesperrt As SqlBoolean

C#

private SqlBoolean m_bGesperrt

C++

private:
SqlBoolean m_bGesperrt;

JScript

private m_bGesperrt : SqlBoolean

Source code

Visual Basic

Copy Code Copy Code

Private m_bBereit_zur_archivierung, m_bAusgangsarchiviert, m_bUnvollstaendig, m_bGesperrt, m_bAuserstuebernahme, m_bZu_retournieren, m_bAmsdokument, m_bAktiv, m_bZustaendig_kube, m_bEingangsarchiviert, m_bVertraulich, m_bFapartnerwechsel, m_bBl_scan, m_bOfficedokumentgeloescht, m_bFAStatuswechsel, m_bFAVerantwortlicherwechsel, m_bBldossier, m_bBedRRetourniert As SqlBoolean

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsDokument Class
clsDokument clsDokument Members


m_bOfficedokumentgeloescht Field

m_bOfficedokumentgeloescht Field

m_bOfficedokumentgeloescht Field | Previous topic | Next topic
m_bOfficedokumentgeloescht Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_bOfficedokumentgeloescht As SqlBoolean

C#

private SqlBoolean m_bOfficedokumentgeloescht

C++

private:
SqlBoolean m_bOfficedokumentgeloescht;

JScript

private m_bOfficedokumentgeloescht : SqlBoolean

Source code

Visual Basic

Copy Code Copy Code

Private m_bBereit_zur_archivierung, m_bAusgangsarchiviert, m_bUnvollstaendig, m_bGesperrt, m_bAuserstuebernahme, m_bZu_retournieren, m_bAmsdokument, m_bAktiv, m_bZustaendig_kube, m_bEingangsarchiviert, m_bVertraulich, m_bFapartnerwechsel, m_bBl_scan, m_bOfficedokumentgeloescht, m_bFAStatuswechsel, m_bFAVerantwortlicherwechsel, m_bBldossier, m_bBedRRetourniert As SqlBoolean

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsDokument Class
clsDokument clsDokument Members


m_bUnvollstaendig Field

m_bUnvollstaendig Field

m_bUnvollstaendig Field | Previous topic | Next topic
m_bUnvollstaendig Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_bUnvollstaendig As SqlBoolean

C#

private SqlBoolean m_bUnvollstaendig

C++

private:
SqlBoolean m_bUnvollstaendig;

JScript

private m_bUnvollstaendig : SqlBoolean

Source code

Visual Basic

Copy Code Copy Code

Private m_bBereit_zur_archivierung, m_bAusgangsarchiviert, m_bUnvollstaendig, m_bGesperrt, m_bAuserstuebernahme, m_bZu_retournieren, m_bAmsdokument, m_bAktiv, m_bZustaendig_kube, m_bEingangsarchiviert, m_bVertraulich, m_bFapartnerwechsel, m_bBl_scan, m_bOfficedokumentgeloescht, m_bFAStatuswechsel, m_bFAVerantwortlicherwechsel, m_bBldossier, m_bBedRRetourniert As SqlBoolean

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsDokument Class
clsDokument clsDokument Members


m_bVertraulich Field

m_bVertraulich Field

m_bVertraulich Field | Previous topic | Next topic
m_bVertraulich Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_bVertraulich As SqlBoolean

C#

private SqlBoolean m_bVertraulich

C++

private:
SqlBoolean m_bVertraulich;

JScript

private m_bVertraulich : SqlBoolean

Source code

Visual Basic

Copy Code Copy Code

Private m_bBereit_zur_archivierung, m_bAusgangsarchiviert, m_bUnvollstaendig, m_bGesperrt, m_bAuserstuebernahme, m_bZu_retournieren, m_bAmsdokument, m_bAktiv, m_bZustaendig_kube, m_bEingangsarchiviert, m_bVertraulich, m_bFapartnerwechsel, m_bBl_scan, m_bOfficedokumentgeloescht, m_bFAStatuswechsel, m_bFAVerantwortlicherwechsel, m_bBldossier, m_bBedRRetourniert As SqlBoolean

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsDokument Class
clsDokument clsDokument Members


m_bZu_retournieren Field

m_bZu_retournieren Field

m_bZu_retournieren Field | Previous topic | Next topic
m_bZu_retournieren Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_bZu_retournieren As SqlBoolean

C#

private SqlBoolean m_bZu_retournieren

C++

private:
SqlBoolean m_bZu_retournieren;

JScript

private m_bZu_retournieren : SqlBoolean

Source code

Visual Basic

Copy Code Copy Code

Private m_bBereit_zur_archivierung, m_bAusgangsarchiviert, m_bUnvollstaendig, m_bGesperrt, m_bAuserstuebernahme, m_bZu_retournieren, m_bAmsdokument, m_bAktiv, m_bZustaendig_kube, m_bEingangsarchiviert, m_bVertraulich, m_bFapartnerwechsel, m_bBl_scan, m_bOfficedokumentgeloescht, m_bFAStatuswechsel, m_bFAVerantwortlicherwechsel, m_bBldossier, m_bBedRRetourniert As SqlBoolean

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsDokument Class
clsDokument clsDokument Members


m_bZustaendig_kube Field

m_bZustaendig_kube Field

m_bZustaendig_kube Field | Previous topic | Next topic
m_bZustaendig_kube Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_bZustaendig_kube As SqlBoolean

C#

private SqlBoolean m_bZustaendig_kube

C++

private:
SqlBoolean m_bZustaendig_kube;

JScript

private m_bZustaendig_kube : SqlBoolean

Source code

Visual Basic

Copy Code Copy Code

Private m_bBereit_zur_archivierung, m_bAusgangsarchiviert, m_bUnvollstaendig, m_bGesperrt, m_bAuserstuebernahme, m_bZu_retournieren, m_bAmsdokument, m_bAktiv, m_bZustaendig_kube, m_bEingangsarchiviert, m_bVertraulich, m_bFapartnerwechsel, m_bBl_scan, m_bOfficedokumentgeloescht, m_bFAStatuswechsel, m_bFAVerantwortlicherwechsel, m_bBldossier, m_bBedRRetourniert As SqlBoolean

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsDokument Class
clsDokument clsDokument Members


m_daArchivierungsdatum Field

m_daArchivierungsdatum Field

m_daArchivierungsdatum Field | Previous topic | Next topic
m_daArchivierungsdatum Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_daArchivierungsdatum As SqlDateTime

C#

private SqlDateTime m_daArchivierungsdatum

C++

private:
SqlDateTime m_daArchivierungsdatum;

JScript

private m_daArchivierungsdatum : SqlDateTime

Source code

Visual Basic

Copy Code Copy Code

Private m_daArchivierungsdatum, m_daTermin, m_daDatum_ausgangsarchivierung, m_daErstellungsdatum, m_daDatum_eingangsarchivierung, m_daGesperrtam, m_daErinnerungam, m_daMutiertam, m_daErstelltam As SqlDateTime

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsDokument Class
clsDokument clsDokument Members


m_daDatum_ausgangsarchivierung Field

m_daDatum_ausgangsarchivierung Field

m_daDatum_ausgangsarchivierung Field | Previous topic | Next topic
m_daDatum_ausgangsarchivierung Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_daDatum_ausgangsarchivierung As SqlDateTime

C#

private SqlDateTime m_daDatum_ausgangsarchivierung

C++

private:
SqlDateTime m_daDatum_ausgangsarchivierung;

JScript

private m_daDatum_ausgangsarchivierung : SqlDateTime

Source code

Visual Basic

Copy Code Copy Code

Private m_daArchivierungsdatum, m_daTermin, m_daDatum_ausgangsarchivierung, m_daErstellungsdatum, m_daDatum_eingangsarchivierung, m_daGesperrtam, m_daErinnerungam, m_daMutiertam, m_daErstelltam As SqlDateTime

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsDokument Class
clsDokument clsDokument Members


m_daDatum_eingangsarchivierung Field

m_daDatum_eingangsarchivierung Field

m_daDatum_eingangsarchivierung Field | Previous topic | Next topic
m_daDatum_eingangsarchivierung Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_daDatum_eingangsarchivierung As SqlDateTime

C#

private SqlDateTime m_daDatum_eingangsarchivierung

C++

private:
SqlDateTime m_daDatum_eingangsarchivierung;

JScript

private m_daDatum_eingangsarchivierung : SqlDateTime

Source code

Visual Basic

Copy Code Copy Code

Private m_daArchivierungsdatum, m_daTermin, m_daDatum_ausgangsarchivierung, m_daErstellungsdatum, m_daDatum_eingangsarchivierung, m_daGesperrtam, m_daErinnerungam, m_daMutiertam, m_daErstelltam As SqlDateTime

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsDokument Class
clsDokument clsDokument Members


m_daErinnerungam Field

m_daErinnerungam Field

m_daErinnerungam Field | Previous topic | Next topic
m_daErinnerungam Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_daErinnerungam As SqlDateTime

C#

private SqlDateTime m_daErinnerungam

C++

private:
SqlDateTime m_daErinnerungam;

JScript

private m_daErinnerungam : SqlDateTime

Source code

Visual Basic

Copy Code Copy Code

Private m_daArchivierungsdatum, m_daTermin, m_daDatum_ausgangsarchivierung, m_daErstellungsdatum, m_daDatum_eingangsarchivierung, m_daGesperrtam, m_daErinnerungam, m_daMutiertam, m_daErstelltam As SqlDateTime

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsDokument Class
clsDokument clsDokument Members


m_daErstelltam Field

m_daErstelltam Field

m_daErstelltam Field | Previous topic | Next topic
m_daErstelltam Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_daErstelltam As SqlDateTime

C#

private SqlDateTime m_daErstelltam

C++

private:
SqlDateTime m_daErstelltam;

JScript

private m_daErstelltam : SqlDateTime

Source code

Visual Basic

Copy Code Copy Code

Private m_daArchivierungsdatum, m_daTermin, m_daDatum_ausgangsarchivierung, m_daErstellungsdatum, m_daDatum_eingangsarchivierung, m_daGesperrtam, m_daErinnerungam, m_daMutiertam, m_daErstelltam As SqlDateTime

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsDokument Class
clsDokument clsDokument Members


m_daErstellungsdatum Field

m_daErstellungsdatum Field

m_daErstellungsdatum Field | Previous topic | Next topic
m_daErstellungsdatum Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_daErstellungsdatum As SqlDateTime

C#

private SqlDateTime m_daErstellungsdatum

C++

private:
SqlDateTime m_daErstellungsdatum;

JScript

private m_daErstellungsdatum : SqlDateTime

Source code

Visual Basic

Copy Code Copy Code

Private m_daArchivierungsdatum, m_daTermin, m_daDatum_ausgangsarchivierung, m_daErstellungsdatum, m_daDatum_eingangsarchivierung, m_daGesperrtam, m_daErinnerungam, m_daMutiertam, m_daErstelltam As SqlDateTime

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsDokument Class
clsDokument clsDokument Members


m_daGesperrtam Field

m_daGesperrtam Field

m_daGesperrtam Field | Previous topic | Next topic
m_daGesperrtam Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_daGesperrtam As SqlDateTime

C#

private SqlDateTime m_daGesperrtam

C++

private:
SqlDateTime m_daGesperrtam;

JScript

private m_daGesperrtam : SqlDateTime

Source code

Visual Basic

Copy Code Copy Code

Private m_daArchivierungsdatum, m_daTermin, m_daDatum_ausgangsarchivierung, m_daErstellungsdatum, m_daDatum_eingangsarchivierung, m_daGesperrtam, m_daErinnerungam, m_daMutiertam, m_daErstelltam As SqlDateTime

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsDokument Class
clsDokument clsDokument Members


m_daMutiertam Field

m_daMutiertam Field

m_daMutiertam Field | Previous topic | Next topic
m_daMutiertam Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_daMutiertam As SqlDateTime

C#

private SqlDateTime m_daMutiertam

C++

private:
SqlDateTime m_daMutiertam;

JScript

private m_daMutiertam : SqlDateTime

Source code

Visual Basic

Copy Code Copy Code

Private m_daArchivierungsdatum, m_daTermin, m_daDatum_ausgangsarchivierung, m_daErstellungsdatum, m_daDatum_eingangsarchivierung, m_daGesperrtam, m_daErinnerungam, m_daMutiertam, m_daErstelltam As SqlDateTime

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsDokument Class
clsDokument clsDokument Members


m_daTermin Field

m_daTermin Field

m_daTermin Field | Previous topic | Next topic
m_daTermin Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_daTermin As SqlDateTime

C#

private SqlDateTime m_daTermin

C++

private:
SqlDateTime m_daTermin;

JScript

private m_daTermin : SqlDateTime

Source code

Visual Basic

Copy Code Copy Code

Private m_daArchivierungsdatum, m_daTermin, m_daDatum_ausgangsarchivierung, m_daErstellungsdatum, m_daDatum_eingangsarchivierung, m_daGesperrtam, m_daErinnerungam, m_daMutiertam, m_daErstelltam As SqlDateTime

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsDokument Class
clsDokument clsDokument Members


m_iAnzeigeStatus Field

m_iAnzeigeStatus Field

m_iAnzeigeStatus Field | Previous topic | Next topic
m_iAnzeigeStatus Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_iAnzeigeStatus As SqlInt32

C#

private SqlInt32 m_iAnzeigeStatus

C++

private:
SqlInt32 m_iAnzeigeStatus;

JScript

private m_iAnzeigeStatus : SqlInt32

Source code

Visual Basic

Copy Code Copy Code

Private m_iUnterschriftrechts, m_iAnzeigeStatus, m_iPostzustellung, m_iStatusnr, m_iAufbewahrung_elektronisch, m_iMonierung_in_tagen, m_iAufbewahrung_phaysisch, m_iBearbeitung_nach_abschluss, m_iIn_edoka_datenbank, m_iDokdurchkubeweitergegeben, m_iMutiererteam, m_iBRVernichtungnachTagen, m_iBearbeitungszeit_in_minuten, m_iBck, m_iGesperrt_durch, m_iMutierertieam, m_iDokumenttypnr, m_iMa_eingangsarchivierung, m_iMa_ausgangsarchivierung, m_iMutierer, m_iMitarbeiternr1, m_iMitarbeiternr, m_iNrpar00, m_iErstellerteam, m_iErsteller, m_iZustaendiger, m_iColdstatus, m_iVerantwortlich, m_iUnterschriftlinks, m_iBarcodenr, m_iStatus_edoka_batch_ausgang, m_iStatus_edoka_batch_eingang As SqlInt32

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsDokument Class
clsDokument clsDokument Members


m_iAufbewahrung_elektronisch Field

m_iAufbewahrung_elektronisch Field

m_iAufbewahrung_elektronisch Field | Previous topic | Next topic
m_iAufbewahrung_elektronisch Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_iAufbewahrung_elektronisch As SqlInt32

C#

private SqlInt32 m_iAufbewahrung_elektronisch

C++

private:
SqlInt32 m_iAufbewahrung_elektronisch;

JScript

private m_iAufbewahrung_elektronisch : SqlInt32

Source code

Visual Basic

Copy Code Copy Code

Private m_iUnterschriftrechts, m_iAnzeigeStatus, m_iPostzustellung, m_iStatusnr, m_iAufbewahrung_elektronisch, m_iMonierung_in_tagen, m_iAufbewahrung_phaysisch, m_iBearbeitung_nach_abschluss, m_iIn_edoka_datenbank, m_iDokdurchkubeweitergegeben, m_iMutiererteam, m_iBRVernichtungnachTagen, m_iBearbeitungszeit_in_minuten, m_iBck, m_iGesperrt_durch, m_iMutierertieam, m_iDokumenttypnr, m_iMa_eingangsarchivierung, m_iMa_ausgangsarchivierung, m_iMutierer, m_iMitarbeiternr1, m_iMitarbeiternr, m_iNrpar00, m_iErstellerteam, m_iErsteller, m_iZustaendiger, m_iColdstatus, m_iVerantwortlich, m_iUnterschriftlinks, m_iBarcodenr, m_iStatus_edoka_batch_ausgang, m_iStatus_edoka_batch_eingang As SqlInt32

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsDokument Class
clsDokument clsDokument Members


m_iAufbewahrung_phaysisch Field

m_iAufbewahrung_phaysisch Field

m_iAufbewahrung_phaysisch Field | Previous topic | Next topic
m_iAufbewahrung_phaysisch Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_iAufbewahrung_phaysisch As SqlInt32

C#

private SqlInt32 m_iAufbewahrung_phaysisch

C++

private:
SqlInt32 m_iAufbewahrung_phaysisch;

JScript

private m_iAufbewahrung_phaysisch : SqlInt32

Source code

Visual Basic

Copy Code Copy Code

Private m_iUnterschriftrechts, m_iAnzeigeStatus, m_iPostzustellung, m_iStatusnr, m_iAufbewahrung_elektronisch, m_iMonierung_in_tagen, m_iAufbewahrung_phaysisch, m_iBearbeitung_nach_abschluss, m_iIn_edoka_datenbank, m_iDokdurchkubeweitergegeben, m_iMutiererteam, m_iBRVernichtungnachTagen, m_iBearbeitungszeit_in_minuten, m_iBck, m_iGesperrt_durch, m_iMutierertieam, m_iDokumenttypnr, m_iMa_eingangsarchivierung, m_iMa_ausgangsarchivierung, m_iMutierer, m_iMitarbeiternr1, m_iMitarbeiternr, m_iNrpar00, m_iErstellerteam, m_iErsteller, m_iZustaendiger, m_iColdstatus, m_iVerantwortlich, m_iUnterschriftlinks, m_iBarcodenr, m_iStatus_edoka_batch_ausgang, m_iStatus_edoka_batch_eingang As SqlInt32

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsDokument Class
clsDokument clsDokument Members


m_iBRVernichtungnachTagen Field

m_iBRVernichtungnachTagen Field

m_iBRVernichtungnachTagen Field | Previous topic | Next topic
m_iBRVernichtungnachTagen Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_iBRVernichtungnachTagen As SqlInt32

C#

private SqlInt32 m_iBRVernichtungnachTagen

C++

private:
SqlInt32 m_iBRVernichtungnachTagen;

JScript

private m_iBRVernichtungnachTagen : SqlInt32

Source code

Visual Basic

Copy Code Copy Code

Private m_iUnterschriftrechts, m_iAnzeigeStatus, m_iPostzustellung, m_iStatusnr, m_iAufbewahrung_elektronisch, m_iMonierung_in_tagen, m_iAufbewahrung_phaysisch, m_iBearbeitung_nach_abschluss, m_iIn_edoka_datenbank, m_iDokdurchkubeweitergegeben, m_iMutiererteam, m_iBRVernichtungnachTagen, m_iBearbeitungszeit_in_minuten, m_iBck, m_iGesperrt_durch, m_iMutierertieam, m_iDokumenttypnr, m_iMa_eingangsarchivierung, m_iMa_ausgangsarchivierung, m_iMutierer, m_iMitarbeiternr1, m_iMitarbeiternr, m_iNrpar00, m_iErstellerteam, m_iErsteller, m_iZustaendiger, m_iColdstatus, m_iVerantwortlich, m_iUnterschriftlinks, m_iBarcodenr, m_iStatus_edoka_batch_ausgang, m_iStatus_edoka_batch_eingang As SqlInt32

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsDokument Class
clsDokument clsDokument Members


m_iBarcodenr Field

m_iBarcodenr Field

m_iBarcodenr Field | Previous topic | Next topic
m_iBarcodenr Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_iBarcodenr As SqlInt32

C#

private SqlInt32 m_iBarcodenr

C++

private:
SqlInt32 m_iBarcodenr;

JScript

private m_iBarcodenr : SqlInt32

Source code

Visual Basic

Copy Code Copy Code

Private m_iUnterschriftrechts, m_iAnzeigeStatus, m_iPostzustellung, m_iStatusnr, m_iAufbewahrung_elektronisch, m_iMonierung_in_tagen, m_iAufbewahrung_phaysisch, m_iBearbeitung_nach_abschluss, m_iIn_edoka_datenbank, m_iDokdurchkubeweitergegeben, m_iMutiererteam, m_iBRVernichtungnachTagen, m_iBearbeitungszeit_in_minuten, m_iBck, m_iGesperrt_durch, m_iMutierertieam, m_iDokumenttypnr, m_iMa_eingangsarchivierung, m_iMa_ausgangsarchivierung, m_iMutierer, m_iMitarbeiternr1, m_iMitarbeiternr, m_iNrpar00, m_iErstellerteam, m_iErsteller, m_iZustaendiger, m_iColdstatus, m_iVerantwortlich, m_iUnterschriftlinks, m_iBarcodenr, m_iStatus_edoka_batch_ausgang, m_iStatus_edoka_batch_eingang As SqlInt32

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsDokument Class
clsDokument clsDokument Members


m_iBck Field

m_iBck Field

m_iBck Field | Previous topic | Next topic
m_iBck Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_iBck As SqlInt32

C#

private SqlInt32 m_iBck

C++

private:
SqlInt32 m_iBck;

JScript

private m_iBck : SqlInt32

Source code

Visual Basic

Copy Code Copy Code

Private m_iUnterschriftrechts, m_iAnzeigeStatus, m_iPostzustellung, m_iStatusnr, m_iAufbewahrung_elektronisch, m_iMonierung_in_tagen, m_iAufbewahrung_phaysisch, m_iBearbeitung_nach_abschluss, m_iIn_edoka_datenbank, m_iDokdurchkubeweitergegeben, m_iMutiererteam, m_iBRVernichtungnachTagen, m_iBearbeitungszeit_in_minuten, m_iBck, m_iGesperrt_durch, m_iMutierertieam, m_iDokumenttypnr, m_iMa_eingangsarchivierung, m_iMa_ausgangsarchivierung, m_iMutierer, m_iMitarbeiternr1, m_iMitarbeiternr, m_iNrpar00, m_iErstellerteam, m_iErsteller, m_iZustaendiger, m_iColdstatus, m_iVerantwortlich, m_iUnterschriftlinks, m_iBarcodenr, m_iStatus_edoka_batch_ausgang, m_iStatus_edoka_batch_eingang As SqlInt32

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsDokument Class
clsDokument clsDokument Members


m_iBearbeitung_nach_abschluss Field

m_iBearbeitung_nach_abschluss Field

m_iBearbeitung_nach_abschluss Field | Previous topic | Next topic
m_iBearbeitung_nach_abschluss Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_iBearbeitung_nach_abschluss As SqlInt32

C#

private SqlInt32 m_iBearbeitung_nach_abschluss

C++

private:
SqlInt32 m_iBearbeitung_nach_abschluss;

JScript

private m_iBearbeitung_nach_abschluss : SqlInt32

Source code

Visual Basic

Copy Code Copy Code

Private m_iUnterschriftrechts, m_iAnzeigeStatus, m_iPostzustellung, m_iStatusnr, m_iAufbewahrung_elektronisch, m_iMonierung_in_tagen, m_iAufbewahrung_phaysisch, m_iBearbeitung_nach_abschluss, m_iIn_edoka_datenbank, m_iDokdurchkubeweitergegeben, m_iMutiererteam, m_iBRVernichtungnachTagen, m_iBearbeitungszeit_in_minuten, m_iBck, m_iGesperrt_durch, m_iMutierertieam, m_iDokumenttypnr, m_iMa_eingangsarchivierung, m_iMa_ausgangsarchivierung, m_iMutierer, m_iMitarbeiternr1, m_iMitarbeiternr, m_iNrpar00, m_iErstellerteam, m_iErsteller, m_iZustaendiger, m_iColdstatus, m_iVerantwortlich, m_iUnterschriftlinks, m_iBarcodenr, m_iStatus_edoka_batch_ausgang, m_iStatus_edoka_batch_eingang As SqlInt32

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsDokument Class
clsDokument clsDokument Members


m_iBearbeitungszeit_in_minuten Field

m_iBearbeitungszeit_in_minuten Field

m_iBearbeitungszeit_in_minuten Field | Previous topic | Next topic
m_iBearbeitungszeit_in_minuten Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_iBearbeitungszeit_in_minuten As SqlInt32

C#

private SqlInt32 m_iBearbeitungszeit_in_minuten

C++

private:
SqlInt32 m_iBearbeitungszeit_in_minuten;

JScript

private m_iBearbeitungszeit_in_minuten : SqlInt32

Source code

Visual Basic

Copy Code Copy Code

Private m_iUnterschriftrechts, m_iAnzeigeStatus, m_iPostzustellung, m_iStatusnr, m_iAufbewahrung_elektronisch, m_iMonierung_in_tagen, m_iAufbewahrung_phaysisch, m_iBearbeitung_nach_abschluss, m_iIn_edoka_datenbank, m_iDokdurchkubeweitergegeben, m_iMutiererteam, m_iBRVernichtungnachTagen, m_iBearbeitungszeit_in_minuten, m_iBck, m_iGesperrt_durch, m_iMutierertieam, m_iDokumenttypnr, m_iMa_eingangsarchivierung, m_iMa_ausgangsarchivierung, m_iMutierer, m_iMitarbeiternr1, m_iMitarbeiternr, m_iNrpar00, m_iErstellerteam, m_iErsteller, m_iZustaendiger, m_iColdstatus, m_iVerantwortlich, m_iUnterschriftlinks, m_iBarcodenr, m_iStatus_edoka_batch_ausgang, m_iStatus_edoka_batch_eingang As SqlInt32

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsDokument Class
clsDokument clsDokument Members


m_iColdstatus Field

m_iColdstatus Field

m_iColdstatus Field | Previous topic | Next topic
m_iColdstatus Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_iColdstatus As SqlInt32

C#

private SqlInt32 m_iColdstatus

C++

private:
SqlInt32 m_iColdstatus;

JScript

private m_iColdstatus : SqlInt32

Source code

Visual Basic

Copy Code Copy Code

Private m_iUnterschriftrechts, m_iAnzeigeStatus, m_iPostzustellung, m_iStatusnr, m_iAufbewahrung_elektronisch, m_iMonierung_in_tagen, m_iAufbewahrung_phaysisch, m_iBearbeitung_nach_abschluss, m_iIn_edoka_datenbank, m_iDokdurchkubeweitergegeben, m_iMutiererteam, m_iBRVernichtungnachTagen, m_iBearbeitungszeit_in_minuten, m_iBck, m_iGesperrt_durch, m_iMutierertieam, m_iDokumenttypnr, m_iMa_eingangsarchivierung, m_iMa_ausgangsarchivierung, m_iMutierer, m_iMitarbeiternr1, m_iMitarbeiternr, m_iNrpar00, m_iErstellerteam, m_iErsteller, m_iZustaendiger, m_iColdstatus, m_iVerantwortlich, m_iUnterschriftlinks, m_iBarcodenr, m_iStatus_edoka_batch_ausgang, m_iStatus_edoka_batch_eingang As SqlInt32

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsDokument Class
clsDokument clsDokument Members


m_iDokdurchkubeweitergegeben Field

m_iDokdurchkubeweitergegeben Field

m_iDokdurchkubeweitergegeben Field | Previous topic | Next topic
m_iDokdurchkubeweitergegeben Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_iDokdurchkubeweitergegeben As SqlInt32

C#

private SqlInt32 m_iDokdurchkubeweitergegeben

C++

private:
SqlInt32 m_iDokdurchkubeweitergegeben;

JScript

private m_iDokdurchkubeweitergegeben : SqlInt32

Source code

Visual Basic

Copy Code Copy Code

Private m_iUnterschriftrechts, m_iAnzeigeStatus, m_iPostzustellung, m_iStatusnr, m_iAufbewahrung_elektronisch, m_iMonierung_in_tagen, m_iAufbewahrung_phaysisch, m_iBearbeitung_nach_abschluss, m_iIn_edoka_datenbank, m_iDokdurchkubeweitergegeben, m_iMutiererteam, m_iBRVernichtungnachTagen, m_iBearbeitungszeit_in_minuten, m_iBck, m_iGesperrt_durch, m_iMutierertieam, m_iDokumenttypnr, m_iMa_eingangsarchivierung, m_iMa_ausgangsarchivierung, m_iMutierer, m_iMitarbeiternr1, m_iMitarbeiternr, m_iNrpar00, m_iErstellerteam, m_iErsteller, m_iZustaendiger, m_iColdstatus, m_iVerantwortlich, m_iUnterschriftlinks, m_iBarcodenr, m_iStatus_edoka_batch_ausgang, m_iStatus_edoka_batch_eingang As SqlInt32

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsDokument Class
clsDokument clsDokument Members


m_iDokumenttypnr Field

m_iDokumenttypnr Field

m_iDokumenttypnr Field | Previous topic | Next topic
m_iDokumenttypnr Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_iDokumenttypnr As SqlInt32

C#

private SqlInt32 m_iDokumenttypnr

C++

private:
SqlInt32 m_iDokumenttypnr;

JScript

private m_iDokumenttypnr : SqlInt32

Source code

Visual Basic

Copy Code Copy Code

Private m_iUnterschriftrechts, m_iAnzeigeStatus, m_iPostzustellung, m_iStatusnr, m_iAufbewahrung_elektronisch, m_iMonierung_in_tagen, m_iAufbewahrung_phaysisch, m_iBearbeitung_nach_abschluss, m_iIn_edoka_datenbank, m_iDokdurchkubeweitergegeben, m_iMutiererteam, m_iBRVernichtungnachTagen, m_iBearbeitungszeit_in_minuten, m_iBck, m_iGesperrt_durch, m_iMutierertieam, m_iDokumenttypnr, m_iMa_eingangsarchivierung, m_iMa_ausgangsarchivierung, m_iMutierer, m_iMitarbeiternr1, m_iMitarbeiternr, m_iNrpar00, m_iErstellerteam, m_iErsteller, m_iZustaendiger, m_iColdstatus, m_iVerantwortlich, m_iUnterschriftlinks, m_iBarcodenr, m_iStatus_edoka_batch_ausgang, m_iStatus_edoka_batch_eingang As SqlInt32

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsDokument Class
clsDokument clsDokument Members


m_iErsteller Field

m_iErsteller Field

m_iErsteller Field | Previous topic | Next topic
m_iErsteller Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_iErsteller As SqlInt32

C#

private SqlInt32 m_iErsteller

C++

private:
SqlInt32 m_iErsteller;

JScript

private m_iErsteller : SqlInt32

Source code

Visual Basic

Copy Code Copy Code

Private m_iUnterschriftrechts, m_iAnzeigeStatus, m_iPostzustellung, m_iStatusnr, m_iAufbewahrung_elektronisch, m_iMonierung_in_tagen, m_iAufbewahrung_phaysisch, m_iBearbeitung_nach_abschluss, m_iIn_edoka_datenbank, m_iDokdurchkubeweitergegeben, m_iMutiererteam, m_iBRVernichtungnachTagen, m_iBearbeitungszeit_in_minuten, m_iBck, m_iGesperrt_durch, m_iMutierertieam, m_iDokumenttypnr, m_iMa_eingangsarchivierung, m_iMa_ausgangsarchivierung, m_iMutierer, m_iMitarbeiternr1, m_iMitarbeiternr, m_iNrpar00, m_iErstellerteam, m_iErsteller, m_iZustaendiger, m_iColdstatus, m_iVerantwortlich, m_iUnterschriftlinks, m_iBarcodenr, m_iStatus_edoka_batch_ausgang, m_iStatus_edoka_batch_eingang As SqlInt32

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsDokument Class
clsDokument clsDokument Members


m_iErstellerteam Field

m_iErstellerteam Field

m_iErstellerteam Field | Previous topic | Next topic
m_iErstellerteam Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_iErstellerteam As SqlInt32

C#

private SqlInt32 m_iErstellerteam

C++

private:
SqlInt32 m_iErstellerteam;

JScript

private m_iErstellerteam : SqlInt32

Source code

Visual Basic

Copy Code Copy Code

Private m_iUnterschriftrechts, m_iAnzeigeStatus, m_iPostzustellung, m_iStatusnr, m_iAufbewahrung_elektronisch, m_iMonierung_in_tagen, m_iAufbewahrung_phaysisch, m_iBearbeitung_nach_abschluss, m_iIn_edoka_datenbank, m_iDokdurchkubeweitergegeben, m_iMutiererteam, m_iBRVernichtungnachTagen, m_iBearbeitungszeit_in_minuten, m_iBck, m_iGesperrt_durch, m_iMutierertieam, m_iDokumenttypnr, m_iMa_eingangsarchivierung, m_iMa_ausgangsarchivierung, m_iMutierer, m_iMitarbeiternr1, m_iMitarbeiternr, m_iNrpar00, m_iErstellerteam, m_iErsteller, m_iZustaendiger, m_iColdstatus, m_iVerantwortlich, m_iUnterschriftlinks, m_iBarcodenr, m_iStatus_edoka_batch_ausgang, m_iStatus_edoka_batch_eingang As SqlInt32

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsDokument Class
clsDokument clsDokument Members


m_iGesperrt_durch Field

m_iGesperrt_durch Field

m_iGesperrt_durch Field | Previous topic | Next topic
m_iGesperrt_durch Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_iGesperrt_durch As SqlInt32

C#

private SqlInt32 m_iGesperrt_durch

C++

private:
SqlInt32 m_iGesperrt_durch;

JScript

private m_iGesperrt_durch : SqlInt32

Source code

Visual Basic

Copy Code Copy Code

Private m_iUnterschriftrechts, m_iAnzeigeStatus, m_iPostzustellung, m_iStatusnr, m_iAufbewahrung_elektronisch, m_iMonierung_in_tagen, m_iAufbewahrung_phaysisch, m_iBearbeitung_nach_abschluss, m_iIn_edoka_datenbank, m_iDokdurchkubeweitergegeben, m_iMutiererteam, m_iBRVernichtungnachTagen, m_iBearbeitungszeit_in_minuten, m_iBck, m_iGesperrt_durch, m_iMutierertieam, m_iDokumenttypnr, m_iMa_eingangsarchivierung, m_iMa_ausgangsarchivierung, m_iMutierer, m_iMitarbeiternr1, m_iMitarbeiternr, m_iNrpar00, m_iErstellerteam, m_iErsteller, m_iZustaendiger, m_iColdstatus, m_iVerantwortlich, m_iUnterschriftlinks, m_iBarcodenr, m_iStatus_edoka_batch_ausgang, m_iStatus_edoka_batch_eingang As SqlInt32

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsDokument Class
clsDokument clsDokument Members


m_iIn_edoka_datenbank Field

m_iIn_edoka_datenbank Field

m_iIn_edoka_datenbank Field | Previous topic | Next topic
m_iIn_edoka_datenbank Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_iIn_edoka_datenbank As SqlInt32

C#

private SqlInt32 m_iIn_edoka_datenbank

C++

private:
SqlInt32 m_iIn_edoka_datenbank;

JScript

private m_iIn_edoka_datenbank : SqlInt32

Source code

Visual Basic

Copy Code Copy Code

Private m_iUnterschriftrechts, m_iAnzeigeStatus, m_iPostzustellung, m_iStatusnr, m_iAufbewahrung_elektronisch, m_iMonierung_in_tagen, m_iAufbewahrung_phaysisch, m_iBearbeitung_nach_abschluss, m_iIn_edoka_datenbank, m_iDokdurchkubeweitergegeben, m_iMutiererteam, m_iBRVernichtungnachTagen, m_iBearbeitungszeit_in_minuten, m_iBck, m_iGesperrt_durch, m_iMutierertieam, m_iDokumenttypnr, m_iMa_eingangsarchivierung, m_iMa_ausgangsarchivierung, m_iMutierer, m_iMitarbeiternr1, m_iMitarbeiternr, m_iNrpar00, m_iErstellerteam, m_iErsteller, m_iZustaendiger, m_iColdstatus, m_iVerantwortlich, m_iUnterschriftlinks, m_iBarcodenr, m_iStatus_edoka_batch_ausgang, m_iStatus_edoka_batch_eingang As SqlInt32

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsDokument Class
clsDokument clsDokument Members


m_iMa_ausgangsarchivierung Field

m_iMa_ausgangsarchivierung Field

m_iMa_ausgangsarchivierung Field | Previous topic | Next topic
m_iMa_ausgangsarchivierung Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_iMa_ausgangsarchivierung As SqlInt32

C#

private SqlInt32 m_iMa_ausgangsarchivierung

C++

private:
SqlInt32 m_iMa_ausgangsarchivierung;

JScript

private m_iMa_ausgangsarchivierung : SqlInt32

Source code

Visual Basic

Copy Code Copy Code

Private m_iUnterschriftrechts, m_iAnzeigeStatus, m_iPostzustellung, m_iStatusnr, m_iAufbewahrung_elektronisch, m_iMonierung_in_tagen, m_iAufbewahrung_phaysisch, m_iBearbeitung_nach_abschluss, m_iIn_edoka_datenbank, m_iDokdurchkubeweitergegeben, m_iMutiererteam, m_iBRVernichtungnachTagen, m_iBearbeitungszeit_in_minuten, m_iBck, m_iGesperrt_durch, m_iMutierertieam, m_iDokumenttypnr, m_iMa_eingangsarchivierung, m_iMa_ausgangsarchivierung, m_iMutierer, m_iMitarbeiternr1, m_iMitarbeiternr, m_iNrpar00, m_iErstellerteam, m_iErsteller, m_iZustaendiger, m_iColdstatus, m_iVerantwortlich, m_iUnterschriftlinks, m_iBarcodenr, m_iStatus_edoka_batch_ausgang, m_iStatus_edoka_batch_eingang As SqlInt32

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsDokument Class
clsDokument clsDokument Members


m_iMa_eingangsarchivierung Field

m_iMa_eingangsarchivierung Field

m_iMa_eingangsarchivierung Field | Previous topic | Next topic
m_iMa_eingangsarchivierung Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_iMa_eingangsarchivierung As SqlInt32

C#

private SqlInt32 m_iMa_eingangsarchivierung

C++

private:
SqlInt32 m_iMa_eingangsarchivierung;

JScript

private m_iMa_eingangsarchivierung : SqlInt32

Source code

Visual Basic

Copy Code Copy Code

Private m_iUnterschriftrechts, m_iAnzeigeStatus, m_iPostzustellung, m_iStatusnr, m_iAufbewahrung_elektronisch, m_iMonierung_in_tagen, m_iAufbewahrung_phaysisch, m_iBearbeitung_nach_abschluss, m_iIn_edoka_datenbank, m_iDokdurchkubeweitergegeben, m_iMutiererteam, m_iBRVernichtungnachTagen, m_iBearbeitungszeit_in_minuten, m_iBck, m_iGesperrt_durch, m_iMutierertieam, m_iDokumenttypnr, m_iMa_eingangsarchivierung, m_iMa_ausgangsarchivierung, m_iMutierer, m_iMitarbeiternr1, m_iMitarbeiternr, m_iNrpar00, m_iErstellerteam, m_iErsteller, m_iZustaendiger, m_iColdstatus, m_iVerantwortlich, m_iUnterschriftlinks, m_iBarcodenr, m_iStatus_edoka_batch_ausgang, m_iStatus_edoka_batch_eingang As SqlInt32

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsDokument Class
clsDokument clsDokument Members


m_iMitarbeiternr Field

m_iMitarbeiternr Field

m_iMitarbeiternr Field | Previous topic | Next topic
m_iMitarbeiternr Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_iMitarbeiternr As SqlInt32

C#

private SqlInt32 m_iMitarbeiternr

C++

private:
SqlInt32 m_iMitarbeiternr;

JScript

private m_iMitarbeiternr : SqlInt32

Source code

Visual Basic

Copy Code Copy Code

Private m_iUnterschriftrechts, m_iAnzeigeStatus, m_iPostzustellung, m_iStatusnr, m_iAufbewahrung_elektronisch, m_iMonierung_in_tagen, m_iAufbewahrung_phaysisch, m_iBearbeitung_nach_abschluss, m_iIn_edoka_datenbank, m_iDokdurchkubeweitergegeben, m_iMutiererteam, m_iBRVernichtungnachTagen, m_iBearbeitungszeit_in_minuten, m_iBck, m_iGesperrt_durch, m_iMutierertieam, m_iDokumenttypnr, m_iMa_eingangsarchivierung, m_iMa_ausgangsarchivierung, m_iMutierer, m_iMitarbeiternr1, m_iMitarbeiternr, m_iNrpar00, m_iErstellerteam, m_iErsteller, m_iZustaendiger, m_iColdstatus, m_iVerantwortlich, m_iUnterschriftlinks, m_iBarcodenr, m_iStatus_edoka_batch_ausgang, m_iStatus_edoka_batch_eingang As SqlInt32

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsDokument Class
clsDokument clsDokument Members


m_iMitarbeiternr1 Field

m_iMitarbeiternr1 Field

m_iMitarbeiternr1 Field | Previous topic | Next topic
m_iMitarbeiternr1 Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_iMitarbeiternr1 As SqlInt32

C#

private SqlInt32 m_iMitarbeiternr1

C++

private:
SqlInt32 m_iMitarbeiternr1;

JScript

private m_iMitarbeiternr1 : SqlInt32

Source code

Visual Basic

Copy Code Copy Code

Private m_iUnterschriftrechts, m_iAnzeigeStatus, m_iPostzustellung, m_iStatusnr, m_iAufbewahrung_elektronisch, m_iMonierung_in_tagen, m_iAufbewahrung_phaysisch, m_iBearbeitung_nach_abschluss, m_iIn_edoka_datenbank, m_iDokdurchkubeweitergegeben, m_iMutiererteam, m_iBRVernichtungnachTagen, m_iBearbeitungszeit_in_minuten, m_iBck, m_iGesperrt_durch, m_iMutierertieam, m_iDokumenttypnr, m_iMa_eingangsarchivierung, m_iMa_ausgangsarchivierung, m_iMutierer, m_iMitarbeiternr1, m_iMitarbeiternr, m_iNrpar00, m_iErstellerteam, m_iErsteller, m_iZustaendiger, m_iColdstatus, m_iVerantwortlich, m_iUnterschriftlinks, m_iBarcodenr, m_iStatus_edoka_batch_ausgang, m_iStatus_edoka_batch_eingang As SqlInt32

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsDokument Class
clsDokument clsDokument Members


m_iMonierung_in_tagen Field

m_iMonierung_in_tagen Field

m_iMonierung_in_tagen Field | Previous topic | Next topic
m_iMonierung_in_tagen Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_iMonierung_in_tagen As SqlInt32

C#

private SqlInt32 m_iMonierung_in_tagen

C++

private:
SqlInt32 m_iMonierung_in_tagen;

JScript

private m_iMonierung_in_tagen : SqlInt32

Source code

Visual Basic

Copy Code Copy Code

Private m_iUnterschriftrechts, m_iAnzeigeStatus, m_iPostzustellung, m_iStatusnr, m_iAufbewahrung_elektronisch, m_iMonierung_in_tagen, m_iAufbewahrung_phaysisch, m_iBearbeitung_nach_abschluss, m_iIn_edoka_datenbank, m_iDokdurchkubeweitergegeben, m_iMutiererteam, m_iBRVernichtungnachTagen, m_iBearbeitungszeit_in_minuten, m_iBck, m_iGesperrt_durch, m_iMutierertieam, m_iDokumenttypnr, m_iMa_eingangsarchivierung, m_iMa_ausgangsarchivierung, m_iMutierer, m_iMitarbeiternr1, m_iMitarbeiternr, m_iNrpar00, m_iErstellerteam, m_iErsteller, m_iZustaendiger, m_iColdstatus, m_iVerantwortlich, m_iUnterschriftlinks, m_iBarcodenr, m_iStatus_edoka_batch_ausgang, m_iStatus_edoka_batch_eingang As SqlInt32

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsDokument Class
clsDokument clsDokument Members


m_iMutierer Field

m_iMutierer Field

m_iMutierer Field | Previous topic | Next topic
m_iMutierer Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_iMutierer As SqlInt32

C#

private SqlInt32 m_iMutierer

C++

private:
SqlInt32 m_iMutierer;

JScript

private m_iMutierer : SqlInt32

Source code

Visual Basic

Copy Code Copy Code

Private m_iUnterschriftrechts, m_iAnzeigeStatus, m_iPostzustellung, m_iStatusnr, m_iAufbewahrung_elektronisch, m_iMonierung_in_tagen, m_iAufbewahrung_phaysisch, m_iBearbeitung_nach_abschluss, m_iIn_edoka_datenbank, m_iDokdurchkubeweitergegeben, m_iMutiererteam, m_iBRVernichtungnachTagen, m_iBearbeitungszeit_in_minuten, m_iBck, m_iGesperrt_durch, m_iMutierertieam, m_iDokumenttypnr, m_iMa_eingangsarchivierung, m_iMa_ausgangsarchivierung, m_iMutierer, m_iMitarbeiternr1, m_iMitarbeiternr, m_iNrpar00, m_iErstellerteam, m_iErsteller, m_iZustaendiger, m_iColdstatus, m_iVerantwortlich, m_iUnterschriftlinks, m_iBarcodenr, m_iStatus_edoka_batch_ausgang, m_iStatus_edoka_batch_eingang As SqlInt32

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsDokument Class
clsDokument clsDokument Members


m_iMutiererteam Field

m_iMutiererteam Field

m_iMutiererteam Field | Previous topic | Next topic
m_iMutiererteam Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_iMutiererteam As SqlInt32

C#

private SqlInt32 m_iMutiererteam

C++

private:
SqlInt32 m_iMutiererteam;

JScript

private m_iMutiererteam : SqlInt32

Source code

Visual Basic

Copy Code Copy Code

Private m_iUnterschriftrechts, m_iAnzeigeStatus, m_iPostzustellung, m_iStatusnr, m_iAufbewahrung_elektronisch, m_iMonierung_in_tagen, m_iAufbewahrung_phaysisch, m_iBearbeitung_nach_abschluss, m_iIn_edoka_datenbank, m_iDokdurchkubeweitergegeben, m_iMutiererteam, m_iBRVernichtungnachTagen, m_iBearbeitungszeit_in_minuten, m_iBck, m_iGesperrt_durch, m_iMutierertieam, m_iDokumenttypnr, m_iMa_eingangsarchivierung, m_iMa_ausgangsarchivierung, m_iMutierer, m_iMitarbeiternr1, m_iMitarbeiternr, m_iNrpar00, m_iErstellerteam, m_iErsteller, m_iZustaendiger, m_iColdstatus, m_iVerantwortlich, m_iUnterschriftlinks, m_iBarcodenr, m_iStatus_edoka_batch_ausgang, m_iStatus_edoka_batch_eingang As SqlInt32

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsDokument Class
clsDokument clsDokument Members


m_iMutierertieam Field

m_iMutierertieam Field

m_iMutierertieam Field | Previous topic | Next topic
m_iMutierertieam Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_iMutierertieam As SqlInt32

C#

private SqlInt32 m_iMutierertieam

C++

private:
SqlInt32 m_iMutierertieam;

JScript

private m_iMutierertieam : SqlInt32

Source code

Visual Basic

Copy Code Copy Code

Private m_iUnterschriftrechts, m_iAnzeigeStatus, m_iPostzustellung, m_iStatusnr, m_iAufbewahrung_elektronisch, m_iMonierung_in_tagen, m_iAufbewahrung_phaysisch, m_iBearbeitung_nach_abschluss, m_iIn_edoka_datenbank, m_iDokdurchkubeweitergegeben, m_iMutiererteam, m_iBRVernichtungnachTagen, m_iBearbeitungszeit_in_minuten, m_iBck, m_iGesperrt_durch, m_iMutierertieam, m_iDokumenttypnr, m_iMa_eingangsarchivierung, m_iMa_ausgangsarchivierung, m_iMutierer, m_iMitarbeiternr1, m_iMitarbeiternr, m_iNrpar00, m_iErstellerteam, m_iErsteller, m_iZustaendiger, m_iColdstatus, m_iVerantwortlich, m_iUnterschriftlinks, m_iBarcodenr, m_iStatus_edoka_batch_ausgang, m_iStatus_edoka_batch_eingang As SqlInt32

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsDokument Class
clsDokument clsDokument Members


m_iNrpar00 Field

m_iNrpar00 Field

m_iNrpar00 Field | Previous topic | Next topic
m_iNrpar00 Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_iNrpar00 As SqlInt32

C#

private SqlInt32 m_iNrpar00

C++

private:
SqlInt32 m_iNrpar00;

JScript

private m_iNrpar00 : SqlInt32

Source code

Visual Basic

Copy Code Copy Code

Private m_iUnterschriftrechts, m_iAnzeigeStatus, m_iPostzustellung, m_iStatusnr, m_iAufbewahrung_elektronisch, m_iMonierung_in_tagen, m_iAufbewahrung_phaysisch, m_iBearbeitung_nach_abschluss, m_iIn_edoka_datenbank, m_iDokdurchkubeweitergegeben, m_iMutiererteam, m_iBRVernichtungnachTagen, m_iBearbeitungszeit_in_minuten, m_iBck, m_iGesperrt_durch, m_iMutierertieam, m_iDokumenttypnr, m_iMa_eingangsarchivierung, m_iMa_ausgangsarchivierung, m_iMutierer, m_iMitarbeiternr1, m_iMitarbeiternr, m_iNrpar00, m_iErstellerteam, m_iErsteller, m_iZustaendiger, m_iColdstatus, m_iVerantwortlich, m_iUnterschriftlinks, m_iBarcodenr, m_iStatus_edoka_batch_ausgang, m_iStatus_edoka_batch_eingang As SqlInt32

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsDokument Class
clsDokument clsDokument Members


m_iPostzustellung Field

m_iPostzustellung Field

m_iPostzustellung Field | Previous topic | Next topic
m_iPostzustellung Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_iPostzustellung As SqlInt32

C#

private SqlInt32 m_iPostzustellung

C++

private:
SqlInt32 m_iPostzustellung;

JScript

private m_iPostzustellung : SqlInt32

Source code

Visual Basic

Copy Code Copy Code

Private m_iUnterschriftrechts, m_iAnzeigeStatus, m_iPostzustellung, m_iStatusnr, m_iAufbewahrung_elektronisch, m_iMonierung_in_tagen, m_iAufbewahrung_phaysisch, m_iBearbeitung_nach_abschluss, m_iIn_edoka_datenbank, m_iDokdurchkubeweitergegeben, m_iMutiererteam, m_iBRVernichtungnachTagen, m_iBearbeitungszeit_in_minuten, m_iBck, m_iGesperrt_durch, m_iMutierertieam, m_iDokumenttypnr, m_iMa_eingangsarchivierung, m_iMa_ausgangsarchivierung, m_iMutierer, m_iMitarbeiternr1, m_iMitarbeiternr, m_iNrpar00, m_iErstellerteam, m_iErsteller, m_iZustaendiger, m_iColdstatus, m_iVerantwortlich, m_iUnterschriftlinks, m_iBarcodenr, m_iStatus_edoka_batch_ausgang, m_iStatus_edoka_batch_eingang As SqlInt32

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsDokument Class
clsDokument clsDokument Members


m_iStatus_edoka_batch_ausgang Field

m_iStatus_edoka_batch_ausgang Field

m_iStatus_edoka_batch_ausgang Field | Previous topic | Next topic
m_iStatus_edoka_batch_ausgang Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_iStatus_edoka_batch_ausgang As SqlInt32

C#

private SqlInt32 m_iStatus_edoka_batch_ausgang

C++

private:
SqlInt32 m_iStatus_edoka_batch_ausgang;

JScript

private m_iStatus_edoka_batch_ausgang : SqlInt32

Source code

Visual Basic

Copy Code Copy Code

Private m_iUnterschriftrechts, m_iAnzeigeStatus, m_iPostzustellung, m_iStatusnr, m_iAufbewahrung_elektronisch, m_iMonierung_in_tagen, m_iAufbewahrung_phaysisch, m_iBearbeitung_nach_abschluss, m_iIn_edoka_datenbank, m_iDokdurchkubeweitergegeben, m_iMutiererteam, m_iBRVernichtungnachTagen, m_iBearbeitungszeit_in_minuten, m_iBck, m_iGesperrt_durch, m_iMutierertieam, m_iDokumenttypnr, m_iMa_eingangsarchivierung, m_iMa_ausgangsarchivierung, m_iMutierer, m_iMitarbeiternr1, m_iMitarbeiternr, m_iNrpar00, m_iErstellerteam, m_iErsteller, m_iZustaendiger, m_iColdstatus, m_iVerantwortlich, m_iUnterschriftlinks, m_iBarcodenr, m_iStatus_edoka_batch_ausgang, m_iStatus_edoka_batch_eingang As SqlInt32

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsDokument Class
clsDokument clsDokument Members


m_iStatus_edoka_batch_eingang Field

m_iStatus_edoka_batch_eingang Field

m_iStatus_edoka_batch_eingang Field | Previous topic | Next topic
m_iStatus_edoka_batch_eingang Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_iStatus_edoka_batch_eingang As SqlInt32

C#

private SqlInt32 m_iStatus_edoka_batch_eingang

C++

private:
SqlInt32 m_iStatus_edoka_batch_eingang;

JScript

private m_iStatus_edoka_batch_eingang : SqlInt32

Source code

Visual Basic

Copy Code Copy Code

Private m_iUnterschriftrechts, m_iAnzeigeStatus, m_iPostzustellung, m_iStatusnr, m_iAufbewahrung_elektronisch, m_iMonierung_in_tagen, m_iAufbewahrung_phaysisch, m_iBearbeitung_nach_abschluss, m_iIn_edoka_datenbank, m_iDokdurchkubeweitergegeben, m_iMutiererteam, m_iBRVernichtungnachTagen, m_iBearbeitungszeit_in_minuten, m_iBck, m_iGesperrt_durch, m_iMutierertieam, m_iDokumenttypnr, m_iMa_eingangsarchivierung, m_iMa_ausgangsarchivierung, m_iMutierer, m_iMitarbeiternr1, m_iMitarbeiternr, m_iNrpar00, m_iErstellerteam, m_iErsteller, m_iZustaendiger, m_iColdstatus, m_iVerantwortlich, m_iUnterschriftlinks, m_iBarcodenr, m_iStatus_edoka_batch_ausgang, m_iStatus_edoka_batch_eingang As SqlInt32

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsDokument Class
clsDokument clsDokument Members


m_iStatusnr Field

m_iStatusnr Field

m_iStatusnr Field | Previous topic | Next topic
m_iStatusnr Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_iStatusnr As SqlInt32

C#

private SqlInt32 m_iStatusnr

C++

private:
SqlInt32 m_iStatusnr;

JScript

private m_iStatusnr : SqlInt32

Source code

Visual Basic

Copy Code Copy Code

Private m_iUnterschriftrechts, m_iAnzeigeStatus, m_iPostzustellung, m_iStatusnr, m_iAufbewahrung_elektronisch, m_iMonierung_in_tagen, m_iAufbewahrung_phaysisch, m_iBearbeitung_nach_abschluss, m_iIn_edoka_datenbank, m_iDokdurchkubeweitergegeben, m_iMutiererteam, m_iBRVernichtungnachTagen, m_iBearbeitungszeit_in_minuten, m_iBck, m_iGesperrt_durch, m_iMutierertieam, m_iDokumenttypnr, m_iMa_eingangsarchivierung, m_iMa_ausgangsarchivierung, m_iMutierer, m_iMitarbeiternr1, m_iMitarbeiternr, m_iNrpar00, m_iErstellerteam, m_iErsteller, m_iZustaendiger, m_iColdstatus, m_iVerantwortlich, m_iUnterschriftlinks, m_iBarcodenr, m_iStatus_edoka_batch_ausgang, m_iStatus_edoka_batch_eingang As SqlInt32

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsDokument Class
clsDokument clsDokument Members


m_iUnterschriftlinks Field

m_iUnterschriftlinks Field

m_iUnterschriftlinks Field | Previous topic | Next topic
m_iUnterschriftlinks Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_iUnterschriftlinks As SqlInt32

C#

private SqlInt32 m_iUnterschriftlinks

C++

private:
SqlInt32 m_iUnterschriftlinks;

JScript

private m_iUnterschriftlinks : SqlInt32

Source code

Visual Basic

Copy Code Copy Code

Private m_iUnterschriftrechts, m_iAnzeigeStatus, m_iPostzustellung, m_iStatusnr, m_iAufbewahrung_elektronisch, m_iMonierung_in_tagen, m_iAufbewahrung_phaysisch, m_iBearbeitung_nach_abschluss, m_iIn_edoka_datenbank, m_iDokdurchkubeweitergegeben, m_iMutiererteam, m_iBRVernichtungnachTagen, m_iBearbeitungszeit_in_minuten, m_iBck, m_iGesperrt_durch, m_iMutierertieam, m_iDokumenttypnr, m_iMa_eingangsarchivierung, m_iMa_ausgangsarchivierung, m_iMutierer, m_iMitarbeiternr1, m_iMitarbeiternr, m_iNrpar00, m_iErstellerteam, m_iErsteller, m_iZustaendiger, m_iColdstatus, m_iVerantwortlich, m_iUnterschriftlinks, m_iBarcodenr, m_iStatus_edoka_batch_ausgang, m_iStatus_edoka_batch_eingang As SqlInt32

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsDokument Class
clsDokument clsDokument Members


m_iUnterschriftrechts Field

m_iUnterschriftrechts Field

m_iUnterschriftrechts Field | Previous topic | Next topic
m_iUnterschriftrechts Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_iUnterschriftrechts As SqlInt32

C#

private SqlInt32 m_iUnterschriftrechts

C++

private:
SqlInt32 m_iUnterschriftrechts;

JScript

private m_iUnterschriftrechts : SqlInt32

Source code

Visual Basic

Copy Code Copy Code

Private m_iUnterschriftrechts, m_iAnzeigeStatus, m_iPostzustellung, m_iStatusnr, m_iAufbewahrung_elektronisch, m_iMonierung_in_tagen, m_iAufbewahrung_phaysisch, m_iBearbeitung_nach_abschluss, m_iIn_edoka_datenbank, m_iDokdurchkubeweitergegeben, m_iMutiererteam, m_iBRVernichtungnachTagen, m_iBearbeitungszeit_in_minuten, m_iBck, m_iGesperrt_durch, m_iMutierertieam, m_iDokumenttypnr, m_iMa_eingangsarchivierung, m_iMa_ausgangsarchivierung, m_iMutierer, m_iMitarbeiternr1, m_iMitarbeiternr, m_iNrpar00, m_iErstellerteam, m_iErsteller, m_iZustaendiger, m_iColdstatus, m_iVerantwortlich, m_iUnterschriftlinks, m_iBarcodenr, m_iStatus_edoka_batch_ausgang, m_iStatus_edoka_batch_eingang As SqlInt32

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsDokument Class
clsDokument clsDokument Members


m_iVerantwortlich Field

m_iVerantwortlich Field

m_iVerantwortlich Field | Previous topic | Next topic
m_iVerantwortlich Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_iVerantwortlich As SqlInt32

C#

private SqlInt32 m_iVerantwortlich

C++

private:
SqlInt32 m_iVerantwortlich;

JScript

private m_iVerantwortlich : SqlInt32

Source code

Visual Basic

Copy Code Copy Code

Private m_iUnterschriftrechts, m_iAnzeigeStatus, m_iPostzustellung, m_iStatusnr, m_iAufbewahrung_elektronisch, m_iMonierung_in_tagen, m_iAufbewahrung_phaysisch, m_iBearbeitung_nach_abschluss, m_iIn_edoka_datenbank, m_iDokdurchkubeweitergegeben, m_iMutiererteam, m_iBRVernichtungnachTagen, m_iBearbeitungszeit_in_minuten, m_iBck, m_iGesperrt_durch, m_iMutierertieam, m_iDokumenttypnr, m_iMa_eingangsarchivierung, m_iMa_ausgangsarchivierung, m_iMutierer, m_iMitarbeiternr1, m_iMitarbeiternr, m_iNrpar00, m_iErstellerteam, m_iErsteller, m_iZustaendiger, m_iColdstatus, m_iVerantwortlich, m_iUnterschriftlinks, m_iBarcodenr, m_iStatus_edoka_batch_ausgang, m_iStatus_edoka_batch_eingang As SqlInt32

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsDokument Class
clsDokument clsDokument Members


m_iZustaendiger Field

m_iZustaendiger Field

m_iZustaendiger Field | Previous topic | Next topic
m_iZustaendiger Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_iZustaendiger As SqlInt32

C#

private SqlInt32 m_iZustaendiger

C++

private:
SqlInt32 m_iZustaendiger;

JScript

private m_iZustaendiger : SqlInt32

Source code

Visual Basic

Copy Code Copy Code

Private m_iUnterschriftrechts, m_iAnzeigeStatus, m_iPostzustellung, m_iStatusnr, m_iAufbewahrung_elektronisch, m_iMonierung_in_tagen, m_iAufbewahrung_phaysisch, m_iBearbeitung_nach_abschluss, m_iIn_edoka_datenbank, m_iDokdurchkubeweitergegeben, m_iMutiererteam, m_iBRVernichtungnachTagen, m_iBearbeitungszeit_in_minuten, m_iBck, m_iGesperrt_durch, m_iMutierertieam, m_iDokumenttypnr, m_iMa_eingangsarchivierung, m_iMa_ausgangsarchivierung, m_iMutierer, m_iMitarbeiternr1, m_iMitarbeiternr, m_iNrpar00, m_iErstellerteam, m_iErsteller, m_iZustaendiger, m_iColdstatus, m_iVerantwortlich, m_iUnterschriftlinks, m_iBarcodenr, m_iStatus_edoka_batch_ausgang, m_iStatus_edoka_batch_eingang As SqlInt32

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsDokument Class
clsDokument clsDokument Members


m_sAnredezustelladresse Field

m_sAnredezustelladresse Field

m_sAnredezustelladresse Field | Previous topic | Next topic
m_sAnredezustelladresse Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_sAnredezustelladresse As SqlString

C#

private SqlString m_sAnredezustelladresse

C++

private:
SqlString m_sAnredezustelladresse;

JScript

private m_sAnredezustelladresse : SqlString

Source code

Visual Basic

Copy Code Copy Code

Private m_sDokumentname, m_sColddokumentid, m_sBedRDokumentid, m_sVvnr, m_sDokumentid, m_sDokumentidn, m_sFanummer3, m_sZustelladresse, m_sBemerkung, m_sBezeichnung, m_sLoeschgrund, m_sAnredezustelladresse, m_sBemerkunguvm, m_sSpeicherort, m_sFANummer1, m_sFANummer2, m_sVersandadresse, m_sColdfolder, m_sColdschema As SqlString

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsDokument Class
clsDokument clsDokument Members


m_sBedRDokumentid Field

m_sBedRDokumentid Field

m_sBedRDokumentid Field | Previous topic | Next topic
m_sBedRDokumentid Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_sBedRDokumentid As SqlString

C#

private SqlString m_sBedRDokumentid

C++

private:
SqlString m_sBedRDokumentid;

JScript

private m_sBedRDokumentid : SqlString

Source code

Visual Basic

Copy Code Copy Code

Private m_sDokumentname, m_sColddokumentid, m_sBedRDokumentid, m_sVvnr, m_sDokumentid, m_sDokumentidn, m_sFanummer3, m_sZustelladresse, m_sBemerkung, m_sBezeichnung, m_sLoeschgrund, m_sAnredezustelladresse, m_sBemerkunguvm, m_sSpeicherort, m_sFANummer1, m_sFANummer2, m_sVersandadresse, m_sColdfolder, m_sColdschema As SqlString

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsDokument Class
clsDokument clsDokument Members


m_sBemerkung Field

m_sBemerkung Field

m_sBemerkung Field | Previous topic | Next topic
m_sBemerkung Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_sBemerkung As SqlString

C#

private SqlString m_sBemerkung

C++

private:
SqlString m_sBemerkung;

JScript

private m_sBemerkung : SqlString

Source code

Visual Basic

Copy Code Copy Code

Private m_sDokumentname, m_sColddokumentid, m_sBedRDokumentid, m_sVvnr, m_sDokumentid, m_sDokumentidn, m_sFanummer3, m_sZustelladresse, m_sBemerkung, m_sBezeichnung, m_sLoeschgrund, m_sAnredezustelladresse, m_sBemerkunguvm, m_sSpeicherort, m_sFANummer1, m_sFANummer2, m_sVersandadresse, m_sColdfolder, m_sColdschema As SqlString

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsDokument Class
clsDokument clsDokument Members


m_sBemerkunguvm Field

m_sBemerkunguvm Field

m_sBemerkunguvm Field | Previous topic | Next topic
m_sBemerkunguvm Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_sBemerkunguvm As SqlString

C#

private SqlString m_sBemerkunguvm

C++

private:
SqlString m_sBemerkunguvm;

JScript

private m_sBemerkunguvm : SqlString

Source code

Visual Basic

Copy Code Copy Code

Private m_sDokumentname, m_sColddokumentid, m_sBedRDokumentid, m_sVvnr, m_sDokumentid, m_sDokumentidn, m_sFanummer3, m_sZustelladresse, m_sBemerkung, m_sBezeichnung, m_sLoeschgrund, m_sAnredezustelladresse, m_sBemerkunguvm, m_sSpeicherort, m_sFANummer1, m_sFANummer2, m_sVersandadresse, m_sColdfolder, m_sColdschema As SqlString

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsDokument Class
clsDokument clsDokument Members


m_sBezeichnung Field

m_sBezeichnung Field

m_sBezeichnung Field | Previous topic | Next topic
m_sBezeichnung Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_sBezeichnung As SqlString

C#

private SqlString m_sBezeichnung

C++

private:
SqlString m_sBezeichnung;

JScript

private m_sBezeichnung : SqlString

Source code

Visual Basic

Copy Code Copy Code

Private m_sDokumentname, m_sColddokumentid, m_sBedRDokumentid, m_sVvnr, m_sDokumentid, m_sDokumentidn, m_sFanummer3, m_sZustelladresse, m_sBemerkung, m_sBezeichnung, m_sLoeschgrund, m_sAnredezustelladresse, m_sBemerkunguvm, m_sSpeicherort, m_sFANummer1, m_sFANummer2, m_sVersandadresse, m_sColdfolder, m_sColdschema As SqlString

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsDokument Class
clsDokument clsDokument Members


m_sColddokumentid Field

m_sColddokumentid Field

m_sColddokumentid Field | Previous topic | Next topic
m_sColddokumentid Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_sColddokumentid As SqlString

C#

private SqlString m_sColddokumentid

C++

private:
SqlString m_sColddokumentid;

JScript

private m_sColddokumentid : SqlString

Source code

Visual Basic

Copy Code Copy Code

Private m_sDokumentname, m_sColddokumentid, m_sBedRDokumentid, m_sVvnr, m_sDokumentid, m_sDokumentidn, m_sFanummer3, m_sZustelladresse, m_sBemerkung, m_sBezeichnung, m_sLoeschgrund, m_sAnredezustelladresse, m_sBemerkunguvm, m_sSpeicherort, m_sFANummer1, m_sFANummer2, m_sVersandadresse, m_sColdfolder, m_sColdschema As SqlString

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsDokument Class
clsDokument clsDokument Members


m_sColdfolder Field

m_sColdfolder Field

m_sColdfolder Field | Previous topic | Next topic
m_sColdfolder Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_sColdfolder As SqlString

C#

private SqlString m_sColdfolder

C++

private:
SqlString m_sColdfolder;

JScript

private m_sColdfolder : SqlString

Source code

Visual Basic

Copy Code Copy Code

Private m_sDokumentname, m_sColddokumentid, m_sBedRDokumentid, m_sVvnr, m_sDokumentid, m_sDokumentidn, m_sFanummer3, m_sZustelladresse, m_sBemerkung, m_sBezeichnung, m_sLoeschgrund, m_sAnredezustelladresse, m_sBemerkunguvm, m_sSpeicherort, m_sFANummer1, m_sFANummer2, m_sVersandadresse, m_sColdfolder, m_sColdschema As SqlString

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsDokument Class
clsDokument clsDokument Members


m_sColdschema Field

m_sColdschema Field

m_sColdschema Field | Previous topic | Next topic
m_sColdschema Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_sColdschema As SqlString

C#

private SqlString m_sColdschema

C++

private:
SqlString m_sColdschema;

JScript

private m_sColdschema : SqlString

Source code

Visual Basic

Copy Code Copy Code

Private m_sDokumentname, m_sColddokumentid, m_sBedRDokumentid, m_sVvnr, m_sDokumentid, m_sDokumentidn, m_sFanummer3, m_sZustelladresse, m_sBemerkung, m_sBezeichnung, m_sLoeschgrund, m_sAnredezustelladresse, m_sBemerkunguvm, m_sSpeicherort, m_sFANummer1, m_sFANummer2, m_sVersandadresse, m_sColdfolder, m_sColdschema As SqlString

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsDokument Class
clsDokument clsDokument Members


m_sDokumentid Field

m_sDokumentid Field

m_sDokumentid Field | Previous topic | Next topic
m_sDokumentid Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_sDokumentid As SqlString

C#

private SqlString m_sDokumentid

C++

private:
SqlString m_sDokumentid;

JScript

private m_sDokumentid : SqlString

Source code

Visual Basic

Copy Code Copy Code

Private m_sDokumentname, m_sColddokumentid, m_sBedRDokumentid, m_sVvnr, m_sDokumentid, m_sDokumentidn, m_sFanummer3, m_sZustelladresse, m_sBemerkung, m_sBezeichnung, m_sLoeschgrund, m_sAnredezustelladresse, m_sBemerkunguvm, m_sSpeicherort, m_sFANummer1, m_sFANummer2, m_sVersandadresse, m_sColdfolder, m_sColdschema As SqlString

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsDokument Class
clsDokument clsDokument Members


m_sDokumentidn Field

m_sDokumentidn Field

m_sDokumentidn Field | Previous topic | Next topic
m_sDokumentidn Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_sDokumentidn As SqlString

C#

private SqlString m_sDokumentidn

C++

private:
SqlString m_sDokumentidn;

JScript

private m_sDokumentidn : SqlString

Source code

Visual Basic

Copy Code Copy Code

Private m_sDokumentname, m_sColddokumentid, m_sBedRDokumentid, m_sVvnr, m_sDokumentid, m_sDokumentidn, m_sFanummer3, m_sZustelladresse, m_sBemerkung, m_sBezeichnung, m_sLoeschgrund, m_sAnredezustelladresse, m_sBemerkunguvm, m_sSpeicherort, m_sFANummer1, m_sFANummer2, m_sVersandadresse, m_sColdfolder, m_sColdschema As SqlString

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsDokument Class
clsDokument clsDokument Members


m_sDokumentname Field

m_sDokumentname Field

m_sDokumentname Field | Previous topic | Next topic
m_sDokumentname Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_sDokumentname As SqlString

C#

private SqlString m_sDokumentname

C++

private:
SqlString m_sDokumentname;

JScript

private m_sDokumentname : SqlString

Source code

Visual Basic

Copy Code Copy Code

Private m_sDokumentname, m_sColddokumentid, m_sBedRDokumentid, m_sVvnr, m_sDokumentid, m_sDokumentidn, m_sFanummer3, m_sZustelladresse, m_sBemerkung, m_sBezeichnung, m_sLoeschgrund, m_sAnredezustelladresse, m_sBemerkunguvm, m_sSpeicherort, m_sFANummer1, m_sFANummer2, m_sVersandadresse, m_sColdfolder, m_sColdschema As SqlString

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsDokument Class
clsDokument clsDokument Members


m_sFANummer1 Field

m_sFANummer1 Field

m_sFANummer1 Field | Previous topic | Next topic
m_sFANummer1 Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_sFANummer1 As SqlString

C#

private SqlString m_sFANummer1

C++

private:
SqlString m_sFANummer1;

JScript

private m_sFANummer1 : SqlString

Source code

Visual Basic

Copy Code Copy Code

Private m_sDokumentname, m_sColddokumentid, m_sBedRDokumentid, m_sVvnr, m_sDokumentid, m_sDokumentidn, m_sFanummer3, m_sZustelladresse, m_sBemerkung, m_sBezeichnung, m_sLoeschgrund, m_sAnredezustelladresse, m_sBemerkunguvm, m_sSpeicherort, m_sFANummer1, m_sFANummer2, m_sVersandadresse, m_sColdfolder, m_sColdschema As SqlString

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsDokument Class
clsDokument clsDokument Members


m_sFANummer2 Field

m_sFANummer2 Field

m_sFANummer2 Field | Previous topic | Next topic
m_sFANummer2 Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_sFANummer2 As SqlString

C#

private SqlString m_sFANummer2

C++

private:
SqlString m_sFANummer2;

JScript

private m_sFANummer2 : SqlString

Source code

Visual Basic

Copy Code Copy Code

Private m_sDokumentname, m_sColddokumentid, m_sBedRDokumentid, m_sVvnr, m_sDokumentid, m_sDokumentidn, m_sFanummer3, m_sZustelladresse, m_sBemerkung, m_sBezeichnung, m_sLoeschgrund, m_sAnredezustelladresse, m_sBemerkunguvm, m_sSpeicherort, m_sFANummer1, m_sFANummer2, m_sVersandadresse, m_sColdfolder, m_sColdschema As SqlString

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsDokument Class
clsDokument clsDokument Members


m_sFanummer3 Field

m_sFanummer3 Field

m_sFanummer3 Field | Previous topic | Next topic
m_sFanummer3 Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_sFanummer3 As SqlString

C#

private SqlString m_sFanummer3

C++

private:
SqlString m_sFanummer3;

JScript

private m_sFanummer3 : SqlString

Source code

Visual Basic

Copy Code Copy Code

Private m_sDokumentname, m_sColddokumentid, m_sBedRDokumentid, m_sVvnr, m_sDokumentid, m_sDokumentidn, m_sFanummer3, m_sZustelladresse, m_sBemerkung, m_sBezeichnung, m_sLoeschgrund, m_sAnredezustelladresse, m_sBemerkunguvm, m_sSpeicherort, m_sFANummer1, m_sFANummer2, m_sVersandadresse, m_sColdfolder, m_sColdschema As SqlString

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsDokument Class
clsDokument clsDokument Members


m_sLoeschgrund Field

m_sLoeschgrund Field

m_sLoeschgrund Field | Previous topic | Next topic
m_sLoeschgrund Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_sLoeschgrund As SqlString

C#

private SqlString m_sLoeschgrund

C++

private:
SqlString m_sLoeschgrund;

JScript

private m_sLoeschgrund : SqlString

Source code

Visual Basic

Copy Code Copy Code

Private m_sDokumentname, m_sColddokumentid, m_sBedRDokumentid, m_sVvnr, m_sDokumentid, m_sDokumentidn, m_sFanummer3, m_sZustelladresse, m_sBemerkung, m_sBezeichnung, m_sLoeschgrund, m_sAnredezustelladresse, m_sBemerkunguvm, m_sSpeicherort, m_sFANummer1, m_sFANummer2, m_sVersandadresse, m_sColdfolder, m_sColdschema As SqlString

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsDokument Class
clsDokument clsDokument Members


m_sSpeicherort Field

m_sSpeicherort Field

m_sSpeicherort Field | Previous topic | Next topic
m_sSpeicherort Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_sSpeicherort As SqlString

C#

private SqlString m_sSpeicherort

C++

private:
SqlString m_sSpeicherort;

JScript

private m_sSpeicherort : SqlString

Source code

Visual Basic

Copy Code Copy Code

Private m_sDokumentname, m_sColddokumentid, m_sBedRDokumentid, m_sVvnr, m_sDokumentid, m_sDokumentidn, m_sFanummer3, m_sZustelladresse, m_sBemerkung, m_sBezeichnung, m_sLoeschgrund, m_sAnredezustelladresse, m_sBemerkunguvm, m_sSpeicherort, m_sFANummer1, m_sFANummer2, m_sVersandadresse, m_sColdfolder, m_sColdschema As SqlString

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsDokument Class
clsDokument clsDokument Members


m_sVersandadresse Field

m_sVersandadresse Field

m_sVersandadresse Field | Previous topic | Next topic
m_sVersandadresse Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_sVersandadresse As SqlString

C#

private SqlString m_sVersandadresse

C++

private:
SqlString m_sVersandadresse;

JScript

private m_sVersandadresse : SqlString

Source code

Visual Basic

Copy Code Copy Code

Private m_sDokumentname, m_sColddokumentid, m_sBedRDokumentid, m_sVvnr, m_sDokumentid, m_sDokumentidn, m_sFanummer3, m_sZustelladresse, m_sBemerkung, m_sBezeichnung, m_sLoeschgrund, m_sAnredezustelladresse, m_sBemerkunguvm, m_sSpeicherort, m_sFANummer1, m_sFANummer2, m_sVersandadresse, m_sColdfolder, m_sColdschema As SqlString

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsDokument Class
clsDokument clsDokument Members


m_sVvnr Field

m_sVvnr Field

m_sVvnr Field | Previous topic | Next topic
m_sVvnr Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_sVvnr As SqlString

C#

private SqlString m_sVvnr

C++

private:
SqlString m_sVvnr;

JScript

private m_sVvnr : SqlString

Source code

Visual Basic

Copy Code Copy Code

Private m_sDokumentname, m_sColddokumentid, m_sBedRDokumentid, m_sVvnr, m_sDokumentid, m_sDokumentidn, m_sFanummer3, m_sZustelladresse, m_sBemerkung, m_sBezeichnung, m_sLoeschgrund, m_sAnredezustelladresse, m_sBemerkunguvm, m_sSpeicherort, m_sFANummer1, m_sFANummer2, m_sVersandadresse, m_sColdfolder, m_sColdschema As SqlString

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsDokument Class
clsDokument clsDokument Members


m_sZustelladresse Field

m_sZustelladresse Field

m_sZustelladresse Field | Previous topic | Next topic
m_sZustelladresse Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_sZustelladresse As SqlString

C#

private SqlString m_sZustelladresse

C++

private:
SqlString m_sZustelladresse;

JScript

private m_sZustelladresse : SqlString

Source code

Visual Basic

Copy Code Copy Code

Private m_sDokumentname, m_sColddokumentid, m_sBedRDokumentid, m_sVvnr, m_sDokumentid, m_sDokumentidn, m_sFanummer3, m_sZustelladresse, m_sBemerkung, m_sBezeichnung, m_sLoeschgrund, m_sAnredezustelladresse, m_sBemerkunguvm, m_sSpeicherort, m_sFANummer1, m_sFANummer2, m_sVersandadresse, m_sColdfolder, m_sColdschema As SqlString

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsDokument Class
clsDokument clsDokument Members


clsDokumenttyp Class

clsDokumenttyp Class

clsDokumenttyp Class | Previous topic | Next topic
clsDokumenttyp Class | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Class clsDokumenttyp
Inherits clsDBInteractionBase

C#

public class clsDokumenttyp : clsDBInteractionBase

C++

public ref class clsDokumenttyp : public clsDBInteractionBase^

JScript

public class clsDokumenttyp
extends clsDBInteractionBase

Inheritance Hierarchy

System.Object

EDKB12WS.edokadb.clsDBInteractionBase

EDKB12WS.edokadb.clsDokumenttyp

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsDokumenttyp Members


clsDokumenttyp Members

clsDokumenttyp Members

clsDokumenttyp Members | Previous topic | Next topic
clsDokumenttyp Members | Previous topic | Next topic

The following tables list the members exposed by the clsDokumenttyp type.

Public Constructors

 | Name | Description
Supported by the .NET Compact Framework. | clsDokumenttyp Constructor |

Top

Public Properties

 | Name | Description
Supported by the .NET Compact Framework. | bAktiv |
Supported by the .NET Compact Framework. | bAmsdokument |
Supported by the .NET Compact Framework. | bAnzeigeZurDokumenterstellung |
Supported by the .NET Compact Framework. | bBedingtretournierbar |
Supported by the .NET Compact Framework. | bBezeichnungmut |
Supported by the .NET Compact Framework. | bCold_ersetzen |
Supported by the .NET Compact Framework. | bDokument_wird_erstellt |
Supported by the .NET Compact Framework. | bDokument_wird_retourniert |
Supported by the .NET Compact Framework. | bEingang_ersetzt_ausgang |
Supported by the .NET Compact Framework. | bEmail_versand |
Supported by the .NET Compact Framework. | bFunktionen_zuweisen |
Supported by the .NET Compact Framework. | bHostdokument |
Supported by the .NET Compact Framework. | bKundenDokument |
Supported by the .NET Compact Framework. | bNurnative |
Supported by the .NET Compact Framework. | bPartnersaldierung_statusalt |
Supported by the .NET Compact Framework. | bSb |
Supported by the .NET Compact Framework. | bSbedituser |
Supported by the .NET Compact Framework. | bSbimport |
Supported by the .NET Compact Framework. | bSbnur |
Supported by the .NET Compact Framework. | bUnterschrift_links |
Supported by the .NET Compact Framework. | bUnterschrift_rechts |
Supported by the .NET Compact Framework. | bVertrag |
Supported by the .NET Compact Framework. | bVertrauliches_dokument |
Supported by the .NET Compact Framework. | bWird_importiert |
Supported by the .NET Compact Framework. | bWird_nicht_geloescht |
Supported by the .NET Compact Framework. | bZu_retournieren |
Supported by the .NET Compact Framework. | bZu_vercolden |
Supported by the .NET Compact Framework. | cpMainConnectionProvider | (inherited from clsDBInteractionBase ).
Supported by the .NET Compact Framework. | daErstellt_am |
Supported by the .NET Compact Framework. | daMutiert_am |
Supported by the .NET Compact Framework. | iAnzahl_tage |
Supported by the .NET Compact Framework. | iAufbewahrungsfrist_elektronisch |
Supported by the .NET Compact Framework. | iAufbewahrungsfrist_physisch |
Supported by the .NET Compact Framework. | iCold_folder |
Supported by the .NET Compact Framework. | iDbearbeitungszeit |
Supported by the .NET Compact Framework. | iDoktypbedingteretournierung |
Supported by the .NET Compact Framework. | iDokumentart_coldausgang |
Supported by the .NET Compact Framework. | iDokumentart_coldeingang |
Supported by the .NET Compact Framework. | iDokumentart_host |
Supported by the .NET Compact Framework. | iDokumentart_kundendossier |
Supported by the .NET Compact Framework. | iDokumentart_nativ |
Supported by the .NET Compact Framework. | iDokumentart_neuerstellung |
Supported by the .NET Compact Framework. | iDokumentart_retournierung |
Supported by the .NET Compact Framework. | iDokumentart_weitere |
Supported by the .NET Compact Framework. | iDokumentstatus |
Supported by the .NET Compact Framework. | iDokumentstatus_barcode |
Supported by the .NET Compact Framework. | iDokumenttypnr |
Supported by the .NET Compact Framework. | iErrorCode | (inherited from clsDBInteractionBase ).
Supported by the .NET Compact Framework. | iMandantnr |
Supported by the .NET Compact Framework. | iMonate_bis_zur_archivierung |
Supported by the .NET Compact Framework. | iMutierer |
Supported by the .NET Compact Framework. | iObjektbezeichnungnr |
Supported by the .NET Compact Framework. | iOffice_vorlagenr |
Supported by the .NET Compact Framework. | iOwner |
Supported by the .NET Compact Framework. | iPhysisches_archiv |
Supported by the .NET Compact Framework. | iProzessnr |
Supported by the .NET Compact Framework. | iProzessnr1 |
Supported by the .NET Compact Framework. | iTage_mutation |
Supported by the .NET Compact Framework. | iTagebisvernichtungbedingteretournierung |
Supported by the .NET Compact Framework. | sBeschreibung |
Supported by the .NET Compact Framework. | sBezeichnung |
Supported by the .NET Compact Framework. | sConnectionString | (inherited from clsDBInteractionBase ).
Supported by the .NET Compact Framework. | sHostdokumenttyp |

Top

Public Methods

 | Name | Description
Supported by the .NET Compact Framework. | Delete |
Supported by the .NET Compact Framework. | Dispose | (Overloaded) (inherited from clsDBInteractionBase ).
Public method | Equals | (Overloaded) (inherited from Object).
Public method | GetHashCode | (inherited from Object).
Public method | GetType | (Overloaded) (inherited from Object).
Supported by the .NET Compact Framework. | Insert |
 | ReferenceEquals | (inherited from Object).
Supported by the .NET Compact Framework. | SelectAll |
Supported by the .NET Compact Framework. | SelectOne |
Public method | ToString | (inherited from Object).
Supported by the .NET Compact Framework. | Update |

Top

Protected Methods

 | Name | Description
Protected method | Finalize | (inherited from Object).
Protected method | MemberwiseClone | (Overloaded) (inherited from Object).

Top

Fields

 | Name | Description
Supported by the .NET Compact Framework. | m_bAktiv |
Supported by the .NET Compact Framework. | m_bAmsdokument |
Supported by the .NET Compact Framework. | m_bAnzeigeZurDokumenterstellung |
Supported by the .NET Compact Framework. | m_bBedingtretournierbar |
Supported by the .NET Compact Framework. | m_bBezeichnungmut |
Supported by the .NET Compact Framework. | m_bCold_ersetzen |
Supported by the .NET Compact Framework. | m_bDokument_wird_erstellt |
Supported by the .NET Compact Framework. | m_bDokument_wird_retourniert |
Supported by the .NET Compact Framework. | m_bEingang_ersetzt_ausgang |
Supported by the .NET Compact Framework. | m_bEmail_versand |
Supported by the .NET Compact Framework. | m_bFunktionen_zuweisen |
Supported by the .NET Compact Framework. | m_bHostdokument |
Supported by the .NET Compact Framework. | m_bKundenDokument |
Supported by the .NET Compact Framework. | m_bMainConnectionIsCreatedLocal | (inherited from clsDBInteractionBase ).
Supported by the .NET Compact Framework. | m_bNurnative |
Supported by the .NET Compact Framework. | m_bPartnersaldierung_statusalt |
Supported by the .NET Compact Framework. | m_bSb |
Supported by the .NET Compact Framework. | m_bSbedituser |
Supported by the .NET Compact Framework. | m_bSbimport |
Supported by the .NET Compact Framework. | m_bSbnur |
Supported by the .NET Compact Framework. | m_bUnterschrift_links |
Supported by the .NET Compact Framework. | m_bUnterschrift_rechts |
Supported by the .NET Compact Framework. | m_bVertrag |
Supported by the .NET Compact Framework. | m_bVertrauliches_dokument |
Supported by the .NET Compact Framework. | m_bWird_importiert |
Supported by the .NET Compact Framework. | m_bWird_nicht_geloescht |
Supported by the .NET Compact Framework. | m_bZu_retournieren |
Supported by the .NET Compact Framework. | m_bZu_vercolden |
Supported by the .NET Compact Framework. | m_cpMainConnectionProvider | (inherited from clsDBInteractionBase ).
Supported by the .NET Compact Framework. | m_daErstellt_am |
Supported by the .NET Compact Framework. | m_daMutiert_am |
Supported by the .NET Compact Framework. | m_iAnzahl_tage |
Supported by the .NET Compact Framework. | m_iAufbewahrungsfrist_elektronisch |
Supported by the .NET Compact Framework. | m_iAufbewahrungsfrist_physisch |
Supported by the .NET Compact Framework. | m_iCold_folder |
Supported by the .NET Compact Framework. | m_iDbearbeitungszeit |
Supported by the .NET Compact Framework. | m_iDoktypbedingteretournierung |
Supported by the .NET Compact Framework. | m_iDokumentart_coldausgang |
Supported by the .NET Compact Framework. | m_iDokumentart_coldeingang |
Supported by the .NET Compact Framework. | m_iDokumentart_host |
Supported by the .NET Compact Framework. | m_iDokumentart_kundendossier |
Supported by the .NET Compact Framework. | m_iDokumentart_nativ |
Supported by the .NET Compact Framework. | m_iDokumentart_neuerstellung |
Supported by the .NET Compact Framework. | m_iDokumentart_retournierung |
Supported by the .NET Compact Framework. | m_iDokumentart_weitere |
Supported by the .NET Compact Framework. | m_iDokumentstatus |
Supported by the .NET Compact Framework. | m_iDokumentstatus_barcode |
Supported by the .NET Compact Framework. | m_iDokumenttypnr |
Supported by the .NET Compact Framework. | m_iErrorCode | (inherited from clsDBInteractionBase ).
Supported by the .NET Compact Framework. | m_iMandantnr |
Supported by the .NET Compact Framework. | m_iMonate_bis_zur_archivierung |
Supported by the .NET Compact Framework. | m_iMutierer |
Supported by the .NET Compact Framework. | m_iObjektbezeichnungnr |
Supported by the .NET Compact Framework. | m_iOffice_vorlagenr |
Supported by the .NET Compact Framework. | m_iOwner |
Supported by the .NET Compact Framework. | m_iPhysisches_archiv |
Supported by the .NET Compact Framework. | m_iProzessnr |
Supported by the .NET Compact Framework. | m_iProzessnr1 |
Supported by the .NET Compact Framework. | m_iTage_mutation |
Supported by the .NET Compact Framework. | m_iTagebisvernichtungbedingteretournierung |
Supported by the .NET Compact Framework. | m_sBeschreibung |
Supported by the .NET Compact Framework. | m_sBezeichnung |
Supported by the .NET Compact Framework. | m_sHostdokumenttyp |
Supported by the .NET Compact Framework. | m_scoMainConnection | (inherited from clsDBInteractionBase ).

Top

See Also

Reference

clsDokumenttyp Class


clsDokumenttyp Constructor

clsDokumenttyp Constructor

clsDokumenttyp Constructor | Previous topic | Next topic
clsDokumenttyp Constructor | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Sub New()

C#

public clsDokumenttyp()

C++

public:
clsDokumenttyp()

JScript

public function clsDokumenttyp();

Source code

Visual Basic

Copy Code Copy Code

Public Sub New()
' // Nothing for now.
End Sub

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsDokumenttyp Class
clsDokumenttyp clsDokumenttyp Members


clsDokumenttyp Properties

clsDokumenttyp Properties

clsDokumenttyp Properties | Previous topic | Next topic
clsDokumenttyp Properties | Previous topic | Next topic

Public Properties

 | Name | Description
Supported by the .NET Compact Framework. | bAktiv |
Supported by the .NET Compact Framework. | bAmsdokument |
Supported by the .NET Compact Framework. | bAnzeigeZurDokumenterstellung |
Supported by the .NET Compact Framework. | bBedingtretournierbar |
Supported by the .NET Compact Framework. | bBezeichnungmut |
Supported by the .NET Compact Framework. | bCold_ersetzen |
Supported by the .NET Compact Framework. | bDokument_wird_erstellt |
Supported by the .NET Compact Framework. | bDokument_wird_retourniert |
Supported by the .NET Compact Framework. | bEingang_ersetzt_ausgang |
Supported by the .NET Compact Framework. | bEmail_versand |
Supported by the .NET Compact Framework. | bFunktionen_zuweisen |
Supported by the .NET Compact Framework. | bHostdokument |
Supported by the .NET Compact Framework. | bKundenDokument |
Supported by the .NET Compact Framework. | bNurnative |
Supported by the .NET Compact Framework. | bPartnersaldierung_statusalt |
Supported by the .NET Compact Framework. | bSb |
Supported by the .NET Compact Framework. | bSbedituser |
Supported by the .NET Compact Framework. | bSbimport |
Supported by the .NET Compact Framework. | bSbnur |
Supported by the .NET Compact Framework. | bUnterschrift_links |
Supported by the .NET Compact Framework. | bUnterschrift_rechts |
Supported by the .NET Compact Framework. | bVertrag |
Supported by the .NET Compact Framework. | bVertrauliches_dokument |
Supported by the .NET Compact Framework. | bWird_importiert |
Supported by the .NET Compact Framework. | bWird_nicht_geloescht |
Supported by the .NET Compact Framework. | bZu_retournieren |
Supported by the .NET Compact Framework. | bZu_vercolden |
Supported by the .NET Compact Framework. | cpMainConnectionProvider | (inherited from clsDBInteractionBase ).
Supported by the .NET Compact Framework. | daErstellt_am |
Supported by the .NET Compact Framework. | daMutiert_am |
Supported by the .NET Compact Framework. | iAnzahl_tage |
Supported by the .NET Compact Framework. | iAufbewahrungsfrist_elektronisch |
Supported by the .NET Compact Framework. | iAufbewahrungsfrist_physisch |
Supported by the .NET Compact Framework. | iCold_folder |
Supported by the .NET Compact Framework. | iDbearbeitungszeit |
Supported by the .NET Compact Framework. | iDoktypbedingteretournierung |
Supported by the .NET Compact Framework. | iDokumentart_coldausgang |
Supported by the .NET Compact Framework. | iDokumentart_coldeingang |
Supported by the .NET Compact Framework. | iDokumentart_host |
Supported by the .NET Compact Framework. | iDokumentart_kundendossier |
Supported by the .NET Compact Framework. | iDokumentart_nativ |
Supported by the .NET Compact Framework. | iDokumentart_neuerstellung |
Supported by the .NET Compact Framework. | iDokumentart_retournierung |
Supported by the .NET Compact Framework. | iDokumentart_weitere |
Supported by the .NET Compact Framework. | iDokumentstatus |
Supported by the .NET Compact Framework. | iDokumentstatus_barcode |
Supported by the .NET Compact Framework. | iDokumenttypnr |
Supported by the .NET Compact Framework. | iErrorCode | (inherited from clsDBInteractionBase ).
Supported by the .NET Compact Framework. | iMandantnr |
Supported by the .NET Compact Framework. | iMonate_bis_zur_archivierung |
Supported by the .NET Compact Framework. | iMutierer |
Supported by the .NET Compact Framework. | iObjektbezeichnungnr |
Supported by the .NET Compact Framework. | iOffice_vorlagenr |
Supported by the .NET Compact Framework. | iOwner |
Supported by the .NET Compact Framework. | iPhysisches_archiv |
Supported by the .NET Compact Framework. | iProzessnr |
Supported by the .NET Compact Framework. | iProzessnr1 |
Supported by the .NET Compact Framework. | iTage_mutation |
Supported by the .NET Compact Framework. | iTagebisvernichtungbedingteretournierung |
Supported by the .NET Compact Framework. | sBeschreibung |
Supported by the .NET Compact Framework. | sBezeichnung |
Supported by the .NET Compact Framework. | sConnectionString | (inherited from clsDBInteractionBase ).
Supported by the .NET Compact Framework. | sHostdokumenttyp |

Top

See Also

Reference

clsDokumenttyp Class


clsDokumenttyp.bAktiv Property

clsDokumenttyp.bAktiv Property

clsDokumenttyp.bAktiv Property | Previous topic | Next topic
clsDokumenttyp.bAktiv Property | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property bAktiv() As SqlBoolean

C#

public SqlBoolean bAktiv {get; set;}

C++

public:
property SqlBoolean bAktiv {
SqlBoolean get( );
void set(
SqlBoolean value
);
}

JScript

public function get bAktiv() : SqlBoolean;
public function set bAktiv(value : SqlBoolean);

Source code

Visual Basic

Copy Code Copy Code

Public Property [bAktiv]() As SqlBoolean
Get
Return m_bAktiv
End Get
Set(ByVal Value As SqlBoolean)
m_bAktiv = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsDokumenttyp Class
clsDokumenttyp clsDokumenttyp Members


clsDokumenttyp.bAmsdokument Property

clsDokumenttyp.bAmsdokument Property

clsDokumenttyp.bAmsdokument Property | Previous topic | Next topic
clsDokumenttyp.bAmsdokument Property | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property bAmsdokument() As SqlBoolean

C#

public SqlBoolean bAmsdokument {get; set;}

C++

public:
property SqlBoolean bAmsdokument {
SqlBoolean get( );
void set(
SqlBoolean value
);
}

JScript

public function get bAmsdokument() : SqlBoolean;
public function set bAmsdokument(value : SqlBoolean);

Source code

Visual Basic

Copy Code Copy Code

Public Property [bAmsdokument]() As SqlBoolean
Get
Return m_bAmsdokument
End Get
Set(ByVal Value As SqlBoolean)
Dim bAmsdokumentTmp As SqlBoolean = Value
If bAmsdokumentTmp.IsNull Then
Throw New ArgumentOutOfRangeException("bAmsdokument", "bAmsdokument can't be NULL")
End If
m_bAmsdokument = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsDokumenttyp Class
clsDokumenttyp clsDokumenttyp Members


clsDokumenttyp.bAnzeigeZurDokumenterstellung Property

clsDokumenttyp.bAnzeigeZurDokumenterstellung Property

clsDokumenttyp.bAnzeigeZurDokumenterstellung Property | Previous topic | Next topic
clsDokumenttyp.bAnzeigeZurDokumenterstellung Property | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property bAnzeigeZurDokumenterstellung() As SqlBoolean

C#

public SqlBoolean bAnzeigeZurDokumenterstellung {get; set;}

C++

public:
property SqlBoolean bAnzeigeZurDokumenterstellung {
SqlBoolean get( );
void set(
SqlBoolean value
);
}

JScript

public function get bAnzeigeZurDokumenterstellung() : SqlBoolean;
public function set bAnzeigeZurDokumenterstellung(value : SqlBoolean);

Source code

Visual Basic

Copy Code Copy Code

Public Property [bAnzeigeZurDokumenterstellung]() As SqlBoolean
Get
Return m_bAnzeigeZurDokumenterstellung
End Get
Set(ByVal Value As SqlBoolean)
m_bAnzeigeZurDokumenterstellung = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsDokumenttyp Class
clsDokumenttyp clsDokumenttyp Members


clsDokumenttyp.bBedingtretournierbar Property

clsDokumenttyp.bBedingtretournierbar Property

clsDokumenttyp.bBedingtretournierbar Property | Previous topic | Next topic
clsDokumenttyp.bBedingtretournierbar Property | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property bBedingtretournierbar() As SqlBoolean

C#

public SqlBoolean bBedingtretournierbar {get; set;}

C++

public:
property SqlBoolean bBedingtretournierbar {
SqlBoolean get( );
void set(
SqlBoolean value
);
}

JScript

public function get bBedingtretournierbar() : SqlBoolean;
public function set bBedingtretournierbar(value : SqlBoolean);

Source code

Visual Basic

Copy Code Copy Code

Public Property [bBedingtretournierbar]() As SqlBoolean
Get
Return m_bBedingtretournierbar
End Get
Set(ByVal Value As SqlBoolean)
m_bBedingtretournierbar = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsDokumenttyp Class
clsDokumenttyp clsDokumenttyp Members


clsDokumenttyp.bBezeichnungmut Property

clsDokumenttyp.bBezeichnungmut Property

clsDokumenttyp.bBezeichnungmut Property | Previous topic | Next topic
clsDokumenttyp.bBezeichnungmut Property | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property bBezeichnungmut() As SqlBoolean

C#

public SqlBoolean bBezeichnungmut {get; set;}

C++

public:
property SqlBoolean bBezeichnungmut {
SqlBoolean get( );
void set(
SqlBoolean value
);
}

JScript

public function get bBezeichnungmut() : SqlBoolean;
public function set bBezeichnungmut(value : SqlBoolean);

Source code

Visual Basic

Copy Code Copy Code

Public Property [bBezeichnungmut]() As SqlBoolean
Get
Return m_bBezeichnungmut
End Get
Set(ByVal Value As SqlBoolean)
m_bBezeichnungmut = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsDokumenttyp Class
clsDokumenttyp clsDokumenttyp Members


clsDokumenttyp.bCold_ersetzen Property

clsDokumenttyp.bCold_ersetzen Property

clsDokumenttyp.bCold_ersetzen Property | Previous topic | Next topic
clsDokumenttyp.bCold_ersetzen Property | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property bCold_ersetzen() As SqlBoolean

C#

public SqlBoolean bCold_ersetzen {get; set;}

C++

public:
property SqlBoolean bCold_ersetzen {
SqlBoolean get( );
void set(
SqlBoolean value
);
}

JScript

public function get bCold_ersetzen() : SqlBoolean;
public function set bCold_ersetzen(value : SqlBoolean);

Source code

Visual Basic

Copy Code Copy Code

Public Property [bCold_ersetzen]() As SqlBoolean
Get
Return m_bCold_ersetzen
End Get
Set(ByVal Value As SqlBoolean)
m_bCold_ersetzen = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsDokumenttyp Class
clsDokumenttyp clsDokumenttyp Members


clsDokumenttyp.bDokument_wird_erstellt Property

clsDokumenttyp.bDokument_wird_erstellt Property

clsDokumenttyp.bDokument_wird_erstellt Property | Previous topic | Next topic
clsDokumenttyp.bDokument_wird_erstellt Property | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property bDokument_wird_erstellt() As SqlBoolean

C#

public SqlBoolean bDokument_wird_erstellt {get; set;}

C++

public:
property SqlBoolean bDokument_wird_erstellt {
SqlBoolean get( );
void set(
SqlBoolean value
);
}

JScript

public function get bDokument_wird_erstellt() : SqlBoolean;
public function set bDokument_wird_erstellt(value : SqlBoolean);

Source code

Visual Basic

Copy Code Copy Code

Public Property [bDokument_wird_erstellt]() As SqlBoolean
Get
Return m_bDokument_wird_erstellt
End Get
Set(ByVal Value As SqlBoolean)
m_bDokument_wird_erstellt = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsDokumenttyp Class
clsDokumenttyp clsDokumenttyp Members


clsDokumenttyp.bDokument_wird_retourniert Property

clsDokumenttyp.bDokument_wird_retourniert Property

clsDokumenttyp.bDokument_wird_retourniert Property | Previous topic | Next topic
clsDokumenttyp.bDokument_wird_retourniert Property | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property bDokument_wird_retourniert() As SqlBoolean

C#

public SqlBoolean bDokument_wird_retourniert {get; set;}

C++

public:
property SqlBoolean bDokument_wird_retourniert {
SqlBoolean get( );
void set(
SqlBoolean value
);
}

JScript

public function get bDokument_wird_retourniert() : SqlBoolean;
public function set bDokument_wird_retourniert(value : SqlBoolean);

Source code

Visual Basic

Copy Code Copy Code

Public Property [bDokument_wird_retourniert]() As SqlBoolean
Get
Return m_bDokument_wird_retourniert
End Get
Set(ByVal Value As SqlBoolean)
m_bDokument_wird_retourniert = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsDokumenttyp Class
clsDokumenttyp clsDokumenttyp Members


clsDokumenttyp.bEingang_ersetzt_ausgang Property

clsDokumenttyp.bEingang_ersetzt_ausgang Property

clsDokumenttyp.bEingang_ersetzt_ausgang Property | Previous topic | Next topic
clsDokumenttyp.bEingang_ersetzt_ausgang Property | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property bEingang_ersetzt_ausgang() As SqlBoolean

C#

public SqlBoolean bEingang_ersetzt_ausgang {get; set;}

C++

public:
property SqlBoolean bEingang_ersetzt_ausgang {
SqlBoolean get( );
void set(
SqlBoolean value
);
}

JScript

public function get bEingang_ersetzt_ausgang() : SqlBoolean;
public function set bEingang_ersetzt_ausgang(value : SqlBoolean);

Source code

Visual Basic

Copy Code Copy Code

Public Property [bEingang_ersetzt_ausgang]() As SqlBoolean
Get
Return m_bEingang_ersetzt_ausgang
End Get
Set(ByVal Value As SqlBoolean)
Dim bEingang_ersetzt_ausgangTmp As SqlBoolean = Value
If bEingang_ersetzt_ausgangTmp.IsNull Then
Throw New ArgumentOutOfRangeException("bEingang_ersetzt_ausgang", "bEingang_ersetzt_ausgang can't be NULL")
End If
m_bEingang_ersetzt_ausgang = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsDokumenttyp Class
clsDokumenttyp clsDokumenttyp Members


clsDokumenttyp.bEmail_versand Property

clsDokumenttyp.bEmail_versand Property

clsDokumenttyp.bEmail_versand Property | Previous topic | Next topic
clsDokumenttyp.bEmail_versand Property | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property bEmail_versand() As SqlBoolean

C#

public SqlBoolean bEmail_versand {get; set;}

C++

public:
property SqlBoolean bEmail_versand {
SqlBoolean get( );
void set(
SqlBoolean value
);
}

JScript

public function get bEmail_versand() : SqlBoolean;
public function set bEmail_versand(value : SqlBoolean);

Source code

Visual Basic

Copy Code Copy Code

Public Property [bEmail_versand]() As SqlBoolean
Get
Return m_bEmail_versand
End Get
Set(ByVal Value As SqlBoolean)
m_bEmail_versand = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsDokumenttyp Class
clsDokumenttyp clsDokumenttyp Members


clsDokumenttyp.bFunktionen_zuweisen Property

clsDokumenttyp.bFunktionen_zuweisen Property

clsDokumenttyp.bFunktionen_zuweisen Property | Previous topic | Next topic
clsDokumenttyp.bFunktionen_zuweisen Property | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property bFunktionen_zuweisen() As SqlBoolean

C#

public SqlBoolean bFunktionen_zuweisen {get; set;}

C++

public:
property SqlBoolean bFunktionen_zuweisen {
SqlBoolean get( );
void set(
SqlBoolean value
);
}

JScript

public function get bFunktionen_zuweisen() : SqlBoolean;
public function set bFunktionen_zuweisen(value : SqlBoolean);

Source code

Visual Basic

Copy Code Copy Code

Public Property [bFunktionen_zuweisen]() As SqlBoolean
Get
Return m_bFunktionen_zuweisen
End Get
Set(ByVal Value As SqlBoolean)
m_bFunktionen_zuweisen = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsDokumenttyp Class
clsDokumenttyp clsDokumenttyp Members


clsDokumenttyp.bHostdokument Property

clsDokumenttyp.bHostdokument Property

clsDokumenttyp.bHostdokument Property | Previous topic | Next topic
clsDokumenttyp.bHostdokument Property | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property bHostdokument() As SqlBoolean

C#

public SqlBoolean bHostdokument {get; set;}

C++

public:
property SqlBoolean bHostdokument {
SqlBoolean get( );
void set(
SqlBoolean value
);
}

JScript

public function get bHostdokument() : SqlBoolean;
public function set bHostdokument(value : SqlBoolean);

Source code

Visual Basic

Copy Code Copy Code

Public Property [bHostdokument]() As SqlBoolean
Get
Return m_bHostdokument
End Get
Set(ByVal Value As SqlBoolean)
m_bHostdokument = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsDokumenttyp Class
clsDokumenttyp clsDokumenttyp Members


clsDokumenttyp.bKundenDokument Property

clsDokumenttyp.bKundenDokument Property

clsDokumenttyp.bKundenDokument Property | Previous topic | Next topic
clsDokumenttyp.bKundenDokument Property | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property bKundenDokument() As SqlBoolean

C#

public SqlBoolean bKundenDokument {get; set;}

C++

public:
property SqlBoolean bKundenDokument {
SqlBoolean get( );
void set(
SqlBoolean value
);
}

JScript

public function get bKundenDokument() : SqlBoolean;
public function set bKundenDokument(value : SqlBoolean);

Source code

Visual Basic

Copy Code Copy Code

Public Property [bKundenDokument]() As SqlBoolean
Get
Return m_bKundenDokument
End Get
Set(ByVal Value As SqlBoolean)
m_bKundenDokument = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsDokumenttyp Class
clsDokumenttyp clsDokumenttyp Members


clsDokumenttyp.bNurnative Property

clsDokumenttyp.bNurnative Property

clsDokumenttyp.bNurnative Property | Previous topic | Next topic
clsDokumenttyp.bNurnative Property | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property bNurnative() As SqlBoolean

C#

public SqlBoolean bNurnative {get; set;}

C++

public:
property SqlBoolean bNurnative {
SqlBoolean get( );
void set(
SqlBoolean value
);
}

JScript

public function get bNurnative() : SqlBoolean;
public function set bNurnative(value : SqlBoolean);

Source code

Visual Basic

Copy Code Copy Code

Public Property [bNurnative]() As SqlBoolean
Get
Return m_bNurnative
End Get
Set(ByVal Value As SqlBoolean)
m_bNurnative = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsDokumenttyp Class
clsDokumenttyp clsDokumenttyp Members


clsDokumenttyp.bPartnersaldierung_statusalt Property

clsDokumenttyp.bPartnersaldierung_statusalt Property

clsDokumenttyp.bPartnersaldierung_statusalt Property | Previous topic | Next topic
clsDokumenttyp.bPartnersaldierung_statusalt Property | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property bPartnersaldierung_statusalt() As SqlBoolean

C#

public SqlBoolean bPartnersaldierung_statusalt {get; set;}

C++

public:
property SqlBoolean bPartnersaldierung_statusalt {
SqlBoolean get( );
void set(
SqlBoolean value
);
}

JScript

public function get bPartnersaldierung_statusalt() : SqlBoolean;
public function set bPartnersaldierung_statusalt(value : SqlBoolean);

Source code

Visual Basic

Copy Code Copy Code

Public Property [bPartnersaldierung_statusalt]() As SqlBoolean
Get
Return m_bPartnersaldierung_statusalt
End Get
Set(ByVal Value As SqlBoolean)
Dim bPartnersaldierung_statusaltTmp As SqlBoolean = Value
If bPartnersaldierung_statusaltTmp.IsNull Then
Throw New ArgumentOutOfRangeException("bPartnersaldierung_statusalt", "bPartnersaldierung_statusalt can't be NULL")
End If
m_bPartnersaldierung_statusalt = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsDokumenttyp Class
clsDokumenttyp clsDokumenttyp Members


clsDokumenttyp.bSb Property

clsDokumenttyp.bSb Property

clsDokumenttyp.bSb Property | Previous topic | Next topic
clsDokumenttyp.bSb Property | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property bSb() As SqlBoolean

C#

public SqlBoolean bSb {get; set;}

C++

public:
property SqlBoolean bSb {
SqlBoolean get( );
void set(
SqlBoolean value
);
}

JScript

public function get bSb() : SqlBoolean;
public function set bSb(value : SqlBoolean);

Source code

Visual Basic

Copy Code Copy Code

Public Property [bSb]() As SqlBoolean
Get
Return m_bSb
End Get
Set(ByVal Value As SqlBoolean)
m_bSb = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsDokumenttyp Class
clsDokumenttyp clsDokumenttyp Members


clsDokumenttyp.bSbedituser Property

clsDokumenttyp.bSbedituser Property

clsDokumenttyp.bSbedituser Property | Previous topic | Next topic
clsDokumenttyp.bSbedituser Property | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property bSbedituser() As SqlBoolean

C#

public SqlBoolean bSbedituser {get; set;}

C++

public:
property SqlBoolean bSbedituser {
SqlBoolean get( );
void set(
SqlBoolean value
);
}

JScript

public function get bSbedituser() : SqlBoolean;
public function set bSbedituser(value : SqlBoolean);

Source code

Visual Basic

Copy Code Copy Code

Public Property [bSbedituser]() As SqlBoolean
Get
Return m_bSbedituser
End Get
Set(ByVal Value As SqlBoolean)
m_bSbedituser = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsDokumenttyp Class
clsDokumenttyp clsDokumenttyp Members


clsDokumenttyp.bSbimport Property

clsDokumenttyp.bSbimport Property

clsDokumenttyp.bSbimport Property | Previous topic | Next topic
clsDokumenttyp.bSbimport Property | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property bSbimport() As SqlBoolean

C#

public SqlBoolean bSbimport {get; set;}

C++

public:
property SqlBoolean bSbimport {
SqlBoolean get( );
void set(
SqlBoolean value
);
}

JScript

public function get bSbimport() : SqlBoolean;
public function set bSbimport(value : SqlBoolean);

Source code

Visual Basic

Copy Code Copy Code

Public Property [bSbimport]() As SqlBoolean
Get
Return m_bSbimport
End Get
Set(ByVal Value As SqlBoolean)
m_bSbimport = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsDokumenttyp Class
clsDokumenttyp clsDokumenttyp Members


clsDokumenttyp.bSbnur Property

clsDokumenttyp.bSbnur Property

clsDokumenttyp.bSbnur Property | Previous topic | Next topic
clsDokumenttyp.bSbnur Property | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property bSbnur() As SqlBoolean

C#

public SqlBoolean bSbnur {get; set;}

C++

public:
property SqlBoolean bSbnur {
SqlBoolean get( );
void set(
SqlBoolean value
);
}

JScript

public function get bSbnur() : SqlBoolean;
public function set bSbnur(value : SqlBoolean);

Source code

Visual Basic

Copy Code Copy Code

Public Property [bSbnur]() As SqlBoolean
Get
Return m_bSbnur
End Get
Set(ByVal Value As SqlBoolean)
m_bSbnur = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsDokumenttyp Class
clsDokumenttyp clsDokumenttyp Members


clsDokumenttyp.bUnterschrift_links Property

clsDokumenttyp.bUnterschrift_links Property

clsDokumenttyp.bUnterschrift_links Property | Previous topic | Next topic
clsDokumenttyp.bUnterschrift_links Property | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property bUnterschrift_links() As SqlBoolean

C#

public SqlBoolean bUnterschrift_links {get; set;}

C++

public:
property SqlBoolean bUnterschrift_links {
SqlBoolean get( );
void set(
SqlBoolean value
);
}

JScript

public function get bUnterschrift_links() : SqlBoolean;
public function set bUnterschrift_links(value : SqlBoolean);

Source code

Visual Basic

Copy Code Copy Code

Public Property [bUnterschrift_links]() As SqlBoolean
Get
Return m_bUnterschrift_links
End Get
Set(ByVal Value As SqlBoolean)
Dim bUnterschrift_linksTmp As SqlBoolean = Value
If bUnterschrift_linksTmp.IsNull Then
Throw New ArgumentOutOfRangeException("bUnterschrift_links", "bUnterschrift_links can't be NULL")
End If
m_bUnterschrift_links = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsDokumenttyp Class
clsDokumenttyp clsDokumenttyp Members


clsDokumenttyp.bUnterschrift_rechts Property

clsDokumenttyp.bUnterschrift_rechts Property

clsDokumenttyp.bUnterschrift_rechts Property | Previous topic | Next topic
clsDokumenttyp.bUnterschrift_rechts Property | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property bUnterschrift_rechts() As SqlBoolean

C#

public SqlBoolean bUnterschrift_rechts {get; set;}

C++

public:
property SqlBoolean bUnterschrift_rechts {
SqlBoolean get( );
void set(
SqlBoolean value
);
}

JScript

public function get bUnterschrift_rechts() : SqlBoolean;
public function set bUnterschrift_rechts(value : SqlBoolean);

Source code

Visual Basic

Copy Code Copy Code

Public Property [bUnterschrift_rechts]() As SqlBoolean
Get
Return m_bUnterschrift_rechts
End Get
Set(ByVal Value As SqlBoolean)
Dim bUnterschrift_rechtsTmp As SqlBoolean = Value
If bUnterschrift_rechtsTmp.IsNull Then
Throw New ArgumentOutOfRangeException("bUnterschrift_rechts", "bUnterschrift_rechts can't be NULL")
End If
m_bUnterschrift_rechts = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsDokumenttyp Class
clsDokumenttyp clsDokumenttyp Members


clsDokumenttyp.bVertrag Property

clsDokumenttyp.bVertrag Property

clsDokumenttyp.bVertrag Property | Previous topic | Next topic
clsDokumenttyp.bVertrag Property | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property bVertrag() As SqlBoolean

C#

public SqlBoolean bVertrag {get; set;}

C++

public:
property SqlBoolean bVertrag {
SqlBoolean get( );
void set(
SqlBoolean value
);
}

JScript

public function get bVertrag() : SqlBoolean;
public function set bVertrag(value : SqlBoolean);

Source code

Visual Basic

Copy Code Copy Code

Public Property [bVertrag]() As SqlBoolean
Get
Return m_bVertrag
End Get
Set(ByVal Value As SqlBoolean)
m_bVertrag = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsDokumenttyp Class
clsDokumenttyp clsDokumenttyp Members


clsDokumenttyp.bVertrauliches_dokument Property

clsDokumenttyp.bVertrauliches_dokument Property

clsDokumenttyp.bVertrauliches_dokument Property | Previous topic | Next topic
clsDokumenttyp.bVertrauliches_dokument Property | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property bVertrauliches_dokument() As SqlBoolean

C#

public SqlBoolean bVertrauliches_dokument {get; set;}

C++

public:
property SqlBoolean bVertrauliches_dokument {
SqlBoolean get( );
void set(
SqlBoolean value
);
}

JScript

public function get bVertrauliches_dokument() : SqlBoolean;
public function set bVertrauliches_dokument(value : SqlBoolean);

Source code

Visual Basic

Copy Code Copy Code

Public Property [bVertrauliches_dokument]() As SqlBoolean
Get
Return m_bVertrauliches_dokument
End Get
Set(ByVal Value As SqlBoolean)
Dim bVertrauliches_dokumentTmp As SqlBoolean = Value
If bVertrauliches_dokumentTmp.IsNull Then
Throw New ArgumentOutOfRangeException("bVertrauliches_dokument", "bVertrauliches_dokument can't be NULL")
End If
m_bVertrauliches_dokument = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsDokumenttyp Class
clsDokumenttyp clsDokumenttyp Members


clsDokumenttyp.bWird_importiert Property

clsDokumenttyp.bWird_importiert Property

clsDokumenttyp.bWird_importiert Property | Previous topic | Next topic
clsDokumenttyp.bWird_importiert Property | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property bWird_importiert() As SqlBoolean

C#

public SqlBoolean bWird_importiert {get; set;}

C++

public:
property SqlBoolean bWird_importiert {
SqlBoolean get( );
void set(
SqlBoolean value
);
}

JScript

public function get bWird_importiert() : SqlBoolean;
public function set bWird_importiert(value : SqlBoolean);

Source code

Visual Basic

Copy Code Copy Code

Public Property [bWird_importiert]() As SqlBoolean
Get
Return m_bWird_importiert
End Get
Set(ByVal Value As SqlBoolean)
Dim bWird_importiertTmp As SqlBoolean = Value
If bWird_importiertTmp.IsNull Then
Throw New ArgumentOutOfRangeException("bWird_importiert", "bWird_importiert can't be NULL")
End If
m_bWird_importiert = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsDokumenttyp Class
clsDokumenttyp clsDokumenttyp Members


clsDokumenttyp.bWird_nicht_geloescht Property

clsDokumenttyp.bWird_nicht_geloescht Property

clsDokumenttyp.bWird_nicht_geloescht Property | Previous topic | Next topic
clsDokumenttyp.bWird_nicht_geloescht Property | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property bWird_nicht_geloescht() As SqlBoolean

C#

public SqlBoolean bWird_nicht_geloescht {get; set;}

C++

public:
property SqlBoolean bWird_nicht_geloescht {
SqlBoolean get( );
void set(
SqlBoolean value
);
}

JScript

public function get bWird_nicht_geloescht() : SqlBoolean;
public function set bWird_nicht_geloescht(value : SqlBoolean);

Source code

Visual Basic

Copy Code Copy Code

Public Property [bWird_nicht_geloescht]() As SqlBoolean
Get
Return m_bWird_nicht_geloescht
End Get
Set(ByVal Value As SqlBoolean)
Dim bWird_nicht_geloeschtTmp As SqlBoolean = Value
If bWird_nicht_geloeschtTmp.IsNull Then
Throw New ArgumentOutOfRangeException("bWird_nicht_geloescht", "bWird_nicht_geloescht can't be NULL")
End If
m_bWird_nicht_geloescht = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsDokumenttyp Class
clsDokumenttyp clsDokumenttyp Members


clsDokumenttyp.bZu_retournieren Property

clsDokumenttyp.bZu_retournieren Property

clsDokumenttyp.bZu_retournieren Property | Previous topic | Next topic
clsDokumenttyp.bZu_retournieren Property | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property bZu_retournieren() As SqlBoolean

C#

public SqlBoolean bZu_retournieren {get; set;}

C++

public:
property SqlBoolean bZu_retournieren {
SqlBoolean get( );
void set(
SqlBoolean value
);
}

JScript

public function get bZu_retournieren() : SqlBoolean;
public function set bZu_retournieren(value : SqlBoolean);

Source code

Visual Basic

Copy Code Copy Code

Public Property [bZu_retournieren]() As SqlBoolean
Get
Return m_bZu_retournieren
End Get
Set(ByVal Value As SqlBoolean)
Dim bZu_retournierenTmp As SqlBoolean = Value
If bZu_retournierenTmp.IsNull Then
Throw New ArgumentOutOfRangeException("bZu_retournieren", "bZu_retournieren can't be NULL")
End If
m_bZu_retournieren = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsDokumenttyp Class
clsDokumenttyp clsDokumenttyp Members


clsDokumenttyp.bZu_vercolden Property

clsDokumenttyp.bZu_vercolden Property

clsDokumenttyp.bZu_vercolden Property | Previous topic | Next topic
clsDokumenttyp.bZu_vercolden Property | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property bZu_vercolden() As SqlBoolean

C#

public SqlBoolean bZu_vercolden {get; set;}

C++

public:
property SqlBoolean bZu_vercolden {
SqlBoolean get( );
void set(
SqlBoolean value
);
}

JScript

public function get bZu_vercolden() : SqlBoolean;
public function set bZu_vercolden(value : SqlBoolean);

Source code

Visual Basic

Copy Code Copy Code

Public Property [bZu_vercolden]() As SqlBoolean
Get
Return m_bZu_vercolden
End Get
Set(ByVal Value As SqlBoolean)
Dim bZu_vercoldenTmp As SqlBoolean = Value
If bZu_vercoldenTmp.IsNull Then
Throw New ArgumentOutOfRangeException("bZu_vercolden", "bZu_vercolden can't be NULL")
End If
m_bZu_vercolden = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsDokumenttyp Class
clsDokumenttyp clsDokumenttyp Members


clsDokumenttyp.daErstellt_am Property

clsDokumenttyp.daErstellt_am Property

clsDokumenttyp.daErstellt_am Property | Previous topic | Next topic
clsDokumenttyp.daErstellt_am Property | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property daErstellt_am() As SqlDateTime

C#

public SqlDateTime daErstellt_am {get; set;}

C++

public:
property SqlDateTime daErstellt_am {
SqlDateTime get( );
void set(
SqlDateTime value
);
}

JScript

public function get daErstellt_am() : SqlDateTime;
public function set daErstellt_am(value : SqlDateTime);

Source code

Visual Basic

Copy Code Copy Code

Public Property [daErstellt_am]() As SqlDateTime
Get
Return m_daErstellt_am
End Get
Set(ByVal Value As SqlDateTime)
m_daErstellt_am = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsDokumenttyp Class
clsDokumenttyp clsDokumenttyp Members


clsDokumenttyp.daMutiert_am Property

clsDokumenttyp.daMutiert_am Property

clsDokumenttyp.daMutiert_am Property | Previous topic | Next topic
clsDokumenttyp.daMutiert_am Property | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property daMutiert_am() As SqlDateTime

C#

public SqlDateTime daMutiert_am {get; set;}

C++

public:
property SqlDateTime daMutiert_am {
SqlDateTime get( );
void set(
SqlDateTime value
);
}

JScript

public function get daMutiert_am() : SqlDateTime;
public function set daMutiert_am(value : SqlDateTime);

Source code

Visual Basic

Copy Code Copy Code

Public Property [daMutiert_am]() As SqlDateTime
Get
Return m_daMutiert_am
End Get
Set(ByVal Value As SqlDateTime)
m_daMutiert_am = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsDokumenttyp Class
clsDokumenttyp clsDokumenttyp Members


clsDokumenttyp.iAnzahl_tage Property

clsDokumenttyp.iAnzahl_tage Property

clsDokumenttyp.iAnzahl_tage Property | Previous topic | Next topic
clsDokumenttyp.iAnzahl_tage Property | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property iAnzahl_tage() As SqlInt32

C#

public SqlInt32 iAnzahl_tage {get; set;}

C++

public:
property SqlInt32 iAnzahl_tage {
SqlInt32 get( );
void set(
SqlInt32 value
);
}

JScript

public function get iAnzahl_tage() : SqlInt32;
public function set iAnzahl_tage(value : SqlInt32);

Source code

Visual Basic

Copy Code Copy Code

Public Property [iAnzahl_tage]() As SqlInt32
Get
Return m_iAnzahl_tage
End Get
Set(ByVal Value As SqlInt32)
Dim iAnzahl_tageTmp As SqlInt32 = Value
If iAnzahl_tageTmp.IsNull Then
Throw New ArgumentOutOfRangeException("iAnzahl_tage", "iAnzahl_tage can't be NULL")
End If
m_iAnzahl_tage = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsDokumenttyp Class
clsDokumenttyp clsDokumenttyp Members


clsDokumenttyp.iAufbewahrungsfrist_elektronisch Property

clsDokumenttyp.iAufbewahrungsfrist_elektronisch Property

clsDokumenttyp.iAufbewahrungsfrist_elektronisch Property | Previous topic | Next topic
clsDokumenttyp.iAufbewahrungsfrist_elektronisch Property | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property iAufbewahrungsfrist_elektronisch() As SqlInt32

C#

public SqlInt32 iAufbewahrungsfrist_elektronisch {get; set;}

C++

public:
property SqlInt32 iAufbewahrungsfrist_elektronisch {
SqlInt32 get( );
void set(
SqlInt32 value
);
}

JScript

public function get iAufbewahrungsfrist_elektronisch() : SqlInt32;
public function set iAufbewahrungsfrist_elektronisch(value : SqlInt32);

Source code

Visual Basic

Copy Code Copy Code

Public Property [iAufbewahrungsfrist_elektronisch]() As SqlInt32
Get
Return m_iAufbewahrungsfrist_elektronisch
End Get
Set(ByVal Value As SqlInt32)
Dim iAufbewahrungsfrist_elektronischTmp As SqlInt32 = Value
If iAufbewahrungsfrist_elektronischTmp.IsNull Then
Throw New ArgumentOutOfRangeException("iAufbewahrungsfrist_elektronisch", "iAufbewahrungsfrist_elektronisch can't be NULL")
End If
m_iAufbewahrungsfrist_elektronisch = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsDokumenttyp Class
clsDokumenttyp clsDokumenttyp Members


clsDokumenttyp.iAufbewahrungsfrist_physisch Property

clsDokumenttyp.iAufbewahrungsfrist_physisch Property

clsDokumenttyp.iAufbewahrungsfrist_physisch Property | Previous topic | Next topic
clsDokumenttyp.iAufbewahrungsfrist_physisch Property | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property iAufbewahrungsfrist_physisch() As SqlInt32

C#

public SqlInt32 iAufbewahrungsfrist_physisch {get; set;}

C++

public:
property SqlInt32 iAufbewahrungsfrist_physisch {
SqlInt32 get( );
void set(
SqlInt32 value
);
}

JScript

public function get iAufbewahrungsfrist_physisch() : SqlInt32;
public function set iAufbewahrungsfrist_physisch(value : SqlInt32);

Source code

Visual Basic

Copy Code Copy Code

Public Property [iAufbewahrungsfrist_physisch]() As SqlInt32
Get
Return m_iAufbewahrungsfrist_physisch
End Get
Set(ByVal Value As SqlInt32)
Dim iAufbewahrungsfrist_physischTmp As SqlInt32 = Value
If iAufbewahrungsfrist_physischTmp.IsNull Then
Throw New ArgumentOutOfRangeException("iAufbewahrungsfrist_physisch", "iAufbewahrungsfrist_physisch can't be NULL")
End If
m_iAufbewahrungsfrist_physisch = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsDokumenttyp Class
clsDokumenttyp clsDokumenttyp Members


clsDokumenttyp.iCold_folder Property

clsDokumenttyp.iCold_folder Property

clsDokumenttyp.iCold_folder Property | Previous topic | Next topic
clsDokumenttyp.iCold_folder Property | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property iCold_folder() As SqlInt32

C#

public SqlInt32 iCold_folder {get; set;}

C++

public:
property SqlInt32 iCold_folder {
SqlInt32 get( );
void set(
SqlInt32 value
);
}

JScript

public function get iCold_folder() : SqlInt32;
public function set iCold_folder(value : SqlInt32);

Source code

Visual Basic

Copy Code Copy Code

Public Property [iCold_folder]() As SqlInt32
Get
Return m_iCold_folder
End Get
Set(ByVal Value As SqlInt32)
m_iCold_folder = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsDokumenttyp Class
clsDokumenttyp clsDokumenttyp Members


clsDokumenttyp.iDbearbeitungszeit Property

clsDokumenttyp.iDbearbeitungszeit Property

clsDokumenttyp.iDbearbeitungszeit Property | Previous topic | Next topic
clsDokumenttyp.iDbearbeitungszeit Property | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property iDbearbeitungszeit() As SqlInt32

C#

public SqlInt32 iDbearbeitungszeit {get; set;}

C++

public:
property SqlInt32 iDbearbeitungszeit {
SqlInt32 get( );
void set(
SqlInt32 value
);
}

JScript

public function get iDbearbeitungszeit() : SqlInt32;
public function set iDbearbeitungszeit(value : SqlInt32);

Source code

Visual Basic

Copy Code Copy Code

Public Property [iDbearbeitungszeit]() As SqlInt32
Get
Return m_iDbearbeitungszeit
End Get
Set(ByVal Value As SqlInt32)
Dim iDbearbeitungszeitTmp As SqlInt32 = Value
If iDbearbeitungszeitTmp.IsNull Then
Throw New ArgumentOutOfRangeException("iDbearbeitungszeit", "iDbearbeitungszeit can't be NULL")
End If
m_iDbearbeitungszeit = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsDokumenttyp Class
clsDokumenttyp clsDokumenttyp Members


clsDokumenttyp.iDoktypbedingteretournierung Property

clsDokumenttyp.iDoktypbedingteretournierung Property

clsDokumenttyp.iDoktypbedingteretournierung Property | Previous topic | Next topic
clsDokumenttyp.iDoktypbedingteretournierung Property | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property iDoktypbedingteretournierung() As SqlInt32

C#

public SqlInt32 iDoktypbedingteretournierung {get; set;}

C++

public:
property SqlInt32 iDoktypbedingteretournierung {
SqlInt32 get( );
void set(
SqlInt32 value
);
}

JScript

public function get iDoktypbedingteretournierung() : SqlInt32;
public function set iDoktypbedingteretournierung(value : SqlInt32);

Source code

Visual Basic

Copy Code Copy Code

Public Property [iDoktypbedingteretournierung]() As SqlInt32
Get
Return m_iDoktypbedingteretournierung
End Get
Set(ByVal Value As SqlInt32)
m_iDoktypbedingteretournierung = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsDokumenttyp Class
clsDokumenttyp clsDokumenttyp Members


clsDokumenttyp.iDokumentart_coldausgang Property

clsDokumenttyp.iDokumentart_coldausgang Property

clsDokumenttyp.iDokumentart_coldausgang Property | Previous topic | Next topic
clsDokumenttyp.iDokumentart_coldausgang Property | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property iDokumentart_coldausgang() As SqlInt32

C#

public SqlInt32 iDokumentart_coldausgang {get; set;}

C++

public:
property SqlInt32 iDokumentart_coldausgang {
SqlInt32 get( );
void set(
SqlInt32 value
);
}

JScript

public function get iDokumentart_coldausgang() : SqlInt32;
public function set iDokumentart_coldausgang(value : SqlInt32);

Source code

Visual Basic

Copy Code Copy Code

Public Property [iDokumentart_coldausgang]() As SqlInt32
Get
Return m_iDokumentart_coldausgang
End Get
Set(ByVal Value As SqlInt32)
Dim iDokumentart_coldausgangTmp As SqlInt32 = Value
If iDokumentart_coldausgangTmp.IsNull Then
Throw New ArgumentOutOfRangeException("iDokumentart_coldausgang", "iDokumentart_coldausgang can't be NULL")
End If
m_iDokumentart_coldausgang = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsDokumenttyp Class
clsDokumenttyp clsDokumenttyp Members


clsDokumenttyp.iDokumentart_coldeingang Property

clsDokumenttyp.iDokumentart_coldeingang Property

clsDokumenttyp.iDokumentart_coldeingang Property | Previous topic | Next topic
clsDokumenttyp.iDokumentart_coldeingang Property | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property iDokumentart_coldeingang() As SqlInt32

C#

public SqlInt32 iDokumentart_coldeingang {get; set;}

C++

public:
property SqlInt32 iDokumentart_coldeingang {
SqlInt32 get( );
void set(
SqlInt32 value
);
}

JScript

public function get iDokumentart_coldeingang() : SqlInt32;
public function set iDokumentart_coldeingang(value : SqlInt32);

Source code

Visual Basic

Copy Code Copy Code

Public Property [iDokumentart_coldeingang]() As SqlInt32
Get
Return m_iDokumentart_coldeingang
End Get
Set(ByVal Value As SqlInt32)
Dim iDokumentart_coldeingangTmp As SqlInt32 = Value
If iDokumentart_coldeingangTmp.IsNull Then
Throw New ArgumentOutOfRangeException("iDokumentart_coldeingang", "iDokumentart_coldeingang can't be NULL")
End If
m_iDokumentart_coldeingang = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsDokumenttyp Class
clsDokumenttyp clsDokumenttyp Members


clsDokumenttyp.iDokumentart_host Property

clsDokumenttyp.iDokumentart_host Property

clsDokumenttyp.iDokumentart_host Property | Previous topic | Next topic
clsDokumenttyp.iDokumentart_host Property | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property iDokumentart_host() As SqlInt32

C#

public SqlInt32 iDokumentart_host {get; set;}

C++

public:
property SqlInt32 iDokumentart_host {
SqlInt32 get( );
void set(
SqlInt32 value
);
}

JScript

public function get iDokumentart_host() : SqlInt32;
public function set iDokumentart_host(value : SqlInt32);

Source code

Visual Basic

Copy Code Copy Code

Public Property [iDokumentart_host]() As SqlInt32
Get
Return m_iDokumentart_host
End Get
Set(ByVal Value As SqlInt32)
m_iDokumentart_host = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsDokumenttyp Class
clsDokumenttyp clsDokumenttyp Members


clsDokumenttyp.iDokumentart_kundendossier Property

clsDokumenttyp.iDokumentart_kundendossier Property

clsDokumenttyp.iDokumentart_kundendossier Property | Previous topic | Next topic
clsDokumenttyp.iDokumentart_kundendossier Property | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property iDokumentart_kundendossier() As SqlInt32

C#

public SqlInt32 iDokumentart_kundendossier {get; set;}

C++

public:
property SqlInt32 iDokumentart_kundendossier {
SqlInt32 get( );
void set(
SqlInt32 value
);
}

JScript

public function get iDokumentart_kundendossier() : SqlInt32;
public function set iDokumentart_kundendossier(value : SqlInt32);

Source code

Visual Basic

Copy Code Copy Code

Public Property [iDokumentart_kundendossier]() As SqlInt32
Get
Return m_iDokumentart_kundendossier
End Get
Set(ByVal Value As SqlInt32)
m_iDokumentart_kundendossier = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsDokumenttyp Class
clsDokumenttyp clsDokumenttyp Members


clsDokumenttyp.iDokumentart_nativ Property

clsDokumenttyp.iDokumentart_nativ Property

clsDokumenttyp.iDokumentart_nativ Property | Previous topic | Next topic
clsDokumenttyp.iDokumentart_nativ Property | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property iDokumentart_nativ() As SqlInt32

C#

public SqlInt32 iDokumentart_nativ {get; set;}

C++

public:
property SqlInt32 iDokumentart_nativ {
SqlInt32 get( );
void set(
SqlInt32 value
);
}

JScript

public function get iDokumentart_nativ() : SqlInt32;
public function set iDokumentart_nativ(value : SqlInt32);

Source code

Visual Basic

Copy Code Copy Code

Public Property [iDokumentart_nativ]() As SqlInt32
Get
Return m_iDokumentart_nativ
End Get
Set(ByVal Value As SqlInt32)
m_iDokumentart_nativ = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsDokumenttyp Class
clsDokumenttyp clsDokumenttyp Members


clsDokumenttyp.iDokumentart_neuerstellung Property

clsDokumenttyp.iDokumentart_neuerstellung Property

clsDokumenttyp.iDokumentart_neuerstellung Property | Previous topic | Next topic
clsDokumenttyp.iDokumentart_neuerstellung Property | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property iDokumentart_neuerstellung() As SqlInt32

C#

public SqlInt32 iDokumentart_neuerstellung {get; set;}

C++

public:
property SqlInt32 iDokumentart_neuerstellung {
SqlInt32 get( );
void set(
SqlInt32 value
);
}

JScript

public function get iDokumentart_neuerstellung() : SqlInt32;
public function set iDokumentart_neuerstellung(value : SqlInt32);

Source code

Visual Basic

Copy Code Copy Code

Public Property [iDokumentart_neuerstellung]() As SqlInt32
Get
Return m_iDokumentart_neuerstellung
End Get
Set(ByVal Value As SqlInt32)
m_iDokumentart_neuerstellung = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsDokumenttyp Class
clsDokumenttyp clsDokumenttyp Members


clsDokumenttyp.iDokumentart_retournierung Property

clsDokumenttyp.iDokumentart_retournierung Property

clsDokumenttyp.iDokumentart_retournierung Property | Previous topic | Next topic
clsDokumenttyp.iDokumentart_retournierung Property | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property iDokumentart_retournierung() As SqlInt32

C#

public SqlInt32 iDokumentart_retournierung {get; set;}

C++

public:
property SqlInt32 iDokumentart_retournierung {
SqlInt32 get( );
void set(
SqlInt32 value
);
}

JScript

public function get iDokumentart_retournierung() : SqlInt32;
public function set iDokumentart_retournierung(value : SqlInt32);

Source code

Visual Basic

Copy Code Copy Code

Public Property [iDokumentart_retournierung]() As SqlInt32
Get
Return m_iDokumentart_retournierung
End Get
Set(ByVal Value As SqlInt32)
m_iDokumentart_retournierung = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsDokumenttyp Class
clsDokumenttyp clsDokumenttyp Members


clsDokumenttyp.iDokumentart_weitere Property

clsDokumenttyp.iDokumentart_weitere Property

clsDokumenttyp.iDokumentart_weitere Property | Previous topic | Next topic
clsDokumenttyp.iDokumentart_weitere Property | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property iDokumentart_weitere() As SqlInt32

C#

public SqlInt32 iDokumentart_weitere {get; set;}

C++

public:
property SqlInt32 iDokumentart_weitere {
SqlInt32 get( );
void set(
SqlInt32 value
);
}

JScript

public function get iDokumentart_weitere() : SqlInt32;
public function set iDokumentart_weitere(value : SqlInt32);

Source code

Visual Basic

Copy Code Copy Code

Public Property [iDokumentart_weitere]() As SqlInt32
Get
Return m_iDokumentart_weitere
End Get
Set(ByVal Value As SqlInt32)
m_iDokumentart_weitere = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsDokumenttyp Class
clsDokumenttyp clsDokumenttyp Members


clsDokumenttyp.iDokumentstatus Property

clsDokumenttyp.iDokumentstatus Property

clsDokumenttyp.iDokumentstatus Property | Previous topic | Next topic
clsDokumenttyp.iDokumentstatus Property | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property iDokumentstatus() As SqlInt32

C#

public SqlInt32 iDokumentstatus {get; set;}

C++

public:
property SqlInt32 iDokumentstatus {
SqlInt32 get( );
void set(
SqlInt32 value
);
}

JScript

public function get iDokumentstatus() : SqlInt32;
public function set iDokumentstatus(value : SqlInt32);

Source code

Visual Basic

Copy Code Copy Code

Public Property [iDokumentstatus]() As SqlInt32
Get
Return m_iDokumentstatus
End Get
Set(ByVal Value As SqlInt32)
m_iDokumentstatus = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsDokumenttyp Class
clsDokumenttyp clsDokumenttyp Members


clsDokumenttyp.iDokumentstatus_barcode Property

clsDokumenttyp.iDokumentstatus_barcode Property

clsDokumenttyp.iDokumentstatus_barcode Property | Previous topic | Next topic
clsDokumenttyp.iDokumentstatus_barcode Property | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property iDokumentstatus_barcode() As SqlInt32

C#

public SqlInt32 iDokumentstatus_barcode {get; set;}

C++

public:
property SqlInt32 iDokumentstatus_barcode {
SqlInt32 get( );
void set(
SqlInt32 value
);
}

JScript

public function get iDokumentstatus_barcode() : SqlInt32;
public function set iDokumentstatus_barcode(value : SqlInt32);

Source code

Visual Basic

Copy Code Copy Code

Public Property [iDokumentstatus_barcode]() As SqlInt32
Get
Return m_iDokumentstatus_barcode
End Get
Set(ByVal Value As SqlInt32)
m_iDokumentstatus_barcode = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsDokumenttyp Class
clsDokumenttyp clsDokumenttyp Members


clsDokumenttyp.iDokumenttypnr Property

clsDokumenttyp.iDokumenttypnr Property

clsDokumenttyp.iDokumenttypnr Property | Previous topic | Next topic
clsDokumenttyp.iDokumenttypnr Property | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property iDokumenttypnr() As SqlInt32

C#

public SqlInt32 iDokumenttypnr {get; set;}

C++

public:
property SqlInt32 iDokumenttypnr {
SqlInt32 get( );
void set(
SqlInt32 value
);
}

JScript

public function get iDokumenttypnr() : SqlInt32;
public function set iDokumenttypnr(value : SqlInt32);

Source code

Visual Basic

Copy Code Copy Code

Public Property [iDokumenttypnr]() As SqlInt32
Get
Return m_iDokumenttypnr
End Get
Set(ByVal Value As SqlInt32)
Dim iDokumenttypnrTmp As SqlInt32 = Value
If iDokumenttypnrTmp.IsNull Then
Throw New ArgumentOutOfRangeException("iDokumenttypnr", "iDokumenttypnr can't be NULL")
End If
m_iDokumenttypnr = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsDokumenttyp Class
clsDokumenttyp clsDokumenttyp Members


clsDokumenttyp.iMandantnr Property

clsDokumenttyp.iMandantnr Property

clsDokumenttyp.iMandantnr Property | Previous topic | Next topic
clsDokumenttyp.iMandantnr Property | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property iMandantnr() As SqlInt32

C#

public SqlInt32 iMandantnr {get; set;}

C++

public:
property SqlInt32 iMandantnr {
SqlInt32 get( );
void set(
SqlInt32 value
);
}

JScript

public function get iMandantnr() : SqlInt32;
public function set iMandantnr(value : SqlInt32);

Source code

Visual Basic

Copy Code Copy Code

Public Property [iMandantnr]() As SqlInt32
Get
Return m_iMandantnr
End Get
Set(ByVal Value As SqlInt32)
m_iMandantnr = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsDokumenttyp Class
clsDokumenttyp clsDokumenttyp Members


clsDokumenttyp.iMonate_bis_zur_archivierung Property

clsDokumenttyp.iMonate_bis_zur_archivierung Property

clsDokumenttyp.iMonate_bis_zur_archivierung Property | Previous topic | Next topic
clsDokumenttyp.iMonate_bis_zur_archivierung Property | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property iMonate_bis_zur_archivierung() As SqlInt32

C#

public SqlInt32 iMonate_bis_zur_archivierung {get; set;}

C++

public:
property SqlInt32 iMonate_bis_zur_archivierung {
SqlInt32 get( );
void set(
SqlInt32 value
);
}

JScript

public function get iMonate_bis_zur_archivierung() : SqlInt32;
public function set iMonate_bis_zur_archivierung(value : SqlInt32);

Source code

Visual Basic

Copy Code Copy Code

Public Property [iMonate_bis_zur_archivierung]() As SqlInt32
Get
Return m_iMonate_bis_zur_archivierung
End Get
Set(ByVal Value As SqlInt32)
Dim iMonate_bis_zur_archivierungTmp As SqlInt32 = Value
If iMonate_bis_zur_archivierungTmp.IsNull Then
Throw New ArgumentOutOfRangeException("iMonate_bis_zur_archivierung", "iMonate_bis_zur_archivierung can't be NULL")
End If
m_iMonate_bis_zur_archivierung = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsDokumenttyp Class
clsDokumenttyp clsDokumenttyp Members


clsDokumenttyp.iMutierer Property

clsDokumenttyp.iMutierer Property

clsDokumenttyp.iMutierer Property | Previous topic | Next topic
clsDokumenttyp.iMutierer Property | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property iMutierer() As SqlInt32

C#

public SqlInt32 iMutierer {get; set;}

C++

public:
property SqlInt32 iMutierer {
SqlInt32 get( );
void set(
SqlInt32 value
);
}

JScript

public function get iMutierer() : SqlInt32;
public function set iMutierer(value : SqlInt32);

Source code

Visual Basic

Copy Code Copy Code

Public Property [iMutierer]() As SqlInt32
Get
Return m_iMutierer
End Get
Set(ByVal Value As SqlInt32)
m_iMutierer = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsDokumenttyp Class
clsDokumenttyp clsDokumenttyp Members


clsDokumenttyp.iObjektbezeichnungnr Property

clsDokumenttyp.iObjektbezeichnungnr Property

clsDokumenttyp.iObjektbezeichnungnr Property | Previous topic | Next topic
clsDokumenttyp.iObjektbezeichnungnr Property | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property iObjektbezeichnungnr() As SqlInt32

C#

public SqlInt32 iObjektbezeichnungnr {get; set;}

C++

public:
property SqlInt32 iObjektbezeichnungnr {
SqlInt32 get( );
void set(
SqlInt32 value
);
}

JScript

public function get iObjektbezeichnungnr() : SqlInt32;
public function set iObjektbezeichnungnr(value : SqlInt32);

Source code

Visual Basic

Copy Code Copy Code

Public Property [iObjektbezeichnungnr]() As SqlInt32
Get
Return m_iObjektbezeichnungnr
End Get
Set(ByVal Value As SqlInt32)
m_iObjektbezeichnungnr = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsDokumenttyp Class
clsDokumenttyp clsDokumenttyp Members


clsDokumenttyp.iOffice_vorlagenr Property

clsDokumenttyp.iOffice_vorlagenr Property

clsDokumenttyp.iOffice_vorlagenr Property | Previous topic | Next topic
clsDokumenttyp.iOffice_vorlagenr Property | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property iOffice_vorlagenr() As SqlInt32

C#

public SqlInt32 iOffice_vorlagenr {get; set;}

C++

public:
property SqlInt32 iOffice_vorlagenr {
SqlInt32 get( );
void set(
SqlInt32 value
);
}

JScript

public function get iOffice_vorlagenr() : SqlInt32;
public function set iOffice_vorlagenr(value : SqlInt32);

Source code

Visual Basic

Copy Code Copy Code

Public Property [iOffice_vorlagenr]() As SqlInt32
Get
Return m_iOffice_vorlagenr
End Get
Set(ByVal Value As SqlInt32)
m_iOffice_vorlagenr = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsDokumenttyp Class
clsDokumenttyp clsDokumenttyp Members


clsDokumenttyp.iOwner Property

clsDokumenttyp.iOwner Property

clsDokumenttyp.iOwner Property | Previous topic | Next topic
clsDokumenttyp.iOwner Property | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property iOwner() As SqlInt32

C#

public SqlInt32 iOwner {get; set;}

C++

public:
property SqlInt32 iOwner {
SqlInt32 get( );
void set(
SqlInt32 value
);
}

JScript

public function get iOwner() : SqlInt32;
public function set iOwner(value : SqlInt32);

Source code

Visual Basic

Copy Code Copy Code

Public Property [iOwner]() As SqlInt32
Get
Return m_iOwner
End Get
Set(ByVal Value As SqlInt32)
m_iOwner = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsDokumenttyp Class
clsDokumenttyp clsDokumenttyp Members


clsDokumenttyp.iPhysisches_archiv Property

clsDokumenttyp.iPhysisches_archiv Property

clsDokumenttyp.iPhysisches_archiv Property | Previous topic | Next topic
clsDokumenttyp.iPhysisches_archiv Property | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property iPhysisches_archiv() As SqlInt32

C#

public SqlInt32 iPhysisches_archiv {get; set;}

C++

public:
property SqlInt32 iPhysisches_archiv {
SqlInt32 get( );
void set(
SqlInt32 value
);
}

JScript

public function get iPhysisches_archiv() : SqlInt32;
public function set iPhysisches_archiv(value : SqlInt32);

Source code

Visual Basic

Copy Code Copy Code

Public Property [iPhysisches_archiv]() As SqlInt32
Get
Return m_iPhysisches_archiv
End Get
Set(ByVal Value As SqlInt32)
m_iPhysisches_archiv = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsDokumenttyp Class
clsDokumenttyp clsDokumenttyp Members


clsDokumenttyp.iProzessnr Property

clsDokumenttyp.iProzessnr Property

clsDokumenttyp.iProzessnr Property | Previous topic | Next topic
clsDokumenttyp.iProzessnr Property | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property iProzessnr() As SqlInt32

C#

public SqlInt32 iProzessnr {get; set;}

C++

public:
property SqlInt32 iProzessnr {
SqlInt32 get( );
void set(
SqlInt32 value
);
}

JScript

public function get iProzessnr() : SqlInt32;
public function set iProzessnr(value : SqlInt32);

Source code

Visual Basic

Copy Code Copy Code

Public Property [iProzessnr]() As SqlInt32
Get
Return m_iProzessnr
End Get
Set(ByVal Value As SqlInt32)
m_iProzessnr = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsDokumenttyp Class
clsDokumenttyp clsDokumenttyp Members


clsDokumenttyp.iProzessnr1 Property

clsDokumenttyp.iProzessnr1 Property

clsDokumenttyp.iProzessnr1 Property | Previous topic | Next topic
clsDokumenttyp.iProzessnr1 Property | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property iProzessnr1() As SqlInt32

C#

public SqlInt32 iProzessnr1 {get; set;}

C++

public:
property SqlInt32 iProzessnr1 {
SqlInt32 get( );
void set(
SqlInt32 value
);
}

JScript

public function get iProzessnr1() : SqlInt32;
public function set iProzessnr1(value : SqlInt32);

Source code

Visual Basic

Copy Code Copy Code

Public Property [iProzessnr1]() As SqlInt32
Get
Return m_iProzessnr1
End Get
Set(ByVal Value As SqlInt32)
m_iProzessnr1 = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsDokumenttyp Class
clsDokumenttyp clsDokumenttyp Members


clsDokumenttyp.iTage_mutation Property

clsDokumenttyp.iTage_mutation Property

clsDokumenttyp.iTage_mutation Property | Previous topic | Next topic
clsDokumenttyp.iTage_mutation Property | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property iTage_mutation() As SqlInt32

C#

public SqlInt32 iTage_mutation {get; set;}

C++

public:
property SqlInt32 iTage_mutation {
SqlInt32 get( );
void set(
SqlInt32 value
);
}

JScript

public function get iTage_mutation() : SqlInt32;
public function set iTage_mutation(value : SqlInt32);

Source code

Visual Basic

Copy Code Copy Code

Public Property [iTage_mutation]() As SqlInt32
Get
Return m_iTage_mutation
End Get
Set(ByVal Value As SqlInt32)
Dim iTage_mutationTmp As SqlInt32 = Value
If iTage_mutationTmp.IsNull Then
Throw New ArgumentOutOfRangeException("iTage_mutation", "iTage_mutation can't be NULL")
End If
m_iTage_mutation = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsDokumenttyp Class
clsDokumenttyp clsDokumenttyp Members


clsDokumenttyp.iTagebisvernichtungbedingteretournierung Property

clsDokumenttyp.iTagebisvernichtungbedingteretournierung Property

clsDokumenttyp.iTagebisvernichtungbedingteretournierung Property | Previous topic | Next topic
clsDokumenttyp.iTagebisvernichtungbedingteretournierung Property | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property iTagebisvernichtungbedingteretournierung() As SqlInt32

C#

public SqlInt32 iTagebisvernichtungbedingteretournierung {get; set;}

C++

public:
property SqlInt32 iTagebisvernichtungbedingteretournierung {
SqlInt32 get( );
void set(
SqlInt32 value
);
}

JScript

public function get iTagebisvernichtungbedingteretournierung() : SqlInt32;
public function set iTagebisvernichtungbedingteretournierung(value : SqlInt32);

Source code

Visual Basic

Copy Code Copy Code

Public Property [iTagebisvernichtungbedingteretournierung]() As SqlInt32
Get
Return m_iTagebisvernichtungbedingteretournierung
End Get
Set(ByVal Value As SqlInt32)
m_iTagebisvernichtungbedingteretournierung = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsDokumenttyp Class
clsDokumenttyp clsDokumenttyp Members


clsDokumenttyp.sBeschreibung Property

clsDokumenttyp.sBeschreibung Property

clsDokumenttyp.sBeschreibung Property | Previous topic | Next topic
clsDokumenttyp.sBeschreibung Property | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property sBeschreibung() As SqlString

C#

public SqlString sBeschreibung {get; set;}

C++

public:
property SqlString sBeschreibung {
SqlString get( );
void set(
SqlString value
);
}

JScript

public function get sBeschreibung() : SqlString;
public function set sBeschreibung(value : SqlString);

Source code

Visual Basic

Copy Code Copy Code

Public Property [sBeschreibung]() As SqlString
Get
Return m_sBeschreibung
End Get
Set(ByVal Value As SqlString)
m_sBeschreibung = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsDokumenttyp Class
clsDokumenttyp clsDokumenttyp Members


clsDokumenttyp.sBezeichnung Property

clsDokumenttyp.sBezeichnung Property

clsDokumenttyp.sBezeichnung Property | Previous topic | Next topic
clsDokumenttyp.sBezeichnung Property | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property sBezeichnung() As SqlString

C#

public SqlString sBezeichnung {get; set;}

C++

public:
property SqlString sBezeichnung {
SqlString get( );
void set(
SqlString value
);
}

JScript

public function get sBezeichnung() : SqlString;
public function set sBezeichnung(value : SqlString);

Source code

Visual Basic

Copy Code Copy Code

Public Property [sBezeichnung]() As SqlString
Get
Return m_sBezeichnung
End Get
Set(ByVal Value As SqlString)
m_sBezeichnung = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsDokumenttyp Class
clsDokumenttyp clsDokumenttyp Members


clsDokumenttyp.sHostdokumenttyp Property

clsDokumenttyp.sHostdokumenttyp Property

clsDokumenttyp.sHostdokumenttyp Property | Previous topic | Next topic
clsDokumenttyp.sHostdokumenttyp Property | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property sHostdokumenttyp() As SqlString

C#

public SqlString sHostdokumenttyp {get; set;}

C++

public:
property SqlString sHostdokumenttyp {
SqlString get( );
void set(
SqlString value
);
}

JScript

public function get sHostdokumenttyp() : SqlString;
public function set sHostdokumenttyp(value : SqlString);

Source code

Visual Basic

Copy Code Copy Code

Public Property [sHostdokumenttyp]() As SqlString
Get
Return m_sHostdokumenttyp
End Get
Set(ByVal Value As SqlString)
m_sHostdokumenttyp = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsDokumenttyp Class
clsDokumenttyp clsDokumenttyp Members


clsDokumenttyp Methods

clsDokumenttyp Methods

clsDokumenttyp Methods | Previous topic | Next topic
clsDokumenttyp Methods | Previous topic | Next topic

Public Methods

 | Name | Description
Supported by the .NET Compact Framework. | Delete |
Supported by the .NET Compact Framework. | Dispose | (Overloaded) (inherited from clsDBInteractionBase ).
Public method | Equals | (Overloaded) (inherited from Object).
Public method | GetHashCode | (inherited from Object).
Public method | GetType | (Overloaded) (inherited from Object).
Supported by the .NET Compact Framework. | Insert |
 | ReferenceEquals | (inherited from Object).
Supported by the .NET Compact Framework. | SelectAll |
Supported by the .NET Compact Framework. | SelectOne |
Public method | ToString | (inherited from Object).
Supported by the .NET Compact Framework. | Update |

Top

Protected Methods

 | Name | Description
Protected method | Finalize | (inherited from Object).
Protected method | MemberwiseClone | (Overloaded) (inherited from Object).

Top

See Also

Reference

clsDokumenttyp Class


clsDokumenttyp.Delete Method

clsDokumenttyp.Delete Method

clsDokumenttyp.Delete Method | Previous topic | Next topic
clsDokumenttyp.Delete Method | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Overrides Function Delete() As Boolean

C#

public override bool Delete()

C++

public:
bool Delete()

JScript

public function Delete() : boolean;

Source code

Visual Basic

Copy Code Copy Code

Public Overrides Function Delete() As Boolean
Dim scmCmdToExecute As SqlCommand = New SqlCommand()
scmCmdToExecute.CommandText = "dbo.[pr_dokumenttyp_Delete]"
scmCmdToExecute.CommandType = CommandType.StoredProcedure

' // Use base class' connection object
scmCmdToExecute.Connection = m_scoMainConnection

Try
scmCmdToExecute.Parameters.Add(New SqlParameter("@idokumenttypnr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iDokumenttypnr))
scmCmdToExecute.Parameters.Add(New SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

If m_bMainConnectionIsCreatedLocal Then
' // Open connection.
m_scoMainConnection.Open()
Else
If m_cpMainConnectionProvider.bIsTransactionPending Then
scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
End If
End If

' // Execute query.
scmCmdToExecute.ExecuteNonQuery()
m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
' // Throw error.
Throw New Exception("Stored Procedure 'pr_dokumenttyp_Delete' reported the ErrorCode: " & m_iErrorCode.ToString())
End If

Return True
Catch ex As Exception
' // some error occured. Bubble it to caller and encapsulate Exception object
Throw New Exception("clsDokumenttyp::Delete::Error occured.", ex)
Finally
If m_bMainConnectionIsCreatedLocal Then
' // Close connection.
m_scoMainConnection.Close()
End If
scmCmdToExecute.Dispose()
End Try
End Function

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsDokumenttyp Class
clsDokumenttyp clsDokumenttyp Members


clsDokumenttyp.Insert Method

clsDokumenttyp.Insert Method

clsDokumenttyp.Insert Method | Previous topic | Next topic
clsDokumenttyp.Insert Method | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Overrides Function Insert() As Boolean

C#

public override bool Insert()

C++

public:
bool Insert()

JScript

public function Insert() : boolean;

Source code

Visual Basic

Copy Code Copy Code

Overrides Public Function Insert() As Boolean
Dim scmCmdToExecute As SqlCommand = New SqlCommand()
scmCmdToExecute.CommandText = "dbo.[pr_dokumenttyp_Insert]"
scmCmdToExecute.CommandType = CommandType.StoredProcedure

' // Use base class' connection object
scmCmdToExecute.Connection = m_scoMainConnection

Try
scmCmdToExecute.Parameters.Add(New SqlParameter("@idokumenttypnr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iDokumenttypnr))
scmCmdToExecute.Parameters.Add(New SqlParameter("@sbezeichnung", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBezeichnung))
scmCmdToExecute.Parameters.Add(New SqlParameter("@sbeschreibung", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBeschreibung))
scmCmdToExecute.Parameters.Add(New SqlParameter("@bzu_vercolden", SqlDbType.Bit, 1, ParameterDirection.Input, False, 1, 0, "", DataRowVersion.Proposed, m_bZu_vercolden))
scmCmdToExecute.Parameters.Add(New SqlParameter("@bzu_retournieren", SqlDbType.Bit, 1, ParameterDirection.Input, False, 1, 0, "", DataRowVersion.Proposed, m_bZu_retournieren))
scmCmdToExecute.Parameters.Add(New SqlParameter("@beingang_ersetzt_ausgang", SqlDbType.Bit, 1, ParameterDirection.Input, False, 1, 0, "", DataRowVersion.Proposed, m_bEingang_ersetzt_ausgang))
scmCmdToExecute.Parameters.Add(New SqlParameter("@bwird_importiert", SqlDbType.Bit, 1, ParameterDirection.Input, False, 1, 0, "", DataRowVersion.Proposed, m_bWird_importiert))
scmCmdToExecute.Parameters.Add(New SqlParameter("@ianzahl_tage", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iAnzahl_tage))
scmCmdToExecute.Parameters.Add(New SqlParameter("@idbearbeitungszeit", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iDbearbeitungszeit))
scmCmdToExecute.Parameters.Add(New SqlParameter("@itage_mutation", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iTage_mutation))
scmCmdToExecute.Parameters.Add(New SqlParameter("@bpartnersaldierung_statusalt", SqlDbType.Bit, 1, ParameterDirection.Input, False, 1, 0, "", DataRowVersion.Proposed, m_bPartnersaldierung_statusalt))
scmCmdToExecute.Parameters.Add(New SqlParameter("@bwird_nicht_geloescht", SqlDbType.Bit, 1, ParameterDirection.Input, False, 1, 0, "", DataRowVersion.Proposed, m_bWird_nicht_geloescht))
scmCmdToExecute.Parameters.Add(New SqlParameter("@bvertrauliches_dokument", SqlDbType.Bit, 1, ParameterDirection.Input, False, 1, 0, "", DataRowVersion.Proposed, m_bVertrauliches_dokument))
scmCmdToExecute.Parameters.Add(New SqlParameter("@bunterschrift_links", SqlDbType.Bit, 1, ParameterDirection.Input, False, 1, 0, "", DataRowVersion.Proposed, m_bUnterschrift_links))
scmCmdToExecute.Parameters.Add(New SqlParameter("@bunterschrift_rechts", SqlDbType.Bit, 1, ParameterDirection.Input, False, 1, 0, "", DataRowVersion.Proposed, m_bUnterschrift_rechts))
scmCmdToExecute.Parameters.Add(New SqlParameter("@imonate_bis_zur_archivierung", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iMonate_bis_zur_archivierung))
scmCmdToExecute.Parameters.Add(New SqlParameter("@iaufbewahrungsfrist_elektronisch", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iAufbewahrungsfrist_elektronisch))
scmCmdToExecute.Parameters.Add(New SqlParameter("@iaufbewahrungsfrist_physisch", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iAufbewahrungsfrist_physisch))
scmCmdToExecute.Parameters.Add(New SqlParameter("@imandantnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMandantnr))
scmCmdToExecute.Parameters.Add(New SqlParameter("@baktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bAktiv))
scmCmdToExecute.Parameters.Add(New SqlParameter("@daerstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daErstellt_am))
scmCmdToExecute.Parameters.Add(New SqlParameter("@damutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daMutiert_am))
scmCmdToExecute.Parameters.Add(New SqlParameter("@imutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
scmCmdToExecute.Parameters.Add(New SqlParameter("@ioffice_vorlagenr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iOffice_vorlagenr))
scmCmdToExecute.Parameters.Add(New SqlParameter("@idokumentart_kundendossier", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iDokumentart_kundendossier))
scmCmdToExecute.Parameters.Add(New SqlParameter("@idokumentart_neuerstellung", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iDokumentart_neuerstellung))
scmCmdToExecute.Parameters.Add(New SqlParameter("@idokumentart_retournierung", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iDokumentart_retournierung))
scmCmdToExecute.Parameters.Add(New SqlParameter("@idokumentart_coldausgang", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iDokumentart_coldausgang))
scmCmdToExecute.Parameters.Add(New SqlParameter("@idokumentart_coldeingang", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iDokumentart_coldeingang))
scmCmdToExecute.Parameters.Add(New SqlParameter("@idokumentart_host", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iDokumentart_host))
scmCmdToExecute.Parameters.Add(New SqlParameter("@idokumentart_weitere", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iDokumentart_weitere))
scmCmdToExecute.Parameters.Add(New SqlParameter("@idokumentart_nativ", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iDokumentart_nativ))
scmCmdToExecute.Parameters.Add(New SqlParameter("@iprozessnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iProzessnr))
scmCmdToExecute.Parameters.Add(New SqlParameter("@iprozessnr1", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iProzessnr1))
scmCmdToExecute.Parameters.Add(New SqlParameter("@bamsdokument", SqlDbType.Bit, 1, ParameterDirection.Input, False, 1, 0, "", DataRowVersion.Proposed, m_bAmsdokument))
scmCmdToExecute.Parameters.Add(New SqlParameter("@bhostdokument", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bHostdokument))
scmCmdToExecute.Parameters.Add(New SqlParameter("@shostdokumenttyp", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sHostdokumenttyp))
scmCmdToExecute.Parameters.Add(New SqlParameter("@icold_folder", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iCold_folder))
scmCmdToExecute.Parameters.Add(New SqlParameter("@iphysisches_archiv", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iPhysisches_archiv))
scmCmdToExecute.Parameters.Add(New SqlParameter("@idokumentstatus", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iDokumentstatus))
scmCmdToExecute.Parameters.Add(New SqlParameter("@bDokument_wird_erstellt", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bDokument_wird_erstellt))
scmCmdToExecute.Parameters.Add(New SqlParameter("@bDokument_wird_retourniert", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bDokument_wird_retourniert))
scmCmdToExecute.Parameters.Add(New SqlParameter("@bcold_ersetzen", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bCold_ersetzen))
scmCmdToExecute.Parameters.Add(New SqlParameter("@bemail_versand", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bEmail_versand))
scmCmdToExecute.Parameters.Add(New SqlParameter("@bfunktionen_zuweisen", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bFunktionen_zuweisen))
scmCmdToExecute.Parameters.Add(New SqlParameter("@idokumentstatus_barcode", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iDokumentstatus_barcode))
scmCmdToExecute.Parameters.Add(New SqlParameter("@bnurnative", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bNurnative))
scmCmdToExecute.Parameters.Add(New SqlParameter("@iOwner", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iOwner))
scmCmdToExecute.Parameters.Add(New SqlParameter("@bvertrag", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bVertrag))
scmCmdToExecute.Parameters.Add(New SqlParameter("@iobjektbezeichnungnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iObjektbezeichnungnr))
scmCmdToExecute.Parameters.Add(New SqlParameter("@bbedingtretournierbar", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bBedingtretournierbar))
scmCmdToExecute.Parameters.Add(New SqlParameter("@idoktypbedingteretournierung", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iDoktypbedingteretournierung))
scmCmdToExecute.Parameters.Add(New SqlParameter("@itagebisvernichtungbedingteretournierung", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iTagebisvernichtungbedingteretournierung))
scmCmdToExecute.Parameters.Add(New SqlParameter("@bAnzeigeZurDokumenterstellung", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bAnzeigeZurDokumenterstellung))
scmCmdToExecute.Parameters.Add(New SqlParameter("@bKundenDokument", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bKundenDokument))
scmCmdToExecute.Parameters.Add(New SqlParameter("@bsb", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bSb))
scmCmdToExecute.Parameters.Add(New SqlParameter("@bsbimport", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bSbimport))
scmCmdToExecute.Parameters.Add(New SqlParameter("@bsbedituser", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bSbedituser))
scmCmdToExecute.Parameters.Add(New SqlParameter("@bsbnur", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bSbnur))
scmCmdToExecute.Parameters.Add(New SqlParameter("@bbezeichnungmut", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bBezeichnungmut))
scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

If m_bMainConnectionIsCreatedLocal Then
' // Open connection.
m_scoMainConnection.Open()
Else
If m_cpMainConnectionProvider.bIsTransactionPending Then
scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
End If
End If

' // Execute query.
scmCmdToExecute.ExecuteNonQuery()
m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
' // Throw error.
Throw New Exception("Stored Procedure 'pr_dokumenttyp_Insert' reported the ErrorCode: " & m_iErrorCode.ToString())
End If

Return True
Catch ex As Exception
' // some error occured. Bubble it to caller and encapsulate Exception object
Throw New Exception("clsDokumenttyp::Insert::Error occured.", ex)
Finally
If m_bMainConnectionIsCreatedLocal Then
' // Close connection.
m_scoMainConnection.Close()
End If
scmCmdToExecute.Dispose()
End Try
End Function

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsDokumenttyp Class
clsDokumenttyp clsDokumenttyp Members


clsDokumenttyp.SelectAll Method

clsDokumenttyp.SelectAll Method

clsDokumenttyp.SelectAll Method | Previous topic | Next topic
clsDokumenttyp.SelectAll Method | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Overrides Function SelectAll() As DataTable

C#

public override DataTable SelectAll()

C++

public:
DataTable^ SelectAll()

JScript

public function SelectAll() : DataTable;

Source code

Visual Basic

Copy Code Copy Code

Public Overrides Function SelectAll() As DataTable
Dim scmCmdToExecute As SqlCommand = New SqlCommand()
scmCmdToExecute.CommandText = "dbo.[pr_dokumenttyp_SelectAll]"
scmCmdToExecute.CommandType = CommandType.StoredProcedure
Dim dtToReturn As DataTable = New DataTable("dokumenttyp")
Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)

' // Use base class' connection object
scmCmdToExecute.Connection = m_scoMainConnection

Try
scmCmdToExecute.Parameters.Add(New SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

If m_bMainConnectionIsCreatedLocal Then
' // Open connection.
m_scoMainConnection.Open()
Else
If m_cpMainConnectionProvider.bIsTransactionPending Then
scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
End If
End If

' // Execute query.
sdaAdapter.Fill(dtToReturn)
m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
' // Throw error.
Throw New Exception("Stored Procedure 'pr_dokumenttyp_SelectAll' reported the ErrorCode: " & m_iErrorCode.ToString())
End If

Return dtToReturn
Catch ex As Exception
' // some error occured. Bubble it to caller and encapsulate Exception object
Throw New Exception("clsDokumenttyp::SelectAll::Error occured.", ex)
Finally
If m_bMainConnectionIsCreatedLocal Then
' // Close connection.
m_scoMainConnection.Close()
End If
scmCmdToExecute.Dispose()
sdaAdapter.Dispose()
End Try
End Function

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsDokumenttyp Class
clsDokumenttyp clsDokumenttyp Members


clsDokumenttyp.SelectOne Method

clsDokumenttyp.SelectOne Method

clsDokumenttyp.SelectOne Method | Previous topic | Next topic
clsDokumenttyp.SelectOne Method | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Overrides Function SelectOne() As DataTable

C#

public override DataTable SelectOne()

C++

public:
DataTable^ SelectOne()

JScript

public function SelectOne() : DataTable;

Source code

Visual Basic

Copy Code Copy Code

Overrides Public Function SelectOne() As DataTable
Dim scmCmdToExecute As SqlCommand = New SqlCommand()
scmCmdToExecute.CommandText = "dbo.[pr_dokumenttyp_SelectOne]"
scmCmdToExecute.CommandType = CommandType.StoredProcedure
Dim dtToReturn As DataTable = new DataTable("dokumenttyp")
Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

' // Use base class' connection object
scmCmdToExecute.Connection = m_scoMainConnection

Try
scmCmdToExecute.Parameters.Add(new SqlParameter("@idokumenttypnr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iDokumenttypnr))
scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

If m_bMainConnectionIsCreatedLocal Then
' // Open connection.
m_scoMainConnection.Open()
Else
If m_cpMainConnectionProvider.bIsTransactionPending Then
scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
End If
End If

' // Execute query.
sdaAdapter.Fill(dtToReturn)
m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
' // Throw error.
Throw New Exception("Stored Procedure 'pr_dokumenttyp_SelectOne' reported the ErrorCode: " & m_iErrorCode.ToString())
End If

If dtToReturn.Rows.Count > 0 Then
m_iDokumenttypnr = New SqlInt32(CType(dtToReturn.Rows(0)("dokumenttypnr"), Integer))
If dtToReturn.Rows(0)("bezeichnung") Is System.DBNull.Value Then
m_sBezeichnung = SqlString.Null
Else
m_sBezeichnung = New SqlString(CType(dtToReturn.Rows(0)("bezeichnung"), String))
End If
If dtToReturn.Rows(0)("beschreibung") Is System.DBNull.Value Then
m_sBeschreibung = SqlString.Null
Else
m_sBeschreibung = New SqlString(CType(dtToReturn.Rows(0)("beschreibung"), String))
End If
m_bZu_vercolden = New SqlBoolean(CType(dtToReturn.Rows(0)("zu_vercolden"), Boolean))
m_bZu_retournieren = New SqlBoolean(CType(dtToReturn.Rows(0)("zu_retournieren"), Boolean))
m_bEingang_ersetzt_ausgang = New SqlBoolean(CType(dtToReturn.Rows(0)("eingang_ersetzt_ausgang"), Boolean))
m_bWird_importiert = New SqlBoolean(CType(dtToReturn.Rows(0)("wird_importiert"), Boolean))
m_iAnzahl_tage = New SqlInt32(CType(dtToReturn.Rows(0)("anzahl_tage"), Integer))
m_iDbearbeitungszeit = New SqlInt32(CType(dtToReturn.Rows(0)("dbearbeitungszeit"), Integer))
m_iTage_mutation = New SqlInt32(CType(dtToReturn.Rows(0)("tage_mutation"), Integer))
m_bPartnersaldierung_statusalt = New SqlBoolean(CType(dtToReturn.Rows(0)("partnersaldierung_statusalt"), Boolean))
m_bWird_nicht_geloescht = New SqlBoolean(CType(dtToReturn.Rows(0)("wird_nicht_geloescht"), Boolean))
m_bVertrauliches_dokument = New SqlBoolean(CType(dtToReturn.Rows(0)("vertrauliches_dokument"), Boolean))
m_bUnterschrift_links = New SqlBoolean(CType(dtToReturn.Rows(0)("unterschrift_links"), Boolean))
m_bUnterschrift_rechts = New SqlBoolean(CType(dtToReturn.Rows(0)("unterschrift_rechts"), Boolean))
m_iMonate_bis_zur_archivierung = New SqlInt32(CType(dtToReturn.Rows(0)("monate_bis_zur_archivierung"), Integer))
m_iAufbewahrungsfrist_elektronisch = New SqlInt32(CType(dtToReturn.Rows(0)("aufbewahrungsfrist_elektronisch"), Integer))
m_iAufbewahrungsfrist_physisch = New SqlInt32(CType(dtToReturn.Rows(0)("aufbewahrungsfrist_physisch"), Integer))
If dtToReturn.Rows(0)("mandantnr") Is System.DBNull.Value Then
m_iMandantnr = SqlInt32.Null
Else
m_iMandantnr = New SqlInt32(CType(dtToReturn.Rows(0)("mandantnr"), Integer))
End If
If dtToReturn.Rows(0)("aktiv") Is System.DBNull.Value Then
m_bAktiv = SqlBoolean.Null
Else
m_bAktiv = New SqlBoolean(CType(dtToReturn.Rows(0)("aktiv"), Boolean))
End If
If dtToReturn.Rows(0)("erstellt_am") Is System.DBNull.Value Then
m_daErstellt_am = SqlDateTime.Null
Else
m_daErstellt_am = New SqlDateTime(CType(dtToReturn.Rows(0)("erstellt_am"), Date))
End If
If dtToReturn.Rows(0)("mutiert_am") Is System.DBNull.Value Then
m_daMutiert_am = SqlDateTime.Null
Else
m_daMutiert_am = New SqlDateTime(CType(dtToReturn.Rows(0)("mutiert_am"), Date))
End If
If dtToReturn.Rows(0)("mutierer") Is System.DBNull.Value Then
m_iMutierer = SqlInt32.Null
Else
m_iMutierer = New SqlInt32(CType(dtToReturn.Rows(0)("mutierer"), Integer))
End If
If dtToReturn.Rows(0)("office_vorlagenr") Is System.DBNull.Value Then
m_iOffice_vorlagenr = SqlInt32.Null
Else
m_iOffice_vorlagenr = New SqlInt32(CType(dtToReturn.Rows(0)("office_vorlagenr"), Integer))
End If
If dtToReturn.Rows(0)("dokumentart_kundendossier") Is System.DBNull.Value Then
m_iDokumentart_kundendossier = SqlInt32.Null
Else
m_iDokumentart_kundendossier = New SqlInt32(CType(dtToReturn.Rows(0)("dokumentart_kundendossier"), Integer))
End If
If dtToReturn.Rows(0)("dokumentart_neuerstellung") Is System.DBNull.Value Then
m_iDokumentart_neuerstellung = SqlInt32.Null
Else
m_iDokumentart_neuerstellung = New SqlInt32(CType(dtToReturn.Rows(0)("dokumentart_neuerstellung"), Integer))
End If
If dtToReturn.Rows(0)("dokumentart_retournierung") Is System.DBNull.Value Then
m_iDokumentart_retournierung = SqlInt32.Null
Else
m_iDokumentart_retournierung = New SqlInt32(CType(dtToReturn.Rows(0)("dokumentart_retournierung"), Integer))
End If
m_iDokumentart_coldausgang = New SqlInt32(CType(dtToReturn.Rows(0)("dokumentart_coldausgang"), Integer))
m_iDokumentart_coldeingang = New SqlInt32(CType(dtToReturn.Rows(0)("dokumentart_coldeingang"), Integer))
If dtToReturn.Rows(0)("dokumentart_host") Is System.DBNull.Value Then
m_iDokumentart_host = SqlInt32.Null
Else
m_iDokumentart_host = New SqlInt32(CType(dtToReturn.Rows(0)("dokumentart_host"), Integer))
End If
If dtToReturn.Rows(0)("dokumentart_weitere") Is System.DBNull.Value Then
m_iDokumentart_weitere = SqlInt32.Null
Else
m_iDokumentart_weitere = New SqlInt32(CType(dtToReturn.Rows(0)("dokumentart_weitere"), Integer))
End If
If dtToReturn.Rows(0)("dokumentart_nativ") Is System.DBNull.Value Then
m_iDokumentart_nativ = SqlInt32.Null
Else
m_iDokumentart_nativ = New SqlInt32(CType(dtToReturn.Rows(0)("dokumentart_nativ"), Integer))
End If
If dtToReturn.Rows(0)("prozessnr") Is System.DBNull.Value Then
m_iProzessnr = SqlInt32.Null
Else
m_iProzessnr = New SqlInt32(CType(dtToReturn.Rows(0)("prozessnr"), Integer))
End If
If dtToReturn.Rows(0)("prozessnr1") Is System.DBNull.Value Then
m_iProzessnr1 = SqlInt32.Null
Else
m_iProzessnr1 = New SqlInt32(CType(dtToReturn.Rows(0)("prozessnr1"), Integer))
End If
m_bAmsdokument = New SqlBoolean(CType(dtToReturn.Rows(0)("amsdokument"), Boolean))
If dtToReturn.Rows(0)("hostdokument") Is System.DBNull.Value Then
m_bHostdokument = SqlBoolean.Null
Else
m_bHostdokument = New SqlBoolean(CType(dtToReturn.Rows(0)("hostdokument"), Boolean))
End If
If dtToReturn.Rows(0)("hostdokumenttyp") Is System.DBNull.Value Then
m_sHostdokumenttyp = SqlString.Null
Else
m_sHostdokumenttyp = New SqlString(CType(dtToReturn.Rows(0)("hostdokumenttyp"), String))
End If
If dtToReturn.Rows(0)("cold_folder") Is System.DBNull.Value Then
m_iCold_folder = SqlInt32.Null
Else
m_iCold_folder = New SqlInt32(CType(dtToReturn.Rows(0)("cold_folder"), Integer))
End If
If dtToReturn.Rows(0)("physisches_archiv") Is System.DBNull.Value Then
m_iPhysisches_archiv = SqlInt32.Null
Else
m_iPhysisches_archiv = New SqlInt32(CType(dtToReturn.Rows(0)("physisches_archiv"), Integer))
End If
If dtToReturn.Rows(0)("dokumentstatus") Is System.DBNull.Value Then
m_iDokumentstatus = SqlInt32.Null
Else
m_iDokumentstatus = New SqlInt32(CType(dtToReturn.Rows(0)("dokumentstatus"), Integer))
End If
If dtToReturn.Rows(0)("Dokument_wird_erstellt") Is System.DBNull.Value Then
m_bDokument_wird_erstellt = SqlBoolean.Null
Else
m_bDokument_wird_erstellt = New SqlBoolean(CType(dtToReturn.Rows(0)("Dokument_wird_erstellt"), Boolean))
End If
If dtToReturn.Rows(0)("Dokument_wird_retourniert") Is System.DBNull.Value Then
m_bDokument_wird_retourniert = SqlBoolean.Null
Else
m_bDokument_wird_retourniert = New SqlBoolean(CType(dtToReturn.Rows(0)("Dokument_wird_retourniert"), Boolean))
End If
If dtToReturn.Rows(0)("cold_ersetzen") Is System.DBNull.Value Then
m_bCold_ersetzen = SqlBoolean.Null
Else
m_bCold_ersetzen = New SqlBoolean(CType(dtToReturn.Rows(0)("cold_ersetzen"), Boolean))
End If
If dtToReturn.Rows(0)("email_versand") Is System.DBNull.Value Then
m_bEmail_versand = SqlBoolean.Null
Else
m_bEmail_versand = New SqlBoolean(CType(dtToReturn.Rows(0)("email_versand"), Boolean))
End If
If dtToReturn.Rows(0)("funktionen_zuweisen") Is System.DBNull.Value Then
m_bFunktionen_zuweisen = SqlBoolean.Null
Else
m_bFunktionen_zuweisen = New SqlBoolean(CType(dtToReturn.Rows(0)("funktionen_zuweisen"), Boolean))
End If
If dtToReturn.Rows(0)("dokumentstatus_barcode") Is System.DBNull.Value Then
m_iDokumentstatus_barcode = SqlInt32.Null
Else
m_iDokumentstatus_barcode = New SqlInt32(CType(dtToReturn.Rows(0)("dokumentstatus_barcode"), Integer))
End If
If dtToReturn.Rows(0)("nurnative") Is System.DBNull.Value Then
m_bNurnative = SqlBoolean.Null
Else
m_bNurnative = New SqlBoolean(CType(dtToReturn.Rows(0)("nurnative"), Boolean))
End If
If dtToReturn.Rows(0)("Owner") Is System.DBNull.Value Then
m_iOwner = SqlInt32.Null
Else
m_iOwner = New SqlInt32(CType(dtToReturn.Rows(0)("Owner"), Integer))
End If
If dtToReturn.Rows(0)("vertrag") Is System.DBNull.Value Then
m_bVertrag = SqlBoolean.Null
Else
m_bVertrag = New SqlBoolean(CType(dtToReturn.Rows(0)("vertrag"), Boolean))
End If
If dtToReturn.Rows(0)("objektbezeichnungnr") Is System.DBNull.Value Then
m_iObjektbezeichnungnr = SqlInt32.Null
Else
m_iObjektbezeichnungnr = New SqlInt32(CType(dtToReturn.Rows(0)("objektbezeichnungnr"), Integer))
End If
If dtToReturn.Rows(0)("bedingtretournierbar") Is System.DBNull.Value Then
m_bBedingtretournierbar = SqlBoolean.Null
Else
m_bBedingtretournierbar = New SqlBoolean(CType(dtToReturn.Rows(0)("bedingtretournierbar"), Boolean))
End If
If dtToReturn.Rows(0)("doktypbedingteretournierung") Is System.DBNull.Value Then
m_iDoktypbedingteretournierung = SqlInt32.Null
Else
m_iDoktypbedingteretournierung = New SqlInt32(CType(dtToReturn.Rows(0)("doktypbedingteretournierung"), Integer))
End If
If dtToReturn.Rows(0)("tagebisvernichtungbedingteretournierung") Is System.DBNull.Value Then
m_iTagebisvernichtungbedingteretournierung = SqlInt32.Null
Else
m_iTagebisvernichtungbedingteretournierung = New SqlInt32(CType(dtToReturn.Rows(0)("tagebisvernichtungbedingteretournierung"), Integer))
End If
If dtToReturn.Rows(0)("AnzeigeZurDokumenterstellung") Is System.DBNull.Value Then
m_bAnzeigeZurDokumenterstellung = SqlBoolean.Null
Else
m_bAnzeigeZurDokumenterstellung = New SqlBoolean(CType(dtToReturn.Rows(0)("AnzeigeZurDokumenterstellung"), Boolean))
End If
If dtToReturn.Rows(0)("KundenDokument") Is System.DBNull.Value Then
m_bKundenDokument = SqlBoolean.Null
Else
m_bKundenDokument = New SqlBoolean(CType(dtToReturn.Rows(0)("KundenDokument"), Boolean))
End If
If dtToReturn.Rows(0)("sb") Is System.DBNull.Value Then
m_bSb = SqlBoolean.Null
Else
m_bSb = New SqlBoolean(CType(dtToReturn.Rows(0)("sb"), Boolean))
End If
If dtToReturn.Rows(0)("sbimport") Is System.DBNull.Value Then
m_bSbimport = SqlBoolean.Null
Else
m_bSbimport = New SqlBoolean(CType(dtToReturn.Rows(0)("sbimport"), Boolean))
End If
If dtToReturn.Rows(0)("sbedituser") Is System.DBNull.Value Then
m_bSbedituser = SqlBoolean.Null
Else
m_bSbedituser = New SqlBoolean(CType(dtToReturn.Rows(0)("sbedituser"), Boolean))
End If
If dtToReturn.Rows(0)("sbnur") Is System.DBNull.Value Then
m_bSbnur = SqlBoolean.Null
Else
m_bSbnur = New SqlBoolean(CType(dtToReturn.Rows(0)("sbnur"), Boolean))
End If
If dtToReturn.Rows(0)("bezeichnungmut") Is System.DBNull.Value Then
m_bBezeichnungmut = SqlBoolean.Null
Else
m_bBezeichnungmut = New SqlBoolean(CType(dtToReturn.Rows(0)("bezeichnungmut"), Boolean))
End If
End If
Return dtToReturn
Catch ex As Exception
' // some error occured. Bubble it to caller and encapsulate Exception object
Throw New Exception("clsDokumenttyp::SelectOne::Error occured.", ex)
Finally
If m_bMainConnectionIsCreatedLocal Then
' // Close connection.
m_scoMainConnection.Close()
End If
scmCmdToExecute.Dispose()
sdaAdapter.Dispose()
End Try
End Function

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsDokumenttyp Class
clsDokumenttyp clsDokumenttyp Members


clsDokumenttyp.Update Method

clsDokumenttyp.Update Method

clsDokumenttyp.Update Method | Previous topic | Next topic
clsDokumenttyp.Update Method | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Overrides Function Update() As Boolean

C#

public override bool Update()

C++

public:
bool Update()

JScript

public function Update() : boolean;

Source code

Visual Basic

Copy Code Copy Code

Overrides Public Function Update() As Boolean
Dim scmCmdToExecute As SqlCommand = New SqlCommand()
scmCmdToExecute.CommandText = "dbo.[pr_dokumenttyp_Update]"
scmCmdToExecute.CommandType = CommandType.StoredProcedure

' // Use base class' connection object
scmCmdToExecute.Connection = m_scoMainConnection

Try
scmCmdToExecute.Parameters.Add(New SqlParameter("@idokumenttypnr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iDokumenttypnr))
scmCmdToExecute.Parameters.Add(New SqlParameter("@sbezeichnung", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBezeichnung))
scmCmdToExecute.Parameters.Add(New SqlParameter("@sbeschreibung", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBeschreibung))
scmCmdToExecute.Parameters.Add(New SqlParameter("@bzu_vercolden", SqlDbType.Bit, 1, ParameterDirection.Input, False, 1, 0, "", DataRowVersion.Proposed, m_bZu_vercolden))
scmCmdToExecute.Parameters.Add(New SqlParameter("@bzu_retournieren", SqlDbType.Bit, 1, ParameterDirection.Input, False, 1, 0, "", DataRowVersion.Proposed, m_bZu_retournieren))
scmCmdToExecute.Parameters.Add(New SqlParameter("@beingang_ersetzt_ausgang", SqlDbType.Bit, 1, ParameterDirection.Input, False, 1, 0, "", DataRowVersion.Proposed, m_bEingang_ersetzt_ausgang))
scmCmdToExecute.Parameters.Add(New SqlParameter("@bwird_importiert", SqlDbType.Bit, 1, ParameterDirection.Input, False, 1, 0, "", DataRowVersion.Proposed, m_bWird_importiert))
scmCmdToExecute.Parameters.Add(New SqlParameter("@ianzahl_tage", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iAnzahl_tage))
scmCmdToExecute.Parameters.Add(New SqlParameter("@idbearbeitungszeit", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iDbearbeitungszeit))
scmCmdToExecute.Parameters.Add(New SqlParameter("@itage_mutation", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iTage_mutation))
scmCmdToExecute.Parameters.Add(New SqlParameter("@bpartnersaldierung_statusalt", SqlDbType.Bit, 1, ParameterDirection.Input, False, 1, 0, "", DataRowVersion.Proposed, m_bPartnersaldierung_statusalt))
scmCmdToExecute.Parameters.Add(New SqlParameter("@bwird_nicht_geloescht", SqlDbType.Bit, 1, ParameterDirection.Input, False, 1, 0, "", DataRowVersion.Proposed, m_bWird_nicht_geloescht))
scmCmdToExecute.Parameters.Add(New SqlParameter("@bvertrauliches_dokument", SqlDbType.Bit, 1, ParameterDirection.Input, False, 1, 0, "", DataRowVersion.Proposed, m_bVertrauliches_dokument))
scmCmdToExecute.Parameters.Add(New SqlParameter("@bunterschrift_links", SqlDbType.Bit, 1, ParameterDirection.Input, False, 1, 0, "", DataRowVersion.Proposed, m_bUnterschrift_links))
scmCmdToExecute.Parameters.Add(New SqlParameter("@bunterschrift_rechts", SqlDbType.Bit, 1, ParameterDirection.Input, False, 1, 0, "", DataRowVersion.Proposed, m_bUnterschrift_rechts))
scmCmdToExecute.Parameters.Add(New SqlParameter("@imonate_bis_zur_archivierung", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iMonate_bis_zur_archivierung))
scmCmdToExecute.Parameters.Add(New SqlParameter("@iaufbewahrungsfrist_elektronisch", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iAufbewahrungsfrist_elektronisch))
scmCmdToExecute.Parameters.Add(New SqlParameter("@iaufbewahrungsfrist_physisch", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iAufbewahrungsfrist_physisch))
scmCmdToExecute.Parameters.Add(New SqlParameter("@imandantnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMandantnr))
scmCmdToExecute.Parameters.Add(New SqlParameter("@baktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bAktiv))
scmCmdToExecute.Parameters.Add(New SqlParameter("@daerstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daErstellt_am))
scmCmdToExecute.Parameters.Add(New SqlParameter("@damutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daMutiert_am))
scmCmdToExecute.Parameters.Add(New SqlParameter("@imutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
scmCmdToExecute.Parameters.Add(New SqlParameter("@ioffice_vorlagenr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iOffice_vorlagenr))
scmCmdToExecute.Parameters.Add(New SqlParameter("@idokumentart_kundendossier", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iDokumentart_kundendossier))
scmCmdToExecute.Parameters.Add(New SqlParameter("@idokumentart_neuerstellung", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iDokumentart_neuerstellung))
scmCmdToExecute.Parameters.Add(New SqlParameter("@idokumentart_retournierung", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iDokumentart_retournierung))
scmCmdToExecute.Parameters.Add(New SqlParameter("@idokumentart_coldausgang", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iDokumentart_coldausgang))
scmCmdToExecute.Parameters.Add(New SqlParameter("@idokumentart_coldeingang", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iDokumentart_coldeingang))
scmCmdToExecute.Parameters.Add(New SqlParameter("@idokumentart_host", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iDokumentart_host))
scmCmdToExecute.Parameters.Add(New SqlParameter("@idokumentart_weitere", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iDokumentart_weitere))
scmCmdToExecute.Parameters.Add(New SqlParameter("@idokumentart_nativ", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iDokumentart_nativ))
scmCmdToExecute.Parameters.Add(New SqlParameter("@iprozessnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iProzessnr))
scmCmdToExecute.Parameters.Add(New SqlParameter("@iprozessnr1", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iProzessnr1))
scmCmdToExecute.Parameters.Add(New SqlParameter("@bamsdokument", SqlDbType.Bit, 1, ParameterDirection.Input, False, 1, 0, "", DataRowVersion.Proposed, m_bAmsdokument))
scmCmdToExecute.Parameters.Add(New SqlParameter("@bhostdokument", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bHostdokument))
scmCmdToExecute.Parameters.Add(New SqlParameter("@shostdokumenttyp", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sHostdokumenttyp))
scmCmdToExecute.Parameters.Add(New SqlParameter("@icold_folder", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iCold_folder))
scmCmdToExecute.Parameters.Add(New SqlParameter("@iphysisches_archiv", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iPhysisches_archiv))
scmCmdToExecute.Parameters.Add(New SqlParameter("@idokumentstatus", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iDokumentstatus))
scmCmdToExecute.Parameters.Add(New SqlParameter("@bDokument_wird_erstellt", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bDokument_wird_erstellt))
scmCmdToExecute.Parameters.Add(New SqlParameter("@bDokument_wird_retourniert", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bDokument_wird_retourniert))
scmCmdToExecute.Parameters.Add(New SqlParameter("@bcold_ersetzen", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bCold_ersetzen))
scmCmdToExecute.Parameters.Add(New SqlParameter("@bemail_versand", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bEmail_versand))
scmCmdToExecute.Parameters.Add(New SqlParameter("@bfunktionen_zuweisen", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bFunktionen_zuweisen))
scmCmdToExecute.Parameters.Add(New SqlParameter("@idokumentstatus_barcode", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iDokumentstatus_barcode))
scmCmdToExecute.Parameters.Add(New SqlParameter("@bnurnative", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bNurnative))
scmCmdToExecute.Parameters.Add(New SqlParameter("@iOwner", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iOwner))
scmCmdToExecute.Parameters.Add(New SqlParameter("@bvertrag", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bVertrag))
scmCmdToExecute.Parameters.Add(New SqlParameter("@iobjektbezeichnungnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iObjektbezeichnungnr))
scmCmdToExecute.Parameters.Add(New SqlParameter("@bbedingtretournierbar", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bBedingtretournierbar))
scmCmdToExecute.Parameters.Add(New SqlParameter("@idoktypbedingteretournierung", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iDoktypbedingteretournierung))
scmCmdToExecute.Parameters.Add(New SqlParameter("@itagebisvernichtungbedingteretournierung", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iTagebisvernichtungbedingteretournierung))
scmCmdToExecute.Parameters.Add(New SqlParameter("@bAnzeigeZurDokumenterstellung", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bAnzeigeZurDokumenterstellung))
scmCmdToExecute.Parameters.Add(New SqlParameter("@bKundenDokument", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bKundenDokument))
scmCmdToExecute.Parameters.Add(New SqlParameter("@bsb", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bSb))
scmCmdToExecute.Parameters.Add(New SqlParameter("@bsbimport", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bSbimport))
scmCmdToExecute.Parameters.Add(New SqlParameter("@bsbedituser", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bSbedituser))
scmCmdToExecute.Parameters.Add(New SqlParameter("@bsbnur", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bSbnur))
scmCmdToExecute.Parameters.Add(New SqlParameter("@bbezeichnungmut", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bBezeichnungmut))
scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

If m_bMainConnectionIsCreatedLocal Then
' // Open connection.
m_scoMainConnection.Open()
Else
If m_cpMainConnectionProvider.bIsTransactionPending Then
scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
End If
End If

' // Execute query.
scmCmdToExecute.ExecuteNonQuery()
m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
' // Throw error.
Throw New Exception("Stored Procedure 'pr_dokumenttyp_Update' reported the ErrorCode: " & m_iErrorCode.ToString())
End If

Return True
Catch ex As Exception
' // some error occured. Bubble it to caller and encapsulate Exception object
Throw New Exception("clsDokumenttyp::Update::Error occured.", ex)
Finally
If m_bMainConnectionIsCreatedLocal Then
' // Close connection.
m_scoMainConnection.Close()
End If
scmCmdToExecute.Dispose()
End Try
End Function

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsDokumenttyp Class
clsDokumenttyp clsDokumenttyp Members


clsDokumenttyp Fields

clsDokumenttyp Fields

clsDokumenttyp Fields | Previous topic | Next topic
clsDokumenttyp Fields | Previous topic | Next topic

Fields

 | Name | Description
Supported by the .NET Compact Framework. | m_bAktiv |
Supported by the .NET Compact Framework. | m_bAmsdokument |
Supported by the .NET Compact Framework. | m_bAnzeigeZurDokumenterstellung |
Supported by the .NET Compact Framework. | m_bBedingtretournierbar |
Supported by the .NET Compact Framework. | m_bBezeichnungmut |
Supported by the .NET Compact Framework. | m_bCold_ersetzen |
Supported by the .NET Compact Framework. | m_bDokument_wird_erstellt |
Supported by the .NET Compact Framework. | m_bDokument_wird_retourniert |
Supported by the .NET Compact Framework. | m_bEingang_ersetzt_ausgang |
Supported by the .NET Compact Framework. | m_bEmail_versand |
Supported by the .NET Compact Framework. | m_bFunktionen_zuweisen |
Supported by the .NET Compact Framework. | m_bHostdokument |
Supported by the .NET Compact Framework. | m_bKundenDokument |
Supported by the .NET Compact Framework. | m_bMainConnectionIsCreatedLocal | (inherited from clsDBInteractionBase ).
Supported by the .NET Compact Framework. | m_bNurnative |
Supported by the .NET Compact Framework. | m_bPartnersaldierung_statusalt |
Supported by the .NET Compact Framework. | m_bSb |
Supported by the .NET Compact Framework. | m_bSbedituser |
Supported by the .NET Compact Framework. | m_bSbimport |
Supported by the .NET Compact Framework. | m_bSbnur |
Supported by the .NET Compact Framework. | m_bUnterschrift_links |
Supported by the .NET Compact Framework. | m_bUnterschrift_rechts |
Supported by the .NET Compact Framework. | m_bVertrag |
Supported by the .NET Compact Framework. | m_bVertrauliches_dokument |
Supported by the .NET Compact Framework. | m_bWird_importiert |
Supported by the .NET Compact Framework. | m_bWird_nicht_geloescht |
Supported by the .NET Compact Framework. | m_bZu_retournieren |
Supported by the .NET Compact Framework. | m_bZu_vercolden |
Supported by the .NET Compact Framework. | m_cpMainConnectionProvider | (inherited from clsDBInteractionBase ).
Supported by the .NET Compact Framework. | m_daErstellt_am |
Supported by the .NET Compact Framework. | m_daMutiert_am |
Supported by the .NET Compact Framework. | m_iAnzahl_tage |
Supported by the .NET Compact Framework. | m_iAufbewahrungsfrist_elektronisch |
Supported by the .NET Compact Framework. | m_iAufbewahrungsfrist_physisch |
Supported by the .NET Compact Framework. | m_iCold_folder |
Supported by the .NET Compact Framework. | m_iDbearbeitungszeit |
Supported by the .NET Compact Framework. | m_iDoktypbedingteretournierung |
Supported by the .NET Compact Framework. | m_iDokumentart_coldausgang |
Supported by the .NET Compact Framework. | m_iDokumentart_coldeingang |
Supported by the .NET Compact Framework. | m_iDokumentart_host |
Supported by the .NET Compact Framework. | m_iDokumentart_kundendossier |
Supported by the .NET Compact Framework. | m_iDokumentart_nativ |
Supported by the .NET Compact Framework. | m_iDokumentart_neuerstellung |
Supported by the .NET Compact Framework. | m_iDokumentart_retournierung |
Supported by the .NET Compact Framework. | m_iDokumentart_weitere |
Supported by the .NET Compact Framework. | m_iDokumentstatus |
Supported by the .NET Compact Framework. | m_iDokumentstatus_barcode |
Supported by the .NET Compact Framework. | m_iDokumenttypnr |
Supported by the .NET Compact Framework. | m_iErrorCode | (inherited from clsDBInteractionBase ).
Supported by the .NET Compact Framework. | m_iMandantnr |
Supported by the .NET Compact Framework. | m_iMonate_bis_zur_archivierung |
Supported by the .NET Compact Framework. | m_iMutierer |
Supported by the .NET Compact Framework. | m_iObjektbezeichnungnr |
Supported by the .NET Compact Framework. | m_iOffice_vorlagenr |
Supported by the .NET Compact Framework. | m_iOwner |
Supported by the .NET Compact Framework. | m_iPhysisches_archiv |
Supported by the .NET Compact Framework. | m_iProzessnr |
Supported by the .NET Compact Framework. | m_iProzessnr1 |
Supported by the .NET Compact Framework. | m_iTage_mutation |
Supported by the .NET Compact Framework. | m_iTagebisvernichtungbedingteretournierung |
Supported by the .NET Compact Framework. | m_sBeschreibung |
Supported by the .NET Compact Framework. | m_sBezeichnung |
Supported by the .NET Compact Framework. | m_sHostdokumenttyp |
Supported by the .NET Compact Framework. | m_scoMainConnection | (inherited from clsDBInteractionBase ).

Top

See Also

Reference

clsDokumenttyp Class


m_bAktiv Field

m_bAktiv Field

m_bAktiv Field | Previous topic | Next topic
m_bAktiv Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_bAktiv As SqlBoolean

C#

private SqlBoolean m_bAktiv

C++

private:
SqlBoolean m_bAktiv;

JScript

private m_bAktiv : SqlBoolean

Source code

Visual Basic

Copy Code Copy Code

Private m_bAktiv, m_bVertrag, m_bNurnative, m_bUnterschrift_rechts, m_bAnzeigeZurDokumenterstellung, m_bBedingtretournierbar, m_bFunktionen_zuweisen, m_bDokument_wird_erstellt, m_bAmsdokument, m_bHostdokument, m_bEmail_versand, m_bCold_ersetzen, m_bDokument_wird_retourniert, m_bUnterschrift_links, m_bWird_importiert, m_bEingang_ersetzt_ausgang, m_bSb, m_bSbimport, m_bZu_retournieren, m_bSbnur, m_bBezeichnungmut, m_bZu_vercolden, m_bSbedituser, m_bPartnersaldierung_statusalt, m_bKundenDokument, m_bVertrauliches_dokument, m_bWird_nicht_geloescht As SqlBoolean

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsDokumenttyp Class
clsDokumenttyp clsDokumenttyp Members


m_bAmsdokument Field

m_bAmsdokument Field

m_bAmsdokument Field | Previous topic | Next topic
m_bAmsdokument Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_bAmsdokument As SqlBoolean

C#

private SqlBoolean m_bAmsdokument

C++

private:
SqlBoolean m_bAmsdokument;

JScript

private m_bAmsdokument : SqlBoolean

Source code

Visual Basic

Copy Code Copy Code

Private m_bAktiv, m_bVertrag, m_bNurnative, m_bUnterschrift_rechts, m_bAnzeigeZurDokumenterstellung, m_bBedingtretournierbar, m_bFunktionen_zuweisen, m_bDokument_wird_erstellt, m_bAmsdokument, m_bHostdokument, m_bEmail_versand, m_bCold_ersetzen, m_bDokument_wird_retourniert, m_bUnterschrift_links, m_bWird_importiert, m_bEingang_ersetzt_ausgang, m_bSb, m_bSbimport, m_bZu_retournieren, m_bSbnur, m_bBezeichnungmut, m_bZu_vercolden, m_bSbedituser, m_bPartnersaldierung_statusalt, m_bKundenDokument, m_bVertrauliches_dokument, m_bWird_nicht_geloescht As SqlBoolean

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsDokumenttyp Class
clsDokumenttyp clsDokumenttyp Members


m_bAnzeigeZurDokumenterstellung Field

m_bAnzeigeZurDokumenterstellung Field

m_bAnzeigeZurDokumenterstellung Field | Previous topic | Next topic
m_bAnzeigeZurDokumenterstellung Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_bAnzeigeZurDokumenterstellung As SqlBoolean

C#

private SqlBoolean m_bAnzeigeZurDokumenterstellung

C++

private:
SqlBoolean m_bAnzeigeZurDokumenterstellung;

JScript

private m_bAnzeigeZurDokumenterstellung : SqlBoolean

Source code

Visual Basic

Copy Code Copy Code

Private m_bAktiv, m_bVertrag, m_bNurnative, m_bUnterschrift_rechts, m_bAnzeigeZurDokumenterstellung, m_bBedingtretournierbar, m_bFunktionen_zuweisen, m_bDokument_wird_erstellt, m_bAmsdokument, m_bHostdokument, m_bEmail_versand, m_bCold_ersetzen, m_bDokument_wird_retourniert, m_bUnterschrift_links, m_bWird_importiert, m_bEingang_ersetzt_ausgang, m_bSb, m_bSbimport, m_bZu_retournieren, m_bSbnur, m_bBezeichnungmut, m_bZu_vercolden, m_bSbedituser, m_bPartnersaldierung_statusalt, m_bKundenDokument, m_bVertrauliches_dokument, m_bWird_nicht_geloescht As SqlBoolean

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsDokumenttyp Class
clsDokumenttyp clsDokumenttyp Members


m_bBedingtretournierbar Field

m_bBedingtretournierbar Field

m_bBedingtretournierbar Field | Previous topic | Next topic
m_bBedingtretournierbar Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_bBedingtretournierbar As SqlBoolean

C#

private SqlBoolean m_bBedingtretournierbar

C++

private:
SqlBoolean m_bBedingtretournierbar;

JScript

private m_bBedingtretournierbar : SqlBoolean

Source code

Visual Basic

Copy Code Copy Code

Private m_bAktiv, m_bVertrag, m_bNurnative, m_bUnterschrift_rechts, m_bAnzeigeZurDokumenterstellung, m_bBedingtretournierbar, m_bFunktionen_zuweisen, m_bDokument_wird_erstellt, m_bAmsdokument, m_bHostdokument, m_bEmail_versand, m_bCold_ersetzen, m_bDokument_wird_retourniert, m_bUnterschrift_links, m_bWird_importiert, m_bEingang_ersetzt_ausgang, m_bSb, m_bSbimport, m_bZu_retournieren, m_bSbnur, m_bBezeichnungmut, m_bZu_vercolden, m_bSbedituser, m_bPartnersaldierung_statusalt, m_bKundenDokument, m_bVertrauliches_dokument, m_bWird_nicht_geloescht As SqlBoolean

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsDokumenttyp Class
clsDokumenttyp clsDokumenttyp Members


m_bBezeichnungmut Field

m_bBezeichnungmut Field

m_bBezeichnungmut Field | Previous topic | Next topic
m_bBezeichnungmut Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_bBezeichnungmut As SqlBoolean

C#

private SqlBoolean m_bBezeichnungmut

C++

private:
SqlBoolean m_bBezeichnungmut;

JScript

private m_bBezeichnungmut : SqlBoolean

Source code

Visual Basic

Copy Code Copy Code

Private m_bAktiv, m_bVertrag, m_bNurnative, m_bUnterschrift_rechts, m_bAnzeigeZurDokumenterstellung, m_bBedingtretournierbar, m_bFunktionen_zuweisen, m_bDokument_wird_erstellt, m_bAmsdokument, m_bHostdokument, m_bEmail_versand, m_bCold_ersetzen, m_bDokument_wird_retourniert, m_bUnterschrift_links, m_bWird_importiert, m_bEingang_ersetzt_ausgang, m_bSb, m_bSbimport, m_bZu_retournieren, m_bSbnur, m_bBezeichnungmut, m_bZu_vercolden, m_bSbedituser, m_bPartnersaldierung_statusalt, m_bKundenDokument, m_bVertrauliches_dokument, m_bWird_nicht_geloescht As SqlBoolean

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsDokumenttyp Class
clsDokumenttyp clsDokumenttyp Members


m_bCold_ersetzen Field

m_bCold_ersetzen Field

m_bCold_ersetzen Field | Previous topic | Next topic
m_bCold_ersetzen Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_bCold_ersetzen As SqlBoolean

C#

private SqlBoolean m_bCold_ersetzen

C++

private:
SqlBoolean m_bCold_ersetzen;

JScript

private m_bCold_ersetzen : SqlBoolean

Source code

Visual Basic

Copy Code Copy Code

Private m_bAktiv, m_bVertrag, m_bNurnative, m_bUnterschrift_rechts, m_bAnzeigeZurDokumenterstellung, m_bBedingtretournierbar, m_bFunktionen_zuweisen, m_bDokument_wird_erstellt, m_bAmsdokument, m_bHostdokument, m_bEmail_versand, m_bCold_ersetzen, m_bDokument_wird_retourniert, m_bUnterschrift_links, m_bWird_importiert, m_bEingang_ersetzt_ausgang, m_bSb, m_bSbimport, m_bZu_retournieren, m_bSbnur, m_bBezeichnungmut, m_bZu_vercolden, m_bSbedituser, m_bPartnersaldierung_statusalt, m_bKundenDokument, m_bVertrauliches_dokument, m_bWird_nicht_geloescht As SqlBoolean

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsDokumenttyp Class
clsDokumenttyp clsDokumenttyp Members


m_bDokument_wird_erstellt Field

m_bDokument_wird_erstellt Field

m_bDokument_wird_erstellt Field | Previous topic | Next topic
m_bDokument_wird_erstellt Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_bDokument_wird_erstellt As SqlBoolean

C#

private SqlBoolean m_bDokument_wird_erstellt

C++

private:
SqlBoolean m_bDokument_wird_erstellt;

JScript

private m_bDokument_wird_erstellt : SqlBoolean

Source code

Visual Basic

Copy Code Copy Code

Private m_bAktiv, m_bVertrag, m_bNurnative, m_bUnterschrift_rechts, m_bAnzeigeZurDokumenterstellung, m_bBedingtretournierbar, m_bFunktionen_zuweisen, m_bDokument_wird_erstellt, m_bAmsdokument, m_bHostdokument, m_bEmail_versand, m_bCold_ersetzen, m_bDokument_wird_retourniert, m_bUnterschrift_links, m_bWird_importiert, m_bEingang_ersetzt_ausgang, m_bSb, m_bSbimport, m_bZu_retournieren, m_bSbnur, m_bBezeichnungmut, m_bZu_vercolden, m_bSbedituser, m_bPartnersaldierung_statusalt, m_bKundenDokument, m_bVertrauliches_dokument, m_bWird_nicht_geloescht As SqlBoolean

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsDokumenttyp Class
clsDokumenttyp clsDokumenttyp Members


m_bDokument_wird_retourniert Field

m_bDokument_wird_retourniert Field

m_bDokument_wird_retourniert Field | Previous topic | Next topic
m_bDokument_wird_retourniert Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_bDokument_wird_retourniert As SqlBoolean

C#

private SqlBoolean m_bDokument_wird_retourniert

C++

private:
SqlBoolean m_bDokument_wird_retourniert;

JScript

private m_bDokument_wird_retourniert : SqlBoolean

Source code

Visual Basic

Copy Code Copy Code

Private m_bAktiv, m_bVertrag, m_bNurnative, m_bUnterschrift_rechts, m_bAnzeigeZurDokumenterstellung, m_bBedingtretournierbar, m_bFunktionen_zuweisen, m_bDokument_wird_erstellt, m_bAmsdokument, m_bHostdokument, m_bEmail_versand, m_bCold_ersetzen, m_bDokument_wird_retourniert, m_bUnterschrift_links, m_bWird_importiert, m_bEingang_ersetzt_ausgang, m_bSb, m_bSbimport, m_bZu_retournieren, m_bSbnur, m_bBezeichnungmut, m_bZu_vercolden, m_bSbedituser, m_bPartnersaldierung_statusalt, m_bKundenDokument, m_bVertrauliches_dokument, m_bWird_nicht_geloescht As SqlBoolean

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsDokumenttyp Class
clsDokumenttyp clsDokumenttyp Members


m_bEingang_ersetzt_ausgang Field

m_bEingang_ersetzt_ausgang Field

m_bEingang_ersetzt_ausgang Field | Previous topic | Next topic
m_bEingang_ersetzt_ausgang Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_bEingang_ersetzt_ausgang As SqlBoolean

C#

private SqlBoolean m_bEingang_ersetzt_ausgang

C++

private:
SqlBoolean m_bEingang_ersetzt_ausgang;

JScript

private m_bEingang_ersetzt_ausgang : SqlBoolean

Source code

Visual Basic

Copy Code Copy Code

Private m_bAktiv, m_bVertrag, m_bNurnative, m_bUnterschrift_rechts, m_bAnzeigeZurDokumenterstellung, m_bBedingtretournierbar, m_bFunktionen_zuweisen, m_bDokument_wird_erstellt, m_bAmsdokument, m_bHostdokument, m_bEmail_versand, m_bCold_ersetzen, m_bDokument_wird_retourniert, m_bUnterschrift_links, m_bWird_importiert, m_bEingang_ersetzt_ausgang, m_bSb, m_bSbimport, m_bZu_retournieren, m_bSbnur, m_bBezeichnungmut, m_bZu_vercolden, m_bSbedituser, m_bPartnersaldierung_statusalt, m_bKundenDokument, m_bVertrauliches_dokument, m_bWird_nicht_geloescht As SqlBoolean

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsDokumenttyp Class
clsDokumenttyp clsDokumenttyp Members


m_bEmail_versand Field

m_bEmail_versand Field

m_bEmail_versand Field | Previous topic | Next topic
m_bEmail_versand Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_bEmail_versand As SqlBoolean

C#

private SqlBoolean m_bEmail_versand

C++

private:
SqlBoolean m_bEmail_versand;

JScript

private m_bEmail_versand : SqlBoolean

Source code

Visual Basic

Copy Code Copy Code

Private m_bAktiv, m_bVertrag, m_bNurnative, m_bUnterschrift_rechts, m_bAnzeigeZurDokumenterstellung, m_bBedingtretournierbar, m_bFunktionen_zuweisen, m_bDokument_wird_erstellt, m_bAmsdokument, m_bHostdokument, m_bEmail_versand, m_bCold_ersetzen, m_bDokument_wird_retourniert, m_bUnterschrift_links, m_bWird_importiert, m_bEingang_ersetzt_ausgang, m_bSb, m_bSbimport, m_bZu_retournieren, m_bSbnur, m_bBezeichnungmut, m_bZu_vercolden, m_bSbedituser, m_bPartnersaldierung_statusalt, m_bKundenDokument, m_bVertrauliches_dokument, m_bWird_nicht_geloescht As SqlBoolean

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsDokumenttyp Class
clsDokumenttyp clsDokumenttyp Members


m_bFunktionen_zuweisen Field

m_bFunktionen_zuweisen Field

m_bFunktionen_zuweisen Field | Previous topic | Next topic
m_bFunktionen_zuweisen Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_bFunktionen_zuweisen As SqlBoolean

C#

private SqlBoolean m_bFunktionen_zuweisen

C++

private:
SqlBoolean m_bFunktionen_zuweisen;

JScript

private m_bFunktionen_zuweisen : SqlBoolean

Source code

Visual Basic

Copy Code Copy Code

Private m_bAktiv, m_bVertrag, m_bNurnative, m_bUnterschrift_rechts, m_bAnzeigeZurDokumenterstellung, m_bBedingtretournierbar, m_bFunktionen_zuweisen, m_bDokument_wird_erstellt, m_bAmsdokument, m_bHostdokument, m_bEmail_versand, m_bCold_ersetzen, m_bDokument_wird_retourniert, m_bUnterschrift_links, m_bWird_importiert, m_bEingang_ersetzt_ausgang, m_bSb, m_bSbimport, m_bZu_retournieren, m_bSbnur, m_bBezeichnungmut, m_bZu_vercolden, m_bSbedituser, m_bPartnersaldierung_statusalt, m_bKundenDokument, m_bVertrauliches_dokument, m_bWird_nicht_geloescht As SqlBoolean

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsDokumenttyp Class
clsDokumenttyp clsDokumenttyp Members


m_bHostdokument Field

m_bHostdokument Field

m_bHostdokument Field | Previous topic | Next topic
m_bHostdokument Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_bHostdokument As SqlBoolean

C#

private SqlBoolean m_bHostdokument

C++

private:
SqlBoolean m_bHostdokument;

JScript

private m_bHostdokument : SqlBoolean

Source code

Visual Basic

Copy Code Copy Code

Private m_bAktiv, m_bVertrag, m_bNurnative, m_bUnterschrift_rechts, m_bAnzeigeZurDokumenterstellung, m_bBedingtretournierbar, m_bFunktionen_zuweisen, m_bDokument_wird_erstellt, m_bAmsdokument, m_bHostdokument, m_bEmail_versand, m_bCold_ersetzen, m_bDokument_wird_retourniert, m_bUnterschrift_links, m_bWird_importiert, m_bEingang_ersetzt_ausgang, m_bSb, m_bSbimport, m_bZu_retournieren, m_bSbnur, m_bBezeichnungmut, m_bZu_vercolden, m_bSbedituser, m_bPartnersaldierung_statusalt, m_bKundenDokument, m_bVertrauliches_dokument, m_bWird_nicht_geloescht As SqlBoolean

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsDokumenttyp Class
clsDokumenttyp clsDokumenttyp Members


m_bKundenDokument Field

m_bKundenDokument Field

m_bKundenDokument Field | Previous topic | Next topic
m_bKundenDokument Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_bKundenDokument As SqlBoolean

C#

private SqlBoolean m_bKundenDokument

C++

private:
SqlBoolean m_bKundenDokument;

JScript

private m_bKundenDokument : SqlBoolean

Source code

Visual Basic

Copy Code Copy Code

Private m_bAktiv, m_bVertrag, m_bNurnative, m_bUnterschrift_rechts, m_bAnzeigeZurDokumenterstellung, m_bBedingtretournierbar, m_bFunktionen_zuweisen, m_bDokument_wird_erstellt, m_bAmsdokument, m_bHostdokument, m_bEmail_versand, m_bCold_ersetzen, m_bDokument_wird_retourniert, m_bUnterschrift_links, m_bWird_importiert, m_bEingang_ersetzt_ausgang, m_bSb, m_bSbimport, m_bZu_retournieren, m_bSbnur, m_bBezeichnungmut, m_bZu_vercolden, m_bSbedituser, m_bPartnersaldierung_statusalt, m_bKundenDokument, m_bVertrauliches_dokument, m_bWird_nicht_geloescht As SqlBoolean

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsDokumenttyp Class
clsDokumenttyp clsDokumenttyp Members


m_bNurnative Field

m_bNurnative Field

m_bNurnative Field | Previous topic | Next topic
m_bNurnative Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_bNurnative As SqlBoolean

C#

private SqlBoolean m_bNurnative

C++

private:
SqlBoolean m_bNurnative;

JScript

private m_bNurnative : SqlBoolean

Source code

Visual Basic

Copy Code Copy Code

Private m_bAktiv, m_bVertrag, m_bNurnative, m_bUnterschrift_rechts, m_bAnzeigeZurDokumenterstellung, m_bBedingtretournierbar, m_bFunktionen_zuweisen, m_bDokument_wird_erstellt, m_bAmsdokument, m_bHostdokument, m_bEmail_versand, m_bCold_ersetzen, m_bDokument_wird_retourniert, m_bUnterschrift_links, m_bWird_importiert, m_bEingang_ersetzt_ausgang, m_bSb, m_bSbimport, m_bZu_retournieren, m_bSbnur, m_bBezeichnungmut, m_bZu_vercolden, m_bSbedituser, m_bPartnersaldierung_statusalt, m_bKundenDokument, m_bVertrauliches_dokument, m_bWird_nicht_geloescht As SqlBoolean

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsDokumenttyp Class
clsDokumenttyp clsDokumenttyp Members


m_bPartnersaldierung_statusalt Field

m_bPartnersaldierung_statusalt Field

m_bPartnersaldierung_statusalt Field | Previous topic | Next topic
m_bPartnersaldierung_statusalt Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_bPartnersaldierung_statusalt As SqlBoolean

C#

private SqlBoolean m_bPartnersaldierung_statusalt

C++

private:
SqlBoolean m_bPartnersaldierung_statusalt;

JScript

private m_bPartnersaldierung_statusalt : SqlBoolean

Source code

Visual Basic

Copy Code Copy Code

Private m_bAktiv, m_bVertrag, m_bNurnative, m_bUnterschrift_rechts, m_bAnzeigeZurDokumenterstellung, m_bBedingtretournierbar, m_bFunktionen_zuweisen, m_bDokument_wird_erstellt, m_bAmsdokument, m_bHostdokument, m_bEmail_versand, m_bCold_ersetzen, m_bDokument_wird_retourniert, m_bUnterschrift_links, m_bWird_importiert, m_bEingang_ersetzt_ausgang, m_bSb, m_bSbimport, m_bZu_retournieren, m_bSbnur, m_bBezeichnungmut, m_bZu_vercolden, m_bSbedituser, m_bPartnersaldierung_statusalt, m_bKundenDokument, m_bVertrauliches_dokument, m_bWird_nicht_geloescht As SqlBoolean

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsDokumenttyp Class
clsDokumenttyp clsDokumenttyp Members


m_bSb Field

m_bSb Field

m_bSb Field | Previous topic | Next topic
m_bSb Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_bSb As SqlBoolean

C#

private SqlBoolean m_bSb

C++

private:
SqlBoolean m_bSb;

JScript

private m_bSb : SqlBoolean

Source code

Visual Basic

Copy Code Copy Code

Private m_bAktiv, m_bVertrag, m_bNurnative, m_bUnterschrift_rechts, m_bAnzeigeZurDokumenterstellung, m_bBedingtretournierbar, m_bFunktionen_zuweisen, m_bDokument_wird_erstellt, m_bAmsdokument, m_bHostdokument, m_bEmail_versand, m_bCold_ersetzen, m_bDokument_wird_retourniert, m_bUnterschrift_links, m_bWird_importiert, m_bEingang_ersetzt_ausgang, m_bSb, m_bSbimport, m_bZu_retournieren, m_bSbnur, m_bBezeichnungmut, m_bZu_vercolden, m_bSbedituser, m_bPartnersaldierung_statusalt, m_bKundenDokument, m_bVertrauliches_dokument, m_bWird_nicht_geloescht As SqlBoolean

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsDokumenttyp Class
clsDokumenttyp clsDokumenttyp Members


m_bSbedituser Field

m_bSbedituser Field

m_bSbedituser Field | Previous topic | Next topic
m_bSbedituser Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_bSbedituser As SqlBoolean

C#

private SqlBoolean m_bSbedituser

C++

private:
SqlBoolean m_bSbedituser;

JScript

private m_bSbedituser : SqlBoolean

Source code

Visual Basic

Copy Code Copy Code

Private m_bAktiv, m_bVertrag, m_bNurnative, m_bUnterschrift_rechts, m_bAnzeigeZurDokumenterstellung, m_bBedingtretournierbar, m_bFunktionen_zuweisen, m_bDokument_wird_erstellt, m_bAmsdokument, m_bHostdokument, m_bEmail_versand, m_bCold_ersetzen, m_bDokument_wird_retourniert, m_bUnterschrift_links, m_bWird_importiert, m_bEingang_ersetzt_ausgang, m_bSb, m_bSbimport, m_bZu_retournieren, m_bSbnur, m_bBezeichnungmut, m_bZu_vercolden, m_bSbedituser, m_bPartnersaldierung_statusalt, m_bKundenDokument, m_bVertrauliches_dokument, m_bWird_nicht_geloescht As SqlBoolean

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsDokumenttyp Class
clsDokumenttyp clsDokumenttyp Members


m_bSbimport Field

m_bSbimport Field

m_bSbimport Field | Previous topic | Next topic
m_bSbimport Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_bSbimport As SqlBoolean

C#

private SqlBoolean m_bSbimport

C++

private:
SqlBoolean m_bSbimport;

JScript

private m_bSbimport : SqlBoolean

Source code

Visual Basic

Copy Code Copy Code

Private m_bAktiv, m_bVertrag, m_bNurnative, m_bUnterschrift_rechts, m_bAnzeigeZurDokumenterstellung, m_bBedingtretournierbar, m_bFunktionen_zuweisen, m_bDokument_wird_erstellt, m_bAmsdokument, m_bHostdokument, m_bEmail_versand, m_bCold_ersetzen, m_bDokument_wird_retourniert, m_bUnterschrift_links, m_bWird_importiert, m_bEingang_ersetzt_ausgang, m_bSb, m_bSbimport, m_bZu_retournieren, m_bSbnur, m_bBezeichnungmut, m_bZu_vercolden, m_bSbedituser, m_bPartnersaldierung_statusalt, m_bKundenDokument, m_bVertrauliches_dokument, m_bWird_nicht_geloescht As SqlBoolean

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsDokumenttyp Class
clsDokumenttyp clsDokumenttyp Members


m_bSbnur Field

m_bSbnur Field

m_bSbnur Field | Previous topic | Next topic
m_bSbnur Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_bSbnur As SqlBoolean

C#

private SqlBoolean m_bSbnur

C++

private:
SqlBoolean m_bSbnur;

JScript

private m_bSbnur : SqlBoolean

Source code

Visual Basic

Copy Code Copy Code

Private m_bAktiv, m_bVertrag, m_bNurnative, m_bUnterschrift_rechts, m_bAnzeigeZurDokumenterstellung, m_bBedingtretournierbar, m_bFunktionen_zuweisen, m_bDokument_wird_erstellt, m_bAmsdokument, m_bHostdokument, m_bEmail_versand, m_bCold_ersetzen, m_bDokument_wird_retourniert, m_bUnterschrift_links, m_bWird_importiert, m_bEingang_ersetzt_ausgang, m_bSb, m_bSbimport, m_bZu_retournieren, m_bSbnur, m_bBezeichnungmut, m_bZu_vercolden, m_bSbedituser, m_bPartnersaldierung_statusalt, m_bKundenDokument, m_bVertrauliches_dokument, m_bWird_nicht_geloescht As SqlBoolean

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsDokumenttyp Class
clsDokumenttyp clsDokumenttyp Members


m_bUnterschrift_links Field

m_bUnterschrift_links Field

m_bUnterschrift_links Field | Previous topic | Next topic
m_bUnterschrift_links Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_bUnterschrift_links As SqlBoolean

C#

private SqlBoolean m_bUnterschrift_links

C++

private:
SqlBoolean m_bUnterschrift_links;

JScript

private m_bUnterschrift_links : SqlBoolean

Source code

Visual Basic

Copy Code Copy Code

Private m_bAktiv, m_bVertrag, m_bNurnative, m_bUnterschrift_rechts, m_bAnzeigeZurDokumenterstellung, m_bBedingtretournierbar, m_bFunktionen_zuweisen, m_bDokument_wird_erstellt, m_bAmsdokument, m_bHostdokument, m_bEmail_versand, m_bCold_ersetzen, m_bDokument_wird_retourniert, m_bUnterschrift_links, m_bWird_importiert, m_bEingang_ersetzt_ausgang, m_bSb, m_bSbimport, m_bZu_retournieren, m_bSbnur, m_bBezeichnungmut, m_bZu_vercolden, m_bSbedituser, m_bPartnersaldierung_statusalt, m_bKundenDokument, m_bVertrauliches_dokument, m_bWird_nicht_geloescht As SqlBoolean

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsDokumenttyp Class
clsDokumenttyp clsDokumenttyp Members


m_bUnterschrift_rechts Field

m_bUnterschrift_rechts Field

m_bUnterschrift_rechts Field | Previous topic | Next topic
m_bUnterschrift_rechts Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_bUnterschrift_rechts As SqlBoolean

C#

private SqlBoolean m_bUnterschrift_rechts

C++

private:
SqlBoolean m_bUnterschrift_rechts;

JScript

private m_bUnterschrift_rechts : SqlBoolean

Source code

Visual Basic

Copy Code Copy Code

Private m_bAktiv, m_bVertrag, m_bNurnative, m_bUnterschrift_rechts, m_bAnzeigeZurDokumenterstellung, m_bBedingtretournierbar, m_bFunktionen_zuweisen, m_bDokument_wird_erstellt, m_bAmsdokument, m_bHostdokument, m_bEmail_versand, m_bCold_ersetzen, m_bDokument_wird_retourniert, m_bUnterschrift_links, m_bWird_importiert, m_bEingang_ersetzt_ausgang, m_bSb, m_bSbimport, m_bZu_retournieren, m_bSbnur, m_bBezeichnungmut, m_bZu_vercolden, m_bSbedituser, m_bPartnersaldierung_statusalt, m_bKundenDokument, m_bVertrauliches_dokument, m_bWird_nicht_geloescht As SqlBoolean

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsDokumenttyp Class
clsDokumenttyp clsDokumenttyp Members


m_bVertrag Field

m_bVertrag Field

m_bVertrag Field | Previous topic | Next topic
m_bVertrag Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_bVertrag As SqlBoolean

C#

private SqlBoolean m_bVertrag

C++

private:
SqlBoolean m_bVertrag;

JScript

private m_bVertrag : SqlBoolean

Source code

Visual Basic

Copy Code Copy Code

Private m_bAktiv, m_bVertrag, m_bNurnative, m_bUnterschrift_rechts, m_bAnzeigeZurDokumenterstellung, m_bBedingtretournierbar, m_bFunktionen_zuweisen, m_bDokument_wird_erstellt, m_bAmsdokument, m_bHostdokument, m_bEmail_versand, m_bCold_ersetzen, m_bDokument_wird_retourniert, m_bUnterschrift_links, m_bWird_importiert, m_bEingang_ersetzt_ausgang, m_bSb, m_bSbimport, m_bZu_retournieren, m_bSbnur, m_bBezeichnungmut, m_bZu_vercolden, m_bSbedituser, m_bPartnersaldierung_statusalt, m_bKundenDokument, m_bVertrauliches_dokument, m_bWird_nicht_geloescht As SqlBoolean

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsDokumenttyp Class
clsDokumenttyp clsDokumenttyp Members


m_bVertrauliches_dokument Field

m_bVertrauliches_dokument Field

m_bVertrauliches_dokument Field | Previous topic | Next topic
m_bVertrauliches_dokument Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_bVertrauliches_dokument As SqlBoolean

C#

private SqlBoolean m_bVertrauliches_dokument

C++

private:
SqlBoolean m_bVertrauliches_dokument;

JScript

private m_bVertrauliches_dokument : SqlBoolean

Source code

Visual Basic

Copy Code Copy Code

Private m_bAktiv, m_bVertrag, m_bNurnative, m_bUnterschrift_rechts, m_bAnzeigeZurDokumenterstellung, m_bBedingtretournierbar, m_bFunktionen_zuweisen, m_bDokument_wird_erstellt, m_bAmsdokument, m_bHostdokument, m_bEmail_versand, m_bCold_ersetzen, m_bDokument_wird_retourniert, m_bUnterschrift_links, m_bWird_importiert, m_bEingang_ersetzt_ausgang, m_bSb, m_bSbimport, m_bZu_retournieren, m_bSbnur, m_bBezeichnungmut, m_bZu_vercolden, m_bSbedituser, m_bPartnersaldierung_statusalt, m_bKundenDokument, m_bVertrauliches_dokument, m_bWird_nicht_geloescht As SqlBoolean

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsDokumenttyp Class
clsDokumenttyp clsDokumenttyp Members


m_bWird_importiert Field

m_bWird_importiert Field

m_bWird_importiert Field | Previous topic | Next topic
m_bWird_importiert Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_bWird_importiert As SqlBoolean

C#

private SqlBoolean m_bWird_importiert

C++

private:
SqlBoolean m_bWird_importiert;

JScript

private m_bWird_importiert : SqlBoolean

Source code

Visual Basic

Copy Code Copy Code

Private m_bAktiv, m_bVertrag, m_bNurnative, m_bUnterschrift_rechts, m_bAnzeigeZurDokumenterstellung, m_bBedingtretournierbar, m_bFunktionen_zuweisen, m_bDokument_wird_erstellt, m_bAmsdokument, m_bHostdokument, m_bEmail_versand, m_bCold_ersetzen, m_bDokument_wird_retourniert, m_bUnterschrift_links, m_bWird_importiert, m_bEingang_ersetzt_ausgang, m_bSb, m_bSbimport, m_bZu_retournieren, m_bSbnur, m_bBezeichnungmut, m_bZu_vercolden, m_bSbedituser, m_bPartnersaldierung_statusalt, m_bKundenDokument, m_bVertrauliches_dokument, m_bWird_nicht_geloescht As SqlBoolean

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsDokumenttyp Class
clsDokumenttyp clsDokumenttyp Members


m_bWird_nicht_geloescht Field

m_bWird_nicht_geloescht Field

m_bWird_nicht_geloescht Field | Previous topic | Next topic
m_bWird_nicht_geloescht Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_bWird_nicht_geloescht As SqlBoolean

C#

private SqlBoolean m_bWird_nicht_geloescht

C++

private:
SqlBoolean m_bWird_nicht_geloescht;

JScript

private m_bWird_nicht_geloescht : SqlBoolean

Source code

Visual Basic

Copy Code Copy Code

Private m_bAktiv, m_bVertrag, m_bNurnative, m_bUnterschrift_rechts, m_bAnzeigeZurDokumenterstellung, m_bBedingtretournierbar, m_bFunktionen_zuweisen, m_bDokument_wird_erstellt, m_bAmsdokument, m_bHostdokument, m_bEmail_versand, m_bCold_ersetzen, m_bDokument_wird_retourniert, m_bUnterschrift_links, m_bWird_importiert, m_bEingang_ersetzt_ausgang, m_bSb, m_bSbimport, m_bZu_retournieren, m_bSbnur, m_bBezeichnungmut, m_bZu_vercolden, m_bSbedituser, m_bPartnersaldierung_statusalt, m_bKundenDokument, m_bVertrauliches_dokument, m_bWird_nicht_geloescht As SqlBoolean

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsDokumenttyp Class
clsDokumenttyp clsDokumenttyp Members


m_bZu_retournieren Field

m_bZu_retournieren Field

m_bZu_retournieren Field | Previous topic | Next topic
m_bZu_retournieren Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_bZu_retournieren As SqlBoolean

C#

private SqlBoolean m_bZu_retournieren

C++

private:
SqlBoolean m_bZu_retournieren;

JScript

private m_bZu_retournieren : SqlBoolean

Source code

Visual Basic

Copy Code Copy Code

Private m_bAktiv, m_bVertrag, m_bNurnative, m_bUnterschrift_rechts, m_bAnzeigeZurDokumenterstellung, m_bBedingtretournierbar, m_bFunktionen_zuweisen, m_bDokument_wird_erstellt, m_bAmsdokument, m_bHostdokument, m_bEmail_versand, m_bCold_ersetzen, m_bDokument_wird_retourniert, m_bUnterschrift_links, m_bWird_importiert, m_bEingang_ersetzt_ausgang, m_bSb, m_bSbimport, m_bZu_retournieren, m_bSbnur, m_bBezeichnungmut, m_bZu_vercolden, m_bSbedituser, m_bPartnersaldierung_statusalt, m_bKundenDokument, m_bVertrauliches_dokument, m_bWird_nicht_geloescht As SqlBoolean

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsDokumenttyp Class
clsDokumenttyp clsDokumenttyp Members


m_bZu_vercolden Field

m_bZu_vercolden Field

m_bZu_vercolden Field | Previous topic | Next topic
m_bZu_vercolden Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_bZu_vercolden As SqlBoolean

C#

private SqlBoolean m_bZu_vercolden

C++

private:
SqlBoolean m_bZu_vercolden;

JScript

private m_bZu_vercolden : SqlBoolean

Source code

Visual Basic

Copy Code Copy Code

Private m_bAktiv, m_bVertrag, m_bNurnative, m_bUnterschrift_rechts, m_bAnzeigeZurDokumenterstellung, m_bBedingtretournierbar, m_bFunktionen_zuweisen, m_bDokument_wird_erstellt, m_bAmsdokument, m_bHostdokument, m_bEmail_versand, m_bCold_ersetzen, m_bDokument_wird_retourniert, m_bUnterschrift_links, m_bWird_importiert, m_bEingang_ersetzt_ausgang, m_bSb, m_bSbimport, m_bZu_retournieren, m_bSbnur, m_bBezeichnungmut, m_bZu_vercolden, m_bSbedituser, m_bPartnersaldierung_statusalt, m_bKundenDokument, m_bVertrauliches_dokument, m_bWird_nicht_geloescht As SqlBoolean

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsDokumenttyp Class
clsDokumenttyp clsDokumenttyp Members


m_daErstellt_am Field

m_daErstellt_am Field

m_daErstellt_am Field | Previous topic | Next topic
m_daErstellt_am Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_daErstellt_am As SqlDateTime

C#

private SqlDateTime m_daErstellt_am

C++

private:
SqlDateTime m_daErstellt_am;

JScript

private m_daErstellt_am : SqlDateTime

Source code

Visual Basic

Copy Code Copy Code

Private m_daMutiert_am, m_daErstellt_am As SqlDateTime

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsDokumenttyp Class
clsDokumenttyp clsDokumenttyp Members


m_daMutiert_am Field

m_daMutiert_am Field

m_daMutiert_am Field | Previous topic | Next topic
m_daMutiert_am Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_daMutiert_am As SqlDateTime

C#

private SqlDateTime m_daMutiert_am

C++

private:
SqlDateTime m_daMutiert_am;

JScript

private m_daMutiert_am : SqlDateTime

Source code

Visual Basic

Copy Code Copy Code

Private m_daMutiert_am, m_daErstellt_am As SqlDateTime

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsDokumenttyp Class
clsDokumenttyp clsDokumenttyp Members


m_iAnzahl_tage Field

m_iAnzahl_tage Field

m_iAnzahl_tage Field | Previous topic | Next topic
m_iAnzahl_tage Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_iAnzahl_tage As SqlInt32

C#

private SqlInt32 m_iAnzahl_tage

C++

private:
SqlInt32 m_iAnzahl_tage;

JScript

private m_iAnzahl_tage : SqlInt32

Source code

Visual Basic

Copy Code Copy Code

Private m_iOwner, m_iPhysisches_archiv, m_iCold_folder, m_iObjektbezeichnungnr, m_iDoktypbedingteretournierung, m_iDokumentstatus_barcode, m_iDokumentstatus, m_iTagebisvernichtungbedingteretournierung, m_iAufbewahrungsfrist_physisch, m_iAufbewahrungsfrist_elektronisch, m_iMandantnr, m_iOffice_vorlagenr, m_iMutierer, m_iAnzahl_tage, m_iDokumenttypnr, m_iDbearbeitungszeit, m_iMonate_bis_zur_archivierung, m_iTage_mutation, m_iDokumentart_kundendossier, m_iDokumentart_nativ, m_iDokumentart_weitere, m_iProzessnr1, m_iProzessnr, m_iDokumentart_host, m_iDokumentart_retournierung, m_iDokumentart_neuerstellung, m_iDokumentart_coldeingang, m_iDokumentart_coldausgang As SqlInt32

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsDokumenttyp Class
clsDokumenttyp clsDokumenttyp Members


m_iAufbewahrungsfrist_elektronisch Field

m_iAufbewahrungsfrist_elektronisch Field

m_iAufbewahrungsfrist_elektronisch Field | Previous topic | Next topic
m_iAufbewahrungsfrist_elektronisch Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_iAufbewahrungsfrist_elektronisch As SqlInt32

C#

private SqlInt32 m_iAufbewahrungsfrist_elektronisch

C++

private:
SqlInt32 m_iAufbewahrungsfrist_elektronisch;

JScript

private m_iAufbewahrungsfrist_elektronisch : SqlInt32

Source code

Visual Basic

Copy Code Copy Code

Private m_iOwner, m_iPhysisches_archiv, m_iCold_folder, m_iObjektbezeichnungnr, m_iDoktypbedingteretournierung, m_iDokumentstatus_barcode, m_iDokumentstatus, m_iTagebisvernichtungbedingteretournierung, m_iAufbewahrungsfrist_physisch, m_iAufbewahrungsfrist_elektronisch, m_iMandantnr, m_iOffice_vorlagenr, m_iMutierer, m_iAnzahl_tage, m_iDokumenttypnr, m_iDbearbeitungszeit, m_iMonate_bis_zur_archivierung, m_iTage_mutation, m_iDokumentart_kundendossier, m_iDokumentart_nativ, m_iDokumentart_weitere, m_iProzessnr1, m_iProzessnr, m_iDokumentart_host, m_iDokumentart_retournierung, m_iDokumentart_neuerstellung, m_iDokumentart_coldeingang, m_iDokumentart_coldausgang As SqlInt32

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsDokumenttyp Class
clsDokumenttyp clsDokumenttyp Members


m_iAufbewahrungsfrist_physisch Field

m_iAufbewahrungsfrist_physisch Field

m_iAufbewahrungsfrist_physisch Field | Previous topic | Next topic
m_iAufbewahrungsfrist_physisch Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_iAufbewahrungsfrist_physisch As SqlInt32

C#

private SqlInt32 m_iAufbewahrungsfrist_physisch

C++

private:
SqlInt32 m_iAufbewahrungsfrist_physisch;

JScript

private m_iAufbewahrungsfrist_physisch : SqlInt32

Source code

Visual Basic

Copy Code Copy Code

Private m_iOwner, m_iPhysisches_archiv, m_iCold_folder, m_iObjektbezeichnungnr, m_iDoktypbedingteretournierung, m_iDokumentstatus_barcode, m_iDokumentstatus, m_iTagebisvernichtungbedingteretournierung, m_iAufbewahrungsfrist_physisch, m_iAufbewahrungsfrist_elektronisch, m_iMandantnr, m_iOffice_vorlagenr, m_iMutierer, m_iAnzahl_tage, m_iDokumenttypnr, m_iDbearbeitungszeit, m_iMonate_bis_zur_archivierung, m_iTage_mutation, m_iDokumentart_kundendossier, m_iDokumentart_nativ, m_iDokumentart_weitere, m_iProzessnr1, m_iProzessnr, m_iDokumentart_host, m_iDokumentart_retournierung, m_iDokumentart_neuerstellung, m_iDokumentart_coldeingang, m_iDokumentart_coldausgang As SqlInt32

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsDokumenttyp Class
clsDokumenttyp clsDokumenttyp Members


m_iCold_folder Field

m_iCold_folder Field

m_iCold_folder Field | Previous topic | Next topic
m_iCold_folder Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_iCold_folder As SqlInt32

C#

private SqlInt32 m_iCold_folder

C++

private:
SqlInt32 m_iCold_folder;

JScript

private m_iCold_folder : SqlInt32

Source code

Visual Basic

Copy Code Copy Code

Private m_iOwner, m_iPhysisches_archiv, m_iCold_folder, m_iObjektbezeichnungnr, m_iDoktypbedingteretournierung, m_iDokumentstatus_barcode, m_iDokumentstatus, m_iTagebisvernichtungbedingteretournierung, m_iAufbewahrungsfrist_physisch, m_iAufbewahrungsfrist_elektronisch, m_iMandantnr, m_iOffice_vorlagenr, m_iMutierer, m_iAnzahl_tage, m_iDokumenttypnr, m_iDbearbeitungszeit, m_iMonate_bis_zur_archivierung, m_iTage_mutation, m_iDokumentart_kundendossier, m_iDokumentart_nativ, m_iDokumentart_weitere, m_iProzessnr1, m_iProzessnr, m_iDokumentart_host, m_iDokumentart_retournierung, m_iDokumentart_neuerstellung, m_iDokumentart_coldeingang, m_iDokumentart_coldausgang As SqlInt32

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsDokumenttyp Class
clsDokumenttyp clsDokumenttyp Members


m_iDbearbeitungszeit Field

m_iDbearbeitungszeit Field

m_iDbearbeitungszeit Field | Previous topic | Next topic
m_iDbearbeitungszeit Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_iDbearbeitungszeit As SqlInt32

C#

private SqlInt32 m_iDbearbeitungszeit

C++

private:
SqlInt32 m_iDbearbeitungszeit;

JScript

private m_iDbearbeitungszeit : SqlInt32

Source code

Visual Basic

Copy Code Copy Code

Private m_iOwner, m_iPhysisches_archiv, m_iCold_folder, m_iObjektbezeichnungnr, m_iDoktypbedingteretournierung, m_iDokumentstatus_barcode, m_iDokumentstatus, m_iTagebisvernichtungbedingteretournierung, m_iAufbewahrungsfrist_physisch, m_iAufbewahrungsfrist_elektronisch, m_iMandantnr, m_iOffice_vorlagenr, m_iMutierer, m_iAnzahl_tage, m_iDokumenttypnr, m_iDbearbeitungszeit, m_iMonate_bis_zur_archivierung, m_iTage_mutation, m_iDokumentart_kundendossier, m_iDokumentart_nativ, m_iDokumentart_weitere, m_iProzessnr1, m_iProzessnr, m_iDokumentart_host, m_iDokumentart_retournierung, m_iDokumentart_neuerstellung, m_iDokumentart_coldeingang, m_iDokumentart_coldausgang As SqlInt32

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsDokumenttyp Class
clsDokumenttyp clsDokumenttyp Members


m_iDoktypbedingteretournierung Field

m_iDoktypbedingteretournierung Field

m_iDoktypbedingteretournierung Field | Previous topic | Next topic
m_iDoktypbedingteretournierung Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_iDoktypbedingteretournierung As SqlInt32

C#

private SqlInt32 m_iDoktypbedingteretournierung

C++

private:
SqlInt32 m_iDoktypbedingteretournierung;

JScript

private m_iDoktypbedingteretournierung : SqlInt32

Source code

Visual Basic

Copy Code Copy Code

Private m_iOwner, m_iPhysisches_archiv, m_iCold_folder, m_iObjektbezeichnungnr, m_iDoktypbedingteretournierung, m_iDokumentstatus_barcode, m_iDokumentstatus, m_iTagebisvernichtungbedingteretournierung, m_iAufbewahrungsfrist_physisch, m_iAufbewahrungsfrist_elektronisch, m_iMandantnr, m_iOffice_vorlagenr, m_iMutierer, m_iAnzahl_tage, m_iDokumenttypnr, m_iDbearbeitungszeit, m_iMonate_bis_zur_archivierung, m_iTage_mutation, m_iDokumentart_kundendossier, m_iDokumentart_nativ, m_iDokumentart_weitere, m_iProzessnr1, m_iProzessnr, m_iDokumentart_host, m_iDokumentart_retournierung, m_iDokumentart_neuerstellung, m_iDokumentart_coldeingang, m_iDokumentart_coldausgang As SqlInt32

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsDokumenttyp Class
clsDokumenttyp clsDokumenttyp Members


m_iDokumentart_coldausgang Field

m_iDokumentart_coldausgang Field

m_iDokumentart_coldausgang Field | Previous topic | Next topic
m_iDokumentart_coldausgang Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_iDokumentart_coldausgang As SqlInt32

C#

private SqlInt32 m_iDokumentart_coldausgang

C++

private:
SqlInt32 m_iDokumentart_coldausgang;

JScript

private m_iDokumentart_coldausgang : SqlInt32

Source code

Visual Basic

Copy Code Copy Code

Private m_iOwner, m_iPhysisches_archiv, m_iCold_folder, m_iObjektbezeichnungnr, m_iDoktypbedingteretournierung, m_iDokumentstatus_barcode, m_iDokumentstatus, m_iTagebisvernichtungbedingteretournierung, m_iAufbewahrungsfrist_physisch, m_iAufbewahrungsfrist_elektronisch, m_iMandantnr, m_iOffice_vorlagenr, m_iMutierer, m_iAnzahl_tage, m_iDokumenttypnr, m_iDbearbeitungszeit, m_iMonate_bis_zur_archivierung, m_iTage_mutation, m_iDokumentart_kundendossier, m_iDokumentart_nativ, m_iDokumentart_weitere, m_iProzessnr1, m_iProzessnr, m_iDokumentart_host, m_iDokumentart_retournierung, m_iDokumentart_neuerstellung, m_iDokumentart_coldeingang, m_iDokumentart_coldausgang As SqlInt32

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsDokumenttyp Class
clsDokumenttyp clsDokumenttyp Members


m_iDokumentart_coldeingang Field

m_iDokumentart_coldeingang Field

m_iDokumentart_coldeingang Field | Previous topic | Next topic
m_iDokumentart_coldeingang Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_iDokumentart_coldeingang As SqlInt32

C#

private SqlInt32 m_iDokumentart_coldeingang

C++

private:
SqlInt32 m_iDokumentart_coldeingang;

JScript

private m_iDokumentart_coldeingang : SqlInt32

Source code

Visual Basic

Copy Code Copy Code

Private m_iOwner, m_iPhysisches_archiv, m_iCold_folder, m_iObjektbezeichnungnr, m_iDoktypbedingteretournierung, m_iDokumentstatus_barcode, m_iDokumentstatus, m_iTagebisvernichtungbedingteretournierung, m_iAufbewahrungsfrist_physisch, m_iAufbewahrungsfrist_elektronisch, m_iMandantnr, m_iOffice_vorlagenr, m_iMutierer, m_iAnzahl_tage, m_iDokumenttypnr, m_iDbearbeitungszeit, m_iMonate_bis_zur_archivierung, m_iTage_mutation, m_iDokumentart_kundendossier, m_iDokumentart_nativ, m_iDokumentart_weitere, m_iProzessnr1, m_iProzessnr, m_iDokumentart_host, m_iDokumentart_retournierung, m_iDokumentart_neuerstellung, m_iDokumentart_coldeingang, m_iDokumentart_coldausgang As SqlInt32

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsDokumenttyp Class
clsDokumenttyp clsDokumenttyp Members


m_iDokumentart_host Field

m_iDokumentart_host Field

m_iDokumentart_host Field | Previous topic | Next topic
m_iDokumentart_host Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_iDokumentart_host As SqlInt32

C#

private SqlInt32 m_iDokumentart_host

C++

private:
SqlInt32 m_iDokumentart_host;

JScript

private m_iDokumentart_host : SqlInt32

Source code

Visual Basic

Copy Code Copy Code

Private m_iOwner, m_iPhysisches_archiv, m_iCold_folder, m_iObjektbezeichnungnr, m_iDoktypbedingteretournierung, m_iDokumentstatus_barcode, m_iDokumentstatus, m_iTagebisvernichtungbedingteretournierung, m_iAufbewahrungsfrist_physisch, m_iAufbewahrungsfrist_elektronisch, m_iMandantnr, m_iOffice_vorlagenr, m_iMutierer, m_iAnzahl_tage, m_iDokumenttypnr, m_iDbearbeitungszeit, m_iMonate_bis_zur_archivierung, m_iTage_mutation, m_iDokumentart_kundendossier, m_iDokumentart_nativ, m_iDokumentart_weitere, m_iProzessnr1, m_iProzessnr, m_iDokumentart_host, m_iDokumentart_retournierung, m_iDokumentart_neuerstellung, m_iDokumentart_coldeingang, m_iDokumentart_coldausgang As SqlInt32

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsDokumenttyp Class
clsDokumenttyp clsDokumenttyp Members


m_iDokumentart_kundendossier Field

m_iDokumentart_kundendossier Field

m_iDokumentart_kundendossier Field | Previous topic | Next topic
m_iDokumentart_kundendossier Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_iDokumentart_kundendossier As SqlInt32

C#

private SqlInt32 m_iDokumentart_kundendossier

C++

private:
SqlInt32 m_iDokumentart_kundendossier;

JScript

private m_iDokumentart_kundendossier : SqlInt32

Source code

Visual Basic

Copy Code Copy Code

Private m_iOwner, m_iPhysisches_archiv, m_iCold_folder, m_iObjektbezeichnungnr, m_iDoktypbedingteretournierung, m_iDokumentstatus_barcode, m_iDokumentstatus, m_iTagebisvernichtungbedingteretournierung, m_iAufbewahrungsfrist_physisch, m_iAufbewahrungsfrist_elektronisch, m_iMandantnr, m_iOffice_vorlagenr, m_iMutierer, m_iAnzahl_tage, m_iDokumenttypnr, m_iDbearbeitungszeit, m_iMonate_bis_zur_archivierung, m_iTage_mutation, m_iDokumentart_kundendossier, m_iDokumentart_nativ, m_iDokumentart_weitere, m_iProzessnr1, m_iProzessnr, m_iDokumentart_host, m_iDokumentart_retournierung, m_iDokumentart_neuerstellung, m_iDokumentart_coldeingang, m_iDokumentart_coldausgang As SqlInt32

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsDokumenttyp Class
clsDokumenttyp clsDokumenttyp Members


m_iDokumentart_nativ Field

m_iDokumentart_nativ Field

m_iDokumentart_nativ Field | Previous topic | Next topic
m_iDokumentart_nativ Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_iDokumentart_nativ As SqlInt32

C#

private SqlInt32 m_iDokumentart_nativ

C++

private:
SqlInt32 m_iDokumentart_nativ;

JScript

private m_iDokumentart_nativ : SqlInt32

Source code

Visual Basic

Copy Code Copy Code

Private m_iOwner, m_iPhysisches_archiv, m_iCold_folder, m_iObjektbezeichnungnr, m_iDoktypbedingteretournierung, m_iDokumentstatus_barcode, m_iDokumentstatus, m_iTagebisvernichtungbedingteretournierung, m_iAufbewahrungsfrist_physisch, m_iAufbewahrungsfrist_elektronisch, m_iMandantnr, m_iOffice_vorlagenr, m_iMutierer, m_iAnzahl_tage, m_iDokumenttypnr, m_iDbearbeitungszeit, m_iMonate_bis_zur_archivierung, m_iTage_mutation, m_iDokumentart_kundendossier, m_iDokumentart_nativ, m_iDokumentart_weitere, m_iProzessnr1, m_iProzessnr, m_iDokumentart_host, m_iDokumentart_retournierung, m_iDokumentart_neuerstellung, m_iDokumentart_coldeingang, m_iDokumentart_coldausgang As SqlInt32

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsDokumenttyp Class
clsDokumenttyp clsDokumenttyp Members


m_iDokumentart_neuerstellung Field

m_iDokumentart_neuerstellung Field

m_iDokumentart_neuerstellung Field | Previous topic | Next topic
m_iDokumentart_neuerstellung Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_iDokumentart_neuerstellung As SqlInt32

C#

private SqlInt32 m_iDokumentart_neuerstellung

C++

private:
SqlInt32 m_iDokumentart_neuerstellung;

JScript

private m_iDokumentart_neuerstellung : SqlInt32

Source code

Visual Basic

Copy Code Copy Code

Private m_iOwner, m_iPhysisches_archiv, m_iCold_folder, m_iObjektbezeichnungnr, m_iDoktypbedingteretournierung, m_iDokumentstatus_barcode, m_iDokumentstatus, m_iTagebisvernichtungbedingteretournierung, m_iAufbewahrungsfrist_physisch, m_iAufbewahrungsfrist_elektronisch, m_iMandantnr, m_iOffice_vorlagenr, m_iMutierer, m_iAnzahl_tage, m_iDokumenttypnr, m_iDbearbeitungszeit, m_iMonate_bis_zur_archivierung, m_iTage_mutation, m_iDokumentart_kundendossier, m_iDokumentart_nativ, m_iDokumentart_weitere, m_iProzessnr1, m_iProzessnr, m_iDokumentart_host, m_iDokumentart_retournierung, m_iDokumentart_neuerstellung, m_iDokumentart_coldeingang, m_iDokumentart_coldausgang As SqlInt32

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsDokumenttyp Class
clsDokumenttyp clsDokumenttyp Members


m_iDokumentart_retournierung Field

m_iDokumentart_retournierung Field

m_iDokumentart_retournierung Field | Previous topic | Next topic
m_iDokumentart_retournierung Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_iDokumentart_retournierung As SqlInt32

C#

private SqlInt32 m_iDokumentart_retournierung

C++

private:
SqlInt32 m_iDokumentart_retournierung;

JScript

private m_iDokumentart_retournierung : SqlInt32

Source code

Visual Basic

Copy Code Copy Code

Private m_iOwner, m_iPhysisches_archiv, m_iCold_folder, m_iObjektbezeichnungnr, m_iDoktypbedingteretournierung, m_iDokumentstatus_barcode, m_iDokumentstatus, m_iTagebisvernichtungbedingteretournierung, m_iAufbewahrungsfrist_physisch, m_iAufbewahrungsfrist_elektronisch, m_iMandantnr, m_iOffice_vorlagenr, m_iMutierer, m_iAnzahl_tage, m_iDokumenttypnr, m_iDbearbeitungszeit, m_iMonate_bis_zur_archivierung, m_iTage_mutation, m_iDokumentart_kundendossier, m_iDokumentart_nativ, m_iDokumentart_weitere, m_iProzessnr1, m_iProzessnr, m_iDokumentart_host, m_iDokumentart_retournierung, m_iDokumentart_neuerstellung, m_iDokumentart_coldeingang, m_iDokumentart_coldausgang As SqlInt32

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsDokumenttyp Class
clsDokumenttyp clsDokumenttyp Members


m_iDokumentart_weitere Field

m_iDokumentart_weitere Field

m_iDokumentart_weitere Field | Previous topic | Next topic
m_iDokumentart_weitere Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_iDokumentart_weitere As SqlInt32

C#

private SqlInt32 m_iDokumentart_weitere

C++

private:
SqlInt32 m_iDokumentart_weitere;

JScript

private m_iDokumentart_weitere : SqlInt32

Source code

Visual Basic

Copy Code Copy Code

Private m_iOwner, m_iPhysisches_archiv, m_iCold_folder, m_iObjektbezeichnungnr, m_iDoktypbedingteretournierung, m_iDokumentstatus_barcode, m_iDokumentstatus, m_iTagebisvernichtungbedingteretournierung, m_iAufbewahrungsfrist_physisch, m_iAufbewahrungsfrist_elektronisch, m_iMandantnr, m_iOffice_vorlagenr, m_iMutierer, m_iAnzahl_tage, m_iDokumenttypnr, m_iDbearbeitungszeit, m_iMonate_bis_zur_archivierung, m_iTage_mutation, m_iDokumentart_kundendossier, m_iDokumentart_nativ, m_iDokumentart_weitere, m_iProzessnr1, m_iProzessnr, m_iDokumentart_host, m_iDokumentart_retournierung, m_iDokumentart_neuerstellung, m_iDokumentart_coldeingang, m_iDokumentart_coldausgang As SqlInt32

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsDokumenttyp Class
clsDokumenttyp clsDokumenttyp Members


m_iDokumentstatus Field

m_iDokumentstatus Field

m_iDokumentstatus Field | Previous topic | Next topic
m_iDokumentstatus Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_iDokumentstatus As SqlInt32

C#

private SqlInt32 m_iDokumentstatus

C++

private:
SqlInt32 m_iDokumentstatus;

JScript

private m_iDokumentstatus : SqlInt32

Source code

Visual Basic

Copy Code Copy Code

Private m_iOwner, m_iPhysisches_archiv, m_iCold_folder, m_iObjektbezeichnungnr, m_iDoktypbedingteretournierung, m_iDokumentstatus_barcode, m_iDokumentstatus, m_iTagebisvernichtungbedingteretournierung, m_iAufbewahrungsfrist_physisch, m_iAufbewahrungsfrist_elektronisch, m_iMandantnr, m_iOffice_vorlagenr, m_iMutierer, m_iAnzahl_tage, m_iDokumenttypnr, m_iDbearbeitungszeit, m_iMonate_bis_zur_archivierung, m_iTage_mutation, m_iDokumentart_kundendossier, m_iDokumentart_nativ, m_iDokumentart_weitere, m_iProzessnr1, m_iProzessnr, m_iDokumentart_host, m_iDokumentart_retournierung, m_iDokumentart_neuerstellung, m_iDokumentart_coldeingang, m_iDokumentart_coldausgang As SqlInt32

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsDokumenttyp Class
clsDokumenttyp clsDokumenttyp Members


m_iDokumentstatus_barcode Field

m_iDokumentstatus_barcode Field

m_iDokumentstatus_barcode Field | Previous topic | Next topic
m_iDokumentstatus_barcode Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_iDokumentstatus_barcode As SqlInt32

C#

private SqlInt32 m_iDokumentstatus_barcode

C++

private:
SqlInt32 m_iDokumentstatus_barcode;

JScript

private m_iDokumentstatus_barcode : SqlInt32

Source code

Visual Basic

Copy Code Copy Code

Private m_iOwner, m_iPhysisches_archiv, m_iCold_folder, m_iObjektbezeichnungnr, m_iDoktypbedingteretournierung, m_iDokumentstatus_barcode, m_iDokumentstatus, m_iTagebisvernichtungbedingteretournierung, m_iAufbewahrungsfrist_physisch, m_iAufbewahrungsfrist_elektronisch, m_iMandantnr, m_iOffice_vorlagenr, m_iMutierer, m_iAnzahl_tage, m_iDokumenttypnr, m_iDbearbeitungszeit, m_iMonate_bis_zur_archivierung, m_iTage_mutation, m_iDokumentart_kundendossier, m_iDokumentart_nativ, m_iDokumentart_weitere, m_iProzessnr1, m_iProzessnr, m_iDokumentart_host, m_iDokumentart_retournierung, m_iDokumentart_neuerstellung, m_iDokumentart_coldeingang, m_iDokumentart_coldausgang As SqlInt32

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsDokumenttyp Class
clsDokumenttyp clsDokumenttyp Members


m_iDokumenttypnr Field

m_iDokumenttypnr Field

m_iDokumenttypnr Field | Previous topic | Next topic
m_iDokumenttypnr Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_iDokumenttypnr As SqlInt32

C#

private SqlInt32 m_iDokumenttypnr

C++

private:
SqlInt32 m_iDokumenttypnr;

JScript

private m_iDokumenttypnr : SqlInt32

Source code

Visual Basic

Copy Code Copy Code

Private m_iOwner, m_iPhysisches_archiv, m_iCold_folder, m_iObjektbezeichnungnr, m_iDoktypbedingteretournierung, m_iDokumentstatus_barcode, m_iDokumentstatus, m_iTagebisvernichtungbedingteretournierung, m_iAufbewahrungsfrist_physisch, m_iAufbewahrungsfrist_elektronisch, m_iMandantnr, m_iOffice_vorlagenr, m_iMutierer, m_iAnzahl_tage, m_iDokumenttypnr, m_iDbearbeitungszeit, m_iMonate_bis_zur_archivierung, m_iTage_mutation, m_iDokumentart_kundendossier, m_iDokumentart_nativ, m_iDokumentart_weitere, m_iProzessnr1, m_iProzessnr, m_iDokumentart_host, m_iDokumentart_retournierung, m_iDokumentart_neuerstellung, m_iDokumentart_coldeingang, m_iDokumentart_coldausgang As SqlInt32

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsDokumenttyp Class
clsDokumenttyp clsDokumenttyp Members


m_iMandantnr Field

m_iMandantnr Field

m_iMandantnr Field | Previous topic | Next topic
m_iMandantnr Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_iMandantnr As SqlInt32

C#

private SqlInt32 m_iMandantnr

C++

private:
SqlInt32 m_iMandantnr;

JScript

private m_iMandantnr : SqlInt32

Source code

Visual Basic

Copy Code Copy Code

Private m_iOwner, m_iPhysisches_archiv, m_iCold_folder, m_iObjektbezeichnungnr, m_iDoktypbedingteretournierung, m_iDokumentstatus_barcode, m_iDokumentstatus, m_iTagebisvernichtungbedingteretournierung, m_iAufbewahrungsfrist_physisch, m_iAufbewahrungsfrist_elektronisch, m_iMandantnr, m_iOffice_vorlagenr, m_iMutierer, m_iAnzahl_tage, m_iDokumenttypnr, m_iDbearbeitungszeit, m_iMonate_bis_zur_archivierung, m_iTage_mutation, m_iDokumentart_kundendossier, m_iDokumentart_nativ, m_iDokumentart_weitere, m_iProzessnr1, m_iProzessnr, m_iDokumentart_host, m_iDokumentart_retournierung, m_iDokumentart_neuerstellung, m_iDokumentart_coldeingang, m_iDokumentart_coldausgang As SqlInt32

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsDokumenttyp Class
clsDokumenttyp clsDokumenttyp Members


m_iMonate_bis_zur_archivierung Field

m_iMonate_bis_zur_archivierung Field

m_iMonate_bis_zur_archivierung Field | Previous topic | Next topic
m_iMonate_bis_zur_archivierung Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_iMonate_bis_zur_archivierung As SqlInt32

C#

private SqlInt32 m_iMonate_bis_zur_archivierung

C++

private:
SqlInt32 m_iMonate_bis_zur_archivierung;

JScript

private m_iMonate_bis_zur_archivierung : SqlInt32

Source code

Visual Basic

Copy Code Copy Code

Private m_iOwner, m_iPhysisches_archiv, m_iCold_folder, m_iObjektbezeichnungnr, m_iDoktypbedingteretournierung, m_iDokumentstatus_barcode, m_iDokumentstatus, m_iTagebisvernichtungbedingteretournierung, m_iAufbewahrungsfrist_physisch, m_iAufbewahrungsfrist_elektronisch, m_iMandantnr, m_iOffice_vorlagenr, m_iMutierer, m_iAnzahl_tage, m_iDokumenttypnr, m_iDbearbeitungszeit, m_iMonate_bis_zur_archivierung, m_iTage_mutation, m_iDokumentart_kundendossier, m_iDokumentart_nativ, m_iDokumentart_weitere, m_iProzessnr1, m_iProzessnr, m_iDokumentart_host, m_iDokumentart_retournierung, m_iDokumentart_neuerstellung, m_iDokumentart_coldeingang, m_iDokumentart_coldausgang As SqlInt32

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsDokumenttyp Class
clsDokumenttyp clsDokumenttyp Members


m_iMutierer Field

m_iMutierer Field

m_iMutierer Field | Previous topic | Next topic
m_iMutierer Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_iMutierer As SqlInt32

C#

private SqlInt32 m_iMutierer

C++

private:
SqlInt32 m_iMutierer;

JScript

private m_iMutierer : SqlInt32

Source code

Visual Basic

Copy Code Copy Code

Private m_iOwner, m_iPhysisches_archiv, m_iCold_folder, m_iObjektbezeichnungnr, m_iDoktypbedingteretournierung, m_iDokumentstatus_barcode, m_iDokumentstatus, m_iTagebisvernichtungbedingteretournierung, m_iAufbewahrungsfrist_physisch, m_iAufbewahrungsfrist_elektronisch, m_iMandantnr, m_iOffice_vorlagenr, m_iMutierer, m_iAnzahl_tage, m_iDokumenttypnr, m_iDbearbeitungszeit, m_iMonate_bis_zur_archivierung, m_iTage_mutation, m_iDokumentart_kundendossier, m_iDokumentart_nativ, m_iDokumentart_weitere, m_iProzessnr1, m_iProzessnr, m_iDokumentart_host, m_iDokumentart_retournierung, m_iDokumentart_neuerstellung, m_iDokumentart_coldeingang, m_iDokumentart_coldausgang As SqlInt32

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsDokumenttyp Class
clsDokumenttyp clsDokumenttyp Members


m_iObjektbezeichnungnr Field

m_iObjektbezeichnungnr Field

m_iObjektbezeichnungnr Field | Previous topic | Next topic
m_iObjektbezeichnungnr Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_iObjektbezeichnungnr As SqlInt32

C#

private SqlInt32 m_iObjektbezeichnungnr

C++

private:
SqlInt32 m_iObjektbezeichnungnr;

JScript

private m_iObjektbezeichnungnr : SqlInt32

Source code

Visual Basic

Copy Code Copy Code

Private m_iOwner, m_iPhysisches_archiv, m_iCold_folder, m_iObjektbezeichnungnr, m_iDoktypbedingteretournierung, m_iDokumentstatus_barcode, m_iDokumentstatus, m_iTagebisvernichtungbedingteretournierung, m_iAufbewahrungsfrist_physisch, m_iAufbewahrungsfrist_elektronisch, m_iMandantnr, m_iOffice_vorlagenr, m_iMutierer, m_iAnzahl_tage, m_iDokumenttypnr, m_iDbearbeitungszeit, m_iMonate_bis_zur_archivierung, m_iTage_mutation, m_iDokumentart_kundendossier, m_iDokumentart_nativ, m_iDokumentart_weitere, m_iProzessnr1, m_iProzessnr, m_iDokumentart_host, m_iDokumentart_retournierung, m_iDokumentart_neuerstellung, m_iDokumentart_coldeingang, m_iDokumentart_coldausgang As SqlInt32

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsDokumenttyp Class
clsDokumenttyp clsDokumenttyp Members


m_iOffice_vorlagenr Field

m_iOffice_vorlagenr Field

m_iOffice_vorlagenr Field | Previous topic | Next topic
m_iOffice_vorlagenr Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_iOffice_vorlagenr As SqlInt32

C#

private SqlInt32 m_iOffice_vorlagenr

C++

private:
SqlInt32 m_iOffice_vorlagenr;

JScript

private m_iOffice_vorlagenr : SqlInt32

Source code

Visual Basic

Copy Code Copy Code

Private m_iOwner, m_iPhysisches_archiv, m_iCold_folder, m_iObjektbezeichnungnr, m_iDoktypbedingteretournierung, m_iDokumentstatus_barcode, m_iDokumentstatus, m_iTagebisvernichtungbedingteretournierung, m_iAufbewahrungsfrist_physisch, m_iAufbewahrungsfrist_elektronisch, m_iMandantnr, m_iOffice_vorlagenr, m_iMutierer, m_iAnzahl_tage, m_iDokumenttypnr, m_iDbearbeitungszeit, m_iMonate_bis_zur_archivierung, m_iTage_mutation, m_iDokumentart_kundendossier, m_iDokumentart_nativ, m_iDokumentart_weitere, m_iProzessnr1, m_iProzessnr, m_iDokumentart_host, m_iDokumentart_retournierung, m_iDokumentart_neuerstellung, m_iDokumentart_coldeingang, m_iDokumentart_coldausgang As SqlInt32

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsDokumenttyp Class
clsDokumenttyp clsDokumenttyp Members


m_iOwner Field

m_iOwner Field

m_iOwner Field | Previous topic | Next topic
m_iOwner Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_iOwner As SqlInt32

C#

private SqlInt32 m_iOwner

C++

private:
SqlInt32 m_iOwner;

JScript

private m_iOwner : SqlInt32

Source code

Visual Basic

Copy Code Copy Code

Private m_iOwner, m_iPhysisches_archiv, m_iCold_folder, m_iObjektbezeichnungnr, m_iDoktypbedingteretournierung, m_iDokumentstatus_barcode, m_iDokumentstatus, m_iTagebisvernichtungbedingteretournierung, m_iAufbewahrungsfrist_physisch, m_iAufbewahrungsfrist_elektronisch, m_iMandantnr, m_iOffice_vorlagenr, m_iMutierer, m_iAnzahl_tage, m_iDokumenttypnr, m_iDbearbeitungszeit, m_iMonate_bis_zur_archivierung, m_iTage_mutation, m_iDokumentart_kundendossier, m_iDokumentart_nativ, m_iDokumentart_weitere, m_iProzessnr1, m_iProzessnr, m_iDokumentart_host, m_iDokumentart_retournierung, m_iDokumentart_neuerstellung, m_iDokumentart_coldeingang, m_iDokumentart_coldausgang As SqlInt32

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsDokumenttyp Class
clsDokumenttyp clsDokumenttyp Members


m_iPhysisches_archiv Field

m_iPhysisches_archiv Field

m_iPhysisches_archiv Field | Previous topic | Next topic
m_iPhysisches_archiv Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_iPhysisches_archiv As SqlInt32

C#

private SqlInt32 m_iPhysisches_archiv

C++

private:
SqlInt32 m_iPhysisches_archiv;

JScript

private m_iPhysisches_archiv : SqlInt32

Source code

Visual Basic

Copy Code Copy Code

Private m_iOwner, m_iPhysisches_archiv, m_iCold_folder, m_iObjektbezeichnungnr, m_iDoktypbedingteretournierung, m_iDokumentstatus_barcode, m_iDokumentstatus, m_iTagebisvernichtungbedingteretournierung, m_iAufbewahrungsfrist_physisch, m_iAufbewahrungsfrist_elektronisch, m_iMandantnr, m_iOffice_vorlagenr, m_iMutierer, m_iAnzahl_tage, m_iDokumenttypnr, m_iDbearbeitungszeit, m_iMonate_bis_zur_archivierung, m_iTage_mutation, m_iDokumentart_kundendossier, m_iDokumentart_nativ, m_iDokumentart_weitere, m_iProzessnr1, m_iProzessnr, m_iDokumentart_host, m_iDokumentart_retournierung, m_iDokumentart_neuerstellung, m_iDokumentart_coldeingang, m_iDokumentart_coldausgang As SqlInt32

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsDokumenttyp Class
clsDokumenttyp clsDokumenttyp Members


m_iProzessnr Field

m_iProzessnr Field

m_iProzessnr Field | Previous topic | Next topic
m_iProzessnr Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_iProzessnr As SqlInt32

C#

private SqlInt32 m_iProzessnr

C++

private:
SqlInt32 m_iProzessnr;

JScript

private m_iProzessnr : SqlInt32

Source code

Visual Basic

Copy Code Copy Code

Private m_iOwner, m_iPhysisches_archiv, m_iCold_folder, m_iObjektbezeichnungnr, m_iDoktypbedingteretournierung, m_iDokumentstatus_barcode, m_iDokumentstatus, m_iTagebisvernichtungbedingteretournierung, m_iAufbewahrungsfrist_physisch, m_iAufbewahrungsfrist_elektronisch, m_iMandantnr, m_iOffice_vorlagenr, m_iMutierer, m_iAnzahl_tage, m_iDokumenttypnr, m_iDbearbeitungszeit, m_iMonate_bis_zur_archivierung, m_iTage_mutation, m_iDokumentart_kundendossier, m_iDokumentart_nativ, m_iDokumentart_weitere, m_iProzessnr1, m_iProzessnr, m_iDokumentart_host, m_iDokumentart_retournierung, m_iDokumentart_neuerstellung, m_iDokumentart_coldeingang, m_iDokumentart_coldausgang As SqlInt32

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsDokumenttyp Class
clsDokumenttyp clsDokumenttyp Members


m_iProzessnr1 Field

m_iProzessnr1 Field

m_iProzessnr1 Field | Previous topic | Next topic
m_iProzessnr1 Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_iProzessnr1 As SqlInt32

C#

private SqlInt32 m_iProzessnr1

C++

private:
SqlInt32 m_iProzessnr1;

JScript

private m_iProzessnr1 : SqlInt32

Source code

Visual Basic

Copy Code Copy Code

Private m_iOwner, m_iPhysisches_archiv, m_iCold_folder, m_iObjektbezeichnungnr, m_iDoktypbedingteretournierung, m_iDokumentstatus_barcode, m_iDokumentstatus, m_iTagebisvernichtungbedingteretournierung, m_iAufbewahrungsfrist_physisch, m_iAufbewahrungsfrist_elektronisch, m_iMandantnr, m_iOffice_vorlagenr, m_iMutierer, m_iAnzahl_tage, m_iDokumenttypnr, m_iDbearbeitungszeit, m_iMonate_bis_zur_archivierung, m_iTage_mutation, m_iDokumentart_kundendossier, m_iDokumentart_nativ, m_iDokumentart_weitere, m_iProzessnr1, m_iProzessnr, m_iDokumentart_host, m_iDokumentart_retournierung, m_iDokumentart_neuerstellung, m_iDokumentart_coldeingang, m_iDokumentart_coldausgang As SqlInt32

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsDokumenttyp Class
clsDokumenttyp clsDokumenttyp Members


m_iTage_mutation Field

m_iTage_mutation Field

m_iTage_mutation Field | Previous topic | Next topic
m_iTage_mutation Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_iTage_mutation As SqlInt32

C#

private SqlInt32 m_iTage_mutation

C++

private:
SqlInt32 m_iTage_mutation;

JScript

private m_iTage_mutation : SqlInt32

Source code

Visual Basic

Copy Code Copy Code

Private m_iOwner, m_iPhysisches_archiv, m_iCold_folder, m_iObjektbezeichnungnr, m_iDoktypbedingteretournierung, m_iDokumentstatus_barcode, m_iDokumentstatus, m_iTagebisvernichtungbedingteretournierung, m_iAufbewahrungsfrist_physisch, m_iAufbewahrungsfrist_elektronisch, m_iMandantnr, m_iOffice_vorlagenr, m_iMutierer, m_iAnzahl_tage, m_iDokumenttypnr, m_iDbearbeitungszeit, m_iMonate_bis_zur_archivierung, m_iTage_mutation, m_iDokumentart_kundendossier, m_iDokumentart_nativ, m_iDokumentart_weitere, m_iProzessnr1, m_iProzessnr, m_iDokumentart_host, m_iDokumentart_retournierung, m_iDokumentart_neuerstellung, m_iDokumentart_coldeingang, m_iDokumentart_coldausgang As SqlInt32

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsDokumenttyp Class
clsDokumenttyp clsDokumenttyp Members


m_iTagebisvernichtungbedingteretournierung Field

m_iTagebisvernichtungbedingteretournierung Field

m_iTagebisvernichtungbedingteretournierung Field | Previous topic | Next topic
m_iTagebisvernichtungbedingteretournierung Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_iTagebisvernichtungbedingteretournierung As SqlInt32

C#

private SqlInt32 m_iTagebisvernichtungbedingteretournierung

C++

private:
SqlInt32 m_iTagebisvernichtungbedingteretournierung;

JScript

private m_iTagebisvernichtungbedingteretournierung : SqlInt32

Source code

Visual Basic

Copy Code Copy Code

Private m_iOwner, m_iPhysisches_archiv, m_iCold_folder, m_iObjektbezeichnungnr, m_iDoktypbedingteretournierung, m_iDokumentstatus_barcode, m_iDokumentstatus, m_iTagebisvernichtungbedingteretournierung, m_iAufbewahrungsfrist_physisch, m_iAufbewahrungsfrist_elektronisch, m_iMandantnr, m_iOffice_vorlagenr, m_iMutierer, m_iAnzahl_tage, m_iDokumenttypnr, m_iDbearbeitungszeit, m_iMonate_bis_zur_archivierung, m_iTage_mutation, m_iDokumentart_kundendossier, m_iDokumentart_nativ, m_iDokumentart_weitere, m_iProzessnr1, m_iProzessnr, m_iDokumentart_host, m_iDokumentart_retournierung, m_iDokumentart_neuerstellung, m_iDokumentart_coldeingang, m_iDokumentart_coldausgang As SqlInt32

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsDokumenttyp Class
clsDokumenttyp clsDokumenttyp Members


m_sBeschreibung Field

m_sBeschreibung Field

m_sBeschreibung Field | Previous topic | Next topic
m_sBeschreibung Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_sBeschreibung As SqlString

C#

private SqlString m_sBeschreibung

C++

private:
SqlString m_sBeschreibung;

JScript

private m_sBeschreibung : SqlString

Source code

Visual Basic

Copy Code Copy Code

Private m_sHostdokumenttyp, m_sBezeichnung, m_sBeschreibung As SqlString

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsDokumenttyp Class
clsDokumenttyp clsDokumenttyp Members


m_sBezeichnung Field

m_sBezeichnung Field

m_sBezeichnung Field | Previous topic | Next topic
m_sBezeichnung Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_sBezeichnung As SqlString

C#

private SqlString m_sBezeichnung

C++

private:
SqlString m_sBezeichnung;

JScript

private m_sBezeichnung : SqlString

Source code

Visual Basic

Copy Code Copy Code

Private m_sHostdokumenttyp, m_sBezeichnung, m_sBeschreibung As SqlString

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsDokumenttyp Class
clsDokumenttyp clsDokumenttyp Members


m_sHostdokumenttyp Field

m_sHostdokumenttyp Field

m_sHostdokumenttyp Field | Previous topic | Next topic
m_sHostdokumenttyp Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_sHostdokumenttyp As SqlString

C#

private SqlString m_sHostdokumenttyp

C++

private:
SqlString m_sHostdokumenttyp;

JScript

private m_sHostdokumenttyp : SqlString

Source code

Visual Basic

Copy Code Copy Code

Private m_sHostdokumenttyp, m_sBezeichnung, m_sBeschreibung As SqlString

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsDokumenttyp Class
clsDokumenttyp clsDokumenttyp Members


clsIdvmakro_office_vorlage Class

clsIdvmakro_office_vorlage Class

clsIdvmakro_office_vorlage Class | Previous topic | Next topic
clsIdvmakro_office_vorlage Class | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Class clsIdvmakro_office_vorlage
Inherits clsDBInteractionBase

C#

public class clsIdvmakro_office_vorlage : clsDBInteractionBase

C++

public ref class clsIdvmakro_office_vorlage : public clsDBInteractionBase^

JScript

public class clsIdvmakro_office_vorlage
extends clsDBInteractionBase

Inheritance Hierarchy

System.Object

EDKB12WS.edokadb.clsDBInteractionBase

EDKB12WS.edokadb.clsIdvmakro_office_vorlage

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsIdvmakro_office_vorlage Members


clsIdvmakro_office_vorlage Members

clsIdvmakro_office_vorlage Members

clsIdvmakro_office_vorlage Members | Previous topic | Next topic
clsIdvmakro_office_vorlage Members | Previous topic | Next topic

The following tables list the members exposed by the clsIdvmakro_office_vorlage type.

Public Constructors

 | Name | Description
Supported by the .NET Compact Framework. | clsIdvmakro_office_vorlage Constructor |

Top

Public Properties

 | Name | Description
Supported by the .NET Compact Framework. | bAktiv |
Supported by the .NET Compact Framework. | cpMainConnectionProvider | (inherited from clsDBInteractionBase ).
Supported by the .NET Compact Framework. | daErstellt_am |
Supported by the .NET Compact Framework. | daMutiert_am |
Supported by the .NET Compact Framework. | iErrorCode | (inherited from clsDBInteractionBase ).
Supported by the .NET Compact Framework. | iIdvmakronr |
Supported by the .NET Compact Framework. | iIdvmakronrOld |
Supported by the .NET Compact Framework. | iIdvmakroofficevorlagenr |
Supported by the .NET Compact Framework. | iMandantnr |
Supported by the .NET Compact Framework. | iMutierer |
Supported by the .NET Compact Framework. | iOffice_vorlagenr |
Supported by the .NET Compact Framework. | iOffice_vorlagenrOld |
Supported by the .NET Compact Framework. | iReihenfolge |
Supported by the .NET Compact Framework. | sConnectionString | (inherited from clsDBInteractionBase ).

Top

Public Methods

 | Name | Description
Supported by the .NET Compact Framework. | Delete |
Supported by the .NET Compact Framework. | Dispose | (Overloaded) (inherited from clsDBInteractionBase ).
Public method | Equals | (Overloaded) (inherited from Object).
Public method | GetHashCode | (inherited from Object).
Public method | GetType | (Overloaded) (inherited from Object).
Supported by the .NET Compact Framework. | Insert |
 | ReferenceEquals | (inherited from Object).
Supported by the .NET Compact Framework. | SelectAll |
Supported by the .NET Compact Framework. | SelectAllWidvmakronrLogic |
Supported by the .NET Compact Framework. | SelectAllWoffice_vorlagenrLogic |
Supported by the .NET Compact Framework. | SelectOne |
Public method | ToString | (inherited from Object).
Supported by the .NET Compact Framework. | Update |
Supported by the .NET Compact Framework. | UpdateAllWidvmakronrLogic |
Supported by the .NET Compact Framework. | UpdateAllWoffice_vorlagenrLogic |

Top

Protected Methods

 | Name | Description
Protected method | Finalize | (inherited from Object).
Protected method | MemberwiseClone | (Overloaded) (inherited from Object).

Top

Fields

 | Name | Description
Supported by the .NET Compact Framework. | m_bAktiv |
Supported by the .NET Compact Framework. | m_bMainConnectionIsCreatedLocal | (inherited from clsDBInteractionBase ).
Supported by the .NET Compact Framework. | m_cpMainConnectionProvider | (inherited from clsDBInteractionBase ).
Supported by the .NET Compact Framework. | m_daErstellt_am |
Supported by the .NET Compact Framework. | m_daMutiert_am |
Supported by the .NET Compact Framework. | m_iErrorCode | (inherited from clsDBInteractionBase ).
Supported by the .NET Compact Framework. | m_iIdvmakronr |
Supported by the .NET Compact Framework. | m_iIdvmakronrOld |
Supported by the .NET Compact Framework. | m_iIdvmakroofficevorlagenr |
Supported by the .NET Compact Framework. | m_iMandantnr |
Supported by the .NET Compact Framework. | m_iMutierer |
Supported by the .NET Compact Framework. | m_iOffice_vorlagenr |
Supported by the .NET Compact Framework. | m_iOffice_vorlagenrOld |
Supported by the .NET Compact Framework. | m_iReihenfolge |
Supported by the .NET Compact Framework. | m_scoMainConnection | (inherited from clsDBInteractionBase ).

Top

See Also

Reference

clsIdvmakro_office_vorlage Class


clsIdvmakro_office_vorlage Constructor

clsIdvmakro_office_vorlage Constructor

clsIdvmakro_office_vorlage Constructor | Previous topic | Next topic
clsIdvmakro_office_vorlage Constructor | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Sub New()

C#

public clsIdvmakro_office_vorlage()

C++

public:
clsIdvmakro_office_vorlage()

JScript

public function clsIdvmakro_office_vorlage();

Source code

Visual Basic

Copy Code Copy Code

Public Sub New()
' // Nothing for now.
End Sub

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsIdvmakro_office_vorlage Class
clsIdvmakro_office_vorlage clsIdvmakro_office_vorlage Members


clsIdvmakro_office_vorlage Properties

clsIdvmakro_office_vorlage Properties

clsIdvmakro_office_vorlage Properties | Previous topic | Next topic
clsIdvmakro_office_vorlage Properties | Previous topic | Next topic

Public Properties

 | Name | Description
Supported by the .NET Compact Framework. | bAktiv |
Supported by the .NET Compact Framework. | cpMainConnectionProvider | (inherited from clsDBInteractionBase ).
Supported by the .NET Compact Framework. | daErstellt_am |
Supported by the .NET Compact Framework. | daMutiert_am |
Supported by the .NET Compact Framework. | iErrorCode | (inherited from clsDBInteractionBase ).
Supported by the .NET Compact Framework. | iIdvmakronr |
Supported by the .NET Compact Framework. | iIdvmakronrOld |
Supported by the .NET Compact Framework. | iIdvmakroofficevorlagenr |
Supported by the .NET Compact Framework. | iMandantnr |
Supported by the .NET Compact Framework. | iMutierer |
Supported by the .NET Compact Framework. | iOffice_vorlagenr |
Supported by the .NET Compact Framework. | iOffice_vorlagenrOld |
Supported by the .NET Compact Framework. | iReihenfolge |
Supported by the .NET Compact Framework. | sConnectionString | (inherited from clsDBInteractionBase ).

Top

See Also

Reference

clsIdvmakro_office_vorlage Class


clsIdvmakro_office_vorlage.bAktiv Property

clsIdvmakro_office_vorlage.bAktiv Property

clsIdvmakro_office_vorlage.bAktiv Property | Previous topic | Next topic
clsIdvmakro_office_vorlage.bAktiv Property | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property bAktiv() As SqlBoolean

C#

public SqlBoolean bAktiv {get; set;}

C++

public:
property SqlBoolean bAktiv {
SqlBoolean get( );
void set(
SqlBoolean value
);
}

JScript

public function get bAktiv() : SqlBoolean;
public function set bAktiv(value : SqlBoolean);

Source code

Visual Basic

Copy Code Copy Code

Public Property [bAktiv]() As SqlBoolean
Get
Return m_bAktiv
End Get
Set(ByVal Value As SqlBoolean)
m_bAktiv = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsIdvmakro_office_vorlage Class
clsIdvmakro_office_vorlage clsIdvmakro_office_vorlage Members


clsIdvmakro_office_vorlage.daErstellt_am Property

clsIdvmakro_office_vorlage.daErstellt_am Property

clsIdvmakro_office_vorlage.daErstellt_am Property | Previous topic | Next topic
clsIdvmakro_office_vorlage.daErstellt_am Property | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property daErstellt_am() As SqlDateTime

C#

public SqlDateTime daErstellt_am {get; set;}

C++

public:
property SqlDateTime daErstellt_am {
SqlDateTime get( );
void set(
SqlDateTime value
);
}

JScript

public function get daErstellt_am() : SqlDateTime;
public function set daErstellt_am(value : SqlDateTime);

Source code

Visual Basic

Copy Code Copy Code

Public Property [daErstellt_am]() As SqlDateTime
Get
Return m_daErstellt_am
End Get
Set(ByVal Value As SqlDateTime)
m_daErstellt_am = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsIdvmakro_office_vorlage Class
clsIdvmakro_office_vorlage clsIdvmakro_office_vorlage Members


clsIdvmakro_office_vorlage.daMutiert_am Property

clsIdvmakro_office_vorlage.daMutiert_am Property

clsIdvmakro_office_vorlage.daMutiert_am Property | Previous topic | Next topic
clsIdvmakro_office_vorlage.daMutiert_am Property | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property daMutiert_am() As SqlDateTime

C#

public SqlDateTime daMutiert_am {get; set;}

C++

public:
property SqlDateTime daMutiert_am {
SqlDateTime get( );
void set(
SqlDateTime value
);
}

JScript

public function get daMutiert_am() : SqlDateTime;
public function set daMutiert_am(value : SqlDateTime);

Source code

Visual Basic

Copy Code Copy Code

Public Property [daMutiert_am]() As SqlDateTime
Get
Return m_daMutiert_am
End Get
Set(ByVal Value As SqlDateTime)
m_daMutiert_am = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsIdvmakro_office_vorlage Class
clsIdvmakro_office_vorlage clsIdvmakro_office_vorlage Members


clsIdvmakro_office_vorlage.iIdvmakronr Property

clsIdvmakro_office_vorlage.iIdvmakronr Property

clsIdvmakro_office_vorlage.iIdvmakronr Property | Previous topic | Next topic
clsIdvmakro_office_vorlage.iIdvmakronr Property | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property iIdvmakronr() As SqlInt32

C#

public SqlInt32 iIdvmakronr {get; set;}

C++

public:
property SqlInt32 iIdvmakronr {
SqlInt32 get( );
void set(
SqlInt32 value
);
}

JScript

public function get iIdvmakronr() : SqlInt32;
public function set iIdvmakronr(value : SqlInt32);

Source code

Visual Basic

Copy Code Copy Code

Public Property [iIdvmakronr]() As SqlInt32
Get
Return m_iIdvmakronr
End Get
Set(ByVal Value As SqlInt32)
m_iIdvmakronr = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsIdvmakro_office_vorlage Class
clsIdvmakro_office_vorlage clsIdvmakro_office_vorlage Members


clsIdvmakro_office_vorlage.iIdvmakronrOld Property

clsIdvmakro_office_vorlage.iIdvmakronrOld Property

clsIdvmakro_office_vorlage.iIdvmakronrOld Property | Previous topic | Next topic
clsIdvmakro_office_vorlage.iIdvmakronrOld Property | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property iIdvmakronrOld() As SqlInt32

C#

public SqlInt32 iIdvmakronrOld {get; set;}

C++

public:
property SqlInt32 iIdvmakronrOld {
SqlInt32 get( );
void set(
SqlInt32 value
);
}

JScript

public function get iIdvmakronrOld() : SqlInt32;
public function set iIdvmakronrOld(value : SqlInt32);

Source code

Visual Basic

Copy Code Copy Code

Public Property [iIdvmakronrOld]() As SqlInt32
Get
Return m_iIdvmakronrOld
End Get
Set(ByVal Value As SqlInt32)
m_iIdvmakronrOld = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsIdvmakro_office_vorlage Class
clsIdvmakro_office_vorlage clsIdvmakro_office_vorlage Members


clsIdvmakro_office_vorlage.iIdvmakroofficevorlagenr Property

clsIdvmakro_office_vorlage.iIdvmakroofficevorlagenr Property

clsIdvmakro_office_vorlage.iIdvmakroofficevorlagenr Property | Previous topic | Next topic
clsIdvmakro_office_vorlage.iIdvmakroofficevorlagenr Property | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property iIdvmakroofficevorlagenr() As SqlInt32

C#

public SqlInt32 iIdvmakroofficevorlagenr {get; set;}

C++

public:
property SqlInt32 iIdvmakroofficevorlagenr {
SqlInt32 get( );
void set(
SqlInt32 value
);
}

JScript

public function get iIdvmakroofficevorlagenr() : SqlInt32;
public function set iIdvmakroofficevorlagenr(value : SqlInt32);

Source code

Visual Basic

Copy Code Copy Code

Public Property [iIdvmakroofficevorlagenr]() As SqlInt32
Get
Return m_iIdvmakroofficevorlagenr
End Get
Set(ByVal Value As SqlInt32)
Dim iIdvmakroofficevorlagenrTmp As SqlInt32 = Value
If iIdvmakroofficevorlagenrTmp.IsNull Then
Throw New ArgumentOutOfRangeException("iIdvmakroofficevorlagenr", "iIdvmakroofficevorlagenr can't be NULL")
End If
m_iIdvmakroofficevorlagenr = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsIdvmakro_office_vorlage Class
clsIdvmakro_office_vorlage clsIdvmakro_office_vorlage Members


clsIdvmakro_office_vorlage.iMandantnr Property

clsIdvmakro_office_vorlage.iMandantnr Property

clsIdvmakro_office_vorlage.iMandantnr Property | Previous topic | Next topic
clsIdvmakro_office_vorlage.iMandantnr Property | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property iMandantnr() As SqlInt32

C#

public SqlInt32 iMandantnr {get; set;}

C++

public:
property SqlInt32 iMandantnr {
SqlInt32 get( );
void set(
SqlInt32 value
);
}

JScript

public function get iMandantnr() : SqlInt32;
public function set iMandantnr(value : SqlInt32);

Source code

Visual Basic

Copy Code Copy Code

Public Property [iMandantnr]() As SqlInt32
Get
Return m_iMandantnr
End Get
Set(ByVal Value As SqlInt32)
m_iMandantnr = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsIdvmakro_office_vorlage Class
clsIdvmakro_office_vorlage clsIdvmakro_office_vorlage Members


clsIdvmakro_office_vorlage.iMutierer Property

clsIdvmakro_office_vorlage.iMutierer Property

clsIdvmakro_office_vorlage.iMutierer Property | Previous topic | Next topic
clsIdvmakro_office_vorlage.iMutierer Property | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property iMutierer() As SqlInt32

C#

public SqlInt32 iMutierer {get; set;}

C++

public:
property SqlInt32 iMutierer {
SqlInt32 get( );
void set(
SqlInt32 value
);
}

JScript

public function get iMutierer() : SqlInt32;
public function set iMutierer(value : SqlInt32);

Source code

Visual Basic

Copy Code Copy Code

Public Property [iMutierer]() As SqlInt32
Get
Return m_iMutierer
End Get
Set(ByVal Value As SqlInt32)
Dim iMutiererTmp As SqlInt32 = Value
If iMutiererTmp.IsNull Then
Throw New ArgumentOutOfRangeException("iMutierer", "iMutierer can't be NULL")
End If
m_iMutierer = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsIdvmakro_office_vorlage Class
clsIdvmakro_office_vorlage clsIdvmakro_office_vorlage Members


clsIdvmakro_office_vorlage.iOffice_vorlagenr Property

clsIdvmakro_office_vorlage.iOffice_vorlagenr Property

clsIdvmakro_office_vorlage.iOffice_vorlagenr Property | Previous topic | Next topic
clsIdvmakro_office_vorlage.iOffice_vorlagenr Property | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property iOffice_vorlagenr() As SqlInt32

C#

public SqlInt32 iOffice_vorlagenr {get; set;}

C++

public:
property SqlInt32 iOffice_vorlagenr {
SqlInt32 get( );
void set(
SqlInt32 value
);
}

JScript

public function get iOffice_vorlagenr() : SqlInt32;
public function set iOffice_vorlagenr(value : SqlInt32);

Source code

Visual Basic

Copy Code Copy Code

Public Property [iOffice_vorlagenr]() As SqlInt32
Get
Return m_iOffice_vorlagenr
End Get
Set(ByVal Value As SqlInt32)
m_iOffice_vorlagenr = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsIdvmakro_office_vorlage Class
clsIdvmakro_office_vorlage clsIdvmakro_office_vorlage Members


clsIdvmakro_office_vorlage.iOffice_vorlagenrOld Property

clsIdvmakro_office_vorlage.iOffice_vorlagenrOld Property

clsIdvmakro_office_vorlage.iOffice_vorlagenrOld Property | Previous topic | Next topic
clsIdvmakro_office_vorlage.iOffice_vorlagenrOld Property | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property iOffice_vorlagenrOld() As SqlInt32

C#

public SqlInt32 iOffice_vorlagenrOld {get; set;}

C++

public:
property SqlInt32 iOffice_vorlagenrOld {
SqlInt32 get( );
void set(
SqlInt32 value
);
}

JScript

public function get iOffice_vorlagenrOld() : SqlInt32;
public function set iOffice_vorlagenrOld(value : SqlInt32);

Source code

Visual Basic

Copy Code Copy Code

Public Property [iOffice_vorlagenrOld]() As SqlInt32
Get
Return m_iOffice_vorlagenrOld
End Get
Set(ByVal Value As SqlInt32)
m_iOffice_vorlagenrOld = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsIdvmakro_office_vorlage Class
clsIdvmakro_office_vorlage clsIdvmakro_office_vorlage Members


clsIdvmakro_office_vorlage.iReihenfolge Property

clsIdvmakro_office_vorlage.iReihenfolge Property

clsIdvmakro_office_vorlage.iReihenfolge Property | Previous topic | Next topic
clsIdvmakro_office_vorlage.iReihenfolge Property | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property iReihenfolge() As SqlInt32

C#

public SqlInt32 iReihenfolge {get; set;}

C++

public:
property SqlInt32 iReihenfolge {
SqlInt32 get( );
void set(
SqlInt32 value
);
}

JScript

public function get iReihenfolge() : SqlInt32;
public function set iReihenfolge(value : SqlInt32);

Source code

Visual Basic

Copy Code Copy Code

Public Property [iReihenfolge]() As SqlInt32
Get
Return m_iReihenfolge
End Get
Set(ByVal Value As SqlInt32)
Dim iReihenfolgeTmp As SqlInt32 = Value
If iReihenfolgeTmp.IsNull Then
Throw New ArgumentOutOfRangeException("iReihenfolge", "iReihenfolge can't be NULL")
End If
m_iReihenfolge = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsIdvmakro_office_vorlage Class
clsIdvmakro_office_vorlage clsIdvmakro_office_vorlage Members


clsIdvmakro_office_vorlage Methods

clsIdvmakro_office_vorlage Methods

clsIdvmakro_office_vorlage Methods | Previous topic | Next topic
clsIdvmakro_office_vorlage Methods | Previous topic | Next topic

Public Methods

 | Name | Description
Supported by the .NET Compact Framework. | Delete |
Supported by the .NET Compact Framework. | Dispose | (Overloaded) (inherited from clsDBInteractionBase ).
Public method | Equals | (Overloaded) (inherited from Object).
Public method | GetHashCode | (inherited from Object).
Public method | GetType | (Overloaded) (inherited from Object).
Supported by the .NET Compact Framework. | Insert |
 | ReferenceEquals | (inherited from Object).
Supported by the .NET Compact Framework. | SelectAll |
Supported by the .NET Compact Framework. | SelectAllWidvmakronrLogic |
Supported by the .NET Compact Framework. | SelectAllWoffice_vorlagenrLogic |
Supported by the .NET Compact Framework. | SelectOne |
Public method | ToString | (inherited from Object).
Supported by the .NET Compact Framework. | Update |
Supported by the .NET Compact Framework. | UpdateAllWidvmakronrLogic |
Supported by the .NET Compact Framework. | UpdateAllWoffice_vorlagenrLogic |

Top

Protected Methods

 | Name | Description
Protected method | Finalize | (inherited from Object).
Protected method | MemberwiseClone | (Overloaded) (inherited from Object).

Top

See Also

Reference

clsIdvmakro_office_vorlage Class


clsIdvmakro_office_vorlage.Delete Method

clsIdvmakro_office_vorlage.Delete Method

clsIdvmakro_office_vorlage.Delete Method | Previous topic | Next topic
clsIdvmakro_office_vorlage.Delete Method | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Overrides Function Delete() As Boolean

C#

public override bool Delete()

C++

public:
bool Delete()

JScript

public function Delete() : boolean;

Source code

Visual Basic

Copy Code Copy Code

Public Overrides Function Delete() As Boolean
Dim scmCmdToExecute As SqlCommand = New SqlCommand()
scmCmdToExecute.CommandText = "dbo.[pr_idvmakro_office_vorlage_Delete]"
scmCmdToExecute.CommandType = CommandType.StoredProcedure

' // Use base class' connection object
scmCmdToExecute.Connection = m_scoMainConnection

Try
scmCmdToExecute.Parameters.Add(New SqlParameter("@iidvmakroofficevorlagenr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iIdvmakroofficevorlagenr))
scmCmdToExecute.Parameters.Add(New SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

If m_bMainConnectionIsCreatedLocal Then
' // Open connection.
m_scoMainConnection.Open()
Else
If m_cpMainConnectionProvider.bIsTransactionPending Then
scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
End If
End If

' // Execute query.
scmCmdToExecute.ExecuteNonQuery()
m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
' // Throw error.
Throw New Exception("Stored Procedure 'pr_idvmakro_office_vorlage_Delete' reported the ErrorCode: " & m_iErrorCode.ToString())
End If

Return True
Catch ex As Exception
' // some error occured. Bubble it to caller and encapsulate Exception object
Throw New Exception("clsIdvmakro_office_vorlage::Delete::Error occured.", ex)
Finally
If m_bMainConnectionIsCreatedLocal Then
' // Close connection.
m_scoMainConnection.Close()
End If
scmCmdToExecute.Dispose()
End Try
End Function

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsIdvmakro_office_vorlage Class
clsIdvmakro_office_vorlage clsIdvmakro_office_vorlage Members


clsIdvmakro_office_vorlage.Insert Method

clsIdvmakro_office_vorlage.Insert Method

clsIdvmakro_office_vorlage.Insert Method | Previous topic | Next topic
clsIdvmakro_office_vorlage.Insert Method | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Overrides Function Insert() As Boolean

C#

public override bool Insert()

C++

public:
bool Insert()

JScript

public function Insert() : boolean;

Source code

Visual Basic

Copy Code Copy Code

Overrides Public Function Insert() As Boolean
Dim scmCmdToExecute As SqlCommand = New SqlCommand()
scmCmdToExecute.CommandText = "dbo.[pr_idvmakro_office_vorlage_Insert]"
scmCmdToExecute.CommandType = CommandType.StoredProcedure

' // Use base class' connection object
scmCmdToExecute.Connection = m_scoMainConnection

Try
scmCmdToExecute.Parameters.Add(New SqlParameter("@iidvmakroofficevorlagenr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iIdvmakroofficevorlagenr))
scmCmdToExecute.Parameters.Add(New SqlParameter("@ireihenfolge", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iReihenfolge))
scmCmdToExecute.Parameters.Add(New SqlParameter("@imandantnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMandantnr))
scmCmdToExecute.Parameters.Add(New SqlParameter("@baktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bAktiv))
scmCmdToExecute.Parameters.Add(New SqlParameter("@daerstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daErstellt_am))
scmCmdToExecute.Parameters.Add(New SqlParameter("@damutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daMutiert_am))
scmCmdToExecute.Parameters.Add(New SqlParameter("@imutierer", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
scmCmdToExecute.Parameters.Add(New SqlParameter("@ioffice_vorlagenr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iOffice_vorlagenr))
scmCmdToExecute.Parameters.Add(New SqlParameter("@iidvmakronr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iIdvmakronr))
scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

If m_bMainConnectionIsCreatedLocal Then
' // Open connection.
m_scoMainConnection.Open()
Else
If m_cpMainConnectionProvider.bIsTransactionPending Then
scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
End If
End If

' // Execute query.
scmCmdToExecute.ExecuteNonQuery()
m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
' // Throw error.
Throw New Exception("Stored Procedure 'pr_idvmakro_office_vorlage_Insert' reported the ErrorCode: " & m_iErrorCode.ToString())
End If

Return True
Catch ex As Exception
' // some error occured. Bubble it to caller and encapsulate Exception object
Throw New Exception("clsIdvmakro_office_vorlage::Insert::Error occured." + ex.Message, ex)
Finally
If m_bMainConnectionIsCreatedLocal Then
' // Close connection.
m_scoMainConnection.Close()
End If
scmCmdToExecute.Dispose()
End Try
End Function

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsIdvmakro_office_vorlage Class
clsIdvmakro_office_vorlage clsIdvmakro_office_vorlage Members


clsIdvmakro_office_vorlage.SelectAll Method

clsIdvmakro_office_vorlage.SelectAll Method

clsIdvmakro_office_vorlage.SelectAll Method | Previous topic | Next topic
clsIdvmakro_office_vorlage.SelectAll Method | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Overrides Function SelectAll() As DataTable

C#

public override DataTable SelectAll()

C++

public:
DataTable^ SelectAll()

JScript

public function SelectAll() : DataTable;

Source code

Visual Basic

Copy Code Copy Code

Public Overrides Function SelectAll() As DataTable
Dim scmCmdToExecute As SqlCommand = New SqlCommand()
scmCmdToExecute.CommandText = "dbo.[pr_idvmakro_office_vorlage_SelectAll]"
scmCmdToExecute.CommandType = CommandType.StoredProcedure
Dim dtToReturn As DataTable = New DataTable("idvmakro_office_vorlage")
Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)

' // Use base class' connection object
scmCmdToExecute.Connection = m_scoMainConnection

Try
scmCmdToExecute.Parameters.Add(New SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

If m_bMainConnectionIsCreatedLocal Then
' // Open connection.
m_scoMainConnection.Open()
Else
If m_cpMainConnectionProvider.bIsTransactionPending Then
scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
End If
End If

' // Execute query.
sdaAdapter.Fill(dtToReturn)
m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
' // Throw error.
Throw New Exception("Stored Procedure 'pr_idvmakro_office_vorlage_SelectAll' reported the ErrorCode: " & m_iErrorCode.ToString())
End If

Return dtToReturn
Catch ex As Exception
' // some error occured. Bubble it to caller and encapsulate Exception object
Throw New Exception("clsIdvmakro_office_vorlage::SelectAll::Error occured.", ex)
Finally
If m_bMainConnectionIsCreatedLocal Then
' // Close connection.
m_scoMainConnection.Close()
End If
scmCmdToExecute.Dispose()
sdaAdapter.Dispose()
End Try
End Function

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsIdvmakro_office_vorlage Class
clsIdvmakro_office_vorlage clsIdvmakro_office_vorlage Members


clsIdvmakro_office_vorlage.SelectAllWidvmakronrLogic Method

clsIdvmakro_office_vorlage.SelectAllWidvmakronrLogic Method

clsIdvmakro_office_vorlage.SelectAllWidvmakronrLogic Method | Previous topic | Next topic
clsIdvmakro_office_vorlage.SelectAllWidvmakronrLogic Method | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Function SelectAllWidvmakronrLogic() As DataTable

C#

public DataTable SelectAllWidvmakronrLogic()

C++

public:
DataTable^ SelectAllWidvmakronrLogic()

JScript

public function SelectAllWidvmakronrLogic() : DataTable;

Source code

Visual Basic

Copy Code Copy Code

Public Function SelectAllWidvmakronrLogic() As DataTable
Dim scmCmdToExecute As SqlCommand = New SqlCommand()
scmCmdToExecute.CommandText = "dbo.[pr_idvmakro_office_vorlage_SelectAllWidvmakronrLogic]"
scmCmdToExecute.CommandType = CommandType.StoredProcedure
Dim dtToReturn As DataTable = New DataTable("idvmakro_office_vorlage")
Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)

' // Use base class' connection object
scmCmdToExecute.Connection = m_scoMainConnection

Try
scmCmdToExecute.Parameters.Add(New SqlParameter("@iidvmakronr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iIdvmakronr))
scmCmdToExecute.Parameters.Add(New SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

If m_bMainConnectionIsCreatedLocal Then
' // Open connection.
m_scoMainConnection.Open()
Else
If m_cpMainConnectionProvider.bIsTransactionPending Then
scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
End If
End If

' // Execute query.
sdaAdapter.Fill(dtToReturn)
m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
' // Throw error.
Throw New Exception("Stored Procedure 'pr_idvmakro_office_vorlage_SelectAllWidvmakronrLogic' reported the ErrorCode: " & m_iErrorCode.ToString())
End If

Return dtToReturn
Catch ex As Exception
' // some error occured. Bubble it to caller and encapsulate Exception object
Throw New Exception("clsIdvmakro_office_vorlage::SelectAllWidvmakronrLogic::Error occured.", ex)
Finally
If m_bMainConnectionIsCreatedLocal Then
' // Close connection.
m_scoMainConnection.Close()
End If
scmCmdToExecute.Dispose()
sdaAdapter.Dispose()
End Try
End Function

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsIdvmakro_office_vorlage Class
clsIdvmakro_office_vorlage clsIdvmakro_office_vorlage Members


clsIdvmakro_office_vorlage.SelectAllWoffice_vorlagenrLogic Method

clsIdvmakro_office_vorlage.SelectAllWoffice_vorlagenrLogic Method

clsIdvmakro_office_vorlage.SelectAllWoffice_vorlagenrLogic Method | Previous topic | Next topic
clsIdvmakro_office_vorlage.SelectAllWoffice_vorlagenrLogic Method | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Function SelectAllWoffice_vorlagenrLogic() As DataTable

C#

public DataTable SelectAllWoffice_vorlagenrLogic()

C++

public:
DataTable^ SelectAllWoffice_vorlagenrLogic()

JScript

public function SelectAllWoffice_vorlagenrLogic() : DataTable;

Source code

Visual Basic

Copy Code Copy Code

Public Function SelectAllWoffice_vorlagenrLogic() As DataTable
Dim scmCmdToExecute As SqlCommand = New SqlCommand()
scmCmdToExecute.CommandText = "dbo.[pr_idvmakro_office_vorlage_SelectAllWoffice_vorlagenrLogic]"
scmCmdToExecute.CommandType = CommandType.StoredProcedure
Dim dtToReturn As DataTable = new DataTable("idvmakro_office_vorlage")
Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

' // Use base class' connection object
scmCmdToExecute.Connection = m_scoMainConnection

Try
scmCmdToExecute.Parameters.Add(new SqlParameter("@ioffice_vorlagenr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iOffice_vorlagenr))
scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

If m_bMainConnectionIsCreatedLocal Then
' // Open connection.
m_scoMainConnection.Open()
Else
If m_cpMainConnectionProvider.bIsTransactionPending Then
scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
End If
End If

' // Execute query.
sdaAdapter.Fill(dtToReturn)
m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
' // Throw error.
Throw New Exception("Stored Procedure 'pr_idvmakro_office_vorlage_SelectAllWoffice_vorlagenrLogic' reported the ErrorCode: " & m_iErrorCode.ToString())
End If

Return dtToReturn
Catch ex As Exception
' // some error occured. Bubble it to caller and encapsulate Exception object
Throw New Exception("clsIdvmakro_office_vorlage::SelectAllWoffice_vorlagenrLogic::Error occured.", ex)
Finally
If m_bMainConnectionIsCreatedLocal Then
' // Close connection.
m_scoMainConnection.Close()
End If
scmCmdToExecute.Dispose()
sdaAdapter.Dispose()
End Try
End Function

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsIdvmakro_office_vorlage Class
clsIdvmakro_office_vorlage clsIdvmakro_office_vorlage Members


clsIdvmakro_office_vorlage.SelectOne Method

clsIdvmakro_office_vorlage.SelectOne Method

clsIdvmakro_office_vorlage.SelectOne Method | Previous topic | Next topic
clsIdvmakro_office_vorlage.SelectOne Method | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Overrides Function SelectOne() As DataTable

C#

public override DataTable SelectOne()

C++

public:
DataTable^ SelectOne()

JScript

public function SelectOne() : DataTable;

Source code

Visual Basic

Copy Code Copy Code

Overrides Public Function SelectOne() As DataTable
Dim scmCmdToExecute As SqlCommand = New SqlCommand()
scmCmdToExecute.CommandText = "dbo.[pr_idvmakro_office_vorlage_SelectOne]"
scmCmdToExecute.CommandType = CommandType.StoredProcedure
Dim dtToReturn As DataTable = new DataTable("idvmakro_office_vorlage")
Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

' // Use base class' connection object
scmCmdToExecute.Connection = m_scoMainConnection

Try
scmCmdToExecute.Parameters.Add(new SqlParameter("@iidvmakroofficevorlagenr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iIdvmakroofficevorlagenr))
scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

If m_bMainConnectionIsCreatedLocal Then
' // Open connection.
m_scoMainConnection.Open()
Else
If m_cpMainConnectionProvider.bIsTransactionPending Then
scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
End If
End If

' // Execute query.
sdaAdapter.Fill(dtToReturn)
m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
' // Throw error.
Throw New Exception("Stored Procedure 'pr_idvmakro_office_vorlage_SelectOne' reported the ErrorCode: " & m_iErrorCode.ToString())
End If

If dtToReturn.Rows.Count > 0 Then
m_iIdvmakroofficevorlagenr = New SqlInt32(CType(dtToReturn.Rows(0)("idvmakroofficevorlagenr"), Integer))
m_iReihenfolge = New SqlInt32(CType(dtToReturn.Rows(0)("reihenfolge"), Integer))
If dtToReturn.Rows(0)("mandantnr") Is System.DBNull.Value Then
m_iMandantnr = SqlInt32.Null
Else
m_iMandantnr = New SqlInt32(CType(dtToReturn.Rows(0)("mandantnr"), Integer))
End If
If dtToReturn.Rows(0)("aktiv") Is System.DBNull.Value Then
m_bAktiv = SqlBoolean.Null
Else
m_bAktiv = New SqlBoolean(CType(dtToReturn.Rows(0)("aktiv"), Boolean))
End If
If dtToReturn.Rows(0)("erstellt_am") Is System.DBNull.Value Then
m_daErstellt_am = SqlDateTime.Null
Else
m_daErstellt_am = New SqlDateTime(CType(dtToReturn.Rows(0)("erstellt_am"), Date))
End If
If dtToReturn.Rows(0)("mutiert_am") Is System.DBNull.Value Then
m_daMutiert_am = SqlDateTime.Null
Else
m_daMutiert_am = New SqlDateTime(CType(dtToReturn.Rows(0)("mutiert_am"), Date))
End If
m_iMutierer = New SqlInt32(CType(dtToReturn.Rows(0)("mutierer"), Integer))
If dtToReturn.Rows(0)("office_vorlagenr") Is System.DBNull.Value Then
m_iOffice_vorlagenr = SqlInt32.Null
Else
m_iOffice_vorlagenr = New SqlInt32(CType(dtToReturn.Rows(0)("office_vorlagenr"), Integer))
End If
If dtToReturn.Rows(0)("idvmakronr") Is System.DBNull.Value Then
m_iIdvmakronr = SqlInt32.Null
Else
m_iIdvmakronr = New SqlInt32(CType(dtToReturn.Rows(0)("idvmakronr"), Integer))
End If
End If
Return dtToReturn
Catch ex As Exception
' // some error occured. Bubble it to caller and encapsulate Exception object
Throw New Exception("clsIdvmakro_office_vorlage::SelectOne::Error occured.", ex)
Finally
If m_bMainConnectionIsCreatedLocal Then
' // Close connection.
m_scoMainConnection.Close()
End If
scmCmdToExecute.Dispose()
sdaAdapter.Dispose()
End Try
End Function

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsIdvmakro_office_vorlage Class
clsIdvmakro_office_vorlage clsIdvmakro_office_vorlage Members


clsIdvmakro_office_vorlage.Update Method

clsIdvmakro_office_vorlage.Update Method

clsIdvmakro_office_vorlage.Update Method | Previous topic | Next topic
clsIdvmakro_office_vorlage.Update Method | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Overrides Function Update() As Boolean

C#

public override bool Update()

C++

public:
bool Update()

JScript

public function Update() : boolean;

Source code

Visual Basic

Copy Code Copy Code

Overrides Public Function Update() As Boolean
Dim scmCmdToExecute As SqlCommand = New SqlCommand()
scmCmdToExecute.CommandText = "dbo.[pr_idvmakro_office_vorlage_Update]"
scmCmdToExecute.CommandType = CommandType.StoredProcedure

' // Use base class' connection object
scmCmdToExecute.Connection = m_scoMainConnection

Try
scmCmdToExecute.Parameters.Add(New SqlParameter("@iidvmakroofficevorlagenr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iIdvmakroofficevorlagenr))
scmCmdToExecute.Parameters.Add(New SqlParameter("@ireihenfolge", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iReihenfolge))
scmCmdToExecute.Parameters.Add(New SqlParameter("@imandantnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMandantnr))
scmCmdToExecute.Parameters.Add(New SqlParameter("@baktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bAktiv))
scmCmdToExecute.Parameters.Add(New SqlParameter("@daerstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daErstellt_am))
scmCmdToExecute.Parameters.Add(New SqlParameter("@damutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daMutiert_am))
scmCmdToExecute.Parameters.Add(New SqlParameter("@imutierer", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
scmCmdToExecute.Parameters.Add(New SqlParameter("@ioffice_vorlagenr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iOffice_vorlagenr))
scmCmdToExecute.Parameters.Add(New SqlParameter("@iidvmakronr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iIdvmakronr))
scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

If m_bMainConnectionIsCreatedLocal Then
' // Open connection.
m_scoMainConnection.Open()
Else
If m_cpMainConnectionProvider.bIsTransactionPending Then
scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
End If
End If

' // Execute query.
scmCmdToExecute.ExecuteNonQuery()
m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
' // Throw error.
Throw New Exception("Stored Procedure 'pr_idvmakro_office_vorlage_Update' reported the ErrorCode: " & m_iErrorCode.ToString())
End If

Return True
Catch ex As Exception
' // some error occured. Bubble it to caller and encapsulate Exception object
Throw New Exception("clsIdvmakro_office_vorlage::Update::Error occured.", ex)
Finally
If m_bMainConnectionIsCreatedLocal Then
' // Close connection.
m_scoMainConnection.Close()
End If
scmCmdToExecute.Dispose()
End Try
End Function

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsIdvmakro_office_vorlage Class
clsIdvmakro_office_vorlage clsIdvmakro_office_vorlage Members


clsIdvmakro_office_vorlage.UpdateAllWidvmakronrLogic Method

clsIdvmakro_office_vorlage.UpdateAllWidvmakronrLogic Method

clsIdvmakro_office_vorlage.UpdateAllWidvmakronrLogic Method | Previous topic | Next topic
clsIdvmakro_office_vorlage.UpdateAllWidvmakronrLogic Method | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Function UpdateAllWidvmakronrLogic() As Boolean

C#

public bool UpdateAllWidvmakronrLogic()

C++

public:
bool UpdateAllWidvmakronrLogic()

JScript

public function UpdateAllWidvmakronrLogic() : boolean;

Source code

Visual Basic

Copy Code Copy Code

Public Function UpdateAllWidvmakronrLogic() As Boolean
Dim scmCmdToExecute As SqlCommand = New SqlCommand()
scmCmdToExecute.CommandText = "dbo.[pr_idvmakro_office_vorlage_UpdateAllWidvmakronrLogic]"
scmCmdToExecute.CommandType = CommandType.StoredProcedure

' // Use base class' connection object
scmCmdToExecute.Connection = m_scoMainConnection

Try
scmCmdToExecute.Parameters.Add(new SqlParameter("@iidvmakronr", SqlDbType.Int, 4, ParameterDirection.Input, false, 10, 0, "", DataRowVersion.Proposed, m_iIdvmakronr))
scmCmdToExecute.Parameters.Add(new SqlParameter("@iidvmakronrOld", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iIdvmakronrOld))
scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

If m_bMainConnectionIsCreatedLocal Then
' // Open connection.
m_scoMainConnection.Open()
Else
If m_cpMainConnectionProvider.bIsTransactionPending Then
scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
End If
End If

' // Execute query.
scmCmdToExecute.ExecuteNonQuery()
m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
' // Throw error.
Throw New Exception("Stored Procedure 'pr_idvmakro_office_vorlage_UpdateAllWidvmakronrLogic' reported the ErrorCode: " & m_iErrorCode.ToString())
End If

Return True
Catch ex As Exception
' // some error occured. Bubble it to caller and encapsulate Exception object
Throw New Exception("clsIdvmakro_office_vorlage::UpdateAllWidvmakronrLogic::Error occured.", ex)
Finally
If m_bMainConnectionIsCreatedLocal Then
' // Close connection.
m_scoMainConnection.Close()
End If
scmCmdToExecute.Dispose()
End Try
End Function

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsIdvmakro_office_vorlage Class
clsIdvmakro_office_vorlage clsIdvmakro_office_vorlage Members


clsIdvmakro_office_vorlage.UpdateAllWoffice_vorlagenrLogic Method

clsIdvmakro_office_vorlage.UpdateAllWoffice_vorlagenrLogic Method

clsIdvmakro_office_vorlage.UpdateAllWoffice_vorlagenrLogic Method | Previous topic | Next topic
clsIdvmakro_office_vorlage.UpdateAllWoffice_vorlagenrLogic Method | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Function UpdateAllWoffice_vorlagenrLogic() As Boolean

C#

public bool UpdateAllWoffice_vorlagenrLogic()

C++

public:
bool UpdateAllWoffice_vorlagenrLogic()

JScript

public function UpdateAllWoffice_vorlagenrLogic() : boolean;

Source code

Visual Basic

Copy Code Copy Code

Public Function UpdateAllWoffice_vorlagenrLogic() As Boolean
Dim scmCmdToExecute As SqlCommand = New SqlCommand()
scmCmdToExecute.CommandText = "dbo.[pr_idvmakro_office_vorlage_UpdateAllWoffice_vorlagenrLogic]"
scmCmdToExecute.CommandType = CommandType.StoredProcedure

' // Use base class' connection object
scmCmdToExecute.Connection = m_scoMainConnection

Try
scmCmdToExecute.Parameters.Add(New SqlParameter("@ioffice_vorlagenr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iOffice_vorlagenr))
scmCmdToExecute.Parameters.Add(New SqlParameter("@ioffice_vorlagenrOld", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iOffice_vorlagenrOld))
scmCmdToExecute.Parameters.Add(New SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

If m_bMainConnectionIsCreatedLocal Then
' // Open connection.
m_scoMainConnection.Open()
Else
If m_cpMainConnectionProvider.bIsTransactionPending Then
scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
End If
End If

' // Execute query.
scmCmdToExecute.ExecuteNonQuery()
m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
' // Throw error.
Throw New Exception("Stored Procedure 'pr_idvmakro_office_vorlage_UpdateAllWoffice_vorlagenrLogic' reported the ErrorCode: " & m_iErrorCode.ToString())
End If

Return True
Catch ex As Exception
' // some error occured. Bubble it to caller and encapsulate Exception object
Throw New Exception("clsIdvmakro_office_vorlage::UpdateAllWoffice_vorlagenrLogic::Error occured.", ex)
Finally
If m_bMainConnectionIsCreatedLocal Then
' // Close connection.
m_scoMainConnection.Close()
End If
scmCmdToExecute.Dispose()
End Try
End Function

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsIdvmakro_office_vorlage Class
clsIdvmakro_office_vorlage clsIdvmakro_office_vorlage Members


clsIdvmakro_office_vorlage Fields

clsIdvmakro_office_vorlage Fields

clsIdvmakro_office_vorlage Fields | Previous topic | Next topic
clsIdvmakro_office_vorlage Fields | Previous topic | Next topic

Fields

 | Name | Description
Supported by the .NET Compact Framework. | m_bAktiv |
Supported by the .NET Compact Framework. | m_bMainConnectionIsCreatedLocal | (inherited from clsDBInteractionBase ).
Supported by the .NET Compact Framework. | m_cpMainConnectionProvider | (inherited from clsDBInteractionBase ).
Supported by the .NET Compact Framework. | m_daErstellt_am |
Supported by the .NET Compact Framework. | m_daMutiert_am |
Supported by the .NET Compact Framework. | m_iErrorCode | (inherited from clsDBInteractionBase ).
Supported by the .NET Compact Framework. | m_iIdvmakronr |
Supported by the .NET Compact Framework. | m_iIdvmakronrOld |
Supported by the .NET Compact Framework. | m_iIdvmakroofficevorlagenr |
Supported by the .NET Compact Framework. | m_iMandantnr |
Supported by the .NET Compact Framework. | m_iMutierer |
Supported by the .NET Compact Framework. | m_iOffice_vorlagenr |
Supported by the .NET Compact Framework. | m_iOffice_vorlagenrOld |
Supported by the .NET Compact Framework. | m_iReihenfolge |
Supported by the .NET Compact Framework. | m_scoMainConnection | (inherited from clsDBInteractionBase ).

Top

See Also

Reference

clsIdvmakro_office_vorlage Class


m_bAktiv Field

m_bAktiv Field

m_bAktiv Field | Previous topic | Next topic
m_bAktiv Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_bAktiv As SqlBoolean

C#

private SqlBoolean m_bAktiv

C++

private:
SqlBoolean m_bAktiv;

JScript

private m_bAktiv : SqlBoolean

Source code

Visual Basic

Copy Code Copy Code

Private m_bAktiv As SqlBoolean

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsIdvmakro_office_vorlage Class
clsIdvmakro_office_vorlage clsIdvmakro_office_vorlage Members


m_daErstellt_am Field

m_daErstellt_am Field

m_daErstellt_am Field | Previous topic | Next topic
m_daErstellt_am Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_daErstellt_am As SqlDateTime

C#

private SqlDateTime m_daErstellt_am

C++

private:
SqlDateTime m_daErstellt_am;

JScript

private m_daErstellt_am : SqlDateTime

Source code

Visual Basic

Copy Code Copy Code

Private m_daErstellt_am, m_daMutiert_am As SqlDateTime

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsIdvmakro_office_vorlage Class
clsIdvmakro_office_vorlage clsIdvmakro_office_vorlage Members


m_daMutiert_am Field

m_daMutiert_am Field

m_daMutiert_am Field | Previous topic | Next topic
m_daMutiert_am Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_daMutiert_am As SqlDateTime

C#

private SqlDateTime m_daMutiert_am

C++

private:
SqlDateTime m_daMutiert_am;

JScript

private m_daMutiert_am : SqlDateTime

Source code

Visual Basic

Copy Code Copy Code

Private m_daErstellt_am, m_daMutiert_am As SqlDateTime

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsIdvmakro_office_vorlage Class
clsIdvmakro_office_vorlage clsIdvmakro_office_vorlage Members


m_iIdvmakronr Field

m_iIdvmakronr Field

m_iIdvmakronr Field | Previous topic | Next topic
m_iIdvmakronr Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_iIdvmakronr As SqlInt32

C#

private SqlInt32 m_iIdvmakronr

C++

private:
SqlInt32 m_iIdvmakronr;

JScript

private m_iIdvmakronr : SqlInt32

Source code

Visual Basic

Copy Code Copy Code

Private m_iMutierer, m_iOffice_vorlagenr, m_iOffice_vorlagenrOld, m_iIdvmakronr, m_iIdvmakronrOld, m_iMandantnr, m_iReihenfolge, m_iIdvmakroofficevorlagenr As SqlInt32

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsIdvmakro_office_vorlage Class
clsIdvmakro_office_vorlage clsIdvmakro_office_vorlage Members


m_iIdvmakronrOld Field

m_iIdvmakronrOld Field

m_iIdvmakronrOld Field | Previous topic | Next topic
m_iIdvmakronrOld Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_iIdvmakronrOld As SqlInt32

C#

private SqlInt32 m_iIdvmakronrOld

C++

private:
SqlInt32 m_iIdvmakronrOld;

JScript

private m_iIdvmakronrOld : SqlInt32

Source code

Visual Basic

Copy Code Copy Code

Private m_iMutierer, m_iOffice_vorlagenr, m_iOffice_vorlagenrOld, m_iIdvmakronr, m_iIdvmakronrOld, m_iMandantnr, m_iReihenfolge, m_iIdvmakroofficevorlagenr As SqlInt32

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsIdvmakro_office_vorlage Class
clsIdvmakro_office_vorlage clsIdvmakro_office_vorlage Members


m_iIdvmakroofficevorlagenr Field

m_iIdvmakroofficevorlagenr Field

m_iIdvmakroofficevorlagenr Field | Previous topic | Next topic
m_iIdvmakroofficevorlagenr Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_iIdvmakroofficevorlagenr As SqlInt32

C#

private SqlInt32 m_iIdvmakroofficevorlagenr

C++

private:
SqlInt32 m_iIdvmakroofficevorlagenr;

JScript

private m_iIdvmakroofficevorlagenr : SqlInt32

Source code

Visual Basic

Copy Code Copy Code

Private m_iMutierer, m_iOffice_vorlagenr, m_iOffice_vorlagenrOld, m_iIdvmakronr, m_iIdvmakronrOld, m_iMandantnr, m_iReihenfolge, m_iIdvmakroofficevorlagenr As SqlInt32

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsIdvmakro_office_vorlage Class
clsIdvmakro_office_vorlage clsIdvmakro_office_vorlage Members


m_iMandantnr Field

m_iMandantnr Field

m_iMandantnr Field | Previous topic | Next topic
m_iMandantnr Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_iMandantnr As SqlInt32

C#

private SqlInt32 m_iMandantnr

C++

private:
SqlInt32 m_iMandantnr;

JScript

private m_iMandantnr : SqlInt32

Source code

Visual Basic

Copy Code Copy Code

Private m_iMutierer, m_iOffice_vorlagenr, m_iOffice_vorlagenrOld, m_iIdvmakronr, m_iIdvmakronrOld, m_iMandantnr, m_iReihenfolge, m_iIdvmakroofficevorlagenr As SqlInt32

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsIdvmakro_office_vorlage Class
clsIdvmakro_office_vorlage clsIdvmakro_office_vorlage Members


m_iMutierer Field

m_iMutierer Field

m_iMutierer Field | Previous topic | Next topic
m_iMutierer Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_iMutierer As SqlInt32

C#

private SqlInt32 m_iMutierer

C++

private:
SqlInt32 m_iMutierer;

JScript

private m_iMutierer : SqlInt32

Source code

Visual Basic

Copy Code Copy Code

Private m_iMutierer, m_iOffice_vorlagenr, m_iOffice_vorlagenrOld, m_iIdvmakronr, m_iIdvmakronrOld, m_iMandantnr, m_iReihenfolge, m_iIdvmakroofficevorlagenr As SqlInt32

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsIdvmakro_office_vorlage Class
clsIdvmakro_office_vorlage clsIdvmakro_office_vorlage Members


m_iOffice_vorlagenr Field

m_iOffice_vorlagenr Field

m_iOffice_vorlagenr Field | Previous topic | Next topic
m_iOffice_vorlagenr Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_iOffice_vorlagenr As SqlInt32

C#

private SqlInt32 m_iOffice_vorlagenr

C++

private:
SqlInt32 m_iOffice_vorlagenr;

JScript

private m_iOffice_vorlagenr : SqlInt32

Source code

Visual Basic

Copy Code Copy Code

Private m_iMutierer, m_iOffice_vorlagenr, m_iOffice_vorlagenrOld, m_iIdvmakronr, m_iIdvmakronrOld, m_iMandantnr, m_iReihenfolge, m_iIdvmakroofficevorlagenr As SqlInt32

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsIdvmakro_office_vorlage Class
clsIdvmakro_office_vorlage clsIdvmakro_office_vorlage Members


m_iOffice_vorlagenrOld Field

m_iOffice_vorlagenrOld Field

m_iOffice_vorlagenrOld Field | Previous topic | Next topic
m_iOffice_vorlagenrOld Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_iOffice_vorlagenrOld As SqlInt32

C#

private SqlInt32 m_iOffice_vorlagenrOld

C++

private:
SqlInt32 m_iOffice_vorlagenrOld;

JScript

private m_iOffice_vorlagenrOld : SqlInt32

Source code

Visual Basic

Copy Code Copy Code

Private m_iMutierer, m_iOffice_vorlagenr, m_iOffice_vorlagenrOld, m_iIdvmakronr, m_iIdvmakronrOld, m_iMandantnr, m_iReihenfolge, m_iIdvmakroofficevorlagenr As SqlInt32

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsIdvmakro_office_vorlage Class
clsIdvmakro_office_vorlage clsIdvmakro_office_vorlage Members


m_iReihenfolge Field

m_iReihenfolge Field

m_iReihenfolge Field | Previous topic | Next topic
m_iReihenfolge Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_iReihenfolge As SqlInt32

C#

private SqlInt32 m_iReihenfolge

C++

private:
SqlInt32 m_iReihenfolge;

JScript

private m_iReihenfolge : SqlInt32

Source code

Visual Basic

Copy Code Copy Code

Private m_iMutierer, m_iOffice_vorlagenr, m_iOffice_vorlagenrOld, m_iIdvmakronr, m_iIdvmakronrOld, m_iMandantnr, m_iReihenfolge, m_iIdvmakroofficevorlagenr As SqlInt32

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsIdvmakro_office_vorlage Class
clsIdvmakro_office_vorlage clsIdvmakro_office_vorlage Members


clsJournaleintrag Class

clsJournaleintrag Class

clsJournaleintrag Class | Previous topic | Next topic
clsJournaleintrag Class | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Class clsJournaleintrag
Inherits clsDBInteractionBase

C#

public class clsJournaleintrag : clsDBInteractionBase

C++

public ref class clsJournaleintrag : public clsDBInteractionBase^

JScript

public class clsJournaleintrag
extends clsDBInteractionBase

Inheritance Hierarchy

System.Object

EDKB12WS.edokadb.clsDBInteractionBase

EDKB12WS.edokadb.clsJournaleintrag

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsJournaleintrag Members


clsJournaleintrag Members

clsJournaleintrag Members

clsJournaleintrag Members | Previous topic | Next topic
clsJournaleintrag Members | Previous topic | Next topic

The following tables list the members exposed by the clsJournaleintrag type.

Public Constructors

 | Name | Description
Supported by the .NET Compact Framework. | clsJournaleintrag Constructor |

Top

Public Properties

 | Name | Description
Supported by the .NET Compact Framework. | cpMainConnectionProvider | (inherited from clsDBInteractionBase ).
Supported by the .NET Compact Framework. | daDatumzeit |
Supported by the .NET Compact Framework. | iErrorCode | (inherited from clsDBInteractionBase ).
Supported by the .NET Compact Framework. | iJournaleintragnr |
Supported by the .NET Compact Framework. | iJournalnr |
Supported by the .NET Compact Framework. | sConnectionString | (inherited from clsDBInteractionBase ).
Supported by the .NET Compact Framework. | sEintrag |

Top

Public Methods

 | Name | Description
Supported by the .NET Compact Framework. | Delete |
Supported by the .NET Compact Framework. | Dispose | (Overloaded) (inherited from clsDBInteractionBase ).
Public method | Equals | (Overloaded) (inherited from Object).
Public method | GetHashCode | (inherited from Object).
Public method | GetType | (Overloaded) (inherited from Object).
Supported by the .NET Compact Framework. | Insert |
 | ReferenceEquals | (inherited from Object).
Supported by the .NET Compact Framework. | SelectAll |
Supported by the .NET Compact Framework. | SelectOne |
Public method | ToString | (inherited from Object).
Supported by the .NET Compact Framework. | Update |

Top

Protected Methods

 | Name | Description
Protected method | Finalize | (inherited from Object).
Protected method | MemberwiseClone | (Overloaded) (inherited from Object).

Top

Fields

 | Name | Description
Supported by the .NET Compact Framework. | m_bMainConnectionIsCreatedLocal | (inherited from clsDBInteractionBase ).
Supported by the .NET Compact Framework. | m_cpMainConnectionProvider | (inherited from clsDBInteractionBase ).
Supported by the .NET Compact Framework. | m_daDatumzeit |
Supported by the .NET Compact Framework. | m_iErrorCode | (inherited from clsDBInteractionBase ).
Supported by the .NET Compact Framework. | m_iJournaleintragnr |
Supported by the .NET Compact Framework. | m_iJournalnr |
Supported by the .NET Compact Framework. | m_sEintrag |
Supported by the .NET Compact Framework. | m_scoMainConnection | (inherited from clsDBInteractionBase ).

Top

See Also

Reference

clsJournaleintrag Class


clsJournaleintrag Constructor

clsJournaleintrag Constructor

clsJournaleintrag Constructor | Previous topic | Next topic
clsJournaleintrag Constructor | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Sub New()

C#

public clsJournaleintrag()

C++

public:
clsJournaleintrag()

JScript

public function clsJournaleintrag();

Source code

Visual Basic

Copy Code Copy Code

Public Sub New()
' // Nothing for now.
End Sub

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsJournaleintrag Class
clsJournaleintrag clsJournaleintrag Members


clsJournaleintrag Properties

clsJournaleintrag Properties

clsJournaleintrag Properties | Previous topic | Next topic
clsJournaleintrag Properties | Previous topic | Next topic

Public Properties

 | Name | Description
Supported by the .NET Compact Framework. | cpMainConnectionProvider | (inherited from clsDBInteractionBase ).
Supported by the .NET Compact Framework. | daDatumzeit |
Supported by the .NET Compact Framework. | iErrorCode | (inherited from clsDBInteractionBase ).
Supported by the .NET Compact Framework. | iJournaleintragnr |
Supported by the .NET Compact Framework. | iJournalnr |
Supported by the .NET Compact Framework. | sConnectionString | (inherited from clsDBInteractionBase ).
Supported by the .NET Compact Framework. | sEintrag |

Top

See Also

Reference

clsJournaleintrag Class


clsJournaleintrag.daDatumzeit Property

clsJournaleintrag.daDatumzeit Property

clsJournaleintrag.daDatumzeit Property | Previous topic | Next topic
clsJournaleintrag.daDatumzeit Property | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property daDatumzeit() As SqlDateTime

C#

public SqlDateTime daDatumzeit {get; set;}

C++

public:
property SqlDateTime daDatumzeit {
SqlDateTime get( );
void set(
SqlDateTime value
);
}

JScript

public function get daDatumzeit() : SqlDateTime;
public function set daDatumzeit(value : SqlDateTime);

Source code

Visual Basic

Copy Code Copy Code

Public Property [daDatumzeit]() As SqlDateTime
Get
Return m_daDatumzeit
End Get
Set(ByVal Value As SqlDateTime)
m_daDatumzeit = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsJournaleintrag Class
clsJournaleintrag clsJournaleintrag Members


clsJournaleintrag.iJournaleintragnr Property

clsJournaleintrag.iJournaleintragnr Property

clsJournaleintrag.iJournaleintragnr Property | Previous topic | Next topic
clsJournaleintrag.iJournaleintragnr Property | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property iJournaleintragnr() As SqlInt32

C#

public SqlInt32 iJournaleintragnr {get; set;}

C++

public:
property SqlInt32 iJournaleintragnr {
SqlInt32 get( );
void set(
SqlInt32 value
);
}

JScript

public function get iJournaleintragnr() : SqlInt32;
public function set iJournaleintragnr(value : SqlInt32);

Source code

Visual Basic

Copy Code Copy Code

Public Property [iJournaleintragnr]() As SqlInt32
Get
Return m_iJournaleintragnr
End Get
Set(ByVal Value As SqlInt32)
Dim iJournaleintragnrTmp As SqlInt32 = Value
If iJournaleintragnrTmp.IsNull Then
Throw New ArgumentOutOfRangeException("iJournaleintragnr", "iJournaleintragnr can't be NULL")
End If
m_iJournaleintragnr = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsJournaleintrag Class
clsJournaleintrag clsJournaleintrag Members


clsJournaleintrag.iJournalnr Property

clsJournaleintrag.iJournalnr Property

clsJournaleintrag.iJournalnr Property | Previous topic | Next topic
clsJournaleintrag.iJournalnr Property | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property iJournalnr() As SqlInt32

C#

public SqlInt32 iJournalnr {get; set;}

C++

public:
property SqlInt32 iJournalnr {
SqlInt32 get( );
void set(
SqlInt32 value
);
}

JScript

public function get iJournalnr() : SqlInt32;
public function set iJournalnr(value : SqlInt32);

Source code

Visual Basic

Copy Code Copy Code

Public Property [iJournalnr]() As SqlInt32
Get
Return m_iJournalnr
End Get
Set(ByVal Value As SqlInt32)
m_iJournalnr = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsJournaleintrag Class
clsJournaleintrag clsJournaleintrag Members


clsJournaleintrag.sEintrag Property

clsJournaleintrag.sEintrag Property

clsJournaleintrag.sEintrag Property | Previous topic | Next topic
clsJournaleintrag.sEintrag Property | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property sEintrag() As SqlString

C#

public SqlString sEintrag {get; set;}

C++

public:
property SqlString sEintrag {
SqlString get( );
void set(
SqlString value
);
}

JScript

public function get sEintrag() : SqlString;
public function set sEintrag(value : SqlString);

Source code

Visual Basic

Copy Code Copy Code

Public Property [sEintrag]() As SqlString
Get
Return m_sEintrag
End Get
Set(ByVal Value As SqlString)
m_sEintrag = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsJournaleintrag Class
clsJournaleintrag clsJournaleintrag Members


clsJournaleintrag Methods

clsJournaleintrag Methods

clsJournaleintrag Methods | Previous topic | Next topic
clsJournaleintrag Methods | Previous topic | Next topic

Public Methods

 | Name | Description
Supported by the .NET Compact Framework. | Delete |
Supported by the .NET Compact Framework. | Dispose | (Overloaded) (inherited from clsDBInteractionBase ).
Public method | Equals | (Overloaded) (inherited from Object).
Public method | GetHashCode | (inherited from Object).
Public method | GetType | (Overloaded) (inherited from Object).
Supported by the .NET Compact Framework. | Insert |
 | ReferenceEquals | (inherited from Object).
Supported by the .NET Compact Framework. | SelectAll |
Supported by the .NET Compact Framework. | SelectOne |
Public method | ToString | (inherited from Object).
Supported by the .NET Compact Framework. | Update |

Top

Protected Methods

 | Name | Description
Protected method | Finalize | (inherited from Object).
Protected method | MemberwiseClone | (Overloaded) (inherited from Object).

Top

See Also

Reference

clsJournaleintrag Class


clsJournaleintrag.Delete Method

clsJournaleintrag.Delete Method

clsJournaleintrag.Delete Method | Previous topic | Next topic
clsJournaleintrag.Delete Method | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Overrides Function Delete() As Boolean

C#

public override bool Delete()

C++

public:
bool Delete()

JScript

public function Delete() : boolean;

Source code

Visual Basic

Copy Code Copy Code

Overrides Public Function Delete() As Boolean
Dim scmCmdToExecute As SqlCommand = New SqlCommand()
scmCmdToExecute.CommandText = "dbo.[pr_Journaleintrag_Delete]"
scmCmdToExecute.CommandType = CommandType.StoredProcedure

' // Use base class' connection object
scmCmdToExecute.Connection = m_scoMainConnection

Try
scmCmdToExecute.Parameters.Add(New SqlParameter("@ijournaleintragnr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iJournaleintragnr))
scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

If m_bMainConnectionIsCreatedLocal Then
' // Open connection.
m_scoMainConnection.Open()
Else
If m_cpMainConnectionProvider.bIsTransactionPending Then
scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
End If
End If

' // Execute query.
scmCmdToExecute.ExecuteNonQuery()
m_iErrorCode = scmCmdToExecute.Parameters.Item("@iErrorCode").Value

If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
' // Throw error.
Throw New Exception("Stored Procedure 'pr_Journaleintrag_Delete' reported the ErrorCode: " & m_iErrorCode.ToString())
End If

Return True
Catch ex As Exception
' // some error occured. Bubble it to caller and encapsulate Exception object
Throw New Exception("clsJournaleintrag::Delete::Error occured.", ex)
Finally
If m_bMainConnectionIsCreatedLocal Then
' // Close connection.
m_scoMainConnection.Close()
End If
scmCmdToExecute.Dispose()
End Try
End Function

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsJournaleintrag Class
clsJournaleintrag clsJournaleintrag Members


clsJournaleintrag.Insert Method

clsJournaleintrag.Insert Method

clsJournaleintrag.Insert Method | Previous topic | Next topic
clsJournaleintrag.Insert Method | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Overrides Function Insert() As Boolean

C#

public override bool Insert()

C++

public:
bool Insert()

JScript

public function Insert() : boolean;

Source code

Visual Basic

Copy Code Copy Code

Overrides Public Function Insert() As Boolean
Dim scmCmdToExecute As SqlCommand = New SqlCommand()
scmCmdToExecute.CommandText = "dbo.[pr_Journaleintrag_Insert]"
scmCmdToExecute.CommandType = CommandType.StoredProcedure

' // Use base class' connection object
scmCmdToExecute.Connection = m_scoMainConnection

Try
scmCmdToExecute.Parameters.Add(New SqlParameter("@ijournalnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iJournalnr))
scmCmdToExecute.Parameters.Add(New SqlParameter("@seintrag", SqlDbType.VarChar, 2048, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sEintrag))
scmCmdToExecute.Parameters.Add(New SqlParameter("@dadatumzeit", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daDatumzeit))
scmCmdToExecute.Parameters.Add(new SqlParameter("@ijournaleintragnr", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iJournaleintragnr))
scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

If m_bMainConnectionIsCreatedLocal Then
' // Open connection.
m_scoMainConnection.Open()
Else
If m_cpMainConnectionProvider.bIsTransactionPending Then
scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
End If
End If

' // Execute query.
scmCmdToExecute.ExecuteNonQuery()
m_iJournaleintragnr = scmCmdToExecute.Parameters.Item("@ijournaleintragnr").Value
m_iErrorCode = scmCmdToExecute.Parameters.Item("@iErrorCode").Value

If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
' // Throw error.
Throw New Exception("Stored Procedure 'pr_Journaleintrag_Insert' reported the ErrorCode: " & m_iErrorCode.ToString())
End If

Return True
Catch ex As Exception
' // some error occured. Bubble it to caller and encapsulate Exception object
Throw New Exception("clsJournaleintrag::Insert::Error occured.", ex)
Finally
If m_bMainConnectionIsCreatedLocal Then
' // Close connection.
m_scoMainConnection.Close()
End If
scmCmdToExecute.Dispose()
End Try
End Function

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsJournaleintrag Class
clsJournaleintrag clsJournaleintrag Members


clsJournaleintrag.SelectAll Method

clsJournaleintrag.SelectAll Method

clsJournaleintrag.SelectAll Method | Previous topic | Next topic
clsJournaleintrag.SelectAll Method | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Overrides Function SelectAll() As DataTable

C#

public override DataTable SelectAll()

C++

public:
DataTable^ SelectAll()

JScript

public function SelectAll() : DataTable;

Source code

Visual Basic

Copy Code Copy Code

Overrides Public Function SelectAll() As DataTable
Dim scmCmdToExecute As SqlCommand = New SqlCommand()
scmCmdToExecute.CommandText = "dbo.[pr_Journaleintrag_SelectAll]"
scmCmdToExecute.CommandType = CommandType.StoredProcedure
Dim dtToReturn As DataTable = new DataTable("Journaleintrag")
Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

' // Use base class' connection object
scmCmdToExecute.Connection = m_scoMainConnection

Try
scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

If m_bMainConnectionIsCreatedLocal Then
' // Open connection.
m_scoMainConnection.Open()
Else
If m_cpMainConnectionProvider.bIsTransactionPending Then
scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
End If
End If

' // Execute query.
sdaAdapter.Fill(dtToReturn)
m_iErrorCode = scmCmdToExecute.Parameters.Item("@iErrorCode").Value

If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
' // Throw error.
Throw New Exception("Stored Procedure 'pr_Journaleintrag_SelectAll' reported the ErrorCode: " & m_iErrorCode.ToString())
End If

Return dtToReturn
Catch ex As Exception
' // some error occured. Bubble it to caller and encapsulate Exception object
Throw New Exception("clsJournaleintrag::SelectAll::Error occured.", ex)
Finally
If m_bMainConnectionIsCreatedLocal Then
' // Close connection.
m_scoMainConnection.Close()
End If
scmCmdToExecute.Dispose()
sdaAdapter.Dispose()
End Try
End Function

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsJournaleintrag Class
clsJournaleintrag clsJournaleintrag Members


clsJournaleintrag.SelectOne Method

clsJournaleintrag.SelectOne Method

clsJournaleintrag.SelectOne Method | Previous topic | Next topic
clsJournaleintrag.SelectOne Method | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Overrides Function SelectOne() As DataTable

C#

public override DataTable SelectOne()

C++

public:
DataTable^ SelectOne()

JScript

public function SelectOne() : DataTable;

Source code

Visual Basic

Copy Code Copy Code

Overrides Public Function SelectOne() As DataTable
Dim scmCmdToExecute As SqlCommand = New SqlCommand()
scmCmdToExecute.CommandText = "dbo.[pr_Journaleintrag_SelectOne]"
scmCmdToExecute.CommandType = CommandType.StoredProcedure
Dim dtToReturn As DataTable = new DataTable("Journaleintrag")
Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

' // Use base class' connection object
scmCmdToExecute.Connection = m_scoMainConnection

Try
scmCmdToExecute.Parameters.Add(new SqlParameter("@ijournaleintragnr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iJournaleintragnr))
scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

If m_bMainConnectionIsCreatedLocal Then
' // Open connection.
m_scoMainConnection.Open()
Else
If m_cpMainConnectionProvider.bIsTransactionPending Then
scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
End If
End If

' // Execute query.
sdaAdapter.Fill(dtToReturn)
m_iErrorCode = scmCmdToExecute.Parameters.Item("@iErrorCode").Value

If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
' // Throw error.
Throw New Exception("Stored Procedure 'pr_Journaleintrag_SelectOne' reported the ErrorCode: " & m_iErrorCode.ToString())
End If

If dtToReturn.Rows.Count > 0 Then
m_iJournaleintragnr = New SqlInt32(CType(dtToReturn.Rows(0)("journaleintragnr"), Integer))
If dtToReturn.Rows(0)("journalnr") Is System.DBNull.Value Then
m_iJournalnr = SqlInt32.Null
Else
m_iJournalnr = New SqlInt32(CType(dtToReturn.Rows(0)("journalnr"), Integer))
End If
If dtToReturn.Rows(0)("eintrag") Is System.DBNull.Value Then
m_sEintrag = SqlString.Null
Else
m_sEintrag = New SqlString(CType(dtToReturn.Rows(0)("eintrag"), String))
End If
If dtToReturn.Rows(0)("datumzeit") Is System.DBNull.Value Then
m_daDatumzeit = SqlDateTime.Null
Else
m_daDatumzeit = New SqlDateTime(CType(dtToReturn.Rows(0)("datumzeit"), Date))
End If
End If
Return dtToReturn
Catch ex As Exception
' // some error occured. Bubble it to caller and encapsulate Exception object
Throw New Exception("clsJournaleintrag::SelectOne::Error occured.", ex)
Finally
If m_bMainConnectionIsCreatedLocal Then
' // Close connection.
m_scoMainConnection.Close()
End If
scmCmdToExecute.Dispose()
sdaAdapter.Dispose()
End Try
End Function

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsJournaleintrag Class
clsJournaleintrag clsJournaleintrag Members


clsJournaleintrag.Update Method

clsJournaleintrag.Update Method

clsJournaleintrag.Update Method | Previous topic | Next topic
clsJournaleintrag.Update Method | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Overrides Function Update() As Boolean

C#

public override bool Update()

C++

public:
bool Update()

JScript

public function Update() : boolean;

Source code

Visual Basic

Copy Code Copy Code

Overrides Public Function Update() As Boolean
Dim scmCmdToExecute As SqlCommand = New SqlCommand()
scmCmdToExecute.CommandText = "dbo.[pr_Journaleintrag_Update]"
scmCmdToExecute.CommandType = CommandType.StoredProcedure

' // Use base class' connection object
scmCmdToExecute.Connection = m_scoMainConnection

Try
scmCmdToExecute.Parameters.Add(New SqlParameter("@ijournaleintragnr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iJournaleintragnr))
scmCmdToExecute.Parameters.Add(New SqlParameter("@ijournalnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iJournalnr))
scmCmdToExecute.Parameters.Add(New SqlParameter("@seintrag", SqlDbType.VarChar, 2048, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sEintrag))
scmCmdToExecute.Parameters.Add(New SqlParameter("@dadatumzeit", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daDatumzeit))
scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

If m_bMainConnectionIsCreatedLocal Then
' // Open connection.
m_scoMainConnection.Open()
Else
If m_cpMainConnectionProvider.bIsTransactionPending Then
scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
End If
End If

' // Execute query.
scmCmdToExecute.ExecuteNonQuery()
m_iErrorCode = scmCmdToExecute.Parameters.Item("@iErrorCode").Value

If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
' // Throw error.
Throw New Exception("Stored Procedure 'pr_Journaleintrag_Update' reported the ErrorCode: " & m_iErrorCode.ToString())
End If

Return True
Catch ex As Exception
' // some error occured. Bubble it to caller and encapsulate Exception object
Throw New Exception("clsJournaleintrag::Update::Error occured.", ex)
Finally
If m_bMainConnectionIsCreatedLocal Then
' // Close connection.
m_scoMainConnection.Close()
End If
scmCmdToExecute.Dispose()
End Try
End Function

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsJournaleintrag Class
clsJournaleintrag clsJournaleintrag Members


clsJournaleintrag Fields

clsJournaleintrag Fields

clsJournaleintrag Fields | Previous topic | Next topic
clsJournaleintrag Fields | Previous topic | Next topic

Fields

 | Name | Description
Supported by the .NET Compact Framework. | m_bMainConnectionIsCreatedLocal | (inherited from clsDBInteractionBase ).
Supported by the .NET Compact Framework. | m_cpMainConnectionProvider | (inherited from clsDBInteractionBase ).
Supported by the .NET Compact Framework. | m_daDatumzeit |
Supported by the .NET Compact Framework. | m_iErrorCode | (inherited from clsDBInteractionBase ).
Supported by the .NET Compact Framework. | m_iJournaleintragnr |
Supported by the .NET Compact Framework. | m_iJournalnr |
Supported by the .NET Compact Framework. | m_sEintrag |
Supported by the .NET Compact Framework. | m_scoMainConnection | (inherited from clsDBInteractionBase ).

Top

See Also

Reference

clsJournaleintrag Class


m_daDatumzeit Field

m_daDatumzeit Field

m_daDatumzeit Field | Previous topic | Next topic
m_daDatumzeit Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_daDatumzeit As SqlDateTime

C#

private SqlDateTime m_daDatumzeit

C++

private:
SqlDateTime m_daDatumzeit;

JScript

private m_daDatumzeit : SqlDateTime

Source code

Visual Basic

Copy Code Copy Code

Private m_daDatumzeit As SqlDateTime

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsJournaleintrag Class
clsJournaleintrag clsJournaleintrag Members


m_iJournaleintragnr Field

m_iJournaleintragnr Field

m_iJournaleintragnr Field | Previous topic | Next topic
m_iJournaleintragnr Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_iJournaleintragnr As SqlInt32

C#

private SqlInt32 m_iJournaleintragnr

C++

private:
SqlInt32 m_iJournaleintragnr;

JScript

private m_iJournaleintragnr : SqlInt32

Source code

Visual Basic

Copy Code Copy Code

Private m_iJournalnr, m_iJournaleintragnr As SqlInt32

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsJournaleintrag Class
clsJournaleintrag clsJournaleintrag Members


m_iJournalnr Field

m_iJournalnr Field

m_iJournalnr Field | Previous topic | Next topic
m_iJournalnr Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_iJournalnr As SqlInt32

C#

private SqlInt32 m_iJournalnr

C++

private:
SqlInt32 m_iJournalnr;

JScript

private m_iJournalnr : SqlInt32

Source code

Visual Basic

Copy Code Copy Code

Private m_iJournalnr, m_iJournaleintragnr As SqlInt32

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsJournaleintrag Class
clsJournaleintrag clsJournaleintrag Members


m_sEintrag Field

m_sEintrag Field

m_sEintrag Field | Previous topic | Next topic
m_sEintrag Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_sEintrag As SqlString

C#

private SqlString m_sEintrag

C++

private:
SqlString m_sEintrag;

JScript

private m_sEintrag : SqlString

Source code

Visual Basic

Copy Code Copy Code

Private m_sEintrag As SqlString

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsJournaleintrag Class
clsJournaleintrag clsJournaleintrag Members


clsKey_tabelle Class

clsKey_tabelle Class

clsKey_tabelle Class | Previous topic | Next topic
clsKey_tabelle Class | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Class clsKey_tabelle
Inherits clsDBInteractionBase

C#

public class clsKey_tabelle : clsDBInteractionBase

C++

public ref class clsKey_tabelle : public clsDBInteractionBase^

JScript

public class clsKey_tabelle
extends clsDBInteractionBase

Inheritance Hierarchy

System.Object

EDKB12WS.edokadb.clsDBInteractionBase

EDKB12WS.edokadb.clsKey_tabelle

EDKB12WS.edokadb.clsMyKey_Tabelle

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsKey_tabelle Members


clsKey_tabelle Members

clsKey_tabelle Members

clsKey_tabelle Members | Previous topic | Next topic
clsKey_tabelle Members | Previous topic | Next topic

The following tables list the members exposed by the clsKey_tabelle type.

Public Constructors

 | Name | Description
Supported by the .NET Compact Framework. | clsKey_tabelle Constructor |

Top

Public Properties

 | Name | Description
Supported by the .NET Compact Framework. | bAktiv |
Supported by the .NET Compact Framework. | cpMainConnectionProvider | (inherited from clsDBInteractionBase ).
Supported by the .NET Compact Framework. | daErstellt_am |
Supported by the .NET Compact Framework. | daMutiert_am |
Supported by the .NET Compact Framework. | iErrorCode | (inherited from clsDBInteractionBase ).
Supported by the .NET Compact Framework. | iKey_wert |
Supported by the .NET Compact Framework. | iKeynr |
Supported by the .NET Compact Framework. | iMandantnr |
Supported by the .NET Compact Framework. | iMutierer |
Supported by the .NET Compact Framework. | sBeschreibung |
Supported by the .NET Compact Framework. | sConnectionString | (inherited from clsDBInteractionBase ).

Top

Public Methods

 | Name | Description
Supported by the .NET Compact Framework. | Delete |
Supported by the .NET Compact Framework. | Dispose | (Overloaded) (inherited from clsDBInteractionBase ).
Public method | Equals | (Overloaded) (inherited from Object).
Public method | GetHashCode | (inherited from Object).
Public method | GetType | (Overloaded) (inherited from Object).
Supported by the .NET Compact Framework. | Insert |
 | ReferenceEquals | (inherited from Object).
Supported by the .NET Compact Framework. | SelectAll |
Supported by the .NET Compact Framework. | SelectOne |
Public method | ToString | (inherited from Object).
Supported by the .NET Compact Framework. | Update |

Top

Protected Methods

 | Name | Description
Protected method | Finalize | (inherited from Object).
Protected method | MemberwiseClone | (Overloaded) (inherited from Object).

Top

Fields

 | Name | Description
Supported by the .NET Compact Framework. | m_bAktiv |
Supported by the .NET Compact Framework. | m_bMainConnectionIsCreatedLocal | (inherited from clsDBInteractionBase ).
Supported by the .NET Compact Framework. | m_cpMainConnectionProvider | (inherited from clsDBInteractionBase ).
Supported by the .NET Compact Framework. | m_daErstellt_am |
Supported by the .NET Compact Framework. | m_daMutiert_am |
Supported by the .NET Compact Framework. | m_iErrorCode | (inherited from clsDBInteractionBase ).
Supported by the .NET Compact Framework. | m_iKey_wert |
Supported by the .NET Compact Framework. | m_iKeynr |
Supported by the .NET Compact Framework. | m_iMandantnr |
Supported by the .NET Compact Framework. | m_iMutierer |
Supported by the .NET Compact Framework. | m_sBeschreibung |
Supported by the .NET Compact Framework. | m_scoMainConnection | (inherited from clsDBInteractionBase ).

Top

See Also

Reference

clsKey_tabelle Class


clsKey_tabelle Constructor

clsKey_tabelle Constructor

clsKey_tabelle Constructor | Previous topic | Next topic
clsKey_tabelle Constructor | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Sub New()

C#

public clsKey_tabelle()

C++

public:
clsKey_tabelle()

JScript

public function clsKey_tabelle();

Source code

Visual Basic

Copy Code Copy Code

Public Sub New()
' // Nothing for now.
End Sub

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsKey_tabelle Class
clsKey_tabelle clsKey_tabelle Members


clsKey_tabelle Properties

clsKey_tabelle Properties

clsKey_tabelle Properties | Previous topic | Next topic
clsKey_tabelle Properties | Previous topic | Next topic

Public Properties

 | Name | Description
Supported by the .NET Compact Framework. | bAktiv |
Supported by the .NET Compact Framework. | cpMainConnectionProvider | (inherited from clsDBInteractionBase ).
Supported by the .NET Compact Framework. | daErstellt_am |
Supported by the .NET Compact Framework. | daMutiert_am |
Supported by the .NET Compact Framework. | iErrorCode | (inherited from clsDBInteractionBase ).
Supported by the .NET Compact Framework. | iKey_wert |
Supported by the .NET Compact Framework. | iKeynr |
Supported by the .NET Compact Framework. | iMandantnr |
Supported by the .NET Compact Framework. | iMutierer |
Supported by the .NET Compact Framework. | sBeschreibung |
Supported by the .NET Compact Framework. | sConnectionString | (inherited from clsDBInteractionBase ).

Top

See Also

Reference

clsKey_tabelle Class


clsKey_tabelle.bAktiv Property

clsKey_tabelle.bAktiv Property

clsKey_tabelle.bAktiv Property | Previous topic | Next topic
clsKey_tabelle.bAktiv Property | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property bAktiv() As SqlBoolean

C#

public SqlBoolean bAktiv {get; set;}

C++

public:
property SqlBoolean bAktiv {
SqlBoolean get( );
void set(
SqlBoolean value
);
}

JScript

public function get bAktiv() : SqlBoolean;
public function set bAktiv(value : SqlBoolean);

Source code

Visual Basic

Copy Code Copy Code

Public Property [bAktiv]() As SqlBoolean
Get
Return m_bAktiv
End Get
Set(ByVal Value As SqlBoolean)
m_bAktiv = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsKey_tabelle Class
clsKey_tabelle clsKey_tabelle Members


clsKey_tabelle.daErstellt_am Property

clsKey_tabelle.daErstellt_am Property

clsKey_tabelle.daErstellt_am Property | Previous topic | Next topic
clsKey_tabelle.daErstellt_am Property | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property daErstellt_am() As SqlDateTime

C#

public SqlDateTime daErstellt_am {get; set;}

C++

public:
property SqlDateTime daErstellt_am {
SqlDateTime get( );
void set(
SqlDateTime value
);
}

JScript

public function get daErstellt_am() : SqlDateTime;
public function set daErstellt_am(value : SqlDateTime);

Source code

Visual Basic

Copy Code Copy Code

Public Property [daErstellt_am]() As SqlDateTime
Get
Return m_daErstellt_am
End Get
Set(ByVal Value As SqlDateTime)
m_daErstellt_am = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsKey_tabelle Class
clsKey_tabelle clsKey_tabelle Members


clsKey_tabelle.daMutiert_am Property

clsKey_tabelle.daMutiert_am Property

clsKey_tabelle.daMutiert_am Property | Previous topic | Next topic
clsKey_tabelle.daMutiert_am Property | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property daMutiert_am() As SqlDateTime

C#

public SqlDateTime daMutiert_am {get; set;}

C++

public:
property SqlDateTime daMutiert_am {
SqlDateTime get( );
void set(
SqlDateTime value
);
}

JScript

public function get daMutiert_am() : SqlDateTime;
public function set daMutiert_am(value : SqlDateTime);

Source code

Visual Basic

Copy Code Copy Code

Public Property [daMutiert_am]() As SqlDateTime
Get
Return m_daMutiert_am
End Get
Set(ByVal Value As SqlDateTime)
m_daMutiert_am = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsKey_tabelle Class
clsKey_tabelle clsKey_tabelle Members


clsKey_tabelle.iKey_wert Property

clsKey_tabelle.iKey_wert Property

clsKey_tabelle.iKey_wert Property | Previous topic | Next topic
clsKey_tabelle.iKey_wert Property | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property iKey_wert() As SqlInt32

C#

public SqlInt32 iKey_wert {get; set;}

C++

public:
property SqlInt32 iKey_wert {
SqlInt32 get( );
void set(
SqlInt32 value
);
}

JScript

public function get iKey_wert() : SqlInt32;
public function set iKey_wert(value : SqlInt32);

Source code

Visual Basic

Copy Code Copy Code

Public Property [iKey_wert]() As SqlInt32
Get
Return m_iKey_wert
End Get
Set(ByVal Value As SqlInt32)
Dim iKey_wertTmp As SqlInt32 = Value
If iKey_wertTmp.IsNull Then
Throw New ArgumentOutOfRangeException("iKey_wert", "iKey_wert can't be NULL")
End If
m_iKey_wert = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsKey_tabelle Class
clsKey_tabelle clsKey_tabelle Members


clsKey_tabelle.iKeynr Property

clsKey_tabelle.iKeynr Property

clsKey_tabelle.iKeynr Property | Previous topic | Next topic
clsKey_tabelle.iKeynr Property | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property iKeynr() As SqlInt32

C#

public SqlInt32 iKeynr {get; set;}

C++

public:
property SqlInt32 iKeynr {
SqlInt32 get( );
void set(
SqlInt32 value
);
}

JScript

public function get iKeynr() : SqlInt32;
public function set iKeynr(value : SqlInt32);

Source code

Visual Basic

Copy Code Copy Code

Public Property [iKeynr]() As SqlInt32
Get
Return m_iKeynr
End Get
Set(ByVal Value As SqlInt32)
Dim iKeynrTmp As SqlInt32 = Value
If iKeynrTmp.IsNull Then
Throw New ArgumentOutOfRangeException("iKeynr", "iKeynr can't be NULL")
End If
m_iKeynr = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsKey_tabelle Class
clsKey_tabelle clsKey_tabelle Members


clsKey_tabelle.iMandantnr Property

clsKey_tabelle.iMandantnr Property

clsKey_tabelle.iMandantnr Property | Previous topic | Next topic
clsKey_tabelle.iMandantnr Property | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property iMandantnr() As SqlInt32

C#

public SqlInt32 iMandantnr {get; set;}

C++

public:
property SqlInt32 iMandantnr {
SqlInt32 get( );
void set(
SqlInt32 value
);
}

JScript

public function get iMandantnr() : SqlInt32;
public function set iMandantnr(value : SqlInt32);

Source code

Visual Basic

Copy Code Copy Code

Public Property [iMandantnr]() As SqlInt32
Get
Return m_iMandantnr
End Get
Set(ByVal Value As SqlInt32)
m_iMandantnr = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsKey_tabelle Class
clsKey_tabelle clsKey_tabelle Members


clsKey_tabelle.iMutierer Property

clsKey_tabelle.iMutierer Property

clsKey_tabelle.iMutierer Property | Previous topic | Next topic
clsKey_tabelle.iMutierer Property | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property iMutierer() As SqlInt32

C#

public SqlInt32 iMutierer {get; set;}

C++

public:
property SqlInt32 iMutierer {
SqlInt32 get( );
void set(
SqlInt32 value
);
}

JScript

public function get iMutierer() : SqlInt32;
public function set iMutierer(value : SqlInt32);

Source code

Visual Basic

Copy Code Copy Code

Public Property [iMutierer]() As SqlInt32
Get
Return m_iMutierer
End Get
Set(ByVal Value As SqlInt32)
m_iMutierer = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsKey_tabelle Class
clsKey_tabelle clsKey_tabelle Members


clsKey_tabelle.sBeschreibung Property

clsKey_tabelle.sBeschreibung Property

clsKey_tabelle.sBeschreibung Property | Previous topic | Next topic
clsKey_tabelle.sBeschreibung Property | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property sBeschreibung() As SqlString

C#

public SqlString sBeschreibung {get; set;}

C++

public:
property SqlString sBeschreibung {
SqlString get( );
void set(
SqlString value
);
}

JScript

public function get sBeschreibung() : SqlString;
public function set sBeschreibung(value : SqlString);

Source code

Visual Basic

Copy Code Copy Code

Public Property [sBeschreibung]() As SqlString
Get
Return m_sBeschreibung
End Get
Set(ByVal Value As SqlString)
Dim sBeschreibungTmp As SqlString = Value
If sBeschreibungTmp.IsNull Then
Throw New ArgumentOutOfRangeException("sBeschreibung", "sBeschreibung can't be NULL")
End If
m_sBeschreibung = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsKey_tabelle Class
clsKey_tabelle clsKey_tabelle Members


clsKey_tabelle Methods

clsKey_tabelle Methods

clsKey_tabelle Methods | Previous topic | Next topic
clsKey_tabelle Methods | Previous topic | Next topic

Public Methods

 | Name | Description
Supported by the .NET Compact Framework. | Delete |
Supported by the .NET Compact Framework. | Dispose | (Overloaded) (inherited from clsDBInteractionBase ).
Public method | Equals | (Overloaded) (inherited from Object).
Public method | GetHashCode | (inherited from Object).
Public method | GetType | (Overloaded) (inherited from Object).
Supported by the .NET Compact Framework. | Insert |
 | ReferenceEquals | (inherited from Object).
Supported by the .NET Compact Framework. | SelectAll |
Supported by the .NET Compact Framework. | SelectOne |
Public method | ToString | (inherited from Object).
Supported by the .NET Compact Framework. | Update |

Top

Protected Methods

 | Name | Description
Protected method | Finalize | (inherited from Object).
Protected method | MemberwiseClone | (Overloaded) (inherited from Object).

Top

See Also

Reference

clsKey_tabelle Class


clsKey_tabelle.Delete Method

clsKey_tabelle.Delete Method

clsKey_tabelle.Delete Method | Previous topic | Next topic
clsKey_tabelle.Delete Method | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Overrides Function Delete() As Boolean

C#

public override bool Delete()

C++

public:
bool Delete()

JScript

public function Delete() : boolean;

Source code

Visual Basic

Copy Code Copy Code

Public Overrides Function Delete() As Boolean
Dim scmCmdToExecute As SqlCommand = New SqlCommand()
scmCmdToExecute.CommandText = "dbo.[pr_key_tabelle_Delete]"
scmCmdToExecute.CommandType = CommandType.StoredProcedure

' // Use base class' connection object
scmCmdToExecute.Connection = m_scoMainConnection

Try
scmCmdToExecute.Parameters.Add(New SqlParameter("@ikeynr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iKeynr))
scmCmdToExecute.Parameters.Add(New SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

If m_bMainConnectionIsCreatedLocal Then
' // Open connection.
m_scoMainConnection.Open()
Else
If m_cpMainConnectionProvider.bIsTransactionPending Then
scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
End If
End If

' // Execute query.
scmCmdToExecute.ExecuteNonQuery()
m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
' // Throw error.
Throw New Exception("Stored Procedure 'pr_key_tabelle_Delete' reported the ErrorCode: " & m_iErrorCode.ToString())
End If

Return True
Catch ex As Exception
' // some error occured. Bubble it to caller and encapsulate Exception object
Throw New Exception("clsKey_tabelle::Delete::Error occured.", ex)
Finally
If m_bMainConnectionIsCreatedLocal Then
' // Close connection.
m_scoMainConnection.Close()
End If
scmCmdToExecute.Dispose()
End Try
End Function

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsKey_tabelle Class
clsKey_tabelle clsKey_tabelle Members


clsKey_tabelle.Insert Method

clsKey_tabelle.Insert Method

clsKey_tabelle.Insert Method | Previous topic | Next topic
clsKey_tabelle.Insert Method | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Overrides Function Insert() As Boolean

C#

public override bool Insert()

C++

public:
bool Insert()

JScript

public function Insert() : boolean;

Source code

Visual Basic

Copy Code Copy Code

Overrides Public Function Insert() As Boolean
Dim scmCmdToExecute As SqlCommand = New SqlCommand()
scmCmdToExecute.CommandText = "dbo.[pr_key_tabelle_Insert]"
scmCmdToExecute.CommandType = CommandType.StoredProcedure

' // Use base class' connection object
scmCmdToExecute.Connection = m_scoMainConnection

Try
scmCmdToExecute.Parameters.Add(New SqlParameter("@ikeynr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iKeynr))
scmCmdToExecute.Parameters.Add(New SqlParameter("@sbeschreibung", SqlDbType.VarChar, 255, ParameterDirection.Input, False, 0, 0, "", DataRowVersion.Proposed, m_sBeschreibung))
scmCmdToExecute.Parameters.Add(New SqlParameter("@ikey_wert", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iKey_wert))
scmCmdToExecute.Parameters.Add(New SqlParameter("@imandantnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMandantnr))
scmCmdToExecute.Parameters.Add(New SqlParameter("@baktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bAktiv))
scmCmdToExecute.Parameters.Add(New SqlParameter("@daerstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daErstellt_am))
scmCmdToExecute.Parameters.Add(New SqlParameter("@damutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daMutiert_am))
scmCmdToExecute.Parameters.Add(New SqlParameter("@imutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

If m_bMainConnectionIsCreatedLocal Then
' // Open connection.
m_scoMainConnection.Open()
Else
If m_cpMainConnectionProvider.bIsTransactionPending Then
scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
End If
End If

' // Execute query.
scmCmdToExecute.ExecuteNonQuery()
m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
' // Throw error.
Throw New Exception("Stored Procedure 'pr_key_tabelle_Insert' reported the ErrorCode: " & m_iErrorCode.ToString())
End If

Return True
Catch ex As Exception
' // some error occured. Bubble it to caller and encapsulate Exception object
Throw New Exception("clsKey_tabelle::Insert::Error occured.", ex)
Finally
If m_bMainConnectionIsCreatedLocal Then
' // Close connection.
m_scoMainConnection.Close()
End If
scmCmdToExecute.Dispose()
End Try
End Function

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsKey_tabelle Class
clsKey_tabelle clsKey_tabelle Members


clsKey_tabelle.SelectAll Method

clsKey_tabelle.SelectAll Method

clsKey_tabelle.SelectAll Method | Previous topic | Next topic
clsKey_tabelle.SelectAll Method | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Overrides Function SelectAll() As DataTable

C#

public override DataTable SelectAll()

C++

public:
DataTable^ SelectAll()

JScript

public function SelectAll() : DataTable;

Source code

Visual Basic

Copy Code Copy Code

Public Overrides Function SelectAll() As DataTable
Dim scmCmdToExecute As SqlCommand = New SqlCommand()
scmCmdToExecute.CommandText = "dbo.[pr_key_tabelle_SelectAll]"
scmCmdToExecute.CommandType = CommandType.StoredProcedure
Dim dtToReturn As DataTable = New DataTable("key_tabelle")
Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)

' // Use base class' connection object
scmCmdToExecute.Connection = m_scoMainConnection

Try
scmCmdToExecute.Parameters.Add(New SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

If m_bMainConnectionIsCreatedLocal Then
' // Open connection.
m_scoMainConnection.Open()
Else
If m_cpMainConnectionProvider.bIsTransactionPending Then
scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
End If
End If

' // Execute query.
sdaAdapter.Fill(dtToReturn)
m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
' // Throw error.
Throw New Exception("Stored Procedure 'pr_key_tabelle_SelectAll' reported the ErrorCode: " & m_iErrorCode.ToString())
End If

Return dtToReturn
Catch ex As Exception
' // some error occured. Bubble it to caller and encapsulate Exception object
Throw New Exception("clsKey_tabelle::SelectAll::Error occured.", ex)
Finally
If m_bMainConnectionIsCreatedLocal Then
' // Close connection.
m_scoMainConnection.Close()
End If
scmCmdToExecute.Dispose()
sdaAdapter.Dispose()
End Try
End Function

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsKey_tabelle Class
clsKey_tabelle clsKey_tabelle Members


clsKey_tabelle.SelectOne Method

clsKey_tabelle.SelectOne Method

clsKey_tabelle.SelectOne Method | Previous topic | Next topic
clsKey_tabelle.SelectOne Method | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Overrides Function SelectOne() As DataTable

C#

public override DataTable SelectOne()

C++

public:
DataTable^ SelectOne()

JScript

public function SelectOne() : DataTable;

Source code

Visual Basic

Copy Code Copy Code

Overrides Public Function SelectOne() As DataTable
Dim scmCmdToExecute As SqlCommand = New SqlCommand()
scmCmdToExecute.CommandText = "dbo.[pr_key_tabelle_SelectOne]"
scmCmdToExecute.CommandType = CommandType.StoredProcedure
Dim dtToReturn As DataTable = new DataTable("key_tabelle")
Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

' // Use base class' connection object
scmCmdToExecute.Connection = m_scoMainConnection

Try
scmCmdToExecute.Parameters.Add(new SqlParameter("@ikeynr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iKeynr))
scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

If m_bMainConnectionIsCreatedLocal Then
' // Open connection.
m_scoMainConnection.Open()
Else
If m_cpMainConnectionProvider.bIsTransactionPending Then
scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
End If
End If

' // Execute query.
sdaAdapter.Fill(dtToReturn)
m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
' // Throw error.
Throw New Exception("Stored Procedure 'pr_key_tabelle_SelectOne' reported the ErrorCode: " & m_iErrorCode.ToString())
End If

If dtToReturn.Rows.Count > 0 Then
m_iKeynr = New SqlInt32(CType(dtToReturn.Rows(0)("keynr"), Integer))
m_sBeschreibung = New SqlString(CType(dtToReturn.Rows(0)("beschreibung"), String))
m_iKey_wert = New SqlInt32(CType(dtToReturn.Rows(0)("key_wert"), Integer))
If dtToReturn.Rows(0)("mandantnr") Is System.DBNull.Value Then
m_iMandantnr = SqlInt32.Null
Else
m_iMandantnr = New SqlInt32(CType(dtToReturn.Rows(0)("mandantnr"), Integer))
End If
If dtToReturn.Rows(0)("aktiv") Is System.DBNull.Value Then
m_bAktiv = SqlBoolean.Null
Else
m_bAktiv = New SqlBoolean(CType(dtToReturn.Rows(0)("aktiv"), Boolean))
End If
If dtToReturn.Rows(0)("erstellt_am") Is System.DBNull.Value Then
m_daErstellt_am = SqlDateTime.Null
Else
m_daErstellt_am = New SqlDateTime(CType(dtToReturn.Rows(0)("erstellt_am"), Date))
End If
If dtToReturn.Rows(0)("mutiert_am") Is System.DBNull.Value Then
m_daMutiert_am = SqlDateTime.Null
Else
m_daMutiert_am = New SqlDateTime(CType(dtToReturn.Rows(0)("mutiert_am"), Date))
End If
If dtToReturn.Rows(0)("mutierer") Is System.DBNull.Value Then
m_iMutierer = SqlInt32.Null
Else
m_iMutierer = New SqlInt32(CType(dtToReturn.Rows(0)("mutierer"), Integer))
End If
End If
Return dtToReturn
Catch ex As Exception
' // some error occured. Bubble it to caller and encapsulate Exception object
Throw New Exception("clsKey_tabelle::SelectOne::Error occured.", ex)
Finally
If m_bMainConnectionIsCreatedLocal Then
' // Close connection.
m_scoMainConnection.Close()
End If
scmCmdToExecute.Dispose()
sdaAdapter.Dispose()
End Try
End Function

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsKey_tabelle Class
clsKey_tabelle clsKey_tabelle Members


clsKey_tabelle.Update Method

clsKey_tabelle.Update Method

clsKey_tabelle.Update Method | Previous topic | Next topic
clsKey_tabelle.Update Method | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Overrides Function Update() As Boolean

C#

public override bool Update()

C++

public:
bool Update()

JScript

public function Update() : boolean;

Source code

Visual Basic

Copy Code Copy Code

Overrides Public Function Update() As Boolean
Dim scmCmdToExecute As SqlCommand = New SqlCommand()
scmCmdToExecute.CommandText = "dbo.[pr_key_tabelle_Update]"
scmCmdToExecute.CommandType = CommandType.StoredProcedure

' // Use base class' connection object
scmCmdToExecute.Connection = m_scoMainConnection

Try
scmCmdToExecute.Parameters.Add(New SqlParameter("@ikeynr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iKeynr))
scmCmdToExecute.Parameters.Add(New SqlParameter("@sbeschreibung", SqlDbType.VarChar, 255, ParameterDirection.Input, False, 0, 0, "", DataRowVersion.Proposed, m_sBeschreibung))
scmCmdToExecute.Parameters.Add(New SqlParameter("@ikey_wert", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iKey_wert))
scmCmdToExecute.Parameters.Add(New SqlParameter("@imandantnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMandantnr))
scmCmdToExecute.Parameters.Add(New SqlParameter("@baktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bAktiv))
scmCmdToExecute.Parameters.Add(New SqlParameter("@daerstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daErstellt_am))
scmCmdToExecute.Parameters.Add(New SqlParameter("@damutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daMutiert_am))
scmCmdToExecute.Parameters.Add(New SqlParameter("@imutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

If m_bMainConnectionIsCreatedLocal Then
' // Open connection.
m_scoMainConnection.Open()
Else
If m_cpMainConnectionProvider.bIsTransactionPending Then
scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
End If
End If

' // Execute query.
scmCmdToExecute.ExecuteNonQuery()
m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
' // Throw error.
Throw New Exception("Stored Procedure 'pr_key_tabelle_Update' reported the ErrorCode: " & m_iErrorCode.ToString())
End If

Return True
Catch ex As Exception
' // some error occured. Bubble it to caller and encapsulate Exception object
Throw New Exception("clsKey_tabelle::Update::Error occured.", ex)
Finally
If m_bMainConnectionIsCreatedLocal Then
' // Close connection.
m_scoMainConnection.Close()
End If
scmCmdToExecute.Dispose()
End Try
End Function

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsKey_tabelle Class
clsKey_tabelle clsKey_tabelle Members


clsKey_tabelle Fields

clsKey_tabelle Fields

clsKey_tabelle Fields | Previous topic | Next topic
clsKey_tabelle Fields | Previous topic | Next topic

Fields

 | Name | Description
Supported by the .NET Compact Framework. | m_bAktiv |
Supported by the .NET Compact Framework. | m_bMainConnectionIsCreatedLocal | (inherited from clsDBInteractionBase ).
Supported by the .NET Compact Framework. | m_cpMainConnectionProvider | (inherited from clsDBInteractionBase ).
Supported by the .NET Compact Framework. | m_daErstellt_am |
Supported by the .NET Compact Framework. | m_daMutiert_am |
Supported by the .NET Compact Framework. | m_iErrorCode | (inherited from clsDBInteractionBase ).
Supported by the .NET Compact Framework. | m_iKey_wert |
Supported by the .NET Compact Framework. | m_iKeynr |
Supported by the .NET Compact Framework. | m_iMandantnr |
Supported by the .NET Compact Framework. | m_iMutierer |
Supported by the .NET Compact Framework. | m_sBeschreibung |
Supported by the .NET Compact Framework. | m_scoMainConnection | (inherited from clsDBInteractionBase ).

Top

See Also

Reference

clsKey_tabelle Class


m_bAktiv Field

m_bAktiv Field

m_bAktiv Field | Previous topic | Next topic
m_bAktiv Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_bAktiv As SqlBoolean

C#

private SqlBoolean m_bAktiv

C++

private:
SqlBoolean m_bAktiv;

JScript

private m_bAktiv : SqlBoolean

Source code

Visual Basic

Copy Code Copy Code

Private m_bAktiv As SqlBoolean

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsKey_tabelle Class
clsKey_tabelle clsKey_tabelle Members


m_daErstellt_am Field

m_daErstellt_am Field

m_daErstellt_am Field | Previous topic | Next topic
m_daErstellt_am Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_daErstellt_am As SqlDateTime

C#

private SqlDateTime m_daErstellt_am

C++

private:
SqlDateTime m_daErstellt_am;

JScript

private m_daErstellt_am : SqlDateTime

Source code

Visual Basic

Copy Code Copy Code

Private m_daErstellt_am, m_daMutiert_am As SqlDateTime

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsKey_tabelle Class
clsKey_tabelle clsKey_tabelle Members


m_daMutiert_am Field

m_daMutiert_am Field

m_daMutiert_am Field | Previous topic | Next topic
m_daMutiert_am Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_daMutiert_am As SqlDateTime

C#

private SqlDateTime m_daMutiert_am

C++

private:
SqlDateTime m_daMutiert_am;

JScript

private m_daMutiert_am : SqlDateTime

Source code

Visual Basic

Copy Code Copy Code

Private m_daErstellt_am, m_daMutiert_am As SqlDateTime

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsKey_tabelle Class
clsKey_tabelle clsKey_tabelle Members


m_iKey_wert Field

m_iKey_wert Field

m_iKey_wert Field | Previous topic | Next topic
m_iKey_wert Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_iKey_wert As SqlInt32

C#

private SqlInt32 m_iKey_wert

C++

private:
SqlInt32 m_iKey_wert;

JScript

private m_iKey_wert : SqlInt32

Source code

Visual Basic

Copy Code Copy Code

Private m_iMutierer, m_iKeynr, m_iKey_wert, m_iMandantnr As SqlInt32

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsKey_tabelle Class
clsKey_tabelle clsKey_tabelle Members


m_iKeynr Field

m_iKeynr Field

m_iKeynr Field | Previous topic | Next topic
m_iKeynr Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_iKeynr As SqlInt32

C#

private SqlInt32 m_iKeynr

C++

private:
SqlInt32 m_iKeynr;

JScript

private m_iKeynr : SqlInt32

Source code

Visual Basic

Copy Code Copy Code

Private m_iMutierer, m_iKeynr, m_iKey_wert, m_iMandantnr As SqlInt32

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsKey_tabelle Class
clsKey_tabelle clsKey_tabelle Members


m_iMandantnr Field

m_iMandantnr Field

m_iMandantnr Field | Previous topic | Next topic
m_iMandantnr Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_iMandantnr As SqlInt32

C#

private SqlInt32 m_iMandantnr

C++

private:
SqlInt32 m_iMandantnr;

JScript

private m_iMandantnr : SqlInt32

Source code

Visual Basic

Copy Code Copy Code

Private m_iMutierer, m_iKeynr, m_iKey_wert, m_iMandantnr As SqlInt32

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsKey_tabelle Class
clsKey_tabelle clsKey_tabelle Members


m_iMutierer Field

m_iMutierer Field

m_iMutierer Field | Previous topic | Next topic
m_iMutierer Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_iMutierer As SqlInt32

C#

private SqlInt32 m_iMutierer

C++

private:
SqlInt32 m_iMutierer;

JScript

private m_iMutierer : SqlInt32

Source code

Visual Basic

Copy Code Copy Code

Private m_iMutierer, m_iKeynr, m_iKey_wert, m_iMandantnr As SqlInt32

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsKey_tabelle Class
clsKey_tabelle clsKey_tabelle Members


m_sBeschreibung Field

m_sBeschreibung Field

m_sBeschreibung Field | Previous topic | Next topic
m_sBeschreibung Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_sBeschreibung As SqlString

C#

private SqlString m_sBeschreibung

C++

private:
SqlString m_sBeschreibung;

JScript

private m_sBeschreibung : SqlString

Source code

Visual Basic

Copy Code Copy Code

Private m_sBeschreibung As SqlString

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsKey_tabelle Class
clsKey_tabelle clsKey_tabelle Members


clsMitarbeiter Class

clsMitarbeiter Class

clsMitarbeiter Class | Previous topic | Next topic
clsMitarbeiter Class | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Class clsMitarbeiter
Inherits clsDBInteractionBase

C#

public class clsMitarbeiter : clsDBInteractionBase

C++

public ref class clsMitarbeiter : public clsDBInteractionBase^

JScript

public class clsMitarbeiter
extends clsDBInteractionBase

Inheritance Hierarchy

System.Object

EDKB12WS.edokadb.clsDBInteractionBase

EDKB12WS.edokadb.clsMitarbeiter

EDKB12WS.edokaDB.clsMyMitarbeiter

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsMitarbeiter Members


clsMitarbeiter Members

clsMitarbeiter Members

clsMitarbeiter Members | Previous topic | Next topic
clsMitarbeiter Members | Previous topic | Next topic

The following tables list the members exposed by the clsMitarbeiter type.

Public Constructors

 | Name | Description
Supported by the .NET Compact Framework. | clsMitarbeiter Constructor |

Top

Public Properties

 | Name | Description
Supported by the .NET Compact Framework. | bAktiv |
Supported by the .NET Compact Framework. | bEdokaMesasge |
Supported by the .NET Compact Framework. | bEdoka_mail |
Supported by the .NET Compact Framework. | bJournalisierung |
Supported by the .NET Compact Framework. | bMailDirektVersenden |
Supported by the .NET Compact Framework. | bMailDokumentrueckgang |
Supported by the .NET Compact Framework. | bMailempfang |
Supported by the .NET Compact Framework. | bShowtip |
Supported by the .NET Compact Framework. | cpMainConnectionProvider | (inherited from clsDBInteractionBase ).
Supported by the .NET Compact Framework. | daErstellt_am |
Supported by the .NET Compact Framework. | daMutiert_am |
Supported by the .NET Compact Framework. | iErrorCode | (inherited from clsDBInteractionBase ).
Supported by the .NET Compact Framework. | iFuermandant |
Supported by the .NET Compact Framework. | iFunktionnr |
Supported by the .NET Compact Framework. | iKlassifizierung |
Supported by the .NET Compact Framework. | iMandantnr |
Supported by the .NET Compact Framework. | iMitarbeiternr |
Supported by the .NET Compact Framework. | iMutierer |
Supported by the .NET Compact Framework. | iPartnernr |
Supported by the .NET Compact Framework. | iSprache |
Supported by the .NET Compact Framework. | sAnrede |
Supported by the .NET Compact Framework. | sConnectionString | (inherited from clsDBInteractionBase ).
Supported by the .NET Compact Framework. | sEmail |
Supported by the .NET Compact Framework. | sFax |
Supported by the .NET Compact Framework. | sFunktion |
Supported by the .NET Compact Framework. | sKurzzeichen |
Supported by the .NET Compact Framework. | sName |
Supported by the .NET Compact Framework. | sRang |
Supported by the .NET Compact Framework. | sTelefon |
Supported by the .NET Compact Framework. | sTgnummer |
Supported by the .NET Compact Framework. | sUnterschrift_text |
Supported by the .NET Compact Framework. | sVorname |

Top

Public Methods

 | Name | Description
Supported by the .NET Compact Framework. | Delete |
Supported by the .NET Compact Framework. | Dispose | (Overloaded) (inherited from clsDBInteractionBase ).
Public method | Equals | (Overloaded) (inherited from Object).
Public method | GetHashCode | (inherited from Object).
Public method | GetType | (Overloaded) (inherited from Object).
Supported by the .NET Compact Framework. | Insert |
 | ReferenceEquals | (inherited from Object).
Supported by the .NET Compact Framework. | SelectAll |
Supported by the .NET Compact Framework. | SelectOne |
Public method | ToString | (inherited from Object).
Supported by the .NET Compact Framework. | Update |

Top

Protected Methods

 | Name | Description
Protected method | Finalize | (inherited from Object).
Protected method | MemberwiseClone | (Overloaded) (inherited from Object).

Top

Fields

 | Name | Description
Supported by the .NET Compact Framework. | m_bAktiv |
Supported by the .NET Compact Framework. | m_bEdokaMesasge |
Supported by the .NET Compact Framework. | m_bEdoka_mail |
Supported by the .NET Compact Framework. | m_bJournalisierung |
Supported by the .NET Compact Framework. | m_bMailDirektVersenden |
Supported by the .NET Compact Framework. | m_bMailDokumentrueckgang |
Supported by the .NET Compact Framework. | m_bMailempfang |
Supported by the .NET Compact Framework. | m_bMainConnectionIsCreatedLocal | (inherited from clsDBInteractionBase ).
Supported by the .NET Compact Framework. | m_bShowtip |
Supported by the .NET Compact Framework. | m_cpMainConnectionProvider | (inherited from clsDBInteractionBase ).
Supported by the .NET Compact Framework. | m_daErstellt_am |
Supported by the .NET Compact Framework. | m_daMutiert_am |
Supported by the .NET Compact Framework. | m_iErrorCode | (inherited from clsDBInteractionBase ).
Supported by the .NET Compact Framework. | m_iFuermandant |
Supported by the .NET Compact Framework. | m_iFunktionnr |
Supported by the .NET Compact Framework. | m_iKlassifizierung |
Supported by the .NET Compact Framework. | m_iMandantnr |
Supported by the .NET Compact Framework. | m_iMitarbeiternr |
Supported by the .NET Compact Framework. | m_iMutierer |
Supported by the .NET Compact Framework. | m_iPartnernr |
Supported by the .NET Compact Framework. | m_iSprache |
Supported by the .NET Compact Framework. | m_sAnrede |
Supported by the .NET Compact Framework. | m_sEmail |
Supported by the .NET Compact Framework. | m_sFax |
Supported by the .NET Compact Framework. | m_sFunktion |
Supported by the .NET Compact Framework. | m_sKurzzeichen |
Supported by the .NET Compact Framework. | m_sName |
Supported by the .NET Compact Framework. | m_sRang |
Supported by the .NET Compact Framework. | m_sTelefon |
Supported by the .NET Compact Framework. | m_sTgnummer |
Supported by the .NET Compact Framework. | m_sUnterschrift_text |
Supported by the .NET Compact Framework. | m_sVorname |
Supported by the .NET Compact Framework. | m_scoMainConnection | (inherited from clsDBInteractionBase ).

Top

See Also

Reference

clsMitarbeiter Class


clsMitarbeiter Properties

clsMitarbeiter Properties

clsMitarbeiter Properties | Previous topic | Next topic
clsMitarbeiter Properties | Previous topic | Next topic

Public Properties

 | Name | Description
Supported by the .NET Compact Framework. | bAktiv |
Supported by the .NET Compact Framework. | bEdokaMesasge |
Supported by the .NET Compact Framework. | bEdoka_mail |
Supported by the .NET Compact Framework. | bJournalisierung |
Supported by the .NET Compact Framework. | bMailDirektVersenden |
Supported by the .NET Compact Framework. | bMailDokumentrueckgang |
Supported by the .NET Compact Framework. | bMailempfang |
Supported by the .NET Compact Framework. | bShowtip |
Supported by the .NET Compact Framework. | cpMainConnectionProvider | (inherited from clsDBInteractionBase ).
Supported by the .NET Compact Framework. | daErstellt_am |
Supported by the .NET Compact Framework. | daMutiert_am |
Supported by the .NET Compact Framework. | iErrorCode | (inherited from clsDBInteractionBase ).
Supported by the .NET Compact Framework. | iFuermandant |
Supported by the .NET Compact Framework. | iFunktionnr |
Supported by the .NET Compact Framework. | iKlassifizierung |
Supported by the .NET Compact Framework. | iMandantnr |
Supported by the .NET Compact Framework. | iMitarbeiternr |
Supported by the .NET Compact Framework. | iMutierer |
Supported by the .NET Compact Framework. | iPartnernr |
Supported by the .NET Compact Framework. | iSprache |
Supported by the .NET Compact Framework. | sAnrede |
Supported by the .NET Compact Framework. | sConnectionString | (inherited from clsDBInteractionBase ).
Supported by the .NET Compact Framework. | sEmail |
Supported by the .NET Compact Framework. | sFax |
Supported by the .NET Compact Framework. | sFunktion |
Supported by the .NET Compact Framework. | sKurzzeichen |
Supported by the .NET Compact Framework. | sName |
Supported by the .NET Compact Framework. | sRang |
Supported by the .NET Compact Framework. | sTelefon |
Supported by the .NET Compact Framework. | sTgnummer |
Supported by the .NET Compact Framework. | sUnterschrift_text |
Supported by the .NET Compact Framework. | sVorname |

Top

See Also

Reference

clsMitarbeiter Class


clsMitarbeiter Methods

clsMitarbeiter Methods

clsMitarbeiter Methods | Previous topic | Next topic
clsMitarbeiter Methods | Previous topic | Next topic

Public Methods

 | Name | Description
Supported by the .NET Compact Framework. | Delete |
Supported by the .NET Compact Framework. | Dispose | (Overloaded) (inherited from clsDBInteractionBase ).
Public method | Equals | (Overloaded) (inherited from Object).
Public method | GetHashCode | (inherited from Object).
Public method | GetType | (Overloaded) (inherited from Object).
Supported by the .NET Compact Framework. | Insert |
 | ReferenceEquals | (inherited from Object).
Supported by the .NET Compact Framework. | SelectAll |
Supported by the .NET Compact Framework. | SelectOne |
Public method | ToString | (inherited from Object).
Supported by the .NET Compact Framework. | Update |

Top

Protected Methods

 | Name | Description
Protected method | Finalize | (inherited from Object).
Protected method | MemberwiseClone | (Overloaded) (inherited from Object).

Top

See Also

Reference

clsMitarbeiter Class


clsMitarbeiter Fields

clsMitarbeiter Fields

clsMitarbeiter Fields | Previous topic | Next topic
clsMitarbeiter Fields | Previous topic | Next topic

Fields

 | Name | Description
Supported by the .NET Compact Framework. | m_bAktiv |
Supported by the .NET Compact Framework. | m_bEdokaMesasge |
Supported by the .NET Compact Framework. | m_bEdoka_mail |
Supported by the .NET Compact Framework. | m_bJournalisierung |
Supported by the .NET Compact Framework. | m_bMailDirektVersenden |
Supported by the .NET Compact Framework. | m_bMailDokumentrueckgang |
Supported by the .NET Compact Framework. | m_bMailempfang |
Supported by the .NET Compact Framework. | m_bMainConnectionIsCreatedLocal | (inherited from clsDBInteractionBase ).
Supported by the .NET Compact Framework. | m_bShowtip |
Supported by the .NET Compact Framework. | m_cpMainConnectionProvider | (inherited from clsDBInteractionBase ).
Supported by the .NET Compact Framework. | m_daErstellt_am |
Supported by the .NET Compact Framework. | m_daMutiert_am |
Supported by the .NET Compact Framework. | m_iErrorCode | (inherited from clsDBInteractionBase ).
Supported by the .NET Compact Framework. | m_iFuermandant |
Supported by the .NET Compact Framework. | m_iFunktionnr |
Supported by the .NET Compact Framework. | m_iKlassifizierung |
Supported by the .NET Compact Framework. | m_iMandantnr |
Supported by the .NET Compact Framework. | m_iMitarbeiternr |
Supported by the .NET Compact Framework. | m_iMutierer |
Supported by the .NET Compact Framework. | m_iPartnernr |
Supported by the .NET Compact Framework. | m_iSprache |
Supported by the .NET Compact Framework. | m_sAnrede |
Supported by the .NET Compact Framework. | m_sEmail |
Supported by the .NET Compact Framework. | m_sFax |
Supported by the .NET Compact Framework. | m_sFunktion |
Supported by the .NET Compact Framework. | m_sKurzzeichen |
Supported by the .NET Compact Framework. | m_sName |
Supported by the .NET Compact Framework. | m_sRang |
Supported by the .NET Compact Framework. | m_sTelefon |
Supported by the .NET Compact Framework. | m_sTgnummer |
Supported by the .NET Compact Framework. | m_sUnterschrift_text |
Supported by the .NET Compact Framework. | m_sVorname |
Supported by the .NET Compact Framework. | m_scoMainConnection | (inherited from clsDBInteractionBase ).

Top

See Also

Reference

clsMitarbeiter Class


m_bAktiv Field

m_bAktiv Field

m_bAktiv Field | Previous topic | Next topic
m_bAktiv Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_bAktiv As SqlBoolean

C#

private SqlBoolean m_bAktiv

C++

private:
SqlBoolean m_bAktiv;

JScript

private m_bAktiv : SqlBoolean

Source code

Visual Basic

Copy Code Copy Code

Private m_bMailempfang, m_bEdokaMesasge, m_bShowtip, m_bAktiv, m_bMailDirektVersenden, m_bEdoka_mail, m_bJournalisierung, m_bMailDokumentrueckgang As SqlBoolean

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsMitarbeiter Class
clsMitarbeiter clsMitarbeiter Members


m_bEdokaMesasge Field

m_bEdokaMesasge Field

m_bEdokaMesasge Field | Previous topic | Next topic
m_bEdokaMesasge Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_bEdokaMesasge As SqlBoolean

C#

private SqlBoolean m_bEdokaMesasge

C++

private:
SqlBoolean m_bEdokaMesasge;

JScript

private m_bEdokaMesasge : SqlBoolean

Source code

Visual Basic

Copy Code Copy Code

Private m_bMailempfang, m_bEdokaMesasge, m_bShowtip, m_bAktiv, m_bMailDirektVersenden, m_bEdoka_mail, m_bJournalisierung, m_bMailDokumentrueckgang As SqlBoolean

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsMitarbeiter Class
clsMitarbeiter clsMitarbeiter Members


m_bEdoka_mail Field

m_bEdoka_mail Field

m_bEdoka_mail Field | Previous topic | Next topic
m_bEdoka_mail Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_bEdoka_mail As SqlBoolean

C#

private SqlBoolean m_bEdoka_mail

C++

private:
SqlBoolean m_bEdoka_mail;

JScript

private m_bEdoka_mail : SqlBoolean

Source code

Visual Basic

Copy Code Copy Code

Private m_bMailempfang, m_bEdokaMesasge, m_bShowtip, m_bAktiv, m_bMailDirektVersenden, m_bEdoka_mail, m_bJournalisierung, m_bMailDokumentrueckgang As SqlBoolean

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsMitarbeiter Class
clsMitarbeiter clsMitarbeiter Members


m_bJournalisierung Field

m_bJournalisierung Field

m_bJournalisierung Field | Previous topic | Next topic
m_bJournalisierung Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_bJournalisierung As SqlBoolean

C#

private SqlBoolean m_bJournalisierung

C++

private:
SqlBoolean m_bJournalisierung;

JScript

private m_bJournalisierung : SqlBoolean

Source code

Visual Basic

Copy Code Copy Code

Private m_bMailempfang, m_bEdokaMesasge, m_bShowtip, m_bAktiv, m_bMailDirektVersenden, m_bEdoka_mail, m_bJournalisierung, m_bMailDokumentrueckgang As SqlBoolean

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsMitarbeiter Class
clsMitarbeiter clsMitarbeiter Members


m_bMailDirektVersenden Field

m_bMailDirektVersenden Field

m_bMailDirektVersenden Field | Previous topic | Next topic
m_bMailDirektVersenden Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_bMailDirektVersenden As SqlBoolean

C#

private SqlBoolean m_bMailDirektVersenden

C++

private:
SqlBoolean m_bMailDirektVersenden;

JScript

private m_bMailDirektVersenden : SqlBoolean

Source code

Visual Basic

Copy Code Copy Code

Private m_bMailempfang, m_bEdokaMesasge, m_bShowtip, m_bAktiv, m_bMailDirektVersenden, m_bEdoka_mail, m_bJournalisierung, m_bMailDokumentrueckgang As SqlBoolean

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsMitarbeiter Class
clsMitarbeiter clsMitarbeiter Members


m_bMailDokumentrueckgang Field

m_bMailDokumentrueckgang Field

m_bMailDokumentrueckgang Field | Previous topic | Next topic
m_bMailDokumentrueckgang Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_bMailDokumentrueckgang As SqlBoolean

C#

private SqlBoolean m_bMailDokumentrueckgang

C++

private:
SqlBoolean m_bMailDokumentrueckgang;

JScript

private m_bMailDokumentrueckgang : SqlBoolean

Source code

Visual Basic

Copy Code Copy Code

Private m_bMailempfang, m_bEdokaMesasge, m_bShowtip, m_bAktiv, m_bMailDirektVersenden, m_bEdoka_mail, m_bJournalisierung, m_bMailDokumentrueckgang As SqlBoolean

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsMitarbeiter Class
clsMitarbeiter clsMitarbeiter Members


m_bMailempfang Field

m_bMailempfang Field

m_bMailempfang Field | Previous topic | Next topic
m_bMailempfang Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_bMailempfang As SqlBoolean

C#

private SqlBoolean m_bMailempfang

C++

private:
SqlBoolean m_bMailempfang;

JScript

private m_bMailempfang : SqlBoolean

Source code

Visual Basic

Copy Code Copy Code

Private m_bMailempfang, m_bEdokaMesasge, m_bShowtip, m_bAktiv, m_bMailDirektVersenden, m_bEdoka_mail, m_bJournalisierung, m_bMailDokumentrueckgang As SqlBoolean

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsMitarbeiter Class
clsMitarbeiter clsMitarbeiter Members


m_bShowtip Field

m_bShowtip Field

m_bShowtip Field | Previous topic | Next topic
m_bShowtip Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_bShowtip As SqlBoolean

C#

private SqlBoolean m_bShowtip

C++

private:
SqlBoolean m_bShowtip;

JScript

private m_bShowtip : SqlBoolean

Source code

Visual Basic

Copy Code Copy Code

Private m_bMailempfang, m_bEdokaMesasge, m_bShowtip, m_bAktiv, m_bMailDirektVersenden, m_bEdoka_mail, m_bJournalisierung, m_bMailDokumentrueckgang As SqlBoolean

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsMitarbeiter Class
clsMitarbeiter clsMitarbeiter Members


m_daErstellt_am Field

m_daErstellt_am Field

m_daErstellt_am Field | Previous topic | Next topic
m_daErstellt_am Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_daErstellt_am As SqlDateTime

C#

private SqlDateTime m_daErstellt_am

C++

private:
SqlDateTime m_daErstellt_am;

JScript

private m_daErstellt_am : SqlDateTime

Source code

Visual Basic

Copy Code Copy Code

Private m_daErstellt_am, m_daMutiert_am As SqlDateTime

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsMitarbeiter Class
clsMitarbeiter clsMitarbeiter Members


m_daMutiert_am Field

m_daMutiert_am Field

m_daMutiert_am Field | Previous topic | Next topic
m_daMutiert_am Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_daMutiert_am As SqlDateTime

C#

private SqlDateTime m_daMutiert_am

C++

private:
SqlDateTime m_daMutiert_am;

JScript

private m_daMutiert_am : SqlDateTime

Source code

Visual Basic

Copy Code Copy Code

Private m_daErstellt_am, m_daMutiert_am As SqlDateTime

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsMitarbeiter Class
clsMitarbeiter clsMitarbeiter Members


m_iFuermandant Field

m_iFuermandant Field

m_iFuermandant Field | Previous topic | Next topic
m_iFuermandant Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_iFuermandant As SqlInt32

C#

private SqlInt32 m_iFuermandant

C++

private:
SqlInt32 m_iFuermandant;

JScript

private m_iFuermandant : SqlInt32

Source code

Visual Basic

Copy Code Copy Code

Private m_iPartnernr, m_iKlassifizierung, m_iMutierer, m_iMandantnr, m_iFunktionnr, m_iMitarbeiternr, m_iFuermandant, m_iSprache As SqlInt32

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsMitarbeiter Class
clsMitarbeiter clsMitarbeiter Members


m_iFunktionnr Field

m_iFunktionnr Field

m_iFunktionnr Field | Previous topic | Next topic
m_iFunktionnr Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_iFunktionnr As SqlInt32

C#

private SqlInt32 m_iFunktionnr

C++

private:
SqlInt32 m_iFunktionnr;

JScript

private m_iFunktionnr : SqlInt32

Source code

Visual Basic

Copy Code Copy Code

Private m_iPartnernr, m_iKlassifizierung, m_iMutierer, m_iMandantnr, m_iFunktionnr, m_iMitarbeiternr, m_iFuermandant, m_iSprache As SqlInt32

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsMitarbeiter Class
clsMitarbeiter clsMitarbeiter Members


m_iKlassifizierung Field

m_iKlassifizierung Field

m_iKlassifizierung Field | Previous topic | Next topic
m_iKlassifizierung Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_iKlassifizierung As SqlInt32

C#

private SqlInt32 m_iKlassifizierung

C++

private:
SqlInt32 m_iKlassifizierung;

JScript

private m_iKlassifizierung : SqlInt32

Source code

Visual Basic

Copy Code Copy Code

Private m_iPartnernr, m_iKlassifizierung, m_iMutierer, m_iMandantnr, m_iFunktionnr, m_iMitarbeiternr, m_iFuermandant, m_iSprache As SqlInt32

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsMitarbeiter Class
clsMitarbeiter clsMitarbeiter Members


m_iMandantnr Field

m_iMandantnr Field

m_iMandantnr Field | Previous topic | Next topic
m_iMandantnr Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_iMandantnr As SqlInt32

C#

private SqlInt32 m_iMandantnr

C++

private:
SqlInt32 m_iMandantnr;

JScript

private m_iMandantnr : SqlInt32

Source code

Visual Basic

Copy Code Copy Code

Private m_iPartnernr, m_iKlassifizierung, m_iMutierer, m_iMandantnr, m_iFunktionnr, m_iMitarbeiternr, m_iFuermandant, m_iSprache As SqlInt32

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsMitarbeiter Class
clsMitarbeiter clsMitarbeiter Members


m_iMitarbeiternr Field

m_iMitarbeiternr Field

m_iMitarbeiternr Field | Previous topic | Next topic
m_iMitarbeiternr Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_iMitarbeiternr As SqlInt32

C#

private SqlInt32 m_iMitarbeiternr

C++

private:
SqlInt32 m_iMitarbeiternr;

JScript

private m_iMitarbeiternr : SqlInt32

Source code

Visual Basic

Copy Code Copy Code

Private m_iPartnernr, m_iKlassifizierung, m_iMutierer, m_iMandantnr, m_iFunktionnr, m_iMitarbeiternr, m_iFuermandant, m_iSprache As SqlInt32

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsMitarbeiter Class
clsMitarbeiter clsMitarbeiter Members


m_iMutierer Field

m_iMutierer Field

m_iMutierer Field | Previous topic | Next topic
m_iMutierer Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_iMutierer As SqlInt32

C#

private SqlInt32 m_iMutierer

C++

private:
SqlInt32 m_iMutierer;

JScript

private m_iMutierer : SqlInt32

Source code

Visual Basic

Copy Code Copy Code

Private m_iPartnernr, m_iKlassifizierung, m_iMutierer, m_iMandantnr, m_iFunktionnr, m_iMitarbeiternr, m_iFuermandant, m_iSprache As SqlInt32

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsMitarbeiter Class
clsMitarbeiter clsMitarbeiter Members


m_iPartnernr Field

m_iPartnernr Field

m_iPartnernr Field | Previous topic | Next topic
m_iPartnernr Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_iPartnernr As SqlInt32

C#

private SqlInt32 m_iPartnernr

C++

private:
SqlInt32 m_iPartnernr;

JScript

private m_iPartnernr : SqlInt32

Source code

Visual Basic

Copy Code Copy Code

Private m_iPartnernr, m_iKlassifizierung, m_iMutierer, m_iMandantnr, m_iFunktionnr, m_iMitarbeiternr, m_iFuermandant, m_iSprache As SqlInt32

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsMitarbeiter Class
clsMitarbeiter clsMitarbeiter Members


m_iSprache Field

m_iSprache Field

m_iSprache Field | Previous topic | Next topic
m_iSprache Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_iSprache As SqlInt32

C#

private SqlInt32 m_iSprache

C++

private:
SqlInt32 m_iSprache;

JScript

private m_iSprache : SqlInt32

Source code

Visual Basic

Copy Code Copy Code

Private m_iPartnernr, m_iKlassifizierung, m_iMutierer, m_iMandantnr, m_iFunktionnr, m_iMitarbeiternr, m_iFuermandant, m_iSprache As SqlInt32

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsMitarbeiter Class
clsMitarbeiter clsMitarbeiter Members


m_sAnrede Field

m_sAnrede Field

m_sAnrede Field | Previous topic | Next topic
m_sAnrede Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_sAnrede As SqlString

C#

private SqlString m_sAnrede

C++

private:
SqlString m_sAnrede;

JScript

private m_sAnrede : SqlString

Source code

Visual Basic

Copy Code Copy Code

Private m_sRang, m_sAnrede, m_sKurzzeichen, m_sVorname, m_sName, m_sFax, m_sTelefon, m_sUnterschrift_text, m_sFunktion, m_sTgnummer, m_sEmail As SqlString

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsMitarbeiter Class
clsMitarbeiter clsMitarbeiter Members


m_sEmail Field

m_sEmail Field

m_sEmail Field | Previous topic | Next topic
m_sEmail Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_sEmail As SqlString

C#

private SqlString m_sEmail

C++

private:
SqlString m_sEmail;

JScript

private m_sEmail : SqlString

Source code

Visual Basic

Copy Code Copy Code

Private m_sRang, m_sAnrede, m_sKurzzeichen, m_sVorname, m_sName, m_sFax, m_sTelefon, m_sUnterschrift_text, m_sFunktion, m_sTgnummer, m_sEmail As SqlString

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsMitarbeiter Class
clsMitarbeiter clsMitarbeiter Members


m_sFax Field

m_sFax Field

m_sFax Field | Previous topic | Next topic
m_sFax Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_sFax As SqlString

C#

private SqlString m_sFax

C++

private:
SqlString m_sFax;

JScript

private m_sFax : SqlString

Source code

Visual Basic

Copy Code Copy Code

Private m_sRang, m_sAnrede, m_sKurzzeichen, m_sVorname, m_sName, m_sFax, m_sTelefon, m_sUnterschrift_text, m_sFunktion, m_sTgnummer, m_sEmail As SqlString

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsMitarbeiter Class
clsMitarbeiter clsMitarbeiter Members


m_sFunktion Field

m_sFunktion Field

m_sFunktion Field | Previous topic | Next topic
m_sFunktion Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_sFunktion As SqlString

C#

private SqlString m_sFunktion

C++

private:
SqlString m_sFunktion;

JScript

private m_sFunktion : SqlString

Source code

Visual Basic

Copy Code Copy Code

Private m_sRang, m_sAnrede, m_sKurzzeichen, m_sVorname, m_sName, m_sFax, m_sTelefon, m_sUnterschrift_text, m_sFunktion, m_sTgnummer, m_sEmail As SqlString

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsMitarbeiter Class
clsMitarbeiter clsMitarbeiter Members


m_sKurzzeichen Field

m_sKurzzeichen Field

m_sKurzzeichen Field | Previous topic | Next topic
m_sKurzzeichen Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_sKurzzeichen As SqlString

C#

private SqlString m_sKurzzeichen

C++

private:
SqlString m_sKurzzeichen;

JScript

private m_sKurzzeichen : SqlString

Source code

Visual Basic

Copy Code Copy Code

Private m_sRang, m_sAnrede, m_sKurzzeichen, m_sVorname, m_sName, m_sFax, m_sTelefon, m_sUnterschrift_text, m_sFunktion, m_sTgnummer, m_sEmail As SqlString

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsMitarbeiter Class
clsMitarbeiter clsMitarbeiter Members


m_sName Field

m_sName Field

m_sName Field | Previous topic | Next topic
m_sName Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_sName As SqlString

C#

private SqlString m_sName

C++

private:
SqlString m_sName;

JScript

private m_sName : SqlString

Source code

Visual Basic

Copy Code Copy Code

Private m_sRang, m_sAnrede, m_sKurzzeichen, m_sVorname, m_sName, m_sFax, m_sTelefon, m_sUnterschrift_text, m_sFunktion, m_sTgnummer, m_sEmail As SqlString

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsMitarbeiter Class
clsMitarbeiter clsMitarbeiter Members


m_sRang Field

m_sRang Field

m_sRang Field | Previous topic | Next topic
m_sRang Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_sRang As SqlString

C#

private SqlString m_sRang

C++

private:
SqlString m_sRang;

JScript

private m_sRang : SqlString

Source code

Visual Basic

Copy Code Copy Code

Private m_sRang, m_sAnrede, m_sKurzzeichen, m_sVorname, m_sName, m_sFax, m_sTelefon, m_sUnterschrift_text, m_sFunktion, m_sTgnummer, m_sEmail As SqlString

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsMitarbeiter Class
clsMitarbeiter clsMitarbeiter Members


m_sTelefon Field

m_sTelefon Field

m_sTelefon Field | Previous topic | Next topic
m_sTelefon Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_sTelefon As SqlString

C#

private SqlString m_sTelefon

C++

private:
SqlString m_sTelefon;

JScript

private m_sTelefon : SqlString

Source code

Visual Basic

Copy Code Copy Code

Private m_sRang, m_sAnrede, m_sKurzzeichen, m_sVorname, m_sName, m_sFax, m_sTelefon, m_sUnterschrift_text, m_sFunktion, m_sTgnummer, m_sEmail As SqlString

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsMitarbeiter Class
clsMitarbeiter clsMitarbeiter Members


m_sTgnummer Field

m_sTgnummer Field

m_sTgnummer Field | Previous topic | Next topic
m_sTgnummer Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_sTgnummer As SqlString

C#

private SqlString m_sTgnummer

C++

private:
SqlString m_sTgnummer;

JScript

private m_sTgnummer : SqlString

Source code

Visual Basic

Copy Code Copy Code

Private m_sRang, m_sAnrede, m_sKurzzeichen, m_sVorname, m_sName, m_sFax, m_sTelefon, m_sUnterschrift_text, m_sFunktion, m_sTgnummer, m_sEmail As SqlString

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsMitarbeiter Class
clsMitarbeiter clsMitarbeiter Members


m_sUnterschrift_text Field

m_sUnterschrift_text Field

m_sUnterschrift_text Field | Previous topic | Next topic
m_sUnterschrift_text Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_sUnterschrift_text As SqlString

C#

private SqlString m_sUnterschrift_text

C++

private:
SqlString m_sUnterschrift_text;

JScript

private m_sUnterschrift_text : SqlString

Source code

Visual Basic

Copy Code Copy Code

Private m_sRang, m_sAnrede, m_sKurzzeichen, m_sVorname, m_sName, m_sFax, m_sTelefon, m_sUnterschrift_text, m_sFunktion, m_sTgnummer, m_sEmail As SqlString

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsMitarbeiter Class
clsMitarbeiter clsMitarbeiter Members


m_sVorname Field

m_sVorname Field

m_sVorname Field | Previous topic | Next topic
m_sVorname Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_sVorname As SqlString

C#

private SqlString m_sVorname

C++

private:
SqlString m_sVorname;

JScript

private m_sVorname : SqlString

Source code

Visual Basic

Copy Code Copy Code

Private m_sRang, m_sAnrede, m_sKurzzeichen, m_sVorname, m_sName, m_sFax, m_sTelefon, m_sUnterschrift_text, m_sFunktion, m_sTgnummer, m_sEmail As SqlString

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsMitarbeiter Class
clsMitarbeiter clsMitarbeiter Members


clsMyDokumentDaten Class

clsMyDokumentDaten Class

clsMyDokumentDaten Class | Previous topic | Next topic
clsMyDokumentDaten Class | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Class clsMyDokumentDaten
Inherits clsVorlagenfeld

C#

public class clsMyDokumentDaten : clsVorlagenfeld

C++

public ref class clsMyDokumentDaten : public clsVorlagenfeld^

JScript

public class clsMyDokumentDaten
extends clsVorlagenfeld

Inheritance Hierarchy

System.Object

EDKB12WS.edokadb.clsDBInteractionBase

EDKB12WS.edokadb.clsVorlagenfeld

EDKB12WS.edokadb.clsMyDokumentDaten

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsMyDokumentDaten Members


clsMyDokumentDaten Members

clsMyDokumentDaten Members

clsMyDokumentDaten Members | Previous topic | Next topic
clsMyDokumentDaten Members | Previous topic | Next topic

The following tables list the members exposed by the clsMyDokumentDaten type.

Public Constructors

 | Name | Description
Supported by the .NET Compact Framework. | clsMyDokumentDaten Constructor | (inherited from clsVorlagenfeld ).

Top

Public Properties

 | Name | Description
Supported by the .NET Compact Framework. | bAktiv | (inherited from clsVorlagenfeld ).
Supported by the .NET Compact Framework. | bAusstiegsmakro | (inherited from clsVorlagenfeld ).
Supported by the .NET Compact Framework. | bEinstiegsmakro | (inherited from clsVorlagenfeld ).
Supported by the .NET Compact Framework. | cpMainConnectionProvider | (inherited from clsDBInteractionBase ).
Supported by the .NET Compact Framework. | daErstellt_am | (inherited from clsVorlagenfeld ).
Supported by the .NET Compact Framework. | daMutiert_am | (inherited from clsVorlagenfeld ).
Supported by the .NET Compact Framework. | iDokumenttypnr | (inherited from clsVorlagenfeld ).
Supported by the .NET Compact Framework. | iDokumenttypnrOld | (inherited from clsVorlagenfeld ).
Supported by the .NET Compact Framework. | iErrorCode | (inherited from clsDBInteractionBase ).
Supported by the .NET Compact Framework. | iMandantnr | (inherited from clsVorlagenfeld ).
Supported by the .NET Compact Framework. | iMutierer | (inherited from clsVorlagenfeld ).
Supported by the .NET Compact Framework. | iVorlagenfeldnr | (inherited from clsVorlagenfeld ).
Supported by the .NET Compact Framework. | iVorlagenfeldregelnr | (inherited from clsVorlagenfeld ).
Supported by the .NET Compact Framework. | iVorlagenfeldregelnrOld | (inherited from clsVorlagenfeld ).
Supported by the .NET Compact Framework. | sBeginntextmarke | (inherited from clsVorlagenfeld ).
Supported by the .NET Compact Framework. | sConnectionString | (inherited from clsDBInteractionBase ).
Supported by the .NET Compact Framework. | sEndetextmarke | (inherited from clsVorlagenfeld ).
Supported by the .NET Compact Framework. | sFeldname | (inherited from clsVorlagenfeld ).
Supported by the .NET Compact Framework. | sTestdaten | (inherited from clsVorlagenfeld ).

Top

Public Methods

 | Name | Description
Supported by the .NET Compact Framework. | Delete | (inherited from clsVorlagenfeld ).
Supported by the .NET Compact Framework. | Dispose | (Overloaded) (inherited from clsDBInteractionBase ).
Public method | Equals | (Overloaded) (inherited from Object).
Public method | GetHashCode | (inherited from Object).
Public method | GetType | (Overloaded) (inherited from Object).
Supported by the .NET Compact Framework. | Insert | (inherited from clsVorlagenfeld ).
 | ReferenceEquals | (inherited from Object).
Supported by the .NET Compact Framework. | SelectAll | (inherited from clsVorlagenfeld ).
Supported by the .NET Compact Framework. | SelectAllWdokumenttypnrLogic | (inherited from clsVorlagenfeld ).
Supported by the .NET Compact Framework. | SelectAllWvorlagenfeldregelnrLogic | (inherited from clsVorlagenfeld ).
Supported by the .NET Compact Framework. | SelectOne | (inherited from clsVorlagenfeld ).
Supported by the .NET Compact Framework. | SelectTestdata |
Supported by the .NET Compact Framework. | Select_IDVMakros |
Public method | ToString | (inherited from Object).
Supported by the .NET Compact Framework. | Update | (inherited from clsVorlagenfeld ).
Supported by the .NET Compact Framework. | UpdateAllWdokumenttypnrLogic | (inherited from clsVorlagenfeld ).
Supported by the .NET Compact Framework. | UpdateAllWvorlagenfeldregelnrLogic | (inherited from clsVorlagenfeld ).

Top

Protected Methods

 | Name | Description
Protected method | Finalize | (inherited from Object).
Protected method | MemberwiseClone | (Overloaded) (inherited from Object).

Top

Fields

 | Name | Description
Supported by the .NET Compact Framework. | m_bMainConnectionIsCreatedLocal | (inherited from clsDBInteractionBase ).
Supported by the .NET Compact Framework. | m_cpMainConnectionProvider | (inherited from clsDBInteractionBase ).
Supported by the .NET Compact Framework. | m_iErrorCode | (inherited from clsDBInteractionBase ).
Supported by the .NET Compact Framework. | m_scoMainConnection | (inherited from clsDBInteractionBase ).

Top

See Also

Reference

clsMyDokumentDaten Class


clsVorlagenfeld Constructor

clsVorlagenfeld Constructor

clsVorlagenfeld Constructor | Previous topic | Next topic
clsVorlagenfeld Constructor | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Sub New()

C#

public clsVorlagenfeld()

C++

public:
clsVorlagenfeld()

JScript

public function clsVorlagenfeld();

Source code

Visual Basic

Copy Code Copy Code

Public Sub New()
' // Nothing for now.
End Sub

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsVorlagenfeld Class
clsVorlagenfeld clsVorlagenfeld Members


clsMyDokumentDaten Properties

clsMyDokumentDaten Properties

clsMyDokumentDaten Properties | Previous topic | Next topic
clsMyDokumentDaten Properties | Previous topic | Next topic

Public Properties

 | Name | Description
Supported by the .NET Compact Framework. | bAktiv | (inherited from clsVorlagenfeld ).
Supported by the .NET Compact Framework. | bAusstiegsmakro | (inherited from clsVorlagenfeld ).
Supported by the .NET Compact Framework. | bEinstiegsmakro | (inherited from clsVorlagenfeld ).
Supported by the .NET Compact Framework. | cpMainConnectionProvider | (inherited from clsDBInteractionBase ).
Supported by the .NET Compact Framework. | daErstellt_am | (inherited from clsVorlagenfeld ).
Supported by the .NET Compact Framework. | daMutiert_am | (inherited from clsVorlagenfeld ).
Supported by the .NET Compact Framework. | iDokumenttypnr | (inherited from clsVorlagenfeld ).
Supported by the .NET Compact Framework. | iDokumenttypnrOld | (inherited from clsVorlagenfeld ).
Supported by the .NET Compact Framework. | iErrorCode | (inherited from clsDBInteractionBase ).
Supported by the .NET Compact Framework. | iMandantnr | (inherited from clsVorlagenfeld ).
Supported by the .NET Compact Framework. | iMutierer | (inherited from clsVorlagenfeld ).
Supported by the .NET Compact Framework. | iVorlagenfeldnr | (inherited from clsVorlagenfeld ).
Supported by the .NET Compact Framework. | iVorlagenfeldregelnr | (inherited from clsVorlagenfeld ).
Supported by the .NET Compact Framework. | iVorlagenfeldregelnrOld | (inherited from clsVorlagenfeld ).
Supported by the .NET Compact Framework. | sBeginntextmarke | (inherited from clsVorlagenfeld ).
Supported by the .NET Compact Framework. | sConnectionString | (inherited from clsDBInteractionBase ).
Supported by the .NET Compact Framework. | sEndetextmarke | (inherited from clsVorlagenfeld ).
Supported by the .NET Compact Framework. | sFeldname | (inherited from clsVorlagenfeld ).
Supported by the .NET Compact Framework. | sTestdaten | (inherited from clsVorlagenfeld ).

Top

See Also

Reference

clsMyDokumentDaten Class


clsVorlagenfeld.bAktiv Property

clsVorlagenfeld.bAktiv Property

clsVorlagenfeld.bAktiv Property | Previous topic | Next topic
clsVorlagenfeld.bAktiv Property | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property bAktiv() As SqlBoolean

C#

public SqlBoolean bAktiv {get; set;}

C++

public:
property SqlBoolean bAktiv {
SqlBoolean get( );
void set(
SqlBoolean value
);
}

JScript

public function get bAktiv() : SqlBoolean;
public function set bAktiv(value : SqlBoolean);

Source code

Visual Basic

Copy Code Copy Code

Public Property [bAktiv]() As SqlBoolean
Get
Return m_bAktiv
End Get
Set(ByVal Value As SqlBoolean)
m_bAktiv = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsVorlagenfeld Class
clsVorlagenfeld clsVorlagenfeld Members


clsVorlagenfeld.bAusstiegsmakro Property

clsVorlagenfeld.bAusstiegsmakro Property

clsVorlagenfeld.bAusstiegsmakro Property | Previous topic | Next topic
clsVorlagenfeld.bAusstiegsmakro Property | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property bAusstiegsmakro() As SqlBoolean

C#

public SqlBoolean bAusstiegsmakro {get; set;}

C++

public:
property SqlBoolean bAusstiegsmakro {
SqlBoolean get( );
void set(
SqlBoolean value
);
}

JScript

public function get bAusstiegsmakro() : SqlBoolean;
public function set bAusstiegsmakro(value : SqlBoolean);

Source code

Visual Basic

Copy Code Copy Code

Public Property [bAusstiegsmakro]() As SqlBoolean
Get
Return m_bAusstiegsmakro
End Get
Set(ByVal Value As SqlBoolean)
m_bAusstiegsmakro = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsVorlagenfeld Class
clsVorlagenfeld clsVorlagenfeld Members


clsVorlagenfeld.bEinstiegsmakro Property

clsVorlagenfeld.bEinstiegsmakro Property

clsVorlagenfeld.bEinstiegsmakro Property | Previous topic | Next topic
clsVorlagenfeld.bEinstiegsmakro Property | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property bEinstiegsmakro() As SqlBoolean

C#

public SqlBoolean bEinstiegsmakro {get; set;}

C++

public:
property SqlBoolean bEinstiegsmakro {
SqlBoolean get( );
void set(
SqlBoolean value
);
}

JScript

public function get bEinstiegsmakro() : SqlBoolean;
public function set bEinstiegsmakro(value : SqlBoolean);

Source code

Visual Basic

Copy Code Copy Code

Public Property [bEinstiegsmakro]() As SqlBoolean
Get
Return m_bEinstiegsmakro
End Get
Set(ByVal Value As SqlBoolean)
m_bEinstiegsmakro = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsVorlagenfeld Class
clsVorlagenfeld clsVorlagenfeld Members


clsVorlagenfeld.daErstellt_am Property

clsVorlagenfeld.daErstellt_am Property

clsVorlagenfeld.daErstellt_am Property | Previous topic | Next topic
clsVorlagenfeld.daErstellt_am Property | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property daErstellt_am() As SqlDateTime

C#

public SqlDateTime daErstellt_am {get; set;}

C++

public:
property SqlDateTime daErstellt_am {
SqlDateTime get( );
void set(
SqlDateTime value
);
}

JScript

public function get daErstellt_am() : SqlDateTime;
public function set daErstellt_am(value : SqlDateTime);

Source code

Visual Basic

Copy Code Copy Code

Public Property [daErstellt_am]() As SqlDateTime
Get
Return m_daErstellt_am
End Get
Set(ByVal Value As SqlDateTime)
m_daErstellt_am = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsVorlagenfeld Class
clsVorlagenfeld clsVorlagenfeld Members


clsVorlagenfeld.daMutiert_am Property

clsVorlagenfeld.daMutiert_am Property

clsVorlagenfeld.daMutiert_am Property | Previous topic | Next topic
clsVorlagenfeld.daMutiert_am Property | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property daMutiert_am() As SqlDateTime

C#

public SqlDateTime daMutiert_am {get; set;}

C++

public:
property SqlDateTime daMutiert_am {
SqlDateTime get( );
void set(
SqlDateTime value
);
}

JScript

public function get daMutiert_am() : SqlDateTime;
public function set daMutiert_am(value : SqlDateTime);

Source code

Visual Basic

Copy Code Copy Code

Public Property [daMutiert_am]() As SqlDateTime
Get
Return m_daMutiert_am
End Get
Set(ByVal Value As SqlDateTime)
m_daMutiert_am = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsVorlagenfeld Class
clsVorlagenfeld clsVorlagenfeld Members


clsVorlagenfeld.iDokumenttypnr Property

clsVorlagenfeld.iDokumenttypnr Property

clsVorlagenfeld.iDokumenttypnr Property | Previous topic | Next topic
clsVorlagenfeld.iDokumenttypnr Property | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property iDokumenttypnr() As SqlInt32

C#

public SqlInt32 iDokumenttypnr {get; set;}

C++

public:
property SqlInt32 iDokumenttypnr {
SqlInt32 get( );
void set(
SqlInt32 value
);
}

JScript

public function get iDokumenttypnr() : SqlInt32;
public function set iDokumenttypnr(value : SqlInt32);

Source code

Visual Basic

Copy Code Copy Code

Public Property [iDokumenttypnr]() As SqlInt32
Get
Return m_iDokumenttypnr
End Get
Set(ByVal Value As SqlInt32)
m_iDokumenttypnr = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsVorlagenfeld Class
clsVorlagenfeld clsVorlagenfeld Members


clsVorlagenfeld.iDokumenttypnrOld Property

clsVorlagenfeld.iDokumenttypnrOld Property

clsVorlagenfeld.iDokumenttypnrOld Property | Previous topic | Next topic
clsVorlagenfeld.iDokumenttypnrOld Property | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property iDokumenttypnrOld() As SqlInt32

C#

public SqlInt32 iDokumenttypnrOld {get; set;}

C++

public:
property SqlInt32 iDokumenttypnrOld {
SqlInt32 get( );
void set(
SqlInt32 value
);
}

JScript

public function get iDokumenttypnrOld() : SqlInt32;
public function set iDokumenttypnrOld(value : SqlInt32);

Source code

Visual Basic

Copy Code Copy Code

Public Property [iDokumenttypnrOld]() As SqlInt32
Get
Return m_iDokumenttypnrOld
End Get
Set(ByVal Value As SqlInt32)
m_iDokumenttypnrOld = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsVorlagenfeld Class
clsVorlagenfeld clsVorlagenfeld Members


clsVorlagenfeld.iMandantnr Property

clsVorlagenfeld.iMandantnr Property

clsVorlagenfeld.iMandantnr Property | Previous topic | Next topic
clsVorlagenfeld.iMandantnr Property | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property iMandantnr() As SqlInt32

C#

public SqlInt32 iMandantnr {get; set;}

C++

public:
property SqlInt32 iMandantnr {
SqlInt32 get( );
void set(
SqlInt32 value
);
}

JScript

public function get iMandantnr() : SqlInt32;
public function set iMandantnr(value : SqlInt32);

Source code

Visual Basic

Copy Code Copy Code

Public Property [iMandantnr]() As SqlInt32
Get
Return m_iMandantnr
End Get
Set(ByVal Value As SqlInt32)
m_iMandantnr = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsVorlagenfeld Class
clsVorlagenfeld clsVorlagenfeld Members


clsVorlagenfeld.iMutierer Property

clsVorlagenfeld.iMutierer Property

clsVorlagenfeld.iMutierer Property | Previous topic | Next topic
clsVorlagenfeld.iMutierer Property | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property iMutierer() As SqlInt32

C#

public SqlInt32 iMutierer {get; set;}

C++

public:
property SqlInt32 iMutierer {
SqlInt32 get( );
void set(
SqlInt32 value
);
}

JScript

public function get iMutierer() : SqlInt32;
public function set iMutierer(value : SqlInt32);

Source code

Visual Basic

Copy Code Copy Code

Public Property [iMutierer]() As SqlInt32
Get
Return m_iMutierer
End Get
Set(ByVal Value As SqlInt32)
m_iMutierer = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsVorlagenfeld Class
clsVorlagenfeld clsVorlagenfeld Members


clsVorlagenfeld.iVorlagenfeldnr Property

clsVorlagenfeld.iVorlagenfeldnr Property

clsVorlagenfeld.iVorlagenfeldnr Property | Previous topic | Next topic
clsVorlagenfeld.iVorlagenfeldnr Property | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property iVorlagenfeldnr() As SqlInt32

C#

public SqlInt32 iVorlagenfeldnr {get; set;}

C++

public:
property SqlInt32 iVorlagenfeldnr {
SqlInt32 get( );
void set(
SqlInt32 value
);
}

JScript

public function get iVorlagenfeldnr() : SqlInt32;
public function set iVorlagenfeldnr(value : SqlInt32);

Source code

Visual Basic

Copy Code Copy Code

Public Property [iVorlagenfeldnr]() As SqlInt32
Get
Return m_iVorlagenfeldnr
End Get
Set(ByVal Value As SqlInt32)
Dim iVorlagenfeldnrTmp As SqlInt32 = Value
If iVorlagenfeldnrTmp.IsNull Then
Throw New ArgumentOutOfRangeException("iVorlagenfeldnr", "iVorlagenfeldnr can't be NULL")
End If
m_iVorlagenfeldnr = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsVorlagenfeld Class
clsVorlagenfeld clsVorlagenfeld Members


clsVorlagenfeld.iVorlagenfeldregelnr Property

clsVorlagenfeld.iVorlagenfeldregelnr Property

clsVorlagenfeld.iVorlagenfeldregelnr Property | Previous topic | Next topic
clsVorlagenfeld.iVorlagenfeldregelnr Property | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property iVorlagenfeldregelnr() As SqlInt32

C#

public SqlInt32 iVorlagenfeldregelnr {get; set;}

C++

public:
property SqlInt32 iVorlagenfeldregelnr {
SqlInt32 get( );
void set(
SqlInt32 value
);
}

JScript

public function get iVorlagenfeldregelnr() : SqlInt32;
public function set iVorlagenfeldregelnr(value : SqlInt32);

Source code

Visual Basic

Copy Code Copy Code

Public Property [iVorlagenfeldregelnr]() As SqlInt32
Get
Return m_iVorlagenfeldregelnr
End Get
Set(ByVal Value As SqlInt32)
m_iVorlagenfeldregelnr = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsVorlagenfeld Class
clsVorlagenfeld clsVorlagenfeld Members


clsVorlagenfeld.iVorlagenfeldregelnrOld Property

clsVorlagenfeld.iVorlagenfeldregelnrOld Property

clsVorlagenfeld.iVorlagenfeldregelnrOld Property | Previous topic | Next topic
clsVorlagenfeld.iVorlagenfeldregelnrOld Property | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property iVorlagenfeldregelnrOld() As SqlInt32

C#

public SqlInt32 iVorlagenfeldregelnrOld {get; set;}

C++

public:
property SqlInt32 iVorlagenfeldregelnrOld {
SqlInt32 get( );
void set(
SqlInt32 value
);
}

JScript

public function get iVorlagenfeldregelnrOld() : SqlInt32;
public function set iVorlagenfeldregelnrOld(value : SqlInt32);

Source code

Visual Basic

Copy Code Copy Code

Public Property [iVorlagenfeldregelnrOld]() As SqlInt32
Get
Return m_iVorlagenfeldregelnrOld
End Get
Set(ByVal Value As SqlInt32)
m_iVorlagenfeldregelnrOld = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsVorlagenfeld Class
clsVorlagenfeld clsVorlagenfeld Members


clsVorlagenfeld.sBeginntextmarke Property

clsVorlagenfeld.sBeginntextmarke Property

clsVorlagenfeld.sBeginntextmarke Property | Previous topic | Next topic
clsVorlagenfeld.sBeginntextmarke Property | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property sBeginntextmarke() As SqlString

C#

public SqlString sBeginntextmarke {get; set;}

C++

public:
property SqlString sBeginntextmarke {
SqlString get( );
void set(
SqlString value
);
}

JScript

public function get sBeginntextmarke() : SqlString;
public function set sBeginntextmarke(value : SqlString);

Source code

Visual Basic

Copy Code Copy Code

Public Property [sBeginntextmarke]() As SqlString
Get
Return m_sBeginntextmarke
End Get
Set(ByVal Value As SqlString)
m_sBeginntextmarke = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsVorlagenfeld Class
clsVorlagenfeld clsVorlagenfeld Members


clsVorlagenfeld.sEndetextmarke Property

clsVorlagenfeld.sEndetextmarke Property

clsVorlagenfeld.sEndetextmarke Property | Previous topic | Next topic
clsVorlagenfeld.sEndetextmarke Property | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property sEndetextmarke() As SqlString

C#

public SqlString sEndetextmarke {get; set;}

C++

public:
property SqlString sEndetextmarke {
SqlString get( );
void set(
SqlString value
);
}

JScript

public function get sEndetextmarke() : SqlString;
public function set sEndetextmarke(value : SqlString);

Source code

Visual Basic

Copy Code Copy Code

Public Property [sEndetextmarke]() As SqlString
Get
Return m_sEndetextmarke
End Get
Set(ByVal Value As SqlString)
m_sEndetextmarke = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsVorlagenfeld Class
clsVorlagenfeld clsVorlagenfeld Members


clsVorlagenfeld.sFeldname Property

clsVorlagenfeld.sFeldname Property

clsVorlagenfeld.sFeldname Property | Previous topic | Next topic
clsVorlagenfeld.sFeldname Property | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property sFeldname() As SqlString

C#

public SqlString sFeldname {get; set;}

C++

public:
property SqlString sFeldname {
SqlString get( );
void set(
SqlString value
);
}

JScript

public function get sFeldname() : SqlString;
public function set sFeldname(value : SqlString);

Source code

Visual Basic

Copy Code Copy Code

Public Property [sFeldname]() As SqlString
Get
Return m_sFeldname
End Get
Set(ByVal Value As SqlString)
m_sFeldname = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsVorlagenfeld Class
clsVorlagenfeld clsVorlagenfeld Members


clsVorlagenfeld.sTestdaten Property

clsVorlagenfeld.sTestdaten Property

clsVorlagenfeld.sTestdaten Property | Previous topic | Next topic
clsVorlagenfeld.sTestdaten Property | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property sTestdaten() As SqlString

C#

public SqlString sTestdaten {get; set;}

C++

public:
property SqlString sTestdaten {
SqlString get( );
void set(
SqlString value
);
}

JScript

public function get sTestdaten() : SqlString;
public function set sTestdaten(value : SqlString);

Source code

Visual Basic

Copy Code Copy Code

Public Property [sTestdaten]() As SqlString
Get
Return m_sTestdaten
End Get
Set(ByVal Value As SqlString)
m_sTestdaten = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsVorlagenfeld Class
clsVorlagenfeld clsVorlagenfeld Members


clsMyDokumentDaten Methods

clsMyDokumentDaten Methods

clsMyDokumentDaten Methods | Previous topic | Next topic
clsMyDokumentDaten Methods | Previous topic | Next topic

Public Methods

 | Name | Description
Supported by the .NET Compact Framework. | Delete | (inherited from clsVorlagenfeld ).
Supported by the .NET Compact Framework. | Dispose | (Overloaded) (inherited from clsDBInteractionBase ).
Public method | Equals | (Overloaded) (inherited from Object).
Public method | GetHashCode | (inherited from Object).
Public method | GetType | (Overloaded) (inherited from Object).
Supported by the .NET Compact Framework. | Insert | (inherited from clsVorlagenfeld ).
 | ReferenceEquals | (inherited from Object).
Supported by the .NET Compact Framework. | SelectAll | (inherited from clsVorlagenfeld ).
Supported by the .NET Compact Framework. | SelectAllWdokumenttypnrLogic | (inherited from clsVorlagenfeld ).
Supported by the .NET Compact Framework. | SelectAllWvorlagenfeldregelnrLogic | (inherited from clsVorlagenfeld ).
Supported by the .NET Compact Framework. | SelectOne | (inherited from clsVorlagenfeld ).
Supported by the .NET Compact Framework. | SelectTestdata |
Supported by the .NET Compact Framework. | Select_IDVMakros |
Public method | ToString | (inherited from Object).
Supported by the .NET Compact Framework. | Update | (inherited from clsVorlagenfeld ).
Supported by the .NET Compact Framework. | UpdateAllWdokumenttypnrLogic | (inherited from clsVorlagenfeld ).
Supported by the .NET Compact Framework. | UpdateAllWvorlagenfeldregelnrLogic | (inherited from clsVorlagenfeld ).

Top

Protected Methods

 | Name | Description
Protected method | Finalize | (inherited from Object).
Protected method | MemberwiseClone | (Overloaded) (inherited from Object).

Top

See Also

Reference

clsMyDokumentDaten Class


clsVorlagenfeld.Delete Method

clsVorlagenfeld.Delete Method

clsVorlagenfeld.Delete Method | Previous topic | Next topic
clsVorlagenfeld.Delete Method | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Overrides Function Delete() As Boolean

C#

public override bool Delete()

C++

public:
bool Delete()

JScript

public function Delete() : boolean;

Source code

Visual Basic

Copy Code Copy Code

Public Overrides Function Delete() As Boolean
Dim scmCmdToExecute As SqlCommand = New SqlCommand()
scmCmdToExecute.CommandText = "dbo.[pr_vorlagenfeld_Delete]"
scmCmdToExecute.CommandType = CommandType.StoredProcedure

' // Use base class' connection object
scmCmdToExecute.Connection = m_scoMainConnection

Try
scmCmdToExecute.Parameters.Add(New SqlParameter("@ivorlagenfeldnr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iVorlagenfeldnr))
scmCmdToExecute.Parameters.Add(New SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

If m_bMainConnectionIsCreatedLocal Then
' // Open connection.
m_scoMainConnection.Open()
Else
If m_cpMainConnectionProvider.bIsTransactionPending Then
scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
End If
End If

' // Execute query.
scmCmdToExecute.ExecuteNonQuery()
m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
' // Throw error.
Throw New Exception("Stored Procedure 'pr_vorlagenfeld_Delete' reported the ErrorCode: " & m_iErrorCode.ToString())
End If

Return True
Catch ex As Exception
' // some error occured. Bubble it to caller and encapsulate Exception object
Throw New Exception("clsVorlagenfeld::Delete::Error occured.", ex)
Finally
If m_bMainConnectionIsCreatedLocal Then
' // Close connection.
m_scoMainConnection.Close()
End If
scmCmdToExecute.Dispose()
End Try
End Function

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsVorlagenfeld Class
clsVorlagenfeld clsVorlagenfeld Members


clsVorlagenfeld.Insert Method

clsVorlagenfeld.Insert Method

clsVorlagenfeld.Insert Method | Previous topic | Next topic
clsVorlagenfeld.Insert Method | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Overrides Function Insert() As Boolean

C#

public override bool Insert()

C++

public:
bool Insert()

JScript

public function Insert() : boolean;

Source code

Visual Basic

Copy Code Copy Code

Overrides Public Function Insert() As Boolean
Dim scmCmdToExecute As SqlCommand = New SqlCommand()
scmCmdToExecute.CommandText = "dbo.[pr_vorlagenfeld_Insert]"
scmCmdToExecute.CommandType = CommandType.StoredProcedure

' // Use base class' connection object
scmCmdToExecute.Connection = m_scoMainConnection

Try
scmCmdToExecute.Parameters.Add(New SqlParameter("@ivorlagenfeldnr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iVorlagenfeldnr))
scmCmdToExecute.Parameters.Add(New SqlParameter("@idokumenttypnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iDokumenttypnr))
scmCmdToExecute.Parameters.Add(New SqlParameter("@ivorlagenfeldregelnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iVorlagenfeldregelnr))
scmCmdToExecute.Parameters.Add(New SqlParameter("@sfeldname", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sFeldname))
scmCmdToExecute.Parameters.Add(New SqlParameter("@sbeginntextmarke", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBeginntextmarke))
scmCmdToExecute.Parameters.Add(New SqlParameter("@sendetextmarke", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sEndetextmarke))
scmCmdToExecute.Parameters.Add(New SqlParameter("@beinstiegsmakro", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bEinstiegsmakro))
scmCmdToExecute.Parameters.Add(New SqlParameter("@bausstiegsmakro", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bAusstiegsmakro))
scmCmdToExecute.Parameters.Add(New SqlParameter("@stestdaten", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sTestdaten))
scmCmdToExecute.Parameters.Add(New SqlParameter("@imandantnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMandantnr))
scmCmdToExecute.Parameters.Add(New SqlParameter("@baktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bAktiv))
scmCmdToExecute.Parameters.Add(New SqlParameter("@daerstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daErstellt_am))
scmCmdToExecute.Parameters.Add(New SqlParameter("@damutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daMutiert_am))
scmCmdToExecute.Parameters.Add(New SqlParameter("@imutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

If m_bMainConnectionIsCreatedLocal Then
' // Open connection.
m_scoMainConnection.Open()
Else
If m_cpMainConnectionProvider.bIsTransactionPending Then
scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
End If
End If

' // Execute query.
scmCmdToExecute.ExecuteNonQuery()
m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
' // Throw error.
Throw New Exception("Stored Procedure 'pr_vorlagenfeld_Insert' reported the ErrorCode: " & m_iErrorCode.ToString())
End If

Return True
Catch ex As Exception
' // some error occured. Bubble it to caller and encapsulate Exception object
Throw New Exception("clsVorlagenfeld::Insert::Error occured.", ex)
Finally
If m_bMainConnectionIsCreatedLocal Then
' // Close connection.
m_scoMainConnection.Close()
End If
scmCmdToExecute.Dispose()
End Try
End Function

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsVorlagenfeld Class
clsVorlagenfeld clsVorlagenfeld Members


clsVorlagenfeld.SelectAll Method

clsVorlagenfeld.SelectAll Method

clsVorlagenfeld.SelectAll Method | Previous topic | Next topic
clsVorlagenfeld.SelectAll Method | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Overrides Function SelectAll() As DataTable

C#

public override DataTable SelectAll()

C++

public:
DataTable^ SelectAll()

JScript

public function SelectAll() : DataTable;

Source code

Visual Basic

Copy Code Copy Code

Public Overrides Function SelectAll() As DataTable
Dim scmCmdToExecute As SqlCommand = New SqlCommand()
scmCmdToExecute.CommandText = "dbo.[pr_vorlagenfeld_SelectAll]"
scmCmdToExecute.CommandType = CommandType.StoredProcedure
Dim dtToReturn As DataTable = New DataTable("vorlagenfeld")
Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)

' // Use base class' connection object
scmCmdToExecute.Connection = m_scoMainConnection

Try
scmCmdToExecute.Parameters.Add(New SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

If m_bMainConnectionIsCreatedLocal Then
' // Open connection.
m_scoMainConnection.Open()
Else
If m_cpMainConnectionProvider.bIsTransactionPending Then
scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
End If
End If

' // Execute query.
sdaAdapter.Fill(dtToReturn)
m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
' // Throw error.
Throw New Exception("Stored Procedure 'pr_vorlagenfeld_SelectAll' reported the ErrorCode: " & m_iErrorCode.ToString())
End If

Return dtToReturn
Catch ex As Exception
' // some error occured. Bubble it to caller and encapsulate Exception object
Throw New Exception("clsVorlagenfeld::SelectAll::Error occured.", ex)
Finally
If m_bMainConnectionIsCreatedLocal Then
' // Close connection.
m_scoMainConnection.Close()
End If
scmCmdToExecute.Dispose()
sdaAdapter.Dispose()
End Try
End Function

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsVorlagenfeld Class
clsVorlagenfeld clsVorlagenfeld Members


clsVorlagenfeld.SelectAllWdokumenttypnrLogic Method

clsVorlagenfeld.SelectAllWdokumenttypnrLogic Method

clsVorlagenfeld.SelectAllWdokumenttypnrLogic Method | Previous topic | Next topic
clsVorlagenfeld.SelectAllWdokumenttypnrLogic Method | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Function SelectAllWdokumenttypnrLogic() As DataTable

C#

public DataTable SelectAllWdokumenttypnrLogic()

C++

public:
DataTable^ SelectAllWdokumenttypnrLogic()

JScript

public function SelectAllWdokumenttypnrLogic() : DataTable;

Source code

Visual Basic

Copy Code Copy Code

Public Function SelectAllWdokumenttypnrLogic() As DataTable
Dim scmCmdToExecute As SqlCommand = New SqlCommand()
scmCmdToExecute.CommandText = "dbo.[pr_vorlagenfeld_SelectAllWdokumenttypnrLogic]"
scmCmdToExecute.CommandType = CommandType.StoredProcedure
Dim dtToReturn As DataTable = new DataTable("vorlagenfeld")
Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

' // Use base class' connection object
scmCmdToExecute.Connection = m_scoMainConnection

Try
scmCmdToExecute.Parameters.Add(new SqlParameter("@idokumenttypnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iDokumenttypnr))
scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

If m_bMainConnectionIsCreatedLocal Then
' // Open connection.
m_scoMainConnection.Open()
Else
If m_cpMainConnectionProvider.bIsTransactionPending Then
scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
End If
End If

' // Execute query.
sdaAdapter.Fill(dtToReturn)
m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
' // Throw error.
Throw New Exception("Stored Procedure 'pr_vorlagenfeld_SelectAllWdokumenttypnrLogic' reported the ErrorCode: " & m_iErrorCode.ToString())
End If

Return dtToReturn
Catch ex As Exception
' // some error occured. Bubble it to caller and encapsulate Exception object
Throw New Exception("clsVorlagenfeld::SelectAllWdokumenttypnrLogic::Error occured.", ex)
Finally
If m_bMainConnectionIsCreatedLocal Then
' // Close connection.
m_scoMainConnection.Close()
End If
scmCmdToExecute.Dispose()
sdaAdapter.Dispose()
End Try
End Function

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsVorlagenfeld Class
clsVorlagenfeld clsVorlagenfeld Members


clsVorlagenfeld.SelectAllWvorlagenfeldregelnrLogic Method

clsVorlagenfeld.SelectAllWvorlagenfeldregelnrLogic Method

clsVorlagenfeld.SelectAllWvorlagenfeldregelnrLogic Method | Previous topic | Next topic
clsVorlagenfeld.SelectAllWvorlagenfeldregelnrLogic Method | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Function SelectAllWvorlagenfeldregelnrLogic() As DataTable

C#

public DataTable SelectAllWvorlagenfeldregelnrLogic()

C++

public:
DataTable^ SelectAllWvorlagenfeldregelnrLogic()

JScript

public function SelectAllWvorlagenfeldregelnrLogic() : DataTable;

Source code

Visual Basic

Copy Code Copy Code

Public Function SelectAllWvorlagenfeldregelnrLogic() As DataTable
Dim scmCmdToExecute As SqlCommand = New SqlCommand()
scmCmdToExecute.CommandText = "dbo.[pr_vorlagenfeld_SelectAllWvorlagenfeldregelnrLogic]"
scmCmdToExecute.CommandType = CommandType.StoredProcedure
Dim dtToReturn As DataTable = New DataTable("vorlagenfeld")
Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)

' // Use base class' connection object
scmCmdToExecute.Connection = m_scoMainConnection

Try
scmCmdToExecute.Parameters.Add(New SqlParameter("@ivorlagenfeldregelnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iVorlagenfeldregelnr))
scmCmdToExecute.Parameters.Add(New SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

If m_bMainConnectionIsCreatedLocal Then
' // Open connection.
m_scoMainConnection.Open()
Else
If m_cpMainConnectionProvider.bIsTransactionPending Then
scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
End If
End If

' // Execute query.
sdaAdapter.Fill(dtToReturn)
m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
' // Throw error.
Throw New Exception("Stored Procedure 'pr_vorlagenfeld_SelectAllWvorlagenfeldregelnrLogic' reported the ErrorCode: " & m_iErrorCode.ToString())
End If

Return dtToReturn
Catch ex As Exception
' // some error occured. Bubble it to caller and encapsulate Exception object
Throw New Exception("clsVorlagenfeld::SelectAllWvorlagenfeldregelnrLogic::Error occured.", ex)
Finally
If m_bMainConnectionIsCreatedLocal Then
' // Close connection.
m_scoMainConnection.Close()
End If
scmCmdToExecute.Dispose()
sdaAdapter.Dispose()
End Try
End Function

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsVorlagenfeld Class
clsVorlagenfeld clsVorlagenfeld Members


clsVorlagenfeld.SelectOne Method

clsVorlagenfeld.SelectOne Method

clsVorlagenfeld.SelectOne Method | Previous topic | Next topic
clsVorlagenfeld.SelectOne Method | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Overrides Function SelectOne() As DataTable

C#

public override DataTable SelectOne()

C++

public:
DataTable^ SelectOne()

JScript

public function SelectOne() : DataTable;

Source code

Visual Basic

Copy Code Copy Code

Overrides Public Function SelectOne() As DataTable
Dim scmCmdToExecute As SqlCommand = New SqlCommand()
scmCmdToExecute.CommandText = "dbo.[pr_vorlagenfeld_SelectOne]"
scmCmdToExecute.CommandType = CommandType.StoredProcedure
Dim dtToReturn As DataTable = new DataTable("vorlagenfeld")
Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

' // Use base class' connection object
scmCmdToExecute.Connection = m_scoMainConnection

Try
scmCmdToExecute.Parameters.Add(new SqlParameter("@ivorlagenfeldnr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iVorlagenfeldnr))
scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

If m_bMainConnectionIsCreatedLocal Then
' // Open connection.
m_scoMainConnection.Open()
Else
If m_cpMainConnectionProvider.bIsTransactionPending Then
scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
End If
End If

' // Execute query.
sdaAdapter.Fill(dtToReturn)
m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
' // Throw error.
Throw New Exception("Stored Procedure 'pr_vorlagenfeld_SelectOne' reported the ErrorCode: " & m_iErrorCode.ToString())
End If

If dtToReturn.Rows.Count > 0 Then
m_iVorlagenfeldnr = New SqlInt32(CType(dtToReturn.Rows(0)("vorlagenfeldnr"), Integer))
If dtToReturn.Rows(0)("dokumenttypnr") Is System.DBNull.Value Then
m_iDokumenttypnr = SqlInt32.Null
Else
m_iDokumenttypnr = New SqlInt32(CType(dtToReturn.Rows(0)("dokumenttypnr"), Integer))
End If
If dtToReturn.Rows(0)("vorlagenfeldregelnr") Is System.DBNull.Value Then
m_iVorlagenfeldregelnr = SqlInt32.Null
Else
m_iVorlagenfeldregelnr = New SqlInt32(CType(dtToReturn.Rows(0)("vorlagenfeldregelnr"), Integer))
End If
If dtToReturn.Rows(0)("feldname") Is System.DBNull.Value Then
m_sFeldname = SqlString.Null
Else
m_sFeldname = New SqlString(CType(dtToReturn.Rows(0)("feldname"), String))
End If
If dtToReturn.Rows(0)("beginntextmarke") Is System.DBNull.Value Then
m_sBeginntextmarke = SqlString.Null
Else
m_sBeginntextmarke = New SqlString(CType(dtToReturn.Rows(0)("beginntextmarke"), String))
End If
If dtToReturn.Rows(0)("endetextmarke") Is System.DBNull.Value Then
m_sEndetextmarke = SqlString.Null
Else
m_sEndetextmarke = New SqlString(CType(dtToReturn.Rows(0)("endetextmarke"), String))
End If
If dtToReturn.Rows(0)("einstiegsmakro") Is System.DBNull.Value Then
m_bEinstiegsmakro = SqlBoolean.Null
Else
m_bEinstiegsmakro = New SqlBoolean(CType(dtToReturn.Rows(0)("einstiegsmakro"), Boolean))
End If
If dtToReturn.Rows(0)("ausstiegsmakro") Is System.DBNull.Value Then
m_bAusstiegsmakro = SqlBoolean.Null
Else
m_bAusstiegsmakro = New SqlBoolean(CType(dtToReturn.Rows(0)("ausstiegsmakro"), Boolean))
End If
If dtToReturn.Rows(0)("testdaten") Is System.DBNull.Value Then
m_sTestdaten = SqlString.Null
Else
m_sTestdaten = New SqlString(CType(dtToReturn.Rows(0)("testdaten"), String))
End If
If dtToReturn.Rows(0)("mandantnr") Is System.DBNull.Value Then
m_iMandantnr = SqlInt32.Null
Else
m_iMandantnr = New SqlInt32(CType(dtToReturn.Rows(0)("mandantnr"), Integer))
End If
If dtToReturn.Rows(0)("aktiv") Is System.DBNull.Value Then
m_bAktiv = SqlBoolean.Null
Else
m_bAktiv = New SqlBoolean(CType(dtToReturn.Rows(0)("aktiv"), Boolean))
End If
If dtToReturn.Rows(0)("erstellt_am") Is System.DBNull.Value Then
m_daErstellt_am = SqlDateTime.Null
Else
m_daErstellt_am = New SqlDateTime(CType(dtToReturn.Rows(0)("erstellt_am"), Date))
End If
If dtToReturn.Rows(0)("mutiert_am") Is System.DBNull.Value Then
m_daMutiert_am = SqlDateTime.Null
Else
m_daMutiert_am = New SqlDateTime(CType(dtToReturn.Rows(0)("mutiert_am"), Date))
End If
If dtToReturn.Rows(0)("mutierer") Is System.DBNull.Value Then
m_iMutierer = SqlInt32.Null
Else
m_iMutierer = New SqlInt32(CType(dtToReturn.Rows(0)("mutierer"), Integer))
End If
End If
Return dtToReturn
Catch ex As Exception
' // some error occured. Bubble it to caller and encapsulate Exception object
Throw New Exception("clsVorlagenfeld::SelectOne::Error occured.", ex)
Finally
If m_bMainConnectionIsCreatedLocal Then
' // Close connection.
m_scoMainConnection.Close()
End If
scmCmdToExecute.Dispose()
sdaAdapter.Dispose()
End Try
End Function

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsVorlagenfeld Class
clsVorlagenfeld clsVorlagenfeld Members


clsMyDokumentDaten.SelectTestdata Method

clsMyDokumentDaten.SelectTestdata Method

clsMyDokumentDaten.SelectTestdata Method | Previous topic | Next topic
clsMyDokumentDaten.SelectTestdata Method | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Function SelectTestdata( _
ByVal dokumenttypnr As Long _
) As DataTable

C#

public DataTable SelectTestdata(
longdokumenttypnr
)

C++

public:
DataTable^ SelectTestdata(
longdokumenttypnr
)

JScript

public function SelectTestdata(
dokumenttypnr : long
) : DataTable;

Parameters

dokumenttypnr

Source code

Visual Basic

Copy Code Copy Code

Public Function SelectTestdata(ByVal dokumenttypnr As Long) As DataTable
Dim scmCmdToExecute As SqlCommand = New SqlCommand()
scmCmdToExecute.CommandText = "dbo.[temp_sp_vorlagenfeld_Select]"
scmCmdToExecute.CommandType = CommandType.StoredProcedure
Dim dtToReturn As DataTable = New DataTable("vorlagenfeld")
Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)

' // Use base class' connection object
scmCmdToExecute.Connection = m_scoMainConnection

Try
scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumenttypnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, dokumenttypnr))
scmCmdToExecute.Parameters.Add(New SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

If m_bMainConnectionIsCreatedLocal Then
' // Open connection.
m_scoMainConnection.Open()
Else
If m_cpMainConnectionProvider.bIsTransactionPending Then
scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
End If
End If

' // Execute query.
sdaAdapter.Fill(dtToReturn)
m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
' // Throw error.
Throw New Exception("Stored Procedure 'pr_vorlagenfeld_SelectAll' reported the ErrorCode: " & m_iErrorCode.ToString())
End If

Return dtToReturn
Catch ex As Exception
' // some error occured. Bubble it to caller and encapsulate Exception object
Throw New Exception("clsVorlagenfeld::SelectAll::Error occured.", ex)
Finally
If m_bMainConnectionIsCreatedLocal Then
' // Close connection.
m_scoMainConnection.Close()
End If
scmCmdToExecute.Dispose()
sdaAdapter.Dispose()
End Try
End Function

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsMyDokumentDaten Class
clsMyDokumentDaten clsMyDokumentDaten Members


clsMyDokumentDaten.Select_IDVMakros Method

clsMyDokumentDaten.Select_IDVMakros Method

clsMyDokumentDaten.Select_IDVMakros Method | Previous topic | Next topic
clsMyDokumentDaten.Select_IDVMakros Method | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Function Select_IDVMakros( _
ByVal dokumenttypnr As Long _
) As DataTable

C#

public DataTable Select_IDVMakros(
longdokumenttypnr
)

C++

public:
DataTable^ Select_IDVMakros(
longdokumenttypnr
)

JScript

public function Select_IDVMakros(
dokumenttypnr : long
) : DataTable;

Parameters

dokumenttypnr

Source code

Visual Basic

Copy Code Copy Code

Public Function Select_IDVMakros(ByVal dokumenttypnr As Long) As DataTable
Dim scmCmdToExecute As SqlCommand = New SqlCommand()
scmCmdToExecute.CommandText = "dbo.[sp_idvmakros_Select]"
scmCmdToExecute.CommandType = CommandType.StoredProcedure
Dim dtToReturn As DataTable = New DataTable("vorlagenfeld")
Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)

' // Use base class' connection object
scmCmdToExecute.Connection = m_scoMainConnection

Try
scmCmdToExecute.Parameters.Add(New SqlParameter("@dokumenttypnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, dokumenttypnr))
scmCmdToExecute.Parameters.Add(New SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

If m_bMainConnectionIsCreatedLocal Then
' // Open connection.
m_scoMainConnection.Open()
Else
If m_cpMainConnectionProvider.bIsTransactionPending Then
scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
End If
End If

' // Execute query.
sdaAdapter.Fill(dtToReturn)
m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
' // Throw error.
Throw New Exception("Stored Procedure 'sp_idvmakros_select' reported the ErrorCode: " & m_iErrorCode.ToString())
End If

Return dtToReturn
Catch ex As Exception
' // some error occured. Bubble it to caller and encapsulate Exception object
Throw New Exception("sp_idvmakros_select::SelectAll::Error occured." + ex.Message, ex)
Finally
If m_bMainConnectionIsCreatedLocal Then
' // Close connection.
m_scoMainConnection.Close()
End If
scmCmdToExecute.Dispose()
sdaAdapter.Dispose()
End Try
End Function

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsMyDokumentDaten Class
clsMyDokumentDaten clsMyDokumentDaten Members


clsVorlagenfeld.Update Method

clsVorlagenfeld.Update Method

clsVorlagenfeld.Update Method | Previous topic | Next topic
clsVorlagenfeld.Update Method | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Overrides Function Update() As Boolean

C#

public override bool Update()

C++

public:
bool Update()

JScript

public function Update() : boolean;

Source code

Visual Basic

Copy Code Copy Code

Overrides Public Function Update() As Boolean
Dim scmCmdToExecute As SqlCommand = New SqlCommand()
scmCmdToExecute.CommandText = "dbo.[pr_vorlagenfeld_Update]"
scmCmdToExecute.CommandType = CommandType.StoredProcedure

' // Use base class' connection object
scmCmdToExecute.Connection = m_scoMainConnection

Try
scmCmdToExecute.Parameters.Add(New SqlParameter("@ivorlagenfeldnr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iVorlagenfeldnr))
scmCmdToExecute.Parameters.Add(New SqlParameter("@idokumenttypnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iDokumenttypnr))
scmCmdToExecute.Parameters.Add(New SqlParameter("@ivorlagenfeldregelnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iVorlagenfeldregelnr))
scmCmdToExecute.Parameters.Add(New SqlParameter("@sfeldname", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sFeldname))
scmCmdToExecute.Parameters.Add(New SqlParameter("@sbeginntextmarke", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBeginntextmarke))
scmCmdToExecute.Parameters.Add(New SqlParameter("@sendetextmarke", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sEndetextmarke))
scmCmdToExecute.Parameters.Add(New SqlParameter("@beinstiegsmakro", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bEinstiegsmakro))
scmCmdToExecute.Parameters.Add(New SqlParameter("@bausstiegsmakro", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bAusstiegsmakro))
scmCmdToExecute.Parameters.Add(New SqlParameter("@stestdaten", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sTestdaten))
scmCmdToExecute.Parameters.Add(New SqlParameter("@imandantnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMandantnr))
scmCmdToExecute.Parameters.Add(New SqlParameter("@baktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bAktiv))
scmCmdToExecute.Parameters.Add(New SqlParameter("@daerstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daErstellt_am))
scmCmdToExecute.Parameters.Add(New SqlParameter("@damutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daMutiert_am))
scmCmdToExecute.Parameters.Add(New SqlParameter("@imutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

If m_bMainConnectionIsCreatedLocal Then
' // Open connection.
m_scoMainConnection.Open()
Else
If m_cpMainConnectionProvider.bIsTransactionPending Then
scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
End If
End If

' // Execute query.
scmCmdToExecute.ExecuteNonQuery()
m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
' // Throw error.
Throw New Exception("Stored Procedure 'pr_vorlagenfeld_Update' reported the ErrorCode: " & m_iErrorCode.ToString())
End If

Return True
Catch ex As Exception
' // some error occured. Bubble it to caller and encapsulate Exception object
Throw New Exception("clsVorlagenfeld::Update::Error occured.", ex)
Finally
If m_bMainConnectionIsCreatedLocal Then
' // Close connection.
m_scoMainConnection.Close()
End If
scmCmdToExecute.Dispose()
End Try
End Function

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsVorlagenfeld Class
clsVorlagenfeld clsVorlagenfeld Members


clsVorlagenfeld.UpdateAllWdokumenttypnrLogic Method

clsVorlagenfeld.UpdateAllWdokumenttypnrLogic Method

clsVorlagenfeld.UpdateAllWdokumenttypnrLogic Method | Previous topic | Next topic
clsVorlagenfeld.UpdateAllWdokumenttypnrLogic Method | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Function UpdateAllWdokumenttypnrLogic() As Boolean

C#

public bool UpdateAllWdokumenttypnrLogic()

C++

public:
bool UpdateAllWdokumenttypnrLogic()

JScript

public function UpdateAllWdokumenttypnrLogic() : boolean;

Source code

Visual Basic

Copy Code Copy Code

Public Function UpdateAllWdokumenttypnrLogic() As Boolean
Dim scmCmdToExecute As SqlCommand = New SqlCommand()
scmCmdToExecute.CommandText = "dbo.[pr_vorlagenfeld_UpdateAllWdokumenttypnrLogic]"
scmCmdToExecute.CommandType = CommandType.StoredProcedure

' // Use base class' connection object
scmCmdToExecute.Connection = m_scoMainConnection

Try
scmCmdToExecute.Parameters.Add(New SqlParameter("@idokumenttypnr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iDokumenttypnr))
scmCmdToExecute.Parameters.Add(New SqlParameter("@idokumenttypnrOld", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iDokumenttypnrOld))
scmCmdToExecute.Parameters.Add(New SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

If m_bMainConnectionIsCreatedLocal Then
' // Open connection.
m_scoMainConnection.Open()
Else
If m_cpMainConnectionProvider.bIsTransactionPending Then
scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
End If
End If

' // Execute query.
scmCmdToExecute.ExecuteNonQuery()
m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
' // Throw error.
Throw New Exception("Stored Procedure 'pr_vorlagenfeld_UpdateAllWdokumenttypnrLogic' reported the ErrorCode: " & m_iErrorCode.ToString())
End If

Return True
Catch ex As Exception
' // some error occured. Bubble it to caller and encapsulate Exception object
Throw New Exception("clsVorlagenfeld::UpdateAllWdokumenttypnrLogic::Error occured.", ex)
Finally
If m_bMainConnectionIsCreatedLocal Then
' // Close connection.
m_scoMainConnection.Close()
End If
scmCmdToExecute.Dispose()
End Try
End Function

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsVorlagenfeld Class
clsVorlagenfeld clsVorlagenfeld Members


clsVorlagenfeld.UpdateAllWvorlagenfeldregelnrLogic Method

clsVorlagenfeld.UpdateAllWvorlagenfeldregelnrLogic Method

clsVorlagenfeld.UpdateAllWvorlagenfeldregelnrLogic Method | Previous topic | Next topic
clsVorlagenfeld.UpdateAllWvorlagenfeldregelnrLogic Method | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Function UpdateAllWvorlagenfeldregelnrLogic() As Boolean

C#

public bool UpdateAllWvorlagenfeldregelnrLogic()

C++

public:
bool UpdateAllWvorlagenfeldregelnrLogic()

JScript

public function UpdateAllWvorlagenfeldregelnrLogic() : boolean;

Source code

Visual Basic

Copy Code Copy Code

Public Function UpdateAllWvorlagenfeldregelnrLogic() As Boolean
Dim scmCmdToExecute As SqlCommand = New SqlCommand()
scmCmdToExecute.CommandText = "dbo.[pr_vorlagenfeld_UpdateAllWvorlagenfeldregelnrLogic]"
scmCmdToExecute.CommandType = CommandType.StoredProcedure

' // Use base class' connection object
scmCmdToExecute.Connection = m_scoMainConnection

Try
scmCmdToExecute.Parameters.Add(new SqlParameter("@ivorlagenfeldregelnr", SqlDbType.Int, 4, ParameterDirection.Input, false, 10, 0, "", DataRowVersion.Proposed, m_iVorlagenfeldregelnr))
scmCmdToExecute.Parameters.Add(new SqlParameter("@ivorlagenfeldregelnrOld", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iVorlagenfeldregelnrOld))
scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

If m_bMainConnectionIsCreatedLocal Then
' // Open connection.
m_scoMainConnection.Open()
Else
If m_cpMainConnectionProvider.bIsTransactionPending Then
scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
End If
End If

' // Execute query.
scmCmdToExecute.ExecuteNonQuery()
m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
' // Throw error.
Throw New Exception("Stored Procedure 'pr_vorlagenfeld_UpdateAllWvorlagenfeldregelnrLogic' reported the ErrorCode: " & m_iErrorCode.ToString())
End If

Return True
Catch ex As Exception
' // some error occured. Bubble it to caller and encapsulate Exception object
Throw New Exception("clsVorlagenfeld::UpdateAllWvorlagenfeldregelnrLogic::Error occured.", ex)
Finally
If m_bMainConnectionIsCreatedLocal Then
' // Close connection.
m_scoMainConnection.Close()
End If
scmCmdToExecute.Dispose()
End Try
End Function

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsVorlagenfeld Class
clsVorlagenfeld clsVorlagenfeld Members


clsMyDokumentDaten Fields

clsMyDokumentDaten Fields

clsMyDokumentDaten Fields | Previous topic | Next topic
clsMyDokumentDaten Fields | Previous topic | Next topic

Fields

 | Name | Description
Supported by the .NET Compact Framework. | m_bMainConnectionIsCreatedLocal | (inherited from clsDBInteractionBase ).
Supported by the .NET Compact Framework. | m_cpMainConnectionProvider | (inherited from clsDBInteractionBase ).
Supported by the .NET Compact Framework. | m_iErrorCode | (inherited from clsDBInteractionBase ).
Supported by the .NET Compact Framework. | m_scoMainConnection | (inherited from clsDBInteractionBase ).

Top

See Also

Reference

clsMyDokumentDaten Class


clsMyKey_Tabelle Class

clsMyKey_Tabelle Class

clsMyKey_Tabelle Class | Previous topic | Next topic
clsMyKey_Tabelle Class | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Class clsMyKey_Tabelle
Inherits clsKey_tabelle

C#

public class clsMyKey_Tabelle : clsKey_tabelle

C++

public ref class clsMyKey_Tabelle : public clsKey_tabelle^

JScript

public class clsMyKey_Tabelle
extends clsKey_tabelle

Inheritance Hierarchy

System.Object

EDKB12WS.edokadb.clsDBInteractionBase

EDKB12WS.edokadb.clsKey_tabelle

EDKB12WS.edokadb.clsMyKey_Tabelle

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsMyKey_Tabelle Members


clsMyKey_Tabelle Members

clsMyKey_Tabelle Members

clsMyKey_Tabelle Members | Previous topic | Next topic
clsMyKey_Tabelle Members | Previous topic | Next topic

The following tables list the members exposed by the clsMyKey_Tabelle type.

Public Constructors

 | Name | Description
Supported by the .NET Compact Framework. | clsMyKey_Tabelle Constructor | (inherited from clsKey_tabelle ).

Top

Public Properties

 | Name | Description
Supported by the .NET Compact Framework. | bAktiv | (inherited from clsKey_tabelle ).
Supported by the .NET Compact Framework. | cpMainConnectionProvider | (inherited from clsDBInteractionBase ).
Supported by the .NET Compact Framework. | daErstellt_am | (inherited from clsKey_tabelle ).
Supported by the .NET Compact Framework. | daMutiert_am | (inherited from clsKey_tabelle ).
Supported by the .NET Compact Framework. | iErrorCode | (inherited from clsDBInteractionBase ).
Supported by the .NET Compact Framework. | iKey_wert | (inherited from clsKey_tabelle ).
Supported by the .NET Compact Framework. | iKeynr | (inherited from clsKey_tabelle ).
Supported by the .NET Compact Framework. | iMandantnr | (inherited from clsKey_tabelle ).
Supported by the .NET Compact Framework. | iMutierer | (inherited from clsKey_tabelle ).
Supported by the .NET Compact Framework. | sBeschreibung | (inherited from clsKey_tabelle ).
Supported by the .NET Compact Framework. | sConnectionString | (inherited from clsDBInteractionBase ).

Top

Public Methods

 | Name | Description
Supported by the .NET Compact Framework. | Delete | (inherited from clsKey_tabelle ).
Supported by the .NET Compact Framework. | Dispose | (Overloaded) (inherited from clsDBInteractionBase ).
Public method | Equals | (Overloaded) (inherited from Object).
Public method | GetHashCode | (inherited from Object).
Public method | GetType | (Overloaded) (inherited from Object).
Supported by the .NET Compact Framework. | Insert | (inherited from clsKey_tabelle ).
 | ReferenceEquals | (inherited from Object).
Supported by the .NET Compact Framework. | SelectAll | (inherited from clsKey_tabelle ).
Supported by the .NET Compact Framework. | SelectOne | (inherited from clsKey_tabelle ).
Public method | ToString | (inherited from Object).
Supported by the .NET Compact Framework. | Update | (inherited from clsKey_tabelle ).
Supported by the .NET Compact Framework. | get_dbkey |

Top

Protected Methods

 | Name | Description
Protected method | Finalize | (inherited from Object).
Protected method | MemberwiseClone | (Overloaded) (inherited from Object).

Top

Fields

 | Name | Description
Supported by the .NET Compact Framework. | m_bMainConnectionIsCreatedLocal | (inherited from clsDBInteractionBase ).
Supported by the .NET Compact Framework. | m_cpMainConnectionProvider | (inherited from clsDBInteractionBase ).
Supported by the .NET Compact Framework. | m_iErrorCode | (inherited from clsDBInteractionBase ).
Supported by the .NET Compact Framework. | m_scoMainConnection | (inherited from clsDBInteractionBase ).

Top

See Also

Reference

clsMyKey_Tabelle Class


clsMyKey_Tabelle Properties

clsMyKey_Tabelle Properties

clsMyKey_Tabelle Properties | Previous topic | Next topic
clsMyKey_Tabelle Properties | Previous topic | Next topic

Public Properties

 | Name | Description
Supported by the .NET Compact Framework. | bAktiv | (inherited from clsKey_tabelle ).
Supported by the .NET Compact Framework. | cpMainConnectionProvider | (inherited from clsDBInteractionBase ).
Supported by the .NET Compact Framework. | daErstellt_am | (inherited from clsKey_tabelle ).
Supported by the .NET Compact Framework. | daMutiert_am | (inherited from clsKey_tabelle ).
Supported by the .NET Compact Framework. | iErrorCode | (inherited from clsDBInteractionBase ).
Supported by the .NET Compact Framework. | iKey_wert | (inherited from clsKey_tabelle ).
Supported by the .NET Compact Framework. | iKeynr | (inherited from clsKey_tabelle ).
Supported by the .NET Compact Framework. | iMandantnr | (inherited from clsKey_tabelle ).
Supported by the .NET Compact Framework. | iMutierer | (inherited from clsKey_tabelle ).
Supported by the .NET Compact Framework. | sBeschreibung | (inherited from clsKey_tabelle ).
Supported by the .NET Compact Framework. | sConnectionString | (inherited from clsDBInteractionBase ).

Top

See Also

Reference

clsMyKey_Tabelle Class


clsMyKey_Tabelle Methods

clsMyKey_Tabelle Methods

clsMyKey_Tabelle Methods | Previous topic | Next topic
clsMyKey_Tabelle Methods | Previous topic | Next topic

Public Methods

 | Name | Description
Supported by the .NET Compact Framework. | Delete | (inherited from clsKey_tabelle ).
Supported by the .NET Compact Framework. | Dispose | (Overloaded) (inherited from clsDBInteractionBase ).
Public method | Equals | (Overloaded) (inherited from Object).
Public method | GetHashCode | (inherited from Object).
Public method | GetType | (Overloaded) (inherited from Object).
Supported by the .NET Compact Framework. | Insert | (inherited from clsKey_tabelle ).
 | ReferenceEquals | (inherited from Object).
Supported by the .NET Compact Framework. | SelectAll | (inherited from clsKey_tabelle ).
Supported by the .NET Compact Framework. | SelectOne | (inherited from clsKey_tabelle ).
Public method | ToString | (inherited from Object).
Supported by the .NET Compact Framework. | Update | (inherited from clsKey_tabelle ).
Supported by the .NET Compact Framework. | get_dbkey |

Top

Protected Methods

 | Name | Description
Protected method | Finalize | (inherited from Object).
Protected method | MemberwiseClone | (Overloaded) (inherited from Object).

Top

See Also

Reference

clsMyKey_Tabelle Class


clsMyKey_Tabelle.get_dbkey Method

clsMyKey_Tabelle.get_dbkey Method

clsMyKey_Tabelle.get_dbkey Method | Previous topic | Next topic
clsMyKey_Tabelle.get_dbkey Method | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Function get_dbkey( _
ByVal Tablename As String _
) As Long

C#

public long get_dbkey(
stringTablename
)

C++

public:
long get_dbkey(
String^ Tablename
)

JScript

public function get_dbkey(
Tablename : String
) : long;

Parameters

Tablename

Source code

Visual Basic

Copy Code Copy Code

Public Function get_dbkey(ByVal Tablename As String) As Long
Dim m_dbkey As Long
Dim scmCmdToExecute As SqlCommand = New SqlCommand()
scmCmdToExecute.CommandText = "dbo.[sp_get_dbkey]"
scmCmdToExecute.CommandType = CommandType.StoredProcedure
' // Use base class' connection object
scmCmdToExecute.Connection = m_scoMainConnection
Try
scmCmdToExecute.Parameters.Add(New SqlParameter("@Tablename", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, Tablename))
scmCmdToExecute.Parameters.Add(New SqlParameter("@dbkey", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_dbkey))
scmCmdToExecute.Parameters.Add(New SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

If m_bMainConnectionIsCreatedLocal Then
' // Open connection.
m_scoMainConnection.Open()
Else
If m_cpMainConnectionProvider.bIsTransactionPending Then
scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
End If
End If

' // Execute query.
Try
scmCmdToExecute.Connection.Open()
Catch ex As Exception
Finally
End Try

scmCmdToExecute.ExecuteNonQuery()
m_dbkey = scmCmdToExecute.Parameters.Item("@dbkey").Value
m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))
scmCmdToExecute.Connection.Close()

If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
' // Throw error.
Throw New Exception("Stored Procedure 'sp_get_dbkey' reported the ErrorCode: " & m_iErrorCode.ToString())
End If

Return m_dbkey
Catch ex As Exception
' // some error occured. Bubble it to caller and encapsulate Exception object
Throw New Exception("clsKey_tabelle::get_dbkey::Error occured." + ex.Message, ex)
Finally
If m_bMainConnectionIsCreatedLocal Then
' // Close connection.
m_scoMainConnection.Close()
End If
scmCmdToExecute.Dispose()
End Try
End Function

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsMyKey_Tabelle Class
clsMyKey_Tabelle clsMyKey_Tabelle Members


clsMyKey_Tabelle Fields

clsMyKey_Tabelle Fields

clsMyKey_Tabelle Fields | Previous topic | Next topic
clsMyKey_Tabelle Fields | Previous topic | Next topic

Fields

 | Name | Description
Supported by the .NET Compact Framework. | m_bMainConnectionIsCreatedLocal | (inherited from clsDBInteractionBase ).
Supported by the .NET Compact Framework. | m_cpMainConnectionProvider | (inherited from clsDBInteractionBase ).
Supported by the .NET Compact Framework. | m_iErrorCode | (inherited from clsDBInteractionBase ).
Supported by the .NET Compact Framework. | m_scoMainConnection | (inherited from clsDBInteractionBase ).

Top

See Also

Reference

clsMyKey_Tabelle Class


clsMyPartner Class

clsMyPartner Class

clsMyPartner Class | Previous topic | Next topic
clsMyPartner Class | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Class clsMyPartner

C#

public class clsMyPartner

C++

public ref class clsMyPartner

JScript

public class clsMyPartner

Inheritance Hierarchy

System.Object

EDKB12WS.edokadb.clsMyPartner

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsMyPartner Members


clsMyPartner Members

clsMyPartner Members

clsMyPartner Members | Previous topic | Next topic
clsMyPartner Members | Previous topic | Next topic

The following tables list the members exposed by the clsMyPartner type.

Public Methods

 | Name | Description
Public method | Equals | (Overloaded) (inherited from Object).
Public method | GetHashCode | (inherited from Object).
Public method | GetType | (Overloaded) (inherited from Object).
Supported by the .NET Compact Framework. | Partner_Betreuer |
Supported by the .NET Compact Framework. | Partner_Detail |
Supported by the .NET Compact Framework. | Partner_Gebdat |
Supported by the .NET Compact Framework. | Partner_VV |
 | ReferenceEquals | (inherited from Object).
Public method | ToString | (inherited from Object).
Supported by the .NET Compact Framework. | search_doppelte_partner |
Supported by the .NET Compact Framework. | search_partner |

Top

Protected Methods

 | Name | Description
Protected method | Finalize | (inherited from Object).
Protected method | MemberwiseClone | (Overloaded) (inherited from Object).

Top

See Also

Reference

clsMyPartner Class


clsMyPartner Methods

clsMyPartner Methods

clsMyPartner Methods | Previous topic | Next topic
clsMyPartner Methods | Previous topic | Next topic

Public Methods

 | Name | Description
Public method | Equals | (Overloaded) (inherited from Object).
Public method | GetHashCode | (inherited from Object).
Public method | GetType | (Overloaded) (inherited from Object).
Supported by the .NET Compact Framework. | Partner_Betreuer |
Supported by the .NET Compact Framework. | Partner_Detail |
Supported by the .NET Compact Framework. | Partner_Gebdat |
Supported by the .NET Compact Framework. | Partner_VV |
 | ReferenceEquals | (inherited from Object).
Public method | ToString | (inherited from Object).
Supported by the .NET Compact Framework. | search_doppelte_partner |
Supported by the .NET Compact Framework. | search_partner |

Top

Protected Methods

 | Name | Description
Protected method | Finalize | (inherited from Object).
Protected method | MemberwiseClone | (Overloaded) (inherited from Object).

Top

See Also

Reference

clsMyPartner Class


clsMyPartner.Partner_Betreuer Method

clsMyPartner.Partner_Betreuer Method

clsMyPartner.Partner_Betreuer Method | Previous topic | Next topic
clsMyPartner.Partner_Betreuer Method | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Function Partner_Betreuer( _
ByVal nrpar00 As String _
) As String

C#

public string Partner_Betreuer(
stringnrpar00
)

C++

public:
String^ Partner_Betreuer(
String^ nrpar00
)

JScript

public function Partner_Betreuer(
nrpar00 : String
) : String;

Parameters

nrpar00

Source code

Visual Basic

Copy Code Copy Code

Public Function Partner_Betreuer(ByVal nrpar00 As String) As String
Dim scmCmdToExecute As SqlCommand = New SqlCommand()
Dim table As String = "dbo.partner"
scmCmdToExecute.CommandText = "dbo.[sp_partner_betreuer]"
scmCmdToExecute.CommandType = CommandType.StoredProcedure
Dim dtToReturn As DataTable = New DataTable("partner")
Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)

' // Use base class' connection object
scmCmdToExecute.Connection = conn.scoDBConnection
Try
scmCmdToExecute.Parameters.Add(New SqlParameter("@nrpar00", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, nrpar00))
scmCmdToExecute.Parameters.Add(New SqlParameter("@betreuer", SqlDbType.VarChar, 255, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, ""))
scmCmdToExecute.Connection.Open()
sdaAdapter.Fill(dtToReturn)
Return scmCmdToExecute.Parameters("@betreuer").Value
Catch ex As Exception
' // some error occured. Bubble it to caller and encapsulate Exception object
Throw New Exception("clsMyPartner::sp_partner_vv::Error occured." + ex.Message, ex)
Return ""
Finally
scmCmdToExecute.Connection.Close()
scmCmdToExecute.Dispose()
sdaAdapter.Dispose()
dtToReturn.Dispose()
End Try

End Function

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsMyPartner Class
clsMyPartner clsMyPartner Members


clsMyPartner.Partner_Detail Method

clsMyPartner.Partner_Detail Method

clsMyPartner.Partner_Detail Method | Previous topic | Next topic
clsMyPartner.Partner_Detail Method | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Function Partner_Detail( _
ByVal nrpar00 As String _
) As DataTable

C#

public DataTable Partner_Detail(
stringnrpar00
)

C++

public:
DataTable^ Partner_Detail(
String^ nrpar00
)

JScript

public function Partner_Detail(
nrpar00 : String
) : DataTable;

Parameters

nrpar00

Source code

Visual Basic

Copy Code Copy Code

Public Function Partner_Detail(ByVal nrpar00 As String) As DataTable
Dim scmCmdToExecute As SqlCommand = New SqlCommand()
Dim table As String = "dbo.partner"
scmCmdToExecute.CommandText = "dbo.[sp_partner_detail]"
scmCmdToExecute.CommandType = CommandType.StoredProcedure
Dim dtToReturn As DataTable = New DataTable("partner")
Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)

' // Use base class' connection object
scmCmdToExecute.Connection = conn.scoDBConnection
Try
scmCmdToExecute.Parameters.Add(New SqlParameter("@nrpar00", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, nrpar00))
scmCmdToExecute.Connection.Open()
sdaAdapter.Fill(dtToReturn)
Return dtToReturn
Catch ex As Exception
' // some error occured. Bubble it to caller and encapsulate Exception object
Throw New Exception("clsMyPartner::sp_partner_detail::Error occured." + ex.Message, ex)
Finally
scmCmdToExecute.Connection.Close()
scmCmdToExecute.Dispose()
sdaAdapter.Dispose()
End Try
End Function

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsMyPartner Class
clsMyPartner clsMyPartner Members


clsMyPartner.Partner_Gebdat Method

clsMyPartner.Partner_Gebdat Method

clsMyPartner.Partner_Gebdat Method | Previous topic | Next topic
clsMyPartner.Partner_Gebdat Method | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Function Partner_Gebdat( _
ByVal nrpar00 As String _
) As String

C#

public string Partner_Gebdat(
stringnrpar00
)

C++

public:
String^ Partner_Gebdat(
String^ nrpar00
)

JScript

public function Partner_Gebdat(
nrpar00 : String
) : String;

Parameters

nrpar00

Source code

Visual Basic

Copy Code Copy Code

Public Function Partner_Gebdat(ByVal nrpar00 As String) As String
Dim scmCmdToExecute As SqlCommand = New SqlCommand()
Dim table As String = "dbo.partner"
scmCmdToExecute.CommandText = "dbo.[sp_partner_gebdat]"
scmCmdToExecute.CommandType = CommandType.StoredProcedure
Dim dtToReturn As DataTable = New DataTable("partner")
Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)

' // Use base class' connection object
scmCmdToExecute.Connection = conn.scoDBConnection
Try
scmCmdToExecute.Parameters.Add(New SqlParameter("@nrpar00", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, nrpar00))
scmCmdToExecute.Parameters.Add(New SqlParameter("@gebdat", SqlDbType.VarChar, 255, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, ""))
scmCmdToExecute.Connection.Open()
sdaAdapter.Fill(dtToReturn)

Return scmCmdToExecute.Parameters("@gebdat").Value
Catch ex As Exception
' MsgBox(ex.Message)
' // some error occured. Bubble it to caller and encapsulate Exception object
' Throw New Exception("clsMyPartner::sp_partner_vv::Error occured." + ex.Message, ex)
Return ""
Finally
scmCmdToExecute.Connection.Close()
scmCmdToExecute.Dispose()
sdaAdapter.Dispose()
End Try
End Function

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsMyPartner Class
clsMyPartner clsMyPartner Members


clsMyPartner.Partner_VV Method

clsMyPartner.Partner_VV Method

clsMyPartner.Partner_VV Method | Previous topic | Next topic
clsMyPartner.Partner_VV Method | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Function Partner_VV( _
ByVal nrpar00 As String _
) As DataTable

C#

public DataTable Partner_VV(
stringnrpar00
)

C++

public:
DataTable^ Partner_VV(
String^ nrpar00
)

JScript

public function Partner_VV(
nrpar00 : String
) : DataTable;

Parameters

nrpar00

Source code

Visual Basic

Copy Code Copy Code

Public Function Partner_VV(ByVal nrpar00 As String) As DataTable
Dim scmCmdToExecute As SqlCommand = New SqlCommand()
Dim table As String = "dbo.partner"
scmCmdToExecute.CommandText = "dbo.[sp_partner_vv]"
scmCmdToExecute.CommandType = CommandType.StoredProcedure
Dim dtToReturn As DataTable = New DataTable("partner")
Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)

' // Use base class' connection object
scmCmdToExecute.Connection = conn.scoDBConnection
Try
scmCmdToExecute.Parameters.Add(New SqlParameter("@nrpar00", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, nrpar00))
scmCmdToExecute.Connection.Open()
sdaAdapter.Fill(dtToReturn)
Return dtToReturn
Catch ex As Exception
' // some error occured. Bubble it to caller and encapsulate Exception object
Throw New Exception("clsMyPartner::sp_partner_vv::Error occured." + ex.Message, ex)
Finally
scmCmdToExecute.Connection.Close()
scmCmdToExecute.Dispose()
sdaAdapter.Dispose()
End Try
End Function

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsMyPartner Class
clsMyPartner clsMyPartner Members


clsMyPartner.search_doppelte_partner Method

clsMyPartner.search_doppelte_partner Method

clsMyPartner.search_doppelte_partner Method | Previous topic | Next topic
clsMyPartner.search_doppelte_partner Method | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Function search_doppelte_partner( _
ByVal query As String, _
ByVal table As String, _
ByVal fnkt As Integer _
) As DataTable

C#

public DataTable search_doppelte_partner(
stringquery,
stringtable,
intfnkt
)

C++

public:
DataTable^ search_doppelte_partner(
String^ query,
String^ table,
intfnkt
)

JScript

public function search_doppelte_partner(
query : String,
table : String,
fnkt : int
) : DataTable;

Parameters

query

table

fnkt

Source code

Visual Basic

Copy Code Copy Code

Public Function search_doppelte_partner(ByVal query As String, ByVal table As String, ByVal fnkt As Integer) As DataTable
Dim scmCmdToExecute As SqlCommand = New SqlCommand()
scmCmdToExecute.CommandText = "dbo.[sp_partner_search]"
scmCmdToExecute.CommandType = CommandType.StoredProcedure
Dim dtToReturn As DataTable = New DataTable("partner")
Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)

' // Use base class' connection object
scmCmdToExecute.Connection = conn.scoDBConnection
Try
scmCmdToExecute.Parameters.Add(New SqlParameter("@query", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, query))
scmCmdToExecute.Parameters.Add(New SqlParameter("@table", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, table))
scmCmdToExecute.Parameters.Add(New SqlParameter("@anz", SqlDbType.VarChar, 10, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, 0))
scmCmdToExecute.Parameters.Add(New SqlParameter("@fnkt", SqlDbType.VarChar, 1, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, 4))
scmCmdToExecute.Connection.Open()
sdaAdapter.Fill(dtToReturn)
Return dtToReturn
Catch ex As Exception
' // some error occured. Bubble it to caller and encapsulate Exception object
Throw New Exception("clsMyPartner::sp_partner_search::Error occured." + ex.Message, ex)
Finally
scmCmdToExecute.Connection.Close()
scmCmdToExecute.Dispose()
sdaAdapter.Dispose()
End Try
End Function

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsMyPartner Class
clsMyPartner clsMyPartner Members


clsMyPartner.search_partner Method

clsMyPartner.search_partner Method

clsMyPartner.search_partner Method | Previous topic | Next topic
clsMyPartner.search_partner Method | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Function search_partner( _
ByVal query As String, _
ByVal anzahl As String, _
ByVal fnkt As Integer _
) As DataTable

C#

public DataTable search_partner(
stringquery,
stringanzahl,
intfnkt
)

C++

public:
DataTable^ search_partner(
String^ query,
String^ anzahl,
intfnkt
)

JScript

public function search_partner(
query : String,
anzahl : String,
fnkt : int
) : DataTable;

Parameters

query

anzahl

fnkt

Source code

Visual Basic

Copy Code Copy Code

Public Function search_partner(ByVal query As String, ByVal anzahl As String, ByVal fnkt As Integer) As DataTable
Dim scmCmdToExecute As SqlCommand = New SqlCommand()
Dim table As String = "dbo.partner"
scmCmdToExecute.CommandText = "dbo.[sp_partner_search]"
scmCmdToExecute.CommandType = CommandType.StoredProcedure
Dim dtToReturn As DataTable = New DataTable("partner")
Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)

' // Use base class' connection object
scmCmdToExecute.Connection = conn.scoDBConnection
Try
scmCmdToExecute.Parameters.Add(New SqlParameter("@query", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, query))
scmCmdToExecute.Parameters.Add(New SqlParameter("@table", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, table))
scmCmdToExecute.Parameters.Add(New SqlParameter("@anz", SqlDbType.VarChar, 10, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, anzahl))
scmCmdToExecute.Parameters.Add(New SqlParameter("@fnkt", SqlDbType.VarChar, 1, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, fnkt))
scmCmdToExecute.Connection.Open()
sdaAdapter.Fill(dtToReturn)
Return dtToReturn
Catch ex As Exception
' // some error occured. Bubble it to caller and encapsulate Exception object
Throw New Exception("clsMyPartner::sp_partner_search::Error occured." + ex.Message, ex)
Finally
scmCmdToExecute.Connection.Close()
scmCmdToExecute.Dispose()
sdaAdapter.Dispose()
End Try
End Function

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsMyPartner Class
clsMyPartner clsMyPartner Members


clsOffice_vorlage Class

clsOffice_vorlage Class

clsOffice_vorlage Class | Previous topic | Next topic
clsOffice_vorlage Class | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Class clsOffice_vorlage
Inherits clsDBInteractionBase

C#

public class clsOffice_vorlage : clsDBInteractionBase

C++

public ref class clsOffice_vorlage : public clsDBInteractionBase^

JScript

public class clsOffice_vorlage
extends clsDBInteractionBase

Inheritance Hierarchy

System.Object

EDKB12WS.edokadb.clsDBInteractionBase

EDKB12WS.edokadb.clsOffice_vorlage

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsOffice_vorlage Members


clsOffice_vorlage Members

clsOffice_vorlage Members

clsOffice_vorlage Members | Previous topic | Next topic
clsOffice_vorlage Members | Previous topic | Next topic

The following tables list the members exposed by the clsOffice_vorlage type.

Public Constructors

 | Name | Description
Supported by the .NET Compact Framework. | clsOffice_vorlage Constructor |

Top

Public Properties

 | Name | Description
Supported by the .NET Compact Framework. | bAbsender_ersteller |
Supported by the .NET Compact Framework. | bAktiv |
Supported by the .NET Compact Framework. | bBchorizontal |
Supported by the .NET Compact Framework. | bDokument_geschuetzt |
Supported by the .NET Compact Framework. | bIdv_nativ |
Supported by the .NET Compact Framework. | bIdv_vorlage |
Supported by the .NET Compact Framework. | bKopfzeile_generieren |
Supported by the .NET Compact Framework. | cpMainConnectionProvider | (inherited from clsDBInteractionBase ).
Supported by the .NET Compact Framework. | daErstellt_am |
Supported by the .NET Compact Framework. | daMutiert_am |
Supported by the .NET Compact Framework. | iAnwendungnr |
Supported by the .NET Compact Framework. | iBch |
Supported by the .NET Compact Framework. | iBcpl |
Supported by the .NET Compact Framework. | iBcpt |
Supported by the .NET Compact Framework. | iBcw |
Supported by the .NET Compact Framework. | iErrorCode | (inherited from clsDBInteractionBase ).
Supported by the .NET Compact Framework. | iKlassifizierung |
Supported by the .NET Compact Framework. | iMandantnr |
Supported by the .NET Compact Framework. | iMutierer |
Supported by the .NET Compact Framework. | iOffice_vorlagenr |
Supported by the .NET Compact Framework. | iOwner |
Supported by the .NET Compact Framework. | iVorlageid |
Supported by the .NET Compact Framework. | sBeschreibung |
Supported by the .NET Compact Framework. | sBezeichnung |
Supported by the .NET Compact Framework. | sConnectionString | (inherited from clsDBInteractionBase ).
Supported by the .NET Compact Framework. | sIdv_id |
Supported by the .NET Compact Framework. | sOffice_vorlage |
Supported by the .NET Compact Framework. | sPrefix_dokumentname |
Supported by the .NET Compact Framework. | sVorlagename |

Top

Public Methods

 | Name | Description
Supported by the .NET Compact Framework. | Delete |
Supported by the .NET Compact Framework. | Dispose | (Overloaded) (inherited from clsDBInteractionBase ).
Public method | Equals | (Overloaded) (inherited from Object).
Public method | GetHashCode | (inherited from Object).
Public method | GetType | (Overloaded) (inherited from Object).
Supported by the .NET Compact Framework. | Insert |
 | ReferenceEquals | (inherited from Object).
Supported by the .NET Compact Framework. | SelectAll |
Supported by the .NET Compact Framework. | SelectOne |
Public method | ToString | (inherited from Object).
Supported by the .NET Compact Framework. | Update |

Top

Protected Methods

 | Name | Description
Protected method | Finalize | (inherited from Object).
Protected method | MemberwiseClone | (Overloaded) (inherited from Object).

Top

Fields

 | Name | Description
Supported by the .NET Compact Framework. | m_bAbsender_ersteller |
Supported by the .NET Compact Framework. | m_bAktiv |
Supported by the .NET Compact Framework. | m_bBchorizontal |
Supported by the .NET Compact Framework. | m_bDokument_geschuetzt |
Supported by the .NET Compact Framework. | m_bIdv_nativ |
Supported by the .NET Compact Framework. | m_bIdv_vorlage |
Supported by the .NET Compact Framework. | m_bKopfzeile_generieren |
Supported by the .NET Compact Framework. | m_bMainConnectionIsCreatedLocal | (inherited from clsDBInteractionBase ).
Supported by the .NET Compact Framework. | m_cpMainConnectionProvider | (inherited from clsDBInteractionBase ).
Supported by the .NET Compact Framework. | m_daErstellt_am |
Supported by the .NET Compact Framework. | m_daMutiert_am |
Supported by the .NET Compact Framework. | m_iAnwendungnr |
Supported by the .NET Compact Framework. | m_iBch |
Supported by the .NET Compact Framework. | m_iBcpl |
Supported by the .NET Compact Framework. | m_iBcpt |
Supported by the .NET Compact Framework. | m_iBcw |
Supported by the .NET Compact Framework. | m_iErrorCode | (inherited from clsDBInteractionBase ).
Supported by the .NET Compact Framework. | m_iKlassifizierung |
Supported by the .NET Compact Framework. | m_iMandantnr |
Supported by the .NET Compact Framework. | m_iMutierer |
Supported by the .NET Compact Framework. | m_iOffice_vorlagenr |
Supported by the .NET Compact Framework. | m_iOwner |
Supported by the .NET Compact Framework. | m_iVorlageid |
Supported by the .NET Compact Framework. | m_sBeschreibung |
Supported by the .NET Compact Framework. | m_sBezeichnung |
Supported by the .NET Compact Framework. | m_sIdv_id |
Supported by the .NET Compact Framework. | m_sOffice_vorlage |
Supported by the .NET Compact Framework. | m_sPrefix_dokumentname |
Supported by the .NET Compact Framework. | m_sVorlagename |
Supported by the .NET Compact Framework. | m_scoMainConnection | (inherited from clsDBInteractionBase ).

Top

See Also

Reference

clsOffice_vorlage Class


clsOffice_vorlage Constructor

clsOffice_vorlage Constructor

clsOffice_vorlage Constructor | Previous topic | Next topic
clsOffice_vorlage Constructor | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Sub New()

C#

public clsOffice_vorlage()

C++

public:
clsOffice_vorlage()

JScript

public function clsOffice_vorlage();

Source code

Visual Basic

Copy Code Copy Code

Public Sub New()
' // Nothing for now.
End Sub

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsOffice_vorlage Class
clsOffice_vorlage clsOffice_vorlage Members


clsOffice_vorlage Properties

clsOffice_vorlage Properties

clsOffice_vorlage Properties | Previous topic | Next topic
clsOffice_vorlage Properties | Previous topic | Next topic

Public Properties

 | Name | Description
Supported by the .NET Compact Framework. | bAbsender_ersteller |
Supported by the .NET Compact Framework. | bAktiv |
Supported by the .NET Compact Framework. | bBchorizontal |
Supported by the .NET Compact Framework. | bDokument_geschuetzt |
Supported by the .NET Compact Framework. | bIdv_nativ |
Supported by the .NET Compact Framework. | bIdv_vorlage |
Supported by the .NET Compact Framework. | bKopfzeile_generieren |
Supported by the .NET Compact Framework. | cpMainConnectionProvider | (inherited from clsDBInteractionBase ).
Supported by the .NET Compact Framework. | daErstellt_am |
Supported by the .NET Compact Framework. | daMutiert_am |
Supported by the .NET Compact Framework. | iAnwendungnr |
Supported by the .NET Compact Framework. | iBch |
Supported by the .NET Compact Framework. | iBcpl |
Supported by the .NET Compact Framework. | iBcpt |
Supported by the .NET Compact Framework. | iBcw |
Supported by the .NET Compact Framework. | iErrorCode | (inherited from clsDBInteractionBase ).
Supported by the .NET Compact Framework. | iKlassifizierung |
Supported by the .NET Compact Framework. | iMandantnr |
Supported by the .NET Compact Framework. | iMutierer |
Supported by the .NET Compact Framework. | iOffice_vorlagenr |
Supported by the .NET Compact Framework. | iOwner |
Supported by the .NET Compact Framework. | iVorlageid |
Supported by the .NET Compact Framework. | sBeschreibung |
Supported by the .NET Compact Framework. | sBezeichnung |
Supported by the .NET Compact Framework. | sConnectionString | (inherited from clsDBInteractionBase ).
Supported by the .NET Compact Framework. | sIdv_id |
Supported by the .NET Compact Framework. | sOffice_vorlage |
Supported by the .NET Compact Framework. | sPrefix_dokumentname |
Supported by the .NET Compact Framework. | sVorlagename |

Top

See Also

Reference

clsOffice_vorlage Class


clsOffice_vorlage.bAbsender_ersteller Property

clsOffice_vorlage.bAbsender_ersteller Property

clsOffice_vorlage.bAbsender_ersteller Property | Previous topic | Next topic
clsOffice_vorlage.bAbsender_ersteller Property | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property bAbsender_ersteller() As SqlBoolean

C#

public SqlBoolean bAbsender_ersteller {get; set;}

C++

public:
property SqlBoolean bAbsender_ersteller {
SqlBoolean get( );
void set(
SqlBoolean value
);
}

JScript

public function get bAbsender_ersteller() : SqlBoolean;
public function set bAbsender_ersteller(value : SqlBoolean);

Source code

Visual Basic

Copy Code Copy Code

Public Property [bAbsender_ersteller]() As SqlBoolean
Get
Return m_bAbsender_ersteller
End Get
Set(ByVal Value As SqlBoolean)
m_bAbsender_ersteller = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsOffice_vorlage Class
clsOffice_vorlage clsOffice_vorlage Members


clsOffice_vorlage.bAktiv Property

clsOffice_vorlage.bAktiv Property

clsOffice_vorlage.bAktiv Property | Previous topic | Next topic
clsOffice_vorlage.bAktiv Property | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property bAktiv() As SqlBoolean

C#

public SqlBoolean bAktiv {get; set;}

C++

public:
property SqlBoolean bAktiv {
SqlBoolean get( );
void set(
SqlBoolean value
);
}

JScript

public function get bAktiv() : SqlBoolean;
public function set bAktiv(value : SqlBoolean);

Source code

Visual Basic

Copy Code Copy Code

Public Property [bAktiv]() As SqlBoolean
Get
Return m_bAktiv
End Get
Set(ByVal Value As SqlBoolean)
m_bAktiv = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsOffice_vorlage Class
clsOffice_vorlage clsOffice_vorlage Members


clsOffice_vorlage.bBchorizontal Property

clsOffice_vorlage.bBchorizontal Property

clsOffice_vorlage.bBchorizontal Property | Previous topic | Next topic
clsOffice_vorlage.bBchorizontal Property | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property bBchorizontal() As SqlBoolean

C#

public SqlBoolean bBchorizontal {get; set;}

C++

public:
property SqlBoolean bBchorizontal {
SqlBoolean get( );
void set(
SqlBoolean value
);
}

JScript

public function get bBchorizontal() : SqlBoolean;
public function set bBchorizontal(value : SqlBoolean);

Source code

Visual Basic

Copy Code Copy Code

Public Property [bBchorizontal]() As SqlBoolean
Get
Return m_bBchorizontal
End Get
Set(ByVal Value As SqlBoolean)
m_bBchorizontal = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsOffice_vorlage Class
clsOffice_vorlage clsOffice_vorlage Members


clsOffice_vorlage.bDokument_geschuetzt Property

clsOffice_vorlage.bDokument_geschuetzt Property

clsOffice_vorlage.bDokument_geschuetzt Property | Previous topic | Next topic
clsOffice_vorlage.bDokument_geschuetzt Property | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property bDokument_geschuetzt() As SqlBoolean

C#

public SqlBoolean bDokument_geschuetzt {get; set;}

C++

public:
property SqlBoolean bDokument_geschuetzt {
SqlBoolean get( );
void set(
SqlBoolean value
);
}

JScript

public function get bDokument_geschuetzt() : SqlBoolean;
public function set bDokument_geschuetzt(value : SqlBoolean);

Source code

Visual Basic

Copy Code Copy Code

Public Property [bDokument_geschuetzt]() As SqlBoolean
Get
Return m_bDokument_geschuetzt
End Get
Set(ByVal Value As SqlBoolean)
m_bDokument_geschuetzt = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsOffice_vorlage Class
clsOffice_vorlage clsOffice_vorlage Members


clsOffice_vorlage.bIdv_nativ Property

clsOffice_vorlage.bIdv_nativ Property

clsOffice_vorlage.bIdv_nativ Property | Previous topic | Next topic
clsOffice_vorlage.bIdv_nativ Property | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property bIdv_nativ() As SqlBoolean

C#

public SqlBoolean bIdv_nativ {get; set;}

C++

public:
property SqlBoolean bIdv_nativ {
SqlBoolean get( );
void set(
SqlBoolean value
);
}

JScript

public function get bIdv_nativ() : SqlBoolean;
public function set bIdv_nativ(value : SqlBoolean);

Source code

Visual Basic

Copy Code Copy Code

Public Property [bIdv_nativ]() As SqlBoolean
Get
Return m_bIdv_nativ
End Get
Set(ByVal Value As SqlBoolean)
Dim bIdv_nativTmp As SqlBoolean = Value
If bIdv_nativTmp.IsNull Then
Throw New ArgumentOutOfRangeException("bIdv_nativ", "bIdv_nativ can't be NULL")
End If
m_bIdv_nativ = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsOffice_vorlage Class
clsOffice_vorlage clsOffice_vorlage Members


clsOffice_vorlage.bIdv_vorlage Property

clsOffice_vorlage.bIdv_vorlage Property

clsOffice_vorlage.bIdv_vorlage Property | Previous topic | Next topic
clsOffice_vorlage.bIdv_vorlage Property | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property bIdv_vorlage() As SqlBoolean

C#

public SqlBoolean bIdv_vorlage {get; set;}

C++

public:
property SqlBoolean bIdv_vorlage {
SqlBoolean get( );
void set(
SqlBoolean value
);
}

JScript

public function get bIdv_vorlage() : SqlBoolean;
public function set bIdv_vorlage(value : SqlBoolean);

Source code

Visual Basic

Copy Code Copy Code

Public Property [bIdv_vorlage]() As SqlBoolean
Get
Return m_bIdv_vorlage
End Get
Set(ByVal Value As SqlBoolean)
Dim bIdv_vorlageTmp As SqlBoolean = Value
If bIdv_vorlageTmp.IsNull Then
Throw New ArgumentOutOfRangeException("bIdv_vorlage", "bIdv_vorlage can't be NULL")
End If
m_bIdv_vorlage = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsOffice_vorlage Class
clsOffice_vorlage clsOffice_vorlage Members


clsOffice_vorlage.bKopfzeile_generieren Property

clsOffice_vorlage.bKopfzeile_generieren Property

clsOffice_vorlage.bKopfzeile_generieren Property | Previous topic | Next topic
clsOffice_vorlage.bKopfzeile_generieren Property | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property bKopfzeile_generieren() As SqlBoolean

C#

public SqlBoolean bKopfzeile_generieren {get; set;}

C++

public:
property SqlBoolean bKopfzeile_generieren {
SqlBoolean get( );
void set(
SqlBoolean value
);
}

JScript

public function get bKopfzeile_generieren() : SqlBoolean;
public function set bKopfzeile_generieren(value : SqlBoolean);

Source code

Visual Basic

Copy Code Copy Code

Public Property [bKopfzeile_generieren]() As SqlBoolean
Get
Return m_bKopfzeile_generieren
End Get
Set(ByVal Value As SqlBoolean)
Dim bKopfzeile_generierenTmp As SqlBoolean = Value
If bKopfzeile_generierenTmp.IsNull Then
Throw New ArgumentOutOfRangeException("bKopfzeile_generieren", "bKopfzeile_generieren can't be NULL")
End If
m_bKopfzeile_generieren = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsOffice_vorlage Class
clsOffice_vorlage clsOffice_vorlage Members


clsOffice_vorlage.daErstellt_am Property

clsOffice_vorlage.daErstellt_am Property

clsOffice_vorlage.daErstellt_am Property | Previous topic | Next topic
clsOffice_vorlage.daErstellt_am Property | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property daErstellt_am() As SqlDateTime

C#

public SqlDateTime daErstellt_am {get; set;}

C++

public:
property SqlDateTime daErstellt_am {
SqlDateTime get( );
void set(
SqlDateTime value
);
}

JScript

public function get daErstellt_am() : SqlDateTime;
public function set daErstellt_am(value : SqlDateTime);

Source code

Visual Basic

Copy Code Copy Code

Public Property [daErstellt_am]() As SqlDateTime
Get
Return m_daErstellt_am
End Get
Set(ByVal Value As SqlDateTime)
m_daErstellt_am = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsOffice_vorlage Class
clsOffice_vorlage clsOffice_vorlage Members


clsOffice_vorlage.daMutiert_am Property

clsOffice_vorlage.daMutiert_am Property

clsOffice_vorlage.daMutiert_am Property | Previous topic | Next topic
clsOffice_vorlage.daMutiert_am Property | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property daMutiert_am() As SqlDateTime

C#

public SqlDateTime daMutiert_am {get; set;}

C++

public:
property SqlDateTime daMutiert_am {
SqlDateTime get( );
void set(
SqlDateTime value
);
}

JScript

public function get daMutiert_am() : SqlDateTime;
public function set daMutiert_am(value : SqlDateTime);

Source code

Visual Basic

Copy Code Copy Code

Public Property [daMutiert_am]() As SqlDateTime
Get
Return m_daMutiert_am
End Get
Set(ByVal Value As SqlDateTime)
m_daMutiert_am = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsOffice_vorlage Class
clsOffice_vorlage clsOffice_vorlage Members


clsOffice_vorlage.iAnwendungnr Property

clsOffice_vorlage.iAnwendungnr Property

clsOffice_vorlage.iAnwendungnr Property | Previous topic | Next topic
clsOffice_vorlage.iAnwendungnr Property | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property iAnwendungnr() As SqlInt32

C#

public SqlInt32 iAnwendungnr {get; set;}

C++

public:
property SqlInt32 iAnwendungnr {
SqlInt32 get( );
void set(
SqlInt32 value
);
}

JScript

public function get iAnwendungnr() : SqlInt32;
public function set iAnwendungnr(value : SqlInt32);

Source code

Visual Basic

Copy Code Copy Code

Public Property [iAnwendungnr]() As SqlInt32
Get
Return m_iAnwendungnr
End Get
Set(ByVal Value As SqlInt32)
m_iAnwendungnr = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsOffice_vorlage Class
clsOffice_vorlage clsOffice_vorlage Members


clsOffice_vorlage.iBch Property

clsOffice_vorlage.iBch Property

clsOffice_vorlage.iBch Property | Previous topic | Next topic
clsOffice_vorlage.iBch Property | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property iBch() As SqlInt32

C#

public SqlInt32 iBch {get; set;}

C++

public:
property SqlInt32 iBch {
SqlInt32 get( );
void set(
SqlInt32 value
);
}

JScript

public function get iBch() : SqlInt32;
public function set iBch(value : SqlInt32);

Source code

Visual Basic

Copy Code Copy Code

Public Property [iBch]() As SqlInt32
Get
Return m_iBch
End Get
Set(ByVal Value As SqlInt32)
Dim iBchTmp As SqlInt32 = Value
If iBchTmp.IsNull Then
Throw New ArgumentOutOfRangeException("iBch", "iBch can't be NULL")
End If
m_iBch = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsOffice_vorlage Class
clsOffice_vorlage clsOffice_vorlage Members


clsOffice_vorlage.iBcpl Property

clsOffice_vorlage.iBcpl Property

clsOffice_vorlage.iBcpl Property | Previous topic | Next topic
clsOffice_vorlage.iBcpl Property | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property iBcpl() As SqlInt32

C#

public SqlInt32 iBcpl {get; set;}

C++

public:
property SqlInt32 iBcpl {
SqlInt32 get( );
void set(
SqlInt32 value
);
}

JScript

public function get iBcpl() : SqlInt32;
public function set iBcpl(value : SqlInt32);

Source code

Visual Basic

Copy Code Copy Code

Public Property [iBcpl]() As SqlInt32
Get
Return m_iBcpl
End Get
Set(ByVal Value As SqlInt32)
m_iBcpl = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsOffice_vorlage Class
clsOffice_vorlage clsOffice_vorlage Members


clsOffice_vorlage.iBcpt Property

clsOffice_vorlage.iBcpt Property

clsOffice_vorlage.iBcpt Property | Previous topic | Next topic
clsOffice_vorlage.iBcpt Property | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property iBcpt() As SqlInt32

C#

public SqlInt32 iBcpt {get; set;}

C++

public:
property SqlInt32 iBcpt {
SqlInt32 get( );
void set(
SqlInt32 value
);
}

JScript

public function get iBcpt() : SqlInt32;
public function set iBcpt(value : SqlInt32);

Source code

Visual Basic

Copy Code Copy Code

Public Property [iBcpt]() As SqlInt32
Get
Return m_iBcpt
End Get
Set(ByVal Value As SqlInt32)
Dim iBcptTmp As SqlInt32 = Value
If iBcptTmp.IsNull Then
Throw New ArgumentOutOfRangeException("iBcpt", "iBcpt can't be NULL")
End If
m_iBcpt = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsOffice_vorlage Class
clsOffice_vorlage clsOffice_vorlage Members


clsOffice_vorlage.iBcw Property

clsOffice_vorlage.iBcw Property

clsOffice_vorlage.iBcw Property | Previous topic | Next topic
clsOffice_vorlage.iBcw Property | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property iBcw() As SqlInt32

C#

public SqlInt32 iBcw {get; set;}

C++

public:
property SqlInt32 iBcw {
SqlInt32 get( );
void set(
SqlInt32 value
);
}

JScript

public function get iBcw() : SqlInt32;
public function set iBcw(value : SqlInt32);

Source code

Visual Basic

Copy Code Copy Code

Public Property [iBcw]() As SqlInt32
Get
Return m_iBcw
End Get
Set(ByVal Value As SqlInt32)
Dim iBcwTmp As SqlInt32 = Value
If iBcwTmp.IsNull Then
Throw New ArgumentOutOfRangeException("iBcw", "iBcw can't be NULL")
End If
m_iBcw = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsOffice_vorlage Class
clsOffice_vorlage clsOffice_vorlage Members


clsOffice_vorlage.iKlassifizierung Property

clsOffice_vorlage.iKlassifizierung Property

clsOffice_vorlage.iKlassifizierung Property | Previous topic | Next topic
clsOffice_vorlage.iKlassifizierung Property | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property iKlassifizierung() As SqlInt32

C#

public SqlInt32 iKlassifizierung {get; set;}

C++

public:
property SqlInt32 iKlassifizierung {
SqlInt32 get( );
void set(
SqlInt32 value
);
}

JScript

public function get iKlassifizierung() : SqlInt32;
public function set iKlassifizierung(value : SqlInt32);

Source code

Visual Basic

Copy Code Copy Code

Public Property [iKlassifizierung]() As SqlInt32
Get
Return m_iKlassifizierung
End Get
Set(ByVal Value As SqlInt32)
m_iKlassifizierung = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsOffice_vorlage Class
clsOffice_vorlage clsOffice_vorlage Members


clsOffice_vorlage.iMandantnr Property

clsOffice_vorlage.iMandantnr Property

clsOffice_vorlage.iMandantnr Property | Previous topic | Next topic
clsOffice_vorlage.iMandantnr Property | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property iMandantnr() As SqlInt32

C#

public SqlInt32 iMandantnr {get; set;}

C++

public:
property SqlInt32 iMandantnr {
SqlInt32 get( );
void set(
SqlInt32 value
);
}

JScript

public function get iMandantnr() : SqlInt32;
public function set iMandantnr(value : SqlInt32);

Source code

Visual Basic

Copy Code Copy Code

Public Property [iMandantnr]() As SqlInt32
Get
Return m_iMandantnr
End Get
Set(ByVal Value As SqlInt32)
m_iMandantnr = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsOffice_vorlage Class
clsOffice_vorlage clsOffice_vorlage Members


clsOffice_vorlage.iMutierer Property

clsOffice_vorlage.iMutierer Property

clsOffice_vorlage.iMutierer Property | Previous topic | Next topic
clsOffice_vorlage.iMutierer Property | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property iMutierer() As SqlInt32

C#

public SqlInt32 iMutierer {get; set;}

C++

public:
property SqlInt32 iMutierer {
SqlInt32 get( );
void set(
SqlInt32 value
);
}

JScript

public function get iMutierer() : SqlInt32;
public function set iMutierer(value : SqlInt32);

Source code

Visual Basic

Copy Code Copy Code

Public Property [iMutierer]() As SqlInt32
Get
Return m_iMutierer
End Get
Set(ByVal Value As SqlInt32)
m_iMutierer = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsOffice_vorlage Class
clsOffice_vorlage clsOffice_vorlage Members


clsOffice_vorlage.iOffice_vorlagenr Property

clsOffice_vorlage.iOffice_vorlagenr Property

clsOffice_vorlage.iOffice_vorlagenr Property | Previous topic | Next topic
clsOffice_vorlage.iOffice_vorlagenr Property | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property iOffice_vorlagenr() As SqlInt32

C#

public SqlInt32 iOffice_vorlagenr {get; set;}

C++

public:
property SqlInt32 iOffice_vorlagenr {
SqlInt32 get( );
void set(
SqlInt32 value
);
}

JScript

public function get iOffice_vorlagenr() : SqlInt32;
public function set iOffice_vorlagenr(value : SqlInt32);

Source code

Visual Basic

Copy Code Copy Code

Public Property [iOffice_vorlagenr]() As SqlInt32
Get
Return m_iOffice_vorlagenr
End Get
Set(ByVal Value As SqlInt32)
Dim iOffice_vorlagenrTmp As SqlInt32 = Value
If iOffice_vorlagenrTmp.IsNull Then
Throw New ArgumentOutOfRangeException("iOffice_vorlagenr", "iOffice_vorlagenr can't be NULL")
End If
m_iOffice_vorlagenr = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsOffice_vorlage Class
clsOffice_vorlage clsOffice_vorlage Members


clsOffice_vorlage.iOwner Property

clsOffice_vorlage.iOwner Property

clsOffice_vorlage.iOwner Property | Previous topic | Next topic
clsOffice_vorlage.iOwner Property | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property iOwner() As SqlInt32

C#

public SqlInt32 iOwner {get; set;}

C++

public:
property SqlInt32 iOwner {
SqlInt32 get( );
void set(
SqlInt32 value
);
}

JScript

public function get iOwner() : SqlInt32;
public function set iOwner(value : SqlInt32);

Source code

Visual Basic

Copy Code Copy Code

Public Property [iOwner]() As SqlInt32
Get
Return m_iOwner
End Get
Set(ByVal Value As SqlInt32)
m_iOwner = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsOffice_vorlage Class
clsOffice_vorlage clsOffice_vorlage Members


clsOffice_vorlage.iVorlageid Property

clsOffice_vorlage.iVorlageid Property

clsOffice_vorlage.iVorlageid Property | Previous topic | Next topic
clsOffice_vorlage.iVorlageid Property | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property iVorlageid() As SqlInt32

C#

public SqlInt32 iVorlageid {get; set;}

C++

public:
property SqlInt32 iVorlageid {
SqlInt32 get( );
void set(
SqlInt32 value
);
}

JScript

public function get iVorlageid() : SqlInt32;
public function set iVorlageid(value : SqlInt32);

Source code

Visual Basic

Copy Code Copy Code

Public Property [iVorlageid]() As SqlInt32
Get
Return m_iVorlageid
End Get
Set(ByVal Value As SqlInt32)
m_iVorlageid = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsOffice_vorlage Class
clsOffice_vorlage clsOffice_vorlage Members


clsOffice_vorlage.sBeschreibung Property

clsOffice_vorlage.sBeschreibung Property

clsOffice_vorlage.sBeschreibung Property | Previous topic | Next topic
clsOffice_vorlage.sBeschreibung Property | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property sBeschreibung() As SqlString

C#

public SqlString sBeschreibung {get; set;}

C++

public:
property SqlString sBeschreibung {
SqlString get( );
void set(
SqlString value
);
}

JScript

public function get sBeschreibung() : SqlString;
public function set sBeschreibung(value : SqlString);

Source code

Visual Basic

Copy Code Copy Code

Public Property [sBeschreibung]() As SqlString
Get
Return m_sBeschreibung
End Get
Set(ByVal Value As SqlString)
m_sBeschreibung = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsOffice_vorlage Class
clsOffice_vorlage clsOffice_vorlage Members


clsOffice_vorlage.sBezeichnung Property

clsOffice_vorlage.sBezeichnung Property

clsOffice_vorlage.sBezeichnung Property | Previous topic | Next topic
clsOffice_vorlage.sBezeichnung Property | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property sBezeichnung() As SqlString

C#

public SqlString sBezeichnung {get; set;}

C++

public:
property SqlString sBezeichnung {
SqlString get( );
void set(
SqlString value
);
}

JScript

public function get sBezeichnung() : SqlString;
public function set sBezeichnung(value : SqlString);

Source code

Visual Basic

Copy Code Copy Code

Public Property [sBezeichnung]() As SqlString
Get
Return m_sBezeichnung
End Get
Set(ByVal Value As SqlString)
m_sBezeichnung = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsOffice_vorlage Class
clsOffice_vorlage clsOffice_vorlage Members


clsOffice_vorlage.sIdv_id Property

clsOffice_vorlage.sIdv_id Property

clsOffice_vorlage.sIdv_id Property | Previous topic | Next topic
clsOffice_vorlage.sIdv_id Property | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property sIdv_id() As SqlString

C#

public SqlString sIdv_id {get; set;}

C++

public:
property SqlString sIdv_id {
SqlString get( );
void set(
SqlString value
);
}

JScript

public function get sIdv_id() : SqlString;
public function set sIdv_id(value : SqlString);

Source code

Visual Basic

Copy Code Copy Code

Public Property [sIdv_id]() As SqlString
Get
Return m_sIdv_id
End Get
Set(ByVal Value As SqlString)
m_sIdv_id = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsOffice_vorlage Class
clsOffice_vorlage clsOffice_vorlage Members


clsOffice_vorlage.sOffice_vorlage Property

clsOffice_vorlage.sOffice_vorlage Property

clsOffice_vorlage.sOffice_vorlage Property | Previous topic | Next topic
clsOffice_vorlage.sOffice_vorlage Property | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property sOffice_vorlage() As SqlString

C#

public SqlString sOffice_vorlage {get; set;}

C++

public:
property SqlString sOffice_vorlage {
SqlString get( );
void set(
SqlString value
);
}

JScript

public function get sOffice_vorlage() : SqlString;
public function set sOffice_vorlage(value : SqlString);

Source code

Visual Basic

Copy Code Copy Code

Public Property [sOffice_vorlage]() As SqlString
Get
Return m_sOffice_vorlage
End Get
Set(ByVal Value As SqlString)
m_sOffice_vorlage = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsOffice_vorlage Class
clsOffice_vorlage clsOffice_vorlage Members


clsOffice_vorlage.sPrefix_dokumentname Property

clsOffice_vorlage.sPrefix_dokumentname Property

clsOffice_vorlage.sPrefix_dokumentname Property | Previous topic | Next topic
clsOffice_vorlage.sPrefix_dokumentname Property | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property sPrefix_dokumentname() As SqlString

C#

public SqlString sPrefix_dokumentname {get; set;}

C++

public:
property SqlString sPrefix_dokumentname {
SqlString get( );
void set(
SqlString value
);
}

JScript

public function get sPrefix_dokumentname() : SqlString;
public function set sPrefix_dokumentname(value : SqlString);

Source code

Visual Basic

Copy Code Copy Code

Public Property [sPrefix_dokumentname]() As SqlString
Get
Return m_sPrefix_dokumentname
End Get
Set(ByVal Value As SqlString)
m_sPrefix_dokumentname = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsOffice_vorlage Class
clsOffice_vorlage clsOffice_vorlage Members


clsOffice_vorlage.sVorlagename Property

clsOffice_vorlage.sVorlagename Property

clsOffice_vorlage.sVorlagename Property | Previous topic | Next topic
clsOffice_vorlage.sVorlagename Property | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property sVorlagename() As SqlString

C#

public SqlString sVorlagename {get; set;}

C++

public:
property SqlString sVorlagename {
SqlString get( );
void set(
SqlString value
);
}

JScript

public function get sVorlagename() : SqlString;
public function set sVorlagename(value : SqlString);

Source code

Visual Basic

Copy Code Copy Code

Public Property [sVorlagename]() As SqlString
Get
Return m_sVorlagename
End Get
Set(ByVal Value As SqlString)
m_sVorlagename = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsOffice_vorlage Class
clsOffice_vorlage clsOffice_vorlage Members


clsOffice_vorlage Methods

clsOffice_vorlage Methods

clsOffice_vorlage Methods | Previous topic | Next topic
clsOffice_vorlage Methods | Previous topic | Next topic

Public Methods

 | Name | Description
Supported by the .NET Compact Framework. | Delete |
Supported by the .NET Compact Framework. | Dispose | (Overloaded) (inherited from clsDBInteractionBase ).
Public method | Equals | (Overloaded) (inherited from Object).
Public method | GetHashCode | (inherited from Object).
Public method | GetType | (Overloaded) (inherited from Object).
Supported by the .NET Compact Framework. | Insert |
 | ReferenceEquals | (inherited from Object).
Supported by the .NET Compact Framework. | SelectAll |
Supported by the .NET Compact Framework. | SelectOne |
Public method | ToString | (inherited from Object).
Supported by the .NET Compact Framework. | Update |

Top

Protected Methods

 | Name | Description
Protected method | Finalize | (inherited from Object).
Protected method | MemberwiseClone | (Overloaded) (inherited from Object).

Top

See Also

Reference

clsOffice_vorlage Class


clsOffice_vorlage.Delete Method

clsOffice_vorlage.Delete Method

clsOffice_vorlage.Delete Method | Previous topic | Next topic
clsOffice_vorlage.Delete Method | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Overrides Function Delete() As Boolean

C#

public override bool Delete()

C++

public:
bool Delete()

JScript

public function Delete() : boolean;

Source code

Visual Basic

Copy Code Copy Code

Public Overrides Function Delete() As Boolean
Dim scmCmdToExecute As SqlCommand = New SqlCommand()
scmCmdToExecute.CommandText = "dbo.[pr_office_vorlage_Delete]"
scmCmdToExecute.CommandType = CommandType.StoredProcedure

' // Use base class' connection object
scmCmdToExecute.Connection = m_scoMainConnection

Try
scmCmdToExecute.Parameters.Add(New SqlParameter("@ioffice_vorlagenr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iOffice_vorlagenr))
scmCmdToExecute.Parameters.Add(New SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

If m_bMainConnectionIsCreatedLocal Then
' // Open connection.
m_scoMainConnection.Open()
Else
If m_cpMainConnectionProvider.bIsTransactionPending Then
scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
End If
End If

' // Execute query.
scmCmdToExecute.ExecuteNonQuery()
m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
' // Throw error.
Throw New Exception("Stored Procedure 'pr_office_vorlage_Delete' reported the ErrorCode: " & m_iErrorCode.ToString())
End If

Return True
Catch ex As Exception
' // some error occured. Bubble it to caller and encapsulate Exception object
Throw New Exception("clsOffice_vorlage::Delete::Error occured.", ex)
Finally
If m_bMainConnectionIsCreatedLocal Then
' // Close connection.
m_scoMainConnection.Close()
End If
scmCmdToExecute.Dispose()
End Try
End Function

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsOffice_vorlage Class
clsOffice_vorlage clsOffice_vorlage Members


clsOffice_vorlage.Insert Method

clsOffice_vorlage.Insert Method

clsOffice_vorlage.Insert Method | Previous topic | Next topic
clsOffice_vorlage.Insert Method | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Overrides Function Insert() As Boolean

C#

public override bool Insert()

C++

public:
bool Insert()

JScript

public function Insert() : boolean;

Source code

Visual Basic

Copy Code Copy Code

Overrides Public Function Insert() As Boolean
Dim scmCmdToExecute As SqlCommand = New SqlCommand()
scmCmdToExecute.CommandText = "dbo.[pr_office_vorlage_Insert]"
scmCmdToExecute.CommandType = CommandType.StoredProcedure

' // Use base class' connection object
scmCmdToExecute.Connection = m_scoMainConnection

Try
scmCmdToExecute.Parameters.Add(New SqlParameter("@ioffice_vorlagenr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iOffice_vorlagenr))
scmCmdToExecute.Parameters.Add(New SqlParameter("@sbezeichnung", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBezeichnung))
scmCmdToExecute.Parameters.Add(New SqlParameter("@sbeschreibung", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBeschreibung))
scmCmdToExecute.Parameters.Add(New SqlParameter("@ivorlageid", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iVorlageid))
scmCmdToExecute.Parameters.Add(New SqlParameter("@svorlagename", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sVorlagename))
scmCmdToExecute.Parameters.Add(New SqlParameter("@sprefix_dokumentname", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sPrefix_dokumentname))
scmCmdToExecute.Parameters.Add(New SqlParameter("@bidv_vorlage", SqlDbType.Bit, 1, ParameterDirection.Input, False, 1, 0, "", DataRowVersion.Proposed, m_bIdv_vorlage))
scmCmdToExecute.Parameters.Add(New SqlParameter("@sidv_id", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sIdv_id))
scmCmdToExecute.Parameters.Add(New SqlParameter("@soffice_vorlage", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sOffice_vorlage))
scmCmdToExecute.Parameters.Add(New SqlParameter("@babsender_ersteller", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bAbsender_ersteller))
scmCmdToExecute.Parameters.Add(New SqlParameter("@bidv_nativ", SqlDbType.Bit, 1, ParameterDirection.Input, False, 1, 0, "", DataRowVersion.Proposed, m_bIdv_nativ))
scmCmdToExecute.Parameters.Add(New SqlParameter("@bdokument_geschuetzt", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bDokument_geschuetzt))
scmCmdToExecute.Parameters.Add(New SqlParameter("@bkopfzeile_generieren", SqlDbType.Bit, 1, ParameterDirection.Input, False, 1, 0, "", DataRowVersion.Proposed, m_bKopfzeile_generieren))
scmCmdToExecute.Parameters.Add(New SqlParameter("@iklassifizierung", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iKlassifizierung))
scmCmdToExecute.Parameters.Add(New SqlParameter("@ibcpt", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iBcpt))
scmCmdToExecute.Parameters.Add(New SqlParameter("@ibcpl", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iBcpl))
scmCmdToExecute.Parameters.Add(New SqlParameter("@ibcw", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iBcw))
scmCmdToExecute.Parameters.Add(New SqlParameter("@ibch", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iBch))
scmCmdToExecute.Parameters.Add(New SqlParameter("@bbchorizontal", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bBchorizontal))
scmCmdToExecute.Parameters.Add(New SqlParameter("@imandantnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMandantnr))
scmCmdToExecute.Parameters.Add(New SqlParameter("@baktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bAktiv))
scmCmdToExecute.Parameters.Add(New SqlParameter("@daerstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daErstellt_am))
scmCmdToExecute.Parameters.Add(New SqlParameter("@damutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daMutiert_am))
scmCmdToExecute.Parameters.Add(New SqlParameter("@imutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
scmCmdToExecute.Parameters.Add(New SqlParameter("@ianwendungnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iAnwendungnr))
scmCmdToExecute.Parameters.Add(New SqlParameter("@iowner", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iOwner))
scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

If m_bMainConnectionIsCreatedLocal Then
' // Open connection.
m_scoMainConnection.Open()
Else
If m_cpMainConnectionProvider.bIsTransactionPending Then
scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
End If
End If

' // Execute query.
scmCmdToExecute.ExecuteNonQuery()
m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
' // Throw error.
Throw New Exception("Stored Procedure 'pr_office_vorlage_Insert' reported the ErrorCode: " & m_iErrorCode.ToString())
End If

Return True
Catch ex As Exception
' // some error occured. Bubble it to caller and encapsulate Exception object
Throw New Exception("clsOffice_vorlage::Insert::Error occured.", ex)
Finally
If m_bMainConnectionIsCreatedLocal Then
' // Close connection.
m_scoMainConnection.Close()
End If
scmCmdToExecute.Dispose()
End Try
End Function

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsOffice_vorlage Class
clsOffice_vorlage clsOffice_vorlage Members


clsOffice_vorlage.SelectAll Method

clsOffice_vorlage.SelectAll Method

clsOffice_vorlage.SelectAll Method | Previous topic | Next topic
clsOffice_vorlage.SelectAll Method | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Overrides Function SelectAll() As DataTable

C#

public override DataTable SelectAll()

C++

public:
DataTable^ SelectAll()

JScript

public function SelectAll() : DataTable;

Source code

Visual Basic

Copy Code Copy Code

Public Overrides Function SelectAll() As DataTable
Dim scmCmdToExecute As SqlCommand = New SqlCommand()
scmCmdToExecute.CommandText = "dbo.[pr_office_vorlage_SelectAll]"
scmCmdToExecute.CommandType = CommandType.StoredProcedure
Dim dtToReturn As DataTable = New DataTable("office_vorlage")
Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)

' // Use base class' connection object
scmCmdToExecute.Connection = m_scoMainConnection

Try
scmCmdToExecute.Parameters.Add(New SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

If m_bMainConnectionIsCreatedLocal Then
' // Open connection.
m_scoMainConnection.Open()
Else
If m_cpMainConnectionProvider.bIsTransactionPending Then
scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
End If
End If

' // Execute query.
sdaAdapter.Fill(dtToReturn)
m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
' // Throw error.
Throw New Exception("Stored Procedure 'pr_office_vorlage_SelectAll' reported the ErrorCode: " & m_iErrorCode.ToString())
End If

Return dtToReturn
Catch ex As Exception
' // some error occured. Bubble it to caller and encapsulate Exception object
Throw New Exception("clsOffice_vorlage::SelectAll::Error occured.", ex)
Finally
If m_bMainConnectionIsCreatedLocal Then
' // Close connection.
m_scoMainConnection.Close()
End If
scmCmdToExecute.Dispose()
sdaAdapter.Dispose()
End Try
End Function

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsOffice_vorlage Class
clsOffice_vorlage clsOffice_vorlage Members


clsOffice_vorlage.SelectOne Method

clsOffice_vorlage.SelectOne Method

clsOffice_vorlage.SelectOne Method | Previous topic | Next topic
clsOffice_vorlage.SelectOne Method | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Overrides Function SelectOne() As DataTable

C#

public override DataTable SelectOne()

C++

public:
DataTable^ SelectOne()

JScript

public function SelectOne() : DataTable;

Source code

Visual Basic

Copy Code Copy Code

Overrides Public Function SelectOne() As DataTable
Dim scmCmdToExecute As SqlCommand = New SqlCommand()
scmCmdToExecute.CommandText = "dbo.[pr_office_vorlage_SelectOne]"
scmCmdToExecute.CommandType = CommandType.StoredProcedure
Dim dtToReturn As DataTable = new DataTable("office_vorlage")
Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

' // Use base class' connection object
scmCmdToExecute.Connection = m_scoMainConnection

Try
scmCmdToExecute.Parameters.Add(new SqlParameter("@ioffice_vorlagenr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iOffice_vorlagenr))
scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

If m_bMainConnectionIsCreatedLocal Then
' // Open connection.
m_scoMainConnection.Open()
Else
If m_cpMainConnectionProvider.bIsTransactionPending Then
scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
End If
End If

' // Execute query.
sdaAdapter.Fill(dtToReturn)
m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
' // Throw error.
Throw New Exception("Stored Procedure 'pr_office_vorlage_SelectOne' reported the ErrorCode: " & m_iErrorCode.ToString())
End If

If dtToReturn.Rows.Count > 0 Then
m_iOffice_vorlagenr = New SqlInt32(CType(dtToReturn.Rows(0)("office_vorlagenr"), Integer))
If dtToReturn.Rows(0)("bezeichnung") Is System.DBNull.Value Then
m_sBezeichnung = SqlString.Null
Else
m_sBezeichnung = New SqlString(CType(dtToReturn.Rows(0)("bezeichnung"), String))
End If
If dtToReturn.Rows(0)("beschreibung") Is System.DBNull.Value Then
m_sBeschreibung = SqlString.Null
Else
m_sBeschreibung = New SqlString(CType(dtToReturn.Rows(0)("beschreibung"), String))
End If
If dtToReturn.Rows(0)("vorlageid") Is System.DBNull.Value Then
m_iVorlageid = SqlInt32.Null
Else
m_iVorlageid = New SqlInt32(CType(dtToReturn.Rows(0)("vorlageid"), Integer))
End If
If dtToReturn.Rows(0)("vorlagename") Is System.DBNull.Value Then
m_sVorlagename = SqlString.Null
Else
m_sVorlagename = New SqlString(CType(dtToReturn.Rows(0)("vorlagename"), String))
End If
If dtToReturn.Rows(0)("prefix_dokumentname") Is System.DBNull.Value Then
m_sPrefix_dokumentname = SqlString.Null
Else
m_sPrefix_dokumentname = New SqlString(CType(dtToReturn.Rows(0)("prefix_dokumentname"), String))
End If
m_bIdv_vorlage = New SqlBoolean(CType(dtToReturn.Rows(0)("idv_vorlage"), Boolean))
If dtToReturn.Rows(0)("idv_id") Is System.DBNull.Value Then
m_sIdv_id = SqlString.Null
Else
m_sIdv_id = New SqlString(CType(dtToReturn.Rows(0)("idv_id"), String))
End If
If dtToReturn.Rows(0)("office_vorlage") Is System.DBNull.Value Then
m_sOffice_vorlage = SqlString.Null
Else
m_sOffice_vorlage = New SqlString(CType(dtToReturn.Rows(0)("office_vorlage"), String))
End If
If dtToReturn.Rows(0)("absender_ersteller") Is System.DBNull.Value Then
m_bAbsender_ersteller = SqlBoolean.Null
Else
m_bAbsender_ersteller = New SqlBoolean(CType(dtToReturn.Rows(0)("absender_ersteller"), Boolean))
End If
m_bIdv_nativ = New SqlBoolean(CType(dtToReturn.Rows(0)("idv_nativ"), Boolean))
If dtToReturn.Rows(0)("dokument_geschuetzt") Is System.DBNull.Value Then
m_bDokument_geschuetzt = SqlBoolean.Null
Else
m_bDokument_geschuetzt = New SqlBoolean(CType(dtToReturn.Rows(0)("dokument_geschuetzt"), Boolean))
End If
m_bKopfzeile_generieren = New SqlBoolean(CType(dtToReturn.Rows(0)("kopfzeile_generieren"), Boolean))
If dtToReturn.Rows(0)("klassifizierung") Is System.DBNull.Value Then
m_iKlassifizierung = SqlInt32.Null
Else
m_iKlassifizierung = New SqlInt32(CType(dtToReturn.Rows(0)("klassifizierung"), Integer))
End If
m_iBcpt = New SqlInt32(CType(dtToReturn.Rows(0)("bcpt"), Integer))
If dtToReturn.Rows(0)("bcpl") Is System.DBNull.Value Then
m_iBcpl = SqlInt32.Null
Else
m_iBcpl = New SqlInt32(CType(dtToReturn.Rows(0)("bcpl"), Integer))
End If
m_iBcw = New SqlInt32(CType(dtToReturn.Rows(0)("bcw"), Integer))
m_iBch = New SqlInt32(CType(dtToReturn.Rows(0)("bch"), Integer))
If dtToReturn.Rows(0)("bchorizontal") Is System.DBNull.Value Then
m_bBchorizontal = SqlBoolean.Null
Else
m_bBchorizontal = New SqlBoolean(CType(dtToReturn.Rows(0)("bchorizontal"), Boolean))
End If
If dtToReturn.Rows(0)("mandantnr") Is System.DBNull.Value Then
m_iMandantnr = SqlInt32.Null
Else
m_iMandantnr = New SqlInt32(CType(dtToReturn.Rows(0)("mandantnr"), Integer))
End If
If dtToReturn.Rows(0)("aktiv") Is System.DBNull.Value Then
m_bAktiv = SqlBoolean.Null
Else
m_bAktiv = New SqlBoolean(CType(dtToReturn.Rows(0)("aktiv"), Boolean))
End If
If dtToReturn.Rows(0)("erstellt_am") Is System.DBNull.Value Then
m_daErstellt_am = SqlDateTime.Null
Else
m_daErstellt_am = New SqlDateTime(CType(dtToReturn.Rows(0)("erstellt_am"), Date))
End If
If dtToReturn.Rows(0)("mutiert_am") Is System.DBNull.Value Then
m_daMutiert_am = SqlDateTime.Null
Else
m_daMutiert_am = New SqlDateTime(CType(dtToReturn.Rows(0)("mutiert_am"), Date))
End If
If dtToReturn.Rows(0)("mutierer") Is System.DBNull.Value Then
m_iMutierer = SqlInt32.Null
Else
m_iMutierer = New SqlInt32(CType(dtToReturn.Rows(0)("mutierer"), Integer))
End If
If dtToReturn.Rows(0)("anwendungnr") Is System.DBNull.Value Then
m_iAnwendungnr = SqlInt32.Null
Else
m_iAnwendungnr = New SqlInt32(CType(dtToReturn.Rows(0)("anwendungnr"), Integer))
End If
If dtToReturn.Rows(0)("owner") Is System.DBNull.Value Then
m_iOwner = SqlInt32.Null
Else
m_iOwner = New SqlInt32(CType(dtToReturn.Rows(0)("owner"), Integer))
End If
End If
Return dtToReturn
Catch ex As Exception
' // some error occured. Bubble it to caller and encapsulate Exception object
Throw New Exception("clsOffice_vorlage::SelectOne::Error occured.", ex)
Finally
If m_bMainConnectionIsCreatedLocal Then
' // Close connection.
m_scoMainConnection.Close()
End If
scmCmdToExecute.Dispose()
sdaAdapter.Dispose()
End Try
End Function

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsOffice_vorlage Class
clsOffice_vorlage clsOffice_vorlage Members


clsOffice_vorlage.Update Method

clsOffice_vorlage.Update Method

clsOffice_vorlage.Update Method | Previous topic | Next topic
clsOffice_vorlage.Update Method | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Overrides Function Update() As Boolean

C#

public override bool Update()

C++

public:
bool Update()

JScript

public function Update() : boolean;

Source code

Visual Basic

Copy Code Copy Code

Overrides Public Function Update() As Boolean
Dim scmCmdToExecute As SqlCommand = New SqlCommand()
scmCmdToExecute.CommandText = "dbo.[pr_office_vorlage_Update]"
scmCmdToExecute.CommandType = CommandType.StoredProcedure

' // Use base class' connection object
scmCmdToExecute.Connection = m_scoMainConnection

Try
scmCmdToExecute.Parameters.Add(New SqlParameter("@ioffice_vorlagenr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iOffice_vorlagenr))
scmCmdToExecute.Parameters.Add(New SqlParameter("@sbezeichnung", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBezeichnung))
scmCmdToExecute.Parameters.Add(New SqlParameter("@sbeschreibung", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBeschreibung))
scmCmdToExecute.Parameters.Add(New SqlParameter("@ivorlageid", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iVorlageid))
scmCmdToExecute.Parameters.Add(New SqlParameter("@svorlagename", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sVorlagename))
scmCmdToExecute.Parameters.Add(New SqlParameter("@sprefix_dokumentname", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sPrefix_dokumentname))
scmCmdToExecute.Parameters.Add(New SqlParameter("@bidv_vorlage", SqlDbType.Bit, 1, ParameterDirection.Input, False, 1, 0, "", DataRowVersion.Proposed, m_bIdv_vorlage))
scmCmdToExecute.Parameters.Add(New SqlParameter("@sidv_id", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sIdv_id))
scmCmdToExecute.Parameters.Add(New SqlParameter("@soffice_vorlage", SqlDbType.VarChar, 255, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sOffice_vorlage))
scmCmdToExecute.Parameters.Add(New SqlParameter("@babsender_ersteller", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bAbsender_ersteller))
scmCmdToExecute.Parameters.Add(New SqlParameter("@bidv_nativ", SqlDbType.Bit, 1, ParameterDirection.Input, False, 1, 0, "", DataRowVersion.Proposed, m_bIdv_nativ))
scmCmdToExecute.Parameters.Add(New SqlParameter("@bdokument_geschuetzt", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bDokument_geschuetzt))
scmCmdToExecute.Parameters.Add(New SqlParameter("@bkopfzeile_generieren", SqlDbType.Bit, 1, ParameterDirection.Input, False, 1, 0, "", DataRowVersion.Proposed, m_bKopfzeile_generieren))
scmCmdToExecute.Parameters.Add(New SqlParameter("@iklassifizierung", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iKlassifizierung))
scmCmdToExecute.Parameters.Add(New SqlParameter("@ibcpt", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iBcpt))
scmCmdToExecute.Parameters.Add(New SqlParameter("@ibcpl", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iBcpl))
scmCmdToExecute.Parameters.Add(New SqlParameter("@ibcw", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iBcw))
scmCmdToExecute.Parameters.Add(New SqlParameter("@ibch", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iBch))
scmCmdToExecute.Parameters.Add(New SqlParameter("@bbchorizontal", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bBchorizontal))
scmCmdToExecute.Parameters.Add(New SqlParameter("@imandantnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMandantnr))
scmCmdToExecute.Parameters.Add(New SqlParameter("@baktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bAktiv))
scmCmdToExecute.Parameters.Add(New SqlParameter("@daerstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daErstellt_am))
scmCmdToExecute.Parameters.Add(New SqlParameter("@damutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daMutiert_am))
scmCmdToExecute.Parameters.Add(New SqlParameter("@imutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
scmCmdToExecute.Parameters.Add(New SqlParameter("@ianwendungnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iAnwendungnr))
scmCmdToExecute.Parameters.Add(New SqlParameter("@iowner", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iOwner))
scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

If m_bMainConnectionIsCreatedLocal Then
' // Open connection.
m_scoMainConnection.Open()
Else
If m_cpMainConnectionProvider.bIsTransactionPending Then
scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
End If
End If

' // Execute query.
scmCmdToExecute.ExecuteNonQuery()
m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
' // Throw error.
Throw New Exception("Stored Procedure 'pr_office_vorlage_Update' reported the ErrorCode: " & m_iErrorCode.ToString())
End If

Return True
Catch ex As Exception
' // some error occured. Bubble it to caller and encapsulate Exception object
Throw New Exception("clsOffice_vorlage::Update::Error occured.", ex)
Finally
If m_bMainConnectionIsCreatedLocal Then
' // Close connection.
m_scoMainConnection.Close()
End If
scmCmdToExecute.Dispose()
End Try
End Function

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsOffice_vorlage Class
clsOffice_vorlage clsOffice_vorlage Members


clsOffice_vorlage Fields

clsOffice_vorlage Fields

clsOffice_vorlage Fields | Previous topic | Next topic
clsOffice_vorlage Fields | Previous topic | Next topic

Fields

 | Name | Description
Supported by the .NET Compact Framework. | m_bAbsender_ersteller |
Supported by the .NET Compact Framework. | m_bAktiv |
Supported by the .NET Compact Framework. | m_bBchorizontal |
Supported by the .NET Compact Framework. | m_bDokument_geschuetzt |
Supported by the .NET Compact Framework. | m_bIdv_nativ |
Supported by the .NET Compact Framework. | m_bIdv_vorlage |
Supported by the .NET Compact Framework. | m_bKopfzeile_generieren |
Supported by the .NET Compact Framework. | m_bMainConnectionIsCreatedLocal | (inherited from clsDBInteractionBase ).
Supported by the .NET Compact Framework. | m_cpMainConnectionProvider | (inherited from clsDBInteractionBase ).
Supported by the .NET Compact Framework. | m_daErstellt_am |
Supported by the .NET Compact Framework. | m_daMutiert_am |
Supported by the .NET Compact Framework. | m_iAnwendungnr |
Supported by the .NET Compact Framework. | m_iBch |
Supported by the .NET Compact Framework. | m_iBcpl |
Supported by the .NET Compact Framework. | m_iBcpt |
Supported by the .NET Compact Framework. | m_iBcw |
Supported by the .NET Compact Framework. | m_iErrorCode | (inherited from clsDBInteractionBase ).
Supported by the .NET Compact Framework. | m_iKlassifizierung |
Supported by the .NET Compact Framework. | m_iMandantnr |
Supported by the .NET Compact Framework. | m_iMutierer |
Supported by the .NET Compact Framework. | m_iOffice_vorlagenr |
Supported by the .NET Compact Framework. | m_iOwner |
Supported by the .NET Compact Framework. | m_iVorlageid |
Supported by the .NET Compact Framework. | m_sBeschreibung |
Supported by the .NET Compact Framework. | m_sBezeichnung |
Supported by the .NET Compact Framework. | m_sIdv_id |
Supported by the .NET Compact Framework. | m_sOffice_vorlage |
Supported by the .NET Compact Framework. | m_sPrefix_dokumentname |
Supported by the .NET Compact Framework. | m_sVorlagename |
Supported by the .NET Compact Framework. | m_scoMainConnection | (inherited from clsDBInteractionBase ).

Top

See Also

Reference

clsOffice_vorlage Class


m_bAbsender_ersteller Field

m_bAbsender_ersteller Field

m_bAbsender_ersteller Field | Previous topic | Next topic
m_bAbsender_ersteller Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_bAbsender_ersteller As SqlBoolean

C#

private SqlBoolean m_bAbsender_ersteller

C++

private:
SqlBoolean m_bAbsender_ersteller;

JScript

private m_bAbsender_ersteller : SqlBoolean

Source code

Visual Basic

Copy Code Copy Code

Private m_bDokument_geschuetzt, m_bIdv_nativ, m_bAbsender_ersteller, m_bAktiv, m_bBchorizontal, m_bKopfzeile_generieren, m_bIdv_vorlage As SqlBoolean

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsOffice_vorlage Class
clsOffice_vorlage clsOffice_vorlage Members


m_bAktiv Field

m_bAktiv Field

m_bAktiv Field | Previous topic | Next topic
m_bAktiv Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_bAktiv As SqlBoolean

C#

private SqlBoolean m_bAktiv

C++

private:
SqlBoolean m_bAktiv;

JScript

private m_bAktiv : SqlBoolean

Source code

Visual Basic

Copy Code Copy Code

Private m_bDokument_geschuetzt, m_bIdv_nativ, m_bAbsender_ersteller, m_bAktiv, m_bBchorizontal, m_bKopfzeile_generieren, m_bIdv_vorlage As SqlBoolean

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsOffice_vorlage Class
clsOffice_vorlage clsOffice_vorlage Members


m_bBchorizontal Field

m_bBchorizontal Field

m_bBchorizontal Field | Previous topic | Next topic
m_bBchorizontal Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_bBchorizontal As SqlBoolean

C#

private SqlBoolean m_bBchorizontal

C++

private:
SqlBoolean m_bBchorizontal;

JScript

private m_bBchorizontal : SqlBoolean

Source code

Visual Basic

Copy Code Copy Code

Private m_bDokument_geschuetzt, m_bIdv_nativ, m_bAbsender_ersteller, m_bAktiv, m_bBchorizontal, m_bKopfzeile_generieren, m_bIdv_vorlage As SqlBoolean

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsOffice_vorlage Class
clsOffice_vorlage clsOffice_vorlage Members


m_bDokument_geschuetzt Field

m_bDokument_geschuetzt Field

m_bDokument_geschuetzt Field | Previous topic | Next topic
m_bDokument_geschuetzt Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_bDokument_geschuetzt As SqlBoolean

C#

private SqlBoolean m_bDokument_geschuetzt

C++

private:
SqlBoolean m_bDokument_geschuetzt;

JScript

private m_bDokument_geschuetzt : SqlBoolean

Source code

Visual Basic

Copy Code Copy Code

Private m_bDokument_geschuetzt, m_bIdv_nativ, m_bAbsender_ersteller, m_bAktiv, m_bBchorizontal, m_bKopfzeile_generieren, m_bIdv_vorlage As SqlBoolean

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsOffice_vorlage Class
clsOffice_vorlage clsOffice_vorlage Members


m_bIdv_nativ Field

m_bIdv_nativ Field

m_bIdv_nativ Field | Previous topic | Next topic
m_bIdv_nativ Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_bIdv_nativ As SqlBoolean

C#

private SqlBoolean m_bIdv_nativ

C++

private:
SqlBoolean m_bIdv_nativ;

JScript

private m_bIdv_nativ : SqlBoolean

Source code

Visual Basic

Copy Code Copy Code

Private m_bDokument_geschuetzt, m_bIdv_nativ, m_bAbsender_ersteller, m_bAktiv, m_bBchorizontal, m_bKopfzeile_generieren, m_bIdv_vorlage As SqlBoolean

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsOffice_vorlage Class
clsOffice_vorlage clsOffice_vorlage Members


m_bIdv_vorlage Field

m_bIdv_vorlage Field

m_bIdv_vorlage Field | Previous topic | Next topic
m_bIdv_vorlage Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_bIdv_vorlage As SqlBoolean

C#

private SqlBoolean m_bIdv_vorlage

C++

private:
SqlBoolean m_bIdv_vorlage;

JScript

private m_bIdv_vorlage : SqlBoolean

Source code

Visual Basic

Copy Code Copy Code

Private m_bDokument_geschuetzt, m_bIdv_nativ, m_bAbsender_ersteller, m_bAktiv, m_bBchorizontal, m_bKopfzeile_generieren, m_bIdv_vorlage As SqlBoolean

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsOffice_vorlage Class
clsOffice_vorlage clsOffice_vorlage Members


m_bKopfzeile_generieren Field

m_bKopfzeile_generieren Field

m_bKopfzeile_generieren Field | Previous topic | Next topic
m_bKopfzeile_generieren Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_bKopfzeile_generieren As SqlBoolean

C#

private SqlBoolean m_bKopfzeile_generieren

C++

private:
SqlBoolean m_bKopfzeile_generieren;

JScript

private m_bKopfzeile_generieren : SqlBoolean

Source code

Visual Basic

Copy Code Copy Code

Private m_bDokument_geschuetzt, m_bIdv_nativ, m_bAbsender_ersteller, m_bAktiv, m_bBchorizontal, m_bKopfzeile_generieren, m_bIdv_vorlage As SqlBoolean

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsOffice_vorlage Class
clsOffice_vorlage clsOffice_vorlage Members


m_daErstellt_am Field

m_daErstellt_am Field

m_daErstellt_am Field | Previous topic | Next topic
m_daErstellt_am Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_daErstellt_am As SqlDateTime

C#

private SqlDateTime m_daErstellt_am

C++

private:
SqlDateTime m_daErstellt_am;

JScript

private m_daErstellt_am : SqlDateTime

Source code

Visual Basic

Copy Code Copy Code

Private m_daMutiert_am, m_daErstellt_am As SqlDateTime

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsOffice_vorlage Class
clsOffice_vorlage clsOffice_vorlage Members


m_daMutiert_am Field

m_daMutiert_am Field

m_daMutiert_am Field | Previous topic | Next topic
m_daMutiert_am Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_daMutiert_am As SqlDateTime

C#

private SqlDateTime m_daMutiert_am

C++

private:
SqlDateTime m_daMutiert_am;

JScript

private m_daMutiert_am : SqlDateTime

Source code

Visual Basic

Copy Code Copy Code

Private m_daMutiert_am, m_daErstellt_am As SqlDateTime

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsOffice_vorlage Class
clsOffice_vorlage clsOffice_vorlage Members


m_iAnwendungnr Field

m_iAnwendungnr Field

m_iAnwendungnr Field | Previous topic | Next topic
m_iAnwendungnr Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_iAnwendungnr As SqlInt32

C#

private SqlInt32 m_iAnwendungnr

C++

private:
SqlInt32 m_iAnwendungnr;

JScript

private m_iAnwendungnr : SqlInt32

Source code

Visual Basic

Copy Code Copy Code

Private m_iMandantnr, m_iBch, m_iBcw, m_iOffice_vorlagenr, m_iMutierer, m_iAnwendungnr, m_iOwner, m_iKlassifizierung, m_iVorlageid, m_iBcpl, m_iBcpt As SqlInt32

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsOffice_vorlage Class
clsOffice_vorlage clsOffice_vorlage Members


m_iBch Field

m_iBch Field

m_iBch Field | Previous topic | Next topic
m_iBch Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_iBch As SqlInt32

C#

private SqlInt32 m_iBch

C++

private:
SqlInt32 m_iBch;

JScript

private m_iBch : SqlInt32

Source code

Visual Basic

Copy Code Copy Code

Private m_iMandantnr, m_iBch, m_iBcw, m_iOffice_vorlagenr, m_iMutierer, m_iAnwendungnr, m_iOwner, m_iKlassifizierung, m_iVorlageid, m_iBcpl, m_iBcpt As SqlInt32

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsOffice_vorlage Class
clsOffice_vorlage clsOffice_vorlage Members


m_iBcpl Field

m_iBcpl Field

m_iBcpl Field | Previous topic | Next topic
m_iBcpl Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_iBcpl As SqlInt32

C#

private SqlInt32 m_iBcpl

C++

private:
SqlInt32 m_iBcpl;

JScript

private m_iBcpl : SqlInt32

Source code

Visual Basic

Copy Code Copy Code

Private m_iMandantnr, m_iBch, m_iBcw, m_iOffice_vorlagenr, m_iMutierer, m_iAnwendungnr, m_iOwner, m_iKlassifizierung, m_iVorlageid, m_iBcpl, m_iBcpt As SqlInt32

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsOffice_vorlage Class
clsOffice_vorlage clsOffice_vorlage Members


m_iBcpt Field

m_iBcpt Field

m_iBcpt Field | Previous topic | Next topic
m_iBcpt Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_iBcpt As SqlInt32

C#

private SqlInt32 m_iBcpt

C++

private:
SqlInt32 m_iBcpt;

JScript

private m_iBcpt : SqlInt32

Source code

Visual Basic

Copy Code Copy Code

Private m_iMandantnr, m_iBch, m_iBcw, m_iOffice_vorlagenr, m_iMutierer, m_iAnwendungnr, m_iOwner, m_iKlassifizierung, m_iVorlageid, m_iBcpl, m_iBcpt As SqlInt32

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsOffice_vorlage Class
clsOffice_vorlage clsOffice_vorlage Members


m_iBcw Field

m_iBcw Field

m_iBcw Field | Previous topic | Next topic
m_iBcw Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_iBcw As SqlInt32

C#

private SqlInt32 m_iBcw

C++

private:
SqlInt32 m_iBcw;

JScript

private m_iBcw : SqlInt32

Source code

Visual Basic

Copy Code Copy Code

Private m_iMandantnr, m_iBch, m_iBcw, m_iOffice_vorlagenr, m_iMutierer, m_iAnwendungnr, m_iOwner, m_iKlassifizierung, m_iVorlageid, m_iBcpl, m_iBcpt As SqlInt32

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsOffice_vorlage Class
clsOffice_vorlage clsOffice_vorlage Members


m_iKlassifizierung Field

m_iKlassifizierung Field

m_iKlassifizierung Field | Previous topic | Next topic
m_iKlassifizierung Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_iKlassifizierung As SqlInt32

C#

private SqlInt32 m_iKlassifizierung

C++

private:
SqlInt32 m_iKlassifizierung;

JScript

private m_iKlassifizierung : SqlInt32

Source code

Visual Basic

Copy Code Copy Code

Private m_iMandantnr, m_iBch, m_iBcw, m_iOffice_vorlagenr, m_iMutierer, m_iAnwendungnr, m_iOwner, m_iKlassifizierung, m_iVorlageid, m_iBcpl, m_iBcpt As SqlInt32

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsOffice_vorlage Class
clsOffice_vorlage clsOffice_vorlage Members


m_iMandantnr Field

m_iMandantnr Field

m_iMandantnr Field | Previous topic | Next topic
m_iMandantnr Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_iMandantnr As SqlInt32

C#

private SqlInt32 m_iMandantnr

C++

private:
SqlInt32 m_iMandantnr;

JScript

private m_iMandantnr : SqlInt32

Source code

Visual Basic

Copy Code Copy Code

Private m_iMandantnr, m_iBch, m_iBcw, m_iOffice_vorlagenr, m_iMutierer, m_iAnwendungnr, m_iOwner, m_iKlassifizierung, m_iVorlageid, m_iBcpl, m_iBcpt As SqlInt32

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsOffice_vorlage Class
clsOffice_vorlage clsOffice_vorlage Members


m_iMutierer Field

m_iMutierer Field

m_iMutierer Field | Previous topic | Next topic
m_iMutierer Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_iMutierer As SqlInt32

C#

private SqlInt32 m_iMutierer

C++

private:
SqlInt32 m_iMutierer;

JScript

private m_iMutierer : SqlInt32

Source code

Visual Basic

Copy Code Copy Code

Private m_iMandantnr, m_iBch, m_iBcw, m_iOffice_vorlagenr, m_iMutierer, m_iAnwendungnr, m_iOwner, m_iKlassifizierung, m_iVorlageid, m_iBcpl, m_iBcpt As SqlInt32

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsOffice_vorlage Class
clsOffice_vorlage clsOffice_vorlage Members


m_iOffice_vorlagenr Field

m_iOffice_vorlagenr Field

m_iOffice_vorlagenr Field | Previous topic | Next topic
m_iOffice_vorlagenr Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_iOffice_vorlagenr As SqlInt32

C#

private SqlInt32 m_iOffice_vorlagenr

C++

private:
SqlInt32 m_iOffice_vorlagenr;

JScript

private m_iOffice_vorlagenr : SqlInt32

Source code

Visual Basic

Copy Code Copy Code

Private m_iMandantnr, m_iBch, m_iBcw, m_iOffice_vorlagenr, m_iMutierer, m_iAnwendungnr, m_iOwner, m_iKlassifizierung, m_iVorlageid, m_iBcpl, m_iBcpt As SqlInt32

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsOffice_vorlage Class
clsOffice_vorlage clsOffice_vorlage Members


m_iOwner Field

m_iOwner Field

m_iOwner Field | Previous topic | Next topic
m_iOwner Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_iOwner As SqlInt32

C#

private SqlInt32 m_iOwner

C++

private:
SqlInt32 m_iOwner;

JScript

private m_iOwner : SqlInt32

Source code

Visual Basic

Copy Code Copy Code

Private m_iMandantnr, m_iBch, m_iBcw, m_iOffice_vorlagenr, m_iMutierer, m_iAnwendungnr, m_iOwner, m_iKlassifizierung, m_iVorlageid, m_iBcpl, m_iBcpt As SqlInt32

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsOffice_vorlage Class
clsOffice_vorlage clsOffice_vorlage Members


m_iVorlageid Field

m_iVorlageid Field

m_iVorlageid Field | Previous topic | Next topic
m_iVorlageid Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_iVorlageid As SqlInt32

C#

private SqlInt32 m_iVorlageid

C++

private:
SqlInt32 m_iVorlageid;

JScript

private m_iVorlageid : SqlInt32

Source code

Visual Basic

Copy Code Copy Code

Private m_iMandantnr, m_iBch, m_iBcw, m_iOffice_vorlagenr, m_iMutierer, m_iAnwendungnr, m_iOwner, m_iKlassifizierung, m_iVorlageid, m_iBcpl, m_iBcpt As SqlInt32

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsOffice_vorlage Class
clsOffice_vorlage clsOffice_vorlage Members


m_sBeschreibung Field

m_sBeschreibung Field

m_sBeschreibung Field | Previous topic | Next topic
m_sBeschreibung Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_sBeschreibung As SqlString

C#

private SqlString m_sBeschreibung

C++

private:
SqlString m_sBeschreibung;

JScript

private m_sBeschreibung : SqlString

Source code

Visual Basic

Copy Code Copy Code

Private m_sPrefix_dokumentname, m_sIdv_id, m_sOffice_vorlage, m_sBezeichnung, m_sBeschreibung, m_sVorlagename As SqlString

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsOffice_vorlage Class
clsOffice_vorlage clsOffice_vorlage Members


m_sBezeichnung Field

m_sBezeichnung Field

m_sBezeichnung Field | Previous topic | Next topic
m_sBezeichnung Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_sBezeichnung As SqlString

C#

private SqlString m_sBezeichnung

C++

private:
SqlString m_sBezeichnung;

JScript

private m_sBezeichnung : SqlString

Source code

Visual Basic

Copy Code Copy Code

Private m_sPrefix_dokumentname, m_sIdv_id, m_sOffice_vorlage, m_sBezeichnung, m_sBeschreibung, m_sVorlagename As SqlString

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsOffice_vorlage Class
clsOffice_vorlage clsOffice_vorlage Members


m_sIdv_id Field

m_sIdv_id Field

m_sIdv_id Field | Previous topic | Next topic
m_sIdv_id Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_sIdv_id As SqlString

C#

private SqlString m_sIdv_id

C++

private:
SqlString m_sIdv_id;

JScript

private m_sIdv_id : SqlString

Source code

Visual Basic

Copy Code Copy Code

Private m_sPrefix_dokumentname, m_sIdv_id, m_sOffice_vorlage, m_sBezeichnung, m_sBeschreibung, m_sVorlagename As SqlString

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsOffice_vorlage Class
clsOffice_vorlage clsOffice_vorlage Members


m_sOffice_vorlage Field

m_sOffice_vorlage Field

m_sOffice_vorlage Field | Previous topic | Next topic
m_sOffice_vorlage Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_sOffice_vorlage As SqlString

C#

private SqlString m_sOffice_vorlage

C++

private:
SqlString m_sOffice_vorlage;

JScript

private m_sOffice_vorlage : SqlString

Source code

Visual Basic

Copy Code Copy Code

Private m_sPrefix_dokumentname, m_sIdv_id, m_sOffice_vorlage, m_sBezeichnung, m_sBeschreibung, m_sVorlagename As SqlString

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsOffice_vorlage Class
clsOffice_vorlage clsOffice_vorlage Members


m_sPrefix_dokumentname Field

m_sPrefix_dokumentname Field

m_sPrefix_dokumentname Field | Previous topic | Next topic
m_sPrefix_dokumentname Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_sPrefix_dokumentname As SqlString

C#

private SqlString m_sPrefix_dokumentname

C++

private:
SqlString m_sPrefix_dokumentname;

JScript

private m_sPrefix_dokumentname : SqlString

Source code

Visual Basic

Copy Code Copy Code

Private m_sPrefix_dokumentname, m_sIdv_id, m_sOffice_vorlage, m_sBezeichnung, m_sBeschreibung, m_sVorlagename As SqlString

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsOffice_vorlage Class
clsOffice_vorlage clsOffice_vorlage Members


m_sVorlagename Field

m_sVorlagename Field

m_sVorlagename Field | Previous topic | Next topic
m_sVorlagename Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_sVorlagename As SqlString

C#

private SqlString m_sVorlagename

C++

private:
SqlString m_sVorlagename;

JScript

private m_sVorlagename : SqlString

Source code

Visual Basic

Copy Code Copy Code

Private m_sPrefix_dokumentname, m_sIdv_id, m_sOffice_vorlage, m_sBezeichnung, m_sBeschreibung, m_sVorlagename As SqlString

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsOffice_vorlage Class
clsOffice_vorlage clsOffice_vorlage Members


clsPartner Class

clsPartner Class

clsPartner Class | Previous topic | Next topic
clsPartner Class | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Class clsPartner
Inherits clsDBInteractionBase

C#

public class clsPartner : clsDBInteractionBase

C++

public ref class clsPartner : public clsDBInteractionBase^

JScript

public class clsPartner
extends clsDBInteractionBase

Inheritance Hierarchy

System.Object

EDKB12WS.edokadb.clsDBInteractionBase

EDKB12WS.edokadb.clsPartner

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsPartner Members


clsPartner Members

clsPartner Members

clsPartner Members | Previous topic | Next topic
clsPartner Members | Previous topic | Next topic

The following tables list the members exposed by the clsPartner type.

Public Constructors

 | Name | Description
Supported by the .NET Compact Framework. | clsPartner Constructor |

Top

Public Properties

 | Name | Description
Supported by the .NET Compact Framework. | bCDVSA00 |
Supported by the .NET Compact Framework. | bSaldiert |
Supported by the .NET Compact Framework. | cpMainConnectionProvider | (inherited from clsDBInteractionBase ).
Supported by the .NET Compact Framework. | iAZEPL00 |
Supported by the .NET Compact Framework. | iErrorCode | (inherited from clsDBInteractionBase ).
Supported by the .NET Compact Framework. | iNRFOG012 |
Supported by the .NET Compact Framework. | iNRPAR00 |
Supported by the .NET Compact Framework. | sBEBAN011 |
Supported by the .NET Compact Framework. | sBEBAN012 |
Supported by the .NET Compact Framework. | sBEBAN022 |
Supported by the .NET Compact Framework. | sBEBAN21 |
Supported by the .NET Compact Framework. | sBEPGM00 |
Supported by the .NET Compact Framework. | sBKPAR00 |
Supported by the .NET Compact Framework. | sCDBAL00 |
Supported by the .NET Compact Framework. | sCDBNK00 |
Supported by the .NET Compact Framework. | sCDVIG00 |
Supported by the .NET Compact Framework. | sConnectionString | (inherited from clsDBInteractionBase ).
Supported by the .NET Compact Framework. | sDMMSG00 |
Supported by the .NET Compact Framework. | sIDMSG00 |
Supported by the .NET Compact Framework. | sNRADR00 |
Supported by the .NET Compact Framework. | sNRFOG011 |
Supported by the .NET Compact Framework. | sNRFOG022 |
Supported by the .NET Compact Framework. | sNRFOG21 |
Supported by the .NET Compact Framework. | sNRPARAD |
Supported by the .NET Compact Framework. | sSAVRS00 |
Supported by the .NET Compact Framework. | sTSMUT00 |
Supported by the .NET Compact Framework. | sTXADZ011 |
Supported by the .NET Compact Framework. | sTXADZ012 |
Supported by the .NET Compact Framework. | sTXADZ021 |
Supported by the .NET Compact Framework. | sTXADZ022 |
Supported by the .NET Compact Framework. | sTXADZ031 |
Supported by the .NET Compact Framework. | sTXADZ032 |
Supported by the .NET Compact Framework. | sTXADZ041 |
Supported by the .NET Compact Framework. | sTXADZ042 |
Supported by the .NET Compact Framework. | sTXADZ051 |
Supported by the .NET Compact Framework. | sTXADZ052 |
Supported by the .NET Compact Framework. | sTXADZ061 |
Supported by the .NET Compact Framework. | sTXADZ062 |
Supported by the .NET Compact Framework. | sTXADZ071 |
Supported by the .NET Compact Framework. | sTXADZ072 |
Supported by the .NET Compact Framework. | sTXRes00 |
Supported by the .NET Compact Framework. | sVDMUTER |
Supported by the .NET Compact Framework. | sZTMSG00 |

Top

Public Methods

 | Name | Description
Supported by the .NET Compact Framework. | Delete |
Supported by the .NET Compact Framework. | Dispose | (Overloaded) (inherited from clsDBInteractionBase ).
Public method | Equals | (Overloaded) (inherited from Object).
Public method | GetHashCode | (inherited from Object).
Public method | GetType | (Overloaded) (inherited from Object).
Supported by the .NET Compact Framework. | Insert |
 | ReferenceEquals | (inherited from Object).
Supported by the .NET Compact Framework. | SelectAll |
Supported by the .NET Compact Framework. | SelectOne |
Public method | ToString | (inherited from Object).
Supported by the .NET Compact Framework. | Update |

Top

Protected Methods

 | Name | Description
Protected method | Finalize | (inherited from Object).
Protected method | MemberwiseClone | (Overloaded) (inherited from Object).

Top

Fields

 | Name | Description
Supported by the .NET Compact Framework. | m_bCDVSA00 |
Supported by the .NET Compact Framework. | m_bMainConnectionIsCreatedLocal | (inherited from clsDBInteractionBase ).
Supported by the .NET Compact Framework. | m_bSaldiert |
Supported by the .NET Compact Framework. | m_cpMainConnectionProvider | (inherited from clsDBInteractionBase ).
Supported by the .NET Compact Framework. | m_iAZEPL00 |
Supported by the .NET Compact Framework. | m_iErrorCode | (inherited from clsDBInteractionBase ).
Supported by the .NET Compact Framework. | m_iNRFOG012 |
Supported by the .NET Compact Framework. | m_iNRPAR00 |
Supported by the .NET Compact Framework. | m_sBEBAN011 |
Supported by the .NET Compact Framework. | m_sBEBAN012 |
Supported by the .NET Compact Framework. | m_sBEBAN022 |
Supported by the .NET Compact Framework. | m_sBEBAN21 |
Supported by the .NET Compact Framework. | m_sBEPGM00 |
Supported by the .NET Compact Framework. | m_sBKPAR00 |
Supported by the .NET Compact Framework. | m_sCDBAL00 |
Supported by the .NET Compact Framework. | m_sCDBNK00 |
Supported by the .NET Compact Framework. | m_sCDVIG00 |
Supported by the .NET Compact Framework. | m_sDMMSG00 |
Supported by the .NET Compact Framework. | m_sIDMSG00 |
Supported by the .NET Compact Framework. | m_sNRADR00 |
Supported by the .NET Compact Framework. | m_sNRFOG011 |
Supported by the .NET Compact Framework. | m_sNRFOG022 |
Supported by the .NET Compact Framework. | m_sNRFOG21 |
Supported by the .NET Compact Framework. | m_sNRPARAD |
Supported by the .NET Compact Framework. | m_sSAVRS00 |
Supported by the .NET Compact Framework. | m_sTSMUT00 |
Supported by the .NET Compact Framework. | m_sTXADZ011 |
Supported by the .NET Compact Framework. | m_sTXADZ012 |
Supported by the .NET Compact Framework. | m_sTXADZ021 |
Supported by the .NET Compact Framework. | m_sTXADZ022 |
Supported by the .NET Compact Framework. | m_sTXADZ031 |
Supported by the .NET Compact Framework. | m_sTXADZ032 |
Supported by the .NET Compact Framework. | m_sTXADZ041 |
Supported by the .NET Compact Framework. | m_sTXADZ042 |
Supported by the .NET Compact Framework. | m_sTXADZ051 |
Supported by the .NET Compact Framework. | m_sTXADZ052 |
Supported by the .NET Compact Framework. | m_sTXADZ061 |
Supported by the .NET Compact Framework. | m_sTXADZ062 |
Supported by the .NET Compact Framework. | m_sTXADZ071 |
Supported by the .NET Compact Framework. | m_sTXADZ072 |
Supported by the .NET Compact Framework. | m_sTXRes00 |
Supported by the .NET Compact Framework. | m_sVDMUTER |
Supported by the .NET Compact Framework. | m_sZTMSG00 |
Supported by the .NET Compact Framework. | m_scoMainConnection | (inherited from clsDBInteractionBase ).

Top

See Also

Reference

clsPartner Class


clsPartner Constructor

clsPartner Constructor

clsPartner Constructor | Previous topic | Next topic
clsPartner Constructor | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Sub New()

C#

public clsPartner()

C++

public:
clsPartner()

JScript

public function clsPartner();

Source code

Visual Basic

Copy Code Copy Code

Public Sub New()
' // Nothing for now.
End Sub

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsPartner Class
clsPartner clsPartner Members


clsPartner Properties

clsPartner Properties

clsPartner Properties | Previous topic | Next topic
clsPartner Properties | Previous topic | Next topic

Public Properties

 | Name | Description
Supported by the .NET Compact Framework. | bCDVSA00 |
Supported by the .NET Compact Framework. | bSaldiert |
Supported by the .NET Compact Framework. | cpMainConnectionProvider | (inherited from clsDBInteractionBase ).
Supported by the .NET Compact Framework. | iAZEPL00 |
Supported by the .NET Compact Framework. | iErrorCode | (inherited from clsDBInteractionBase ).
Supported by the .NET Compact Framework. | iNRFOG012 |
Supported by the .NET Compact Framework. | iNRPAR00 |
Supported by the .NET Compact Framework. | sBEBAN011 |
Supported by the .NET Compact Framework. | sBEBAN012 |
Supported by the .NET Compact Framework. | sBEBAN022 |
Supported by the .NET Compact Framework. | sBEBAN21 |
Supported by the .NET Compact Framework. | sBEPGM00 |
Supported by the .NET Compact Framework. | sBKPAR00 |
Supported by the .NET Compact Framework. | sCDBAL00 |
Supported by the .NET Compact Framework. | sCDBNK00 |
Supported by the .NET Compact Framework. | sCDVIG00 |
Supported by the .NET Compact Framework. | sConnectionString | (inherited from clsDBInteractionBase ).
Supported by the .NET Compact Framework. | sDMMSG00 |
Supported by the .NET Compact Framework. | sIDMSG00 |
Supported by the .NET Compact Framework. | sNRADR00 |
Supported by the .NET Compact Framework. | sNRFOG011 |
Supported by the .NET Compact Framework. | sNRFOG022 |
Supported by the .NET Compact Framework. | sNRFOG21 |
Supported by the .NET Compact Framework. | sNRPARAD |
Supported by the .NET Compact Framework. | sSAVRS00 |
Supported by the .NET Compact Framework. | sTSMUT00 |
Supported by the .NET Compact Framework. | sTXADZ011 |
Supported by the .NET Compact Framework. | sTXADZ012 |
Supported by the .NET Compact Framework. | sTXADZ021 |
Supported by the .NET Compact Framework. | sTXADZ022 |
Supported by the .NET Compact Framework. | sTXADZ031 |
Supported by the .NET Compact Framework. | sTXADZ032 |
Supported by the .NET Compact Framework. | sTXADZ041 |
Supported by the .NET Compact Framework. | sTXADZ042 |
Supported by the .NET Compact Framework. | sTXADZ051 |
Supported by the .NET Compact Framework. | sTXADZ052 |
Supported by the .NET Compact Framework. | sTXADZ061 |
Supported by the .NET Compact Framework. | sTXADZ062 |
Supported by the .NET Compact Framework. | sTXADZ071 |
Supported by the .NET Compact Framework. | sTXADZ072 |
Supported by the .NET Compact Framework. | sTXRes00 |
Supported by the .NET Compact Framework. | sVDMUTER |
Supported by the .NET Compact Framework. | sZTMSG00 |

Top

See Also

Reference

clsPartner Class


clsPartner.bCDVSA00 Property

clsPartner.bCDVSA00 Property

clsPartner.bCDVSA00 Property | Previous topic | Next topic
clsPartner.bCDVSA00 Property | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property bCDVSA00() As SqlBoolean

C#

public SqlBoolean bCDVSA00 {get; set;}

C++

public:
property SqlBoolean bCDVSA00 {
SqlBoolean get( );
void set(
SqlBoolean value
);
}

JScript

public function get bCDVSA00() : SqlBoolean;
public function set bCDVSA00(value : SqlBoolean);

Source code

Visual Basic

Copy Code Copy Code

Public Property [bCDVSA00]() As SqlBoolean
Get
Return m_bCDVSA00
End Get
Set(ByVal Value As SqlBoolean)
m_bCDVSA00 = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsPartner Class
clsPartner clsPartner Members


clsPartner.bSaldiert Property

clsPartner.bSaldiert Property

clsPartner.bSaldiert Property | Previous topic | Next topic
clsPartner.bSaldiert Property | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property bSaldiert() As SqlBoolean

C#

public SqlBoolean bSaldiert {get; set;}

C++

public:
property SqlBoolean bSaldiert {
SqlBoolean get( );
void set(
SqlBoolean value
);
}

JScript

public function get bSaldiert() : SqlBoolean;
public function set bSaldiert(value : SqlBoolean);

Source code

Visual Basic

Copy Code Copy Code

Public Property [bSaldiert]() As SqlBoolean
Get
Return m_bSaldiert
End Get
Set(ByVal Value As SqlBoolean)
m_bSaldiert = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsPartner Class
clsPartner clsPartner Members


clsPartner.iAZEPL00 Property

clsPartner.iAZEPL00 Property

clsPartner.iAZEPL00 Property | Previous topic | Next topic
clsPartner.iAZEPL00 Property | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property iAZEPL00() As SqlInt32

C#

public SqlInt32 iAZEPL00 {get; set;}

C++

public:
property SqlInt32 iAZEPL00 {
SqlInt32 get( );
void set(
SqlInt32 value
);
}

JScript

public function get iAZEPL00() : SqlInt32;
public function set iAZEPL00(value : SqlInt32);

Source code

Visual Basic

Copy Code Copy Code

Public Property [iAZEPL00]() As SqlInt32
Get
Return m_iAZEPL00
End Get
Set(ByVal Value As SqlInt32)
m_iAZEPL00 = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsPartner Class
clsPartner clsPartner Members


clsPartner.iNRFOG012 Property

clsPartner.iNRFOG012 Property

clsPartner.iNRFOG012 Property | Previous topic | Next topic
clsPartner.iNRFOG012 Property | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property iNRFOG012() As SqlInt32

C#

public SqlInt32 iNRFOG012 {get; set;}

C++

public:
property SqlInt32 iNRFOG012 {
SqlInt32 get( );
void set(
SqlInt32 value
);
}

JScript

public function get iNRFOG012() : SqlInt32;
public function set iNRFOG012(value : SqlInt32);

Source code

Visual Basic

Copy Code Copy Code

Public Property [iNRFOG012]() As SqlInt32
Get
Return m_iNRFOG012
End Get
Set(ByVal Value As SqlInt32)
m_iNRFOG012 = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsPartner Class
clsPartner clsPartner Members


clsPartner.iNRPAR00 Property

clsPartner.iNRPAR00 Property

clsPartner.iNRPAR00 Property | Previous topic | Next topic
clsPartner.iNRPAR00 Property | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property iNRPAR00() As SqlInt32

C#

public SqlInt32 iNRPAR00 {get; set;}

C++

public:
property SqlInt32 iNRPAR00 {
SqlInt32 get( );
void set(
SqlInt32 value
);
}

JScript

public function get iNRPAR00() : SqlInt32;
public function set iNRPAR00(value : SqlInt32);

Source code

Visual Basic

Copy Code Copy Code

Public Property [iNRPAR00]() As SqlInt32
Get
Return m_iNRPAR00
End Get
Set(ByVal Value As SqlInt32)
Dim iNRPAR00Tmp As SqlInt32 = Value
If iNRPAR00Tmp.IsNull Then
Throw New ArgumentOutOfRangeException("iNRPAR00", "iNRPAR00 can't be NULL")
End If
m_iNRPAR00 = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsPartner Class
clsPartner clsPartner Members


clsPartner.sBEBAN011 Property

clsPartner.sBEBAN011 Property

clsPartner.sBEBAN011 Property | Previous topic | Next topic
clsPartner.sBEBAN011 Property | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property sBEBAN011() As SqlString

C#

public SqlString sBEBAN011 {get; set;}

C++

public:
property SqlString sBEBAN011 {
SqlString get( );
void set(
SqlString value
);
}

JScript

public function get sBEBAN011() : SqlString;
public function set sBEBAN011(value : SqlString);

Source code

Visual Basic

Copy Code Copy Code

Public Property [sBEBAN011]() As SqlString
Get
Return m_sBEBAN011
End Get
Set(ByVal Value As SqlString)
m_sBEBAN011 = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsPartner Class
clsPartner clsPartner Members


clsPartner.sBEBAN012 Property

clsPartner.sBEBAN012 Property

clsPartner.sBEBAN012 Property | Previous topic | Next topic
clsPartner.sBEBAN012 Property | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property sBEBAN012() As SqlString

C#

public SqlString sBEBAN012 {get; set;}

C++

public:
property SqlString sBEBAN012 {
SqlString get( );
void set(
SqlString value
);
}

JScript

public function get sBEBAN012() : SqlString;
public function set sBEBAN012(value : SqlString);

Source code

Visual Basic

Copy Code Copy Code

Public Property [sBEBAN012]() As SqlString
Get
Return m_sBEBAN012
End Get
Set(ByVal Value As SqlString)
m_sBEBAN012 = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsPartner Class
clsPartner clsPartner Members


clsPartner.sBEBAN022 Property

clsPartner.sBEBAN022 Property

clsPartner.sBEBAN022 Property | Previous topic | Next topic
clsPartner.sBEBAN022 Property | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property sBEBAN022() As SqlString

C#

public SqlString sBEBAN022 {get; set;}

C++

public:
property SqlString sBEBAN022 {
SqlString get( );
void set(
SqlString value
);
}

JScript

public function get sBEBAN022() : SqlString;
public function set sBEBAN022(value : SqlString);

Source code

Visual Basic

Copy Code Copy Code

Public Property [sBEBAN022]() As SqlString
Get
Return m_sBEBAN022
End Get
Set(ByVal Value As SqlString)
m_sBEBAN022 = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsPartner Class
clsPartner clsPartner Members


clsPartner.sBEBAN21 Property

clsPartner.sBEBAN21 Property

clsPartner.sBEBAN21 Property | Previous topic | Next topic
clsPartner.sBEBAN21 Property | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property sBEBAN21() As SqlString

C#

public SqlString sBEBAN21 {get; set;}

C++

public:
property SqlString sBEBAN21 {
SqlString get( );
void set(
SqlString value
);
}

JScript

public function get sBEBAN21() : SqlString;
public function set sBEBAN21(value : SqlString);

Source code

Visual Basic

Copy Code Copy Code

Public Property [sBEBAN21]() As SqlString
Get
Return m_sBEBAN21
End Get
Set(ByVal Value As SqlString)
m_sBEBAN21 = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsPartner Class
clsPartner clsPartner Members


clsPartner.sBEPGM00 Property

clsPartner.sBEPGM00 Property

clsPartner.sBEPGM00 Property | Previous topic | Next topic
clsPartner.sBEPGM00 Property | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property sBEPGM00() As SqlString

C#

public SqlString sBEPGM00 {get; set;}

C++

public:
property SqlString sBEPGM00 {
SqlString get( );
void set(
SqlString value
);
}

JScript

public function get sBEPGM00() : SqlString;
public function set sBEPGM00(value : SqlString);

Source code

Visual Basic

Copy Code Copy Code

Public Property [sBEPGM00]() As SqlString
Get
Return m_sBEPGM00
End Get
Set(ByVal Value As SqlString)
m_sBEPGM00 = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsPartner Class
clsPartner clsPartner Members


clsPartner.sBKPAR00 Property

clsPartner.sBKPAR00 Property

clsPartner.sBKPAR00 Property | Previous topic | Next topic
clsPartner.sBKPAR00 Property | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property sBKPAR00() As SqlString

C#

public SqlString sBKPAR00 {get; set;}

C++

public:
property SqlString sBKPAR00 {
SqlString get( );
void set(
SqlString value
);
}

JScript

public function get sBKPAR00() : SqlString;
public function set sBKPAR00(value : SqlString);

Source code

Visual Basic

Copy Code Copy Code

Public Property [sBKPAR00]() As SqlString
Get
Return m_sBKPAR00
End Get
Set(ByVal Value As SqlString)
m_sBKPAR00 = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsPartner Class
clsPartner clsPartner Members


clsPartner.sCDBAL00 Property

clsPartner.sCDBAL00 Property

clsPartner.sCDBAL00 Property | Previous topic | Next topic
clsPartner.sCDBAL00 Property | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property sCDBAL00() As SqlString

C#

public SqlString sCDBAL00 {get; set;}

C++

public:
property SqlString sCDBAL00 {
SqlString get( );
void set(
SqlString value
);
}

JScript

public function get sCDBAL00() : SqlString;
public function set sCDBAL00(value : SqlString);

Source code

Visual Basic

Copy Code Copy Code

Public Property [sCDBAL00]() As SqlString
Get
Return m_sCDBAL00
End Get
Set(ByVal Value As SqlString)
m_sCDBAL00 = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsPartner Class
clsPartner clsPartner Members


clsPartner.sCDBNK00 Property

clsPartner.sCDBNK00 Property

clsPartner.sCDBNK00 Property | Previous topic | Next topic
clsPartner.sCDBNK00 Property | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property sCDBNK00() As SqlString

C#

public SqlString sCDBNK00 {get; set;}

C++

public:
property SqlString sCDBNK00 {
SqlString get( );
void set(
SqlString value
);
}

JScript

public function get sCDBNK00() : SqlString;
public function set sCDBNK00(value : SqlString);

Source code

Visual Basic

Copy Code Copy Code

Public Property [sCDBNK00]() As SqlString
Get
Return m_sCDBNK00
End Get
Set(ByVal Value As SqlString)
m_sCDBNK00 = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsPartner Class
clsPartner clsPartner Members


clsPartner.sCDVIG00 Property

clsPartner.sCDVIG00 Property

clsPartner.sCDVIG00 Property | Previous topic | Next topic
clsPartner.sCDVIG00 Property | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property sCDVIG00() As SqlString

C#

public SqlString sCDVIG00 {get; set;}

C++

public:
property SqlString sCDVIG00 {
SqlString get( );
void set(
SqlString value
);
}

JScript

public function get sCDVIG00() : SqlString;
public function set sCDVIG00(value : SqlString);

Source code

Visual Basic

Copy Code Copy Code

Public Property [sCDVIG00]() As SqlString
Get
Return m_sCDVIG00
End Get
Set(ByVal Value As SqlString)
m_sCDVIG00 = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsPartner Class
clsPartner clsPartner Members


clsPartner.sDMMSG00 Property

clsPartner.sDMMSG00 Property

clsPartner.sDMMSG00 Property | Previous topic | Next topic
clsPartner.sDMMSG00 Property | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property sDMMSG00() As SqlString

C#

public SqlString sDMMSG00 {get; set;}

C++

public:
property SqlString sDMMSG00 {
SqlString get( );
void set(
SqlString value
);
}

JScript

public function get sDMMSG00() : SqlString;
public function set sDMMSG00(value : SqlString);

Source code

Visual Basic

Copy Code Copy Code

Public Property [sDMMSG00]() As SqlString
Get
Return m_sDMMSG00
End Get
Set(ByVal Value As SqlString)
m_sDMMSG00 = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsPartner Class
clsPartner clsPartner Members


clsPartner.sIDMSG00 Property

clsPartner.sIDMSG00 Property

clsPartner.sIDMSG00 Property | Previous topic | Next topic
clsPartner.sIDMSG00 Property | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property sIDMSG00() As SqlString

C#

public SqlString sIDMSG00 {get; set;}

C++

public:
property SqlString sIDMSG00 {
SqlString get( );
void set(
SqlString value
);
}

JScript

public function get sIDMSG00() : SqlString;
public function set sIDMSG00(value : SqlString);

Source code

Visual Basic

Copy Code Copy Code

Public Property [sIDMSG00]() As SqlString
Get
Return m_sIDMSG00
End Get
Set(ByVal Value As SqlString)
m_sIDMSG00 = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsPartner Class
clsPartner clsPartner Members


clsPartner.sNRADR00 Property

clsPartner.sNRADR00 Property

clsPartner.sNRADR00 Property | Previous topic | Next topic
clsPartner.sNRADR00 Property | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property sNRADR00() As SqlString

C#

public SqlString sNRADR00 {get; set;}

C++

public:
property SqlString sNRADR00 {
SqlString get( );
void set(
SqlString value
);
}

JScript

public function get sNRADR00() : SqlString;
public function set sNRADR00(value : SqlString);

Source code

Visual Basic

Copy Code Copy Code

Public Property [sNRADR00]() As SqlString
Get
Return m_sNRADR00
End Get
Set(ByVal Value As SqlString)
m_sNRADR00 = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsPartner Class
clsPartner clsPartner Members


clsPartner.sNRFOG011 Property

clsPartner.sNRFOG011 Property

clsPartner.sNRFOG011 Property | Previous topic | Next topic
clsPartner.sNRFOG011 Property | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property sNRFOG011() As SqlString

C#

public SqlString sNRFOG011 {get; set;}

C++

public:
property SqlString sNRFOG011 {
SqlString get( );
void set(
SqlString value
);
}

JScript

public function get sNRFOG011() : SqlString;
public function set sNRFOG011(value : SqlString);

Source code

Visual Basic

Copy Code Copy Code

Public Property [sNRFOG011]() As SqlString
Get
Return m_sNRFOG011
End Get
Set(ByVal Value As SqlString)
m_sNRFOG011 = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsPartner Class
clsPartner clsPartner Members


clsPartner.sNRFOG022 Property

clsPartner.sNRFOG022 Property

clsPartner.sNRFOG022 Property | Previous topic | Next topic
clsPartner.sNRFOG022 Property | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property sNRFOG022() As SqlString

C#

public SqlString sNRFOG022 {get; set;}

C++

public:
property SqlString sNRFOG022 {
SqlString get( );
void set(
SqlString value
);
}

JScript

public function get sNRFOG022() : SqlString;
public function set sNRFOG022(value : SqlString);

Source code

Visual Basic

Copy Code Copy Code

Public Property [sNRFOG022]() As SqlString
Get
Return m_sNRFOG022
End Get
Set(ByVal Value As SqlString)
m_sNRFOG022 = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsPartner Class
clsPartner clsPartner Members


clsPartner.sNRFOG21 Property

clsPartner.sNRFOG21 Property

clsPartner.sNRFOG21 Property | Previous topic | Next topic
clsPartner.sNRFOG21 Property | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property sNRFOG21() As SqlString

C#

public SqlString sNRFOG21 {get; set;}

C++

public:
property SqlString sNRFOG21 {
SqlString get( );
void set(
SqlString value
);
}

JScript

public function get sNRFOG21() : SqlString;
public function set sNRFOG21(value : SqlString);

Source code

Visual Basic

Copy Code Copy Code

Public Property [sNRFOG21]() As SqlString
Get
Return m_sNRFOG21
End Get
Set(ByVal Value As SqlString)
m_sNRFOG21 = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsPartner Class
clsPartner clsPartner Members


clsPartner.sNRPARAD Property

clsPartner.sNRPARAD Property

clsPartner.sNRPARAD Property | Previous topic | Next topic
clsPartner.sNRPARAD Property | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property sNRPARAD() As SqlString

C#

public SqlString sNRPARAD {get; set;}

C++

public:
property SqlString sNRPARAD {
SqlString get( );
void set(
SqlString value
);
}

JScript

public function get sNRPARAD() : SqlString;
public function set sNRPARAD(value : SqlString);

Source code

Visual Basic

Copy Code Copy Code

Public Property [sNRPARAD]() As SqlString
Get
Return m_sNRPARAD
End Get
Set(ByVal Value As SqlString)
m_sNRPARAD = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsPartner Class
clsPartner clsPartner Members


clsPartner.sSAVRS00 Property

clsPartner.sSAVRS00 Property

clsPartner.sSAVRS00 Property | Previous topic | Next topic
clsPartner.sSAVRS00 Property | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property sSAVRS00() As SqlString

C#

public SqlString sSAVRS00 {get; set;}

C++

public:
property SqlString sSAVRS00 {
SqlString get( );
void set(
SqlString value
);
}

JScript

public function get sSAVRS00() : SqlString;
public function set sSAVRS00(value : SqlString);

Source code

Visual Basic

Copy Code Copy Code

Public Property [sSAVRS00]() As SqlString
Get
Return m_sSAVRS00
End Get
Set(ByVal Value As SqlString)
m_sSAVRS00 = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsPartner Class
clsPartner clsPartner Members


clsPartner.sTSMUT00 Property

clsPartner.sTSMUT00 Property

clsPartner.sTSMUT00 Property | Previous topic | Next topic
clsPartner.sTSMUT00 Property | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property sTSMUT00() As SqlString

C#

public SqlString sTSMUT00 {get; set;}

C++

public:
property SqlString sTSMUT00 {
SqlString get( );
void set(
SqlString value
);
}

JScript

public function get sTSMUT00() : SqlString;
public function set sTSMUT00(value : SqlString);

Source code

Visual Basic

Copy Code Copy Code

Public Property [sTSMUT00]() As SqlString
Get
Return m_sTSMUT00
End Get
Set(ByVal Value As SqlString)
m_sTSMUT00 = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsPartner Class
clsPartner clsPartner Members


clsPartner.sTXADZ011 Property

clsPartner.sTXADZ011 Property

clsPartner.sTXADZ011 Property | Previous topic | Next topic
clsPartner.sTXADZ011 Property | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property sTXADZ011() As SqlString

C#

public SqlString sTXADZ011 {get; set;}

C++

public:
property SqlString sTXADZ011 {
SqlString get( );
void set(
SqlString value
);
}

JScript

public function get sTXADZ011() : SqlString;
public function set sTXADZ011(value : SqlString);

Source code

Visual Basic

Copy Code Copy Code

Public Property [sTXADZ011]() As SqlString
Get
Return m_sTXADZ011
End Get
Set(ByVal Value As SqlString)
m_sTXADZ011 = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsPartner Class
clsPartner clsPartner Members


clsPartner.sTXADZ012 Property

clsPartner.sTXADZ012 Property

clsPartner.sTXADZ012 Property | Previous topic | Next topic
clsPartner.sTXADZ012 Property | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property sTXADZ012() As SqlString

C#

public SqlString sTXADZ012 {get; set;}

C++

public:
property SqlString sTXADZ012 {
SqlString get( );
void set(
SqlString value
);
}

JScript

public function get sTXADZ012() : SqlString;
public function set sTXADZ012(value : SqlString);

Source code

Visual Basic

Copy Code Copy Code

Public Property [sTXADZ012]() As SqlString
Get
Return m_sTXADZ012
End Get
Set(ByVal Value As SqlString)
m_sTXADZ012 = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsPartner Class
clsPartner clsPartner Members


clsPartner.sTXADZ021 Property

clsPartner.sTXADZ021 Property

clsPartner.sTXADZ021 Property | Previous topic | Next topic
clsPartner.sTXADZ021 Property | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property sTXADZ021() As SqlString

C#

public SqlString sTXADZ021 {get; set;}

C++

public:
property SqlString sTXADZ021 {
SqlString get( );
void set(
SqlString value
);
}

JScript

public function get sTXADZ021() : SqlString;
public function set sTXADZ021(value : SqlString);

Source code

Visual Basic

Copy Code Copy Code

Public Property [sTXADZ021]() As SqlString
Get
Return m_sTXADZ021
End Get
Set(ByVal Value As SqlString)
m_sTXADZ021 = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsPartner Class
clsPartner clsPartner Members


clsPartner.sTXADZ022 Property

clsPartner.sTXADZ022 Property

clsPartner.sTXADZ022 Property | Previous topic | Next topic
clsPartner.sTXADZ022 Property | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property sTXADZ022() As SqlString

C#

public SqlString sTXADZ022 {get; set;}

C++

public:
property SqlString sTXADZ022 {
SqlString get( );
void set(
SqlString value
);
}

JScript

public function get sTXADZ022() : SqlString;
public function set sTXADZ022(value : SqlString);

Source code

Visual Basic

Copy Code Copy Code

Public Property [sTXADZ022]() As SqlString
Get
Return m_sTXADZ022
End Get
Set(ByVal Value As SqlString)
m_sTXADZ022 = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsPartner Class
clsPartner clsPartner Members


clsPartner.sTXADZ031 Property

clsPartner.sTXADZ031 Property

clsPartner.sTXADZ031 Property | Previous topic | Next topic
clsPartner.sTXADZ031 Property | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property sTXADZ031() As SqlString

C#

public SqlString sTXADZ031 {get; set;}

C++

public:
property SqlString sTXADZ031 {
SqlString get( );
void set(
SqlString value
);
}

JScript

public function get sTXADZ031() : SqlString;
public function set sTXADZ031(value : SqlString);

Source code

Visual Basic

Copy Code Copy Code

Public Property [sTXADZ031]() As SqlString
Get
Return m_sTXADZ031
End Get
Set(ByVal Value As SqlString)
m_sTXADZ031 = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsPartner Class
clsPartner clsPartner Members


clsPartner.sTXADZ032 Property

clsPartner.sTXADZ032 Property

clsPartner.sTXADZ032 Property | Previous topic | Next topic
clsPartner.sTXADZ032 Property | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property sTXADZ032() As SqlString

C#

public SqlString sTXADZ032 {get; set;}

C++

public:
property SqlString sTXADZ032 {
SqlString get( );
void set(
SqlString value
);
}

JScript

public function get sTXADZ032() : SqlString;
public function set sTXADZ032(value : SqlString);

Source code

Visual Basic

Copy Code Copy Code

Public Property [sTXADZ032]() As SqlString
Get
Return m_sTXADZ032
End Get
Set(ByVal Value As SqlString)
m_sTXADZ032 = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsPartner Class
clsPartner clsPartner Members


clsPartner.sTXADZ041 Property

clsPartner.sTXADZ041 Property

clsPartner.sTXADZ041 Property | Previous topic | Next topic
clsPartner.sTXADZ041 Property | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property sTXADZ041() As SqlString

C#

public SqlString sTXADZ041 {get; set;}

C++

public:
property SqlString sTXADZ041 {
SqlString get( );
void set(
SqlString value
);
}

JScript

public function get sTXADZ041() : SqlString;
public function set sTXADZ041(value : SqlString);

Source code

Visual Basic

Copy Code Copy Code

Public Property [sTXADZ041]() As SqlString
Get
Return m_sTXADZ041
End Get
Set(ByVal Value As SqlString)
m_sTXADZ041 = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsPartner Class
clsPartner clsPartner Members


clsPartner.sTXADZ042 Property

clsPartner.sTXADZ042 Property

clsPartner.sTXADZ042 Property | Previous topic | Next topic
clsPartner.sTXADZ042 Property | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property sTXADZ042() As SqlString

C#

public SqlString sTXADZ042 {get; set;}

C++

public:
property SqlString sTXADZ042 {
SqlString get( );
void set(
SqlString value
);
}

JScript

public function get sTXADZ042() : SqlString;
public function set sTXADZ042(value : SqlString);

Source code

Visual Basic

Copy Code Copy Code

Public Property [sTXADZ042]() As SqlString
Get
Return m_sTXADZ042
End Get
Set(ByVal Value As SqlString)
m_sTXADZ042 = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsPartner Class
clsPartner clsPartner Members


clsPartner.sTXADZ051 Property

clsPartner.sTXADZ051 Property

clsPartner.sTXADZ051 Property | Previous topic | Next topic
clsPartner.sTXADZ051 Property | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property sTXADZ051() As SqlString

C#

public SqlString sTXADZ051 {get; set;}

C++

public:
property SqlString sTXADZ051 {
SqlString get( );
void set(
SqlString value
);
}

JScript

public function get sTXADZ051() : SqlString;
public function set sTXADZ051(value : SqlString);

Source code

Visual Basic

Copy Code Copy Code

Public Property [sTXADZ051]() As SqlString
Get
Return m_sTXADZ051
End Get
Set(ByVal Value As SqlString)
m_sTXADZ051 = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsPartner Class
clsPartner clsPartner Members


clsPartner.sTXADZ052 Property

clsPartner.sTXADZ052 Property

clsPartner.sTXADZ052 Property | Previous topic | Next topic
clsPartner.sTXADZ052 Property | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property sTXADZ052() As SqlString

C#

public SqlString sTXADZ052 {get; set;}

C++

public:
property SqlString sTXADZ052 {
SqlString get( );
void set(
SqlString value
);
}

JScript

public function get sTXADZ052() : SqlString;
public function set sTXADZ052(value : SqlString);

Source code

Visual Basic

Copy Code Copy Code

Public Property [sTXADZ052]() As SqlString
Get
Return m_sTXADZ052
End Get
Set(ByVal Value As SqlString)
m_sTXADZ052 = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsPartner Class
clsPartner clsPartner Members


clsPartner.sTXADZ061 Property

clsPartner.sTXADZ061 Property

clsPartner.sTXADZ061 Property | Previous topic | Next topic
clsPartner.sTXADZ061 Property | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property sTXADZ061() As SqlString

C#

public SqlString sTXADZ061 {get; set;}

C++

public:
property SqlString sTXADZ061 {
SqlString get( );
void set(
SqlString value
);
}

JScript

public function get sTXADZ061() : SqlString;
public function set sTXADZ061(value : SqlString);

Source code

Visual Basic

Copy Code Copy Code

Public Property [sTXADZ061]() As SqlString
Get
Return m_sTXADZ061
End Get
Set(ByVal Value As SqlString)
m_sTXADZ061 = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsPartner Class
clsPartner clsPartner Members


clsPartner.sTXADZ062 Property

clsPartner.sTXADZ062 Property

clsPartner.sTXADZ062 Property | Previous topic | Next topic
clsPartner.sTXADZ062 Property | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property sTXADZ062() As SqlString

C#

public SqlString sTXADZ062 {get; set;}

C++

public:
property SqlString sTXADZ062 {
SqlString get( );
void set(
SqlString value
);
}

JScript

public function get sTXADZ062() : SqlString;
public function set sTXADZ062(value : SqlString);

Source code

Visual Basic

Copy Code Copy Code

Public Property [sTXADZ062]() As SqlString
Get
Return m_sTXADZ062
End Get
Set(ByVal Value As SqlString)
m_sTXADZ062 = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsPartner Class
clsPartner clsPartner Members


clsPartner.sTXADZ071 Property

clsPartner.sTXADZ071 Property

clsPartner.sTXADZ071 Property | Previous topic | Next topic
clsPartner.sTXADZ071 Property | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property sTXADZ071() As SqlString

C#

public SqlString sTXADZ071 {get; set;}

C++

public:
property SqlString sTXADZ071 {
SqlString get( );
void set(
SqlString value
);
}

JScript

public function get sTXADZ071() : SqlString;
public function set sTXADZ071(value : SqlString);

Source code

Visual Basic

Copy Code Copy Code

Public Property [sTXADZ071]() As SqlString
Get
Return m_sTXADZ071
End Get
Set(ByVal Value As SqlString)
m_sTXADZ071 = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsPartner Class
clsPartner clsPartner Members


clsPartner.sTXADZ072 Property

clsPartner.sTXADZ072 Property

clsPartner.sTXADZ072 Property | Previous topic | Next topic
clsPartner.sTXADZ072 Property | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property sTXADZ072() As SqlString

C#

public SqlString sTXADZ072 {get; set;}

C++

public:
property SqlString sTXADZ072 {
SqlString get( );
void set(
SqlString value
);
}

JScript

public function get sTXADZ072() : SqlString;
public function set sTXADZ072(value : SqlString);

Source code

Visual Basic

Copy Code Copy Code

Public Property [sTXADZ072]() As SqlString
Get
Return m_sTXADZ072
End Get
Set(ByVal Value As SqlString)
m_sTXADZ072 = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsPartner Class
clsPartner clsPartner Members


clsPartner.sTXRes00 Property

clsPartner.sTXRes00 Property

clsPartner.sTXRes00 Property | Previous topic | Next topic
clsPartner.sTXRes00 Property | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property sTXRes00() As SqlString

C#

public SqlString sTXRes00 {get; set;}

C++

public:
property SqlString sTXRes00 {
SqlString get( );
void set(
SqlString value
);
}

JScript

public function get sTXRes00() : SqlString;
public function set sTXRes00(value : SqlString);

Source code

Visual Basic

Copy Code Copy Code

Public Property [sTXRes00]() As SqlString
Get
Return m_sTXRes00
End Get
Set(ByVal Value As SqlString)
m_sTXRes00 = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsPartner Class
clsPartner clsPartner Members


clsPartner.sVDMUTER Property

clsPartner.sVDMUTER Property

clsPartner.sVDMUTER Property | Previous topic | Next topic
clsPartner.sVDMUTER Property | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property sVDMUTER() As SqlString

C#

public SqlString sVDMUTER {get; set;}

C++

public:
property SqlString sVDMUTER {
SqlString get( );
void set(
SqlString value
);
}

JScript

public function get sVDMUTER() : SqlString;
public function set sVDMUTER(value : SqlString);

Source code

Visual Basic

Copy Code Copy Code

Public Property [sVDMUTER]() As SqlString
Get
Return m_sVDMUTER
End Get
Set(ByVal Value As SqlString)
m_sVDMUTER = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsPartner Class
clsPartner clsPartner Members


clsPartner.sZTMSG00 Property

clsPartner.sZTMSG00 Property

clsPartner.sZTMSG00 Property | Previous topic | Next topic
clsPartner.sZTMSG00 Property | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property sZTMSG00() As SqlString

C#

public SqlString sZTMSG00 {get; set;}

C++

public:
property SqlString sZTMSG00 {
SqlString get( );
void set(
SqlString value
);
}

JScript

public function get sZTMSG00() : SqlString;
public function set sZTMSG00(value : SqlString);

Source code

Visual Basic

Copy Code Copy Code

Public Property [sZTMSG00]() As SqlString
Get
Return m_sZTMSG00
End Get
Set(ByVal Value As SqlString)
m_sZTMSG00 = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsPartner Class
clsPartner clsPartner Members


clsPartner Methods

clsPartner Methods

clsPartner Methods | Previous topic | Next topic
clsPartner Methods | Previous topic | Next topic

Public Methods

 | Name | Description
Supported by the .NET Compact Framework. | Delete |
Supported by the .NET Compact Framework. | Dispose | (Overloaded) (inherited from clsDBInteractionBase ).
Public method | Equals | (Overloaded) (inherited from Object).
Public method | GetHashCode | (inherited from Object).
Public method | GetType | (Overloaded) (inherited from Object).
Supported by the .NET Compact Framework. | Insert |
 | ReferenceEquals | (inherited from Object).
Supported by the .NET Compact Framework. | SelectAll |
Supported by the .NET Compact Framework. | SelectOne |
Public method | ToString | (inherited from Object).
Supported by the .NET Compact Framework. | Update |

Top

Protected Methods

 | Name | Description
Protected method | Finalize | (inherited from Object).
Protected method | MemberwiseClone | (Overloaded) (inherited from Object).

Top

See Also

Reference

clsPartner Class


clsPartner.Delete Method

clsPartner.Delete Method

clsPartner.Delete Method | Previous topic | Next topic
clsPartner.Delete Method | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Overrides Function Delete() As Boolean

C#

public override bool Delete()

C++

public:
bool Delete()

JScript

public function Delete() : boolean;

Source code

Visual Basic

Copy Code Copy Code

Public Overrides Function Delete() As Boolean
Dim scmCmdToExecute As SqlCommand = New SqlCommand()
scmCmdToExecute.CommandText = "dbo.[pr_Partner_Delete]"
scmCmdToExecute.CommandType = CommandType.StoredProcedure

' // Use base class' connection object
scmCmdToExecute.Connection = m_scoMainConnection

Try
scmCmdToExecute.Parameters.Add(New SqlParameter("@iNRPAR00", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iNRPAR00))
scmCmdToExecute.Parameters.Add(New SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

If m_bMainConnectionIsCreatedLocal Then
' // Open connection.
m_scoMainConnection.Open()
Else
If m_cpMainConnectionProvider.bIsTransactionPending Then
scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
End If
End If

' // Execute query.
scmCmdToExecute.ExecuteNonQuery()
m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
' // Throw error.
Throw New Exception("Stored Procedure 'pr_Partner_Delete' reported the ErrorCode: " & m_iErrorCode.ToString())
End If

Return True
Catch ex As Exception
' // some error occured. Bubble it to caller and encapsulate Exception object
Throw New Exception("clsPartner::Delete::Error occured.", ex)
Finally
If m_bMainConnectionIsCreatedLocal Then
' // Close connection.
m_scoMainConnection.Close()
End If
scmCmdToExecute.Dispose()
End Try
End Function

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsPartner Class
clsPartner clsPartner Members


clsPartner.Insert Method

clsPartner.Insert Method

clsPartner.Insert Method | Previous topic | Next topic
clsPartner.Insert Method | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Overrides Function Insert() As Boolean

C#

public override bool Insert()

C++

public:
bool Insert()

JScript

public function Insert() : boolean;

Source code

Visual Basic

Copy Code Copy Code

Overrides Public Function Insert() As Boolean
Dim scmCmdToExecute As SqlCommand = New SqlCommand()
scmCmdToExecute.CommandText = "dbo.[pr_Partner_Insert]"
scmCmdToExecute.CommandType = CommandType.StoredProcedure

' // Use base class' connection object
scmCmdToExecute.Connection = m_scoMainConnection

Try
scmCmdToExecute.Parameters.Add(New SqlParameter("@sIDMSG00", SqlDbType.VarChar, 8, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sIDMSG00))
scmCmdToExecute.Parameters.Add(New SqlParameter("@sDMMSG00", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sDMMSG00))
scmCmdToExecute.Parameters.Add(New SqlParameter("@sZTMSG00", SqlDbType.VarChar, 12, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sZTMSG00))
scmCmdToExecute.Parameters.Add(New SqlParameter("@sBEPGM00", SqlDbType.VarChar, 8, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBEPGM00))
scmCmdToExecute.Parameters.Add(New SqlParameter("@sCDBNK00", SqlDbType.VarChar, 8, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sCDBNK00))
scmCmdToExecute.Parameters.Add(New SqlParameter("@iNRPAR00", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iNRPAR00))
scmCmdToExecute.Parameters.Add(New SqlParameter("@sBKPAR00", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBKPAR00))
scmCmdToExecute.Parameters.Add(New SqlParameter("@iNRFOG012", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iNRFOG012))
scmCmdToExecute.Parameters.Add(New SqlParameter("@sBEBAN012", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBEBAN012))
scmCmdToExecute.Parameters.Add(New SqlParameter("@sNRFOG022", SqlDbType.VarChar, 35, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sNRFOG022))
scmCmdToExecute.Parameters.Add(New SqlParameter("@sBEBAN022", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBEBAN022))
scmCmdToExecute.Parameters.Add(New SqlParameter("@sTXADZ012", SqlDbType.VarChar, 35, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sTXADZ012))
scmCmdToExecute.Parameters.Add(New SqlParameter("@sTXADZ022", SqlDbType.VarChar, 35, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sTXADZ022))
scmCmdToExecute.Parameters.Add(New SqlParameter("@sTXADZ032", SqlDbType.VarChar, 35, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sTXADZ032))
scmCmdToExecute.Parameters.Add(New SqlParameter("@sTXADZ042", SqlDbType.VarChar, 35, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sTXADZ042))
scmCmdToExecute.Parameters.Add(New SqlParameter("@sTXADZ052", SqlDbType.VarChar, 35, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sTXADZ052))
scmCmdToExecute.Parameters.Add(New SqlParameter("@sTXADZ062", SqlDbType.VarChar, 35, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sTXADZ062))
scmCmdToExecute.Parameters.Add(New SqlParameter("@sTXADZ072", SqlDbType.VarChar, 35, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sTXADZ072))
scmCmdToExecute.Parameters.Add(New SqlParameter("@sNRPARAD", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sNRPARAD))
scmCmdToExecute.Parameters.Add(New SqlParameter("@sNRADR00", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sNRADR00))
scmCmdToExecute.Parameters.Add(New SqlParameter("@sNRFOG011", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sNRFOG011))
scmCmdToExecute.Parameters.Add(New SqlParameter("@sBEBAN011", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBEBAN011))
scmCmdToExecute.Parameters.Add(New SqlParameter("@sNRFOG21", SqlDbType.VarChar, 4, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sNRFOG21))
scmCmdToExecute.Parameters.Add(New SqlParameter("@sBEBAN21", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBEBAN21))
scmCmdToExecute.Parameters.Add(New SqlParameter("@sTXADZ011", SqlDbType.VarChar, 35, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sTXADZ011))
scmCmdToExecute.Parameters.Add(New SqlParameter("@sTXADZ021", SqlDbType.VarChar, 35, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sTXADZ021))
scmCmdToExecute.Parameters.Add(New SqlParameter("@sTXADZ031", SqlDbType.VarChar, 35, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sTXADZ031))
scmCmdToExecute.Parameters.Add(New SqlParameter("@sTXADZ041", SqlDbType.VarChar, 35, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sTXADZ041))
scmCmdToExecute.Parameters.Add(New SqlParameter("@sTXADZ051", SqlDbType.VarChar, 35, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sTXADZ051))
scmCmdToExecute.Parameters.Add(New SqlParameter("@sTXADZ061", SqlDbType.VarChar, 35, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sTXADZ061))
scmCmdToExecute.Parameters.Add(New SqlParameter("@sTXADZ071", SqlDbType.VarChar, 53, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sTXADZ071))
scmCmdToExecute.Parameters.Add(New SqlParameter("@sCDBAL00", SqlDbType.VarChar, 1, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sCDBAL00))
scmCmdToExecute.Parameters.Add(New SqlParameter("@sCDVIG00", SqlDbType.VarChar, 1, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sCDVIG00))
scmCmdToExecute.Parameters.Add(New SqlParameter("@sSAVRS00", SqlDbType.VarChar, 1, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sSAVRS00))
scmCmdToExecute.Parameters.Add(New SqlParameter("@sTSMUT00", SqlDbType.VarChar, 26, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sTSMUT00))
scmCmdToExecute.Parameters.Add(New SqlParameter("@sVDMUTER", SqlDbType.VarChar, 8, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sVDMUTER))
scmCmdToExecute.Parameters.Add(New SqlParameter("@sTXRes00", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sTXRes00))
scmCmdToExecute.Parameters.Add(New SqlParameter("@bSaldiert", SqlDbType.Bit, 1, ParameterDirection.Input, False, 1, 0, "", DataRowVersion.Proposed, m_bSaldiert))
scmCmdToExecute.Parameters.Add(New SqlParameter("@iAZEPL00", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iAZEPL00))
scmCmdToExecute.Parameters.Add(New SqlParameter("@bCDVSA00", SqlDbType.Bit, 1, ParameterDirection.Input, False, 1, 0, "", DataRowVersion.Proposed, m_bCDVSA00))
scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

If m_bMainConnectionIsCreatedLocal Then
' // Open connection.
m_scoMainConnection.Open()
Else
If m_cpMainConnectionProvider.bIsTransactionPending Then
scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
End If
End If

' // Execute query.
scmCmdToExecute.ExecuteNonQuery()
m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
' // Throw error.
Throw New Exception("Stored Procedure 'pr_Partner_Insert' reported the ErrorCode: " & m_iErrorCode.ToString())
End If

Return True
Catch ex As Exception
' // some error occured. Bubble it to caller and encapsulate Exception object
Throw New Exception("clsPartner::Insert::Error occured." + ex.Message, ex)
Finally
If m_bMainConnectionIsCreatedLocal Then
' // Close connection.
m_scoMainConnection.Close()
End If
scmCmdToExecute.Dispose()
End Try
End Function

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsPartner Class
clsPartner clsPartner Members


clsPartner.SelectAll Method

clsPartner.SelectAll Method

clsPartner.SelectAll Method | Previous topic | Next topic
clsPartner.SelectAll Method | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Overrides Function SelectAll() As DataTable

C#

public override DataTable SelectAll()

C++

public:
DataTable^ SelectAll()

JScript

public function SelectAll() : DataTable;

Source code

Visual Basic

Copy Code Copy Code

Public Overrides Function SelectAll() As DataTable
Dim scmCmdToExecute As SqlCommand = New SqlCommand()
scmCmdToExecute.CommandText = "dbo.[pr_Partner_SelectAll]"
scmCmdToExecute.CommandType = CommandType.StoredProcedure
Dim dtToReturn As DataTable = New DataTable("Partner")
Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)

' // Use base class' connection object
scmCmdToExecute.Connection = m_scoMainConnection

Try
scmCmdToExecute.Parameters.Add(New SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

If m_bMainConnectionIsCreatedLocal Then
' // Open connection.
m_scoMainConnection.Open()
Else
If m_cpMainConnectionProvider.bIsTransactionPending Then
scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
End If
End If

' // Execute query.
sdaAdapter.Fill(dtToReturn)
m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
' // Throw error.
Throw New Exception("Stored Procedure 'pr_Partner_SelectAll' reported the ErrorCode: " & m_iErrorCode.ToString())
End If

Return dtToReturn
Catch ex As Exception
' // some error occured. Bubble it to caller and encapsulate Exception object
Throw New Exception("clsPartner::SelectAll::Error occured.", ex)
Finally
If m_bMainConnectionIsCreatedLocal Then
' // Close connection.
m_scoMainConnection.Close()
End If
scmCmdToExecute.Dispose()
sdaAdapter.Dispose()
End Try
End Function

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsPartner Class
clsPartner clsPartner Members


clsPartner.SelectOne Method

clsPartner.SelectOne Method

clsPartner.SelectOne Method | Previous topic | Next topic
clsPartner.SelectOne Method | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Overrides Function SelectOne() As DataTable

C#

public override DataTable SelectOne()

C++

public:
DataTable^ SelectOne()

JScript

public function SelectOne() : DataTable;

Source code

Visual Basic

Copy Code Copy Code

Overrides Public Function SelectOne() As DataTable
Dim scmCmdToExecute As SqlCommand = New SqlCommand()
scmCmdToExecute.CommandText = "dbo.[pr_Partner_SelectOne]"
scmCmdToExecute.CommandType = CommandType.StoredProcedure
Dim dtToReturn As DataTable = new DataTable("Partner")
Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

' // Use base class' connection object
scmCmdToExecute.Connection = m_scoMainConnection

Try
scmCmdToExecute.Parameters.Add(new SqlParameter("@iNRPAR00", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iNRPAR00))
scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

If m_bMainConnectionIsCreatedLocal Then
' // Open connection.
m_scoMainConnection.Open()
Else
If m_cpMainConnectionProvider.bIsTransactionPending Then
scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
End If
End If

' // Execute query.
sdaAdapter.Fill(dtToReturn)
m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
' // Throw error.
Throw New Exception("Stored Procedure 'pr_Partner_SelectOne' reported the ErrorCode: " & m_iErrorCode.ToString())
End If

If dtToReturn.Rows.Count > 0 Then
If dtToReturn.Rows(0)("IDMSG00") Is System.DBNull.Value Then
m_sIDMSG00 = SqlString.Null
Else
m_sIDMSG00 = New SqlString(CType(dtToReturn.Rows(0)("IDMSG00"), String))
End If
If dtToReturn.Rows(0)("DMMSG00") Is System.DBNull.Value Then
m_sDMMSG00 = SqlString.Null
Else
m_sDMMSG00 = New SqlString(CType(dtToReturn.Rows(0)("DMMSG00"), String))
End If
If dtToReturn.Rows(0)("ZTMSG00") Is System.DBNull.Value Then
m_sZTMSG00 = SqlString.Null
Else
m_sZTMSG00 = New SqlString(CType(dtToReturn.Rows(0)("ZTMSG00"), String))
End If
If dtToReturn.Rows(0)("BEPGM00") Is System.DBNull.Value Then
m_sBEPGM00 = SqlString.Null
Else
m_sBEPGM00 = New SqlString(CType(dtToReturn.Rows(0)("BEPGM00"), String))
End If
If dtToReturn.Rows(0)("CDBNK00") Is System.DBNull.Value Then
m_sCDBNK00 = SqlString.Null
Else
m_sCDBNK00 = New SqlString(CType(dtToReturn.Rows(0)("CDBNK00"), String))
End If
m_iNRPAR00 = New SqlInt32(CType(dtToReturn.Rows(0)("NRPAR00"), Integer))
If dtToReturn.Rows(0)("BKPAR00") Is System.DBNull.Value Then
m_sBKPAR00 = SqlString.Null
Else
m_sBKPAR00 = New SqlString(CType(dtToReturn.Rows(0)("BKPAR00"), String))
End If
If dtToReturn.Rows(0)("NRFOG012") Is System.DBNull.Value Then
m_iNRFOG012 = SqlInt32.Null
Else
m_iNRFOG012 = New SqlInt32(CType(dtToReturn.Rows(0)("NRFOG012"), Integer))
End If
If dtToReturn.Rows(0)("BEBAN012") Is System.DBNull.Value Then
m_sBEBAN012 = SqlString.Null
Else
m_sBEBAN012 = New SqlString(CType(dtToReturn.Rows(0)("BEBAN012"), String))
End If
If dtToReturn.Rows(0)("NRFOG022") Is System.DBNull.Value Then
m_sNRFOG022 = SqlString.Null
Else
m_sNRFOG022 = New SqlString(CType(dtToReturn.Rows(0)("NRFOG022"), String))
End If
If dtToReturn.Rows(0)("BEBAN022") Is System.DBNull.Value Then
m_sBEBAN022 = SqlString.Null
Else
m_sBEBAN022 = New SqlString(CType(dtToReturn.Rows(0)("BEBAN022"), String))
End If
If dtToReturn.Rows(0)("TXADZ012") Is System.DBNull.Value Then
m_sTXADZ012 = SqlString.Null
Else
m_sTXADZ012 = New SqlString(CType(dtToReturn.Rows(0)("TXADZ012"), String))
End If
If dtToReturn.Rows(0)("TXADZ022") Is System.DBNull.Value Then
m_sTXADZ022 = SqlString.Null
Else
m_sTXADZ022 = New SqlString(CType(dtToReturn.Rows(0)("TXADZ022"), String))
End If
If dtToReturn.Rows(0)("TXADZ032") Is System.DBNull.Value Then
m_sTXADZ032 = SqlString.Null
Else
m_sTXADZ032 = New SqlString(CType(dtToReturn.Rows(0)("TXADZ032"), String))
End If
If dtToReturn.Rows(0)("TXADZ042") Is System.DBNull.Value Then
m_sTXADZ042 = SqlString.Null
Else
m_sTXADZ042 = New SqlString(CType(dtToReturn.Rows(0)("TXADZ042"), String))
End If
If dtToReturn.Rows(0)("TXADZ052") Is System.DBNull.Value Then
m_sTXADZ052 = SqlString.Null
Else
m_sTXADZ052 = New SqlString(CType(dtToReturn.Rows(0)("TXADZ052"), String))
End If
If dtToReturn.Rows(0)("TXADZ062") Is System.DBNull.Value Then
m_sTXADZ062 = SqlString.Null
Else
m_sTXADZ062 = New SqlString(CType(dtToReturn.Rows(0)("TXADZ062"), String))
End If
If dtToReturn.Rows(0)("TXADZ072") Is System.DBNull.Value Then
m_sTXADZ072 = SqlString.Null
Else
m_sTXADZ072 = New SqlString(CType(dtToReturn.Rows(0)("TXADZ072"), String))
End If
If dtToReturn.Rows(0)("NRPARAD") Is System.DBNull.Value Then
m_sNRPARAD = SqlString.Null
Else
m_sNRPARAD = New SqlString(CType(dtToReturn.Rows(0)("NRPARAD"), String))
End If
If dtToReturn.Rows(0)("NRADR00") Is System.DBNull.Value Then
m_sNRADR00 = SqlString.Null
Else
m_sNRADR00 = New SqlString(CType(dtToReturn.Rows(0)("NRADR00"), String))
End If
If dtToReturn.Rows(0)("NRFOG011") Is System.DBNull.Value Then
m_sNRFOG011 = SqlString.Null
Else
m_sNRFOG011 = New SqlString(CType(dtToReturn.Rows(0)("NRFOG011"), String))
End If
If dtToReturn.Rows(0)("BEBAN011") Is System.DBNull.Value Then
m_sBEBAN011 = SqlString.Null
Else
m_sBEBAN011 = New SqlString(CType(dtToReturn.Rows(0)("BEBAN011"), String))
End If
If dtToReturn.Rows(0)("NRFOG21") Is System.DBNull.Value Then
m_sNRFOG21 = SqlString.Null
Else
m_sNRFOG21 = New SqlString(CType(dtToReturn.Rows(0)("NRFOG21"), String))
End If
If dtToReturn.Rows(0)("BEBAN21") Is System.DBNull.Value Then
m_sBEBAN21 = SqlString.Null
Else
m_sBEBAN21 = New SqlString(CType(dtToReturn.Rows(0)("BEBAN21"), String))
End If
If dtToReturn.Rows(0)("TXADZ011") Is System.DBNull.Value Then
m_sTXADZ011 = SqlString.Null
Else
m_sTXADZ011 = New SqlString(CType(dtToReturn.Rows(0)("TXADZ011"), String))
End If
If dtToReturn.Rows(0)("TXADZ021") Is System.DBNull.Value Then
m_sTXADZ021 = SqlString.Null
Else
m_sTXADZ021 = New SqlString(CType(dtToReturn.Rows(0)("TXADZ021"), String))
End If
If dtToReturn.Rows(0)("TXADZ031") Is System.DBNull.Value Then
m_sTXADZ031 = SqlString.Null
Else
m_sTXADZ031 = New SqlString(CType(dtToReturn.Rows(0)("TXADZ031"), String))
End If
If dtToReturn.Rows(0)("TXADZ041") Is System.DBNull.Value Then
m_sTXADZ041 = SqlString.Null
Else
m_sTXADZ041 = New SqlString(CType(dtToReturn.Rows(0)("TXADZ041"), String))
End If
If dtToReturn.Rows(0)("TXADZ051") Is System.DBNull.Value Then
m_sTXADZ051 = SqlString.Null
Else
m_sTXADZ051 = New SqlString(CType(dtToReturn.Rows(0)("TXADZ051"), String))
End If
If dtToReturn.Rows(0)("TXADZ061") Is System.DBNull.Value Then
m_sTXADZ061 = SqlString.Null
Else
m_sTXADZ061 = New SqlString(CType(dtToReturn.Rows(0)("TXADZ061"), String))
End If
If dtToReturn.Rows(0)("TXADZ071") Is System.DBNull.Value Then
m_sTXADZ071 = SqlString.Null
Else
m_sTXADZ071 = New SqlString(CType(dtToReturn.Rows(0)("TXADZ071"), String))
End If
If dtToReturn.Rows(0)("CDBAL00") Is System.DBNull.Value Then
m_sCDBAL00 = SqlString.Null
Else
m_sCDBAL00 = New SqlString(CType(dtToReturn.Rows(0)("CDBAL00"), String))
End If
If dtToReturn.Rows(0)("CDVIG00") Is System.DBNull.Value Then
m_sCDVIG00 = SqlString.Null
Else
m_sCDVIG00 = New SqlString(CType(dtToReturn.Rows(0)("CDVIG00"), String))
End If
If dtToReturn.Rows(0)("SAVRS00") Is System.DBNull.Value Then
m_sSAVRS00 = SqlString.Null
Else
m_sSAVRS00 = New SqlString(CType(dtToReturn.Rows(0)("SAVRS00"), String))
End If
If dtToReturn.Rows(0)("TSMUT00") Is System.DBNull.Value Then
m_sTSMUT00 = SqlString.Null
Else
m_sTSMUT00 = New SqlString(CType(dtToReturn.Rows(0)("TSMUT00"), String))
End If
If dtToReturn.Rows(0)("VDMUTER") Is System.DBNull.Value Then
m_sVDMUTER = SqlString.Null
Else
m_sVDMUTER = New SqlString(CType(dtToReturn.Rows(0)("VDMUTER"), String))
End If
If dtToReturn.Rows(0)("TXRes00") Is System.DBNull.Value Then
m_sTXRes00 = SqlString.Null
Else
m_sTXRes00 = New SqlString(CType(dtToReturn.Rows(0)("TXRes00"), String))
End If
m_bSaldiert = New SqlBoolean(CType(dtToReturn.Rows(0)("Saldiert"), Boolean))
If dtToReturn.Rows(0)("AZEPL00") Is System.DBNull.Value Then
m_iAZEPL00 = SqlInt32.Null
Else
m_iAZEPL00 = New SqlInt32(CType(dtToReturn.Rows(0)("AZEPL00"), Integer))
End If
m_bCDVSA00 = New SqlBoolean(CType(dtToReturn.Rows(0)("CDVSA00"), Boolean))
End If
Return dtToReturn
Catch ex As Exception
' // some error occured. Bubble it to caller and encapsulate Exception object
Throw New Exception("clsPartner::SelectOne::Error occured.", ex)
Finally
If m_bMainConnectionIsCreatedLocal Then
' // Close connection.
m_scoMainConnection.Close()
End If
scmCmdToExecute.Dispose()
sdaAdapter.Dispose()
End Try
End Function

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsPartner Class
clsPartner clsPartner Members


clsPartner.Update Method

clsPartner.Update Method

clsPartner.Update Method | Previous topic | Next topic
clsPartner.Update Method | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Overrides Function Update() As Boolean

C#

public override bool Update()

C++

public:
bool Update()

JScript

public function Update() : boolean;

Source code

Visual Basic

Copy Code Copy Code

Overrides Public Function Update() As Boolean
Dim scmCmdToExecute As SqlCommand = New SqlCommand()
scmCmdToExecute.CommandText = "dbo.[pr_Partner_Update]"
scmCmdToExecute.CommandType = CommandType.StoredProcedure

' // Use base class' connection object
scmCmdToExecute.Connection = m_scoMainConnection

Try
scmCmdToExecute.Parameters.Add(New SqlParameter("@sIDMSG00", SqlDbType.VarChar, 8, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sIDMSG00))
scmCmdToExecute.Parameters.Add(New SqlParameter("@sDMMSG00", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sDMMSG00))
scmCmdToExecute.Parameters.Add(New SqlParameter("@sZTMSG00", SqlDbType.VarChar, 12, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sZTMSG00))
scmCmdToExecute.Parameters.Add(New SqlParameter("@sBEPGM00", SqlDbType.VarChar, 8, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBEPGM00))
scmCmdToExecute.Parameters.Add(New SqlParameter("@sCDBNK00", SqlDbType.VarChar, 8, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sCDBNK00))
scmCmdToExecute.Parameters.Add(New SqlParameter("@iNRPAR00", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iNRPAR00))
scmCmdToExecute.Parameters.Add(New SqlParameter("@sBKPAR00", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBKPAR00))
scmCmdToExecute.Parameters.Add(New SqlParameter("@iNRFOG012", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iNRFOG012))
scmCmdToExecute.Parameters.Add(New SqlParameter("@sBEBAN012", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBEBAN012))
scmCmdToExecute.Parameters.Add(New SqlParameter("@sNRFOG022", SqlDbType.VarChar, 35, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sNRFOG022))
scmCmdToExecute.Parameters.Add(New SqlParameter("@sBEBAN022", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBEBAN022))
scmCmdToExecute.Parameters.Add(New SqlParameter("@sTXADZ012", SqlDbType.VarChar, 35, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sTXADZ012))
scmCmdToExecute.Parameters.Add(New SqlParameter("@sTXADZ022", SqlDbType.VarChar, 35, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sTXADZ022))
scmCmdToExecute.Parameters.Add(New SqlParameter("@sTXADZ032", SqlDbType.VarChar, 35, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sTXADZ032))
scmCmdToExecute.Parameters.Add(New SqlParameter("@sTXADZ042", SqlDbType.VarChar, 35, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sTXADZ042))
scmCmdToExecute.Parameters.Add(New SqlParameter("@sTXADZ052", SqlDbType.VarChar, 35, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sTXADZ052))
scmCmdToExecute.Parameters.Add(New SqlParameter("@sTXADZ062", SqlDbType.VarChar, 35, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sTXADZ062))
scmCmdToExecute.Parameters.Add(New SqlParameter("@sTXADZ072", SqlDbType.VarChar, 35, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sTXADZ072))
scmCmdToExecute.Parameters.Add(New SqlParameter("@sNRPARAD", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sNRPARAD))
scmCmdToExecute.Parameters.Add(New SqlParameter("@sNRADR00", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sNRADR00))
scmCmdToExecute.Parameters.Add(New SqlParameter("@sNRFOG011", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sNRFOG011))
scmCmdToExecute.Parameters.Add(New SqlParameter("@sBEBAN011", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBEBAN011))
scmCmdToExecute.Parameters.Add(New SqlParameter("@sNRFOG21", SqlDbType.VarChar, 4, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sNRFOG21))
scmCmdToExecute.Parameters.Add(New SqlParameter("@sBEBAN21", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sBEBAN21))
scmCmdToExecute.Parameters.Add(New SqlParameter("@sTXADZ011", SqlDbType.VarChar, 35, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sTXADZ011))
scmCmdToExecute.Parameters.Add(New SqlParameter("@sTXADZ021", SqlDbType.VarChar, 35, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sTXADZ021))
scmCmdToExecute.Parameters.Add(New SqlParameter("@sTXADZ031", SqlDbType.VarChar, 35, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sTXADZ031))
scmCmdToExecute.Parameters.Add(New SqlParameter("@sTXADZ041", SqlDbType.VarChar, 35, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sTXADZ041))
scmCmdToExecute.Parameters.Add(New SqlParameter("@sTXADZ051", SqlDbType.VarChar, 35, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sTXADZ051))
scmCmdToExecute.Parameters.Add(New SqlParameter("@sTXADZ061", SqlDbType.VarChar, 35, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sTXADZ061))
scmCmdToExecute.Parameters.Add(New SqlParameter("@sTXADZ071", SqlDbType.VarChar, 53, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sTXADZ071))
scmCmdToExecute.Parameters.Add(New SqlParameter("@sCDBAL00", SqlDbType.VarChar, 1, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sCDBAL00))
scmCmdToExecute.Parameters.Add(New SqlParameter("@sCDVIG00", SqlDbType.VarChar, 1, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sCDVIG00))
scmCmdToExecute.Parameters.Add(New SqlParameter("@sSAVRS00", SqlDbType.VarChar, 1, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sSAVRS00))
scmCmdToExecute.Parameters.Add(New SqlParameter("@sTSMUT00", SqlDbType.VarChar, 26, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sTSMUT00))
scmCmdToExecute.Parameters.Add(New SqlParameter("@sVDMUTER", SqlDbType.VarChar, 8, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sVDMUTER))
scmCmdToExecute.Parameters.Add(New SqlParameter("@sTXRes00", SqlDbType.VarChar, 50, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sTXRes00))
scmCmdToExecute.Parameters.Add(New SqlParameter("@bSaldiert", SqlDbType.Bit, 1, ParameterDirection.Input, False, 1, 0, "", DataRowVersion.Proposed, m_bSaldiert))
scmCmdToExecute.Parameters.Add(New SqlParameter("@iAZEPL00", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iAZEPL00))
scmCmdToExecute.Parameters.Add(New SqlParameter("@bCDVSA00", SqlDbType.Bit, 1, ParameterDirection.Input, False, 1, 0, "", DataRowVersion.Proposed, m_bCDVSA00))
scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

If m_bMainConnectionIsCreatedLocal Then
' // Open connection.
m_scoMainConnection.Open()
Else
If m_cpMainConnectionProvider.bIsTransactionPending Then
scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
End If
End If

' // Execute query.
scmCmdToExecute.ExecuteNonQuery()
m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
' // Throw error.
Throw New Exception("Stored Procedure 'pr_Partner_Update' reported the ErrorCode: " & m_iErrorCode.ToString())
End If

Return True
Catch ex As Exception
' // some error occured. Bubble it to caller and encapsulate Exception object
Throw New Exception("clsPartner::Update::Error occured.", ex)
Finally
If m_bMainConnectionIsCreatedLocal Then
' // Close connection.
m_scoMainConnection.Close()
End If
scmCmdToExecute.Dispose()
End Try
End Function

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsPartner Class
clsPartner clsPartner Members


clsPartner Fields

clsPartner Fields

clsPartner Fields | Previous topic | Next topic
clsPartner Fields | Previous topic | Next topic

Fields

 | Name | Description
Supported by the .NET Compact Framework. | m_bCDVSA00 |
Supported by the .NET Compact Framework. | m_bMainConnectionIsCreatedLocal | (inherited from clsDBInteractionBase ).
Supported by the .NET Compact Framework. | m_bSaldiert |
Supported by the .NET Compact Framework. | m_cpMainConnectionProvider | (inherited from clsDBInteractionBase ).
Supported by the .NET Compact Framework. | m_iAZEPL00 |
Supported by the .NET Compact Framework. | m_iErrorCode | (inherited from clsDBInteractionBase ).
Supported by the .NET Compact Framework. | m_iNRFOG012 |
Supported by the .NET Compact Framework. | m_iNRPAR00 |
Supported by the .NET Compact Framework. | m_sBEBAN011 |
Supported by the .NET Compact Framework. | m_sBEBAN012 |
Supported by the .NET Compact Framework. | m_sBEBAN022 |
Supported by the .NET Compact Framework. | m_sBEBAN21 |
Supported by the .NET Compact Framework. | m_sBEPGM00 |
Supported by the .NET Compact Framework. | m_sBKPAR00 |
Supported by the .NET Compact Framework. | m_sCDBAL00 |
Supported by the .NET Compact Framework. | m_sCDBNK00 |
Supported by the .NET Compact Framework. | m_sCDVIG00 |
Supported by the .NET Compact Framework. | m_sDMMSG00 |
Supported by the .NET Compact Framework. | m_sIDMSG00 |
Supported by the .NET Compact Framework. | m_sNRADR00 |
Supported by the .NET Compact Framework. | m_sNRFOG011 |
Supported by the .NET Compact Framework. | m_sNRFOG022 |
Supported by the .NET Compact Framework. | m_sNRFOG21 |
Supported by the .NET Compact Framework. | m_sNRPARAD |
Supported by the .NET Compact Framework. | m_sSAVRS00 |
Supported by the .NET Compact Framework. | m_sTSMUT00 |
Supported by the .NET Compact Framework. | m_sTXADZ011 |
Supported by the .NET Compact Framework. | m_sTXADZ012 |
Supported by the .NET Compact Framework. | m_sTXADZ021 |
Supported by the .NET Compact Framework. | m_sTXADZ022 |
Supported by the .NET Compact Framework. | m_sTXADZ031 |
Supported by the .NET Compact Framework. | m_sTXADZ032 |
Supported by the .NET Compact Framework. | m_sTXADZ041 |
Supported by the .NET Compact Framework. | m_sTXADZ042 |
Supported by the .NET Compact Framework. | m_sTXADZ051 |
Supported by the .NET Compact Framework. | m_sTXADZ052 |
Supported by the .NET Compact Framework. | m_sTXADZ061 |
Supported by the .NET Compact Framework. | m_sTXADZ062 |
Supported by the .NET Compact Framework. | m_sTXADZ071 |
Supported by the .NET Compact Framework. | m_sTXADZ072 |
Supported by the .NET Compact Framework. | m_sTXRes00 |
Supported by the .NET Compact Framework. | m_sVDMUTER |
Supported by the .NET Compact Framework. | m_sZTMSG00 |
Supported by the .NET Compact Framework. | m_scoMainConnection | (inherited from clsDBInteractionBase ).

Top

See Also

Reference

clsPartner Class


m_bCDVSA00 Field

m_bCDVSA00 Field

m_bCDVSA00 Field | Previous topic | Next topic
m_bCDVSA00 Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_bCDVSA00 As SqlBoolean

C#

private SqlBoolean m_bCDVSA00

C++

private:
SqlBoolean m_bCDVSA00;

JScript

private m_bCDVSA00 : SqlBoolean

Source code

Visual Basic

Copy Code Copy Code

Private m_bSaldiert, m_bCDVSA00 As SqlBoolean

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsPartner Class
clsPartner clsPartner Members


m_bSaldiert Field

m_bSaldiert Field

m_bSaldiert Field | Previous topic | Next topic
m_bSaldiert Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_bSaldiert As SqlBoolean

C#

private SqlBoolean m_bSaldiert

C++

private:
SqlBoolean m_bSaldiert;

JScript

private m_bSaldiert : SqlBoolean

Source code

Visual Basic

Copy Code Copy Code

Private m_bSaldiert, m_bCDVSA00 As SqlBoolean

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsPartner Class
clsPartner clsPartner Members


m_iAZEPL00 Field

m_iAZEPL00 Field

m_iAZEPL00 Field | Previous topic | Next topic
m_iAZEPL00 Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_iAZEPL00 As SqlInt32

C#

private SqlInt32 m_iAZEPL00

C++

private:
SqlInt32 m_iAZEPL00;

JScript

private m_iAZEPL00 : SqlInt32

Source code

Visual Basic

Copy Code Copy Code

Private m_iNRFOG012, m_iNRPAR00, m_iAZEPL00 As SqlInt32

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsPartner Class
clsPartner clsPartner Members


m_iNRFOG012 Field

m_iNRFOG012 Field

m_iNRFOG012 Field | Previous topic | Next topic
m_iNRFOG012 Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_iNRFOG012 As SqlInt32

C#

private SqlInt32 m_iNRFOG012

C++

private:
SqlInt32 m_iNRFOG012;

JScript

private m_iNRFOG012 : SqlInt32

Source code

Visual Basic

Copy Code Copy Code

Private m_iNRFOG012, m_iNRPAR00, m_iAZEPL00 As SqlInt32

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsPartner Class
clsPartner clsPartner Members


m_iNRPAR00 Field

m_iNRPAR00 Field

m_iNRPAR00 Field | Previous topic | Next topic
m_iNRPAR00 Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_iNRPAR00 As SqlInt32

C#

private SqlInt32 m_iNRPAR00

C++

private:
SqlInt32 m_iNRPAR00;

JScript

private m_iNRPAR00 : SqlInt32

Source code

Visual Basic

Copy Code Copy Code

Private m_iNRFOG012, m_iNRPAR00, m_iAZEPL00 As SqlInt32

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsPartner Class
clsPartner clsPartner Members


m_sBEBAN011 Field

m_sBEBAN011 Field

m_sBEBAN011 Field | Previous topic | Next topic
m_sBEBAN011 Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_sBEBAN011 As SqlString

C#

private SqlString m_sBEBAN011

C++

private:
SqlString m_sBEBAN011;

JScript

private m_sBEBAN011 : SqlString

Source code

Visual Basic

Copy Code Copy Code

Private m_sTXADZ021, m_sTXADZ031, m_sTXADZ051, m_sTXADZ041, m_sNRFOG21, m_sBEBAN011, m_sTXADZ011, m_sBEBAN21, m_sTSMUT00, m_sSAVRS00, m_sTXRes00, m_sVDMUTER, m_sTXADZ071, m_sTXADZ061, m_sCDVIG00, m_sCDBAL00, m_sBEBAN012, m_sBKPAR00, m_sBEBAN022, m_sNRFOG022, m_sCDBNK00, m_sDMMSG00, m_sIDMSG00, m_sBEPGM00, m_sZTMSG00, m_sTXADZ012, m_sNRPARAD, m_sTXADZ072, m_sNRFOG011, m_sNRADR00, m_sTXADZ062, m_sTXADZ032, m_sTXADZ022, m_sTXADZ052, m_sTXADZ042 As SqlString

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsPartner Class
clsPartner clsPartner Members


m_sBEBAN012 Field

m_sBEBAN012 Field

m_sBEBAN012 Field | Previous topic | Next topic
m_sBEBAN012 Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_sBEBAN012 As SqlString

C#

private SqlString m_sBEBAN012

C++

private:
SqlString m_sBEBAN012;

JScript

private m_sBEBAN012 : SqlString

Source code

Visual Basic

Copy Code Copy Code

Private m_sTXADZ021, m_sTXADZ031, m_sTXADZ051, m_sTXADZ041, m_sNRFOG21, m_sBEBAN011, m_sTXADZ011, m_sBEBAN21, m_sTSMUT00, m_sSAVRS00, m_sTXRes00, m_sVDMUTER, m_sTXADZ071, m_sTXADZ061, m_sCDVIG00, m_sCDBAL00, m_sBEBAN012, m_sBKPAR00, m_sBEBAN022, m_sNRFOG022, m_sCDBNK00, m_sDMMSG00, m_sIDMSG00, m_sBEPGM00, m_sZTMSG00, m_sTXADZ012, m_sNRPARAD, m_sTXADZ072, m_sNRFOG011, m_sNRADR00, m_sTXADZ062, m_sTXADZ032, m_sTXADZ022, m_sTXADZ052, m_sTXADZ042 As SqlString

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsPartner Class
clsPartner clsPartner Members


m_sBEBAN022 Field

m_sBEBAN022 Field

m_sBEBAN022 Field | Previous topic | Next topic
m_sBEBAN022 Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_sBEBAN022 As SqlString

C#

private SqlString m_sBEBAN022

C++

private:
SqlString m_sBEBAN022;

JScript

private m_sBEBAN022 : SqlString

Source code

Visual Basic

Copy Code Copy Code

Private m_sTXADZ021, m_sTXADZ031, m_sTXADZ051, m_sTXADZ041, m_sNRFOG21, m_sBEBAN011, m_sTXADZ011, m_sBEBAN21, m_sTSMUT00, m_sSAVRS00, m_sTXRes00, m_sVDMUTER, m_sTXADZ071, m_sTXADZ061, m_sCDVIG00, m_sCDBAL00, m_sBEBAN012, m_sBKPAR00, m_sBEBAN022, m_sNRFOG022, m_sCDBNK00, m_sDMMSG00, m_sIDMSG00, m_sBEPGM00, m_sZTMSG00, m_sTXADZ012, m_sNRPARAD, m_sTXADZ072, m_sNRFOG011, m_sNRADR00, m_sTXADZ062, m_sTXADZ032, m_sTXADZ022, m_sTXADZ052, m_sTXADZ042 As SqlString

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsPartner Class
clsPartner clsPartner Members


m_sBEBAN21 Field

m_sBEBAN21 Field

m_sBEBAN21 Field | Previous topic | Next topic
m_sBEBAN21 Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_sBEBAN21 As SqlString

C#

private SqlString m_sBEBAN21

C++

private:
SqlString m_sBEBAN21;

JScript

private m_sBEBAN21 : SqlString

Source code

Visual Basic

Copy Code Copy Code

Private m_sTXADZ021, m_sTXADZ031, m_sTXADZ051, m_sTXADZ041, m_sNRFOG21, m_sBEBAN011, m_sTXADZ011, m_sBEBAN21, m_sTSMUT00, m_sSAVRS00, m_sTXRes00, m_sVDMUTER, m_sTXADZ071, m_sTXADZ061, m_sCDVIG00, m_sCDBAL00, m_sBEBAN012, m_sBKPAR00, m_sBEBAN022, m_sNRFOG022, m_sCDBNK00, m_sDMMSG00, m_sIDMSG00, m_sBEPGM00, m_sZTMSG00, m_sTXADZ012, m_sNRPARAD, m_sTXADZ072, m_sNRFOG011, m_sNRADR00, m_sTXADZ062, m_sTXADZ032, m_sTXADZ022, m_sTXADZ052, m_sTXADZ042 As SqlString

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsPartner Class
clsPartner clsPartner Members


m_sBEPGM00 Field

m_sBEPGM00 Field

m_sBEPGM00 Field | Previous topic | Next topic
m_sBEPGM00 Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_sBEPGM00 As SqlString

C#

private SqlString m_sBEPGM00

C++

private:
SqlString m_sBEPGM00;

JScript

private m_sBEPGM00 : SqlString

Source code

Visual Basic

Copy Code Copy Code

Private m_sTXADZ021, m_sTXADZ031, m_sTXADZ051, m_sTXADZ041, m_sNRFOG21, m_sBEBAN011, m_sTXADZ011, m_sBEBAN21, m_sTSMUT00, m_sSAVRS00, m_sTXRes00, m_sVDMUTER, m_sTXADZ071, m_sTXADZ061, m_sCDVIG00, m_sCDBAL00, m_sBEBAN012, m_sBKPAR00, m_sBEBAN022, m_sNRFOG022, m_sCDBNK00, m_sDMMSG00, m_sIDMSG00, m_sBEPGM00, m_sZTMSG00, m_sTXADZ012, m_sNRPARAD, m_sTXADZ072, m_sNRFOG011, m_sNRADR00, m_sTXADZ062, m_sTXADZ032, m_sTXADZ022, m_sTXADZ052, m_sTXADZ042 As SqlString

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsPartner Class
clsPartner clsPartner Members


m_sBKPAR00 Field

m_sBKPAR00 Field

m_sBKPAR00 Field | Previous topic | Next topic
m_sBKPAR00 Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_sBKPAR00 As SqlString

C#

private SqlString m_sBKPAR00

C++

private:
SqlString m_sBKPAR00;

JScript

private m_sBKPAR00 : SqlString

Source code

Visual Basic

Copy Code Copy Code

Private m_sTXADZ021, m_sTXADZ031, m_sTXADZ051, m_sTXADZ041, m_sNRFOG21, m_sBEBAN011, m_sTXADZ011, m_sBEBAN21, m_sTSMUT00, m_sSAVRS00, m_sTXRes00, m_sVDMUTER, m_sTXADZ071, m_sTXADZ061, m_sCDVIG00, m_sCDBAL00, m_sBEBAN012, m_sBKPAR00, m_sBEBAN022, m_sNRFOG022, m_sCDBNK00, m_sDMMSG00, m_sIDMSG00, m_sBEPGM00, m_sZTMSG00, m_sTXADZ012, m_sNRPARAD, m_sTXADZ072, m_sNRFOG011, m_sNRADR00, m_sTXADZ062, m_sTXADZ032, m_sTXADZ022, m_sTXADZ052, m_sTXADZ042 As SqlString

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsPartner Class
clsPartner clsPartner Members


m_sCDBAL00 Field

m_sCDBAL00 Field

m_sCDBAL00 Field | Previous topic | Next topic
m_sCDBAL00 Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_sCDBAL00 As SqlString

C#

private SqlString m_sCDBAL00

C++

private:
SqlString m_sCDBAL00;

JScript

private m_sCDBAL00 : SqlString

Source code

Visual Basic

Copy Code Copy Code

Private m_sTXADZ021, m_sTXADZ031, m_sTXADZ051, m_sTXADZ041, m_sNRFOG21, m_sBEBAN011, m_sTXADZ011, m_sBEBAN21, m_sTSMUT00, m_sSAVRS00, m_sTXRes00, m_sVDMUTER, m_sTXADZ071, m_sTXADZ061, m_sCDVIG00, m_sCDBAL00, m_sBEBAN012, m_sBKPAR00, m_sBEBAN022, m_sNRFOG022, m_sCDBNK00, m_sDMMSG00, m_sIDMSG00, m_sBEPGM00, m_sZTMSG00, m_sTXADZ012, m_sNRPARAD, m_sTXADZ072, m_sNRFOG011, m_sNRADR00, m_sTXADZ062, m_sTXADZ032, m_sTXADZ022, m_sTXADZ052, m_sTXADZ042 As SqlString

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsPartner Class
clsPartner clsPartner Members


m_sCDBNK00 Field

m_sCDBNK00 Field

m_sCDBNK00 Field | Previous topic | Next topic
m_sCDBNK00 Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_sCDBNK00 As SqlString

C#

private SqlString m_sCDBNK00

C++

private:
SqlString m_sCDBNK00;

JScript

private m_sCDBNK00 : SqlString

Source code

Visual Basic

Copy Code Copy Code

Private m_sTXADZ021, m_sTXADZ031, m_sTXADZ051, m_sTXADZ041, m_sNRFOG21, m_sBEBAN011, m_sTXADZ011, m_sBEBAN21, m_sTSMUT00, m_sSAVRS00, m_sTXRes00, m_sVDMUTER, m_sTXADZ071, m_sTXADZ061, m_sCDVIG00, m_sCDBAL00, m_sBEBAN012, m_sBKPAR00, m_sBEBAN022, m_sNRFOG022, m_sCDBNK00, m_sDMMSG00, m_sIDMSG00, m_sBEPGM00, m_sZTMSG00, m_sTXADZ012, m_sNRPARAD, m_sTXADZ072, m_sNRFOG011, m_sNRADR00, m_sTXADZ062, m_sTXADZ032, m_sTXADZ022, m_sTXADZ052, m_sTXADZ042 As SqlString

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsPartner Class
clsPartner clsPartner Members


m_sCDVIG00 Field

m_sCDVIG00 Field

m_sCDVIG00 Field | Previous topic | Next topic
m_sCDVIG00 Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_sCDVIG00 As SqlString

C#

private SqlString m_sCDVIG00

C++

private:
SqlString m_sCDVIG00;

JScript

private m_sCDVIG00 : SqlString

Source code

Visual Basic

Copy Code Copy Code

Private m_sTXADZ021, m_sTXADZ031, m_sTXADZ051, m_sTXADZ041, m_sNRFOG21, m_sBEBAN011, m_sTXADZ011, m_sBEBAN21, m_sTSMUT00, m_sSAVRS00, m_sTXRes00, m_sVDMUTER, m_sTXADZ071, m_sTXADZ061, m_sCDVIG00, m_sCDBAL00, m_sBEBAN012, m_sBKPAR00, m_sBEBAN022, m_sNRFOG022, m_sCDBNK00, m_sDMMSG00, m_sIDMSG00, m_sBEPGM00, m_sZTMSG00, m_sTXADZ012, m_sNRPARAD, m_sTXADZ072, m_sNRFOG011, m_sNRADR00, m_sTXADZ062, m_sTXADZ032, m_sTXADZ022, m_sTXADZ052, m_sTXADZ042 As SqlString

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsPartner Class
clsPartner clsPartner Members


m_sDMMSG00 Field

m_sDMMSG00 Field

m_sDMMSG00 Field | Previous topic | Next topic
m_sDMMSG00 Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_sDMMSG00 As SqlString

C#

private SqlString m_sDMMSG00

C++

private:
SqlString m_sDMMSG00;

JScript

private m_sDMMSG00 : SqlString

Source code

Visual Basic

Copy Code Copy Code

Private m_sTXADZ021, m_sTXADZ031, m_sTXADZ051, m_sTXADZ041, m_sNRFOG21, m_sBEBAN011, m_sTXADZ011, m_sBEBAN21, m_sTSMUT00, m_sSAVRS00, m_sTXRes00, m_sVDMUTER, m_sTXADZ071, m_sTXADZ061, m_sCDVIG00, m_sCDBAL00, m_sBEBAN012, m_sBKPAR00, m_sBEBAN022, m_sNRFOG022, m_sCDBNK00, m_sDMMSG00, m_sIDMSG00, m_sBEPGM00, m_sZTMSG00, m_sTXADZ012, m_sNRPARAD, m_sTXADZ072, m_sNRFOG011, m_sNRADR00, m_sTXADZ062, m_sTXADZ032, m_sTXADZ022, m_sTXADZ052, m_sTXADZ042 As SqlString

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsPartner Class
clsPartner clsPartner Members


m_sIDMSG00 Field

m_sIDMSG00 Field

m_sIDMSG00 Field | Previous topic | Next topic
m_sIDMSG00 Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_sIDMSG00 As SqlString

C#

private SqlString m_sIDMSG00

C++

private:
SqlString m_sIDMSG00;

JScript

private m_sIDMSG00 : SqlString

Source code

Visual Basic

Copy Code Copy Code

Private m_sTXADZ021, m_sTXADZ031, m_sTXADZ051, m_sTXADZ041, m_sNRFOG21, m_sBEBAN011, m_sTXADZ011, m_sBEBAN21, m_sTSMUT00, m_sSAVRS00, m_sTXRes00, m_sVDMUTER, m_sTXADZ071, m_sTXADZ061, m_sCDVIG00, m_sCDBAL00, m_sBEBAN012, m_sBKPAR00, m_sBEBAN022, m_sNRFOG022, m_sCDBNK00, m_sDMMSG00, m_sIDMSG00, m_sBEPGM00, m_sZTMSG00, m_sTXADZ012, m_sNRPARAD, m_sTXADZ072, m_sNRFOG011, m_sNRADR00, m_sTXADZ062, m_sTXADZ032, m_sTXADZ022, m_sTXADZ052, m_sTXADZ042 As SqlString

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsPartner Class
clsPartner clsPartner Members


m_sNRADR00 Field

m_sNRADR00 Field

m_sNRADR00 Field | Previous topic | Next topic
m_sNRADR00 Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_sNRADR00 As SqlString

C#

private SqlString m_sNRADR00

C++

private:
SqlString m_sNRADR00;

JScript

private m_sNRADR00 : SqlString

Source code

Visual Basic

Copy Code Copy Code

Private m_sTXADZ021, m_sTXADZ031, m_sTXADZ051, m_sTXADZ041, m_sNRFOG21, m_sBEBAN011, m_sTXADZ011, m_sBEBAN21, m_sTSMUT00, m_sSAVRS00, m_sTXRes00, m_sVDMUTER, m_sTXADZ071, m_sTXADZ061, m_sCDVIG00, m_sCDBAL00, m_sBEBAN012, m_sBKPAR00, m_sBEBAN022, m_sNRFOG022, m_sCDBNK00, m_sDMMSG00, m_sIDMSG00, m_sBEPGM00, m_sZTMSG00, m_sTXADZ012, m_sNRPARAD, m_sTXADZ072, m_sNRFOG011, m_sNRADR00, m_sTXADZ062, m_sTXADZ032, m_sTXADZ022, m_sTXADZ052, m_sTXADZ042 As SqlString

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsPartner Class
clsPartner clsPartner Members


m_sNRFOG011 Field

m_sNRFOG011 Field

m_sNRFOG011 Field | Previous topic | Next topic
m_sNRFOG011 Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_sNRFOG011 As SqlString

C#

private SqlString m_sNRFOG011

C++

private:
SqlString m_sNRFOG011;

JScript

private m_sNRFOG011 : SqlString

Source code

Visual Basic

Copy Code Copy Code

Private m_sTXADZ021, m_sTXADZ031, m_sTXADZ051, m_sTXADZ041, m_sNRFOG21, m_sBEBAN011, m_sTXADZ011, m_sBEBAN21, m_sTSMUT00, m_sSAVRS00, m_sTXRes00, m_sVDMUTER, m_sTXADZ071, m_sTXADZ061, m_sCDVIG00, m_sCDBAL00, m_sBEBAN012, m_sBKPAR00, m_sBEBAN022, m_sNRFOG022, m_sCDBNK00, m_sDMMSG00, m_sIDMSG00, m_sBEPGM00, m_sZTMSG00, m_sTXADZ012, m_sNRPARAD, m_sTXADZ072, m_sNRFOG011, m_sNRADR00, m_sTXADZ062, m_sTXADZ032, m_sTXADZ022, m_sTXADZ052, m_sTXADZ042 As SqlString

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsPartner Class
clsPartner clsPartner Members


m_sNRFOG022 Field

m_sNRFOG022 Field

m_sNRFOG022 Field | Previous topic | Next topic
m_sNRFOG022 Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_sNRFOG022 As SqlString

C#

private SqlString m_sNRFOG022

C++

private:
SqlString m_sNRFOG022;

JScript

private m_sNRFOG022 : SqlString

Source code

Visual Basic

Copy Code Copy Code

Private m_sTXADZ021, m_sTXADZ031, m_sTXADZ051, m_sTXADZ041, m_sNRFOG21, m_sBEBAN011, m_sTXADZ011, m_sBEBAN21, m_sTSMUT00, m_sSAVRS00, m_sTXRes00, m_sVDMUTER, m_sTXADZ071, m_sTXADZ061, m_sCDVIG00, m_sCDBAL00, m_sBEBAN012, m_sBKPAR00, m_sBEBAN022, m_sNRFOG022, m_sCDBNK00, m_sDMMSG00, m_sIDMSG00, m_sBEPGM00, m_sZTMSG00, m_sTXADZ012, m_sNRPARAD, m_sTXADZ072, m_sNRFOG011, m_sNRADR00, m_sTXADZ062, m_sTXADZ032, m_sTXADZ022, m_sTXADZ052, m_sTXADZ042 As SqlString

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsPartner Class
clsPartner clsPartner Members


m_sNRFOG21 Field

m_sNRFOG21 Field

m_sNRFOG21 Field | Previous topic | Next topic
m_sNRFOG21 Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_sNRFOG21 As SqlString

C#

private SqlString m_sNRFOG21

C++

private:
SqlString m_sNRFOG21;

JScript

private m_sNRFOG21 : SqlString

Source code

Visual Basic

Copy Code Copy Code

Private m_sTXADZ021, m_sTXADZ031, m_sTXADZ051, m_sTXADZ041, m_sNRFOG21, m_sBEBAN011, m_sTXADZ011, m_sBEBAN21, m_sTSMUT00, m_sSAVRS00, m_sTXRes00, m_sVDMUTER, m_sTXADZ071, m_sTXADZ061, m_sCDVIG00, m_sCDBAL00, m_sBEBAN012, m_sBKPAR00, m_sBEBAN022, m_sNRFOG022, m_sCDBNK00, m_sDMMSG00, m_sIDMSG00, m_sBEPGM00, m_sZTMSG00, m_sTXADZ012, m_sNRPARAD, m_sTXADZ072, m_sNRFOG011, m_sNRADR00, m_sTXADZ062, m_sTXADZ032, m_sTXADZ022, m_sTXADZ052, m_sTXADZ042 As SqlString

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsPartner Class
clsPartner clsPartner Members


m_sNRPARAD Field

m_sNRPARAD Field

m_sNRPARAD Field | Previous topic | Next topic
m_sNRPARAD Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_sNRPARAD As SqlString

C#

private SqlString m_sNRPARAD

C++

private:
SqlString m_sNRPARAD;

JScript

private m_sNRPARAD : SqlString

Source code

Visual Basic

Copy Code Copy Code

Private m_sTXADZ021, m_sTXADZ031, m_sTXADZ051, m_sTXADZ041, m_sNRFOG21, m_sBEBAN011, m_sTXADZ011, m_sBEBAN21, m_sTSMUT00, m_sSAVRS00, m_sTXRes00, m_sVDMUTER, m_sTXADZ071, m_sTXADZ061, m_sCDVIG00, m_sCDBAL00, m_sBEBAN012, m_sBKPAR00, m_sBEBAN022, m_sNRFOG022, m_sCDBNK00, m_sDMMSG00, m_sIDMSG00, m_sBEPGM00, m_sZTMSG00, m_sTXADZ012, m_sNRPARAD, m_sTXADZ072, m_sNRFOG011, m_sNRADR00, m_sTXADZ062, m_sTXADZ032, m_sTXADZ022, m_sTXADZ052, m_sTXADZ042 As SqlString

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsPartner Class
clsPartner clsPartner Members


m_sSAVRS00 Field

m_sSAVRS00 Field

m_sSAVRS00 Field | Previous topic | Next topic
m_sSAVRS00 Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_sSAVRS00 As SqlString

C#

private SqlString m_sSAVRS00

C++

private:
SqlString m_sSAVRS00;

JScript

private m_sSAVRS00 : SqlString

Source code

Visual Basic

Copy Code Copy Code

Private m_sTXADZ021, m_sTXADZ031, m_sTXADZ051, m_sTXADZ041, m_sNRFOG21, m_sBEBAN011, m_sTXADZ011, m_sBEBAN21, m_sTSMUT00, m_sSAVRS00, m_sTXRes00, m_sVDMUTER, m_sTXADZ071, m_sTXADZ061, m_sCDVIG00, m_sCDBAL00, m_sBEBAN012, m_sBKPAR00, m_sBEBAN022, m_sNRFOG022, m_sCDBNK00, m_sDMMSG00, m_sIDMSG00, m_sBEPGM00, m_sZTMSG00, m_sTXADZ012, m_sNRPARAD, m_sTXADZ072, m_sNRFOG011, m_sNRADR00, m_sTXADZ062, m_sTXADZ032, m_sTXADZ022, m_sTXADZ052, m_sTXADZ042 As SqlString

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsPartner Class
clsPartner clsPartner Members


m_sTSMUT00 Field

m_sTSMUT00 Field

m_sTSMUT00 Field | Previous topic | Next topic
m_sTSMUT00 Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_sTSMUT00 As SqlString

C#

private SqlString m_sTSMUT00

C++

private:
SqlString m_sTSMUT00;

JScript

private m_sTSMUT00 : SqlString

Source code

Visual Basic

Copy Code Copy Code

Private m_sTXADZ021, m_sTXADZ031, m_sTXADZ051, m_sTXADZ041, m_sNRFOG21, m_sBEBAN011, m_sTXADZ011, m_sBEBAN21, m_sTSMUT00, m_sSAVRS00, m_sTXRes00, m_sVDMUTER, m_sTXADZ071, m_sTXADZ061, m_sCDVIG00, m_sCDBAL00, m_sBEBAN012, m_sBKPAR00, m_sBEBAN022, m_sNRFOG022, m_sCDBNK00, m_sDMMSG00, m_sIDMSG00, m_sBEPGM00, m_sZTMSG00, m_sTXADZ012, m_sNRPARAD, m_sTXADZ072, m_sNRFOG011, m_sNRADR00, m_sTXADZ062, m_sTXADZ032, m_sTXADZ022, m_sTXADZ052, m_sTXADZ042 As SqlString

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsPartner Class
clsPartner clsPartner Members


m_sTXADZ011 Field

m_sTXADZ011 Field

m_sTXADZ011 Field | Previous topic | Next topic
m_sTXADZ011 Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_sTXADZ011 As SqlString

C#

private SqlString m_sTXADZ011

C++

private:
SqlString m_sTXADZ011;

JScript

private m_sTXADZ011 : SqlString

Source code

Visual Basic

Copy Code Copy Code

Private m_sTXADZ021, m_sTXADZ031, m_sTXADZ051, m_sTXADZ041, m_sNRFOG21, m_sBEBAN011, m_sTXADZ011, m_sBEBAN21, m_sTSMUT00, m_sSAVRS00, m_sTXRes00, m_sVDMUTER, m_sTXADZ071, m_sTXADZ061, m_sCDVIG00, m_sCDBAL00, m_sBEBAN012, m_sBKPAR00, m_sBEBAN022, m_sNRFOG022, m_sCDBNK00, m_sDMMSG00, m_sIDMSG00, m_sBEPGM00, m_sZTMSG00, m_sTXADZ012, m_sNRPARAD, m_sTXADZ072, m_sNRFOG011, m_sNRADR00, m_sTXADZ062, m_sTXADZ032, m_sTXADZ022, m_sTXADZ052, m_sTXADZ042 As SqlString

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsPartner Class
clsPartner clsPartner Members


m_sTXADZ012 Field

m_sTXADZ012 Field

m_sTXADZ012 Field | Previous topic | Next topic
m_sTXADZ012 Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_sTXADZ012 As SqlString

C#

private SqlString m_sTXADZ012

C++

private:
SqlString m_sTXADZ012;

JScript

private m_sTXADZ012 : SqlString

Source code

Visual Basic

Copy Code Copy Code

Private m_sTXADZ021, m_sTXADZ031, m_sTXADZ051, m_sTXADZ041, m_sNRFOG21, m_sBEBAN011, m_sTXADZ011, m_sBEBAN21, m_sTSMUT00, m_sSAVRS00, m_sTXRes00, m_sVDMUTER, m_sTXADZ071, m_sTXADZ061, m_sCDVIG00, m_sCDBAL00, m_sBEBAN012, m_sBKPAR00, m_sBEBAN022, m_sNRFOG022, m_sCDBNK00, m_sDMMSG00, m_sIDMSG00, m_sBEPGM00, m_sZTMSG00, m_sTXADZ012, m_sNRPARAD, m_sTXADZ072, m_sNRFOG011, m_sNRADR00, m_sTXADZ062, m_sTXADZ032, m_sTXADZ022, m_sTXADZ052, m_sTXADZ042 As SqlString

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsPartner Class
clsPartner clsPartner Members


m_sTXADZ021 Field

m_sTXADZ021 Field

m_sTXADZ021 Field | Previous topic | Next topic
m_sTXADZ021 Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_sTXADZ021 As SqlString

C#

private SqlString m_sTXADZ021

C++

private:
SqlString m_sTXADZ021;

JScript

private m_sTXADZ021 : SqlString

Source code

Visual Basic

Copy Code Copy Code

Private m_sTXADZ021, m_sTXADZ031, m_sTXADZ051, m_sTXADZ041, m_sNRFOG21, m_sBEBAN011, m_sTXADZ011, m_sBEBAN21, m_sTSMUT00, m_sSAVRS00, m_sTXRes00, m_sVDMUTER, m_sTXADZ071, m_sTXADZ061, m_sCDVIG00, m_sCDBAL00, m_sBEBAN012, m_sBKPAR00, m_sBEBAN022, m_sNRFOG022, m_sCDBNK00, m_sDMMSG00, m_sIDMSG00, m_sBEPGM00, m_sZTMSG00, m_sTXADZ012, m_sNRPARAD, m_sTXADZ072, m_sNRFOG011, m_sNRADR00, m_sTXADZ062, m_sTXADZ032, m_sTXADZ022, m_sTXADZ052, m_sTXADZ042 As SqlString

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsPartner Class
clsPartner clsPartner Members


m_sTXADZ022 Field

m_sTXADZ022 Field

m_sTXADZ022 Field | Previous topic | Next topic
m_sTXADZ022 Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_sTXADZ022 As SqlString

C#

private SqlString m_sTXADZ022

C++

private:
SqlString m_sTXADZ022;

JScript

private m_sTXADZ022 : SqlString

Source code

Visual Basic

Copy Code Copy Code

Private m_sTXADZ021, m_sTXADZ031, m_sTXADZ051, m_sTXADZ041, m_sNRFOG21, m_sBEBAN011, m_sTXADZ011, m_sBEBAN21, m_sTSMUT00, m_sSAVRS00, m_sTXRes00, m_sVDMUTER, m_sTXADZ071, m_sTXADZ061, m_sCDVIG00, m_sCDBAL00, m_sBEBAN012, m_sBKPAR00, m_sBEBAN022, m_sNRFOG022, m_sCDBNK00, m_sDMMSG00, m_sIDMSG00, m_sBEPGM00, m_sZTMSG00, m_sTXADZ012, m_sNRPARAD, m_sTXADZ072, m_sNRFOG011, m_sNRADR00, m_sTXADZ062, m_sTXADZ032, m_sTXADZ022, m_sTXADZ052, m_sTXADZ042 As SqlString

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsPartner Class
clsPartner clsPartner Members


m_sTXADZ031 Field

m_sTXADZ031 Field

m_sTXADZ031 Field | Previous topic | Next topic
m_sTXADZ031 Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_sTXADZ031 As SqlString

C#

private SqlString m_sTXADZ031

C++

private:
SqlString m_sTXADZ031;

JScript

private m_sTXADZ031 : SqlString

Source code

Visual Basic

Copy Code Copy Code

Private m_sTXADZ021, m_sTXADZ031, m_sTXADZ051, m_sTXADZ041, m_sNRFOG21, m_sBEBAN011, m_sTXADZ011, m_sBEBAN21, m_sTSMUT00, m_sSAVRS00, m_sTXRes00, m_sVDMUTER, m_sTXADZ071, m_sTXADZ061, m_sCDVIG00, m_sCDBAL00, m_sBEBAN012, m_sBKPAR00, m_sBEBAN022, m_sNRFOG022, m_sCDBNK00, m_sDMMSG00, m_sIDMSG00, m_sBEPGM00, m_sZTMSG00, m_sTXADZ012, m_sNRPARAD, m_sTXADZ072, m_sNRFOG011, m_sNRADR00, m_sTXADZ062, m_sTXADZ032, m_sTXADZ022, m_sTXADZ052, m_sTXADZ042 As SqlString

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsPartner Class
clsPartner clsPartner Members


m_sTXADZ032 Field

m_sTXADZ032 Field

m_sTXADZ032 Field | Previous topic | Next topic
m_sTXADZ032 Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_sTXADZ032 As SqlString

C#

private SqlString m_sTXADZ032

C++

private:
SqlString m_sTXADZ032;

JScript

private m_sTXADZ032 : SqlString

Source code

Visual Basic

Copy Code Copy Code

Private m_sTXADZ021, m_sTXADZ031, m_sTXADZ051, m_sTXADZ041, m_sNRFOG21, m_sBEBAN011, m_sTXADZ011, m_sBEBAN21, m_sTSMUT00, m_sSAVRS00, m_sTXRes00, m_sVDMUTER, m_sTXADZ071, m_sTXADZ061, m_sCDVIG00, m_sCDBAL00, m_sBEBAN012, m_sBKPAR00, m_sBEBAN022, m_sNRFOG022, m_sCDBNK00, m_sDMMSG00, m_sIDMSG00, m_sBEPGM00, m_sZTMSG00, m_sTXADZ012, m_sNRPARAD, m_sTXADZ072, m_sNRFOG011, m_sNRADR00, m_sTXADZ062, m_sTXADZ032, m_sTXADZ022, m_sTXADZ052, m_sTXADZ042 As SqlString

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsPartner Class
clsPartner clsPartner Members


m_sTXADZ041 Field

m_sTXADZ041 Field

m_sTXADZ041 Field | Previous topic | Next topic
m_sTXADZ041 Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_sTXADZ041 As SqlString

C#

private SqlString m_sTXADZ041

C++

private:
SqlString m_sTXADZ041;

JScript

private m_sTXADZ041 : SqlString

Source code

Visual Basic

Copy Code Copy Code

Private m_sTXADZ021, m_sTXADZ031, m_sTXADZ051, m_sTXADZ041, m_sNRFOG21, m_sBEBAN011, m_sTXADZ011, m_sBEBAN21, m_sTSMUT00, m_sSAVRS00, m_sTXRes00, m_sVDMUTER, m_sTXADZ071, m_sTXADZ061, m_sCDVIG00, m_sCDBAL00, m_sBEBAN012, m_sBKPAR00, m_sBEBAN022, m_sNRFOG022, m_sCDBNK00, m_sDMMSG00, m_sIDMSG00, m_sBEPGM00, m_sZTMSG00, m_sTXADZ012, m_sNRPARAD, m_sTXADZ072, m_sNRFOG011, m_sNRADR00, m_sTXADZ062, m_sTXADZ032, m_sTXADZ022, m_sTXADZ052, m_sTXADZ042 As SqlString

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsPartner Class
clsPartner clsPartner Members


m_sTXADZ042 Field

m_sTXADZ042 Field

m_sTXADZ042 Field | Previous topic | Next topic
m_sTXADZ042 Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_sTXADZ042 As SqlString

C#

private SqlString m_sTXADZ042

C++

private:
SqlString m_sTXADZ042;

JScript

private m_sTXADZ042 : SqlString

Source code

Visual Basic

Copy Code Copy Code

Private m_sTXADZ021, m_sTXADZ031, m_sTXADZ051, m_sTXADZ041, m_sNRFOG21, m_sBEBAN011, m_sTXADZ011, m_sBEBAN21, m_sTSMUT00, m_sSAVRS00, m_sTXRes00, m_sVDMUTER, m_sTXADZ071, m_sTXADZ061, m_sCDVIG00, m_sCDBAL00, m_sBEBAN012, m_sBKPAR00, m_sBEBAN022, m_sNRFOG022, m_sCDBNK00, m_sDMMSG00, m_sIDMSG00, m_sBEPGM00, m_sZTMSG00, m_sTXADZ012, m_sNRPARAD, m_sTXADZ072, m_sNRFOG011, m_sNRADR00, m_sTXADZ062, m_sTXADZ032, m_sTXADZ022, m_sTXADZ052, m_sTXADZ042 As SqlString

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsPartner Class
clsPartner clsPartner Members


m_sTXADZ051 Field

m_sTXADZ051 Field

m_sTXADZ051 Field | Previous topic | Next topic
m_sTXADZ051 Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_sTXADZ051 As SqlString

C#

private SqlString m_sTXADZ051

C++

private:
SqlString m_sTXADZ051;

JScript

private m_sTXADZ051 : SqlString

Source code

Visual Basic

Copy Code Copy Code

Private m_sTXADZ021, m_sTXADZ031, m_sTXADZ051, m_sTXADZ041, m_sNRFOG21, m_sBEBAN011, m_sTXADZ011, m_sBEBAN21, m_sTSMUT00, m_sSAVRS00, m_sTXRes00, m_sVDMUTER, m_sTXADZ071, m_sTXADZ061, m_sCDVIG00, m_sCDBAL00, m_sBEBAN012, m_sBKPAR00, m_sBEBAN022, m_sNRFOG022, m_sCDBNK00, m_sDMMSG00, m_sIDMSG00, m_sBEPGM00, m_sZTMSG00, m_sTXADZ012, m_sNRPARAD, m_sTXADZ072, m_sNRFOG011, m_sNRADR00, m_sTXADZ062, m_sTXADZ032, m_sTXADZ022, m_sTXADZ052, m_sTXADZ042 As SqlString

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsPartner Class
clsPartner clsPartner Members


m_sTXADZ052 Field

m_sTXADZ052 Field

m_sTXADZ052 Field | Previous topic | Next topic
m_sTXADZ052 Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_sTXADZ052 As SqlString

C#

private SqlString m_sTXADZ052

C++

private:
SqlString m_sTXADZ052;

JScript

private m_sTXADZ052 : SqlString

Source code

Visual Basic

Copy Code Copy Code

Private m_sTXADZ021, m_sTXADZ031, m_sTXADZ051, m_sTXADZ041, m_sNRFOG21, m_sBEBAN011, m_sTXADZ011, m_sBEBAN21, m_sTSMUT00, m_sSAVRS00, m_sTXRes00, m_sVDMUTER, m_sTXADZ071, m_sTXADZ061, m_sCDVIG00, m_sCDBAL00, m_sBEBAN012, m_sBKPAR00, m_sBEBAN022, m_sNRFOG022, m_sCDBNK00, m_sDMMSG00, m_sIDMSG00, m_sBEPGM00, m_sZTMSG00, m_sTXADZ012, m_sNRPARAD, m_sTXADZ072, m_sNRFOG011, m_sNRADR00, m_sTXADZ062, m_sTXADZ032, m_sTXADZ022, m_sTXADZ052, m_sTXADZ042 As SqlString

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsPartner Class
clsPartner clsPartner Members


m_sTXADZ061 Field

m_sTXADZ061 Field

m_sTXADZ061 Field | Previous topic | Next topic
m_sTXADZ061 Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_sTXADZ061 As SqlString

C#

private SqlString m_sTXADZ061

C++

private:
SqlString m_sTXADZ061;

JScript

private m_sTXADZ061 : SqlString

Source code

Visual Basic

Copy Code Copy Code

Private m_sTXADZ021, m_sTXADZ031, m_sTXADZ051, m_sTXADZ041, m_sNRFOG21, m_sBEBAN011, m_sTXADZ011, m_sBEBAN21, m_sTSMUT00, m_sSAVRS00, m_sTXRes00, m_sVDMUTER, m_sTXADZ071, m_sTXADZ061, m_sCDVIG00, m_sCDBAL00, m_sBEBAN012, m_sBKPAR00, m_sBEBAN022, m_sNRFOG022, m_sCDBNK00, m_sDMMSG00, m_sIDMSG00, m_sBEPGM00, m_sZTMSG00, m_sTXADZ012, m_sNRPARAD, m_sTXADZ072, m_sNRFOG011, m_sNRADR00, m_sTXADZ062, m_sTXADZ032, m_sTXADZ022, m_sTXADZ052, m_sTXADZ042 As SqlString

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsPartner Class
clsPartner clsPartner Members


m_sTXADZ062 Field

m_sTXADZ062 Field

m_sTXADZ062 Field | Previous topic | Next topic
m_sTXADZ062 Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_sTXADZ062 As SqlString

C#

private SqlString m_sTXADZ062

C++

private:
SqlString m_sTXADZ062;

JScript

private m_sTXADZ062 : SqlString

Source code

Visual Basic

Copy Code Copy Code

Private m_sTXADZ021, m_sTXADZ031, m_sTXADZ051, m_sTXADZ041, m_sNRFOG21, m_sBEBAN011, m_sTXADZ011, m_sBEBAN21, m_sTSMUT00, m_sSAVRS00, m_sTXRes00, m_sVDMUTER, m_sTXADZ071, m_sTXADZ061, m_sCDVIG00, m_sCDBAL00, m_sBEBAN012, m_sBKPAR00, m_sBEBAN022, m_sNRFOG022, m_sCDBNK00, m_sDMMSG00, m_sIDMSG00, m_sBEPGM00, m_sZTMSG00, m_sTXADZ012, m_sNRPARAD, m_sTXADZ072, m_sNRFOG011, m_sNRADR00, m_sTXADZ062, m_sTXADZ032, m_sTXADZ022, m_sTXADZ052, m_sTXADZ042 As SqlString

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsPartner Class
clsPartner clsPartner Members


m_sTXADZ071 Field

m_sTXADZ071 Field

m_sTXADZ071 Field | Previous topic | Next topic
m_sTXADZ071 Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_sTXADZ071 As SqlString

C#

private SqlString m_sTXADZ071

C++

private:
SqlString m_sTXADZ071;

JScript

private m_sTXADZ071 : SqlString

Source code

Visual Basic

Copy Code Copy Code

Private m_sTXADZ021, m_sTXADZ031, m_sTXADZ051, m_sTXADZ041, m_sNRFOG21, m_sBEBAN011, m_sTXADZ011, m_sBEBAN21, m_sTSMUT00, m_sSAVRS00, m_sTXRes00, m_sVDMUTER, m_sTXADZ071, m_sTXADZ061, m_sCDVIG00, m_sCDBAL00, m_sBEBAN012, m_sBKPAR00, m_sBEBAN022, m_sNRFOG022, m_sCDBNK00, m_sDMMSG00, m_sIDMSG00, m_sBEPGM00, m_sZTMSG00, m_sTXADZ012, m_sNRPARAD, m_sTXADZ072, m_sNRFOG011, m_sNRADR00, m_sTXADZ062, m_sTXADZ032, m_sTXADZ022, m_sTXADZ052, m_sTXADZ042 As SqlString

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsPartner Class
clsPartner clsPartner Members


m_sTXADZ072 Field

m_sTXADZ072 Field

m_sTXADZ072 Field | Previous topic | Next topic
m_sTXADZ072 Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_sTXADZ072 As SqlString

C#

private SqlString m_sTXADZ072

C++

private:
SqlString m_sTXADZ072;

JScript

private m_sTXADZ072 : SqlString

Source code

Visual Basic

Copy Code Copy Code

Private m_sTXADZ021, m_sTXADZ031, m_sTXADZ051, m_sTXADZ041, m_sNRFOG21, m_sBEBAN011, m_sTXADZ011, m_sBEBAN21, m_sTSMUT00, m_sSAVRS00, m_sTXRes00, m_sVDMUTER, m_sTXADZ071, m_sTXADZ061, m_sCDVIG00, m_sCDBAL00, m_sBEBAN012, m_sBKPAR00, m_sBEBAN022, m_sNRFOG022, m_sCDBNK00, m_sDMMSG00, m_sIDMSG00, m_sBEPGM00, m_sZTMSG00, m_sTXADZ012, m_sNRPARAD, m_sTXADZ072, m_sNRFOG011, m_sNRADR00, m_sTXADZ062, m_sTXADZ032, m_sTXADZ022, m_sTXADZ052, m_sTXADZ042 As SqlString

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsPartner Class
clsPartner clsPartner Members


m_sTXRes00 Field

m_sTXRes00 Field

m_sTXRes00 Field | Previous topic | Next topic
m_sTXRes00 Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_sTXRes00 As SqlString

C#

private SqlString m_sTXRes00

C++

private:
SqlString m_sTXRes00;

JScript

private m_sTXRes00 : SqlString

Source code

Visual Basic

Copy Code Copy Code

Private m_sTXADZ021, m_sTXADZ031, m_sTXADZ051, m_sTXADZ041, m_sNRFOG21, m_sBEBAN011, m_sTXADZ011, m_sBEBAN21, m_sTSMUT00, m_sSAVRS00, m_sTXRes00, m_sVDMUTER, m_sTXADZ071, m_sTXADZ061, m_sCDVIG00, m_sCDBAL00, m_sBEBAN012, m_sBKPAR00, m_sBEBAN022, m_sNRFOG022, m_sCDBNK00, m_sDMMSG00, m_sIDMSG00, m_sBEPGM00, m_sZTMSG00, m_sTXADZ012, m_sNRPARAD, m_sTXADZ072, m_sNRFOG011, m_sNRADR00, m_sTXADZ062, m_sTXADZ032, m_sTXADZ022, m_sTXADZ052, m_sTXADZ042 As SqlString

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsPartner Class
clsPartner clsPartner Members


m_sVDMUTER Field

m_sVDMUTER Field

m_sVDMUTER Field | Previous topic | Next topic
m_sVDMUTER Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_sVDMUTER As SqlString

C#

private SqlString m_sVDMUTER

C++

private:
SqlString m_sVDMUTER;

JScript

private m_sVDMUTER : SqlString

Source code

Visual Basic

Copy Code Copy Code

Private m_sTXADZ021, m_sTXADZ031, m_sTXADZ051, m_sTXADZ041, m_sNRFOG21, m_sBEBAN011, m_sTXADZ011, m_sBEBAN21, m_sTSMUT00, m_sSAVRS00, m_sTXRes00, m_sVDMUTER, m_sTXADZ071, m_sTXADZ061, m_sCDVIG00, m_sCDBAL00, m_sBEBAN012, m_sBKPAR00, m_sBEBAN022, m_sNRFOG022, m_sCDBNK00, m_sDMMSG00, m_sIDMSG00, m_sBEPGM00, m_sZTMSG00, m_sTXADZ012, m_sNRPARAD, m_sTXADZ072, m_sNRFOG011, m_sNRADR00, m_sTXADZ062, m_sTXADZ032, m_sTXADZ022, m_sTXADZ052, m_sTXADZ042 As SqlString

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsPartner Class
clsPartner clsPartner Members


m_sZTMSG00 Field

m_sZTMSG00 Field

m_sZTMSG00 Field | Previous topic | Next topic
m_sZTMSG00 Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_sZTMSG00 As SqlString

C#

private SqlString m_sZTMSG00

C++

private:
SqlString m_sZTMSG00;

JScript

private m_sZTMSG00 : SqlString

Source code

Visual Basic

Copy Code Copy Code

Private m_sTXADZ021, m_sTXADZ031, m_sTXADZ051, m_sTXADZ041, m_sNRFOG21, m_sBEBAN011, m_sTXADZ011, m_sBEBAN21, m_sTSMUT00, m_sSAVRS00, m_sTXRes00, m_sVDMUTER, m_sTXADZ071, m_sTXADZ061, m_sCDVIG00, m_sCDBAL00, m_sBEBAN012, m_sBKPAR00, m_sBEBAN022, m_sNRFOG022, m_sCDBNK00, m_sDMMSG00, m_sIDMSG00, m_sBEPGM00, m_sZTMSG00, m_sTXADZ012, m_sNRPARAD, m_sTXADZ072, m_sNRFOG011, m_sNRADR00, m_sTXADZ062, m_sTXADZ032, m_sTXADZ022, m_sTXADZ052, m_sTXADZ042 As SqlString

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsPartner Class
clsPartner clsPartner Members


clsStatushistory Class

clsStatushistory Class

clsStatushistory Class | Previous topic | Next topic
clsStatushistory Class | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Class clsStatushistory
Inherits clsDBInteractionBase

C#

public class clsStatushistory : clsDBInteractionBase

C++

public ref class clsStatushistory : public clsDBInteractionBase^

JScript

public class clsStatushistory
extends clsDBInteractionBase

Inheritance Hierarchy

System.Object

EDKB12WS.edokadb.clsDBInteractionBase

EDKB12WS.edokadb.clsStatushistory

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsStatushistory Members


clsStatushistory Members

clsStatushistory Members

clsStatushistory Members | Previous topic | Next topic
clsStatushistory Members | Previous topic | Next topic

The following tables list the members exposed by the clsStatushistory type.

Public Constructors

 | Name | Description
Supported by the .NET Compact Framework. | clsStatushistory Constructor |

Top

Public Properties

 | Name | Description
Supported by the .NET Compact Framework. | bAktiv |
Supported by the .NET Compact Framework. | cpMainConnectionProvider | (inherited from clsDBInteractionBase ).
Supported by the .NET Compact Framework. | daErstellt_am |
Supported by the .NET Compact Framework. | daMutiert_am |
Supported by the .NET Compact Framework. | iErrorCode | (inherited from clsDBInteractionBase ).
Supported by the .NET Compact Framework. | iMandantnr |
Supported by the .NET Compact Framework. | iMutierer |
Supported by the .NET Compact Framework. | iStatus |
Supported by the .NET Compact Framework. | iStatushistorynr |
Supported by the .NET Compact Framework. | iVerantwortlich |
Supported by the .NET Compact Framework. | sConnectionString | (inherited from clsDBInteractionBase ).
Supported by the .NET Compact Framework. | sDokumentid |

Top

Public Methods

 | Name | Description
Supported by the .NET Compact Framework. | Delete |
Supported by the .NET Compact Framework. | Dispose | (Overloaded) (inherited from clsDBInteractionBase ).
Public method | Equals | (Overloaded) (inherited from Object).
Public method | GetHashCode | (inherited from Object).
Public method | GetType | (Overloaded) (inherited from Object).
Supported by the .NET Compact Framework. | Insert |
 | ReferenceEquals | (inherited from Object).
Supported by the .NET Compact Framework. | SelectAll |
Supported by the .NET Compact Framework. | SelectOne |
Public method | ToString | (inherited from Object).
Supported by the .NET Compact Framework. | Update |

Top

Protected Methods

 | Name | Description
Protected method | Finalize | (inherited from Object).
Protected method | MemberwiseClone | (Overloaded) (inherited from Object).

Top

Fields

 | Name | Description
Supported by the .NET Compact Framework. | m_bAktiv |
Supported by the .NET Compact Framework. | m_bMainConnectionIsCreatedLocal | (inherited from clsDBInteractionBase ).
Supported by the .NET Compact Framework. | m_cpMainConnectionProvider | (inherited from clsDBInteractionBase ).
Supported by the .NET Compact Framework. | m_daErstellt_am |
Supported by the .NET Compact Framework. | m_daMutiert_am |
Supported by the .NET Compact Framework. | m_iErrorCode | (inherited from clsDBInteractionBase ).
Supported by the .NET Compact Framework. | m_iMandantnr |
Supported by the .NET Compact Framework. | m_iMutierer |
Supported by the .NET Compact Framework. | m_iStatus |
Supported by the .NET Compact Framework. | m_iStatushistorynr |
Supported by the .NET Compact Framework. | m_iVerantwortlich |
Supported by the .NET Compact Framework. | m_sDokumentid |
Supported by the .NET Compact Framework. | m_scoMainConnection | (inherited from clsDBInteractionBase ).

Top

See Also

Reference

clsStatushistory Class


clsStatushistory Constructor

clsStatushistory Constructor

clsStatushistory Constructor | Previous topic | Next topic
clsStatushistory Constructor | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Sub New()

C#

public clsStatushistory()

C++

public:
clsStatushistory()

JScript

public function clsStatushistory();

Source code

Visual Basic

Copy Code Copy Code

Public Sub New()
' // Nothing for now.
End Sub

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsStatushistory Class
clsStatushistory clsStatushistory Members


clsStatushistory Properties

clsStatushistory Properties

clsStatushistory Properties | Previous topic | Next topic
clsStatushistory Properties | Previous topic | Next topic

Public Properties

 | Name | Description
Supported by the .NET Compact Framework. | bAktiv |
Supported by the .NET Compact Framework. | cpMainConnectionProvider | (inherited from clsDBInteractionBase ).
Supported by the .NET Compact Framework. | daErstellt_am |
Supported by the .NET Compact Framework. | daMutiert_am |
Supported by the .NET Compact Framework. | iErrorCode | (inherited from clsDBInteractionBase ).
Supported by the .NET Compact Framework. | iMandantnr |
Supported by the .NET Compact Framework. | iMutierer |
Supported by the .NET Compact Framework. | iStatus |
Supported by the .NET Compact Framework. | iStatushistorynr |
Supported by the .NET Compact Framework. | iVerantwortlich |
Supported by the .NET Compact Framework. | sConnectionString | (inherited from clsDBInteractionBase ).
Supported by the .NET Compact Framework. | sDokumentid |

Top

See Also

Reference

clsStatushistory Class


clsStatushistory.bAktiv Property

clsStatushistory.bAktiv Property

clsStatushistory.bAktiv Property | Previous topic | Next topic
clsStatushistory.bAktiv Property | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property bAktiv() As SqlBoolean

C#

public SqlBoolean bAktiv {get; set;}

C++

public:
property SqlBoolean bAktiv {
SqlBoolean get( );
void set(
SqlBoolean value
);
}

JScript

public function get bAktiv() : SqlBoolean;
public function set bAktiv(value : SqlBoolean);

Source code

Visual Basic

Copy Code Copy Code

Public Property [bAktiv]() As SqlBoolean
Get
Return m_bAktiv
End Get
Set(ByVal Value As SqlBoolean)
m_bAktiv = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsStatushistory Class
clsStatushistory clsStatushistory Members


clsStatushistory.daErstellt_am Property

clsStatushistory.daErstellt_am Property

clsStatushistory.daErstellt_am Property | Previous topic | Next topic
clsStatushistory.daErstellt_am Property | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property daErstellt_am() As SqlDateTime

C#

public SqlDateTime daErstellt_am {get; set;}

C++

public:
property SqlDateTime daErstellt_am {
SqlDateTime get( );
void set(
SqlDateTime value
);
}

JScript

public function get daErstellt_am() : SqlDateTime;
public function set daErstellt_am(value : SqlDateTime);

Source code

Visual Basic

Copy Code Copy Code

Public Property [daErstellt_am]() As SqlDateTime
Get
Return m_daErstellt_am
End Get
Set(ByVal Value As SqlDateTime)
m_daErstellt_am = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsStatushistory Class
clsStatushistory clsStatushistory Members


clsStatushistory.daMutiert_am Property

clsStatushistory.daMutiert_am Property

clsStatushistory.daMutiert_am Property | Previous topic | Next topic
clsStatushistory.daMutiert_am Property | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property daMutiert_am() As SqlDateTime

C#

public SqlDateTime daMutiert_am {get; set;}

C++

public:
property SqlDateTime daMutiert_am {
SqlDateTime get( );
void set(
SqlDateTime value
);
}

JScript

public function get daMutiert_am() : SqlDateTime;
public function set daMutiert_am(value : SqlDateTime);

Source code

Visual Basic

Copy Code Copy Code

Public Property [daMutiert_am]() As SqlDateTime
Get
Return m_daMutiert_am
End Get
Set(ByVal Value As SqlDateTime)
m_daMutiert_am = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsStatushistory Class
clsStatushistory clsStatushistory Members


clsStatushistory.iMandantnr Property

clsStatushistory.iMandantnr Property

clsStatushistory.iMandantnr Property | Previous topic | Next topic
clsStatushistory.iMandantnr Property | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property iMandantnr() As SqlInt32

C#

public SqlInt32 iMandantnr {get; set;}

C++

public:
property SqlInt32 iMandantnr {
SqlInt32 get( );
void set(
SqlInt32 value
);
}

JScript

public function get iMandantnr() : SqlInt32;
public function set iMandantnr(value : SqlInt32);

Source code

Visual Basic

Copy Code Copy Code

Public Property [iMandantnr]() As SqlInt32
Get
Return m_iMandantnr
End Get
Set(ByVal Value As SqlInt32)
m_iMandantnr = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsStatushistory Class
clsStatushistory clsStatushistory Members


clsStatushistory.iMutierer Property

clsStatushistory.iMutierer Property

clsStatushistory.iMutierer Property | Previous topic | Next topic
clsStatushistory.iMutierer Property | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property iMutierer() As SqlInt32

C#

public SqlInt32 iMutierer {get; set;}

C++

public:
property SqlInt32 iMutierer {
SqlInt32 get( );
void set(
SqlInt32 value
);
}

JScript

public function get iMutierer() : SqlInt32;
public function set iMutierer(value : SqlInt32);

Source code

Visual Basic

Copy Code Copy Code

Public Property [iMutierer]() As SqlInt32
Get
Return m_iMutierer
End Get
Set(ByVal Value As SqlInt32)
m_iMutierer = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsStatushistory Class
clsStatushistory clsStatushistory Members


clsStatushistory.iStatus Property

clsStatushistory.iStatus Property

clsStatushistory.iStatus Property | Previous topic | Next topic
clsStatushistory.iStatus Property | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property iStatus() As SqlInt32

C#

public SqlInt32 iStatus {get; set;}

C++

public:
property SqlInt32 iStatus {
SqlInt32 get( );
void set(
SqlInt32 value
);
}

JScript

public function get iStatus() : SqlInt32;
public function set iStatus(value : SqlInt32);

Source code

Visual Basic

Copy Code Copy Code

Public Property [iStatus]() As SqlInt32
Get
Return m_iStatus
End Get
Set(ByVal Value As SqlInt32)
Dim iStatusTmp As SqlInt32 = Value
If iStatusTmp.IsNull Then
Throw New ArgumentOutOfRangeException("iStatus", "iStatus can't be NULL")
End If
m_iStatus = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsStatushistory Class
clsStatushistory clsStatushistory Members


clsStatushistory.iStatushistorynr Property

clsStatushistory.iStatushistorynr Property

clsStatushistory.iStatushistorynr Property | Previous topic | Next topic
clsStatushistory.iStatushistorynr Property | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property iStatushistorynr() As SqlInt32

C#

public SqlInt32 iStatushistorynr {get; set;}

C++

public:
property SqlInt32 iStatushistorynr {
SqlInt32 get( );
void set(
SqlInt32 value
);
}

JScript

public function get iStatushistorynr() : SqlInt32;
public function set iStatushistorynr(value : SqlInt32);

Source code

Visual Basic

Copy Code Copy Code

Public Property [iStatushistorynr]() As SqlInt32
Get
Return m_iStatushistorynr
End Get
Set(ByVal Value As SqlInt32)
Dim iStatushistorynrTmp As SqlInt32 = Value
If iStatushistorynrTmp.IsNull Then
Throw New ArgumentOutOfRangeException("iStatushistorynr", "iStatushistorynr can't be NULL")
End If
m_iStatushistorynr = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsStatushistory Class
clsStatushistory clsStatushistory Members


clsStatushistory.iVerantwortlich Property

clsStatushistory.iVerantwortlich Property

clsStatushistory.iVerantwortlich Property | Previous topic | Next topic
clsStatushistory.iVerantwortlich Property | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property iVerantwortlich() As SqlInt32

C#

public SqlInt32 iVerantwortlich {get; set;}

C++

public:
property SqlInt32 iVerantwortlich {
SqlInt32 get( );
void set(
SqlInt32 value
);
}

JScript

public function get iVerantwortlich() : SqlInt32;
public function set iVerantwortlich(value : SqlInt32);

Source code

Visual Basic

Copy Code Copy Code

Public Property [iVerantwortlich]() As SqlInt32
Get
Return m_iVerantwortlich
End Get
Set(ByVal Value As SqlInt32)
m_iVerantwortlich = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsStatushistory Class
clsStatushistory clsStatushistory Members


clsStatushistory.sDokumentid Property

clsStatushistory.sDokumentid Property

clsStatushistory.sDokumentid Property | Previous topic | Next topic
clsStatushistory.sDokumentid Property | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Property sDokumentid() As SqlString

C#

public SqlString sDokumentid {get; set;}

C++

public:
property SqlString sDokumentid {
SqlString get( );
void set(
SqlString value
);
}

JScript

public function get sDokumentid() : SqlString;
public function set sDokumentid(value : SqlString);

Source code

Visual Basic

Copy Code Copy Code

Public Property [sDokumentid]() As SqlString
Get
Return m_sDokumentid
End Get
Set(ByVal Value As SqlString)
m_sDokumentid = Value
End Set
End Property

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsStatushistory Class
clsStatushistory clsStatushistory Members


clsStatushistory Methods

clsStatushistory Methods

clsStatushistory Methods | Previous topic | Next topic
clsStatushistory Methods | Previous topic | Next topic

Public Methods

 | Name | Description
Supported by the .NET Compact Framework. | Delete |
Supported by the .NET Compact Framework. | Dispose | (Overloaded) (inherited from clsDBInteractionBase ).
Public method | Equals | (Overloaded) (inherited from Object).
Public method | GetHashCode | (inherited from Object).
Public method | GetType | (Overloaded) (inherited from Object).
Supported by the .NET Compact Framework. | Insert |
 | ReferenceEquals | (inherited from Object).
Supported by the .NET Compact Framework. | SelectAll |
Supported by the .NET Compact Framework. | SelectOne |
Public method | ToString | (inherited from Object).
Supported by the .NET Compact Framework. | Update |

Top

Protected Methods

 | Name | Description
Protected method | Finalize | (inherited from Object).
Protected method | MemberwiseClone | (Overloaded) (inherited from Object).

Top

See Also

Reference

clsStatushistory Class


clsStatushistory.Delete Method

clsStatushistory.Delete Method

clsStatushistory.Delete Method | Previous topic | Next topic
clsStatushistory.Delete Method | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Overrides Function Delete() As Boolean

C#

public override bool Delete()

C++

public:
bool Delete()

JScript

public function Delete() : boolean;

Source code

Visual Basic

Copy Code Copy Code

Public Overrides Function Delete() As Boolean
Dim scmCmdToExecute As SqlCommand = New SqlCommand()
scmCmdToExecute.CommandText = "dbo.[pr_statushistory_Delete]"
scmCmdToExecute.CommandType = CommandType.StoredProcedure

' // Use base class' connection object
scmCmdToExecute.Connection = m_scoMainConnection

Try
scmCmdToExecute.Parameters.Add(New SqlParameter("@istatushistorynr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iStatushistorynr))
scmCmdToExecute.Parameters.Add(New SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

If m_bMainConnectionIsCreatedLocal Then
' // Open connection.
m_scoMainConnection.Open()
Else
If m_cpMainConnectionProvider.bIsTransactionPending Then
scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
End If
End If

' // Execute query.
scmCmdToExecute.ExecuteNonQuery()
m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
' // Throw error.
Throw New Exception("Stored Procedure 'pr_statushistory_Delete' reported the ErrorCode: " & m_iErrorCode.ToString())
End If

Return True
Catch ex As Exception
' // some error occured. Bubble it to caller and encapsulate Exception object
Throw New Exception("clsStatushistory::Delete::Error occured.", ex)
Finally
If m_bMainConnectionIsCreatedLocal Then
' // Close connection.
m_scoMainConnection.Close()
End If
scmCmdToExecute.Dispose()
End Try
End Function

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsStatushistory Class
clsStatushistory clsStatushistory Members


clsStatushistory.Insert Method

clsStatushistory.Insert Method

clsStatushistory.Insert Method | Previous topic | Next topic
clsStatushistory.Insert Method | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Overrides Function Insert() As Boolean

C#

public override bool Insert()

C++

public:
bool Insert()

JScript

public function Insert() : boolean;

Source code

Visual Basic

Copy Code Copy Code

Overrides Public Function Insert() As Boolean
Dim scmCmdToExecute As SqlCommand = New SqlCommand()
scmCmdToExecute.CommandText = "dbo.[pr_statushistory_Insert]"
scmCmdToExecute.CommandType = CommandType.StoredProcedure

' // Use base class' connection object
scmCmdToExecute.Connection = m_scoMainConnection

Try
scmCmdToExecute.Parameters.Add(New SqlParameter("@istatushistorynr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iStatushistorynr))
scmCmdToExecute.Parameters.Add(New SqlParameter("@istatus", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iStatus))
scmCmdToExecute.Parameters.Add(New SqlParameter("@imandantnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMandantnr))
scmCmdToExecute.Parameters.Add(New SqlParameter("@baktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bAktiv))
scmCmdToExecute.Parameters.Add(New SqlParameter("@daerstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daErstellt_am))
scmCmdToExecute.Parameters.Add(New SqlParameter("@damutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daMutiert_am))
scmCmdToExecute.Parameters.Add(New SqlParameter("@imutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
scmCmdToExecute.Parameters.Add(New SqlParameter("@sdokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sDokumentid))
scmCmdToExecute.Parameters.Add(New SqlParameter("@iverantwortlich", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iVerantwortlich))
scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

If m_bMainConnectionIsCreatedLocal Then
' // Open connection.
m_scoMainConnection.Open()
Else
If m_cpMainConnectionProvider.bIsTransactionPending Then
scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
End If
End If

' // Execute query.
scmCmdToExecute.ExecuteNonQuery()
m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
' // Throw error.
Throw New Exception("Stored Procedure 'pr_statushistory_Insert' reported the ErrorCode: " & m_iErrorCode.ToString())
End If

Return True
Catch ex As Exception
' // some error occured. Bubble it to caller and encapsulate Exception object
Throw New Exception("clsStatushistory::Insert::Error occured.", ex)
Finally
If m_bMainConnectionIsCreatedLocal Then
' // Close connection.
m_scoMainConnection.Close()
End If
scmCmdToExecute.Dispose()
End Try
End Function

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsStatushistory Class
clsStatushistory clsStatushistory Members


clsStatushistory.SelectAll Method

clsStatushistory.SelectAll Method

clsStatushistory.SelectAll Method | Previous topic | Next topic
clsStatushistory.SelectAll Method | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Overrides Function SelectAll() As DataTable

C#

public override DataTable SelectAll()

C++

public:
DataTable^ SelectAll()

JScript

public function SelectAll() : DataTable;

Source code

Visual Basic

Copy Code Copy Code

Public Overrides Function SelectAll() As DataTable
Dim scmCmdToExecute As SqlCommand = New SqlCommand()
scmCmdToExecute.CommandText = "dbo.[pr_statushistory_SelectAll]"
scmCmdToExecute.CommandType = CommandType.StoredProcedure
Dim dtToReturn As DataTable = New DataTable("statushistory")
Dim sdaAdapter As SqlDataAdapter = New SqlDataAdapter(scmCmdToExecute)

' // Use base class' connection object
scmCmdToExecute.Connection = m_scoMainConnection

Try
scmCmdToExecute.Parameters.Add(New SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

If m_bMainConnectionIsCreatedLocal Then
' // Open connection.
m_scoMainConnection.Open()
Else
If m_cpMainConnectionProvider.bIsTransactionPending Then
scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
End If
End If

' // Execute query.
sdaAdapter.Fill(dtToReturn)
m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
' // Throw error.
Throw New Exception("Stored Procedure 'pr_statushistory_SelectAll' reported the ErrorCode: " & m_iErrorCode.ToString())
End If

Return dtToReturn
Catch ex As Exception
' // some error occured. Bubble it to caller and encapsulate Exception object
Throw New Exception("clsStatushistory::SelectAll::Error occured.", ex)
Finally
If m_bMainConnectionIsCreatedLocal Then
' // Close connection.
m_scoMainConnection.Close()
End If
scmCmdToExecute.Dispose()
sdaAdapter.Dispose()
End Try
End Function

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsStatushistory Class
clsStatushistory clsStatushistory Members


clsStatushistory.SelectOne Method

clsStatushistory.SelectOne Method

clsStatushistory.SelectOne Method | Previous topic | Next topic
clsStatushistory.SelectOne Method | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Overrides Function SelectOne() As DataTable

C#

public override DataTable SelectOne()

C++

public:
DataTable^ SelectOne()

JScript

public function SelectOne() : DataTable;

Source code

Visual Basic

Copy Code Copy Code

Overrides Public Function SelectOne() As DataTable
Dim scmCmdToExecute As SqlCommand = New SqlCommand()
scmCmdToExecute.CommandText = "dbo.[pr_statushistory_SelectOne]"
scmCmdToExecute.CommandType = CommandType.StoredProcedure
Dim dtToReturn As DataTable = new DataTable("statushistory")
Dim sdaAdapter As SqlDataAdapter = new SqlDataAdapter(scmCmdToExecute)

' // Use base class' connection object
scmCmdToExecute.Connection = m_scoMainConnection

Try
scmCmdToExecute.Parameters.Add(new SqlParameter("@istatushistorynr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iStatushistorynr))
scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

If m_bMainConnectionIsCreatedLocal Then
' // Open connection.
m_scoMainConnection.Open()
Else
If m_cpMainConnectionProvider.bIsTransactionPending Then
scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
End If
End If

' // Execute query.
sdaAdapter.Fill(dtToReturn)
m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
' // Throw error.
Throw New Exception("Stored Procedure 'pr_statushistory_SelectOne' reported the ErrorCode: " & m_iErrorCode.ToString())
End If

If dtToReturn.Rows.Count > 0 Then
m_iStatushistorynr = New SqlInt32(CType(dtToReturn.Rows(0)("statushistorynr"), Integer))
m_iStatus = New SqlInt32(CType(dtToReturn.Rows(0)("status"), Integer))
If dtToReturn.Rows(0)("mandantnr") Is System.DBNull.Value Then
m_iMandantnr = SqlInt32.Null
Else
m_iMandantnr = New SqlInt32(CType(dtToReturn.Rows(0)("mandantnr"), Integer))
End If
If dtToReturn.Rows(0)("aktiv") Is System.DBNull.Value Then
m_bAktiv = SqlBoolean.Null
Else
m_bAktiv = New SqlBoolean(CType(dtToReturn.Rows(0)("aktiv"), Boolean))
End If
If dtToReturn.Rows(0)("erstellt_am") Is System.DBNull.Value Then
m_daErstellt_am = SqlDateTime.Null
Else
m_daErstellt_am = New SqlDateTime(CType(dtToReturn.Rows(0)("erstellt_am"), Date))
End If
If dtToReturn.Rows(0)("mutiert_am") Is System.DBNull.Value Then
m_daMutiert_am = SqlDateTime.Null
Else
m_daMutiert_am = New SqlDateTime(CType(dtToReturn.Rows(0)("mutiert_am"), Date))
End If
If dtToReturn.Rows(0)("mutierer") Is System.DBNull.Value Then
m_iMutierer = SqlInt32.Null
Else
m_iMutierer = New SqlInt32(CType(dtToReturn.Rows(0)("mutierer"), Integer))
End If
If dtToReturn.Rows(0)("dokumentid") Is System.DBNull.Value Then
m_sDokumentid = SqlString.Null
Else
m_sDokumentid = New SqlString(CType(dtToReturn.Rows(0)("dokumentid"), String))
End If
If dtToReturn.Rows(0)("verantwortlich") Is System.DBNull.Value Then
m_iVerantwortlich = SqlInt32.Null
Else
m_iVerantwortlich = New SqlInt32(CType(dtToReturn.Rows(0)("verantwortlich"), Integer))
End If
End If
Return dtToReturn
Catch ex As Exception
' // some error occured. Bubble it to caller and encapsulate Exception object
Throw New Exception("clsStatushistory::SelectOne::Error occured.", ex)
Finally
If m_bMainConnectionIsCreatedLocal Then
' // Close connection.
m_scoMainConnection.Close()
End If
scmCmdToExecute.Dispose()
sdaAdapter.Dispose()
End Try
End Function

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsStatushistory Class
clsStatushistory clsStatushistory Members


clsStatushistory.Update Method

clsStatushistory.Update Method

clsStatushistory.Update Method | Previous topic | Next topic
clsStatushistory.Update Method | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Overrides Function Update() As Boolean

C#

public override bool Update()

C++

public:
bool Update()

JScript

public function Update() : boolean;

Source code

Visual Basic

Copy Code Copy Code

Overrides Public Function Update() As Boolean
Dim scmCmdToExecute As SqlCommand = New SqlCommand()
scmCmdToExecute.CommandText = "dbo.[pr_statushistory_Update]"
scmCmdToExecute.CommandType = CommandType.StoredProcedure

' // Use base class' connection object
scmCmdToExecute.Connection = m_scoMainConnection

Try
scmCmdToExecute.Parameters.Add(New SqlParameter("@istatushistorynr", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iStatushistorynr))
scmCmdToExecute.Parameters.Add(New SqlParameter("@istatus", SqlDbType.Int, 4, ParameterDirection.Input, False, 10, 0, "", DataRowVersion.Proposed, m_iStatus))
scmCmdToExecute.Parameters.Add(New SqlParameter("@imandantnr", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMandantnr))
scmCmdToExecute.Parameters.Add(New SqlParameter("@baktiv", SqlDbType.Bit, 1, ParameterDirection.Input, True, 1, 0, "", DataRowVersion.Proposed, m_bAktiv))
scmCmdToExecute.Parameters.Add(New SqlParameter("@daerstellt_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daErstellt_am))
scmCmdToExecute.Parameters.Add(New SqlParameter("@damutiert_am", SqlDbType.DateTime, 8, ParameterDirection.Input, True, 23, 3, "", DataRowVersion.Proposed, m_daMutiert_am))
scmCmdToExecute.Parameters.Add(New SqlParameter("@imutierer", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iMutierer))
scmCmdToExecute.Parameters.Add(New SqlParameter("@sdokumentid", SqlDbType.VarChar, 22, ParameterDirection.Input, True, 0, 0, "", DataRowVersion.Proposed, m_sDokumentid))
scmCmdToExecute.Parameters.Add(New SqlParameter("@iverantwortlich", SqlDbType.Int, 4, ParameterDirection.Input, True, 10, 0, "", DataRowVersion.Proposed, m_iVerantwortlich))
scmCmdToExecute.Parameters.Add(new SqlParameter("@iErrorCode", SqlDbType.Int, 4, ParameterDirection.Output, True, 10, 0, "", DataRowVersion.Proposed, m_iErrorCode))

If m_bMainConnectionIsCreatedLocal Then
' // Open connection.
m_scoMainConnection.Open()
Else
If m_cpMainConnectionProvider.bIsTransactionPending Then
scmCmdToExecute.Transaction = m_cpMainConnectionProvider.stCurrentTransaction
End If
End If

' // Execute query.
scmCmdToExecute.ExecuteNonQuery()
m_iErrorCode = New SqlInt32(CType(scmCmdToExecute.Parameters.Item("@iErrorCode").Value, SqlInt32))

If Not m_iErrorCode.Equals(New SqlInt32(LLBLError.AllOk)) Then
' // Throw error.
Throw New Exception("Stored Procedure 'pr_statushistory_Update' reported the ErrorCode: " & m_iErrorCode.ToString())
End If

Return True
Catch ex As Exception
' // some error occured. Bubble it to caller and encapsulate Exception object
Throw New Exception("clsStatushistory::Update::Error occured.", ex)
Finally
If m_bMainConnectionIsCreatedLocal Then
' // Close connection.
m_scoMainConnection.Close()
End If
scmCmdToExecute.Dispose()
End Try
End Function

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsStatushistory Class
clsStatushistory clsStatushistory Members


clsStatushistory Fields

clsStatushistory Fields

clsStatushistory Fields | Previous topic | Next topic
clsStatushistory Fields | Previous topic | Next topic

Fields

 | Name | Description
Supported by the .NET Compact Framework. | m_bAktiv |
Supported by the .NET Compact Framework. | m_bMainConnectionIsCreatedLocal | (inherited from clsDBInteractionBase ).
Supported by the .NET Compact Framework. | m_cpMainConnectionProvider | (inherited from clsDBInteractionBase ).
Supported by the .NET Compact Framework. | m_daErstellt_am |
Supported by the .NET Compact Framework. | m_daMutiert_am |
Supported by the .NET Compact Framework. | m_iErrorCode | (inherited from clsDBInteractionBase ).
Supported by the .NET Compact Framework. | m_iMandantnr |
Supported by the .NET Compact Framework. | m_iMutierer |
Supported by the .NET Compact Framework. | m_iStatus |
Supported by the .NET Compact Framework. | m_iStatushistorynr |
Supported by the .NET Compact Framework. | m_iVerantwortlich |
Supported by the .NET Compact Framework. | m_sDokumentid |
Supported by the .NET Compact Framework. | m_scoMainConnection | (inherited from clsDBInteractionBase ).

Top

See Also

Reference

clsStatushistory Class


m_bAktiv Field

m_bAktiv Field

m_bAktiv Field | Previous topic | Next topic
m_bAktiv Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_bAktiv As SqlBoolean

C#

private SqlBoolean m_bAktiv

C++

private:
SqlBoolean m_bAktiv;

JScript

private m_bAktiv : SqlBoolean

Source code

Visual Basic

Copy Code Copy Code

Private m_bAktiv As SqlBoolean

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsStatushistory Class
clsStatushistory clsStatushistory Members


m_daErstellt_am Field

m_daErstellt_am Field

m_daErstellt_am Field | Previous topic | Next topic
m_daErstellt_am Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_daErstellt_am As SqlDateTime

C#

private SqlDateTime m_daErstellt_am

C++

private:
SqlDateTime m_daErstellt_am;

JScript

private m_daErstellt_am : SqlDateTime

Source code

Visual Basic

Copy Code Copy Code

Private m_daErstellt_am, m_daMutiert_am As SqlDateTime

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsStatushistory Class
clsStatushistory clsStatushistory Members


m_daMutiert_am Field

m_daMutiert_am Field

m_daMutiert_am Field | Previous topic | Next topic
m_daMutiert_am Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_daMutiert_am As SqlDateTime

C#

private SqlDateTime m_daMutiert_am

C++

private:
SqlDateTime m_daMutiert_am;

JScript

private m_daMutiert_am : SqlDateTime

Source code

Visual Basic

Copy Code Copy Code

Private m_daErstellt_am, m_daMutiert_am As SqlDateTime

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsStatushistory Class
clsStatushistory clsStatushistory Members


m_iMandantnr Field

m_iMandantnr Field

m_iMandantnr Field | Previous topic | Next topic
m_iMandantnr Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_iMandantnr As SqlInt32

C#

private SqlInt32 m_iMandantnr

C++

private:
SqlInt32 m_iMandantnr;

JScript

private m_iMandantnr : SqlInt32

Source code

Visual Basic

Copy Code Copy Code

Private m_iMutierer, m_iVerantwortlich, m_iStatushistorynr, m_iMandantnr, m_iStatus As SqlInt32

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsStatushistory Class
clsStatushistory clsStatushistory Members


m_iMutierer Field

m_iMutierer Field

m_iMutierer Field | Previous topic | Next topic
m_iMutierer Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_iMutierer As SqlInt32

C#

private SqlInt32 m_iMutierer

C++

private:
SqlInt32 m_iMutierer;

JScript

private m_iMutierer : SqlInt32

Source code

Visual Basic

Copy Code Copy Code

Private m_iMutierer, m_iVerantwortlich, m_iStatushistorynr, m_iMandantnr, m_iStatus As SqlInt32

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsStatushistory Class
clsStatushistory clsStatushistory Members


m_iStatus Field

m_iStatus Field

m_iStatus Field | Previous topic | Next topic
m_iStatus Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_iStatus As SqlInt32

C#

private SqlInt32 m_iStatus

C++

private:
SqlInt32 m_iStatus;

JScript

private m_iStatus : SqlInt32

Source code

Visual Basic

Copy Code Copy Code

Private m_iMutierer, m_iVerantwortlich, m_iStatushistorynr, m_iMandantnr, m_iStatus As SqlInt32

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsStatushistory Class
clsStatushistory clsStatushistory Members


m_iStatushistorynr Field

m_iStatushistorynr Field

m_iStatushistorynr Field | Previous topic | Next topic
m_iStatushistorynr Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_iStatushistorynr As SqlInt32

C#

private SqlInt32 m_iStatushistorynr

C++

private:
SqlInt32 m_iStatushistorynr;

JScript

private m_iStatushistorynr : SqlInt32

Source code

Visual Basic

Copy Code Copy Code

Private m_iMutierer, m_iVerantwortlich, m_iStatushistorynr, m_iMandantnr, m_iStatus As SqlInt32

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsStatushistory Class
clsStatushistory clsStatushistory Members


m_iVerantwortlich Field

m_iVerantwortlich Field

m_iVerantwortlich Field | Previous topic | Next topic
m_iVerantwortlich Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_iVerantwortlich As SqlInt32

C#

private SqlInt32 m_iVerantwortlich

C++

private:
SqlInt32 m_iVerantwortlich;

JScript

private m_iVerantwortlich : SqlInt32

Source code

Visual Basic

Copy Code Copy Code

Private m_iMutierer, m_iVerantwortlich, m_iStatushistorynr, m_iMandantnr, m_iStatus As SqlInt32

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsStatushistory Class
clsStatushistory clsStatushistory Members


m_sDokumentid Field

m_sDokumentid Field

m_sDokumentid Field | Previous topic | Next topic
m_sDokumentid Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_sDokumentid As SqlString

C#

private SqlString m_sDokumentid

C++

private:
SqlString m_sDokumentid;

JScript

private m_sDokumentid : SqlString

Source code

Visual Basic

Copy Code Copy Code

Private m_sDokumentid As SqlString

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsStatushistory Class
clsStatushistory clsStatushistory Members


clsVorlagenfeld Class

clsVorlagenfeld Class

clsVorlagenfeld Class | Previous topic | Next topic
clsVorlagenfeld Class | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Class clsVorlagenfeld
Inherits clsDBInteractionBase

C#

public class clsVorlagenfeld : clsDBInteractionBase

C++

public ref class clsVorlagenfeld : public clsDBInteractionBase^

JScript

public class clsVorlagenfeld
extends clsDBInteractionBase

Inheritance Hierarchy

System.Object

EDKB12WS.edokadb.clsDBInteractionBase

EDKB12WS.edokadb.clsVorlagenfeld

EDKB12WS.edokadb.clsMyDokumentDaten

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsVorlagenfeld Members


clsVorlagenfeld Members

clsVorlagenfeld Members

clsVorlagenfeld Members | Previous topic | Next topic
clsVorlagenfeld Members | Previous topic | Next topic

The following tables list the members exposed by the clsVorlagenfeld type.

Public Constructors

 | Name | Description
Supported by the .NET Compact Framework. | clsVorlagenfeld Constructor |

Top

Public Properties

 | Name | Description
Supported by the .NET Compact Framework. | bAktiv |
Supported by the .NET Compact Framework. | bAusstiegsmakro |
Supported by the .NET Compact Framework. | bEinstiegsmakro |
Supported by the .NET Compact Framework. | cpMainConnectionProvider | (inherited from clsDBInteractionBase ).
Supported by the .NET Compact Framework. | daErstellt_am |
Supported by the .NET Compact Framework. | daMutiert_am |
Supported by the .NET Compact Framework. | iDokumenttypnr |
Supported by the .NET Compact Framework. | iDokumenttypnrOld |
Supported by the .NET Compact Framework. | iErrorCode | (inherited from clsDBInteractionBase ).
Supported by the .NET Compact Framework. | iMandantnr |
Supported by the .NET Compact Framework. | iMutierer |
Supported by the .NET Compact Framework. | iVorlagenfeldnr |
Supported by the .NET Compact Framework. | iVorlagenfeldregelnr |
Supported by the .NET Compact Framework. | iVorlagenfeldregelnrOld |
Supported by the .NET Compact Framework. | sBeginntextmarke |
Supported by the .NET Compact Framework. | sConnectionString | (inherited from clsDBInteractionBase ).
Supported by the .NET Compact Framework. | sEndetextmarke |
Supported by the .NET Compact Framework. | sFeldname |
Supported by the .NET Compact Framework. | sTestdaten |

Top

Public Methods

 | Name | Description
Supported by the .NET Compact Framework. | Delete |
Supported by the .NET Compact Framework. | Dispose | (Overloaded) (inherited from clsDBInteractionBase ).
Public method | Equals | (Overloaded) (inherited from Object).
Public method | GetHashCode | (inherited from Object).
Public method | GetType | (Overloaded) (inherited from Object).
Supported by the .NET Compact Framework. | Insert |
 | ReferenceEquals | (inherited from Object).
Supported by the .NET Compact Framework. | SelectAll |
Supported by the .NET Compact Framework. | SelectAllWdokumenttypnrLogic |
Supported by the .NET Compact Framework. | SelectAllWvorlagenfeldregelnrLogic |
Supported by the .NET Compact Framework. | SelectOne |
Public method | ToString | (inherited from Object).
Supported by the .NET Compact Framework. | Update |
Supported by the .NET Compact Framework. | UpdateAllWdokumenttypnrLogic |
Supported by the .NET Compact Framework. | UpdateAllWvorlagenfeldregelnrLogic |

Top

Protected Methods

 | Name | Description
Protected method | Finalize | (inherited from Object).
Protected method | MemberwiseClone | (Overloaded) (inherited from Object).

Top

Fields

 | Name | Description
Supported by the .NET Compact Framework. | m_bAktiv |
Supported by the .NET Compact Framework. | m_bAusstiegsmakro |
Supported by the .NET Compact Framework. | m_bEinstiegsmakro |
Supported by the .NET Compact Framework. | m_bMainConnectionIsCreatedLocal | (inherited from clsDBInteractionBase ).
Supported by the .NET Compact Framework. | m_cpMainConnectionProvider | (inherited from clsDBInteractionBase ).
Supported by the .NET Compact Framework. | m_daErstellt_am |
Supported by the .NET Compact Framework. | m_daMutiert_am |
Supported by the .NET Compact Framework. | m_iDokumenttypnr |
Supported by the .NET Compact Framework. | m_iDokumenttypnrOld |
Supported by the .NET Compact Framework. | m_iErrorCode | (inherited from clsDBInteractionBase ).
Supported by the .NET Compact Framework. | m_iMandantnr |
Supported by the .NET Compact Framework. | m_iMutierer |
Supported by the .NET Compact Framework. | m_iVorlagenfeldnr |
Supported by the .NET Compact Framework. | m_iVorlagenfeldregelnr |
Supported by the .NET Compact Framework. | m_iVorlagenfeldregelnrOld |
Supported by the .NET Compact Framework. | m_sBeginntextmarke |
Supported by the .NET Compact Framework. | m_sEndetextmarke |
Supported by the .NET Compact Framework. | m_sFeldname |
Supported by the .NET Compact Framework. | m_sTestdaten |
Supported by the .NET Compact Framework. | m_scoMainConnection | (inherited from clsDBInteractionBase ).

Top

See Also

Reference

clsVorlagenfeld Class


clsVorlagenfeld Properties

clsVorlagenfeld Properties

clsVorlagenfeld Properties | Previous topic | Next topic
clsVorlagenfeld Properties | Previous topic | Next topic

Public Properties

 | Name | Description
Supported by the .NET Compact Framework. | bAktiv |
Supported by the .NET Compact Framework. | bAusstiegsmakro |
Supported by the .NET Compact Framework. | bEinstiegsmakro |
Supported by the .NET Compact Framework. | cpMainConnectionProvider | (inherited from clsDBInteractionBase ).
Supported by the .NET Compact Framework. | daErstellt_am |
Supported by the .NET Compact Framework. | daMutiert_am |
Supported by the .NET Compact Framework. | iDokumenttypnr |
Supported by the .NET Compact Framework. | iDokumenttypnrOld |
Supported by the .NET Compact Framework. | iErrorCode | (inherited from clsDBInteractionBase ).
Supported by the .NET Compact Framework. | iMandantnr |
Supported by the .NET Compact Framework. | iMutierer |
Supported by the .NET Compact Framework. | iVorlagenfeldnr |
Supported by the .NET Compact Framework. | iVorlagenfeldregelnr |
Supported by the .NET Compact Framework. | iVorlagenfeldregelnrOld |
Supported by the .NET Compact Framework. | sBeginntextmarke |
Supported by the .NET Compact Framework. | sConnectionString | (inherited from clsDBInteractionBase ).
Supported by the .NET Compact Framework. | sEndetextmarke |
Supported by the .NET Compact Framework. | sFeldname |
Supported by the .NET Compact Framework. | sTestdaten |

Top

See Also

Reference

clsVorlagenfeld Class


clsVorlagenfeld Methods

clsVorlagenfeld Methods

clsVorlagenfeld Methods | Previous topic | Next topic
clsVorlagenfeld Methods | Previous topic | Next topic

Public Methods

 | Name | Description
Supported by the .NET Compact Framework. | Delete |
Supported by the .NET Compact Framework. | Dispose | (Overloaded) (inherited from clsDBInteractionBase ).
Public method | Equals | (Overloaded) (inherited from Object).
Public method | GetHashCode | (inherited from Object).
Public method | GetType | (Overloaded) (inherited from Object).
Supported by the .NET Compact Framework. | Insert |
 | ReferenceEquals | (inherited from Object).
Supported by the .NET Compact Framework. | SelectAll |
Supported by the .NET Compact Framework. | SelectAllWdokumenttypnrLogic |
Supported by the .NET Compact Framework. | SelectAllWvorlagenfeldregelnrLogic |
Supported by the .NET Compact Framework. | SelectOne |
Public method | ToString | (inherited from Object).
Supported by the .NET Compact Framework. | Update |
Supported by the .NET Compact Framework. | UpdateAllWdokumenttypnrLogic |
Supported by the .NET Compact Framework. | UpdateAllWvorlagenfeldregelnrLogic |

Top

Protected Methods

 | Name | Description
Protected method | Finalize | (inherited from Object).
Protected method | MemberwiseClone | (Overloaded) (inherited from Object).

Top

See Also

Reference

clsVorlagenfeld Class


clsVorlagenfeld Fields

clsVorlagenfeld Fields

clsVorlagenfeld Fields | Previous topic | Next topic
clsVorlagenfeld Fields | Previous topic | Next topic

Fields

 | Name | Description
Supported by the .NET Compact Framework. | m_bAktiv |
Supported by the .NET Compact Framework. | m_bAusstiegsmakro |
Supported by the .NET Compact Framework. | m_bEinstiegsmakro |
Supported by the .NET Compact Framework. | m_bMainConnectionIsCreatedLocal | (inherited from clsDBInteractionBase ).
Supported by the .NET Compact Framework. | m_cpMainConnectionProvider | (inherited from clsDBInteractionBase ).
Supported by the .NET Compact Framework. | m_daErstellt_am |
Supported by the .NET Compact Framework. | m_daMutiert_am |
Supported by the .NET Compact Framework. | m_iDokumenttypnr |
Supported by the .NET Compact Framework. | m_iDokumenttypnrOld |
Supported by the .NET Compact Framework. | m_iErrorCode | (inherited from clsDBInteractionBase ).
Supported by the .NET Compact Framework. | m_iMandantnr |
Supported by the .NET Compact Framework. | m_iMutierer |
Supported by the .NET Compact Framework. | m_iVorlagenfeldnr |
Supported by the .NET Compact Framework. | m_iVorlagenfeldregelnr |
Supported by the .NET Compact Framework. | m_iVorlagenfeldregelnrOld |
Supported by the .NET Compact Framework. | m_sBeginntextmarke |
Supported by the .NET Compact Framework. | m_sEndetextmarke |
Supported by the .NET Compact Framework. | m_sFeldname |
Supported by the .NET Compact Framework. | m_sTestdaten |
Supported by the .NET Compact Framework. | m_scoMainConnection | (inherited from clsDBInteractionBase ).

Top

See Also

Reference

clsVorlagenfeld Class


m_bAktiv Field

m_bAktiv Field

m_bAktiv Field | Previous topic | Next topic
m_bAktiv Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_bAktiv As SqlBoolean

C#

private SqlBoolean m_bAktiv

C++

private:
SqlBoolean m_bAktiv;

JScript

private m_bAktiv : SqlBoolean

Source code

Visual Basic

Copy Code Copy Code

Private m_bEinstiegsmakro, m_bAusstiegsmakro, m_bAktiv As SqlBoolean

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsVorlagenfeld Class
clsVorlagenfeld clsVorlagenfeld Members


m_bAusstiegsmakro Field

m_bAusstiegsmakro Field

m_bAusstiegsmakro Field | Previous topic | Next topic
m_bAusstiegsmakro Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_bAusstiegsmakro As SqlBoolean

C#

private SqlBoolean m_bAusstiegsmakro

C++

private:
SqlBoolean m_bAusstiegsmakro;

JScript

private m_bAusstiegsmakro : SqlBoolean

Source code

Visual Basic

Copy Code Copy Code

Private m_bEinstiegsmakro, m_bAusstiegsmakro, m_bAktiv As SqlBoolean

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsVorlagenfeld Class
clsVorlagenfeld clsVorlagenfeld Members


m_bEinstiegsmakro Field

m_bEinstiegsmakro Field

m_bEinstiegsmakro Field | Previous topic | Next topic
m_bEinstiegsmakro Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_bEinstiegsmakro As SqlBoolean

C#

private SqlBoolean m_bEinstiegsmakro

C++

private:
SqlBoolean m_bEinstiegsmakro;

JScript

private m_bEinstiegsmakro : SqlBoolean

Source code

Visual Basic

Copy Code Copy Code

Private m_bEinstiegsmakro, m_bAusstiegsmakro, m_bAktiv As SqlBoolean

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsVorlagenfeld Class
clsVorlagenfeld clsVorlagenfeld Members


m_daErstellt_am Field

m_daErstellt_am Field

m_daErstellt_am Field | Previous topic | Next topic
m_daErstellt_am Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_daErstellt_am As SqlDateTime

C#

private SqlDateTime m_daErstellt_am

C++

private:
SqlDateTime m_daErstellt_am;

JScript

private m_daErstellt_am : SqlDateTime

Source code

Visual Basic

Copy Code Copy Code

Private m_daErstellt_am, m_daMutiert_am As SqlDateTime

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsVorlagenfeld Class
clsVorlagenfeld clsVorlagenfeld Members


m_daMutiert_am Field

m_daMutiert_am Field

m_daMutiert_am Field | Previous topic | Next topic
m_daMutiert_am Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_daMutiert_am As SqlDateTime

C#

private SqlDateTime m_daMutiert_am

C++

private:
SqlDateTime m_daMutiert_am;

JScript

private m_daMutiert_am : SqlDateTime

Source code

Visual Basic

Copy Code Copy Code

Private m_daErstellt_am, m_daMutiert_am As SqlDateTime

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsVorlagenfeld Class
clsVorlagenfeld clsVorlagenfeld Members


m_iDokumenttypnr Field

m_iDokumenttypnr Field

m_iDokumenttypnr Field | Previous topic | Next topic
m_iDokumenttypnr Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_iDokumenttypnr As SqlInt32

C#

private SqlInt32 m_iDokumenttypnr

C++

private:
SqlInt32 m_iDokumenttypnr;

JScript

private m_iDokumenttypnr : SqlInt32

Source code

Visual Basic

Copy Code Copy Code

Private m_iVorlagenfeldnr, m_iMandantnr, m_iDokumenttypnr, m_iDokumenttypnrOld, m_iMutierer, m_iVorlagenfeldregelnr, m_iVorlagenfeldregelnrOld As SqlInt32

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsVorlagenfeld Class
clsVorlagenfeld clsVorlagenfeld Members


m_iDokumenttypnrOld Field

m_iDokumenttypnrOld Field

m_iDokumenttypnrOld Field | Previous topic | Next topic
m_iDokumenttypnrOld Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_iDokumenttypnrOld As SqlInt32

C#

private SqlInt32 m_iDokumenttypnrOld

C++

private:
SqlInt32 m_iDokumenttypnrOld;

JScript

private m_iDokumenttypnrOld : SqlInt32

Source code

Visual Basic

Copy Code Copy Code

Private m_iVorlagenfeldnr, m_iMandantnr, m_iDokumenttypnr, m_iDokumenttypnrOld, m_iMutierer, m_iVorlagenfeldregelnr, m_iVorlagenfeldregelnrOld As SqlInt32

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsVorlagenfeld Class
clsVorlagenfeld clsVorlagenfeld Members


m_iMandantnr Field

m_iMandantnr Field

m_iMandantnr Field | Previous topic | Next topic
m_iMandantnr Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_iMandantnr As SqlInt32

C#

private SqlInt32 m_iMandantnr

C++

private:
SqlInt32 m_iMandantnr;

JScript

private m_iMandantnr : SqlInt32

Source code

Visual Basic

Copy Code Copy Code

Private m_iVorlagenfeldnr, m_iMandantnr, m_iDokumenttypnr, m_iDokumenttypnrOld, m_iMutierer, m_iVorlagenfeldregelnr, m_iVorlagenfeldregelnrOld As SqlInt32

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsVorlagenfeld Class
clsVorlagenfeld clsVorlagenfeld Members


m_iMutierer Field

m_iMutierer Field

m_iMutierer Field | Previous topic | Next topic
m_iMutierer Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_iMutierer As SqlInt32

C#

private SqlInt32 m_iMutierer

C++

private:
SqlInt32 m_iMutierer;

JScript

private m_iMutierer : SqlInt32

Source code

Visual Basic

Copy Code Copy Code

Private m_iVorlagenfeldnr, m_iMandantnr, m_iDokumenttypnr, m_iDokumenttypnrOld, m_iMutierer, m_iVorlagenfeldregelnr, m_iVorlagenfeldregelnrOld As SqlInt32

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsVorlagenfeld Class
clsVorlagenfeld clsVorlagenfeld Members


m_iVorlagenfeldnr Field

m_iVorlagenfeldnr Field

m_iVorlagenfeldnr Field | Previous topic | Next topic
m_iVorlagenfeldnr Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_iVorlagenfeldnr As SqlInt32

C#

private SqlInt32 m_iVorlagenfeldnr

C++

private:
SqlInt32 m_iVorlagenfeldnr;

JScript

private m_iVorlagenfeldnr : SqlInt32

Source code

Visual Basic

Copy Code Copy Code

Private m_iVorlagenfeldnr, m_iMandantnr, m_iDokumenttypnr, m_iDokumenttypnrOld, m_iMutierer, m_iVorlagenfeldregelnr, m_iVorlagenfeldregelnrOld As SqlInt32

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsVorlagenfeld Class
clsVorlagenfeld clsVorlagenfeld Members


m_iVorlagenfeldregelnr Field

m_iVorlagenfeldregelnr Field

m_iVorlagenfeldregelnr Field | Previous topic | Next topic
m_iVorlagenfeldregelnr Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_iVorlagenfeldregelnr As SqlInt32

C#

private SqlInt32 m_iVorlagenfeldregelnr

C++

private:
SqlInt32 m_iVorlagenfeldregelnr;

JScript

private m_iVorlagenfeldregelnr : SqlInt32

Source code

Visual Basic

Copy Code Copy Code

Private m_iVorlagenfeldnr, m_iMandantnr, m_iDokumenttypnr, m_iDokumenttypnrOld, m_iMutierer, m_iVorlagenfeldregelnr, m_iVorlagenfeldregelnrOld As SqlInt32

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsVorlagenfeld Class
clsVorlagenfeld clsVorlagenfeld Members


m_iVorlagenfeldregelnrOld Field

m_iVorlagenfeldregelnrOld Field

m_iVorlagenfeldregelnrOld Field | Previous topic | Next topic
m_iVorlagenfeldregelnrOld Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_iVorlagenfeldregelnrOld As SqlInt32

C#

private SqlInt32 m_iVorlagenfeldregelnrOld

C++

private:
SqlInt32 m_iVorlagenfeldregelnrOld;

JScript

private m_iVorlagenfeldregelnrOld : SqlInt32

Source code

Visual Basic

Copy Code Copy Code

Private m_iVorlagenfeldnr, m_iMandantnr, m_iDokumenttypnr, m_iDokumenttypnrOld, m_iMutierer, m_iVorlagenfeldregelnr, m_iVorlagenfeldregelnrOld As SqlInt32

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsVorlagenfeld Class
clsVorlagenfeld clsVorlagenfeld Members


m_sBeginntextmarke Field

m_sBeginntextmarke Field

m_sBeginntextmarke Field | Previous topic | Next topic
m_sBeginntextmarke Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_sBeginntextmarke As SqlString

C#

private SqlString m_sBeginntextmarke

C++

private:
SqlString m_sBeginntextmarke;

JScript

private m_sBeginntextmarke : SqlString

Source code

Visual Basic

Copy Code Copy Code

Private m_sBeginntextmarke, m_sFeldname, m_sTestdaten, m_sEndetextmarke As SqlString

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsVorlagenfeld Class
clsVorlagenfeld clsVorlagenfeld Members


m_sEndetextmarke Field

m_sEndetextmarke Field

m_sEndetextmarke Field | Previous topic | Next topic
m_sEndetextmarke Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_sEndetextmarke As SqlString

C#

private SqlString m_sEndetextmarke

C++

private:
SqlString m_sEndetextmarke;

JScript

private m_sEndetextmarke : SqlString

Source code

Visual Basic

Copy Code Copy Code

Private m_sBeginntextmarke, m_sFeldname, m_sTestdaten, m_sEndetextmarke As SqlString

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsVorlagenfeld Class
clsVorlagenfeld clsVorlagenfeld Members


m_sFeldname Field

m_sFeldname Field

m_sFeldname Field | Previous topic | Next topic
m_sFeldname Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_sFeldname As SqlString

C#

private SqlString m_sFeldname

C++

private:
SqlString m_sFeldname;

JScript

private m_sFeldname : SqlString

Source code

Visual Basic

Copy Code Copy Code

Private m_sBeginntextmarke, m_sFeldname, m_sTestdaten, m_sEndetextmarke As SqlString

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsVorlagenfeld Class
clsVorlagenfeld clsVorlagenfeld Members


m_sTestdaten Field

m_sTestdaten Field

m_sTestdaten Field | Previous topic | Next topic
m_sTestdaten Field | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Private m_sTestdaten As SqlString

C#

private SqlString m_sTestdaten

C++

private:
SqlString m_sTestdaten;

JScript

private m_sTestdaten : SqlString

Source code

Visual Basic

Copy Code Copy Code

Private m_sBeginntextmarke, m_sFeldname, m_sTestdaten, m_sEndetextmarke As SqlString

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsVorlagenfeld Class
clsVorlagenfeld clsVorlagenfeld Members


ICommonDBAccess Interface

ICommonDBAccess Interface

ICommonDBAccess Interface | Previous topic | Next topic
ICommonDBAccess Interface | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Interface ICommonDBAccess

C#

public interface ICommonDBAccess

C++

public interface class ICommonDBAccess

JScript

public interface ICommonDBAccess

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

ICommonDBAccess Members


ICommonDBAccess Members

ICommonDBAccess Members

ICommonDBAccess Members | Previous topic | Next topic
ICommonDBAccess Members | Previous topic | Next topic

The following tables list the members exposed by the ICommonDBAccess type.

Public Methods

 | Name | Description
Supported by the .NET Compact Framework. | Delete |
Supported by the .NET Compact Framework. | Insert |
Supported by the .NET Compact Framework. | SelectAll |
Supported by the .NET Compact Framework. | SelectOne |
Supported by the .NET Compact Framework. | Update |

Top

See Also

Reference

ICommonDBAccess Interface


ICommonDBAccess Methods

ICommonDBAccess Methods

ICommonDBAccess Methods | Previous topic | Next topic
ICommonDBAccess Methods | Previous topic | Next topic

Public Methods

 | Name | Description
Supported by the .NET Compact Framework. | Delete |
Supported by the .NET Compact Framework. | Insert |
Supported by the .NET Compact Framework. | SelectAll |
Supported by the .NET Compact Framework. | SelectOne |
Supported by the .NET Compact Framework. | Update |

Top

See Also

Reference

ICommonDBAccess Interface


ICommonDBAccess.Delete Method

ICommonDBAccess.Delete Method

ICommonDBAccess.Delete Method | Previous topic | Next topic
ICommonDBAccess.Delete Method | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Function Delete() As Boolean

C#

bool Delete()

C++

bool Delete()

JScript

function Delete() : boolean;

Source code

Visual Basic

Copy Code Copy Code

Function Delete() As Boolean

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

ICommonDBAccess Interface
ICommonDBAccess ICommonDBAccess Members


ICommonDBAccess.Insert Method

ICommonDBAccess.Insert Method

ICommonDBAccess.Insert Method | Previous topic | Next topic
ICommonDBAccess.Insert Method | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Function Insert() As Boolean

C#

bool Insert()

C++

bool Insert()

JScript

function Insert() : boolean;

Source code

Visual Basic

Copy Code Copy Code

Function Insert() As Boolean

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

ICommonDBAccess Interface
ICommonDBAccess ICommonDBAccess Members


ICommonDBAccess.SelectAll Method

ICommonDBAccess.SelectAll Method

ICommonDBAccess.SelectAll Method | Previous topic | Next topic
ICommonDBAccess.SelectAll Method | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Function SelectAll() As DataTable

C#

DataTable SelectAll()

C++

DataTable^ SelectAll()

JScript

function SelectAll() : DataTable;

Source code

Visual Basic

Copy Code Copy Code

Function SelectAll() As DataTable

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

ICommonDBAccess Interface
ICommonDBAccess ICommonDBAccess Members


ICommonDBAccess.SelectOne Method

ICommonDBAccess.SelectOne Method

ICommonDBAccess.SelectOne Method | Previous topic | Next topic
ICommonDBAccess.SelectOne Method | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Function SelectOne() As DataTable

C#

DataTable SelectOne()

C++

DataTable^ SelectOne()

JScript

function SelectOne() : DataTable;

Source code

Visual Basic

Copy Code Copy Code

Function SelectOne() As DataTable

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

ICommonDBAccess Interface
ICommonDBAccess ICommonDBAccess Members


ICommonDBAccess.Update Method

ICommonDBAccess.Update Method

ICommonDBAccess.Update Method | Previous topic | Next topic
ICommonDBAccess.Update Method | Previous topic | Next topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Function Update() As Boolean

C#

bool Update()

C++

bool Update()

JScript

function Update() : boolean;

Source code

Visual Basic

Copy Code Copy Code

Function Update() As Boolean

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

ICommonDBAccess Interface
ICommonDBAccess ICommonDBAccess Members


LLBLError Enumeration

LLBLError Enumeration

LLBLError Enumeration | Previous topic | This is the last topic
LLBLError Enumeration | Previous topic | This is the last topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Members

Member name | Description
AllOk |

Source code

Visual Basic

Copy Code Copy Code

Public Enum LLBLError
AllOk
' // Add more here (check the comma's!)
End Enum

See Also

Reference

EDKB12WS.edokadb Namespace


Action Attached Properties

Action Attached Properties

Action Attached Properties | This is the first topic | This is the last topic
Action Attached Properties | This is the first topic | This is the last topic

See Also

Reference

Action Class


Action Events

Action Events

Action Events | This is the first topic | This is the last topic
Action Events | This is the first topic | This is the last topic

See Also

Reference

Action Class


clsConnectionProvider.Dispose Method

clsConnectionProvider.Dispose Method

clsConnectionProvider.Dispose Method | This is the first topic | This is the last topic
clsConnectionProvider.Dispose Method | This is the first topic | This is the last topic

Overload List

Name | Description
Dispose() |
Dispose(bool) |

See Also

Reference

clsConnectionProvider Class
clsConnectionProvider clsConnectionProvider Members


clsConnectionProvider.Dispose Method

clsConnectionProvider.Dispose Method

clsConnectionProvider.Dispose Method | This is the first topic | This is the last topic
clsConnectionProvider.Dispose Method | This is the first topic | This is the last topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Overloads Sub Dispose() Implements _
IDisposable.Dispose

C#

public System.Void Dispose()

C++

public:
System::Void Dispose()

JScript

public function Dispose();

Implements

IDisposable.Dispose

Source code

Visual Basic

Copy Code Copy Code

Overloads Public Sub Dispose() Implements IDisposable.Dispose
Dispose(True)
GC.SuppressFinalize(Me)
End Sub

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsConnectionProvider Class
clsConnectionProvider clsConnectionProvider Members


clsConnectionProvider.Dispose (Boolean) Method

clsConnectionProvider.Dispose (Boolean) Method

clsConnectionProvider.Dispose (Boolean) Method | This is the first topic | This is the last topic
clsConnectionProvider.Dispose (Boolean) Method | This is the first topic | This is the last topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Protected Overloads Overridable Sub Dispose( _
ByVal bIsDisposing As Boolean _
)

C#

protected virtual System.Void Dispose(
boolbIsDisposing
)

C++

protected:
virtual System::Void Dispose(
boolbIsDisposing
)

JScript

protected function Dispose(
bIsDisposing : boolean
);

Parameters

bIsDisposing

Source code

Visual Basic

Copy Code Copy Code

Overridable Overloads Protected Sub Dispose(ByVal bIsDisposing As Boolean)
' // Check to see if Dispose has already been called.
If Not m_bIsDisposed Then
If bIsDisposing Then
' // Dispose managed resources.
If Not (m_stCurrentTransaction Is Nothing) Then
m_stCurrentTransaction.Dispose()
m_stCurrentTransaction = Nothing
End If
If Not (m_scoDBConnection Is Nothing) Then
' // closing the connection will abort (rollback) any pending transactions
m_scoDBConnection.Close()
m_scoDBConnection.Dispose()
m_scoDBConnection = Nothing
End If
End If
End If
m_bIsDisposed = True
End Sub

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsConnectionProvider Class
clsConnectionProvider clsConnectionProvider Members


ICommonDBAccess Attached Properties

ICommonDBAccess Attached Properties

ICommonDBAccess Attached Properties | This is the first topic | This is the last topic
ICommonDBAccess Attached Properties | This is the first topic | This is the last topic

See Also

Reference

ICommonDBAccess Interface


ICommonDBAccess Events

ICommonDBAccess Events

ICommonDBAccess Events | This is the first topic | This is the last topic
ICommonDBAccess Events | This is the first topic | This is the last topic

See Also

Reference

ICommonDBAccess Interface


ICommonDBAccess Properties

ICommonDBAccess Properties

ICommonDBAccess Properties | This is the first topic | This is the last topic
ICommonDBAccess Properties | This is the first topic | This is the last topic

See Also

Reference

ICommonDBAccess Interface


ICommonDBAccess Fields

ICommonDBAccess Fields

ICommonDBAccess Fields | This is the first topic | This is the last topic
ICommonDBAccess Fields | This is the first topic | This is the last topic

See Also

Reference

ICommonDBAccess Interface


clsDBInteractionBase Attached Properties

clsDBInteractionBase Attached Properties

clsDBInteractionBase Attached Properties | This is the first topic | This is the last topic
clsDBInteractionBase Attached Properties | This is the first topic | This is the last topic

See Also

Reference

clsDBInteractionBase Class


clsDBInteractionBase Events

clsDBInteractionBase Events

clsDBInteractionBase Events | This is the first topic | This is the last topic
clsDBInteractionBase Events | This is the first topic | This is the last topic

See Also

Reference

clsDBInteractionBase Class


clsDBInteractionBase.Dispose Method

clsDBInteractionBase.Dispose Method

clsDBInteractionBase.Dispose Method | This is the first topic | This is the last topic
clsDBInteractionBase.Dispose Method | This is the first topic | This is the last topic

Overload List

Name | Description
Dispose() |
Dispose(bool) |

See Also

Reference

clsDBInteractionBase Class
clsDBInteractionBase clsDBInteractionBase Members


clsDBInteractionBase.Dispose Method

clsDBInteractionBase.Dispose Method

clsDBInteractionBase.Dispose Method | This is the first topic | This is the last topic
clsDBInteractionBase.Dispose Method | This is the first topic | This is the last topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Public Overloads Sub Dispose() Implements _
IDisposable.Dispose

C#

public System.Void Dispose()

C++

public:
System::Void Dispose()

JScript

public function Dispose();

Implements

IDisposable.Dispose

Source code

Visual Basic

Copy Code Copy Code

Overloads Public Sub Dispose() Implements IDisposable.Dispose
Dispose(True)
GC.SuppressFinalize(Me)
End Sub

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsDBInteractionBase Class
clsDBInteractionBase clsDBInteractionBase Members


clsDBInteractionBase.Dispose (Boolean) Method

clsDBInteractionBase.Dispose (Boolean) Method

clsDBInteractionBase.Dispose (Boolean) Method | This is the first topic | This is the last topic
clsDBInteractionBase.Dispose (Boolean) Method | This is the first topic | This is the last topic

Namespace: EDKB12WS.edokadb
Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Protected Overloads Overridable Sub Dispose( _
ByVal bIsDisposing As Boolean _
)

C#

protected virtual System.Void Dispose(
boolbIsDisposing
)

C++

protected:
virtual System::Void Dispose(
boolbIsDisposing
)

JScript

protected function Dispose(
bIsDisposing : boolean
);

Parameters

bIsDisposing

Source code

Visual Basic

Copy Code Copy Code

Overridable Overloads Protected Sub Dispose(ByVal bIsDisposing As Boolean)
' // Check to see if Dispose has already been called.
If Not m_bIsDisposed Then
If bIsDisposing Then
' // Dispose managed resources.
If m_bMainConnectionIsCreatedLocal Then
' // Object is created in this class, so destroy it here.
m_scoMainConnection.Close()
m_scoMainConnection.Dispose()
m_bMainConnectionIsCreatedLocal = True
End If
m_cpMainConnectionProvider = Nothing
m_scoMainConnection = Nothing
End If
End If
m_bIsDisposed = True
End Sub

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

clsDBInteractionBase Class
clsDBInteractionBase clsDBInteractionBase Members


clsDokument Attached Properties

clsDokument Attached Properties

clsDokument Attached Properties | This is the first topic | This is the last topic
clsDokument Attached Properties | This is the first topic | This is the last topic

See Also

Reference

clsDokument Class


clsDokument Events

clsDokument Events

clsDokument Events | This is the first topic | This is the last topic
clsDokument Events | This is the first topic | This is the last topic

See Also

Reference

clsDokument Class


clsIdvmakro_office_vorlage Attached Properties

clsIdvmakro_office_vorlage Attached Properties

clsIdvmakro_office_vorlage Attached Properties | This is the first topic | This is the last topic
clsIdvmakro_office_vorlage Attached Properties | This is the first topic | This is the last topic

See Also

Reference

clsIdvmakro_office_vorlage Class


clsIdvmakro_office_vorlage Events

clsIdvmakro_office_vorlage Events

clsIdvmakro_office_vorlage Events | This is the first topic | This is the last topic
clsIdvmakro_office_vorlage Events | This is the first topic | This is the last topic

See Also

Reference

clsIdvmakro_office_vorlage Class


AvaloqDokumentWerte Attached Properties

AvaloqDokumentWerte Attached Properties

AvaloqDokumentWerte Attached Properties | This is the first topic | This is the last topic
AvaloqDokumentWerte Attached Properties | This is the first topic | This is the last topic

See Also

Reference

AvaloqDokumentWerte Class


AvaloqDokumentWerte Events

AvaloqDokumentWerte Events

AvaloqDokumentWerte Events | This is the first topic | This is the last topic
AvaloqDokumentWerte Events | This is the first topic | This is the last topic

See Also

Reference

AvaloqDokumentWerte Class


AvaloqDokumentWerte Properties

AvaloqDokumentWerte Properties

AvaloqDokumentWerte Properties | This is the first topic | This is the last topic
AvaloqDokumentWerte Properties | This is the first topic | This is the last topic

See Also

Reference

AvaloqDokumentWerte Class


clsOffice_Vorlage_Datei Attached Properties

clsOffice_Vorlage_Datei Attached Properties

clsOffice_Vorlage_Datei Attached Properties | This is the first topic | This is the last topic
clsOffice_Vorlage_Datei Attached Properties | This is the first topic | This is the last topic

See Also

Reference

clsOffice_Vorlage_Datei Class


clsOffice_Vorlage_Datei Events

clsOffice_Vorlage_Datei Events

clsOffice_Vorlage_Datei Events | This is the first topic | This is the last topic
clsOffice_Vorlage_Datei Events | This is the first topic | This is the last topic

See Also

Reference

clsOffice_Vorlage_Datei Class


clsPartner Attached Properties

clsPartner Attached Properties

clsPartner Attached Properties | This is the first topic | This is the last topic
clsPartner Attached Properties | This is the first topic | This is the last topic

See Also

Reference

clsPartner Class


clsPartner Events

clsPartner Events

clsPartner Events | This is the first topic | This is the last topic
clsPartner Events | This is the first topic | This is the last topic

See Also

Reference

clsPartner Class


EDKB12WS.edokadb Members

EDKB12WS.edokadb Members

EDKB12WS.edokadb Members | This is the first topic | This is the last topic
EDKB12WS.edokadb Members | This is the first topic | This is the last topic

The following tables list the members exposed by the EDKB12WS.edokadb type.

Classes

 | Name | Description
Supported by the .NET Compact Framework. | clsApplikation |
Supported by the .NET Compact Framework. | clsConnectionProvider |
Supported by the .NET Compact Framework. | clsDBInteractionBase |
Supported by the .NET Compact Framework. | clsDokument |
Supported by the .NET Compact Framework. | clsDokumenttyp |
Supported by the .NET Compact Framework. | clsIdvmakro_office_vorlage |
Supported by the .NET Compact Framework. | clsJournaleintrag |
Supported by the .NET Compact Framework. | clsKey_tabelle |
Supported by the .NET Compact Framework. | clsMitarbeiter |
Supported by the .NET Compact Framework. | clsMyDokumentDaten |
Supported by the .NET Compact Framework. | clsMyKey_Tabelle |
Supported by the .NET Compact Framework. | clsMyPartner |
Supported by the .NET Compact Framework. | clsOffice_vorlage |
Supported by the .NET Compact Framework. | clsPartner |
Supported by the .NET Compact Framework. | clsStatushistory |
Supported by the .NET Compact Framework. | clsVorlagenfeld |

Top

Interfaces

 | Name | Description
Supported by the .NET Compact Framework. | ICommonDBAccess |

Top

Enumerations

 | Name | Description
Supported by the .NET Compact Framework. | LLBLError |

Top

See Also

Reference

EDKB12WS.edokadb Namespace


clsApplikation Attached Properties

clsApplikation Attached Properties

clsApplikation Attached Properties | This is the first topic | This is the last topic
clsApplikation Attached Properties | This is the first topic | This is the last topic

See Also

Reference

clsApplikation Class


clsApplikation Events

clsApplikation Events

clsApplikation Events | This is the first topic | This is the last topic
clsApplikation Events | This is the first topic | This is the last topic

See Also

Reference

clsApplikation Class


EDKB12WS.My.Resources Members

EDKB12WS.My.Resources Members

EDKB12WS.My.Resources Members | This is the first topic | This is the last topic
EDKB12WS.My.Resources Members | This is the first topic | This is the last topic

The following tables list the members exposed by the EDKB12WS.My.Resources type.

Classes

 | Name | Description
Internal (Friend) class Supported by the .NET Compact Framework. | Resources | Eine stark typisierte Ressourcenklasse zum Suchen von lokalisierten Zeichenfolgen usw.

Top

See Also

Reference

EDKB12WS.My.Resources Namespace


Resources Attached Properties

Resources Attached Properties

Resources Attached Properties | This is the first topic | This is the last topic
Resources Attached Properties | This is the first topic | This is the last topic

See Also

Reference

Resources Class
EDKB12WS.My.Resources Namespace


Resources Events

Resources Events

Resources Events | This is the first topic | This is the last topic
Resources Events | This is the first topic | This is the last topic

See Also

Reference

Resources Class
EDKB12WS.My.Resources Namespace


EDKB12WS.My Members

EDKB12WS.My Members

EDKB12WS.My Members | This is the first topic | This is the last topic
EDKB12WS.My Members | This is the first topic | This is the last topic

The following tables list the members exposed by the EDKB12WS.My type.

Classes

 | Name | Description
Internal (Friend) class Supported by the .NET Compact Framework. | MySettings |
Internal (Friend) class Supported by the .NET Compact Framework. | MySettingsProperty |

Top

See Also

Reference

EDKB12WS.My Namespace


MySettings Attached Properties

MySettings Attached Properties

MySettings Attached Properties | This is the first topic | This is the last topic
MySettings Attached Properties | This is the first topic | This is the last topic

See Also

Reference

MySettings Class
EDKB12WS.My Namespace


MySettingsProperty Attached Properties

MySettingsProperty Attached Properties

MySettingsProperty Attached Properties | This is the first topic | This is the last topic
MySettingsProperty Attached Properties | This is the first topic | This is the last topic

See Also

Reference

MySettingsProperty Class
EDKB12WS.My Namespace


MySettingsProperty Events

MySettingsProperty Events

MySettingsProperty Events | This is the first topic | This is the last topic
MySettingsProperty Events | This is the first topic | This is the last topic

See Also

Reference

MySettingsProperty Class
EDKB12WS.My Namespace


MySettingsProperty Fields

MySettingsProperty Fields

MySettingsProperty Fields | This is the first topic | This is the last topic
MySettingsProperty Fields | This is the first topic | This is the last topic

See Also

Reference

MySettingsProperty Class
EDKB12WS.My Namespace


Parameters Attached Properties

Parameters Attached Properties

Parameters Attached Properties | This is the first topic | This is the last topic
Parameters Attached Properties | This is the first topic | This is the last topic

See Also

Reference

Parameters Class


Parameters Events

Parameters Events

Parameters Events | This is the first topic | This is the last topic
Parameters Events | This is the first topic | This is the last topic

See Also

Reference

Parameters Class


clsConnectionProvider Attached Properties

clsConnectionProvider Attached Properties

clsConnectionProvider Attached Properties | This is the first topic | This is the last topic
clsConnectionProvider Attached Properties | This is the first topic | This is the last topic

See Also

Reference

clsConnectionProvider Class


clsConnectionProvider Events

clsConnectionProvider Events

clsConnectionProvider Events | This is the first topic | This is the last topic
clsConnectionProvider Events | This is the first topic | This is the last topic

See Also

Reference

clsConnectionProvider Class


ActionException Attached Properties

ActionException Attached Properties

ActionException Attached Properties | This is the first topic | This is the last topic
ActionException Attached Properties | This is the first topic | This is the last topic

See Also

Reference

ActionException Class


clsDokumenttyp Attached Properties

clsDokumenttyp Attached Properties

clsDokumenttyp Attached Properties | This is the first topic | This is the last topic
clsDokumenttyp Attached Properties | This is the first topic | This is the last topic

See Also

Reference

clsDokumenttyp Class


clsDokumenttyp Events

clsDokumenttyp Events

clsDokumenttyp Events | This is the first topic | This is the last topic
clsDokumenttyp Events | This is the first topic | This is the last topic

See Also

Reference

clsDokumenttyp Class


Parameter Attached Properties

Parameter Attached Properties

Parameter Attached Properties | This is the first topic | This is the last topic
Parameter Attached Properties | This is the first topic | This is the last topic

See Also

Reference

Parameter Structure


Parameter Events

Parameter Events

Parameter Events | This is the first topic | This is the last topic
Parameter Events | This is the first topic | This is the last topic

See Also

Reference

Parameter Structure


Parameter Methods

Parameter Methods

Parameter Methods | This is the first topic | This is the last topic
Parameter Methods | This is the first topic | This is the last topic

See Also

Reference

Parameter Structure


clsJournaleintrag Attached Properties

clsJournaleintrag Attached Properties

clsJournaleintrag Attached Properties | This is the first topic | This is the last topic
clsJournaleintrag Attached Properties | This is the first topic | This is the last topic

See Also

Reference

clsJournaleintrag Class


clsJournaleintrag Events

clsJournaleintrag Events

clsJournaleintrag Events | This is the first topic | This is the last topic
clsJournaleintrag Events | This is the first topic | This is the last topic

See Also

Reference

clsJournaleintrag Class


clsKey_tabelle Attached Properties

clsKey_tabelle Attached Properties

clsKey_tabelle Attached Properties | This is the first topic | This is the last topic
clsKey_tabelle Attached Properties | This is the first topic | This is the last topic

See Also

Reference

clsKey_tabelle Class


clsKey_tabelle Events

clsKey_tabelle Events

clsKey_tabelle Events | This is the first topic | This is the last topic
clsKey_tabelle Events | This is the first topic | This is the last topic

See Also

Reference

clsKey_tabelle Class


AvaloqDokumentWert Attached Properties

AvaloqDokumentWert Attached Properties

AvaloqDokumentWert Attached Properties | This is the first topic | This is the last topic
AvaloqDokumentWert Attached Properties | This is the first topic | This is the last topic

See Also

Reference

AvaloqDokumentWert Class


AvaloqDokumentWert Events

AvaloqDokumentWert Events

AvaloqDokumentWert Events | This is the first topic | This is the last topic
AvaloqDokumentWert Events | This is the first topic | This is the last topic

See Also

Reference

AvaloqDokumentWert Class


EDKB12WS.edokaDB Members

EDKB12WS.edokaDB Members

EDKB12WS.edokaDB Members | This is the first topic | This is the last topic
EDKB12WS.edokaDB Members | This is the first topic | This is the last topic

The following tables list the members exposed by the EDKB12WS.edokaDB type.

Classes

 | Name | Description
Supported by the .NET Compact Framework. | clsMyMitarbeiter |
Supported by the .NET Compact Framework. | clsOffice_Vorlage_Datei |

Top

See Also

Reference

EDKB12WS.edokaDB Namespace


clsMyMitarbeiter Attached Properties

clsMyMitarbeiter Attached Properties

clsMyMitarbeiter Attached Properties | This is the first topic | This is the last topic
clsMyMitarbeiter Attached Properties | This is the first topic | This is the last topic

See Also

Reference

clsMyMitarbeiter Class


clsMyMitarbeiter Events

clsMyMitarbeiter Events

clsMyMitarbeiter Events | This is the first topic | This is the last topic
clsMyMitarbeiter Events | This is the first topic | This is the last topic

See Also

Reference

clsMyMitarbeiter Class


clsDivFnkt Attached Properties

clsDivFnkt Attached Properties

clsDivFnkt Attached Properties | This is the first topic | This is the last topic
clsDivFnkt Attached Properties | This is the first topic | This is the last topic

See Also

Reference

clsDivFnkt Class


clsDivFnkt Events

clsDivFnkt Events

clsDivFnkt Events | This is the first topic | This is the last topic
clsDivFnkt Events | This is the first topic | This is the last topic

See Also

Reference

clsDivFnkt Class


clsDivFnkt Properties

clsDivFnkt Properties

clsDivFnkt Properties | This is the first topic | This is the last topic
clsDivFnkt Properties | This is the first topic | This is the last topic

See Also

Reference

clsDivFnkt Class


clsVorlagenfeld Attached Properties

clsVorlagenfeld Attached Properties

clsVorlagenfeld Attached Properties | This is the first topic | This is the last topic
clsVorlagenfeld Attached Properties | This is the first topic | This is the last topic

See Also

Reference

clsVorlagenfeld Class


clsVorlagenfeld Events

clsVorlagenfeld Events

clsVorlagenfeld Events | This is the first topic | This is the last topic
clsVorlagenfeld Events | This is the first topic | This is the last topic

See Also

Reference

clsVorlagenfeld Class


Globals Attached Properties

Globals Attached Properties

Globals Attached Properties | This is the first topic | This is the last topic
Globals Attached Properties | This is the first topic | This is the last topic

See Also

Reference

Globals Class


Globals Events

Globals Events

Globals Events | This is the first topic | This is the last topic
Globals Events | This is the first topic | This is the last topic

See Also

Reference

Globals Class


Globals Properties

Globals Properties

Globals Properties | This is the first topic | This is the last topic
Globals Properties | This is the first topic | This is the last topic

See Also

Reference

Globals Class


ModMain Attached Properties

ModMain Attached Properties

ModMain Attached Properties | This is the first topic | This is the last topic
ModMain Attached Properties | This is the first topic | This is the last topic

See Also

Reference

ModMain Class


ModMain Events

ModMain Events

ModMain Events | This is the first topic | This is the last topic
ModMain Events | This is the first topic | This is the last topic

See Also

Reference

ModMain Class


ModMain Properties

ModMain Properties

ModMain Properties | This is the first topic | This is the last topic
ModMain Properties | This is the first topic | This is the last topic

See Also

Reference

ModMain Class


ProjectInstaller.Dispose Method

ProjectInstaller.Dispose Method

ProjectInstaller.Dispose Method | This is the first topic | This is the last topic
ProjectInstaller.Dispose Method | This is the first topic | This is the last topic

Overload List

Name | Description
Dispose(bool) |
Dispose | (System.ComponentModel.Component).

See Also

Reference

ProjectInstaller Class
ProjectInstaller ProjectInstaller Members


ProjectInstaller Attached Properties

ProjectInstaller Attached Properties

ProjectInstaller Attached Properties | This is the first topic | This is the last topic
ProjectInstaller Attached Properties | This is the first topic | This is the last topic

See Also

Reference

ProjectInstaller Class


ProjectInstaller.Dispose Method

ProjectInstaller.Dispose Method

ProjectInstaller.Dispose Method | This is the first topic | This is the last topic
ProjectInstaller.Dispose Method | This is the first topic | This is the last topic

Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

<System.Diagnostics.DebuggerNonUserCode()> _
Protected Overrides Sub Dispose( _
ByVal disposing As Boolean _
)

C#

[System.Diagnostics.DebuggerNonUserCode()]
protected override System.Void Dispose(
booldisposing
)

C++

[System.Diagnostics.DebuggerNonUserCode()]
protected:
System::Void Dispose(
booldisposing
)

JScript

protected
System.Diagnostics.DebuggerNonUserCode()
function Dispose(
disposing : boolean
);

Parameters

disposing

Source code

Visual Basic

Copy Code Copy Code

Protected Overrides Sub Dispose(ByVal disposing As Boolean)
If disposing AndAlso components IsNot Nothing Then
components.Dispose()
End If
MyBase.Dispose(disposing)
End Sub

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

ProjectInstaller Class
ProjectInstaller ProjectInstaller Members


Service1.Dispose Method

Service1.Dispose Method

Service1.Dispose Method | This is the first topic | This is the last topic
Service1.Dispose Method | This is the first topic | This is the last topic

Overload List

Name | Description
Dispose(bool) |
Dispose | (System.ComponentModel.Component).

See Also

Reference

Service1 Class
Service1 Service1 Members


EDKB12WS Members

EDKB12WS Members

EDKB12WS Members | This is the first topic | This is the last topic
EDKB12WS Members | This is the first topic | This is the last topic

The following tables list the members exposed by the EDKB12WS type.

Classes

 | Name | Description
Supported by the .NET Compact Framework. | Action |
Supported by the .NET Compact Framework. | ActionException |
Supported by the .NET Compact Framework. | AvaloqDokumentWert |
Supported by the .NET Compact Framework. | AvaloqDokumentWerte |
Supported by the .NET Compact Framework. | Parameters |
Supported by the .NET Compact Framework. | ProjectInstaller |
Supported by the .NET Compact Framework. | Service1 |
Supported by the .NET Compact Framework. | clsDivFnkt |
Internal (Friend) class Supported by the .NET Compact Framework. | Globals |
Internal (Friend) class Supported by the .NET Compact Framework. | ModMain |

Top

Structures

 | Name | Description
Supported by the .NET Compact Framework. | Parameter | Struct für einzelne Parameter

Top

Enumerations

 | Name | Description
Supported by the .NET Compact Framework. | ActionType |

Top

See Also

Reference

EDKB12WS Namespace


clsMitarbeiter Attached Properties

clsMitarbeiter Attached Properties

clsMitarbeiter Attached Properties | This is the first topic | This is the last topic
clsMitarbeiter Attached Properties | This is the first topic | This is the last topic

See Also

Reference

clsMitarbeiter Class


clsMitarbeiter Events

clsMitarbeiter Events

clsMitarbeiter Events | This is the first topic | This is the last topic
clsMitarbeiter Events | This is the first topic | This is the last topic

See Also

Reference

clsMitarbeiter Class


clsMyDokumentDaten Attached Properties

clsMyDokumentDaten Attached Properties

clsMyDokumentDaten Attached Properties | This is the first topic | This is the last topic
clsMyDokumentDaten Attached Properties | This is the first topic | This is the last topic

See Also

Reference

clsMyDokumentDaten Class


clsMyDokumentDaten Events

clsMyDokumentDaten Events

clsMyDokumentDaten Events | This is the first topic | This is the last topic
clsMyDokumentDaten Events | This is the first topic | This is the last topic

See Also

Reference

clsMyDokumentDaten Class


clsMyKey_Tabelle Attached Properties

clsMyKey_Tabelle Attached Properties

clsMyKey_Tabelle Attached Properties | This is the first topic | This is the last topic
clsMyKey_Tabelle Attached Properties | This is the first topic | This is the last topic

See Also

Reference

clsMyKey_Tabelle Class


clsMyKey_Tabelle Events

clsMyKey_Tabelle Events

clsMyKey_Tabelle Events | This is the first topic | This is the last topic
clsMyKey_Tabelle Events | This is the first topic | This is the last topic

See Also

Reference

clsMyKey_Tabelle Class


clsMyPartner Attached Properties

clsMyPartner Attached Properties

clsMyPartner Attached Properties | This is the first topic | This is the last topic
clsMyPartner Attached Properties | This is the first topic | This is the last topic

See Also

Reference

clsMyPartner Class


clsMyPartner Events

clsMyPartner Events

clsMyPartner Events | This is the first topic | This is the last topic
clsMyPartner Events | This is the first topic | This is the last topic

See Also

Reference

clsMyPartner Class


clsMyPartner Properties

clsMyPartner Properties

clsMyPartner Properties | This is the first topic | This is the last topic
clsMyPartner Properties | This is the first topic | This is the last topic

See Also

Reference

clsMyPartner Class


clsMyPartner Fields

clsMyPartner Fields

clsMyPartner Fields | This is the first topic | This is the last topic
clsMyPartner Fields | This is the first topic | This is the last topic

See Also

Reference

clsMyPartner Class


clsOffice_vorlage Attached Properties

clsOffice_vorlage Attached Properties

clsOffice_vorlage Attached Properties | This is the first topic | This is the last topic
clsOffice_vorlage Attached Properties | This is the first topic | This is the last topic

See Also

Reference

clsOffice_vorlage Class


clsOffice_vorlage Events

clsOffice_vorlage Events

clsOffice_vorlage Events | This is the first topic | This is the last topic
clsOffice_vorlage Events | This is the first topic | This is the last topic

See Also

Reference

clsOffice_vorlage Class


clsStatushistory Attached Properties

clsStatushistory Attached Properties

clsStatushistory Attached Properties | This is the first topic | This is the last topic
clsStatushistory Attached Properties | This is the first topic | This is the last topic

See Also

Reference

clsStatushistory Class


clsStatushistory Events

clsStatushistory Events

clsStatushistory Events | This is the first topic | This is the last topic
clsStatushistory Events | This is the first topic | This is the last topic

See Also

Reference

clsStatushistory Class


Service1 Attached Properties

Service1 Attached Properties

Service1 Attached Properties | This is the first topic | This is the last topic
Service1 Attached Properties | This is the first topic | This is the last topic

See Also

Reference

Service1 Class


Service1.OnStart Method

Service1.OnStart Method

Service1.OnStart Method | This is the first topic | This is the last topic
Service1.OnStart Method | This is the first topic | This is the last topic

Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

Protected Overrides Sub OnStart( _
ByVal args As String() _
)

C#

protected override System.Void OnStart(
string[] args
)

C++

protected:
System::Void OnStart(
array< String^ >^ args
)

JScript

protected function OnStart(
args : String[]
);

Parameters

args

Source code

Visual Basic

Copy Code Copy Code

Protected Overrides Sub OnStart(ByVal args() As String)
Globals.Param = New Parameters
CheckTimer.Interval = Globals.Param.TimerInterval
CheckTimer.Start()
CheckTimer.Enabled = True

End Sub

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

Service1 Class
Service1 Service1 Members


Service1.Dispose Method

Service1.Dispose Method

Service1.Dispose Method | This is the first topic | This is the last topic
Service1.Dispose Method | This is the first topic | This is the last topic

Assembly: EDKB12WS (in EDKB12WS.exe)

Syntax

Visual Basic

<System.Diagnostics.DebuggerNonUserCode()> _
Protected Overrides Sub Dispose( _
ByVal disposing As Boolean _
)

C#

[System.Diagnostics.DebuggerNonUserCode()]
protected override System.Void Dispose(
booldisposing
)

C++

[System.Diagnostics.DebuggerNonUserCode()]
protected:
System::Void Dispose(
booldisposing
)

JScript

protected
System.Diagnostics.DebuggerNonUserCode()
function Dispose(
disposing : boolean
);

Parameters

disposing

Source code

Visual Basic

Copy Code Copy Code

Protected Overrides Sub Dispose(ByVal disposing As Boolean)
If disposing AndAlso components IsNot Nothing Then
components.Dispose()
End If
MyBase.Dispose(disposing)
End Sub

Platforms

Windows 8, Windows Server 2012, Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows XP SP2 x64 Edition, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

The .NET Framework does not support all versions of every platform. For a list of the supported versions, see System Requirements.

Version Information

.NET Framework

Supported in: 4.5, 4, 3.5, 3.0, 2.0, 1.1, 1.0

.NET Compact Framework

Supported in: 3.5, 2.0, 1.0

XNA Framework

Supported in: 3.0, 2.0, 1.0

See Also

Reference

Service1 Class
Service1 Service1 Members