DataAccess Reference

DataAccess

2006 by Zubler & Partner AG


EDOKALib.DataAccess Namespace

Namespace EDOKALib.DataAccess

Classes

class Anwendung | DataAccess Klasse von der Tabelle Anwendung
class Config |
class Dokumentart | Datenzugriff auf Tabelle dokumentart
class Dokumenttyp | Datenzugriff auf Tabelle dokumenttyp
class Funktionsgruppe | Datenzugriff auf Tabelle Funktionsgruppe
class Klassifizierung | Datenzugriff auf Tabelle Klassifizierung
class Meldungstext | Datenzugriff auf Tabelle Meldungstext
class Mitarbeiter | Datenzugriff auf Tabelle Mitarbeiter
class MitarbeiterFunktionsgruppe | Datenzugriff auf Tabelle mitarbeiter_funktionsgruppe
class NullHandler |
class OfficeVorlage | Datenzugriff auf Tabelle office_vorlage
class Parameter | Datenzugriff auf die Tabelle Parameter
class Spalten | Datenzugriff auf Tabelle spalten
class Team | Datenzugriff auf Tabelle team
class TeamMitarbeiter | Datenzugriff auf Tabelle team_mitarbeiter


EDOKALib.DataAccess Members

EDOKALib.DataAccess overview

Classes

class Anwendung | DataAccess Klasse von der Tabelle Anwendung
class Config |
class Dokumentart | Datenzugriff auf Tabelle dokumentart
class Dokumenttyp | Datenzugriff auf Tabelle dokumenttyp
class Funktionsgruppe | Datenzugriff auf Tabelle Funktionsgruppe
class Klassifizierung | Datenzugriff auf Tabelle Klassifizierung
class Meldungstext | Datenzugriff auf Tabelle Meldungstext
class Mitarbeiter | Datenzugriff auf Tabelle Mitarbeiter
class MitarbeiterFunktionsgruppe | Datenzugriff auf Tabelle mitarbeiter_funktionsgruppe
class NullHandler |
class OfficeVorlage | Datenzugriff auf Tabelle office_vorlage
class Parameter | Datenzugriff auf die Tabelle Parameter
class Spalten | Datenzugriff auf Tabelle spalten
class Team | Datenzugriff auf Tabelle team
class TeamMitarbeiter | Datenzugriff auf Tabelle team_mitarbeiter

See Also

EDOKALib.DataAccess Namespace


Anwendung Class

DataAccess Klasse von der Tabelle Anwendung

For a list of all members of this type, see Anwendung Members.

System.Object
EDOKALib.DataAccess.Anwendung

Public Class Anwendung

Requirements

Namespace: DataAccess

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKALib.DataAccess (in EDOKALib.DataAccess.dll)

See Also

Anwendung Members


Anwendung Members

Anwendung overview

Methods

method Add | erstellt eine anwendung
method Delete | Löscht eine bestehende anwendung
method GetAnwendung | gibt eine anwendung zurück
method List | gibt eine liste aller anwendungen zurück
method Update | aktualisiert eine anwendung

See Also

Anwendung Class


Anwendung Methods

Anwendung overview

Methods

method Add | erstellt eine anwendung
method Delete | Löscht eine bestehende anwendung
method GetAnwendung | gibt eine anwendung zurück
method List | gibt eine liste aller anwendungen zurück
method Update | aktualisiert eine anwendung

See Also

Anwendung Class


Anwendung.Add Method

erstellt eine anwendung

Public Shared Function Add( _
   ByRef anwendungNr As Integer, _
   ByVal bezeichnung As String, _
   ByVal beschreibung As String, _
   ByVal mandantnr As Integer, _
   ByVal aktiv As Boolean, _
   ByVal mutierer As Integer _
) As Integer

Parameters

anwendungNr
Required.
bezeichnung
Required.
beschreibung
Required.
mandantnr
Required.
aktiv
Required.
mutierer
Required.

Returns

error

Source code

[Visual Basic]
    Public Shared Function Add(ByRef anwendungNr As Integer, ByVal bezeichnung As String, _
        ByVal beschreibung As String, ByVal mandantnr As Integer, ByVal aktiv As Boolean, _
        ByVal mutierer As Integer) As Integer

        Dim sqlConn As New SqlConnection()
        Dim sqlCmd As New SqlCommand()

        Try
            sqlConn.ConnectionString = Common.Datenbank.GetDSN()
            sqlCmd.CommandText = "sp_InsAnwendung"
            sqlCmd.CommandType = CommandType.StoredProcedure
            sqlCmd.Connection = sqlConn

            sqlCmd.Parameters.Add(New SqlParameter("@bezeichnung", NullHandler.CToSqlString(bezeichnung)))
            sqlCmd.Parameters.Add(New SqlParameter("@beschreibung", NullHandler.CToSqlString(beschreibung)))
            sqlCmd.Parameters.Add(New SqlParameter("@mandantnr", NullHandler.CToSqlInt(mandantnr)))
            sqlCmd.Parameters.Add(New SqlParameter("@Aktiv", aktiv))
            sqlCmd.Parameters.Add(New SqlParameter("@mutierer", mutierer))

            sqlCmd.Parameters.Add(New SqlParameter("@AnwendungNr", 0))
            sqlCmd.Parameters.Add(New SqlParameter("@Return", DBNull.Value))
            sqlCmd.Parameters("@AnwendungNr").Direction = ParameterDirection.Output
            sqlCmd.Parameters("@Return").Direction = ParameterDirection.ReturnValue

            sqlConn.Open()
            sqlCmd.ExecuteNonQuery()

            If CInt(sqlCmd.Parameters("@Return").Value) = 0 Then
                anwendungnr = CInt(sqlCmd.Parameters("@AnwendungNr").Value)
            End If

            Return CInt(sqlCmd.Parameters("@Return").Value)

        Catch ex As Exception
            TKBLib.Errorhandling.TraceHelper.Msg("EDOKALib.DA.Anwendung.Add", ex.Message + " " + ex.StackTrace, TraceLevel.Error)
            Throw ex
        Finally
            sqlConn.Dispose()
            sqlCmd.Dispose()
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Anwendung


Anwendung.Delete Method

Löscht eine bestehende anwendung

Public Shared Function Delete( _
   ByVal anwendungNr As Integer _
) As Integer

Parameters

anwendungNr
Required.

Returns

error

Source code

[Visual Basic]
    Public Shared Function Delete(ByVal anwendungNr As Integer) As Integer
        Dim sqlConn As New SqlConnection()
        Dim sqlCmd As New SqlCommand()

        Try
            sqlConn.ConnectionString = Common.Datenbank.GetDSN()
            sqlCmd.CommandText = "sp_DelAnwendung"
            sqlCmd.CommandType = CommandType.StoredProcedure
            sqlCmd.Connection = sqlConn

            sqlCmd.Parameters.Add(New SqlParameter("@@anwendungnr", anwendungNr))
            sqlCmd.Parameters.Add(New SqlParameter("@Return", DBNull.Value))
            sqlCmd.Parameters("@Return").Direction = ParameterDirection.ReturnValue

            sqlConn.Open()
            sqlCmd.ExecuteNonQuery()

            Return CInt(sqlCmd.Parameters("@Return").Value)

        Catch ex As Exception
            TKBLib.Errorhandling.TraceHelper.Msg("EDOKALib.DA.Anwendung.Delete", ex.Message + " " + ex.StackTrace, TraceLevel.Error)
            Throw ex
        Finally
            sqlConn.Dispose()
            sqlCmd.Dispose()
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Anwendung


Anwendung.GetAnwendung Method

gibt eine anwendung zurück

Public Shared Sub GetAnwendung( _
   ByRef ds As DataSet, _
   ByVal anwendungsNr As Integer _
)

Parameters

ds
Required. für datenrückgabe
anwendungsNr
Required.

Source code

[Visual Basic]
    Public Shared Sub GetAnwendung(ByRef ds As DataSet, ByVal anwendungsNr As Integer)
        Dim sqlConn As New SqlConnection()
        Dim sqlCmd As New SqlCommand()
        Dim da As New SqlDataAdapter()

        Try
            sqlConn.ConnectionString = Common.Datenbank.GetDSN()
            sqlCmd.CommandText = "sp_GetAnwendung"
            sqlCmd.CommandType = CommandType.StoredProcedure
            sqlCmd.Connection = sqlConn

            sqlCmd.Parameters.Add(New SqlParameter("@DokumentartNr", anwendungsNr))
            da.SelectCommand = sqlCmd
            da.Fill(ds, "Anwendung")

        Catch ex As Exception
            TKBLib.Errorhandling.TraceHelper.Msg("EDOKALib.DA.Dokumentart.GetAnwendung", ex.Message + " " + ex.StackTrace, TraceLevel.Error)
            Throw ex
        Finally
            sqlConn.Dispose()
            sqlCmd.Dispose()
            da.Dispose()
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Anwendung


Anwendung.List Method

gibt eine liste aller anwendungen zurück

Public Shared Sub List( _
   ByRef ds As DataSet, _
   ByVal aktiv As Integer _
)

Parameters

ds
Required. für datenrückgabe
aktiv
Required. 1 nur aktive; 0 nur inaktive; -1 alle

Source code

[Visual Basic]
    Public Shared Sub List(ByRef ds As DataSet, ByVal aktiv As Integer)
        Dim sqlConn As New SqlConnection()
        Dim sqlCmd As New SqlCommand()
        Dim da As New SqlDataAdapter()

        Try
            sqlConn.ConnectionString = Common.Datenbank.GetDSN()
            sqlCmd.CommandText = "sp_ListAnwendung"
            sqlCmd.CommandType = CommandType.StoredProcedure
            sqlCmd.Connection = sqlConn

            If aktiv <> -1 Then
                sqlCmd.Parameters.Add(New SqlParameter("@Aktiv", aktiv))
            End If

            da.SelectCommand = sqlCmd
            da.Fill(ds, "Anwendungen")

        Catch ex As Exception
            TKBLib.Errorhandling.TraceHelper.Msg("EDOKALib.DA.Anwendung.List", ex.Message + " " + ex.StackTrace, TraceLevel.Error)
            Throw ex
        Finally
            sqlConn.Dispose()
            sqlCmd.Dispose()
            da.Dispose()
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Anwendung


Anwendung.Update Method

aktualisiert eine anwendung

Public Shared Function Update( _
   ByVal anwendungNr As Integer, _
   ByVal bezeichnung As String, _
   ByVal beschreibung As String, _
   ByVal mandantnr As Integer, _
   ByVal aktiv As Boolean, _
   ByVal mutierer As Integer _
) As Integer

Parameters

anwendungNr
Required. kritetrium (wird nicht aktualisiert)
bezeichnung
Required.
beschreibung
Required.
mandantnr
Required.
aktiv
Required.
mutierer
Required.

Returns

error

Source code

[Visual Basic]
    Public Shared Function Update(ByVal anwendungNr As Integer, ByVal bezeichnung As String, _
            ByVal beschreibung As String, ByVal mandantnr As Integer, ByVal aktiv As Boolean, _
            ByVal mutierer As Integer) As Integer

        Dim sqlConn As New SqlConnection()
        Dim sqlCmd As New SqlCommand()

        Try
            sqlConn.ConnectionString = Common.Datenbank.GetDSN()
            sqlCmd.CommandText = "sp_SetAnwendung"
            sqlCmd.CommandType = CommandType.StoredProcedure
            sqlCmd.Connection = sqlConn

            sqlCmd.Parameters.Add(New SqlParameter("@AnwendungNr", anwendungNr))
            sqlCmd.Parameters.Add(New SqlParameter("@bezeichnung", NullHandler.CToSqlString(bezeichnung)))
            sqlCmd.Parameters.Add(New SqlParameter("@beschreibung", NullHandler.CToSqlString(beschreibung)))
            sqlCmd.Parameters.Add(New SqlParameter("@mandantnr", NullHandler.CToSqlInt(mandantnr)))
            sqlCmd.Parameters.Add(New SqlParameter("@Aktiv", aktiv))
            sqlCmd.Parameters.Add(New SqlParameter("@mutierer", mutierer))

            sqlCmd.Parameters.Add(New SqlParameter("@Return", DBNull.Value))
            sqlCmd.Parameters("@Return").Direction = ParameterDirection.ReturnValue

            sqlConn.Open()
            sqlCmd.ExecuteNonQuery()

            Return CInt(sqlCmd.Parameters("@Return").Value)

        Catch ex As Exception
            TKBLib.Errorhandling.TraceHelper.Msg("EDOKALib.DA.Anwendung.Update", ex.Message + " " + ex.StackTrace, TraceLevel.Error)
            Throw ex
        Finally
            sqlConn.Dispose()
            sqlCmd.Dispose()
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Anwendung


Config Class

For a list of all members of this type, see Config Members.

System.Object
EDOKALib.DataAccess.Config

Public Class Config

Requirements

Namespace: DataAccess

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKALib.DataAccess (in EDOKALib.DataAccess.dll)

See Also

Config Members


Config Members

Config overview

Properties

property NullReplacer

Fields

field _firstTime
field _nullReplacer

See Also

Config Class


Config Properties

Config overview

Properties

property NullReplacer

See Also

Config Class


Config.NullReplacer Property

Public Shared ReadOnly Property NullReplacer() As Integer

Source code

[Visual Basic]
    Public Shared ReadOnly Property NullReplacer() As Integer
        Get
            Try
                If _firstTime Then 'load from db
                    Dim ds As New DataSet()
                    Parameter.GetParameter(ds, 0, "NullReplaceValue")
                    If ds.Tables.Count > 0 Then
                        If ds.Tables(0).Rows.Count > 0 Then
                            _nullReplacer = CInt(ds.Tables(0).Rows(0)("Wert"))
                        End If
                    End If
                End If
                Return _nullReplacer
            Catch ex As Exception
                TKBLib.Errorhandling.TraceHelper.Msg("EDOKALib.DA.Config.NullReplacer", ex.Message + " " + ex.StackTrace, TraceLevel.Error)
                Throw ex
            End Try
        End Get
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Config


Config Fields

Config overview

Fields

field _firstTime
field _nullReplacer

See Also

Config Class


_firstTime Variable

Private Shared _firstTime As Boolean = True

Source code

[Visual Basic]
    Private Shared _firstTime As Boolean = True

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Config


_nullReplacer Variable

Private Shared _nullReplacer As Integer

Source code

[Visual Basic]
    Private Shared _nullReplacer As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Config


Dokumentart Class

Datenzugriff auf Tabelle dokumentart

For a list of all members of this type, see Dokumentart Members.

System.Object
EDOKALib.DataAccess.Dokumentart

Public Class Dokumentart

Requirements

Namespace: DataAccess

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKALib.DataAccess (in EDOKALib.DataAccess.dll)

See Also

Dokumentart Members


Dokumentart Members

Dokumentart overview

Methods

method Add | erstellt eine neue dokumentart
method Delete | Löscht eine bestehende dokumentenArt
method GetDokumentart | gibt eine dokumentart zurück
method List | gibt eine liste aller dokumentarten zurück
method Update | updatet eine dokumentenart

See Also

Dokumentart Class


Dokumentart Methods

Dokumentart overview

Methods

method Add | erstellt eine neue dokumentart
method Delete | Löscht eine bestehende dokumentenArt
method GetDokumentart | gibt eine dokumentart zurück
method List | gibt eine liste aller dokumentarten zurück
method Update | updatet eine dokumentenart

See Also

Dokumentart Class


Dokumentart.Add Method

erstellt eine neue dokumentart

Public Shared Function Add( _
   ByRef dokumentartNr As Integer, _
   ByVal bezeichnung As String, _
   ByVal parentId As Integer, _
   ByVal sort As Integer, _
   ByVal imageIndex As Integer, _
   ByVal imageIndexOpen As Integer, _
   ByVal beschreibung As String, _
   ByVal mandantNr As Integer, _
   ByVal sprache As Integer, _
   ByVal aktiv As Boolean, _
   ByVal mutierer As Integer, _
   ByVal coldApplication As String, _
   ByVal coldBezeichnung As String _
) As Integer

Parameters

dokumentartNr
Required. gibt den neuen primarykey zurück
bezeichnung
Required.
parentId
Required.
sort
Required.
imageIndex
Required.
imageIndexOpen
Required.
beschreibung
Required.
mandantNr
Required.
sprache
Required.
aktiv
Required.
mutierer
Required.
coldApplication
Required.
coldBezeichnung
Required.

Returns

error

Source code

[Visual Basic]
    Public Shared Function Add(ByRef dokumentartNr As Integer, ByVal bezeichnung As String, ByVal parentId As Integer, ByVal sort As Integer, _
        ByVal imageIndex As Integer, ByVal imageIndexOpen As Integer, ByVal beschreibung As String, ByVal mandantNr As Integer, ByVal sprache As Integer, _
        ByVal aktiv As Boolean, ByVal mutierer As Integer, ByVal coldApplication As String, ByVal coldBezeichnung As String) As Integer

        Dim sqlConn As New SqlConnection()
        Dim sqlCmd As New SqlCommand()

        Try
            sqlConn.ConnectionString = Common.Datenbank.GetDSN()
            sqlCmd.CommandText = "sp_InsDokumentart"
            sqlCmd.CommandType = CommandType.StoredProcedure
            sqlCmd.Connection = sqlConn

            sqlCmd.Parameters.Add(New SqlParameter("@Bezeichnung", NullHandler.CToSqlString(bezeichnung)))
            sqlCmd.Parameters.Add(New SqlParameter("@ParentId", NullHandler.CToSqlInt(parentId)))
            sqlCmd.Parameters.Add(New SqlParameter("@Sort", NullHandler.CToSqlInt(sort)))
            sqlCmd.Parameters.Add(New SqlParameter("@ImageIndex", NullHandler.CToSqlInt(imageIndex)))
            sqlCmd.Parameters.Add(New SqlParameter("@ImageIndexOpen", NullHandler.CToSqlInt(imageIndexOpen)))
            sqlCmd.Parameters.Add(New SqlParameter("@Beschreibung", NullHandler.CToSqlString(beschreibung)))
            sqlCmd.Parameters.Add(New SqlParameter("@MandantNr", mandantNr))
            sqlCmd.Parameters.Add(New SqlParameter("@Sprache", sprache))
            sqlCmd.Parameters.Add(New SqlParameter("@Aktiv", aktiv))
            sqlCmd.Parameters.Add(New SqlParameter("@Mutierer", NullHandler.CToSqlInt(mutierer)))
            sqlCmd.Parameters.Add(New SqlParameter("@ColdApplication", NullHandler.CToSqlString(coldApplication)))
            sqlCmd.Parameters.Add(New SqlParameter("@ColdBezeichnung", NullHandler.CToSqlString(coldBezeichnung)))
            sqlCmd.Parameters.Add(New SqlParameter("@DokumentartNr", 0))
            sqlCmd.Parameters.Add(New SqlParameter("@Return", DBNull.Value))
            sqlCmd.Parameters("@DokumentartNr").Direction = ParameterDirection.Output
            sqlCmd.Parameters("@Return").Direction = ParameterDirection.ReturnValue

            sqlConn.Open()
            sqlCmd.ExecuteNonQuery()

            If CInt(sqlCmd.Parameters("@Return").Value) = 0 Then
                dokumentartNr = CInt(sqlCmd.Parameters("@DokumentartNr").Value)
            End If

            Return CInt(sqlCmd.Parameters("@Return").Value)

        Catch ex As Exception
            TKBLib.Errorhandling.TraceHelper.Msg("EDOKALib.DA.Dokumentart.Add", ex.Message + " " + ex.StackTrace, TraceLevel.Error)
            Throw ex
        Finally
            sqlConn.Dispose()
            sqlCmd.Dispose()
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Dokumentart


Dokumentart.Delete Method

Löscht eine bestehende dokumentenArt

Public Shared Function Delete( _
   ByVal dokumentartNr As Integer _
) As Integer

Parameters

dokumentartNr
Required.

Returns

error

Source code

[Visual Basic]
    Public Shared Function Delete(ByVal dokumentartNr As Integer) As Integer
        Dim sqlConn As New SqlConnection()
        Dim sqlCmd As New SqlCommand()

        Try
            sqlConn.ConnectionString = Common.Datenbank.GetDSN()
            sqlCmd.CommandText = "sp_DelDokumentart"
            sqlCmd.CommandType = CommandType.StoredProcedure
            sqlCmd.Connection = sqlConn

            sqlCmd.Parameters.Add(New SqlParameter("@DokumentartNr", dokumentartNr))
            sqlCmd.Parameters.Add(New SqlParameter("@Return", DBNull.Value))
            sqlCmd.Parameters("@Return").Direction = ParameterDirection.ReturnValue

            sqlConn.Open()
            sqlCmd.ExecuteNonQuery()

            Return CInt(sqlCmd.Parameters("@Return").Value)

        Catch ex As Exception
            TKBLib.Errorhandling.TraceHelper.Msg("EDOKALib.DA.Dokumentart.Delete", ex.Message + " " + ex.StackTrace, TraceLevel.Error)
            Throw ex
        Finally
            sqlConn.Dispose()
            sqlCmd.Dispose()
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Dokumentart


Dokumentart.GetDokumentart Method

gibt eine dokumentart zurück

Public Shared Sub GetDokumentart( _
   ByRef ds As DataSet, _
   ByVal dokumentartNr As Integer _
)

Parameters

ds
Required. für datenrückgabe
dokumentartNr
Required.

Source code

[Visual Basic]
    Public Shared Sub GetDokumentart(ByRef ds As DataSet, ByVal dokumentartNr As Integer)
        Dim sqlConn As New SqlConnection()
        Dim sqlCmd As New SqlCommand()
        Dim da As New SqlDataAdapter()

        Try
            sqlConn.ConnectionString = Common.Datenbank.GetDSN()
            sqlCmd.CommandText = "sp_GetDokumentart"
            sqlCmd.CommandType = CommandType.StoredProcedure
            sqlCmd.Connection = sqlConn

            sqlCmd.Parameters.Add(New SqlParameter("@DokumentartNr", dokumentartNr))
            da.SelectCommand = sqlCmd
            da.Fill(ds, "Dokumentart")

        Catch ex As Exception
            TKBLib.Errorhandling.TraceHelper.Msg("EDOKALib.DA.Dokumentart.GetDokumentart", ex.Message + " " + ex.StackTrace, TraceLevel.Error)
            Throw ex
        Finally
            sqlConn.Dispose()
            sqlCmd.Dispose()
            da.Dispose()
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Dokumentart


Dokumentart.List Method

gibt eine liste aller dokumentarten zurück

Public Shared Sub List( _
   ByRef ds As DataSet, _
   ByVal aktiv As Integer _
)

Parameters

ds
Required. für datenrückgabe
aktiv
Required. 1 nur aktive; 0 nur inaktive; -1 alle

Source code

[Visual Basic]
    Public Shared Sub List(ByRef ds As DataSet, ByVal aktiv As Integer)
        Dim sqlConn As New SqlConnection()
        Dim sqlCmd As New SqlCommand()
        Dim da As New SqlDataAdapter()

        Try
            sqlConn.ConnectionString = Common.Datenbank.GetDSN()
            sqlCmd.CommandText = "sp_ListDokumentart"
            sqlCmd.CommandType = CommandType.StoredProcedure
            sqlCmd.Connection = sqlConn

            If aktiv <> -1 Then
                sqlCmd.Parameters.Add(New SqlParameter("@Aktiv", aktiv))
            End If

            da.SelectCommand = sqlCmd
            da.Fill(ds, "Dokumentarten")

        Catch ex As Exception
            TKBLib.Errorhandling.TraceHelper.Msg("EDOKALib.DA.Dokumentart.List", ex.Message + " " + ex.StackTrace, TraceLevel.Error)
            Throw ex
        Finally
            sqlConn.Dispose()
            sqlCmd.Dispose()
            da.Dispose()
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Dokumentart


Dokumentart.Update Method

updatet eine dokumentenart

Public Shared Function Update( _
   ByVal dokumentartNr As Integer, _
   ByVal bezeichnung As String, _
   ByVal parentId As Integer, _
   ByVal sort As Integer, _
   ByVal imageIndex As Integer, _
   ByVal imageIndexOpen As Integer, _
   ByVal beschreibung As String, _
   ByVal mandantNr As Integer, _
   ByVal sprache As Integer, _
   ByVal aktiv As Boolean, _
   ByVal mutierer As Integer, _
   ByVal coldApplication As String, _
   ByVal coldBezeichnung As String _
) As Integer

Parameters

dokumentartNr
Required. criterium (keine aktualisierung für diesen param)
bezeichnung
Required.
parentId
Required.
sort
Required.
imageIndex
Required.
imageIndexOpen
Required.
beschreibung
Required.
mandantNr
Required.
sprache
Required.
aktiv
Required.
mutierer
Required.
coldApplication
Required.
coldBezeichnung
Required.

Returns

error

Source code

[Visual Basic]
    Public Shared Function Update(ByVal dokumentartNr As Integer, ByVal bezeichnung As String, ByVal parentId As Integer, ByVal sort As Integer, _
        ByVal imageIndex As Integer, ByVal imageIndexOpen As Integer, ByVal beschreibung As String, ByVal mandantNr As Integer, ByVal sprache As Integer, _
        ByVal aktiv As Boolean, ByVal mutierer As Integer, ByVal coldApplication As String, ByVal coldBezeichnung As String) As Integer

        Dim sqlConn As New SqlConnection()
        Dim sqlCmd As New SqlCommand()

        Try
            sqlConn.ConnectionString = Common.Datenbank.GetDSN()
            sqlCmd.CommandText = "sp_SetDokumentart"
            sqlCmd.CommandType = CommandType.StoredProcedure
            sqlCmd.Connection = sqlConn

            sqlCmd.Parameters.Add(New SqlParameter("@DokumentartNr", dokumentartNr))
            sqlCmd.Parameters.Add(New SqlParameter("@Bezeichnung", NullHandler.CToSqlString(bezeichnung)))
            sqlCmd.Parameters.Add(New SqlParameter("@ParentId", NullHandler.CToSqlInt(parentId)))
            sqlCmd.Parameters.Add(New SqlParameter("@Sort", NullHandler.CToSqlInt(sort)))
            sqlCmd.Parameters.Add(New SqlParameter("@ImageIndex", NullHandler.CToSqlInt(imageIndex)))
            sqlCmd.Parameters.Add(New SqlParameter("@ImageIndexOpen", NullHandler.CToSqlInt(imageIndexOpen)))
            sqlCmd.Parameters.Add(New SqlParameter("@Beschreibung", NullHandler.CToSqlString(beschreibung)))
            sqlCmd.Parameters.Add(New SqlParameter("@MandantNr", mandantNr))
            sqlCmd.Parameters.Add(New SqlParameter("@Sprache", sprache))
            sqlCmd.Parameters.Add(New SqlParameter("@Aktiv", aktiv))
            sqlCmd.Parameters.Add(New SqlParameter("@Mutierer", NullHandler.CToSqlInt(mutierer)))
            sqlCmd.Parameters.Add(New SqlParameter("@ColdApplication", NullHandler.CToSqlString(coldApplication)))
            sqlCmd.Parameters.Add(New SqlParameter("@ColdBezeichnung", NullHandler.CToSqlString(coldBezeichnung)))
            sqlCmd.Parameters.Add(New SqlParameter("@Return", DBNull.Value))
            sqlCmd.Parameters("@Return").Direction = ParameterDirection.ReturnValue

            sqlConn.Open()
            sqlCmd.ExecuteNonQuery()

            Return CInt(sqlCmd.Parameters("@Return").Value)

        Catch ex As Exception
            TKBLib.Errorhandling.TraceHelper.Msg("EDOKALib.DA.Dokumentart.Update", ex.Message + " " + ex.StackTrace, TraceLevel.Error)
            Throw ex
        Finally
            sqlConn.Dispose()
            sqlCmd.Dispose()
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Dokumentart


Dokumenttyp Class

Datenzugriff auf Tabelle dokumenttyp

For a list of all members of this type, see Dokumenttyp Members.

System.Object
EDOKALib.DataAccess.Dokumenttyp

Public Class Dokumenttyp

Requirements

Namespace: DataAccess

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKALib.DataAccess (in EDOKALib.DataAccess.dll)

See Also

Dokumenttyp Members


Dokumenttyp Members

Dokumenttyp overview

Methods

method Add | erstellt einen datentyp
method Delete | Löscht ein bestehender dokumententyp
method GetDokumenttyp | gibt einen dokumenttyp zurück
method List | gibt eine liste aller Dokumenttypen zurück
method Update | aktualisiert einen datentyp

See Also

Dokumenttyp Class


Dokumenttyp Methods

Dokumenttyp overview

Methods

method Add | erstellt einen datentyp
method Delete | Löscht ein bestehender dokumententyp
method GetDokumenttyp | gibt einen dokumenttyp zurück
method List | gibt eine liste aller Dokumenttypen zurück
method Update | aktualisiert einen datentyp

See Also

Dokumenttyp Class


Dokumenttyp.Add Method

erstellt einen datentyp

Public Shared Function Add( _
   ByRef DokumenttypNr As Integer, _
   ByVal bezeichnung As String, _
   ByVal beschreibung As String, _
   ByVal zu_vercolden As Boolean, _
   ByVal zu_retournieren As Boolean, _
   ByVal eingang_ersetzt_ausgang As Boolean, _
   ByVal wird_importiert As Boolean, _
   ByVal anzahl_tage As Integer, _
   ByVal dbearbeitungszeit As Integer, _
   ByVal tage_mutation As Integer, _
   ByVal partnersaldierung_statusalt As Boolean, _
   ByVal wird_nicht_geloescht As Boolean, _
   ByVal vertrauliches_dokument As Boolean, _
   ByVal unterschrift_links As Boolean, _
   ByVal unterschrift_rechts As Boolean, _
   ByVal monate_bis_zur_archivierung As Integer, _
   ByVal aufbewahrungsfrist_elektronisch As Integer, _
   ByVal aufbewahrungsfrist_physisch As Integer, _
   ByVal mandantnr As Integer, _
   ByVal aktiv As Boolean, _
   ByVal erstellt_am As DateTime, _
   ByVal mutiert_am As DateTime, _
   ByVal mutierer As Integer, _
   ByVal office_vorlagenr As Integer, _
   ByVal dokumentart_kundendossier As Integer, _
   ByVal dokumentart_neuerstellung As Integer, _
   ByVal dokumentart_retournierung As Integer, _
   ByVal dokumentart_coldausgang As Integer, _
   ByVal dokumentart_coldeingang As Integer, _
   ByVal dokumentart_host As Integer, _
   ByVal dokumentart_weitere As Integer, _
   ByVal dokumentart_nativ As Integer, _
   ByVal prozessnr As Integer, _
   ByVal prozessnr1 As Integer, _
   ByVal amsdokument As Boolean, _
   ByVal hostdokument As Boolean, _
   ByVal hostdokumenttyp As String, _
   ByVal cold_folder As Integer, _
   ByVal physisches_archiv As Integer, _
   ByVal dokumentstatus As Integer, _
   ByVal Dokument_wird_erstellt As Boolean, _
   ByVal Dokument_wird_retourniert As Boolean, _
   ByVal cold_ersetzen As Boolean, _
   ByVal email_versand As Boolean, _
   ByVal funktionen_zuweisen As Boolean, _
   ByVal dokumentstatus_barcode As Integer, _
   ByVal nurnative As Boolean, _
   ByVal Owner As Integer, _
   ByVal vertrag As Boolean, _
   ByVal objektbezeichnungnr As Integer, _
   ByVal bedingtretournierbar As Boolean, _
   ByVal doktypbedingteretournierung As Integer, _
   ByVal tagebisvernichtungbedingteretournierung As Integer, _
   ByVal AnzeigeZurDokumenterstellung As Boolean, _
   ByVal KundenDokument As Boolean, _
   ByVal sb As Boolean, _
   ByVal sbimport As Boolean, _
   ByVal sbedituser As Boolean, _
   ByVal sbnur As Boolean, _
   ByVal bezeichnungmut As Boolean, _
   ByVal istFarbigArchiviert As Boolean _
) As Integer

Parameters

DokumenttypNr
Required. return neuer primary key
bezeichnung
Required.
beschreibung
Required.
zu_vercolden
Required.
zu_retournieren
Required.
eingang_ersetzt_ausgang
Required.
wird_importiert
Required.
anzahl_tage
Required.
dbearbeitungszeit
Required.
tage_mutation
Required.
partnersaldierung_statusalt
Required.
wird_nicht_geloescht
Required.
vertrauliches_dokument
Required.
unterschrift_links
Required.
unterschrift_rechts
Required.
monate_bis_zur_archivierung
Required.
aufbewahrungsfrist_elektronisch
Required.
aufbewahrungsfrist_physisch
Required.
mandantnr
Required.
aktiv
Required.
erstellt_am
Required.
mutiert_am
Required.
mutierer
Required.
office_vorlagenr
Required.
dokumentart_kundendossier
Required.
dokumentart_neuerstellung
Required.
dokumentart_retournierung
Required.
dokumentart_coldausgang
Required.
dokumentart_coldeingang
Required.
dokumentart_host
Required.
dokumentart_weitere
Required.
dokumentart_nativ
Required.
prozessnr
Required.
prozessnr1
Required.
amsdokument
Required.
hostdokument
Required.
hostdokumenttyp
Required.
cold_folder
Required.
physisches_archiv
Required.
dokumentstatus
Required.
Dokument_wird_erstellt
Required.
Dokument_wird_retourniert
Required.
cold_ersetzen
Required.
email_versand
Required.
funktionen_zuweisen
Required.
dokumentstatus_barcode
Required.
nurnative
Required.
Owner
Required.
vertrag
Required.
objektbezeichnungnr
Required.
bedingtretournierbar
Required.
doktypbedingteretournierung
Required.
tagebisvernichtungbedingteretournierung
Required.
AnzeigeZurDokumenterstellung
Required.
KundenDokument
Required.
sb
Required.
sbimport
Required.
sbedituser
Required.
sbnur
Required.
bezeichnungmut
Required.
istFarbigArchiviert
Required.

Returns

error

Source code

[Visual Basic]
    Public Shared Function Add(ByRef DokumenttypNr As Integer, ByVal bezeichnung As String, ByVal beschreibung As String, _
        ByVal zu_vercolden As Boolean, ByVal zu_retournieren As Boolean, ByVal eingang_ersetzt_ausgang As Boolean, _
        ByVal wird_importiert As Boolean, ByVal anzahl_tage As Integer, ByVal dbearbeitungszeit As Integer, _
        ByVal tage_mutation As Integer, ByVal partnersaldierung_statusalt As Boolean, ByVal wird_nicht_geloescht As Boolean, _
        ByVal vertrauliches_dokument As Boolean, ByVal unterschrift_links As Boolean, ByVal unterschrift_rechts As Boolean, _
        ByVal monate_bis_zur_archivierung As Integer, ByVal aufbewahrungsfrist_elektronisch As Integer, _
        ByVal aufbewahrungsfrist_physisch As Integer, ByVal mandantnr As Integer, ByVal aktiv As Boolean, _
        ByVal erstellt_am As DateTime, ByVal mutiert_am As DateTime, ByVal mutierer As Integer, _
        ByVal office_vorlagenr As Integer, ByVal dokumentart_kundendossier As Integer, ByVal dokumentart_neuerstellung As Integer, _
        ByVal dokumentart_retournierung As Integer, ByVal dokumentart_coldausgang As Integer, _
        ByVal dokumentart_coldeingang As Integer, ByVal dokumentart_host As Integer, ByVal dokumentart_weitere As Integer, _
        ByVal dokumentart_nativ As Integer, ByVal prozessnr As Integer, ByVal prozessnr1 As Integer, _
        ByVal amsdokument As Boolean, ByVal hostdokument As Boolean, ByVal hostdokumenttyp As String, _
        ByVal cold_folder As Integer, ByVal physisches_archiv As Integer, ByVal dokumentstatus As Integer, _
        ByVal Dokument_wird_erstellt As Boolean, ByVal Dokument_wird_retourniert As Boolean, ByVal cold_ersetzen As Boolean, _
        ByVal email_versand As Boolean, ByVal funktionen_zuweisen As Boolean, ByVal dokumentstatus_barcode As Integer, _
        ByVal nurnative As Boolean, ByVal Owner As Integer, ByVal vertrag As Boolean, ByVal objektbezeichnungnr As Integer, _
        ByVal bedingtretournierbar As Boolean, ByVal doktypbedingteretournierung As Integer, _
        ByVal tagebisvernichtungbedingteretournierung As Integer, ByVal AnzeigeZurDokumenterstellung As Boolean, _
        ByVal KundenDokument As Boolean, ByVal sb As Boolean, ByVal sbimport As Boolean, ByVal sbedituser As Boolean, _
        ByVal sbnur As Boolean, ByVal bezeichnungmut As Boolean, ByVal istFarbigArchiviert As Boolean) As Integer

        Dim sqlConn As New SqlConnection()
        Dim sqlCmd As New SqlCommand()

        Try
            sqlConn.ConnectionString = Common.Datenbank.GetDSN()
            sqlCmd.CommandText = "sp_InsDokumenttyp"
            sqlCmd.CommandType = CommandType.StoredProcedure
            sqlCmd.Connection = sqlConn

            sqlCmd.Parameters.Add(New SqlParameter("@bezeichnung", NullHandler.CToSqlString(bezeichnung)))
            sqlCmd.Parameters.Add(New SqlParameter("@beschreibung", NullHandler.CToSqlString(beschreibung)))
            sqlCmd.Parameters.Add(New SqlParameter("@zu_vercolden", zu_vercolden))
            sqlCmd.Parameters.Add(New SqlParameter("@zu_retournieren", zu_retournieren))
            sqlCmd.Parameters.Add(New SqlParameter("@eingang_ersetzt_ausgang", eingang_ersetzt_ausgang))
            sqlCmd.Parameters.Add(New SqlParameter("@wird_importiert", wird_importiert))
            sqlCmd.Parameters.Add(New SqlParameter("@anzahl_tage", anzahl_tage))
            sqlCmd.Parameters.Add(New SqlParameter("@dbearbeitungszeit", dbearbeitungszeit))
            sqlCmd.Parameters.Add(New SqlParameter("@tage_mutation", tage_mutation))
            sqlCmd.Parameters.Add(New SqlParameter("@partnersaldierung_statusalt", partnersaldierung_statusalt))
            sqlCmd.Parameters.Add(New SqlParameter("@wird_nicht_geloescht", wird_nicht_geloescht))
            sqlCmd.Parameters.Add(New SqlParameter("@vertrauliches_dokument", vertrauliches_dokument))
            sqlCmd.Parameters.Add(New SqlParameter("@unterschrift_links", unterschrift_links))
            sqlCmd.Parameters.Add(New SqlParameter("@unterschrift_rechts", unterschrift_rechts))
            sqlCmd.Parameters.Add(New SqlParameter("@monate_bis_zur_archivierung", monate_bis_zur_archivierung))
            sqlCmd.Parameters.Add(New SqlParameter("@aufbewahrungsfrist_elektronisch", aufbewahrungsfrist_elektronisch))
            sqlCmd.Parameters.Add(New SqlParameter("@aufbewahrungsfrist_physisch", aufbewahrungsfrist_physisch))
            sqlCmd.Parameters.Add(New SqlParameter("@mandantnr", NullHandler.CToSqlInt(mandantnr)))
            sqlCmd.Parameters.Add(New SqlParameter("@aktiv", aktiv))
            sqlCmd.Parameters.Add(New SqlParameter("@erstellt_am", NullHandler.CToSqlDateTime(erstellt_am)))
            sqlCmd.Parameters.Add(New SqlParameter("@mutiert_am", NullHandler.CToSqlDateTime(mutiert_am)))
            sqlCmd.Parameters.Add(New SqlParameter("@mutierer", NullHandler.CToSqlInt(mutierer)))
            sqlCmd.Parameters.Add(New SqlParameter("@office_vorlagenr", NullHandler.CToSqlInt(office_vorlagenr)))
            sqlCmd.Parameters.Add(New SqlParameter("@dokumentart_kundendossier", NullHandler.CToSqlInt(dokumentart_kundendossier)))
            sqlCmd.Parameters.Add(New SqlParameter("@dokumentart_neuerstellung", NullHandler.CToSqlInt(dokumentart_neuerstellung)))
            sqlCmd.Parameters.Add(New SqlParameter("@dokumentart_retournierung", NullHandler.CToSqlInt(dokumentart_retournierung)))
            sqlCmd.Parameters.Add(New SqlParameter("@dokumentart_coldausgang", dokumentart_coldausgang))
            sqlCmd.Parameters.Add(New SqlParameter("@dokumentart_coldeingang", dokumentart_coldeingang))
            sqlCmd.Parameters.Add(New SqlParameter("@dokumentart_host", NullHandler.CToSqlInt(dokumentart_host)))
            sqlCmd.Parameters.Add(New SqlParameter("@dokumentart_weitere", NullHandler.CToSqlInt(dokumentart_weitere)))
            sqlCmd.Parameters.Add(New SqlParameter("@dokumentart_nativ", NullHandler.CToSqlInt(dokumentart_nativ)))
            sqlCmd.Parameters.Add(New SqlParameter("@prozessnr", NullHandler.CToSqlInt(prozessnr)))
            sqlCmd.Parameters.Add(New SqlParameter("@prozessnr1", NullHandler.CToSqlInt(prozessnr1)))
            sqlCmd.Parameters.Add(New SqlParameter("@amsdokument", amsdokument))
            sqlCmd.Parameters.Add(New SqlParameter("@hostdokument", hostdokument))
            sqlCmd.Parameters.Add(New SqlParameter("@hostdokumenttyp", NullHandler.CToSqlString(hostdokumenttyp)))
            sqlCmd.Parameters.Add(New SqlParameter("@cold_folder", NullHandler.CToSqlInt(cold_folder)))
            sqlCmd.Parameters.Add(New SqlParameter("@physisches_archiv", NullHandler.CToSqlInt(physisches_archiv)))
            sqlCmd.Parameters.Add(New SqlParameter("@dokumentstatus", NullHandler.CToSqlInt(dokumentstatus)))
            sqlCmd.Parameters.Add(New SqlParameter("@Dokument_wird_erstellt", Dokument_wird_erstellt))
            sqlCmd.Parameters.Add(New SqlParameter("@Dokument_wird_retourniert", Dokument_wird_retourniert))
            sqlCmd.Parameters.Add(New SqlParameter("@cold_ersetzen", cold_ersetzen))
            sqlCmd.Parameters.Add(New SqlParameter("@email_versand", email_versand))
            sqlCmd.Parameters.Add(New SqlParameter("@funktionen_zuweisen", funktionen_zuweisen))
            sqlCmd.Parameters.Add(New SqlParameter("@dokumentstatus_barcode", NullHandler.CToSqlInt(dokumentstatus_barcode)))
            sqlCmd.Parameters.Add(New SqlParameter("@nurnative", nurnative))
            sqlCmd.Parameters.Add(New SqlParameter("@Owner", NullHandler.CToSqlInt(Owner)))
            sqlCmd.Parameters.Add(New SqlParameter("@vertrag", vertrag))
            sqlCmd.Parameters.Add(New SqlParameter("@objektbezeichnungnr", NullHandler.CToSqlInt(objektbezeichnungnr)))
            sqlCmd.Parameters.Add(New SqlParameter("@bedingtretournierbar", bedingtretournierbar))
            sqlCmd.Parameters.Add(New SqlParameter("@doktypbedingteretournierung", NullHandler.CToSqlInt(doktypbedingteretournierung)))
            sqlCmd.Parameters.Add(New SqlParameter("@tagebisvernichtungbedingteretournierung", NullHandler.CToSqlInt(tagebisvernichtungbedingteretournierung)))
            sqlCmd.Parameters.Add(New SqlParameter("@AnzeigeZurDokumenterstellung", AnzeigeZurDokumenterstellung))
            sqlCmd.Parameters.Add(New SqlParameter("@KundenDokument", KundenDokument))
            sqlCmd.Parameters.Add(New SqlParameter("@sb", sb))
            sqlCmd.Parameters.Add(New SqlParameter("@sbimport", sbimport))
            sqlCmd.Parameters.Add(New SqlParameter("@sbedituser", sbedituser))
            sqlCmd.Parameters.Add(New SqlParameter("@sbnur", sbnur))
            sqlCmd.Parameters.Add(New SqlParameter("@bezeichnungmut", bezeichnungmut))
            sqlCmd.Parameters.Add(New SqlParameter("@istFarbigArchiviert", istFarbigArchiviert))
            sqlCmd.Parameters.Add(New SqlParameter("@DokumenttypNr", 0))
            sqlCmd.Parameters.Add(New SqlParameter("@Return", DBNull.Value))
            sqlCmd.Parameters("@DokumenttypNr").Direction = ParameterDirection.Output
            sqlCmd.Parameters("@Return").Direction = ParameterDirection.ReturnValue

            sqlConn.Open()
            sqlCmd.ExecuteNonQuery()

            If CInt(sqlCmd.Parameters("@Return").Value) = 0 Then
                DokumenttypNr = CInt(sqlCmd.Parameters("@DokumenttypNr").Value)
            End If

            Return CInt(sqlCmd.Parameters("@Return").Value)

        Catch ex As Exception
            TKBLib.Errorhandling.TraceHelper.Msg("EDOKALib.DA.Dokumenttyp.Add", ex.Message + " " + ex.StackTrace, TraceLevel.Error)
            Throw ex
        Finally
            sqlConn.Dispose()
            sqlCmd.Dispose()
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Dokumenttyp


Dokumenttyp.Delete Method

Löscht ein bestehender dokumententyp

Public Shared Function Delete( _
   ByVal DokumenttypNr As Integer _
) As Integer

Parameters

DokumenttypNr
Required.

Returns

error

Source code

[Visual Basic]
    Public Shared Function Delete(ByVal DokumenttypNr As Integer) As Integer
        Dim sqlConn As New SqlConnection()
        Dim sqlCmd As New SqlCommand()

        Try
            sqlConn.ConnectionString = Common.Datenbank.GetDSN()
            sqlCmd.CommandText = "sp_DelDokumenttyp"
            sqlCmd.CommandType = CommandType.StoredProcedure
            sqlCmd.Connection = sqlConn

            sqlCmd.Parameters.Add(New SqlParameter("@DokumenttypNr", DokumenttypNr))
            sqlCmd.Parameters.Add(New SqlParameter("@Return", DBNull.Value))
            sqlCmd.Parameters("@Return").Direction = ParameterDirection.ReturnValue

            sqlConn.Open()
            sqlCmd.ExecuteNonQuery()

            Return CInt(sqlCmd.Parameters("@Return").Value)

        Catch ex As Exception
            TKBLib.Errorhandling.TraceHelper.Msg("EDOKALib.DA.Dokumenttyp.Delete", ex.Message + " " + ex.StackTrace, TraceLevel.Error)
            Throw ex
        Finally
            sqlConn.Dispose()
            sqlCmd.Dispose()
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Dokumenttyp


Dokumenttyp.GetDokumenttyp Method

gibt einen dokumenttyp zurück

Public Shared Sub GetDokumenttyp( _
   ByRef ds As DataSet, _
   ByVal DokumenttypNr As Integer _
)

Parameters

ds
Required. für datenrückgabe
DokumenttypNr
Required.

Source code

[Visual Basic]
    Public Shared Sub GetDokumenttyp(ByRef ds As DataSet, ByVal DokumenttypNr As Integer)
        Dim sqlConn As New SqlConnection()
        Dim sqlCmd As New SqlCommand()
        Dim da As New SqlDataAdapter()

        Try
            sqlConn.ConnectionString = Common.Datenbank.GetDSN()
            sqlCmd.CommandText = "sp_GetDokumenttyp"
            sqlCmd.CommandType = CommandType.StoredProcedure
            sqlCmd.Connection = sqlConn

            sqlCmd.Parameters.Add(New SqlParameter("@DokumenttypNr", DokumenttypNr))
            da.SelectCommand = sqlCmd
            da.Fill(ds, "Dokumenttyp")

        Catch ex As Exception
            TKBLib.Errorhandling.TraceHelper.Msg("EDOKALib.DA.Dokumenttyp.GetDokumenttyp", ex.Message + " " + ex.StackTrace, TraceLevel.Error)
            Throw ex
        Finally
            sqlConn.Dispose()
            sqlCmd.Dispose()
            da.Dispose()
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Dokumenttyp


Dokumenttyp.List Method

gibt eine liste aller Dokumenttypen zurück

Public Shared Sub List( _
   ByRef ds As DataSet, _
   ByVal aktiv As Integer _
)

Parameters

ds
Required. für datenrückgabe
aktiv
Required. 1 nur aktive; 0 nur inaktive; -1 alle

Source code

[Visual Basic]
    Public Shared Sub List(ByRef ds As DataSet, ByVal aktiv As Integer)
        Dim sqlConn As New SqlConnection()
        Dim sqlCmd As New SqlCommand()
        Dim da As New SqlDataAdapter()

        Try
            sqlConn.ConnectionString = Common.Datenbank.GetDSN()
            sqlCmd.CommandText = "sp_ListDokumenttyp"
            sqlCmd.CommandType = CommandType.StoredProcedure
            sqlCmd.Connection = sqlConn

            If aktiv <> -1 Then
                sqlCmd.Parameters.Add(New SqlParameter("@Aktiv", aktiv))
            End If

            da.SelectCommand = sqlCmd
            da.Fill(ds, "Dokumenttypen")

        Catch ex As Exception
            TKBLib.Errorhandling.TraceHelper.Msg("EDOKALib.DA.Dokumenttyp.List", ex.Message + " " + ex.StackTrace, TraceLevel.Error)
            Throw ex
        Finally
            sqlConn.Dispose()
            sqlCmd.Dispose()
            da.Dispose()
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Dokumenttyp


Dokumenttyp.Update Method

aktualisiert einen datentyp

Public Shared Function Update( _
   ByVal DokumenttypNr As Integer, _
   ByVal bezeichnung As String, _
   ByVal beschreibung As String, _
   ByVal zu_vercolden As Boolean, _
   ByVal zu_retournieren As Boolean, _
   ByVal eingang_ersetzt_ausgang As Boolean, _
   ByVal wird_importiert As Boolean, _
   ByVal anzahl_tage As Integer, _
   ByVal dbearbeitungszeit As Integer, _
   ByVal tage_mutation As Integer, _
   ByVal partnersaldierung_statusalt As Boolean, _
   ByVal wird_nicht_geloescht As Boolean, _
   ByVal vertrauliches_dokument As Boolean, _
   ByVal unterschrift_links As Boolean, _
   ByVal unterschrift_rechts As Boolean, _
   ByVal monate_bis_zur_archivierung As Integer, _
   ByVal aufbewahrungsfrist_elektronisch As Integer, _
   ByVal aufbewahrungsfrist_physisch As Integer, _
   ByVal mandantnr As Integer, _
   ByVal aktiv As Boolean, _
   ByVal erstellt_am As DateTime, _
   ByVal mutiert_am As DateTime, _
   ByVal mutierer As Integer, _
   ByVal office_vorlagenr As Integer, _
   ByVal dokumentart_kundendossier As Integer, _
   ByVal dokumentart_neuerstellung As Integer, _
   ByVal dokumentart_retournierung As Integer, _
   ByVal dokumentart_coldausgang As Integer, _
   ByVal dokumentart_coldeingang As Integer, _
   ByVal dokumentart_host As Integer, _
   ByVal dokumentart_weitere As Integer, _
   ByVal dokumentart_nativ As Integer, _
   ByVal prozessnr As Integer, _
   ByVal prozessnr1 As Integer, _
   ByVal amsdokument As Boolean, _
   ByVal hostdokument As Boolean, _
   ByVal hostdokumenttyp As String, _
   ByVal cold_folder As Integer, _
   ByVal physisches_archiv As Integer, _
   ByVal dokumentstatus As Integer, _
   ByVal Dokument_wird_erstellt As Boolean, _
   ByVal Dokument_wird_retourniert As Boolean, _
   ByVal cold_ersetzen As Boolean, _
   ByVal email_versand As Boolean, _
   ByVal funktionen_zuweisen As Boolean, _
   ByVal dokumentstatus_barcode As Integer, _
   ByVal nurnative As Boolean, _
   ByVal Owner As Integer, _
   ByVal vertrag As Boolean, _
   ByVal objektbezeichnungnr As Integer, _
   ByVal bedingtretournierbar As Boolean, _
   ByVal doktypbedingteretournierung As Integer, _
   ByVal tagebisvernichtungbedingteretournierung As Integer, _
   ByVal AnzeigeZurDokumenterstellung As Boolean, _
   ByVal KundenDokument As Boolean, _
   ByVal sb As Boolean, _
   ByVal sbimport As Boolean, _
   ByVal sbedituser As Boolean, _
   ByVal sbnur As Boolean, _
   ByVal bezeichnungmut As Boolean, _
   ByVal istFarbigArchiviert As Boolean _
) As Integer

Parameters

DokumenttypNr
Required. kriterium (kein update auf diesem feld)
bezeichnung
Required.
beschreibung
Required.
zu_vercolden
Required.
zu_retournieren
Required.
eingang_ersetzt_ausgang
Required.
wird_importiert
Required.
anzahl_tage
Required.
dbearbeitungszeit
Required.
tage_mutation
Required.
partnersaldierung_statusalt
Required.
wird_nicht_geloescht
Required.
vertrauliches_dokument
Required.
unterschrift_links
Required.
unterschrift_rechts
Required.
monate_bis_zur_archivierung
Required.
aufbewahrungsfrist_elektronisch
Required.
aufbewahrungsfrist_physisch
Required.
mandantnr
Required.
aktiv
Required.
erstellt_am
Required.
mutiert_am
Required.
mutierer
Required.
office_vorlagenr
Required.
dokumentart_kundendossier
Required.
dokumentart_neuerstellung
Required.
dokumentart_retournierung
Required.
dokumentart_coldausgang
Required.
dokumentart_coldeingang
Required.
dokumentart_host
Required.
dokumentart_weitere
Required.
dokumentart_nativ
Required.
prozessnr
Required.
prozessnr1
Required.
amsdokument
Required.
hostdokument
Required.
hostdokumenttyp
Required.
cold_folder
Required.
physisches_archiv
Required.
dokumentstatus
Required.
Dokument_wird_erstellt
Required.
Dokument_wird_retourniert
Required.
cold_ersetzen
Required.
email_versand
Required.
funktionen_zuweisen
Required.
dokumentstatus_barcode
Required.
nurnative
Required.
Owner
Required.
vertrag
Required.
objektbezeichnungnr
Required.
bedingtretournierbar
Required.
doktypbedingteretournierung
Required.
tagebisvernichtungbedingteretournierung
Required.
AnzeigeZurDokumenterstellung
Required.
KundenDokument
Required.
sb
Required.
sbimport
Required.
sbedituser
Required.
sbnur
Required.
bezeichnungmut
Required.
istFarbigArchiviert
Required.

Returns

error

Source code

[Visual Basic]
    Public Shared Function Update(ByVal DokumenttypNr As Integer, ByVal bezeichnung As String, ByVal beschreibung As String, _
        ByVal zu_vercolden As Boolean, ByVal zu_retournieren As Boolean, ByVal eingang_ersetzt_ausgang As Boolean, _
        ByVal wird_importiert As Boolean, ByVal anzahl_tage As Integer, ByVal dbearbeitungszeit As Integer, _
        ByVal tage_mutation As Integer, ByVal partnersaldierung_statusalt As Boolean, ByVal wird_nicht_geloescht As Boolean, _
        ByVal vertrauliches_dokument As Boolean, ByVal unterschrift_links As Boolean, ByVal unterschrift_rechts As Boolean, _
        ByVal monate_bis_zur_archivierung As Integer, ByVal aufbewahrungsfrist_elektronisch As Integer, _
        ByVal aufbewahrungsfrist_physisch As Integer, ByVal mandantnr As Integer, ByVal aktiv As Boolean, _
        ByVal erstellt_am As DateTime, ByVal mutiert_am As DateTime, ByVal mutierer As Integer, _
        ByVal office_vorlagenr As Integer, ByVal dokumentart_kundendossier As Integer, ByVal dokumentart_neuerstellung As Integer, _
        ByVal dokumentart_retournierung As Integer, ByVal dokumentart_coldausgang As Integer, _
        ByVal dokumentart_coldeingang As Integer, ByVal dokumentart_host As Integer, ByVal dokumentart_weitere As Integer, _
        ByVal dokumentart_nativ As Integer, ByVal prozessnr As Integer, ByVal prozessnr1 As Integer, _
        ByVal amsdokument As Boolean, ByVal hostdokument As Boolean, ByVal hostdokumenttyp As String, _
        ByVal cold_folder As Integer, ByVal physisches_archiv As Integer, ByVal dokumentstatus As Integer, _
        ByVal Dokument_wird_erstellt As Boolean, ByVal Dokument_wird_retourniert As Boolean, ByVal cold_ersetzen As Boolean, _
        ByVal email_versand As Boolean, ByVal funktionen_zuweisen As Boolean, ByVal dokumentstatus_barcode As Integer, _
        ByVal nurnative As Boolean, ByVal Owner As Integer, ByVal vertrag As Boolean, ByVal objektbezeichnungnr As Integer, _
        ByVal bedingtretournierbar As Boolean, ByVal doktypbedingteretournierung As Integer, _
        ByVal tagebisvernichtungbedingteretournierung As Integer, ByVal AnzeigeZurDokumenterstellung As Boolean, _
        ByVal KundenDokument As Boolean, ByVal sb As Boolean, ByVal sbimport As Boolean, ByVal sbedituser As Boolean, _
        ByVal sbnur As Boolean, ByVal bezeichnungmut As Boolean, ByVal istFarbigArchiviert As Boolean) As Integer

        Dim sqlConn As New SqlConnection()
        Dim sqlCmd As New SqlCommand()

        Try
            sqlConn.ConnectionString = Common.Datenbank.GetDSN()
            sqlCmd.CommandText = "sp_SetParameter"
            sqlCmd.CommandType = CommandType.StoredProcedure
            sqlCmd.Connection = sqlConn

            sqlCmd.Parameters.Add(New SqlParameter("@DokumenttypNr", DokumenttypNr))
            sqlCmd.Parameters.Add(New SqlParameter("@bezeichnung", NullHandler.CToSqlString(bezeichnung)))
            sqlCmd.Parameters.Add(New SqlParameter("@beschreibung", NullHandler.CToSqlString(beschreibung)))
            sqlCmd.Parameters.Add(New SqlParameter("@zu_vercolden", zu_vercolden))
            sqlCmd.Parameters.Add(New SqlParameter("@zu_retournieren", zu_retournieren))
            sqlCmd.Parameters.Add(New SqlParameter("@eingang_ersetzt_ausgang", eingang_ersetzt_ausgang))
            sqlCmd.Parameters.Add(New SqlParameter("@wird_importiert", wird_importiert))
            sqlCmd.Parameters.Add(New SqlParameter("@anzahl_tage", anzahl_tage))
            sqlCmd.Parameters.Add(New SqlParameter("@dbearbeitungszeit", dbearbeitungszeit))
            sqlCmd.Parameters.Add(New SqlParameter("@tage_mutation", tage_mutation))
            sqlCmd.Parameters.Add(New SqlParameter("@partnersaldierung_statusalt", partnersaldierung_statusalt))
            sqlCmd.Parameters.Add(New SqlParameter("@wird_nicht_geloescht", wird_nicht_geloescht))
            sqlCmd.Parameters.Add(New SqlParameter("@vertrauliches_dokument", vertrauliches_dokument))
            sqlCmd.Parameters.Add(New SqlParameter("@unterschrift_links", unterschrift_links))
            sqlCmd.Parameters.Add(New SqlParameter("@unterschrift_rechts", unterschrift_rechts))
            sqlCmd.Parameters.Add(New SqlParameter("@monate_bis_zur_archivierung", monate_bis_zur_archivierung))
            sqlCmd.Parameters.Add(New SqlParameter("@aufbewahrungsfrist_elektronisch", aufbewahrungsfrist_elektronisch))
            sqlCmd.Parameters.Add(New SqlParameter("@aufbewahrungsfrist_physisch", aufbewahrungsfrist_physisch))
            sqlCmd.Parameters.Add(New SqlParameter("@mandantnr", NullHandler.CToSqlInt(mandantnr)))
            sqlCmd.Parameters.Add(New SqlParameter("@aktiv", aktiv))
            sqlCmd.Parameters.Add(New SqlParameter("@erstellt_am", NullHandler.CToSqlDateTime(erstellt_am)))
            sqlCmd.Parameters.Add(New SqlParameter("@mutiert_am", NullHandler.CToSqlDateTime(mutiert_am)))
            sqlCmd.Parameters.Add(New SqlParameter("@mutierer", NullHandler.CToSqlInt(mutierer)))
            sqlCmd.Parameters.Add(New SqlParameter("@office_vorlagenr", NullHandler.CToSqlInt(office_vorlagenr)))
            sqlCmd.Parameters.Add(New SqlParameter("@dokumentart_kundendossier", NullHandler.CToSqlInt(dokumentart_kundendossier)))
            sqlCmd.Parameters.Add(New SqlParameter("@dokumentart_neuerstellung", NullHandler.CToSqlInt(dokumentart_neuerstellung)))
            sqlCmd.Parameters.Add(New SqlParameter("@dokumentart_retournierung", NullHandler.CToSqlInt(dokumentart_retournierung)))
            sqlCmd.Parameters.Add(New SqlParameter("@dokumentart_coldausgang", dokumentart_coldausgang))
            sqlCmd.Parameters.Add(New SqlParameter("@dokumentart_coldeingang", dokumentart_coldeingang))
            sqlCmd.Parameters.Add(New SqlParameter("@dokumentart_host", NullHandler.CToSqlInt(dokumentart_host)))
            sqlCmd.Parameters.Add(New SqlParameter("@dokumentart_weitere", NullHandler.CToSqlInt(dokumentart_weitere)))
            sqlCmd.Parameters.Add(New SqlParameter("@dokumentart_nativ", NullHandler.CToSqlInt(dokumentart_nativ)))
            sqlCmd.Parameters.Add(New SqlParameter("@prozessnr", NullHandler.CToSqlInt(prozessnr)))
            sqlCmd.Parameters.Add(New SqlParameter("@prozessnr1", NullHandler.CToSqlInt(prozessnr1)))
            sqlCmd.Parameters.Add(New SqlParameter("@amsdokument", amsdokument))
            sqlCmd.Parameters.Add(New SqlParameter("@hostdokument", hostdokument))
            sqlCmd.Parameters.Add(New SqlParameter("@hostdokumenttyp", NullHandler.CToSqlString(hostdokumenttyp)))
            sqlCmd.Parameters.Add(New SqlParameter("@cold_folder", NullHandler.CToSqlInt(cold_folder)))
            sqlCmd.Parameters.Add(New SqlParameter("@physisches_archiv", NullHandler.CToSqlInt(physisches_archiv)))
            sqlCmd.Parameters.Add(New SqlParameter("@dokumentstatus", NullHandler.CToSqlInt(dokumentstatus)))
            sqlCmd.Parameters.Add(New SqlParameter("@Dokument_wird_erstellt", Dokument_wird_erstellt))
            sqlCmd.Parameters.Add(New SqlParameter("@Dokument_wird_retourniert", Dokument_wird_retourniert))
            sqlCmd.Parameters.Add(New SqlParameter("@cold_ersetzen", cold_ersetzen))
            sqlCmd.Parameters.Add(New SqlParameter("@email_versand", email_versand))
            sqlCmd.Parameters.Add(New SqlParameter("@funktionen_zuweisen", funktionen_zuweisen))
            sqlCmd.Parameters.Add(New SqlParameter("@dokumentstatus_barcode", NullHandler.CToSqlInt(dokumentstatus_barcode)))
            sqlCmd.Parameters.Add(New SqlParameter("@nurnative", nurnative))
            sqlCmd.Parameters.Add(New SqlParameter("@Owner", NullHandler.CToSqlInt(Owner)))
            sqlCmd.Parameters.Add(New SqlParameter("@vertrag", vertrag))
            sqlCmd.Parameters.Add(New SqlParameter("@objektbezeichnungnr", NullHandler.CToSqlInt(objektbezeichnungnr)))
            sqlCmd.Parameters.Add(New SqlParameter("@bedingtretournierbar", bedingtretournierbar))
            sqlCmd.Parameters.Add(New SqlParameter("@doktypbedingteretournierung", NullHandler.CToSqlInt(doktypbedingteretournierung)))
            sqlCmd.Parameters.Add(New SqlParameter("@tagebisvernichtungbedingteretournierung", NullHandler.CToSqlInt(tagebisvernichtungbedingteretournierung)))
            sqlCmd.Parameters.Add(New SqlParameter("@AnzeigeZurDokumenterstellung", AnzeigeZurDokumenterstellung))
            sqlCmd.Parameters.Add(New SqlParameter("@KundenDokument", KundenDokument))
            sqlCmd.Parameters.Add(New SqlParameter("@sb", sb))
            sqlCmd.Parameters.Add(New SqlParameter("@sbimport", sbimport))
            sqlCmd.Parameters.Add(New SqlParameter("@sbedituser", sbedituser))
            sqlCmd.Parameters.Add(New SqlParameter("@sbnur", sbnur))
            sqlCmd.Parameters.Add(New SqlParameter("@bezeichnungmut", bezeichnungmut))
            sqlCmd.Parameters.Add(New SqlParameter("@istFarbigArchiviert", istFarbigArchiviert))
            sqlCmd.Parameters.Add(New SqlParameter("@Return", DBNull.Value))
            sqlCmd.Parameters("@Return").Direction = ParameterDirection.ReturnValue

            sqlConn.Open()
            sqlCmd.ExecuteNonQuery()

            Return CInt(sqlCmd.Parameters("@Return").Value)

        Catch ex As Exception
            TKBLib.Errorhandling.TraceHelper.Msg("EDOKALib.DA.Dokumenttyp.Update", ex.Message + " " + ex.StackTrace, TraceLevel.Error)
            Throw ex
        Finally
            sqlConn.Dispose()
            sqlCmd.Dispose()
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Dokumenttyp


Funktionsgruppe Class

Datenzugriff auf Tabelle Funktionsgruppe

For a list of all members of this type, see Funktionsgruppe Members.

System.Object
EDOKALib.DataAccess.Funktionsgruppe

Public Class Funktionsgruppe

Requirements

Namespace: DataAccess

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKALib.DataAccess (in EDOKALib.DataAccess.dll)

See Also

Funktionsgruppe Members


Funktionsgruppe Members

Funktionsgruppe overview

Methods

method GetListe Gibt eine Liste mit allen Funktionsgrupppen zurück

See Also

Funktionsgruppe Class


Funktionsgruppe Methods

Funktionsgruppe overview

Methods

method GetListe Gibt eine Liste mit allen Funktionsgrupppen zurück

See Also

Funktionsgruppe Class


Funktionsgruppe.GetListe Method

Gibt eine Liste mit allen Funktionsgrupppen zurück

Overloads Shared Sub GetListe( _
   ByRef ds As DataSet _
)

Parameters

ds
Required. Das DataSet welches gefüllt werden soll

Source code

[Visual Basic]
    Overloads Shared Sub GetListe(ByRef ds As DataSet)
        Dim sqlConn As New SqlConnection()
        Dim sqlCmd As New SqlCommand()
        Dim da As New SqlDataAdapter()

        Try
            sqlCmd.CommandText = "sp_ListFunktionsgruppen"
            sqlCmd.CommandType = CommandType.StoredProcedure
            sqlCmd.Connection = sqlConn

            sqlConn.ConnectionString = Common.Datenbank.GetDSN()

            sqlConn.Open()

            da.SelectCommand = sqlCmd
            da.Fill(ds, "FunktionsgruppenListe")

        Catch ex As Exception
            Throw ex
        Finally
            If sqlCmd Is Nothing Then
                sqlCmd.Dispose()
            End If
            If sqlConn Is Nothing Then
                sqlConn.Dispose()
            End If
            If da Is Nothing Then
                da.Dispose()
            End If
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Funktionsgruppe


Klassifizierung Class

Datenzugriff auf Tabelle Klassifizierung

For a list of all members of this type, see Klassifizierung Members.

System.Object
EDOKALib.DataAccess.Klassifizierung

Public Class Klassifizierung

Requirements

Namespace: DataAccess

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKALib.DataAccess (in EDOKALib.DataAccess.dll)

See Also

Klassifizierung Members


Klassifizierung Members

Klassifizierung overview

Methods

method GetById | Gibt alle Details zur einer Klassifizierung zurück
method GetListe | Gibt eine Liste mit allen Funktionsgrupppen zurück

See Also

Klassifizierung Class


Klassifizierung Methods

Klassifizierung overview

Methods

method GetById | Gibt alle Details zur einer Klassifizierung zurück
method GetListe | Gibt eine Liste mit allen Funktionsgrupppen zurück

See Also

Klassifizierung Class


Klassifizierung.GetById Method

Gibt alle Details zur einer Klassifizierung zurück

Overloads Shared Sub GetById( _
   ByVal klassifizierungNr As Integer, _
   ByRef ds As DataSet _
)

Parameters

klassifizierungNr
Required. Die Datenbank Nummer der Klassifizierung (ID)
ds
Required. Das zu füllende DataSet

Source code

[Visual Basic]
    Overloads Shared Sub GetById(ByVal klassifizierungNr As Integer, ByRef ds As DataSet)
        Dim sqlConn As New SqlConnection()
        Dim sqlCmd As New SqlCommand()
        Dim da As New SqlDataAdapter()

        Try
            sqlCmd.CommandText = "sp_GetKlassifizierungById"
            sqlCmd.CommandType = CommandType.StoredProcedure
            sqlCmd.Connection = sqlConn

            sqlCmd.Parameters.Add(New SqlParameter("@KlassifizierungNr", klassifizierungNr))

            sqlConn.ConnectionString = Common.Datenbank.GetDSN()

            sqlConn.Open()

            da.SelectCommand = sqlCmd
            da.Fill(ds, "Klassifizierung")

        Catch ex As Exception
            Throw ex
        Finally
            If sqlCmd Is Nothing Then
                sqlCmd.Dispose()
            End If
            If sqlConn Is Nothing Then
                sqlConn.Dispose()
            End If
            If da Is Nothing Then
                da.Dispose()
            End If
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Klassifizierung


Klassifizierung.GetListe Method

Gibt eine Liste mit allen Funktionsgrupppen zurück

Overloads Shared Sub GetListe( _
   ByRef ds As DataSet _
)

Parameters

ds
Required. Das DataSet welches gefüllt werden soll

Source code

[Visual Basic]
    Overloads Shared Sub GetListe(ByRef ds As DataSet)
        Dim sqlConn As New SqlConnection()
        Dim sqlCmd As New SqlCommand()
        Dim da As New SqlDataAdapter()

        Try
            sqlCmd.CommandText = "sp_ListKlassifizierung"
            sqlCmd.CommandType = CommandType.StoredProcedure
            sqlCmd.Connection = sqlConn

            sqlConn.ConnectionString = Common.Datenbank.GetDSN()

            sqlConn.Open()

            da.SelectCommand = sqlCmd
            da.Fill(ds, "KlassifizierungListe")

        Catch ex As Exception
            Throw ex
        Finally
            If sqlCmd Is Nothing Then
                sqlCmd.Dispose()
            End If
            If sqlConn Is Nothing Then
                sqlConn.Dispose()
            End If
            If da Is Nothing Then
                da.Dispose()
            End If
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Klassifizierung


Meldungstext Class

Datenzugriff auf Tabelle Meldungstext

For a list of all members of this type, see Meldungstext Members.

System.Object
EDOKALib.DataAccess.Meldungstext

Public Class Meldungstext

Requirements

Namespace: DataAccess

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKALib.DataAccess (in EDOKALib.DataAccess.dll)

See Also

Meldungstext Members


Meldungstext Members

Meldungstext overview

Methods

method GetById Gibt eine Liste mit allen Spalten in einem DataSet zurück

See Also

Meldungstext Class


Meldungstext Methods

Meldungstext overview

Methods

method GetById Gibt eine Liste mit allen Spalten in einem DataSet zurück

See Also

Meldungstext Class


Meldungstext.GetById Method

Gibt eine Liste mit allen Spalten in einem DataSet zurück

Public Overloads Shared Sub GetById( _
   ByVal meldungsTextNr As Integer, _
   ByRef dsMeldungstext As DataSet _
)

Parameters

meldungsTextNr
Required.
dsMeldungstext
Required.

Source code

[Visual Basic]
    Public Overloads Shared Sub GetById(ByVal meldungsTextNr As Integer, ByRef dsMeldungstext As DataSet)
        Dim sqlConn As New SqlConnection()
        Dim sqlCmd As New SqlCommand()
        Dim da As New SqlDataAdapter()

        Try
            sqlCmd.CommandText = "sp_GetMeldungstextById"
            sqlCmd.CommandType = CommandType.StoredProcedure
            sqlCmd.Connection = sqlConn

            sqlCmd.Parameters.Add(New SqlParameter("@MeldungstextNr", meldungsTextNr))

            sqlConn.ConnectionString = Common.Datenbank.GetDSN()

            sqlConn.Open()

            da.SelectCommand = sqlCmd
            da.Fill(dsMeldungstext, "Meldungstext")

        Catch ex As Exception
            Throw ex
        Finally
            If sqlCmd Is Nothing Then
                sqlCmd.Dispose()
            End If
            If sqlConn Is Nothing Then
                sqlConn.Dispose()
            End If
            If da Is Nothing Then
                da.Dispose()
            End If
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Meldungstext


Mitarbeiter Class

Datenzugriff auf Tabelle Mitarbeiter

For a list of all members of this type, see Mitarbeiter Members.

System.Object
EDOKALib.DataAccess.Mitarbeiter

Public Class Mitarbeiter

Requirements

Namespace: DataAccess

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKALib.DataAccess (in EDOKALib.DataAccess.dll)

See Also

Mitarbeiter Members


Mitarbeiter Members

Mitarbeiter overview

Constructors

constructor Mitarbeiter Constructor

Methods

method CreateNewStandardProfil | Erstellt ein neues Standard Profil für den angegebenen Mitarbeiter
method GetById | Gibt alle Details zur einem Mitarbeiter zurück
method GetListe | Gibt eine Liste mit allen Mitarbeitern zurück
method Insert | Gibt alle Details zur einem Mitarbeiter zurück
method Update | Aktualisiert alle Details von einem Mitarbeiter

See Also

Mitarbeiter Class


Mitarbeiter Constructor

Public Sub New( _
   ByVal mitarbeiterId As Integer _
)

Parameters

mitarbeiterId
Required.

Source code

[Visual Basic]
    Public Sub New(ByVal mitarbeiterId As Integer)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Mitarbeiter


Mitarbeiter Methods

Mitarbeiter overview

Methods

method CreateNewStandardProfil | Erstellt ein neues Standard Profil für den angegebenen Mitarbeiter
method GetById | Gibt alle Details zur einem Mitarbeiter zurück
method GetListe | Gibt eine Liste mit allen Mitarbeitern zurück
method Insert | Gibt alle Details zur einem Mitarbeiter zurück
method Update | Aktualisiert alle Details von einem Mitarbeiter

See Also

Mitarbeiter Class


Mitarbeiter.CreateNewStandardProfil Method

Erstellt ein neues Standard Profil für den angegebenen Mitarbeiter

Overloads Shared Sub CreateNewStandardProfil( _
   ByVal mitarbeiterNr As Integer, _
   ByVal mutiererMitarbeiterNr As Integer _
)

Parameters

mitarbeiterNr
Required. Die datenbank Nummer des Mitarbeiters (ID)
mutiererMitarbeiterNr
Required. Die datenbank Nummer des Mutierers (ID)

Source code

[Visual Basic]
    Overloads Shared Sub CreateNewStandardProfil(ByVal mitarbeiterNr As Integer, ByVal mutiererMitarbeiterNr As Integer)
        Dim sqlConn As New SqlConnection()
        Dim sqlCmd As New SqlCommand()

        Try
            sqlCmd.CommandText = "sp_InsMitarbeiterProfil"
            sqlCmd.CommandType = CommandType.StoredProcedure
            sqlCmd.Connection = sqlConn

            sqlCmd.Parameters.Add(New SqlParameter("@MitarbeiterNr", mitarbeiterNr))
            sqlCmd.Parameters.Add(New SqlParameter("@MutiererMitarbeiterNr", mutiererMitarbeiterNr))

            sqlConn.ConnectionString = Common.Datenbank.GetDSN()

            sqlConn.Open()

            sqlCmd.ExecuteNonQuery()

        Catch ex As Exception
            Throw ex
        Finally
            If sqlCmd Is Nothing Then
                sqlCmd.Dispose()
            End If
            If sqlConn Is Nothing Then
                sqlConn.Dispose()
            End If
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Mitarbeiter


Mitarbeiter.GetById Method

Gibt alle Details zur einem Mitarbeiter zurück

Overloads Shared Sub GetById( _
   ByVal mitarbeiterNr As Integer, _
   ByRef dsMitarbeiter As DataSet _
)

Parameters

mitarbeiterNr
Required. Die datenbank Nummer des Mitarbeiters (ID)
dsMitarbeiter
Required. Das zu füllende DataSet

Source code

[Visual Basic]
    Overloads Shared Sub GetById(ByVal mitarbeiterNr As Integer, ByRef dsMitarbeiter As DataSet)
        Dim sqlConn As New SqlConnection()
        Dim sqlCmd As New SqlCommand()
        Dim da As New SqlDataAdapter()

        Try
            sqlCmd.CommandText = "sp_GetMitarbeiterById"
            sqlCmd.CommandType = CommandType.StoredProcedure
            sqlCmd.Connection = sqlConn

            sqlCmd.Parameters.Add(New SqlParameter("@MitarbeiterNr", mitarbeiterNr))

            sqlConn.ConnectionString = Common.Datenbank.GetDSN()

            sqlConn.Open()

            da.SelectCommand = sqlCmd
            da.Fill(dsMitarbeiter, "Mitarbeiter")

        Catch ex As Exception
            Throw ex
        Finally
            If sqlCmd Is Nothing Then
                sqlCmd.Dispose()
            End If
            If sqlConn Is Nothing Then
                sqlConn.Dispose()
            End If
            If da Is Nothing Then
                da.Dispose()
            End If
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Mitarbeiter


Mitarbeiter.GetListe Method

Gibt eine Liste mit allen Mitarbeitern zurück

Overloads Shared Sub GetListe( _
   ByVal teamNr As Integer, _
   ByVal funktionsGruppeNr As Integer, _
   ByRef dsMitarbeiter As DataSet _
)

Parameters

teamNr
Required. Nur Mitarbeiter von diesem Team
funktionsGruppeNr
Required. Nur Mitarbeiter von dieser Funktionsgruppe
dsMitarbeiter
Required. Das DataSet welches gefüllt werden soll

Source code

[Visual Basic]
    Overloads Shared Sub GetListe(ByVal teamNr As Integer, ByVal funktionsGruppeNr As Integer, ByRef dsMitarbeiter As DataSet)
        Dim sqlConn As New SqlConnection()
        Dim sqlCmd As New SqlCommand()
        Dim da As New SqlDataAdapter()

        Try
            sqlCmd.CommandText = "sp_ListMitarbeiter"
            sqlCmd.CommandType = CommandType.StoredProcedure
            sqlCmd.Connection = sqlConn

            sqlConn.ConnectionString = Common.Datenbank.GetDSN()

            If teamNr = 0 Then
                sqlCmd.Parameters.Add(New SqlParameter("@TeamNr", DBNull.Value))
            Else
                sqlCmd.Parameters.Add(New SqlParameter("@TeamNr", teamNr))
            End If

            If funktionsGruppeNr = 0 Then
                sqlCmd.Parameters.Add(New SqlParameter("@FunktionsGruppeNr", DBNull.Value))
            Else
                sqlCmd.Parameters.Add(New SqlParameter("@FunktionsGruppeNr", funktionsGruppeNr))
            End If

            sqlConn.Open()

            da.SelectCommand = sqlCmd
            da.Fill(dsMitarbeiter, "MitarbeiterListe")

        Catch ex As Exception
            Throw ex
        Finally
            If sqlCmd Is Nothing Then
                sqlCmd.Dispose()
            End If
            If sqlConn Is Nothing Then
                sqlConn.Dispose()
            End If
            If da Is Nothing Then
                da.Dispose()
            End If
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Mitarbeiter


Mitarbeiter.Insert Method

Gibt alle Details zur einem Mitarbeiter zurück

Overloads Shared Function Insert( _
   ByVal vorname As String, _
   ByVal name As String, _
   ByVal kurzzeichen As String, _
   ByVal anrede As String, _
   ByVal tgNummer As String, _
   ByVal eMail As String, _
   ByVal fax As String, _
   ByVal telefon As String, _
   ByVal unterschriftText As String, _
   ByVal spracheNr As Integer, _
   ByVal fuerMandant As Integer, _
   ByVal showTipp As Boolean, _
   ByVal partnerNr As Integer, _
   ByVal mandantNr As Integer, _
   ByVal isAktiv As Boolean, _
   ByVal mailEmpfang As Boolean, _
   ByVal edokaMessage As Boolean, _
   ByVal funktion As String, _
   ByVal mailDirektVersenden As Boolean, _
   ByVal rang As String, _
   ByVal mailDokumentrueckgang As Boolean, _
   ByVal klassifizierungNr As Integer, _
   ByVal edokaMail As Boolean, _
   ByVal journalisierung As Boolean, _
   ByVal getMeldung As Boolean, _
   ByVal mail1 As String, _
   ByVal mutiererMitarbeiterNr As Integer _
) As Integer

Parameters

vorname
Required.
name
Required.
kurzzeichen
Required.
anrede
Required.
tgNummer
Required.
eMail
Required.
fax
Required.
telefon
Required.
unterschriftText
Required.
spracheNr
Required.
fuerMandant
Required.
showTipp
Required.
partnerNr
Required.
mandantNr
Required.
isAktiv
Required.
mailEmpfang
Required.
edokaMessage
Required.
funktion
Required.
mailDirektVersenden
Required.
rang
Required.
mailDokumentrueckgang
Required.
klassifizierungNr
Required.
edokaMail
Required.
journalisierung
Required.
getMeldung
Required.
mail1
Required.
mutiererMitarbeiterNr
Required.

Returns

Die MitarbeiterNr des neu eingefügten Mitarbeiters

Source code

[Visual Basic]
    Overloads Shared Function Insert(ByVal vorname As String, ByVal name As String, ByVal kurzzeichen As String, ByVal anrede As String, _
    ByVal tgNummer As String, ByVal eMail As String, ByVal fax As String, ByVal telefon As String, _
    ByVal unterschriftText As String, ByVal spracheNr As Integer, ByVal fuerMandant As Integer, _
    ByVal showTipp As Boolean, ByVal partnerNr As Integer, ByVal mandantNr As Integer, _
    ByVal isAktiv As Boolean, ByVal mailEmpfang As Boolean, ByVal edokaMessage As Boolean, _
    ByVal funktion As String, ByVal mailDirektVersenden As Boolean, ByVal rang As String, _
    ByVal mailDokumentrueckgang As Boolean, ByVal klassifizierungNr As Integer, _
    ByVal edokaMail As Boolean, ByVal journalisierung As Boolean, ByVal getMeldung As Boolean, _
    ByVal mail1 As String, ByVal mutiererMitarbeiterNr As Integer) As Integer

        Dim sqlConn As New SqlConnection()
        Dim sqlCmd As New SqlCommand()

        Try
            sqlCmd.CommandText = "sp_InsertMitarbeiter"
            sqlCmd.CommandType = CommandType.StoredProcedure
            sqlCmd.Connection = sqlConn

            sqlCmd.Parameters.Add(New SqlParameter("@Vorname", vorname))
            sqlCmd.Parameters.Add(New SqlParameter("@Name", name))
            sqlCmd.Parameters.Add(New SqlParameter("@KurzZeichen", kurzzeichen))
            sqlCmd.Parameters.Add(New SqlParameter("@Anrede", anrede))
            sqlCmd.Parameters.Add(New SqlParameter("@TgNummer", tgNummer))
            sqlCmd.Parameters.Add(New SqlParameter("@eMail", eMail))
            sqlCmd.Parameters.Add(New SqlParameter("@Fax", fax))
            sqlCmd.Parameters.Add(New SqlParameter("@Telefon", telefon))
            sqlCmd.Parameters.Add(New SqlParameter("@UnterschriftText", unterschriftText))
            sqlCmd.Parameters.Add(New SqlParameter("@SpracheNr", spracheNr))
            sqlCmd.Parameters.Add(New SqlParameter("@FuerMandantNr", fuerMandant))
            sqlCmd.Parameters.Add(New SqlParameter("@ShowTipp", showTipp))
            sqlCmd.Parameters.Add(New SqlParameter("@PartnerNr", partnerNr))
            sqlCmd.Parameters.Add(New SqlParameter("@MandantNr", mandantNr))
            sqlCmd.Parameters.Add(New SqlParameter("@Aktiv", isAktiv))
            sqlCmd.Parameters.Add(New SqlParameter("@MutiererMitarbeiterNr", mutiererMitarbeiterNr))
            sqlCmd.Parameters.Add(New SqlParameter("@MailEmpfang", mailEmpfang))
            sqlCmd.Parameters.Add(New SqlParameter("@EdokaMessage", edokaMessage))
            sqlCmd.Parameters.Add(New SqlParameter("@Funktion", funktion))
            sqlCmd.Parameters.Add(New SqlParameter("@MailDirektVersenden", mailDirektVersenden))
            sqlCmd.Parameters.Add(New SqlParameter("@Rang", rang))
            sqlCmd.Parameters.Add(New SqlParameter("@MailDokumentRueckgang", mailDokumentrueckgang))
            sqlCmd.Parameters.Add(New SqlParameter("@KlassifizierungNr", klassifizierungNr))
            sqlCmd.Parameters.Add(New SqlParameter("@EdokaMail", edokaMail))
            sqlCmd.Parameters.Add(New SqlParameter("@Journalisierung", journalisierung))
            sqlCmd.Parameters.Add(New SqlParameter("@GebMeldung", getMeldung))
            sqlCmd.Parameters.Add(New SqlParameter("@Mail1", mail1))

            sqlCmd.Parameters.Add(New SqlParameter("@MitarbeiterNr", -1))
            sqlCmd.Parameters("@MitarbeiterNr").Direction = ParameterDirection.InputOutput

            sqlCmd.Parameters.Add(New SqlParameter("@Return", SqlDbType.Int))
            sqlCmd.Parameters("@Return").Direction = ParameterDirection.ReturnValue

            sqlConn.ConnectionString = Common.Datenbank.GetDSN()

            sqlConn.Open()

            If sqlCmd.ExecuteNonQuery() = 0 Then
                Return -1
            Else
                If Convert.ToInt32(sqlCmd.Parameters("@Return").Value) <> 0 Then
                    Throw New Exception("DA.Mitarbeiter.Insert(): Return value was " + sqlCmd.Parameters("@Return").Value)
                Else
                    Return Convert.ToInt32(sqlCmd.Parameters("@MitarbeiterNr").Value)
                End If
            End If

        Catch ex As Exception
            Throw ex
        Finally
            If sqlCmd Is Nothing Then
                sqlCmd.Dispose()
            End If
            If sqlConn Is Nothing Then
                sqlConn.Dispose()
            End If
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Mitarbeiter


Mitarbeiter.Update Method

Aktualisiert alle Details von einem Mitarbeiter

Overloads Shared Function Update( _
   ByVal mitarbeiterNr As Integer, _
   ByVal vorname As String, _
   ByVal name As String, _
   ByVal kurzzeichen As String, _
   ByVal anrede As String, _
   ByVal tgNummer As String, _
   ByVal eMail As String, _
   ByVal fax As String, _
   ByVal telefon As String, _
   ByVal unterschriftText As String, _
   ByVal spracheNr As Integer, _
   ByVal fuerMandant As Integer, _
   ByVal showTipp As Boolean, _
   ByVal partnerNr As Integer, _
   ByVal mandantNr As Integer, _
   ByVal isAktiv As Boolean, _
   ByVal mailEmpfang As Boolean, _
   ByVal edokaMessage As Boolean, _
   ByVal funktion As String, _
   ByVal mailDirektVersenden As Boolean, _
   ByVal rang As String, _
   ByVal mailDokumentrueckgang As Boolean, _
   ByVal klassifizierungNr As Integer, _
   ByVal edokaMail As Boolean, _
   ByVal journalisierung As Boolean, _
   ByVal getMeldung As Boolean, _
   ByVal mail1 As String, _
   ByVal mutiererMitarbeiterNr As Integer _
)

Parameters

mitarbeiterNr
Required.
vorname
Required.
name
Required.
kurzzeichen
Required.
anrede
Required.
tgNummer
Required.
eMail
Required.
fax
Required.
telefon
Required.
unterschriftText
Required.
spracheNr
Required.
fuerMandant
Required.
showTipp
Required.
partnerNr
Required.
mandantNr
Required.
isAktiv
Required.
mailEmpfang
Required.
edokaMessage
Required.
funktion
Required.
mailDirektVersenden
Required.
rang
Required.
mailDokumentrueckgang
Required.
klassifizierungNr
Required.
edokaMail
Required.
journalisierung
Required.
getMeldung
Required.
mail1
Required.
mutiererMitarbeiterNr
Required.

Source code

[Visual Basic]
    Overloads Shared Function Update(ByVal mitarbeiterNr As Integer, ByVal vorname As String, ByVal name As String, ByVal kurzzeichen As String, ByVal anrede As String, _
    ByVal tgNummer As String, ByVal eMail As String, ByVal fax As String, ByVal telefon As String, _
    ByVal unterschriftText As String, ByVal spracheNr As Integer, ByVal fuerMandant As Integer, _
    ByVal showTipp As Boolean, ByVal partnerNr As Integer, ByVal mandantNr As Integer, _
    ByVal isAktiv As Boolean, ByVal mailEmpfang As Boolean, ByVal edokaMessage As Boolean, _
    ByVal funktion As String, ByVal mailDirektVersenden As Boolean, ByVal rang As String, _
    ByVal mailDokumentrueckgang As Boolean, ByVal klassifizierungNr As Integer, _
    ByVal edokaMail As Boolean, ByVal journalisierung As Boolean, ByVal getMeldung As Boolean, _
    ByVal mail1 As String, ByVal mutiererMitarbeiterNr As Integer)

        Dim sqlConn As New SqlConnection()
        Dim sqlCmd As New SqlCommand()

        Try
            sqlCmd.CommandText = "sp_UpdateMitarbeiter"
            sqlCmd.CommandType = CommandType.StoredProcedure
            sqlCmd.Connection = sqlConn

            sqlCmd.Parameters.Add(New SqlParameter("@MitarbeiterNr", mitarbeiterNr))
            sqlCmd.Parameters.Add(New SqlParameter("@Vorname", vorname))
            sqlCmd.Parameters.Add(New SqlParameter("@Name", name))
            sqlCmd.Parameters.Add(New SqlParameter("@KurzZeichen", kurzzeichen))
            sqlCmd.Parameters.Add(New SqlParameter("@Anrede", anrede))
            sqlCmd.Parameters.Add(New SqlParameter("@TgNummer", tgNummer))
            sqlCmd.Parameters.Add(New SqlParameter("@eMail", eMail))
            sqlCmd.Parameters.Add(New SqlParameter("@Fax", fax))
            sqlCmd.Parameters.Add(New SqlParameter("@Telefon", telefon))
            sqlCmd.Parameters.Add(New SqlParameter("@UnterschriftText", unterschriftText))
            sqlCmd.Parameters.Add(New SqlParameter("@SpracheNr", spracheNr))
            sqlCmd.Parameters.Add(New SqlParameter("@FuerMandantNr", fuerMandant))
            sqlCmd.Parameters.Add(New SqlParameter("@ShowTipp", showTipp))
            sqlCmd.Parameters.Add(New SqlParameter("@PartnerNr", partnerNr))
            sqlCmd.Parameters.Add(New SqlParameter("@MandantNr", mandantNr))
            sqlCmd.Parameters.Add(New SqlParameter("@Aktiv", isAktiv))
            sqlCmd.Parameters.Add(New SqlParameter("@MutiererMitarbeiterNr", mutiererMitarbeiterNr))
            sqlCmd.Parameters.Add(New SqlParameter("@MailEmpfang", mailEmpfang))
            sqlCmd.Parameters.Add(New SqlParameter("@EdokaMessage", edokaMessage))
            sqlCmd.Parameters.Add(New SqlParameter("@Funktion", funktion))
            sqlCmd.Parameters.Add(New SqlParameter("@MailDirektVersenden", mailDirektVersenden))
            sqlCmd.Parameters.Add(New SqlParameter("@Rang", rang))
            sqlCmd.Parameters.Add(New SqlParameter("@MailDokumentRueckgang", mailDokumentrueckgang))
            sqlCmd.Parameters.Add(New SqlParameter("@KlassifizierungNr", klassifizierungNr))
            sqlCmd.Parameters.Add(New SqlParameter("@EdokaMail", edokaMail))
            sqlCmd.Parameters.Add(New SqlParameter("@Journalisierung", journalisierung))
            sqlCmd.Parameters.Add(New SqlParameter("@GebMeldung", getMeldung))
            sqlCmd.Parameters.Add(New SqlParameter("@Mail1", mail1))

            sqlConn.ConnectionString = Common.Datenbank.GetDSN()

            sqlConn.Open()

            sqlCmd.ExecuteNonQuery()

        Catch ex As Exception
            Throw ex
        Finally
            If sqlCmd Is Nothing Then
                sqlCmd.Dispose()
            End If
            If sqlConn Is Nothing Then
                sqlConn.Dispose()
            End If
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Mitarbeiter


MitarbeiterFunktionsgruppe Class

Datenzugriff auf Tabelle mitarbeiter_funktionsgruppe

For a list of all members of this type, see MitarbeiterFunktionsgruppe Members.

System.Object
EDOKALib.DataAccess.MitarbeiterFunktionsgruppe

Public Class MitarbeiterFunktionsgruppe

Requirements

Namespace: DataAccess

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKALib.DataAccess (in EDOKALib.DataAccess.dll)

See Also

MitarbeiterFunktionsgruppe Members


MitarbeiterFunktionsgruppe Members

MitarbeiterFunktionsgruppe overview

Methods

method Delete | Fügt einen Mitarbeiter zu einer Funktionsgruppe hinzu
method GetListeByMitarbeiterNr | Gibt eine Liste mit allen Funktionsgrupppen denen ein Mitarbeiter zugewiesen ist zurück
method Insert | Fügt einen Mitarbeiter zu einer Funktionsgruppe hinzu
method SetAktiv | Set den Aktiv Status einer Mitarbeiter Funktionsgruppen Zuordnung

See Also

MitarbeiterFunktionsgruppe Class


MitarbeiterFunktionsgruppe Methods

MitarbeiterFunktionsgruppe overview

Methods

method Delete | Fügt einen Mitarbeiter zu einer Funktionsgruppe hinzu
method GetListeByMitarbeiterNr | Gibt eine Liste mit allen Funktionsgrupppen denen ein Mitarbeiter zugewiesen ist zurück
method Insert | Fügt einen Mitarbeiter zu einer Funktionsgruppe hinzu
method SetAktiv | Set den Aktiv Status einer Mitarbeiter Funktionsgruppen Zuordnung

See Also

MitarbeiterFunktionsgruppe Class


MitarbeiterFunktionsgruppe.Delete Method

Fügt einen Mitarbeiter zu einer Funktionsgruppe hinzu

Public Overloads Shared Function Delete( _
   ByVal mitarbeiter_funktionsGruppeNr As Integer, _
   ByVal mutiererMitarbeiterNr As Integer _
)

Parameters

mitarbeiter_funktionsGruppeNr
Required.
mutiererMitarbeiterNr
Required. Mitarbeiter welcher die Änderung vornimmt

Source code

[Visual Basic]
    Public Overloads Shared Function Delete(ByVal mitarbeiter_funktionsGruppeNr As Integer, ByVal mutiererMitarbeiterNr As Integer)
        Dim sqlConn As New SqlConnection()
        Dim sqlCmd As New SqlCommand()

        Try
            sqlCmd.CommandText = "sp_DeleteMitarbeiterFunktionsGruppe"
            sqlCmd.CommandType = CommandType.StoredProcedure
            sqlCmd.Connection = sqlConn

            sqlCmd.Parameters.Add(New SqlParameter("@Mitarbeiter_FunktionsGruppeNr", mitarbeiter_funktionsGruppeNr))
            sqlCmd.Parameters.Add(New SqlParameter("@MutiererMANr", mutiererMitarbeiterNr))

            sqlConn.ConnectionString = Common.Datenbank.GetDSN()

            sqlConn.Open()

            sqlCmd.ExecuteNonQuery()

        Catch ex As Exception
            Throw ex
        Finally
            If sqlCmd Is Nothing Then
                sqlCmd.Dispose()
            End If
            If sqlConn Is Nothing Then
                sqlConn.Dispose()
            End If
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

MitarbeiterFunktionsgruppe


MitarbeiterFunktionsgruppe.GetListeByMitarbeiterNr Method

Gibt eine Liste mit allen Funktionsgrupppen denen ein Mitarbeiter zugewiesen ist zurück

Overloads Shared Sub GetListeByMitarbeiterNr( _
   ByVal mitarbeiterNr As Integer, _
   ByRef ds As DataSet _
)

Parameters

mitarbeiterNr
Required.
ds
Required. Das DataSet welches gefüllt werden soll

Source code

[Visual Basic]
    Overloads Shared Sub GetListeByMitarbeiterNr(ByVal mitarbeiterNr As Integer, ByRef ds As DataSet)
        Dim sqlConn As New SqlConnection()
        Dim sqlCmd As New SqlCommand()
        Dim da As New SqlDataAdapter()

        Try
            sqlCmd.CommandText = "sp_GetMitarbeiterFunktionsgruppen"
            sqlCmd.CommandType = CommandType.StoredProcedure
            sqlCmd.Connection = sqlConn

            sqlCmd.Parameters.Add(New SqlParameter("@MitarbeiterNr", mitarbeiterNr))

            sqlConn.ConnectionString = Common.Datenbank.GetDSN()

            sqlConn.Open()

            da.SelectCommand = sqlCmd
            da.Fill(ds, "FunktionsgruppenListe")

        Catch ex As Exception
            Throw ex
        Finally
            If sqlCmd Is Nothing Then
                sqlCmd.Dispose()
            End If
            If sqlConn Is Nothing Then
                sqlConn.Dispose()
            End If
            If da Is Nothing Then
                da.Dispose()
            End If
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

MitarbeiterFunktionsgruppe


MitarbeiterFunktionsgruppe.Insert Method

Fügt einen Mitarbeiter zu einer Funktionsgruppe hinzu

Public Overloads Shared Sub Insert( _
   ByVal mitarbeiterNr As Integer, _
   ByVal funktionsGruppeNr As Integer, _
   ByVal mutiererMitarbeiterNr As Integer _
)

Parameters

mitarbeiterNr
Required. Mitarbeiter ID welche hinzugefügt werden soll
funktionsGruppeNr
Required. Ziel-Funktionsgruppe
mutiererMitarbeiterNr
Required. Mitarbeiter welcher die Änderung vornimmt

Source code

[Visual Basic]
    Public Overloads Shared Sub Insert(ByVal mitarbeiterNr As Integer, ByVal funktionsGruppeNr As Integer, ByVal mutiererMitarbeiterNr As Integer)
        Dim sqlConn As New SqlConnection()
        Dim sqlCmd As New SqlCommand()

        Try
            sqlCmd.CommandText = "sp_InsertMitarbeiterFunktionsGruppe"
            sqlCmd.CommandType = CommandType.StoredProcedure
            sqlCmd.Connection = sqlConn

            sqlCmd.Parameters.Add(New SqlParameter("@MitarbeiterNr", mitarbeiterNr))
            sqlCmd.Parameters.Add(New SqlParameter("@FunktionsGruppeNr", funktionsGruppeNr))
            sqlCmd.Parameters.Add(New SqlParameter("@MutiererMANr", mutiererMitarbeiterNr))

            sqlConn.ConnectionString = Common.Datenbank.GetDSN()

            sqlConn.Open()

            sqlCmd.ExecuteNonQuery()

        Catch ex As Exception
            Throw ex
        Finally
            If sqlCmd Is Nothing Then
                sqlCmd.Dispose()
            End If
            If sqlConn Is Nothing Then
                sqlConn.Dispose()
            End If
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

MitarbeiterFunktionsgruppe


MitarbeiterFunktionsgruppe.SetAktiv Method

Set den Aktiv Status einer Mitarbeiter Funktionsgruppen Zuordnung

Overloads Shared Sub SetAktiv( _
   ByVal mitarbeiterFunktionsgruppeNr As Integer, _
   ByVal isAktiv As Boolean, _
   ByVal mutiererMitarbeiterNr As Integer _
)

Parameters

mitarbeiterFunktionsgruppeNr
Required. Das DataSet welches gefüllt werden soll
isAktiv
Required. Das DataSet welches gefüllt werden soll
mutiererMitarbeiterNr
Required.

Source code

[Visual Basic]
    Overloads Shared Sub SetAktiv(ByVal mitarbeiterFunktionsgruppeNr As Integer, ByVal isAktiv As Boolean, ByVal mutiererMitarbeiterNr As Integer)
        Dim sqlConn As New SqlConnection()
        Dim sqlCmd As New SqlCommand()

        Try
            sqlCmd.CommandText = "sp_SetMitarbeiterFunktionsgruppen"
            sqlCmd.CommandType = CommandType.StoredProcedure
            sqlCmd.Connection = sqlConn

            sqlCmd.Parameters.Add(New SqlParameter("@MitarbeiterFunktionsgruppeNr", mitarbeiterFunktionsgruppeNr))
            sqlCmd.Parameters.Add(New SqlParameter("@IsAktiv", isAktiv))
            sqlCmd.Parameters.Add(New SqlParameter("@MutiererMitarbeiterNr", mutiererMitarbeiterNr))

            sqlConn.ConnectionString = Common.Datenbank.GetDSN()

            sqlConn.Open()

            sqlCmd.ExecuteNonQuery()

        Catch ex As Exception
            Throw ex
        Finally
            If sqlCmd Is Nothing Then
                sqlCmd.Dispose()
            End If
            If sqlConn Is Nothing Then
                sqlConn.Dispose()
            End If
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

MitarbeiterFunktionsgruppe


NullHandler Class

For a list of all members of this type, see NullHandler Members.

System.Object
EDOKALib.DataAccess.NullHandler

Public Class NullHandler

Requirements

Namespace: DataAccess

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKALib.DataAccess (in EDOKALib.DataAccess.dll)

See Also

NullHandler Members


NullHandler Members

NullHandler overview

Methods

method CToSqlDateTime
method CToSqlInt
method CToSqlString

See Also

NullHandler Class


NullHandler Methods

NullHandler overview

Methods

method CToSqlDateTime
method CToSqlInt
method CToSqlString

See Also

NullHandler Class


NullHandler.CToSqlDateTime Method

Public Shared Function CToSqlDateTime( _
   ByVal value As DateTime _
) As SqlTypes.SqlDateTime

Parameters

value
Required.

Source code

[Visual Basic]
    Public Shared Function CToSqlDateTime(ByVal value As DateTime) As SqlTypes.SqlDateTime
        If value = DateTime.MinValue Then
            Return SqlTypes.SqlDateTime.Null
        Else
            Return New SqlTypes.SqlDateTime(value)
        End If
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

NullHandler


NullHandler.CToSqlInt Method

Public Shared Function CToSqlInt( _
   ByVal value As Integer _
) As SqlTypes.SqlInt32

Parameters

value
Required.

Source code

[Visual Basic]
    Public Shared Function CToSqlInt(ByVal value As Integer) As SqlTypes.SqlInt32
        If value = Config.NullReplacer Then
            Return SqlTypes.SqlInt32.Null
        Else
            Return SqlTypes.SqlInt32.Parse(value.ToString())
        End If
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

NullHandler


NullHandler.CToSqlString Method

Public Shared Function CToSqlString( _
   ByVal value As String _
) As SqlTypes.SqlString

Parameters

value
Required.

Source code

[Visual Basic]
    Public Shared Function CToSqlString(ByVal value As String) As SqlTypes.SqlString
        If value = Config.NullReplacer.ToString() Then
            Return SqlTypes.SqlString.Null
        Else
            Return New SqlTypes.SqlString(value)
        End If
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

NullHandler


OfficeVorlage Class

Datenzugriff auf Tabelle office_vorlage

For a list of all members of this type, see OfficeVorlage Members.

System.Object
EDOKALib.DataAccess.OfficeVorlage

Public Class OfficeVorlage

Requirements

Namespace: DataAccess

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKALib.DataAccess (in EDOKALib.DataAccess.dll)

See Also

OfficeVorlage Members


OfficeVorlage Members

OfficeVorlage overview

Methods

method Add | Fügt eine neue OffiecVorlage in die DB ein
method Delete | Löscht eine bestehende officeVorlage
method GetByNr |
method List | gibt eine liste aller office vorlagen zurück
method Update | Aktualisiert eine OfficeVorlage in der Datenbank

See Also

OfficeVorlage Class


OfficeVorlage Methods

OfficeVorlage overview

Methods

method Add | Fügt eine neue OffiecVorlage in die DB ein
method Delete | Löscht eine bestehende officeVorlage
method GetByNr |
method List | gibt eine liste aller office vorlagen zurück
method Update | Aktualisiert eine OfficeVorlage in der Datenbank

See Also

OfficeVorlage Class


OfficeVorlage.Add Method

Fügt eine neue OffiecVorlage in die DB ein

Public Shared Function Add( _
   ByRef officeVorlageNr As Integer, _
   ByVal bezeichnung As String, _
   ByVal beschreibung As String, _
   ByVal vorlageId As Integer, _
   ByVal vorlageName As String, _
   ByVal prefixDokumentName As String, _
   ByVal idvVorlage As Boolean, _
   ByVal idvId As String, _
   ByVal officeVorlage As String, _
   ByVal absenderErsteller As Boolean, _
   ByVal idvNativ As Boolean, _
   ByVal dokumentGeschuetzt As Boolean, _
   ByVal kopfzeileGenerieren As Boolean, _
   ByVal klassifizierung As Integer, _
   ByVal bcpt As Integer, _
   ByVal bcpl As Integer, _
   ByVal bcw As Integer, _
   ByVal bch As Integer, _
   ByVal bchorizontal As Boolean, _
   ByVal mandantNr As Integer, _
   ByVal aktiv As Boolean, _
   ByVal erstelltAm As DateTime, _
   ByVal mutiertAm As DateTime, _
   ByVal mutierer As Integer, _
   ByVal anwendungNr As Integer, _
   ByVal owner As Integer _
) As Integer

Parameters

officeVorlageNr
Required.
bezeichnung
Required.
beschreibung
Required.
vorlageId
Required.
vorlageName
Required.
prefixDokumentName
Required.
idvVorlage
Required.
idvId
Required.
officeVorlage
Required.
absenderErsteller
Required.
idvNativ
Required.
dokumentGeschuetzt
Required.
kopfzeileGenerieren
Required.
klassifizierung
Required.
bcpt
Required.
bcpl
Required.
bcw
Required.
bch
Required.
bchorizontal
Required.
mandantNr
Required.
aktiv
Required.
erstelltAm
Required.
mutiertAm
Required.
mutierer
Required.
anwendungNr
Required.
owner
Required.

Returns

error

Source code

[Visual Basic]
    Public Shared Function Add(ByRef officeVorlageNr As Integer, ByVal bezeichnung As String, ByVal beschreibung As String, _
     ByVal vorlageId As Integer, ByVal vorlageName As String, ByVal prefixDokumentName As String, ByVal idvVorlage As Boolean, ByVal idvId As String, _
     ByVal officeVorlage As String, ByVal absenderErsteller As Boolean, ByVal idvNativ As Boolean, ByVal dokumentGeschuetzt As Boolean, _
     ByVal kopfzeileGenerieren As Boolean, ByVal klassifizierung As Integer, ByVal bcpt As Integer, ByVal bcpl As Integer, ByVal bcw As Integer, _
     ByVal bch As Integer, ByVal bchorizontal As Boolean, ByVal mandantNr As Integer, ByVal aktiv As Boolean, ByVal erstelltAm As DateTime, _
     ByVal mutiertAm As DateTime, ByVal mutierer As Integer, ByVal anwendungNr As Integer, ByVal owner As Integer) As Integer

        Dim sqlConn As New SqlConnection()
        Dim sqlCmd As New SqlCommand()

        Try
            sqlConn.ConnectionString = Common.Datenbank.GetDSN()
            sqlCmd.CommandText = "sp_InsOfficeVorlage"
            sqlCmd.CommandType = CommandType.StoredProcedure
            sqlCmd.Connection = sqlConn

            sqlCmd.Parameters.Add(New SqlParameter("@bezeichnung", NullHandler.CToSqlString(bezeichnung)))
            sqlCmd.Parameters.Add(New SqlParameter("@beschreibung", NullHandler.CToSqlString(beschreibung)))
            sqlCmd.Parameters.Add(New SqlParameter("@vorlageid", NullHandler.CToSqlInt(vorlageId)))
            sqlCmd.Parameters.Add(New SqlParameter("@vorlagename", NullHandler.CToSqlString(vorlageName)))
            sqlCmd.Parameters.Add(New SqlParameter("@prefix_dokumentname", NullHandler.CToSqlString(prefixDokumentName)))
            sqlCmd.Parameters.Add(New SqlParameter("@idv_vorlage", idvVorlage))
            sqlCmd.Parameters.Add(New SqlParameter("@idv_id", NullHandler.CToSqlString(idvId)))
            sqlCmd.Parameters.Add(New SqlParameter("@Office_Vorlage", NullHandler.CToSqlString(officeVorlage)))
            sqlCmd.Parameters.Add(New SqlParameter("@absender_ersteller", NullHandler.CToSqlString(absenderErsteller)))
            sqlCmd.Parameters.Add(New SqlParameter("@idv_nativ", idvNativ))
            sqlCmd.Parameters.Add(New SqlParameter("@dokument_geschuetzt", dokumentGeschuetzt))
            sqlCmd.Parameters.Add(New SqlParameter("@kopfzeile_generieren", kopfzeileGenerieren))
            sqlCmd.Parameters.Add(New SqlParameter("@klassifizierung", NullHandler.CToSqlInt(klassifizierung)))
            sqlCmd.Parameters.Add(New SqlParameter("@bcpt", bcpt))
            sqlCmd.Parameters.Add(New SqlParameter("@bcpl", NullHandler.CToSqlInt(bcpl)))
            sqlCmd.Parameters.Add(New SqlParameter("@bcw", bcw))
            sqlCmd.Parameters.Add(New SqlParameter("@bch", bch))
            sqlCmd.Parameters.Add(New SqlParameter("@bchorizontal", bchorizontal))
            sqlCmd.Parameters.Add(New SqlParameter("@mandantnr", NullHandler.CToSqlInt(mandantNr)))
            sqlCmd.Parameters.Add(New SqlParameter("@aktiv", aktiv))
            sqlCmd.Parameters.Add(New SqlParameter("@erstellt_am", NullHandler.CToSqlDateTime(erstelltAm)))
            sqlCmd.Parameters.Add(New SqlParameter("@mutiert_am", NullHandler.CToSqlDateTime(mutiertAm)))
            sqlCmd.Parameters.Add(New SqlParameter("@mutierer", NullHandler.CToSqlInt(mutierer)))
            sqlCmd.Parameters.Add(New SqlParameter("@anwendungnr", NullHandler.CToSqlInt(anwendungNr)))
            sqlCmd.Parameters.Add(New SqlParameter("@OWNER", NullHandler.CToSqlInt(owner)))

            sqlCmd.Parameters.Add(New SqlParameter("@OfficeVorlageNr", DBNull.Value))
            sqlCmd.Parameters.Add(New SqlParameter("@Return", DBNull.Value))
            sqlCmd.Parameters("@OfficeVorlageNr").Direction = ParameterDirection.Output
            sqlCmd.Parameters("@Return").Direction = ParameterDirection.ReturnValue

            sqlConn.Open()
            sqlCmd.ExecuteNonQuery()

            If CInt(sqlCmd.Parameters("@Return").Value) <> 0 Then
                officeVorlageNr = CInt(sqlCmd.Parameters("@OfficeVorlageNr").Value)
            End If

            Return CInt(sqlCmd.Parameters("@Return").Value)

        Catch ex As Exception
            TKBLib.Errorhandling.TraceHelper.Msg("EDOKALib.DA.OfficeVorlage.Add", ex.Message + " " + ex.StackTrace, TraceLevel.Error)
            Throw ex
        Finally
            sqlConn.Dispose()
            sqlCmd.Dispose()
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

OfficeVorlage


OfficeVorlage.Delete Method

Löscht eine bestehende officeVorlage

Public Shared Function Delete( _
   ByVal officeVorlageNr As Integer _
) As Integer

Parameters

officeVorlageNr
Required.

Returns

error

Source code

[Visual Basic]
    Public Shared Function Delete(ByVal officeVorlageNr As Integer) As Integer
        Dim sqlConn As New SqlConnection()
        Dim sqlCmd As New SqlCommand()

        Try
            sqlConn.ConnectionString = Common.Datenbank.GetDSN()
            sqlCmd.CommandText = "sp_DelOfficeVorlage"
            sqlCmd.CommandType = CommandType.StoredProcedure
            sqlCmd.Connection = sqlConn

            sqlCmd.Parameters.Add(New SqlParameter("@OfficeVorlageNr", officeVorlageNr))
            sqlCmd.Parameters.Add(New SqlParameter("@Return", DBNull.Value))
            sqlCmd.Parameters("@Return").Direction = ParameterDirection.ReturnValue

            sqlConn.Open()
            sqlCmd.ExecuteNonQuery()

            Return CInt(sqlCmd.Parameters("@Return").Value)

        Catch ex As Exception
            TKBLib.Errorhandling.TraceHelper.Msg("EDOKALib.DA.OfficeVorlage.Delete", ex.Message + " " + ex.StackTrace, TraceLevel.Error)
            Throw ex
        Finally
            sqlConn.Dispose()
            sqlCmd.Dispose()
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

OfficeVorlage


OfficeVorlage.GetByNr Method

Public Shared Sub GetByNr( _
   ByRef ds As DataSet, _
   ByVal officeVorlageNr As Integer _
)

Parameters

ds
Required.
officeVorlageNr
Required.

Source code

[Visual Basic]
    Public Shared Sub GetByNr(ByRef ds As DataSet, ByVal officeVorlageNr As Integer)
        Dim sqlConn As New SqlConnection()
        Dim sqlCmd As New SqlCommand()
        Dim da As New SqlDataAdapter()

        Try
            sqlConn.ConnectionString = Common.Datenbank.GetDSN()
            sqlCmd.CommandText = "sp_GetOfficeVorlageByNr"
            sqlCmd.CommandType = CommandType.StoredProcedure
            sqlCmd.Connection = sqlConn

            sqlCmd.Parameters.Add(New SqlParameter("@OfficeVorlageNr", officeVorlageNr))
            da.SelectCommand = sqlCmd
            da.Fill(ds, "OfficeVorlage")

        Catch ex As Exception
            TKBLib.Errorhandling.TraceHelper.Msg("EDOKALib.DA.OfficeVorlage.GetOfficeVorlageByNr", ex.Message + " " + ex.StackTrace, TraceLevel.Error)
            Throw ex
        Finally
            sqlConn.Dispose()
            sqlCmd.Dispose()
            da.Dispose()
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

OfficeVorlage


OfficeVorlage.List Method

gibt eine liste aller office vorlagen zurück

Public Shared Sub List( _
   ByRef ds As DataSet, _
   ByVal aktiv As Integer _
)

Parameters

ds
Required. für datenrückgabe
aktiv
Required. 1 nur aktive; 0 nur inaktive; -1 alle

Source code

[Visual Basic]
    Public Shared Sub List(ByRef ds As DataSet, ByVal aktiv As Integer)
        Dim sqlConn As New SqlConnection()
        Dim sqlCmd As New SqlCommand()
        Dim da As New SqlDataAdapter()

        Try
            sqlConn.ConnectionString = Common.Datenbank.GetDSN()
            sqlCmd.CommandText = "sp_ListOfficeVorlage"
            sqlCmd.CommandType = CommandType.StoredProcedure
            sqlCmd.Connection = sqlConn

            sqlCmd.Parameters.Add(New SqlParameter("@Aktiv", aktiv))

            da.SelectCommand = sqlCmd
            da.Fill(ds, "OfficeVorlagen")

        Catch ex As Exception
            TKBLib.Errorhandling.TraceHelper.Msg("EDOKALib.DA.OfficeVorlage.List", ex.Message + " " + ex.StackTrace, TraceLevel.Error)
            Throw ex
        Finally
            sqlConn.Dispose()
            sqlCmd.Dispose()
            da.Dispose()
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

OfficeVorlage


OfficeVorlage.Update Method

Aktualisiert eine OfficeVorlage in der Datenbank

Public Shared Function Update( _
   ByVal officeVorlageNr As Integer, _
   ByVal bezeichnung As String, _
   ByVal beschreibung As String, _
   ByVal vorlageId As Integer, _
   ByVal vorlageName As String, _
   ByVal prefixDokumentName As String, _
   ByVal idvVorlage As Boolean, _
   ByVal idvId As String, _
   ByVal officeVorlage As String, _
   ByVal absenderErsteller As Boolean, _
   ByVal idvNativ As Boolean, _
   ByVal dokumentGeschuetzt As Boolean, _
   ByVal kopfzeileGenerieren As Boolean, _
   ByVal klassifizierung As Integer, _
   ByVal bcpt As Integer, _
   ByVal bcpl As Integer, _
   ByVal bcw As Integer, _
   ByVal bch As Integer, _
   ByVal bchorizontal As Boolean, _
   ByVal mandantNr As Integer, _
   ByVal aktiv As Boolean, _
   ByVal erstelltAm As DateTime, _
   ByVal mutiertAm As DateTime, _
   ByVal mutierer As Integer, _
   ByVal anwendungNr As Integer, _
   ByVal owner As Integer _
) As Integer

Parameters

officeVorlageNr
Required.
bezeichnung
Required.
beschreibung
Required.
vorlageId
Required.
vorlageName
Required.
prefixDokumentName
Required.
idvVorlage
Required.
idvId
Required.
officeVorlage
Required.
absenderErsteller
Required.
idvNativ
Required.
dokumentGeschuetzt
Required.
kopfzeileGenerieren
Required.
klassifizierung
Required.
bcpt
Required.
bcpl
Required.
bcw
Required.
bch
Required.
bchorizontal
Required.
mandantNr
Required.
aktiv
Required.
erstelltAm
Required.
mutiertAm
Required.
mutierer
Required.
anwendungNr
Required.
owner
Required.

Source code

[Visual Basic]
    Public Shared Function Update(ByVal officeVorlageNr As Integer, ByVal bezeichnung As String, ByVal beschreibung As String, _
      ByVal vorlageId As Integer, ByVal vorlageName As String, ByVal prefixDokumentName As String, ByVal idvVorlage As Boolean, ByVal idvId As String, _
      ByVal officeVorlage As String, ByVal absenderErsteller As Boolean, ByVal idvNativ As Boolean, ByVal dokumentGeschuetzt As Boolean, _
      ByVal kopfzeileGenerieren As Boolean, ByVal klassifizierung As Integer, ByVal bcpt As Integer, ByVal bcpl As Integer, ByVal bcw As Integer, _
      ByVal bch As Integer, ByVal bchorizontal As Boolean, ByVal mandantNr As Integer, ByVal aktiv As Boolean, ByVal erstelltAm As DateTime, _
      ByVal mutiertAm As DateTime, ByVal mutierer As Integer, ByVal anwendungNr As Integer, ByVal owner As Integer) As Integer

        Dim sqlConn As New SqlConnection()
        Dim sqlCmd As New SqlCommand()

        Try
            sqlConn.ConnectionString = Common.Datenbank.GetDSN()
            sqlCmd.CommandText = "sp_SetOfficeVorlage"
            sqlCmd.CommandType = CommandType.StoredProcedure
            sqlCmd.Connection = sqlConn

            sqlCmd.Parameters.Add(New SqlParameter("@bezeichnung", bezeichnung))
            sqlCmd.Parameters.Add(New SqlParameter("@beschreibung", beschreibung))
            sqlCmd.Parameters.Add(New SqlParameter("@vorlageid", vorlageId))
            sqlCmd.Parameters.Add(New SqlParameter("@vorlagename", vorlageName))
            sqlCmd.Parameters.Add(New SqlParameter("@prefix_dokumentname", prefixDokumentName))
            sqlCmd.Parameters.Add(New SqlParameter("@idv_vorlage", idvVorlage))
            sqlCmd.Parameters.Add(New SqlParameter("@idv_id", idvId))
            sqlCmd.Parameters.Add(New SqlParameter("@Office_Vorlage", NullHandler.CToSqlString(officeVorlage)))
            sqlCmd.Parameters.Add(New SqlParameter("@absender_ersteller", absenderErsteller))
            sqlCmd.Parameters.Add(New SqlParameter("@idv_nativ", idvNativ))
            sqlCmd.Parameters.Add(New SqlParameter("@dokument_geschuetzt", dokumentGeschuetzt))
            sqlCmd.Parameters.Add(New SqlParameter("@kopfzeile_generieren", kopfzeileGenerieren))
            sqlCmd.Parameters.Add(New SqlParameter("@klassifizierung", klassifizierung))
            sqlCmd.Parameters.Add(New SqlParameter("@bcpt", bcpt))
            sqlCmd.Parameters.Add(New SqlParameter("@bcpl", bcpl))
            sqlCmd.Parameters.Add(New SqlParameter("@bcw", bcw))
            sqlCmd.Parameters.Add(New SqlParameter("@bch", bch))
            sqlCmd.Parameters.Add(New SqlParameter("@bchorizontal", bchorizontal))
            sqlCmd.Parameters.Add(New SqlParameter("@mandantnr", mandantNr))
            sqlCmd.Parameters.Add(New SqlParameter("@aktiv", aktiv))
            sqlCmd.Parameters.Add(New SqlParameter("@erstellt_am", erstelltAm))
            sqlCmd.Parameters.Add(New SqlParameter("@mutiert_am", mutiertAm))
            sqlCmd.Parameters.Add(New SqlParameter("@mutierer", mutierer))
            sqlCmd.Parameters.Add(New SqlParameter("@anwendungnr", anwendungNr))
            sqlCmd.Parameters.Add(New SqlParameter("@OWNER", owner))

            sqlCmd.Parameters.Add(New SqlParameter("@Return", DBNull.Value))
            sqlCmd.Parameters("@Return").Direction = ParameterDirection.ReturnValue

            sqlConn.Open()
            sqlCmd.ExecuteNonQuery()

            Return CInt(sqlCmd.Parameters("@Return").Value)

        Catch ex As Exception
            TKBLib.Errorhandling.TraceHelper.Msg("EDOKALib.DA.OfficeVorlage.Update", ex.Message + " " + ex.StackTrace, TraceLevel.Error)
            Throw ex
        Finally
            sqlConn.Dispose()
            sqlCmd.Dispose()
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

OfficeVorlage


Parameter Class

Datenzugriff auf die Tabelle Parameter

For a list of all members of this type, see Parameter Members.

System.Object
EDOKALib.DataAccess.Parameter

Public Class Parameter

Requirements

Namespace: DataAccess

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKALib.DataAccess (in EDOKALib.DataAccess.dll)

See Also

Parameter Members


Parameter Members

Parameter overview

Methods

method Add | erstellt einen neuen parameter
method Delete | löscht einen parameter
method GetParameter | gibt einen einzelnen paramter zurück
method List | gibt eine liste aller paramter zurück
method Update | aktualisiert einen paramter

See Also

Parameter Class


Parameter Methods

Parameter overview

Methods

method Add | erstellt einen neuen parameter
method Delete | löscht einen parameter
method GetParameter | gibt einen einzelnen paramter zurück
method List | gibt eine liste aller paramter zurück
method Update | aktualisiert einen paramter

See Also

Parameter Class


Parameter.Add Method

erstellt einen neuen parameter

Public Shared Function Add( _
   ByRef parameterId As Integer, _
   ByVal benutzerNr As Integer, _
   ByVal name As String, _
   ByVal wert As String, _
   ByVal datentyp As Integer, _
   ByVal beschreibung As String, _
   ByVal aktiv As Boolean, _
   ByVal mutiererId As Integer _
) As Integer

Parameters

parameterId
Required. gibt den neuen primary key zurück
benutzerNr
Required.
name
Required.
wert
Required.
datentyp
Required.
beschreibung
Required.
aktiv
Required.
mutiererId
Required.

Returns

error

Source code

[Visual Basic]
    Public Shared Function Add(ByRef parameterId As Integer, ByVal benutzerNr As Integer, ByVal name As String, ByVal wert As String, _
            ByVal datentyp As Integer, ByVal beschreibung As String, ByVal aktiv As Boolean, ByVal mutiererId As Integer) As Integer

        Dim sqlConn As New SqlConnection()
        Dim sqlCmd As New SqlCommand()

        Try
            sqlConn.ConnectionString = Common.Datenbank.GetDSN()
            sqlCmd.CommandText = "sp_InsParameter"
            sqlCmd.CommandType = CommandType.StoredProcedure
            sqlCmd.Connection = sqlConn

            sqlCmd.Parameters.Add(New SqlParameter("@BenutzerNr", benutzerNr))
            sqlCmd.Parameters.Add(New SqlParameter("@Name", name))
            sqlCmd.Parameters.Add(New SqlParameter("@Wert", wert))
            sqlCmd.Parameters.Add(New SqlParameter("@Datentyp", datentyp))
            sqlCmd.Parameters.Add(New SqlParameter("@Beschreibung", beschreibung))
            sqlCmd.Parameters.Add(New SqlParameter("@Aktiv", aktiv))
            sqlCmd.Parameters.Add(New SqlParameter("@MutiererId", mutiererId))
            sqlCmd.Parameters.Add(New SqlParameter("@ParameterId", 0))
            sqlCmd.Parameters.Add(New SqlParameter("@Return", DBNull.Value))
            sqlCmd.Parameters("@ParameterId").Direction = ParameterDirection.Output
            sqlCmd.Parameters("@Return").Direction = ParameterDirection.ReturnValue

            sqlConn.Open()
            sqlCmd.ExecuteNonQuery()

            If CInt(sqlCmd.Parameters("@Return").Value) <> 0 Then
                parameterId = CInt(sqlCmd.Parameters("@ParameterId").Value)
            End If

            Return CInt(sqlCmd.Parameters("@Return").Value)

        Catch ex As Exception
            TKBLib.Errorhandling.TraceHelper.Msg("EDOKALib.DA.Parameter.Add", ex.Message + " " + ex.StackTrace, TraceLevel.Error)
            Throw ex
        Finally
            sqlConn.Dispose()
            sqlCmd.Dispose()
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Parameter


Parameter.Delete Method

löscht einen parameter

Public Shared Function Delete( _
   ByVal benutzerNr As Integer, _
   ByVal name As String _
) As Integer

Parameters

benutzerNr
Required.
name
Required.

Returns

error

Source code

[Visual Basic]
    Public Shared Function Delete(ByVal benutzerNr As Integer, ByVal name As String) As Integer
        Dim sqlConn As New SqlConnection()
        Dim sqlCmd As New SqlCommand()

        Try
            sqlConn.ConnectionString = Common.Datenbank.GetDSN()
            sqlCmd.CommandText = "sp_DelParameter"
            sqlCmd.CommandType = CommandType.StoredProcedure
            sqlCmd.Connection = sqlConn

            sqlCmd.Parameters.Add(New SqlParameter("@BenutzerNr", benutzerNr))
            sqlCmd.Parameters.Add(New SqlParameter("@Name", name))
            sqlCmd.Parameters.Add(New SqlParameter("@Return", DBNull.Value))
            sqlCmd.Parameters("@Return").Direction = ParameterDirection.ReturnValue

            sqlConn.Open()
            sqlCmd.ExecuteNonQuery()

            Return CInt(sqlCmd.Parameters("@Return").Value)

        Catch ex As Exception
            TKBLib.Errorhandling.TraceHelper.Msg("EDOKALib.DA.Parameter.Delete", ex.Message + " " + ex.StackTrace, TraceLevel.Error)
            Throw ex
        Finally
            sqlConn.Dispose()
            sqlCmd.Dispose()
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Parameter


Parameter.GetParameter Method

gibt einen einzelnen paramter zurück

Public Shared Sub GetParameter( _
   ByRef ds As DataSet, _
   ByVal benutzerNr As Integer, _
   ByVal name As String _
)

Parameters

ds
Required. speicher für datenrückgabe
benutzerNr
Required.
name
Required.

Source code

[Visual Basic]
    Public Shared Sub GetParameter(ByRef ds As DataSet, ByVal benutzerNr As Integer, ByVal name As String)
        Dim sqlConn As New SqlConnection()
        Dim sqlCmd As New SqlCommand()
        Dim da As New SqlDataAdapter()

        Try
            sqlConn.ConnectionString = Common.Datenbank.GetDSN()
            sqlCmd.CommandText = "sp_GetParameter"
            sqlCmd.CommandType = CommandType.StoredProcedure
            sqlCmd.Connection = sqlConn

            sqlCmd.Parameters.Add(New SqlParameter("@BenutzerNr", benutzerNr))
            sqlCmd.Parameters.Add(New SqlParameter("@Name", name))
            da.SelectCommand = sqlCmd
            da.Fill(ds, "Parameter")

        Catch ex As Exception
            TKBLib.Errorhandling.TraceHelper.Msg("EDOKALib.DA.Parameter.GetParameter", ex.Message + " " + ex.StackTrace, TraceLevel.Error)
            Throw ex
        Finally
            sqlConn.Dispose()
            sqlCmd.Dispose()
            da.Dispose()
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Parameter


Parameter.List Method

gibt eine liste aller paramter zurück

Public Shared Sub List( _
   ByRef ds As DataSet, _
   ByVal aktiv As Integer _
)

Parameters

ds
Required. speicher für datenrückgabe
aktiv
Required. 1 nur aktive; 0 nur inaktive; -1 alle

Source code

[Visual Basic]
    Public Shared Sub List(ByRef ds As DataSet, ByVal aktiv As Integer)
        Dim sqlConn As New SqlConnection()
        Dim sqlCmd As New SqlCommand()
        Dim da As New SqlDataAdapter()

        Try
            sqlConn.ConnectionString = Common.Datenbank.GetDSN()
            sqlCmd.CommandText = "sp_ListParameter"
            sqlCmd.CommandType = CommandType.StoredProcedure
            sqlCmd.Connection = sqlConn

            If aktiv <> -1 Then
                sqlCmd.Parameters.Add(New SqlParameter("@Aktiv", aktiv))
            End If

            da.SelectCommand = sqlCmd
            da.Fill(ds, "Parameters")

        Catch ex As Exception
            TKBLib.Errorhandling.TraceHelper.Msg("EDOKALib.DA.Parameter.List", ex.Message + " " + ex.StackTrace, TraceLevel.Error)
            Throw ex
        Finally
            sqlConn.Dispose()
            sqlCmd.Dispose()
            da.Dispose()
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Parameter


Parameter.Update Method

aktualisiert einen paramter

Public Shared Function Update( _
   ByVal benutzerNr As Integer, _
   ByVal name As String, _
   ByVal wert As String, _
   ByVal datentyp As Integer, _
   ByVal beschreibung As String, _
   ByVal aktiv As Boolean, _
   ByVal mutiererId As Integer _
) As Integer

Parameters

benutzerNr
Required. criterium (keine aktualisierung)
name
Required. criterium (keine aktualisierung)
wert
Required.
datentyp
Required.
beschreibung
Required.
aktiv
Required.
mutiererId
Required.

Returns

error

Source code

[Visual Basic]
    Public Shared Function Update(ByVal benutzerNr As Integer, ByVal name As String, ByVal wert As String, ByVal datentyp As Integer, _
            ByVal beschreibung As String, ByVal aktiv As Boolean, ByVal mutiererId As Integer) As Integer

        Dim sqlConn As New SqlConnection()
        Dim sqlCmd As New SqlCommand()

        Try
            sqlConn.ConnectionString = Common.Datenbank.GetDSN()
            sqlCmd.CommandText = "sp_SetParameter"
            sqlCmd.CommandType = CommandType.StoredProcedure
            sqlCmd.Connection = sqlConn

            sqlCmd.Parameters.Add(New SqlParameter("@BenutzerNr", benutzerNr))
            sqlCmd.Parameters.Add(New SqlParameter("@Name", name))
            sqlCmd.Parameters.Add(New SqlParameter("@Wert", wert))
            sqlCmd.Parameters.Add(New SqlParameter("@Datentyp", datentyp))
            sqlCmd.Parameters.Add(New SqlParameter("@Beschreibung", beschreibung))
            sqlCmd.Parameters.Add(New SqlParameter("@Aktiv", aktiv))
            sqlCmd.Parameters.Add(New SqlParameter("@MutiererId", mutiererId))
            sqlCmd.Parameters.Add(New SqlParameter("@Return", DBNull.Value))
            sqlCmd.Parameters("@Return").Direction = ParameterDirection.ReturnValue

            sqlConn.Open()
            sqlCmd.ExecuteNonQuery()

            Return CInt(sqlCmd.Parameters("@Return").Value)

        Catch ex As Exception
            TKBLib.Errorhandling.TraceHelper.Msg("EDOKALib.DA.Parameter.Update", ex.Message + " " + ex.StackTrace, TraceLevel.Error)
            Throw ex
        Finally
            sqlConn.Dispose()
            sqlCmd.Dispose()
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Parameter


Spalten Class

Datenzugriff auf Tabelle spalten

For a list of all members of this type, see Spalten Members.

System.Object
EDOKALib.DataAccess.Spalten

Public Class Spalten

Requirements

Namespace: DataAccess

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKALib.DataAccess (in EDOKALib.DataAccess.dll)

See Also

Spalten Members


Spalten Members

Spalten overview

Methods

method GetListe Gibt eine Liste mit allen Spalten in einem DataSet zurück

See Also

Spalten Class


Spalten Methods

Spalten overview

Methods

method GetListe Gibt eine Liste mit allen Spalten in einem DataSet zurück

See Also

Spalten Class


Spalten.GetListe Method

Gibt eine Liste mit allen Spalten in einem DataSet zurück

Public Overloads Shared Sub GetListe( _
   ByVal tableName As String, _
   ByRef dsSpalten As DataSet _
)

Parameters

tableName
Required. Name der Tabelle, von welcher die Spalten zurück gegeben werden sollen
dsSpalten
Required.

Source code

[Visual Basic]
    Public Overloads Shared Sub GetListe(ByVal tableName As String, ByRef dsSpalten As DataSet)
        Dim sqlConn As New SqlConnection()
        Dim sqlCmd As New SqlCommand()
        Dim da As New SqlDataAdapter()

        Try
            sqlCmd.CommandText = "sp_GetSpalten"
            sqlCmd.CommandType = CommandType.StoredProcedure
            sqlCmd.Connection = sqlConn

            sqlCmd.Parameters.Add(New SqlParameter("@TableName", tableName))

            sqlConn.ConnectionString = Common.Datenbank.GetDSN()

            sqlConn.Open()

            da.SelectCommand = sqlCmd
            da.Fill(dsSpalten, "SpaltenListe")

        Catch ex As Exception
            Throw ex
        Finally
            If sqlCmd Is Nothing Then
                sqlCmd.Dispose()
            End If
            If sqlConn Is Nothing Then
                sqlConn.Dispose()
            End If
            If da Is Nothing Then
                da.Dispose()
            End If
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Spalten


Team Class

Datenzugriff auf Tabelle team

For a list of all members of this type, see Team Members.

System.Object
EDOKALib.DataAccess.Team

Public Class Team

Requirements

Namespace: DataAccess

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKALib.DataAccess (in EDOKALib.DataAccess.dll)

See Also

Team Members


Team Members

Team overview

Methods

method GetById | Gibt alle Details zur einem TeamMitarbeiter Verhältnis zurück
method GetListe | Gibt eine Liste mit allen Teams zurück
method GetListeByMitarbeiterNr | Gibt eine Liste mit allen Teams denen ein Mitarbeiter zugewiesen ist zurück

See Also

Team Class


Team Methods

Team overview

Methods

method GetById | Gibt alle Details zur einem TeamMitarbeiter Verhältnis zurück
method GetListe | Gibt eine Liste mit allen Teams zurück
method GetListeByMitarbeiterNr | Gibt eine Liste mit allen Teams denen ein Mitarbeiter zugewiesen ist zurück

See Also

Team Class


Team.GetById Method

Gibt alle Details zur einem TeamMitarbeiter Verhältnis zurück

Overloads Shared Sub GetById( _
   ByVal teamNr As Integer, _
   ByRef ds As DataSet _
)

Parameters

teamNr
Required.
ds
Required. Das zu füllende DataSet

Source code

[Visual Basic]
    Overloads Shared Sub GetById(ByVal teamNr As Integer, ByRef ds As DataSet)
        Dim sqlConn As New SqlConnection()
        Dim sqlCmd As New SqlCommand()
        Dim da As New SqlDataAdapter()

        Try
            sqlCmd.CommandText = "sp_GetTeamById"
            sqlCmd.CommandType = CommandType.StoredProcedure
            sqlCmd.Connection = sqlConn

            sqlCmd.Parameters.Add(New SqlParameter("@TeamNr", teamNr))

            sqlConn.ConnectionString = Common.Datenbank.GetDSN()

            sqlConn.Open()

            da.SelectCommand = sqlCmd
            da.Fill(ds, "Team")

        Catch ex As Exception
            Throw ex
        Finally
            If sqlCmd Is Nothing Then
                sqlCmd.Dispose()
            End If
            If sqlConn Is Nothing Then
                sqlConn.Dispose()
            End If
            If da Is Nothing Then
                da.Dispose()
            End If
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Team


Team.GetListe Method

Gibt eine Liste mit allen Teams zurück

Overloads Shared Sub GetListe( _
   ByRef ds As DataSet _
)

Parameters

ds
Required. Das DataSet welches gefüllt werden soll

Source code

[Visual Basic]
    Overloads Shared Sub GetListe(ByRef ds As DataSet)
        Dim sqlConn As New SqlConnection()
        Dim sqlCmd As New SqlCommand()
        Dim da As New SqlDataAdapter()

        Try
            sqlCmd.CommandText = "sp_ListTeams"
            sqlCmd.CommandType = CommandType.StoredProcedure
            sqlCmd.Connection = sqlConn

            sqlConn.ConnectionString = Common.Datenbank.GetDSN()

            sqlConn.Open()

            da.SelectCommand = sqlCmd
            da.Fill(ds, "TeamListe")

        Catch ex As Exception
            Throw ex
        Finally
            If sqlCmd Is Nothing Then
                sqlCmd.Dispose()
            End If
            If sqlConn Is Nothing Then
                sqlConn.Dispose()
            End If
            If da Is Nothing Then
                da.Dispose()
            End If
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Team


Team.GetListeByMitarbeiterNr Method

Gibt eine Liste mit allen Teams denen ein Mitarbeiter zugewiesen ist zurück

Overloads Shared Sub GetListeByMitarbeiterNr( _
   ByVal mitarbeiterNr As Integer, _
   ByRef ds As DataSet _
)

Parameters

mitarbeiterNr
Required.
ds
Required. Das DataSet welches gefüllt werden soll

Source code

[Visual Basic]
    Overloads Shared Sub GetListeByMitarbeiterNr(ByVal mitarbeiterNr As Integer, ByRef ds As DataSet)
        Dim sqlConn As New SqlConnection()
        Dim sqlCmd As New SqlCommand()
        Dim da As New SqlDataAdapter()

        Try
            sqlCmd.CommandText = "sp_GetTeamsByMitarbeiterNr"
            sqlCmd.CommandType = CommandType.StoredProcedure
            sqlCmd.Connection = sqlConn

            sqlCmd.Parameters.Add(New SqlParameter("@MitarbeiterNr", mitarbeiterNr))

            sqlConn.ConnectionString = Common.Datenbank.GetDSN()

            sqlConn.Open()

            da.SelectCommand = sqlCmd
            da.Fill(ds, "FunktionsgruppenListe")

        Catch ex As Exception
            Throw ex
        Finally
            If sqlCmd Is Nothing Then
                sqlCmd.Dispose()
            End If
            If sqlConn Is Nothing Then
                sqlConn.Dispose()
            End If
            If da Is Nothing Then
                da.Dispose()
            End If
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Team


TeamMitarbeiter Class

Datenzugriff auf Tabelle team_mitarbeiter

For a list of all members of this type, see TeamMitarbeiter Members.

System.Object
EDOKALib.DataAccess.TeamMitarbeiter

Public Class TeamMitarbeiter

Requirements

Namespace: DataAccess

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKALib.DataAccess (in EDOKALib.DataAccess.dll)

See Also

TeamMitarbeiter Members


TeamMitarbeiter Members

TeamMitarbeiter overview

Methods

method Delete | Löscht eine Team-Mitarbeiter Zuordnung aus der Datenbank
method GetById | Gibt alle Details zur einem TeamMitarbeiter Verhältnis zurück
method GetListByMitarbeiterNr | Gibt eine Liste mit allen TeamMitarbeitern zurück
method Insert | Fügt eine neue Team-Mitarbeiter Verbindung in die Datenbank ein
method Update | Aktualisiert eine bestehede Team-Mitarbeiter Zuordnung

See Also

TeamMitarbeiter Class


TeamMitarbeiter Methods

TeamMitarbeiter overview

Methods

method Delete | Löscht eine Team-Mitarbeiter Zuordnung aus der Datenbank
method GetById | Gibt alle Details zur einem TeamMitarbeiter Verhältnis zurück
method GetListByMitarbeiterNr | Gibt eine Liste mit allen TeamMitarbeitern zurück
method Insert | Fügt eine neue Team-Mitarbeiter Verbindung in die Datenbank ein
method Update | Aktualisiert eine bestehede Team-Mitarbeiter Zuordnung

See Also

TeamMitarbeiter Class


TeamMitarbeiter.Delete Method

Löscht eine Team-Mitarbeiter Zuordnung aus der Datenbank

Public Overloads Shared Function Delete( _
   ByVal teamMitarbeiterNr As Integer, _
   ByVal mutiererMitarbeiterNr As Integer _
)

Parameters

teamMitarbeiterNr
Required. Zu löschende Verbindung
mutiererMitarbeiterNr
Required. Die Id des Benutzers, welcher die Änderungen vornimmt

Source code

[Visual Basic]
    Public Overloads Shared Function Delete(ByVal teamMitarbeiterNr As Integer, ByVal mutiererMitarbeiterNr As Integer)
        Dim sqlConn As New SqlConnection()
        Dim sqlCmd As New SqlCommand()

        Try
            sqlCmd.CommandText = "sp_DeleteTeamMitarbeiter"
            sqlCmd.CommandType = CommandType.StoredProcedure
            sqlCmd.Connection = sqlConn

            sqlCmd.Parameters.Add(New SqlParameter("@TeamMitarbeiterNr", teamMitarbeiterNr))

            sqlConn.ConnectionString = Common.Datenbank.GetDSN()

            sqlConn.Open()

            sqlCmd.ExecuteNonQuery()

        Catch ex As Exception
            Throw ex
        Finally
            If sqlCmd Is Nothing Then
                sqlCmd.Dispose()
            End If
            If sqlConn Is Nothing Then
                sqlConn.Dispose()
            End If
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

TeamMitarbeiter


TeamMitarbeiter.GetById Method

Gibt alle Details zur einem TeamMitarbeiter Verhältnis zurück

Overloads Shared Sub GetById( _
   ByVal mitarbeiterTeamNr As Integer, _
   ByRef ds As DataSet _
)

Parameters

mitarbeiterTeamNr
Required. Die datenbank Nummer des TeamMitarbeiters (ID)
ds
Required. Das zu füllende DataSet

Source code

[Visual Basic]
    Overloads Shared Sub GetById(ByVal mitarbeiterTeamNr As Integer, ByRef ds As DataSet)
        Dim sqlConn As New SqlConnection()
        Dim sqlCmd As New SqlCommand()
        Dim da As New SqlDataAdapter()

        Try
            sqlCmd.CommandText = "sp_GetTeamMitarbeiterById"
            sqlCmd.CommandType = CommandType.StoredProcedure
            sqlCmd.Connection = sqlConn

            sqlCmd.Parameters.Add(New SqlParameter("@TeamMitarbeiterNr", mitarbeiterTeamNr))

            sqlConn.ConnectionString = Common.Datenbank.GetDSN()

            sqlConn.Open()

            da.SelectCommand = sqlCmd
            da.Fill(ds, "TeamMitarbeiter")

        Catch ex As Exception
            Throw ex
        Finally
            If sqlCmd Is Nothing Then
                sqlCmd.Dispose()
            End If
            If sqlConn Is Nothing Then
                sqlConn.Dispose()
            End If
            If da Is Nothing Then
                da.Dispose()
            End If
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

TeamMitarbeiter


TeamMitarbeiter.GetListByMitarbeiterNr Method

Gibt eine Liste mit allen TeamMitarbeitern zurück

Overloads Shared Sub GetListByMitarbeiterNr( _
   ByVal mitarbeiterNr As Integer, _
   ByRef ds As DataSet _
)

Parameters

mitarbeiterNr
Required.
ds
Required. Das DataSet welches gefüllt werden soll

Source code

[Visual Basic]
    Overloads Shared Sub GetListByMitarbeiterNr(ByVal mitarbeiterNr As Integer, ByRef ds As DataSet)
        Dim sqlConn As New SqlConnection()
        Dim sqlCmd As New SqlCommand()
        Dim da As New SqlDataAdapter()

        Try
            sqlCmd.CommandText = "sp_GetTeamsByMitarbeiterNr"
            sqlCmd.CommandType = CommandType.StoredProcedure
            sqlCmd.Connection = sqlConn

            sqlCmd.Parameters.Add(New SqlParameter("@MitarbeiterNr", mitarbeiterNr))

            sqlConn.ConnectionString = Common.Datenbank.GetDSN()

            sqlConn.Open()

            da.SelectCommand = sqlCmd
            da.Fill(ds, "TeamMitarbeiter")

        Catch ex As Exception
            Throw ex
        Finally
            If sqlCmd Is Nothing Then
                sqlCmd.Dispose()
            End If
            If sqlConn Is Nothing Then
                sqlConn.Dispose()
            End If
            If da Is Nothing Then
                da.Dispose()
            End If
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

TeamMitarbeiter


TeamMitarbeiter.Insert Method

Fügt eine neue Team-Mitarbeiter Verbindung in die Datenbank ein

Overloads Shared Sub Insert( _
   ByVal teamNr As Integer, _
   ByVal mitarbeiterNr As Integer, _
   ByVal anteil As Integer, _
   ByVal mandantNr As Integer, _
   ByVal isAktiv As Boolean, _
   ByVal mutiererMitarbeiterNr As Integer _
)

Parameters

teamNr
Required.
mitarbeiterNr
Required.
anteil
Required.
mandantNr
Required.
isAktiv
Required.
mutiererMitarbeiterNr
Required.

Source code

[Visual Basic]
    Overloads Shared Sub Insert(ByVal teamNr As Integer, ByVal mitarbeiterNr As Integer, ByVal anteil As Integer, ByVal mandantNr As Integer, ByVal isAktiv As Boolean, ByVal mutiererMitarbeiterNr As Integer)
        Dim sqlConn As New SqlConnection()
        Dim sqlCmd As New SqlCommand()

        Try
            sqlCmd.CommandText = "sp_InsertTeamMitarbeiter"
            sqlCmd.CommandType = CommandType.StoredProcedure
            sqlCmd.Connection = sqlConn

            sqlCmd.Parameters.Add(New SqlParameter("@TeamNr", teamNr))
            sqlCmd.Parameters.Add(New SqlParameter("@MitarbeiterNr", mitarbeiterNr))
            sqlCmd.Parameters.Add(New SqlParameter("@Anteil", anteil))
            sqlCmd.Parameters.Add(New SqlParameter("@MandantNr", mandantNr))
            sqlCmd.Parameters.Add(New SqlParameter("@aktiv", isAktiv))
            sqlCmd.Parameters.Add(New SqlParameter("@MutiererMitarbeiterNr", mutiererMitarbeiterNr))

            sqlConn.ConnectionString = Common.Datenbank.GetDSN()

            sqlConn.Open()

            sqlCmd.ExecuteNonQuery()

        Catch ex As Exception
            Throw ex
        Finally
            If sqlCmd Is Nothing Then
                sqlCmd.Dispose()
            End If
            If sqlConn Is Nothing Then
                sqlConn.Dispose()
            End If
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

TeamMitarbeiter


TeamMitarbeiter.Update Method

Aktualisiert eine bestehede Team-Mitarbeiter Zuordnung

Overloads Shared Sub Update( _
   ByVal teamMitarbeiterNr As Integer, _
   ByVal teamNr As Integer, _
   ByVal mitarbeiterNr As Integer, _
   ByVal anteil As Integer, _
   ByVal mandantNr As Integer, _
   ByVal isAktiv As Boolean, _
   ByVal mutiererMitarbeiterNr As Integer _
)

Parameters

teamMitarbeiterNr
Required.
teamNr
Required.
mitarbeiterNr
Required.
anteil
Required.
mandantNr
Required.
isAktiv
Required.
mutiererMitarbeiterNr
Required.

Source code

[Visual Basic]
    Overloads Shared Sub Update(ByVal teamMitarbeiterNr As Integer, ByVal teamNr As Integer, ByVal mitarbeiterNr As Integer, ByVal anteil As Integer, ByVal mandantNr As Integer, ByVal isAktiv As Boolean, ByVal mutiererMitarbeiterNr As Integer)
        Dim sqlConn As New SqlConnection()
        Dim sqlCmd As New SqlCommand()

        Try
            sqlCmd.CommandText = "sp_UpdateTeamMitarbeiter"
            sqlCmd.CommandType = CommandType.StoredProcedure
            sqlCmd.Connection = sqlConn

            sqlCmd.Parameters.Add(New SqlParameter("@TeamMitarbeiterNr", teamMitarbeiterNr))
            sqlCmd.Parameters.Add(New SqlParameter("@TeamNr", teamNr))
            sqlCmd.Parameters.Add(New SqlParameter("@MitarbeiterNr", mitarbeiterNr))
            sqlCmd.Parameters.Add(New SqlParameter("@Anteil", anteil))
            sqlCmd.Parameters.Add(New SqlParameter("@MandantNr", mandantNr))
            sqlCmd.Parameters.Add(New SqlParameter("@aktiv", isAktiv))
            sqlCmd.Parameters.Add(New SqlParameter("@MutiererMitarbeiterNr", mutiererMitarbeiterNr))

            sqlConn.ConnectionString = Common.Datenbank.GetDSN()

            sqlConn.Open()

            sqlCmd.ExecuteNonQuery()

        Catch ex As Exception
            Throw ex
        Finally
            If sqlCmd Is Nothing Then
                sqlCmd.Dispose()
            End If
            If sqlConn Is Nothing Then
                sqlConn.Dispose()
            End If
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

TeamMitarbeiter