BusinessFacade Reference

BusinessFacade

2006 by Zubler & Partner AG


EDOKALib.BusinessFacade Namespace

Namespace EDOKALib.BusinessFacade

Classes

class AktuellerBenutzer | Diese klasse beinhaltet die Informationen für den aktuell angemeldeten Benutzer
class Anwendung | Diese klasse beinhaltet die Logik für Anwendungen
class Config | Verwaltet eine hashtable mit den parametern, damit nicht jedes mal ein dbzugriff erfolgt
class ConfigException | Diese Klasse behandelt eine Configuration spezifische Ausnahme
class Dokumentart | Verwaltung und logik von Dokumentarten
class DokumentartException | Diese Klasse behandelt eine DokumentArt spezifische Ausnahme
class Dokumenttyp | Diese klasse beinhaltet die Logik für die Dokumenttypen
class Funktionsgruppe | Diese klasse beinhaltet die Logik für die Funktionsgruppe
class Klassifizierung | Diese klasse beinhaltet die Logik für die Klassifizierung
class Meldungstext | Diese klasse beinhaltet die Logik für die Meldungstext
class Mitarbeiter | Diese klasse beinhaltet die Logik für die Mitarbeiter
class MitarbeiterException | Diese Klasse behandelt eine Mitarbeiter spezifische Ausnahme
class MitarbeiterFunktionsgruppe | Diese klasse beinhaltet die Logik für die Mitarbeiter-Funktionsgruppen Zuweisung
class NullHandler | diese klasse ersetzt null values durch den parameter 'NullReplaceValue' von der parameter tabelle
class OfficeVorlage | Diese klasse beinhaltet die Logik für die Office Vorlage
class OfficeVorlageException | Diese Klasse behandelt eine OfficeVorlage spezifische Ausnahme
class Parameter | Applikations Parameter (verwaltet Programmeinstellungen für einzelne oder alle Benutzer in einer sql-tabelle)
class Spalten | Diese klasse beinhaltet die Logik für die Spalten Definitionen
class Team | Diese klasse beinhaltet die Logik für die Teams
class TeamMitarbeiter | Diese klasse beinhaltet die Logik für die Team-Mitarbeiter Zuordnung


EDOKALib.BusinessFacade Members

EDOKALib.BusinessFacade overview

Classes

class AktuellerBenutzer | Diese klasse beinhaltet die Informationen für den aktuell angemeldeten Benutzer
class Anwendung | Diese klasse beinhaltet die Logik für Anwendungen
class Config | Verwaltet eine hashtable mit den parametern, damit nicht jedes mal ein dbzugriff erfolgt
class ConfigException | Diese Klasse behandelt eine Configuration spezifische Ausnahme
class Dokumentart | Verwaltung und logik von Dokumentarten
class DokumentartException | Diese Klasse behandelt eine DokumentArt spezifische Ausnahme
class Dokumenttyp | Diese klasse beinhaltet die Logik für die Dokumenttypen
class Funktionsgruppe | Diese klasse beinhaltet die Logik für die Funktionsgruppe
class Klassifizierung | Diese klasse beinhaltet die Logik für die Klassifizierung
class Meldungstext | Diese klasse beinhaltet die Logik für die Meldungstext
class Mitarbeiter | Diese klasse beinhaltet die Logik für die Mitarbeiter
class MitarbeiterException | Diese Klasse behandelt eine Mitarbeiter spezifische Ausnahme
class MitarbeiterFunktionsgruppe | Diese klasse beinhaltet die Logik für die Mitarbeiter-Funktionsgruppen Zuweisung
class NullHandler | diese klasse ersetzt null values durch den parameter 'NullReplaceValue' von der parameter tabelle
class OfficeVorlage | Diese klasse beinhaltet die Logik für die Office Vorlage
class OfficeVorlageException | Diese Klasse behandelt eine OfficeVorlage spezifische Ausnahme
class Parameter | Applikations Parameter (verwaltet Programmeinstellungen für einzelne oder alle Benutzer in einer sql-tabelle)
class Spalten | Diese klasse beinhaltet die Logik für die Spalten Definitionen
class Team | Diese klasse beinhaltet die Logik für die Teams
class TeamMitarbeiter | Diese klasse beinhaltet die Logik für die Team-Mitarbeiter Zuordnung

See Also

EDOKALib.BusinessFacade Namespace


AktuellerBenutzer Class

Diese klasse beinhaltet die Informationen für den aktuell angemeldeten Benutzer

For a list of all members of this type, see AktuellerBenutzer Members.

System.Object
EDOKALib.BusinessFacade.AktuellerBenutzer

Public Class AktuellerBenutzer

Requirements

Namespace: BusinessFacade

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKALib.BusinessFacade (in EDOKALib.BusinessFacade.dll)

See Also

AktuellerBenutzer Members


AktuellerBenutzer Members

AktuellerBenutzer overview

Constructors

constructor AktuellerBenutzer Constructor (Overloaded)

Properties

property Journalisierung
property MitarbeiterNr
property Nachname
property TGNummer
property Vorname

Methods

method ContructorHelper | Ermöglicht eine Überladung des Contrustors analog c#
method Destroy | Settz die aktuelle Objekt Instanz auf Null (Nothing)

Fields

field _mitarbeiter

See Also

AktuellerBenutzer Class


New

Overload List

[Visual Basic] Public Sub New()

[Visual Basic] Public Sub New(ByVal mitarbeiterNr As Integer)

See Also

AktuellerBenutzer | BusinessFacade


AktuellerBenutzer Properties

AktuellerBenutzer overview

Properties

property Journalisierung
property MitarbeiterNr
property Nachname
property TGNummer
property Vorname

See Also

AktuellerBenutzer Class


AktuellerBenutzer.Journalisierung Property

Public Shared ReadOnly Property Journalisierung() As Boolean

Source code

[Visual Basic]
    Public Shared ReadOnly Property Journalisierung() As Boolean
        Get
            Return _mitarbeiter.Journalisierung
        End Get
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

AktuellerBenutzer


AktuellerBenutzer.MitarbeiterNr Property

Public Shared ReadOnly Property MitarbeiterNr() As String

Source code

[Visual Basic]
    Public Shared ReadOnly Property MitarbeiterNr() As String
        Get
            Return _mitarbeiter.MitarbeiterNr
        End Get
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

AktuellerBenutzer


AktuellerBenutzer.Nachname Property

Public Shared ReadOnly Property Nachname() As String

Source code

[Visual Basic]
    Public Shared ReadOnly Property Nachname() As String
        Get
            Return _mitarbeiter.Nachname
        End Get
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

AktuellerBenutzer


AktuellerBenutzer.TGNummer Property

Public Shared ReadOnly Property TGNummer() As String

Source code

[Visual Basic]
    Public Shared ReadOnly Property TGNummer() As String
        Get
            Return _mitarbeiter.TGNummer
        End Get
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

AktuellerBenutzer


AktuellerBenutzer.Vorname Property

Public Shared ReadOnly Property Vorname() As String

Source code

[Visual Basic]
    Public Shared ReadOnly Property Vorname() As String
        Get
            Return _mitarbeiter.Vorname
        End Get
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

AktuellerBenutzer


AktuellerBenutzer Methods

AktuellerBenutzer overview

Methods

method ContructorHelper | Ermöglicht eine Überladung des Contrustors analog c#
method Destroy | Settz die aktuelle Objekt Instanz auf Null (Nothing)

See Also

AktuellerBenutzer Class


AktuellerBenutzer.ContructorHelper Method

Ermöglicht eine Überladung des Contrustors analog c#

Private Sub ContructorHelper( _
   ByVal mitarbeiterNr As Integer _
)

Parameters

mitarbeiterNr
Required.

Source code

[Visual Basic]
    Private Sub ContructorHelper(ByVal mitarbeiterNr As Integer)
        Try
            If _mitarbeiter Is Nothing Then
                _mitarbeiter = New Mitarbeiter(mitarbeiterNr)
            Else
                Destroy()
                _mitarbeiter = New Mitarbeiter(mitarbeiterNr)
            End If
        Catch ex As Exception
            TKBLib.Errorhandling.TraceHelper.Msg("EDOKALib.BF.AktuellerBenutzer.ContructorHelper", ex.Message + " " + ex.StackTrace, TraceLevel.Error)
            Throw ex
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

AktuellerBenutzer


AktuellerBenutzer.Destroy Method

Settz die aktuelle Objekt Instanz auf Null (Nothing)

Public Shared Sub Destroy()

Source code

[Visual Basic]
    Public Shared Sub Destroy()
        _mitarbeiter = Nothing
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

AktuellerBenutzer


AktuellerBenutzer Fields

AktuellerBenutzer overview

Fields

field _mitarbeiter

See Also

AktuellerBenutzer Class


_mitarbeiter Variable

Private Shared _mitarbeiter As Mitarbeiter

Source code

[Visual Basic]
    Private Shared _mitarbeiter As Mitarbeiter

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

AktuellerBenutzer


Anwendung Class

Diese klasse beinhaltet die Logik für Anwendungen

For a list of all members of this type, see Anwendung Members.

System.Object
EDOKALib.BusinessFacade.Anwendung

Public Class Anwendung

Requirements

Namespace: BusinessFacade

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKALib.BusinessFacade (in EDOKALib.BusinessFacade.dll)

See Also

Anwendung Members


Anwendung Members

Anwendung overview

Constructors

constructor Anwendung Constructor (Overloaded) default konstruktor

Properties

property Aktiv
property AnwendungsNr
property Beschreibung
property Bezeichnung
property ErstelltAm
property MutiererId
property MutiertAm

Methods

method Delete | Löscht einen Mitarbeiter aus der DB (Setzt in auf inaktiv)
method LoadData | Lädt alle Daten einer Anwendung aus der DB
method Save | Speichert alle Members in die DB

Fields

field _aktiv
field _anwendungsNr
field _beschreibung
field _bezeichnung
field _erstelltAm
field _mandantNr
field _mutiererId
field _mutiertAm

See Also

Anwendung Class


New

Overload List

default konstruktor

[Visual Basic] Public Sub New()

lädt eine anwendung aus der db

[Visual Basic] Public Sub New(ByVal anwendungsNr As Integer)

erstellt eine neue anwendung in der db und lädt diese

[Visual Basic] Public Sub New(ByVal bezeichnung As String, ByVal beschreibung As String, ByVal aktiv As Boolean, ByVal mutiererId As Integer)

See Also

Anwendung | BusinessFacade


Anwendung Properties

Anwendung overview

Properties

property Aktiv
property AnwendungsNr
property Beschreibung
property Bezeichnung
property ErstelltAm
property MutiererId
property MutiertAm

See Also

Anwendung Class


Anwendung.Aktiv Property

Public Property Aktiv() As Boolean

Source code

[Visual Basic]
    Public Property Aktiv() As Boolean
        Get
            Return _aktiv
        End Get
        Set(ByVal Value As Boolean)
            _aktiv = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Anwendung


Anwendung.AnwendungsNr Property

Public Property AnwendungsNr() As Integer

Source code

[Visual Basic]
    Public Property AnwendungsNr() As Integer
        Get
            Return _anwendungsNr
        End Get
        Set(ByVal Value As Integer)
            _anwendungsNr = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Anwendung


Anwendung.Beschreibung Property

Public Property Beschreibung() As String

Source code

[Visual Basic]
    Public Property Beschreibung() As String
        Get
            Return _beschreibung
        End Get
        Set(ByVal Value As String)
            _beschreibung = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Anwendung


Anwendung.Bezeichnung Property

Public Property Bezeichnung() As String

Source code

[Visual Basic]
    Public Property Bezeichnung() As String
        Get
            Return _bezeichnung
        End Get
        Set(ByVal Value As String)
            _bezeichnung = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Anwendung


Anwendung.ErstelltAm Property

Public Property ErstelltAm() As DateTime

Source code

[Visual Basic]
    Public Property ErstelltAm() As DateTime
        Get
            Return _erstelltAm
        End Get
        Set(ByVal Value As DateTime)
            _erstelltAm = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Anwendung


Anwendung.MutiererId Property

Public Property MutiererId() As Integer

Source code

[Visual Basic]
    Public Property MutiererId() As Integer
        Get
            Return _mutiererId
        End Get
        Set(ByVal Value As Integer)
            _mutiererId = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Anwendung


Anwendung.MutiertAm Property

Public Property MutiertAm() As DateTime

Source code

[Visual Basic]
    Public Property MutiertAm() As DateTime
        Get
            Return _mutiertAm
        End Get
        Set(ByVal Value As DateTime)
            _mutiertAm = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Anwendung


Anwendung Methods

Anwendung overview

Methods

method Delete | Löscht einen Mitarbeiter aus der DB (Setzt in auf inaktiv)
method LoadData | Lädt alle Daten einer Anwendung aus der DB
method Save | Speichert alle Members in die DB

See Also

Anwendung Class


Anwendung.Delete Method

Löscht einen Mitarbeiter aus der DB (Setzt in auf inaktiv)

Public Sub Delete( _
   ByVal mutierer As Integer _
)

Parameters

mutierer
Required.

Source code

[Visual Basic]
    Public Sub Delete(ByVal mutierer As Integer)
        Try
            _aktiv = False
            Save(mutierer)
        Catch ex As Exception
            TKBLib.Errorhandling.TraceHelper.Msg("EDOKALib.BF.Anwendung.Delete", ex.Message + " " + ex.StackTrace, TraceLevel.Error)
            Throw ex
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Anwendung


Anwendung.LoadData Method

Lädt alle Daten einer Anwendung aus der DB

Private Sub LoadData( _
   ByVal ds As DataSet _
)

Parameters

ds
Required.

Source code

[Visual Basic]
    Private Sub LoadData(ByVal ds As DataSet)
        Try
            If Common.Tools.ValidateDS(ds) Then
                _anwendungsNr = Common.Tools.CToInt32(ds.Tables(0).Rows(0)("anwendungNr"))
                _bezeichnung = NullHandler.CToString(ds.Tables(0).Rows(0)("bezeichnung"))
                _beschreibung = NullHandler.CToString(ds.Tables(0).Rows(0)("beschreibung"))
                _mandantNr = NullHandler.CToInt32(ds.Tables(0).Rows(0)("mandantNr"))
                _aktiv = Common.Tools.CToBool(ds.Tables(0).Rows(0)("aktiv"))
                _erstelltAm = NullHandler.CToDateTime(ds.Tables(0).Rows(0)("erstellt_am"))
                _mutiertAm = NullHandler.CToDateTime(ds.Tables(0).Rows(0)("mutiert_am"))
                _mutiererId = Common.Tools.CToInt32(ds.Tables(0).Rows(0)("mutierer"))
            End If
        Catch ex As Exception
            TKBLib.Errorhandling.TraceHelper.Msg("EDOKALib.BF.Anwendung.Save", ex.Message + " " + ex.StackTrace, TraceLevel.Error)
            Throw ex
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Anwendung


Anwendung.Save Method

Speichert alle Members in die DB

Public Sub Save( _
   ByVal mutierer As Integer _
)

Parameters

mutierer
Required.

Source code

[Visual Basic]
    Public Sub Save(ByVal mutierer As Integer)
        Try
            Dim err As Integer
            Dim key As Integer

            If _anwendungsNr = 0 Then			 'create new
                err = DataAccess.Anwendung.Add(key, _bezeichnung, _beschreibung, _mandantNr, _aktiv, mutierer)
                If err = 0 Then
                    _anwendungsNr = key
                End If
            Else			 'save existing
                err = DataAccess.Anwendung.Update(_anwendungsNr, _bezeichnung, Beschreibung, _mandantNr, _aktiv, mutierer)
            End If

            If err <> 0 Then
                Throw New DokumentartException(Meldungstext.GetInhaltById(40000))
            End If

            'refresh data
            Dim ds As New DataSet()
            DataAccess.Anwendung.GetAnwendung(ds, _anwendungsNr)
            LoadData(ds)

        Catch ex As Exception
            TKBLib.Errorhandling.TraceHelper.Msg("EDOKALib.BF.Anwendung.Save", ex.Message + " " + ex.StackTrace, TraceLevel.Error)
            Throw ex
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Anwendung


Anwendung Fields

Anwendung overview

Fields

field _aktiv
field _anwendungsNr
field _beschreibung
field _bezeichnung
field _erstelltAm
field _mandantNr
field _mutiererId
field _mutiertAm

See Also

Anwendung Class


_aktiv Variable

Private _aktiv As Boolean

Source code

[Visual Basic]
    Private _aktiv As Boolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Anwendung


_anwendungsNr Variable

Private _anwendungsNr As Integer

Source code

[Visual Basic]
    Private _anwendungsNr As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Anwendung


_beschreibung Variable

Private _beschreibung As String

Source code

[Visual Basic]
    Private _beschreibung As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Anwendung


_bezeichnung Variable

Private _bezeichnung As String

Source code

[Visual Basic]
    Private _bezeichnung As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Anwendung


_erstelltAm Variable

Private _erstelltAm As DateTime

Source code

[Visual Basic]
    Private _erstelltAm As DateTime

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Anwendung


_mandantNr Variable

Private _mandantNr As Integer

Source code

[Visual Basic]
    Private _mandantNr As Integer	'wird nicht gebraucht. kein property implementiert

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Anwendung


_mutiererId Variable

Private _mutiererId As Integer

Source code

[Visual Basic]
    Private _mutiererId As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Anwendung


_mutiertAm Variable

Private _mutiertAm As DateTime

Source code

[Visual Basic]
    Private _mutiertAm As DateTime

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Anwendung


Config Class

Verwaltet eine hashtable mit den parametern, damit nicht jedes mal ein dbzugriff erfolgt

For a list of all members of this type, see Config Members.

System.Object
EDOKALib.BusinessFacade.Config

Public Class Config

Requirements

Namespace: BusinessFacade

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKALib.BusinessFacade (in EDOKALib.BusinessFacade.dll)

See Also

Config Members


Config Members

Config overview

Methods

method Add | Fügt einen neuen Parameter hinzu
method AddUserParam | Fügt einen neuen Parameter hinzu
method GetParameter |
method GetParameterValue (Overloaded) | Gibt den Wert eines Parameters zurück
method GetUserParameter |

Fields

field _parameterList
field _userList

See Also

Config Class


Config Methods

Config overview

Methods

method Add | Fügt einen neuen Parameter hinzu
method AddUserParam | Fügt einen neuen Parameter hinzu
method GetParameter |
method GetParameterValue (Overloaded) | Gibt den Wert eines Parameters zurück
method GetUserParameter |

See Also

Config Class


Config.Add Method

Fügt einen neuen Parameter hinzu

Private Shared Sub Add( _
   ByVal p As Parameter _
)

Parameters

p
Required.

Source code

[Visual Basic]
    Private Shared Sub Add(ByVal p As Parameter)
        Try
            _parameterList.Add(p.Name, p)
        Catch ex As Exception
            TKBLib.Errorhandling.TraceHelper.Msg("EDOKALib.BF.Config.Add", ex.Message + " " + ex.StackTrace, TraceLevel.Error)
            Throw ex
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Config


Config.AddUserParam Method

Fügt einen neuen Parameter hinzu

Private Shared Sub AddUserParam( _
   ByVal p As Parameter _
)

Parameters

p
Required.

Source code

[Visual Basic]
    Private Shared Sub AddUserParam(ByVal p As Parameter)
        Try
            Dim h As Hashtable

            h = _userList(p.BenutzerNr)
            If h Is Nothing Then			 'noch keine param für diesen benutzer
                h = New Hashtable()				'neue param liste für benutzer erstellen
                h.Add(p.Name, p)				'parameter hinzufügen
                _userList.Add(p.BenutzerNr, h)				'parameter liste zur benutzerliste hinzufügen
            Else			 'user hat eine liste
                h.Add(p.Name, p)				'parameter hinzufügen
            End If
        Catch ex As Exception
            TKBLib.Errorhandling.TraceHelper.Msg("EDOKALib.BF.Config.AddUserParam", ex.Message + " " + ex.StackTrace, TraceLevel.Error)
            Throw ex
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Config


Config.GetParameter Method

Public Shared Function GetParameter( _
   ByVal name As String _
) As Parameter

Parameters

name
Required.

Source code

[Visual Basic]
    Public Shared Function GetParameter(ByVal name As String) As Parameter
        Try
            Dim p As Parameter

            p = _parameterList(name)			 'suche nach param

            If Not p Is Nothing Then
                Return p				'gefunden & return
            Else
                'try to load from db
                p = New Parameter(name, 0)
                If p.ParameterId <> 0 Then
                    Add(p)					  'zur hashtabelle hinzufügen
                    Return p
                Else
                    Throw New ConfigException("Parameter wurde nicht gefunden!")					  'weder in der db noch in der hashtable gefunden
                End If
            End If
        Catch ex As Exception
            TKBLib.Errorhandling.TraceHelper.Msg("EDOKALib.BF.Config.GetParameter", ex.Message + " " + ex.StackTrace, TraceLevel.Error)
            Throw ex
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Config


GetParameterValue Method

Overload List

Gibt den Wert eines Parameters zurück

[Visual Basic] Public Shared Function GetParameterValue(ByVal name As String) As String

Gibt den Wert eines Benuzer spzifischen Parameters zurück

[Visual Basic] Public Shared Function GetParameterValue(ByVal name As String, ByVal benutzerNr As Integer) As String

See Also

Config | BusinessFacade


Config.GetUserParameter Method

Public Shared Function GetUserParameter( _
   ByVal name As String, _
   ByVal benutzerNr As Integer _
) As Parameter

Parameters

name
Required.
benutzerNr
Required.

Source code

[Visual Basic]
    Public Shared Function GetUserParameter(ByVal name As String, ByVal benutzerNr As Integer) As Parameter
        Try
            Dim p As Parameter
            Dim h As Hashtable

            If benutzerNr = 0 Then
                Return GetParameter(name)
            End If

            h = _userList(benutzerNr)			 'benutzer parameterliste suchen
            If h Is Nothing Then
                h = New Hashtable()				'nicht gefunden neuerstellen
            End If
            p = h(name)			 'nach parameter suchen

            If Not p Is Nothing Then
                Return p				'parameter gefunden und zurückgeben
            Else
                'try to load from db
                p = New Parameter(name, benutzerNr)
                If p.ParameterId <> 0 Then
                    AddUserParam(p)
                    Return p
                Else
                    Throw New ConfigException("Parameter wurde nicht gefunden!")					  'weder in der db noch in der hashtable gefunden
                End If
            End If
        Catch ex As Exception
            TKBLib.Errorhandling.TraceHelper.Msg("EDOKALib.BF.Config.GetParameter(...)", ex.Message + " " + ex.StackTrace, TraceLevel.Error)
            Throw ex
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Config


Config Fields

Config overview

Fields

field _parameterList
field _userList

See Also

Config Class


_parameterList Variable

Private Shared _parameterList As New Hashtable()

Source code

[Visual Basic]
    Private Shared _parameterList As New Hashtable() 'parameter für alle benutzer  (benutzerNr = 0)

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Config


_userList Variable

Private Shared _userList As New Hashtable()

Source code

[Visual Basic]
    Private Shared _userList As New Hashtable() 'liste für benutzer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Config


ConfigException Class

Diese Klasse behandelt eine Configuration spezifische Ausnahme

For a list of all members of this type, see ConfigException Members.

System.Object
System.Exception
EDOKALib.BusinessFacade.ConfigException

Public Class ConfigException
   Inherits Exception

Requirements

Namespace: BusinessFacade

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKALib.BusinessFacade (in EDOKALib.BusinessFacade.dll)

See Also

ConfigException Members


ConfigException Members

ConfigException overview

Constructors

constructor ConfigException Constructor

Properties

property Message

Fields

field _message

See Also

ConfigException Class


ConfigException Constructor

Public Sub New( _
   ByVal message As String _
)

Parameters

message
Required.

Source code

[Visual Basic]
    Public Sub New(ByVal message As String)
        _message = message
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

ConfigException


ConfigException Properties

ConfigException overview

Properties

property Message

See Also

ConfigException Class


ConfigException.Message Property

Public Overrides ReadOnly Property Message() As String

Source code

[Visual Basic]
    Public Overrides ReadOnly Property Message() As String
        Get
            Return _message
        End Get
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

ConfigException


ConfigException Fields

ConfigException overview

Fields

field _message

See Also

ConfigException Class


_message Variable

Dim _message As String

Source code

[Visual Basic]
    Dim _message As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

ConfigException


Dokumentart Class

Verwaltung und logik von Dokumentarten

For a list of all members of this type, see Dokumentart Members.

System.Object
EDOKALib.BusinessFacade.Dokumentart

Public Class Dokumentart

Requirements

Namespace: BusinessFacade

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKALib.BusinessFacade (in EDOKALib.BusinessFacade.dll)

See Also

Dokumentart Members


Dokumentart Members

Dokumentart overview

Constructors

constructor Dokumentart Constructor (Overloaded)

Properties

property Aktiv
property Beschreibung
property Bezeichnung
property ColdApplication
property ColdBezeichnung
property DokumentartNr
property ErstelltAm
property ImageIndex
property ImageIndexOpen
property MutiererId
property MutiertAm
property ParentId
property Sort

Methods

method Delete |
method LoadData | lädt die daten vom ds in die member der klasse
method Save | speichert eine dokumentart (insert und update)

Fields

field _aktiv
field _beschreibung
field _bezeichnung
field _coldApplication
field _coldBezeichnung
field _dokumentartNr
field _erstelltAm
field _imageIndex
field _imageIndexOpen
field _mandantNr
field _mutiererId
field _mutiertAm
field _parentId
field _sort
field _sprache

See Also

Dokumentart Class


New

Overload List

[Visual Basic] Public Sub New()

neue dokumentart in db erstellen und laden

[Visual Basic] Public Sub New(ByVal bezeichnung As String, ByVal parentId As Integer, ByVal sort As Integer, ByVal imageIndex As Integer, ByVal imageIndexOpen As Integer, ByVal beschreibung As String, ByVal aktiv As Boolean, ByVal coldApplication As String, ByVal coldBezeichnung As String, ByVal mutiererId As Integer)

[Visual Basic] Public Sub New(ByVal dokumentartNr As Integer)

See Also

Dokumentart | BusinessFacade


Dokumentart Properties

Dokumentart overview

Properties

property Aktiv
property Beschreibung
property Bezeichnung
property ColdApplication
property ColdBezeichnung
property DokumentartNr
property ErstelltAm
property ImageIndex
property ImageIndexOpen
property MutiererId
property MutiertAm
property ParentId
property Sort

See Also

Dokumentart Class


Dokumentart.Aktiv Property

Public Property Aktiv() As Boolean

Source code

[Visual Basic]
    Public Property Aktiv() As Boolean
        Get
            Return _aktiv
        End Get
        Set(ByVal Value As Boolean)
            _aktiv = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Dokumentart


Dokumentart.Beschreibung Property

Public Property Beschreibung() As String

Source code

[Visual Basic]
    Public Property Beschreibung() As String
        Get
            Return _beschreibung
        End Get
        Set(ByVal Value As String)
            _beschreibung = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Dokumentart


Dokumentart.Bezeichnung Property

Public Property Bezeichnung() As String

Source code

[Visual Basic]
    Public Property Bezeichnung() As String
        Get
            Return _bezeichnung
        End Get
        Set(ByVal Value As String)
            _bezeichnung = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Dokumentart


Dokumentart.ColdApplication Property

Public Property ColdApplication() As String

Source code

[Visual Basic]
    Public Property ColdApplication() As String
        Get
            Return _coldApplication
        End Get
        Set(ByVal Value As String)
            _coldApplication = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Dokumentart


Dokumentart.ColdBezeichnung Property

Public Property ColdBezeichnung() As String

Source code

[Visual Basic]
    Public Property ColdBezeichnung() As String
        Get
            Return _coldBezeichnung
        End Get
        Set(ByVal Value As String)
            _coldBezeichnung = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Dokumentart


Dokumentart.DokumentartNr Property

Public ReadOnly Property DokumentartNr() As Integer

Source code

[Visual Basic]
    Public ReadOnly Property DokumentartNr() As Integer
        Get
            Return _dokumentartNr
        End Get
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Dokumentart


Dokumentart.ErstelltAm Property

Public Property ErstelltAm() As DateTime

Source code

[Visual Basic]
    Public Property ErstelltAm() As DateTime
        Get
            Return _erstelltAm
        End Get
        Set(ByVal Value As DateTime)
            _erstelltAm = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Dokumentart


Dokumentart.ImageIndex Property

Public Property ImageIndex() As Integer

Source code

[Visual Basic]
    Public Property ImageIndex() As Integer
        Get
            Return _imageIndex
        End Get
        Set(ByVal Value As Integer)
            _imageIndex = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Dokumentart


Dokumentart.ImageIndexOpen Property

Public Property ImageIndexOpen() As Integer

Source code

[Visual Basic]
    Public Property ImageIndexOpen() As Integer
        Get
            Return _imageIndexOpen
        End Get
        Set(ByVal Value As Integer)
            _imageIndexOpen = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Dokumentart


Dokumentart.MutiererId Property

Public Property MutiererId() As Integer

Source code

[Visual Basic]
    Public Property MutiererId() As Integer
        Get
            Return _mutiererId
        End Get
        Set(ByVal Value As Integer)
            _mutiererId = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Dokumentart


Dokumentart.MutiertAm Property

Public Property MutiertAm() As DateTime

Source code

[Visual Basic]
    Public Property MutiertAm() As DateTime
        Get
            Return _mutiertAm
        End Get
        Set(ByVal Value As DateTime)
            _mutiertAm = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Dokumentart


Dokumentart.ParentId Property

Public Property ParentId() As Integer

Source code

[Visual Basic]
    Public Property ParentId() As Integer
        Get
            Return ParentId
        End Get
        Set(ByVal Value As Integer)
            ParentId = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Dokumentart


Dokumentart.Sort Property

Public Property Sort() As Integer

Source code

[Visual Basic]
    Public Property Sort() As Integer
        Get
            Return _sort
        End Get
        Set(ByVal Value As Integer)
            _sort = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Dokumentart


Dokumentart Methods

Dokumentart overview

Methods

method Delete |
method LoadData | lädt die daten vom ds in die member der klasse
method Save | speichert eine dokumentart (insert und update)

See Also

Dokumentart Class


Dokumentart.Delete Method

Public Function Delete( _
   ByVal mutierer As Integer _
)

Parameters

mutierer
Required.

Source code

[Visual Basic]
    Public Function Delete(ByVal mutierer As Integer)
        Try
            _aktiv = False
            Save(mutierer)
        Catch ex As Exception
            TKBLib.Errorhandling.TraceHelper.Msg("EDOKA", ex.Message + " " + ex.StackTrace, TraceLevel.Error)
            Throw ex
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Dokumentart


Dokumentart.LoadData Method

lädt die daten vom ds in die member der klasse

Private Sub LoadData( _
   ByRef ds As DataSet _
)

Parameters

ds
Required.

Source code

[Visual Basic]
    Private Sub LoadData(ByRef ds As DataSet)
        Try
            If Common.Tools.ValidateDS(ds) Then
                _dokumentartNr = NullHandler.CToInt32(ds.Tables(0).Rows(0)("dokumentartNr"))
                _bezeichnung = NullHandler.CToString(ds.Tables(0).Rows(0)("bezeichnung"))
                _parentId = NullHandler.CToInt32(ds.Tables(0).Rows(0)("parentId"))
                _sort = NullHandler.CToInt32(ds.Tables(0).Rows(0)("sort"))
                _imageIndex = NullHandler.CToInt32(ds.Tables(0).Rows(0)("imageIndex"))
                _imageIndexOpen = NullHandler.CToInt32(ds.Tables(0).Rows(0)("imageIndexOpen"))
                _beschreibung = NullHandler.CToString(ds.Tables(0).Rows(0)("beschreibung"))
                _mandantNr = NullHandler.CToInt32(ds.Tables(0).Rows(0)("mandantNr"))
                _sprache = NullHandler.CToInt32(ds.Tables(0).Rows(0)("sprache"))
                _aktiv = Common.Tools.CToBool(ds.Tables(0).Rows(0)("aktiv")) 'no null support, wird auf 0 gesetzt
                _erstelltAm = NullHandler.CToDateTime(ds.Tables(0).Rows(0)("erstellt_am"))
                _mutiertAm = NullHandler.CToDateTime(ds.Tables(0).Rows(0)("mutiert_am"))
                _mutiererId = NullHandler.CToInt32(ds.Tables(0).Rows(0)("mutierer"))
                _coldApplication = NullHandler.CToString(ds.Tables(0).Rows(0)("coldApplication"))
                _coldBezeichnung = NullHandler.CToString(ds.Tables(0).Rows(0)("coldBezeichnung"))
            End If
        Catch ex As Exception
            TKBLib.Errorhandling.TraceHelper.Msg("EDOKALib.BF.Dokumentart.LoadData", ex.Message + " " + ex.StackTrace, TraceLevel.Error)
            Throw ex
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Dokumentart


Dokumentart.Save Method

speichert eine dokumentart (insert und update)

Public Function Save( _
   ByVal mutierer As Integer _
)

Parameters

mutierer
Required.

Source code

[Visual Basic]
    Public Function Save(ByVal mutierer As Integer)
        Try
            Dim err As Integer

            If _dokumentartNr = 0 Then 'create new
                err = DataAccess.Dokumentart.Add(_dokumentartNr, _bezeichnung, _parentId, _sort, _imageIndex, _
               _imageIndexOpen, _beschreibung, _mandantNr, _sprache, _aktiv, mutierer, _coldApplication, _
                _coldBezeichnung)

            Else 'save existing
                err = DataAccess.Dokumentart.Update(_dokumentartNr, _bezeichnung, _parentId, _sort, _imageIndex, _
                _imageIndexOpen, _beschreibung, _mandantNr, _sprache, _aktiv, mutierer, _coldApplication, _
                 _coldBezeichnung)
            End If

            If err <> 0 Then
                Throw New DokumentartException(Meldungstext.GetInhaltById(40000))
            End If

            'refresh data
            Dim ds As New DataSet()
            DataAccess.Dokumentart.GetDokumentart(ds, _dokumentartNr)
            LoadData(ds)

        Catch ex As Exception
            TKBLib.Errorhandling.TraceHelper.Msg("EDOKALib.BF.Dokumentart.Save", ex.Message + " " + ex.StackTrace, TraceLevel.Error)
            Throw ex
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Dokumentart


Dokumentart Fields

Dokumentart overview

Fields

field _aktiv
field _beschreibung
field _bezeichnung
field _coldApplication
field _coldBezeichnung
field _dokumentartNr
field _erstelltAm
field _imageIndex
field _imageIndexOpen
field _mandantNr
field _mutiererId
field _mutiertAm
field _parentId
field _sort
field _sprache

See Also

Dokumentart Class


_aktiv Variable

Private _aktiv As Boolean

Source code

[Visual Basic]
    Private _aktiv As Boolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Dokumentart


_beschreibung Variable

Private _beschreibung As String

Source code

[Visual Basic]
    Private _beschreibung As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Dokumentart


_bezeichnung Variable

Private _bezeichnung As String

Source code

[Visual Basic]
    Private _bezeichnung As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Dokumentart


_coldApplication Variable

Private _coldApplication As String

Source code

[Visual Basic]
    Private _coldApplication As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Dokumentart


_coldBezeichnung Variable

Private _coldBezeichnung As String

Source code

[Visual Basic]
    Private _coldBezeichnung As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Dokumentart


_dokumentartNr Variable

Private _dokumentartNr As Integer

Source code

[Visual Basic]
    Private _dokumentartNr As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Dokumentart


_erstelltAm Variable

Private _erstelltAm As DateTime

Source code

[Visual Basic]
    Private _erstelltAm As DateTime

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Dokumentart


_imageIndex Variable

Private _imageIndex As Integer

Source code

[Visual Basic]
    Private _imageIndex As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Dokumentart


_imageIndexOpen Variable

Private _imageIndexOpen As Integer

Source code

[Visual Basic]
    Private _imageIndexOpen As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Dokumentart


_mandantNr Variable

Private _mandantNr As Integer

Source code

[Visual Basic]
    Private _mandantNr As Integer 'nicht implementiert

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Dokumentart


_mutiererId Variable

Private _mutiererId As Integer

Source code

[Visual Basic]
    Private _mutiererId As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Dokumentart


_mutiertAm Variable

Private _mutiertAm As DateTime

Source code

[Visual Basic]
    Private _mutiertAm As DateTime

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Dokumentart


_parentId Variable

Private _parentId As Integer

Source code

[Visual Basic]
    Private _parentId As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Dokumentart


_sort Variable

Private _sort As Integer

Source code

[Visual Basic]
    Private _sort As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Dokumentart


_sprache Variable

Private _sprache As Integer

Source code

[Visual Basic]
    Private _sprache As Integer 'nicht implementiert

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Dokumentart


DokumentartException Class

Diese Klasse behandelt eine DokumentArt spezifische Ausnahme

For a list of all members of this type, see DokumentartException Members.

System.Object
System.Exception
EDOKALib.BusinessFacade.DokumentartException

Public Class DokumentartException
   Inherits Exception

Requirements

Namespace: BusinessFacade

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKALib.BusinessFacade (in EDOKALib.BusinessFacade.dll)

See Also

DokumentartException Members


DokumentartException Members

DokumentartException overview

Constructors

constructor DokumentartException Constructor

Properties

property Message

Fields

field _message

See Also

DokumentartException Class


DokumentartException Constructor

Public Sub New( _
   ByVal message As String _
)

Parameters

message
Required.

Source code

[Visual Basic]
    Public Sub New(ByVal message As String)
        _message = message
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

DokumentartException


DokumentartException Properties

DokumentartException overview

Properties

property Message

See Also

DokumentartException Class


DokumentartException.Message Property

Public Overrides ReadOnly Property Message() As String

Source code

[Visual Basic]
    Public Overrides ReadOnly Property Message() As String
        Get
            Return _message
        End Get
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

DokumentartException


DokumentartException Fields

DokumentartException overview

Fields

field _message

See Also

DokumentartException Class


_message Variable

Dim _message As String

Source code

[Visual Basic]
    Dim _message As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

DokumentartException


Dokumenttyp Class

Diese klasse beinhaltet die Logik für die Dokumenttypen

For a list of all members of this type, see Dokumenttyp Members.

System.Object
EDOKALib.BusinessFacade.Dokumenttyp

Public Class Dokumenttyp

Requirements

Namespace: BusinessFacade

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKALib.BusinessFacade (in EDOKALib.BusinessFacade.dll)

See Also

Dokumenttyp Members


Dokumenttyp Members

Dokumenttyp overview

Constructors

constructor Dokumenttyp Constructor (Overloaded) default konstruktor

Properties

property AnzahlTage
property AufbewahrungsFristElektronisch
property AufbewahrungsFristPhysisch
property Beschreibung
property Bezeichnung
property ColdFolder
property DBearbeitungsZeit
property DoktypBedingteRetournierung
property DokumentArtColdAusgang
property DokumentArtColdEingang
property DokumentArtHost
property DokumentArtKundendossier
property DokumentArtNativ
property DokumentArtNeuerstellung
property DokumentArtRetournierung
property DokumentArtWeitere
property DokumentStatus
property DokumentStatusBarcode
property DokumentTypNr
property ErstelltAm
property HostDokumenttyp
property IsAktiv
property IsAmsDokument
property IsAnzeigeZurDokumenterstellung
property IsBedingtRetournierBar
property IsBezeichnungMut
property IsColdErsetzen
property IsDokumentWirdErstellt
property IsDokumentWirdRetourniert
property IsEingangErsetztAusgang
property IsEmailVersand
property IsFarbigArchiviert
property IsFunktionenZuweisen
property IsHostDokument
property IsKundenDokument
property IsNurNative
property IsPartnerSaldierungStatusAlt
property IsSb
property IsSbEditUser
property IsSbImport
property IsSbNur
property IsUnterschriftLinks
property IsUnterschriftRechts
property IsVertrag
property IsVertraulichesDokument
property IsWirdImportiert
property IsWirdNichtGeloescht
property IsZuRetournieren
property MonateBisZurArchivierung
property Mutierer
property MutiertAm
property ObjektbezeichnungNr
property OfficeVorlageNr
property Owner
property PhysischesArchiv
property ProzessNr
property ProzessNr1
property TageBisVernichtungbedingteRetournierung
property TageMutation
property ZuVercolden

Methods

method Delete |
method LoadData | lädt die daten aus dem dataset in die members der klasse
method Save | speichert einen dokumenttyp(update und insert)

Fields

field _anzahlTage
field _aufbewahrungsFristElektronisch
field _aufbewahrungsFristPhysisch
field _beschreibung
field _bezeichnung
field _coldFolder
field _dBearbeitungsZeit
field _doktypBedingteRetournierung
field _dokumentArtColdAusgang
field _dokumentArtColdEingang
field _dokumentArtHost
field _dokumentArtKundendossier
field _dokumentArtNativ
field _dokumentArtNeuerstellung
field _dokumentArtRetournierung
field _dokumentArtWeitere
field _dokumentStatus
field _dokumentStatusBarcode
field _dokumentTypNr
field _erstelltAm
field _hostDokumenttyp
field _isAktiv
field _isAmsDokument
field _isAnzeigeZurDokumenterstellung
field _isBedingtRetournierBar
field _isBezeichnungMut
field _isColdErsetzen
field _isDokumentWirdErstellt
field _isDokumentWirdRetourniert
field _isEingangErsetztAusgang
field _isEmailVersand
field _isFarbigArchiviert
field _isFunktionenZuweisen
field _isHostDokument
field _isKundenDokument
field _isNurNative
field _isPartnerSaldierungStatusAlt
field _isSb
field _isSbEditUser
field _isSbImport
field _isSbNur
field _isUnterschriftLinks
field _isUnterschriftRechts
field _isVertrag
field _isVertraulichesDokument
field _isWirdImportiert
field _isWirdNichtGeloescht
field _isZuRetournieren
field _mandantNr
field _monateBisZurArchivierung
field _mutierer
field _mutiertAm
field _objektbezeichnungNr
field _officeVorlageNr
field _owner
field _physischesArchiv
field _prozessNr
field _prozessNr1
field _tageBisVernichtungbedingteRetournierung
field _tageMutation
field _zuVercolden

See Also

Dokumenttyp Class


New

Overload List

default konstruktor

[Visual Basic] Public Sub New()

lädt den dokumenttyp mit der entsprechenden dokumenttypnr

[Visual Basic] Public Sub New(ByVal dokumentTypNr As Integer)

See Also

Dokumenttyp | BusinessFacade


Dokumenttyp Properties

Dokumenttyp overview

Properties

property AnzahlTage
property AufbewahrungsFristElektronisch
property AufbewahrungsFristPhysisch
property Beschreibung
property Bezeichnung
property ColdFolder
property DBearbeitungsZeit
property DoktypBedingteRetournierung
property DokumentArtColdAusgang
property DokumentArtColdEingang
property DokumentArtHost
property DokumentArtKundendossier
property DokumentArtNativ
property DokumentArtNeuerstellung
property DokumentArtRetournierung
property DokumentArtWeitere
property DokumentStatus
property DokumentStatusBarcode
property DokumentTypNr
property ErstelltAm
property HostDokumenttyp
property IsAktiv
property IsAmsDokument
property IsAnzeigeZurDokumenterstellung
property IsBedingtRetournierBar
property IsBezeichnungMut
property IsColdErsetzen
property IsDokumentWirdErstellt
property IsDokumentWirdRetourniert
property IsEingangErsetztAusgang
property IsEmailVersand
property IsFarbigArchiviert
property IsFunktionenZuweisen
property IsHostDokument
property IsKundenDokument
property IsNurNative
property IsPartnerSaldierungStatusAlt
property IsSb
property IsSbEditUser
property IsSbImport
property IsSbNur
property IsUnterschriftLinks
property IsUnterschriftRechts
property IsVertrag
property IsVertraulichesDokument
property IsWirdImportiert
property IsWirdNichtGeloescht
property IsZuRetournieren
property MonateBisZurArchivierung
property Mutierer
property MutiertAm
property ObjektbezeichnungNr
property OfficeVorlageNr
property Owner
property PhysischesArchiv
property ProzessNr
property ProzessNr1
property TageBisVernichtungbedingteRetournierung
property TageMutation
property ZuVercolden

See Also

Dokumenttyp Class


Dokumenttyp.AnzahlTage Property

Public Property AnzahlTage() As Integer

Source code

[Visual Basic]
    Public Property AnzahlTage() As Integer
        Get
            Return _anzahlTage
        End Get
        Set(ByVal Value As Integer)
            _anzahlTage = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Dokumenttyp


Dokumenttyp.AufbewahrungsFristElektronisch Property

Public Property AufbewahrungsFristElektronisch() As Integer

Source code

[Visual Basic]
    Public Property AufbewahrungsFristElektronisch() As Integer
        Get
            Return _aufbewahrungsFristElektronisch
        End Get
        Set(ByVal Value As Integer)
            _aufbewahrungsFristElektronisch = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Dokumenttyp


Dokumenttyp.AufbewahrungsFristPhysisch Property

Public Property AufbewahrungsFristPhysisch() As Integer

Source code

[Visual Basic]
    Public Property AufbewahrungsFristPhysisch() As Integer
        Get
            Return _aufbewahrungsFristPhysisch
        End Get
        Set(ByVal Value As Integer)
            _aufbewahrungsFristPhysisch = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Dokumenttyp


Dokumenttyp.Beschreibung Property

Public Property Beschreibung() As String

Source code

[Visual Basic]
    Public Property Beschreibung() As String
        Get
            Return _beschreibung
        End Get
        Set(ByVal Value As String)
            _beschreibung = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Dokumenttyp


Dokumenttyp.Bezeichnung Property

Public Property Bezeichnung() As String

Source code

[Visual Basic]
    Public Property Bezeichnung() As String
        Get
            Return _bezeichnung
        End Get
        Set(ByVal Value As String)
            _bezeichnung = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Dokumenttyp


Dokumenttyp.ColdFolder Property

Public Property ColdFolder() As Integer

Source code

[Visual Basic]
    Public Property ColdFolder() As Integer
        Get
            Return _coldFolder
        End Get
        Set(ByVal Value As Integer)
            _coldFolder = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Dokumenttyp


Dokumenttyp.DBearbeitungsZeit Property

Public Property DBearbeitungsZeit() As Integer

Source code

[Visual Basic]
    Public Property DBearbeitungsZeit() As Integer
        Get
            Return _dBearbeitungsZeit
        End Get
        Set(ByVal Value As Integer)
            _dBearbeitungsZeit = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Dokumenttyp


Dokumenttyp.DoktypBedingteRetournierung Property

Public Property DoktypBedingteRetournierung() As Integer

Source code

[Visual Basic]
    Public Property DoktypBedingteRetournierung() As Integer
        Get
            Return _doktypBedingteRetournierung
        End Get
        Set(ByVal Value As Integer)
            _doktypBedingteRetournierung = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Dokumenttyp


Dokumenttyp.DokumentArtColdAusgang Property

Public Property DokumentArtColdAusgang() As Integer

Source code

[Visual Basic]
    Public Property DokumentArtColdAusgang() As Integer
        Get
            Return _dokumentArtColdAusgang
        End Get
        Set(ByVal Value As Integer)
            _dokumentArtColdAusgang = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Dokumenttyp


Dokumenttyp.DokumentArtColdEingang Property

Public Property DokumentArtColdEingang() As Integer

Source code

[Visual Basic]
    Public Property DokumentArtColdEingang() As Integer
        Get
            Return _dokumentArtColdEingang
        End Get
        Set(ByVal Value As Integer)
            _dokumentArtColdEingang = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Dokumenttyp


Dokumenttyp.DokumentArtHost Property

Public Property DokumentArtHost() As Integer

Source code

[Visual Basic]
    Public Property DokumentArtHost() As Integer
        Get
            Return _dokumentArtHost
        End Get
        Set(ByVal Value As Integer)
            _dokumentArtHost = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Dokumenttyp


Dokumenttyp.DokumentArtKundendossier Property

Public Property DokumentArtKundendossier() As Integer

Source code

[Visual Basic]
    Public Property DokumentArtKundendossier() As Integer
        Get
            Return _dokumentArtKundendossier
        End Get
        Set(ByVal Value As Integer)
            _dokumentArtKundendossier = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Dokumenttyp


Dokumenttyp.DokumentArtNativ Property

Public Property DokumentArtNativ() As Integer

Source code

[Visual Basic]
    Public Property DokumentArtNativ() As Integer
        Get
            Return _dokumentArtNativ
        End Get
        Set(ByVal Value As Integer)
            _dokumentArtNativ = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Dokumenttyp


Dokumenttyp.DokumentArtNeuerstellung Property

Public Property DokumentArtNeuerstellung() As Integer

Source code

[Visual Basic]
    Public Property DokumentArtNeuerstellung() As Integer
        Get
            Return _dokumentArtNeuerstellung
        End Get
        Set(ByVal Value As Integer)
            _dokumentArtNeuerstellung = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Dokumenttyp


Dokumenttyp.DokumentArtRetournierung Property

Public Property DokumentArtRetournierung() As Integer

Source code

[Visual Basic]
    Public Property DokumentArtRetournierung() As Integer
        Get
            Return _dokumentArtRetournierung
        End Get
        Set(ByVal Value As Integer)
            _dokumentArtRetournierung = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Dokumenttyp


Dokumenttyp.DokumentArtWeitere Property

Public Property DokumentArtWeitere() As Integer

Source code

[Visual Basic]
    Public Property DokumentArtWeitere() As Integer
        Get
            Return _dokumentArtWeitere
        End Get
        Set(ByVal Value As Integer)
            _dokumentArtWeitere = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Dokumenttyp


Dokumenttyp.DokumentStatus Property

Public Property DokumentStatus() As Integer

Source code

[Visual Basic]
    Public Property DokumentStatus() As Integer
        Get
            Return _dokumentStatus
        End Get
        Set(ByVal Value As Integer)
            _dokumentStatus = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Dokumenttyp


Dokumenttyp.DokumentStatusBarcode Property

Public Property DokumentStatusBarcode() As Integer

Source code

[Visual Basic]
    Public Property DokumentStatusBarcode() As Integer
        Get
            Return _dokumentStatusBarcode
        End Get
        Set(ByVal Value As Integer)
            _dokumentStatusBarcode = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Dokumenttyp


Dokumenttyp.DokumentTypNr Property

Public ReadOnly Property DokumentTypNr() As Integer

Source code

[Visual Basic]
    Public ReadOnly Property DokumentTypNr() As Integer
        Get
            Return _dokumentTypNr
        End Get
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Dokumenttyp


Dokumenttyp.ErstelltAm Property

Public Property ErstelltAm() As DateTime

Source code

[Visual Basic]
    Public Property ErstelltAm() As DateTime
        Get
            Return _erstelltAm
        End Get
        Set(ByVal Value As DateTime)
            _erstelltAm = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Dokumenttyp


Dokumenttyp.HostDokumenttyp Property

Public Property HostDokumenttyp() As String

Source code

[Visual Basic]
    Public Property HostDokumenttyp() As String
        Get
            Return _hostDokumenttyp
        End Get
        Set(ByVal Value As String)
            _hostDokumenttyp = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Dokumenttyp


Dokumenttyp.IsAktiv Property

Public Property IsAktiv() As Boolean

Source code

[Visual Basic]
    Public Property IsAktiv() As Boolean
        Get
            Return _isAktiv
        End Get
        Set(ByVal Value As Boolean)
            _isAktiv = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Dokumenttyp


Dokumenttyp.IsAmsDokument Property

Public Property IsAmsDokument() As Boolean

Source code

[Visual Basic]
    Public Property IsAmsDokument() As Boolean
        Get
            Return _isAmsDokument
        End Get
        Set(ByVal Value As Boolean)
            _isAmsDokument = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Dokumenttyp


Dokumenttyp.IsAnzeigeZurDokumenterstellung Property

Public Property IsAnzeigeZurDokumenterstellung() As Boolean

Source code

[Visual Basic]
    Public Property IsAnzeigeZurDokumenterstellung() As Boolean
        Get
            Return _isAnzeigeZurDokumenterstellung
        End Get
        Set(ByVal Value As Boolean)
            _isAnzeigeZurDokumenterstellung = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Dokumenttyp


Dokumenttyp.IsBedingtRetournierBar Property

Public Property IsBedingtRetournierBar() As Boolean

Source code

[Visual Basic]
    Public Property IsBedingtRetournierBar() As Boolean
        Get
            Return _isBedingtRetournierBar
        End Get
        Set(ByVal Value As Boolean)
            _isBedingtRetournierBar = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Dokumenttyp


Dokumenttyp.IsBezeichnungMut Property

Public Property IsBezeichnungMut() As Boolean

Source code

[Visual Basic]
    Public Property IsBezeichnungMut() As Boolean
        Get
            Return _isBezeichnungMut
        End Get
        Set(ByVal Value As Boolean)
            _isBezeichnungMut = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Dokumenttyp


Dokumenttyp.IsColdErsetzen Property

Public Property IsColdErsetzen() As Boolean

Source code

[Visual Basic]
    Public Property IsColdErsetzen() As Boolean
        Get
            Return _isColdErsetzen
        End Get
        Set(ByVal Value As Boolean)
            _isColdErsetzen = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Dokumenttyp


Dokumenttyp.IsDokumentWirdErstellt Property

Public Property IsDokumentWirdErstellt() As Boolean

Source code

[Visual Basic]
    Public Property IsDokumentWirdErstellt() As Boolean
        Get
            Return _isDokumentWirdErstellt
        End Get
        Set(ByVal Value As Boolean)
            _isDokumentWirdErstellt = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Dokumenttyp


Dokumenttyp.IsDokumentWirdRetourniert Property

Public Property IsDokumentWirdRetourniert() As Boolean

Source code

[Visual Basic]
    Public Property IsDokumentWirdRetourniert() As Boolean
        Get
            Return _isDokumentWirdRetourniert
        End Get
        Set(ByVal Value As Boolean)
            _isDokumentWirdRetourniert = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Dokumenttyp


Dokumenttyp.IsEingangErsetztAusgang Property

Public Property IsEingangErsetztAusgang() As Boolean

Source code

[Visual Basic]
    Public Property IsEingangErsetztAusgang() As Boolean
        Get
            Return _isEingangErsetztAusgang
        End Get
        Set(ByVal Value As Boolean)
            _isEingangErsetztAusgang = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Dokumenttyp


Dokumenttyp.IsEmailVersand Property

Public Property IsEmailVersand() As Boolean

Source code

[Visual Basic]
    Public Property IsEmailVersand() As Boolean
        Get
            Return _isEmailVersand
        End Get
        Set(ByVal Value As Boolean)
            _isEmailVersand = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Dokumenttyp


Dokumenttyp.IsFarbigArchiviert Property

Public Property IsFarbigArchiviert() As Boolean

Source code

[Visual Basic]
    Public Property IsFarbigArchiviert() As Boolean
        Get
            Return _isFarbigArchiviert
        End Get
        Set(ByVal Value As Boolean)
            _isFarbigArchiviert = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Dokumenttyp


Dokumenttyp.IsFunktionenZuweisen Property

Public Property IsFunktionenZuweisen() As Boolean

Source code

[Visual Basic]
    Public Property IsFunktionenZuweisen() As Boolean
        Get
            Return _isFunktionenZuweisen
        End Get
        Set(ByVal Value As Boolean)
            _isFunktionenZuweisen = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Dokumenttyp


Dokumenttyp.IsHostDokument Property

Public Property IsHostDokument() As Boolean

Source code

[Visual Basic]
    Public Property IsHostDokument() As Boolean
        Get
            Return _isHostDokument
        End Get
        Set(ByVal Value As Boolean)
            _isHostDokument = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Dokumenttyp


Dokumenttyp.IsKundenDokument Property

Public Property IsKundenDokument() As Boolean

Source code

[Visual Basic]
    Public Property IsKundenDokument() As Boolean
        Get
            Return _isKundenDokument
        End Get
        Set(ByVal Value As Boolean)
            _isKundenDokument = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Dokumenttyp


Dokumenttyp.IsNurNative Property

Public Property IsNurNative() As Boolean

Source code

[Visual Basic]
    Public Property IsNurNative() As Boolean
        Get
            Return _isNurNative
        End Get
        Set(ByVal Value As Boolean)
            _isNurNative = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Dokumenttyp


Dokumenttyp.IsPartnerSaldierungStatusAlt Property

Public Property IsPartnerSaldierungStatusAlt() As Boolean

Source code

[Visual Basic]
    Public Property IsPartnerSaldierungStatusAlt() As Boolean
        Get
            Return _isPartnerSaldierungStatusAlt
        End Get
        Set(ByVal Value As Boolean)
            _isPartnerSaldierungStatusAlt = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Dokumenttyp


Dokumenttyp.IsSb Property

Public Property IsSb() As Boolean

Source code

[Visual Basic]
    Public Property IsSb() As Boolean
        Get
            Return _isSb
        End Get
        Set(ByVal Value As Boolean)
            _isSb = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Dokumenttyp


Dokumenttyp.IsSbEditUser Property

Public Property IsSbEditUser() As Boolean

Source code

[Visual Basic]
    Public Property IsSbEditUser() As Boolean
        Get
            Return _isSbEditUser
        End Get
        Set(ByVal Value As Boolean)
            _isSbEditUser = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Dokumenttyp


Dokumenttyp.IsSbImport Property

Public Property IsSbImport() As Boolean

Source code

[Visual Basic]
    Public Property IsSbImport() As Boolean
        Get
            Return _isSbImport
        End Get
        Set(ByVal Value As Boolean)
            _isSbImport = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Dokumenttyp


Dokumenttyp.IsSbNur Property

Public Property IsSbNur() As Boolean

Source code

[Visual Basic]
    Public Property IsSbNur() As Boolean
        Get
            Return _isSbNur
        End Get
        Set(ByVal Value As Boolean)
            _isSbNur = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Dokumenttyp


Dokumenttyp.IsUnterschriftLinks Property

Public Property IsUnterschriftLinks() As Boolean

Source code

[Visual Basic]
    Public Property IsUnterschriftLinks() As Boolean
        Get
            Return _isUnterschriftLinks
        End Get
        Set(ByVal Value As Boolean)
            _isUnterschriftLinks = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Dokumenttyp


Dokumenttyp.IsUnterschriftRechts Property

Public Property IsUnterschriftRechts() As Boolean

Source code

[Visual Basic]
    Public Property IsUnterschriftRechts() As Boolean
        Get
            Return _isUnterschriftRechts
        End Get
        Set(ByVal Value As Boolean)
            _isUnterschriftRechts = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Dokumenttyp


Dokumenttyp.IsVertrag Property

Public Property IsVertrag() As Boolean

Source code

[Visual Basic]
    Public Property IsVertrag() As Boolean
        Get
            Return _isVertrag
        End Get
        Set(ByVal Value As Boolean)
            _isVertrag = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Dokumenttyp


Dokumenttyp.IsVertraulichesDokument Property

Public Property IsVertraulichesDokument() As Boolean

Source code

[Visual Basic]
    Public Property IsVertraulichesDokument() As Boolean
        Get
            Return _isVertraulichesDokument
        End Get
        Set(ByVal Value As Boolean)
            _isVertraulichesDokument = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Dokumenttyp


Dokumenttyp.IsWirdImportiert Property

Public Property IsWirdImportiert() As Boolean

Source code

[Visual Basic]
    Public Property IsWirdImportiert() As Boolean
        Get
            Return _isWirdImportiert
        End Get
        Set(ByVal Value As Boolean)
            _isWirdImportiert = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Dokumenttyp


Dokumenttyp.IsWirdNichtGeloescht Property

Public Property IsWirdNichtGeloescht() As Boolean

Source code

[Visual Basic]
    Public Property IsWirdNichtGeloescht() As Boolean
        Get
            Return _isWirdNichtGeloescht
        End Get
        Set(ByVal Value As Boolean)
            _isWirdNichtGeloescht = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Dokumenttyp


Dokumenttyp.IsZuRetournieren Property

Public Property IsZuRetournieren() As Boolean

Source code

[Visual Basic]
    Public Property IsZuRetournieren() As Boolean
        Get
            Return _isZuRetournieren
        End Get
        Set(ByVal Value As Boolean)
            _isZuRetournieren = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Dokumenttyp


Dokumenttyp.MonateBisZurArchivierung Property

Public Property MonateBisZurArchivierung() As Integer

Source code

[Visual Basic]
    Public Property MonateBisZurArchivierung() As Integer
        Get
            Return _monateBisZurArchivierung
        End Get
        Set(ByVal Value As Integer)
            _monateBisZurArchivierung = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Dokumenttyp


Dokumenttyp.Mutierer Property

Public Property Mutierer() As Integer

Source code

[Visual Basic]
    Public Property Mutierer() As Integer
        Get
            Return _mutierer
        End Get
        Set(ByVal Value As Integer)
            _mutierer = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Dokumenttyp


Dokumenttyp.MutiertAm Property

Public Property MutiertAm() As DateTime

Source code

[Visual Basic]
    Public Property MutiertAm() As DateTime
        Get
            Return _mutiertAm
        End Get
        Set(ByVal Value As DateTime)
            _mutiertAm = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Dokumenttyp


Dokumenttyp.ObjektbezeichnungNr Property

Public Property ObjektbezeichnungNr() As Integer

Source code

[Visual Basic]
    Public Property ObjektbezeichnungNr() As Integer
        Get
            Return _objektbezeichnungNr
        End Get
        Set(ByVal Value As Integer)
            _objektbezeichnungNr = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Dokumenttyp


Dokumenttyp.OfficeVorlageNr Property

Public Property OfficeVorlageNr() As Integer

Source code

[Visual Basic]
    Public Property OfficeVorlageNr() As Integer
        Get
            Return _officeVorlageNr
        End Get
        Set(ByVal Value As Integer)
            _officeVorlageNr = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Dokumenttyp


Dokumenttyp.Owner Property

Public Property Owner() As Integer

Source code

[Visual Basic]
    Public Property Owner() As Integer
        Get
            Return _owner
        End Get
        Set(ByVal Value As Integer)
            _owner = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Dokumenttyp


Dokumenttyp.PhysischesArchiv Property

Public Property PhysischesArchiv() As Integer

Source code

[Visual Basic]
    Public Property PhysischesArchiv() As Integer
        Get
            Return _physischesArchiv
        End Get
        Set(ByVal Value As Integer)
            _physischesArchiv = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Dokumenttyp


Dokumenttyp.ProzessNr Property

Public Property ProzessNr() As Integer

Source code

[Visual Basic]
    Public Property ProzessNr() As Integer
        Get
            Return _prozessNr
        End Get
        Set(ByVal Value As Integer)
            _prozessNr = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Dokumenttyp


Dokumenttyp.ProzessNr1 Property

Public Property ProzessNr1() As Integer

Source code

[Visual Basic]
    Public Property ProzessNr1() As Integer
        Get
            Return _prozessNr1
        End Get
        Set(ByVal Value As Integer)
            _prozessNr1 = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Dokumenttyp


Dokumenttyp.TageBisVernichtungbedingteRetournierung Property

Public Property TageBisVernichtungbedingteRetournierung() As Integer

Source code

[Visual Basic]
    Public Property TageBisVernichtungbedingteRetournierung() As Integer
        Get
            Return _tageBisVernichtungbedingteRetournierung
        End Get
        Set(ByVal Value As Integer)
            _tageBisVernichtungbedingteRetournierung = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Dokumenttyp


Dokumenttyp.TageMutation Property

Public Property TageMutation() As Integer

Source code

[Visual Basic]
    Public Property TageMutation() As Integer
        Get
            Return _tageMutation
        End Get
        Set(ByVal Value As Integer)
            _tageMutation = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Dokumenttyp


Dokumenttyp.ZuVercolden Property

Public Property ZuVercolden() As Boolean

Source code

[Visual Basic]
    Public Property ZuVercolden() As Boolean
        Get
            Return _zuVercolden
        End Get
        Set(ByVal Value As Boolean)
            _zuVercolden = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Dokumenttyp


Dokumenttyp Methods

Dokumenttyp overview

Methods

method Delete |
method LoadData | lädt die daten aus dem dataset in die members der klasse
method Save | speichert einen dokumenttyp(update und insert)

See Also

Dokumenttyp Class


Dokumenttyp.Delete Method

Public Function Delete( _
   ByVal mutierer As Integer _
)

Parameters

mutierer
Required.

Source code

[Visual Basic]
    Public Function Delete(ByVal mutierer As Integer)
        Try

        Catch ex As Exception
            TKBLib.Errorhandling.TraceHelper.Msg("EDOKALib.BF.Dokumenttyp.Delete", ex.Message + " " + ex.StackTrace, TraceLevel.Error)
            Throw ex
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Dokumenttyp


Dokumenttyp.LoadData Method

lädt die daten aus dem dataset in die members der klasse

Private Sub LoadData( _
   ByRef ds As DataSet _
)

Parameters

ds
Required.

Source code

[Visual Basic]
    Private Sub LoadData(ByRef ds As DataSet)
        Try
            If Common.Tools.ValidateDS(ds) Then
                _dokumentTypNr = Tools.CToInt32(ds.Tables(0).Rows(0)("dokumentTypNr"))
                _bezeichnung = NullHandler.CToString(ds.Tables(0).Rows(0)("bezeichnung"))
                _beschreibung = NullHandler.CToString(ds.Tables(0).Rows(0)("beschreibung"))
                _zuVercolden = Tools.CToBool(ds.Tables(0).Rows(0)("zu_vercolden"))
                _isZuRetournieren = Tools.CToBool(ds.Tables(0).Rows(0)("zu_retournieren"))
                _isEingangErsetztAusgang = Tools.CToBool(ds.Tables(0).Rows(0)("eingang_ersetzt_ausgang"))
                _isWirdImportiert = Tools.CToBool(ds.Tables(0).Rows(0)("wird_importiert"))
                _anzahlTage = Tools.CToInt32(ds.Tables(0).Rows(0)("anzahl_tage"))
                _dBearbeitungsZeit = Tools.CToInt32(ds.Tables(0).Rows(0)("dbearbeitungszeit"))
                _tageMutation = Tools.CToInt32(ds.Tables(0).Rows(0)("tage_mutation"))
                _isPartnerSaldierungStatusAlt = Tools.CToBool(ds.Tables(0).Rows(0)("partnersaldierung_statusalt"))
                _isWirdNichtGeloescht = Tools.CToBool(ds.Tables(0).Rows(0)("wird_nicht_geloescht"))
                _isVertraulichesDokument = Tools.CToBool(ds.Tables(0).Rows(0)("vertrauliches_dokument"))
                _isUnterschriftLinks = Tools.CToBool(ds.Tables(0).Rows(0)("unterschrift_links"))
                _isUnterschriftRechts = Tools.CToBool(ds.Tables(0).Rows(0)("unterschrift_rechts"))
                _monateBisZurArchivierung = Tools.CToInt32(ds.Tables(0).Rows(0)("monate_bis_zur_archivierung"))
                _aufbewahrungsFristElektronisch = Tools.CToInt32(ds.Tables(0).Rows(0)("aufbewahrungsfrist_elektronisch"))
                _aufbewahrungsFristPhysisch = Tools.CToInt32(ds.Tables(0).Rows(0)("aufbewahrungsfrist_physisch"))
                _mandantNr = NullHandler.CToInt32(ds.Tables(0).Rows(0)("mandantnr"))
                _isAktiv = Tools.CToBool(ds.Tables(0).Rows(0)("aktiv"))
                _erstelltAm = NullHandler.CToDateTime(ds.Tables(0).Rows(0)("erstellt_am"))
                _mutiertAm = NullHandler.CToDateTime(ds.Tables(0).Rows(0)("mutiert_am"))
                _mutierer = NullHandler.CToInt32(ds.Tables(0).Rows(0)("mutierer"))
                _officeVorlageNr = NullHandler.CToInt32(ds.Tables(0).Rows(0)("office_vorlagenr"))
                _dokumentArtKundendossier = NullHandler.CToInt32(ds.Tables(0).Rows(0)("dokumentart_kundendossier"))
                _dokumentArtNeuerstellung = NullHandler.CToInt32(ds.Tables(0).Rows(0)("dokumentart_neuerstellung"))
                _dokumentArtRetournierung = NullHandler.CToInt32(ds.Tables(0).Rows(0)("dokumentart_retournierung"))
                _dokumentArtColdAusgang = Tools.CToInt32(ds.Tables(0).Rows(0)("dokumentart_coldausgang"))
                _dokumentArtColdEingang = Tools.CToInt32(ds.Tables(0).Rows(0)("dokumentart_coldeingang"))
                _dokumentArtHost = NullHandler.CToInt32(ds.Tables(0).Rows(0)("dokumentart_host"))
                _dokumentArtWeitere = NullHandler.CToInt32(ds.Tables(0).Rows(0)("dokumentart_weitere"))
                _dokumentArtNativ = NullHandler.CToInt32(ds.Tables(0).Rows(0)("dokumentart_nativ"))
                _prozessNr = NullHandler.CToInt32(ds.Tables(0).Rows(0)("prozessnr"))
                _prozessNr1 = NullHandler.CToInt32(ds.Tables(0).Rows(0)("prozessnr1"))
                _isAmsDokument = Tools.CToBool(ds.Tables(0).Rows(0)("amsdokument"))
                _isHostDokument = Tools.CToBool(ds.Tables(0).Rows(0)("hostdokument"))
                _hostDokumenttyp = NullHandler.CToString(ds.Tables(0).Rows(0)("hostdokumenttyp"))
                _coldFolder = NullHandler.CToInt32(ds.Tables(0).Rows(0)("cold_folder"))
                _physischesArchiv = NullHandler.CToInt32(ds.Tables(0).Rows(0)("physisches_archiv"))
                _dokumentStatus = NullHandler.CToInt32(ds.Tables(0).Rows(0)("dokumentstatus"))
                _isDokumentWirdErstellt = Tools.CToBool(ds.Tables(0).Rows(0)("Dokument_wird_erstellt"))
                _isDokumentWirdRetourniert = Tools.CToBool(ds.Tables(0).Rows(0)("Dokument_wird_retourniert"))
                _isColdErsetzen = Tools.CToBool(ds.Tables(0).Rows(0)("cold_ersetzen"))
                _isEmailVersand = Tools.CToBool(ds.Tables(0).Rows(0)("email_versand"))
                _isFunktionenZuweisen = Tools.CToBool(ds.Tables(0).Rows(0)("funktionen_zuweisen"))
                _dokumentStatusBarcode = NullHandler.CToInt32(ds.Tables(0).Rows(0)("dokumentstatus_barcode"))
                _isNurNative = Tools.CToBool(ds.Tables(0).Rows(0)("nurnative"))
                _owner = NullHandler.CToInt32(ds.Tables(0).Rows(0)("Owner"))
                _isVertrag = Tools.CToBool(ds.Tables(0).Rows(0)("vertrag"))
                _objektbezeichnungNr = NullHandler.CToInt32(ds.Tables(0).Rows(0)("objektbezeichnungnr"))
                _isBedingtRetournierBar = Tools.CToBool(ds.Tables(0).Rows(0)("bedingtretournierbar"))
                _doktypBedingteRetournierung = NullHandler.CToInt32(ds.Tables(0).Rows(0)("doktypbedingteretournierung"))
                _tageBisVernichtungbedingteRetournierung = NullHandler.CToInt32(ds.Tables(0).Rows(0)("tagebisvernichtungbedingteretournierung"))
                _isAnzeigeZurDokumenterstellung = Tools.CToBool(ds.Tables(0).Rows(0)("AnzeigeZurDokumenterstellung"))
                _isKundenDokument = Tools.CToBool(ds.Tables(0).Rows(0)("KundenDokument"))
                _isSb = Tools.CToBool(ds.Tables(0).Rows(0)("sb"))
                _isSbImport = Tools.CToBool(ds.Tables(0).Rows(0)("sbimport"))
                _isSbEditUser = Tools.CToBool(ds.Tables(0).Rows(0)("sbedituser"))
                _isSbNur = Tools.CToBool(ds.Tables(0).Rows(0)("sbnur"))
                _isBezeichnungMut = Tools.CToBool(ds.Tables(0).Rows(0)("bezeichnungmut"))
                _isFarbigArchiviert = Tools.CToBool(ds.Tables(0).Rows(0)("istFarbigArchiviert"))
            End If
        Catch ex As Exception
            TKBLib.Errorhandling.TraceHelper.Msg("EDOKALib.BF.DokumentTyp.LoadData", ex.Message + " " + ex.StackTrace, TraceLevel.Error)
            Throw ex
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Dokumenttyp


Dokumenttyp.Save Method

speichert einen dokumenttyp(update und insert)

Public Function Save( _
   ByVal mutierer As Integer _
)

Parameters

mutierer
Required.

Source code

[Visual Basic]
    Public Function Save(ByVal mutierer As Integer)
        Try
            Dim err As Integer
            If _dokumentTypNr = 0 Then 'create new
                err = DataAccess.Dokumenttyp.Add(_dokumentTypNr, _bezeichnung, _beschreibung, _zuVercolden, _isZuRetournieren, _
                _isEingangErsetztAusgang, _isWirdImportiert, _anzahlTage, _dBearbeitungsZeit, _tageMutation, _
                _isPartnerSaldierungStatusAlt, _isWirdNichtGeloescht, _isVertraulichesDokument, _isUnterschriftLinks, _
                _isUnterschriftRechts, _monateBisZurArchivierung, _aufbewahrungsFristElektronisch, _
                _aufbewahrungsFristPhysisch, _mandantNr, _isAktiv, _erstelltAm, _mutiertAm, mutierer, _
                _officeVorlageNr, _dokumentArtKundendossier, _dokumentArtNeuerstellung, _dokumentArtRetournierung, _
                _dokumentArtColdAusgang, _dokumentArtColdEingang, _dokumentArtHost, _dokumentArtWeitere, _
                _dokumentArtNativ, _prozessNr, _prozessNr1, _isAmsDokument, _isHostDokument, _hostDokumenttyp, _
                _coldFolder, _physischesArchiv, _dokumentStatus, _isDokumentWirdErstellt, _isDokumentWirdRetourniert, _
                _isColdErsetzen, _isEmailVersand, _isFunktionenZuweisen, _dokumentStatusBarcode, _isNurNative, _
                _owner, _isVertrag, _objektbezeichnungNr, _isBedingtRetournierBar, _doktypBedingteRetournierung, _
                _tageBisVernichtungbedingteRetournierung, _isAnzeigeZurDokumenterstellung, _isKundenDokument, _
                _isSb, _isSbImport, _isSbEditUser, _isSbNur, _isBezeichnungMut, _isFarbigArchiviert)

            Else 'save existing
                err = DataAccess.Dokumenttyp.Update(_dokumentTypNr, _bezeichnung, _beschreibung, _zuVercolden, _isZuRetournieren, _
                _isEingangErsetztAusgang, _isWirdImportiert, _anzahlTage, _dBearbeitungsZeit, _tageMutation, _
                _isPartnerSaldierungStatusAlt, _isWirdNichtGeloescht, _isVertraulichesDokument, _isUnterschriftLinks, _
                _isUnterschriftRechts, _monateBisZurArchivierung, _aufbewahrungsFristElektronisch, _
                _aufbewahrungsFristPhysisch, _mandantNr, _isAktiv, _erstelltAm, _mutiertAm, mutierer, _
                _officeVorlageNr, _dokumentArtKundendossier, _dokumentArtNeuerstellung, _dokumentArtRetournierung, _
                _dokumentArtColdAusgang, _dokumentArtColdEingang, _dokumentArtHost, _dokumentArtWeitere, _
                _dokumentArtNativ, _prozessNr, _prozessNr1, _isAmsDokument, _isHostDokument, _hostDokumenttyp, _
                _coldFolder, _physischesArchiv, _dokumentStatus, _isDokumentWirdErstellt, _isDokumentWirdRetourniert, _
                _isColdErsetzen, _isEmailVersand, _isFunktionenZuweisen, _dokumentStatusBarcode, _isNurNative, _
                _owner, _isVertrag, _objektbezeichnungNr, _isBedingtRetournierBar, _doktypBedingteRetournierung, _
                _tageBisVernichtungbedingteRetournierung, _isAnzeigeZurDokumenterstellung, _isKundenDokument, _
                _isSb, _isSbImport, _isSbEditUser, _isSbNur, _isBezeichnungMut, _isFarbigArchiviert)
            End If

            If err <> 0 Then
                Throw New DokumentartException(Meldungstext.GetInhaltById(40000))
            End If

            'refresh data
            Dim ds As New DataSet()
            DataAccess.Dokumentart.GetDokumentart(ds, _dokumentTypNr)
            LoadData(ds)

        Catch ex As Exception
            TKBLib.Errorhandling.TraceHelper.Msg("EDOKALib.BF.Dokumentart.Save", ex.Message + " " + ex.StackTrace, TraceLevel.Error)
            Throw ex
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Dokumenttyp


Dokumenttyp Fields

Dokumenttyp overview

Fields

field _anzahlTage
field _aufbewahrungsFristElektronisch
field _aufbewahrungsFristPhysisch
field _beschreibung
field _bezeichnung
field _coldFolder
field _dBearbeitungsZeit
field _doktypBedingteRetournierung
field _dokumentArtColdAusgang
field _dokumentArtColdEingang
field _dokumentArtHost
field _dokumentArtKundendossier
field _dokumentArtNativ
field _dokumentArtNeuerstellung
field _dokumentArtRetournierung
field _dokumentArtWeitere
field _dokumentStatus
field _dokumentStatusBarcode
field _dokumentTypNr
field _erstelltAm
field _hostDokumenttyp
field _isAktiv
field _isAmsDokument
field _isAnzeigeZurDokumenterstellung
field _isBedingtRetournierBar
field _isBezeichnungMut
field _isColdErsetzen
field _isDokumentWirdErstellt
field _isDokumentWirdRetourniert
field _isEingangErsetztAusgang
field _isEmailVersand
field _isFarbigArchiviert
field _isFunktionenZuweisen
field _isHostDokument
field _isKundenDokument
field _isNurNative
field _isPartnerSaldierungStatusAlt
field _isSb
field _isSbEditUser
field _isSbImport
field _isSbNur
field _isUnterschriftLinks
field _isUnterschriftRechts
field _isVertrag
field _isVertraulichesDokument
field _isWirdImportiert
field _isWirdNichtGeloescht
field _isZuRetournieren
field _mandantNr
field _monateBisZurArchivierung
field _mutierer
field _mutiertAm
field _objektbezeichnungNr
field _officeVorlageNr
field _owner
field _physischesArchiv
field _prozessNr
field _prozessNr1
field _tageBisVernichtungbedingteRetournierung
field _tageMutation
field _zuVercolden

See Also

Dokumenttyp Class


_anzahlTage Variable

Private _anzahlTage As Integer

Source code

[Visual Basic]
    Private _anzahlTage As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Dokumenttyp


_aufbewahrungsFristElektronisch Variable

Private _aufbewahrungsFristElektronisch As Integer

Source code

[Visual Basic]
    Private _aufbewahrungsFristElektronisch As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Dokumenttyp


_aufbewahrungsFristPhysisch Variable

Private _aufbewahrungsFristPhysisch As Integer

Source code

[Visual Basic]
    Private _aufbewahrungsFristPhysisch As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Dokumenttyp


_beschreibung Variable

Private _beschreibung As String

Source code

[Visual Basic]
    Private _beschreibung As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Dokumenttyp


_bezeichnung Variable

Private _bezeichnung As String

Source code

[Visual Basic]
    Private _bezeichnung As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Dokumenttyp


_coldFolder Variable

Private _coldFolder As Integer

Source code

[Visual Basic]
    Private _coldFolder As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Dokumenttyp


_dBearbeitungsZeit Variable

Private _dBearbeitungsZeit As Integer

Source code

[Visual Basic]
    Private _dBearbeitungsZeit As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Dokumenttyp


_doktypBedingteRetournierung Variable

Private _doktypBedingteRetournierung As Integer

Source code

[Visual Basic]
    Private _doktypBedingteRetournierung As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Dokumenttyp


_dokumentArtColdAusgang Variable

Private _dokumentArtColdAusgang As Integer

Source code

[Visual Basic]
    Private _dokumentArtColdAusgang As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Dokumenttyp


_dokumentArtColdEingang Variable

Private _dokumentArtColdEingang As Integer

Source code

[Visual Basic]
    Private _dokumentArtColdEingang As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Dokumenttyp


_dokumentArtHost Variable

Private _dokumentArtHost As Integer

Source code

[Visual Basic]
    Private _dokumentArtHost As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Dokumenttyp


_dokumentArtKundendossier Variable

Private _dokumentArtKundendossier As Integer

Source code

[Visual Basic]
    Private _dokumentArtKundendossier As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Dokumenttyp


_dokumentArtNativ Variable

Private _dokumentArtNativ As Integer

Source code

[Visual Basic]
    Private _dokumentArtNativ As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Dokumenttyp


_dokumentArtNeuerstellung Variable

Private _dokumentArtNeuerstellung As Integer

Source code

[Visual Basic]
    Private _dokumentArtNeuerstellung As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Dokumenttyp


_dokumentArtRetournierung Variable

Private _dokumentArtRetournierung As Integer

Source code

[Visual Basic]
    Private _dokumentArtRetournierung As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Dokumenttyp


_dokumentArtWeitere Variable

Private _dokumentArtWeitere As Integer

Source code

[Visual Basic]
    Private _dokumentArtWeitere As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Dokumenttyp


_dokumentStatus Variable

Private _dokumentStatus As Integer

Source code

[Visual Basic]
    Private _dokumentStatus As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Dokumenttyp


_dokumentStatusBarcode Variable

Private _dokumentStatusBarcode As Integer

Source code

[Visual Basic]
    Private _dokumentStatusBarcode As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Dokumenttyp


_dokumentTypNr Variable

Private _dokumentTypNr As Integer

Source code

[Visual Basic]
    Private _dokumentTypNr As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Dokumenttyp


_erstelltAm Variable

Private _erstelltAm As DateTime

Source code

[Visual Basic]
    Private _erstelltAm As DateTime

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Dokumenttyp


_hostDokumenttyp Variable

Private _hostDokumenttyp As String

Source code

[Visual Basic]
    Private _hostDokumenttyp As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Dokumenttyp


_isAktiv Variable

Private _isAktiv As Boolean

Source code

[Visual Basic]
    Private _isAktiv As Boolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Dokumenttyp


_isAmsDokument Variable

Private _isAmsDokument As Boolean

Source code

[Visual Basic]
    Private _isAmsDokument As Boolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Dokumenttyp


_isAnzeigeZurDokumenterstellung Variable

Private _isAnzeigeZurDokumenterstellung As Boolean

Source code

[Visual Basic]
    Private _isAnzeigeZurDokumenterstellung As Boolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Dokumenttyp


_isBedingtRetournierBar Variable

Private _isBedingtRetournierBar As Boolean

Source code

[Visual Basic]
    Private _isBedingtRetournierBar As Boolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Dokumenttyp


_isBezeichnungMut Variable

Private _isBezeichnungMut As Boolean

Source code

[Visual Basic]
    Private _isBezeichnungMut As Boolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Dokumenttyp


_isColdErsetzen Variable

Private _isColdErsetzen As Boolean

Source code

[Visual Basic]
    Private _isColdErsetzen As Boolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Dokumenttyp


_isDokumentWirdErstellt Variable

Private _isDokumentWirdErstellt As Boolean

Source code

[Visual Basic]
    Private _isDokumentWirdErstellt As Boolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Dokumenttyp


_isDokumentWirdRetourniert Variable

Private _isDokumentWirdRetourniert As Boolean

Source code

[Visual Basic]
    Private _isDokumentWirdRetourniert As Boolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Dokumenttyp


_isEingangErsetztAusgang Variable

Private _isEingangErsetztAusgang As Boolean

Source code

[Visual Basic]
    Private _isEingangErsetztAusgang As Boolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Dokumenttyp


_isEmailVersand Variable

Private _isEmailVersand As Boolean

Source code

[Visual Basic]
    Private _isEmailVersand As Boolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Dokumenttyp


_isFarbigArchiviert Variable

Private _isFarbigArchiviert As Boolean

Source code

[Visual Basic]
    Private _isFarbigArchiviert As Boolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Dokumenttyp


_isFunktionenZuweisen Variable

Private _isFunktionenZuweisen As Boolean

Source code

[Visual Basic]
    Private _isFunktionenZuweisen As Boolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Dokumenttyp


_isHostDokument Variable

Private _isHostDokument As Boolean

Source code

[Visual Basic]
    Private _isHostDokument As Boolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Dokumenttyp


_isKundenDokument Variable

Private _isKundenDokument As Boolean

Source code

[Visual Basic]
    Private _isKundenDokument As Boolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Dokumenttyp


_isNurNative Variable

Private _isNurNative As Boolean

Source code

[Visual Basic]
    Private _isNurNative As Boolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Dokumenttyp


_isPartnerSaldierungStatusAlt Variable

Private _isPartnerSaldierungStatusAlt As Boolean

Source code

[Visual Basic]
    Private _isPartnerSaldierungStatusAlt As Boolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Dokumenttyp


_isSb Variable

Private _isSb As Boolean

Source code

[Visual Basic]
    Private _isSb As Boolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Dokumenttyp


_isSbEditUser Variable

Private _isSbEditUser As Boolean

Source code

[Visual Basic]
    Private _isSbEditUser As Boolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Dokumenttyp


_isSbImport Variable

Private _isSbImport As Boolean

Source code

[Visual Basic]
    Private _isSbImport As Boolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Dokumenttyp


_isSbNur Variable

Private _isSbNur As Boolean

Source code

[Visual Basic]
    Private _isSbNur As Boolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Dokumenttyp


_isUnterschriftLinks Variable

Private _isUnterschriftLinks As Boolean

Source code

[Visual Basic]
    Private _isUnterschriftLinks As Boolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Dokumenttyp


_isUnterschriftRechts Variable

Private _isUnterschriftRechts As Boolean

Source code

[Visual Basic]
    Private _isUnterschriftRechts As Boolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Dokumenttyp


_isVertrag Variable

Private _isVertrag As Boolean

Source code

[Visual Basic]
    Private _isVertrag As Boolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Dokumenttyp


_isVertraulichesDokument Variable

Private _isVertraulichesDokument As Boolean

Source code

[Visual Basic]
    Private _isVertraulichesDokument As Boolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Dokumenttyp


_isWirdImportiert Variable

Private _isWirdImportiert As Boolean

Source code

[Visual Basic]
    Private _isWirdImportiert As Boolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Dokumenttyp


_isWirdNichtGeloescht Variable

Private _isWirdNichtGeloescht As Boolean

Source code

[Visual Basic]
    Private _isWirdNichtGeloescht As Boolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Dokumenttyp


_isZuRetournieren Variable

Private _isZuRetournieren As Boolean

Source code

[Visual Basic]
    Private _isZuRetournieren As Boolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Dokumenttyp


_mandantNr Variable

Private _mandantNr As Integer

Source code

[Visual Basic]
    Private _mandantNr As Integer 'wird nicht in den properties implemnetiert

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Dokumenttyp


_monateBisZurArchivierung Variable

Private _monateBisZurArchivierung As Integer

Source code

[Visual Basic]
    Private _monateBisZurArchivierung As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Dokumenttyp


_mutierer Variable

Private _mutierer As Integer

Source code

[Visual Basic]
    Private _mutierer As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Dokumenttyp


_mutiertAm Variable

Private _mutiertAm As DateTime

Source code

[Visual Basic]
    Private _mutiertAm As DateTime

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Dokumenttyp


_objektbezeichnungNr Variable

Private _objektbezeichnungNr As Integer

Source code

[Visual Basic]
    Private _objektbezeichnungNr As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Dokumenttyp


_officeVorlageNr Variable

Private _officeVorlageNr As Integer

Source code

[Visual Basic]
    Private _officeVorlageNr As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Dokumenttyp


_owner Variable

Private _owner As Integer

Source code

[Visual Basic]
    Private _owner As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Dokumenttyp


_physischesArchiv Variable

Private _physischesArchiv As Integer

Source code

[Visual Basic]
    Private _physischesArchiv As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Dokumenttyp


_prozessNr Variable

Private _prozessNr As Integer

Source code

[Visual Basic]
    Private _prozessNr As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Dokumenttyp


_prozessNr1 Variable

Private _prozessNr1 As Integer

Source code

[Visual Basic]
    Private _prozessNr1 As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Dokumenttyp


_tageBisVernichtungbedingteRetournierung Variable

Private _tageBisVernichtungbedingteRetournierung As Integer

Source code

[Visual Basic]
    Private _tageBisVernichtungbedingteRetournierung As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Dokumenttyp


_tageMutation Variable

Private _tageMutation As Integer

Source code

[Visual Basic]
    Private _tageMutation As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Dokumenttyp


_zuVercolden Variable

Private _zuVercolden As Boolean

Source code

[Visual Basic]
    Private _zuVercolden As Boolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Dokumenttyp


Funktionsgruppe Class

Diese klasse beinhaltet die Logik für die Funktionsgruppe

For a list of all members of this type, see Funktionsgruppe Members.

System.Object
EDOKALib.BusinessFacade.Funktionsgruppe

Public Class Funktionsgruppe

Requirements

Namespace: BusinessFacade

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKALib.BusinessFacade (in EDOKALib.BusinessFacade.dll)

See Also

Funktionsgruppe Members


Funktionsgruppe Members

Funktionsgruppe overview

Constructors

constructor Funktionsgruppe Constructor

Methods

method GetListe Gibt eine Liste mit allen Funktionsgruppen zurück

Fields

field _beschreibung
field _bezeichnung
field _funktionsGruppeNr
field _isAktiv
field _mandantNr
field _zugehoerigkeit

See Also

Funktionsgruppe Class


Funktionsgruppe Constructor

Public Sub New()

Source code

[Visual Basic]
    Public Sub New()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Funktionsgruppe


Funktionsgruppe Methods

Funktionsgruppe overview

Methods

method GetListe Gibt eine Liste mit allen Funktionsgruppen zurück

See Also

Funktionsgruppe Class


Funktionsgruppe.GetListe Method

Gibt eine Liste mit allen Funktionsgruppen zurück

Public Overloads Shared Sub GetListe( _
   ByRef ds As DataSet _
)

Parameters

ds
Required. Das DataSet welches gefüllt werden soll

Source code

[Visual Basic]
    Public Overloads Shared Sub GetListe(ByRef ds As DataSet)
        Try
            DataAccess.Funktionsgruppe.GetListe(ds)
        Catch ex As Exception
            Throw ex
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Funktionsgruppe


Funktionsgruppe Fields

Funktionsgruppe overview

Fields

field _beschreibung
field _bezeichnung
field _funktionsGruppeNr
field _isAktiv
field _mandantNr
field _zugehoerigkeit

See Also

Funktionsgruppe Class


_beschreibung Variable

Private _beschreibung As String

Source code

[Visual Basic]
    Private _beschreibung As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Funktionsgruppe


_bezeichnung Variable

Private _bezeichnung As String

Source code

[Visual Basic]
    Private _bezeichnung As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Funktionsgruppe


_funktionsGruppeNr Variable

Private _funktionsGruppeNr As Integer

Source code

[Visual Basic]
    Private _funktionsGruppeNr As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Funktionsgruppe


_isAktiv Variable

Private _isAktiv As Boolean

Source code

[Visual Basic]
    Private _isAktiv As Boolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Funktionsgruppe


_mandantNr Variable

Private _mandantNr As Integer

Source code

[Visual Basic]
    Private _mandantNr As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Funktionsgruppe


_zugehoerigkeit Variable

Private _zugehoerigkeit As String

Source code

[Visual Basic]
    Private _zugehoerigkeit As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Funktionsgruppe


Klassifizierung Class

Diese klasse beinhaltet die Logik für die Klassifizierung

For a list of all members of this type, see Klassifizierung Members.

System.Object
EDOKALib.BusinessFacade.Klassifizierung

Public Class Klassifizierung

Requirements

Namespace: BusinessFacade

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKALib.BusinessFacade (in EDOKALib.BusinessFacade.dll)

See Also

Klassifizierung Members


Klassifizierung Members

Klassifizierung overview

Constructors

constructor Klassifizierung Constructor (Overloaded) Erstellt eine neue Instanz für einen neuen Mitarbeiter

Properties

property Beschreibung
property Bezeichnung
property ErstellerMitarbeiterNr
property ErstelltAm
property IsAktiv
property IsFunktionsgruppeZwingend
property IsTeamZwingend
property KlassenId
property MandantNr
property MutiererMitarbeiterNr
property MutiertAm

Methods

method GetListe Gibt eine Liste mit allen Klassifizierungen zurück

Fields

field _beschreibung
field _bezeichnung
field _erstellerMitarbeiterNr
field _erstelltAm
field _isAktiv
field _isFunktionsgruppeZwingend
field _isTeamZwingend
field _klassenId
field _mandantNr
field _mutiererMitarbeiterNr
field _mutiertAm

See Also

Klassifizierung Class


New

Overload List

Erstellt eine neue Instanz für einen neuen Mitarbeiter

[Visual Basic] Public Sub New()

Erstellt eine neue Instanz für eine bestehende Klassifizierung

[Visual Basic] Public Sub New(ByVal klassifizierungNr As Integer)

See Also

Klassifizierung | BusinessFacade


Klassifizierung Properties

Klassifizierung overview

Properties

property Beschreibung
property Bezeichnung
property ErstellerMitarbeiterNr
property ErstelltAm
property IsAktiv
property IsFunktionsgruppeZwingend
property IsTeamZwingend
property KlassenId
property MandantNr
property MutiererMitarbeiterNr
property MutiertAm

See Also

Klassifizierung Class


Klassifizierung.Beschreibung Property

Public Property Beschreibung() As String

Source code

[Visual Basic]
    Public Property Beschreibung() As String
        Get
            Return _beschreibung
        End Get
        Set(ByVal Value As String)
            _beschreibung = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Klassifizierung


Klassifizierung.Bezeichnung Property

Public Property Bezeichnung() As String

Source code

[Visual Basic]
    Public Property Bezeichnung() As String
        Get
            Return _bezeichnung
        End Get
        Set(ByVal Value As String)
            _bezeichnung = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Klassifizierung


Klassifizierung.ErstellerMitarbeiterNr Property

Public ReadOnly Property ErstellerMitarbeiterNr() As Integer

Source code

[Visual Basic]
    Public ReadOnly Property ErstellerMitarbeiterNr() As Integer
        Get
            Return _erstellerMitarbeiterNr
        End Get
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Klassifizierung


Klassifizierung.ErstelltAm Property

Public ReadOnly Property ErstelltAm() As DateTime

Source code

[Visual Basic]
    Public ReadOnly Property ErstelltAm() As DateTime
        Get
            Return _erstelltAm
        End Get
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Klassifizierung


Klassifizierung.IsAktiv Property

Public Property IsAktiv() As Boolean

Source code

[Visual Basic]
    Public Property IsAktiv() As Boolean
        Get
            Return _isAktiv
        End Get
        Set(ByVal Value As Boolean)
            _isAktiv = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Klassifizierung


Klassifizierung.IsFunktionsgruppeZwingend Property

Public Property IsFunktionsgruppeZwingend() As Boolean

Source code

[Visual Basic]
    Public Property IsFunktionsgruppeZwingend() As Boolean
        Get
            Return _isFunktionsgruppeZwingend
        End Get
        Set(ByVal Value As Boolean)
            _isFunktionsgruppeZwingend = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Klassifizierung


Klassifizierung.IsTeamZwingend Property

Public Property IsTeamZwingend() As Boolean

Source code

[Visual Basic]
    Public Property IsTeamZwingend() As Boolean
        Get
            Return _isTeamZwingend
        End Get
        Set(ByVal Value As Boolean)
            _isTeamZwingend = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Klassifizierung


Klassifizierung.KlassenId Property

Public ReadOnly Property KlassenId() As Integer

Source code

[Visual Basic]
    Public ReadOnly Property KlassenId() As Integer
        Get
            Return _klassenId
        End Get
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Klassifizierung


Klassifizierung.MandantNr Property

Public Property MandantNr() As Integer

Source code

[Visual Basic]
    Public Property MandantNr() As Integer
        Get
            Return _mandantNr
        End Get
        Set(ByVal Value As Integer)
            _mandantNr = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Klassifizierung


Klassifizierung.MutiererMitarbeiterNr Property

Public Property MutiererMitarbeiterNr() As Integer

Source code

[Visual Basic]
    Public Property MutiererMitarbeiterNr() As Integer
        Get
            Return _mutiererMitarbeiterNr
        End Get
        Set(ByVal Value As Integer)
            _mutiererMitarbeiterNr = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Klassifizierung


Klassifizierung.MutiertAm Property

Public Property MutiertAm() As DateTime

Source code

[Visual Basic]
    Public Property MutiertAm() As DateTime
        Get
            Return _mutiertAm
        End Get
        Set(ByVal Value As DateTime)
            _mutiertAm = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Klassifizierung


Klassifizierung Methods

Klassifizierung overview

Methods

method GetListe Gibt eine Liste mit allen Klassifizierungen zurück

See Also

Klassifizierung Class


Klassifizierung.GetListe Method

Gibt eine Liste mit allen Klassifizierungen zurück

Public Overloads Shared Sub GetListe( _
   ByRef ds As DataSet _
)

Parameters

ds
Required. Das DataSet welches gefüllt werden soll

Source code

[Visual Basic]
    Public Overloads Shared Sub GetListe(ByRef ds As DataSet)
        Try
            DataAccess.Klassifizierung.GetListe(ds)
        Catch ex As Exception
            Throw ex
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Klassifizierung


Klassifizierung Fields

Klassifizierung overview

Fields

field _beschreibung
field _bezeichnung
field _erstellerMitarbeiterNr
field _erstelltAm
field _isAktiv
field _isFunktionsgruppeZwingend
field _isTeamZwingend
field _klassenId
field _mandantNr
field _mutiererMitarbeiterNr
field _mutiertAm

See Also

Klassifizierung Class


_beschreibung Variable

Dim _beschreibung As String

Source code

[Visual Basic]
    Dim _beschreibung As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Klassifizierung


_bezeichnung Variable

Dim _bezeichnung As String

Source code

[Visual Basic]
    Dim _bezeichnung As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Klassifizierung


_erstellerMitarbeiterNr Variable

Dim _erstellerMitarbeiterNr As Integer

Source code

[Visual Basic]
    Dim _erstellerMitarbeiterNr As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Klassifizierung


_erstelltAm Variable

Dim _erstelltAm As DateTime

Source code

[Visual Basic]
    Dim _erstelltAm As DateTime

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Klassifizierung


_isAktiv Variable

Dim _isAktiv As Boolean

Source code

[Visual Basic]
    Dim _isAktiv As Boolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Klassifizierung


_isFunktionsgruppeZwingend Variable

Dim _isFunktionsgruppeZwingend As Boolean

Source code

[Visual Basic]
    Dim _isFunktionsgruppeZwingend As Boolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Klassifizierung


_isTeamZwingend Variable

Dim _isTeamZwingend As Boolean

Source code

[Visual Basic]
    Dim _isTeamZwingend As Boolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Klassifizierung


_klassenId Variable

Dim _klassenId As Integer

Source code

[Visual Basic]
    Dim _klassenId As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Klassifizierung


_mandantNr Variable

Dim _mandantNr As Integer

Source code

[Visual Basic]
    Dim _mandantNr As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Klassifizierung


_mutiererMitarbeiterNr Variable

Dim _mutiererMitarbeiterNr As Integer

Source code

[Visual Basic]
    Dim _mutiererMitarbeiterNr As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Klassifizierung


_mutiertAm Variable

Dim _mutiertAm As DateTime

Source code

[Visual Basic]
    Dim _mutiertAm As DateTime

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Klassifizierung


Meldungstext Class

Diese klasse beinhaltet die Logik für die Meldungstext

For a list of all members of this type, see Meldungstext Members.

System.Object
EDOKALib.BusinessFacade.Meldungstext

Public Class Meldungstext

Requirements

Namespace: BusinessFacade

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKALib.BusinessFacade (in EDOKALib.BusinessFacade.dll)

See Also

Meldungstext Members


Meldungstext Members

Meldungstext overview

Constructors

constructor Meldungstext Constructor Erstellt eine neue Instanz für einen bestehenen Meldungstext

Properties

property Beschreibung
property ErstelltAm
property Inhalt
property IsAktiv
property MandantNr
property MeldungsTextNr
property MutiertAm
property MutiertMitarbeiterNr
property SpracheNr

Methods

method GetInhaltById | Gibt den Inhalt einer Melungs zurück
method LoadData |
method LoadDataFromCache |

Fields

field _beschreibungs
field _erstelltAm
field _inhalt
field _isAktiv
field _mandantNr
field _meldungsTextNr
field _meldungstexte
field _mutiertAm
field _mutiertMitarbeiterNr
field _spracheNr

See Also

Meldungstext Class


Meldungstext Constructor

Erstellt eine neue Instanz für einen bestehenen Meldungstext

Public Sub New( _
   ByVal meldungsTextNr As Integer _
)

Parameters

meldungsTextNr
Required.

Source code

[Visual Basic]
    Public Sub New(ByVal meldungsTextNr As Integer)
        Try

            Select Case LoadDataFromCache(meldungsTextNr)
                Case 0
                    'found in cache
                Case 1
                    'caching is disabled
                    LoadData(meldungsTextNr)				'from db
                Case 2
                    'not found in cache
                    LoadData(meldungsTextNr)				'from db
                    _meldungstexte.Add(meldungsTextNr, Me)				'hinzufügen da nicht vorhanden
            End Select
        Catch ex As Exception
            Throw ex
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Meldungstext


Meldungstext Properties

Meldungstext overview

Properties

property Beschreibung
property ErstelltAm
property Inhalt
property IsAktiv
property MandantNr
property MeldungsTextNr
property MutiertAm
property MutiertMitarbeiterNr
property SpracheNr

See Also

Meldungstext Class


Meldungstext.Beschreibung Property

Public ReadOnly Property Beschreibung() As String

Source code

[Visual Basic]
    Public ReadOnly Property Beschreibung() As String
        Get
            Return _beschreibungs
        End Get
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Meldungstext


Meldungstext.ErstelltAm Property

Public ReadOnly Property ErstelltAm() As DateTime

Source code

[Visual Basic]
    Public ReadOnly Property ErstelltAm() As DateTime
        Get
            Return _erstelltAm
        End Get
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Meldungstext


Meldungstext.Inhalt Property

Public ReadOnly Property Inhalt() As String

Source code

[Visual Basic]
    Public ReadOnly Property Inhalt() As String
        Get
            Return _inhalt
        End Get
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Meldungstext


Meldungstext.IsAktiv Property

Public ReadOnly Property IsAktiv() As Boolean

Source code

[Visual Basic]
    Public ReadOnly Property IsAktiv() As Boolean
        Get
            Return _isAktiv
        End Get
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Meldungstext


Meldungstext.MandantNr Property

Public ReadOnly Property MandantNr() As Integer

Source code

[Visual Basic]
    Public ReadOnly Property MandantNr() As Integer
        Get
            Return _mandantNr
        End Get
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Meldungstext


Meldungstext.MeldungsTextNr Property

Public ReadOnly Property MeldungsTextNr() As Integer

Source code

[Visual Basic]
    Public ReadOnly Property MeldungsTextNr() As Integer
        Get
            Return _meldungsTextNr
        End Get
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Meldungstext


Meldungstext.MutiertAm Property

Public ReadOnly Property MutiertAm() As DateTime

Source code

[Visual Basic]
    Public ReadOnly Property MutiertAm() As DateTime
        Get
            Return _mutiertAm
        End Get
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Meldungstext


Meldungstext.MutiertMitarbeiterNr Property

Public ReadOnly Property MutiertMitarbeiterNr() As Integer

Source code

[Visual Basic]
    Public ReadOnly Property MutiertMitarbeiterNr() As Integer
        Get
            Return _mutiertMitarbeiterNr
        End Get
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Meldungstext


Meldungstext.SpracheNr Property

Public ReadOnly Property SpracheNr() As String

Source code

[Visual Basic]
    Public ReadOnly Property SpracheNr() As String
        Get
            Return _spracheNr
        End Get
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Meldungstext


Meldungstext Methods

Meldungstext overview

Methods

method GetInhaltById | Gibt den Inhalt einer Melungs zurück
method LoadData |
method LoadDataFromCache |

See Also

Meldungstext Class


Meldungstext.GetInhaltById Method

Gibt den Inhalt einer Melungs zurück

Public Overloads Shared Function GetInhaltById( _
   ByVal meldungsTextNr _
) As String

Parameters

meldungsTextNr
Required.

Source code

[Visual Basic]
    Public Overloads Shared Function GetInhaltById(ByVal meldungsTextNr) As String
        Try
            Dim meldung As New Meldungstext(meldungsTextNr)

            If meldung.MeldungsTextNr = 0 Then
                Return "Der MeldungsText mit der Id " + meldungsTextNr.ToString() + " wurde nicht gefunden."
            Else
                Return meldung.Inhalt
            End If
        Catch ex As Exception
            Throw ex
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Meldungstext


Meldungstext.LoadData Method

Private Sub LoadData( _
   ByVal meldungsTextNr As Integer _
)

Parameters

meldungsTextNr
Required.

Source code

[Visual Basic]
    Private Sub LoadData(ByVal meldungsTextNr As Integer)
        Try
            Dim ds As New DataSet()
            DataAccess.Meldungstext.GetById(meldungsTextNr, ds)
            If Common.Tools.ValidateDS(ds) Then
                _meldungsTextNr = Convert.ToInt32(ds.Tables(0).Rows(0)("meldungstextnr"))
                _spracheNr = Convert.ToInt32(ds.Tables(0).Rows(0)("Sprache"))
                _inhalt = ds.Tables(0).Rows(0)("inhalt")
                _beschreibungs = ds.Tables(0).Rows(0)("beschreibung")
                _isAktiv = Convert.ToBoolean(ds.Tables(0).Rows(0)("aktiv"))
                _erstelltAm = Convert.ToDateTime(ds.Tables(0).Rows(0)("erstellt_am"))
                _mutiertAm = Convert.ToDateTime(ds.Tables(0).Rows(0)("mutiert_am"))
                _mutiertMitarbeiterNr = Convert.ToInt32(ds.Tables(0).Rows(0)("mutierer"))
                _mandantNr = Convert.ToInt32(ds.Tables(0).Rows(0)("mandantnr"))
            End If

            If _meldungsTextNr = 0 Then		  'meldung nicht gefunden in db
                TKBLib.Errorhandling.TraceHelper.Msg("EDOKALib.BF.Meldungstext.New", "Achtung Meldungstext wurde nicht gefunden! MeldungstextNr: " & CStr(meldungsTextNr), TraceLevel.Warning)
            End If
        Catch ex As Exception
            TKBLib.Errorhandling.TraceHelper.Msg("EDOKALib.Meldungstext.LoadData", ex.Message + " " + ex.StackTrace, TraceLevel.Error)
            Throw ex
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Meldungstext


Meldungstext.LoadDataFromCache Method

Private Function LoadDataFromCache( _
   ByVal meldungsTextNr As Integer _
) As Integer

Parameters

meldungsTextNr
Required.

Source code

[Visual Basic]
    Private Function LoadDataFromCache(ByVal meldungsTextNr As Integer) As Integer
        Try
            Dim source As Meldungstext

            If Config.GetParameterValue("CacheMeldungstexte") = 1 Then		  'cache is enabled
                source = _meldungstexte.Item(meldungsTextNr)
                If Not source Is Nothing Then
                    _meldungsTextNr = source.MeldungsTextNr
                    _spracheNr = source.SpracheNr
                    _inhalt = source.Inhalt
                    _beschreibungs = source.Beschreibung
                    _isAktiv = source.IsAktiv
                    _erstelltAm = source.ErstelltAm
                    _mutiertAm = source.MutiertAm
                    _mutiertMitarbeiterNr = source.MutiertMitarbeiterNr
                    _mandantNr = source.MandantNr
                    Return 0
                Else
                    Return 2				'not found
                End If
            End If
            Return 1		  'caching is disabled
        Catch ex As Exception
            TKBLib.Errorhandling.TraceHelper.Msg("EDOKALib.Meldungstext.LoadDataFromCache", ex.Message + " " + ex.StackTrace, TraceLevel.Error)
            Throw ex
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Meldungstext


Meldungstext Fields

Meldungstext overview

Fields

field _beschreibungs
field _erstelltAm
field _inhalt
field _isAktiv
field _mandantNr
field _meldungsTextNr
field _meldungstexte
field _mutiertAm
field _mutiertMitarbeiterNr
field _spracheNr

See Also

Meldungstext Class


_beschreibungs Variable

Private _beschreibungs As String

Source code

[Visual Basic]
    Private _beschreibungs As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Meldungstext


_erstelltAm Variable

Private _erstelltAm As DateTime

Source code

[Visual Basic]
    Private _erstelltAm As DateTime

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Meldungstext


_inhalt Variable

Private _inhalt As String

Source code

[Visual Basic]
    Private _inhalt As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Meldungstext


_isAktiv Variable

Private _isAktiv As Boolean

Source code

[Visual Basic]
    Private _isAktiv As Boolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Meldungstext


_mandantNr Variable

Private _mandantNr As Integer

Source code

[Visual Basic]
    Private _mandantNr As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Meldungstext


_meldungsTextNr Variable

Private _meldungsTextNr As Integer

Source code

[Visual Basic]
    Private _meldungsTextNr As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Meldungstext


_meldungstexte Variable

Private Shared _meldungstexte As New Hashtable()

Source code

[Visual Basic]
    Private Shared _meldungstexte As New Hashtable()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Meldungstext


_mutiertAm Variable

Private _mutiertAm As DateTime

Source code

[Visual Basic]
    Private _mutiertAm As DateTime

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Meldungstext


_mutiertMitarbeiterNr Variable

Private _mutiertMitarbeiterNr As Integer

Source code

[Visual Basic]
    Private _mutiertMitarbeiterNr As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Meldungstext


_spracheNr Variable

Private _spracheNr As Integer

Source code

[Visual Basic]
    Private _spracheNr As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Meldungstext


Mitarbeiter Class

Diese klasse beinhaltet die Logik für die Mitarbeiter

For a list of all members of this type, see Mitarbeiter Members.

System.Object
EDOKALib.BusinessFacade.Mitarbeiter

Public Class Mitarbeiter

Requirements

Namespace: BusinessFacade

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKALib.BusinessFacade (in EDOKALib.BusinessFacade.dll)

See Also

Mitarbeiter Members


Mitarbeiter Members

Mitarbeiter overview

Constructors

constructor Mitarbeiter Constructor (Overloaded) Erstellt eine neue Instanz für einen neuen Mitarbeiter

Properties

property Anrede
property AnzeigeName
property EMail
property ErstelltAm
property Fax
property FuerMandantNr
property Funktion
property IsAktiv
property IsEdokaMail
property IsEdokaMessage
property IsGebMeldung
property IsMailDirektVersenden
property IsMailDokumentRueckgang
property IsMailEmpfang
property Journalisierung
property KlassifizierungNr
property KurzZeichen
property Mail1
property MandantNr
property MitarbeiterNr
property MutiererMitarbeiterNr
property MutiertAm
property Nachname
property PartnerNr
property Rang
property ShowTipp
property SpracheNr
property TGNummer
property Telefon
property UnterschritText
property Vorname

Methods

method CreateNewStandardProfil | Erstellt ein neues Standard Profil für den angegebenen Mitarbeiter
method GetListe | Gibt eine Liste mit allen Mitarbeitern zurück
method GetListeByFunktionsGruppeNr | Gibt eine Liste mit allen Mitarbeitern zurück
method GetListeByTeamNr | Gibt eine Liste mit allen Mitarbeitern zurück
method GetRowCountAfterSave | Gibt die Anzahl der Rows zurück, welche sie nach dem Speichern haben werden
method LoadData | lädt die daten in die klassen member
method Save (Overloaded) | Speichert die Änderungen an einem Mitarbeiter

Fields

field _anrede
field _email
field _erstelltAm
field _fax
field _fuerMandantNr
field _funktion
field _funktionsgruppen
field _isAktiv
field _isEdokaMail
field _isEdokaMessage
field _isGebMeldung
field _isJournalisierung
field _isMailDirektVersenden
field _isMailDokumentRueckgang
field _isMailEmpfang
field _klassifizierungNr
field _kurzZeichen
field _mail1
field _mandantNr
field _mitarbeiterNr
field _mutiererMitarbeiterNr
field _mutiertAm
field _nachname
field _partnerNr
field _rang
field _showTipp
field _spracheNr
field _telefon
field _tgNummer
field _unterschriftText
field _vorname

See Also

Mitarbeiter Class


New

Overload List

Erstellt eine neue Instanz für einen neuen Mitarbeiter

[Visual Basic] Public Sub New()

Erstellt eine neue Instanz für einen bestehenen Mitarbeiter

[Visual Basic] Public Sub New(ByVal mitarbeiterNr As Integer)

See Also

Mitarbeiter | BusinessFacade


Mitarbeiter Properties

Mitarbeiter overview

Properties

property Anrede
property AnzeigeName
property EMail
property ErstelltAm
property Fax
property FuerMandantNr
property Funktion
property IsAktiv
property IsEdokaMail
property IsEdokaMessage
property IsGebMeldung
property IsMailDirektVersenden
property IsMailDokumentRueckgang
property IsMailEmpfang
property Journalisierung
property KlassifizierungNr
property KurzZeichen
property Mail1
property MandantNr
property MitarbeiterNr
property MutiererMitarbeiterNr
property MutiertAm
property Nachname
property PartnerNr
property Rang
property ShowTipp
property SpracheNr
property TGNummer
property Telefon
property UnterschritText
property Vorname

See Also

Mitarbeiter Class


Mitarbeiter.Anrede Property

Public Property Anrede() As String

Source code

[Visual Basic]
    Public Property Anrede() As String
        Get
            Return _anrede
        End Get
        Set(ByVal Value As String)
            _anrede = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Mitarbeiter


Mitarbeiter.AnzeigeName Property

Public ReadOnly Property AnzeigeName() As String

Source code

[Visual Basic]
    Public ReadOnly Property AnzeigeName() As String
        Get
            Return _nachname + " " + _vorname
        End Get
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Mitarbeiter


Mitarbeiter.EMail Property

Public Property EMail() As String

Source code

[Visual Basic]
    Public Property EMail() As String
        Get
            Return _email
        End Get
        Set(ByVal Value As String)
            _email = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Mitarbeiter


Mitarbeiter.ErstelltAm Property

Public ReadOnly Property ErstelltAm() As DateTime

Source code

[Visual Basic]
    Public ReadOnly Property ErstelltAm() As DateTime
        Get
            Return _erstelltAm
        End Get
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Mitarbeiter


Mitarbeiter.Fax Property

Public Property Fax() As String

Source code

[Visual Basic]
    Public Property Fax() As String
        Get
            Return _fax
        End Get
        Set(ByVal Value As String)
            _fax = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Mitarbeiter


Mitarbeiter.FuerMandantNr Property

Public Property FuerMandantNr() As Integer

Source code

[Visual Basic]
    Public Property FuerMandantNr() As Integer
        Get
            Return _fuerMandantNr
        End Get
        Set(ByVal Value As Integer)
            _fuerMandantNr = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Mitarbeiter


Mitarbeiter.Funktion Property

Public Property Funktion() As String

Source code

[Visual Basic]
    Public Property Funktion() As String
        Get
            Return _funktion
        End Get
        Set(ByVal Value As String)
            _funktion = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Mitarbeiter


Mitarbeiter.IsAktiv Property

Public Property IsAktiv() As Boolean

Source code

[Visual Basic]
    Public Property IsAktiv() As Boolean
        Get
            Return _isAktiv
        End Get
        Set(ByVal Value As Boolean)
            _isAktiv = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Mitarbeiter


Mitarbeiter.IsEdokaMail Property

Public Property IsEdokaMail() As Boolean

Source code

[Visual Basic]
    Public Property IsEdokaMail() As Boolean
        Get
            Return _isEdokaMail
        End Get
        Set(ByVal Value As Boolean)
            _isEdokaMail = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Mitarbeiter


Mitarbeiter.IsEdokaMessage Property

Public Property IsEdokaMessage() As Boolean

Source code

[Visual Basic]
    Public Property IsEdokaMessage() As Boolean
        Get
            Return _isEdokaMessage
        End Get
        Set(ByVal Value As Boolean)
            _isEdokaMessage = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Mitarbeiter


Mitarbeiter.IsGebMeldung Property

Public Property IsGebMeldung() As Boolean

Source code

[Visual Basic]
    Public Property IsGebMeldung() As Boolean
        Get
            Return _isGebMeldung
        End Get
        Set(ByVal Value As Boolean)
            _isGebMeldung = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Mitarbeiter


Mitarbeiter.IsMailDirektVersenden Property

Public Property IsMailDirektVersenden() As Boolean

Source code

[Visual Basic]
    Public Property IsMailDirektVersenden() As Boolean
        Get
            Return _isMailDirektVersenden
        End Get
        Set(ByVal Value As Boolean)
            _isMailDirektVersenden = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Mitarbeiter


Mitarbeiter.IsMailDokumentRueckgang Property

Public Property IsMailDokumentRueckgang() As Boolean

Source code

[Visual Basic]
    Public Property IsMailDokumentRueckgang() As Boolean
        Get
            Return _isMailDokumentRueckgang
        End Get
        Set(ByVal Value As Boolean)
            _isMailDokumentRueckgang = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Mitarbeiter


Mitarbeiter.IsMailEmpfang Property

Public Property IsMailEmpfang() As Boolean

Source code

[Visual Basic]
    Public Property IsMailEmpfang() As Boolean
        Get
            Return _isMailEmpfang
        End Get
        Set(ByVal Value As Boolean)
            _isMailEmpfang = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Mitarbeiter


Mitarbeiter.Journalisierung Property

Public Property Journalisierung() As Boolean

Source code

[Visual Basic]
    Public Property Journalisierung() As Boolean
        Get
            Return _isJournalisierung
        End Get
        Set(ByVal Value As Boolean)
            _isJournalisierung = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Mitarbeiter


Mitarbeiter.KlassifizierungNr Property

Public Property KlassifizierungNr() As Integer

Source code

[Visual Basic]
    Public Property KlassifizierungNr() As Integer
        Get
            Return _klassifizierungNr
        End Get
        Set(ByVal Value As Integer)
            _klassifizierungNr = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Mitarbeiter


Mitarbeiter.KurzZeichen Property

Public Property KurzZeichen() As String

Source code

[Visual Basic]
    Public Property KurzZeichen() As String
        Get
            Return _kurzZeichen
        End Get
        Set(ByVal Value As String)
            _kurzZeichen = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Mitarbeiter


Mitarbeiter.Mail1 Property

Public Property Mail1() As String

Source code

[Visual Basic]
    Public Property Mail1() As String
        Get
            Return _mail1
        End Get
        Set(ByVal Value As String)
            _mail1 = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Mitarbeiter


Mitarbeiter.MandantNr Property

Public Property MandantNr() As Integer

Source code

[Visual Basic]
    Public Property MandantNr() As Integer
        Get
            Return _mandantNr
        End Get
        Set(ByVal Value As Integer)
            _mandantNr = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Mitarbeiter


Mitarbeiter.MitarbeiterNr Property

Public ReadOnly Property MitarbeiterNr() As Integer

Source code

[Visual Basic]
    Public ReadOnly Property MitarbeiterNr() As Integer
        Get
            Return _mitarbeiterNr
        End Get
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Mitarbeiter


Mitarbeiter.MutiererMitarbeiterNr Property

Public ReadOnly Property MutiererMitarbeiterNr() As Integer

Source code

[Visual Basic]
    Public ReadOnly Property MutiererMitarbeiterNr() As Integer
        Get
            Return _mutiererMitarbeiterNr
        End Get
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Mitarbeiter


Mitarbeiter.MutiertAm Property

Public ReadOnly Property MutiertAm() As DateTime

Source code

[Visual Basic]
    Public ReadOnly Property MutiertAm() As DateTime
        Get
            Return _mutiertAm
        End Get
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Mitarbeiter


Mitarbeiter.Nachname Property

Public Property Nachname() As String

Source code

[Visual Basic]
    Public Property Nachname() As String
        Get
            Return _nachname
        End Get
        Set(ByVal Value As String)
            _nachname = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Mitarbeiter


Mitarbeiter.PartnerNr Property

Public Property PartnerNr() As Integer

Source code

[Visual Basic]
    Public Property PartnerNr() As Integer
        Get
            Return _partnerNr
        End Get
        Set(ByVal Value As Integer)
            _partnerNr = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Mitarbeiter


Mitarbeiter.Rang Property

Public Property Rang() As String

Source code

[Visual Basic]
    Public Property Rang() As String
        Get
            Return _rang
        End Get
        Set(ByVal Value As String)
            _rang = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Mitarbeiter


Mitarbeiter.ShowTipp Property

Public Property ShowTipp() As Boolean

Source code

[Visual Basic]
    Public Property ShowTipp() As Boolean
        Get
            Return _showTipp
        End Get
        Set(ByVal Value As Boolean)
            _showTipp = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Mitarbeiter


Mitarbeiter.SpracheNr Property

Public Property SpracheNr() As Integer

Source code

[Visual Basic]
    Public Property SpracheNr() As Integer
        Get
            Return _spracheNr
        End Get
        Set(ByVal Value As Integer)
            _spracheNr = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Mitarbeiter


Mitarbeiter.TGNummer Property

Public Property TGNummer() As String

Source code

[Visual Basic]
    Public Property TGNummer() As String
        Get
            Return _tgNummer
        End Get
        Set(ByVal Value As String)
            _tgNummer = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Mitarbeiter


Mitarbeiter.Telefon Property

Public Property Telefon() As String

Source code

[Visual Basic]
    Public Property Telefon() As String
        Get
            Return _telefon
        End Get
        Set(ByVal Value As String)
            _telefon = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Mitarbeiter


Mitarbeiter.UnterschritText Property

Public Property UnterschritText() As String

Source code

[Visual Basic]
    Public Property UnterschritText() As String
        Get
            Return _unterschriftText
        End Get
        Set(ByVal Value As String)
            _unterschriftText = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Mitarbeiter


Mitarbeiter.Vorname Property

Public Property Vorname() As String

Source code

[Visual Basic]
    Public Property Vorname() As String
        Get
            Return _vorname
        End Get
        Set(ByVal Value As String)
            _vorname = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Mitarbeiter


Mitarbeiter Methods

Mitarbeiter overview

Methods

method CreateNewStandardProfil | Erstellt ein neues Standard Profil für den angegebenen Mitarbeiter
method GetListe | Gibt eine Liste mit allen Mitarbeitern zurück
method GetListeByFunktionsGruppeNr | Gibt eine Liste mit allen Mitarbeitern zurück
method GetListeByTeamNr | Gibt eine Liste mit allen Mitarbeitern zurück
method GetRowCountAfterSave | Gibt die Anzahl der Rows zurück, welche sie nach dem Speichern haben werden
method LoadData | lädt die daten in die klassen member
method Save (Overloaded) | Speichert die Änderungen an einem Mitarbeiter

See Also

Mitarbeiter Class


Mitarbeiter.CreateNewStandardProfil Method

Erstellt ein neues Standard Profil für den angegebenen Mitarbeiter

Public Function CreateNewStandardProfil( _
   ByVal mutiererMitarbeiterNr As Integer _
)

Parameters

mutiererMitarbeiterNr
Required. Die datenbank Nummer des Mutierers (ID)

Source code

[Visual Basic]
    Public Function CreateNewStandardProfil(ByVal mutiererMitarbeiterNr As Integer)
        Try
            DataAccess.Mitarbeiter.CreateNewStandardProfil(_mitarbeiterNr, mutiererMitarbeiterNr)
        Catch ex As Exception
            Throw ex
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Mitarbeiter


Mitarbeiter.GetListe Method

Gibt eine Liste mit allen Mitarbeitern zurück

Public Overloads Shared Sub GetListe( _
   ByRef dsMitarbeiter As DataSet _
)

Parameters

dsMitarbeiter
Required. Das DataSet welches gefüllt werden soll

Source code

[Visual Basic]
    Public Overloads Shared Sub GetListe(ByRef dsMitarbeiter As DataSet)
        Try
            DataAccess.Mitarbeiter.GetListe(0, 0, dsMitarbeiter)
        Catch ex As Exception
            Throw ex
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Mitarbeiter


Mitarbeiter.GetListeByFunktionsGruppeNr Method

Gibt eine Liste mit allen Mitarbeitern zurück

Public Overloads Shared Sub GetListeByFunktionsGruppeNr( _
   ByVal funktionsGruppeNr As Integer, _
   ByRef dsMitarbeiter As DataSet _
)

Parameters

funktionsGruppeNr
Required. Nur Mitarbeiter von dieser Funktionsgruppe
dsMitarbeiter
Required. Das DataSet welches gefüllt werden soll

Source code

[Visual Basic]
    Public Overloads Shared Sub GetListeByFunktionsGruppeNr(ByVal funktionsGruppeNr As Integer, ByRef dsMitarbeiter As DataSet)
        Try
            DataAccess.Mitarbeiter.GetListe(0, funktionsGruppeNr, dsMitarbeiter)
        Catch ex As Exception
            Throw ex
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Mitarbeiter


Mitarbeiter.GetListeByTeamNr Method

Gibt eine Liste mit allen Mitarbeitern zurück

Public Overloads Shared Sub GetListeByTeamNr( _
   ByVal teamNr As Integer, _
   ByRef dsMitarbeiter As DataSet _
)

Parameters

teamNr
Required. Nur Mitarbeiter von diesem Team
dsMitarbeiter
Required. Das DataSet welches gefüllt werden soll

Source code

[Visual Basic]
    Public Overloads Shared Sub GetListeByTeamNr(ByVal teamNr As Integer, ByRef dsMitarbeiter As DataSet)
        Try
            DataAccess.Mitarbeiter.GetListe(teamNr, 0, dsMitarbeiter)
        Catch ex As Exception
            Throw ex
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Mitarbeiter


Mitarbeiter.GetRowCountAfterSave Method

Gibt die Anzahl der Rows zurück, welche sie nach dem Speichern haben werden

Private Function GetRowCountAfterSave( _
   ByVal ds2Validate As DataSet _
) As Integer

Parameters

ds2Validate
Required. Das zu überprüfende DataSet

Returns

Der neue rowCount

Source code

[Visual Basic]
    Private Function GetRowCountAfterSave(ByVal ds2Validate As DataSet) As Integer
        Try
            'validierung nicht möglich, es werden keines row mehr da sein nach dem speichern
            If IsNothing(ds2Validate) Then
                Return 0
            End If

            Dim row As DataRow
            Dim newRowCount As Integer = 0

            'neue rows zählen
            For Each row In ds2Validate.Tables(0).Rows
                If Convert.ToBoolean(row("aktiv")) And _
                 (row.RowState = DataRowState.Added Or _
                 row.RowState = DataRowState.Modified Or _
                 row.RowState = DataRowState.Unchanged) Then

                    newRowCount = newRowCount + 1
                End If
            Next

            Return newRowCount
        Catch ex As Exception
            Throw ex
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Mitarbeiter


Mitarbeiter.LoadData Method

lädt die daten in die klassen member

Private Sub LoadData( _
   ByVal ds As DataSet _
)

Parameters

ds
Required.

Source code

[Visual Basic]
    Private Sub LoadData(ByVal ds As DataSet)
        Try
            If Not Common.Tools.ValidateDS(ds) Then
                Return
            End If

            _mitarbeiterNr = Tools.CToInt32(ds.Tables(0).Rows(0)("mitarbeiterNr"))
            _vorname = Tools.CToString(ds.Tables(0).Rows(0)("vorname"))
            _nachname = Tools.CToString(ds.Tables(0).Rows(0)("name"))
            _kurzZeichen = Tools.CToString(ds.Tables(0).Rows(0)("kurzzeichen"))
            _anrede = Tools.CToString(ds.Tables(0).Rows(0)("anrede"))
            _tgNummer = Tools.CToString(ds.Tables(0).Rows(0)("tgnummer"))
            _email = Tools.CToString(ds.Tables(0).Rows(0)("email"))
            _fax = Tools.CToString(ds.Tables(0).Rows(0)("fax"))
            _telefon = Tools.CToString(ds.Tables(0).Rows(0)("telefon"))
            _unterschriftText = Tools.CToString(ds.Tables(0).Rows(0)("unterschrift_text"))
            _spracheNr = Tools.CToInt32(ds.Tables(0).Rows(0)("sprache"))
            _fuerMandantNr = Tools.CToInt32(ds.Tables(0).Rows(0)("fuermandant"))
            _showTipp = Common.Tools.CToBool(ds.Tables(0).Rows(0)("showtip"))
            _partnerNr = Tools.CToInt32(ds.Tables(0).Rows(0)("partnernr"))
            _mandantNr = Tools.CToInt32(ds.Tables(0).Rows(0)("mandantnr"))
            _isAktiv = Common.Tools.CToBool(ds.Tables(0).Rows(0)("aktiv"))
            _erstelltAm = Tools.CToDateTime(ds.Tables(0).Rows(0)("erstellt_am"))
            _mutiertAm = Tools.CToDateTime(ds.Tables(0).Rows(0)("mutiert_am"))
            _mutiererMitarbeiterNr = Tools.CToInt32(ds.Tables(0).Rows(0)("mutierer"))
            _isMailEmpfang = Common.Tools.CToBool(ds.Tables(0).Rows(0)("mailempfang"))
            _isEdokaMessage = Common.Tools.CToBool(ds.Tables(0).Rows(0)("EdokaMesasge"))
            _funktion = Tools.CToString(ds.Tables(0).Rows(0)("funktion"))
            _isMailDirektVersenden = Common.Tools.CToBool(ds.Tables(0).Rows(0)("MailDirektVersenden"))
            _rang = Tools.CToString(ds.Tables(0).Rows(0)("Rang"))
            _isMailDokumentRueckgang = Common.Tools.CToBool(ds.Tables(0).Rows(0)("MailDokumentrueckgang"))
            _klassifizierungNr = Tools.CToInt32(ds.Tables(0).Rows(0)("klassifizierung"))
            _isEdokaMail = Common.Tools.CToBool(ds.Tables(0).Rows(0)("edoka_mail"))
            _isJournalisierung = Common.Tools.CToBool(ds.Tables(0).Rows(0)("journalisierung"))
            _isGebMeldung = Common.Tools.CToBool(ds.Tables(0).Rows(0)("GebMeldung"))
            _mail1 = Tools.CToString(ds.Tables(0).Rows(0)("Mail_1"))
        Catch ex As Exception
            TKBLib.Errorhandling.TraceHelper.Msg("EDOKALib.BF.Parameter.LoadData", ex.Message + " " + ex.StackTrace, TraceLevel.Error)
            Throw ex
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Mitarbeiter


Save Method

Overload List

Speichert die Änderungen an einem Mitarbeiter inklusive Funktionsgruppen- und Team-Zuordnungen

[Visual Basic] Public Function Save(ByVal dsMaTeams As DataSet, ByVal dsMaFunktionsGruppen As DataSet, ByVal mutiererMitarbeiterNr As Integer)

Speichert die Änderungen an einem Mitarbeiter

[Visual Basic] Public Function Save(ByVal mutiererMitarbeiterNr As Integer)

See Also

Mitarbeiter | BusinessFacade


Mitarbeiter Fields

Mitarbeiter overview

Fields

field _anrede
field _email
field _erstelltAm
field _fax
field _fuerMandantNr
field _funktion
field _funktionsgruppen
field _isAktiv
field _isEdokaMail
field _isEdokaMessage
field _isGebMeldung
field _isJournalisierung
field _isMailDirektVersenden
field _isMailDokumentRueckgang
field _isMailEmpfang
field _klassifizierungNr
field _kurzZeichen
field _mail1
field _mandantNr
field _mitarbeiterNr
field _mutiererMitarbeiterNr
field _mutiertAm
field _nachname
field _partnerNr
field _rang
field _showTipp
field _spracheNr
field _telefon
field _tgNummer
field _unterschriftText
field _vorname

See Also

Mitarbeiter Class


_anrede Variable

Private _anrede As String

Source code

[Visual Basic]
    Private _anrede As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Mitarbeiter


_email Variable

Private _email As String

Source code

[Visual Basic]
    Private _email As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Mitarbeiter


_erstelltAm Variable

Private _erstelltAm As DateTime

Source code

[Visual Basic]
    Private _erstelltAm As DateTime

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Mitarbeiter


_fax Variable

Private _fax As String

Source code

[Visual Basic]
    Private _fax As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Mitarbeiter


_fuerMandantNr Variable

Private _fuerMandantNr As Integer

Source code

[Visual Basic]
    Private _fuerMandantNr As Integer	 'arbeitet für diesen mandant

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Mitarbeiter


_funktion Variable

Private _funktion As String

Source code

[Visual Basic]
    Private _funktion As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Mitarbeiter


_funktionsgruppen Variable

Private _funktionsgruppen As BusinessFacade.Funktionsgruppe()

Source code

[Visual Basic]
    Private _funktionsgruppen As BusinessFacade.Funktionsgruppe()

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Mitarbeiter


_isAktiv Variable

Private _isAktiv As Boolean

Source code

[Visual Basic]
    Private _isAktiv As Boolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Mitarbeiter


_isEdokaMail Variable

Private _isEdokaMail As Boolean

Source code

[Visual Basic]
    Private _isEdokaMail As Boolean	 'meldung via edoka empfangen

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Mitarbeiter


_isEdokaMessage Variable

Private _isEdokaMessage As Boolean

Source code

[Visual Basic]
    Private _isEdokaMessage As Boolean	 'DANGER: feld in db heisst "EdokaMesasge"

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Mitarbeiter


_isGebMeldung Variable

Private _isGebMeldung As Boolean

Source code

[Visual Basic]
    Private _isGebMeldung As Boolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Mitarbeiter


_isJournalisierung Variable

Private _isJournalisierung As Boolean

Source code

[Visual Basic]
    Private _isJournalisierung As Boolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Mitarbeiter


_isMailDirektVersenden Variable

Private _isMailDirektVersenden As Boolean

Source code

[Visual Basic]
    Private _isMailDirektVersenden As Boolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Mitarbeiter


_isMailDokumentRueckgang Variable

Private _isMailDokumentRueckgang As Boolean

Source code

[Visual Basic]
    Private _isMailDokumentRueckgang As Boolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Mitarbeiter


_isMailEmpfang Variable

Private _isMailEmpfang As Boolean

Source code

[Visual Basic]
    Private _isMailEmpfang As Boolean	 'meldung via email

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Mitarbeiter


_klassifizierungNr Variable

Private _klassifizierungNr As Integer

Source code

[Visual Basic]
    Private _klassifizierungNr As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Mitarbeiter


_kurzZeichen Variable

Private _kurzZeichen As String

Source code

[Visual Basic]
    Private _kurzZeichen As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Mitarbeiter


_mail1 Variable

Private _mail1 As String

Source code

[Visual Basic]
    Private _mail1 As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Mitarbeiter


_mandantNr Variable

Private _mandantNr As Integer

Source code

[Visual Basic]
    Private _mandantNr As Integer	 'zugehörigkeit des mitarbeiter

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Mitarbeiter


_mitarbeiterNr Variable

Private _mitarbeiterNr As Integer = 0

Source code

[Visual Basic]
    Private _mitarbeiterNr As Integer = 0

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Mitarbeiter


_mutiererMitarbeiterNr Variable

Private _mutiererMitarbeiterNr As Integer

Source code

[Visual Basic]
    Private _mutiererMitarbeiterNr As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Mitarbeiter


_mutiertAm Variable

Private _mutiertAm As DateTime

Source code

[Visual Basic]
    Private _mutiertAm As DateTime

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Mitarbeiter


_nachname Variable

Private _nachname As String

Source code

[Visual Basic]
    Private _nachname As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Mitarbeiter


_partnerNr Variable

Private _partnerNr As Integer

Source code

[Visual Basic]
    Private _partnerNr As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Mitarbeiter


_rang Variable

Private _rang As String

Source code

[Visual Basic]
    Private _rang As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Mitarbeiter


_showTipp Variable

Private _showTipp As Boolean

Source code

[Visual Basic]
    Private _showTipp As Boolean	 'display tipp bim startup

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Mitarbeiter


_spracheNr Variable

Private _spracheNr As Integer

Source code

[Visual Basic]
    Private _spracheNr As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Mitarbeiter


_telefon Variable

Private _telefon As String

Source code

[Visual Basic]
    Private _telefon As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Mitarbeiter


_tgNummer Variable

Private _tgNummer As String

Source code

[Visual Basic]
    Private _tgNummer As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Mitarbeiter


_unterschriftText Variable

Private _unterschriftText As String

Source code

[Visual Basic]
    Private _unterschriftText As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Mitarbeiter


_vorname Variable

Private _vorname As String

Source code

[Visual Basic]
    Private _vorname As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Mitarbeiter


MitarbeiterException Class

Diese Klasse behandelt eine Mitarbeiter spezifische Ausnahme

For a list of all members of this type, see MitarbeiterException Members.

System.Object
System.Exception
EDOKALib.BusinessFacade.MitarbeiterException

Public Class MitarbeiterException
   Inherits Exception

Requirements

Namespace: BusinessFacade

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKALib.BusinessFacade (in EDOKALib.BusinessFacade.dll)

See Also

MitarbeiterException Members


MitarbeiterException Members

MitarbeiterException overview

Constructors

constructor MitarbeiterException Constructor

Properties

property Message

Fields

field _message

See Also

MitarbeiterException Class


MitarbeiterException Constructor

Public Sub New( _
   ByVal message As String _
)

Parameters

message
Required.

Source code

[Visual Basic]
    Public Sub New(ByVal message As String)
        _message = message
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

MitarbeiterException


MitarbeiterException Properties

MitarbeiterException overview

Properties

property Message

See Also

MitarbeiterException Class


MitarbeiterException.Message Property

Public Overrides ReadOnly Property Message() As String

Source code

[Visual Basic]
    Public Overrides ReadOnly Property Message() As String
        Get
            Return _message
        End Get
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

MitarbeiterException


MitarbeiterException Fields

MitarbeiterException overview

Fields

field _message

See Also

MitarbeiterException Class


_message Variable

Dim _message As String

Source code

[Visual Basic]
    Dim _message As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

MitarbeiterException


MitarbeiterFunktionsgruppe Class

Diese klasse beinhaltet die Logik für die Mitarbeiter-Funktionsgruppen Zuweisung

For a list of all members of this type, see MitarbeiterFunktionsgruppe Members.

System.Object
EDOKALib.BusinessFacade.MitarbeiterFunktionsgruppe

Public Class MitarbeiterFunktionsgruppe

Requirements

Namespace: BusinessFacade

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKALib.BusinessFacade (in EDOKALib.BusinessFacade.dll)

See Also

MitarbeiterFunktionsgruppe Members


MitarbeiterFunktionsgruppe Members

MitarbeiterFunktionsgruppe overview

Methods

method Delete | Löscht eine Team-Mitarbeiter Zuordnung aus der Datenbank
method GetListeByMitarbeiterNr | Gibt eine Liste mit allen Funktionsgrupppen denen ein Mitarbeiter zugewiesen ist zurück
method Insert | Speichert die Daten der aktuellen Instanz in die Datenbank
method SetAktiv | Gibt eine Liste mit allen Funktionsgrupppen denen ein Mitarbeiter zugewiesen ist zurück

See Also

MitarbeiterFunktionsgruppe Class


MitarbeiterFunktionsgruppe Methods

MitarbeiterFunktionsgruppe overview

Methods

method Delete | Löscht eine Team-Mitarbeiter Zuordnung aus der Datenbank
method GetListeByMitarbeiterNr | Gibt eine Liste mit allen Funktionsgrupppen denen ein Mitarbeiter zugewiesen ist zurück
method Insert | Speichert die Daten der aktuellen Instanz in die Datenbank
method SetAktiv | Gibt eine Liste mit allen Funktionsgrupppen denen ein Mitarbeiter zugewiesen ist zurück

See Also

MitarbeiterFunktionsgruppe Class


MitarbeiterFunktionsgruppe.Delete Method

Löscht eine Team-Mitarbeiter Zuordnung aus der Datenbank

Public Overloads Shared Function Delete( _
   ByVal mitarbeiterFunktionsGruppeNr As Integer, _
   ByVal mutiererMitarbeiterNr As Integer _
)

Parameters

mitarbeiterFunktionsGruppeNr
Required. Zu löschende Verbindung
mutiererMitarbeiterNr
Required. Die Id des Benutzers, welcher die Änderungen vornimmt

Source code

[Visual Basic]
    Public Overloads Shared Function Delete(ByVal mitarbeiterFunktionsGruppeNr As Integer, ByVal mutiererMitarbeiterNr As Integer)
        Try
            DataAccess.MitarbeiterFunktionsgruppe.Delete(mitarbeiterFunktionsGruppeNr, mutiererMitarbeiterNr)
        Catch ex As Exception
            Throw ex
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

MitarbeiterFunktionsgruppe


MitarbeiterFunktionsgruppe.GetListeByMitarbeiterNr Method

Gibt eine Liste mit allen Funktionsgrupppen denen ein Mitarbeiter zugewiesen ist zurück

Public Overloads Shared Sub GetListeByMitarbeiterNr( _
   ByVal mitarbeiterNr As Integer, _
   ByRef ds As DataSet _
)

Parameters

mitarbeiterNr
Required.
ds
Required. Das DataSet welches gefüllt werden soll

Source code

[Visual Basic]
    Public Overloads Shared Sub GetListeByMitarbeiterNr(ByVal mitarbeiterNr As Integer, ByRef ds As DataSet)
        Try
            DataAccess.MitarbeiterFunktionsgruppe.GetListeByMitarbeiterNr(mitarbeiterNr, ds)
        Catch ex As Exception
            Throw ex
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

MitarbeiterFunktionsgruppe


MitarbeiterFunktionsgruppe.Insert Method

Speichert die Daten der aktuellen Instanz in die Datenbank

Public Overloads Shared Function Insert( _
   ByVal mitarbeiterNr As Integer, _
   ByVal funktionsGruppeNr As Integer, _
   ByVal mutiererMitarbeiterNr As Integer _
)

Parameters

mitarbeiterNr
Required.
funktionsGruppeNr
Required.
mutiererMitarbeiterNr
Required. Die Id des Benutzers, welcher die Änderungen vornimmt

Source code

[Visual Basic]
    Public Overloads Shared Function Insert(ByVal mitarbeiterNr As Integer, ByVal funktionsGruppeNr As Integer, ByVal mutiererMitarbeiterNr As Integer)
        Try
            'neuer eintrag
            DataAccess.MitarbeiterFunktionsgruppe.Insert(mitarbeiterNr, funktionsGruppeNr, mutiererMitarbeiterNr)
        Catch ex As Exception
            Throw ex
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

MitarbeiterFunktionsgruppe


MitarbeiterFunktionsgruppe.SetAktiv Method

Gibt eine Liste mit allen Funktionsgrupppen denen ein Mitarbeiter zugewiesen ist zurück

Public Overloads Shared Sub SetAktiv( _
   ByVal mitarbeiterFunktionsGruppeNr As Integer, _
   ByVal isAktiv As Boolean, _
   ByVal mutiererMitarbeiterNr As Integer _
)

Parameters

mitarbeiterFunktionsGruppeNr
Required.
isAktiv
Required.
mutiererMitarbeiterNr
Required.

Source code

[Visual Basic]
    Public Overloads Shared Sub SetAktiv(ByVal mitarbeiterFunktionsGruppeNr As Integer, ByVal isAktiv As Boolean, ByVal mutiererMitarbeiterNr As Integer)
        Try
            DataAccess.MitarbeiterFunktionsgruppe.SetAktiv(mitarbeiterFunktionsGruppeNr, isAktiv, mutiererMitarbeiterNr)
        Catch ex As Exception
            Throw ex
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

MitarbeiterFunktionsgruppe


NullHandler Class

diese klasse ersetzt null values durch den parameter 'NullReplaceValue' von der parameter tabelle

For a list of all members of this type, see NullHandler Members.

System.Object
EDOKALib.BusinessFacade.NullHandler

Public Class NullHandler

Requirements

Namespace: BusinessFacade

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKALib.BusinessFacade (in EDOKALib.BusinessFacade.dll)

See Also

NullHandler Members


NullHandler Members

NullHandler overview

Constructors

constructor NullHandler Constructor

Properties

property _nullReplacerInt
property _nullReplacerStr

Methods

method CToDateTime | spezialfall wird auf DateTime.MinValue gesetzt
method CToDecimal |
method CToDouble |
method CToInt16 |
method CToInt32 |
method CToInt64 |
method CToSingle |
method CToString |

See Also

NullHandler Class


NullHandler Constructor

Shared Sub New()

Source code

[Visual Basic]
    Shared Sub New()
        _nullReplacerInt = Integer.Parse(Config.GetParameterValue("NullReplaceValue"))
        _nullReplacerStr = Config.GetParameterValue("NullReplaceValue")
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

NullHandler


NullHandler Properties

NullHandler overview

Properties

property _nullReplacerInt
property _nullReplacerStr

See Also

NullHandler Class


_nullReplacerInt Property

Public Shared _nullReplacerInt As Integer

Source code

[Visual Basic]
    Public Shared _nullReplacerInt As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

NullHandler


_nullReplacerStr Property

Public Shared _nullReplacerStr As String

Source code

[Visual Basic]
    Public Shared _nullReplacerStr As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

NullHandler


NullHandler Methods

NullHandler overview

Methods

method CToDateTime | spezialfall wird auf DateTime.MinValue gesetzt
method CToDecimal |
method CToDouble |
method CToInt16 |
method CToInt32 |
method CToInt64 |
method CToSingle |
method CToString |

See Also

NullHandler Class


NullHandler.CToDateTime Method

spezialfall wird auf DateTime.MinValue gesetzt

Public Shared Function CToDateTime( _
   ByVal o As Object _
) As DateTime

Parameters

o
Required.

Source code

[Visual Basic]
    Public Shared Function CToDateTime(ByVal o As Object) As DateTime
        If o Is System.DBNull.Value Then
            Return DateTime.MinValue
        Else
            If TypeOf o Is DateTime Then
                Return CDate(o)
            End If
        End If
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

NullHandler


NullHandler.CToDecimal Method

Public Shared Function CToDecimal( _
   ByVal o As Object _
) As Decimal

Parameters

o
Required.

Source code

[Visual Basic]
    Public Shared Function CToDecimal(ByVal o As Object) As Decimal
        If o Is System.DBNull.Value Then
            Return CDec(_nullReplacerInt)
        Else
            If TypeOf o Is Decimal Then
                Return CDec(o)
            End If
        End If
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

NullHandler


NullHandler.CToDouble Method

Public Shared Function CToDouble( _
   ByVal o As Object _
) As Double

Parameters

o
Required.

Source code

[Visual Basic]
    Public Shared Function CToDouble(ByVal o As Object) As Double
        If o Is System.DBNull.Value Then
            Return CDbl(_nullReplacerInt)
        Else
            If TypeOf o Is Double Then
                Return CDbl(o)
            End If
        End If
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

NullHandler


NullHandler.CToInt16 Method

Public Shared Function CToInt16( _
   ByVal o As Object _
) As Int16

Parameters

o
Required.

Source code

[Visual Basic]
    Public Shared Function CToInt16(ByVal o As Object) As Int16
        If o Is System.DBNull.Value Then
            Return CShort(_nullReplacerInt)
        Else
            If TypeOf o Is Int16 Then
                Return CShort(o)
            End If
        End If
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

NullHandler


NullHandler.CToInt32 Method

Public Shared Function CToInt32( _
   ByVal o As Object _
) As Int32

Parameters

o
Required.

Source code

[Visual Basic]
    Public Shared Function CToInt32(ByVal o As Object) As Int32
        If o Is System.DBNull.Value Then
            Return _nullReplacerInt
        Else
            If TypeOf o Is Int32 Then
                Return CInt(o)
            End If
        End If
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

NullHandler


NullHandler.CToInt64 Method

Public Shared Function CToInt64( _
   ByVal o As Object _
) As Int64

Parameters

o
Required.

Source code

[Visual Basic]
    Public Shared Function CToInt64(ByVal o As Object) As Int64
        If o Is System.DBNull.Value Then
            Return CLng(_nullReplacerInt)
        Else
            If TypeOf o Is Int64 Then
                Return CLng(o)
            End If
        End If
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

NullHandler


NullHandler.CToSingle Method

Public Shared Function CToSingle( _
   ByVal o As Object _
) As Single

Parameters

o
Required.

Source code

[Visual Basic]
    Public Shared Function CToSingle(ByVal o As Object) As Single
        If o Is System.DBNull.Value Then
            Return CSng(_nullReplacerInt)
        Else
            If TypeOf o Is Single Then
                Return CSng(o)
            End If
        End If
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

NullHandler


NullHandler.CToString Method

Public Shared Function CToString( _
   ByVal o As Object _
) As String

Parameters

o
Required.

Source code

[Visual Basic]
    Public Shared Function CToString(ByVal o As Object) As String
        If o Is System.DBNull.Value Then
            Return _nullReplacerStr
        Else
            If TypeOf o Is String Then
                Return CStr(o)
            End If
        End If
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

NullHandler


OfficeVorlage Class

Diese klasse beinhaltet die Logik für die Office Vorlage

For a list of all members of this type, see OfficeVorlage Members.

System.Object
EDOKALib.BusinessFacade.OfficeVorlage

Public Class OfficeVorlage

Requirements

Namespace: BusinessFacade

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKALib.BusinessFacade (in EDOKALib.BusinessFacade.dll)

See Also

OfficeVorlage Members


OfficeVorlage Members

OfficeVorlage overview

Constructors

constructor OfficeVorlage Constructor (Overloaded)

Properties

property Anwendung
property BarcodeMember
property Beschreibung
property Bezeichnung
property ErstelltAm
property IdvId
property IsAktiv
property IsIdvNativ
property IsIdvVorlage
property IsKopfzeileGenerieren
property MandantNr
property MutiererMitarbeiterNr
property MutiertAm
property OfficeVorlage
property OfficeVorlageNr
property OwnerMitarbeiterNr
property PrefixDokumentName
property VorlageId
property VorlageName

Methods

method Delete |
method LoadData | lädt die daten in die klassen member
method Save |

Fields

field _anwendung
field _barcode
field _beschreibung
field _bezeichnung
field _erstelltAm
field _idvId
field _isAbsenderErsteller
field _isAktiv
field _isDokumentGeschuetzt
field _isIdvNativ
field _isIdvVorlage
field _isKopfzeileGenerieren
field _klassifizierung
field _mandantNr
field _mutiererMitarbeiterNr
field _mutiertAm
field _officeVorlage
field _officeVorlageNr
field _ownerMitarbeiterNr
field _prefixDokumentName
field _vorlageId
field _vorlageName

See Also

OfficeVorlage Class


New

Overload List

[Visual Basic] Public Sub New()

Neue Instanz für bestehende OfficeVorlage erstellen

[Visual Basic] Public Sub New(ByVal officeVorlageNr As Integer)

See Also

OfficeVorlage | BusinessFacade


OfficeVorlage Properties

OfficeVorlage overview

Properties

property Anwendung
property BarcodeMember
property Beschreibung
property Bezeichnung
property ErstelltAm
property IdvId
property IsAktiv
property IsIdvNativ
property IsIdvVorlage
property IsKopfzeileGenerieren
property MandantNr
property MutiererMitarbeiterNr
property MutiertAm
property OfficeVorlage
property OfficeVorlageNr
property OwnerMitarbeiterNr
property PrefixDokumentName
property VorlageId
property VorlageName

See Also

OfficeVorlage Class


OfficeVorlage.Anwendung Property

Public Property Anwendung() As Anwendung

Source code

[Visual Basic]
    Public Property Anwendung() As Anwendung
        Get
            Return _anwendung
        End Get
        Set(ByVal Value As Anwendung)
            _anwendung = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

OfficeVorlage


OfficeVorlage.BarcodeMember Property

Public Property BarcodeMember() As BarcodeTyp

Source code

[Visual Basic]
    Public Property BarcodeMember() As BarcodeTyp
        Get
            Return _barcode
        End Get
        Set(ByVal Value As BarcodeTyp)
            _barcode = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

OfficeVorlage


OfficeVorlage.Beschreibung Property

Public Property Beschreibung() As String

Source code

[Visual Basic]
    Public Property Beschreibung() As String
        Get
            Return _beschreibung
        End Get
        Set(ByVal Value As String)
            _beschreibung = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

OfficeVorlage


OfficeVorlage.Bezeichnung Property

Public Property Bezeichnung() As String

Source code

[Visual Basic]
    Public Property Bezeichnung() As String
        Get
            Return _bezeichnung
        End Get
        Set(ByVal Value As String)
            _bezeichnung = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

OfficeVorlage


OfficeVorlage.ErstelltAm Property

Public Property ErstelltAm() As DateTime

Source code

[Visual Basic]
    Public Property ErstelltAm() As DateTime
        Get
            Return _erstelltAm
        End Get
        Set(ByVal Value As DateTime)
            _erstelltAm = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

OfficeVorlage


OfficeVorlage.IdvId Property

Public Property IdvId() As String

Source code

[Visual Basic]
    Public Property IdvId() As String
        Get
            Return _idvId
        End Get
        Set(ByVal Value As String)
            _idvId = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

OfficeVorlage


OfficeVorlage.IsAktiv Property

Public Property IsAktiv() As Boolean

Source code

[Visual Basic]
    Public Property IsAktiv() As Boolean
        Get
            Return _isAktiv
        End Get
        Set(ByVal Value As Boolean)
            _isAktiv = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

OfficeVorlage


OfficeVorlage.IsIdvNativ Property

Public Property IsIdvNativ() As Boolean

Source code

[Visual Basic]
    Public Property IsIdvNativ() As Boolean
        Get
            Return _isIdvNativ
        End Get
        Set(ByVal Value As Boolean)
            _isIdvNativ = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

OfficeVorlage


OfficeVorlage.IsIdvVorlage Property

Public Property IsIdvVorlage() As Boolean

Source code

[Visual Basic]
    Public Property IsIdvVorlage() As Boolean
        Get
            Return _isIdvVorlage
        End Get
        Set(ByVal Value As Boolean)
            _isIdvVorlage = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

OfficeVorlage


OfficeVorlage.IsKopfzeileGenerieren Property

Public Property IsKopfzeileGenerieren() As Boolean

Source code

[Visual Basic]
    Public Property IsKopfzeileGenerieren() As Boolean
        Get
            Return _isKopfzeileGenerieren
        End Get
        Set(ByVal Value As Boolean)
            _isKopfzeileGenerieren = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

OfficeVorlage


OfficeVorlage.MandantNr Property

Public Property MandantNr() As Integer

Source code

[Visual Basic]
    Public Property MandantNr() As Integer
        Get
            Return _mandantNr
        End Get
        Set(ByVal Value As Integer)
            _mandantNr = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

OfficeVorlage


OfficeVorlage.MutiererMitarbeiterNr Property

Public Property MutiererMitarbeiterNr() As Integer

Source code

[Visual Basic]
    Public Property MutiererMitarbeiterNr() As Integer
        Get
            Return _mutiererMitarbeiterNr
        End Get
        Set(ByVal Value As Integer)
            _mutiererMitarbeiterNr = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

OfficeVorlage


OfficeVorlage.MutiertAm Property

Public Property MutiertAm() As DateTime

Source code

[Visual Basic]
    Public Property MutiertAm() As DateTime
        Get
            Return _mutiertAm
        End Get
        Set(ByVal Value As DateTime)
            _mutiertAm = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

OfficeVorlage


OfficeVorlage.OfficeVorlage Property

Public Property OfficeVorlage() As String

Source code

[Visual Basic]
    Public Property OfficeVorlage() As String
        Get
            Return _officeVorlage
        End Get
        Set(ByVal Value As String)
            _officeVorlage = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

OfficeVorlage


OfficeVorlage.OfficeVorlageNr Property

Public Property OfficeVorlageNr() As Integer

Source code

[Visual Basic]
    Public Property OfficeVorlageNr() As Integer
        Get
            Return _officeVorlageNr
        End Get
        Set(ByVal Value As Integer)
            _officeVorlageNr = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

OfficeVorlage


OfficeVorlage.OwnerMitarbeiterNr Property

Public Property OwnerMitarbeiterNr() As Integer

Source code

[Visual Basic]
    Public Property OwnerMitarbeiterNr() As Integer
        Get
            Return _ownerMitarbeiterNr
        End Get
        Set(ByVal Value As Integer)
            _ownerMitarbeiterNr = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

OfficeVorlage


OfficeVorlage.PrefixDokumentName Property

Public Property PrefixDokumentName() As String

Source code

[Visual Basic]
    Public Property PrefixDokumentName() As String
        Get
            Return _prefixDokumentName
        End Get
        Set(ByVal Value As String)
            _prefixDokumentName = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

OfficeVorlage


OfficeVorlage.VorlageId Property

Public Property VorlageId() As Integer

Source code

[Visual Basic]
    Public Property VorlageId() As Integer
        Get
            Return _vorlageId
        End Get
        Set(ByVal Value As Integer)
            _vorlageId = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

OfficeVorlage


OfficeVorlage.VorlageName Property

Public Property VorlageName() As String

Source code

[Visual Basic]
    Public Property VorlageName() As String
        Get
            Return _vorlageName
        End Get
        Set(ByVal Value As String)
            _vorlageName = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

OfficeVorlage


OfficeVorlage Methods

OfficeVorlage overview

Methods

method Delete |
method LoadData | lädt die daten in die klassen member
method Save |

See Also

OfficeVorlage Class


OfficeVorlage.Delete Method

Public Function Delete( _
   ByVal mutierer As Integer _
)

Parameters

mutierer
Required.

Source code

[Visual Basic]
    Public Function Delete(ByVal mutierer As Integer)
        Try
            _isAktiv = False
            Save(mutierer)
        Catch ex As Exception
            TKBLib.Errorhandling.TraceHelper.Msg("EDOKALib.BF.OfficeVorlage.Delete", ex.Message + " " + ex.StackTrace, TraceLevel.Error)
            Throw ex
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

OfficeVorlage


OfficeVorlage.LoadData Method

lädt die daten in die klassen member

Private Sub LoadData( _
   ByVal ds As DataSet _
)

Parameters

ds
Required.

Source code

[Visual Basic]
    Private Sub LoadData(ByVal ds As DataSet)
        Try
            If Not Common.Tools.ValidateDS(ds) Then
                Return
            End If

            _officeVorlageNr = Tools.CToInt32(ds.Tables(0).Rows(0)("offfice_vorlagenr"))
            _bezeichnung = NullHandler.CToString(ds.Tables(0).Rows(0)("bezeichnung"))
            _beschreibung = NullHandler.CToString(ds.Tables(0).Rows(0)("beschreibung"))
            _vorlageId = NullHandler.CToInt32(ds.Tables(0).Rows(0)("vorlageid"))
            _vorlageName = NullHandler.CToString(ds.Tables(0).Rows(0)("vorlagename"))
            _prefixDokumentName = NullHandler.CToString(ds.Tables(0).Rows(0)("prefix_dokumentname"))
            _isIdvVorlage = Tools.CToBool(ds.Tables(0).Rows(0)("idv_vorlage"))
            _idvId = NullHandler.CToString(ds.Tables(0).Rows(0)("idv_id"))
            _officeVorlage = NullHandler.CToString(ds.Tables(0).Rows(0)("office_vorlage"))
            _isAbsenderErsteller = Tools.CToBool(ds.Tables(0).Rows(0)("absender_ersteller"))
            _isIdvNativ = Tools.CToBool(ds.Tables(0).Rows(0)("idv_nativ"))
            _isDokumentGeschuetzt = Tools.CToBool(ds.Tables(0).Rows(0)("dokument_geschuetzt"))
            _isKopfzeileGenerieren = Tools.CToBool(ds.Tables(0).Rows(0)("kopfzeile_generieren"))
            _klassifizierung = NullHandler.CToInt32(ds.Tables(0).Rows(0)("klassifizierung"))

            _barcode = New BarcodeTyp(Tools.CToInt32(ds.Tables(0).Rows(0)("bcpt")), _
            NullHandler.CToInt32(ds.Tables(0).Rows(0)("bcpl")), _
            Tools.CToInt32(ds.Tables(0).Rows(0)("bcw")), _
            Tools.CToInt32(ds.Tables(0).Rows(0)("bch")), _
            NullHandler.CToInt32(ds.Tables(0).Rows(0)("bhorizontal")))

            _mandantNr = NullHandler.CToInt32(ds.Tables(0).Rows(0)("mandantnr"))
            _isAktiv = Tools.CToBool(ds.Tables(0).Rows(0)("aktiv"))
            _erstelltAm = NullHandler.CToDateTime(ds.Tables(0).Rows(0)("erstellt_am"))
            _mutiertAm = NullHandler.CToDateTime(ds.Tables(0).Rows(0)("mutiert_am"))
            _mutiererMitarbeiterNr = NullHandler.CToInt32(ds.Tables(0).Rows(0)("mutierer"))

            _anwendung = New Anwendung(NullHandler.CToInt32(ds.Tables(0).Rows(0)("anwendungnr")))
            _ownerMitarbeiterNr = NullHandler.CToInt32(ds.Tables(0).Rows(0)("owner"))

        Catch ex As Exception
            TKBLib.Errorhandling.TraceHelper.Msg("EDOKALib.BF.OfficeVorlage.ConstructorHelper", ex.Message + " " + ex.StackTrace, TraceLevel.Error)
            Throw ex
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

OfficeVorlage


OfficeVorlage.Save Method

Public Function Save( _
   ByVal mutierer As Integer _
)

Parameters

mutierer
Required.

Source code

[Visual Basic]
    Public Function Save(ByVal mutierer As Integer)
        Try
            Dim err As Integer
            Dim key As Integer
            If _officeVorlageNr = 0 Then		  'create new
                err = DataAccess.OfficeVorlage.Add(key, _bezeichnung, _beschreibung, _vorlageId, _vorlageName, _
                _prefixDokumentName, _isIdvVorlage, _idvId, _officeVorlage, _isAbsenderErsteller, _isIdvNativ, _
                _isDokumentGeschuetzt, _isKopfzeileGenerieren, _klassifizierung, _barcode.Top, _barcode.Left, _
                _barcode.Width, _barcode.Height, _barcode.IsHorizontal, _mandantNr, _isAktiv, _erstelltAm, _
                _mutiertAm, _mutiererMitarbeiterNr, _anwendung.AnwendungsNr, _ownerMitarbeiterNr)

                If err = 0 Then
                    _officeVorlageNr = key
                End If
            Else		  'save existing

            End If

            If err <> 0 Then
                Throw New DokumentartException(Meldungstext.GetInhaltById(40000))
            End If

            'refresh data
            Dim ds As New DataSet()
            DataAccess.OfficeVorlage.GetByNr(ds, OfficeVorlageNr)
            LoadData(ds)

        Catch ex As Exception
            TKBLib.Errorhandling.TraceHelper.Msg("EDOKALib.BF.OfficeVorlage.Save", ex.Message + " " + ex.StackTrace, TraceLevel.Error)
            Throw ex
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

OfficeVorlage


OfficeVorlage Fields

OfficeVorlage overview

Fields

field _anwendung
field _barcode
field _beschreibung
field _bezeichnung
field _erstelltAm
field _idvId
field _isAbsenderErsteller
field _isAktiv
field _isDokumentGeschuetzt
field _isIdvNativ
field _isIdvVorlage
field _isKopfzeileGenerieren
field _klassifizierung
field _mandantNr
field _mutiererMitarbeiterNr
field _mutiertAm
field _officeVorlage
field _officeVorlageNr
field _ownerMitarbeiterNr
field _prefixDokumentName
field _vorlageId
field _vorlageName

See Also

OfficeVorlage Class


_anwendung Variable

Private _anwendung As Anwendung

Source code

[Visual Basic]
    Private _anwendung As Anwendung

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

OfficeVorlage


_barcode Variable

Private _barcode As BarcodeTyp

Source code

[Visual Basic]
    Private _barcode As BarcodeTyp

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

OfficeVorlage


_beschreibung Variable

Private _beschreibung As String

Source code

[Visual Basic]
    Private _beschreibung As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

OfficeVorlage


_bezeichnung Variable

Private _bezeichnung As String

Source code

[Visual Basic]
    Private _bezeichnung As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

OfficeVorlage


_erstelltAm Variable

Private _erstelltAm As DateTime

Source code

[Visual Basic]
    Private _erstelltAm As DateTime

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

OfficeVorlage


_idvId Variable

Private _idvId As String

Source code

[Visual Basic]
    Private _idvId As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

OfficeVorlage


_isAbsenderErsteller Variable

Private _isAbsenderErsteller As Boolean

Source code

[Visual Basic]
    Private _isAbsenderErsteller As Boolean	  'nicht implementiert -> property not visible

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

OfficeVorlage


_isAktiv Variable

Private _isAktiv As Boolean

Source code

[Visual Basic]
    Private _isAktiv As Boolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

OfficeVorlage


_isDokumentGeschuetzt Variable

Private _isDokumentGeschuetzt As Boolean

Source code

[Visual Basic]
    Private _isDokumentGeschuetzt As Boolean	  'nicht implementiert -> property not visible

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

OfficeVorlage


_isIdvNativ Variable

Private _isIdvNativ As Boolean

Source code

[Visual Basic]
    Private _isIdvNativ As Boolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

OfficeVorlage


_isIdvVorlage Variable

Private _isIdvVorlage As Boolean

Source code

[Visual Basic]
    Private _isIdvVorlage As Boolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

OfficeVorlage


_isKopfzeileGenerieren Variable

Private _isKopfzeileGenerieren As Boolean

Source code

[Visual Basic]
    Private _isKopfzeileGenerieren As Boolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

OfficeVorlage


_klassifizierung Variable

Private _klassifizierung As Boolean

Source code

[Visual Basic]
    Private _klassifizierung As Boolean	  'nicht implementiert -> property not visible

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

OfficeVorlage


_mandantNr Variable

Private _mandantNr As Integer

Source code

[Visual Basic]
    Private _mandantNr As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

OfficeVorlage


_mutiererMitarbeiterNr Variable

Private _mutiererMitarbeiterNr As Integer

Source code

[Visual Basic]
    Private _mutiererMitarbeiterNr As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

OfficeVorlage


_mutiertAm Variable

Private _mutiertAm As DateTime

Source code

[Visual Basic]
    Private _mutiertAm As DateTime

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

OfficeVorlage


_officeVorlage Variable

Private _officeVorlage As String

Source code

[Visual Basic]
    Private _officeVorlage As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

OfficeVorlage


_officeVorlageNr Variable

Private _officeVorlageNr As Integer

Source code

[Visual Basic]
    Private _officeVorlageNr As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

OfficeVorlage


_ownerMitarbeiterNr Variable

Private _ownerMitarbeiterNr As Integer

Source code

[Visual Basic]
    Private _ownerMitarbeiterNr As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

OfficeVorlage


_prefixDokumentName Variable

Private _prefixDokumentName As String

Source code

[Visual Basic]
    Private _prefixDokumentName As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

OfficeVorlage


_vorlageId Variable

Private _vorlageId As Integer

Source code

[Visual Basic]
    Private _vorlageId As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

OfficeVorlage


_vorlageName Variable

Private _vorlageName As String

Source code

[Visual Basic]
    Private _vorlageName As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

OfficeVorlage


OfficeVorlageException Class

Diese Klasse behandelt eine OfficeVorlage spezifische Ausnahme

For a list of all members of this type, see OfficeVorlageException Members.

System.Object
System.Exception
EDOKALib.BusinessFacade.OfficeVorlageException

Public Class OfficeVorlageException
   Inherits Exception

Requirements

Namespace: BusinessFacade

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKALib.BusinessFacade (in EDOKALib.BusinessFacade.dll)

See Also

OfficeVorlageException Members


OfficeVorlageException Members

OfficeVorlageException overview

Constructors

constructor OfficeVorlageException Constructor

Properties

property Message

Fields

field _message

See Also

OfficeVorlageException Class


OfficeVorlageException Constructor

Public Sub New( _
   ByVal message As String _
)

Parameters

message
Required.

Source code

[Visual Basic]
    Public Sub New(ByVal message As String)
        _message = message
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

OfficeVorlageException


OfficeVorlageException Properties

OfficeVorlageException overview

Properties

property Message

See Also

OfficeVorlageException Class


OfficeVorlageException.Message Property

Public Overrides ReadOnly Property Message() As String

Source code

[Visual Basic]
    Public Overrides ReadOnly Property Message() As String
        Get
            Return _message
        End Get
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

OfficeVorlageException


OfficeVorlageException Fields

OfficeVorlageException overview

Fields

field _message

See Also

OfficeVorlageException Class


_message Variable

Dim _message As String

Source code

[Visual Basic]
    Dim _message As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

OfficeVorlageException


Parameter Class

Applikations Parameter (verwaltet Programmeinstellungen für einzelne oder alle Benutzer in einer sql-tabelle)

For a list of all members of this type, see Parameter Members.

System.Object
EDOKALib.BusinessFacade.Parameter

Public Class Parameter

Requirements

Namespace: BusinessFacade

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKALib.BusinessFacade (in EDOKALib.BusinessFacade.dll)

See Also

Parameter Members


Parameter Members

Parameter overview

Constructors

constructor Parameter Constructor (Overloaded)

Properties

property Aktiv
property BenutzerNr
property Beschreibung
property MutiererId
property MutiertAm
property Name
property ParameterId
property Typ
property Wert

Methods

method ConstructorHelper | workaround für fehlendes konstruktor überladen
method LoadData | lädt die daten in die klassen member

Fields

field _aktiv
field _benutzerNr
field _beschreibung
field _datentyp
field _mutiererId
field _mutiertAm
field _name
field _parameterId
field _wert

See Also

Parameter Class


New

Overload List

[Visual Basic] Public Sub New()

load the parameter for all users (benutzerNr=0)

[Visual Basic] Public Sub New(ByVal parameterName As String)

lädt einen parameter für einen bestimmten benutzer oder für alle

[Visual Basic] Public Sub New(ByVal parameterName As String, ByVal benutzerNr As Integer)

See Also

Parameter | BusinessFacade


Parameter Properties

Parameter overview

Properties

property Aktiv
property BenutzerNr
property Beschreibung
property MutiererId
property MutiertAm
property Name
property ParameterId
property Typ
property Wert

See Also

Parameter Class


Parameter.Aktiv Property

Public Property Aktiv() As Boolean

Source code

[Visual Basic]
    Public Property Aktiv() As Boolean
        Get
            Return _aktiv
        End Get
        Set(ByVal Value As Boolean)
            _aktiv = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Parameter


Parameter.BenutzerNr Property

Public Property BenutzerNr() As Integer

Source code

[Visual Basic]
    Public Property BenutzerNr() As Integer
        Get
            Return _benutzerNr
        End Get
        Set(ByVal Value As Integer)
            _benutzerNr = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Parameter


Parameter.Beschreibung Property

Public Property Beschreibung() As String

Source code

[Visual Basic]
    Public Property Beschreibung() As String
        Get
            Return _beschreibung
        End Get
        Set(ByVal Value As String)
            _beschreibung = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Parameter


Parameter.MutiererId Property

Public Property MutiererId() As Integer

Source code

[Visual Basic]
    Public Property MutiererId() As Integer
        Get
            Return _mutiererId
        End Get
        Set(ByVal Value As Integer)
            _mutiererId = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Parameter


Parameter.MutiertAm Property

Public Property MutiertAm() As DateTime

Source code

[Visual Basic]
    Public Property MutiertAm() As DateTime
        Get
            Return _mutiertAm
        End Get
        Set(ByVal Value As DateTime)
            _mutiertAm = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Parameter


Parameter.Name Property

Public Property Name() As String

Source code

[Visual Basic]
    Public Property Name() As String
        Get
            Return _name
        End Get
        Set(ByVal Value As String)
            _name = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Parameter


Parameter.ParameterId Property

Public Property ParameterId() As Integer

Source code

[Visual Basic]
    Public Property ParameterId() As Integer
        Get
            Return _parameterId
        End Get
        Set(ByVal Value As Integer)
            _parameterId = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Parameter


Parameter.Typ Property

Public Property Typ() As Datentyp

Source code

[Visual Basic]
    Public Property Typ() As Datentyp
        Get
            Return _datentyp
        End Get
        Set(ByVal Value As Datentyp)
            _datentyp = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Parameter


Parameter.Wert Property

Public Property Wert() As String

Source code

[Visual Basic]
    Public Property Wert() As String
        Get
            Return _wert
        End Get
        Set(ByVal Value As String)
            _wert = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Parameter


Parameter Methods

Parameter overview

Methods

method ConstructorHelper | workaround für fehlendes konstruktor überladen
method LoadData | lädt die daten in die klassen member

See Also

Parameter Class


Parameter.ConstructorHelper Method

workaround für fehlendes konstruktor überladen

Private Sub ConstructorHelper( _
   ByVal parameterName As String, _
   ByVal benutzerNr As Integer _
)

Parameters

parameterName
Required.
benutzerNr
Required.

Source code

[Visual Basic]
    Private Sub ConstructorHelper(ByVal parameterName As String, ByVal benutzerNr As Integer)
        Try
            Dim ds As New DataSet()
            DataAccess.Parameter.GetParameter(ds, benutzerNr, parameterName)
            LoadData(ds)

        Catch ex As Exception
            TKBLib.Errorhandling.TraceHelper.Msg("EDOKALib.BF.Parameter.ConstructorHelper", ex.Message + " " + ex.StackTrace, TraceLevel.Error)
            Throw ex
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Parameter


Parameter.LoadData Method

lädt die daten in die klassen member

Private Sub LoadData( _
   ByVal ds As DataSet _
)

Parameters

ds
Required.

Source code

[Visual Basic]
    Private Sub LoadData(ByVal ds As DataSet)
        Try
            If Not Common.Tools.ValidateDS(ds) Then
                Return
            End If

            _parameterId = ds.Tables(0).Rows(0).Item("ParameterId")
            _benutzerNr = ds.Tables(0).Rows(0).Item("BenutzerNr")
            _name = ds.Tables(0).Rows(0).Item("Name")
            _wert = ds.Tables(0).Rows(0).Item("Wert")
            _datentyp = CType(ds.Tables(0).Rows(0).Item("Datentyp"), Datentyp)
            _beschreibung = ds.Tables(0).Rows(0).Item("Beschreibung")
            _aktiv = ds.Tables(0).Rows(0).Item("Aktiv")
            _mutiererId = ds.Tables(0).Rows(0).Item("MutiererId")
            _mutiertAm = ds.Tables(0).Rows(0).Item("MutiertAm")
        Catch ex As Exception
            TKBLib.Errorhandling.TraceHelper.Msg("EDOKALib.BF.Parameter.LoadData", ex.Message + " " + ex.StackTrace, TraceLevel.Error)
            Throw ex
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Parameter


Parameter Fields

Parameter overview

Fields

field _aktiv
field _benutzerNr
field _beschreibung
field _datentyp
field _mutiererId
field _mutiertAm
field _name
field _parameterId
field _wert

See Also

Parameter Class


_aktiv Variable

Private _aktiv As Boolean

Source code

[Visual Basic]
    Private _aktiv As Boolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Parameter


_benutzerNr Variable

Private _benutzerNr As Integer

Source code

[Visual Basic]
    Private _benutzerNr As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Parameter


_beschreibung Variable

Private _beschreibung As String

Source code

[Visual Basic]
    Private _beschreibung As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Parameter


_datentyp Variable

Private _datentyp As Datentyp

Source code

[Visual Basic]
    Private _datentyp As Datentyp

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Parameter


_mutiererId Variable

Private _mutiererId As Integer

Source code

[Visual Basic]
    Private _mutiererId As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Parameter


_mutiertAm Variable

Private _mutiertAm As DateTime

Source code

[Visual Basic]
    Private _mutiertAm As DateTime

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Parameter


_name Variable

Private _name As String

Source code

[Visual Basic]
    Private _name As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Parameter


_parameterId Variable

Private _parameterId As Integer

Source code

[Visual Basic]
    Private _parameterId As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Parameter


_wert Variable

Private _wert As String = ""

Source code

[Visual Basic]
    Private _wert As String = ""

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Parameter


Spalten Class

Diese klasse beinhaltet die Logik für die Spalten Definitionen

For a list of all members of this type, see Spalten Members.

System.Object
EDOKALib.BusinessFacade.Spalten

Public Class Spalten

Requirements

Namespace: BusinessFacade

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKALib.BusinessFacade (in EDOKALib.BusinessFacade.dll)

See Also

Spalten Members


Spalten Members

Spalten overview

Methods

method FillGridColumns Füllt ein C1TrueDbGrid mit allen in der Datenbank definierten Spalten

See Also

Spalten Class


Spalten Methods

Spalten overview

Methods

method FillGridColumns Füllt ein C1TrueDbGrid mit allen in der Datenbank definierten Spalten

See Also

Spalten Class


Spalten.FillGridColumns Method

Füllt ein C1TrueDbGrid mit allen in der Datenbank definierten Spalten

Public Overloads Shared Sub FillGridColumns( _
   ByVal tableName As String, _
   ByRef grid As C1.Win.C1TrueDBGrid.C1TrueDBGrid _
)

Parameters

tableName
Required. Name der Tabelle, von welcher die Spalten zurück gegeben werden sollen
grid
Required.

Source code

[Visual Basic]
    Public Overloads Shared Sub FillGridColumns(ByVal tableName As String, ByRef grid As C1.Win.C1TrueDBGrid.C1TrueDBGrid)
        Try
            Dim dsSpalten As New DataSet()
            DataAccess.Spalten.GetListe(tableName, dsSpalten)

            If dsSpalten.Tables.Count > 0 Then
                If dsSpalten.Tables(0).Rows.Count > 0 Then

                    'bestehende löschen
                    grid.Columns.Clear()

                    Dim row As DataRow

                    grid.Splits(0).DisplayColumns.Clear()

                    Dim index As Integer = 0
                    Dim column As C1.Win.C1TrueDBGrid.C1DisplayColumn

                    'alle spalten in grid erstellen
                    For Each row In dsSpalten.Tables(0).Rows
                        index = grid.Columns.Add(New C1.Win.C1TrueDBGrid.C1DataColumn())

                        grid.Columns(index).Caption = Tools.CToString(row("spalte"))
                        grid.Columns(index).DataField = Tools.CToString(row("tabellenspalte"))

                        'feld mit checkbox anzeigen
                        If Common.Tools.CToBool(row("alsHacken")) Then
                            grid.Columns(index).ValueItems().Presentation = C1.Win.C1TrueDBGrid.PresentationEnum.CheckBox
                        End If

                        grid.Splits(0).DisplayColumns(index).Width = Common.Tools.CToInt32(row("Breite"))
                        grid.Splits(0).DisplayColumns(index).Visible = True

                        index += 1
                    Next

                End If
            End If
        Catch ex As Exception
            Throw ex
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Spalten


Team Class

Diese klasse beinhaltet die Logik für die Teams

For a list of all members of this type, see Team Members.

System.Object
EDOKALib.BusinessFacade.Team

Public Class Team

Requirements

Namespace: BusinessFacade

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKALib.BusinessFacade (in EDOKALib.BusinessFacade.dll)

See Also

Team Members


Team Members

Team overview

Constructors

constructor Team Constructor Erstellt eine neue Instanz für ein bestehendes Team

Properties

property Bezeichnung
property ErstelltAm
property IsAktiv
property KostenstellenNr
property MandantNr
property MutiererMitarbeiter
property MutiertAm
property TeamNr

Methods

method GetListe | Gibt eine Liste mit allen Teams zurück
method GetListeByMitarbeiterNr | Gibt eine Liste mit allen Teams denen ein Mitarbeiter zugewiesen ist zurück

Fields

field _bezeichnung
field _erstelltAm
field _isAktiv
field _kostenstellenNr
field _mandantNr
field _mutiererMitarbeiter
field _mutiertAm
field _teamNr

See Also

Team Class


Team Constructor

Erstellt eine neue Instanz für ein bestehendes Team

Public Sub New( _
   ByVal teamNr As Integer _
)

Parameters

teamNr
Required.

Source code

[Visual Basic]
    Public Sub New(ByVal teamNr As Integer)
        Try
            Dim ds As New DataSet()
            DataAccess.Team.GetById(teamNr, ds)

            If ds.Tables.Count > 0 Then
                If ds.Tables(0).Rows.Count > 0 Then
                    _teamNr = teamNr
                    _bezeichnung = Tools.CToString(ds.Tables(0).Rows(0)("bezeichnung"))
                    _kostenstellenNr = Tools.CToInt32(ds.Tables(0).Rows(0)("kostenstellenr"))
                    _mandantNr = Tools.CToInt32(ds.Tables(0).Rows(0)("mandantnr"))
                    _isAktiv = Common.Tools.CToBool(ds.Tables(0).Rows(0)("aktiv"))
                    _erstelltAm = Tools.CToDateTime(ds.Tables(0).Rows(0)("erstellt_am"))
                    _mutiertAm = Tools.CToDateTime(ds.Tables(0).Rows(0)("mutiert_am"))
                    _mutiererMitarbeiter = New BusinessFacade.Mitarbeiter(Tools.CToInt32(ds.Tables(0).Rows(0)("mutierer")))
                End If
            End If
        Catch ex As Exception
            Throw ex
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Team


Team Properties

Team overview

Properties

property Bezeichnung
property ErstelltAm
property IsAktiv
property KostenstellenNr
property MandantNr
property MutiererMitarbeiter
property MutiertAm
property TeamNr

See Also

Team Class


Team.Bezeichnung Property

Public Property Bezeichnung() As String

Source code

[Visual Basic]
    Public Property Bezeichnung() As String
        Get
            Return _bezeichnung
        End Get
        Set(ByVal Value As String)
            _bezeichnung = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Team


Team.ErstelltAm Property

Public Property ErstelltAm() As DateTime

Source code

[Visual Basic]
    Public Property ErstelltAm() As DateTime
        Get
            Return _erstelltAm
        End Get
        Set(ByVal Value As DateTime)
            _erstelltAm = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Team


Team.IsAktiv Property

Public Property IsAktiv() As Boolean

Source code

[Visual Basic]
    Public Property IsAktiv() As Boolean
        Get
            Return _isAktiv
        End Get
        Set(ByVal Value As Boolean)
            _isAktiv = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Team


Team.KostenstellenNr Property

Public Property KostenstellenNr() As Integer

Source code

[Visual Basic]
    Public Property KostenstellenNr() As Integer
        Get
            Return _kostenstellenNr
        End Get
        Set(ByVal Value As Integer)
            _kostenstellenNr = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Team


Team.MandantNr Property

Public Property MandantNr() As Integer

Source code

[Visual Basic]
    Public Property MandantNr() As Integer
        Get
            Return _mandantNr
        End Get
        Set(ByVal Value As Integer)
            _mandantNr = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Team


Team.MutiererMitarbeiter Property

Public ReadOnly Property MutiererMitarbeiter() As BusinessFacade.Mitarbeiter

Source code

[Visual Basic]
    Public ReadOnly Property MutiererMitarbeiter() As BusinessFacade.Mitarbeiter
        Get
            Return _mutiererMitarbeiter
        End Get
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Team


Team.MutiertAm Property

Public ReadOnly Property MutiertAm() As DateTime

Source code

[Visual Basic]
    Public ReadOnly Property MutiertAm() As DateTime
        Get
            Return _mutiertAm
        End Get
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Team


Team.TeamNr Property

Public ReadOnly Property TeamNr() As Integer

Source code

[Visual Basic]
    Public ReadOnly Property TeamNr() As Integer
        Get
            Return _teamNr
        End Get
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Team


Team Methods

Team overview

Methods

method GetListe | Gibt eine Liste mit allen Teams zurück
method GetListeByMitarbeiterNr | Gibt eine Liste mit allen Teams denen ein Mitarbeiter zugewiesen ist zurück

See Also

Team Class


Team.GetListe Method

Gibt eine Liste mit allen Teams zurück

Public Overloads Shared Sub GetListe( _
   ByRef ds As DataSet _
)

Parameters

ds
Required. Das DataSet welches gefüllt werden soll

Source code

[Visual Basic]
    Public Overloads Shared Sub GetListe(ByRef ds As DataSet)
        Try
            DataAccess.Team.GetListe(ds)
        Catch ex As Exception
            Throw ex
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Team


Team.GetListeByMitarbeiterNr Method

Gibt eine Liste mit allen Teams denen ein Mitarbeiter zugewiesen ist zurück

Public Overloads Shared Sub GetListeByMitarbeiterNr( _
   ByVal mitarbeiterNr As Integer, _
   ByRef ds As DataSet _
)

Parameters

mitarbeiterNr
Required.
ds
Required. Das DataSet welches gefüllt werden soll

Source code

[Visual Basic]
    Public Overloads Shared Sub GetListeByMitarbeiterNr(ByVal mitarbeiterNr As Integer, ByRef ds As DataSet)
        Try
            DataAccess.Team.GetListeByMitarbeiterNr(mitarbeiterNr, ds)
        Catch ex As Exception
            Throw ex
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Team


Team Fields

Team overview

Fields

field _bezeichnung
field _erstelltAm
field _isAktiv
field _kostenstellenNr
field _mandantNr
field _mutiererMitarbeiter
field _mutiertAm
field _teamNr

See Also

Team Class


_bezeichnung Variable

Private _bezeichnung As String

Source code

[Visual Basic]
    Private _bezeichnung As String

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Team


_erstelltAm Variable

Private _erstelltAm As DateTime

Source code

[Visual Basic]
    Private _erstelltAm As DateTime

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Team


_isAktiv Variable

Private _isAktiv As Boolean

Source code

[Visual Basic]
    Private _isAktiv As Boolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Team


_kostenstellenNr Variable

Private _kostenstellenNr As Integer

Source code

[Visual Basic]
    Private _kostenstellenNr As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Team


_mandantNr Variable

Private _mandantNr As Integer

Source code

[Visual Basic]
    Private _mandantNr As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Team


_mutiererMitarbeiter Variable

Private _mutiererMitarbeiter As BusinessFacade.Mitarbeiter

Source code

[Visual Basic]
    Private _mutiererMitarbeiter As BusinessFacade.Mitarbeiter

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Team


_mutiertAm Variable

Private _mutiertAm As DateTime

Source code

[Visual Basic]
    Private _mutiertAm As DateTime

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Team


_teamNr Variable

Private _teamNr As Integer

Source code

[Visual Basic]
    Private _teamNr As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Team


TeamMitarbeiter Class

Diese klasse beinhaltet die Logik für die Team-Mitarbeiter Zuordnung

For a list of all members of this type, see TeamMitarbeiter Members.

System.Object
EDOKALib.BusinessFacade.TeamMitarbeiter

Public Class TeamMitarbeiter

Requirements

Namespace: BusinessFacade

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

Assembly: EDOKALib.BusinessFacade (in EDOKALib.BusinessFacade.dll)

See Also

TeamMitarbeiter Members


TeamMitarbeiter Members

TeamMitarbeiter overview

Constructors

constructor TeamMitarbeiter Constructor (Overloaded)

Properties

property Anteil
property ErstelltAm
property IsAktiv
property MandantNr
property MitarbeiterNr
property MutiererMitarbeiter
property MutiertAm
property Team
property TeamMitarbeiterNr

Methods

method Delete | Löscht eine Team-Mitarbeiter Zuordnung aus der Datenbank
method GetListe | Gibt eine Liste mit allen Teams für einen Mitarbeitern zurück
method Save | Speichert die Daten der aktuellen Instanz in die Datenbank

Fields

field _anteil
field _erstelltAm
field _isAktiv
field _mandantNr
field _mitarbeiterNr
field _mutiererMitarbeiter
field _mutiertAm
field _team
field _teamMitarbeiterNr

See Also

TeamMitarbeiter Class


New

Overload List

[Visual Basic] Public Sub New()

[Visual Basic] Public Sub New(ByVal teamMitarbeiterNr As Integer)

See Also

TeamMitarbeiter | BusinessFacade


TeamMitarbeiter Properties

TeamMitarbeiter overview

Properties

property Anteil
property ErstelltAm
property IsAktiv
property MandantNr
property MitarbeiterNr
property MutiererMitarbeiter
property MutiertAm
property Team
property TeamMitarbeiterNr

See Also

TeamMitarbeiter Class


TeamMitarbeiter.Anteil Property

Public Property Anteil() As Integer

Source code

[Visual Basic]
    Public Property Anteil() As Integer
        Get
            Return _anteil
        End Get
        Set(ByVal Value As Integer)
            _anteil = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

TeamMitarbeiter


TeamMitarbeiter.ErstelltAm Property

Public ReadOnly Property ErstelltAm() As DateTime

Source code

[Visual Basic]
    Public ReadOnly Property ErstelltAm() As DateTime
        Get
            Return _erstelltAm
        End Get
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

TeamMitarbeiter


TeamMitarbeiter.IsAktiv Property

Public Property IsAktiv() As Boolean

Source code

[Visual Basic]
    Public Property IsAktiv() As Boolean
        Get
            Return _isAktiv
        End Get
        Set(ByVal Value As Boolean)
            _isAktiv = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

TeamMitarbeiter


TeamMitarbeiter.MandantNr Property

Public Property MandantNr() As Integer

Source code

[Visual Basic]
    Public Property MandantNr() As Integer
        Get
            Return _mandantNr
        End Get
        Set(ByVal Value As Integer)
            _mandantNr = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

TeamMitarbeiter


TeamMitarbeiter.MitarbeiterNr Property

Public Property MitarbeiterNr() As Integer

Source code

[Visual Basic]
    Public Property MitarbeiterNr() As Integer
        Get
            Return _mitarbeiterNr
        End Get
        Set(ByVal Value As Integer)
            _mitarbeiterNr = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

TeamMitarbeiter


TeamMitarbeiter.MutiererMitarbeiter Property

Public ReadOnly Property MutiererMitarbeiter() As BusinessFacade.Mitarbeiter

Source code

[Visual Basic]
    Public ReadOnly Property MutiererMitarbeiter() As BusinessFacade.Mitarbeiter
        Get
            Return _mutiererMitarbeiter
        End Get
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

TeamMitarbeiter


TeamMitarbeiter.MutiertAm Property

Public Property MutiertAm() As DateTime

Source code

[Visual Basic]
    Public Property MutiertAm() As DateTime
        Get
            Return _mutiertAm
        End Get
        Set(ByVal Value As DateTime)
            _mutiertAm = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

TeamMitarbeiter


TeamMitarbeiter.Team Property

Public Property Team() As BusinessFacade.Team

Source code

[Visual Basic]
    Public Property Team() As BusinessFacade.Team
        Get
            Return _team
        End Get
        Set(ByVal Value As BusinessFacade.Team)
            _team = Value
        End Set
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

TeamMitarbeiter


TeamMitarbeiter.TeamMitarbeiterNr Property

Public ReadOnly Property TeamMitarbeiterNr() As Integer

Source code

[Visual Basic]
    Public ReadOnly Property TeamMitarbeiterNr() As Integer
        Get
            Return _teamMitarbeiterNr
        End Get
    End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

TeamMitarbeiter


TeamMitarbeiter Methods

TeamMitarbeiter overview

Methods

method Delete | Löscht eine Team-Mitarbeiter Zuordnung aus der Datenbank
method GetListe | Gibt eine Liste mit allen Teams für einen Mitarbeitern zurück
method Save | Speichert die Daten der aktuellen Instanz in die Datenbank

See Also

TeamMitarbeiter Class


TeamMitarbeiter.Delete Method

Löscht eine Team-Mitarbeiter Zuordnung aus der Datenbank

Public Overloads Shared Function Delete( _
   ByVal teamMitarbeiterNr As Integer, _
   ByVal mutiererMitarbeiterNr As Integer _
)

Parameters

teamMitarbeiterNr
Required. Zu löschende Verbindung
mutiererMitarbeiterNr
Required. Die Id des Benutzers, welcher die Änderungen vornimmt

Source code

[Visual Basic]
    Public Overloads Shared Function Delete(ByVal teamMitarbeiterNr As Integer, ByVal mutiererMitarbeiterNr As Integer)
        Try
            DataAccess.TeamMitarbeiter.Delete(teamMitarbeiterNr, mutiererMitarbeiterNr)
        Catch ex As Exception
            Throw ex
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

TeamMitarbeiter


TeamMitarbeiter.GetListe Method

Gibt eine Liste mit allen Teams für einen Mitarbeitern zurück

Public Overloads Shared Sub GetListe( _
   ByVal mitarbeiterNr As Integer, _
   ByRef ds As DataSet _
)

Parameters

mitarbeiterNr
Required.
ds
Required. Das DataSet welches gefüllt werden soll

Source code

[Visual Basic]
    Public Overloads Shared Sub GetListe(ByVal mitarbeiterNr As Integer, ByRef ds As DataSet)
        Try
            DataAccess.TeamMitarbeiter.GetListByMitarbeiterNr(mitarbeiterNr, ds)
        Catch ex As Exception
            Throw ex
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

TeamMitarbeiter


TeamMitarbeiter.Save Method

Speichert die Daten der aktuellen Instanz in die Datenbank

Public Function Save( _
   ByVal mutiererMitarbeiterNr As Integer _
)

Parameters

mutiererMitarbeiterNr
Required. Die Id des Benutzers, welcher die Änderungen vornimmt

Source code

[Visual Basic]
    Public Function Save(ByVal mutiererMitarbeiterNr As Integer)
        Try
            If _teamMitarbeiterNr < 0 Then
                'neuer eintrag
                DataAccess.TeamMitarbeiter.Insert(_team.TeamNr, _mitarbeiterNr, _anteil, _mandantNr, _isAktiv, mutiererMitarbeiterNr)
            Else
                'bestehender eintrag
                DataAccess.TeamMitarbeiter.Update(_teamMitarbeiterNr, _team.TeamNr, _mitarbeiterNr, _anteil, _mandantNr, _isAktiv, mutiererMitarbeiterNr)
            End If
        Catch ex As Exception
            Throw ex
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

TeamMitarbeiter


TeamMitarbeiter Fields

TeamMitarbeiter overview

Fields

field _anteil
field _erstelltAm
field _isAktiv
field _mandantNr
field _mitarbeiterNr
field _mutiererMitarbeiter
field _mutiertAm
field _team
field _teamMitarbeiterNr

See Also

TeamMitarbeiter Class


_anteil Variable

Private _anteil As Integer

Source code

[Visual Basic]
    Private _anteil As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

TeamMitarbeiter


_erstelltAm Variable

Private _erstelltAm As DateTime

Source code

[Visual Basic]
    Private _erstelltAm As DateTime

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

TeamMitarbeiter


_isAktiv Variable

Private _isAktiv As Boolean

Source code

[Visual Basic]
    Private _isAktiv As Boolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

TeamMitarbeiter


_mandantNr Variable

Private _mandantNr As Integer

Source code

[Visual Basic]
    Private _mandantNr As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

TeamMitarbeiter


_mitarbeiterNr Variable

Private _mitarbeiterNr As Integer

Source code

[Visual Basic]
    Private _mitarbeiterNr As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

TeamMitarbeiter


_mutiererMitarbeiter Variable

Private _mutiererMitarbeiter As BusinessFacade.Mitarbeiter

Source code

[Visual Basic]
    Private _mutiererMitarbeiter As BusinessFacade.Mitarbeiter

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

TeamMitarbeiter


_mutiertAm Variable

Private _mutiertAm As DateTime

Source code

[Visual Basic]
    Private _mutiertAm As DateTime

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

TeamMitarbeiter


_team Variable

Private _team As BusinessFacade.Team

Source code

[Visual Basic]
    Private _team As BusinessFacade.Team

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

TeamMitarbeiter


_teamMitarbeiterNr Variable

Private _teamMitarbeiterNr As Integer = -1

Source code

[Visual Basic]
    Private _teamMitarbeiterNr As Integer = -1

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

TeamMitarbeiter


Anwendung Constructor

default konstruktor

Public Sub New()

Source code

[Visual Basic]
    Public Sub New()

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Anwendung


Klassifizierung Constructor

Erstellt eine neue Instanz für einen neuen Mitarbeiter

Public Sub New()

Source code

[Visual Basic]
    Public Sub New()
        Try

        Catch ex As Exception
            Throw ex
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Klassifizierung


Klassifizierung Constructor (System.Int32)

Erstellt eine neue Instanz für eine bestehende Klassifizierung

Public Sub New( _
   ByVal klassifizierungNr As Integer _
)

Parameters

klassifizierungNr
Required.

Source code

[Visual Basic]
    Public Sub New(ByVal klassifizierungNr As Integer)
        Try
            Dim ds As New DataSet()

            DataAccess.Klassifizierung.GetById(klassifizierungNr, ds)

            If ds.Tables.Count > 0 Then
                If ds.Tables(0).Rows.Count > 0 Then
                    _klassenId = Common.Tools.CToInt32(ds.Tables(0).Rows(0)("klassenid"))
                    _bezeichnung = Common.Tools.CToString(ds.Tables(0).Rows(0)("bezeichnung"))
                    _beschreibung = Common.Tools.CToString(ds.Tables(0).Rows(0)("beschreibung"))
                    _isAktiv = Common.Tools.CToBool(ds.Tables(0).Rows(0)("aktiv"))
                    _mandantNr = Common.Tools.CToInt32(ds.Tables(0).Rows(0)("mandantnr"))
                    _erstellerMitarbeiterNr = Common.Tools.CToInt32(ds.Tables(0).Rows(0)("ersteller"))
                    _erstelltAm = Common.Tools.CToDateTime(ds.Tables(0).Rows(0)("erstellt_am"))
                    _mutiertAm = Common.Tools.CToDateTime(ds.Tables(0).Rows(0)("mutiert_am"))
                    _mutiererMitarbeiterNr = Common.Tools.CToInt32(ds.Tables(0).Rows(0)("mutierer"))
                    _isTeamZwingend = Common.Tools.CToBool(ds.Tables(0).Rows(0)("zwingendTeam"))
                    _isFunktionsgruppeZwingend = Common.Tools.CToBool(ds.Tables(0).Rows(0)("zwingendFunktion"))
                End If
            End If
        Catch ex As Exception
            Throw ex
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Klassifizierung


Anwendung Constructor (System.Int32)

lädt eine anwendung aus der db

Public Sub New( _
   ByVal anwendungsNr As Integer _
)

Parameters

anwendungsNr
Required.

Source code

[Visual Basic]
    Public Sub New(ByVal anwendungsNr As Integer)

        If anwendungsNr.ToString() <> Config.GetParameterValue("NullReplaceValue") Then
            Dim ds As New DataSet()
            DataAccess.Anwendung.GetAnwendung(ds, anwendungsNr)
            LoadData(ds)
        Else
            'erstelle leere instanz
        End If
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Anwendung


BarcodeTyp.Left Property

Public ReadOnly Property Left()

Source code

[Visual Basic]
        Public ReadOnly Property Left()
            Get
                Return _left
            End Get
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET


Anwendung Constructor (System.String, System.String, System.Boolean, System.Int32)

erstellt eine neue anwendung in der db und lädt diese

Public Sub New( _
   ByVal bezeichnung As String, _
   ByVal beschreibung As String, _
   ByVal aktiv As Boolean, _
   ByVal mutiererId As Integer _
)

Parameters

bezeichnung
Required.
beschreibung
Required.
aktiv
Required.
mutiererId
Required.

Source code

[Visual Basic]
    Public Sub New(ByVal bezeichnung As String, ByVal beschreibung As String, ByVal aktiv As Boolean, ByVal mutiererId As Integer)
        _bezeichnung = bezeichnung
        _beschreibung = beschreibung
        _aktiv = aktiv
        Save(mutiererId)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Anwendung


Mitarbeiter Constructor

Erstellt eine neue Instanz für einen neuen Mitarbeiter

Public Sub New()

Source code

[Visual Basic]
    Public Sub New()
        Try

        Catch ex As Exception
            Throw ex
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Mitarbeiter


Mitarbeiter Constructor (System.Int32)

Erstellt eine neue Instanz für einen bestehenen Mitarbeiter

Public Sub New( _
   ByVal mitarbeiterNr As Integer _
)

Parameters

mitarbeiterNr
Required.

Source code

[Visual Basic]
    Public Sub New(ByVal mitarbeiterNr As Integer)
        Try
            Dim ds As New DataSet()

            DataAccess.Mitarbeiter.GetById(mitarbeiterNr, ds)
            LoadData(ds)

        Catch ex As Exception
            Throw ex
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Mitarbeiter


OfficeVorlage Constructor

Public Sub New()

Source code

[Visual Basic]
    Public Sub New()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

OfficeVorlage


OfficeVorlage Constructor (System.Int32)

Neue Instanz für bestehende OfficeVorlage erstellen

Public Sub New( _
   ByVal officeVorlageNr As Integer _
)

Parameters

officeVorlageNr
Required.

Source code

[Visual Basic]
    Public Sub New(ByVal officeVorlageNr As Integer)
        Try
            Dim ds As New DataSet()
            DataAccess.OfficeVorlage.GetByNr(ds, officeVorlageNr)
            LoadData(ds)
        Catch ex As Exception
            TKBLib.Errorhandling.TraceHelper.Msg("EDOKALib.BF.OfficeVorlage.New", ex.Message + " " + ex.StackTrace, TraceLevel.Error)
            Throw ex
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

OfficeVorlage


Parameter Constructor

Public Sub New()

Source code

[Visual Basic]
    Public Sub New()

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Parameter


Parameter Constructor (System.String)

load the parameter for all users (benutzerNr=0)

Public Sub New( _
   ByVal parameterName As String _
)

Parameters

parameterName
Required. parameterName

Source code

[Visual Basic]
    Public Sub New(ByVal parameterName As String)
        ConstructorHelper(parameterName, 0)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Parameter


Parameter Constructor (System.String, System.Int32)

lädt einen parameter für einen bestimmten benutzer oder für alle

Public Sub New( _
   ByVal parameterName As String, _
   ByVal benutzerNr As Integer _
)

Parameters

parameterName
Required. parameterName
benutzerNr
Required. BenutzerNr oder 0 = gültig für alle benutzer

Source code

[Visual Basic]
    Public Sub New(ByVal parameterName As String, ByVal benutzerNr As Integer)
        ConstructorHelper(parameterName, benutzerNr)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Parameter


_top Variable

Private _top As Integer

Source code

[Visual Basic]
        Private _top As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

2006 by Zubler & Partner AG


_width Variable

Private _width As Integer

Source code

[Visual Basic]
        Private _width As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

2006 by Zubler & Partner AG


Dokumentart Constructor (System.Int32)

Public Sub New( _
   ByVal dokumentartNr As Integer _
)

Parameters

dokumentartNr
Required.

Source code

[Visual Basic]
    Public Sub New(ByVal dokumentartNr As Integer)
        'instanz von db laden
        Dim ds As New DataSet()
        DataAccess.Dokumentart.GetDokumentart(ds, dokumentartNr)
        LoadData(ds)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Dokumentart


Dokumentart Constructor (System.String, System.Int32, System.Int32, System.Int32, System.Int32, System.String, System.Boolean, System.String, System.String, System.Int32)

neue dokumentart in db erstellen und laden

Public Sub New( _
   ByVal bezeichnung As String, _
   ByVal parentId As Integer, _
   ByVal sort As Integer, _
   ByVal imageIndex As Integer, _
   ByVal imageIndexOpen As Integer, _
   ByVal beschreibung As String, _
   ByVal aktiv As Boolean, _
   ByVal coldApplication As String, _
   ByVal coldBezeichnung As String, _
   ByVal mutiererId As Integer _
)

Parameters

bezeichnung
Required.
parentId
Required.
sort
Required.
imageIndex
Required.
imageIndexOpen
Required.
beschreibung
Required.
aktiv
Required.
coldApplication
Required.
coldBezeichnung
Required.
mutiererId
Required.

Source code

[Visual Basic]
    Public Sub New(ByVal bezeichnung As String, ByVal parentId As Integer, ByVal sort As Integer, _
    ByVal imageIndex As Integer, ByVal imageIndexOpen As Integer, ByVal beschreibung As String, _
    ByVal aktiv As Boolean, ByVal coldApplication As String, ByVal coldBezeichnung As String, ByVal mutiererId As Integer)
        _bezeichnung = bezeichnung
        _parentId = parentId
        _sort = sort
        _imageIndex = imageIndex
        _imageIndexOpen = imageIndexOpen
        _beschreibung = beschreibung
        _aktiv = aktiv
        _coldApplication = coldApplication
        _coldBezeichnung = coldBezeichnung
        Save(mutiererId)

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Dokumentart


AktuellerBenutzer Constructor

Public Sub New()

Source code

[Visual Basic]
    Public Sub New()
        'erstelle dummy
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

AktuellerBenutzer


AktuellerBenutzer Constructor (System.Int32)

Public Sub New( _
   ByVal mitarbeiterNr As Integer _
)

Parameters

mitarbeiterNr
Required.

Source code

[Visual Basic]
    Public Sub New(ByVal mitarbeiterNr As Integer)
        ContructorHelper(mitarbeiterNr)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

AktuellerBenutzer


BarcodeTyp.Top Property

Public ReadOnly Property Top()

Source code

[Visual Basic]
        Public ReadOnly Property Top()
            Get
                Return _top
            End Get
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

2006 by Zubler & Partner AG


BarcodeTyp Constructor

Public Sub New( _
   ByVal top As Integer, _
   ByVal left As Integer, _
   ByVal width As Integer, _
   ByVal height As Integer, _
   ByVal isHorizontal As Boolean _
)

Parameters

top
Required.
left
Required.
width
Required.
height
Required.
isHorizontal
Required.

Source code

[Visual Basic]
        Public Sub New(ByVal top As Integer, ByVal left As Integer, ByVal width As Integer, ByVal height As Integer, ByVal isHorizontal As Boolean)
            Try
                _top = top
                _left = left
                _width = width
                _height = height
                _isHorizontal = isHorizontal

            Catch ex As Exception
                TKBLib.Errorhandling.TraceHelper.Msg("EDOKALib.BF.OfficeVorlage.Barcode", ex.Message + " " + ex.StackTrace, TraceLevel.Error)
            End Try
        End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

2006 by Zubler & Partner AG


_left Variable

Private _left As Integer

Source code

[Visual Basic]
        Private _left As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

2006 by Zubler & Partner AG


Dokumentart Constructor

Public Sub New()

Source code

[Visual Basic]
    Public Sub New()
        'leere instanz erstellen
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Dokumentart


Dokumenttyp Constructor

default konstruktor

Public Sub New()

Source code

[Visual Basic]
    Public Sub New()

    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Dokumenttyp


Dokumenttyp Constructor (System.Int32)

lädt den dokumenttyp mit der entsprechenden dokumenttypnr

Public Sub New( _
   ByVal dokumentTypNr As Integer _
)

Parameters

dokumentTypNr
Required.

Source code

[Visual Basic]
    Public Sub New(ByVal dokumentTypNr As Integer)
        Dim ds As New DataSet()
        DataAccess.Dokumenttyp.GetDokumenttyp(ds, dokumentTypNr)
        LoadData(ds)
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Dokumenttyp


Config.GetParameterValue (System.String) Method

Gibt den Wert eines Parameters zurück

Public Shared Function GetParameterValue( _
   ByVal name As String _
) As String

Parameters

name
Required. Name des Parameters

Source code

[Visual Basic]
    Public Shared Function GetParameterValue(ByVal name As String) As String
        Return GetParameter(name).Wert
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Config


Config.GetParameterValue (System.String, System.Int32) Method

Gibt den Wert eines Benuzer spzifischen Parameters zurück

Public Shared Function GetParameterValue( _
   ByVal name As String, _
   ByVal benutzerNr As Integer _
) As String

Parameters

name
Required. Name des Parameters
benutzerNr
Required.

Source code

[Visual Basic]
    Public Shared Function GetParameterValue(ByVal name As String, ByVal benutzerNr As Integer) As String
        If benutzerNr = 0 Then
            Return GetParameter(name).Wert
        Else
            Return GetUserParameter(name, benutzerNr).Wert
        End If
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Config


BarcodeTyp.Height Property

Public ReadOnly Property Height()

Source code

[Visual Basic]
        Public ReadOnly Property Height()
            Get
                Return _height
            End Get
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

2006 by Zubler & Partner AG


BarcodeTyp.IsHorizontal Property

Public ReadOnly Property IsHorizontal()

Source code

[Visual Basic]
        Public ReadOnly Property IsHorizontal()
            Get
                Return _isHorizontal
            End Get
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

2006 by Zubler & Partner AG


Mitarbeiter.Save (System.Data.DataSet, System.Data.DataSet, System.Int32) Method

Speichert die Änderungen an einem Mitarbeiter inklusive Funktionsgruppen- und Team-Zuordnungen

Public Function Save( _
   ByVal dsMaTeams As DataSet, _
   ByVal dsMaFunktionsGruppen As DataSet, _
   ByVal mutiererMitarbeiterNr As Integer _
)

Parameters

dsMaTeams
Required.
dsMaFunktionsGruppen
Required.
mutiererMitarbeiterNr
Required.

Source code

[Visual Basic]
    Public Function Save(ByVal dsMaTeams As DataSet, ByVal dsMaFunktionsGruppen As DataSet, ByVal mutiererMitarbeiterNr As Integer)
        Try
            'daten des mitarbeiters speichern
            If _mitarbeiterNr <= 0 Then
                'neuer mitarbeiter
                _mitarbeiterNr = DataAccess.Mitarbeiter.Insert(_vorname, _nachname, _kurzZeichen, _anrede, _tgNummer, _
                _email, _fax, _telefon, _unterschriftText, _spracheNr, _fuerMandantNr, _showTipp, _partnerNr, _mandantNr, _
                _isAktiv, _isMailEmpfang, _isEdokaMessage, _funktion, _isMailDirektVersenden, _rang, _isMailDokumentRueckgang, _
                _klassifizierungNr, _isEdokaMail, _isJournalisierung, _isGebMeldung, _mail1, mutiererMitarbeiterNr)
            Else
                'besthender mitarbeiter
                DataAccess.Mitarbeiter.Update(_mitarbeiterNr, _vorname, _nachname, _kurzZeichen, _anrede, _tgNummer, _
                _email, _fax, _telefon, _unterschriftText, _spracheNr, _fuerMandantNr, _showTipp, _partnerNr, _mandantNr, _
                _isAktiv, _isMailEmpfang, _isEdokaMessage, _funktion, _isMailDirektVersenden, _rang, _isMailDokumentRueckgang, _
                _klassifizierungNr, _isEdokaMail, _isJournalisierung, _isGebMeldung, _mail1, mutiererMitarbeiterNr)
            End If

            'je nach klassifizierung müssen min ein team, bzw funktionsgruppe ausgewählt werden
            Dim klassifizierung As New klassifizierung(_klassifizierungNr)

            'checks auf ds == null finden in GetRowCountAfterSave() statt
            If klassifizierung.IsTeamZwingend Then
                If Not GetRowCountAfterSave(dsMaTeams) > 0 Then
                    Throw New MitarbeiterException(String.Format(BusinessFacade.Meldungstext.GetInhaltById(310), klassifizierung.Bezeichnung))
                    Return 1
                End If
            Else
                'wenn nicht zwingend darf keine zuordnung enthalten sein.
                If GetRowCountAfterSave(dsMaTeams) > 0 Then
                    Throw New MitarbeiterException(String.Format(BusinessFacade.Meldungstext.GetInhaltById(317), klassifizierung.Bezeichnung))
                    Return 1
                End If
            End If
            If klassifizierung.IsFunktionsgruppeZwingend Then
                If Not GetRowCountAfterSave(dsMaFunktionsGruppen) > 0 Then
                    Throw New MitarbeiterException(String.Format(BusinessFacade.Meldungstext.GetInhaltById(311), klassifizierung.Bezeichnung))
                    Return 1
                End If
            Else
                'wenn nicht zwingend darf keine zuordnung enthalten sein.
                If GetRowCountAfterSave(dsMaFunktionsGruppen) > 0 Then
                    Throw New MitarbeiterException(String.Format(BusinessFacade.Meldungstext.GetInhaltById(318), klassifizierung.Bezeichnung))
                    Return 1
                End If
            End If

            If Not IsNothing(dsMaTeams) Then
                'zuordnungen speichern
                Dim row As DataRow
                Dim teamMitarbeiter As BusinessFacade.TeamMitarbeiter
                For Each row In dsMaTeams.Tables(0).Rows
                    Select Case row.RowState
                        Case DataRowState.Added
                            'neue zuordnung erstellen
                            teamMitarbeiter = New BusinessFacade.TeamMitarbeiter()
                            teamMitarbeiter.Anteil = Tools.CToInt32(row("anteil"))
                            teamMitarbeiter.IsAktiv = row("aktiv")
                            teamMitarbeiter.MandantNr = row("mandantnr")
                            teamMitarbeiter.MitarbeiterNr = _mitarbeiterNr
                            teamMitarbeiter.Team = New BusinessFacade.Team(Tools.CToInt32(row("teamnr")))

                            teamMitarbeiter.Save(mutiererMitarbeiterNr)

                        Case DataRowState.Modified
                            'bestehende speichern
                            teamMitarbeiter = New BusinessFacade.TeamMitarbeiter(Tools.CToInt32(row("teammitarbeiternr")))
                            teamMitarbeiter.Anteil = row("anteil")
                            teamMitarbeiter.IsAktiv = row("aktiv")

                            teamMitarbeiter.Save(mutiererMitarbeiterNr)

                            'Case DataRowState.Deleted
                            'bestehende löschen -> kb310370
                            'BusinessFacade.TeamMitarbeiter.Delete(Tools.CToInt32(row("teammitarbeiternr", DataRowVersion.Original)), mutiererMitarbeiterNr)

                    End Select
                Next
            End If

            If Not IsNothing(dsMaFunktionsGruppen) Then
                'zuordnungen speichern
                Dim row As DataRow
                For Each row In dsMaFunktionsGruppen.Tables(0).Rows
                    Select Case row.RowState
                        Case DataRowState.Added
                            If Common.Tools.CToBool(row("aktiv")) Then
                                'neue verbindung herstellen
                                BusinessFacade.MitarbeiterFunktionsgruppe.Insert(Tools.CToInt32(row("mitarbeiternr")), Tools.CToInt32(row("funktionsgruppenr")), mutiererMitarbeiterNr)
                            End If

                        Case DataRowState.Modified
                            BusinessFacade.MitarbeiterFunktionsgruppe.SetAktiv(Tools.CToInt32(row("mitarbeiter_funktionsgruppenr")), Common.Tools.CToBool(row("aktiv")), mutiererMitarbeiterNr)

                            'Case DataRowState.Deleted
                            'bestehende löschen -> kb310370
                            'BusinessFacade.MitarbeiterFunktionsgruppe.Delete(Tools.CToInt32(row("mitarbeiter_funktionsgruppenr", DataRowVersion.Original)), mutiererMitarbeiterNr)

                    End Select
                Next
            End If

            'members refreshen
            Dim dsRefresh As New DataSet()
            DataAccess.Mitarbeiter.GetById(_mitarbeiterNr, dsRefresh)
            LoadData(dsRefresh)

        Catch ex As Exception
            Throw ex
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Mitarbeiter


Mitarbeiter.Save (System.Int32) Method

Speichert die Änderungen an einem Mitarbeiter

Public Function Save( _
   ByVal mutiererMitarbeiterNr As Integer _
)

Parameters

mutiererMitarbeiterNr
Required.

Source code

[Visual Basic]
    Public Function Save(ByVal mutiererMitarbeiterNr As Integer)
        Try
            Save(Nothing, Nothing, mutiererMitarbeiterNr)
        Catch ex As Exception
            Throw ex
        End Try
    End Function

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

Mitarbeiter


TeamMitarbeiter Constructor

Public Sub New()

Source code

[Visual Basic]
    Public Sub New()
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

TeamMitarbeiter


TeamMitarbeiter Constructor (System.Int32)

Public Sub New( _
   ByVal teamMitarbeiterNr As Integer _
)

Parameters

teamMitarbeiterNr
Required.

Source code

[Visual Basic]
    Public Sub New(ByVal teamMitarbeiterNr As Integer)
        Try
            Dim ds As New DataSet()
            DataAccess.TeamMitarbeiter.GetById(teamMitarbeiterNr, ds)

            If ds.Tables.Count > 0 Then
                If ds.Tables(0).Rows.Count > 0 Then
                    _teamMitarbeiterNr = teamMitarbeiterNr
                    _team = New BusinessFacade.Team(Tools.CToInt32(ds.Tables(0).Rows(0)("teamNr")))
                    _mitarbeiterNr = Tools.CToInt32(ds.Tables(0).Rows(0)("mitarbeiternr"))
                    _anteil = Tools.CToInt32(ds.Tables(0).Rows(0)("anteil"))
                    _mandantNr = Tools.CToInt32(ds.Tables(0).Rows(0)("mandantnr"))
                    _isAktiv = Common.Tools.CToBool(ds.Tables(0).Rows(0)("aktiv"))
                    _erstelltAm = Tools.CToDateTime(ds.Tables(0).Rows(0)("erstellt_am"))
                    _mutiertAm = Tools.CToDateTime(ds.Tables(0).Rows(0)("mutiert_am"))
                    _mutiererMitarbeiter = New BusinessFacade.Mitarbeiter(Tools.CToInt32(ds.Tables(0).Rows(0)("mutierer")))
                End If
            End If
        Catch ex As Exception
            Throw ex
        End Try
    End Sub

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

See Also

TeamMitarbeiter


BarcodeTyp.Width Property

Public ReadOnly Property Width()

Source code

[Visual Basic]
        Public ReadOnly Property Width()
            Get
                Return _width
            End Get
        End Property

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

2006 by Zubler & Partner AG


_height Variable

Private _height As Integer

Source code

[Visual Basic]
        Private _height As Integer

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

2006 by Zubler & Partner AG


_isHorizontal Variable

Private _isHorizontal As Boolean

Source code

[Visual Basic]
        Private _isHorizontal As Boolean

Requirements

Platforms: Windows 98, Windows NT 4.0, Windows Millennium Edition, Windows 2000, Windows XP Home Edition, Windows XP Professional, Windows Server 2003 family, .NET Compact Framework - Windows CE .NET

2006 by Zubler & Partner AG